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Chapter 1: ANSYS TurboGrid Overview

ANSYS TurboGrid is a powerful tool that lets designers and analysts of rotating machinery create high-

quality hexahedral meshes, while preserving the underlying geometry. These meshes are used in the

ANSYS workflow to solve complex blade passage problems.

The ANSYS TurboGrid online product documentation is divided into five major areas:

1. ANSYS TurboGrid Introduction

A brief introduction, listing of new features, and detailed information about the ANSYS TurboGrid

Launcher

2. ANSYS TurboGrid Tutorials

3. ANSYS TurboGrid User's Guide

Information about the user interface and workflow

4. ANSYS TurboGrid Reference Guide

Detailed information about menu items, command actions, syntax, and so on.

5. Installation and Licensing

Help on using ANSYS TurboGrid in ANSYS Workbench is provided in ANSYS TurboGrid in ANSYS Work-

bench (p. 5) and in the TurboSystem > ANSYS TurboGrid section of the ANSYS Workbench help.

1.1. Valid Decimal Separators

In ANSYS TurboGrid, only a period is allowed to be used decimal delimiters in fields that accept floating-

point input. If your system is set to a European locale that uses a comma separator (such as Germany),

fields that accept numeric input will accept a comma, but an error will be returned. If your system is

set to a non-European locale, numeric fields will not accept a comma at all.

ANSYS Workbench accepts commas as decimal delimiters, but translates these to periods when passing

data to ANSYS TurboGrid.

1
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Chapter 2: Using the ANSYS TurboGrid Launcher

ANSYS TurboGrid can be run in two modes:

• ANSYS TurboGrid stand-alone, which refers to ANSYS TurboGrid running as a stand-alone application

independent of the ANSYS Workbench software.

• ANSYS TurboGrid Workbench, which refers to ANSYS TurboGrid running as a component inside of the

ANSYS Workbench software. This is described in ANSYS TurboGrid in ANSYS Workbench (p. 5).

ANSYS TurboGrid stand-alone has the ANSYS TurboGrid Launcher, which makes it easy to run all the

modules of CFX without having to use a command line. The launcher enables you to:

• Set the working directory for your project

• Start CFX and ANSYS products

• Access various other tools, including a command window that enables you to run other utilities

• Access the online help and other useful information

• Customize the behavior of the launcher to start your own applications.

The launcher automatically searches for installations of CFX and ANSYS products including the license

manager. Depending on the application, the search includes common installation directories, directories

pointed to by environment variables associated with CFX and ANSYS products, and the Windows registry.

In the unlikely event that a product is not found, you can configure the launcher using the steps outlined

in Customizing the ANSYS TurboGrid Launcher in the TurboGrid Reference Guide.

This chapter discusses:

2.1. Starting the ANSYS TurboGrid Launcher

For more information about the launcher, see The ANSYS TurboGrid Launcher Interface in the TurboGrid

Reference Guide and Customizing the ANSYS TurboGrid Launcher in the TurboGrid Reference Guide.

2.1. Starting the ANSYS TurboGrid Launcher

You can run the ANSYS TurboGrid Launcher in any of the following ways:

• On Windows:

– From the Start menu, go to All Programs > ANSYS 14.0 > Meshing > TurboGrid 14.0.

– In a DOS window that has its path set up correctly to run ANSYS TurboGrid, enter cfxlaunch
(otherwise, you will need to enter the full pathname of the cfxlaunch command).

• On UNIX, enter cfxlaunch in a terminal window that has its path set up to run ANSYS TurboGrid.

To run ANSYS TurboGrid, start the launcher, set the working directory, then click TurboGrid 14.0.

3
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Chapter 3: ANSYS TurboGrid in ANSYS Workbench

Note

This chapter assumes that you are familiar with using ANSYS TurboGrid in standalone mode,

as described in Using the ANSYS TurboGrid Launcher (p. 3), and that you are familiar with

ANSYS Workbench.

This chapter describes using ANSYS TurboGrid in ANSYS Workbench. The following topics are discussed:

3.1.The ANSYS Workbench Interface

3.2. Example Workflow involving ANSYS TurboGrid

3.3. Known Limitations of ANSYS TurboGrid Running in ANSYS Workbench

For an example workflow that includes the use of ANSYS TurboGrid, see TurboSystem Workflows in the

TurboSystem User Guide.

For information about using ANSYS Workbench journaling and scripting with ANSYS TurboGrid, including

a special note about playing older journal and session files, see Using ANSYS Workbench Journaling

and Scripting with TurboSystem in the TurboSystem User Guide.

3.1. The ANSYS Workbench Interface

To launch ANSYS Workbench on Windows, click the Start menu, then select All Programs > ANSYS

14.0 > Workbench.

To launch ANSYS Workbench on Linux, open a command line interface, type the path to “runwb2” (for

example, “~/ansys_inc/v140/Framework/bin/Linux64/runwb2”), then press Enter.

The ANSYS Workbench interface is organized to make it easy to choose the tool set that will enable

you to solve particular types of problems. Once you have chosen a system from the Toolbox and moved

it into the Project Schematic, supporting features such as Properties and Messages provide orienting

information. These features and the status indicators in the system cells guide you through the completion

of the System steps.

The figure that follows shows ANSYS Workbench with a TurboGrid component system open and the

properties of cell C2 (Turbo Mesh) displayed:
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The following sections describe the main ANSYS Workbench features.

3.1.1.Toolbox

3.1.2. Project Schematic

3.1.3.View Bar

3.1.4. Properties View

3.1.5. Files View

3.1.6. Sidebar Help

3.1.7. Shortcuts (Context Menu Options)

3.1.8. Using Workbench Input Parameters and Workbench Output Parameters

3.1.1. Toolbox

The Toolbox shows the systems available to you:

Analysis Systems

Systems that match the workflow required to solve particular types of problems. For example, the Fluid

Flow (CFX) system contains tools for creating the geometry, performing the meshing, setting up the

solver, using the solver to derive the solution, and viewing the results.

Release 14.0 - © SAS IP, Inc. All rights reserved. - Contains proprietary and confidential information
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Component Systems

Software elements upon which Analysis Systems are based. For example, the CFX component system

contains Setup (CFX-Pre), Solution (CFX-Solver Manager), and Results (CFD-Post). The Results component

system contains only Results (CFD-Post).

Custom Systems

Systems that combine separate analysis systems. For example, the FSI: Fluid Flow (CFX) > Static

Structural system combines ANSYS CFX and the Mechanical application to perform a unidirectional (that

is, one-way) Fluid Structure Interaction (FSI) analysis.

Design Exploration

Systems that enable you to see how changes to parameters affect the performance of the system.

Note

Which systems are shown in the Toolbox depends on the licenses that exist on your system.

You can hide systems by enabling View > Toolbox Customization and clearing the check

box beside the name of the system you want to hide.

To begin using a system, drag it into the Project Schematic area.

3.1.2. Project Schematic

The Project Schematic enables you to manage the process of solving your problem. It keeps track of

your files and shows the actions available as you work on a project. At each step you can select the

operations that process or modify the case you are solving.

When you move a system from the Component Systems toolbox to the Project Schematic, you will

see a set of tools similar to the following:

Each white cell represents a step in solving a problem. Right-click the cell to see what options are

available for you to complete a step.

7
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For example, in a TurboGrid system:

• Edit launches ANSYS TurboGrid.

• Transfer Data To New > CFX adds a new CFX component system that uses the mesh from the Turbo

Mesh cell.

3.1.3. View Bar

You control which views are displayed by opening the View menu and setting a check mark beside

the view you want to display. If you minimize that view, it appears as a tab in the View Bar and the

check box is cleared from the View menu.

3.1.4. Properties View

The Properties view is a table whose entries describe the status of a system. These entries vary between

system cells and are affected by the status of the cell. Some entries in the Properties area are writable;

others are for information only.

To display the Properties for a particular cell, right-click the cell and select Properties. Once the

Properties view is open, simply selecting a cell in the Project Schematic will display that cell's properties.

The properties specific to the Turbo Mesh cell of the TurboGrid system are documented in ANSYS Help

> TurboSystem > ANSYS TurboGrid.

3.1.5. Files View

The Files view shows the files that are in the current project. The project files are updated constantly,

and any “save” operation from ANSYS TurboGrid will save all files associated with the project.
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3.1.6. Sidebar Help

In addition to having a visual layout that guides you through completing

your project, you can also access Sidebar Help by pressing F1 while the

mouse focus is anywhere on ANSYS Workbench. Sidebar Help is a dynam-

ically generated set of links to information appropriate for helping you

with questions you have about any of the tools and systems you currently

have open.

3.1.7. Shortcuts (Context Menu Options)

You can access commonly used commands by right-clicking in most areas of ANSYS Workbench. These

commands are described in the section Context Menu Options in the ANSYS Workbench help. The only

context menu command that is specific to the Turbo Mesh cell is the Edit command, which opens

ANSYS TurboGrid.

3.1.8. Using Workbench Input Parameters and Workbench Output Parameters

For information about using and managing Workbench input parameters and Workbench output

parameters in ANSYS TurboGrid, see Object Editor in the TurboGrid User's Guide and Expression Editor

Dialog Box in the TurboGrid User's Guide.

3.2. Example Workflow involving ANSYS TurboGrid

In ANSYS Workbench, you can create a CFD simulation of a pump impeller that has the following

schematic:

9
Release 14.0 - © SAS IP, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Example Workflow involving ANSYS TurboGrid



In this example, the pump impeller is generated in BladeGen, has fillets added in BladeEditor, and is

meshed in ANSYS TurboGrid. The pump diffuser is generated in BladeGen and is meshed in ANSYS

TurboGrid. Both meshes are used in a CFD analysis.

To set up this schematic, you can follow this general procedure:

1. Launch ANSYS Workbench.

2. Save the project to a new directory.

3. Add a BladeGen system by double-clicking BladeGen in the toolbox, under Component Systems.

Alternatively, you can drag a BladeGen system from the toolbox to the Project Schematic.

4. Add a Geometry system to the BladeGen system by any one of the following methods:

• Double-click a Geometry system in the toolbox to add a Geometry system to the schematic, then

drag from the Blade Design cell to the Geometry cell to connect the systems.

• Drag a Geometry system from the toolbox to the Project Schematic, then drag from the Blade

Design cell to the Geometry cell to connect the systems.

• Drag a Geometry system from the toolbox to the Blade Design cell.

• Right-click the Blade Design cell and select Transfer Data To New > Geometry.

5. Optionally rename the system.

You can enter a name for a system when you first create the system. You can also initiate a rename

operation by right-clicking the upper-left corner of the system and selecting Rename from the

shortcut menu.

6. Continue adding systems until the schematic is complete.

7. Edit each cell in sequence, starting from the upstream cell, and use the associated software to provide

the required data.

For example, after editing the Blade Design cell to provide a geometry, edit the Turbo Mesh cell

to create a mesh in ANSYS TurboGrid.

8. Save the project when finished.
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Important

Saving a project enables you to re-open the project on the machine that originally created

it. To make the project available on another machine, you need to use File > Archive to

create a project archive. To open the project on a different machine, run File > Restore

Archive on that machine.

3.3. Known Limitations of ANSYS TurboGrid Running in ANSYS Workbench

• The Units settings in the ANSYS Workbench menu have no effect on the units used in ANSYS TurboGrid.

• The mesh is always saved in the “Combined in one domain, one file” mode and in the user-preferred

length unit.

• Session playback is not supported in ANSYS TurboGrid running in ANSYS Workbench.

• ANSYS TurboGrid in ANSYS Workbench does not support the use of filenames or project names that

contain either the "$", ”#”, or "," characters anywhere in their file path.

• If you play a journal file on a platform that is different from the one used to record it, you might en-

counter a problem. For example, a journal file recorded on Windows and played on Linux can result in

a different number of outlet points being generated. This can happen due to different amounts of

round-off error, and can lead to errors being generated.

• If an upstream or downstream adjacent blade is specified for computing inlet or outlet locations and

an error occurs while loading/refreshing the geometry then the inlet/outlet locations will not be computed

based on the adjacent blade. Once the cause of the original error is fixed, closing and reopening Tur-

boGrid will fix this problem.

• If the number of blades in an upstream geometry is changed then TurboGrid may produce some er-

ror/warning messages when it is opened. This is not indicative of a real issue. Closing and re-opening

TurboGrid will result in everything being updated correctly.
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Chapter 4: ANSYS TurboGrid Help and Conventions

This chapter discusses:

4.1. Accessing Help

4.2. Using the Help Browser Index

4.3. Using the Search Feature

4.4. Document Conventions

4.1. Accessing Help

You can access the online help in the following ways:

• Select the appropriate command from the Help menu of the ANSYS TurboGrid Launcher or ANSYS

TurboGrid.

Depending on the command you select, you will see help in either online format or PDF format.

A PDF file will be opened in Adobe Reader if possible, otherwise it may (with uncertain results) be

opened in Xpdf, Gpdf, KPDF, or Evince, depending on which of these viewers have been installed.

• Click a feature of the ANSYS TurboGrid interface to make it active and, with the mouse pointer over the

feature, press the F1 key for context-sensitive help (that is, the online help opens at the appropriate

page for the feature under the mouse pointer). Not every area of the interface supports context-sensitive

help.

For information on using the ANSYS Help Viewer, see:

• Using Help

• Index Navigation

• "Using Help: Searching".

You can access the ANSYS TurboGrid documentation in PDF form in <CFXROOT>\..\common-
files\help\en-us\pdf\ on Windows and in <CFXROOT>/../commonfiles/help/en-us/pdf/
on Linux. The documentation is also available in PDF format on the ANSYS Customer Portal (at ht-

tp://www.ansys.com/customerportal/index.htm).

PDF

Name

DescriptionBook

tg_in-

tr.pdf

How to run ANSYS TurboGrid.ANSYS TurboGrid Introduc-

tion

tg_user.pdfHow to use ANSYS TurboGrid.ANSYS TurboGrid User’s

Guide

tg_ref.pdfComplete details for CFX Command Language,

CFX Expression Language, Command Actions,

and line interface mode.

ANSYS TurboGrid Reference

Guide

tg_tutr.pdfA set of tutorials that demonstrate the workflow

in ANSYS TurboGrid.

ANSYS TurboGrid Tutorials
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4.2. Using the Help Browser Index

The Index tab of the help browser enables you to search for index terms and display the associated

topics.

To find a topic using the index, type the first few letters of a keyword in the field at the top. The list

scrolls to the relevant index entry as you type.

Results from the Help index will not be exhaustive, so you should consider using the Search function

as well.

For information on the ANSYS help viewer index, see Index Navigation in the Using Help section.

4.3. Using the Search Feature

The Search tab of the help browser enables you to perform searches through the online help.

For information on the ANSYS help viewer search function, see Using Help: Searching in the Using Help

section.

4.4. Document Conventions

This section describes the conventions used in this document to distinguish between text, computer

file names, system messages, and input that you need to type.

4.4.1. File and Directory Names

File names and directory names appear in a plain fixed-width font (for example, /usr/lib). Note that

on Linux, directory names are separated by forward slashes (/) but on Windows, backslashes are used

(\). For example, a directory name on Linux might be /CFX/bin whereas on a Windows system, the

same directory would be named C:\CFX\bin.

4.4.2. User Input

Input to be typed verbatim is shown in the following convention:

mkdir /usr/local/cfx

4.4.3. Input Substitution

Input substitution is shown in the following convention:

cfx5 -def <def_file>

you should actually type cfx5 -def, and substitute a suitable file name for <def_file>.

4.4.4. Optional Arguments

Optional arguments are shown using square brackets:

cfxlaunch [-help] [-verbose] [-display <display>]

Here the arguments -help, -verbose, and -display are optional, but if you specify -display,

you must then specify a suitable display server (represented by <display>).
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4.4.5. Long Commands

Commands that are too long to display on a printed page are shown with “\” characters at the ends of

intermediate lines:

mount -r -F hsfs \
/dev/dsk/c0t6d0s0 /cdrom

On a Linux system, you may type the “\” characters, pressing Enter after each. However, on a Windows

machine you must enter the whole command without the “\” characters; continue typing if the command

is too long to fit in the command prompt window and press Enter only at the end of the complete

command.

4.4.6. Operating System Names

When we refer to objects that depend on the type of system being used, we will use one of the following

symbols in the text:

<os> refers to the short form of the name which ANSYS CFX uses to identify the operating system in

question. <os> will generally be used for directory names where the contents of the directory depend

on the operating system but do not depend on the release of the operating system or on the processor

type. Wherever you see <os> in the text you should substitute with the operating system name. The

correct value can be determined by running:

<CFXROOT>/bin/cfx5info -os

<arch> refers to the long form of the name which ANSYS CFX uses to identify the system architecture

in question. <arch> will generally be used for directory names where the contents of the directory

depend on the operating system and on the release of the operating system or the processor type.

Wherever you see <arch> in the text you should substitute the appropriate value for your system,

which can be determined by running the command:

<CFXROOT>/bin/cfx5info -arch

15
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Chapter 5: Contact Information

Technical Support for ANSYS, Inc. products is provided either by ANSYS, Inc. directly or by one of our

certified ANSYS Support Providers. Please check with the ANSYS Support Coordinator (ASC) at your

company to determine who provides support for your company, or go to www.ansys.com and select

About ANSYS> Contacts and Locations. The direct URL is: http://www1.ansys.com/customer/public/sup-

portlist.asp. Follow the on-screen instructions to obtain your support provider contact information. You

will need your customer number. If you don't know your customer number, contact the ASC at your

company.

If your support is provided by ANSYS, Inc. directly, Technical Support can be accessed quickly and effi-

ciently from the ANSYS Customer Portal, which is available from the ANSYS Website (www.ansys.com)

under Support> Technical Support where the Customer Portal is located. The direct URL is: ht-

tp://www.ansys.com/customerportal.

One of the many useful features of the Customer Portal is the Knowledge Resources Search, which can

be found on the Home page of the Customer Portal.

Systems and installation Knowledge Resources are easily accessible via the Customer Portal by using

the following keywords in the search box: Systems/Installation. These Knowledge Resources

provide solutions and guidance on how to resolve installation and licensing issues quickly.

NORTH AMERICA

All ANSYS, Inc. Products

Web: Go to the ANSYS Customer Portal (http://www.ansys.com/customerportal) and select the appropriate

option.

Toll-Free Telephone: 1.800.711.7199

Fax: 1.724.514.5096

Support for University customers is provided only through the ANSYS Customer Portal.

GERMANY

ANSYS Mechanical Products

Telephone: +49 (0) 8092 7005-55

Email: support@cadfem.de

All ANSYS Products

Web: Go to the ANSYS Customer Portal (http://www.ansys.com/customerportal) and select the appropriate

option.

National Toll-Free Telephone:

German language: 0800 181 8499

English language: 0800 181 1565

International Telephone:
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German language: +49 6151 3644 300

English language: +49 6151 3644 400

Email: support-germany@ansys.com

UNITED KINGDOM

All ANSYS, Inc. Products

Web: Go to the ANSYS Customer Portal (http://www.ansys.com/customerportal) and select the appropriate

option.

Telephone: +44 (0) 870 142 0300

Fax: +44 (0) 870 142 0302

Email: support-uk@ansys.com

Support for University customers is provided only through the ANSYS Customer Portal.

JAPAN

CFX , ICEM CFD and Mechanical Products

Telephone: +81-3-5324-8333

Fax: +81-3-5324-7308

Email: CFX: japan-cfx-support@ansys.com; Mechanical: japan-ansys-support@ansys.com

FLUENT Products

Telephone: +81-3-5324-7305

Email: FLUENT: japan-fluent-support@ansys.com;POLYFLOW: japan-polyflow-support@ansys.com;FfC: japan-

ffc-support@ansys.com; FloWizard: japan-flowizard-support@ansys.com

Icepak

Telephone: +81-3-5324-7444

Email: japan-icepak-support@ansys.com

Licensing and Installation

Email: japan-license-support@ansys.com

INDIA

ANSYS Products (including FLUENT, CFX, ICEM-CFD)

Web: Go to the ANSYS Customer Portal (http://www.ansys.com/customerportal) and select the appropriate

option.

Telephone: +91 1 800 233 3475 (toll free) or +91 1 800 209 3475 (toll free)

Fax: +91 80 2529 1271

Email: FEA products: feasup-india@ansys.com;CFD products: cfdsup-india@ansys.com; Installation: installation-

india@ansys.com

FRANCE

All ANSYS, Inc. Products

Web: Go to the ANSYS Customer Portal (http://www.ansys.com/customerportal) and select the appropriate

option.

Release 14.0 - © SAS IP, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.18

Chapter 5: Contact Information

http://www.ansys.com/customerportal
http://www.ansys.com/customerportal
http://www.ansys.com/customerportal


Toll-Free Telephone: +33 (0) 800 919 225

Email: support-france@ansys.com

Support for University customers is provided only through the ANSYS Customer Portal.

BELGIUM

All ANSYS Products

Web: Go to the ANSYS Customer Portal (http://www.ansys.com/customerportal) and select the appropriate

option.

Telephone: +32 (0) 10 45 28 61

Email: support-belgium@ansys.com

Support for University customers is provided only through the ANSYS Customer Portal.

SWEDEN

All ANSYS Products

Web: Go to the ANSYS Customer Portal (http://www.ansys.com/customerportal) and select the appropriate

option.

Telephone: +44 (0) 870 142 0300

Email: support-sweden@ansys.com

Support for University customers is provided only through the ANSYS Customer Portal.

SPAIN and PORTUGAL

All ANSYS Products

Web: Go to the ANSYS Customer Portal (http://www.ansys.com/customerportal) and select the appropriate

option.

Telephone: +33 1 30 60 15 63

Email: support-spain@ansys.com

Support for University customers is provided only through the ANSYS Customer Portal.

ITALY

All ANSYS Products

Web: Go to the ANSYS Customer Portal (http://www.ansys.com/customerportal) and select the appropriate

option.

Telephone: +39 02 89013378

Email: support-italy@ansys.com

Support for University customers is provided only through the ANSYS Customer Portal.
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