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Chapter 1: ANSYS TurboGrid Workspace

• Introduction (p. 1)

• "ANSYS TurboGrid in ANSYS Workbench"

• Object Selector (p. 2)

• Object Editor (p. 4)

1.1. Introduction

The ANSYS TurboGrid interface is divided into several parts, as shown in Figure 1.1 (p. 1). This chapter

describes two main parts of the ANSYS TurboGrid interface: the object selector and the object editor.

Figure 1.1  Workspace

After reading this chapter, you will be familiar with the basic features of the object selector and the

object editor.

Information about main menu options and the viewer is given in subsequent chapters in this guide.
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ANSYS TurboGrid Workflow (p. 71) shows how to use ANSYS TurboGrid.

1.2. Object Selector

The object selector lists all existing objects in ANSYS TurboGrid.

The object selector initially contains some objects in a tree format. Objects are data items used to drive

aspects of mesh generation, visualization, and calculations. These objects must be defined in a certain

order. For details, see Steps to Create a Mesh (p. 71).

To help guide you through the mesh creation process, the object names are listed with special icons

and text fonts in the object selector.

Table 1.1  Icon Overlays and Text Styles

DescriptionAppended

Phrase

FontIcon

Over-

lay

The object cannot be pro-

cessed. Some other object(s)

Grey

Ital-

ic must be defined before this

object can be processed.

The object is ready to be

defined, if applicable, and then

Blue

Bold

processed. The object must beItal-

ic processed before a mesh can

be created.

Release 14.0 - © SAS IP, Inc. All rights reserved. - Contains proprietary and confidential information
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DescriptionAppended

Phrase

FontIcon

Over-

lay

The object is complete and re-

quires no more information

Black

before a mesh can be gener-

ated. The object can, however,

be edited.

The object has a problem. In

the case of the Mesh Analys-
(Error)Red

Bold

Ital-

ic

is object, a red font indicates

that at least one mesh statistic

falls outside the limits set in the

Mesh Limits object.

The object will not be pro-

cessed because it is suspended.

(Suspended)

You can control whether such

an object is suspended from

the shortcut menu. For details,

see Suspend Object Updates

Command (p. 142).

The object is suspended be-

cause a parent object is suspen-

(Parent suspen-

ded)

ded. For example, whenever

the Topology Set object is sus-

pended, the Mesh Data object

will also be suspended.

The tree view reflects the structure of the object definitions. For example, there is a Hub object in both

the Geometry and 3D Mesh branches. To select the geometry Hub object, select the Hub object from

the Geometry branch.

You can open the object editor for any object by:

• Double-clicking it.

You may need to expand a tree branch to reach a particular object. This is accomplished by clicking

on the plus symbol at the root of the branch.

• Right-clicking the object and using the shortcut menu.

Shortcut menu items will be available according to the type of object. All shortcut menu commands

are described in Shortcut Menu Commands (p. 136).

An alternative way to edit an object is by using the Command Editor dialog box. The Edit in Command

Editor menu item is available by right-clicking an object in the object selector. This operation opens

the Command Editor dialog box and displays the definition of the object and its parameter settings.

Edit the CCL to change the object. For further details, see Command Editor Command (p. 66).
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1.2.1. Visibility Check Box

In the object selector, each object that can be displayed in the viewer window has a check box to the

left of it. The check box controls the visibility of the object in the viewer. Selecting the check box turns

visibility on for that object, while clearing the check box turns the visibility off. For details, see Common

Options (p. 5).

1.3. Object Editor

The object editor is used to define or edit the properties of an object. It contains a set of one or more

tabs that depend on the type of object being edited.

Many properties can be set via a CEL expression. To enter an expression, click in the box for a property,

then click the Enter Expression  icon which appears beside the field, then do one of the following:

• Enter an expression definition directly.

• Type the name of an existing expression.

(This is a special case of the first point.)

You must ensure that the expression evaluates to a value having appropriate units for the property

that uses the expression.

For details on CEL expressions, see ANSYS CFX Expression Language in the TurboGrid Reference Guide.

When using ANSYS TurboGrid in ANSYS Workbench, you can set any property that accepts a CEL expres-

sion via a parameterized CEL expression with the parameterized CEL expression being defined by a

Workbench input parameter. You can do this in either of the following ways:

• Create an expression and parameterize it using the Expression Editor dialog box, then use that expres-

sion as the value of the property. For details, see Expression Editor Dialog Box (p. 62).

• In the object editor, click the Set to Workbench input parameter  icon (which appears to the right of

the property) and then, in the Enter Parameter Name dialog box, either enter a unique name for a

new Workbench input parameter (a suggested name is entered by default) or select an existing Work-

bench input parameter.

If you make changes in the object editor, be sure to apply them (click Apply) before clicking the

Set to Workbench input parameter  icon, otherwise your changes will be lost.

If you cannot see the Set to Workbench input parameter  icon, click the user interface away from

the property that you are trying to parameterize.

You can click Set to value  to stop a property from being specified by a Workbench input parameter.

However, the corresponding CEL expression persists, and can be managed by the Expression Editor

dialog box. For details, see Expression Editor Dialog Box (p. 62).

A property that accepts only an integer value is also capable of being controlled by a Workbench input

parameter. For such a property, the Set to Workbench input parameter  and Set to value  icons

are used in the same way as for a property that accepts a CEL expression. Integer-value properties
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cannot take expressions. (No CEL expression is involved in transferring the Workbench input parameter's

value from ANSYS Workbench to ANSYS TurboGrid, for a property that accepts only an integer value.)

1.3.1. Common Options

The options located at the bottom of the object editor are available from any of the tabs, and are

common to most objects. A description of each option follows:

• The Apply button saves the changes made to all the tabs and updates the object in the viewer. Objects

that depend on the edited object are also updated. For example, altering a plane would also change

any object that uses that plane in its definition.

• The Reset button returns the settings for the object to those stored in the database for all the tabs.

The settings are stored in the database each time you click the Apply button.

• The Defaults button restores the system default settings for all the tabs of the object. The system defaults

are stored for each parameter, without regard for the types of object(s) in which the parameter may be

used. For this reason, using the Defaults button may result in unsuitable changes to an object’s settings,

and is not recommended.

1.3.2. Data Tab

Most objects have one or more tabs which define the object. These are often called data tabs; e.g., the

one for a hub is called Data Hub. The data tab displays the definition of the object currently being

edited. Each of the objects are described in ANSYS TurboGrid Workflow (p. 71).

1.3.3. Color Tab

1.3.3.1. Mode

The Color tab controls the color of objects in the viewer. The color can be either constant or based on

a variable. Select one of the two options for Mode.

• Select Constant to specify a single color for an object. To choose a color, click the  icon to the

right of the Color box.

• Select Variable to plot a variable on an object (maximum face angle on a plane, for example).

• Select Use Plot Variable (available for some plots, including an isosurface) to color an object by

the same variable used to define it.

1.3.3.2. Variable

Choose the variable to plot from the Variable drop-down list. The drop-down list of variables contains

the most commonly used variables. For a full list of variables, click the  icon.
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1.3.3.3. Range

Click  next to the Range box to see the available methods for defining the range of the variable used

to define the plot. This affects the variation of color used when plotting the object in the viewer. The

lowest values of a variable in the selected range are shown in blue in the viewer, the highest values

are shown in red.

• Global uses the range of the variable over all domains (regardless of the domains selected on the

Geometry tab) to determine the minimum and maximum values.

• Local uses the range of the variable over the current object to determine the minimum and maximum

values. This option is useful for utilizing the full color range on the object.

• Using User Specified, enter the minimum and maximum values for the contours. This option is

useful to concentrate the full color range in a specific variable range. The variable values can be typed

in, set using the embedded slider or, by clicking the  icon to the right of the Units box, entered as

an expression. Click  in the box to the right of the variable value to see the available units for the

variable(s).

1.3.3.4. Hybrid and Conservative Values

Select whether the plotted object is based on hybrid or conservative values of the variable used for

coloring.

1.3.3.5. Undefined Color

Any areas in which the variable is not defined (when a section of an object lies outside of the compu-

tational domain, for example) use the color specified in the Undef. Color box. Click the  icon to

the right of this box, to change the undefined color.

1.3.4. Render Tab

The exact appearance of the Render tab depends on the type of object plotted in the viewer window.
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1.3.4.1. Draw Faces

If the Draw Faces check box is selected, the faces which make up an object are drawn. The faces are

colored using the settings on the Color tab.

To change the transparency of an object, type in the transparency value or use the embedded slider

(which has a maximum value of 1 and a minimum value of 0). A transparency of 0 means the shading

is opaque (or having no transparency) and a transparency of 1 means the shading is invisible (completely

transparent).

Shading properties can be changed to either None, Flat Shading or Smooth Shading.

• Select None so that no shading is applied to the object; it appears black.

• Select Flat Shading so that each rendered element is colored a constant color. Color interpolation

is not used across or between rendered elements.

• Select Smooth Shading so that color interpolation is applied which results in color variation across

a rendered element based on the color of surrounding rendered elements.

Lighting can be turned on and off by selecting/clearing the Lighting check box.

Specular lighting can be turned on and off by selecting/clearing the Specular check box. When selected,

objects appear to reflect light.

Face culling turns off visibility of rendered element faces of objects that either face the viewer or point

away from the viewer. Domain boundaries always have a normal vector that points out of the domain.

Face Culling options are:

• Front Faces

Selecting Front Faces turns off visibility of all outward-facing rendered element faces (the faces

on the same side as the normal vector). This would, for example, turn off visibility of one side of a

plane or the outward facing rendered elements of a cylinder locator. When applied to a volume

object, the first layer of rendered element faces that point outwards are rendered invisible.

• Back Faces

Selecting Back Faces turns off visibility of inward-facing rendered element faces (the faces on

the opposite side to the normal vector). When applied to volume objects, the effect of back culling

is not always visible in the viewer, since the object-rendered elements that face the outward direction

obscure the culled faces. It can, however, reduce the render time when further actions are performed

on the object. The effect of this would be most noticeable for large volume objects. In the same

way as for front face culling, it turns off visibility of one side of surface locators.

• No Culling

No Culling turns on the visibility of all rendered element faces.

Note

Face culling affects printouts performed using the Use Screen Capture method.
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1.3.4.2. Draw Lines

If the Draw Lines check box is selected, the lines which make up the object’s surface are drawn. To

change the line width, type in the line width value, increase or decrease the value by 1 by clicking the

up and down arrows, or use the embedded slider (which has a maximum value of 10 and a minimum

value of 1). Line color can be changed by clicking on the  icon to the right of the Color box.

The Edge Angle setting is used to limit the number of visible edges in a plot. The edge angle is con-

sidered to be the angle between two faceted faces of a surface which are connected by an edge. If the

angle between two adjacent faces is greater than the Edge Angle setting, then the edge shared by the

faces is drawn. If the edge angle is 0°, the entire surface is drawn. If the edge angle is large, then only

the most significant corner edges of the surface are drawn.

A sensible setting for Edge Angle depends on the geometry. Experiment to get a value that clearly

shows where the surface is located, without displaying too much of the surface mesh. Too many lines

can make it confusing when more objects are added to the geometry.

Setting an edge angle defines a minimum angle for drawing parts of the surface mesh. For example, if

an edge angle of 30° is chosen, any edges shared by faces with an angle between them of 30° or more

are drawn.

Reducing the edge angle shows more of the surface mesh in the viewer. When the edge angle is 0°, all

of the surface mesh is shown.

1.3.4.3. Applying Instance Transforms to Objects

Instance transforms are created separately using Insert > User Defined > Instance Transform. For

details, see Instance Transform Command (p. 44). The Apply Instancing check box is selected by default,

and Default Transform is selected. To apply a different transform, it must be created and then

selected from the list of existing instance transforms.
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Chapter 2: File Menu

The following sections describe the commands available in the File menu:

2.1. Introduction

2.2. New Case Command

2.3. Load BladeGen Command

2.4. Load Curves Command

2.5. Load CFG Command

2.6. Reread Curves Command

2.7. Load State Command (Import State Command)

2.8. Save State Command (Export State Command)

2.9. Save State As Command

2.10. Save Project

2.11. Refresh

2.12. Save Submenu

2.13. Save Mesh Command

2.14. Save Mesh As Command

2.15. Export Geometry Command

2.16. Save Picture Command

2.17. Recent State Files Submenu

2.18. Recent Session Files Submenu

2.19. Quit Command

2.1. Introduction

ANSYS TurboGrid uses and produces the following file types:

Session File

.tse session files are produced by ANSYS TurboGrid and contain CCL commands. Session files record

the commands executed to a file for playback at a later date. Use session files to run ANSYS TurboGrid

in batch mode. See Session Menu (p. 27) and Batch Mode in the TurboGrid Reference Guide for details.

Note

Because the session file is a text file of CCL commands, you can write your own session files

using a text editor.

State File

.tst state files are produced by ANSYS TurboGrid and contain CCL commands. They differ from session

files in that only a snap-shot of the current state is saved to a file. Using state files, you can close ANSYS

TurboGrid and continue working later from the same point. See Load State Command (Import State

Command) (p. 14) and Save State Command (Export State Command) (p. 15) for details.
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Note

Because the state file is a text file of CCL commands, you can write your own state files using

a text editor.

Note

State files previously had the extension .cst.

Topology File

.tgt topology files are produced by ANSYS TurboGrid and define the topology. Using topology files,

you can use the same topology for various cases without having to redefine it each time.

Note

Because the topology file is a text file, you can write your own topology files using a text

editor.

Grid and Boundary Condition Files

.grd and .bcf grid and boundary condition files are produced by ANSYS TurboGrid and contain the

mesh in a format which can be read by CFX-TASCflow. For details, see Save Mesh Command (p. 17).

Mesh File

.gtm mesh files are produced by ANSYS TurboGrid and contain the mesh in a format which can be

read by ANSYS CFX. For details, see Save Mesh Command (p. 17).

BladeGen.inf File

BladeGen.inf information files contain machine data and curve file data. By loading a BladeGen.inf
file, you can set up the machine data, hub, shroud, and blade curves.

When loading a BladeGen.inf file, the curve type of the Hub and Shroud geometry objects will be

set to Piecewise Linear.

Curve File

.crv and .curve curve files are used by ANSYS TurboGrid to define machine geometry. These files

contain points in free-format ASCII style and can be created using a text editor, ANSYS BladeGen or by

saving a modified blade geometry in ANSYS TurboGrid.

TurboGrid 1.6 cfg File

.cfg simulation setup files contain machine data. By loading a .cfg file, you can set up the machine

data, the hub, shroud, blade curves, and the tip geometry.
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Tetin File

.tin Tetin files are produced by ANSYS TurboGrid and describe the geometry in a format which can

be read by ICEM CFD products. For details, see Export Geometry Command (p. 20).

Picture Files

PNG (.png), CFD Viewer State (3D), JPEG (.jpg), Windows Bitmap (.bmp), PPM (.ppm), PostScript

(.ps), Encapsulated PS (.eps), and VRML (3D) (.wrl) files can be saved. For details, see Save Picture

Command (p. 20).

2.2. New Case Command

To display the object selector and begin a new ANSYS TurboGrid simulation, select File > New Case

from the main menu or click New Case .

2.3. Load BladeGen Command

To load a BladeGen inf file, select File > Load BladeGen. The Open BladeGen File dialog box is dis-

played. Select a file to load, then click Open. The inf is structured as follows:

!======  CFX-BladeGen Export  ========
Axis of Rotation: Z
Number of Blade Sets: 9
Number of Blades Per Set: 2
Geometry Units: MM       <---- Unknown|IN|MM|FT|MI|M|KM|MIL|UM|CM|UIN
Blade 0 LE: EllipseEnd   <---- EllipseEnd|CutoffEnd|SquareEnd
Blade 0 TE: CutOffEnd
Blade 1 LE: EllipseEnd
Blade 1 TE: CutOffEnd
Hub Data File: hub3.curve
Shroud Data File: shroud3.curve
Profile Data File: profile3.curve

(The statements following “<----” are comments that show possible values. They are not part of the

format.)

If the inf file does not specify the curve files, you may turn on an option in the dialog box (called

Guess missing curve files) in order to guess the names of the missing curve files. The algorithm for

guessing curve files looks for files in the working directory with a .curve or .crv extension, with

“hub”, “shroud”, or “profile” in the name (using a case-insensitive search). If the curve file names are

unusual, you should verify that the correct curve files were selected by opening the appropriate Geo-
metry object (for example, the Hub object) in the object editor, or by selecting File > Load Curves

and examining the curve file names.

If a BladeGen.inf file specifies multiple blades in the blade set, multiple blades will be generated.

Note

After loading a BladeGen.inf file, the Curve Type settings for the Hub and Shroud objects

will be set to Piece-wise linear instead of the default (Bspline).
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2.4. Load Curves Command

To load new geometry curves, select File > Load Curves from the main menu or click Load Curves .

The Load TurboGrid Curves dialog box is displayed.

This dialog box provides a convenient way to define multiple geometry objects, compared to editing

each geometry object separately using the object selector. It is useful when you first open ANSYS Tur-

boGrid and when you want to use the same settings on a slightly modified geometry.

The information specified on the Load TurboGrid Curves dialog box will be used to overwrite the

corresponding information in the appropriate geometry objects. No other previously-defined settings

are affected. For example, if a control angle is defined for the Hub object, it will not be changed by

using the Load TurboGrid Curves dialog box.

If a curve file that specifies multiple blades in the blade set is specified for the Blade Set object,

multiple blades will be generated. If a curve file that specifies multiple blades in the blade set is specified
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for a particular blade object (stored under the Blade Set object in the object selector), only the first

blade in the file is used. If blade names are not included in the curve file, then names will be generated

in the form Blade n, where n is an integer.

2.4.1. Geometry

A rotating machine component is made up of adjacent blades which are equally spaced around the

circumference of the machine. The Theta extent of one blade set is calculated as 360 degrees divided

by the number of main blades. Many rotating machine components have secondary and tertiary blades

which are placed between the main blades. These are often called splitter blades. A blade set contains

one main blade and optional splitter blades which repeat cyclically around the axis of the rotating

machine component.

For rotating machine components without any splitter blades, the number of blade sets equals the total

number of blades.

ANSYS TurboGrid creates a mesh for one blade set only. The mesh can be copied and rotated using an

ANSYS CFX Pre-processor, if necessary, before it is solved in an ANSYS CFX Solver.

2.4.2. Rotation

Click  next to the method box to see the available methods for defining the machine’s rotation axis.

• Using Principal Axis, select the rotation axis from the X, Y or Z axes using the Axis drop-down

list.

• Using Rotation Axis, define a custom rotation axis by entering the Cartesian coordinates of 2 points

on the axis. The coordinates of the points can be typed in or set using the embedded sliders.

2.4.3. Coordinates and Units

Click  next to the corresponding boxes to select the coordinates, angle units, and length units used

in the hub, shroud, and blade files. If any of these are not the same for all three geometry files, use the

object selector to individually define them.

2.4.4. TurboGrid Curve Files

To specify a curve file, set a file name using a path relative to the working directory. You can click the

corresponding Browse  icon to select a curve file using a browser.

2.4.5. Leading/Trailing Edge Definition on the Blade

Define whether the trailing edge is cut-off or square. Optionally specify a line-of-rotation division

of the mesh that stems from the trailing edge at the hub and shroud. The same applies for the leading

edge.

2.5. Load CFG Command

To load ANSYS TurboGrid 1.6 simulation setup (CFG) files, select File > Load CFG from the main menu

to access the Load CFG File dialog box.

The Length Units setting in the dialog box must be set correctly. The units that you specify will be

used to interpret the data stored in the curve files specified by the CFG file.
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The following data is loaded from a CFG file:

• # of passages

• Axis of rotation

• Existence of tip and location

• Coordinate frame for curve files

• Hub, shroud and blade curve file names

• Existence of inlet and outlet regions.

2.6. Reread Curves Command

To re-load the curve files that have previously been loaded into memory, select File > Reread Curves.

This command is useful if you are updating the files in, for example, ANSYS BladeGen/Blade Modeler,

and you want to re-load the updated files into ANSYS TurboGrid.

2.7. Load State Command (Import State Command)

A previously saved state file can be loaded into ANSYS TurboGrid. To load a state file in stand-alone

mode, select File > Load State from the main menu or click Load State  on the toolbar; when running

in ANSYS Workbench, select File > Import State. The Load State File dialog box is displayed.

If any file specified in a state or session file cannot be found, ANSYS TurboGrid will automatically search

the state or session file directory for a file of the same name. If this search fails, the current working

directory will be searched. As a result, state and session files will not have to be edited to change the

path when state, session and curve files are moved from one directory to another.

Select the Load as new simulation radio button to delete all existing objects and create new objects

which are defined in the state file.

Select the Append to current simulation radio button to add all objects defined in the state file to

the existing objects. Existing objects are not removed unless they have the same name as an object in

the state file, in which case they are replaced. Loading a state file in this way allows the use of a number

of state files as building blocks for commonly used objects.

Note

If you are running ANSYS TurboGrid in ANSYS Workbench, and there is a geometry provided

to ANSYS TurboGrid from an upstream cell, then that geometry is used and the geometry

data in the state file is ignored.

Note

Because the TOPOLOGY SET object is now suspended by default, session and state files

from version 11 or earlier may not play or load correctly. To support older session and state

files, the Play Session File and Load State dialog boxes have an option named Unsuspend

TOPOLOGY SET before loading. Selecting this option causes the TOPOLOGY SET object

to be unsuspended before playing/loading a session/state file. When starting ANSYS TurboGrid

from the command line, adding the command line parameter -u causes the TOPOLOGY
SET object to be initially unsuspended.
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2.8. Save State Command (Export State Command)

If you have not saved a state file during the current ANSYS TurboGrid session, selecting File > Save

State from the main menu (File > Export State when running in ANSYS Workbench) opens the Save

State dialog box where you can type a file name for your state file. For details, see Save State As Com-

mand (p. 15).

If you have already saved a state file during the current ANSYS TurboGrid session, selecting File > Save

State from the main menu overwrites that file. To save a state to a different file name, select File >

Save State As... from the main menu. For details, see Save State As Command (p. 15).

2.9. Save State As Command

Saving a state file produces a text file containing CCL commands for the current ANSYS TurboGrid state.

To save a state to a new file, select File > Save State As... from the main menu or click Save State As...

. The Save State dialog box is displayed.

Set Look in to the directory in which you want to create the state file.

In the list on the right side, select the objects to include in the state file, or select Save All Objects. If

Save All Objects is selected, the current state of all objects is written to the state file. If Save All Objects

is cleared, select the objects to save to the state file by clicking on each object. The current state of all

selected objects is written to the state file.

Enter (or select) a file name, then click Save to save the state file.

A state file is linked to the geometry files from which it was created by an absolute path; therefore, the

location of the geometry files should not be changed. This also applies to topology files if the From

File option is selected for a Topology Set object.

State files are automatically saved with a .tst file extension.
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2.10. Save Project

When running in ANSYS Workbench, you can select File > Save Project to save the entire ANSYS

Workbench project.

2.11. Refresh

When running in ANSYS Workbench, you can select File > Refresh to refresh the associated Turbo Mesh

cell.

2.12. Save Submenu

Many objects that can be saved or saved under a different name are listed under the Save submenu.

• Save Blade Command (p. 16)

• Save Blade As Command (p. 16)

• Save Periodic/Interface Surfaces Command (p. 16)

• Save Inlet Command (p. 17)

• Save Inlet As Command (p. 17)

• Save Outlet Command (p. 17)

• Save Outlet As Command (p. 17)

• Save Topology Command (p. 17)

• Save Topology As Command (p. 17)

2.12.1. Save Blade Command

If you have not saved a blade file during the current ANSYS TurboGrid session, selecting File > Save >

Blade from the main menu opens the Save Blade dialog box where you can type a file name for your

blade file. For details, see Save Blade As Command (p. 16).

If you have already saved a blade file during the current ANSYS TurboGrid session, selecting File > Save

> Blade from the main menu overwrites that file. To save a blade to a different file name, select File >

Save > Blade As... from the main menu. For details, see Save Blade As Command (p. 16).

2.12.2. Save Blade As Command

Saving a blade file produces a text file defining the current blade, which can then be used to define

the blade for future meshes. If the same changes to the blade would otherwise be repeated, this elim-

inates wasted time. To save a blade to a new file, select File > Save > Blade As from the main menu.

The Save Blade dialog box is displayed.

Blade files are saved with a .crv file extension if the file type is All Blade Files (*.crv
*.curve).

2.12.3. Save Periodic/Interface Surfaces Command

Saving the periodic/interface surfaces produces a text file describing the location and shape of the in-

terfaces between adjacent blades. You can optionally set a base name for constructing the data file

name. You can optionally change the units in which to save the data.
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2.12.4. Save Inlet Command

Saving the inlet produces a text file describing the location and shape of the inlet region. This includes

any added inlet points.

Inlet files are saved with a .crv file extension if the file type is All Inlet Files (*.crv
*.curve).

2.12.5. Save Inlet As Command

Save an inlet (see above) to an alternative filename.

2.12.6. Save Outlet Command

Saving the outlet produces a text file describing the location and shape of the outlet region. This includes

any added inlet points.

Outlet files are saved with a .crv file extension if the file type is All Outlet Files (*.crv
*.curve).

2.12.7. Save Outlet As Command

Save an outlet (see above) to an alternative filename.

2.12.8. Save Topology Command

If you have not saved a topology file during the current ANSYS TurboGrid session, selecting File > Save

> Save Topology from the main menu opens the Save Topology dialog box where you can type a file

name for the topology file. For details, see Save Topology As Command (p. 17).

If you have already saved a topology file during the current ANSYS TurboGrid session, selecting File >

Save > Save Topology from the main menu overwrites that file. To save a topology to a different file

name, select File > Save > Save Topology As from the main menu. For details, see Save Topology As

Command (p. 17).

2.12.9. Save Topology As Command

Saving a topology file produces a text file defining the current topology. This file can then be used to

define the topology for other geometries, which may be necessary for certain analyses. To save a topology

to a new file, select File > Save > Save Topology As from the main menu or click Save Topology As

. The Save Topology window is displayed.

Topology files are saved with a .tgt file extension automatically.

2.13. Save Mesh Command

If you have not saved a mesh during the current ANSYS TurboGrid session, selecting File > Save Mesh

from the main menu opens the Save Mesh dialog box where you can type a file name for the mesh

file(s). For details, see Save Mesh As Command (p. 18).
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If you have already saved a mesh during the current ANSYS TurboGrid session, selecting File > Save

Mesh from the main menu overwrites the file(s). To save a mesh to a different name, select File > Save

Mesh As from the main menu. For details, see Save Mesh As Command (p. 18).

2.14. Save Mesh As Command

Saving a mesh file produces input files for ANSYS CFX or CFX-TASCflow, or produces a CGNS file. To

save a mesh to a new file, select File > Save > Save Mesh As from the main menu or click Save Mesh

As . The Save Mesh dialog box is displayed.

2.14.1. Save Mesh Dialog Box

Set Look in to the directory in which you want to create the mesh file.

2.14.1.1. File Type

If File type is set to ANSYS CFX, a file of type .gtm is saved by default (that is, if no extension is

specified). You can also save a file of type .def by adding the .def extension to the specified filename.

Both .gtm and .def files contain regions that can be used in CFX-Pre to set up a CFD problem.

If File type is set to CFX-TASCflow, four types of file are saved: .grd, .bcf, .gci and .lun. A

.grd file contains a number of regions that can be used in CFX-TASCflow to set up the CFD problem.

If you specify the filename mycustomname or mycustomname.grd, ANSYS TurboGrid saves files

named mycustomname.grd, mycustomname.bcf, mycustomname.gci, and mycustomname.lun.

If you specify a filename of grd, ANSYS TurboGrid saves files named grd, bcf, gci, and name.lun.

If File type is switched to CFX-TASCflow when the specified file name is blank, ANSYS TurboGrid

sets the file name to grd.

If File type is set to CGNS, a .cgns file is saved. The .cgns file can be used by, for example, CFX-Pre,

CFD-Post, and FLUENT.

If you change File type, any existing file extension (for example, .def or .grd) is changed automatically

in the specified file name.
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2.14.1.2. Export Units

Set Export Units to the length unit for the exported mesh.

2.14.1.3. Write In/Out/Passage As

If File type is set to ANSYS CFX, the following options are available:

• Separate domains, one file The inlet and outlet blocks remain separate from the passage block. Three

separate assemblies appear in CFX-Pre. This choice is ideal when you want to place the inlet and outlet

blocks in a different frame of reference from the passage.

• Combined in one domain, one file

The inlet and outlet blocks are combined with (merged with) the passage block. One combined

assembly appears in CFX-Pre. This choice is ideal when you want to keep the inlet and outlet blocks

in the same frame of reference as the passage.

• Separate domains, multiple files

The inlet and outlet blocks are combined with (merged with) the passage block. One combined

assembly appears in CFX-Pre. This choice is ideal when you want to keep the inlet and outlet blocks

in the same frame of reference as the passage.

If File type is set to CFX-TASCflow, three sets of files are saved using the same naming convention

as for CFX. This means that there will be a FILENAME_Inlet, FILENAME_Outlet, and a FILENAME
all of which will each have a file with a .grd, .bcf, .gci and .lun extension.

2.14.1.4. Write Single Precision Mesh

If File type is set to ANSYS CFX, you can select the Write single precision mesh check box to cause

a single-precision mesh file to be written instead of a double-precision file. The default is double-precision.

There is little benefit to using single-precision other than to reduce the size of the mesh file.

2.14.1.5. Generate Periodic and GGI Interfaces

This option is available if File type is set to CFX-TASCflow. This option causes the export to carry

out the following steps:

• Create a .gci file for each mesh which defines macros for generating periodic interfaces in CFX-

TASCbob3D.

• Run CFX-TASCbob3D in batch (if CFX-TASCflow is installed with a valid license), execute the required

macros to generate the interfaces between blades (passage and periodic interfaces), and update the

.grd and .bcf files as required.

2.14.2. Region Naming

The regions saved to the .gtm, .def, and .grd files are BLADE, PER1, PER2, HUB, SHROUD, INFLOW

and OUTFLOW.

If the mesh has an inlet or outlet 3D region, additional regions will be created in the files for these do-

mains with the suffix Inlet or Outlet. For example, the regions for a case with an inlet 3D region are

PER1 Inlet, PER2 Inlet, HUB Inlet, SHROUD Inlet, INFLOW and OUTFLOW Inlet. The same applies for an
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outlet 3D region and for the Passage Region. For the parts specific to a region (BLADE for Passage, IN-

FLOW for Inlet, and OUTFLOW for Outlet), no suffix is added.

2.15. Export Geometry Command

The geometry in ANSYS TurboGrid can be exported to a tetin file format which can then be read by

ICEM CFD products. To export a geometry to a tetin file, select File > Export Geometry from the main

menu. The Export Geometry dialog box is displayed.

Geometry files are saved with a .tin file extension automatically.

2.16. Save Picture Command

To save the current contents of the viewer window to a file, select File > Save Picture from the main

menu or click Save Picture . The Save Picture dialog box is displayed.

2.16.1. Save Picture Dialog Box

Type a file name and path into the File box, or click Browse  to open a dialog box that helps you to

select a directory and file name.

Files are always saved with the file extension corresponding to the selected graphics format.

2.16.1.1. Format

Click  next to the Format box to see the available file formats.
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• Portable Network Graphics (*.png) is a file format intended to replace the GIF format. It was

designed for use on the WorldWide Web and retains many of the features of GIF with new features

added.

• CFD Viewer State (3D) (*.cvf) is a format that can be read by the stand-alone CFD viewer.

• JPEG (*.jpg) is a compressed file format developed for compressing raw digital information. File sizes

are small but it is not recommended for line drawings.

• Bitmap (*.bmp) files are usually large and do not adjust well to resizing or editing. They do retain all

of the quality of the original image and can be easily converted to other formats.

• Portable Pixel Map (*.ppm) is similar to the bitmap format.

• PostScript (*.ps) and Encapsulated PS (*.eps) are generally recommended for output to a printer or

line drawings. However, labels
1
, the ruler 

2
 and transparency

3
 will cause the PS/EPS to output as a very

large bitmap file, in which case a PNG file would be a more efficient alternative. Note that the ANSYS

logo and the axis do not cause the PS/EPS output to become a bitmap.

• Virtual Reality Modeling Language (*.wrl) is used to present interactive three-dimensional

views and can be delivered across the World Wide Web.

2.16.1.2. Use Screen Capture Check Box

When Use Screen Capture is selected, a screen capture of the viewer is saved to the output file.

Note

Face culling only affects printouts made using the screen capture method.

2.16.1.3. White Background Check Box

You can save the current image with a white background by selecting White Background.

When the White Background check box is selected, certain white objects are colored black and certain

black objects are colored white in the image file (except VRML). Objects that are not affected can usually

be manually colored by editing them.

2.16.1.4. Enhanced Output (Smooth Edges) Check Box

When Enhanced Output (Smooth Edges) is selected, the image is processed by antialiasing.

2.16.1.5. Use Screen Size Check Box

When Use Screen Size is selected, the output has the same width and height, measured in pixels, as

shown in the viewer. You can clear the check box to specify the width and height manually.

2.16.1.6. Width and Height Settings

You can specify the width and height of the image in pixels by entering values for Width and Height.

In order to use these settings, the Use Screen Size check box must be cleared.

1
You can hide labels from Edit > Options > CFX-Pre > Labels and Markers > Labels.

2
You can hide the ruler from Edit > Options > CFX-Pre > Graphics Style > Visibility > Ruler Visibility.

3
You can control transparency from Edit > Render > Transparency.
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2.16.1.7. Scale (%)

Scale (%) is used to scale the size of bitmap images to a fraction (in percent) of the current viewer

window size. This option is disabled with the clearing of the Use Screen Size check box.

2.16.1.8. Image Quality

Image Quality is only available for the JPEG format. Type in the value for the image quality, increase

or decrease the value by 1 by clicking  or  respectively, or use the embedded slider (which has a

maximum value of 100, which is the highest image quality, and a minimum value of 1, which is the

lowest image quality).

2.16.1.9. Tolerance

Tolerance is a non-dimensional value used in face sorting when generating pictures. Larger values

result in faster generation times, but may cause defects in the resulting output.

2.16.1.10. Save Button

Click Save to save the current viewer contents to an image file.

2.17. Recent State Files Submenu

ANSYS TurboGrid saves the file paths of the last several state files opened. To re-open a recently used

state file, select File > Recent State Files from the main menu and then select the file from the Recent

State Files submenu.

2.18. Recent Session Files Submenu

ANSYS TurboGrid saves the file paths of the last several session files opened. To re-open a recently used

session file, select File > Recent Session Files from the main menu and then select the file from the

Recent Session Files submenu.

2.19. Quit Command

To exit from ANSYS TurboGrid select Quit from the file menu. Objects created during the ANSYS Tur-

boGrid session are not automatically saved. If you want to save the objects before quitting, create a

state file. For details, see Save State Command (Export State Command) (p. 15).
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Chapter 3: Edit Menu

The following sections describe the commands available in the Edit menu:

3.1. Undo and Redo Commands

3.2. Options Command

3.1. Undo and Redo Commands

ANSYS TurboGrid includes an infinite Undo feature, limited only by the available memory on the machine

and a few other restrictions described below. Select Edit > Undo from the main menu or click Undo

 on the toolbar to return to the state immediately prior to when the last Apply action was executed.

Select Edit > Redo from the main menu or click Redo  on the toolbar to reapply changes that were

undone. A Redo command must follow an undo or Redo command.

The undo function has a few limitations:

• When a mesh is created, the undo stack is cleared, meaning that the mesh creation process itself, and

all commands before it, cannot be undone using the Undo command.

• While creating a session file, the undo/redo commands are not available.

• Any action which does not affect the state cannot be undone. For example, creating a mesh cannot be

undone, nor can saving a topology file since neither of these actions changes the state.

• The undo function cannot return to the initial state of a default object. For example, after defining the

Hub object for the first time, you cannot click Undo to return to the undefined state of the Hub object.

• Undo also reverses geometry manipulation when the named view icons located at the top of the

Viewer window have been used. Rotation, zoom and translation actions performed using the mouse

are not affected by selecting Edit > Undo from the main menu or by clicking on the  icon on the

toolbar. You can, however, undo some viewer manipulations. For details, see Viewer Hotkeys (p. 53).

The redo feature is used to reverse an undo action. Selecting Edit > Redo from the main menu or

clicking on the  icon on the toolbar can be done repeatedly to reverse as many undo actions as

have been applied.

3.2. Options Command

Select Edit > Options from the main menu to set various viewer and appearance options in ANSYS

TurboGrid.

3.2.1. TurboGrid Options

The Enable Beta Features check box will make the beta features of ANSYS TurboGrid available.
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3.2.1.1. Viewer

Highlight Type controls how an object is highlighted in the viewer window while in picking mode when

highlighting is on. For details, see Viewer Toolbar (p. 52).

• If Bounding Box is selected, the object is always highlighted with a red box surrounding the Object.

• If Wireframe is selected, the object is traced with a red line if the object contains surfaces.

3.2.1.1.1. Background

The following background options are available:

• Color: A constant color can be chosen.

• Image: One of a list of Predefined images or a Custom image can be selected. When setting a

custom image, you must choose an image file and a type of mapping. The image types that are supported

are: bmp, jpg, png, ppm. Mapping options are Flat and Spherical.

3.2.1.1.2. Text Color and Edge Color

In the stand-alone version, set text color and edge color as appropriate.

3.2.1.1.3. Axis Visibility

If the Axis Visibility check box is selected, the axis appears in the lower left corner of the viewer window.

The axis is useful for reference when the geometry is rotated. The axis labels change when the viewer

coordinates are transformed.

3.2.1.1.4. Ruler Visibility

If the Ruler Visibility check box is selected, a ruler appears in the viewer to show the length scale.

3.2.1.1.5. Stereo

See Stereo Viewer (p. 56).

3.2.2. Common Options

ANSYS TurboGrid includes an auto-save function which backs up work at set time intervals by saving

a state file. Select the frequency of the auto save by picking a value from the drop-down list. Auto Save

can be disabled by selecting Never from the list.

To change the directory in which auto-saved state files are saved, type a file name and path into the

Temporary Dir box, or click on the browse icon beside the Temporary Dir box to open the Temporary

Directory dialog box.

3.2.2.1. Appearance

Click on Appearance in the options box to control the appearance of the GUI.
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ANSYS TurboGrid sets the GUI Style to that of the machine’s platform, by default. For example, on

Windows the GUI has a Windows look to it. If you prefer a Linux appearance to the GUI, then select

Motif from the drop-down list. Any of the following appearances can be used on any platform:

• Windows

• Motif

• CDE

• Plastique

• Cleanlooks

The font used within the GUI can be changed by clicking on the font button to open the Select Font

window.

3.2.2.2. Viewer Setup: General

Viewer options under the Common branch are Double Buffering and Unlimited Zoom toggles.

Note

Using Unlimited Zoom will allow the exceeding of the depth buffer accuracy, resulting in

rendering artifacts.

3.2.2.2.1. Double Buffering

Double Buffering is a feature supported by most OpenGL implementations. It provides two complete

color buffers that swap between each other to animate graphics smoothly. If your implementation of

OpenGL does not support double buffering, you can clear this check box.

3.2.2.2.2. Unlimited Zoom

By default, zoom is restricted to prevent graphics problems related to depth sorting. Selecting Unlim-
ited Zoom allows an unrestricted zoom.

3.2.2.3. Viewer Setup: Mouse Mapping

The mouse mapping options enable you to assign viewer actions to mouse actions and keyboard/mouse

combined actions.

A description of each action follows.

• Rotate: rotate the view about the screen X and Y axes.
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• Object Zoom: drag the mouse up to zoom out and down to zoom in.

• Camera Zoom: drag the mouse up to zoom in and down to zoom out.

• Translate: drag the mouse to translate the view in the plane of the screen.

• Zoom Box: drag a rectangle around the area of interest. The selected area will fill the viewer when the

mouse button is released.

• Zoom In: click the mouse button to zoom in step-by-step centered on the location of the mouse

pointer.

• Zoom Out: click the mouse button to zoom out step-by-step centered on the location of the mouse

pointer.

• Rotate Z: drag the mouse up to rotate the view clockwise about the screen Z axis, and down to rotate

the view counterclockwise.

• Set Pivot Point: click on an object to set the point about which the Rotate and Rotate Z actions pivot.

• Move Light: drag to move the angle of the virtual light source in the viewer. Drag the mouse left or

right to move the horizontal lighting source and up or down to move the vertical lighting source. The

lighting angle holds two angular values, each between 0° and 180°.

3.2.2.4. Units

Click on Units in the options box to control the units which are presented in the GUI for each

Quantity Type.

Select a pre-defined Units System such as SI, English Engineering or British Technical.

The predefined Units for any quantity types in these units systems cannot be changed. Select the Custom

units system to specify any valid units for each quantity type. For example, you may want to display

Length in mm (an SI unit), but Angle in radians (not an SI unit). Click on More Quantity Types to

display the Custom Quantity Types form and set custom units for more quantity types.

The units set on this panel define the units used in the GUI for all quantity types. The units you select

for a quantity type appear wherever that quantity type is used. For example, if you choose mm as the

unit of Length and create a plot in ANSYS TurboGrid colored by Length, you must specify a user specified

length range in units of mm. If you created a Legend for the plot, the values on the Legend would be

in units of mm.

If the Always convert units to Preferred Units check box is selected, all quantities entered in the GUI

are converted into the preferred units.

Note

Setting units in the variable editor will override the actual setting for that quantity type.

3.2.2.5. Advanced

The cmd timeout value is an advanced feature. It sets the delay between a mouse control action and

its execution.
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Chapter 4: Session Menu

The following sections describe the commands available in the Session menu:

4.1. Introduction

4.2. Play Session Command

4.3. New Session Command

4.4. Start Recording Command

4.5. Stop Recording Command

4.1. Introduction

Session files contain a record of the commands issued during an ANSYS TurboGrid session. Actions that

cause commands to be written to a session file include:

• Creation of new objects and changes to existing objects committed by clicking Apply in the object

editor.

• Creation of a mesh.

• Commands issued in the Command Editor dialog box.

• Calculations performed in the built-in calculator.

• Viewer manipulation performed using the icons located at the top of the viewer window. (Viewer ma-

nipulation performed using the mouse and keyboard are not recorded to a session file.)

• Creation of new cameras and selecting a camera view.

• All actions available from the File menu.

• Creation of expressions and user variables.

• Creation of chart lines and viewing charts.

Session files can be used to run ANSYS TurboGrid in batch mode. For details, see Batch Mode in the

TurboGrid Reference Guide.

Note

Since the session file is a text file of CCL commands, you can write your own session files

using a text editor.

Note

Do not end your session file with the quit command.
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4.2. Play Session Command

A previously recorded session file can be played in ANSYS TurboGrid. To play a session file, select Session

> Play Session from the main menu or click Play Session  on the toolbar. The Play Session File

dialog box is displayed.

The commands listed in the selected session file are executed. Existing objects with the same name as

objects defined in the session file are replaced by those in the session file.

For any file specified in a state or session file, if the file cannot be found ANSYS TurboGrid will automat-

ically search the state or session file directory for a file of the same name. If this procedure fails, the

current working directory will be searched. As a result, state and session files will not have to be edited

to change the path when state, session and curve files are moved from one directory to another.

Note

A session file cannot be played if it contains the Undo command. To run a session file which

contains the Undo command, edit the session file first to remove the command.

Note

Since the TOPOLOGY SET object is now suspended by default, session and state files from

version 11 or earlier may not play or load correctly. To support older session and state files,

the Play Session File and Load State dialog boxes have an option named Unsuspend TO-

POLOGY SET before loading. Selecting this option causes the TOPOLOGY SET object to

be unsuspended before playing/loading a session/state file. When starting ANSYS TurboGrid

from the command line, adding the command line parameter -u causes the TOPOLOGY
SET object to be initially unsuspended.

Note

Workbench journal files for TurboGrid and TurboGrid session files from 12.0/12.1 may not

work with 14.0. If the recorded file does not explicitly set the topology type, the following

CCL block needs to be added:

TOPOLOGY SET:
ATM Topology Optimizer = off
END

For Workbench journal files, this CCL block should be added immediately before the following

line occurs:

> um mode=normal, object=/TOPOLOGY SET

The line above appears only in journal files that were recorded while the Topology Set
object was processed (unsuspended).

For session files, this CCL block should be added to the beginning of the session file.

For information about using ANSYS Workbench journaling and scripting with ANSYS TurboGrid, see

Using ANSYS Workbench Journaling and Scripting with TurboSystem in the TurboSystem User Guide.

Release 14.0 - © SAS IP, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.28

Chapter 4: Session Menu



4.3. New Session Command

To create a new Session file, select Session > New Session from the main menu or click New Session

 on the toolbar. The Set Session File dialog box is displayed.

Upon clicking Save in the dialog window, that file becomes the current session file. Commands are not

written to the file until recording begins. For details, see Start Recording Command (p. 29).

Session files should be saved with a .tse file extension. The extension is added to a file name if TG
Session Files (*.tse) is selected as the file type.

If you create more than one session file during a ANSYS TurboGrid session, the most recently created

file is by default the current session file. To set a different file to be the current session file, select an

existing file from the Set Session File dialog box and then click Save. The following message then appears:

Click Overwrite to delete the existing session file and create a new file in its place. Click Append to

add selected commands to the end of the existing session file when recording begins.

4.4. Start Recording Command

To start recording a session file, select Session > Start Recording from the main menu or click Start

Recording  on the toolbar. This activates recording of CCL commands issued to the current session

file. A session file must be set before recording can begin. For details, see New Session Command (p. 29).

While recording a session file, the Undo  and Redo  icons are disabled.

4.5. Stop Recording Command

To stop recording a session file, select Session > Stop Recording from the main menu or click Stop

Recording  on the toolbar. This terminates recording of CCL commands issued to the current session

file. Start and stop recording to a session file as many times as necessary.
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Chapter 5: Insert Menu

The following sections describe the commands available in the Insert menu.

Note

Some of the commands in the Insert menu are not available until you create a mesh.

5.1. Introduction

5.2. Mesh Command

5.3. User Defined Submenu

5.1. Introduction

The Insert menu contains a list of objects that can be used as tools to analyze the mesh and geometry

(although they are not necessary for mesh generation).

When you select any of the objects from the Insert menu, a dialog box appears in which you can either

accept the default name or type a new one for the object (in this case a plane). The name should be

different from any current object of the same type to avoid overwriting the existing object. ANSYS

TurboGrid does not let you create objects with the same name but different types.

Click OK or press Enter to open the relevant object editor. The object does not exist in the database

until you click Apply in the object editor. For information on how to create objects from the command

line see Object Creation and Deletion in the TurboGrid Reference Guide

5.2. Mesh Command

The flow path through the rotating machine is divided into small but discrete volumes. These volumes

are hexahedral elements, which have six sides and eight corners. There are nodes placed on each corner

and the assembly of these nodes forms the mesh. The mesh fills the entire flow path and is used by

ANSYS CFX solvers. The quality of the solution depends partly on the quality of the Mesh. To create a

mesh, select Insert > Mesh from the main menu, click Insert Mesh  on the toolbar, or right-click

anywhere in the viewer or tree view and select Insert Mesh from the shortcut menu.

ANSYS TurboGrid creates the mesh using the current state of the Topology Set and Mesh Data
objects. The time it takes to create the mesh depends on its size and the number of smoothing iterations

chosen. Displayed in the status bar at the bottom left corner of the application window is an estimate
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of the total number of nodes and the total number of elements in the mesh. After the mesh is created,

the color and rendering settings in the viewer window can be controlled for each individual mesh surface.

If changes are made to any of the Geometry, Topology Set, Mesh Data, or Layers objects, the

mesh must be recreated in order for these changes to be included in the mesh.

5.3. User Defined Submenu

The User Defined submenu lists commands that create new objects.

Each command invokes a dialog box to prompt you for the name of the object to create. The name of

a new object must be different from any existing object. When you click OK or press Enter to accept

the name of the object, the relevant object editor opens, but the object is not created until you click

Apply on the object editor.

5.3.1. Point Command

A point can exist anywhere within or outside the domain. To create a new point, select Insert > User

Defined > Point from the main menu.

5.3.1.1. Point: Geometry Tab

5.3.1.1.1. Point Definition

The available options for defining a point are described next:

• XYZ

Set the point coordinates. To set the coordinates, first click one of the point coordinate boxes. The

point coordinates will be displayed with a yellow background, and the viewer will switch to picking

mode. You can then pick a point directly by clicking a visible object in the viewer. The point can

lie outside of the domain.

You can alternatively set the coordinates one-at-a-time by typing in the coordinates and/or using

the embedded slider that appears beneath the coordinate boxes.

• Node Number

Create a point at a nodal location. Use the Domains drop-down list to select the domain(s) in

which the locator exists. After choosing the domain(s) in which to select the node, enter the node

number. Type in the node number or set it using the embedded sliders. When more than one domain

is selected, a point is created for the specified node number in each domain (if the node number

exists). If the node number does not exist in one domain but exists in another, select only the domain

in which the node exists or an error message is displayed.

• Variable Minimum and Variable Maximum

Create the point where a variable is at its maximum or minimum value on any named locator. The

Domains drop-down list is used to select the domain(s) in which the locator exists. After choosing

the domain(s), select the locator name and the variable of interest. When more than one domain

is selected, a point is created for the maximum/minimum value of the variable within each domain.
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5.3.1.1.2. Symbol Definition

The Symbol Size must be between 0 and 10 (10 being a similar scale to the geometry). Type in the

value or set it using the embedded slider.

Set Symbol to one of the available symbols.

Picking Mode can be used to select and/or translate points in the viewer. For details, see Viewer Tool-

bar (p. 52).

Note

You cannot move points that have been defined using Node Number, Variable Minimum,

or Variable Maximum.

5.3.1.2. Point: Color Tab

See Color Tab (p. 5) for details.

5.3.1.3. Point: Render Tab

See Render Tab (p. 6) for details.

5.3.2. Line Command

A line locator can exist between two points anywhere within or outside the domain. To create a new

line, select Insert > User Defined > Line from the main menu.

5.3.2.1. Line: Geometry Tab

5.3.2.1.1. Domains

Select the domain(s) in which the line will exist.

5.3.2.1.2. Line Definition

Lines are created by defining two points. To set the coordinates, first click one of the point coordinate

boxes. The point coordinates will be displayed with a yellow background, and the viewer will switch to

picking mode. You can then pick a point directly by clicking a visible object in the viewer. The point

can lie outside of the domain.

You can alternatively set the coordinates one-at-a-time by typing in the coordinates and/or using the

embedded slider that appears beneath the coordinate boxes.

5.3.2.1.3. Line Type

Set the Line Type to either Cut or Sample.

• Cut extends the line in both directions until it reaches the edge of the domain. Points on the line cor-

respond to points where the line intersects a mesh element face. As a result, the number of points on

the line is indirectly proportional to the mesh spacing.
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• Sample creates the line between the two specified points. The sample line is a set of evenly-spaced

sampling points that are independent of the mesh spacing. The number of points along the line corres-

ponds to the value in the Samples box.

Picking Mode can be used to select and/or translate lines in the viewer. For details, see Viewer Tool-

bar (p. 52).

5.3.2.2. Line: Color Tab

See Color Tab (p. 5) for details.

5.3.2.3. Line: Render Tab

See Render Tab (p. 6) for details.

5.3.3. Plane Command

A plane locator is a two-dimensional area that exists only within the boundaries of the geometry. To

create a new plane, select Insert > User Defined > Plane from the main menu.

5.3.3.1. Plane: Geometry Tab

5.3.3.1.1. Domains

Select the domain(s) in which the plane will exist.

5.3.3.1.2. Plane Definition

The available methods for defining a plane are described next:

• YZ Plane

Create a plane normal to the X axis and at a specific X value. Type in a value for X, set it using the

embedded slider, or click in the box beside X, then click Enter Expression  to the right of the X

setting and enter its value as an expression. For details, see Expressions Command (p. 61).

• ZX Plane

Create a plane normal to the Y axis and at a specific Y value. Type in a value for Y, set it using the

embedded slider, or click in the box beside Y, then click Enter Expression  to the right of the Y

setting and enter its value as an expression. For details, see Expressions Command (p. 61).

• XY Plane

Create a plane normal to the Z axis and at a specific Z value. Type in a value for Z, set it using the

embedded slider, or click in the box beside Z, then click Enter Expression  to the right of the Z

setting and enter its value as an expression. For details, see Expressions Command (p. 61).

• Point and Normal

Create a plane using a single point on the plane and a vector normal to the plane.

To set the point coordinates, first click one of the point coordinate boxes. The point coordinates

will be displayed with a yellow background and the viewer will switch to picking mode. You can
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then pick a point directly by clicking a visible object in the viewer. The point can lie outside of the

domain.

You can alternatively set the coordinates one-at-a-time by typing in the coordinates and/or using

the embedded slider that appears beneath the coordinate boxes.

When picking a point from the viewer for the normal vector, the vector is taken from the origin to

the point picked.

• Three Points

Create a plane using three points. To set the point coordinates, first click one of the point coordinate

boxes. The point coordinates will be displayed with a yellow background, and the viewer will switch

to picking mode. You can then pick a point directly by clicking a visible object in the viewer. The

point can lie outside of the domain.

You can alternatively set the coordinates one-at-a-time by typing in the coordinates and/or using

the embedded slider that appears beneath the coordinate boxes.

The normal vector to the plane is calculated using the right-hand rule. The first vector is from

Point 1 to Point 2 and the second is from Point 1 to Point 3 as shown in the diagram below.

5.3.3.1.3. Plane Bounds

The available types of bounds are described next:

• When None is selected the plane cuts through a complete cross-section of each domain specified in

the Domains list. The plane is only bounded by the limits of the domains.

• The Circular option defines the bounds of a plane as a circle centered at the point used in the Plane

Definition. Enter the value of the radius of the circle or click in the box beside Radius, then click Enter

Expression  to the right of the Radius setting to enter an expression for the radius of the circle. The

plane is undefined in areas where the circle extends outside of the domains specified in the Domains

list.

• For the Rectangular option, the plane bounds are defined by a rectangle centered about the point

selected in the Plane Definition with lengths in the x and y-directions of X Size and Y Size, respectively

(You might have to specify lengths in other directions, depending on the Plane Definition.) . The size

is determined with reference to the plane center (that is, the plane is resized around its center). The

X Angle value rotates the plane counter-clockwise about its normal by the specified number of degrees.

The plane is undefined in areas where the rectangle extends outside of the domains specified in the

Domains list.
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Both the circular and rectangular options have an Invert Plane Bound check box. If this check box is

selected, the area defined by the rectangle or circle is used as a cut-out area from a slice plane that is

bounded only by the domain(s). The area inside the bounds of the rectangle or circle does not form

part of the plane, but everything on the slice plane outside of these bounds is included.

5.3.3.1.4. Plane Type

Set Plane Type to either Slice or Sample.

Slice extends the plane in all directions until it reaches the edge of the domain. Points on the plane

correspond to points where the plane intersects an edge of the mesh. As a result, the number of points

in a slice plane is indirectly proportional to the mesh spacing.

Sample creates the plane with either circular or rectangular bounds, depending on the plane bounds

selected. For the Circular option, the density of points on the plane corresponds to the radius of

the plane specified in the Plane Bounds frame, and the values for the Radial and Circumferential

settings in the Plane Type frame. For rectangular bounds, the density of points on the plane corresponds

to the size of the bounds for the plane in each of the plane directions, and the sample values provided

in the Plane Type frame. A sample plane is a set of evenly-spaced points that are independent of the

mesh spacing.

Picking Mode can be used to select and/or translate planes in the viewer. For details, see Viewer Tool-

bar (p. 52).

5.3.3.2. Plane: Color Tab

See Color Tab (p. 5) for details.

5.3.3.3. Plane: Render Tab

See Render Tab (p. 6) for details.

5.3.4. Turbo Surface Command

A turbo surface is a surface that exists only within the boundaries of the geometry and is defined using

variables specific to rotating machinery. To create a new turbo surface, select Insert > User Defined >

Turbo Surface from the main menu.

5.3.4.1. Turbo Surface: Geometry Tab

5.3.4.1.1. Domains

Select the domain(s) in which the turbo surface will exist.

5.3.4.1.2. Turbo Surface Definition

ANSYS TurboGrid creates a turbo surface using a defined variable and its value. Set the domain to either

All Domains or DOMAIN:Passage. Select a variable and set a value to define the location of the

turbo surface (The variable is “K” by default, which is the mesh plane index that varies from hub to

shroud for the H-Grid and J-Grid topologies.). You may enter the value directly, or, for the “K” variable,

use the up/down arrows, or, for any other variable, click in the Value box, then click Enter Expression

 (to the right of the Value box) to enter an expression for the value, or use the slider.
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5.3.4.2. Turbo Surface: Color Tab

See Color Tab (p. 5) for details.

5.3.4.3. Turbo Surface: Render Tab

See Render Tab (p. 6) for details.

5.3.5. Volume Command

A volume object is a collection of mesh elements; it can be created anywhere within the domain. To

create a new volume, select Insert > User Defined > Volume from the main menu.

5.3.5.1. Volume: Geometry Tab

5.3.5.1.1. Domains

Select the domain(s) in which the volume will exist.

5.3.5.1.2. Volume Definition

The available methods for defining a volume are described next:

• Sphere

Create a volume in the shape of a sphere by defining the center point and radius for the sphere.

To set the coordinates of the center points, first click one of the point coordinate boxes. The point

coordinates will be displayed with a yellow background, and the viewer will switch to picking mode.

You can then pick a point directly by clicking a visible object in the viewer. The point can lie outside

of the domain.

You can alternatively set the coordinates one-at-a-time by typing in the coordinates and/or using

the embedded slider that appears beneath the coordinate boxes.

Type in the radius value or set it using the embedded slider. Ensure that the units are set correctly.

When Mode is set to Intersection, the volume consists of all elements that intersect the sphere

surface. When Mode is set to Below Intersection or Above Intersection, the volume

consists of all elements that are “below” or “above” the sphere surface, respectively. If the Inclusive

check box is selected, all elements that intersect the sphere surface are added to the volume.

• From Surface

Create a volume using an existing surface. Set Location to one or more of the available surfaces

for defining the volume (Use Ctrl to multi-select.). When Mode is set to Intersection, the

volume consists of all elements that intersect the sphere surface. When Mode is set to Below
Intersection or Above Intersection, the volume consists of all elements that are “below”

or “above” the sphere surface, respectively. If the Inclusive check box is selected, all elements that

intersect the sphere surface are added to the volume.

• Isovolume

Create a volume based on the value(s) of a variable. Click  next to the variable box to see the

available variables for defining the volume. Type in the value(s), set the value(s) using the embedded
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slider, or click in the box, click Enter Expression  to the right of the box, then enter the value(s)

as an expression. Set the units for the variable(s) appropriately. When Mode is set to At Value,

the volume consists of all elements having the defined variable value. When Mode is set to Below
Value or Above Value, the volume consists of all elements that are “below” or “above” the

defined variable value, respectively. When Mode is set to Between Values, the volume consists

of all elements that are “between” the defined variable values. If the Inclusive check box is selected,

the elements having the defined variable value are added to the volume.

5.3.5.1.3. Hybrid/Conservative

For volumes made with Method set to Isovolume, the option of using hybrid or conservative values

is available. Unless you are post-processing CFD results using ANSYS TurboGrid, this option can be ig-

nored. For details, see Hybrid and Conservative Variable Values (p. 65).

Note

Volumes are not displayed as perfect shapes (for example, a perfect sphere) because mesh

elements are either included or excluded from the volume.

5.3.5.2. Volume: Color Tab

See Color Tab (p. 5) for details.

5.3.5.3. Volume: Render Tab

See Render Tab (p. 6) for details.

5.3.6. Isosurface Command

An isosurface object is a surface upon which a particular variable has a constant value, called the “level”.

To create a new Isosurface, select Insert > User Defined > Isosurface from the main menu.

5.3.6.1. Isosurface: Geometry Tab

5.3.6.1.1. Domains

Select the domain(s) in which the isosurface will exist.

5.3.6.1.2. Isosurface Definition

Set Variable to one of the available variables for defining the isosurface. Type in the variable value, set

it using the embedded slider, or click in the box, click Enter Expression  (to the right of the box), and

enter an expression. Set appropriate units for the variable. The isosurface connects all locations with

the specified variable value.

5.3.6.1.3. Hybrid/Conservative

The option of using hybrid or conservative values is available. Unless you are post-processing CFD results

using ANSYS TurboGrid, this option can be ignored. For details, see Hybrid and Conservative Variable

Values (p. 65).
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5.3.6.2. Isosurface: Color Tab

See Color Tab (p. 5) for details.

Note

You may color the isosurface using any variable or choose a constant color. You should not

select the Local range option when coloring an isosurface with the variable used to define

it. In this case the local range is zero by definition, so a plot would be colored according to

the effects of round-off error.

5.3.6.3. Isosurface: Render Tab

See Render Tab (p. 6) for details.

5.3.7. Polyline Command

5.3.7.1. Polyline: Geometry Tab

A polyline object is a set of connected line segments that connect a series of points. To create a polyline,

select Insert > User Defined > Polyline from the main menu.

Available methods of creating a polyline are:

• From File

• Boundary Intersection

The file format for a polyline is shown below:

[Name]
Polyline 1
[Data]
X [ m ], Y [ m ], Z [ m ], Area [ m^2 ], Density [ kg m^-3 ]
-1.04539007e-01, 1.68649014e-02, 5.99999987e-02, 0.00000000e+00, ...
-9.89871025e-02, 3.27597000e-02, 5.99999987e-02, 0.00000000e+00, ...
.
.
.
[Lines]
0, 1
1, 2
.
.
.
[Name]
Polyline 2
.
.
.

In this example, the two lines containing data are shown word-wrapped onto the next line. In the actual

file, all data for a given point must be on a single line.

The name of each locator is listed under the Name section. Point coordinates and the corresponding

variable values are stored in the Data section. Line connectivity data is listed in the Lines section; this

data makes reference to the points that are defined in the Data section. For this purpose, point num-

bering in the Data section is consecutive, starting at zero.
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Comments in the file are preceded by # (or ## for the CFX-5.6 polyline format) and can appear anywhere

in the file.

Blank lines are ignored and can appear anywhere in the file (except between the line “[Data]” and

first line of data following it).

5.3.7.2. Polyline: Color Tab

See Color Tab (p. 5) for details.

5.3.7.3. Polyline: Render Tab

See Render Tab (p. 6) for details.

5.3.8. Surface Command

To create a user surface, select Insert > User Defined > Surface from the main menu.

5.3.8.1. User Surface: Geometry Tab

5.3.8.1.1. Method

Choose one of the available methods for defining a user surface:

• From File

Select the From File alternative when you are not able to create the required surface using the

Boundary Intersection method. This more versatile option reads data describing the surface from

a file. The points may have path variables (variables that are only defined on the surface) associated

with them. For details on the required format for a surface data file, see Surface Data Format (p. 40).

Click the browse icon to open an Import dialog box and browse to the surface data file. You can

alternatively type the path and file name into the Input File box.

• Boundary Intersection

Boundary Intersection forms a user surface where a given locator intersects a specified list

of boundaries. The Domains setting specifies the domains in which this user surface exists. To select

multiple boundaries for the Boundary List, click  and hold Ctrl as you select each boundary.

Set Location to one of the existing graphic objects.

The user surface consists of mesh element faces on the specified boundaries, for the mesh elements

that are intersected by the locator. The user surface is usually narrow with a varying width. The

fluctuation in width is more noticeable in a coarser mesh.

5.3.8.1.2. Surface Data Format

When the From File method is selected, an external file must exist that defines the surface. A set of

surfaces can be defined in a simple text file with the following format.

## Comment line - optional.
## List of path variables
# <varName1>
# <varName2>
# ...
## List of point locations with path variable values
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## Each line in the following list is numbered 0,1,2...
<X> <Y> <Z> <Var1Value> <Var2Value> ...
<X> <Y> <Z> <Var1Value> <Var2Value> ...
...
## Next line is a keyword that starts the definition of faces
# Faces
## List of 3 - 6 point numbers to define faces.
<Point0> <Point1> <Point2>
<Point1> <Point2> <Point3> <Point4> <Point5> <Point6>
...

Comments in the file are preceded by ## and can appear anywhere in the file. A single # does not in-

dicate a comment; words appearing after a single # are keywords such as Faces.

The start of the file should begin with a list of path variables (up to 256 characters, spaces allowed).

These are variables that are only defined on the user surface. Ensure that the names of these variables

do not conflict with the names of existing variables. There is no need to define any path variables (if

you just want to define the location of a user surface), in which case the file begins with the point loc-

ation values.

The point location list in X Y Z format follows the optional path variable list. You must also include a

value for each path variable that you have defined at the start of the file (if any). Surfaces are defined

by typing # Faces followed by lists of 3 (triangle) to 6 (hexagon) points to define each surface. Each

surface is automatically closed by connecting the last point to the first point. The list of point locations

are numbered 0,1,2....n-1 where n is the number of points in the list. When defining faces, use these

numbers to reference the points in the point location list. The faces specification is not optional.

Blank lines are ignored and can appear anywhere in the file.

The following example defines one quadrilateral face with two path variables at each point of the face:

# Time
# MyVar
1 1 1 1.2 500
1 2 1 2.1 200
2 2 1 3.4 300
2 1 1 4.65 400
# Faces
0 1 2 3

5.3.8.2. User Surface: Color Tab

See Color Tab (p. 5) for details.

5.3.8.3. User Surface: Render Tab

See Render Tab (p. 6) for details.

5.3.8.4. Surface Groups

Surface groups are produced automatically when a mesh is generated. They are found in the 3D Mesh
branch of the object selector. Each surface group shows a surface of the mesh. The available surface

groups vary according to the number of blades and types of leading and trailing edges. A representative

list follows:

• HUB, SHROUD

• [blade name] LOWBLADE, [blade name] HIGHBLADE
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If there is one blade in the blade set, then the surface groups LOWBLADE and HIGHBLADE will be

available after generating a mesh. If there are two or more blades in the blade set, the surface

group names start with the blade name. For example, if there are two blades named Main and

Splitter, then surface groups Main LOWBLADE, Main HIGHBLADE, Splitter LOWBLADE
and Splitter HIGHBLADE will be available after generating a mesh.

• [blade name] BLADE LE, [blade name] BLADE TE

If there is one blade in the blade set, then the surface groups BLADE TE and BLADE LE will be

available, as applicable, after generating a mesh. These surface groups are applicable only for cut-

off or square leading/trailing edges. If there are two or more blades in the blade set, the surface

group names start with the blade name. For example, if there are two blades named Main and

Splitter, and the trailing edge of Main is cut-off, and the leading and trailing edges of

Splitter are cut-off, then surface groups Main BLADE TE, Splitter BLADE LE and

Splitter BLADE TE will be available after generating a mesh.

• LOWPERIODIC, HIGHPERIODIC

• INLET, OUTLET

“LOW” refers to low Theta value and “HIGH” refers to high Theta value.

A visibility check box next to each surface group enables you to control which are displayed.

Besides the visibility, you may also change the color and render properties for each surface group.

5.3.8.4.1. Surface Group: Definition Tab

You may view the Domains and Locations information on the Definition tab.

5.3.8.4.2. Surface Group: Color Tab

See Color Tab (p. 5) for details.

5.3.8.4.3. Surface Group: Render Tab

See Render Tab (p. 6) for details.

5.3.9. Contour Command

A contour plot is a series of lines linking points with equal values of a given variable. For example, contours

of height exist on geographical maps and give an impression of gradient and land shape. To create a

contour, select Insert > User Defined > Contour from the main menu.

5.3.9.1. Contour Plot: Definition Tab

5.3.9.1.1. Domains

Select the domain(s) in which the contour object will exist.

5.3.9.1.2. Locations

Select the locator(s) on which to plot the contours. To select multiple locators, click the  icon, hold

down Ctrl, and select each locator.
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5.3.9.1.3. Variable

Choose the plot variable for the contour plot.

5.3.9.1.4. Range

Set Range to one of the available methods for defining the range of the contour plot. This affects the

variation of color used when plotting the contours in the viewer. The lowest values of a variable in the

selected range are shown in blue in the viewer, the highest values are shown in red.

• Global uses the range of the variable over all domains (regardless of the domains selected on the

Geometry tab) to determine the minimum and maximum values for the contours.

• Local uses the range of the variable over the selected locator(s) to determine the minimum and

maximum values for the contours.

• When using User Specified, enter the minimum and maximum values for the contours. Type in

the variable values, set them using the embedded slider or, by clicking Enter Expression  to the right

of the Units box, enter them as an expression.

• Using Value List, a list separated by commas, specify the actual values at which contours should

be plotted. For example, if plotting minimum face angle, try a value list of 5, 10, 15, 20, 25
degrees. It should be noted that entering a value list overrides the number specified in the # of Contours

box (see below).

5.3.9.1.5. Hybrid/Conservative

The option of using hybrid or conservative values is available. Unless you are post-processing CFD results

using ANSYS TurboGrid, this option can be ignored. For details, see Hybrid and Conservative Variable

Values (p. 65).

5.3.9.1.6. Number of Contours

Set the # of Contours to appear in the plot. This is the number of bands plus one. This number is

overridden if the Range setting is set to Value List.

5.3.9.2. Contour Plot: Labels Tab

The Show Numbers check box determines whether numbers corresponding to the number of contours

are displayed on the plot. To view the values of the plotted variable at each contour, create a legend

of the contour plot. See Legend Command (p. 45) for more details. To change the size of the text that

appears on the contour plot, type a new value into the Text Height box or use the embedded slider

(which has a maximum value of 1 and a minimum value of 0). The Text Height number is a fraction of

the viewer height. Text Font controls which font is used for the numbers that appear in the contour

plot. To change the text color, set Color Mode to User Specified then choose a color by clicking

in the Text Color box or by clicking the  icon, which invokes a color selector.

5.3.9.3. Contour Plot: Render Tab

See Render Tab (p. 6) for details.
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Note

When the Draw Faces check box is selected, the area between contour lines is shaded with

a color that corresponds to a value midway between the upper and lower contour line value.

For example, for a contour line at 1000 Pa and a contour line at 1200 Pa, the shaded area

has a color that corresponds to 1100 Pa. If you have created a legend for the contour plot,

the legend adopts flat shading between 2 contour levels. By referring to the legend, the

variable values can quickly be associated with the shaded regions of the plot.

Note

To view the contour lines as a single color, select the Constant Coloring check box. With

this option selected, you can either leave the color set to default or you can set Color Mode

to User Specified then choose a color by clicking in the Text Color box or by clicking

the  icon, which invokes a color selector.

5.3.10. Instance Transform Command

Due to rotational symmetry, only one blade passage needs to be meshed, reducing computing cost

and time. Instance transforms are used to replicate sections of the computational domain in the viewer

for viewing purposes. For example, you may use a rotational transform to copy a blade passage to

produce a plot of an entire rotor or stator, or a fraction thereof. However, for most purposes, it is sufficient

to make use of the special toolbar icons dedicated to viewing 1, 2, or all instances ( , , and 

respectively). Instance transforms are more flexible than these special toolbar icons in that they can be

applied to single objects rather than to only all (qualified) objects at the same time.

To create an instance transform, select Insert > User Defined > Instance Transform from the main

menu.

5.3.10.1. Instance Transform: Definition Tab

Note

In this release of ANSYS TurboGrid, instancing is purely visual. This means that quantitative

calculations can only be carried out for the original geometry.

5.3.10.1.1. Number of Copies

The # of Copies is the number of times the domain is replicated in the viewer. Type in the value, increase

or decrease the value by 1 by clicking  or  respectively.

To see the whole rotating machine, the number of copies must equal the number of blade sets, as

defined in the Machine Data object.

5.3.10.1.2. CCL Editing

If you edit an instance transform in the Command Editor dialog box, changes to settings, other than

Number of Copies, will be lost the next time the Apply button is clicked in the instance transform
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editor. This happens because the instance transform editor overwrites all of the ccl parameters, except

# of Copies, with the values stored in the default instance transform object.

5.3.11. Legend Command

A legend can be created for any object that plots a variable. The legend gives an approximate quantit-

ative value to the colors representing the variable on a locator. To create a legend, select Insert > User

Defined > Legend from the main menu. After a legend object is created, it is listed in the object selector

under User Defined.

5.3.11.1. Legend: Definition Tab

5.3.11.1.1. Plot

Set Plot to the object for which to create a legend.

Note

Any existing object can be selected, but if there is not a variable for which to create a legend,

one is not created.

5.3.11.1.2. Location

The exact position of the legend in the viewer can be controlled using the Location settings. Set X

Justification to Left, Center, Right, or None. Similarly, set Y Justification to Top, Center, Bottom,

or None. In both cases, if None is selected, type in the position value(s) (or use the embedded sliders,

which have a maximum value of 1 and a minimum value of 0) in the appropriate Position box (The

left box is for X Justification and the right box is for Y Justification.). The position values represent a

fraction of the viewer width from the left side for X Position, or a fraction of the viewer height from

the bottom for Y Position. The position entered is the bottom-left corner of the legend.

5.3.11.2. Legend: Appearance Tab

5.3.11.2.1. Sizing Parameters

The size of the legend can be set as a fraction of the viewer window height. Increasing the value of the

Size setting increases both the height and width of the legend. Type in the size value or use the em-

bedded slider (which has a maximum value of 1 and a minimum value of 0).

The Aspect setting controls the width of the color range bar displayed in the legend. Type in the aspect

value or use the embedded slider (which has a maximum value of 0.2 and a minimum value of 0).

5.3.11.2.2. Text Parameters

The Precision setting controls the number of digits after the decimal point, for numbers displayed in

the legend. Set Precision to a format of either Scientific or Fixed.

The Value Ticks setting specifies the number of graduations (with labels) displayed in the legend. For

example, for a scale ranging from 0 to 10, a setting of 3 ticks produces graduations at 0, 5 and 10. For

a contour plot, each number assigned to a contour line is displayed on the legend, along with its asso-

ciated variable value. The Value Ticks setting has no effect when the legend is for a contour plot.
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5.3.12. Text Command

Text can be added to the viewer, for example for annotation or comments. To create text, select Insert

> User Defined > Text from the main menu. After a text object is created, it is listed in the object se-

lector under User Defined.

5.3.12.1. Text: Definition Tab

5.3.12.1.1. Location

Set Position Mode to one of the available methods for defining the location of the text.

• Using Two Coords, position the text at a fixed location in the viewer. Set X Justification to Left,

Center, Right, or None. Similarly, set Y Justification to Top, Center, Bottom, or None. In both

cases, if None is selected, type in the position value(s) (or use the embedded sliders, which have a

maximum value of 1 and a minimum value of 0) in the appropriate Position box (The left box is for X

Justification and the right box is for Y Justification.). The position values represent a fraction of the

viewer width from the left side for X Position, or a fraction of the viewer height from the bottom for

Y Position. The position entered is the bottom-left corner of the text.

• Using Three Coords, position the text using Cartesian coordinates attached to the geometry. The text

moves with the geometry, but its orientation remains fixed. The X, Y, and Z coordinates are required

to set the text location. Type in the position values or use the embedded sliders. Type in the rotation

value, or set it using the embedded slider (which has a maximum value of 360 degrees and a minimum

value of 0 degrees), or click in the Rotation box, click Enter Expression  (to the right of the Rotation

setting), and enter an expression. A rotation angle of 0 degrees positions the text horizontally; a positive

angle is measured counter-clockwise from that position.

5.3.12.2. Text: Appearance Tab

5.3.12.2.1. Text Properties

Type in the text height or use the embedded slider (which has a maximum value of 1 and a minimum

value of 0).

To change the text color, change Color Mode to User Specified then choose a color by clicking

in the Color box or by clicking the  icon, which invokes a color selector.
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Chapter 6: Display Menu

The following sections describe the commands available in the Display menu:

6.1. Introduction

6.2. Display One Instance Command

6.3. Display Two Instances Command

6.4. Display All Instances Command

6.5. Hide/Unhide Geometry Objects Commands

6.6. Hide/Unhide Layers Commands

6.7. Hide/Unhide Mesh Objects Commands

6.8. Blade-to-Blade View Submenu

6.1. Introduction

The Display Menu options are also available from a toolbar located above the viewer.

6.2. Display One Instance Command

The default setting, Display One Instance, will show one passage of the geometry in the viewer. Since

only one instance must be solved, displaying only one instance will allow ANSYS TurboGrid to work

more quickly as less rendering is required.

For further information, see Instance Transform Command (p. 44).

6.3. Display Two Instances Command

When Display Two Instances is set, two passages of the geometry are shown in the viewer. This can

give a better idea of the full machine without having ANSYS TurboGrid slowed by rendering the full

machine.

For further information, see Instance Transform Command (p. 44).

Note

When working with two instances displayed, it is important to know that topology changes,

such as the movement of master control points, can only be done on the original instance,

and not the second one displayed.
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6.4. Display All Instances Command

When Display All Instances is set, the full machine is shown in the viewer. This setting shows the full

geometry and the mesh can be seen on the entire geometry. It is not recommended to work in this

setting as the constant rendering of the full machine will slow down processing speed.

For further information, see Instance Transform Command (p. 44).

6.5. Hide/Unhide Geometry Objects Commands

Select Hide Geometry Objects to turn off the visibility of all geometry objects (that is, hub, shroud,

blade, and so on) and give a clear view of the remaining objects. Select Unhide Geometry Objects to

do the opposite.

6.6. Hide/Unhide Layers Commands

Select Hide Layers to turn off the visibility of all of the layers. This is much more efficient than turning

off the visibility for each individual layer in the object selector. Select Unhide Layers to do the opposite.

6.7. Hide/Unhide Mesh Objects Commands

Select Hide Mesh Objects to turn off the visibility of the 3D Mesh objects. This can be useful for

viewing the geometry after a mesh has been created. Select Unhide Mesh Objects to do the opposite.

6.8. Blade-to-Blade View Submenu

In the blade-to-blade view, some parts of the mesh might appear to be distorted, wavy, or overlapping
1
.

You might be able to reduce the amount of distortion by selecting an appropriate command in the

Blade-to-Blade View submenu. Each command affects the portion of the geometry on which the

transform is based. The optimal choice depends on the blade geometry.

The Blade-to-Blade View submenu commands are:

• Use Default Transform

The Use Default Transform command chooses the transform method automatically by effectively

choosing either the Use Full Transform command or the Use Passage Transform command.

• Use Full Transform

The Use Full Transform command causes the blade-to-blade coordinates to be calculated using

the complete hub and shroud curves.

• Use Passage Transform

The Use Passage Transform command causes the blade-to-blade coordinates to be calculated

using the portion of the hub and shroud curves that fall within the passage mesh, truncated at the

inlet and outlet (that is, excluding the portions of the hub and shroud curves that lie within the

inlet and outlet mesh blocks).

• Use Passage Excluding Tip Transform

1
By contrast, the Cartesian view does not typically exhibit distortion, except at extremely high zoom levels.
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The Use Passage Excluding Tip Transform command is similar to the Use Passage Transform

command, except that the tip regions are excluded in the spanwise direction. For example, if a

blade has no hub tip and a profile-based shroud tip, the blade-to-blade coordinates are calculated

using the portion of the hub curve that falls within the passage and the profile curve at the shroud

tip. This transform may be the best choice if the hub/shroud tip is defined by a profile that varies

significantly from a constant span when viewed in the other transforms.

The Passage and Passage Excluding Tip transforms:

• usually exhibit less distortion than the Full transform,

• are available only after the topology has been created,

• cause geometry objects to be omitted from the blade-to-blade view (even if these transforms are used

indirectly via the default transform).

49
Release 14.0 - © SAS IP, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Blade-to-Blade View Submenu



Release 14.0 - © SAS IP, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.50



Chapter 7: Viewer

• Introduction (p. 51)

• Viewer Toolbar (p. 52)

• Viewer Hotkeys (p. 53)

• Multiple Viewports (p. 54)

• Selecting and Dragging Objects while in Viewing Mode (p. 55)

• Stereo Viewer (p. 56)

7.1. Introduction

The viewer in ANSYS TurboGrid plays a central role in the mesh creation process. Its interactive interface,

including the mouse, toolbars and hotkeys, allows you to inspect and alter your work.

The viewer toolbar and hotkeys are described in this chapter. Mouse controls are described in Viewer

Setup: Mouse Mapping (p. 25).

Note

In order to see correct colors and accurately displayed objects in the 3D Viewer, some com-

binations of ATI video cards and ATI graphics drivers on Windows XP require that you set

the environment variable VIEWER_CACHE_COLORS to 0:

1. Right-click My Computer and select Properties. The System Properties dialog box appears.

2. Click the Advanced tab.

3. Click Environment Variables.

4. Under System variables, click New.

5. In the Variable name field, type: VIEWER_CACHE_COLORS

6. In the Variable value field, type the number: 0

7. Click OK.

8. To verify the setting, open a command window and enter: set

The results should include the line:

VIEWER_CACHE_COLORS=0

This setting will fix problems such as:

• Boundary condition markers placed incorrectly or rendered in white.

• Regions around the circles are incorrect (rendered as yellow areas marked with blue)

• Mesh lines not displayed properly and with dark patches showing.
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Note

Depending on the graphics card and driver version, you may experience problems with the

accuracy of mouse clicks in the 3D Viewer. For example, you may try to insert a control point

at a given location by using the mouse, but the control point appears at a location far from

where you clicked the mouse. If you experience such problems, try lowering the hardware

acceleration setting of your graphics card.

7.2. Viewer Toolbar

The viewer has the following tools:

DescriptionTool

Enters picking mode. To choose the behavior of this

mode, use the drop-down arrow on the adjacent

toolbar icon (which becomes visible only after you

click Select ):

This is the Single Select option for the Select  tool.

You can use it to select objects or drag certain objects

to new locations, using the mouse.

When a number of objects overlap, the one closest to

the camera is picked. The text at the bottom of the

viewer window shows which object would be picked

at the mouse’s current location. If you cannot pick the

object you want because other objects overlap it, turn

off the visibility of the overlapping objects, or adjust

the camera to make it possible to pick the object.

This is the Box Select option for the Select  tool.

You can use it to select objects using a box. Drag a

box around the object(s) you want to select.

This is the Polygon Select option for the Select

tool. You can use it to select objects using an enclosed

polygon. Click to drop points around the object(s).

Double-click to complete the selection.

Rotates the view as you drag with the mouse. Altern-

atively, hold down the middle mouse button to rotate

the view.
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DescriptionTool

Pans the view as you drag with the mouse. Alternat-

ively, you can pan the view by holding down Ctrl and

the middle mouse button.

Adjusts the zoom level as you drag with the mouse

vertically. Alternatively, you can zoom the view by

holding down Shift and the middle mouse button.

Zooms to the area enclosed in a box that you create

by dragging with the mouse. Alternatively, you can

drag and zoom the view by holding down the right

mouse button.

Centers all visible objects in the viewer.

Toggles highlighting. Highlighting makes it easier to

select the correct object from the viewer. While in

picking mode, highlighting by default puts a red box

around the object which would be selected at the

mouse’s current location. The style of highlighting is

controlled by Edit > Options > TurboGrid > Viewer

> Highlight Type.

Selects the viewport arrangement; by default, each

view displays a different transform. Independent zoom,

rotation, and translate options can be carried out in

each viewport.

Displays the Viewer Key Mapping dialog box. See

Viewer Hotkeys (p. 53) for details.

7.3. Viewer Hotkeys

A number of hotkeys are available to carry out common viewer tasks. Before using a viewer hotkey,

place the mouse focus on the viewer window.

ActionKey

Toggle between picking and viewing mode.Space

Rotate about horizontal and vertical axes.Up

or

Down

or

Left

or
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ActionKey

Right

Rotate about an axis normal to the screen.Ctrl-Up

or

Ctrl-Down

Moves the light source.Shift-Up

or

Shift-Down

or

Shift-Left

or

Shift-Right

When in viewing mode, you can hold Ctrl+Shift to

select objects in the viewer. Releasing Ctrl+Shift re-

turns you to viewing mode.

Ctrl-Shift

Switches to one viewport.1

Switches to two viewports.2

Switches to three viewports.3

Switches to four viewports.4

Centers the graphic object in the viewer window.c

Toggles the projection between orthographic and

perspective.

n

Resets the view to the initial orientation.r

Undoes transformation.u

Redoes transformation.U

Sets view from +X axis.x

Sets view from -X axis.X

Sets view from +Y axis.y

Sets view from -Y axis.Y

Sets view from +Z axis.z

Sets view from -Z axis.Z

7.4. Multiple Viewports

Initially the viewer contains one single viewport. The viewer can be divided into more than one window

or multiple viewports, ranging from one to four.

By default, the viewer shows the current objects in a 3D Cartesian view.

The currently active viewport layout is shown in the box to the right of the Highlighting  icon on

the viewer toolbar. Click  to the right of the current viewport layout picture to select a new viewport

layout from the drop-down list on the viewer toolbar.
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Change the active viewport by placing the mouse pointer over a viewport and clicking with any of the

three mouse buttons. The viewport that contains the mouse pointer is then set as the active viewport.

Mouse-controlled transformations are applied automatically to the viewport which contains the mouse

pointer. When the transformation is complete the viewport also becomes the active viewport.

Hardcopy plots (postscript or other image file formats) always show all visible viewports in the viewer

(a verbatim copy of the viewer window).

If the viewer consists of four viewports, each with object(s), and the viewport layout is changed to have

less than four viewports, the graphic in the now “hidden” viewports remains intact, but not visible.

When the viewport layout returns to the former layout all graphic objects are present, unchanged.

Each viewport has a default coordinate system.

• Viewport 1: Cartesian

• Viewport 2: 2D Blade-to-blade

• Viewport 3: 2D Meridional

• Viewport 4: 3D Turbo

You can change the coordinate system for each viewport by right-clicking on a blank area in the viewer,

and selecting one of the Transformation commands.

Note

If a viewport initially appears to be empty when it is used for the first time, try clicking Fit

View . This will center the objects and reset the zoom level.

7.4.1. Selecting, Adding, and Deleting Views

Each viewport can use any of the 4 pre-defined views or user-defined views. To switch between views,

use the drop-down menu in the upper-left corner of the viewport. To add a new view based on the

current state of the viewer, right-click in the viewer and select Create New View from the shortcut

menu. To delete an existing user-defined view, right-click in the viewer and select Delete View while

the view is selected.

7.5. Selecting and Dragging Objects while in Viewing Mode

Picking mode allows you to select and move objects, such as points, curves, and planes.
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To enter picking mode, click Select . To leave picking mode (i.e., switch back to viewing mode), click

Rotate  or Pan .

To temporarily enter picking mode when you are in viewing mode, hold Ctrl+Shift. When you release

the Ctrl+Shift keys, you will return to viewing mode.

When you click Select  to enter picking mode, a toolbar icon appears to enable you to change the

selection method:

For details, see Viewer Toolbar (p. 52).

7.6. Stereo Viewer

If you:

1. Have a standard stereo display

2. Have a graphics card that supports quad buffering OpenGL output

3. Have set your graphics card to "Stereo"

4. Have set your view to Perspective mode (right-click in the Viewer and select Projection > Perspective)

...you can view output in stereo
1
. To enable this functionality:

1. Select Edit > Options.

2. In the Options dialog box, select TurboGrid > Viewer.

3. On the Viewer panel:

a. Set the Stereo Mode to Stereo.

b. Set the Stereo Effect. The value of the "stereo effect" that is required is related to the distance

between the observer and the display. If the stereo effect is too strong, either move away from

the display, or move the slider towards Weaker.

4. Click OK to save the settings.

1
The stereo viewer feature has been tested on:

• XP-64 and Vista-64 with an NVidia graphics card and a Planar Stereo Monitor

• XP-64 with an ATI card and a Zalman Stereo Monitor.
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Chapter 8: Tools Menu

The following sections describe the commands available in the Tools menu:

8.1. Calculator Command

8.2. Expressions Command

8.3.Variables Command

8.4. Command Editor Command

8.1. Calculator Command

The built-in calculator provides quantitative information about the geometry and mesh. To view the

calculator, select Tools > Calculator from the main menu. The Function Calculator dialog box is dis-

played.

Note

In this release of ANSYS TurboGrid, quantitative calculations can only be carried out for the

original geometry. Any applied instance transforms are purely visual and do not affect the

calculation results.

8.1.1. Function Calculator Dialog Box

8.1.1.1. Function

Click  to select a function from the drop-down list. The table below outlines the available quantitative

functions.

OperationFunction

Name

Area of locationarea (p. 58)

Area-weighted averageareaAve (p. 58)

Area-weighted integral (can be projected to a direction)areaInt (p. 58)

Arithmetic averageave (p. 59)

Number of calculation pointscount (p. 59)

Length of a curvelength (p. 59)

Length-weighted averagelengthAve (p. 59)

Length-weighted integrationlength-

Int (p. 59)

Maximum ValuemaxVal (p. 60)

Minimum ValueminVal (p. 60)

Value at a pointprobe (p. 60)
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OperationFunction

Name

Sum over the calculation pointssum (p. 60)

Volume of a 3-D locationvolume (p. 60)

Volume-weighted averagevolumeAve (p. 60)

Volume-weighted integralvolumeInt (p. 61)

8.1.1.1.1. area

The area function is used to calculate the area of a 2-D location. The following example demonstrates

use of the function.

• Function: area, Location: Plane1. This example calculates the total area of the locator Plane1.

8.1.1.1.2. areaAve

The areaAve function calculates the area-weighted average of an expression on a 2-D location. The

area-weighted average of a variable is the average value of the variable on a location when the mesh

element sizes are taken into account. Without the area weighting function, the average of all the nodal

variable values would be biased towards variable values in regions of high mesh density. The following

examples demonstrate use of the Function.

• Function: areaAve, Location: Outlet, Variable: Velocity. This example calculates the average

magnitude of the velocity on the outlet location. Note that flow direction is not considered since the

magnitude of a vector quantity at each node is calculated. Use the scalar components of velocity (e.g.,

Velocity u) to include a directional sign, for example:

• Function: areaAve, Location: Outlet, Variable: max(Velocity u, 0.0[m s^-1]). This example

calculates the area-weighted average value of Velocity u, with negative values of the variable replaced

by zero. Note that this is not the average positive value since zero values contribute to the average.

8.1.1.1.3. areaInt

The areaInt function integrates a variable over the specified 2-D location. To perform the integration

over the total face area, the None option should be selected from the Direction drop-down list. If a

direction is selected, the result is an integration over the projected area of each face onto a plane normal

to that direction. Each point on a location has an associated area which is stored as a vector and

therefore has direction. By selecting a direction in the calculator you are using only a single component

of the vector in the area-weighting function. Since these components can be positive or negative, de-

pending on the direction of the normal on the location, it is possible for areas to cancel out. An example

of this would be on a closed surface where the projected area is always zero (the results returned are

not in general zero since the variable values differ over the closed surface). On a flat surface the normal

vectors always point in the same direction and never cancel out. The following examples demonstrate

use of the function.

• Function: areaInt, Location: Plane1, Variable: Pressure, Direction: None This example integrates

pressure over Plane1. The result returned is the total pressure force acting on Plane1. The magnitude

of each area vector is used and so the direction of the vectors is not considered.

• Function: areaInt, Location: Plane1, Variable: Pressure, Direction: Global X. This example

integrates pressure over the projected area of Plane1 onto a plane normal to the X-axis. The result is

the pressure force acting in the X-direction on Plane1. This differs slightly from using the force function

to calculate the X-directional force on Plane1 — the force function includes forces due to the advection
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of momentum when calculating the force on an internal arbitrary plane or a non-wall boundary (inlets

etc.).

8.1.1.1.4. ave

The ave function calculates the arithmetic average (the mean value) of a variable or expression on the

specified location. This is the sum of the values at each node on the location divided by the number

of nodes. Results are biased towards areas of high nodal density on the location. To obtain a mesh-in-

dependent result, use the lengthAve, areaAve, volumeAve or massFlowAve functions. The fol-

lowing example demonstrates use of the function.

The average of a vector value is calculated as an average of its magnitudes, not the magnitude of

component averages. As an example, for velocity, = +
�
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• Function: ave, Location: MainDomain, Variable: Temperature. This example calculates the mean

temperature at all nodes in the selected domain.

8.1.1.1.5. count

The count function returns the number of nodes on the specified location. The following example

demonstrates use of the function.

• Function: count, Location: MainDomain. This example returns the number of nodes in the specified

domain.

8.1.1.1.6. length

Computes the length of the specified line as the sum of the distances between the points making up

the line. The following example demonstrates use of the function.

• Function: length, Location: Polyline1. Calculates the length of the Polyline.

8.1.1.1.7. lengthAve

Computes the length-based average of the variable on the specified line. This is the 1-D equivalent of

the areaAve function. The result is independent of the nodal distribution along the line since a

weighting function assigns a higher weighting to areas of sparse nodal density. The following example

demonstrates use of the function.

• Function: lengthAve, Location: Polyline1, Variable: Velocity. This calculates the average velocity

on the location Polyline1 using a length-based weighting function to account for the distribution of

points along the line.

8.1.1.1.8. lengthInt

Computes the length-based integral of the variable on the specified line. This is the 1-D equivalent of

the areaInt function. The following example demonstrates use of the function.
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8.1.1.1.9. maxVal

Returns the maximum value of the specified variable on the specified locator. Create a user variable if

you want to find the maximum value of an expression. The following example demonstrates use of the

function.

• Function: maxVal, Location: Default, Variable: Yplus. This returns the maximum Yplus value on

the Default wall boundaries.

8.1.1.1.10. minVal

Returns the minimum value of the specified variable on the specified locator. Create a user variable if

you want to find the minimum value of an expression. The following example demonstrates use of the

function.

• Function: minVal, Location: MainDomain, Variable: Temperature. These settings return the

minimum temperature in the domain.

8.1.1.1.11. probe

Returns the value of the specified variable on the specified point object. The following example

demonstrates use of the function.

• Function: probe, Location: Point1, Variable: Density. Returns the density value at Point1.

Important

This calculation should only be performed for point locators described by single points.

Incorrect solutions are produced for multiple point locators.

8.1.1.1.12. sum

Computes the sum of the specified variable values at each point on the specified location. The following

example demonstrates use of the function.

• Function: sum, Location: SubDomain1, Variable: Volume of Finite Volume. Returns the sum

of the finite volumes assigned to each node in the location SubDomain1. In this case this sums to the

volume of the subdomain.

8.1.1.1.13. volume

The volume function is used to calculate the volume of a 3-D location. The following example

demonstrates use of the function.

• Function: volume, Location: Volume1. Returns the sum of the volumes of each mesh element included

in the location Volume1.

8.1.1.1.14. volumeAve

The volumeAve function calculates the volume-weighted average of an expression on a 3-D location.

This is the 3-D equivalent of the areaAve function. The volume-weighted average of a variable is the

average value of the variable on a location weighted by the volume assigned to each point on a location.
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Without the volume weighting function, the average of all the nodal variable values would be biased

towards values in regions of high mesh density. The following example demonstrates use of the function.

• Function: volumeAve, Location: Volume1, Variable: Density. This example calculates the volume-

weighted average value of density in the region enclosed by the location Volume1.

8.1.1.1.15. volumeInt

The volumeInt function integrates the specified variable over the volume location. This is the 3-D

equivalent of the areaInt function. The following example demonstrates use of the function.

• Function: volumeInt, Location: Volume1, Variable: Density. This calculates the integral of density

(the total mass) in Volume1.

8.1.1.2. Location

Click  to select a location from the drop-down list. Only locations valid for the selected function are

available.

8.1.1.3. Variable

Click  to select a variable from the drop-down list. Only variables valid for the selected function are

available.

For most functions, click in the Variable box and enter an expression to use as the variable. The expres-

sion can include other variables and any valid CEL (ANSYS CFX Expression Language) function (see CEL

Functions, Constants and System Variables in the TurboGrid Reference Guide). For example, abs(Velo-
city u) could be entered so that the calculation is performed using the absolute values of the variable

Velocity u.

8.1.1.4. Direction

The areaInt function requires a direction to be specified before the calculation can be performed.

The areaInt function projects the location onto a plane normal to the specified direction (if the dir-

ection is not set to None), and then performs the calculation on the projected location (direction spe-

cification can also be None). The direction of the normal vectors for the location is important and cancels

out for surfaces such as closed surfaces.

8.1.1.5. Hybrid and Conservative Variables

In ANSYS TurboGrid there is no difference between hybrid and conservative variables. Leave all controls

for selecting between them at their default values.

8.2. Expressions Command

The expression editor is used to create new expressions and modify existing expressions in ANSYS

TurboGrid. ANSYS TurboGrid can use expressions in place of any numeric value (as long as the correct

units are returned by the expression). For example, you can use expressions to define object properties

or new variables.
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Note

• When a setting is defined by an expression, and the latter evaluates to a quantity that has

no units, the software internally applies the default units for that setting.

• In an expression, a term that has no units can be added to a term that has angular units, in

which case the software internally applies radians to the term that has no units.

To create or edit an expression, select Tools > Expressions from the main menu. The Expression Editor

dialog box is displayed.

8.2.1. Expression Editor Dialog Box

The Expression Editor dialog box contains:

• A tree view for viewing and managing expressions (The tree view has a shortcut menu with commands

for creating/deleting/modifying expressions, as described below.)

• A details view for creating/editing/displaying the definition of the new/selected expression

(You can find a list of valid CEL expressions and constants in ANSYS CFX Expression Language in

the TurboGrid Reference Guide.)

• A Value box to show the value of the selected expression when the expression does not contain variables

and evaluates to a single value.

You can right-click an existing expression or a blank area in the tree view portion of the Expression

Editor dialog box in order to access a shortcut menu with the following commands:

Table 8.1  Expression Editor Shortcut Menu Commands

DescriptionCommand

Displays the definition of the selected Expression in

the details view portion of the Expression Editor dia-

Edit

log box, and gives it the keyboard focus. An alternative

way to do the same is to double-click an expression

in the tree view.

Opens the New Expression dialog box where you can

enter a name for a new expression. After you enter a

Insert > Expres-

sion

name, you must provide and apply a definition in order

to finish creating the new expression.

When selecting an expression name:

• You cannot create an expression with the same name

as an object.

• You cannot create an expression with the same name

as a variable.

Invokes the Command Editor dialog box populated

with the selected expression.

Edit in Com-

mand Editor

Deletes the selected expression.Delete
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DescriptionCommand

Creates a duplicate of the selected expression after

obtaining the name of the new expression from the

New Expression dialog box.

Duplicate

Makes the selected expression a Workbench input

parameter so that it is available in, and controllable

by, ANSYS Workbench.

Use as Work-

bench Input

Paramet-

er
[1 (p. 63)]

The Workbench input parameter is initialized by the

expression definition specified in ANSYS TurboGrid.

The definition must be a function of only constants;

units are permitted.

It is not possible to edit the value of an expression in

ANSYS TurboGrid while the expression is a Workbench

input parameter.

Makes the selected expression a Workbench output

parameter, causing it to be output from ANSYS Tur-

boGrid for use in ANSYS Workbench.

Use as Work-

bench Output

Paramet-

er
[1 (p. 63),2 (p. 63)]

Removes the ANSYS Workbench parameter status from

the selected expression.

Deselect as

Workbench

Paramet-

er
[1 (p. 63),2 (p. 63)]

Footnote

1. You can enable/disable the use of a Workbench input parameter directly for many settings

in the object editor. For details, see Object Editor (p. 4).

2. For details on Workbench parameters, see Working with Parameters and Design Points in

the Workbench User Guide.

When defining an expression:

• You cannot use a user variable.

• Constants require units inside square brackets.

• You can right-click in the details view to access a shortcut menu for inserting variables, locators, expres-

sions, and functions into your equation.

8.2.1.1. Expression Editor Example

To define an expression for distance from the X-axis:

1. Select Tools > Expressions from the main menu to open the Expression Editor dialog box.

2. When the New Expression dialog box appears, enter the name radial and click OK.

3. In the details view portion of the Expression Editor dialog box, enter the following expression defin-

ition:

63
Release 14.0 - © SAS IP, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Expressions Command



sqrt(Y^2+Z^2)

4. Click Apply to create the expression.

Note that the Value box does not show a value for the expression because the expression does not

evaluate to a single value.

The expression created in this example (radial) is used in the Variable Editor Example (p. 65).

8.3. Variables Command

The variable editor is used to create new user variables and modify existing variables in ANSYS TurboGrid.

To create or edit a variable, select Tools > Variables from the main menu. The Variable Editor dialog

box is displayed.

8.3.1. Variable Editor Dialog Box

All icons become active when you select a variable from the Variable list. Alternatively, you can right-

click on an existing variable in the list to see the same options. Each icon and its function is described

in the following table.

DescriptionIcon

New opens the New Variable dialog box where you can enter

a name.

Edit displays the selected Variable in the Expression and/or

Units box where you can edit it.

Copy makes a duplicate of the selected variable and opens

the New Variable dialog box where you can enter a name for

the copy.

Delete removes the selected variable from the list.

Use Hybrid Values sets all variables to hybrid values.

Use Conservative Values sets all variables to conservative values.

When you click New  to create a new variable, the New Variable dialog box is displayed.

8.3.1.1. Name

There are a few guidelines to follow when selecting a variable name.
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• You cannot create a variable with the same name as an object.

• You cannot create a variable with the same name as an expression. For example, if you have an expression

named Radius, you must choose a different variable name for that expression.

• Within the ANSYS CFX Expression Language some variables are known by short names to save typing

in the full variable name. For example, p refers to Pressure. Although it is possible to create a variable

with the same name as an abbreviated variable, it is ignored. For example, if you use a variable with

the name p in an expression, it returns the value Pressure in all cases, no matter what the definition

of the variable is.

8.3.1.2. Type

Click Edit  to edit both the fundamental and user variables. Select the expression used to define the

variable from a list of existing expressions for user variables. The expressions available from this list are

those which you have created in the expression editor. For details, see Expressions Command (p. 61).

For fundamental variables, the units are changeable. Click  next to the Units box to see the available

units for the selected variable. This means, for example, that you could create a legend which uses al-

ternative angle units (such as degrees or radians) by clicking on the  icon and selecting new units.

Note

These settings override the global units setting, defined in the Edit Menu. For details, see

Options Command (p. 23).

The variable type used affects all quantitative calculations and plots in ANSYS TurboGrid.

8.3.1.3. Hybrid and Conservative Variable Values

This is useful only for advanced post-processing and is not relevant for ANSYS TurboGrid. It is included

to maintain consistency with other ANSYS CFX products. Refer to the CFD-Post documentation for more

information on the differences between hybrid and conservative variable values.

8.3.1.4. Variable Editor Example

In this example, an isosurface that has a fixed radial distance from the X-axis is created using the expres-

sion defined in the Expression Editor Example (p. 63).

1. Select Tools > Variables from the main menu to open the variable editor.

2. Click New  to create a new variable. When the New Variable dialog box appears enter the name

Radial Distance and click OK.

3. In the variable editor, use the Expression drop-down list to select the expression radial which you

created earlier. Click Apply to create the new variable.

This variable now appears in the list of available variables and can be used like any other variable. Notice

that the variable type is listed as User.

You can now create an isosurface using this variable. For details on creating isosurfaces, see Isosurface

Command (p. 38).
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1. Select Insert > User Defined > Isosurface from the main menu, enter a name, then click OK on the

New Isosurface dialog box.

2. In the Geometry tab for the isosurface set Variable to Radial Distance.

3. Set Value to 20 m. This is a suitable value for the Rotor 37 geometry used in Tutorial 1. You may need

to alter this value to something more sensible depending on the geometry you are viewing.

4. Click the Color tab and set Mode to Variable.

5. Select a sensible variable (e.g., Maximum Face Angle or Axial Distance) with which to color

the isosurface.

6. Set Range to Local so that the full color range is used on the isosurface.

7. Click Apply to create the isosurface object.

You should now see the isosurface in the viewer. All points on the isosurface are a distance of 20 m (or

whatever value you used in the Value box) from the X-axis.

8.4. Command Editor Command

The Command Editor dialog box can be used to create or modify any of the objects in ANSYS TurboGrid

using the CFX Command Language. For further details, see CFX Command Language in the TurboGrid

Reference Guide.

Power Syntax can be entered and processed in the Command Editor dialog box. For details, see Power

Syntax in the TurboGrid Reference Guide. Power Syntax commands should be proceeded by the ! symbol.

In addition, any valid CCL command can be typed and processed in the Command Editor dialog box.

For details, see Command Actions in the TurboGrid Reference Guide. Action Commands should be preceded

by the > symbol.

To create an object using CCL, select Tools > Command Editor from the main menu. The Command

Editor dialog box is displayed.

To edit an existing object using CCL, right-click the object in the object selector and select Edit in

Command Editor from the shortcut menu. The CCL definition of that object is automatically displayed

and can be edited to alter the object properties.

You can access the following basic editing tools by right-clicking in the Command Editor dialog box:

• Undo

Undoes the last edit action.

• Redo

Redoes the most recently undone edit action.

• Cut

Cuts the selected text and places it on a clipboard.

• Copy

Places the selected text on a clipboard.

• Paste
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Pastes the clipboard text at the insertion point, or replaces the selection.

• Clear

Clears all of the contents of the Command Editor dialog box.

• Select All

Selects all of the contents of the Command Editor dialog box.

• Find

Makes a search tool appear at the bottom of the Command Editor dialog box. Enter a search term

and click either Next or Previous to search upwards or downwards from the insertion point or

text selection. To hide the search tool, press <Esc>.

67
Release 14.0 - © SAS IP, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Command Editor Command



Release 14.0 - © SAS IP, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.68



Chapter 9: Help Menu

The following sections describe the commands available in the Help menu:

9.1. On ANSYS TurboGrid Command

9.2. Contents Command

9.3. Index Command

9.4.Tutorials Command

9.5. Search Command

9.6. Installation and Licensing Command

9.7. About ANSYS TurboGrid Command

9.8. About ICEM CFD Command

9.9. About Qt Command

9.10. Help on Help Command

9.1. On ANSYS TurboGrid Command

Click Help > On ANSYS TurboGrid to view the introductory documentation. This includes the new

features for ANSYS TurboGrid.

9.2. Contents Command

The Contents command shows a table of contents for all of the online ANSYS TurboGrid documentation.

9.3. Index Command

The Index command shows how to access the index for the ANSYS TurboGrid documentation.

9.4. Tutorials Command

The Tutorials command provides access to the ANSYS TurboGrid tutorials.

9.5. Search Command

The Search command shows how to access the search feature for the ANSYS TurboGrid online docu-

mentation.

9.6. Installation and Licensing Command

Opens the installation and licensing documentation.

9.7. About ANSYS TurboGrid Command

The About ANSYS TurboGrid command describes the purpose of ANSYS TurboGrid, shows the version

number, and provides an internet address.
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9.8. About ICEM CFD Command

The About ICEM CFD command describes ICEM CFD, shows the version number, and provides an internet

address.

9.9. About Qt Command

The About Qt command describes the purpose, shows the version number, and provides an internet

address.

9.10. Help on Help Command

The Help on Help command provides additional information about ANSYS TurboGrid help and how to

access it.
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Chapter 10: ANSYS TurboGrid Workflow

• Introduction (p. 71)

• Steps to Create a Mesh (p. 71)

• Geometry (p. 73)

• Topology (p. 90)

• Mesh Data (p. 113)

• Layers (p. 122)

• 3D Mesh (p. 133)

• Mesh Analysis (p. 133)

• User Defined Objects (p. 136)

• Default Instance Transform (p. 136)

• Shortcut Menu Commands (p. 136)

10.1. Introduction

This chapter explains the steps required to create a mesh. A brief overview is given in the next section.

The remaining sections of this chapter cover each major step in detail.

10.2. Steps to Create a Mesh

To create a mesh:

1. Define the geometry.

For details, see Geometry (p. 73).

2. Define the topology object(s) by selecting a method and optionally changing other settings.

For details, see Topology (p. 90).

3. Optionally modify the Mesh Data object to adjust the number of nodes.

If you plan to make a fine (high-resolution) mesh, you can optionally set the mesh density at a

later time in order to minimize processing time while establishing the topology. Keep in mind

that changing the mesh density can affect the mesh quality.

For details, see Mesh Data (p. 113).

4. Optionally modify the layer objects to improve mesh quality.

For details, see Layers (p. 122).

5. Generate the 3D mesh using the Insert > Mesh menu item, the Create Mesh  icon, or by clicking

the Generate button in the 3D Mesh object.
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For details, see 3D Mesh (p. 133).

6. Optionally investigate the mesh and refine any of the above objects as necessary.

To help identify problem areas of the mesh, mesh analysis tools are available. For details, see Mesh

Analysis (p. 133).

If you change any objects that affect the mesh, you must generate the mesh again.

7. Save the mesh to a file.

For details, see Save Mesh Command (p. 17).

In general, you should proceed from top to bottom in the object selector, or from left to right on the

toolbar.

Figure 10.1  Object Selector

Figure 10.2  Part of Toolbar

The other objects in the object selector are used for visualization and inspection purposes.
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Not every object in the object selector needs to be defined before a mesh can be created. However,

every object represented by an icon on the toolbar must be defined.

10.3. Geometry

To define the geometry, you can do any of the following:

• In ANSYS Workbench, attach a Geometry or Blade Design cell upstream of the Turbo Mesh cell.

Note that, in this case, some of the geometry objects (such as Machine Data, Hub, Shroud, Blade

Set, and Blade) have their settings taken from the upstream cell, and changes to these settings

cannot be made in ANSYS TurboGrid. Other settings in geometry objects are taken from the upstream

cell by default, but can be overridden. To override a particular setting, select the check box for the

frame surrounding the setting (in the object editor). For example, although the machine rotation

axis is, by default, taken from the upstream cell, you can change the rotation axis by selecting the

Rotation check box in the Machine Data object editor.

• Load a BladeGen inf file by selecting File > Load BladeGen or clicking Load BladeGen .

This is recommended if a BladeGen.inf file exists. For details, see BladeGen.inf File (p. 10).

• Specify multiple geometry objects at once by selecting File > Load Curves or clicking Load Curves .

This information includes machine data, the names of geometry definition files, choice of coordinate

system and leading/trailing edge settings. For details, see Curve File (p. 10).

• Load a cfg file by selecting File > Load CFG.

For details, see TurboGrid 1.6 cfg File (p. 10).

• Define the Machine Data object, then load each of the remaining geometry objects separately.

The geometry objects are outlined below with a summary of the function performed by each.

This object defines the geometry and

rotation properties of the rotating ma-

The Machine Data Ob-

ject (p. 74)

chine. For details, see The Machine Data

Object (p. 74).

These objects define the hub of the

rotating machine. For details, see The

Hub and Shroud Objects (p. 76).

The Hub and Shroud

Objects (p. 76)

These objects define the blade(s) of the

rotating machine. For details, see The

The Blade Set Object and

Blade Objects (p. 77)

Blade Set Object and Blade Ob-

jects (p. 77).

These objects define the hub tip and

shroud tip of the blade(s). For details,

The Hub Tip and Shroud

Tip Objects (p. 86)

see The Hub Tip and Shroud Tip Ob-

jects (p. 86).

These objects control the methods for

creating the low and high periodic

The Low Periodic and

High Periodic Ob-

jects (p. 87) surfaces. For details, see The Low Peri-

odic and High Periodic Objects (p. 87).
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These objects define the locations and

profiles of the inlet and outlet domains

The Inlet and Outlet Ob-

jects (p. 88)

of the mesh. For details, see The Inlet

and Outlet Objects (p. 88).

This object controls the display of the

outline of the geometry. For details,

see The Outline Object (p. 90).

The Outline Ob-

ject (p. 90)

After you have finished creating the geometry, you may want to hide some or all of it to allow you to

see the topology clearly. You can control the visibility of a geometry object by toggling the check box

next to the object in the object selector. You can also right-click an object and use shortcut menu

commands. The toolbar allows you to hide and unhide all geometry objects via the Hide all geometry ob-

jects  and Unhide_geometry_objects  icons.

10.3.1. The Machine Data Object

The Machine Data object contains geometric data that applies to the entire turbo machine (e.g., the

location of the rotation axis). Defining the machine data is an essential step in creating a mesh in ANSYS

TurboGrid, and can be accomplished by one of the following methods:

• Editing the Machine Data object.

• In ANSYS Workbench, attaching a Geometry or Blade Design cell upstream of the Turbo Mesh cell.

Note that, in this case:

– The Pitch Angle setting is taken from the upstream cell, and cannot be changed in ANSYS TurboGrid.

– The Rotation settings are taken from the upstream cell by default, but can be overridden by selecting

the Rotation check box.

– The Base Units setting can be changed and is not affected by changes to the upstream cell.

• Loading a BladeGen .inf file by selecting File > Load BladeGen or clicking Load BladeGen INF file .

You can define machine data, hub, shroud, and blade objects by loading a BladeGen .inf file.

For details, see Load BladeGen Command (p. 11).

• Loading curve files by selecting File > Load Curves or clicking Load Curves .

You can define the machine data, hub, shroud, and blade objects by loading curve files. For details,

see Load Curves Command (p. 12).

• Loading a cfg file by selecting File > Load CFG.

For details, see TurboGrid 1.6 cfg File (p. 10).

To edit the machine data, open the Machine Data object from the object selector or click Edit Machine

Data .
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10.3.1.1. Data Tab

10.3.1.1.1. Pitch Angle

A rotating machine component is made up of blade sets that are identical, adjacent to each other, and

equally spaced around the entire circumference. In the context of ANSYS TurboGrid, the pitch angle is

the Theta extent of one blade set. To calculate the pitch angle based on the number of blade sets per

360°, set Method to Bladeset Count; the pitch angle is then calculated as 360° divided by the

number of blade sets. If you need to specify the pitch angle directly (as in the Deformed Turbine tutorial),

set Method to Specified Angle.

ANSYS TurboGrid creates a mesh for one blade set only. The mesh can be copied and rotated using an

ANSYS CFX Pre-processor, if necessary, before it is solved in an ANSYS CFX Solver.

10.3.1.1.2. Rotation

The Method for defining the rotation axis can be set to one of the following:

• Principal Axis - select the X, Y, Z, -X, -Y, or -Z axis.

• Rotation Axis - define a custom axis by entering the Cartesian coordinates of 2 points on the axis. The

coordinates of the points can be typed in or selected using the  icon in the object editor.

10.3.1.1.3. Units

It is necessary to specify base units because the geometry kernel has an optimal range for storing

numbers between 1 and 500. If, for example, the geometry data is given in mm, but the machine is on

the order of 10 m in size, the numbers stored in mm would be outside of the optimal range. In this

case, the base units should be cm (default), to reflect the scale of the machine.

The base units specified in the Machine Data object are used only to adjust the range of numbers

to suit the geometry kernel; they are not used to interpret geometric data contained in files (e.g., the

hub curve file), nor are they used to specify the units of an exported mesh.

10.3.1.2. Rotation Axis Visibility

By turning on the visibility of the Machine Data object, the rotation axis becomes visible in the

viewer, along with a sample radial direction vector. An example is shown in Figure 10.3 (p. 75).

Figure 10.3  Rotation Axis
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The visibility of the Machine Data object is off by default. For details on setting visibility, see Visibility

Check Box (p. 4).

10.3.2. The Hub and Shroud Objects

The hub is the surface of the machine closest to the axis of rotation. It defines the inner fluid flow surface.

To define the machine component’s hub, edit the Hub object from the selector or click Edit Hub .

The shroud is the surface of the machine farthest from the axis of rotation. It defines the outer fluid

flow surface. To define the machine component’s shroud, edit the Shroud object from the selector or

click Edit Shroud .

The hub and shroud can be defined only after the machine data has been defined, although all of these

objects can be defined in one step. For details, see Steps to Create a Mesh (p. 71).

10.3.2.1. Data Hub and Data Shroud Tabs

10.3.2.1.1. Coordinate System and Hub File Definition

Set Coordinates, Angle Units, and Length Units according to the data in the hub/shroud file. The

hub/shroud file must contain data points which define the hub/shroud curve. To specify a hub/shroud

file, set File Name using a path relative to the working directory. You can click the Browse  icon to

select a curve file using a browser.

The hub/shroud curve runs upstream to downstream and must extend upstream of the blade leading

edge and downstream of the blade trailing edge. The points must be listed in the file line by line, in

free-format ASCII style, in order from upstream to downstream.

For example:

-1.0  0.0  1.0
2.0  0.0  1.0

No names or labels may be present in the file.

Note

If the hub/shroud file was used in earlier versions of CFX-TurboGrid, you can use the file

again in this release without any modifications. However, any data in the fourth field formerly

used for parametric values is now ignored.

The Curve Type setting has the following options for defining the type of hub/shroud curve.

• Bspline, the default, means that a smooth curve is interpolated using the points listed in the

hub/shroud file. This method may be necessary if the hub/shroud curve is defined with a small number

of points.

• Piece-Wise Linear means that the points listed in the hub/shroud file are connected to one an-

other with straight lines.
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10.3.2.1.2. Curve or Surface Visibility

By default, the hub/shroud surface is visible while the hub/shroud curve is not visible. To see the curve,

the following steps could be taken in the Data Hub tab:

1. Select the Curve or Surface Visibility > Show Curve check box.

2. Clear the Curve or Surface Visibility > Show Surface check box.

3. Click Apply.

4. Right-click the Hub/Shroud object and select Render (Properties) > Edit Options.

5. On the Render tab, select the Draw Lines check box.

6. Click OK.

10.3.2.1.3. Reread Button

If the file that defines the hub/shroud has been modified since it was last loaded, clicking the Reread

button will cause the hub/shroud data to be reloaded. The Blade Set object and individual blade

objects also have this feature.

10.3.2.2. Transform Tab

This tab contains specifications for rotational and translational transforms that adjust the geometry.

The settings on this tab adjust the hub/shroud geometry only. The Blade Set object and individual

blade objects can also have their coordinates transformed using the corresponding tabs of those objects.

10.3.2.2.1. General Rotation

Specify an axis via two points and a rotation angle about the axis.

10.3.2.2.2. Translation

Specify the direction and distance to translate the geometry. The direction may be any one of: Machine
Axis, X Axis, Y Axis, Z Axis, or Vector (any specified direction).

10.3.2.2.3. Axial Rotation

Specify the angle to revolve the geometry about the machine axis.

10.3.3. The Blade Set Object and Blade Objects

To define the machine component’s blades as a set, edit the Blade Set object from the object selector

or click Edit Blade Set . To define or modify a single blade, edit the corresponding object stored under

the Blade Set object. You can only define the blade set or individual blades after the hub and shroud

have been defined, although all of these can be defined in one step. For details, see Steps to Create a

Mesh (p. 71).

The count and naming of the individual geometry (and topology, and mesh data) objects for each blade

in the blade set are managed automatically by ANSYS TurboGrid. If a profile file containing multiple

blades is specified for the Blade Set object (whether directly or indirectly, e.g., by loading a BladeGen

.inf file or .cfg file), then a blade object will be created for each set of data in the file and named

according to the name specified in the file (unless a name is not specified, in which case a generic name

of the form "Blade n" will be given, where n is an integer starting at 1).
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The individual blade objects contain a profile curve file specification and a setting to indicate which

single blade in the file applies; numbering starts at zero.

10.3.3.1. Blade Tab

10.3.3.1.1. Apply Settings To All Blades Check Box

When Apply Settings To All Blades is selected, Blade Set settings overwrite the corresponding

blade object settings. If Apply Settings To All Blades is cleared, the settings that apply to all blades

are disabled.

If you change a setting for a blade object, and the Blade Set object has a corresponding setting,

then the Apply Settings To All Blades check box will be cleared to help prevent accidentally losing

the blade-specific settings in case you reapply the Blade Set object.

10.3.3.1.2. Coordinate System and Blade File Definition

10.3.3.1.2.1. File Name

Set File Name to the name of the blade set file. To open a file selector, click Browse .

The blade file must contain data points which define the blade profile (or rib) curves and should have

the file extension .curve or .crv.

The profile points must be listed line by line, in free-format ASCII style in a closed-loop surrounding the

blade.

A minimum of two profiles are required in the blade file: one which lies close to the hub surface and

one which lies close to the shroud surface. The profile is not required to lie exactly on the surface. If it

lies between the hub and shroud surfaces, it must be within 8% of the span from the surface. If a profile

lies outside of the passage, its distance from the surface has no maximum limit.

Profiles can be used to define tips. For details, see The Hub Tip and Shroud Tip Objects (p. 86). Profiles

are allowed, and sometimes required, beyond a tip.

The profiles must be listed in the file in order from hub to shroud. Individual profile datasets are separated

by a line beginning with the “#” character. Any text following the “#” character is used as the name

associated with the subsequent profile.

For example:

# Hub Profile
0.0  0.0  1.0 le
1.0  0.0  1.0
1.0  1.0  1.0 te
0.0  1.0  1.0
0.0  0.0  1.0
# Intermediate Blade Profile
0.0  0.0  2.0 le
1.0  0.0  2.0
1.0  1.0  2.0 te
0.0  1.0  2.0
0.0  0.0  2.0
# Shroud Tip Profile
0.0  0.0  2.75 le
1.0  0.0 2.75
1.0  1.0 2.75 te
0.0  1.0 2.75
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0.0  0.0 2.75
# Shroud Profile
0.0  0.0  3.0 le
1.0  0.0  3.0
1.0  1.0  3.0 te
0.0  1.0  3.0
0.0  0.0  3.0

There is no restriction on the number of profiles or the number of data points in a profile dataset.

However, as noted above, a minimum of two profiles is required.

10.3.3.1.2.2. Coordinates, Angle Units, and Length Units

Set Coordinates, Angle Units, and Length Units according to the data in the blade file.

10.3.3.1.3. Geometric Representation

ANSYS TurboGrid generates blade surfaces using a two-step process:

1. Curves are generated.

2. A surface is created by lofting across the set of curves (that is, sweeping from one curve to the next).

The Geometric Representation settings control how these steps are performed.

10.3.3.1.3.1. Method

The Method setting allows two preset methods, and one general method, for controlling the settings

that govern the geometric representation of blade surfaces (that is, the Lofting, Curve Type, and Surface

Type settings, described shortly).

The available Method options are:

• BladeModeler

The BladeModeler option sets Lofting to Spanwise, Curve Type to Bspline, and Surface

Type to Ruled.

• Flank Milled

The Flank Milled option sets Lofting to Streamwise, Curve Type to Piece-wise Linear,

Surface Type to Ruled.

• Specify

The Specify option makes the Lofting, Curve Type, and Surface Type settings available for

direct specification.

The following rules are followed by ANSYS TurboGrid for selecting the geometric representation

method:

• If you load a blade from a BladeModeler .inf file, the BladeModeler option will be selected auto-

matically.

• If the BladeModeler option is selected and there are only 2 blade profile curves (for the applicable

blade), the selected option will change to Flank Milled (which is equivalent, in this case).

• If the Flank Milled option is selected and there are more than 2 blade profile curves (for the applic-

able blade), the selected option will change to BladeModeler and a warning message will be issued.
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10.3.3.1.3.2. Lofting

The direction in which lofting occurs is set by the Lofting setting. The available Lofting options are:

• Streamwise

The curves that are swept in the process of streamwise lofting are formed by connecting corres-

ponding points between adjacent blade profiles. For this method of lofting, you must ensure that:

– each blade profile has the same number of points

– the points are ordered in the same direction

– the first, nth, and last point of each blade profile are at similar locations around the blade

• Spanwise

The curves that are swept in the process of spanwise lofting are the blade profile curves.

Figure 10.4 (p. 81) shows how spanwise lofting and streamwise lofting differ.
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Figure 10.4  Spanwise Lofting versus Streamwise Lofting

The appropriate lofting setting depends on how the geometry was produced. For example, Blade

Modeler can produce blades via streamwise or spanwise lofting. The appropriate setting is stored in

the BladeGen.inf file. As another example, a flank-milled blade should be generated and interpreted

using two blade profiles (one at (or near) the hub and one at (or near) the shroud) with streamwise

lofting.

Note

The method of “sweeping” through the curves in the lofting process is controllable via the

Surface Type setting, which can be set to Bspline (default) or Ruled. For details, see

Surface Type (p. 82). For streamwise lofting, the Bspline method may cause unexpected

results. In this case, the workaround is to use the Ruled method.
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10.3.3.1.3.3. Curve Type

The set of curves that are used to loft the blade surface may be constructed in one of two ways, as

determined by the Curve Type setting. The available Curve Type settings are:

• Piece-wise linear

The Piece-wise linear setting causes the points listed for each profile in the blade file to be

connected to one another with straight lines. You should use this setting when you have a large

number of points (1000 or more) in a profile. This setting is always used when Method is set to

Flank Milled.

• Bspline

The Bspline setting results in the interpolation of a smooth curve for each profile using points

listed in the blade file. This setting may be necessary if the profile curves are defined with a small

number of points. This setting is discouraged when you have a large number of points (1000 or

more) in a profile, due to undesirable effects on the shape of the spline, and due to limitations of

the software. The Bspline setting is the default when Method is set to BladeModeler or

Specify.

10.3.3.1.3.4. Surface Type

The manner in which the set of curves is lofted is controlled by the Surface Type setting. The available

Surface Type options are:

• Ruled

A ruled surface is created by sweeping along linear paths that connect one curve to a corresponding

place on the next curve. The Ruled method for surfaces is similar to the Piece-wise linear
method for curves, but is done in 2 dimensions instead.

• Bspline

A B-spline surface is created by sweeping along curvilinear paths that connect one curve to a cor-

responding place on the next curve. The Bspline method may be necessary if the blade is defined

with a small number of profile curves.

10.3.3.1.4. Leading and Trailing Edge Definitions

ANSYS TurboGrid uses an algorithm to determine the location of the leading edge curve(s) and trailing

edge curve(s) and in most cases gets the correct locations (double edges are possible in the case of

cut-off or square edges). In some instances, the location of one or more of the points may need to be

adjusted. See Leading Edge (p. 84) and Trailing Edge (p. 85) for information about adjusting the leading

and trailing edges.

If you know which points on each profile should lay on the leading and trailing edge curves, you can

optionally designate them in the blade file using a fourth field. This ensures the correct positioning of

the leading and trailing edge curves in the beginning. The leading edge point on a profile should have

le1 (or le2 for the second leading edge in the case of a double leading edge) in the fourth field and

the trailing edge point on a profile should have te1 (or te2) in the fourth field. These points are then

guaranteed to be listed in the leading edge or trailing edge objects. For an example of the format of

a blade file containing leading and trailing edge designations, try the following:

1. Load a blade file into ANSYS TurboGrid.
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2. Optionally change the type of leading or trailing edge between single and double (using the LE Type

and TE Type settings which are described below).

3. Save the blade file and examine it in a text editor, noting the le1, te1 (and, for double edges le2 and

te2) entries in the fourth field.

10.3.3.1.4.1. Cut-off or square

This is an option that may be used to create a flat leading/trailing edge between two edge curves. See

Figure 10.5 (p. 83) for an example of a “cut-off or square” trailing edge.

Figure 10.5  Trailing Edge with Pair of Edge Curves

The Cut-off or square option is intended for use on blade profiles that have discontinuities in slope at

the edges. Use of this option on rounded or blunt leading/trailing edges may result in edge curves that

are not placed in optimal locations (i.e., further adjustments may be necessary).

10.3.3.1.4.2. Line of rotation on hub and shroud

This option, available in the Blade Set object, generates a line of rotation from each cut-off point

of a “cut-off or square” blade edge. A “cut-off or square” edge having the same axial and radial coordin-

ates at both cut-off points will have lines of rotation that coincide. In this case, the Line of rotation on

hub and shroud option will divide the passage mesh, hub, and shroud at the cut-off edge by a surface

of revolution about the machine axis. Additional 2D and 3D regions will be created as a result of this

division of the passage. This allows, for example, the mesh to be used in a simulation where the portion

of the passage mesh surrounding the blade rotates, while the rest of the passage mesh is stationary.

This option may still be used if the cut-off points do not have the same axial and radial coordinates,

although the interface between the divisions will not be a surface of revolution.

As a result of the division of the passage, the topology (see Topology (p. 90)) will also be affected. For

details, see Topology with Cut-off or Square Leading or Trailing Edges (p. 112).
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10.3.3.1.5. Bias of Blade towards High Periodic

The Bias of Blade towards High Periodic > Factor setting, available in the Blade Set object, controls

the location of the periodic surface in the passage, with respect to the first blade of the blade set. Set

Factor to a number somewhere between 0 and 1. A higher value brings the high periodic surface closer

to the first blade (causing the low periodic surface to move further from the blade). A lower value brings

the low periodic surface closer to the blade. The main purpose of this feature is to avoid having a

periodic surface too close to (esp. touching), the blade surface. Such a situation can occur for some

blade geometries.

10.3.3.1.6. Curve or Surface Visibility

The visibility of curves and surfaces for a blade object works in the same way as for the hub. For details,

see Curve or Surface Visibility (p. 77).

10.3.3.1.7. Reread Button

If the file that defines the blade profile has been modified since it was last loaded, clicking the Reread

button will cause the blade profile data to be reloaded. The hub and shroud objects also have this

feature.

10.3.3.1.8. Save & Load Button

If a leading or trailing edge point has been moved, the Save & Load button appears in place of the

Reread button. Selecting this button causes the modified blade profile data to be saved to a profile

file (you will be prompted for the name), then reloaded (from the same file) in order for the new geometry

to take effect. The leading edge and trailing edge objects also have this feature.

10.3.3.2. Transform Tab

The Transform tab contains specifications for rotational and translational transforms that adjust the

geometry. The settings on this tab adjust the blade geometry only. The hub and shroud can also have

their coordinates transformed using the corresponding tab of those objects.

10.3.3.2.1. General Rotation

Specify an axis via two points and a rotation angle about the axis.

10.3.3.2.2. Translation

Specify the direction and distance to translate the geometry. The direction may be any one of: Machine
Axis, X Axis, Y Axis, Z Axis, or Vector (any specified direction).

10.3.3.2.3. Axial Rotation

Specify the angle to revolve the geometry about the machine axis.

10.3.3.3. Leading Edge

The leading edge curve is the most upstream part of the blade. To modify the blade’s leading edge,

select the leading edge object from the object selector. The leading edge can only be defined after the

blade has been defined.
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10.3.3.3.1. Leading Edge Tab

10.3.3.3.1.1. Curve

The leading edge curve appears green in the viewer window and each point on the curve (one for each

blade profile, or rib, curve) is marked with an octahedron symbol. The points are listed from hub to

shroud. Edit the individual leading edge point locations to create the correct leading edge curve for

the blade.

The quality of the mesh is dependent on the accuracy of the leading edge curve. In most cases, the

initial placement of leading edge points is adequate. However there are some cases when some points

may need to be moved.

Any change to the leading edge changes the blade surfaces, which changes the periodic surfaces as

well as the hub and shroud surfaces. In order to avoid the delays associated with recreating the entire

geometry after any modification to the leading edge, another step is required. The blade must be saved

after the modifications to the leading edge are complete. For details, see Save Blade As Command (p. 16).

The saved blade file contains data in the fourth field to designate the leading edge points. To complete

the leading edge modification, the blade object must be updated with this new blade file. For details,

see The Blade Set Object and Blade Objects (p. 77).

There are several steps required to edit the location of a point on the leading edge curve.

1. Select the point to edit by clicking on it in the list of points. Alternatively, you can pick the point to

edit from the viewer after clicking Select  (on the viewer toolbar).

2. Click in any coordinate widget and then click the new location for the point in the viewer. The coordin-

ates of the picked point are displayed in the object editor. Alternatively, type the coordinates of the

new location for the point or use the embedded sliders. The units of the coordinates are the base units

or solution units. For details, see Units (p. 75).

3. Click Apply to save the new location of the current point.

Picking Mode can also be used to select and translate leading edge points in the viewer. For details, see

Selecting and Dragging Objects while in Viewing Mode (p. 55). After moving the leading edge point, it

will snap to the nearest point on the current profile curve.

If the leading edge points were designated in the blade file, it may not be necessary to adjust them

since, in that case, the leading edge curve may already be acceptable. For details, see Coordinate System

and Blade File Definition (p. 78).

10.3.3.3.1.2. Save & Load Button

If a leading or trailing edge point has been moved, the Save & Load button appears. Clicking this

button causes the modified blade profile data to be saved to a profile file (you will be prompted for

the name), then reloaded (from the same file) in order for the new geometry to take effect. The blade

and trailing edge objects also have this feature.

10.3.3.4. Trailing Edge

The trailing edge curve is the most downstream part of the blade. The trailing edge curve appears red

in the viewer window. Because of the similarity of the trailing edge with the leading edge, see Leading

Edge (p. 84) for details.
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10.3.4. The Hub Tip and Shroud Tip Objects

The shroud tip is the portion of the blade surface that exists as a result of the blade not extending all

the way to the shroud. By default, the blade extends all the way to the shroud (i.e., no shroud tip exists).

To create a shroud tip, edit the Shroud Tip object after the blade has been defined.

The hub tip is similar to the shroud tip, except that it is at the hub end of the blade. The settings for

the hub tip are stored in the Hub Tip object.

Note

It is possible to specify a hub tip and a shroud tip for the same blade.

Note

Using a tip clearance on one blade but not another is possible by changing the CCL for indi-

vidual blades, but could produce an invalid mesh near the tip of any blade that does not

have tip clearance.

10.3.4.1. Hub Tip and Shroud Tip Tabs

The following sections describe the object editor settings for the Hub Tip and Shroud Tip objects:

10.3.4.1.1. Override Upstream Geometry Options

10.3.4.1.2. Clearance Type

10.3.4.1.1. Override Upstream Geometry Options

Selecting the Override Upstream Geometry Options check box enables you to change the hub/shroud

tip settings for the case of TurboGrid running in Workbench with an upstream geometry provided by

BladeEditor. If you do not select the Override Upstream Geometry Options check box, the hub/shroud

tip settings are displayed but are not editable, being controlled by the upstream BladeEditor geometry.

Note

In Release 14.0, only the shroud tip geometry can be defined in BladeEditor.

10.3.4.1.2. Clearance Type

The Tip Option setting has the following options:

• None

This option causes the blade to extend from hub to shroud.

• Constant Span

This option creates a tip at the span location that you specify. A span of 0.0 represents the hub

and a span of 1.0 represents the shroud. The span value for the hub tip must be between 0 and

0.5; the span value for the shroud tip must be between 0.5 and 1.0.

• Normal Distance

This option creates a tip so that the gap distance is whatever you specify.
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• Variable Normal Distance

This option creates a tip so that the gap distance varies from leading edge to trailing edge using

values that you specify. The gap distance varies linearly with m-coordinate as calculated on the

hub (for a hub tip) or shroud (for a shroud tip).

• Profile Number

This option creates a tip at the blade profile that you specify. The available profiles are defined in

the blade file. For details, see The Blade Set Object and Blade Objects (p. 77). The profile closest to

the hub is profile 1.

Note

The blade surface and resulting mesh can be adversely affected when a blade shroud

tip is defined by the second-last profile, and the last profile has a shape that is inconsist-

ent with where the blade would exist if the blade were extended in the spanwise direction

without the last profile. To avoid this problem, you can either ensure that the last profile

is consistent with the second last profile, or manually remove the last profile from the

curve file. A similar statement applies for the hub end of a blade having a hub tip.

10.3.5. The Low Periodic and High Periodic Objects

The low periodic surface extends from hub to shroud and inlet to outlet along the side of the mesh

that has the lowest Theta values (The direction of Theta is determined by the machine rotation axis

and the right-hand rule.). The high periodic surface is on the opposite side of the passage from the low

periodic surface (i.e., on the high-Theta side).

The periodic surfaces can be modified only after the blade has been defined.

10.3.5.1. Data Tab

Set Method to one of the following:

• Automatic

This option creates the periodic surface automatically. The shape of the periodic surface is based

on the geometry of the adjacent blades. The position of the automatically-generated periodic surface

is governed by the Bias of Blade towards High Periodic setting found in the Blade Set object,

as well as the # of Bladesets setting of the Machine Data object.

• From File

This option allows you to load a periodic surface that was saved to a file. The Length Units setting

controls the units that will be used to interpret the coordinate data in the file. The Rotation Angle

setting transforms the loaded periodic surface by rotating by the specified angle about the machine

rotation axis. Note that the # of Bladesets setting of the Machine Data object will not change

automatically due to changes to the Rotation Angle setting.

10.3.5.2. Rendering Properties

To modify the color or rendering of the low or high periodic surface, right-click the Low Periodic
or High Periodic object (respectively), then select Render (Properties) > Edit Options.
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10.3.6. The Inlet and Outlet Objects

The inlet region of the passage is controlled by the Inlet object. The outlet region is controlled by

the Outlet object.

You can modify the Inlet and Outlet objects only after the blade has been defined.

Note

If a 3D inlet (or outlet) region is added, the inlet (or outlet) object becomes the interface

between this 3D region and the topology. For details, see Inlet Domain and Outlet Domain

Settings (p. 120).

10.3.6.1. Inlet Tab or Outlet Tab

10.3.6.1.1. Control Angle

By default, ANSYS TurboGrid automatically adjusts the geometry upstream and downstream of the

blade. You can override the angle of the periodic surface relative to the rotation axis. This can be useful

for improving the quality of the mesh and/or guiding the mesh in the general flow direction.

10.3.6.1.2. Initialize points to full extents of Hub or Shroud curves

The Initialize points to full extents of Hub/Shroud curves option is only visible before the hub,

shroud, and blade are loaded. When selected, all inlet points will move to the very beginning of the

passage (as far away from the blade as possible). Similarly, all outlet points will move to the very end

of the passage. Such a feature can be useful when the shape of the blade is likely to intersect the default

placement of the inlet points.

10.3.6.1.3. Automatically Generate Intermediate Points

This option is only available before the hub, shroud, and blade are loaded. It is on by default. When

selected, a set of intermediate points will be generated between the low hub point and low shroud

point upon loading the geometry (hub, shroud and blade). The purpose of these points is to control

the meridional shape of the inlet surface. The automatic generation process aims to add an appropriate

number of points, placed at locations that follow the shape of the leading edge of the blade.

10.3.6.1.4. Curve

The inlet/outlet curve consists of a set of points that guide the meridional shape of the inlet end of the

passage mesh as a function of the local spanwise direction. By default, a set of points is automatically

generated (see Automatically Generate Intermediate Points (p. 88)).

The inlet/outlet curve can be defined by creating, modifying and deleting points in the list of points.

There must be a point at both the hub and shroud while additional points are optional. The points are

connected linearly and must be listed in order from hub to shroud, or they will be ignored.

A point can be selected by clicking on it in the list of points or by picking it in the viewer window. For

details on picking points in the viewer, see Selecting and Dragging Objects while in Viewing Mode (p. 55).

The available icons become active when a point is selected. Alternatively, you can right-click an existing

point in the list of points to see the same options. Each icon and its function is described in the following

table:
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DescriptionIcon

New adds a point in the list of points below the selected point. The

initial location of the new point on the Inlet is between the locations

of the selected point and the following point in the list of points. You

cannot create a new point after the low shroud point.

Generate intermediate points removes all points except for the low hub

point and the low shroud point, then automatically generates a set

of zero or more points between them.

Delete removes the selected point from the list of points. You cannot

delete the low hub point or the low shroud point.

Read from File opens a load file window. Select the file with the inlet

points and click Open.

You can modify the location of the selected point by:

1. Typing in the coordinates (axial, radial, or both, depending on the selected Method option), or

2. Selecting and dragging the point in the viewer using the left mouse button. This can be done as for

a control point. For details, see How to Select and Move a Control Point (p. 129).

Set Method to one of the available options:

• From A and R

• Set A

• Set R

Regardless of the method used to modify the location of the selected point, the location is restricted.

The low hub point snaps to the line of intersection between the hub and low periodic surfaces. The

low shroud point snaps to the line of intersection between the shroud and low periodic surfaces. Use

the OUTLINE object as a guide when dragging the points. Any other points between the hub and shroud

snap to the low periodic surface and are not constrained in the spanwise or streamwise directions. Inlet

points cannot be moved further downstream on the low periodic surface than a position level with the

leading edge of the blade. After you have clicked Apply, or dragged a point, the Selected Point setting

will show the actual position to which the point has moved.

Note

The points are defined using the A-R coordinate system as opposed to the X-Y coordinate

system.

The visibility of the inlet (or outlet) points is controlled by the Point Visibility check box.

10.3.6.2. Using an Adjacent Stage to Define the Inlet/Outlet Stage Interface

You can automatically adjust a stage interface (i.e., the inlet/outlet points that shape the end of the

passage mesh) by loading a blade from the adjacent stage. To do this:

1. Click the Interface button in Inlet or Outlet editor, depending on the location of the next stage.

The Open Blade File dialog box appears.

2. Select and open the file that defines the blade in the adjacent stage.
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Note that the hub and shroud curves are required to extend past this blade.

ANSYS TurboGrid will then do the following:

• Adjust the stage interface location according to the shape of the new blade.

• Add a graphical representation of the new blade to the Inlet or Outlet object, as applicable.

• Turn on the visibility of the Inlet or Outlet object, as applicable.

• Make the Points generated using adjacent stage check box available, and initially selected.

The Points generated using adjacent stage option overrides the Curve settings, forcing them to be

computed based on the blade from the adjacent stage.

10.3.6.3. Using Stage Interfaces

In order to produce a proper stage interface, you should follow these guidelines:

• Use the same hub curve for both stages, and the same Curve Type setting: Bspline or Piece-Wise
Linear. The hub curve must extend through both stages to do this.

The same applies to the shroud curve.

As a less preferable alternative, you can use hub curves for each stage. The curves should meet at

a point, and not overlap. When using this method, there is a risk of a discontinuity in slope where

the curves meet.

• Use the same interface points for stage interfaces. Do this by saving the interface (inlet or outlet geometry

object, as applicable), then loading the interface for the adjacent stage.

10.3.7. The Outline Object

The outline is a group of curves on the outer extents of the geometry. The outline includes the full extent

of the hub and shroud read from the files, independent of the inlet and outlet locations. To modify the

color or rendering of the geometry outline, right-click the OUTLINE object, then select Render (Prop-

erties) > Edit Options. You can only modify the outline after the blade has been defined.

10.4. Topology

The topology is a structure of blocks that acts as a framework for positioning mesh elements. Topology

blocks represent sections of the mesh that contain a regular pattern of hexahedral (hex) elements. They

are laid out adjacent to each other without overlap or gaps, with shared edges and corners between

adjacent blocks, such that the entire domain is filled. By using topology blocks to control the placement

of hex elements, a valid hex mesh can be generated to fill a domain of arbitrary shape. The topology

is invariant from hub to shroud and is viewed/edited on 2-D layers which are located at various spanwise

stations (see Layers (p. 122)).

The topology blocks can be arranged in a regular (structured) pattern, an irregular (unstructured) pattern,

or in a pattern consisting of structured patches and unstructured patches. The choice of which approach

should be followed should be based on whichever method minimizes the maximum skew of the topology

blocks, since the skew in the hex elements of the mesh is directly related (differs only because of mesh

smoothing). The topology should then be investigated at various layers (especially the hub and shroud

layers) to check its quality since the mesh quality is directly dependent.
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Note

To visualize the topology on a layer, turn on the visibility using the visibility check box for

that layer in the object selector and ensure that at least one topology visibility setting for

the layer is turned on. The Topology Visibility setting controls the visibility of the yellow

line segments that outline the topology block edges. The Master Topology Visibility setting

controls the visibility of the violet line segments that outline the master topology edges. For

details, see Topology Visibility (p. 126).

A key feature of ANSYS TurboGrid is the visibility of the surface mesh on the topology. As you adjust

the topology, ANSYS TurboGrid adjusts the surface mesh in real time so that the true effect of topology

changes is visible. To help identify problem areas in the surface mesh before you generate the full 3D

mesh, you can visualize mesh statistics on the layers.

Topology blocks generally contain the same number of mesh elements along each side. The mesh ele-

ments vary in size across topology blocks in a way that produces a smooth transition
1
 within and

between blocks. This is accomplished by shifting the nodes (“node biasing”
2
) toward, or away from,

certain block edges. The topology blocks are positioned by default so that the mesh element sizes vary

as smoothly as possible, given the constraints. The following changes to the topology object settings

can influence the variation in mesh element edge ratios:

• Changing the number of topology blocks along certain paths (e.g., across the blade passage or from a

blade’s leading edge to the inlet). For details, see Blade Blocks Calculation (p. 108), and Blade to Period-

ic/Inlet/Outlet Surface Block Distribution (p. 109).

• Moving control points which control the position of block edges on a given layer. For details, see Master

Control Points (p. 128) and Added Control Points (p. 131).

ANSYS TurboGrid features two different topology sets: ATM Optimized and Traditional Topologies. ATM

Optimized is the default setting and allows high-quality meshes to be easily generated. Traditional To-

pologies give you more control over mesh generation. Both sets are discussed in the following topics:

• ATM Optimized Topology (p. 91)

• Traditional Topologies (p. 99)

10.4.1. ATM Optimized Topology

This chapter provides a description of the Automatic Topology and Meshing (ATM Optimized) feature.

ATM Optimized topology is the default setting in ANSYS TurboGrid and an alternative to the topologies

mentioned in The Topology Set Object and Topology Objects (p. 99). This topology type enables you to

create high-quality meshes with minimal effort; there is no need for control point adjustment.

Important

ATM is not applicable for blades that have square leading or trailing edges.

The basic steps to using the ATM Optimized feature are as follows:

1
The smooth transition is not preserved if ordinary control points are moved. However, the smooth transition is preserved if master

control points are moved.
2
Node biasing is an important aspect of mesh generation because it helps to reduce the number of mesh elements.
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1. Load the blade geometry and set the geometry parameters (for example, inlet/output points) as neces-

sary.

2. Open Topology Set and set Topology Definition > Placement to ATM Optimized.

3. Click Apply.

4. Open Mesh Data.

5. On the Mesh Size tab, set Method to Target Passage Mesh Size or Global Size Factor
as appropriate.

6. Click Apply.

7. Right-click Topology Set and clear Suspend Object Updates.

ANSYS TurboGrid computes the topology and mesh for the hub and shroud layers based on the

current default mesh size.

8. Click Create Mesh  to generate the volume mesh.

Afterwards you can view the 2-D mesh on a layer and view the layer statistics, just as you would with

one of the traditional control point topologies. The Master Topology (magenta) shows the master block

topology curves. The Topology (gold) shows the background mesh, which is typically useful only for

developer debugging. The Refined Mesh (brown) shows the final mesh for the layer; this is the most

useful of the three.

The following topics are discussed:

10.4.1.1. Changing the Overall Mesh Size

10.4.1.2. Changing the Boundary Layer Resolution near the Blade

10.4.1.3. Changing the Mesh Size near Five-Edge Vertices

10.4.1.4. Changing the Number of Elements on a Selected Topology Edge

10.4.1.5. Changing the Spanwise Mesh Distribution

10.4.1.6. Locking the Mesh Dimensions

10.4.1.7. Using Splitter Blades with ATM

10.4.1.8. Advanced Topology Control

10.4.1.9. Advanced Local Refinement Control

10.4.1.10. Advanced Mesh Element Size Control

10.4.1.11. Example Mesh

10.4.1.1. Changing the Overall Mesh Size

The ATM Optimized method automatically computes a default mesh and sets the base mesh dimensions.

Each unique mesh dimension has an edge refinement factor that is multiplied by the base mesh dimen-

sion and a global size factor to determine the final size of the mesh dimension. Local mesh size adjust-

ments can be made by adjusting the local edge refinement factors. The overall mesh size can be changed

by using one of the following methods on the Mesh Size tab in the Mesh Data object editor:

• Set Method to Global Size Factor and set Size Factor.

This option directly sets the Global Size Factor that is used to multiply all the individual edge element

counts for the base (default) mesh. Increasing this factor will increase the overall mesh size, and

decreasing this factor will decrease the overall mesh size, but the change is not linear. In this mode,

if you change the spanwise mesh size or the boundary layer refinement, or make any local edge

refinements to the mesh, the Global Size Factor will stay fixed and the overall mesh size may

change. This factor, when used with proportional refinement, can be used to scale the mesh size

for a mesh refinement study.
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• Set Method to Target Passage Mesh Size and set Node Count.

This option enables you to choose the approximate mesh size (in nodes), and lets ANSYS TurboGrid

compute the mesh dimensions automatically, including the size factor. In this mode, if you change

the spanwise mesh size or the boundary layer refinement, or make any local refinements to the

mesh, ANSYS TurboGrid will adjust the mesh size factor (Edge Refinement Size Factor) automat-

ically to achieve the desired target mesh size.

10.4.1.2. Changing the Boundary Layer Resolution near the Blade

Within the O-grid block around the blade, ANSYS TurboGrid uses a constant expansion rate to distribute

the elements normal to the blade surface, and to assure a smooth transition to the passage mesh. The

expansion rate is determined by the number of elements normal to the blade, the ‘base mesh distribution’

and the size of the elements in the adjacent passage mesh. While you cannot directly specify the expan-

sion rate, you can control the expansion rate by adjusting the number of elements normal to the blade.

When the topology is created, ANSYS TurboGrid creates a Boundary Layer Control object under

the Mesh Data object in the object selector that provides direct control of the mesh resolution in the

O-grid and also displays the base and actual Block Edge Split Counts for the O-grid. The O-grid element

count normal to the blade is defined by the local Edge Refinement Factor times Global Size Factor times

the base mesh dimension for the O-grid. ANSYS TurboGrid automatically computes the base mesh di-

mension, and this remains fixed for a given geometry/topology. Increasing or decreasing the Edge Re-

finement Factor will increase or decrease the mesh resolution in the O-grid, respectively.

The Edge Refinement Factor can be specified directly, or it can be computed by ANSYS TurboGrid. These

options are described as follows:

• Use Proportional to Mesh Size — This option lets ANSYS TurboGrid compute the Edge Refine-

ment Factor as the Proportional Offset Factor Ratio times the Global Size Factor. This method maintains

a similar O-grid expansion rate when the Global Size Factor is changed. On the Mesh Size tab of the

Mesh Data object editor, set Boundary Layer Refinement Control > Method to Proportional
to Mesh Size, specify the Factor Base or Factor Ratio, and then click Apply. The Edge Refinement

Factor is computed as the sum of Factor Base, Factor Ratio and Global Size Factor. For both Factor

Base and Factor Ratio, increasing or decreasing the value will effectively increase or decrease the ex-

pansion rate, respectively.

• Use Edge Refinement Factor — This option lets you directly specify the Edge Refinement Factor.

This method does not maintain a similar O-grid expansion rate when the Global Size Factor is changed,

and therefore the Edge Refinement Factor may need to be adjusted when the mesh size is changed.

On the Mesh Size tab of the Mesh Data object editor, set Boundary Layer Refinement Control >

Method to Edge Refinement Factor. Specify Parameters > Factor, and then click Apply.

• Use First Element Offset via y+ height and Reynolds number — This option lets you specify

the approximate maximum y+ height for the blade. ANSYS TurboGrid uses this information to compute

the Edge Refinement Factor. The specified offset and the actual offset may differ. The elements near

the surface of the blade will not all have a constant height, but they will generally be at or less than

the specified maximum. Furthermore, the y+ calculation is only approximate. On the Mesh Size tab of

the Mesh Data object editor, set Boundary Layer Refinement Control > Method to First Element
Offset, set Near Wall Element Size Specification > Method to y+, enter a suitable Reynolds No.

(Reynolds number), specify Parameters > Offset Y+ and then click Apply.

• Use First Element Offset via Absolute offset height — This option lets you specify the approx-

imate maximum near wall element height. ANSYS TurboGrid uses this information to compute the Edge

Refinement Factor. The elements near the surface of the blade will not all have a constant height, but

they will generally be at or less than the specified maximum. On the Mesh Size tab of the Mesh Data
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object editor, set Boundary Layer Refinement Control > Method to First Element Offset, set

Near Wall Element Size Specification > Method to Absolute, specify Parameters > Offset and then

click Apply.

For the Edge Refinement Factor and First Element Offset methods, the parameters controlling the

boundary layer distribution can also be edited on the Boundary Layer Control object editor. If there

is more than one boundary layer in the topology, all the boundary layers can be changed at the same

time by selecting the Apply to All check box on the Mesh Data object editor; or they can be edited

individually on the Boundary Layer Control object editor.

10.4.1.3. Changing the Mesh Size near Five-Edge Vertices

For details, see Five-Edge Vertex Mesh Size Reduction.

10.4.1.4. Changing the Number of Elements on a Selected Topology Edge

You can control the number of elements along a given edge, but because of the smoothing process

you cannot control the distribution of the elements along the edge. To increase or decrease the number

of elements on a given topology edge, right-click the edge in the viewer and select one of the following:

• Insert Edge Split Control - This option inserts an Edge Split object under the Mesh Data object.

You can then edit this object to adjust the Edge Split Factor. The Edge Split object also displays

the base and actual Block Edge Split Counts for the selected edge.

• Increase Edge Refinement - This option lets you choose a preset amount by which to increase the Edge

Split Factor. An Edge Split object is automatically added for the selected edge if one has not been

created already.

• Decrease Edge Refinement - This option lets you choose a preset amount by which to decrease the

Edge Split Factor. An Edge Split object is automatically added for the selected edge if one has not

been created already.

The Edge Split object also displays the base and actual Block Edge Split Counts. You can remove

the control by right-clicking the Edge Split object in the object selector and selecting Delete.

10.4.1.5. Changing the Spanwise Mesh Distribution

ANSYS TurboGrid has several methods for controlling the spanwise mesh distributions. The default

method is Proportional. These methods are selected on the Passage tab of the Mesh Data object,

and they are described below:

• Proportional - With this option ANSYS TurboGrid automatically computes the number and distribution

of elements in the spanwise direction so that the near wall element heights on the hub and shroud

match the maximum near wall element height on the blade. ANSYS TurboGrid adjusts the spanwise

mesh count so that the average element aspect ratio (spanwise height divided by streamwise length)

near the midspan is approximately equal to the blade aspect ratio divided by the Proportional Factor.

Increasing or decreasing the Proportional Factor increases or decreases, respectively, the mesh resolution

in the spanwise direction. This option is only available when using the ATM Optimized method.

• Element Count and Size - This option lets you choose the spanwise element count and the element

height near the hub and shroud, and it operates the same as for the traditional control point topologies.

• Boundary Layer - This option gives you more control over the spanwise mesh distribution by providing

additional biasing adjustments near the hub and shroud compared with the Element Count and
Size option. It operates the same as for the traditional control point topologies.
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• Uniform - This option lets you specify the number of spanwise elements that will be distributed uniformly

from hub to shroud.

The Passage tab of the Mesh Data object also shows the approximate size of the elements next to

the wall. The values are reported in y+ or absolute distance depending on the Near Wall Element Size

Specification > Method setting on the Mesh Size tab.

10.4.1.6. Locking the Mesh Dimensions

In some situations, for example when you are comparing minor geometry variations, you may want to

keep the mesh dimensions the same from one case to the next. This will reduce the influence of the

mesh on the CFD results. To lock the mesh dimensions, select the Lock mesh size check box on the

Mesh Size tab of the Mesh Data object. This setting will maintain the current mesh dimensions and

prevent any subsequent changes to the global or local mesh controls. The lock status will be preserved

from one session to the next if the project or state file is saved. To unlock the mesh, clear the Lock

mesh size check box.

10.4.1.7. Using Splitter Blades with ATM

The ATM method now supports splitter blades which meet the following criteria:

• The main and splitter blades have rounded leading edges and cut-off trailing edges.

• The leading edge for the main blade is positioned ahead (meridionally) of the splitter leading edge.

• The trailing edges for both blades are located at the same meridional position.

10.4.1.8. Advanced Topology Control

By default, ANSYS TurboGrid automatically selects the appropriate topology based on the blade style

(cut-off or rounded edges) and blade angles. If you want to override the selection, then you can do it

by editing the CCL. The topology pieces are set using the following CCL lines:

• The first line specifies which topology pieces to use:

ATM Topology List = "leading edge topology choice" , "mid-passage topology choice" , 
" trailing edge topology choice"

The available topology pieces are listed in the table below and can be specified either using the

template name or the topology file name. If multiple topology pieces are set, each must be delimited

by a comma and should be ordered in the same way as the CCL above. User defined topology

pieces can also be specified using their file name. For more information on setting up user-defined

topologies in ANSYS TurboGrid, please contact your customer support representative.

If you choose to let ANSYS TurboGrid specify the topology pieces, ANSYS TurboGrid will also

automatically add the CCL above to show the topology pieces chosen. The available templates and

corresponding file names are shown in the table below:

Topology File

Name

Template Name

LE1by4.tgtLECutoffBlock1by4

LEHerringHigh.tgtLECutoffHerringboneHigh

LEHerringLow.tgtLECutoffHerringboneLow

LEs2by4.tgtLERoundedSymmetricStar

95
Release 14.0 - © SAS IP, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Topology



Topology File

Name

Template Name

mid1by4.tgtPassageBlock1by4

TE1by4.tgtTECutoffBlock1by4

TEHerringHigh.tgtTECutoffHerringboneHigh

TEHerringLow.tgtTECutoffHerringboneLow

TEs2by4.tgtTERoundedSymmetricStar

Note

– Pictures of the various topology pieces can be found in ATM Topology in the TurboGrid

Reference Guide.

– Leading edge topology pieces are prefixed with “LE”. Similarly, mid-passage and trailing

edge pieces are prefixed with “mid” and “TE”, respectively.

• The second line determines whether you or ANSYS TurboGrid selects the topology pieces:

Override ATM Topology List = "True/False"

If the value is set to true, then you select the topology pieces using the first line. If the value is set

to false, then ANSYS TurboGrid automatically selects and lists the topology pieces in the first ex-

pression. The topology pieces are selected based on the average blade angle: if the angle is between

0 and 10 degrees — ANSYS TurboGrid chooses the H style; if the angle is greater than 10 degrees

— ANSYS TurboGrid chooses the herringbone.

10.4.1.9. Advanced Local Refinement Control

When ANSYS TurboGrid initializes the ATM topology, it builds the topology in pieces and then conglom-

erates the block structure to minimize the number of blocks in the final topology. Because you can

control only the number of elements along a given topology edge and not the distribution, having

more blocks in specific areas, for example near the trailing edge, gives you better control of the mesh

resolution in these areas. Preserving specific vertices from being conglomerated in these situations will

give you better control of the local mesh resolution — the specific vertices will be dependent on the

topology pieces used. For a list of the available topology pieces, see Advanced Topology Control (p. 95).

You can retain additional vertices with CCL of the following format: “template name” , “vertex number”.

This must be repeated for each new vertex number, leading to the form:

TOPOLOGY SET:
  Override Conglomeration Retained Vertices List = true
  Conglomeration Retained Vertices List = "template name", "vertex number", "template name", "vertex number", ...
END

The following is an example of CCL that provides additional control near the leading and trailing edges

for rounded blades:

TOPOLOGY SET:
  Override Conglomeration Retained Vertices List = true
  Conglomeration Retained Vertices List = LERoundedSymmetricStar, 0, TERoundedSymmetricStar, 0, LERoundedSymmetricStar, 13, TERoundedSymmetricStar, 13
END

Topology piece diagrams and node numbers can be found in ATM Topology in the TurboGrid Reference

Guide.
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10.4.1.10. Advanced Mesh Element Size Control

You can scale the thickness of the outer row of mesh elements in the blade tip gap by adjusting the

CCL parameter Blade Tip First Element Size Factor. The default value of this parameter

is 1.0. The figure below shows which mesh elements are scaled by this parameter (colored blue), and

the direction in which they are scaled.

10.4.1.11. Example Mesh

The following figures show the resulting mesh for an example axial turbine blade.
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Figure 10.6  Mesh on the Hub for an Axial Turbine Blade
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Figure 10.7  Mesh at the Tip for an Axial Turbine Blade

10.4.2. Traditional Topologies

The following topics are discussed:

• The Topology Set Object and Topology Objects (p. 99)

• Topology with Cut-off or Square Leading or Trailing Edges (p. 112)

10.4.2.1. The Topology Set Object and Topology Objects

To define the topology settings that affect the topology of every blade in the blade set, edit the Topo-

logy Set object from the object selector or click Edit Topology Set . To define or modify the settings

that affect the topology for individual blades in the blade set, edit the corresponding blade-specific

topology objects stored under the Topology Set object. You can only define the topology set or

topology for an individual blade after the geometry has been defined. For details, see Steps to Create a

Mesh (p. 71).
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10.4.2.1.1. Definition Tab

10.4.2.1.1.1. Apply Settings To All Topologies Check Box

When the Apply Settings To All Topologies check box is selected, some Topology Set settings

overwrite the corresponding blade-specific topology settings. When the check box is not selected, those

same settings are disabled, enabling you to set the corresponding blade-specific settings independently.

If you change a setting for a blade-specific topology object, and the Topology Set object has a

corresponding setting, then the Apply Settings To All Topologies check box will be cleared to help

prevent accidentally losing the blade-specific settings in case you reapply the Topology Set object.

10.4.2.1.1.2. Topology Definition

The Topology Definition settings govern the general way in which the mesh is generated.

These settings are described in the following sections:

• Placement (p. 100)

• Method (p. 100)

10.4.2.1.1.2.1. Placement

The Placement setting makes it possible to choose between:

• ATM Optimized

For details, see ATM Optimized Topology (p. 91).

• Traditional with Control Points

This enables you to select from the topology types described in the next section.

10.4.2.1.1.2.2. Method

The Method options are described next:

• None prevents the creation of topology.

This is useful when making changes to the geometry since the topology and mesh preview are

not recreated after every minor geometry change.

• H/J/C/L-Grid allows a separate choice of topology type for the upstream and downstream ends of

the passage mesh. The decisions are automatic by default but an override is available. For more inform-

ation, see H/J/C/L Topology Definition (p. 106).

• H-Grid applies a topology of type H-Grid. An example of a topology of type H-Grid is shown in Figure

10.8 (p. 101).
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Figure 10.8  Topology of Type H-Grid

• J-Grid applies a topology of type J-Grid with an optional embedded O-Grid that surrounds the blade.

An example of a topology of type J-Grid is shown in Figure 10.9 (p. 102). A topology of type J-Grid always

wraps in opposite directions around the leading and trailing edges (unlike choosing the J-J case of a

topology of type H/J/C/L-Grid. For more information, see H/J/C/L Topology Definition (p. 106).).
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Figure 10.9  Topology of Type J-Grid

• H-Grid Dominant adds some topology blocks in a structured manner around an optional embedded

O-Grid that surrounds the blade (as for a topology of type H-Grid), then completes the mesh by adding

topology blocks in an unstructured manner. The structured blocks extend upstream of the leading edge,

downstream of the trailing edge, and from the blade to the periodic surfaces. An example of a topology

of type H-Grid Dominant is shown in Figure 10.10 (p. 103).
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Figure 10.10  Topology of type H-Grid Dominant

• From File uses a previously saved topology file as a starting point for a new topology.

Topology files can be saved in the GUI (see Save Topology Command (p. 17)), or created manually

using a text editor. If you have a topology file that you want to share with anyone using your in-

stallation of ANSYS TurboGrid, it should be saved in the directory <CFXROOT>/etc/templates.

A typical template (.tgt file extension) for a topology of type H-Grid is provided in this directory.

Note

For a case with multiple blades, if you perform any of the following actions:

– Freeze the topology

– Manually lock one or more of the advanced parameters for a splitter blade

– Load a topology from a file

and subsequently, when attempting to change the topology, you encounter an error

message about topology settings, then there is likely a problem due to the splitter blade

advanced parameters being locked. In this case, for each splitter blade, go to the Ad-

vanced Parameters tab and clear all the check boxes that have "Override" in the name,

then click Apply. You should then be able to successfully change the topology.

10.4.2.1.1.3. Include O-Grid

An O-Grid is a topology that forms a continuous loop around the blade profile (as would be seen in a

blade-to-blade view). Using an O-Grid around the blade yields excellent boundary layer resolution and

near-orthogonal elements on the blade.

103
Release 14.0 - © SAS IP, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Topology



To use an O-Grid, select Include O-Grid.

The Width Factor setting is used to adjust the thickness of the O-Grid. A width factor of n means that

the O-Grid thickness is roughly n times the average blade width at a particular span location (The span

location is set on the Advanced Parameters tab.).

10.4.2.1.1.4. One-To-One Interface Ranges

10.4.2.1.1.4.1. Periodic

The Periodic setting controls which parts of one side of the periodic surface are connected to the

other side via one-to-one node matching. The possible options are:

• Full

This is the default option. All of the nodes on one periodic surface correspond in a 1-to-1 fashion

with nodes on the other periodic surface.

• Between Blades & Upstream

The periodic surfaces have a 1-to-1 correspondence along the section between blades, and along

the inlet block, but not along the outlet block. The latter is connected by a GGI interface.

• Between Blades & Downstream

The periodic surfaces have a 1-to-1 correspondence along the section between blades, and along

the outlet block, but not along the inlet block. The latter is connected by a GGI interface.

• Between Blades

The periodic surfaces have a 1-to-1 correspondence along the section between blades, but not

along the portions in the inlet and outlet blocks. The latter are connected by GGI interfaces.

• None

A GGI interface is used along the entire periodic surface. In general, the nodes along one side of

a GGI interface do not correspond with nodes on the other side.

10.4.2.1.1.4.2. Passage

The Passage setting controls the type of interface for all passage interfaces (i.e., all interfaces between

adjacent blades in the blade set). Setting Passage to Full produces 1-to-1 interfaces. Setting Passage

to None produces GGI interfaces. In general, the nodes along one side of a GGI interface do not corres-

pond with nodes on the other side.

10.4.2.1.1.5. Tip Topology

Tip Topology is available when a hub or shroud tip (The Hub Tip and Shroud Tip Objects (p. 86)) exists.

The Hub and Shroud settings have the following options:

• H-Grid

Most of the blade is filled with an H-Grid block. The leading edge and trailing edge ends are filled

with butterfly mesh blocks. If the H-Grid tip mesh is reasonably orthogonal, this is by far the best

choice.

This option is not available when using a topology of type H/J/C/L-Grid for the passage since,

in general, this topology type yields different numbers of elements along each side of the blade.
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• H-Grid Not Matching

Similar to H-Grid except that the grid is split along the center of the blade thickness and there

is no one-to-one connection of nodes between the halves. This option is useful when the distribution

or number of nodes along each side of the blade is mismatched. When mesh alignment across the

blade is difficult or impossible, H-Grid Not Matching is the best choice for such situations.

The GGI interface is created near the mean camber line of the blade, rather than around the peri-

meter. This has the advantage of reducing the GGI surface area and the curvature of the GGI surfaces.

It is also coincident in the tip-to-shroud direction to reduce errors, and is located away from regions

of large flow gradients (i.e., away from the large gradients that occur at the passage/tip junction.

Important

If importing a grid with a non-matching interface into CFX-Pre, you will need to set up the

interface manually when you define the pre-processing for your simulation. Refer to the

Domain Interfaces section of the CFX-Pre documentation for details.

10.4.2.1.1.6. Preserve Control Points on Layers

The Preserve Control Points on Layers option, when selected, will cause the customized relative dis-

placements of added local control points to be preserved if and when the topology block distribution

changes.

10.4.2.1.1.7. Periodicity

Control the behavior of periodic topological vertices and mesh nodes using one of two methods for

Projection:

• Float on Curves limits the periodic vertices and nodes to lie on the curve formed by intersecting

the span surface (at the specified location), and the periodic surface.

• Float on Surface is the default method, and will allow periodic vertices and nodes to float on the

span surface. The result is a topology and mesh which has less stretching between blades and improved

skewness properties along the periodic boundary.

10.4.2.1.2. Advanced Parameters Tab for Topology Objects

The Advanced Parameters tab exists for every blade topology object.
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Note

For a case with multiple blades, if you perform any of the following actions:

• Freeze the topology

• Manually lock one or more of the advanced parameters for a splitter blade

• Load a topology from a file

and subsequently, when attempting to change the topology, you encounter an error message

about topology settings, then there is likely a problem due to the splitter blade advanced

parameters being locked. In this case, for each splitter blade, go to the Advanced Parameters

tab and clear all the check boxes that have "Override" in the name, then click Apply. You

should then be able to successfully change the topology.

10.4.2.1.2.1. H/J/C/L Topology Definition

(applies only for topologies of type H/J/C/L-Grid)

The topology type settings used for the upstream and downstream ends of the passage are shown in

the drop-down boxes. When the override is turned off, the settings are determined automatically. When

the override is turned on, the settings are manually adjustable.

When the One-to-one Interfaces: Periodic Range option on the Definition tab of the Topology
Set object is not set to Full, the upstream and/or downstream ends that do not have 1-to-1 periodicity

can have a topology of type L-Grid, provided that there is only one blade. L-Grid topologies are not

supported for multiple-blade systems. An example of a topology of type L-Grid is shown in Figure

10.11 (p. 107).
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Figure 10.11  Topology of Type L-Grid

For topology types J-Grid and L-Grid, the orientation of the bend is automatically chosen as that which

produces the smallest bending angle.

C-Grid is another available topology type for the leading and/or trailing edges when H/J/C/L Topo-
logy is selected. Before you can set the topology type for the leading or trailing edge to C-Grid, you

must select the H/J/C/L Topology Definition > Override default parameters check box. An example

of a topology of type C-Grid is shown in Figure 10.12 (p. 108).
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Figure 10.12  Topology of Type C-Grid

H-Grid Dominant is another available topology type for the leading and/or trailing edges when H/J/C/L
Topology is selected.

If you specify a topology of type H/J/C/L-Grid, ANSYS TurboGrid assigns default topology types for

the upstream and downstream ends as follows:

1. The blade metal angle is calculated at the span location of the topology (set on the Advanced Para-

meters tab) by linearly interpolating from the corresponding angles at the hub and shroud.

2. If this angle is greater than 60° and 1-to-1 periodicity is not set for that upstream/downstream end, a

topology of type L-Grid is used; otherwise if the angle is greater than 45°, a topology of type J-Grid is

used; otherwise a topology of type H-Grid is used.

10.4.2.1.2.2. Blade Blocks Calculation

The Blade Blocks Calculation settings define the number of topology blocks along each side of the

blade from the leading edge to the trailing edge. In the case of multiple blades per blade set, these

settings are available only for the first blade in the set.

The number of blocks is the starting point which ANSYS TurboGrid uses to create a topology. The

driving force for topology creation is to approach isotropy and orthogonality, meaning that each block

is as close to having equal lengths and right angles as possible. The entered value for # of Blocks is

treated as a target, but may not exactly match the resulting topology. In most cases, the number of

blocks in the topology is quite close to the number of blocks defined.

Specify the blade block distribution using a uniform or non-uniform method. If you select non-uniform,

enter a target value for the number of constant blocks (Const Blocks), which determines a target for

the number of the blocks which have a uniform distribution (the actual number may not be the same
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as the target value). If set to zero (default), the maximum number of constant blocks is automatically

calculated.

10.4.2.1.2.3. Blade to Periodic/Inlet/Outlet Surface Block Distribution

These options are for specifying the block count from the blade to the following surfaces:

• Periodic Surface

• Inlet

• Outlet

In the case of multiple blades per blade set, the blade to inlet and blade to outlet settings are available

only for the first blade in the set.

Block Count

The Block Count parameter is the most basic parameter for controlling the number of topology blocks

between the blade and the applicable surface (periodic, inlet, or outlet). The availability of this parameter

is dependent on other topology settings.

Blade to Inlet Surface Block Distribution: Extra at LE

(applies for H/J/C/L-Grid topology when topology type J-Grid is applied at the leading edge)

The Extra at LE option causes the specified number of rows of topology blocks to be added. The added

rows extend from the inlet to the periodic surface that makes an acute angle with the inlet (as measured

in the local plane of the layer on the inside of the layer outline). The rows pass by, and touch, the

leading edge O-Grid (or the leading edge itself, if no O-Grid exists), increasing the number of topology

rows between the blade and the inlet.

Blade to Outlet Surface Block Distribution: Extra at TE

(applies for H/J/C/L-Grid topology when topology of type J-Grid is applied at the trailing edge)

The Extra at TE option for Blade to Outlet Surface Block Distribution is analogous to that for Blade

to Inlet Surface Block Distribution.

10.4.2.1.2.4. Sharp Leading/Trailing Edges

To improve mesh orthogonality, ANSYS TurboGrid automatically adapts the topology for sharp lead-

ing/trailing edges.

Figure 10.13 (p. 110) shows the effect of the sharp edge treatment on the topology near a blade edge.

Note that the sharp edge treatment improves element face angles in the refined mesh.
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Figure 10.13  No Sharp Edge Treatment versus Sharp Edge Treatment

For blade edges that are slightly blunt, you may want to manually control whether a sharp edge treatment

is applied or not applied. For the leading edge, do the following:

1. Select the Override Sharp LE Determination check box.

2. Select or clear the Sharp Leading Edge check box to force the sharp edge treatment to be applied

or not applied.

The trailing edge settings work similarly.

Note that the sharp edge treatment is not supported for cut-off edges.

10.4.2.1.2.5. O-Grid Corner Vertices

For a cut-off or square blade edge, the two vertices at the end of an O-grid can be positioned using

two different methods which are explained next, and illustrated in Figure 10.14 (p. 111):

• At Same AR

This option causes the O-Grid end vertices to be positioned at the same axial and radial coordinates

as the blade end.

• Project to OGrid

This option causes the O-Grid end vertices to be positioned at the projected locations of the blade

end corners, with projections being outward from the blade in a direction normal to the O-Grid.
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Figure 10.14  O-Grid Corner Vertex Placement: At Same AR versus Project to OGrid

10.4.2.1.3. Span Location for Controlling Topology

The span is the distance between the hub and shroud, expressed as a fraction between 0 and 1. The

span is calculated when m’-Theta coordinates are created. For details, see Transformation Commands

and Coordinate Systems (p. 143).

ANSYS TurboGrid uses a span parameter for several reasons related to topology, including:

• Obtaining blade metal angles so that ANSYS TurboGrid can automatically set topology types after you

have specified the topology method: H/J/C/L-Grid.

• Calculating an appropriate number of topology blocks between the blade and the periodic interface

or interface between blades.

By default, the span location is set to 0.5 (that is, 50% of the span). To adjust the span parameter,

called Span Location, edit the Topology Set object using the Command Editor dialog box.

10.4.2.1.4. Freeze Button

In the course of creating a mesh, after you have decided on a topology type, you can freeze (make

static) the topology advanced parameters by doing either of the following:

• Clicking the Freeze button, which is in the object editor for the Topology Set object and any blade-

specific topology object. This freezes all topology advanced parameters for all blade-specific topology

objects.

• Turning on all of the overrides manually on the Advanced Parameters tabs of all blade-specific topology

objects.

If any of the topology advanced parameters are not static (that is, they do not have overrides turned

on), they will be recalculated if any geometry object is loaded or changed. This could result in an un-

wanted change to the topology.

Geometry changes include:

• Loading a different hub, shroud, or profile curve

• Moving an inlet or outlet point (for example, inlet low shroud point)
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• Saving a state file on one computer and then restoring the state on another (the effect of round-off

differences)

Since changes to topology can destroy local control points, ensure that topology advanced parameters

are frozen.

Note

When the H-Grid Dominant topology type option is selected, the “freeze” in topology

is accomplished by saving the topology to a file and then loading it. This is performed semi-

automatically; you only need to provide the file name for the topology file. In this case, upon

loading the topology, the method will change to From File and, as usual for that method,

the overrides on the Advanced Parameters tab will be permanently selected.

10.4.2.2. Topology with Cut-off or Square Leading or Trailing Edges

10.4.2.2.1. Using the Cut-off or Square Option

The blade geometry object allows leading and trailing edges to be specified as “cut-off or square” (For

details, see Cut-off or square (p. 83).). This option can affect the topology.

Figure 10.15 (p. 112) shows an example of how the Cut-off or Square option causes an O-Grid to

be truncated from the end of the blade, starting at the pair of edge curves.

Figure 10.15  Cut-off Trailing Edge using Topology of Type H-Grid with O-Grid

The Cut-off or Square option can also be used for a topology with no O-Grid present. In this case, the

topology points surrounding the blade edge will be constrained to lie on the edge curves.
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10.4.2.2.1.1. Automatic Generation of Edge Split Controls

When a “cut-off or square” edge is used (or when a topology of type C-Grid is used), ANSYS TurboGrid

automatically adds edge split controls just off the end of the blade in order to improve element size

matching in that region. The edge split controls are found under the Mesh Data object. If you open

one of the automatically-created edge split controls in the object editor, you will see that the Automat-

ically computed split factor check box is selected by default. When selected, this check box causes

the edge split value to be calculated automatically. To override the Split Factor setting, clear the check

box. The Split Factor setting is multiplied by the global block edge split count in order to determine

the local block edge split count. For details about edge split controls, see Edge Split Controls (p. 121).

10.4.2.2.2. Using the Line of Rotation on Hub and Shroud Option

When the Line of Rotation on Hub and Shroud option is selected in the Blade Set object, certain

topology points on the hub and shroud layers are constrained to lie on lines of rotation (about the

machine axis) starting from the cut-off edges.

The topology points that are affected are those on the topological paths between the cut-off edges of

the blade and the periodic surfaces. When this option is applied, these points are constrained to lie on

the line of rotation, about the machine axis, of the corresponding cut-off edge point. As a result of this

added constraint, the affected topology points lose 1 degree of freedom; those on the periodic surfaces

and O-Grid (if applicable) become fixed, while the remaining affected topology points become constrained

to the line of rotation.

Only topologies of type H-Grid are affected by this option, including the H-Grid portion of a topology

of type H/J/C/L-Grid or H-Grid Dominant.

10.5. Mesh Data

To define the mesh properties for the entire mesh, edit the Mesh Data object from the object selector

or click Edit Mesh Data . To define or modify the mesh properties of a blade-specific portion of the

mesh, edit the corresponding object stored under the Mesh Data object.

Defining the Mesh Data object does not create the mesh. The mesh data can only be set after the

topology has been defined, but it is recommended that you set the required mesh size before you

create the layers (discussed later), because the true mesh nodes are displayed on the topology layers

as the topology is adjusted. For details on creating a mesh, see Steps to Create a Mesh (p. 71) and Mesh

Command (p. 31).

10.5.1. The Mesh Data Objects

The Mesh Data object contains settings that affect the mesh globally. The individual blade mesh data

objects (stored under the Mesh Data object in the object selector) contain a subset of the settings

of the Mesh Data object, and affect the mesh for individual blades in the blade set.

10.5.1.1. Mesh Size Tab

The Mesh Size tab is applicable to the Mesh Data object.

10.5.1.1.1. Method

The Method setting controls the mesh density, and can be set to one of the following:
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• Target Passage Mesh Size

The Target Passage Mesh Size method sets a target for the number of nodes in the mesh

passage. The pre-set options for the Node Count setting are Coarse (20000), Medium
(100000), and Fine (250000). There is also an option, Specify, to specify the target number

of nodes.

ANSYS TurboGrid attempts to reach the target number of nodes by:

– Adjusting the number of elements placed along each topology block edge (This can be viewed after

pressing Apply by changing the method to Topology Block Edge Split or Global Size
Factor as applicable.)

– Adjusting the number of elements from hub (or hub tip) to shroud (or shroud tip) if these have not

been explicitly set.

• Topology Block Edge Split (Traditional topology only)

The Topology Block Edge Split method defines how fine the mesh is on each layer. Enter

the value for the number of elements placed along each topology block edge. For example, if you

set # of Elements to 2, there are two elements placed along each topology block edge.

The topology block edge split can also be controlled locally. For details, see Edge Split Controls (p. 121).

• Global Size Factor (ATM topology only)

The Global Size Factor method defines the overall mesh size. To increase the resolution of

the mesh, increase the size factor using the Size Factor setting.

10.5.1.1.2. Boundary Layer Refinement Control

In the context of the Boundary Layer Refinement Control settings, the boundary layer is represented

by the set of topology blocks along the pressure and suction sides of the blade.

The available Method options for boundary layer refinement control are:

• Proportional to Mesh Size

• Edge Refinement Factor

• First Element Offset

10.5.1.1.2.1. Proportional to Mesh Size

The Proportional to Mesh Size option controls the number of elements across the boundary

layer in proportion to the specified values for Factor Base and Factor Ratio. If the blade has a cut-off

edge, Factor Ratio also controls the number of elements along the cut-off edge. Increasing the Factor

Base or Factor Ratio increases the number of elements across the boundary layer and along the cut-

off edge (if applicable). Conversely, decreasing the value of Factor Base or Factor Ratio decreases the

number of elements.

10.5.1.1.2.2. Edge Refinement Factor

The Edge Refinement Factor option does not maintain an O-grid expansion rate similar to

Proportional to Mesh Size when the global size factor is changed, and therefore the edge

refinement factor may need to be adjusted when the mesh size is changed. Increasing or decreasing

the edge refinement factor will increase or decrease the mesh resolution in the O-grid, respectively.
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10.5.1.1.2.3. First Element Offset

The First Element Offset option controls the near-wall height for elements. ANSYS TurboGrid

uses the near-wall height to compute the edge refinement factor. The specified Offset value and the

actual offset may differ. The elements near the surface of the blade will not all have a constant height,

but they will generally be at or less than the specified Offset value, which is treated as a maximum.

The Method can be set to either y+ or Absolute.

10.5.1.1.2.4. Cutoff Edge to Boundary Layer

The Cutoff Edge To Boundary Layer setting controls the number of elements along the cut-off edge

in proportion to the specified Factor. The number of elements along the cut-off edge is also propor-

tional to the number of elements across the boundary layer. Increasing the Factor increases the number

of elements along the cut-off edge. Conversely, decreasing the Factor decreases the number of elements

along the cut-off edge.

10.5.1.1.2.5. Five-Edge Vertex Mesh Size Reduction

An ATM-based mesh may contain one or more vertices that each join exactly five edges. At these loca-

tions, the mesh generation process will tend to pull the mesh away from the five-edge vertex to make

the surrounding element edges more orthogonal, resulting in relatively larger elements surrounding

the vertex than the rest of the mesh in their vicinity. The Five-Edge Vertex Mesh Size Reduction >

Factor setting, when set to a value less than 1.0, will reduce this tendency, trading off between mesh

orthogonality for sizing.

10.5.1.1.2.6. Near Wall Element Size Specification

The Near Wall Element Size Specification setting controls the method by which the near-wall node

spacing is specified on the Passage and Hub/Shroud Tip tabs. The near-wall node spacing is the distance

between a wall (e.g., hub, shroud, or blade) and the first layer of nodes from the wall.

The available Method options for calculating the near wall spacing are:

• y+

For details, see Y Plus (p. 116).

• Normalized
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For details, see Normalized (p. 116).

• Absolute

For details, see Absolute (p. 116).

10.5.1.1.2.6.1. Y Plus

The y+ method allows you to set the near wall spacing, �, in accordance with a target value of 
+
� .

The target value of 
+
�  may then be specified on the Passage and Hub/Shroud Tip tabs, as applicable

(i.e., when a near wall size is required by the specified distribution method).

The following formula relates the near wall spacing to 
+
� :

(10–1)= +
� � � � �

� �
�

	


�
�

where 
 is the blade chord,
+
�  is the specified target y+ value, � �� is the Reynolds number based

on the distance along the chord (measured from the leading edge), and � �� is the Reynolds number

based on chord length. ANSYS TurboGrid approximates � as the algebraic average of the chord lengths

of each blade profile in the blade file. You must specify � ��. ANSYS TurboGrid approximates � �� as

being equal to the specified value of � ��.

Note

If you specify a near wall size (on the Passage or Hub/Shroud Tip tab) when the near wall

method is not 
+
� , you can switch the method to y+ (at least temporarily) to see the estimated

value of 
+
  as a setting on the Passage or Hub/Shroud Tip tab.

10.5.1.1.2.6.2. Normalized

The Normalized method allows you to set the near wall spacing as a normalized value. Normalization

is interpreted as the absolute distance divided by the maximum possible distance. The latter is one of

the following, as appropriate:

• boundary layer thickness

• distance from hub (or hub tip, if it exists) to the shroud (or shroud tip, if it exists)

• thickness of the O-Grid

• distance from the hub tip to the hub, or shroud tip to the shroud.

10.5.1.1.2.6.3. Absolute

The Absolute method allows you to set the near wall spacing directly. Such a specification (i.e., on

the Passage or Hub/Shroud Tip tab) requires a dimensional value with units of distance.
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10.5.1.1.3. Inlet Domain and Outlet Domain Check Boxes

The Inlet Domain and Outlet domain check boxes determine whether or not the inlet and outlet do-

mains are to be generated as part of the mesh. Settings that affect these grid regions are found on the

Inlet/Outlet tab.

10.5.1.2. Passage Tab

The Passage tab is applicable to the Mesh Data object, and is used to specify distribution settings.

Distribution settings are described generically in Distribution Settings in General (p. 119).

10.5.1.2.1. Spanwise Blade Distribution Parameters

Use the Spanwise Blade Distribution Parameters section to control the distribution of mesh elements

in the spanwise direction along the blade.

The Method setting and its associated settings are described in Distribution Settings in General (p. 119).

10.5.1.2.2. Apply O-Grid Parameters To All Blades / O-Grid

The O-Grid section (for single-blade cases) and Apply O-Grid Parameters To All Blades section (for

multiple-blade cases) describe distribution of the nodes in the O-Grid, outward from the blade surface.

The section is available if an O-Grid is defined for any blade. To include an O-Grid in the mesh, see Include

O-Grid (p. 103).

The Method setting and its associated settings are described in Distribution Settings in General (p. 119).

The Distance setting controls how the O-Grid distance varies from hub to shroud, and has the following

options:

• Proportional to Radius

Using the Proportional to Radius method (which is default), the O-Grid distance from hub

to shroud is proportional to the average span radius. This may result in the O-Grid distance increasing

in size from hub to shroud.

• Proportional to Width

Using the Proportional to Width method, the O-Grid distance from hub to shroud is pro-

portional to the average span blade thickness.

• Constant

Using the Constant method, the O-Grid distance is constant from hub to shroud.

10.5.1.3. Hub Tip and Shroud Tip Tabs

The Shroud Tip tab is available when a shroud tip exists; the Hub Tip tab is available when a hub tip

exists. See The Hub Tip and Shroud Tip Objects (p. 86) for details on defining the shroud (or hub) tip.

These tabs are applicable to the Mesh Data object, and are used to specify distribution settings.

10.5.1.3.1. Hub Tip Distribution Parameters and Shroud Tip Distribution Parameters

Use these settings to control the distribution of mesh elements in the spanwise direction across the tip

gap.
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Set Method to one of the following:

• Match Expansion at Blade Tip

• Element Count and Size

• Uniform

These methods are described in Distribution Settings in General (p. 119).

10.5.1.3.2. Apply Blade Tip Parameters to All Blades Check Box

The type of topology for the blade tip is selected on the Definition tab of the topology object (see Tip

Topology (p. 104)). When using the H-Grid or H-Grid Not Matching topology types, you may edit

the number of elements across the blade thickness by selecting Override default # of Elements, then

setting the appropriate value(s) for the number of mesh elements. The settings that are available depend

on the type of tip topology (set in the applicable topology object). The following list contains topology-

specific information about the settings:

• H-Grid

Set # of Elements to indicate the number of elements across the blade thickness away from the

leading edge and trailing edge. This should be an even number.

Set # of LE Elements/# of TE Elements to indicate the number of rows in the butterfly mesh that

fills the leading/trailing edge. This number must be at least 2 less than the # of Elements since

the difference divided by 2 becomes the number of columns in the butterfly mesh.

• H-Grid Not Matching

Set # of Elements to indicate the number of elements across the blade thickness away from the

leading edge and trailing edge.

10.5.1.3.2.1. Tip Centerline Location

The Tip Centerline Location setting is available when the following conditions are met:

• The corresponding blade tip, hub or shroud, exists.

• The tip topology is set to H-Grid Not Matching.

• The corresponding edge of the blade, leading or trailing, is cut off.

The setting controls how the blade centerline behaves at the cut-off end. The options are:

• Automatic

Effectively selects one of the other two methods automatically, based on the geometry. If one of

the corners of the cut-off edge is at a sufficiently acute angle (default is 45°), then the Corner
option is selected, otherwise the Middle option is selected. The threshold angle can be set by

defining the parameter GGI Tip Angle To Switch Mean Line Into Cut Off Corner
(to an angular value; default unit is [degree]) in the CCL for the blade-specific mesh data object.

• Middle

The centerline meets the cut-off blade edge in the middle (between the corners).

• Corner
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The centerline meets the corner of the cut-off blade edge.

10.5.1.4. Distribution Settings in General

The distribution of elements along the blade (in the spanwise direction) is controlled by one of these

methods:

• End Ratio

The End Ratio method is default. Specify an end ratio, which is the ratio of the largest element

size (measured in the pertinent direction) to the element size at the pertinent wall. All other para-

meters that affect the distribution (i.e., those for the Element Count and Size method) will

be set automatically. The advantage of using the End Ratio method is that a change in mesh

density will result in a self-similar mesh.

• Element Count and Size

To use the Element Count and Size method, specify the number of elements that span the

pertinent extent and whether the distribution is uniform or non-uniform. If the distribution is non-

uniform, you must also specify the number of uniformly-distributed elements (Const Elements)

and the element size next to the pertinent wall(s).

• Boundary Layer

To use the Boundary Layer method (not applicable for O-Grid settings), specify distribution

parameters for three sections: boundary layer at the hub, boundary layer at the tip/shroud, and

the section in between. Layer Offset means the thickness of the boundary layer and Wall Offset

means the thickness of the first element next to the wall.

• Expansion Rate

To use the Expansion Rate method, specify an expansion rate and the element size next to

the blade wall.

• Uniform

To use the Uniform method, specify the number of elements. Each element is the same size.

Note

The Const Elements value cannot be negative and must be at least 2 less than the

# of Elements value for that region.

The distribution of elements across a tip gap (in the spanwise direction) is controlled by one of these

methods:

1. Match Expansion at Blade Tip

The Match Expansion at Blade Tip method is default. This method will apply the same

expansion factor as that used along the blade span, and will match the size of the elements on

each side of the tip clearance gap with the size of the first element along the blade. An appropriate

number of elements is then derived.

2. Element Count and Size

(described above)
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3. Uniform

(described above)

When using the End Ratio method, the element count and wall size(s) are updated accordingly in

the Element Count and Size settings (When two wall sizes are adjusted, they are adjusted to the same

value.). When using the Element Count and Size method, the End Ratio setting is updated ac-

cordingly.

In the case of an O-Grid distribution, the Blade End Ratio is the size ratio of the passage mesh element

nearest the O-Grid to the O-Grid element nearest the blade surface. A special feature of the distribution

settings for O-Grids is that, if # of Elements is set to 0, the number of elements will be calculated

automatically so that the best possible matching of element sizes at the interface between the O-Grid

and the passage is ensured.

Size of Elements Next to Wall (Normalized) is normalized based on the total distance along the blade

(not counting any tip clearance gaps). For example, on the Hub Tip tab, a value of 0.05 for Size of

Elements Next to Wall (Normalized) > Hub represents an element size of five percent of the distance

along the blade, applied on the elements next to the hub, and a value of 0.05 for the Size of Elements

Next to Wall (Normalized) > Tip represents an element size of five percent of the distance along the

blade, applied on the elements next to the hub end of the blade (both in the tip clearance gap and on

the blade).

Note

The Size of Elements Next to Wall (Normalized) value must be less than 1 (unity) divided

by the number of elements for that region. If it is not, ANSYS TurboGrid decreases it to meet

this criterion.

To increase the quality of the mesh, try to minimize drastic changes in element size. Wherever

possible, attempt to have gradual increases and decreases in element size in all directions.

10.5.1.5. Inlet/Outlet Tab

The geometries of the inlet and outlet domains of the mesh are controlled by the hub and shroud

curves, and the Inlet and Outlet geometry objects. For details, see The Hub and Shroud Objects (p. 76)

and The Inlet and Outlet Objects (p. 88).

The Inlet/Outlet tab contains settings that affect the mesh in the inlet and outlet domains. The Inlet

Domain and Outlet domain check boxes on the Mesh Size tab of the Mesh Data object determine

whether or not the inlet and outlet domains are to be generated as part of the mesh.

The nodes of the inlet and outlet domains match one-to-one with the nodes of the passage domain

where they meet at the interfaces. The rest of the mesh in the inlet domain is then as near to being

isotropic and orthogonal as possible.

10.5.1.5.1. Inlet Domain and Outlet Domain Settings

Setting Mesh Type to H-Grid (default) or H-Grid in Parametric Space specifies an H-Grid

type mesh in the inlet/outlet domain that preserves the boundary layer mesh resolution at the hub and

shroud, and automatically matches the element size at the interface between the inlet/outlet domain

and passage domain. In this case, the streamwise distribution of elements is non-uniform. The # of

Elements setting controls the number of elements in the inlet/outlet domain in the streamwise direction.
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If the number of elements is 0, the number of elements in the inlet/outlet domain is determined by

matching the element size at the passage interface and expanding the size at a prescribed rate for each

successive element. The default element size ratio is 1.15.

When Mesh Type is set to H-Grid in Parametric Space, the resulting mesh will try to follow

a parametric space created by an elliptic smoothing method. This type of mesh is particularly suitable

for return channels.

Important

Clicking the Apply button does not create the mesh, it only saves the Mesh Data object

and updates the 2D mesh previews. To create the mesh, select Insert > Mesh from the main

menu or click Create Mesh .

Note

The number of elements is a starting point and the actual mesh may vary slightly if it results

in a better mesh quality.

10.5.1.6. Mesh Around Blade Tab

The Mesh Around Blade tab is applicable to the blade-specific mesh data objects.

The O-Grid settings on this tab are the same as the O-Grid settings on the Passage tab for the Mesh
Data object, except they are blade-specific. For details, see Apply O-Grid Parameters To All Blades / O-

Grid (p. 117).

The Size of Elements Next to Wall (Normalized) setting is described in Distribution Settings in Gener-

al (p. 119).

The Hub Tip, and Shroud Tip settings are for controlling the number of elements across the hub or

shroud tip gap. They are similar to the settings on the Hub Tip and Shroud Tip tabs for the Mesh
Data object. For details, see Apply Blade Tip Parameters to All Blades Check Box (p. 118).

10.5.1.6.1. Tip Centerline Location

For details, see Tip Centerline Location (p. 118).

10.5.2. Edge Split Controls

The number of elements placed along each topology block edge is globally controlled by the Mesh

Size tab for the Mesh Data object. This value can be scaled locally by right-clicking a topology block

edge and then selecting Insert Edge Split Control. This causes an editor to appear for edge

split controls. It also causes all affected topology block edges to become highlighted with red lines.

After entering a scale factor (the Split Factor setting) to multiply the default block edge split and then

clicking Apply, the affected topology block edges are updated. To see the result, turn on the visibility

of the refined mesh.

After applying a local edge split control, a new object is created and stored under Mesh Data in the

object tree. This object may be edited or deleted in order to change or remove the local edge split

control.
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10.6. Layers

A layer shows the topology projected onto a given span. The addition of layers improves the 3D mesh

by adapting the topology to the local geometry before mesh generation. Creating (and adjusting if

necessary) additional layers enhances the quality of the mesh by creating a curve for the mesh to follow

between the hub and the shroud. The more complex the blade shape-change from hub to shroud, the

more layers will be required. The main user task in ANSYS TurboGrid is the adjustment of control points

(discussed later in this section) to alter the topology on various layers (mainly the hub and shroud layers).

By default, and as a minimum, there are two layers present: one at the hub and one at the shroud. In

many cases, additional layers are required to improve mesh quality.

10.6.1. Adding Layers

Layers can be added from the editor for the Layers object (see The Layers Object (p. 123)), or by right-

clicking a layer object in the selector, and selecting the appropriate command from the Insert submenu

of the shortcut menu. Layers can also be added automatically at the time of mesh creation (default),

depending on a setting found in the editor for the Layers object.

10.6.2. Deleting Layers

The object selector and the editor for the Layers object (The Layers Object (p. 123)) each have an icon

to delete layers ( ) as well as a shortcut menu option for deleting layers.

10.6.3. Editing the Settings of Layers

The editor for the Layers object (The Layers Object (p. 123)) and the editor for layer objects (Layer Ob-

jects (p. 126)) are used to control various properties of layers.

10.6.4. Layer Visibility

There are visibility check boxes next to each layer listed in the object selector. By right-clicking a layer

object, a shortcut menu will appear, allowing the following visibility options as applicable:

• Show

Makes the layer visible.

• Show + Hide All Siblings

Makes the layer visible and turns off the visibility of all other layers.

• Hide

Turns off the visibility of the layer.

The visibility of a layer can also be controlled by the visibility settings in the individual layer objects.

To change which parts of a layer are visible, select the layer(s) from the object selector, then right-click

on the selection and select an appropriate render option from the shortcut menu. For details, see

Master Topology Visibility (p. 126), Topology Visibility (p. 126), and Refined Mesh Visibility (p. 126).
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10.6.5. The Layers Object

The Layers object is used to control the individual layer objects. You can access the Layers objects

in the object selector.

10.6.5.1. Layers Tab

A number of possible operations are available for a layer by clicking it in the list box and then selecting

one of the icons on the right of the list box, or by right-clicking the object and then selecting an oper-

ation from the shortcut menu.

10.6.5.1.1. New Layer

Clicking New Layer  (or right-clicking a layer and selecting New Layer) creates a new layer at the

most suitable span location as determined by ANSYS TurboGrid.

10.6.5.1.2. Delete Selected Layers

Clicking Delete Selected Layer(s)  removes the selected layer(s). Hold Shift or Ctrl to select multiple

layers to delete. You cannot delete the hub or the shroud layers.

10.6.5.1.3. Inserting Layers Automatically

Clicking Auto Add Layers  in the editor for the Layers object, or selecting Insert > Layers Auto-

matically from the shortcut menu for a layer object, causes ANSYS TurboGrid to insert layers automat-

ically, using built-in heuristics to determine an appropriate number of layers to insert, and the location

of each layer. The number of layers that ANSYS TurboGrid proposes to add is shown in the editor for

the Layers object.

Selecting Insert > Layer Automatically from the shortcut menu for any layer object will cause ANSYS

TurboGrid to insert one layer automatically using built-in heuristics to determine an appropriate location.

The position of the inserted layer does not depend on which layer object you right-click to access the

shortcut menu.

10.6.5.1.4. Insert Layer After Selected Layer

The Insert Layer After and Insert > Layer After Selected Layer shortcut menu items will cause a new

layer to be created at the span halfway between the selected layer and the next layer. For example, if

the only existing layers are on the hub and the shroud, and Insert > Layer After Selected Layer is

selected from the hub, ANSYS TurboGrid inserts the new layer at a span of 0.5.

10.6.5.1.5. Span Location

The span location of a layer can be modified in the Span Location box.

10.6.5.2. Advanced Parameters Tab

10.6.5.2.1. Automatically generate required layers at mesh creation

If you leave Automatically generate required layers at mesh creation turned on, then, upon creating

a mesh, ANSYS TurboGrid will check to see if the number of layers is adequate (according to its recom-
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mended number of layers). If the current number of layers is deemed to be inadequate, new layers will

be added automatically (before the mesh is generated) and a notification that layers are being added

will appear in the status bar in the lower-left corner. The number of layers that ANSYS TurboGrid proposes

to add is shown in the editor for the Layers object.

Note

The recommended number of layers is a recommendation based on blade shape, size of the

topology around the blade, proximity of inlet/outlet, and so on. As such the recommendation

is not always reliable.

10.6.5.2.2. Leading And Trailing Edge O-Grid Control Points

This option controls the constraint on the control point found at the leading or trailing edge of a layer

on the outside edge of the O-Grid (provided that an O-Grid exists, and that the leading/trailing edge

is not Cut-off or square or Line of rotation on hub and shroud, as specified in the editor for the

blade).

The following methods are available:

• Point

The point will be entirely constrained.

• Curve

The point will be allowed to move along the outer edge of the O-Grid.

• Surface

The point will be allowed to move freely within the layer.

10.6.5.2.3. Default Control Point Type

This setting controls the type (Local or Master) of control points that are added. After a control point

has been added, its type can be changed. For details, see Change control point type to Master (p. 128)

and Change control point type to Local (p. 128).

10.6.5.2.4. Orthogonality Factors

The Orthogonality Factors settings control how the elements are distributed along the blade surface

for the hub or shroud layer. The values range from 0, meaning that the topology is aligned across the

blade, to 1, meaning that the orthogonality of the passage mesh with respect to the blade is maximized

(possibly at the expense of orthogonality across the blade). The orthogonality factors are interpolated

to the intermediate layers using the values at the hub and shroud layers.

Another way to control the distribution of elements along the blade surface is to manually add and

move control points along the blade surface. For details, see Added Control Points (p. 131). Due to the

influence of orthogonality factors, though, such manual control of the element distribution can be re-

stricted, especially near the blade leading and trailing edges, and when the displacements of the control

points are large.
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10.6.5.2.5. Floating the Leading and Trailing Edges on the Blade

The Float leading and trailing edges on blade option lets the O-Grid slide around the leading and

trailing edges for better mesh quality on highly-twisted blades. Although it is possible to obtain similar

results by adjusting the leading/trailing edge curves, it is more convenient to use this topology feature.

To cause the O-Grid to slide around the leading or trailing edge:

1. Select the Float leading and trailing edges on blade option on the Advanced Parameters tab of

the Layers object and click Apply.

2. Introduce a master control point on the O-Grid, directly in front of the leading edge or behind the

trailing edge, as applicable.

Note that “cut-off or square” edges and sharp edges, have no such part of the O-Grid. The Float

leading and trailing edges on blade option is only applicable for blades with single leading/trail-

ing edge curves on edges that are not sharp.

3. Move the master control point along the O-Grid.

The refined mesh will show that the mesh slides around the leading/trailing edge.

Note

The mesh may shift slightly on the blade when you select the Float leading and

trailing edges on blade option, even if you have not moved any control points.

The figure below shows the effect of selecting the Float leading and trailing edges on blade

option on the leading edge of a highly-twisted blade. The left side shows the option turned off,

and the right side shows the option turned on. Note the distribution of elements on the blade,

as shown by the refined mesh.
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10.6.6. Layer Objects

You can access the layer objects under the Layers object in the object selector.

10.6.6.1. Data Tab

10.6.6.1.1. Master Topology Visibility

Clicking in the box will toggle the visibility of the master topology. The master topology is shown as

violet line segments that connect the default master control points (not any added ones).

You can also change the Master Topology Visibility setting from the shortcut menu after selecting

and right-clicking the layer(s) in the object selector, or right-clicking a layer in the viewer.

10.6.6.1.2. Topology Visibility

Clicking in the box will toggle the visibility of the topology. The topology is shown as yellow line seg-

ments.

You can also change the Topology Visibility setting from the shortcut menu after selecting and right-

clicking the layer(s) in the object selector, or right-clicking a layer in the viewer.

10.6.6.1.3. Refined Mesh Visibility

Selecting Refined Mesh Visibility causes the refined mesh to appear in the viewer.

You can also change the Refined Mesh Visibility setting from the shortcut menu after selecting and

right-clicking the layer(s) in the object selector, or right-clicking a layer in the viewer.

When Refined Mesh Visibility is selected, the following refined-mesh quality statistics—Mesh Meas-

ure—are available for viewing:

• Minimum Face Angle

• Maximum Face Angle

• Maximum Aspect Ratio

To display problem areas in the refined mesh, double-click one of the Mesh Measure statistics in the

list. Figure 10.16 (p. 127) shows an example of problem areas, shown with thick red lines, for the Minim-
um Face Angle statistic.
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Figure 10.16  Refined Mesh Showing Areas of Unacceptable Minimum Face Angle

The Mesh Limits object holds the criteria that determine if the Mesh Measure statistics are acceptable.

If, for a given layer, Refined Mesh Visibility is turned on and either the Minimum Face Angle or

Maximum Face Angle is outside the applicable limit, the layer will be listed in red text in the selector

tree.

10.6.6.2. Control Points Tab

10.6.6.2.1. User Control Points

Toggles the application of all modifications to control points.

10.6.6.2.2. Override default control point size factor

This option allows you to override the default size of control points as they appear in the viewer.

10.6.6.2.3. New Control Point

After selecting New Control Point , click the topology in the viewer where you want to add a control

point. A new control point (of type Local) will be created at the nearest intersection of topology line

segments (even if the topology line segments are not visible). At least one of the master topology, to-

pology, or refined mesh must be visible.
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10.6.6.2.4. New Control Points Mode

The New Control Points Mode  tool is similar to the New Control Point  tool, except that multiple

control points can be added with successive mouse clicks. To stop adding control points, select this

tool a second time.

10.6.6.2.5. Delete

The Delete  tool deletes the selected control point(s).

10.6.6.2.6. Change control point type to Master

The Change control point type to Master  tool changes the selected control point(s) to type Master.

10.6.6.2.7. Change control point type to Local

The Change control point type to Local  tool changes the selected control point(s) to type Local.

10.6.6.3. Smoothing Tab

On the Smoothing tab, the smoothing level of the refined mesh may be set to None, Low, Medium,

High, or Specify. The first 4 items correspond with 0, 1, 3, and 5 smoothing iterations respectively.

The Specify option allows you to enter the number of iterations.

10.6.7. Master Control Points

10.6.7.1. Definition and Purpose

Master control points are points that specify the location of key topology block corners on a given

layer. They can be moved to improve the quality of a mesh. Unacceptable element face angles, edge

length ratios, etc. in a particular region of a mesh can usually be eliminated by appropriately moving

one or more master control points. For example, a common adjustment is to modify the position of a

master control point on the leading edge of a blade to improve the orthogonality of the surrounding

topology blocks.

The orientation of the wake region can be adjusted by modifying the master control points on the inlet

and outlet (although it may be more beneficial to optimize the inlet and outlet control angles first. For

details, see Control Angle (p. 88).).

Another use for master control points is to concentrate mesh elements for the purpose of resolving a

flow feature. For example, certain master control points can be moved closer together in order to help

resolve a wake or shock wave.

10.6.7.2. Availability

Most topologies include master control points when they are first created. You can move, but not delete,

these master control points. Master control points can be added. For details, see Added Control

Points (p. 131).
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10.6.7.3. How to Select and Move a Control Point

You can select and move control points in the following ways:

• Select a control point by holding Ctrl+Shift, and clicking the mouse while pointing at a control point.

• Select and move a control point by holding Ctrl+Shift and dragging using the left mouse button. When

the mouse button is released, the topology and mesh will update interactively.

• If you want to reset a control point to its original position, right-click the point and select Reset Offset

from the shortcut menu.

• To select and drag control points without holding down Ctrl+Shift, you can click the Select  icon,

then select and drag control points with the left mouse button.

• You may also right-click a point and select Edit to select that point for editing.

Also see Control Point Selection and Highlighting (p. 132) and Selecting and Dragging Objects while in

Viewing Mode (p. 55).

Note

When multiple instances of the layer are displayed, any instance can be used for selecting

or adjusting control points, but only the first instance can be used for inserting control points.

Note

Moving a control point causes the mesh, if it exists, to be out-of-date. As a reminder that

the mesh must be re-created, a yellow lightning bolt appears on the Create Mesh icon (i.e.,

the icon switches from  to ). Moving a control point does not cause the deletion of

the surface objects found under the 3D Mesh object in the object selector.

10.6.7.4. Range of Influence
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Master control points can be manually adjusted in order to adjust the layout of relatively large portions

of the topology layout at a time. By contrast, local control points affect only the topology blocks that

immediately surround them. For details, see Local Control Points (p. 131).

Moving a master control point causes some of the surrounding topology blocks to be adjusted in a

way that maintains smooth trends in topology block size. This, in turn, promotes smooth trends in mesh

element size.

The topology block edges that are influenced by a given master control point depend on the location

of the latter, and are highlighted when the master control point is selected. An exception to this rule

can occur when moving master control points along the surface of the blade. For details, see Orthogon-

ality Factors (p. 124).

There are ways of restricting the range of influence of a master control point:

• The range of influence of a master control point can be reduced to extend only as far as the first topology

node encountered on a master topology line. For details, see Mixed Influence Command (p. 140).

• You can limit the range of influence of an added master control point so that it stops at another master

control point by making the latter “sticky”. To make a control point “sticky”, right-click it in the viewer

and select the Sticky menu command. For details, see Sticky Command (p. 142).

10.6.7.5. Advice on Moving Master Control Points

Before moving master control points, you may want to adjust the inlet and outlet control angles if they

are not suitable for your geometry. This can apply particularly for high angle blades. The control angle

adjustment procedure is given in Control Angle (p. 88).

It is recommended that you adjust the master control points on the hub and shroud before adjusting

those on the intermediate layers because the latter are initialized by the former. If you move control

points on either the hub or the shroud layer after creating intermediate layers then, when you attempt

to create a mesh, a message will be displayed asking if you want to re-initialize the master control

points on the intermediate layers.

If you have introduced layers and then subsequently moved master control points on the hub and/or

shroud, you will be prompted on whether or not to re-interpolate the control point positions on inter-

mediate layers. It is generally recommended that you update intermediate layers by selecting Update

& Continue.
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10.6.8. Local Control Points

Local control points can be manually adjusted in order to adjust the layout of the immediately adjacent

topology blocks. By contrast, master control points affect larger portions of the topology. For details,

see Master Control Points (p. 128).

10.6.9. Master versus Local Control Points

The difference between a control point of type Master and a control point of type Local is described

in the following table.

Control Points of Type “Loc-

al”

Control Points of Type “Mas-

ter”

represented by a sphererepresented by an octahedron

movement of the control point

influences only those topology

movement of the control point

can influence topology line

line segments in contact with

it

segments that are beyond

those in contact with it

does not preserve element size

matching across the affected

preserves element size match-

ing across the affected topo-

logy blocks topology blocks (uses uniform

element sizes)

10.6.10. Added Control Points

Sometimes it is beneficial to move topology vertices that have no associated control point. In this case,

you may be able to add a control point to such a vertex. This might be necessary, for example, near

the leading edge to get fine control of the topology distribution.

How to Add a Control Point

A control point can be added using the mouse by holding Ctrl+Shift and right-clicking a topology

vertex. Alternatively, you can add control points using the object editor as follows:

1. Open the object editor for a particular layer.

2. Click New Control Point  in the editor, then left click over the topology block corner where you

want the control point added. A number of control points can be created simultaneously on a layer

by clicking New Control Points Mode  in the editor for layer objects. Each left click will then add a

new control point. Once you have completed creating new control points, click New Control Points Mode

 a second time to exit from this mode.

Note

When multiple instances of the layer are displayed, only the first instance can be used

for adding/selecting/adjusting control points.

You might find it helpful to turn off the visibility of the hub or shroud geometry object before attempting

to add control points to the corresponding hub or shroud layer. This prevents the picking mechanism
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from picking the geometry object instead of the intended topology vertex. An easy way to turn off all

geometry objects is to select Display > Hide Geometry Objects. For details, see Hide/Unhide Geometry

Objects Commands (p. 48).

A colored symbol will be drawn where a control point is added. Move it as you would move a master

control point. For details, see How to Select and Move a Control Point (p. 129).

The color of the control point indicates its constraint:

• You can move a magenta control point in any direction on the layer.

• A yellow control point can be moved along a curve (e.g., the O-Grid boundary curve or periodic curves).

• It is not possible to move a red control point.

To delete a control point, select it in the object editor then click Delete .

The size of the control points can be edited in the object editor.

By default, an added control point is of type Local (This default can be changed by the Default Control

Point Type setting in the editor for the Layers object.). The type of a control point can be toggled

to Master (and back to Local) by double-clicking it in the list in the editor for layer objects. Changes

made in this way are specific to the current layer only. An alternative way to toggle the control point

type is by right-clicking the point in the list and using the shortcut menu. This method allows changes

to affect the current layer or all layers, depending on which command is selected. For details, see

Shortcut Menu Commands (p. 136).

10.6.11. Control Point Selection and Highlighting

To select a control point, click Select  in the viewer (if necessary), then click the control point in the

viewer. An alternative way to select a control point is to hold down Ctrl+Shift and click the point in

the viewer. For added control points, a third method is to click the appropriate entry in the list of control

points in the editor for layer objects on the Data tab. If selecting an added control point from the

viewer, the appropriate editor for layer objects will open with the entry for the control point highlighted

in the list of control points.

After Select  has been clicked, holding the mouse pointer over a control point (or any other object)

will result in the type and name of the control point (or object) appearing in the lower-left corner of

the ANSYS TurboGrid window.

After selecting a control point, the latter is shown highlighted with red lines. If any master topology

edges would be affected by a movement of the selected control point, they are highlighted with red

lines.

Also see How to Select and Move a Control Point (p. 129).

10.6.12. Saving Layers to State Files

When saving a state file that contains layers, make sure that the topology is frozen (see Freeze But-

ton (p. 111)) and included in the state file. On loading the state file, the layer information will then be

applied to the topology that existed at the time the state file was saved.
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10.6.13. Loading Layers from State Files

Before loading a state file that contains layers, reset the topology to None so that any existing topology,

layers, and control points are deleted.

10.7. 3D Mesh

The 3D mesh generated by ANSYS TurboGrid has objects associated with it. These objects are useful

for generating and examining the mesh.

10.7.1. The 3D Mesh Object

The 3D Mesh object contains a Generate button, which is enabled when it is possible to generate (or

refresh) a mesh. This button creates the mesh, and is the same as selecting Insert > Mesh from the

main menu or clicking Create Mesh .

You can open the 3D Mesh object to see node and element counts for the passage, inlet, outlet, and

the whole mesh.

10.7.2. Surface Group and Turbo Surface Objects

The 3D Mesh branch contains objects which display the mesh on geometry surfaces and turbo surfaces.

Of these display objects, only the turbo surface object Show Mesh is visible by default. To view another

surface, select the visibility check box for that object.

The mesh can be displayed only after it has been created. Changes made to the Geometry, Topology,

or Mesh Data objects will cause the mesh, and the surface objects found under the 3D Mesh object,

to be deleted. Control point movement causes the mesh to be out-of-date if it exists, but does not delete

or affect the surface objects found under the 3D Mesh object. Control point movement also causes a

yellow lightning bolt to appear on the Create Mesh icon (i.e., the icon switches from  to ) to serve

as a reminder that the mesh must be re-created, and that the 3D Mesh surface objects are no longer

up-to-date.

10.7.2.1. 3D Mesh Turbo Surfaces

The turbo surface is a flexible object that allows you to closely examine every area of the mesh. One

turbo surface exists in the 3D Mesh branch of the object selector after you create a mesh. You can

create other turbo surfaces. For details, see Turbo Surface Command (p. 36).

10.7.2.2. 3D Mesh Surface Groups

A collection of surface groups exists in the 3D Mesh branch of the object selector after you create a

mesh. For details, see Surface Groups (p. 41).

10.8. Mesh Analysis

The Mesh Analysis branch offers a variety of tools to analyze the quality of the mesh. The mesh

can be analyzed only after it has been created. If changes are made to the Geometry, Topology,

Layers, or Mesh Data objects, the mesh cannot be analyzed again until it has been recreated. For

details, see Mesh Command (p. 31).
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10.8.1. Mesh Statistics

The Mesh Statistics object provides details about the quality of the current mesh. The Mesh
Statistics object cannot be viewed until the mesh is created. For details, see Steps to Create a

Mesh (p. 71). To view the mesh statistics, double-click the Mesh Analysis object or Mesh Stat-
istics object in the object selector.

The Mesh Statistics object does not open in the object editor like the other objects in the object

selector. The Mesh Statistics object is in a window of its own so it can stay open while other

objects are edited in the object editor. This allows for constant monitoring of the statistics.

The available mesh statistics include Minimum Face Angle, Maximum Face Angle, Element
Volume Ratio, Edge Length Ratio and Connectivity Number. Statistics displayed in red

are outside the limits defined in the Mesh Analysis > Mesh Limits object. For details, see Mesh

Limits (p. 134). To display the regions where the mesh statistics are outside the limits, select the mesh

measure, then click Display. Alternatively, double-click the mesh analysis variable in the list.

Each calculated mesh measure is added to the list of available variables for creating new plots (e.g., a

contour plot).

10.8.2. Mesh Limits

The Mesh Limits object defines the acceptable values for the mesh analysis variables. These variables

are described here. The default limits are generally good and should highlight any problem areas of

the mesh.

10.8.2.1. Maximum Face Angle

This is the greatest face angle for all faces that touch the node. For each face, the angle between the

two edges of the face that touch the node is calculated. The largest angle from all faces is returned.

The maximum face angle can be considered to be a measure of skew.

10.8.2.2. Minimum Face Angle

This is the smallest face angle for all faces that touch the node.
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10.8.2.3. Connectivity Number

Connectivity Number is the number of elements that touch a node. This variable is the maximum

connectivity number on any element. For the unstructured ANSYS CFX solver, this value is not important.

However, high connectivity numbers in much of the mesh can have an adverse effect on the speed of

the structured CFX-TASCflow solver.

10.8.2.4. Element Volume Ratio

Element Volume Ratio is defined as the ratio of the maximum volume of an element that touches

a node, to the minimum volume of an element that touches a node. The value returned can be used

as a measure of the local expansion factor.

10.8.2.5. Minimum Volume

Minimum Volume is used to ensure that no negative volumes are created within the passage. The

value given is that of the minimum volume of an element touching any of the nodes.

10.8.2.6. Edge Length Ratio

This is a ratio of the longest edge of a face divided by the shortest edge of the face. For each face,

�� � � �

� � � � �

��

��

�

�

is calculated for the two edges of the face that touch the node. The largest ratio is returned. The edge

length ratio can be considered to be a measure of aspect ratio.

10.8.3. Mesh Statistics Parameters - Order Of Importance

Generally, the mesh statistics can be ranked as follows (most important to least important)

1. Minimum Volume - these MUST be fixed before the mesh would be usable.

2. Maximum Face Angle/ Minimum Face Angle - these should be improved until they fall within

the constraints (minimum of 15° and maximum of 165°), if possible. Values close to, but just outside

the constraints may still be acceptable for your simulation.

3. Edge Length Ratio - this can often be fixed by increasing the number of elements from hub to

shroud. The default limit is 100, so values close to this will normally be acceptable.

4. Element Volume Ratio - depending on the mesh, it may not be possible to satisfy this constraint.

5. Connectivity Number - may or may not be pertinent depending on the type of solver used. For

details, see Connectivity Number (p. 135).

10.8.4. Volume

The Mesh Analysis > Show Limits volume object provides a convenient way to examine the

mesh. It functions exactly the same as the volume object in the create menu, except that the only

variables available are the mesh statistics variables. For details, see Volume Command (p. 37).
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Note

The visibility of the volume object is off by default.

10.9. User Defined Objects

The User Defined branch in the object selector is initially empty. Any new objects created using

the Insert menu will be displayed in this branch. Examples include points and legends. For details, see

Insert Menu (p. 31).

10.10. Default Instance Transform

The default instance transform is initially applied to all objects for which instance transforms are possible.

As a result, editing the definition of the default instance transform causes all such plots and objects to

be transformed. Additional instance transform objects can be created. For details, see Instance Transform

Command (p. 44). A different instance transform can be applied to an object using its Render tab. For

details, see Applying Instance Transforms to Objects (p. 8).

10.11. Shortcut Menu Commands

You can perform many actions from shortcut menus; simply right-click one of the following:

• The viewer background (i.e., a blank area in the viewer)

• An object in the viewer

• An object listed in the object selector

• An object listed in the object editor

The following sections describe all of the shortcut menu commands that can appear:

• Auto Add Layers and Insert Layers Automatically Commands (p. 137)

• Color Command (p. 137)

• Copy Control Points to Hub and Shroud Command (p. 138)

• Copy Smoothing Levels to All Layers Command (p. 138)

• Copy to Hub, Copy All to Hub, and Copy Control Points to Hub Commands (p. 138)

• Copy to Shroud, Copy All to Shroud, and Copy Control Points to Shroud Commands (p. 138)

• Create Mesh Command (p. 138)

• Create New View Command (p. 138)

• Delete Command (p. 139)

• Delete New View Command (p. 139)

• Edit Command (p. 139)

• Edit in Command Editor Command (p. 139)

• Fit View Command (p. 139)

• Hide Command (p. 139)

• Insert Blade Command (p. 139)
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• Insert Layer After and Insert Layer After Selected Layer Commands (p. 139)

• Insert Layer Automatically Command (p. 139)

• Insert Local and Insert Master Commands (p. 140)

• Insert USER DEFINED Object Command (p. 140)

• Insert Edge Split Control Command (p. 140)

• Interpolating Control Point Offsets for Inner Layers (p. 140)

• Make Local Command (p. 140)

• Make Master Command (p. 140)

• Master Influence Command (p. 140)

• Mixed Influence Command (p. 140)

• Predefined Camera Commands (p. 141)

• Save Picture Command (p. 141)

• Projection Commands (p. 141)

• Render Properties Edit Options Command (p. 141)

• Render Properties Show Curves Command (p. 141)

• Render Properties Show Surfaces Command (p. 141)

• Render Properties Topology and Refined Mesh Visibility Commands (p. 142)

• Reset Offset Command (p. 142)

• Show Object and Show Commands (p. 142)

• Show and Hide All Siblings Command (p. 142)

• Sticky Command (p. 142)

• Suspend Object Updates Command (p. 142)

• Toggle Axis Visibility Command (p. 143)

• Toggle Ruler Visibility Command (p. 143)

• Transformation Commands and Coordinate Systems (p. 143)

• Update Now Command (p. 144)

• Viewer Options Command (p. 144)

10.11.1. Auto Add Layers and Insert Layers Automatically Commands

For details, see Inserting Layers Automatically (p. 123).

10.11.2. Color Command

The Color command provides a subset of the functionality offered by the Color tab. The latter is available

by selecting an eligible object from the object selector, then clicking Rendering . For details, see

Color Tab (p. 5).
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10.11.3. Copy Control Points to Hub and Shroud Command

The Copy Control Points to Hub & Shroud command is available for any layer other than the hub or

shroud layer. This command has the combined effect of the Copy Control Points to Hub and Copy

Control Points to Shroud commands.

10.11.4. Copy Smoothing Levels to All Layers Command

The Copy Smoothing Levels to All Layers command is available by right-clicking on a layer at a location

other than a control point (i.e., on a master topology, topology, or refined mesh line), or by right-clicking

a layer listed in the object selector. This command takes the smoothing setting found on the Smoothing

tab for the layer (in the object editor) and applies it to all layers.

10.11.5. Copy to Hub, Copy All to Hub, and Copy Control Points to Hub Com-

mands

The Copy to Hub command is available by right-clicking a control point on the shroud layer. It copies

the offset of the control point to the corresponding control point on the hub layer, and creates the

corresponding control point if it does not already exist.

The Control Point > Copy All to Hub command is available by right-clicking on a layer at a location

other than a control point (i.e., on a master topology, topology, or refined mesh line). This command

carries out the Copy to Hub command for all control points on the layer.

The Copy Control Points to Hub command is available for the shroud layer when you select the latter

from the object selector. It is the same as the Control Point > Copy All to Hub command.

10.11.6. Copy to Shroud, Copy All to Shroud, and Copy Control Points to

Shroud Commands

The Copy to Shroud command is available by right-clicking a control point on the hub layer. It copies

the offset of the control point to the corresponding control point on the shroud layer, and creates the

corresponding control point if it does not already exist.

The Control Point > Copy All to Shroud command is available by right-clicking on a layer at a location

other than a control point (i.e., on a master topology, topology, or refined mesh line). This command

carries out the Copy to Shroud command for all control points on the layer.

The Copy Control Points to Shroud command is available for the hub layer when you select the latter

from the object selector. It is the same as the Control Point > Copy All to Shroud command.

10.11.7. Create Mesh Command

The Create Mesh command is available when the topology has been created. It is the same as selecting

Insert > Mesh. For details, see Mesh Command (p. 31).

10.11.8. Create New View Command

Adds a new view based on the current state of the viewer.
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10.11.9. Delete Command

The Delete command is analogous to Make Master command, and operates on added control points.

10.11.10. Delete New View Command

Deletes an existing user-defined view.

10.11.11. Edit Command

The Edit command opens the object editor for the selected object.

10.11.12. Edit in Command Editor Command

The Edit in Command Editor command opens the command editor dialog box for the selected object.

For details, see Command Editor Command (p. 66).

10.11.13. Fit View Command

The Fit View command centers the view on the displayed objects and sets the zoom to an appropriate

level for viewing all of the visible objects. Only the active viewport is affected by this command.

Note

Objects which have their visibility check box cleared do not necessarily fit into the viewer.

Only visible objects are considered.

10.11.14. Hide Command

The Hide command turns off the visibility of the selected object(s). To turn the visibility back on, find

the object in the object selector and select its check box or use the Show Object command available

in the shortcut menu that appears when right-clicking the viewer background.

10.11.15. Insert Blade Command

The Insert Blade command adds a blade to the blade set. After selecting this command, ANSYS TurboGrid

prompts you for a name for the blade, then generates the new blade object. If you already have a blade

loaded, most settings for the new blade will default to those from the first blade. Simply change the

File Name setting to indicate the file for the added blade and click Apply.

10.11.16. Insert Layer After and Insert Layer After Selected Layer Commands

For details, see Insert Layer After Selected Layer (p. 123).

10.11.17. Insert Layer Automatically Command

For details, see Inserting Layers Automatically (p. 123).
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10.11.18. Insert Local and Insert Master Commands

The Insert Local and Insert Master commands are available by right-clicking on a layer at a location

other than a control point (i.e., on a master topology, topology, or refined mesh line). These commands

insert a control point of the corresponding type on the layer at the nearest suitable location to where

you right-click.

10.11.19. Insert USER DEFINED Object Command

The Insert > USER DEFINED Object command creates a new object. It functions like the Insert menu.

For details, see Insert Menu (p. 31).

10.11.20. Insert Edge Split Control Command

The Insert Edge Split Control command is available by right-clicking a topology line between topology

nodes. This command creates/edits an edge split control object. Edge split control objects appear in

the object selector under Mesh Data. For details, see Edge Split Controls (p. 121).

10.11.21. Interpolating Control Point Offsets for Inner Layers

If you have more than two layers, and you move a control point on the hub or shroud layer, then the

next time you try to generate a mesh, the control points on the inner layers will move. If you manually

adjust any control point on any inner layer, then move a control point on the hub or shroud layer,

ANSYS TurboGrid will prompt you the next time you try to generate a mesh. The prompt will offer the

choice of keeping your custom movements for the inner layers, or recalculating all control points for

all inner layers. In order to recalculate all control points for a single layer, or subset of layers, select the

layer(s), then use the shortcut menu option: Interpolate CP Offsets, or Control Point > Interpolate

Offsets. You may select an inner layer by right clicking it in the viewer. You may select one or more

inner layers using the object selector, or the list of layers that appears when editing the Layers object

in the object editor.

10.11.22. Make Local Command

The Make Local command is analogous to Make Master command, and operates on added master

control points.

10.11.23. Make Master Command

The Make Master command is available by right-clicking a local control point. It can be used to make

the local control point type Master by selecting Make Master > on Current Layer, It can be used to

make the local control point, and all of the control points in the corresponding location on the other

layers, type Master by selecting Make Master > on All Layers.

10.11.24. Master Influence Command

The Master Influence command removes the effect of the Mixed Influence command. For details, see

Mixed Influence Command (p. 140).

10.11.25. Mixed Influence Command

When a control point is selected, a red line indicates the range of influence on the topology nodes. For

details, see Range of Influence (p. 129).
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The Mixed Influence command reduces the range of influence of a master control point along master

topology lines. After this command has been applied to a master control point other than a default

master control point, the range of influence of the control point stops at the first topology node en-

countered on any master topology line.

10.11.26. Predefined Camera Commands

The Predefined Camera commands allow you to set the viewing angle according to one of the built-

in presets. These commands also set the zoom level automatically after adjusting the viewing angle.

10.11.27. Save Picture Command

The Save Picture command is available by right-clicking the background. It is the same as selecting

File > Save Picture.

10.11.28. Projection Commands

10.11.28.1. Perspective Command

The Perspective command sets a view with a fixed amount of perspective.

10.11.28.2. Orthographic Command

The Orthographic command sets an orthographic view.

10.11.29. Render Properties Edit Options Command

The Render (Properties) > Edit Options command enables you to adjust color and render settings for

the selected object. For details, see Color Tab (p. 5) and Render Tab (p. 6).

10.11.30. Render Properties Show Curves Command

The Render (Properties) > Show Curves command is available by right-clicking an object (e.g., the

hub, shroud or blade surface). Use this command to view the raw curve file data instead of the surface.

10.11.31. Render Properties Show Surfaces Command

The Render (Properties) > Show Surfaces command is available by right-clicking the hub or shroud

curve, or one of the blade curves. Use this command to view the surface instead of the raw curve file

data.

Note

The blade surface and resulting mesh can be adversely affected when a blade shroud tip is

defined by the second-last profile and the last profile has a shape that is inconsistent with

where the blade would exist if the blade were extended in the spanwise direction while ig-

noring the last profile. To avoid this problem, you can either ensure that the last profile is

consistent with the second last profile, or manually remove the last profile from the curve

file. A similar statement applies for the hub end of a blade having a hub tip.
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10.11.32. Render Properties Topology and Refined Mesh Visibility Commands

The Render (Properties) > Master Topology Visibility, Topology Visibility, and Refined Mesh Visib-

ility commands toggle the visibility of the corresponding items for the selected layer(s).

10.11.33. Reset Offset Command

The Reset Offset command is available by right-clicking a control point that has been moved since it

was created. It resets the position of the control point to its original location.

10.11.34. Show Object and Show Commands

The Show Object command is available by right-clicking the background. It turns on the visibility of

any geometry, volume, or mesh data object.

The Show command turns on the visibility of the object(s) selected in the object selector.

10.11.35. Show and Hide All Siblings Command

The Show + Hide All Siblings command turns on the visibility of the object selected in the object se-

lector, and turns off the visibility of every sibling object in the tree.

10.11.36. Sticky Command

The Sticky command, when selected, makes a master control point “sticky”. A “sticky” master control

point usually limits the range of influence of an added master control point that lies on the same

master topology line; the range of influence stops at the “sticky” master control point. In some cases,

a “sticky” master control point does not restrict the range of influence of another master control point

on the same topology line.

Note

A sticky control point will not remain stationary if you move a pre-defined master control

point on the same master topology line.

10.11.37. Suspend Object Updates Command

You can save time by appropriately suspending objects. The Suspend Object Updates command

toggles the state of suspension of an object. By suspending an object, you prevent it from being updated

in response to changes to other objects.

For example, the Topology Set object depends on the Geometry object, and, when not suspended,

will be reprocessed each time the geometry is changed. If you want to make several changes to the

geometry, you can skip the intermediate processing of the topology by suspending the Topology
Set object. Note that the Topology Set object is initially suspended when you start a new case.

To process a suspended object, you can either deselect the Suspend Object Updates command or

select the Update Now command. If you select the Update Now command, the object will be processed

once, but will remain suspended.

Objects that depend on a suspended object are also suspended. An icon overlay indicates whether or

not an object is suspended. Icon overlays are illustrated in Table 1.1: Icon Overlays and Text Styles (p. 2).
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10.11.38. Toggle Axis Visibility Command

The Toggle Axis Visibility command is available by right-clicking the background. It controls the visib-

ility of the axis orientation indicator that appears in the lower-right corner of the viewer.

10.11.39. Toggle Ruler Visibility Command

The Toggle Ruler Visibility command is available by right-clicking the background. It controls the vis-

ibility of the ruler that appears near the lower edge of the viewer.

10.11.40. Transformation Commands and Coordinate Systems

The Transformation commands are available by right-clicking the background.

You can use different coordinate systems to display various views of the geometry and mesh objects

in the viewer window. This is useful when closely examining every aspect of the mesh before saving it

for use in a CFD solver.

10.11.40.1. Cartesian

The Cartesian coordinate system is used by default in the viewer window when there is only one

viewport. The 3 axis coordinates for the Cartesian coordinate system are X, Y and Z.

10.11.40.2. Blade-to-Blade

The blade-to-blade coordinate system is used to display the geometry in the ′�  - � conformal space

which is familiar to blade designers. The ′�  - � coordinate space is angle-preserving and minimizes the

effect of changing radius on viewing and manipulation. By utilizing the blade-to-blade coordinate system,

a wide variety of machine types, from axial to radial, can be treated similarly.

′�  is defined in Meridional (p. 143).

Note

Due to the fact that ′�  is ill-conditioned at =� , you can expect to see different behavior

in cases which extend to the machine axis.

10.11.40.3. Meridional

The meridional coordinate system is one transformation used by blade designers. It is useful for viewing

the flow path as well as the upstream and downstream extents of the mesh. The three axis coordinates

for the meridional coordinate system are A (axial), R (radial) and � (Theta). The viewer shows only the

A and R coordinates.

DescriptionVariable

Axial location�

Radius or radial location	

Normalized distance along meridional curve (e.g., from

0 to 1)
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DescriptionVariable

The particular value of � that corresponds to the point

location for which � and ′�  are to be computed

�

Meridional coordinate (distance along meridional curve)�

Normalized meridional coordinate (radius normalized

distance along meridional curve)
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10.11.40.4. 3D Turbo

The three axis coordinates for the 3D Turbo Coordinate System are M ( ′� ), T (Theta) and S (span).

10.11.41. Update Now Command

The Update Now command causes a suspended object to be processed. For more details, see Suspend

Object Updates Command (p. 142).

10.11.42. Viewer Options Command

The Viewer Options command is available by right-clicking the background. It is the same as selecting

Edit > Options and then navigating to TurboGrid > Viewer. For details, see Viewer (p. 24).
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Index

Symbols
3D Turbo coordinate system, 144

A
ANSYS CFX, 18

ANSYS TurboGrid

workflow, 1, 71

ANSYS Workbench parameter, 63

appearance, 24

font, 25

GUI (Graphical User Interface), 25

append

session, 29

state, 14

append to current simulation, 14

apply button, 5

area function, 58

areaAve function, 58

areaInt function, 58

auto save, 24

automatic y+, 115

ave function, 59

axis visibility, 24

B
bitmap (bmp), 21

blade, 77

hub tip, 86

leading edge, 84

save, 16

shroud tip, 86

trailing edge, 85

transformations, 84

blade set, 13, 77

blade-to-blade coordinate system, 143

bmp (bitmap), 21

boundary condition

file, 10

C
calculator, 57

function, 57

Cartesian coordinate system, 143–144

CFD Viewer State (3D), 21

CFX-TASCflow, 18

CGNS, 18

color

range, 6

tab in object editor, 5

undefined, 6

command editor, 140

command editor dialog box, 66

shortcut menu access, 139

command timeout, 26

commands

expression, 62

connectivity number, 135

conservative variable values, 65

contour

insert, 42

range, 43

control angle

inlet, 88

control points

added, 131

interpolation on inner layers, 140

local, 128

master, 128

master and local types, 124, 132

selection and highlighting, 132

sticky, 130, 142

user, 127

coordinate systems, 143

count function, 59

culling, 7

curve

file, 10

load, 12

cut line, 33

cut-off or square leading or trailing edge, 83

D
default instance transform, 136

defaults button, 5

direction, 61

display

menu, 47

domain

inlet, 120

outlet, 120

double buffering, 25

draw

faces, 7

lines, 8

E
edge length ratio, 135

edge split control, 121

automatic generation of, 113

insertion of, 140

145
Release 14.0 - © SAS IP, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.



edit

menu, 23

redo, 23

undo, 23

element size normalized, 119

element volume ratio, 135

elements

distribution, 119

number, 113

encapsulated PostScript (eps), 21

eps (Encapsulated PostScript), 21

example

expression editor, 63

variable editor, 65

export

ANSYS CFX, 18

CFX-TASCflow, 18

CGNS, 18

geometry, 20

expression

commands, 62

editor, 61

example, 63

name, 62

F
face

angle - maximum, 134

angle - minimum, 134

culling, 7, 21

draw, 7

lighting, 7

shading, 7

file

export geometry, 20

load curves, 12

load state, 14

menu, 9

quit, 22

recent, 22

save blade, 16

save mesh, 17

save state, 15

save topology, 17

types, 9

fit view, 53, 139

FLUENT, 18

font selection, 25

format, 20

surface data, 40

function

calculator, 57

direction, 61

G
general

auto save, 24

command timeout, 26

temporary directory, 24

geometry, 73

blade, 77

export, 20

high periodic, 87

hub, 76

inlet, 88

low periodic, 87

machine data, 74

object editor, 5

outlet, 88

outline, 90

shroud, 76

global range

color, 6

contour, 43

grid

file, 10

GUI (Graphical User Interface)

style, 25

H
H-Grid, 100

H-Grid Dominant, 102

H/J/C/L-Grid, 100

help

menu, 69

high periodic surface, 87

highlighting, 53

hub, 76

tip, 86

hybrid variable values, 65

I
icons

inlet, 88

variable, 64

views, 141

image quality, 22

image tolerance, 22

import surface data, 40

inlet, 88

angle - control, 88

domain, 120

icons, 88
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insert

contour, 42

instance transform, 44

isosurface, 38

isovolume, 37

legend, 45

line, 33

menu, 31

mesh, 31

plane, 34

point, 32

surface, 40

surface group, 41

text, 46

turbo surface, 36

volume, 37

instance transform

default, 136

insert, 44

render, 8

isosurface

insert, 38

isovolume

insert, 37

J
J-Grid, 101

jpg (JPEG), 21

L
layers, 122

loading, 133

saving, 132

leading edge, 82, 84

legend

insert, 45

length function, 59

lengthAve function, 59

lengthInt function, 59

lighting, 7

lighting angle, 26

line

cut, 33

draw, 8

insert, 33

sample, 34

selection, 34

translation, 34

line of rotation mesh division, 83

load

curves, 12

state, 14

load as new simulation, 14

local control points, 128

local range

color, 6

contour, 43

low periodic surface, 87

M
machine data, 74

master control points, 128

maximum face angle, 134

maxVal function, 60

menu

display, 47

edit, 23

file, 9

help, 69

insert, 31

session, 27

tools, 57

viewer, 51

meridional coordinate system, 143

mesh, 133

analysis, 133

connectivity number, 135

data, 113

edge length ratio, 135

element volume ratio, 135

file, 10

insert, 31

limits, 134

maximum face angle, 134

minimum face angle, 134

minimum volume, 135

save, 17

span, 117

statistics, 134
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mesh data

blade tip, 118

near wall element size specification, 115

O-grid, 117

topology block edge split, 113

mesh units, 19
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minVal function, 60
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picking, 52
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culling, 7

instance transform, 8
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shortcut menu, 136
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viewer, 24
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overwrite

session, 29
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picking mode, 52

picture
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quality, 22
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use screen capture, 21
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slice, 36

translation, 36

play

session, 28

png (Portable Network Graphics), 21

point
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PostScript (ps), 21

ppm (Portable Pixel Map), 21

preserve control points on layers, 105

probe function, 60

ps (PostScript), 21
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quit, 22
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recent
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record session, 29
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render

faces, 7

instance transforms, 8
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reread button, 84

reset button, 5
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save
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save and load button for leading/trailing edges, 84

scale, 22

selection

font, 25

leading edge point, 85

line, 34

plane, 36

point, 33

session

append, 29

file, 9, 29

menu, 27

new, 29

overwrite, 29

play, 28

recent files, 22

recording, 29

set, 29

set

session, 29
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shortcut menu, 136

color, 137

copy all to hub, 138

copy all to shroud, 138

copy smoothing levels to all layers, 138

copy to hub, 138

copy to shroud, 138
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create new view, 138

delete, 139

delete view, 139

edit, 139

hide, 139

insert edge split control, 140

insert user defined object, 140

make local, 140

make master, 140

master influence, 140

mixed influence, 140

render options, 141

reset offset, 142

save picture, 141

show and hide all siblings, 142

show curves, 141

show object, 142
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toggle ruler visibility, 143

topology and refined mesh visibility, 142

viewer options, 144

shroud, 76

tip, 86

size of elements, 119
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span, 111

element count, 117

location, 111

splitter blades, 13, 42

start recording session, 29

state

append, 14

file, 9

load, 14

overwrite, 14

recent files, 22

save, 15

save all objects, 15

stereo viewer

enabling, 56

sticky control points, 130, 142

stop recording session, 29

style

GUI (Graphical User Interface), 25

sum function, 60

surface

data

import, 40
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surface group, 133

insert, 41

suspend object updates, 3, 142

T
temporary directory, 24

text

add to viewer, 46

tip topology, 104

tolerance (hardcopy), 22

tools

calculator, 57

command editor dialog box, 66

expressions, 61

menu, 57

object editor, 4

object selector, 2

variables, 64

topology, 90

advanced parameters, 105

cut-off or square leading/trailing edges, 112

definition, 100

effect of line of rotation, 113

file, 10

freeze button, 111
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From File, 103

H-Grid, 100

H-Grid Dominant, 102

H/J/C/L-Grid, 100

J-Grid, 101

layers, 122

method, 100

O-Grid, 103

save, 17

span location, 111

Topology

sharp leading/trailing edge, 109

topology pattern, 100

trailing edge, 82, 85

transformations to other coordinate systems, 143

translate, 26

translation

leading edge point, 85

line, 34
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point, 33

turbo surface, 133
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TurboGrid

workflow, 1, 71

U
undefined

color, 6

values, 6

undo, 23

units, 26

use screen capture, 21

user

defined objects, 136

specified range - color, 6

specified range - contour, 43

V
value list

contour, 43

values

undefined, 6

variable

editor, 64

example, 65

hybrid and conservative values, 65

icons, 64

name, 64

path, 40–41

type, 65

viewer

axis visibility, 24

coordinate systems, 143

double buffering, 25

fit view, 139

highlighting, 53

menu, 51

mouse mapping, 25

multiple viewports, 54

options, 24
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perspective, 141

picking mode, 52

pre-defined camera, 141

rotate, 52

shortcut menu, 136

white background, 21

viewports

multiple, 54

views, 55

selection, 55

visibility

axis, 24
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volume

insert, 37

isovolume, 37

volume function, 60
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VRML (Virtual Reality Modeling Language), 21
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white background, 21

wrl (VRML file extension), 21
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