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Find the Information You
Need

 

The Help system is organized in a structured design that makes

information easy to locate.

This program is a powerful application with tools that help

you work with a high level of efficiency and productivity.

You instFall this software with the Installation wizard that

starts automatically when you insert the product CD.

This application is often intuitive, but when you do need to

look something up, you can save time and avoid frustration

if you use the Help system to find information. The Help

system is organized in a structured design that makes

information easy to locate.
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■ Receive Product Updates and
Announcements

■ View the Product Readme



Install the Product
You can easily install and configure this program on a stand-alone computer.

Insert the product CD in the CD-ROM drive. Then, in the Media Browser, on
the Install tab, click Stand-Alone Installation. Then, click Install. The
Installation wizard leads you through the installation process. The Media
Browser also provides instructions for network installations and access to
information about technical support and licensing.

If you want more information about installing a stand-alone version of
AutoCAD, consult the Stand-Alone Installation Guide. To access this guide, in
the Media Browser, click the Documentation tab. Then click Stand-Alone
Installation Guide (.pdf).

If you want more information about deploying this program on a network,
consult the Network Administrator's Guide. To access this guide, in the Media
Browser, click the Documentation tab. Then, click Network Administrator's
Guide (.pdf).

Once the product is installed, you can access either the Stand-Alone Installation
Guide or the Network Administrator's Guide in the Help system.

Migration Tools

Migration Tools help you when upgrading to a new release of this program.
You can download the Migration Tools in several languages from the Autodesk
website.

NOTE You can migrate some custom settings and files by using the Migrate
Custom Settings dialog box. For more information about the Migrate Custom
Settings dialog box, see the Stand-Alone Installation Guide.

Available tools include

■ Layer State Converter

■ Batch Drawing Converter

■ AutoLISP Compatibility Analyzer

■ ScriptPro

Go to the Autodesk website,
http://www.autodesk.com
, and perform a search on Migration Tools.
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NOTE Because these are public tools, product support for them is limited to the
Autodesk discussion groups.

Use the Help System Efficiently
You can get much more benefit from the Help system when you learn how
to use it efficiently.

The Help system contains complete information about using this program.
In the Help window, you use the left pane to locate information. The tabs
above the left pane give you several ways for finding the topics you want to
view. The right pane displays the topics you select.

Find Information in Help

The tabs on the left side of the Help window provide different methods for
finding information.

To locate a specific word or phrase in the current topic, click in the topic text
and use the CTRL+F keys.

Contents Tab

■ Presents an overview of the available documentation in a list of topics and
subtopics.

■ Allows you to browse by selecting and expanding topics.

■ Provides a structure so you can always see where you are in Help and quickly
jump to other topics.

Index Tab

■ Displays an alphabetical list of keywords related to the topics listed on the
Contents tab.

■ Accesses information quickly when you already know the name of a feature,
command, or operation, or when you know what action you want the
program to perform.

Search Tab

■ Provides full-text search of all the topics listed on the Contents tab.

■ Allows you to perform an exhaustive search for a specific word or phrase.
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■ Displays a ranked list of topics that contain the word or words entered in
the keyword field.

Ask Me Tab

■ Allows you to find information using a question phrased in everyday
language.

■ Displays a ranked list of topics that correspond to the word or phrase entered
in the question field.

■ Provides a "Search the Web" link that sends a query to a search engine on
the Web.

To start Help

■ Click Help menu ➤ Help, or press F1.

For Developer Help, click Help ➤ Additional Resources ➤ Developer Help.

NOTE You can press F1 at the Command prompt, in a dialog box, or at a prompt
within a command to display Help information.

To use the Help Contents

1 If necessary, click the Show button to display the left pane of the Help
window. Then click the Contents tab to display Help Contents.

2 To expand the Help Contents list, use one of these methods:

■ Double-click a closed-book icon or click the + icon next to it.

■ Right-click in Help Contents. Click Open All.

3 To close the Help Contents list, use one of these methods:

■ Double-click an open-book icon or click the - icon next to it.

■ Right-click in Help Contents. Click Close All.

4 To view a topic, use one of these methods:

■ In Help Contents, click the topic.

■ In a topic, click any blue underlined text.
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Use Searches

A basic search using the Search tab consists of the word or phrase you want
to find.

The basic search rules are as follows:

■ Type your search in uppercase or lowercase characters; searches are not
case-sensitive.

■ Search for any combination of letters (a-z) and numbers (0-9).

■ Do not use punctuation marks such as the period, colon, semicolon, comma,
hyphen, and single quotation marks; they are ignored during a search.

■ Group the elements of your search using double quotation marks or
parentheses to set each element apart.

NOTE When you use the Search tab, all topics that contain the word or phrase
that you specify are listed. This includes the text in topic titles and labels, not just
the topic text.

Use Advanced Search

Advanced full-text search on the Search tab allows you to search using Boolean
operators and wild cards. You can limit the search to previous results, match
similar words, or search topic titles only. When searching for multi-word
topics, use double quotation marks (" ") to enclose words that must appear
next to each other in the specified sequence. For example, enter "specifying
units of measurement" to find only topics with all those words in that order.
If you don’t use the quotation marks around that text, Help finds all topics
containing any one of the listed words, that is, all topics containing
"specifying", all topics containing "units", all topics containing "of", and all
topics containing "measurement".

With the AND, OR, NOT, and NEAR operators, you can precisely define your
search by creating a relationship between search terms. The following table
shows how you can use each of these operators. If no operator is specified,
AND is used. For example, the query "spacing border printing" is equivalent
to "spacing AND border AND printing".

ResultsExampleSearch for

Topics containing both the words "tree
view" and "palette"

"tree view" AND
"palette"

Both terms in the
same topic
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ResultsExampleSearch for

Topics containing either the word
"raster" or the word "vector" or both

"raster" OR "vector"Either term in a topic

Topics containing the word "OLE," but
not the word "DDE"

"ole" NOT "dde"The first term without the
second term

Topics containing the word "user"
within eight words of the word "kernel"

"user" NEAR "kernel"Both terms in the
same topic, close
together

NOTE The |, &, and ! characters do not work as Boolean operators. You must use
AND, OR, and NOT.

To search for information in Help

1 Click the Search tab. Enter the word or phrase you want to find.

2 (Optional) Refine your search with Boolean operators:

■ Click

to add Boolean operators to your search.

■ Enter the word or phrase you want to appear after the Boolean
operator.

(Optional) Further refine your search with the check boxes at the bottom
of the Search tab:

■ Search previous results. Refines a search by applying new search
criteria to the results of a previous search.

■ Match similar words. Expands the search to include words similar
to your search criteria, rather than limiting the search to exact
matches.

■ Search titles only. Limits the search to topic titles, rather than
searching titles and topic contents.

4 Click List Topics and select the topic you want. Click Display.

5 To sort the topic list, click the Title, Location, or Rank column heading.

To view only procedures, click the Title column heading and scroll down to
the items that begin with the word “To.”
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Use Ask Me

You can find information by typing a question phrased in everyday language.

You can perform this natural language query in Help by clicking the Ask Me
tab and entering a question, a word, or a phrase. For example, you could enter:
How do I create a layout?

The results of natural language queries are often more accurate than the results
of searches. Matching topics are ranked by percentages that reflect how likely
they are to answer your questions.

You can also expand your natural language query to the Web.

To use natural language queries in Help

1 On the Ask Me tab, enter the question you want answered. Alternatively,
you can enter a phrase or a single word.

2 To narrow query results, select a particular item or set from the List of
Components to Search.

3 Click the link for the topic you want to display.

NOTE For hints on obtaining good query results, click the Query Tips link on the
Ask Me tab.

To expand your queries to the Web

1 If the results of a natural language query do not provide the information
you need, scroll to the bottom of the list of matching topics that resulted
from your query.

2 Click the Search the Web link at the bottom of the list

A web search engine displays the results of your search.

NOTE For hints on obtaining good query results, click the Query Tips link on the
Ask Me tab.

Understand How Help Topics Are Organized

Most topics in this Help system have three tabs above the right pane of the
Help window. The tabs display different types of information.
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The tabs display different types of information.

■ Concepts tab. Describe a feature or function. When you click a Concepts
tab, the Help Contents list in the left pane of the Help window expands
and highlights the current topic. The Contents tab displays the structure
of the Help on that topic. You can easily display nearby topics by clicking
them in the list.

■ Procedures tab. Provides step-by-step instructions for common procedures
related to the current topic. After displaying a procedure, you can click the
Procedures tab to redisplay the current list of procedures.

■ Commands tab. Lists commands and system variables related to the
current topic, with links to detailed descriptions of the commands. If you
click an entry on the Commands tab, the Command Reference opens to the
command or system variable that you selected.

When you click a different tab, the topic remains the same. Only the type of
information displayed—concepts, procedures, or commands links—is different.

Concepts Tab Organization

In the Concepts tab, there are two types of information displayed: navigation
text and destination text. Navigation text displays links with short descriptions.
The purpose of navigation text is to guide you step-by-step to the information
that you need. The links on navigation pages lead to additional navigation
pages deeper in the Help structure until you come to a destination page. Each
link is designed to provide you with more detailed information.

Procedures Tab and Commands Tab Organization

As you navigate deeper into the Help structure on the Contents tab, the
corresponding information on the Procedures tab and on the Commands tab
becomes more specific, and the number of entries displayed on each of these
two tabs decreases.

To change the type of Help information displayed

■ Click the Concepts, Procedures, or Commands tab to change the type of
information that is displayed in the right pane of the Help window.

Use the Up Arrow to Navigate Help Topics

An up arrow may be displayed in the upper-right corner of a topic.

Click this arrow to move up a level from the current topic to one that contains
a broader scope of information.
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Print Help Topics

The quickest way to print the current topic is to right-click within the topic
and click Print.

The Print button on the Help toolbar provides these print options:

■ Print the selected topic (recommended)

■ Print the selected heading and all subtopics

NOTE When you select the second option, you may get numerous printed pages,
depending on how many subtopics the currently selected topic contains.

To print a Help topic

1 Display the topic you want to print.

2 Right-click in the topic pane. Click Print.

3 In the Print dialog box, click Print.

To print a selected heading and all subtopics

1 Display the topic you want to print and make sure that the Contents
tab is showing.

2 On the Help toolbar, click the Print button.

3 In the Print Topics dialog box, click Print the Selected Heading and All
Subtopics.

4 Click OK.

Show and Hide the Contents Pane

Use the Hide button on the Help toolbar to shrink the Help window to a
compact size by hiding the pane that contains the Contents, Index, Search,
and Ask Me tabs.

The compact window size is best for displaying procedures while you work.
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Use the Show button to expand the Help window to display the pane that
contains Help Contents, Index, Search, and Ask Me tabs. The expanded window
size is best for locating and displaying conceptual and reference information.

Get Additional Help

You can access several additional sources of help.

■ Press F1 from within a command, system variable, or dialog box.
Displays complete information from the Command Reference.

■ Click the question mark button in many dialog boxes. Displays
a description of the dialog box option you select.

■ View the product Readme topic in Help. Displays late-breaking
information about this product.

■ Display Quick Help on the Info Palette. Displays procedures relevant
to the current command in a compact palette.

Other resources help you get information about Autodesk products and
assistance with your questions about this program.

■ Autodesk website. Access
http://www.autodesk.com
.

■ Local support.  Check with your dealer or Autodesk country/region office.

Use Quick Help on the Info Palette
Quick Help on the Info palette provides convenient information from the
Help system. With Quick Help, you can display procedures in a compact
palette that takes up very little space in your drawing area.

During any command, Quick Help displays a list of procedures that are relevant
to the current command. With Quick Help, you can click a procedure to
display it in the Info palette, a compact palette that takes up very little space
in your drawing area.
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Often, the guidance you get from Quick Help is just enough to get you started
performing unfamiliar or rarely used tasks.

Normally, the Info palette updates the Quick Help information that is displayed
as you start new commands. However, if you need to freeze the information
displayed, you can lock the Info palette.

To display Quick Help

■ Click Help menu ➤ Info Palette.

To navigate Quick Help

1 Right-click in the Info palette.

2 Click Home, Back, or Forward to navigate topics, as you would in a web
browser.

To print Quick Help information

1 Display the Quick Help information you want to print.

2 Right-click in the Info palette. Click Print.

3 In the Print dialog box, click OK.

To lock Quick Help on the current topic

1 Display the Quick Help information you want to see.

2 Right-click in the Info palette. Click Lock.

The Quick Help information that is displayed in the Info palette is locked
in place until you unlock it.

Learn the Product
Training programs and products from Autodesk Professional Services help you
learn the key technical features of your Autodesk software.

Autodesk Professional Services training programs and products help you learn
the key technical features of your Autodesk software.

For the latest information about Autodesk training, visit
http://www.autodesk.com/training
or contact your local Autodesk office.
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Autodesk Authorized Training Centers

The Autodesk® Authorized Training Center (ATC® ) network delivers
Autodesk-authorized, instructor-led training to design professionals who use
Autodesk software. Autodesk Authorized Training Centers use experienced
and knowledgeable instructors. More than 1,100 ATC sites are available
worldwide to meet your needs for discipline-specific, locally based training.

To find a training center near you, contact your local Autodesk country office
or visit
http://www.autodesk.com/atc
.

Autodesk Official Training Courseware

Autodesk Official Training Courseware (AOTC) supports training organizations
and customers. AOTC is authorized technical training material developed by
Autodesk for traditional 1- to 5-day, instructor-led classroom training. AOTC
courseware covers key concepts in step-by-step exercises. You can purchase
AOTC from your local reseller or distributor, or you can order it online from
the Autodesk Store at
http://www.autodesk.com/aotc.

Partner Products and Services

Autodesk works together with thousands of software partners around the
world. These partners provide products and services that enhance Autodesk
products for design professionals. Visit the Partner Products & Services page
at
http://www.autodesk.com/partnerproducts
for a list of resources available for your Autodesk product and your industry.

e-Learning

Autodesk e-Learning features interactive lessons organized into product
catalogs. Each lesson is 15-30 minutes in length and features hands-on
exercises, with an option to use a simulation instead of the software
application. You can use an online evaluation tool that identifies gaps in skills,
determines what lessons will be most helpful, and gauges learning progress.

If you are a member of Autodesk subscription, you can access e-Learning and
other subscription services from within your Autodesk product. For more
information about how to access e-Learning in the product, see “Access
Subscription Center” on page 13. For more information about Autodesk
subscription resources, visit
http://www.autodesk.com/subscription
.
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Access Subscription Center
The Subscription Center is available to subscription members from within the
product. If you are a subscription member, you can access subscription services
by using Help and clicking a Subscription resource. To learn more about
Autodesk subscription membership, visit
http://www.autodesk.com/subscription.

Overview of Subscription Center

With Autodesk Subscription, you get the latest releases of Autodesk software,
incremental product enhancements, personalized web support from Autodesk
technical experts, and self-paced e-Learning. Subscription services are available
to subscription members only.

By clicking the Help menu, members have access to the following options:

■ Subscription e-Learning Catalog. Features interactive lessons organized
into product catalogs. Each lesson is 15-30 minutes and features hands-on
exercises, with an option to use a simulation instead of the software
application. You can use an online evaluation tool that identifies gaps in
skills, determines what lessons will be most helpful, and gauges learning
progress.

■ Create Support Request. Provides direct one-to-one communication
with Autodesk support technicians. You receive fast, complete answers to
your installation, configuration, and troubleshooting questions.

■ View Support Requests. Allows you to track and manage your questions
and responses through Autodesk’s state-of-the-art support system.

■ Edit Subscription Center Profile. Allows you to set up and maintain
your subscription account.

Subscription Resources and Privacy

Subscription resources provide interactive product features over the Internet.
Each time you access subscription resource (such as e-Learning or Create
Support Request) from the Help menu in an Autodesk product, product
information (such as the serial number, version, language, and the subscription
contract ID) is sent to Autodesk for verification that your product is on
subscription.

Autodesk compiles statistics using the information sent to subscription
resources to monitor how they are being used and how they can be improved.
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Autodesk maintains the information provided by or collected from you in
accordance with Autodesk’s published privacy policy, which is available at
http://www.autodesk.com/privacy

Enable Subscription Resources

The CAD Manager Control utility can be used to turn Subscription resources
on and off in the Help menu. For more information about how to install the
utility, see "To install the Subscription Center (part of the CAD Manager
Control utility)." For more information about using the utility once it is
installed, click Help in the CAD Manager Control utility window.

To access the Subscription Center in the program

1 Click Help menu, and then click the subscription resource you want to
access.

NOTE Subscription Center is not available to all product users. If Subscription
Resources is not available on the Help menu in your product, your product is not
entitled to subscription benefits.

To install the Subscription Center (part of the CAD Manager Control utility)

1 Double-click setup.exe on the product CD.

2 In the Media Browser, Install tab, click either Multi-Seat Stand-Alone
Installation or Network Deployment.

3 Under Install Supplemental Tools, click Autodesk CAD Manager Tools
3.0.

4 Under Autodesk CAD Manager Tools 3.0, click Install.

After you install the CAD Manager Control utility, you access it from
the Start menu (Windows).

Receive Product Updates and Announcements
The Communication Center provides up-to-date product information, software
updates, product support announcements, and other product-related
announcements on your screen. The types of information and the frequency
of announcements can be easily configured to fit your needs.
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Overview of Communication Center

Communication Center provides the following kinds of announcements:

■ General Product Information. Stay informed about Autodesk company
news and product announcements; give your feedback directly to Autodesk.

■ Product Support Information. Get breaking news from the Product
Support team at Autodesk.

■ Subscription Information and Extension Announcements.Receive
announcements and subscription program news if you are an Autodesk
subscription member (available in countries/regions where Autodesk
subscriptions are offered).

■ Articles and Tips. Be notified when new articles and tips are available
on Autodesk websites.

You use the Welcome wizard to set Communication Center for your
country/region, and for the frequency you prefer for updates and the
information channels you want displayed.

To open Communication Center, click the Communication Center icon in
the tray on the right side of the status bar.

Communication Center Online Privacy

Communication Center is an interactive feature that must be connected to
the Internet to deliver content and information. Each time Communication
Center is connected, it sends information to Autodesk so that the correct
information can be returned. All information is sent anonymously to maintain
your privacy.
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The following information is sent to Autodesk:

■ Product Name. The name of the product in which you are using
Communication Center

■ Product Release Number. The version of the product

■ Product Language. The language version of your product

■ Country/Region. The country/region that was specified in the
Communication Center settings

■ Your Subscription Contract Number. The information sent to
Autodesk if you entered it in the Error Report dialog box

Autodesk compiles statistics using the information sent from Communication
Center to monitor how it is being used and how it can be improved. Autodesk
will maintain information provided by or collected from you in accordance
with the company’s published privacy policy, which is available on
http://www.autodesk.com/privacy
.

Turn Communication Center On or Off

The Autodesk CAD Manager Control utility turns Communication Center on
and off. For example, if you want to prevent Communication Center from
sending information to Autodesk, you can turn it off. Information about how
to use the utility is available by installing and running the utility, and then
clicking Help in the CAD Manager Control Utility window.

To install the Communication Center utility (part of the CAD Manager Control
utility)

1 Double-click setup.exe on the product CD.

2 In the Media Browser, Install tab, click either Multi-Seat Stand-Alone
Installation or Network Deployment.

3 Under Install Supplemental Tools, click Autodesk CAD Manager Tools
3.0.

4 Under Autodesk CAD Manager Tools 3.0, click Install.

After you install the CAD Manager Control utility, you access it from
the Start menu (Windows).
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Customize the Update and Announcement Options

After installing your Autodesk product, you configure Communication Center
with the Welcome wizard to specify the information you want sent to you.

■ Country/Region. Specifies your country/region so that Communication
Center can provide information that is designed specifically for your
location.

■ Update Frequency. Specifies how often you want Communication Center
to synchronize with Autodesk servers.

■ Balloon Notification. Turns on balloon notification so that
Communication Center balloon messages are displayed above the status
bar when a new announcement is received. If the balloon notifications
have been turned off in the tray settings, the Balloon Notification setting
in the Communication Center is ignored.

■ Channels. Specifies the information that you want displayed in
Communication Center.

To customize Communication Center options

1 Click the Communication Center icon located in the tray on the right
side of the status bar.

2 In the Communication Center window, click Settings.

3 In the Configuration Settings dialog box, choose the settings and options
that you want to use. Click Apply.

4 Click OK to close the Configuration Settings dialog box. Then, close the
Communication Center window.

Receive New Information Notifications

Whenever new information is available, Communication Center notifies you
by displaying a balloon message above the status bar.
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Click the balloon message to open the Communication Center window. If
you prefer to be notified by the Communication Center icon, you can turn
off Balloon Notification in the Configuration Settings dialog box of
Communication Center.

If no Communication Center icon is shown on the status bar, see your network
administrator.

To open the Communication Center window

■ Click the Communication Center icon located in the tray on the right side
of the status bar.

View the Product Readme
You can find late-breaking information about this software in the Readme.

It is suggested that you read through the Readme for information about
recommended hardware, updated installation instructions, and known software
problems.

■ View the Readme
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Menus, Toolbars, and
Tool Palettes

 

You can use several menus, shortcut menus, tool palettes,

and toolbars for access to frequently used commands, settings,

and modes.

2
In this chapter
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■ Toolbars

■ The Menu Bar

■ Shortcut Menus

■ The Object Snap Menu

■ Create Your Own Menu and
Toolbar Groups



Tool Palettes
Tool palettes are tabbed areas within the Tool Palettes window that provide
an efficient method for organizing, sharing, and placing blocks and hatches.
Tool palettes can also contain custom tools provided by third-party developers.

Create and Use Tools from Objects and Images

You can create a tool by dragging objects from your drawing onto a tool
palette. You can then use the new tool to create objects with the same
properties as the object you dragged onto the tool palette.

Tool palettes are tabbed areas within the Tool Palettes window. The items you
add to a tool palette are called tools. You can create a tool by dragging any of
the following, one at a time, onto your tool palette:

■ Geometric objects such as lines, circles, and polylines

■ Dimensions

■ Blocks

■ Hatches

■ Solid fills

■ Gradient fills

■ Raster images

■ External references (xrefs)

You can then use the new tool to create objects in your drawing with the same
properties as the object you dragged to the tool palette. For example, if you
drag a red circle with a lineweight of .05 mm from your drawing to your tool
palette, the new tool creates a red circle with a lineweight of .05 mm. If you
drag a block or xref to a tool palette, the new tool inserts the block or xref
with the same properties into your drawing.

When you drag a geometric object or a dimension onto a tool palette, the
new tool is automatically created with an appropriate flyout. Dimension tool
flyouts, for example, provide an assortment of dimension styles. Click the
arrow on the right side of the tool icon on the tool palette to display the flyout.
When you use a tool on a flyout, the object in the drawing will have the same
properties as the original tool on the tool palette.

For block and xref tools, you can choose to be prompted at the command line
for a rotation angle (starting from 0) when you click and place the block or
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xref. When you select this option, the angle that is specified under Rotation
in the Tool Properties dialog box is ignored. The prompt for a rotation angle
is not shown if you drag the block or xref or, if at the initial insertion command
line prompt, you enter rotate.

Blocks that are placed by dragging from a tool palette must often be rotated
or scaled after they are placed. You can use object snaps when dragging blocks
from a tool palette; however, grid snap is suppressed during dragging. You
can set an auxiliary scale for a block or a hatch tool to override the regular
scale setting when the tool is used. (An auxiliary scale multiplies your current
scale setting by the plot scale or the dimension scale.)

Scale Blocks Automatically

When a block is dragged from a tool palette into a drawing, it is scaled
automatically according to the ratio of units defined in the block and defined
in the current drawing. For example, if the current drawing uses meters as its
units and a block is defined using centimeters as its units, the ratio of the
units is 1 m/100 cm. When the block is dragged into the drawing, it is inserted
at 1/100 scale.

NOTE In the Options dialog box, User Preferences tab, the Source Content Units
and Target Drawing Units settings are used when Drag-and-Drop Scale is set to
Unitless, either in the source block or target drawing.

See also:

“Control Tool Properties” on page 31
“Customize Tool Palettes” on page 35
“Use Workspaces” on page 88
“Add Content with DesignCenter” on page 67

To display the Tool Palettes window

■ Click Tools menu ➤ Tool Palettes Window. Alternatively, you can press
CTRL+3.

Standard toolbar

To create a tool from an object in the current drawing

1 In the current drawing, select an object such as a dimension, block,
hatch, gradient fill, raster image, xref, or any geometric object.
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2 Drag the object to a tool palette and, without releasing the mouse button,
move the cursor to the place on the tool palette where you want the
tool.

The black line indicates where the tool will be located.

3 Release the mouse button.

Standard toolbar

TOOLPALETTES

To use a tool created from a geometric object

1 On a tool palette, click the geometric object tool you want to use.

2 Use the tool as if you selected the corresponding option from the Draw
menu or the corresponding button on the Draw toolbar, following the
prompts on the command line.

The geometric object you create will have the same properties as the tool
you selected from the tool palette.

Standard toolbar

TOOLPALETTES

To use a tool created from a dimension

1 On a tool palette, click the dimension tool you want to use.

2 Use the tool as if you selected the corresponding option from the
Dimension menu or the corresponding button on the Dimension toolbar,
following the prompts on the command line.

The dimension you create will have the same dimension style and
properties as the tool you selected from the tool palette.

Standard toolbar

TOOLPALETTES
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To use a tool on a tool flyout

1 On a tool palette, click the arrow on the right side of the dimension tool
or the geometric object tool you want to use.

2 On the flyout, select a tool.

3 Use the tool as if you selected the corresponding option from a menu
or the corresponding button on a toolbar, following the prompts on the
command line.

The object you create will have the same properties as the tool whose
icon you selected on the tool flyout.

Standard toolbar

TOOLPALETTES

To add or remove a tool flyout

1 On a tool palette, right-click the geometric object tool or the dimension
tool whose flyout you want to add or remove. Click Properties.

2 In the Tool Properties dialog box, under Command, click in the Use
Flyout box.

3 In the drop-down list, select Yes if you want to add a flyout, or select No
if you want to remove one.

4 Click OK.

NOTE If you remove the flyout from a tool but then add the flyout back,
the image, name, and description (the tooltip) that are shown on the tool
palette for each tool on the flyout will not be accurate. To correct this, you
must return the image, name, and description of the flyout tool to the default
settings. See “To change the image, name, and description of a flyout tool
to the default settings” on page 35.

Standard toolbar

TOOLPALETTES
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To customize a tool flyout

1 On a tool palette, right-click the geometric object tool or dimension tool
whose flyout you want to customize. Click Properties.

2 In the Tool Properties dialog box, under Command, click in the Flyout
Options box. Click the [...] button.

3 In the Flyout Options dialog box, select the tools that you want to be
shown on the flyout. Click OK. (At least one tool must be selected.)

4 In the Tool Properties dialog box, click OK.

Standard toolbar

TOOLPALETTES

To use a tool created from a hatch

1 On a tool palette, click a hatch tool and drag it to an object in the
drawing.

2 Release the mouse button to apply the hatch to the object.

The hatch you create will have the same hatch style and properties as
the tool you selected from the tool palette.

Standard toolbar

TOOLPALETTES

To use a tool created from a gradient fill

1 On a tool palette, click a gradient fill tool and drag it to an object in the
drawing.

2 Release the mouse button to apply the gradient fill to the object.

The gradient fill you create will have the same style and properties as
the tool you selected from the tool palette.

Standard toolbar
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TOOLPALETTES

To use a tool created from a block, xref, or raster image

1 On a tool palette, click the block, xref, or raster image you want to insert
into your drawing.

2 Drag the block, xref, or raster image to the appropriate place in the
drawing.

3 Release the mouse button to insert the block, xref, or raster image.

The block, xref, or raster image you insert will have the same properties
as the tool you selected from the tool palette.

Standard toolbar

TOOLPALETTES

To be prompted for a rotation angle when placing a block or xref from a tool
palette

1 In a tool palette, right-click a block or xref tool. Click Properties.

2 In the Tool Properties dialog box, under Insert, click Prompt for Rotation.

3 In the drop-down list, select Yes.

4 Click OK.

NOTE When you select this option, the angle that is specified under Rotation
in the Tool Properties dialog box is ignored. The prompt for a rotation angle
is not shown if you drag the block or xref or, if at the initial insertion
command line prompt, you enter rotate.

Standard toolbar

TOOLPALETTES
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Create and Use Command Tools

You can create a tool on a tool palette that executes a single command or a
string of commands.

You can add frequently used commands to a tool palette. When the Customize
dialog box is open, you can drag tools from a toolbar to a tool palette.

Once you add a command to a tool palette, you can click the tool to execute
the command. For example, clicking a Save tool on a tool palette saves a
drawing just as the Save button on the Standard toolbar does.

You can also create a tool that executes a string of commands or customized
commands, such as an AutoLISP®  routine, a VBA macro or application, or a
script.

To create a command tool

1 Make sure the toolbar that contains the command you want to add to
the tool palette is displayed.

If the required toolbar is not displayed, right-click any displayed toolbar
and select another toolbar from the list.

2 Right-click on the title bar of a tool palette. Click Customize to open the
Customize dialog box.

NOTE Even though you won’t make any changes in the Customize dialog
box in this procedure, it must be displayed when you add command tools
to a tool palette.

3 In the program, drag a command (button) from a toolbar to the tool
palette and, without releasing the mouse button, move the cursor to the
place on the tool palette where you want the tool.

The black line indicates where the tool will be located.

4 Release the mouse button.

5 In the Customize dialog box, click Close.

CUSTOMIZE

To create a command tool that executes multiple or customized commands
(advanced)

1 Right-click on the title bar of a tool palette. Click Customize.
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2 In the program, drag a command from a toolbar to the tool palette and,
without releasing the mouse button, move the cursor to the place on
the tool palette where you want the tool.

3 Release the mouse button.

4 On the tool palette, right-click the tool. Click Properties.

5 In the Tool Properties dialog box, change the name and description to
an appropriate name and description for the string, AutoLISP routine,
or script.

6 Under Command, in the Command String box, enter a string of
commands or customized commands, such as an AutoLISP routine, a
VBA macro or application, or a script.

7 Click OK.

CUSTOMIZE

To use a command tool

1 On a tool palette, click the command tool that you want to use.

2 Follow any prompts that are shown on the command line.

Change Tool Palette Settings

The options and settings for tool palettes are accessible from shortcut menus
that are displayed when you right-click in different areas of the Tool Palettes
window.

These settings include

■ Auto-hide. The Tool Palettes window can automatically roll open or roll
away (called rollover behavior) when your cursor moves over the title bar on
the Tool Palettes window.
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■ Transparency. The Tool Palettes window can be made transparent so it
does not obscure objects under it.

■ Views. The display style and size of the icons in a tool palette can be
changed.

You can dock the Tool Palettes window on the right or left edge of the
application window. Press the CTRL key if you want to prevent docking as
you move the Tool Palettes window.

Tool palette settings are saved with your profile.

To change the rollover behavior of the Tool Palettes window

■ Click the Auto-Hide button at the bottom of the title bar of the Tool Palettes
window.

Rollover behavior is on.

Rollover behavior is off.
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NOTE Rollover behavior is available only when the Tool Palettes window is
undocked.

To change the transparency of the Tool Palettes window

1 Right-click the title bar of the Tool Palettes window. Click Transparency.

2 In the Transparency dialog box, adjust the level of transparency for the
Tool Palettes window. Click OK.

NOTE Transparency is available only when the Tool Palettes window is
undocked.

To change the icon display style in the Tool Palettes window

1 Right-click a blank area inside the Tool Palettes window. Click View
Options.

2 In the View Options dialog box, click the icon display option that you
want to set. You can also change the size of the icons.

3 Click the list box under Apply To, and then select either Current Tool
Palette or All Tool Palettes.

4 Click OK.

Control Tool Properties

You can change the properties of any tool on a tool palette.

Once a tool is on a tool palette, you can change its properties. For example,
you can change the insertion scale of a block or the angle of a hatch pattern.
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To change tool properties, right-click on a tool, and then click Properties on
the shortcut menu to display the Tool Properties dialog box. The Tool
Properties dialog box has the following two categories of properties:

■ Insert or Pattern properties. Control object-specific properties such as
scale, rotation, and angle.

■ General properties. Override the current drawing property settings such
as layer, color, and linetype.

You can expand and collapse the property categories by clicking the arrow
buttons.

Update the Icon for a Tool

The icon for a block, xref, or raster image in a tool palette is not automatically
updated if its definition changes. If you change the definition for a block,
xref, or raster image, you can update the icon by right-clicking the tool in the
palette and selecting Update Tool Image. You must save the drawing before
you can update the tool image.

Alternatively, you can delete the tool, and then replace it using DesignCenter™.

Specify Overrides for Tool Properties

In some cases, you may want to assign specific property overrides to a tool.
For example, you may want a hatch to be placed automatically on a
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pre-specified layer, regardless of the current layer setting. This feature can save
you time and reduce errors by setting properties automatically when creating
certain objects.

The Tool Properties dialog box provides areas for each possible property
override.

Layer property overrides affect color, linetype, lineweight, plot style, and plot.
Layer property overrides are resolved as follows:

■ If a layer is missing from the drawing, that layer is created automatically.

■ If a layer to which you are adding content is currently turned off or frozen,
the layer is temporarily turned on or thawed.

To display the properties of a tool on a tool palette

1 On a tool palette, right-click a tool. Click Properties.

2 In the Tool Properties dialog box, use the scroll bar to view all tool
properties.

You can resize the Tool Properties dialog box by dragging an edge, or
you can expand and collapse the property categories by clicking the
double arrow buttons.

3 Click OK.

To change the property of a tool on a tool palette

1 On a tool palette, right-click a tool. Click Properties.

2 In the Tool Properties dialog box, click any property in the list of
properties and specify the new value or setting.

■ Properties listed under the Insert or Pattern category control
object-specific properties such as scale, rotation, and angle.

■ Properties listed under the General category override the current
drawing property settings such as layer, color, and linetype.

■ Auxiliary scale for a block or a hatch tool overrides the regular scale
setting when the tool is used. (An auxiliary scale multiplies your
current scale setting by the plot scale or the dimension scale.)

You can resize the Tool Properties dialog box by dragging an edge, or
you can expand and collapse the property categories by clicking the
arrow buttons.

3 Click OK.
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NOTE If you specify an image, name, or description for a tool that has a
flyout, that image, name, and description are displayed on the tool palette
for each tool on the flyout. To return the flyout tool’s image, name, and
description to their default settings, leave the corresponding boxes blank in
the Tool Properties dialog box.

Standard toolbar

To refresh the image of a block tool on a tool palette

1 On a tool palette, right-click a tool.

2 Click Update Tool Image.

NOTE You must save the drawing before you can update the tool image.

Standard toolbar

TOOLPALETTES

To change the image of a tool on a tool palette

1 On a tool palette, right-click a tool.

2 Click Properties.

3 In the Tool Properties dialog box, right-click in the Image area. Click
Specify Image.

NOTE In AutoCAD, this option is available only for geometric object,
dimension, and command tools.

4 In the Select Image File dialog box, locate the image file you want to
use.

5 Click Open to insert the new image.

6 In the Tool Properties dialog box, click OK.

NOTE If you specify an image for a tool that has a flyout, that image is
displayed on the tool palette for each tool on the flyout. To return the flyout
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tool images to their default images, see “To change the image, name, and
description of a flyout tool to the default settings” on page 35.

Standard toolbar

TOOLPALETTES

To change the image, name, and description of a flyout tool to the default
settings

1 On a tool palette, right-click a tool. Click Properties.

2 In the Tool Properties dialog box, right-click in the image area. Click
Delete Image.

3 Click in the Name box and delete the text.

4 Click in the Description box and delete the text.

5 Click OK.

NOTE Leaving the Image, Name, and Description boxes blank in the Tool
Properties dialog box will return the flyout tool’s image, name, and
description to their default settings.

Standard toolbar

TOOLPALETTES

Customize Tool Palettes

You can add tools to a tool palette with several methods.

You can create new tool palettes using the Properties button on the title bar
of the Tool Palettes window. Add tools to a tool palette with the following
methods:

■ Drag any of the following onto your tool palette: geometric objects such
as lines, circles, and polylines; dimensions; hatches; gradient fills; blocks;
xrefs; raster images.
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■ Drag drawings, blocks, and hatches from DesignCenter to the tool palette.
Drawings that are added to a tool palette are inserted as blocks when dragged
into the drawing.

■ Using the Customize dialog box, drag commands to a tool palette just as
you might add them to a toolbar.

■ Use Cut, Copy, and Paste to move or copy tools from one tool palette to
another.

■ Create a tool palette tab with predetermined content by right-clicking a
folder, a drawing file, or a block in the DesignCenter tree view, and then
clicking Create Tool Palette on the shortcut menu.

NOTE If the source drawing file for a block, xref, or raster image tool is moved
to a different folder, you must modify the tool that references it by right-clicking
the tool and, in the Tool Properties dialog box, specifying the new source file
folder.

Once tools are placed on a tool palette, you can rearrange them by dragging
them around or by sorting them. You can also add text and separator lines to
tool palettes.

36 | Chapter 3   Menus, Toolbars, and Tool Palettes



You can move a tool palette tab up and down the list of tabs by using the tool
palette shortcut menu or the Tool Palettes tab of the Customize dialog box.
Similarly, you can delete tool palettes that you no longer need. Tool palettes
that are deleted are lost unless they are first saved by exporting them to a file.
You can control the path to your tool palettes on the Files tab in the Options
dialog box. This path can be to a shared network location.

Read-Only Tool Palettes

If a tool palette file is set with a read-only attribute, a lock icon is displayed
in a lower corner of the tool palette. This indicates that you cannot modify
the tool palette beyond changing its display settings and rearranging the icons.

To apply a read-only attribute to a tool palette, right-click the tool palette
(ATC) file in the following location: C:\documents and settings\<user
name>\application data\autodesk\AutoCAD
2006\r16.2\enu\support\ToolPalette\Palettes. On the shortcut menu, click
Properties. On the General tab, select Read-only, and click OK.

To create a tool palette from a folder or a drawing

1 If DesignCenter is not already open, click Tools menu ➤ DesignCenter.

2 In the DesignCenter tree view or the content area, right-click a folder,
drawing file, or block. Click Create Tool Palette.

A new tool palette is created that contains all the blocks and hatches in
the selected folder or drawing.

Standard toolbar

To add text to a tool palette

1 Right-click a blank area inside the Tool Palettes window. Click Add Text.

2 In the text box, add the text you want to display in the window.

3 If necessary, drag the text to the appropriate location in the window.

Standard toolbar

TOOLPALETTES
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To add a separator line to a tool palette

1 Right-click a blank area inside the Tool Palettes window. Click Add
Separator.

2 If necessary, drag the separator to the appropriate location in the window.

Standard toolbar

TOOLPALETTES

To sort items in a tool palette

■ Right-click a blank area inside the Tool Palettes window. Click Sort By ➤

Name or Sort By ➤ Type.

NOTE Items are sorted in order, by text, separator, and tool.

Standard toolbar

TOOLPALETTES

Organize Tool Palettes

You can organize tool palettes into groups and specify which group of tool
palettes is displayed.

For example, if you have several tool palettes that contain hatch patterns, you
can create a group called Hatch Patterns. You can then add all your tool palettes
that contain hatch patterns to the Hatch Pattern group. When you set the
Hatch Pattern group as the current group, only those tool palettes you’ve
added to the group are displayed.

To create a tool palette group

1 Right-click on the title bar of a tool palette. Click Customize.

2 In the Customize dialog box, Tool Palettes tab, under Palette Groups,
right-click on the lower, blank area. Click New Group.
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If there are no groups listed in the Palette Groups area, you can create a
group by dragging a tool palette from the Tool Palettes area into the
Palette Groups area.

3 Enter a name for the tool palette group.

4 Click Close.

To add a tool palette to a tool palette group

1 Right-click on the title bar of a tool palette. Click Customize.

2 In the Customize dialog box, Tool Palettes tab, drag a tool palette from
the Tool Palettes area into a group in the Palette Groups area.

3 Click Close.

To remove a tool palette from a tool palette group

1 Right-click on the title bar of a tool palette. Click Customize.

2 In the Customize dialog box, Tool Palettes tab, under Palette Groups,
right-click the name of the tool palette you want to remove. Click
Remove.

You can also drag the tool palette into the Tool Palettes area to remove
it from a group.

3 Click Close.

To display a tool palette group

1 Right-click on the title bar of a tool palette.

2 Click the name of the tool palette group that you want to be shown.

You can also specify the tool palette group you want to be displayed using
the Customize dialog box. On the Tool Palettes tab, under Palette Groups,
right-click the group you want to be shown. Click Set Current.

To delete a tool palette group

1 Right-click on the title bar of a tool palette. Click Customize.

2 In the Customize dialog box, Tool Palettes tab, under Palette Groups,
right-click the tool palette group you want to delete. Click Delete.
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NOTE You cannot delete a tool palette group if it is set as the current group.
To delete a group that is set as the current group, you must first set another
group as the current group.

3 Click Close.

To delete all tool palette groups

1 Right-click on the title bar of a tool palette. Click All Palettes.

NOTE You must display all tool palettes so that no tool palette group is set
as the current group.

2 Right-click on the title bar of a tool palette. Click Customize.

3 In the Customize dialog box, Tool Palettes tab, under Palette Groups,
right-click a tool palette group. Click Delete.

4 Repeat step 3 until all tool palette groups are deleted.

5 When you are finished, click Close.

To rename a tool palette group

1 Right-click on the title bar of a tool palette. Click Customize.

2 In the Customize dialog box, Tool Palettes tab, under Palette Groups,
right-click the tool palette group you want to rename. Click Rename.

3 Enter a new name for the tool palette group.

4 Click Close.

To rearrange tool palette groups

1 Right-click on the title bar of a tool palette. Click Customize.

2 In the Customize dialog box, Tool Palettes tab, under Palette Groups,
click a tool palette group and drag it into the new position.

Any other tool palette groups contained in the group you move will also
be moved.

3 Click Close.

NOTE You cannot drag a tool palette group into a group that is contained
by it.
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To create a tool palette group within another one

1 Right-click on the title bar of a tool palette. Click Customize.

2 In the Customize dialog box, Tool Palettes tab, under Palette Groups,
right-click the tool palette group to which you want to add the new
group. Click New Group.

3 Enter a name for the new tool palette group.

4 Click Close.

To copy and paste a tool palette from one group to another

1 Right-click on the title bar of a tool palette. Click Customize.

2 In the Customize dialog box, Tool Palettes tab, under Palette Groups,
select the tool palette that you want to copy.

3 Press CTRL while you drag the selected tool palette to another group.

When you release the mouse button, a copy of the tool palette is
displayed in the new location.

4 Click Close.

To change the order of displayed tool palettes within a group

1 Right-click on the title bar of a tool palette. Click Customize.

2 In the Customize dialog box, Tool Palettes tab, under Palette Groups,
drag a tool palette to the new location in its tool palette group.

3 Click Close.

To change the order of displayed tool palettes when all of them are displayed

1 Right-click on the title bar of a tool palette. Click Customize.

2 In the Customize dialog box, Tool Palettes tab, under Tool Palettes, drag
a tool palette to the location you want.

When all tool palettes are displayed, they are shown in the order they
appear in this list.

3 Click Close.

To display all tool palettes

■ Right-click on the title bar of a tool palette. Click All Palettes.
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Save and Share Tool Palettes

Save and share a tool palette by exporting it or importing it as a tool palette
file.

You can save and share a tool palette by exporting it or importing it as a tool
palette file. You import and export a tool palette from the Tool Palettes tab
of the Customize dialog box. Tool palette files have an .xtp file extension.

Tool palettes can be used only in the version of AutoCAD in which they were
created. For example, you cannot use a tool palette that was created in
AutoCAD 2006 in AutoCAD 2005.

The default path for tool palette files is set on the Files tab of the Options
dialog box under Tool Palettes File Locations.

Tool palette groups are saved in profiles.

If you send tool palettes to someone who uses AutoCAD LT, note that some
tools created in AutoCAD do not behave the same way or work in AutoCAD
LT. Note the following limitations:

■ The color property of tools that use a color other than an AutoCAD Color
Index (ACI) color convert to ByLayer in AutoCAD LT.

■ Gradient fill tools switch to hatch tools in AutoCAD LT.

■ Raster image tools do not work in AutoCAD LT.

NOTE If a tool palette file is set with a read-only attribute, a lock icon is displayed
in a lower corner of the tool palette. This indicates that you cannot modify the
tool palette beyond changing its display settings and rearranging the icons.

See also:

“Save and Restore Profiles” on page 87

Toolbars
Use buttons on toolbars to start commands, display flyout toolbars, and display
tooltips. You can display or hide, dock, and resize toolbars.

Toolbars contain buttons that start commands. When you move your mouse
or pointing device over a toolbar button, the tooltip displays the name of the
button. Buttons with a small black triangle in the lower-right corner are flyout
toolbars that contain related commands. With the cursor over the icon, hold
down the left button on your mouse until the flyout toolbar is displayed.
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The Standard toolbar at the top of the drawing area is displayed by default.
This toolbar is similar to those found in Microsoft®  Office programs. It
contains frequently used AutoCAD commands such as , , and , as well as
Microsoft Office standard commands such as New, Open, and Save.

Display or Hide, Dock, and Resize Toolbars

AutoCAD initially displays several toolbars:

■ Standard toolbar

■ Styles toolbar

■ Layers toolbar

■ Properties toolbar

■ Draw toolbar

■ Modify toolbar

You can display or hide these toolbars and additional ones. You can also create
your own toolbars.

A toolbar can be floating or docked. A floating toolbar is located anywhere in
the drawing area, and you can drag a floating toolbar to a new location, resize
it, or dock it. A docked toolbar is attached to any edge of the drawing area.
You can move a docked toolbar by dragging it to a new docking location.

See also:

“Customize Toolbars” in the Customization Guide

To display a toolbar

1 Right-click any toolbar and click a toolbar on the shortcut menu.

To dock a toolbar

1 Position the cursor on the name of the toolbar or in any blank area, and
hold down the button on your pointing device.

2 Drag the toolbar to a docking location at the top, bottom, or either side
of the drawing area.

3 When the outline of the toolbar is displayed in the docking area, release
the button.

To place a toolbar in a docking region without docking it, hold down
CTRL as you drag.
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To undock a toolbar

1 Position the cursor on the double bars at the end of the toolbar, and
hold down the button on your pointing device.

2 Drag the toolbar away from its docked location and release the button.

To resize a toolbar

1 Position the cursor on the edge of a floating toolbar until the cursor
changes to a horizontal or vertical double arrow.

2 Hold down the button and move the cursor until the toolbar is in the
shape you want.

To close a toolbar

1 If the toolbar is docked, undock it.

2 Click the Close button in the upper-right corner of the toolbar.

The Menu Bar
Display pull-down menus from the menu bar using one of several methods.
You can also specify alternate menus.

Menus are available from the menu bar at the top of the AutoCAD drawing
area.

You can specify menus to display in the program by customizing a CUI file
and loading it into the program.

See also:

“Create Pull-Down and Shortcut Menus” in the Customization Guide

To use a menu

Choose one of the following methods:

■ On the menu bar, click a menu name to display a list of options. On the
menu, either click an option or use the DOWN ARROW to move down the
list, and then press ENTER.

■ Press ALT and press the key for the underlined letter in the menu name;
then, press the underlined letter in the option name. For example, to open
a new drawing, press ALT and press F to open the File menu; then, press N
for New.
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Shortcut Menus
Display a shortcut menu for quick access to commands that are relevant to
your current activity.

You can display different shortcut menus when you right-click different areas
of the screen, including

■ Within the drawing area with or without any objects selected

■ Within the drawing area during a command

■ Within the text and command windows

■ Within areas and on icons in DesignCenter

■ Within areas and on text in the In-Place Text Editor

■ On a toolbar or tool palette

■ On the Model or layout tabs

■ On the status bar or the status bar buttons

■ In certain dialog boxes

Shortcut menus typically include options to

■ Repeat the last command entered

■ Cancel the current command

■ Display a list of recent user input

■ Cut, copy, and paste from the Clipboard

■ Select a different command option

■ Display a dialog box, such as Options or Customize

■ Undo the last command entered

You can customize right-click behavior to be time-sensitive, so that a quick
right-click acts the same as pressing ENTER, and a longer right-click displays
a shortcut menu.

Shortcut menus can be customized using a customization (CUI) file. The main
CUI file is called acad.cui by default.
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See also:

“Create Submenus” in the Customization Guide

To display a shortcut menu

1 At the Command prompt, move the cursor over an area, feature, or icon.

2 Right-click your mouse, or press the equivalent button on your pointing
device.

A shortcut menu relevant to the cursor location is displayed. If one or
more objects are selected when you right-click in the drawing area, an
editing-oriented shortcut menu is displayed. You can also display a
shortcut menu during PAN or ZOOM.

To turn off shortcut menus in the drawing area

1 Click Tools menu ➤ Options.

2 In the Options dialog box, User Preferences tab, under Windows Standard
Behavior, clear Shortcut Menus in Drawing Area.

3 To control Default, Edit, and Command shortcut menus individually,
select Shortcut Menus in Drawing Area. Right-Click Customization.

4 In the Right-Click Customization dialog box, under Default Mode or
Edit Mode, select one of the following options to control what happens
when you right-click in the drawing area and no command is in progress:

■ Repeat Last Command. Repeats the last command. Selecting this
option turns off the Default and Edit shortcut menus. Right-clicking
is the same as pressing  ENTER .

■ Shortcut Menu. Displays the Default or Edit shortcut menu.

5 Under Command Mode, select one of the following options to determine
what happens when you right-click in the drawing area while a command
is in progress:

■ Enter . Turns off the Command shortcut menu. Right-clicking is the
same as pressing  ENTER .

■ Shortcut Menu: Always Enabled . Displays the Command shortcut
menu.

■ Shortcut Menu: Enabled When Command Options Are
Present . Displays the Command shortcut menu only when options
are currently available in the Command prompt. In a Command
prompt, options are enclosed in square brackets. If no options are
available, right-clicking is the same as pressing  ENTER.
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In addition to turning the Default, Edit, and Command shortcut menus
on and off, you can customize the options that are displayed on them.
For example, you can add options to the Edit shortcut menu that are
displayed only when circles are selected.

To turn on time-sensitive right-click behavior

1 Click Tools menu ➤ Options.

2 In the Options dialog box, User Preferences tab, under Windows Standard
Behavior, click Right-Click Customization.

3 In the Right-Click Customization dialog box, select Turn on
Time-Sensitive Right-Click.

You can specify the duration of the longer click. The default is 250
milliseconds

4 Click Apply & Close.

5 In the Options dialog box, click OK.

To control the display of icons and notifications in the status bar tray

1 Click the arrow at the right end of the status bar, and then click Tray
Settings.

2 In the Tray Settings dialog box, select or clear the following display
options:

■ Display Icons from Services. Displays the tray at the right end of
the status bar and displays icons from services. When this option is
cleared, the tray is not displayed.

■ Display Notifications from Services. Displays notifications from
services such as Communications Center. When the Display Icons
from Services option is cleared, this option is unavailable.

3 If Display Notifications from Services is selected, set a time for a
notification to be displayed, or select Display Until Closed.

4 Click OK.

Right-click an empty area on the status bar. Click Tray Settings.

To control the display of buttons on the status bar

■ Click the arrow at the right end of the status bar and click any button name
to change the display.
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Items with a check mark next to them are displayed on the status bar.

Right-click an empty area on the status bar. Click a button name.

To control the display of coordinates on the status bar

■ Click the arrow at the right end of the status bar and click Cursor Coordinate
Values.

Items with a check mark next to them are displayed on the status bar.

Right-click an empty area on the status bar. Click Cursor Coordinate Values.

To control the display of recent input

1 At the Command prompt, enter inputhistorymode.

2 Enter a sum of one or more of the following values:

■ 0. No history of recent input is displayed.

■ 1. History of recent input is displayed at the command line with access
through Up Arrow and Down Arrow keys.

■ 2. History of recent input for the current command is displayed in
the shortcut menu.

■ 4. History of recent input for all commands in the current session is
displayed in the shortcut menu.

■ 8. Markers for recent input of point locations are displayed in the
drawing.

The default value is 15.

3 (Optional) At the Command prompt, enter cmdinputhistorymax.

4 Enter a value to control how many unique values entered at a prompt
are remembered and available to be displayed as recent input.

The Object Snap Menu
Specify an object snap quickly and conveniently from a shortcut menu.

The object snap menu is displayed at your cursor location when you hold
down SHIFT and click the right mouse button or the equivalent button on
another pointing device.
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The default object snap menu lists object snaps and tracking options. If you
want to change the options, you can modify a customization file. The main
customization file that’s shipped with the product is acad.cui.

See also:

“Create Pull-Down and Shortcut Menus” in the Customization Guide

To display the object snap menu

1 Enter any command that prompts you to specify a point. For example,
enter line.

2 At the From Point prompt, hold down  SHIFT  and right-click.

The object snap menu is displayed, and you can click an object snap
option.

Create Your Own Menu and Toolbar Groups
Create your own menu and toolbar groups in a workspace.

You can identify task specific toolbars and menus for each workspace that
you create or use.

For more information about how toolbars and menus interact with workspaces,
see “Use Workspaces” on page 88 and Customize Workspaces in the
Customization Guide.
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The Command Window

 
Commands, system variables, options, messages, and prompts

are displayed in a dockable and resizable window called the

command window. The bottom line of the command window

is called the command line. The command line displays the

operation in progress and provides an inside view of exactly

what the program is doing.

3
In this chapter

■ Enter Commands on the
Command Line

■ Enter System Variables on the
Command Line

■ Navigate and Edit Within the
Command Window

■ Switch Between Dialog Boxes
and the Command Line

■ Dock, Resize, and Hide the
Command Window



Enter Commands on the Command Line
You can enter a command by using the keyboard. Some commands also have
abbreviated names called command aliases.

To enter a command by using the keyboard, type the full command name on
the command line and press ENTER or SPACEBAR.

NOTE When Dynamic Input is on and is set to display dynamic prompts, you can
enter many commands in tooltips near the cursor.

Some commands also have abbreviated names. For example, instead of entering
line to start the  command, you can enter l. Abbreviated command names
are called command aliases and are defined in the acad.pgp file.

To define your own command aliases, see “Create Command Aliases” in the
Customization Guide.

To find a command, you can type a letter on the command line and press
TAB to cycle through all the commands that begin with that letter. Press
ENTER or SPACEBAR. Restart a recently used command by right-clicking on
the command line.

Specify Command Options

When you enter commands on the command line, you see either a set of
options or a dialog box. For example, when you enter circle at the Command
prompt, the following prompt is displayed:

Specify center point for circle or [3P/2P/Ttr (tan, tan, radius)]:
You can specify the center point either by entering X,Y coordinate values or
by using the pointing device to click a point on the screen.

To choose a different option, enter the letters capitalized in one of the options
in the brackets. You can enter uppercase or lowercase letters. For example, to
choose the three-point option (3P), enter 3p.

Execute Commands

To execute commands, press SPACEBAR or ENTER, or right-click your pointing
device after entering command names or responses to prompts. The
instructions in Help assume this step and do not specifically instruct you to
press ENTER after each entry.

Repeat and Cancel Commands

If you want to repeat a command that you have just used, press  ENTER  or
SPACEBAR , or right-click your pointing device at the Command prompt.
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You also can repeat a command by entering multiple, a space, and the
command name, as shown in the following example:

Command: multiple circle

To cancel a command in progress, press  ESC .

Interrupt a Command with Another Command or System Variable

Many commands can be used transparently: that is, they can be entered on
the command line while you use another command. Transparent commands
frequently change drawing settings or display options, for example,  or . In
the Command Reference, transparent commands are designated by an apostrophe
in front of the command name.

To use a command transparently, click its toolbar button or enter an
apostrophe (') before entering the command at any prompt. On the command
line, double angle brackets (>>) precede prompts that are displayed for
transparent commands. After you complete the transparent command, the
original command resumes. In the following example, you turn on the dot
grid and set it to one-unit intervals while you draw a line, and then you
continue drawing the line.

Command: line
Specify first point: 'grid
>>Specify grid spacing (X) or [ON/OFF/Snap/Aspect] <0.000>: 1
Resuming  command
Specify first point:

Commands that do not select objects, create new objects, or end the drawing
session usually can be used transparently. Changes made in dialog boxes that
you have opened transparently cannot take effect until the interrupted
command has been executed. Similarly, if you reset a system variable
transparently, the new value cannot take effect until you start the next
command.

See also:

“Add Shortcut Keys and Temporary Override Keys” in the Customization Guide

To copy a command you have recently used

1 Right-click on the command line. Click Recent History.

2 Click the command you want to use.
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Enter System Variables on the Command Line
System variables are settings that control how certain commands work.

They can turn on or turn off modes such as Snap, Grid, or Ortho. They can
set default scales for hatch patterns. They can store information about the
current drawing and about program configuration. Sometimes you use a system
variable in order to change a setting. At other times you use a system variable
to display the current status.

For example, the  system variable turns the dot grid display on and off when
you change the value. In this case, the GRIDMODE system variable is
functionally equivalent to the  command.  is a read-only system variable that
stores the current date. You can display this value, but you cannot change it.

You can examine or change a system variable's setting transparently, that is,
while using another command; however, new values may not take effect until
the interrupted command ends.

To change the setting of a system variable

1 At the Command prompt, enter the system variable name. For example,
enter gridmode to change the grid setting.

2 To change the status of GRIDMODE, enter 1 for on or 0 for off. To retain
the current value of the system variable, press ENTER.

To see a complete list of system variables

1 At the Command prompt, enter setvar.

2 At the Variable Name prompt, enter ?.

3 At the Enter Variable(s) to List prompt, press ENTER.

Navigate and Edit Within the Command
Window

You can edit text in the command window to correct or repeat commands.

Use the standard keys:

■ UP, DOWN, LEFT ARROW, and  RIGHT ARROW

■ INS, DEL
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■ PAGE UP, PAGE DOWN

■ HOME, END

■ BACKSPACE

You can repeat any command used in the current session by cycling through
the commands in the command window with UP ARROW and DOWN ARROW
and pressing ENTER. By default, pressing CTRL+C copies highlighted text to
the Clipboard. Pressing CTRL+V pastes text from the Clipboard to the text
window or the command window.

If you right-click in the command window or text window, a shortcut menu
is displayed from which you can access the six most recently used commands,
copy selected text or the entire command history, paste text, and access the
Options dialog box.

For most commands, a command line with two or three lines of previous
prompts, called the command history, is sufficient for viewing and editing.
To see more than one line of command history, you can scroll through the
history or resize the command window by dragging its border. For commands
with text output, such as , you might need a larger command window, or you
can press F2 to use the text window.

Use the Text Window

The text window is a window similar to the command window in which you
can enter commands and view prompts and messages. The text window
displays a complete command history for the current work session. Use the
text window to view lengthy output of commands such as LIST, which displays
detailed information about objects you select. To move forward and backward
in the command history, you can click the scroll arrows along the right edge
of the window.

Press SHIFT with a key to highlight text. For example, press SHIFT+HOME in
the text window to highlight all text from the cursor location to the beginning
of the line.

To copy all the text in the text window to the Clipboard, use the  command.

See also:

“Dock, Resize, and Hide the Command Window” on page 57
“Use Dynamic Input” on page 335

To display the text window

■ From within the drawing area, press F2.
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The text window is displayed in front of the drawing area.

To close the text window

■ From within the text window, press F2.

The text window is closed. You can also close the text window using the
standard Windows controls.

To copy text from the text window to the command line

1 If the text window is not displayed, press  F2  to display it.

2 Select the text you want to copy.

3 Right-click in the command window or text window. Click Paste to
Command Line.

The text is copied to the Clipboard and then pasted on the command
line. After you press ENTER, the commands are executed in sequence,
like a script. You can also use  CTRL + C  and  CTRL + V  to copy and
paste text.

,

Switch Between Dialog Boxes and the
Command Line

You can display prompts on the command line instead of using a dialog box,
or switch back again. This option is useful primarily when using scripts.

Some functions are available both on the command line and in a dialog box.
In many cases, you can enter a hyphen before the command to suppress the
dialog box and display prompts on the command line instead. For example,
entering layer on the command line displays the Layer Properties Manager.
Entering -layer on the command line displays the equivalent command line
options. Suppressing the dialog box is useful for compatibility with earlier
versions of AutoCAD and for using script files. There may be slight differences
between the options in the dialog box and those available on the command
line.

These system variables also affect the display of dialog boxes:

■ controls whether  uses a dialog box for attribute value entry.

■ displays the name (in English) of the currently active command and
transparent command.
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■ controls whether certain warning dialog boxes are displayed.

■ controls the display of dialog boxes used with commands that read and
write files. For example, if FILEDIA is set to 1,  displays the Save Drawing
As dialog box. If FILEDIA is set to 0, SAVEAS displays prompts on the
command line. The procedures in this documentation assume that FILEDIA
is set to 1. Even when FILEDIA is set to 0, you can display a file dialog box
by entering a tilde (~) at the first prompt.

FILEDIA and EXPERT are useful when you use scripts to run commands.

To use the command line version of a command

■ For most commands, enter minus (-) in front of the command.

■ For dialog boxes that open and save files, set the FILEDIA system variable
to 0.

Dock, Resize, and Hide the Command
Window

To relocate and resize the command window for your convenience, drag it or
use the splitter bar. To hide the command window, click Command Line on
the Tools menu.

By default, the command window is docked. The docked command window
is the same width as the AutoCAD window. If text that is entered becomes
longer than the width of the command line, the window pops up in front of
the command line to show the full text of the line.

You can resize the window vertically by dragging the splitter bar, which is
located on the top edge of the window when it is docked on the bottom and
at the bottom edge of the window when it is docked at the top.

Undock the command window by dragging it away from the docking region.
You can move the floating command window anywhere on the screen and
resize its width and height with the pointing device.

Dock the command window by dragging it until it is over the top or bottom
docking region of the AutoCAD window.

Hide the command line by clicking the Tools menu ➤ Command Line (or
press CTRL+9). When you hide the command line, you can still enter
commands. However, some commands and system variables return values at
the command line, so you may want to display the command line in those
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instances. To display the command line when it’s hidden, click the Tools
menu ➤ Command Line (or press CTRL+9).

NOTE For information about display options (such as auto-hide or transparency)
for dockable windows, see “Control the Size, Location, and Appearance of Dockable
Windows” in the topic “Set Interface Options” on page 80.

To float the command window

■ Click the move handle on the left edge of the docked command window
and drag the command window away from the docking region until it has
a thick outline. Then drop it in the drawing area of the AutoCAD window.

To make the floating command window transparent

1 Right-click in the floating command window. Click Transparency.

2 In the Transparency dialog box, move the slider to the left to make the
command window less transparent and to the right to make it more
transparent.

The range is from opaque to transparent. When the Turn Off
Transparency for All Palettes option is selected, the command window
cannot be made transparent.

To dock the command window

■ Click the title bar and drag the command window until it is over the top
or bottom docking region of the AutoCAD window.

To resize the command window when it is docked

1 Position the cursor over the horizontal splitter bar so that the cursor
appears as a double line and arrows.

2 Drag the splitter bar vertically until the command window is the size
you want it to be.

To hide the command window

■ On the Tools menu, click Command Line.

NOTE Some commands and system variables return values at the command
line, so you may want to display the command line in those instances. To display
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the command line when it’s hidden, press CTRL+9 or click the Tools menu ➤
Command Line.
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DesignCenter

 
With DesignCenter, you can organize access to blocks,

hatches, xrefs, and other drawing content. You can drag

content from any source drawing to your current drawing.

You can drag drawings, blocks, and hatches to a tool palette.

Source drawings can be on your computer, on a network

location, or on a website. In addition, if you have multiple

drawings open, you can use DesignCenter to streamline your

drawing process by copying and pasting other content, such

as layer definitions, layouts, and text styles between drawings.

4
In this chapter

■ Overview of DesignCenter

■ Understand the DesignCenter
Window

■ Access Content with
DesignCenter

■ Add Content with
DesignCenter

■ Retrieve Content from the
Web with DesignCenter
Online



Overview of DesignCenter
With DesignCenter, you can

■ Browse for drawing content such as drawings or symbol libraries on your
computer, on a networked drive, and on a web page

■ View definition tables for named objects such as blocks and layers in any
drawing file and then insert, attach, or copy and paste the definitions into
the current drawing

■ Update (redefine) a block definition

■ Create shortcuts to drawings, folders, and Internet locations that you access
frequently

■ Add content such as xrefs, blocks, and hatches to a drawing

■ Open drawing files in a new window

■ Drag drawings, blocks, and hatches to a tool palette for convenient access

Understand the DesignCenter Window
You can control the size, location, and appearance of DesignCenter.

The Organization of the DesignCenter Window

The DesignCenter window is divided into the tree view on the left side and
the content area on the right side. Use the tree view to browse sources of
content and to display content in the content area. Use the content area to
add items to a drawing or to a tool palette.

Undocked, the DesignCenter window is displayed as shown.
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Below the content area, you can also display a preview or a description of a
selected drawing, block, hatch pattern, or xref. A toolbar at the top of the
window provides several options and operations.

Control the Size, Location, and Appearance of DesignCenter

You can control the size, location, and appearance of DesignCenter.

■ Resize DesignCenter by dragging the bar between the content area and the
tree view or by dragging an edge as you would any other window.

■ Dock DesignCenter by dragging it over the right or left docking region of
the AutoCAD®  window until it snaps into the docked position. You can
also dock the DesignCenter window by double-clicking its title bar.

■ Undock DesignCenter by dragging the area above the toolbar away from
the docking region. Pressing CTRL while dragging prevents docking.

■ Change the automatic rollover behavior of DesignCenter by clicking the
Auto-hide button on the DesignCenter title bar.

When the DesignCenter rollover option is turned on, the DesignCenter tree
view and content area disappear when you move your cursor off the
DesignCenter window, leaving only the title bar. When you move your cursor
over the title bar, the DesignCenter window is restored.

Several options are available on the shortcut menu that is displayed when you
right-click on the DesignCenter title bar.

The DesignCenter Toolbar

The DesignCenter toolbar controls navigation and display of information in
the tree view and the content area. For information about these buttons, see
the  command. The same navigation and display options are available on a
shortcut menu. Right-click in the DesignCenter content area.

To change the DesignCenter rollover behavior

1 If DesignCenter is not already open, click Tools menu ➤ DesignCenter.

2 Right-click the DesignCenter title bar. Click Auto-hide.

When the DesignCenter rollover option is turned on, the DesignCenter
tree view and content area disappear when you move your cursor off
the DesignCenter window, leaving only the title bar. When you move
your cursor over the title bar, the DesignCenter window is restored.

Standard toolbar
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To prevent DesignCenter from docking

1 If DesignCenter is not already open, click Tools menu ➤ DesignCenter.

2 Click and hold on the DesignCenter title bar. Press CTRL as you move
your mouse.

Standard toolbar

To display and hide the DesignCenter tree view

1 If DesignCenter is not already open, click Tools menu ➤ DesignCenter.

2 On the DesignCenter toolbar, click Tree View Toggle.

Standard toolbar

Right-click the content area background and click Tree.

Access Content with DesignCenter
The tree view in the left portion of the DesignCenter window and the four
DesignCenter tabs help you find and load content into the content area.

Folders Tab

The Folders tab displays a hierarchy of navigational icons, including

■ Networks and computers
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■ Web addresses (URLs)

■ Computer drives

■ Folders

■ Drawings and related support files

■ Xrefs, layouts, hatch styles, and named objects, including blocks, layers,
linetypes, text styles, dimension styles, and plot styles within a drawing

Click an item in the tree view to display its contents in the content area. Click
the plus (+) or minus (-) sign to display and hide additional levels in the
hierarchy. You can also double-click an item to display deeper levels.
Right-clicking in the tree view displays a shortcut menu with several related
options.

Open Drawings, History, and DC Online Tabs

The Open Drawings, History, and DC Online tabs provide alternate methods
of locating content.

■ Open Drawings. Displays a list of the drawings that are currently open.
Click a drawing file and then click one of the definition tables from the list
to load the content into the content area.

■ History. Displays a list of files opened previously with DesignCenter.
Double-click a drawing file from the list to navigate to the drawing file in
the tree view of the Folders tab and to load the content into the content
area.

■ DC Online. Provides content from the DesignCenter Online web page
including blocks, symbol libraries, manufacturer's content, and online
catalogs.

Bookmark Frequently Used Content

DesignCenter provides a solution to finding content that you need to access
quickly on a regular basis. Both the tree view and the content area include
options that activate a folder called Favorites. The Favorites folder can contain
shortcuts to content on local or network drives as well as in Internet locations.

When you select a drawing, folder, or another type of content and choose
Add to Favorites, a shortcut to that item is added to the Favorites folder. The
original file or folder doesn't actually move; in fact, all the shortcuts you create
are stored in the Favorites folder. The shortcuts saved in the Favorites folder
can be moved, copied, or deleted using Windows® Explorer.
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To change the source of the content displayed in DesignCenter

1 If DesignCenter is not already open, click Tools menu ➤ DesignCenter.

2 On the DesignCenter window, click one of the following tabs:

■ Folders. Lists your local and network drives.

■ Open Drawings. Lists the drawings that are currently open.

■ History. Lists the last 20 locations accessed through DesignCenter.

■ DC Online. Displays online content from the Web.

Standard toolbar

To change the folder of the Home button in DesignCenter

1 If DesignCenter is not already open, click Tools menu ➤ DesignCenter.

2 In the DesignCenter tree view, navigate to the folder that you want to
set as home.

3 Right-click on the folder. Click Set as Home.

When you click the Home button, DesignCenter will automatically load this
folder.

Standard toolbar

To add items to the Favorites folder in DesignCenter

1 If DesignCenter is not already open, click Tools menu ➤ DesignCenter.

2 Right-click the item in the DesignCenter tree view or content area. Click
Add to Favorites.

Standard toolbar

66 | Chapter 5   DesignCenter



To display the contents of the Favorites folder in DesignCenter

1 If DesignCenter is not already open, click Tools menu ➤ DesignCenter.

2 In DesignCenter, click the Favorites button.

When you are working in the tree view, you can use the Folders tab to
navigate to the Favorites folder.

Standard toolbar

To organize your DesignCenter Favorites folder

1 If DesignCenter is not already open, click Tools menu ➤ DesignCenter.

2 In DesignCenter, click the Favorites button.

3 Right-click the background in the content area. Click Organize Favorites.

Your Autodesk Favorites folder is opened in a window.

Standard toolbar

Add Content with DesignCenter
The right portion of the DesignCenter window operates on the content
displayed.

Double-clicking an item in the content area displays successive levels of detail.
For example, double-clicking a drawing image displays several icons, including
an icon for blocks. Double-clicking the Blocks icon displays images of each
block in the drawing.

Add Content to a Drawing

You can add content from the content area into your current drawing using
several methods:

■ Drag an item to the graphics area of a drawing to add it using default
settings, if any.

■ Right-click an item in the content area to display a shortcut menu with
several options.
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■ Double-click a block to display the Insert dialog box; double-click a hatch
to display the Boundary Hatch and Fill dialog box.

You can preview graphical content such as a drawing, xref, or block in the
content area, and you can display a text description if available.

Update Block Definitions with DesignCenter

Unlike xrefs, when the source file of a block definition is changed, block
definitions in the drawings that contain that block are not automatically
updated. With DesignCenter, you decide whether a block definition should
be updated in the current drawing. The source file of a block definition can
be a drawing file or a nested block in a symbol library drawing.

From the shortcut menu displayed when you right-click a block or drawing
file in the content area, click Redefine Only or Insert and Redefine to update
the selected block.

Open Drawings with DesignCenter

With DesignCenter, you can open a drawing from the content area using the
shortcut menu, pressing CTRL while dragging a drawing, or dragging a drawing
icon to any location outside the graphics area of a drawing area. The drawing
name is added to the DesignCenter history list for quick access in future
sessions.

Add Items from DesignCenter to a Tool Palette

You can add drawings, blocks, and hatches from DesignCenter to the current
tool palette.

■ From the DesignCenter content area, you can drag one or more items to
the current tool palette.

■ From the DesignCenter tree view, you can right-click and, from the shortcut
menu, create a new tool palette from the current folder, drawing file, or
block icon.

When you add drawings to a tool palette, they are inserted as blocks when
you drag them into the current drawing.

NOTE You can select multiple blocks or hatches from the content area to add
them to a tool palette.

To create a tool palette containing DesignCenter content

1 If DesignCenter is not already open, click Tools menu ➤ DesignCenter.
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2 Do one of the following:

■ Right-click an item in the DesignCenter tree view. Click Create Tool
Palette. The new tool palette contains the drawings, blocks, or hatches
from the item you selected.

■ Right-click the background in the DesignCenter content area. Click
Create Tool Palette. The new tool palette contains the drawings, blocks,
or hatches from the DesignCenter content area.

■ Right-click a drawing in the DesignCenter tree view or content area.
Click Create Tool Palette of Blocks. The new tool palette contains the
blocks from the drawing you selected.

You can drag additional drawings, blocks, or hatches from the
DesignCenter content area to the tool palette.

Standard toolbar

To load the content area from the DesignCenter Search dialog box

1 If DesignCenter is not already open, click Tools menu ➤ DesignCenter.

2 In DesignCenter, use one of the following methods:

■ Drag the item from the search results list into the content area.

■ Double-click the item in the search results list.

■ Right-click the item in the search results list. Click Load into Content
Area.

3 In the DesignCenter content area, double-click the Blocks icon.

Standard toolbar

To load the content area of DesignCenter with a symbol library

1 If DesignCenter is not already open, click Tools menu ➤ DesignCenter.

2 On the DesignCenter toolbar, click Home.
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3 In the content area, double-click the symbol library drawing that you
want to load into the DesignCenter and then double-click the Blocks
icon.

The symbol library you selected is loaded into the DesignCenter content
area.

NOTE You can set your home folder to any folder that contains symbol library
drawings. If your home folder is set to a different path, navigate to a folder that
contains symbol library drawings and right-click on the folder. Click Set as Home.

Standard toolbar

To load the content area of DesignCenter with hatch patterns

1 If DesignCenter is not already open, click Tools menu ➤ DesignCenter.

2 On the DesignCenter toolbar, click Search.

3 In the Search dialog box, click the Look For box. Click Hatch Pattern
Files.

4 On the Hatch Pattern Files tab, in the Search for the Name box, enter *.

5 Click Search Now.

6 Double-click one of the hatch pattern files that was found.

The hatch pattern file you selected is loaded into DesignCenter.

Standard toolbar

To open a drawing from DesignCenter

1 If DesignCenter is not already open, click Tools menu ➤ DesignCenter.

2 In DesignCenter, do one of the following:

■ Right-click the drawing icon in the DesignCenter content area. Click
Open in Application Window.

■ Press CTRL and drag the drawing icon from the DesignCenter content
area to the drawing area.
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■ Drag the drawing icon from the DesignCenter content area to a
location anywhere outside the drawing area of the application window.
(If you drag the drawing icon into the drawing area, a block is created
in the current drawing.)

Standard toolbar

To update a block definition with DesignCenter

1 If DesignCenter is not already open, click Tools menu ➤ DesignCenter.

2 Right-click a block in the DesignCenter content area. Click Redefine
Only or Insert and Redefine.

NOTE If the source of the block that you want to update is an entire drawing
file rather than a block definition within a drawing file, right-click the
drawing’s icon in the DesignCenter content area. Click Insert as Block.

Standard toolbar

Retrieve Content from the Web with
DesignCenter Online

DesignCenter Online provides access to pre-drawn content such as blocks,
symbol libraries, manufacturers’ content, and online catalogs.

Overview of DesignCenter Online

DesignCenter Online provides access to pre-drawn content such as blocks,
symbol libraries, manufacturers' content, and online catalogs. This content
can be used in common design applications to assist you in creating your
drawings.

To access DesignCenter Online, click the DC Online tab in DesignCenter.
Once the DesignCenter Online window is open, you can browse, search, and
download content to use in your drawing.
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In the DesignCenter Online window, two panes are displayed—a right pane
and a left pane. The right pane is called the content area. The content area
displays the items or folders that you selected in the left pane. The left pane
can display one of the following four views:

■ Category Listing. Displays folders containing libraries of standard parts,
manufacturer-specific content, and content aggregator websites.

■ Search. Searches for online content. You can query items with Boolean
and multiple-word search strings.

■ Settings. Controls how many categories and items are displayed on each
page in the content area as a result of a search or folder navigation.

■ Collections. Specifies the discipline-specific content types that are displayed
in DesignCenter Online.

You choose the view by clicking the heading at the top of the left pane.

Once you select a folder in the left pane, all of its content is loaded into the
content area. You can select an item in the content area to load it into the
preview area. Items can be downloaded by dragging them from the preview
area into your drawing or tool palette, or by saving the items to your computer.
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NOTE If the DC Online tab is not available in DesignCenter and you want to access
DesignCenter Online, see your network or CAD administrator.

DesignCenter Online Privacy

DesignCenter Online is an interactive feature that must be connected to the
Internet to deliver content and information. Each time DesignCenter Online
is connected, it sends information to Autodesk so that the correct information
can be returned. All information is sent anonymously to maintain your privacy.

The following information is sent to Autodesk:

■ Product Name. The name of the product in which you are using
DesignCenter Online

■ Product Release Number. The version of the product

■ Product Language. The language version of your product

■ Random Number Identifier. DesignCenter Online assigns a random
number identifier to each person who uses the feature. This identifier is
used to retain your Collections and your Settings views each time
DesignCenter Online is used.

Autodesk compiles statistics using the information sent from DesignCenter
Online to monitor how it is being used and how it can be improved. Autodesk
will maintain information provided by or collected from you in accordance
with Autodesk’s published privacy policy, which is available on
http://www.autodesk.com/privacy
.

Turn the DC Online Tab On or Off

The CAD Manager Control utility turns the DC Online tab in DesignCenter
on and off. Information about how to use the utility is available by installing
and running the utility, and then clicking Help in the CAD Manager Control
Utility window.

To install the CAD Manager Control utility

1 Insert the CD or DVD, and double-click setup.exe.

2 In the Media Browser, Network Deployment tab, under Install
Supplemental Tools, click Autodesk CAD Manager Tools 2.0.

3 Under Autodesk CAD Manager Tools 2.0, click Install.
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After you install the CAD Manager Control utility, you access it from
the Start menu (Windows). Information about how to use the utility is
available in Help on the CAD Manager Control Utility window.

Understand DesignCenter Online Content Types

With DesignCenter Online, content is categorized into folders.

In the DesignCenter Online folders, you can retrieve discipline-specific content.
The content that you can retrieve includes the following:

■ Standard Parts. Generic standard parts that are commonly used in design.
These parts include blocks for architectural, mechanical, and GIS
applications.

■ Manufacturers. Blocks and 3D models that can be located and
downloaded by clicking a link to a manufacturer's website.

■ Aggregators. Lists of libraries from commercial catalog providers can be
searched for parts and blocks.

You use the Collections view to select the categories of online content that
you want to display in the Category Listing view.

To view online content folders in the Category Listing view

■ In DesignCenter Online, at the top of the left pane, click the heading, and
then click Category Listing.

The category folders are displayed in the left pane of the window.

Retrieve Content from the Web

You can download content from the Web and use it in your drawings.

Browse for Content

When you use the Category Listing view, you can click the folders in the left
pane to view their contents. These folders may contain other folders.
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When you click a folder or an item inside a folder, the contents are displayed
in the Content area. When you click a block, graphical and descriptive
information about the block is displayed in the preview area.

Search for Content

When you search for online content with DesignCenter Online, you can query
items with Boolean and multiple-word search strings in the Search view. You
can access Search by clicking the magnifying glass or by choosing Search from
the drop-down heading at the top of the left pane.

Control the Number of Categories and Items in a Page

By using the Settings view, you can control how many categories or items are
displayed on each page in the content area as a result of a search or folder
navigation.

Collections

You can choose the type of content to navigate and search. In the Collections
pane, you can specify the content types that are displayed each time you open
DesignCenter Online. For example, if you use architectural blocks in your
drawings, you select collections that contain architectural items. Once you
make your selection, categories that you specified are displayed.
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Download Content

To download content from the Web, locate the folder containing the content
that you want to use. Then, click a thumbnail image of the content in the
content area. The content is displayed in the preview area along with
information about the content. You can drag the block directly from the
preview area into a drawing or tool palette, or you can save it to your computer
to be used later.

To search for content in DesignCenter Online

1 In DesignCenter Online, at the top of the left pane, click the heading,
and then click Search.

2 In the Search view, enter a single word or multiple-word strings.

NOTE The Need Help link provides more information about searches,
including examples of Boolean searches.

To specify content collections

1 In DesignCenter Online, at the top of the left pane, click the heading,
and then click Collections.

2 In the Collections view, click the check boxes of the collections that you
want to use.

3 Click Update Collections.

The categories that you have selected are displayed in the left pane.

To download content to your computer

1 In DesignCenter Online, at the top of the left pane, click the heading,
and then click Category Listing.

2 In the Category folders, click a content item.

3 In the Preview area, under the image of the content item, click Save This
Symbol As.

4 In the Save As dialog box, specify the location on your computer and
the file name.

5 Click Save.

The content is downloaded to your computer.
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To download content to your drawing

1 In DesignCenter Online, at the top of the left pane, click the heading,
and then click Category Listing.

2 In the Category folders, click a content item to display it in the Preview
area.

3 Drag the image from the Preview area into your drawing or tool palette.
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Customize the Drawing
Environment

 

You can change many window and drawing environment

settings in the Options dialog box, when starting the program,

or on the fly. For example, you can change how often a

drawing is automatically saved to a temporary file, and you

can link the program to folders containing files you use

frequently. You can create workspaces to set up a drawing

environment that is specific to your drawing needs.

Experiment with different settings until you create the

drawing environment that best fits your needs.
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Set Interface Options
You can change the appearance of elements in the drawing area and specify
other aspects of your working environment, for example, how often the
drawing is automatically saved.

In the Options dialog box, you can change many of the settings that affect
the interface and the drawing environment. Experiment until you find the
best environment for your needs.

■ Automatic Save (Open and Save tab). Saves your drawing at specified
time intervals. To use this option, in the Options dialog box, Open and
Save tab, select Automatic Save and enter the interval in minutes.

■ Search Path (Files tab). Sets the search path the program uses to find
drawing support files such as text fonts, drawings, linetypes, and hatch
patterns.

Change the Appearance of Elements in the Drawing Area

Some settings in the Options dialog box affect the appearance of the drawing
area, for example:

■ Color (Display tab). Specifies the background colors used in the layout
and Model tabs and the color used for prompts and crosshairs.

■ Font (Display tab). Changes the fonts used in the application window
and in the text window. This setting does not affect the text in your
drawings.

Clear the Screen

To expand the drawing display area, click View menu ➤ Clean Screen to
display only the menu bar, status bar, and command window. A check mark
is displayed next to the option. Click Clean Screen again to restore the previous
setup.

Calculate Mathematical Expressions in a Dialog Box

You can enter and evaluate mathematical expressions in a dialog box using
the following format: =expression<END>.

NOTE To evaluate expressions in a dialog box, make sure the system variable,
CALCINPUT, is set to 1.
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Control the Size, Location, and Appearance of Dockable Windows

Windows that can dock or float, such as the Properties palette, tool palette
windows, and DesignCenter, can be resized and placed where you want them
in the drawing area.

■ Resize. Drag an edge of the window to change its size. If the window has
panes, drag the bar between panes to resize the panes.

■ Allow Docking. Right-click the title bar. Click Allow Docking. A check
mark is displayed next to the option.

To dock the window, drag it over the right or left edge of the application
window until it snaps into the docked position. You can also double-click
the title bar to dock the window.

To undock the window, drag the double lines at the top of the docked
window away from the docking region. You can press CTRL to prevent
docking while you drag.

■ Auto-hide. Click the Auto-hide button to automatically roll open or roll
up the window when your cursor moves over its title bar. This option is
also available on a shortcut menu that is displayed when you right-click
the title bar.

■ Transparency. Right-click the title bar. Click Transparency to make the
window transparent so that it does not obscure objects under it. This option
is not available for all windows.

Control the Display, Location, and Size of Toolbars

To display or hide toolbars, right-click any toolbar to display a list of toolbars.
A check mark next to a toolbar name indicates that it is displayed. Click a
toolbar name in the list to display or clear the check mark.

A toolbar can be docked or floating. A docked toolbar is attached to any edge
of the drawing area. Undock a toolbar by clicking an empty area on the toolbar
and dragging it into the drawing area. A floating toolbar is located anywhere
in the drawing area. You can click the title bar and drag it to a new location
or dock it. Resize a floating toolbar by dragging an edge.

Lock the Position of Toolbars and Dockable Windows

Once you have toolbars and dockable windows arranged the way you want
them, you can lock their position, whether they are docked or floating. Locked
toolbars and windows can still be opened and closed and items can be added
and deleted. To unlock them temporarily, hold down CTRL .
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Control View Transitions

You can control whether view transitions appear smooth or instantaneous ().
The default is a smooth transition from one view to another. The view
transitions settings affect the change of view when you pan or zoom or change
from one view to another, including a named view.

Set the Appearance of Tooltips

Tooltips provide information for many of the drafting aids. The  system variable
turns them on and off. The  system variable can combine the display of
information into one tooltip. You can set the general appearance of tooltips
in the Tooltip Appearance Dialog Box

To set options

1 Click Tools menu ➤ Options.

2 In the Options dialog box, click the tab you want.

3 Set options as desired.

4 Do either or both of the following:

■ Click Apply to record the current options settings in the system
registry.

■ Click OK to record the current options settings in the system registry
and close the Options dialog box.

To customize the colors of the application window elements

1 Click Tools menu ➤ Options.

2 In the Options dialog box, Display tab, click Colors.

3 In the Color Options dialog box, select the element you want to change
by clicking the images for the Model tab or layout tabs.

As you click areas of the images, the selection is displayed in the Window
Element list. You can also change an attribute by selecting it from the
Window Element list.

4 Select the color you want to use from the Color list.

To specify a custom color, select Select Color from the Color list.

5 If you want to revert to the colors specified by the Windows Control
Panel, click Default All.

6 Click Apply and Close to record the current option settings in the system
registry and close the dialog box.
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7 Click OK to close the Options dialog box.

To change the font displayed in the command window

1 Click Tools menu ➤ Options.

2 In the Options dialog box, Display tab, under Window Elements, click
Fonts.

3 In the Command Line Window Font dialog box, select the appropriate
Font, Font Style, and Size.

An example of the current choices appears under Sample Command
Line Font.

4 Click Apply & Close to record the current option settings in the system
registry and close the dialog box.

5 Click OK to close the Options dialog box.

To lock the position and size of toolbars and dockable windows

■ Click Window menu ➤ Lock Location.

■ Place a check mark next to one or more of the following options, or click
All ➤ Locked:

■ Floating Toolbars

■ Docked Toolbars

■ Floating Windows

■ Docked Windows

A lock icon in the system tray indicates whether toolbars or dockable windows
are locked. To unlock them temporarily, hold down CTRL .

Right-click the lock icon in the system tray. Place a check mark next to one
or more options or click All ➤ Locked.

To evaluate mathematical expressions in a dialog box

NOTE To evaluate expressions in a dialog box, the system variable, CALCINPUT,
must be set to 1.

■ In a dialog box, in an area where you can enter a numeric value, enter a
mathematical expression in the following format: =expression (for example,
=5+3).
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■ Click END on the keyboard.

■ The expression is evaluated and its value is displayed.

CALCINPUT

To change the appearance of view transitions

1 At the Command prompt, enter vtoptions.

2 In the View Transitions dialog box, check one or more options:

■ Enable Animation for Pan and Zoom. Makes a smooth view
transition during panning and zooming.

■ Enable Animation When View Rotates. Makes a smooth view
transition when the view angle is changed.

■ Enable Animation During Scripts. Makes smooth view transition
while a script is running.

3 Set the transition speed by moving the slider.

4 To preserve performance, set the minimum frames per second for showing
smooth view transitions. When a smooth view transition cannot
maintain this speed, an instant transition is used.

5 Click OK.

Customize Startup
Command line switches can specify a separate startup routine for each project.

You can use command line switches to specify several options when you start
the program. For example, you can run a script, start with a specified drawing
template, and display a specified view when a drawing is opened. With
command line switches, you can also set up several program icons, each with
different start-up options.

Command line switches are parameters you can add to the acad.exe command
line associated with a Microsoft®  Windows® shortcut icon or the Windows
Run dialog box. You can include several switches within a single command
line. Valid switches are listed in the following table.

Designates a script to run after you start the
program (b stands for batch process). Scripts

Script name/b

can be used to set up drawing parameters in
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a new drawing file. An SCR file type is
assumed.

Creates a new drawing based on a template
or prototype drawing. A DWT file type is
assumed.

Template file name/t

Specifies the path for the hardware
configuration file that you want to use. You

Configuration folder/c

can specify a directory or a particular file. A
CFG file type is assumed.
If you don't set the /c switch, the executable
directory is searched and the ACADCFGW or
ACADCFG environment variable is used as a
way to define the configuration file and
directory location.

Designates a particular view of the drawing
for display at startup.

View name/v

Loads a specified ARX or DBX application. Use
the following format:

ARX or DBX application/ld

<path>\<filename>.ARX
If the path or file name contains spaces, then
the path or file name should be wrapped in
double quotes. If no path information is
included, the program search path is used.

Designates support folders other than the
current folder. Drawing support files include

Support folders/s

text fonts, menus, AutoLISP files, linetypes,
and hatch patterns. The maximum number
of folders you can specify in the path is 15.
Each folder name is delimited by semicolons.

Restores the default system pointing device.
It creates a new configuration file (acad.cfg)

Default system pointing
device

/r

and renames the previous acad.cfg file to
acad.bak.

Starts the program without first displaying the
logo screen.

No AutoCAD logo screen/nologo

Specifies a user-defined registry profile for
starting the program. The selected profile is

User-defined registry
profile for starting the
program

/p

in effect only for the current session of the
program, unless you make another profile
current in the Options dialog box during that
session.
You create or import profiles on the Profiles
tab in the Options dialog box. With the /p
switch, you can specify only those profiles that
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are listed in the Options dialog box. If the
profile does not exist, the current profile is
used.

Suppresses the display of the Sheet Set
Manager window on startup.

No Sheet Set Manager
window

/nossm

Loads the named sheet set on startup. Use the
following format:

Sheet set/set

<path>\<sheet set data file>.DST

The syntax for using command line switches is

"drive:pathname\acad.exe" ["drawing name"] [/switch "name"]
When using a switch option, you must follow the switch with a space and
then the name of a file, path, or view within quotation marks. For example,
the following entry starts the program from a folder named AutoCAD 2006
with the drawing template arch1.dwt, restores a named view PLAN1, and
executes a script file startup.scr.

"d:\ AutoCAD 2006\acad.exe”/t "d:\AutoCAD 2006\template\arch1" /v "plan1"
/b "startup"

The environment settings are resolved in the following way:

■ If you use a command line switch to specify an environment setting, the
command line switch overrides the settings specified in either the Options
dialog box or the environment variable.

■ If a command line switch is not set, the corresponding value set in the
Options dialog box is used.

■ If neither a command line switch nor an Options value is set, the
environment variable value is used.

NOTE Command line switches and environment variables override values set in
the Options dialog box for the current session only. They do not alter the system
registry.

To start the program with a command line switch

1 Right-click the program icon on the Windows desktop. Click Properties.

2 In the AutoCAD Properties dialog box, Shortcut tab, in the Target box,
edit the parameters for the switch using the following syntax:

"drive:pathname\acad.exe" ["drawing name"] [/switch "name"]

Valid switches are as follows:
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/b Script name (b stands for batch process)

/t Template file name

/c Configuration folder

/v View name

/s Support folders

/r Default system pointing device

/nologo No AutoCAD logo screen

/p User-defined registry profile

/nossm No Sheet Set Manager window

/set Sheet Set name

For example, enter "d:\AutoCAD 2006\ acad.exe " /t "d:\AutoCAD
2006\template\arch1" /v "plan1" /b "startup"

3 Click OK.

Save and Restore Profiles
Profiles store drawing environment settings. You can create profiles for different
users or projects and share profiles by importing and exporting profile files.

You can use the Profiles tab in the Options dialog box to create and save your
drawing environment settings as a profile. If you share your workstation with
other users who use the same login name, you can restore your options by
making the profile current. You can also create and save profiles to use with
different projects. By default, your current options are stored in a profile named
UNNAMED PROFILE. The current profile name, as well as the current drawing
name, are displayed in the Options dialog box.

The profile information is stored in the system registry and can be saved to a
text file (an ARG file). The program organizes essential data and maintains
changes in the registry as necessary.

Once you save a profile, you can export or import the ARG file to and from
different computers. If you make changes to your current profile during a
work session and you want to save those changes in the ARG file, you must
export the profile. When you export the profile with the current profile name,
the ARG file is updated with the new settings. You can import the profile
again to update your profile settings.

For more information about profiles, see  in the Command Reference.

To make a profile current

1 Click Tools menu ➤ Options.
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2 In the Options dialog box, Profiles tab, select the profile you want to
make current.

3 Click Set Current.

4 Click OK.

To save a profile

1 Click Tools menu ➤ Options.

2 In the Options dialog box, Profiles tab, click Add to List.

3 In the Add Profiles dialog box, enter a Profile name and Description.

4 Click Apply & Close to record the current option settings in the system
registry and close the dialog box.

5 Click OK.

To make a profile current before starting the program

1 On the Windows desktop, right-click the program icon. Click Properties.

2 In the AutoCAD Properties dialog box, Shortcut tab, under Target, enter
/p currentprofile after the current target directory. For example, to
make the profile User12 current, enter the following in Target:

"c:\Program Files\<current release name>\acad.exe"/p user12

3 Click OK.

The profile name you enter is the current profile each time you start the
program.

Use Workspaces
Workspaces are sets of menus, toolbars, and dockable windows (such as the
Properties palette, DesignCenter, and the Tool palettes window) that are
grouped and organized so that you can work in a custom, task-oriented drawing
environment. When you use a workspace, the menus, toolbars, and dockable
windows display only those options that are relative to the workspace.

For example, if you typically do 2D drafting, you can use a 2D drafting
workspace to streamline those drafting tasks. Or if your work primarily involves
publishing drawings, you can create a workspace that contains
publishing-related toolbars, menus, and dockable windows. You can also
modify workspaces, switch between workspaces as you need them, change
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workspace settings, or use the default workspace that is shipped with the
product.

When you make changes to your drawing display (such as moving, hiding,
or displaying a toolbar or a tool palette group) and you want to preserve the
display settings for future use, you can save the current settings to a workspace.

Workspaces help you to

■ Streamline common tasks

■ Engage in best practices for drawing tasks and workflow

■ Customize your drawing environment

Workspaces and Profiles

While workspaces change the display of your drawing environment, much
like profiles do, workspaces are not the same as profiles.

Workspaces control the display of menus, toolbars, and dockable windows in
the drawing area. When you use or switch a workspace, you change the display
of your drawing area. You can easily switch to another workspace within a
drawing session. You manage your workspaces from the Customize User
Interface dialog box.

Profiles collect many of your user options, drafting settings, paths, and values.
Profiles are updated each time you make a change to an option, setting, or
other value. If you have previously saved display settings to different profiles,
you can use workspaces to switch between display environments. You can
manage most of your profiles from the Options dialog box.

When you make changes to the drawing display, the changes are stored in
your profile and are displayed the next time you launch the program, regardless
of your workspace settings. The profile changes are not automatically saved
to a workspace unless you select the Automatically Save Workspace Changes
option in the Workspace Settings dialog box. To preserve profile settings in a
workspace, click Window menu ➤ Workspaces ➤ Save Current As.

For more information about profiles, see “Save and Restore Profiles” on page
87.

Create or Change a Workspace

You can create your own workspaces and modify the default workspace. You
can create a workspace that contains only those toolbars and menus that you
want. To create or change a workspace, you use the Customize User Interface
dialog box to set the workspace environment. You can also create a workspace
by rearranging toolbars and windows, and then saving the current workspace
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(from the Workspaces toolbar, the Window menu, or using the WORKSPACE
command).

NOTE For more information about creating or modifying workspaces, see
“Customize Workspaces” in the Customization Guide.

Switch Workspaces

If you use the product for a variety of tasks, you might have several workspaces.
You can switch to another workspace whenever you need to work on a different
task.

Change Workspace Settings

You can change workspace settings, such as which workspace you want to
display or whether or not to save your configuration when you switch
workspaces. You change these settings in the Workspace Settings dialog box.

Select a Sample Workspace

You can use the sample workspaces that are shipped with the product. These
predefined workspaces demonstrate how you might use a workspace to
streamline your work tasks. You can also modify these sample workspaces.

You can find the sample workspaces in the following location:

C:\Documents and Settings\<user name>\Application Data\Autodesk\AutoCAD
2006\R16.2\<product language>\Support\acadSampleWorkspaces.CUI

To use these sample workspaces, you must first transfer them to your main
customization (CUI) file. To learn more about transferring a workspace, see
Migrate and Transfer Customizations in the Customization Guide.

To switch workspaces

1 Click Window menu ➤ Workspaces.

2 From the list of workspaces, select the workspace you want to switch to.

To change workspace settings

1 Click Window menu ➤ Workspaces ➤ Workspace Settings.

2 In the Workspace Settings dialog box, change workspace settings as
needed.

3 Click OK.
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To save a workspace

1 In the drawing area, arrange a drawing environment by moving, deleting,
or displaying those toolbars and dockable windows you'd like to preserve
for future use.

2 Click Window menu ➤ Workspaces ➤ Save Current As.

3 In the Save Workspace dialog box, enter a name for the new workspace
or select a name from the drop-down list.

4 Click Save.
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Pointing Devices

 
You can control this program with a pointing device such as

a mouse, digitizing puck, or stylus. A pointing device may

have a number of buttons. The first 10 buttons are

automatically assigned by the program, but you can reassign

all but button 1, the pick button, by modifying the menu file.

You can change how mouse buttons function by choosing

the Mouse icon in the Windows Control Panel.
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Pointing Device Buttons
The first 10 pointing device buttons are automatically assigned; you can
reassign all except button 1, the pick button.

On a two-button mouse, the left button is the pick button used to

■ Specify locations

■ Select objects for editing

■ Choose menu options and dialog box buttons and fields

The operation of the right button on a mouse depends on context; it can be
used to

■ End a command in progress

■ Display a shortcut menu

■ Display the Object Snap menu

■ Display the Toolbars dialog box

Right-click operation can be modified in the Options dialog box (). The
operation of additional buttons on a pointing device is defined in the menu
file.

The Wheel Mouse

The wheel mouse has a small wheel between the buttons. The left and right
buttons behave the same as they do on a standard mouse. You can rotate the
wheel by discrete values. You can use the wheel to zoom and pan in your
drawing without using any commands.

By default, the zoom factor is set to 10 percent; each increment in the wheel
rotation changes the zoom level by 10 percent. The  system variable controls
the incremental change, whether forward or backward. The higher the number,
the larger the change.

The following table lists the wheel mouse actions supported in this program.

Do this...To...

Rotate the wheel forward to zoom in,
backward to zoom out

Zoom in or out

Double-click the wheel buttonZoom to drawing extents
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Do this...To...

Hold down the wheel button and drag the
mouse

Pan

Hold down CTRL and the wheel button, and
drag the mouse

Pan (joystick)

With the MBUTTONPAN system variable set
to 0, click the wheel button

Display the Object Snap menu

See also:

“Customize Mouse Buttons” in the Customization Guide

To practice using several features of the mouse

1 Move your mouse and notice that the pointer on the screen changes
from crosshairs while the pointer is in the drawing area, to an arrow
when it's not over the drawing area, and to an I-beam when it's in the
text window.

2 As you continue to move the mouse, notice that the numbers in the
coordinate display on the status bar change. These numbers indicate the
exact location, or coordinate, of the crosshairs on the screen. Click in
the coordinate display to turn it off. Notice that the coordinates are
updated only when you click in the drawing area.

3 Find the Snap button on the status bar and click it with the pick button
on your mouse (usually the left button). Notice that the button darkens
to indicate that Snap mode has been turned on.

4 Move the pointer around the screen and observe that it seems to adhere,
or "snap," to points at predetermined and equivalent intervals on the
screen. You can change the size of these intervals.

5 Click the Snap button again to turn Snap mode off.

6 Move the pointer over the Standard toolbar at the top of the drawing
area. As you leave the pointer over a button for a few moments, notice
a pop-up label, called a tooltip, that identifies the button.

7 Move the pointer over double bars at the end of a toolbar. Then, as you
hold down the pick button, drag the toolbar around the screen to
reposition it.

8 Dock the toolbar by dragging it to a docking location at the top, bottom,
or either side of the drawing area. When the outline of the toolbar
appears in the docking area, release the pick button.
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To turn off all shortcut menus in the drawing area

1 Click Tools menu ➤ Options.

2 In the Options dialog box, User Preferences tab, under Windows Standard
Behavior, clear Shortcut Menus in Drawing Area.

3 Click OK to record the current options settings in the system registry
and close the Options dialog box.

To turn off shortcut menus individually

1 Click Tools menu ➤ Options.

2 In the Options dialog box, User Preferences tab, select Shortcut Menus
in Drawing Area, and then click Right-Click Customization.

3 In the Right-Click Customization dialog box, under Default Mode, Edit
Mode, or Command Mode, select the options to control what happens
when you right-click in the drawing area.

4 Click Apply & Close to close the dialog box.

5 Click OK to record the current options settings in the system registry
and close the Options dialog box.

Digitizing Tablets
You can use the puck or stylus of a digitizing tablet as a pointing device, or
you can trace a paper drawing into a file.

A digitizing tablet, or digitizer, is a peripheral device that can be used to trace
paper drawings into a drawing file or to choose commands from a digitizing
tablet overlay. With the Wintab driver, the tablet pointer can also be used
instead of a mouse as a system pointer to choose menu items and drawing
objects or to interact with the operating system. The tablet pointer can be a
puck or a stylus.

The digitizing tablet must first be configured and then can optionally be
calibrated.

■ When the tablet is configured, portions of the tablet surface are designated
as menu areas and a screen-pointing area.

■ When the tablet is calibrated, it can be used to trace geometry from an
existing paper drawing or photograph into a drawing.
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You can easily switch between using the tablet uncalibrated as a system pointer
(Tablet mode off) or calibrated for digitizing a drawing (Tablet mode on). Click
the Tablet button on the status bar. If a screen-pointing area has been
designated, a Float button is displayed on the status bar and toggles the
screen-pointing area on and off.

NOTE A sample digitizing tablet overlay, tablet.dwg, is included in the Sample
folder, which is located in the product installation directory.

See also:

“Create Tablet Menus” in the Customization Guide
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Start a Drawing

 
You can start a new drawing several ways, including starting

from scratch or using a template file. In each case, you can

choose the units of measurement and other unit format

conventions.

7
In this chapter
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Start a Drawing from Scratch
A quick way to begin a new drawing is to start from scratch, which starts a
drawing that uses settings from a default drawing template file.

You can start from scratch from the Create New Drawing dialog box, from
the Select Template dialog box, or without using a dialog box at all. In each
case, you use either the  command or the  command.

Use the Create New Drawing Dialog Box

The Create New Drawing dialog box is displayed under the following
conditions:

■ You set the  system variable to 1 (on).

■ You set the  system variable to 1 (on).

■ You click New on the File menu or Qnew on the Standard toolbar when
no drawing template file is specified in the Options dialog box.

The Create New Drawing dialog box provides several methods for starting a
new drawing.

When you use Start from Scratch, you can specify either imperial or metric
units for the new drawing. The setting you select determines default values
used for many system variables controlling text, dimensions, grid, snap, and
the default linetype and hatch pattern file.

■ Imperial .  Creates a new drawing based on the imperial measurement
system. The drawing uses internal default values, and the default grid display
boundary, called the grid limits, is 12 x 9 inches.

■ Metric . Creates a new drawing based on the metric measurement system.
The drawing uses internal default values, and the default grid display
boundary is 420 x 290 millimeters.

Use the Select Template Dialog Box

The Select Template dialog box is displayed under the following conditions:

■ You set the  system variable to 0 (off).

■ You set the  system variable to 1 (on).

■ You click New on the File menu or, by default, Qnew on the Standard
toolbar.
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At the bottom-right corner of the Select Template dialog box, there is an Open
button with an arrow button next to it. If you click the arrow button, you can
choose between two internal default drawing templates, metric or imperial.

Use a Default Drawing Template File

The fastest way to begin working on a new drawing is to start automatically
with a default drawing template file. No dialog box is displayed with this
method:

■ You set the  system variable to 0 (off).

■ You set the  system variable to 1 (on).

■ You specify a default drawing template file in the Options dialog box on
the Files tab. Click the node labeled “Drawing Template Settings” and
specify a path and drawing template file.

■ You click Qnew on the Standard toolbar.

From now on, a new drawing is immediately created that is based on the
specified default drawing template file.

If no template file is specified in the Options dialog box, QNEW displays the
Select Template dialog box.

To start a drawing from scratch with the Create Drawing dialog box

1 If necessary, set the STARTUP system variable to 1 and the FILEDIA
system variable to 1. On the command line, enter startup and 1; then
enter filedia and 1.

2 Click File menu ➤ New.

3 In the Create New Drawing dialog box, click Start from Scratch.

4 Under Default Settings, click either Imperial or Metric.

The new drawing starts as drawing1.dwg. The default drawing name
changes to reflect the number of new drawings that have been started.
For example, if you start another drawing, the default drawing name is
drawing2.dwg.

To start a drawing from scratch from a default drawing template file

1 If necessary, set the STARTUP system variable to 0 and the FILEDIA
system variable to 1. On the command line, enter startup and 0; then
enter filedia and 1.

2 Click Tools menu ➤ Options.
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3 In the Options dialog box, Files tab, in the list of nodes, click the plus
sign (+) next to Template Settings. Click the plus sign (+) next to Drawing
Template File Location, and specify a folder path.

4 Click the plus sign (+) next to Default Template File Name for QNEW,
and specify a drawing template file name.

5 Click OK.

6 On the Standard toolbar, click Qnew.

The new drawing starts as drawing1.dwg. The default drawing name
changes to reflect the number of new drawings that have been started.
For example, if you start another drawing, the default drawing name is
drawing2.dwg.

Standard toolbar

Use a Wizard to Start a Drawing
A setup wizard establishes basic drawing settings step by step.

You have two wizard options to help you set up a drawing:

■ Quick Setup Wizard . Sets units of measurement, precision of displayed
units, and grid limits.

■ Advanced Setup Wizard . Sets units of measurement, precision of
displayed units, and grid limits. Also establishes angle settings such as units
of measurement style, precision, direction, and orientation.

These wizards are available in the Create New Drawing dialog box.

To begin a new drawing using a wizard

1 If necessary, set the STARTUP system variable to 1 and the FILEDIA
system variable to 1.

2 Click File menu ➤ New.

3 In the Create New Drawing dialog box, click Use a Wizard.

4 Click Quick Setup or Advanced Setup.

5 Complete the wizard pages using the Next and Back buttons to move
forward and backward.
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6 On the last page, click Finish.

Use a Template File to Start a Drawing
A drawing template file contains standard settings. Select one of the template
files supplied, or create your own template files.

Drawing template files have a .dwt file extension.

When you create a new drawing based on an existing template file and make
changes, the changes in the new drawing do not affect the template file. You
can use one of the template files supplied with the program, or you can create
your own template files.

Create a Drawing Template File

When you need to create several drawings that use the same conventions and
default settings, you can save time by creating or customizing a template file
instead of specifying the conventions and default settings each time you start.
Conventions and settings commonly stored in template files include

■ Unit type and precision

■ Title blocks, borders, and logos

■ Layer names

■ Snap, Grid, and Ortho settings

■ Grid limits

■ Dimension styles

■ Text styles

■ Linetypes

By default, drawing template files are stored in the template folder, where they
are easily accessible.

Recover the Default Drawing Template File

If the settings in the drawing template file acad.dwt or acadiso.dwt have been
changed from the original defaults, you can reset them by starting a new
drawing with no template and then saving the drawing as a drawing template
file, replacing acad.dwt or acadiso.dwt.
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You can start a new drawing with the original defaults by using NEW to display
the Select Template dialog box. To do this, click the arrow next to the Open
button and then click one of the “no template” options from the list.

To start a drawing by selecting a template file

1 Click File menu ➤ New.

2 In the Select Template dialog box, select a template from the list.

3 Click Open.

The drawing is opened as drawing1.dwg. The default drawing name
changes to reflect the number of new drawings that have been opened.
For example, if you open another drawing from a template, the default
drawing name is drawing2.dwg.

If you want to start a new drawing with no template file, click the arrow
next to the Open button. Select one of the “no template” options from
the list.

To create a drawing template file from an existing drawing

1 Click File menu ➤ Open.

2 In the Select File dialog box, select the file you want to use as a template.

3 Click OK.

4 If you want to delete the existing file contents, click Modify menu ➤
Erase.

5 At the Select Objects prompt, enter all, and then select the border and
title block (if you want to remove them) and enter r (Remove).

6 Click File menu ➤ Save As.

7 In the Save Drawing As dialog box, under Files of Type, select the Drawing
Template file type.

DWT files must be saved in the current drawing file format. To create a
DWT file in a previous format, save the file in the desired DWG format,
and then rename the DWG file using a DWT extension.

8 In the File Name box, enter a name for the template.

9 Click Save.

10 Enter a description of the template.

11 Click OK.

The new template is saved in the template folder.
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Standard toolbar

To recover the default drawing template files

1 Click File menu ➤ New.

2 In the Select Template dialog box, click the arrow next to the Open
button. Select one of the options from the list:

■ Open with No Template - Imperial (to restore acad.dwt)

■ Open with No Template - Metric (to restore acadiso.dwt)

The drawing opens with the default settings.

3 Click File menu ➤ Save As.

4 In the Save Drawing As dialog box, select the Drawing Template file type.
Save the drawing with its original name, either acad.dwt for imperial or
acadiso.dwt for metric.

5 Click Save.

Specify Units and Unit Formats
Before you start to draw, you decide on the units of measurement to be used
in the drawing, and set the format, precision, and other conventions to be
used in coordinates and distances.

Determine the Units of Measurement

Every object you create is measured in drawing units. Before you start to draw,
you must decide what one drawing unit will represent based on what you
plan to draw. Then you create your drawing at actual size with that convention.
For example, a distance of one drawing unit typically represents one millimeter,
one centimeter, one inch, or one foot in real-world units.

Convert Drawing Units

If you start a drawing in one system of measurement (imperial or metric) and
then want to switch to the other system, use  to scale the model geometry by
the appropriate conversion factor to obtain correct distances and dimensions.
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For example, to convert a drawing created in inches to centimeters, you scale
the model geometry by a factor of 2.54. To convert from centimeters to inches,
the scale factor is 1/2.54 or about 0.3937.

See also:

“Set the Scale for Dimensions” on page 806

To set the units format and precision

1 Click Format menu ➤ Units.

2 In the Drawing Units dialog box, under Length, select a unit format and
precision.

The Sample Output area shows an example of the unit format at the
current precision.

3 Click OK.

To convert a drawing from inches to centimeters

1 Click Modify menu ➤ Scale.

2 At the Select Objects prompt, enter all.

All objects in the drawing are selected for scaling.

3 Enter a base point of *0,0.

Scaling will be relative to the world coordinate system origin and the
location of the drawing origin will remain at the WCS origin.

4 Enter a scale factor of 2.54 (there are 2.54 centimeters per inch).

All objects in the drawing are now 2.54 times larger, corresponding to
the equivalent distance in centimeters.

Modify toolbar

To convert a drawing from centimeters to inches

1 Click Modify menu ➤ Scale.

2 At the Select Objects prompt, enter all.

All objects in the drawing are selected for scaling.

3 Enter a base point of *0,0.
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Scaling is performed relative to the world coordinate system origin, and
the location of the drawing origin will remain at the WCS origin.

4 Enter a scale factor of 0.3937 (the inverse of 2.54 centimeters per inch).

All objects in the drawing are now smaller, corresponding to the
equivalent distance in inches.

Modify toolbar

Set Linear Unit Conventions

Before you start to draw, you set the format and the number of decimal places
to be used when you enter and display linear units.

You can choose from several common conventions to represent the display
style and the precision of distances and coordinates. Depending on what you
specify, you can enter and display in decimal format, fractional format, or
other notation. These settings affect

■ The Properties palette

■ Dynamic input

■ The LIST command

■ The ID command

■ The coordinate display on the status bar

■ Several dialog boxes that display coordinates

You can set the unit type and precision in the Drawing Units dialog box, the
Quick Setup wizard, or the Advanced Setup wizard.

Understand Rounding and Precision

When you specify the display precision of units, the values for coordinates
and distances are rounded off. However, the internal precision of coordinates
and distances is always maintained regardless of the display precision.

For example, if you set the display precision of decimal-format units to 1 (or
0.0), the display of coordinates is rounded to one place after the decimal point.
Thus, the coordinates 0.000,1.375 are displayed as 0.0,1.4, but the internal
precision is still maintained.
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Enter Distances in Imperial Architectural Format

In architectural format, to enter feet and inches, indicate feet using the prime
symbol ('), for example, 72'3. You don't need to enter quotation marks (“) to
specify inches.

NOTE The units format for creating and listing objects, measuring distances, and
displaying coordinate locations is separate from the dimension units setting used
in creating dimension values.

See also:

“Set the Scale for Dimensions” on page 806

To set the units format and precision

1 Click Format menu ➤ Units.

2 In the Drawing Units dialog box, under Length, select a unit format and
precision.

The Sample Output area shows an example of the unit format at the
current precision.

3 Click OK.

To convert a drawing from inches to centimeters

1 If necessary, click the Model tab to make the Model tab current.

2 Click Modify menu ➤ Scale.

3 At the Select Objects prompt, enter all.

All objects in the drawing are selected for scaling.

4 Enter a base point of *0,0.

Scaling will be relative to the world coordinate system origin and the
location of the drawing origin will remain at the WCS origin.

5 Enter a scale factor of 2.54 (there are 2.54 centimeters per inch).

All objects in the drawing are now 2.54 times larger, corresponding to
the equivalent distance in centimeters.

Modify toolbar
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To convert a drawing from centimeters to inches

1 If necessary, click the Model tab to make the Model tab current.

2 Click Modify menu ➤ Scale.

3 At the Select Objects prompt, enter all.

All objects in the drawing are selected for scaling.

4 Enter a base point of *0,0.

Scaling is performed relative to the world coordinate system origin, and
the location of the drawing origin will remain at the WCS origin.

5 Enter a scale factor of 0.3937 (the inverse of 2.54 centimeters per inch).

All objects in the drawing are now smaller, corresponding to the
equivalent distance in inches.

Modify toolbar

Set Angular Unit Conventions

Angle conventions include the position of angle 0 and the direction of
measurement: clockwise or counterclockwise. You also set the format and the
number of decimal places.

You can choose from several common conventions to represent angles in a
drawing. You can specify that positive values of angles are measured either
clockwise or counterclockwise, and angle 0 can be set to any direction (usually
East or North). You can enter angles using grads, radians, or surveyor's units
or using degrees, minutes, and seconds.

Work with Surveyor’s Angles

If you use surveyor's angles when specifying polar coordinates, indicate whether
the surveyor's angles are in the north, south, east, or west direction. For
example, to enter a coordinate relative to the current coordinate for a property
line that is 72 feet, 8 inches long with a bearing of 45 degrees north, 20
minutes, 6 seconds east, enter

@72'8"<n45d20'6"e

To set the angle format and precision

1 Click Format menu ➤ Units.
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2 In the Drawing Units dialog box, under Angle, select an angle type and
precision.

The Sample Output area shows an example of the angle type at the
current precision.

3 Select Direction to specify an angle direction.

The angle direction controls the point from which angles are measured
and the direction in which they're measured. The default starting angle,
0 degrees, is toward 3 o'clock (or east), and positive angle measurement
is counterclockwise.

4 Select the options you want to use.

5 Click OK to close each dialog box.

Add Identifying Information to Drawings
You can keep track of your drawings more easily if you add keywords or other
information to them.

Use Windows Explorer

Drawing properties can help you identify a drawing. Some drawing properties
are stored by the operating system; for example, drawing type, location, and
size. These values are read-only in the drawing file and can only be changed
through Windows Explorer.

Use the Find Tool

The Find tool in a standard file selection dialog box can use this information.
For example, you can search for all files created on a certain date, or for files
you modified yesterday.

Use DesignCenter

You can create additional properties in drawing files. You can store author,
title, and subject, and you can assign keywords, hyperlink addresses or directory
paths, and custom properties to your drawings. The Advanced tab in the Search
tool in DesignCenter can use these properties to locate drawing files. For more
information about DesignCenter, see  and “Access Content with DesignCenter”
on page 64.

Use Sheet Set Manager Properties

With Sheet Set Manager, you can assign a sheet title, number, and a description
to every sheet in a sheet set. For more information about sheet sets, see
“Include Information with Sheets and Sheet Sets” on page 250.
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Display Properties in Fields

You can assign any of the drawing properties to a field in a text object. For
more information about fields, see “Use Fields in Text” on page 725.

To display drawing properties for the active drawing

1 Click File menu ➤ Drawing Properties.

2 In the Drawing Properties dialog box, click tabs to view the different
types of information.

To define drawing properties

1 Click File menu ➤ Drawing Properties.

2 In the Drawing Properties dialog box, enter property information on the
following tabs:

■ Summary tab . Enter the drawing title, subject, author, keywords,
comments, and a default address for hyperlinked data in your drawing.
For example, you can add the keyword Autodesk to certain drawing
files and then use DesignCenter to search for all drawing files with
that keyword. For a hyperlink base, you can specify an Internet address
or a path to a folder on a network drive.

■ Custom tab. Click Add. In the Add Custom Property dialog box,
enter a name and a value for the custom property. Click OK. The new
custom property and its value are displayed on the Custom tab. This
information can be used for advanced searches in DesignCenter.

3 Click OK.
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Open or Save a Drawing

 
You can use several methods to find and open drawings, even

damaged drawings. You can save and backup drawings

automatically.

8
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Open a Drawing
You open drawings to work on them just as you do with other Windows
applications. In addition, you can choose from several powerful alternatives.

To open a drawing, you can

■ Use Open on the File menu to display the Select File dialog box.

■ Double-click a drawing in Windows Explorer to launch AutoCAD® and
open the drawing. If the program is already running, the drawing opens in
the current session rather than in a second session.

■ Drag a drawing from Windows Explorer into AutoCAD.

If you drop a drawing anywhere outside the drawing area—for example,
the command line or the blank space next to the toolbars— the drawing
is opened. However, if you drag a single drawing into the drawing area of
an open drawing, the new drawing is not opened but inserted as a block
reference.

■ Use DesignCenter to open drawings

■ Use the Sheet Set Manager to locate and open the drawings in a sheet set

Check Drawing Authenticity

If the  system variable is set to On (1), the DWG file format is checked and an
alert box is displayed if

■ The drawing file format is AutoCAD LT 97 or later or AutoCAD Release 14
or later and

■ The file was last saved by a program other than AutoCAD LT 97 or later or
AutoCAD Release 14 or later

To avoid checking for file authenticity each time you open drawings, clear
the Always Show This Dialog Box option when the alert is displayed.
Alternatively, you can set  to Off (0).

Change the Default Drawing Folder

Each time you start AutoCAD, the My Documents folder is the default path in
each standard file selection dialog box. Alternatively, you can configure
AutoCAD to default always to a specified path by changing the default drawing
folder using the system variable.
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See also:

“Overview of DesignCenter” on page 62
“Customize Startup” on page 84
“Work with Sheets in a Sheet Set” on page 233

To open a drawing

1 Click File menu ➤ Open.

2 In the Select File dialog box, select one or more files. Click Open.

The icons on the left side of the dialog box provide quick access to
commonly used files and file locations. To reorder the icons, drag them
to a new location. To add, modify, or remove an icon, right-click the
icon to display a shortcut menu.

Standard toolbar

To change the default drawing folder

1 On the command line, enter rememberfolders, and then enter 0.

2 On the Windows desktop, right-click the AutoCAD icon. Click Properties.

3 Click the Shortcut tab.

4 In the Start In box, enter the path of the folder that should be the default
when you open or save drawing files.

5 Click OK.

Open Part of a Large Drawing (Partial Load)
If you work with large drawings, you can improve performance by opening
only the view and layer geometry that you want to work with.

If you work with large drawings, you can use the Partial Open option of the
OPEN command to select which view and layer geometry (graphical objects
only) that you want to work with in a drawing. For example, if you load
geometry from the EXTENTS view and the SITE layer, everything on the SITE
layer that falls within the Extents view is loaded into the drawing.

You can only edit what is loaded into the drawing file, but all the drawing’s
named objects are available in the partially open drawing. Named objects
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include layers, views, blocks, dimension styles, text styles, viewport
configurations, layouts, UCSs, and linetypes.

By organizing large drawings into sectored views, you can load and edit only
what you need. For example, if you work with a city plan and need to edit
only the southeast sector (sector D3 in the illustration), you can load this
drawing area by specifying the predefined view. If you need to edit only the
city plot numbers, you can load just the geometry on this specific layer.

After a drawing is partially open, you can load additional geometry from a
view, selected area, or layer into the drawing by using . The Partial Open
option is available only for drawings in AutoCAD 2000 or later format.

To partially open a drawing

1 Click File menu ➤ Open.

2 In the Select File dialog box, select a drawing.

3 Click the arrow next to Open. Click Partial Open.

4 In the Partial Open dialog box, select a view; the default view is EXTENTS.

You can load only geometry from model space views that are saved in
the current drawing.

5 Select one or more layers.
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If you do not select a layer or layers to load, no layer geometry is loaded
into the drawing but all drawing layers exist in the drawing. If no layer
geometry is specified to load into the drawing, no geometry is loaded
even if the geometry from a view is specified to load. If you draw objects
on a layer that is not loaded, you may be drawing on top of existing
geometry that is not loaded in the drawing.

NOTE Xref-dependent layers are displayed in the Layer Geometry to Load
list only if the selected drawing was last saved with the  system variable set
to 1. Any layers created in the xref since the xref was loaded into the drawing
are not displayed in the Layer Geometry to Load list.

6 If the drawing contains a spatial index, you can select the Use Spatial
Index option.

A spatial index is a list that organizes objects based on their location in
space. A spatial index is used to locate the portion of the drawing that
is read; this minimizes the time required to open the drawing.

7 If the drawing contains xrefs but you don’t want to load them, select
Unload All Xrefs on Open.

NOTE If you partially open a drawing that contains a bound xref, only the
portion of the xref that is loaded (defined by the selected view) is bound to
the partially open drawing.

8 Click Open.

You can choose to load additional information into the current drawing
as long as the drawing is partially open.

To load additional geometry into a partially open drawing

1 Click File menu ➤ Partial Load.

The Partial Load option is available only if the current drawing is a
partially open drawing.

2 In the Partial Load dialog box, select a view or click Pick Window to
define a view.

The default view is Extents. You can load only geometry from model
space views that are saved in the current drawing.

3 Select one or more layers.

If you do not select a layer or layers to load, no layer geometry is loaded
into the drawing, but all drawing layers exist in the drawing. If no layer
geometry is specified to load into the drawing, no geometry is loaded
even if the geometry from a view is specified to load. If you draw objects
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on a layer that is not loaded, you may be drawing on top of existing
geometry that is not loaded in the drawing. You cannot unload any
geometry that is loaded in the current drawing.

4 Click Open.

Work with Multiple Open Drawings
You can easily transfer information between drawings that are open in a single
session.

When you open multiple drawings in a single session, you can

■ Quickly reference other drawings

■ Copy and paste between drawings

■ Drag selected objects from one drawing to another with the right button
on your pointing device

■ Use Match Properties () to copy properties from objects in one drawing to
objects in another drawing

■ Use object snaps, the Copy with Basepoint () command, and the Paste to
Original Coordinates () command to ensure accurate placement

Set the TASKBAR command to 1 to display multiple open drawings as separate
items on the Windows taskbar. You can then press Alt+TAB to quickly switch
from drawing to drawing. If you prefer to display only the active drawing on
the taskbar, set TASKBAR to 0.

To switch between open drawings

Do one of the following to switch between open drawings:

■ Click anywhere in a drawing to make it active.

■ Use  CTRL +  F6  or  CTRL +  TAB .

■ Set the TASKBAR command to 1 to display multiple open drawings as
separate items on the Windows taskbar. You can then press Alt+TAB to
quickly switch from drawing to drawing.
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Save a Drawing
You save drawing files for later use just as you do with other Microsoft
Windows applications. You can also set up automatic saving and backup files
and save only selected objects.

When you work on a drawing, you should save it frequently. Saving protects
you from losing work in the event of a power failure or other unexpected
event. If you want to create a new version of a drawing without affecting the
original drawing, you can save it under another name.

The file extension for drawing files is .dwg, and unless you change the default
file format in which drawings are saved, drawings are saved in the latest
drawing-file format. This format is optimized for file compression and for use
on a network.

Save Part of a Drawing File

If you want to create a new drawing file from part of an existing drawing, you
can use  or . With either command, you can select objects or specify a block
definition in your current drawing and save them in a new drawing file. You
can also save a description along with the new drawing.

Save to a Different Type of Drawing File

You can save a drawing to an earlier version of the drawing format (DWG) or
drawing interchange format (DXF), or save a drawing as a template file. Choose
the format from Files of Type in the Save Drawing As dialog box.

Reduce the Time Required to Save a Drawing File

You can reduce the time required to save a drawing file if you specify
incremental saves rather than full saves. An incremental save updates only
those portions of the saved drawing file that you changed.

When you use incremental saves, drawing files will contain a percentage of
potentially wasted space. This percentage increases after each incremental
save until it reaches a specified maximum, at which time a full save is
performed instead. You can set the incremental save percentage in the Open
and Save tab of the Options dialog box or by setting the value of the system
variable . If you set the value of ISAVEPERCENT to 0, all saves are full saves.

To reduce the size of drawing files, it is recommended that you perform a full
save (with IPERCENTSAVE set to 0) before transmitting or archiving a drawing.
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Avoid File Name Issues for International Work

If you share drawing files with companies in other countries and regions, the
drawing file names might contain characters that are not available in other
languages.

For example, a drawing file created in China might be saved with double-byte
characters in the file name. When this drawing file is transmitted to a different
language version of Windows, either of the following will occur:

■ If Asian language support is turned on, the file name characters are visible
in Windows Explorer

■ If Asian language support is not turned on, the file name characters appear
as a series of question marks in Windows Explorer

In either case, you will not be able to open the drawing file in AutoCAD LT
unless you rename it. This is also true for special characters in file names of
European and other languages.

To avoid these issues when your language uses double-byte characters or special
characters, do not use high ASCII values (values of 80 hexadecimal and above)
when choosing a file name.

See also:

“Save Drawings to Previous Drawing File Formats”
“Export Drawings to Other File Formats”
“Create Drawing Files for Use as Blocks” on page 456
“Add Identifying Information to Drawings” on page 112
“Create and Restore Backup Files” on page 130

To save a drawing

1 Click File menu ➤ Save.

If you previously saved and named the drawing, any changes made are
saved and the Command prompt is redisplayed. If you have never saved
the drawing, the Save Drawing As dialog box is displayed.

2 In the Save Drawing As dialog box under File Name, enter the new
drawing name; the file extension is not required. Click Save.

Standard toolbar
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To save a drawing automatically

1 Click Tools menu ➤ Options.

2 In the Options dialog box, Open and Save tab, select Automatic Save.

3 Enter a number in Minutes Between Saves.

4 Click OK.

To save a backup of the previous version every time the drawing is saved

1 Click Tools menu ➤ Options.

2 In the Options dialog box, Open and Save tab, select Create Backup Copy
with Each Save.

3 Click OK.

To save selected objects into a new drawing file

1 At the Command prompt, enter wblock.

2 In the Write Block dialog box, under Objects, select Objects.

3 Under Base Point, click Pick Point.

4 Specify the base point in the drawing area, or enter coordinate values in
the X, Y, and Z boxes.

5 Under Objects, click the Select Objects button.

6 Select the objects in the drawing area.

7 Under Objects, select an option to indicate whether you want to retain,
convert, or delete the selected objects.

8 In the File Name box, enter the name for the new drawing file.

9 In the Location box, specify the folder for the new drawing file.

10 In the Insert Units box, you can select a different base unit. This option
provides a method to scale objects automatically in the new drawing
file.

11 Click OK.

The objects you selected in the drawing are saved in a new drawing file.

To save a block definition as a new drawing file

1 At the Command prompt, enter wblock.
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2 In the Write Block dialog box, select Block.

3 Click in the box next to Block. Select the block definition you want to
save.

4 In the File Name box, enter the name for the new drawing file.

5 In the Location box, specify the folder for the new drawing file.

6 In the Insert Units box, you can select a different base unit. This option
provides a method to scale objects automatically in the new drawing
file.

7 Click OK.

The objects in the specified block definition are saved as objects in a new
drawing file. The insertion base point of the block definition will be
located at the origin point (0,0,0) in the new drawing.

Find a Drawing File
You can search for a drawing using name, location, and date filters, properties
such as keywords that you added to the drawing, or text strings containing a
specific word or phrase.

■ Use the Search tool in Microsoft® Windows® to search for drawings using
name, location, and date filters. You can also specify a word or phrase
contained in the drawing file. You can search for all textual data except
text in tables and fields, and xrefs within drawing files. Supported drawing
file types include DWG, DWF, DWT, and DWS.

■ Use the Search dialog box for DesignCenter™ to search for Microsoft
Windows file properties, such as title or keyword, that you added to
drawings.

■ Use the Select File dialog box for the OPEN command to display drawing
file previews. When the  system variable is on, a raster preview image is
automatically generated and stored with the drawing when you save it.

See also:

“Add Identifying Information to Drawings” on page 112
“Access Content with DesignCenter” on page 64
“Work with Sheets in a Sheet Set” on page 233

To search for files

1 Click File menu ➤ Open.
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2 In the Select File dialog box, click Tools ➤ Find.

3 In the Find dialog box, Name & Location tab, specify a file type, file
name, and path.

You can use wild cards when specifying a file name.

4 On the Date Modified tab, click All Files, or click Find All Files Created
or Modified to specify a date filter.

You can search for drawings modified between a specified range of dates
or within a specified number of months or days.

5 Click Find Now.

6 Select one or more files from the search results. Click OK.

7 In the Select File dialog box, click Open.

Standard toolbar

Specify Search Paths, File Names, and File
Locations

You can set the search path to drawing support files such as text fonts,
drawings, linetypes, and hatch patterns. You also can specify the location of
temporary files, which is important when working in a network environment.

The Files tab of the Options dialog box is where you set the search path that
is used by the program to find drawing support files such as text fonts,
drawings, linetypes, and hatch patterns. The  system variable stores the location
of the My Documents folder for the current user.

The working search path for drawing support files lists paths that are valid
and exist in the current system directory structure (including system network
mapping). Using these options helps improve performance when these files
are loaded.

Using the Files tab of the Options dialog box, you can also specify the location
of temporary files. Temporary files are created on disk, and then deleted when
you exit the program. The temporary directory is set to the location that
Microsoft Windows uses. If you plan to run this program from a write-protected
directory (for example, if you work on a network or open files on a CD), specify
a different location for your temporary files.
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The temporary directory you specify must not be write-protected, and the
drive containing the directory should have sufficient disk space for the
temporary files. It is recommended that you manually delete the files from
this directory on a regular basis to ensure sufficient space is provided for
temporary files. If not enough space is available for temporary files, you may
experience errors or instability in the program.

If you want to use a file that contains custom interface elements, specify it in
the Customizations Files item on the Files tab of the Options dialog box. The
default customization file is acad.cui.

To change a search path

1 Click Tools menu ➤ Options.

2 In the Options dialog box, Files tab, click the plus sign (+) to the left of
the kind of path you want to change.

3 Select the path you want to change.

4 Click Browse, and then search drives and directories until you find the
one you want.

5 Select the drive and directory you want to use.

6 Click OK.
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Repair, Restore, or
Recover Drawing Files

 

If a drawing file is damaged or if your program terminates

unexpectedly, you can recover some or all of the data by using

commands to find and correct errors, or by reverting to a

backup file.

9
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Repair a Damaged Drawing File
If a drawing file is damaged, you can recover some or all of the data by using
commands to find and correct errors.

Repair and Recovery

When an error occurs, diagnostic information is recorded in the acad.err file,
which you can use to report a problem.

A drawing file is marked as damaged if corrupted data is detected, or if you
request that the drawing be saved after a program failure. If the damage is
minor, sometimes you can repair the drawing simply by opening it. Otherwise,
you can use the following:

■ . Performs an audit on, and attempts to open, any drawing file

■ . Finds and corrects errors in the currently open drawing file.

Example: Auditing Files

Auditing a file generates a description of problems with a drawing file and
recommendations for correcting them. As you start the audit, you specify
whether you want the program to try to fix the problems it encounters. The
report is similar to the following example:

Auditing Header
DXF NAME Current Value Validation Default
PDMODE 990 - 2040
UCSFOLLOW 811 or 0
Error found in auditing header variables
4 Blocks audited
Pass 1 4 objects audited
Pass 2 4 objects audited
Total errors found 2 fixed 2
If you chose not to correct the errors, the last statement changes to

Total errors found 2 fixed 0.

The output from a recovery audit is written to an audit log (ADT) file if the
system variable is set to 1 (on).

Recovery does not necessarily preserve the high-level consistency of the
drawing file. The program extracts as much material as it can from the damaged
file.
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To repair a damaged drawing file

1 Click File menu ➤ Drawing Utilities ➤ Recover.

2 In the Select File dialog box, select a file. Click Open.

After the audit, RECOVER places all objects with errors in the Previous
selection set for easy access. The output from the audit is written to an
audit log (ADT) file if the AUDITCTL system variable is set to 1 (on).

To repair a damaged drawing file due to a system failure

1 If the program encounters a problem and cannot continue, it displays
an error message and, for some errors, an error code. Record the error
code number, save the changes if possible, and exit to the operating
system.

2 Restart the program.

3 In the Drawing Recovery window, under Backup Files, double-click the
drawing node to expand it. On the list, double-click one of the drawing
or backup files to open it.

If the program detects that the drawing has been damaged, a message is
displayed asking if you want to proceed.

4 Enter y to proceed.

As the program attempts to repair the drawing, a diagnostic report is
displayed. The output from the audit is written to an audit log (ADT)
file if the AUDITCTL system variable is set to 1 (on).

5 Depending on whether the repair is successful, do one of the following:

■ If the repair is successful, the drawing opens. Save the drawing file.

■ If the program cannot repair the file, a message is displayed. In that
case, choose one of the other drawing or backup files listed in the
Drawing Recovery window beginning with step 3.

To repair an open drawing

1 Click File menu ➤ Drawing Utilities ➤ Audit.

2 At the Fix Any Errors Detected? prompt, enter y or n.

AUDIT places all objects with errors in the Previous selection set for easy
access. The output from the audit is written to an audit log (ADT) file if
the AUDITCTL system variable is set to 1 (on).
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NOTE If the drawing contains errors that AUDIT cannot fix, try using
RECOVER. RECOVER repairs any specified DWG file that is not the current
drawing file.

To restore a drawing from a backup file

1 In Windows Explorer, locate the backup file identified by the .bak file
extension.

2 Right-click the backup file. Click Rename.

3 Type a new name using the .dwg file extension.

4 Open the file as you would open any other drawing file.

Create and Restore Backup Files
Computer hardware problems, power failures or surges, user mistakes, or
software problems can cause errors in a drawing. By saving your work
frequently, you can ensure a minimum of lost data if your system fails for any
reason. If a problem occurs, you can restore a drawing backup file.

Use Backup Files

In the Options dialog box, on the Open and Save tab, you can specify that
backup files are created when you save drawings. If you do, each time you
save a drawing, the previous version of your drawing is saved to a file with
the same name and a .bak file extension. The backup file is located in the same
folder as the drawing file.

You can revert to your backup version by renaming the .bak file in Windows
Explorer to a file with a .dwg extension. You may want to copy it to a different
folder to avoid overwriting your original file.

Save Your Drawing Automatically at Specified Intervals

If you turn the automatic save option on, your drawing is saved at specified
time intervals. By default, files saved automatically are temporarily assigned
the name filename_a_b_nnnn.sv$.

■ Filename is the current drawing name.

■ a is the number of open instances of the same drawing file in the same
work session.

■ b is the number of open instances of the same drawing in different work
sessions.
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■ nnnn is a random number.

These temporary files are automatically deleted when a drawing closes
normally. In the event of a program failure or a power failure, these files are
not deleted.

To recover a previous version of your drawing from the automatically saved
file, rename the file using a .dwg extension in place of the .sv$ extension before
you close the program.

See also:

“Recover from a System Failure” on page 131

To restore a drawing from a backup file

1 In Windows Explorer, locate the backup file identified by the .bak file
extension.

2 Select the file you want to rename. You do not need to open it.

3 Click File menu ➤ Rename.

4 Enter a new name using the .dwg file extension.

5 Open the file as you would open any other drawing file.

Recover from a System Failure
A hardware problem, power failure, or software problem can cause this program
to terminate unexpectedly. If this happens, you can restore the drawing files
that were open.

If the program fails, you can save your current work to a different file. This
file uses the format, DrawingFileName_recover.dwg, where DrawingFileName is
the file name of your current drawing.

Resolve Drawing Files

After a program or system failure, the Drawing Recovery Manager opens the
next time you start AutoCAD. Drawing Recovery Manager displays a list of all
drawing files that were open, including the following drawing file types:

■ Drawing files (DWG)

■ Drawing template files (DWT)

■ Drawing Standards files (DWS)
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NOTE Unsaved drawings that are open at the time of an unexpected failure are
not tracked by the Drawing Recovery Manager. Be sure to save your work after
you begin, and regularly thereafter.

For each drawing, you can open and choose from the following files if they
exist:

■ DrawingFileName_recover.dwg

■ DrawingFileName_a_b_nnnn.sv$

■ DrawingFileName.dwg

■ DrawingFileName.bak

NOTE The drawing, backup, and recover files are listed in the order of their time
stamps—the time when they were last saved.

Double-click a top-level drawing node listed under Backup Files to display up
to four files as listed above. Right-click any node under Backup Files to display
shortcut menu options.

If you close the Drawing Recovery window before resolving all affected
drawings, you can open Drawing Recovery at a later time with the  command.

Send an Error Report Automatically to Autodesk

If the program encounters a problem and closes unexpectedly, you can send
an error report to help Autodesk diagnose problems with the software. The
error report includes information about the state of your system at the time
the error occurred. You can also add other information, such as what you were
doing at the time of the error. The  system variable controls whether the
error-reporting feature is available.

To open the Drawing Recovery Manager

■ Click File menu ➤ Drawing Utilities ➤ Drawing Recovery Manager.

Any drawings that need to be restored from an unexpected program or
system failure are listed under Backup Files.

To restore a drawing using the Drawing Recovery Manager

1 If necessary open the Drawing Recovery Manager.

2 In the Drawing Recovery Manager, under Backup Files, double-click a
drawing node to list all available drawing and backup files.
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3 Double-click a file to open it.

If the drawing file is damaged, the drawing is automatically repaired, if
possible.

To remove a drawing from the Drawing Recovery Manager

1 If necessary, click File menu ➤ Drawing Utilities ➤ Drawing Recovery
Manager.

2 Do one of the following:

■ Restore the drawing and then save it.

■ Right-click a drawing node. Click Remove.

To expand or collapse all nodes in the Drawing Recovery Manager

■ Right-click in the Backup Files area under the last drawing node listed. Click
Collapse All.

To turn error reporting on or off

1 At the Command prompt, enter reporterror.

2 Enter 0 to turn off error reporting, or enter 1 to turn on error reporting.
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Maintain Standards in
Drawings

 

Drawings are easier to interpret if you set standards to enforce

consistency. You can set standards for layer names, dimension

styles, and other elements; check drawings against these

standards; and then change any properties that do not

conform.
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Overview of CAD Standards
You can create a standards file to define common properties in order to
maintain consistency throughout your drawing files. Standards define a set
of common properties for named objects such as layers and text styles. You
or your CAD manager can create, apply, and audit standards in drawings to
enforce consistency. Because standards make it easier for others to interpret
drawings, standards are particularly useful in collaborative environments,
where many individuals contribute to the creation of a drawing.

Named Objects for Standards-Checking

You can create standards for the following named objects:

■ Layers

■ Text styles

■ Linetypes

■ Dimension styles

Standards File

After you define standards, you save them as a standards file. You can then
associate the standards file with one or more drawing files. After you associate
a standards file with a drawing, you should periodically check the drawing to
make sure it conforms with the standards.

Sample Drawing and Associated Standards File

With this program, you get a sample drawing and an associated standards file.
The drawing file has been deliberately modified to contain a number of
nonstandard objects to demonstrate how drawings are audited. The sample
files, MKMPlan.dwg and MKMStd.dws, are installed in the Sample folder.

How a Standards Audit Works

When you check a drawing for standards violations, each named object of a
specific type is checked against the standards files associated with the drawing.
For example, each layer in the drawing is checked against the layers in the
standards file.

A standards audit can uncover two types of problems:

■ An object with a nonstandard name is present in the drawing being checked.
For example, a layer named WALL is present in the drawing but not in any
associated standards files.
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■ A named object in a drawing matches the name of one in a standards file,
but their properties are different. For example, in the drawing the WALL
layer is yellow, but the standards file specifies red for the WALL layer.

When you fix objects with nonstandard names, the nonstandard objects are
purged from the drawing. Any drawing objects that are associated with the
nonstandard object are transferred to a replacement standard object that you
specify. For example, you fix a nonstandard layer, WALL, and replace it with
the standard ARCH-WALL. In this example, choosing Fix in the Check
Standards dialog box transfers all objects from layer WALL to layer ARCH-WALL
and then purges layer WALL from the drawing.

Standards Plug-Ins

The auditing process uses standards plug-ins, applications that define the rules
for the properties that are checked for individual named objects. Layers,
dimension styles, linetypes, and text styles are each checked against their
corresponding plug-ins. You can specify which plug-ins to use when checking
a drawing for standards violations. Autodesk or third-party developers may
add standards plug-ins for checking additional drawing properties.

All plug-ins check all properties for each named object except for the layer
plug-in. The following layer properties are checked when using the layer
plug-in:

■ Color

■ Linetype

■ Lineweight

■ Plot style mode

■ Plot style name (when the PSTYLEMODE system variable is set to 0)

The following layer properties are not checked by the layer plug-in:

■ On/Off

■ Freeze/Thaw

■ Lock

■ Plot/No Plot
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Standards Settings

A variety of settings that may be useful to CAD managers are available in the
CAD Standards Settings dialog box. This dialog box can be accessed by clicking
Settings in the Check Standards and Configure Standards dialog boxes.

Define Standards
To set standards, you create a file that defines properties for layers, dimension
styles, linetypes, and text styles, and you save it as a standards file with the
.dws file name extension.

Depending on how you organize your projects, you may decide to create and
associate more than one project-specific standards file with an individual
drawing. When you audit the drawing file, conflicts may arise between settings
in the standards files. For example, one standards file specifies that the layer
WALL is yellow, and another standards file specifies that it is red. In the case
of conflicts, the first standards file associated with the drawing takes
precedence. If necessary, you can change the order of the standards files to
change the precedence.

If you want to audit drawings using just a specific plug-in, you can specify the
plug-in when defining your standards file. For example, if recent changes to
a drawing are limited to text changes, you may want to audit the drawing
using only the layers and text styles plug-ins to save time. By default, all
plug-ins are used when auditing drawings for standards violations.

To create a standards file

1 Click File menu ➤ New.

2 Enter a template file name or press  ENTER  to continue.

3 In a new drawing, create any layers, dimension styles, linetypes, and
text styles that you want to be part of the standards file.

4 Click File menu ➤ Save As.

5 In File Name, enter a name for the standards file.

6 In the Files of Type list, select AutoCAD Drawing Standards (*.dws).

DWS files must be saved in the current drawing file format. To create a
DWS file in a previous drawing file format, save the file in the desired
DWG format, and then rename the DWG file using a .dws extension.

7 Click Save.
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To associate a standards file with the current drawing

1 At the Command prompt, enter standards.

2 In the Configure Standards dialog box, Standards tab, click the plus (+)
button (Add Standards File).

3 In the Select Standards File dialog box, locate and select a standards file.

4 Click Open.

5 (Optional) Repeat steps 2 and 3 if you want to associate additional
standards files with the current drawing.

6 Click OK.

CAD Standards toolbar

To remove a standards file from the current drawing

1 At the Command prompt, enter standards.

2 In the Configure Standards dialog box, Standards tab, select a standards
file in Standards Files Associated with the Current Drawing.

3 Click the X button (Remove Standards File).

4 (Optional) Repeat steps 2 and 3 if you want to remove additional
standards files.

5 Click OK.

CAD Standards toolbar

To change the order of standards files associated with the current drawing

1 At the Command prompt, enter standards.

2 In the Configure Standards dialog box, Standards tab, select the standards
file whose position you want to change in Standards Files Associated
with the Current Drawing.
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3 Do one of the following:

■ Click the up arrow button (Move Up) to move the standards file up
one position in the list.

■ Click the down arrow button (Move Down) to move the standards
file down one position in the list.

4 (Optional) Repeat steps 2 and 3 if you want to change the position of
other standards files in the list.

5 Click OK.

CAD Standards toolbar

To specify which standards plug-ins to use when auditing a drawing

1 At the Command prompt, enter standards.

2 In the Configure Standards dialog box, Plug-ins tab, do one of the
following:

■ Select the check box for at least one plug-in to audit a drawing for
standards violations.

■ To select all plug-ins, right-click in the Plug-ins list. Click Select All.
(You can clear all plug-ins. Right-click in the Plug-ins list. Click Clear
All.)

3 Click OK.

CAD Standards toolbar

Check Drawings for Standards Violations
You can audit a drawing file for violations of standards and then fix violations.
The Batch Standards Checker audits more than one file at a time.

After you associate a standards file with a drawing, you should periodically
check the drawing to make sure it conforms with its standards. This is especially
important when more than one person is updating the drawing file. For
example, in a project with multiple subcontractors, one subcontractor may
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create new layers that do not comply with the standards you have defined.
In that case, you need to be able to identify the nonstandard layers and fix
them.

You can use the notification feature to alert users that a standards violation
has occurred while working in a drawing. This feature allows you to fix a
standards violation just after it has occurred, making it easier to create and
maintain drawings that comply with standards.

Check a Single Drawing

You can use the CHECKSTANDARDS command to view all standards violations
in the current drawing. The Check Standards dialog box reports each
nonstandard object, along with any suggested fixes.

You can choose to fix or ignore each reported standards violation. If you ignore
a reported violation, it is flagged in the drawing. You can turn off the display
of ignored problems so that they are not reported as violations the next time
you audit the drawing.

If no fix is provided for the current standards violation, no item is highlighted
in the Replace With list, and the Fix button is not available. If you fix a
standards violation that is currently displayed in the Check Standards dialog
box, the violation is not removed from the dialog box until you click the Fix
or the Next button.

Once the entire drawing has been audited, the Checking Complete message
is displayed. This message summarizes the standards violations that were
found in the drawing. The message also shows the violations that were fixed
automatically, the violations that were fixed manually, and the violations
that were ignored.

NOTE When two separate violations are displayed for a nonstandard layer (one
violation for the nonstandard layer name and one for the nonstandard layer
properties), both violations will be fixed at the same time if you choose to fix either
one. This results in a discrepancy in the Checking Complete alert summary: there
will be fewer standards violations found than were originally reported in the Check
Standards dialog box.

Check Multiple Drawings

You can use the Batch Standards Checker to analyze multiple drawings and
summarize standards violations in an HTML report. To run a batch standards
audit, you must first create a standards check (CHX) file. The CHX file is a
configuration and report file; it contains a list of drawing and standards files,
as well as a report on a standards check.
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By default, each drawing is checked against the standards files that are
associated with it. Alternatively, you can override the default and choose
another set of standards files to be used.

After the batch standards audit is complete, you can view an HTML report
with details of the audit. You can also create notes that are included in the
HTML report. This report can be exported and printed. In a collaborative
environment, you can distribute the report to drafters so that they can fix any
problems with their sections.

Use Notification of Standards Violations While Working in a Drawing

You can set options for notification in the CAD Standards Settings dialog box
and with the STANDARDSVIOLATION system variable. If you select Display
Alert upon Standards Violation in the dialog box, then an alert is displayed
when a violation occurs while you work. If you select Display Standards Status
Bar Icon, an icon is displayed when you open a file associated with a standards
file and when you create or modify nonstandard objects.

By default, if an associated standards file is missing or if a violation occurs
while you work, a pop-up message appears in the lower-right corner of the
application window (the status bar tray).

You should check a drawing for standards violations using the Check Standards
dialog box before using the notification options. This prevents triggering a
notification alert carried over from a previous session. After a drawing has
been checked and fixed, the notification options trigger an alert only if a new
violation occurs.

Display Alerts for Named Objects

If you select Display Alert upon Standards Violation, you are notified of
violations when you create or edit only named objects (linetypes, text styles,
layers, and dimensions). Standards violations that do not affect named objects
do not trigger a notification alert. Also, if a named object was marked as
ignored in the Check Standards dialog box, that object no longer triggers a
notification alert, even though the named object is nonstandard. Changing
nonstandard named objects, such as setting a nonstandard layer as current,
does trigger a notification alert.

After an alert is displayed, you can choose to fix or not fix the violation.
Choosing to fix the violation opens the Check Standards dialog box. If it is
already open, the dialog box addresses the specific violations that just occurred.
You can resume your previous work in the Check Standards dialog box after
you respond to the most recent standards violations. Alternatively, if you do
not want to fix violations when alerted, you can click Do Not Fix to dismiss
the alert.
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If you open a drawing that has one or more associated standards files, an
Associated Standards File(s) icon is displayed in the status bar. If an associated
standards file is missing, a Missing Standards File(s) icon is displayed in the
status bar. If you double-click the Missing Standards File(s) icon and then
resolve or dissociate missing standards files, the Missing Standards File(s) icon
is replaced by the Associated Standards File(s) icon.

NOTE If you select Display Alert upon Standards Violation in the Check Standards
dialog box and you fix a violation, you can return to a fixing operation where you
left off. If you select Display Standards Status Bar icon and you click the icon and
fix a violation, you must return to a standards-fixing operation from the beginning.

To audit a drawing for standards violations

1 Open a drawing that has one or more associated standards files.

An Associated Standards File(s) icon is displayed in the status bar. If an
associated standards file is missing, a Missing Standards File(s) icon is
displayed in the status bar.

NOTE If you click the Missing Standards File(s) icon and then resolve or
dissociate missing standards files, the Missing Standards File(s) icon is replaced
by the Associated Standards File(s) icon.

2 In the drawing with one or more associated standards files, enter
checkstandards at the Command prompt.

The Check Standards dialog box is displayed with the first standards
violation reported under Problem.

3 Do one of the following:

■ If you want to apply the item selected in the Replace With list to fix
the violation reported under Problem, click Fix. If there is a
recommended fix in the Replace With list, it is preceded by a check
mark. If no recommended fix exists for the current standards violation,
the Fix button is not available.

The Check Standards dialog box automatically displays the next
standards violation under Problem.

■ Manually fix the standards violation. Click the Next button to display
the next violation.

■ Select Mark This Problem as Ignored. Click the Next button to display
the next violation.

Selecting Mark This Problem as Ignored flags the standards violation
so you can prevent it from being displayed the next time you use the
CHECKSTANDARDS command.
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■ Click the Next button to display the next violation.

4 Repeat steps 2 and 3 until you have cycled through all standards
violations.

5 Click Close.

CAD Standards toolbar

To turn the display of ignored problems on or off

1 In a drawing with one or more associated standards files, enter
checkstandards at the Command prompt.

2 In the Check Standards dialog box, click Settings.

3 In the CAD Standards Settings dialog box, select or clear Show Ignored
Problems.

4 Click OK.

CAD Standards toolbar

To turn notification for standards violations on or off

1 At the Command prompt, enter standards.

2 In the Configure Standards dialog box, click Settings.

3 Do one of the following:

■ To turn off standards notifications, select Disable Standards
Notifications.

■ To be notified by alert, select Display Alert upon Standards Violation.

■ To be notified by the display of an icon in the status bar, select Display
Standards Status Bar Icon.

4 Click OK.

CAD Standards toolbar
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To start the Batch Standards Checker

■ Click Start menu (Windows) ➤ All Programs ➤ Autodesk ➤ AutoCAD 2006
➤ Batch Standards Checker.

NOTE When you start the Batch Standards Checker from a DOS command line
using the DWGCHECKSTANDARDS command, the Batch Standards Checker
accepts a variety of command-line parameters that can be used for scripting batch
standards audits.

To create a standards check file for the Batch Standards Checker

1 Start the Batch Standards Checker.

2 In the Batch Standards Checker, click File menu ➤ New Check File. (You
can also click New on the Batch Standards Checker toolbar.)

3 On the Drawings tab, click the + button (Add Drawing).

4 In the Open dialog box, select a drawing to audit.

5 (Optional) Repeat steps 3 and 4 if you want to add additional drawings
to the standards check file.

6 Click File menu ➤ Save As. (You can also click the Save As button on
the Batch Standards Checker toolbar.)

7 In the Save As dialog box, in File Name, enter a name for the file.

8 Click Save.

To open an existing standards check file

1 Start the Batch Standards Checker.

2 In the Batch Standards Checker, click File menu ➤ Open Check File.
(You can also click Open on the Batch Standards Checker toolbar.)

3 In the Open dialog box, locate and select a standards check file.

4 Click Open.
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To specify a standards override for a standards check file

1 Start the Batch Standards Checker.

2 Create a standards check file or open an existing one.

3 In the Batch Standards Checker, Standards tab, select the Check All
Drawings Using the Following Standards Files option.

4 Click the + button (Add Standards File).

5 In the Open dialog box, select a standards file to use as an override. Click
Open.

6 (Optional) Repeat steps 5 and 6 if you want to add additional standards
files as overrides.

7 In the Batch Standards Checker, click File menu ➤ Save Check File. (You
can also click Save on the Batch Standards Checker toolbar.)

To audit a set of drawings for standards violations

1 Start the Batch Standards Checker.

2 Open an existing standards check file, or create a new one.

3 In the Batch Standards Checker, click Check menu ➤ Start Check. You
can also click Start Check on the Batch Standards Checker toolbar.)

When the batch audit is complete, the report is displayed in a browser
window.

You can cancel the batch audit at any time by clicking Stop Check.

NOTE You cannot check encrypted files using the Batch Standards Checker.

To add notes to the batch audit report

1 Start the Batch Standards Checker.

2 Create a standards check file or open an existing one.

3 In the Batch Standards Checker, Notes tab, enter notes to be included
in the report.

4 Click File menu ➤ Save Check File. (You can also click Save on the Batch
Standards Checker toolbar.)

To view a previously generated batch audit report

1 Start the Batch Standards Checker.
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2 Open the standards check file that generated the report you want to
view.

3 In the Batch Standards Checker, click Check menu ➤ View Report. (You
can also click View Report on the Batch Standards Checker toolbar.)

The report is displayed in a browser window.

4 Select one of the following options to filter the data displayed in the
report:

■ Overview. Summarizes the number of problems encountered in each
audited drawing.

■ Plug-ins. Summarizes the standards plug-ins installed on the system
used to run the batch audit.

■ Standards. Summarizes the standards files used to check the drawings
in the batch audit.

■ Problems. Provides detailed information about each problem that
was encountered.

■ Ignored Problems.  Provides detailed information about problems
that were flagged as ignored.

■ All. Shows all available standards audit information.

5 In the For list, select individual drawings to view their audit information.

To export a batch audit report

1 Start the Batch Standards Checker.

2 Create a standards check file or open an existing one.

3 In the Batch Standards Checker, click Check menu ➤ Export Report.
(You can also click Export Report on the Batch Standards Checker
toolbar.)

Translate Layer Names and Properties
With the Layer Translator, you can change a drawing’s layers to match layer
standards you set.
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Convert Layers to Established Drawing Standards

Using the Layer Translator, you can convert layers in one drawing to standards
you define.

For example, if you receive a drawing from a company that does not follow
your company’s layer conventions, you can convert the drawing’s layer names
and properties to your company’s standards. You can map layers in the drawing
you are currently working on to different layers in another drawing or
standards file, and then convert the current layers using those mappings. If
the drawings contain layers of the same name, the Layer Translator can
automatically change the properties of the current layers to match those in
the other layers.

You can save your layer translation mappings in a file and reuse them with
other drawings.

To convert a drawing’s layers to standard layer settings

1 Click Tools menu ➤ CAD Standards ➤ Layer Translator.

2 In the Layer Translator, do one of the following:

■ Click Load to load layers from a drawing, a drawing template, or a
drawing standards file. In the Select Drawing File dialog box, select
the file you want. Click Open.

■ Click New to define a new layer. In the New Layer dialog box, enter
a name for the new layer and select its properties. Click OK.

You can repeat step 2 as many times as you want. If you load other files
containing layers of the same name as ones already shown in the
Translate To list, the layer properties first loaded in the list are
maintained; any duplicate layer properties are ignored.

3 Map layers in the current drawing to the layers you want to convert to.
Use either or both of the following methods to map layers:

■ To map all identically named layers from one list to the other, click
Map Same.

■ To map individual layers, in the Translate From list, select one or
more layers. In the Translate To list, select the layer whose properties
you want to use. Click Map to define the mapping. You can repeat
this method for each layer or group of layers to be translated.

To remove a mapping, select the mapping from the Layer Translation
Mappings list. Click Remove. To remove all mappings, right-click in the
list. Click Remove All.
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4 (Optional) You can perform the following tasks in the Layer Translator:

■ To change the properties of a mapped layer, in the Layer Translation
Mappings list, select the mapping whose properties you want to
change. Click Edit. In the Edit Layer dialog box, change the linetype,
color, lineweight, or plot style of the mapped layer. Click OK.

■ To customize the process of layer translation, click Settings. In the
Settings dialog box, select the options you want. Click OK.

■ To save layer mappings to a file, click Save. In the Save Layer Mappings
dialog box, enter a file name. Click OK.

5 Click Translate to perform the layer translations you have specified.

CAD Standards toolbar

View Selected Drawing Layers

With the Layer Translator, you can control which layers are visible in the
drawing area.

You can choose to display objects on all layers in your drawing, or objects on
layers you specify. By viewing selected layers, you can visually verify the
contents of those layers.

To specify which layers are displayed in the drawing area

1 Click Tools menu ➤ CAD Standards ➤ Layer Translator.

2 In the Layer Translator, click Settings.

3 In the Settings dialog box, do one of the following:

■ To display objects on selected layers in your drawing, select Show
Layer Contents When Selected. Only the layers selected in the Layer
Translator dialog box are displayed in the drawing area.

■ To display objects on all layers in your drawing, clear Show Layer
Contents When Selected.

4 Click OK.

CAD Standards toolbar

Translate Layer Names and Properties | 149



Purge Unreferenced Layers

You can use the Layer Translator to purge (delete all) unreferenced layers from
a drawing.

For example, if your drawing includes layers that you do not need, you may
want to remove those layers. Reducing the number of layers makes working
with the remaining layers more manageable.

To purge all unreferenced layers from a drawing

1 Click Tools menu ➤ CAD Standards ➤ Layer Translator.

2 In the Layer Translator, right-click in the Translate From list. Click Purge
Layers. All unreferenced layers are deleted from the current drawing.

CAD Standards toolbar

150 | Chapter 12   Maintain Standards in Drawings



Part 3
Control the Drawing Views

Chapter 11 Change a View in Two Dimensions

Chapter 12 Specify a 3D View

Chapter 13 Display Multiple Views in Model Space
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Change a View in Two
Dimensions

 

You can magnify the details in your drawing for a closer view

or shift the view to a different part of the drawing. If you save

views by name, you can restore them later.

As you edit your drawing, you can control the drawing display

and move quickly to different areas of your drawing while

you track the overall effect of your changes. You can zoom

to change magnification or pan to reposition the view in the

drawing area, and you can save a view and then restore it

when you need to plot or refer to specific details.

11
In this chapter

■ Pan a View

■ Magnify a View (Zoom)

■ Pan and Zoom with the Aerial
View Window

■ Save and Restore Views



Pan a View
You can shift the location of your view by using PAN or by using the window
scroll bars.

With the Realtime option of , you pan dynamically by moving your pointing
device. Like panning with a camera, PAN does not change the location or
magnification of objects on your drawing; it changes only the view.

By right-clicking, you can display a shortcut menu with additional viewing
options.

See also:

“Pointing Device Buttons” on page 94

To pan by dragging

1 Click View menu ➤ Pan ➤ Realtime.

2 When the hand cursor appears, drag the view by holding down the
button as you move the pointing device.

If you are using a wheel mouse, hold down the wheel button and move
the mouse.

Standard toolbar

To pan by specifying points

1 Click View menu ➤ Pan ➤ Point.

2 Specify a base point. This is the point you want to change.

3 Specify a second (pan to) point. This is the new location for the point
you selected first.

Magnify a View (Zoom)
When you are working with the details in your drawing, you can zoom in for
a closer view.

You can change the magnification of a view by zooming in and out, which
is similar to zooming in and out with a camera.  does not change the absolute
size of objects in the drawing; it changes only the magnification of the view.
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When you work with minute parts in your drawing, you may need to zoom
out frequently to see an overview of your work. Use ZOOM Previous to return
quickly to the prior view.

The options described here are the options most commonly used. For a
description of all ZOOM options, see the Command Reference.

zoomed out zoomed in

Zoom to Magnify a Specified Rectangular Area

You can quickly zoom on a rectangular area of your drawing by specifying
two diagonal corners of the area you are interested in.

original view new view

1

2
zoom window

The lower-left corner of the area you specify becomes the lower-left corner of
the new display. The shape of the zoom area you specify does not correspond
exactly to the new view, which must fit the shape of the viewport.

Zoom in Real Time

With the Realtime option, you zoom dynamically by moving your pointing
device up or down. By right-clicking, you can display a shortcut menu with
additional viewing options.

Zoom to Magnify One or More Objects

ZOOM Objects displays a view with the largest possible magnification that
includes all of the objects you selected.
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Zoom to View All Objects in the Drawing

ZOOM Extents displays a view with the largest possible magnification that
includes all of the objects in the drawing. This view includes objects on layers
that are turned off but does not include objects on frozen layers.

ZOOM All displays either the user-defined grid limits or the drawing extents,
whichever view is larger.

zoomed to show entire drawing
(all)

current view zoomed to extents

See also:

“Scale Views in Layout Viewports” on page 216
“Toolbars” on page 42

To zoom by dragging

1 Click View menu ➤ Zoom ➤ Realtime.

2 Hold down the button on your pointing device and drag vertically to
zoom in and out.

3 Press  ENTER, press  ESC , or right-click to exit.

Standard toolbar
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To zoom in to an area by specifying its boundaries

1 Click View menu ➤ Zoom ➤ Window.

2 Specify one corner of the rectangular area you want to view.

3 Specify the opposite corner.

You automatically choose the Window option when you specify a point
immediately after entering the ZOOM command.

Standard toolbar

To display the drawing extents by zooming

■ Click View menu ➤ Zoom ➤ Extents.

All objects in the drawing are displayed to be as large as possible and still fit
in the current viewport or the drawing area.

Standard toolbar

To display the area of the grid limits by zooming

■ Click View menu ➤ Zoom ➤ All.

The limits of the drawing grid fill the current viewport or the drawing area.
If there are any objects outside the grid limits, they are also included.

Standard toolbar

To restore the previous view

■ Click View menu ➤ Zoom ➤ Previous.

Zoom Previous restores only the view magnification and position, not the
previous content of an edited drawing.

Standard toolbar
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With the ZOOM command active, right-click in the drawing area. Click Zoom
Previous.

Pan and Zoom with the Aerial View Window
In a large drawing, you can pan and zoom quickly in a window that can display
the whole drawing.

You can use the Aerial View window to change the view in your current
viewport quickly. If you keep the Aerial View window open as you work, you
can zoom and pan without interrupting your current command. You can also
specify a new view without having to choose a menu option or enter a
command.

Use the View Box to Pan and Zoom

Within the Aerial View window is a view box, a heavy rectangle that displays
the boundary of the view in your current viewport. You can change the view
in the drawing by changing the view box in the Aerial View window. To zoom
in to the drawing, make the view box smaller. To zoom out of the drawing,
make the view box larger. All pan and zoom operations are performed by
left-clicking. Right-click to end a pan or zoom operation.

current view box

current view in drawing areaAerial View window

new view in drawing areaAerial View window

new view box
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To pan the drawing, move the view box.

current view in drawing areaAerial View window

current view box

new view in drawing areaAerial View window

new view box

Change the View Displayed Inside the Aerial View Window

You can use the Aerial View toolbar buttons to change the magnification of
the image in the Aerial View window, or you can resize the image
incrementally. These changes do not affect the view in the drawing itself.

Use the Aerial View Window with Multiple Viewports

Only the view in the current viewport is used in the Aerial View window.

The Aerial View image is updated as you make changes to your drawing and
as you select different viewports. In complex drawings, you may want to turn
off this dynamic updating to improve drawing speed. If you turn off this
feature, the Aerial View image is updated only when you activate the Aerial
View window.

To zoom to a new area using the Aerial View window

1 Click View menu ➤ Aerial View.

2 In the Aerial View window, click inside the view box until you see the
arrow.

3 Drag to the right to zoom out. Drag to the left to zoom in.
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4 Right-click to end the zoom operation.

To pan using the Aerial View window

1 Click View menu ➤ Aerial View.

2 In the Aerial View window, click inside the view box until you see an
X.

3 Drag to change the view.

4 Right-click to end the pan operation.

To display the entire drawing in the Aerial View window

1 Click View menu ➤ Aerial View.

2 In the Aerial View window, click View menu ➤ Global.

To increase or decrease magnification of the Aerial View image

1 Click View menu ➤ Aerial View.

2 On the Aerial View toolbar, click Zoom Out or Zoom In.

NOTE When the entire drawing is displayed in the Aerial View window, the Zoom
Out menu option and button are unavailable. When the current view nearly fills
the Aerial View window, the Zoom In menu option and button are unavailable.

To turn dynamic updating on and off

■ In the Aerial View window, click Options menu ➤ Dynamic Update.

A check mark indicates that the Aerial View window shows changes as they
occur.

To turn viewport updating on and off

■ In the Aerial View window, click Options menu ➤ Auto Viewport.

A check mark indicates that Aerial View displays the current viewport as
you switch viewports.
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Save and Restore Views
When you save specific views by name, you can restore them for layout and
plotting or when you need to refer to specific details.

A specific magnification, position, and orientation is known as a view. In each
drawing session, you can restore the last view displayed in each viewport and
up to 10 previous views.

Named views are saved with the drawing and can be used anytime. When you
are composing a layout, you can restore a named view to a viewport on the
layout.

Save a View

When you name and save a view, the following settings are saved:

■ Magnification, center point, and view direction

■ A view category that you assign to the view (optional)

■ The location of the view: the Model tab or a specific layout tab

■ Whether the view is associated with a viewport on a sheet

■ Layer visibility in the drawing at the time the view is saved

■ User coordinate system

■ 3D perspective and clipping

Restore a Named View

You restore a named view to the current viewport. You can use named views
to do the following:

■ Compose a layout.

■ Restore a view that you use frequently while you are working in model
space.

■ Control which model space view is displayed when the drawing is opened.

You can specify a layout view to be displayed when the drawing is opened
only if you saved the drawing from that specific layout tab.

To display the previous view

■ On the Standard toolbar, click Zoom Previous.
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To display the previous view during PAN Realtime and ZOOM Realtime

■ Right-click in the drawing area. Click Zoom Original.

To save and name a view

1 If you have more than one viewport in model space, click inside the
viewport that contains the view you want to save. If you are working in
a layout, select the viewport.

2 Click View menu ➤ Named Views.

3 In the View dialog box, Named Views tab, click New.

4 In the New View dialog box, enter a name for the view.

The name can be up to 255 characters long and contain letters, digits,
and the special characters dollar sign ($), hyphen (–), and underscore
(_).

5 (Optional) Enter a view category.

If the drawing is part of a sheet set, the view categories for the sheet set
are listed. You can add a category or select one from the list.

6 Select one of the following options to define the area of the view:

■ Current Display. Includes all of the drawing that is currently visible.

■ Define Window. Saves part of the current display. The dialog box
closes while you use the pointing device to specify opposite corners
of the view. Click the Define View Window button to redefine the
window.

7 Click OK to save the new view and exit each dialog box.

To restore a saved view

1 If you have more than one viewport in model space, click inside the
viewport that contains the view you want to replace. If you are working
in a layout, select the viewport.

2 Click View menu ➤ Named Views.

3 In the View dialog box, Named Views tab, select the view that you want
to restore.

4 Click Set Current.

The current view setting is indicated by a small pointer icon beside the
name in the list and is also displayed next to Current View.

162 | Chapter 14   Change a View in Two Dimensions



5 Click OK.

View toolbar

To delete a named view

1 Click View menu ➤ Named Views.

2 In the View dialog box, select the view you want to delete.

3 Right-click in the drawing area. Click Delete.

4 Click OK.

View toolbar

To view the list of saved viewport arrangements

■ Click View menu ➤ Viewports ➤ Named Viewports.

The list of saved viewports is displayed in the Viewports dialog box on the
Named Viewports tab.

Viewports toolbar
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Specify a 3D View

 
When working in 3D, you'll often want to display several

different views so that you can easily verify the 3D effects of

your editing.

One of these viewpoints is often an isometric view to reduce

the number of visually overlapping objects. From a selected

viewpoint, you can create new objects, edit existing objects,

or generate a hidden-line or shaded view.

12
In this chapter

■ Overview of Specifying a 3D
View

■ View a Parallel Projection in
3D

■ Display a Perspective View

■ Specify 3D Views Interactively
(3D Orbit)



Overview of Specifying a 3D View
You can display parallel and perspective views with several commands to
facilitate constructing and visualizing 3D models.

When working in 3D, you'll often want to display several different views so
that you can easily verify the 3D effects of your editing. One of these
viewpoints is often an isometric view to reduce the number of visually
overlapping objects. From a selected viewpoint, you can create new objects,
edit existing objects, or generate a hidden-line or shaded view.

View a Parallel Projection in 3D
You can view the parallel projection of a 3D model from any point in model
space.

Overview of Viewing Parallel Projections in 3D

To determine the point or angle in model space, you can

■ Choose a preset 3D view from a toolbar.

■ Enter a coordinate or angles that represent your viewing location in 3D.

■ Change to a view of the XY plane of the current UCS, a saved UCS, or the
WCS.

■ Change the 3D view dynamically with your pointing device.

■ Set front and back clipping planes to limit the objects being displayed.

Viewing in 3D is available only in model space. If you are working in paper
space, you cannot use 3D viewing commands such as , , or  to define paper
space views. The view in paper space is always a plan view.

Choose Preset 3D Views

You can select predefined standard orthographic and isometric views by name
or description.

A quick way to set a view is to choose one of the predefined 3D views. You
can select predefined standard orthographic and isometric views by name or
description. These views represent commonly used options: Top, Bottom,
Front, Left, Right, and Back. In addition, you can set views from isometric
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options: SW (southwest) Isometric, SE (southeast) Isometric, NE (northeast)
Isometric, and NW (northwest) Isometric.

To understand how the isometric views work, imagine you are looking down
at the top of a box. If you move toward the lower-left corner of the box, you
are viewing the box from the SW Isometric View. If you move toward the
upper-right corner of the box, you are viewing it from NE Isometric View.

NW NE

SW SE

SW iso

top
top

To use a preset 3D view

■ Click View menu ➤ 3D Views. Select a preset view (Top, Bottom, Left, and
so on).

View toolbar

Define a 3D View with Coordinate Values or Angles

You can define a viewing direction by entering the coordinate values of a
point or the measures of two angles of rotation.

This point represents your position in 3D space as you view the model while
looking toward the origin (0,0,0). Viewpoint coordinate values are relative to
the world coordinate system unless you change the  system variable. The
conventions for defining standard views differ between architectural (AEC)
and mechanical design. In AEC design, the perpendicular view of the XY plane
is the top or plan view; in mechanical design, the perpendicular view of the
XY plane is the front view.

You can rotate a view using . The following illustration shows a view defined
by two angles relative to the X axis and the XY plane of the WCS.
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To set a view with a viewpoint coordinate

1 Click View menu ➤ 3D Views ➤ Viewpoint.

2 Click inside the compass to specify the viewpoint. The selected viewpoint
is used to view the drawing in the direction of 0,0,0.

To set a view with two angles of rotation

1 At the Command prompt, enter vpoint.

2 Enter r (Rotate) to specify a new direction using two angles.

3 Enter an angle in the XY plane measured from the positive X axis.

4 Enter an angle from the XY plane that represents your position while
viewing the model in the direction of 0,0,0.

To set standard views with VPOINT (AEC convention)

1 On the command line, enter vpoint.

2 Enter a coordinate according to the viewpoint you want:

■ Enter 0,0,1 for a top (plan) view.

■ Enter 0,-1,0 for a front view.

■ Enter 1,0,0 for a right side view.

■ Enter 1,-1,1 for an isometric view.
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To set standard views with VPOINT (mechanical design convention)

1 On the command line, enter vpoint.

2 Enter a coordinate according to the viewpoint you want:

■ Enter 0,1,0 for a top view.

■ Enter 0,0,1 for a front view.

■ Enter 1,0,0 for a right side view.

■ Enter 1,1,1 for an isometric view. This view is identical to one with
a right-out of 45 degrees and a top-out of 35.267 degrees.

Change to a View of the XY Plane

You can change the current viewpoint to a plan view of the current UCS, a
previously saved UCS, or the WCS.

A plan view is a view aimed toward the origin (0,0,0) from a point on the
positive Z axis. This results in a view of the XY plane.

You can restore the view and coordinate system that is the default for most
drawings by setting the UCS orientation to World and then setting the 3D
view to Plan View.

To change the current view to the XY plane

1 Click View menu ➤ 3D Views. Click Plan View.

2 Select one of the following options:

■ Current (for the current UCS)

■ World (for the WCS)

■ Named (for a saved UCS)

NOTE PLAN changes the viewing direction and turns off perspective and
clipping; it does not change the current UCS. Any coordinates entered or
displayed subsequent to the PLAN command remain relative to the current
UCS.
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Change a 3D View Dynamically

You can change a view quickly without interrupting your current operation
using a feature that combines panning and zooming.

With dynamic viewing, you can display the effects of changing your viewpoint
as you make the changes. Using this method, you can also simplify your view
temporarily by choosing only the objects that you need to determine the view.
Alternatively, if you press ENTER without selecting any objects, 3D Dynamic
View displays a model of a small house instead of your actual drawing. You
can use this house to define the viewing angle and distance. When your
adjustments are complete and you exit the command, the changes are applied
to the entire 3D model in the current view.

Set Clipping Planes

You can create cutaway, or section, views of your drawing by positioning front
and back clipping planes that control the visibility of objects based on their
distance from a theoretical camera. You can move the clipping planes
perpendicular to the line of sight between the camera and target (where the
camera is pointing). Clipping removes the display of objects from the front
and back of clipping planes. The following illustration shows how clipping
planes work:

position of clipping planes

camera

front clip
back clip

view resulting from camera position

To create a parallel projection dynamically

1 On the command line, enter dview.

2 Do one of the following:

■ Select the objects to display and press ENTER.

■ Press ENTER without selecting objects to see a representation of a
house that shows the current viewing angle.

3 Enter ca (Camera).
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By default, a camera point is set at the center of the drawing.

4 Adjust the view as if you're aiming a camera.

You can set your view dynamically by moving the crosshairs and clicking.

5 To switch between the angle-input methods, enter t (Toggle Angle).

You can also adjust the view with one of two angle-input methods.

■ For the Enter Angle from the XY Plane option, enter the angle of the
camera up or down relative to the XY plane of the current UCS. The
default setting, 90 degrees, points the camera straight down from
above.

After you enter the angle, the camera is locked at that height, and
you can rotate the camera about the target with the rotation angle
measured relative to the X axis of the current UCS.

■ For the Enter Angle in the XY Plane from the X Axis option, rotate
the camera about the target with the rotation angle measured relative
to the X axis of the current UCS.

6 When you finish specifying the parallel projection, press ENTER.

To set clipping planes

1 On the command line, enter dview.

2 Select the objects on which to base the view.

3 On the command line, enter cL (Clip).

4 Enter f to set a front clipping plane or b to set a back clipping plane, or
press ENTER.

5 Position the clipping plane by dragging the slider or entering a distance
from the target.

6 Press ENTER to exit the command.

To restore the default view and UCS

1 Click View menu ➤ 3D Views.

2 Click Plan View.

3 Click World UCS.
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Display a Perspective View
You can define perspective views of a model to create realistic effects.

The difference between defining perspective views and defining parallel
projections is that perspective views require a distance between a theoretical
camera and target point. Small distances produce severe perspective effects;
large distances produce mild effects.

The following illustration shows the same wireframe model in a parallel
projection and in a perspective view. Both are based on the same viewing
direction.

parallel projection perspective projection

Many operations are not available in perspective view, including panning and
zooming and operations that require using object snap or input from the
pointing device.

A perspective view remains in effect until the perspective effect is turned off
or until a new view is defined in its place.

To define a perspective view of a 3D model

1 On the command line, enter dview.

2 Select the objects to display.

3 Enter ca (Camera).

By default, a camera point is set at the center of the drawing.

4 Adjust the view as if you're aiming a camera.

A representation of a house shows the current viewing angle. You can
set your view dynamically by moving the crosshairs and clicking.

5 To switch between angle-input methods, enter t (Toggle Angle).
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You also can adjust the view with one of two angle-input methods.

■ For the Enter Angle from the XY Plane option, enter the angle of the
camera up or down relative to the XY plane of the current UCS. The
default setting, 90 degrees, points the camera straight down from
above.

After you enter the angle, the camera is locked at that height, and
you can rotate the camera about the target with the rotation angle
measured relative to the X axis of the current UCS.

■ For the Enter Angle in the XY Plane from the X Axis option, rotate
the camera about the target with the rotation angle measured relative
to the X axis of the current UCS.

6 To turn on the perspective view, enter d (Distance).

7 Specify a distance, or press ENTER to set the perspective view.

You can use the slider bar to set the distance between the selected objects
and the camera, or you can enter a real number. If the target and camera
points are very close (or if the Zoom option is set high), you might see
only a small part of your drawing.

To turn off a perspective view

1 On the command line, enter dview.

2 Select the objects to display.

3 Enter o (Off).

Perspective is turned off and the view is restored to a parallel projection.

Specify 3D Views Interactively (3D Orbit)
Use the  command to activate an interactive view of your 3D model.

Overview of 3D Orbit

The  command activates an interactive 3D Orbit view in the current viewport.
You use the pointing device to manipulate a view of the entire model or any
object in the model from different points around it.

NOTE Viewing the entire drawing may degrade the video display.

The 3D Orbit view displays an arcball, which is a circle divided into four
quadrants by smaller circles. When 3DORBIT is active, the target of the view
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stays stationary and the camera location, or point of view, moves around the
target. The center of the arcball, not the center of the objects you’re viewing,
is the target point.

arcball

You can also shade the objects in your drawing while the 3DORBIT command
is active.

Set 3D Graphics Display Options (3D Orbit)

Graphics configuration settings affect the way that 3D objects are displayed;
for example, the shading of 3D objects and the way graphics are displayed
when the  command is active. You set these options using the 3D Graphics
System Configuration dialog box. These settings do not affect how objects are
rendered.

This program uses the Heidi® 3D Graphics System developed by Autodesk as
the default graphics system. If you want to use a different graphics system,
install it according to your display card’s vendor documentation.

Set Lights and Materials (3D Orbit)

You can adjust how lights, materials, textures, and transparency are displayed
in 3D views by changing the settings in the “3D Graphics System Configuration
Dialog Box”. These settings affect objects in the 3D Orbit view and objects
shaded using . You have several options:

■ Enable Lights . Controls the illumination, as defined by .

■ Enable Materials . Controls the materials attached using .

174 | Chapter 15   Specify a 3D View



■ Enable Textures . Controls textured materials attached using RMAT and
.

■ Transparency . Controls image quality at the expense of drawing speed.

The display both in 3D Orbit and with objects that are shaded using
SHADEMODE is subject to the following limitations.

For lights:

■ Shadows are not shown.

For materials:

■ 2D textures (bitmaps and bitmap blending) are displayed for the
color/pattern material component only.

■ 3D textures (also called solid, template, or procedural materials) are not
shown.

■ Bump maps are not shown.

■ Opacity maps are not shown.

■ Refraction is not shown.

■ Reflection is not shown.

Other rendering features, such as background and fog, are not supported in
3D views.

See also:

“Use Lights in Rendering”

Locate the Camera Position (3D Orbit)

You use the  command to change the point from which you view the objects
in a 3D view and the point that you are viewing. The point from which you
are viewing objects is the camera location, and the point you are viewing is
the target location.

When the  command is active, the default target location is the center of the
3D view, which is not always the center of the objects you are viewing. Use
CAMERA before starting 3DORBIT to change the camera and target locations
for the 3D Orbit view.
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camera location and target point

camera at B, target at A

camera at A, target at B

To change the camera and target locations

1 On the command line, enter camera.

The current camera and target positions are displayed.

2 To set the camera location, use the pointing device or enter X,Y,Z
coordinate values.

3 To set the target location, use the pointing device or enter X,Y,Z
coordinate values.

To adjust the camera distance in the 3D Orbit view

1 Click View menu, ➤ 3D Orbit.

2 Right-click in the drawing area. Click More ➤ Adjust Distance.

The cursor changes to a line with one arrow pointing up and one
pointing down.

3 Click and drag toward the top of the screen to move the camera closer
to the objects. Click and drag toward the bottom of the screen to move
the camera away from the objects.

Adjust Distance simulates the effect of moving the camera closer to the
objects or farther away.
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plan view camera at B

camera at A

Use 3D Orbit Commands

You can choose from several commands that control the 3D Orbit display,
projection, and visualization tools. You can access Pan and Zoom options
from the 3D Orbit shortcut menu or on the 3D Orbit toolbar. You can also
choose to use a perspective or a parallel projection of the view while  is active.

Shade Objects in the 3D Orbit View

Objects in the 3D Orbit view can be shaded to give them a more realistic 3D
appearance. You can change the way objects are shaded using the different
shading modes, which are also accessible from the 3D Orbit shortcut menu.

Use Visual Aids in the 3D Orbit View

You can choose to display one or more of the visual aids (compass, grid, and
UCS icon) in the 3D Orbit view. A check mark is displayed next to the active
visual aid option(s). A visual aid that is active when you exit 3DORBIT remains
active in the view outside the 3D Orbit view unless  is set to 2D Wireframe.

■ Compass. Draws a sphere within the arcball composed of three lines
representing the X, Y, and Z axes.
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■ Grid. Draws an array of lines on a plane parallel to the current X and Y
axes, perpendicular to the Z axis. You specify the height of the grid display
in the  system variable.

Before starting 3DORBIT, you can use the  command to set system variables
that control the grid display. The number of major grid lines corresponds
to the value you set using the Grid Spacing option of GRID, which is stored
in the  system variable. Ten horizontal lines and ten vertical lines are drawn
between major lines.

When you zoom in and out of the 3D Orbit view, the number of grid lines
changes to give you a clear view of the lines. Fewer lines are drawn as you
zoom out. As you zoom in closer, more grid lines are drawn until the
number of lines corresponds again to the number set in GRIDUNIT.

■ UCS Icon. Turns the display of the UCS icon on and off. If the UCS icon
is displayed when you start 3DORBIT, a shaded 3D UCS icon is displayed
in the 3D Orbit view. On the 3D UCS icon, the X axis is red, the Y axis is
green, and the Z axis is blue or cyan. The  command also controls the
display of the 3D UCS icon.

Use Continuous Orbit

You can click and drag in the 3D Orbit view to start a continuous motion.
When you release the pick button on your pointing device, the orbit continues
in the direction that you were dragging.

While Continuous Orbit is active, you can change the view by right-clicking
in the drawing area and choosing Projection, Shading Modes, Visual Aids,
Reset View, or Preset Views from the shortcut menu. You can also turn the
front and back clipping planes on and off while Continuous Orbit is active;
however, you cannot adjust the clipping planes. If you choose Pan, Zoom,
Orbit, or Adjust Clipping Planes from the shortcut menu, Continuous Orbit
ends.
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Reset the View or Use Preset Views

While 3DORBIT is active, you can reset the view to the view that was current
when you first entered the 3D Orbit view.

You can set the view to one of the six standard orthogonal views, or one of
four isometric views. The isometric views are based on a camera location of
0,0,0.

Access 3D Orbit Commands from the Command Line

You cannot enter commands on the command line while 3DORBIT is active.
If 3DORBIT is not active, you can enter a command that starts 3DORBIT and
activates one of the options at the same time. For example,  starts 3D Orbit
view and activates the Zoom option. See , 3DORBIT, , , , and 3DZOOM
in the Command Reference.

To start 3D Orbit view

1 Select the object or objects you want to view with 3DORBIT.

You can view your entire model by not selecting any objects. However,
viewing only selected objects enhances performance.

NOTE OLE objects and raster objects do not appear in the 3D Orbit view.

2 Click View menu ➤ 3D Orbit.

An arcball is displayed within the active viewport. If the UCS icon is on,
it appears shaded. If the GRID is on, a 3D line grid replaces the 2D dot
grid.

3 Click and drag the cursor to rotate the view. When you move your cursor
over different parts of the arcball, the cursor icon changes. The
appearance of your cursor when you click to start dragging indicates the
rotation of the view as follows:

■ A small sphere encircled by two lines is the cursor icon displayed
when you move the cursor inside the arcball. By clicking and dragging
when the cursor is a sphere you can manipulate the view freely. It
works as if your cursor were grabbing a sphere surrounding the objects
and dragging the sphere around the target point. You can drag
horizontally, vertically, and diagonally.
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■ A circular arrow around a small sphere is the cursor icon displayed
when you move the cursor outside the arcball. Clicking outside the
arcball and dragging the cursor around the arcball moves the view
around an axis that extends through the center of the arcball,
perpendicular to the screen. This is called a “roll.”

If you drag the cursor into the arcball, it changes to a small sphere
encircled by two lines and the view moves freely, as described above.
If you move the cursor back outside the arcball, you revert to a roll.

■ A horizontal ellipse around a small sphere is the cursor icon displayed
when you move the cursor over one of the smaller circles on the left
or right side of the arcball. Clicking and dragging from either of these
points rotates the view around the vertical or Y axis that extends
through the center of the arcball. The Y axis is represented on the
cursor by a vertical line.

■ A vertical ellipse around a small sphere is the cursor displayed when
you move the cursor over one of the smaller circles on the top or
bottom of the arcball. Clicking and dragging from either of these
points rotates the view around the horizontal or X axis that extends
through the center of the arcball. The X axis is represented on the
cursor by a horizontal line.

NOTE You cannot edit objects while 3DORBIT is active. To exit 3DORBIT,
press  ENTER  or  ESC , or click Exit on the shortcut menu.

To pan in the 3D Orbit view

1 Click View menu ➤3D Orbit.

2 Right-click in the drawing area. Click Pan.

The cursor changes to a hand cursor.
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3 Click and drag the cursor to move the view horizontally, vertically, or
diagonally.

The view moves in the direction that you drag the cursor.

You can use the projection options, shading modes, and visual aids at
the same time that you pan and zoom by choosing an option from the
3D Orbit shortcut menu.

4 To stop panning, right-click in the drawing area. Click Orbit or Zoom.

To zoom in the 3D Orbit view

1 Click View menu ➤ 3D Orbit.

2 Right-click in the drawing area. Click Zoom.

The cursor changes to a magnifying glass with plus (+) and minus (–)
signs. Zoom simulates the effect of a camera’s zoom lens by making
objects appear closer or farther away. Zooming in magnifies the image.
If you are using perspective projection, Zoom exaggerates the perspective
with which you view the objects. It may slightly distort the display of
some objects.

3 Click and drag toward the top of the screen to zoom in. Click and drag
toward the bottom of the screen to zoom out.

4 To change the projection or shading mode or use a visual aid, right-click
and click an option on the shortcut menu.

5 To stop zooming, right-click in the drawing area. Click Orbit or Pan.

To use a zoom window in the 3D Orbit view

1 Click View menu ➤ 3D Orbit.

2 Right-click in the drawing area. Click More ➤ Zoom Window.

The cursor changes to a window icon, and you can select a specific area
that you want to zoom.

3 Click and drag the pointing device to draw a square around the area you
want to select.

When you release the pick button, the drawing is zoomed in, focused
on the area you selected.

To zoom to extents in the 3D Orbit view

1 Click View menu ➤ 3D Orbit,
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2 Right-click in the drawing area. Click More ➤ Zoom Extents.

The view is centered and sized to display all objects in the 3D view.

To choose a parallel or perspective projection in the 3D Orbit view

1 Click View menu ➤ 3D Orbit.

2 Right-click in the drawing area. Click Projection.

3 Select one of the following options:

■ Parallel . Changes the view so that two parallel lines never converge
at a single point. The shapes in the drawing always remain the same
and do not appear distorted when they are closer. This is the default.

■ Perspective . Changes the view so that all parallel lines converge at
one point. Objects appear to recede into the distance while parts of
the objects appear larger and closer to you. The shapes are somewhat
distorted when the object is very close. This view correlates most
closely to what your eye sees.

A check mark is displayed next to the current projection option.

NOTE When you exit 3DORBIT, the projection that you choose remains
current. You cannot edit, pick points, zoom, or pan when viewing objects
in perspective projection.

To change the shading mode in 3D Orbit view

1 Click View menu ➤ 3D Orbit.

2 Right-click in the drawing area. Click Shading Modes.

3 Select one of the following options:

■ Wireframe . Displays the objects in the 3D view using lines and
curves to represent the boundaries.

■ Hidden. Displays the objects in the 3D view using wireframe
representation with the lines representing the back faces hidden.
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■ Flat Shaded . Shades the objects in the 3D view between the polygon
faces. This gives the objects a faceted, less smooth appearance.

■ Gouraud Shaded . Shades the objects in the 3D view and smooths
the edges between polygon faces. This gives the objects a smoother,
more realistic appearance.

■ Flat Shaded, Edges On . Combines the Flat Shaded and Wireframe
options. The objects are flat shaded with the wireframe showing
through.
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■ Gouraud Shaded, Edges On . Combines the Gouraud Shaded and
Wireframe options. The objects are Gouraud shaded with the
wireframe showing through.

NOTE When you shade objects in the 3D Orbit view, the shading is still
applied to the objects after you exit 3DORBIT. Use SHADEMODE to change
the shading when 3DORBIT is not active.

To display a visual aid

1 Click View menu ➤ 3D Orbit.

2 Right-click in the drawing area. Click Visual Aids.

3 Select one or more of the following options: Compass, Grid, or UCS Icon.

To start a continuous orbit

1 Click View menu ➤ 3D Orbit.

2 Right-click in the drawing area. Click More ➤ Continuous Orbit.

The cursor changes to a small sphere encircled by two lines.

3 Click and drag in the direction that you want the continuous orbit to
move.

4 Release the pick button.

The orbit continues moving in the direction that you indicated with
your pointing device.

5 To change the direction of the continuous orbit, click and drag in a new
direction and release the pick button.

The direction of the continuous orbit changes.
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To reset the view

1 Click View menu ➤ 3D Orbit.

2 Right-click in the drawing area. Click Reset View.

The view is reset to the view that was current when you started 3DORBIT.

To use a preset 3D Orbit view

1 Click View menu ➤ 3D Orbit.

2 Right-click in the drawing area. Click Preset Views.

3 Select one of the views from the list.

Adjust Clipping Planes (3D Orbit)

You can set the front and back clipping planes for the objects in 3D Orbit
view. Anything outside the clipping planes is not visible.

You can set clipping planes for the objects in 3D Orbit view. A clipping plane
is an invisible plane. Objects or parts of objects that move beyond a clipping
plane cannot be seen in the view. In the Adjust Clipping Planes window, there
are two clipping planes, front and back. The front and back clipping planes
are represented as lines at the top and bottom of the Adjust Clipping Planes
window.

You use the toolbar buttons or the options on the Adjust Clipping Planes
shortcut menu to choose the clipping plane that you want to adjust.

If clipping planes are on when you exit the 3D Orbit view, they remain on in
the 2D and 3D view.

You can adjust only one clipping plane at a time except when using the Create
Slice option. On the toolbar, the depressed button indicates the plane that
you are adjusting. When you’ve finished adjusting one plane, you can adjust
the other. If the Create Slice button is depressed, you are adjusting both planes
at the same time.

Turn Clipping Planes On and Off

Closing the Adjust Clipping Planes window does not turn the clipping planes
off. You can rotate the 3D Orbit view and still see the clipping planes. As you
rotate the view, different portions of the objects are clipped as they pass
through the clipping planes. You can use the 3D Orbit shortcut menu to turn
the clipping planes off and on.
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NOTE If the clipping planes are on when you exit 3D Orbit view, they remain on
in the 2D and 3D view.

To adjust clipping planes in the 3D Orbit view

1 Click View menu ➤ 3D Orbit.

2 Right-click in the drawing area. Click More ➤ Adjust Clipping Planes.

The Adjust Clipping Planes window displays the objects in the view,
rotated at a 90-degree angle. You set the clipping planes in the Adjust
Clipping Planes window, and the results are displayed in the main 3D
Orbit view.

3 Right-click in the Adjust Clipping Planes window. Click one of the
following:

■ Front Clipping On. Toggles the front clipping plane on or off. When
the front clipping plane is on, you can see the results of moving the
line that adjusts the front clipping plane, as described in step 4.

■ Back Clipping On. Toggles the back clipping plane on or off. When
the back clipping plane is on, you can see the results of moving the
line that adjusts the back clipping plane, as described in step 4.

4 Right-click in the Adjust Clipping Planes window. Click one of the
following options to adjust the clipping planes:

■ Adjust Front Clipping. Adjusts only the front clipping plane. The
line near the bottom of the window adjusts the front clipping plane.
If you chose Front Clipping On in step 3, you can see the clipping in
the main 3D Orbit view as you move the line up or down.

■ Adjust Back Clipping. Adjusts only the back clipping plane. The
line near the top of the window adjusts the back clipping plane. If
you chose Back Clipping On in step 3, you can see the clipping in the
main 3D Orbit view as you move the line up or down.

■ Create Slice. Causes the back and front clipping planes to move
together at a set distance apart. Adjust the front and back clipping
planes as described above to set the distance, and then choose Create
Slice. This displays a “slice” of the objects in the 3D Orbit view. To
see the slice in the main 3D Orbit view, choose both Front Clipping
On and Back Clipping On in step 3.

5 Click and drag the Clipping Plane line to clip the area that you do not
want to see in the view.

You can adjust only one clipping plane at a time except when using the
Create Slice option. On the toolbar, the depressed button indicates the
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plane that you are adjusting. When you've finished adjusting one plane,
you can adjust the other. If the Create Slice button is depressed, you are
adjusting both planes at the same time.

To turn clipping planes on and off

1 Click View menu ➤ 3D Orbit.

2 Right-click in the drawing area. Click More.

A check mark in front of Front Clipping On or Back Clipping On indicates
that the clipping plane is on.

3 Select the option that has a check mark next to it to turn the clipping
plane off.

Specify 3D Views Interactively (3D Orbit) | 187



188



Display Multiple Views in
Model Space

 

To see several views at the same time, you can split the

drawing area of the Model tab into separate viewing areas

called model space viewports. You can save arrangements of

model space viewports for reuse at any time.

You can save arrangements of model space viewports for reuse

at any time.

13
In this chapter

■ Set Model Space Viewports

■ Select and Use the Current
Viewport

■ Save and Restore Model Tab
Viewport Arrangements



Set Model Space Viewports
On the Model tab, you can split the drawing area into one or more adjacent
rectangular views known as model space viewports.

Viewports are areas that display different views of your model. As you work
on the Model tab, you can split the drawing area into one or more adjacent
rectangular views known as model space viewports. In large or complex drawings,
displaying different views reduces the time needed to zoom or pan in a single
view. Also, errors you might miss in one view may be apparent in the others.

Viewports created on the Model tab completely fill the drawing area and do
not overlap. As you make changes in one viewport, the others are updated
simultaneously. Three model space viewports are shown in the illustration.

You can also create viewports on a layout tab. You use those viewports, called
layout viewports, to arrange the views of your drawing on a sheet. You can
move and resize layout viewports. By using layout viewports, you have more
control over the display; for example, you can freeze certain layers in one
layout viewport without affecting the others. For more information about
layouts and layout viewports, see “Create Multiple-View Drawing Layouts
(Paper Space)” on page 203.
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Use Model Space Viewports

With model space viewports, you can do the following:

■ Pan; zoom; set Snap, Grid, and UCS icon modes; and restore named views.

■ Save user coordinate system orientations with individual viewports.

■ Draw from one viewport to another when executing a command.

■ Name a viewport arrangement so that you can reuse it on the Model tab
or insert it on a layout tab.

Setting up different coordinate systems in individual viewports is useful if you
typically work on 3D models. See “Assign User Coordinate System Orientations
to Viewports” on page 331.

Split and Join Model Space Viewports

The illustrations below show several default model space viewport
configurations.

horizontalrightleft

vertical above below

You can easily modify model space viewports by splitting and joining them.
If you want to join two viewports, they must share a common edge of the
same length.

To subdivide a viewport on the Model tab

1 If you have more than one viewport, click inside the viewport you want
to subdivide.
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2 Click View menu ➤ Viewports and then either 2 Viewports, 3 Viewports,
or 4 Viewports to indicate how many model space viewports should be
created.

3 At the Next prompt, specify the arrangement of the new viewports.

To join two viewports on the Model tab

1 Click View menu ➤ Viewports ➤ Join.

2 Click within the model space viewport containing the view you want
to keep.

3 Click within an adjacent viewport to join it to the first viewport.

To restore a single viewport on the Model tab

■ Click View menu ➤ Viewports ➤ 1 Viewport.

To switch from a layout tab to the Model tab

■ Click the Model tab at the bottom of the drawing area.

Select and Use the Current Viewport
When you use multiple viewports, one of them is the current viewport, which
accepts cursor input and view commands.

When a viewport is current, the cursor is displayed as crosshairs rather than
an arrow, and the viewport boundary is highlighted. You can change the
current viewport at any time except when a View command is in progress.

To make a viewport the current viewport, you click inside it or press  CTRL +
R to cycle through the existing viewports.

To draw a line using two model space viewports, you start the line in the
current viewport, make another viewport current by clicking within it, and
then specify the endpoint of the line in the second viewport. In a large
drawing, you can use this method to draw a line from a detail in one corner
to a detail in a distant corner.
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start of line

current viewport
and end of line

To make a viewport current

■ Click anywhere within the viewport border.

To cycle through viewports without clicking

■ Press  CTRL + R  repeatedly.

Save and Restore Model Tab Viewport
Arrangements

Arrangements of model viewports can be saved and restored by name.

You don't have to set up viewports and views every time you need them. With
, viewport arrangements can be saved and later restored by name. Settings
that are saved with viewport arrangements include

■ The number and position of viewports

■ The views that the viewports contain

■ The grid and snap settings for each viewport

■ The UCS icon display setting for each viewport
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You can list, restore, and delete the available viewport arrangements. A
viewport arrangement saved on the Model tab can be inserted on a layout
tab.

To save and name a viewport arrangement

1 Click View menu ➤ Viewports ➤ New Viewports.

2 In the Viewports dialog box, New Viewports tab, enter a name for the
viewport configuration in the New Name box.

The name can be up to 255 characters long and contain letters, digits,
the special characters dollar sign ($), hyphen (–), and underscore (_).

3 Click OK.

NOTE You can save a viewport arrangement only on the Model tab.

To restore a saved viewport arrangement

1 Click View menu ➤ Viewports ➤ Named Viewports.

2 In the Viewports dialog box, Named Viewports tab, select the name of
the viewport configuration from the list.

3 Click OK.

To delete a saved viewport arrangement

1 Click View menu ➤ Viewports ➤ Named Viewports.

2 In the Viewports dialog box, Named Viewports tab, select the name of
the viewport configuration you want to delete.

3 Press  DELETE .

To view a list of saved viewport arrangements

■ Click View menu ➤ Viewports ➤ Named Viewports to display the Viewports
dialog box.

All saved viewport arrangements in the drawing are listed on the Named
Viewports tab under Named Viewports.

194 | Chapter 16   Display Multiple Views in Model Space



Part 4
Choose a Work Process Before You
Begin

Chapter 14 Create Single-View Drawings (Model Space)

Chapter 15 Create Multiple-View Drawing Layouts (Paper Space)

Chapter 16 Work with Sheets in a Sheet Set
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Create Single-View
Drawings (Model Space)

 

If you are going to create a two dimensional drawing that has

one view, you can create the drawing and its annotation

entirely in model space. This is the traditional method for

creating drawings with AutoCAD
®

.

With this method, you create the building, mechanical part,

or geographic area that you want to represent at full scale

(1:1), but you create the text, dimensions, and the title block

of the drawing at a scale to match the intended plot scale.

14
In this chapter

■ Quick Start for Model Space
Drafting

■ Draw, Scale, and Annotate in
Model Space



Quick Start for Model Space Drafting
The process of creating and plotting a drawing file in model space is very
different from the process used in manual drafting.

In AutoCAD, there are two distinct working environments that are represented
by the Model and layout tabs. These tabs are located near the bottom of the
drawing area.

If you are going to create a two-dimensional drawing that has one view, you
can create both the model and its annotation entirely in model space, not
using a layout tab. This is the traditional method for creating drawings with
AutoCAD. This method is simple but has several limitations, including

■ It is suitable for 2D drawings only

■ It does not support multiple views and view-dependent layer settings

■ Scaling the annotation and title block requires computation

With this method, you always draw geometric objects at full scale (1:1) and
text, dimensions, and other annotation at a scale that will appear at the correct
size when the drawing is plotted.

See also:

“Create Multiple-View Drawing Layouts (Paper Space)” on page 203
“Work with Sheets in a Sheet Set” on page 233

Draw, Scale, and Annotate in Model Space
If you draw and plot from model space, you must determine and apply a scale
factor to annotation objects before you plot.

You can draw and plot entirely from model space. This method is useful
primarily for two-dimensional drawings that have a single view. With this
method, you use the following process:

■ Determine the unit of measurement (drawing units) for the drawing.

■ Specify the display style for the drawing unit.

■ Calculate and set the scale for dimensions, annotations, and blocks.

■ Draw at full scale (1:1) in model space.

■ Create the annotation and insert the blocks in model space.

■ Plot the drawing at the predetermined scale.
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Determine the Unit of Measurement

Before you begin drawing in model space, you determine the unit of
measurement (drawing units) that you plan to use. You decide what each unit
on the screen represents, such as an inch, a millimeter, a kilometer, or some
other unit of measurement. For example, if you are drawing a motor part, you
might decide that one drawing unit equals a millimeter. If you are drawing a
map, you might decide that one unit equals a kilometer.

Specify the Display Style of Drawing Units

Once you have determined a drawing unit for the drawing, you need to specify
the style for displaying the drawing unit, which includes the unit type and
precision. For example, a value of 14.5 can be displayed as 14.500, 14-1/2, or
1’2-1/2”.

Specify the display style of drawing units with the  command. The default
drawing unit type is decimal.

Set the Scale for Annotations and Blocks

Before you draw, you should set the scale for dimensions, annotations, and
blocks in your drawings. Scaling these elements beforehand ensures that they
are at the correct size when you plot the final drawing.

You should enter the scale for the following objects:

■ Text. Set the text height as you create text or by setting a fixed text height
in the text style ().

■ Dimensions. Set the dimension scale in a dimension style () or with the
system variable.

■ Linetypes. Set the scale for noncontinuous linetypes with the  and  system
variables.

■ Hatch patterns. Set the scale for hatch patterns in the Hatch and Gradient
dialog box () or with the  system variable.

■ Blocks. Specify the insertion scale for blocks either as you insert them, or
set an insertion scale in the Insert dialog box () or in DesignCenter (). The
system variables used for inserting blocks are , , and . This also applies to
the border and title block of the drawing.

Determine the Scale Factor for Plotting

To plot your drawing from the Model tab, you calculate the exact scale factor
by converting the drawing scale to a ratio of 1:n. This ratio compares plotted
units to drawing units that represent the actual size of the objects you are
drawing.

Draw, Scale, and Annotate in Model Space | 199



For example, if you plan to plot at a scale of 1/4 inch = 1 foot, you would
calculate the scale factor 48 as follows:

1/4" = 12"

1 = 12 x 4

1 (plotted unit) = 48 (drawing units)

Using the same calculation, the scale factor for 1 centimeter = 1 meter is 100,
and the scale factor for 1 inch = 20 feet is 240.

Sample Scale Ratios

The sample architectural scale ratios in the table can be used to calculate text
sizes in model space.

Set drawing text
size to

To plot text
size at

Scale factorScale

30 cm3 mm1001 cm = 1 m

12"1/8"961/8" = 1'-0"

8"1/8"643/16" = 1'-0"

6"1/8"481/4" = 1'-0"

4"1/8"323/8" = 1'-0"

3"1/8"241/2" = 1'-0"

2"1/8"163/4" = 1'-0"

1.5"1/8"121" = 1'-0"

1.0"1/8"81 1/2" = 1'-0"

If you are working in metric units, you might have a sheet size of 210 x 297
mm (A4 size) and a scale factor of 20. You calculate grid limits as follows:

210 x 20 = 4200 mm

297 x 20 = 5900 mm

See also:

“Specify Units and Unit Formats” on page 107

To specify the display style for drawing units

1 Click Format menu ➤ Units.

2 In the Drawing Units dialog box, set the unit values for your drawing.
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3 As you change unit settings, you can see examples under Sample Output.

■ Under Length, select a unit type and level of precision. This determines
the display style for linear drawing units.

■ Under Drawing Units for DesignCenter Blocks, select the unit that
you want used to scale blocks, images, or other content inserted into
the drawing. If you do not want inserted content to be scaled, select
Unitless.

■ Under Angle, select an angle type and precision. This determines the
display style for angular drawing units. The default starting angle, 0
degrees, is toward 3 o'clock (or east).

■ To specify an angle direction, click Direction, and then select the base
angle in the Direction Control dialog box. The angle direction controls
the point from which angles are measured and the direction in which
they are measured. If you select Other, you can enter an angle, or click
Angle to specify an angle using your pointing device. The default
positive angle measurement is counterclockwise.

4 Click OK to exit each dialog box.
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Create Multiple-View
Drawing Layouts (Paper
Space)

 

You layout viewports to display views of your model. Each view

can have a different viewing angle, view scale, and layer

display.

15
In this chapter

■ Quick Start for Layouts

■ Understand the Layout
Process

■ Work with Model Space and
Paper Space

■ Create and Modify Layout
Viewports

■ Control Views in Layout
Viewports

■ Reuse Layouts and Layout
Settings



Quick Start for Layouts
There are two distinct working environments, or “spaces,” in which you can
create objects in a drawing.

Typically, a model composed of geometric objects is created in a
three-dimensional space called model space. A final layout of specific views
and annotations of this model is created in a two-dimensional space called
paper space. These spaces are accessible on two or more tabs near the bottom
of the drawing area: the Model tab and one or more layout tabs.

Working on the Model tab, you draw a model of your subject at 1:1 scale.
Working on a layout tab, you place one or more viewports, dimensions, notes,
and a title block to represent a drawing sheet.

On a layout tab, each layout viewport is like a picture frame containing a
“photograph” of the model. Each layout viewport contains a view that displays
the model at the scale and orientation that you specify. You can also specify
which layers are visible in each layout viewport.

After you finish arranging the layout, you turn off the layer that contains the
layout viewport objects. The views are still visible, and you can plot the layout
without displaying the viewport boundaries.

Understand the Layout Process
When you use a layout tab to prepare your drawing for plotting, you follow
a series of steps in a process.

You design the subject of your drawing on the Model tab (in model space)
and prepare it for plotting on a layout tab (in paper space).

There is one Model tab and one or more layout tabs at the bottom of the
drawing window.
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Process Summary

When you prepare a layout, you typically step through the following process:

■ Create a model of your subject on the Model tab.

■ Click a layout tab.

■ Specify layout page settings such as plotting device, paper size, plot area,
plot scale, and drawing orientation.

■ Insert a title block into the layout (unless you have started with a drawing
template that already has a title block).

■ Create a new layer to be used for layout viewports.

■ Create layout viewports and position them on the layout.

■ Set the orientation, scale, and layer visibility of the view in each layout
viewport.

■ Add dimensions and annotate in the layout as needed.

■ Turn off the layer containing the layout viewports.

■ Plot your layout.

The other topics in this chapter provide additional detail on how to create,
use, and modify layouts and layout viewports.

Work with Model Space and Paper Space
There are several benefits to switching between model space and paper space
to perform certain tasks. Use model space for creating and editing your model.
Use paper space for composing your drawing sheet and defining views.

Work on the Model Tab

In model space, you draw your model at 1:1 scale, and you decide whether
one unit represents one millimeter, one centimeter, one inch, one foot, or
whatever unit is most convenient or customary in your business.

On the Model tab, you can view and edit model space objects. The crosshairs
cursor is active over the entire drawing area.
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In model space, you can also define named views that you display in layout
viewports on a layout.

To activate the Model tab

Do one of the following to make the Model tab current:

■ Click the Model tab.

■ Right-click any layout tab or the Model tab. Click Activate Model Tab.

Work on a Layout Tab

Layout tabs access an area called paper space. In paper space, you place your
title block, create layout viewports to display views, dimension your drawing,
and add notes.

In paper space, one unit represents the paper distance on a plotted sheet. The
units will be in either millimeters or inches, depending on the plot setup for
your plotter.

On a layout tab, you can view and edit paper space objects, such as layout
viewports and title blocks. The crosshairs cursor is active over the entire layout
area.
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Create Additional Layout Tabs

By default, a new drawing starts with two layout tabs, named Layout1 and
Layout2. If you use a drawing template or open an existing drawing, the layout
tabs in your drawing may be named differently.

You can create a new layout tab using one of the following methods:

■ Add a new layout tab with no settings and then specify the settings in the
Page Setup Manager.

■ Use the Create Layout wizard to create the layout tab and specify settings.

■ Copy a layout tab and its settings from the current drawing file.

■ Import a layout tab from an existing drawing template (DWT) file or drawing
(DWG) file.

Right-click a layout tab to display a layout shortcut menu with options.

NOTE You can create multiple layouts in a drawing; each layout can contain
different plot settings and paper sizes. However, to avoid confusion when
transmitting and publishing drawings, it is usually recommended that you create
only one layout for each drawing.

Use the Layout Wizard to Specify Layout Settings

You can create a new layout using the Create Layout wizard. The wizard
prompts you for information about the layout settings, including

■ A name for the new layout

■ The printer associated with the layout

■ A paper size to use for the layout

■ The orientation of the drawing on the paper

■ A title block

■ Viewport setup information

■ A location for the viewport configuration in the layout

You can edit the information entered in the wizard later by selecting the layout
and clicking Page Setup on the File menu.
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To specify the page setup for the current layout

■ Right-click the current layout tab. Click Page Setup.

Layouts toolbar

To create a new layout

1 Click Insert menu ➤ Layout ➤ New Layout.

2 Enter the name of the new layout on the command line.

A new layout tab is created. To switch to the new layout, choose the
layout tab.

Layouts toolbar

To import a layout from a template

1 Click Insert menu ➤ Layout ➤ Layout from Template.

2 In the Select File dialog box, select a DWT or DWG file to import a layout
from.

3 Click Open.

4 In the Insert Layout(s) dialog box, select a layout to import.

A new layout tab is created. To switch to the new layout, click the layout
tab.

Layouts toolbar

To create a layout using a wizard

1 Click Insert menu ➤ Layout ➤ Layout Wizard.

2 On each page of the Create Layout wizard, select the appropriate settings
for the new layout.
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When finished, the new layout will be the current layout tab.

To duplicate a layout

1 Right-click the layout tab of the layout you want to duplicate. Click
Move or Copy.

2 In the Move or Copy dialog box, select a position for the new layout
tab.

3 Make sure that Create a Copy is selected.

4 Click OK.

NOTE The Model tab cannot be duplicated.

To rename a layout

1 Right-click the layout tab for the layout you want to rename. Click
Rename.

2 In the Rename Layout dialog box, enter the new name for the layout.

3 Click OK.

NOTE The Model tab cannot be renamed.

To delete a layout

1 Right-click the layout tab for the layout you want to delete. Click Delete.

2 In the warning box, click OK to delete the layout.

Any named views associated with the layout are deleted automatically
when the layout is deleted.

NOTE The Model tab cannot be deleted.

To rearrange layout tabs

1 Right-click the layout tab of the layout you want to reposition. Click
Move or Copy.

2 In the Move or Copy dialog box, select the layout tab that should be
placed immediately after the moved or copied layout tab. If you want
to move the layout tab to the end of the list of layout tabs, select Move
to End.
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3 Click OK.

NOTE The Model tab cannot be repositioned.

To make a layout current

Do one of the following to make a layout current:

■ Click the layout tab for the layout that you want to make current.

■ Press CTRL+Page Down to cycle through the layout tabs from left to right
or CTRL+Page Up to cycle through the layout tabs from right to left. Stop
when you get to the tab of the layout that you want to make current.

To activate the previous layout

1 Right-click any layout tab or the Model tab.

2 Click Activate Previous Layout.

To select all layouts

■ Right-click any layout tab. Click Select All Layouts.

To plot a layout

1 Do one of the following:

■ Right-click a layout tab. Click Plot.

■ Hold down SHIFT to select several layout tabs. Right-click a layout
tab. Click Publish Selected Layouts.

2 Select settings in the Plot or the Publish dialog box. Click OK or Publish.

Standard toolbar

Access Model Space from a Layout Viewport

You can access model space from a layout viewport to edit objects, to freeze
and thaw layers, and to adjust the view.
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After creating viewport objects, you can access model space from a layout
viewport to perform the following tasks:

■ Create and modify objects in model space inside the layout viewport.

■ Pan the view inside the layout viewport and change layer visibility.

The method you use to access model space depends on what you plan to do.

Create and Modify Objects in a Layout Viewport

If you plan to create or modify objects, use the button on the status bar to
maximize the layout viewport. The maximized layout viewport expands to
fill the drawing area. The center point and the layer visibility settings of the
viewport are retained, and the surrounding objects are displayed.

You can pan and zoom while you are working in model space, but when you
restore the viewport to return to paper space, the position and scale of the
objects in the layout viewport are restored.

NOTE If you use PLOT while a viewport is maximized, the layout tab is restored
before the Plot dialog box is displayed. If you save and close the drawing while a
viewport is maximized, the drawing opens with the layout tab restored.

If you choose to switch to the Model tab to make changes, the layer visibility
settings are the settings for the drawing as a whole, not the settings for that
particular layout viewport. Also, the view is not centered or magnified the
same way it is in the layout viewport.

Adjust the View in a Layout Viewport

If you plan to pan the view and change the visibility of layers, double-click
within a layout viewport to access model space. The viewport border becomes
thicker, and the crosshairs cursor is visible in the current viewport only. All
active viewports in the layout remain visible while you work. You can freeze
and thaw layers in the current viewport in the Layer Properties Manager, and
you can pan the view. To return to paper space, double-click an empty area
on the layout outside a viewport. The changes you made are displayed in the
viewport.

If you set the scale in the layout viewport before you access model space, you
can lock the scale to prevent changes. When the scale is locked, you cannot
use  while you work in model space.
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To switch between model space and paper space on a layout

On a layout, use one of the following methods:

■ If you are in paper space, double-click within a layout viewport.

You are now in model space. The selected layout viewport becomes the
current viewport, and you can pan the view and change layer properties.
If you need to make significant changes to the model, it is recommended
that you use  to maximize the layout viewport or switch to the Model tab.

■ If you are in model space in a layout viewport, double-click outside the
viewport.

You are now in paper space. You can create and modify objects on the
layout.

■ If you are in model space and want to switch to another layout viewport,
double-click within another layout viewport, or press  CTRL +  R to cycle
through the existing layout viewports.

To edit in a maximized layout viewport

1 Click the boundary of the layout viewport to select it.

NOTE You can maximize a locked viewport and modify objects. When you
restore the viewport, it is locked again.

2 On the status bar, click the Maximize Viewport button.

You can restore the viewport and maximize another viewport by clicking
one of the arrows next to the Maximize Viewport button.

3 Make any changes.

4 To return to the layout viewport, click the Restore Viewport button on
the status bar.

The center point and magnification are returned to the settings that
were in effect before the viewport was maximized.
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Status bar

,

Right-click. Click Maximize Viewport.

Create and Modify Layout Viewports
You can create a single layout viewport that fits the entire layout or create
multiple layout viewports in the layout. Once you create the viewports, you
can change their size, their properties, and also scale and move them as needed.

NOTE It is important to create layout viewports on their own layer. When you are
ready to plot, you can turn off the layer and plot the layout without plotting the
boundaries of the layout viewports.

With , you have several options for creating one or more layout viewports.
You can also use  and  to create multiple layout viewports.

Create Nonrectangular Layout Viewports

You can create a new viewport with nonrectangular boundaries by converting
an object drawn in paper space into a layout viewport.

The  command provides two options to assist you in defining an irregularly
shaped viewport.
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With the Object option, you can select a closed object, such as a circle or
closed polyline created in paper space, to convert into a layout viewport. The
object that defines the viewport boundary is associated with the viewport after
the viewport is created.

The Polygonal option can be used to create a nonrectangular layout viewport
by specifying points. The prompt sequence is the same as the prompt sequence
for creating a polyline.

NOTE When you want to suppress the display of the boundary of a layout
viewport, you should turn off the layer of the nonrectangular viewport instead of
freezing it. If the layer of a nonrectangular layout viewport is frozen, the boundary
is not displayed, but the viewport is not clipped.

Resize Layout Viewports

If you want to change the shape or size of a layout viewport, you can use grips
to edit the vertices just as you edit any object with grips.

Clip Layout Viewports

You can redefine the boundary of a layout viewport by using the  command.
To clip a layout viewport, you can use your pointing device to either select
an existing object to designate as the new boundary, or specify the points of
a new boundary.

To create a new layout viewport

1 On the layout tab, click View menu ➤ Viewports ➤ 1 Viewport.

2 Click to specify one corner of the new layout viewport.

3 Click to specify the opposite corner.

A new layout viewport object is available and displays a default view.
To adjust the view, double-click within the layout viewport to access
model space.

Viewports toolbar

,

To create a viewport configuration on a layout

1 Click a layout tab.
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2 Click View menu ➤ Viewports ➤ New Viewports.

3 In the Viewports dialog box, New Viewports tab, select a viewport
configuration from the list.

4 Under Setup, select either 2D or 3D.

When you select 3D, a set of standard 3D views is applied to each
viewport in the configuration.

5 Under Viewport Spacing, select the amount of spacing you want to add
between the viewports.

6 To change a view, select a viewport in the preview image. Under Change
View To, select a view from the list of standard views.

The list includes top, bottom, front, back, left, right, and isometric views,
along with any named views that are saved in the drawing. The selected
view is displayed under Preview.

7 Click OK.

8 In the drawing area, specify two points to indicate the area to contain
the viewport configuration.

Viewports toolbar

To place a named viewport configuration into a layout

1 Click a layout tab.

2 Click View menu ➤ Viewports ➤ New Viewports.

3 In the Viewports dialog box, Named Viewports tab, select the named
viewport configuration from the list.

4 Click OK.

5 In the layout, specify a location for the named viewport configuration.

Viewports toolbar
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To modify viewport properties using the Properties palette

1 Click the border of the layout viewport whose properties you want to
modify.

2 Right-click, and then click Properties.

3 In the Properties palette, select the value for the property you want to
modify. Enter a new value or select a new setting from the list provided.

The new property setting or value is assigned to the current viewport.

Standard toolbar

Select the viewport and right-click in the drawing area. Click Properties.

To clip a viewport boundary

1 At the Command prompt, enter vpclip.

2 Select the viewport to clip.

3 Enter d (Delete) to delete the clipping boundary.

4 Enter p (Polygonal).

5 Specify points, or select the object, to define the new viewport boundary.

Select the viewport to clip and right-click in the drawing area. Click Viewport
Clip.

Control Views in Layout Viewports
When you create a layout, you can add layout viewports that act as windows
into model space. In each layout viewport, you can control the view that is
displayed.

Scale Views in Layout Viewports

To scale each displayed view in the plotted drawing accurately, set the scale
of each view relative to paper space.

You can change the view scale of the viewport using

■ The Properties palette
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■ The XP option of the  command

■ The Viewports toolbar

NOTE You can modify the list of scales that are displayed in all view and plot scale
lists with .

When you work in a layout, the scale factor of a view in a layout viewport
represents a ratio between the actual size of the model displayed in the
viewport and the size of the layout. The ratio is determined by dividing the
paper space units by the model space units. For example, for a quarter-scale
drawing, the ratio would be a scale factor of one paper space unit to four model
space units, or 1:4.

Scaling or stretching the layout viewport border does not change the scale of
the view within the viewport.

Lock the Scale of Layout Viewports

Once you set the viewport scale, you cannot zoom within a viewport without
changing the viewport scale. By locking the viewport scale first, you can zoom
in to view different levels of detail in your viewport without altering the
viewport scale.

Scale locking locks the scale that you set for the selected viewport. Once the
scale is locked, you can continue to modify the geometry in the viewport
without affecting the viewport scale. If you turn a viewport's scale locking on,
most of the viewing commands, such as , , , , and , no longer function in that
viewport.

NOTE Viewport scale locking is also available for nonrectangular viewports. To
lock a nonrectangular viewport, you must perform an extra step in the Properties
palette to select the viewport object rather than the viewport clipping boundary.

To modify a layout viewport scale using the Properties palette

1 Make sure you are on a layout tab in paper space.

2 Click the border of the viewport whose scale you want to modify.

3 Right-click, and then click Properties.

4 In the Properties palette, select Standard Scale, and then select a new
scale from the list.

The scale you choose is applied to the viewport.

Standard toolbar
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Select the viewport and right-click in the drawing area. Click Properties.

To turn on scale locking in a layout viewport

1 In the layout, click the viewport whose scale you want to lock.

2 If necessary, open the Properties palette.

3 In the Properties palette, do one of the following:

■ If you selected a rectangular viewport, select Display Locked, and then
click Yes.

■ If you selected a nonrectangular viewport, first click All (2) and select
Viewport (1). Then select Display Locked, and click Yes.

The current viewport’s scale is locked. If you change the zoom factor in
the viewport, only paper space objects are affected.

Standard toolbar

Select the viewport and right-click in the drawing area. Click Properties.

Control Visibility in Layout Viewports

You can control the visibility of objects in layout viewports using several
methods. These methods are useful for emphasizing or hiding different
elements of a drawing, and for reducing screen regeneration time.

Freeze Specified Layers in a Layout Viewport

A major benefit to using layout viewports is that you can selectively freeze
layers in each layout viewport. You can also specify default visibility settings
for new viewports and for new layers. As a result, you can view different objects
in each layout viewport.

You can freeze or thaw layers in current and future layout viewports without
affecting other viewports. Frozen layers are invisible. They are not regenerated
or plotted. In the illustration, the layer showing terrain has been frozen in
one viewport.
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Thawing the layer restores visibility. The easiest way to freeze or thaw layers
in the current viewport is to use the Layer Properties Manager.

In the Layer Properties Manager, on the right side, use the column labeled
Current VP Freeze to freeze one or more layers in the current layout viewport.
To display the Current VP Freeze column, you must be on a layout tab. Specify
the current layout viewport by double-clicking anywhere within its borders.

Freeze or Thaw Layers Automatically in New Layout Viewports

You can set visibility defaults for specific layers in all new layout viewports.
For example, you can restrict the display of dimensions by freezing the
DIMENSIONS layer in all new viewports. If you create a viewport that requires
dimensions, you can override the default setting by changing the setting in
the current viewport. Changing the default for new viewports does not affect
existing viewports.

Create New Layers That Are Frozen in All Layout Viewports

You can create new layers that are frozen in all existing and new layout
viewports. Then you can thaw the layers in the viewports you specify. This is
a shortcut for creating a new layer that is visible only in a single viewport.

To freeze or thaw layers in the current layout viewport

1 Double-click within a layout viewport to make it current.

2 Click Format menu ➤ Layer.

3 In the Layer Properties Manager, select the layers to freeze or thaw.

Hold down  CTRL  to select more than one layer. Hold down  SHIFT  to
select a sequence of layers.
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4 Click the icon in the Current VP Freeze column for one of the selected
layers.

5 Click OK.

Layers toolbar

To view a list of layers that are frozen in the current viewport

1 Click a layout tab.

2 Double-click within a layout viewport to make it current.

3 Click Format menu ➤ Layer.

4 In the Layer Properties Manager, look at the Current VP Freeze column
for the Freeze/Thaw in Current Viewports icon.

5 Click OK.

Layers toolbar

,

To freeze or thaw layers in all viewports

1 Click a layout tab.

2 Click Format menu ➤ Layer.

3 In the Layer Properties Manager, select one or more layers to freeze or
thaw.

Hold down  CTRL  to select more than one layer. Hold down  SHIFT  to
select a sequence of layers.

4 In the Freeze column, click the icon to freeze or thaw.

Layers toolbar
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To freeze or thaw layers in paper space

1 Click a layout tab.

2 Make sure that you are in paper space. (On the status bar, PAPER is on.)

3 Click Format menu ➤ Layer.

4 In the Layer Properties Manager, select the layer or layers you want to
freeze or thaw.

5 In the Freeze column, click the icon to change a layer’s state. The sun
icon means that a layer is thawed; the snowflake icon means that a layer
is frozen.

6 Click OK.

Layers toolbar

To freeze or thaw layers in all new viewports

1 Click a layout tab.

2 Click Format menu ➤ click Layer.

3 In the Layer Properties Manager, select the layer or layers you want to
be automatically frozen or thawed in new viewports you create.

Hold down  CTRL  to select more than one layer. Hold down  SHIFT  to
select a sequence of layers.

4 In the New VP Freeze column, click the icon to change a layer’s state.
The sun icon means that a layer is thawed; the snowflake icon means
that a layer is frozen.

5 Click OK.

Layers toolbar

To create new layers that are frozen in all viewports

1 Click a layout tab.
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2 Click Format menu ➤ Layer.

3 Click the New Layer button to create a layer.

4 Rename the new layer.

5 Click the icon in the Freeze column to change the layer’s state to frozen.
The sun icon means that a layer is thawed; the snowflake icon means
that a layer is frozen.

6 Click OK.

Layers toolbar

,

Screen Objects in Layout Viewports

Screening refers to applying less ink to an object when it is plotted. The object
appears dimmer on the screen and on the plotted paper. Screening can be
used to help differentiate objects in a drawing without changing the objects'
color properties.

To assign a screening value to an object, you must assign a plot style to the
object, and then define the screening value in that plot style.

You can assign a screening value from 0 to 100. The default setting, 100, means
no screening is applied, and the object is displayed with normal ink intensity.
A screening value of 0 means the object contains no ink and is thus invisible
in that viewport.

See also:

“Set Options for Plotted Objects” on page 886

To apply screening to objects in a layout viewport

1 Click File menu ➤ Plot Style Manager.

2 Right-click a CTB or STB file. Click Open.

3 In the Plot Style Table Editor, Form View tab, select a plot style to change.

4 In the Screening box, enter an intensity value between 1 and 100.

5 Click Save & Close.

6 In the layout, click File menu ➤ Page Setup.
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7 In the Page Setup dialog box, Plot Device tab, select the edited plot style
table from the Plot Style Table (Pen Assignments) list.

8 Double-click within the layout viewport that contains the objects whose
screening you want to change.

9 Select the objects whose plot style you want to change.

10 Right-click in the drawing area and click Properties.

11 In the Properties palette, use one of the following methods:

■ If you are using named plot style tables, next to Plot Style, select the
plot style you edited in the Plot Style Table Editor. If that plot style
is not listed, select Other and set Active Plot Style Table to the plot
style you edited in the Plot Style Table Editor. Select the edited plot
style from the Plot Styles list in the Select Plot Style dialog box.

■ If you are using color-dependent plot style tables, next to Color, select
the color whose plot style you edited in the Plot Style Table Editor.

Turn Layout Viewports On or Off

You can save time by turning some layout viewports off or by limiting the
number of active viewports.

Displaying a large number of active layout viewports can affect your system’s
performance as the content of each layout viewport regenerates. You can save
time by turning some layout viewports off or by limiting the number of active
viewports. The following illustration shows the effects of turning off two
layout viewports.

all viewports on two viewports off

New layout viewports are turned on by default. If you turn off the layout
viewports you aren’t using, you can copy layout viewports without waiting
for each one to regenerate.

Control Views in Layout Viewports | 223



If you don’t want to plot a layout viewport, you can turn the layout viewport
off.

To turn viewports on or off using the Properties palette

1 Make sure you are on a layout tab in paper space.

2 Click the border of the viewport to turn on or off.

3 Right-click, and then click Properties.

4 In the Properties palette, under Misc, select On, and then select Yes or
No to turn the viewport on or off.

For a nonrectangular viewport, select All (2) in the Properties palette,
and then select Viewport (1) before changing any viewport properties.

Standard toolbar

Select the viewport and right-click in the drawing area. Click Display Viewport
Objects.

Scale Linetypes in Layout Viewports

You can scale linetypes in paper space either based on the drawing units of
the space in which the object was created or based on the paper space units.

You can set the  system variable to maintain the same linetype scaling for
objects displayed at different zoom factors in a layout and in a layout viewport.
For example, with PSLTSCALE set to 1 (default), set the current linetype to
dashed, and then draw a line in a paper space layout. In the layout, create a
viewport with a zoom factor of 1x, make that layout viewport current, and
then draw a line using the same dashed linetype. The dashed lines should
appear to be the same. If you change the viewport zoom factor to 2x, the
linetype scaling for the dashed line in the layout and the dashed line in the
layout viewport will be the same, regardless of the difference in the zoom
factor.

With PSLTSCALE turned on, you can still control the dash lengths with  and
. In the following illustration, the pattern of the linetypes in the drawing on
the left has been scaled to be the same regardless of the scale of the view. In
the drawing on the right, the scale of the linetypes matches the scale of each
view.
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PSLTSCALE=1, dashes scaled to
paper space

PSLTSCALE=0, dashes scaled to space
where they were created

See also:

“Set the Lineweight Scale for a Layout” on page 855

To scale linetypes globally in paper space

1 Click Format menu ➤ Linetype.

2 In the Linetype Manager, click Show Details.

3 Under Global Scale Factor, enter a global scale to apply to the linetypes.

4 Click OK.

Align Views in Layout Viewports

You can arrange the elements of your drawing by aligning the view in one
layout viewport with the view in another viewport.

For angled, horizontal, and vertical alignments, you can move each layout
viewport relative to distances defined by the model-space geometry displayed.
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Horizontal alignments

Vertical alignments

Angled alignments

2
1

1

2

To adjust the views on a layout with precision, you can create construction
geometry, use object snaps on the model-space objects displayed in layout
viewports, or use one of the cursor constraint features available on the status
bar.

To align objects between viewports using a construction line

1 Make sure you are on a layout tab.

2 Click Draw menu ➤ Construction Line.

3 Specify a point in the first viewport. Specify a second point to determine
a line for the alignment.

Choose a point that can be aligned with objects in the second viewport.
Use object snaps for precision.
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4 Click Modify menu ➤ Move.

5 Select the viewport to align to the first viewport. Press ENTER.

6 When prompted for a base point, specify a point in the second viewport.
Choose a point that corresponds with the point selected in the first
viewport.

7 When prompted for the second point, hold down SHIFT and right-click.
Choose Object Snap menu ➤ Perpendicular. Click on the construction
line you created.

The first and second viewports, and the objects in the viewports, are
aligned.

NOTE When aligning objects in viewports, the scale of the viewports should
be the same.

Modify toolbar

To align objects between viewports using MVSETUP

1 At the Command prompt, enter mvsetup.

2 Enter a (Align).

3 Select one of the following alignments:

■ Horizontal . Aligns a point in one viewport horizontally with a base
point in another viewport.

■ Vertical . Aligns a point in one viewport vertically with a base point
in another viewport.

■ Angled . Aligns a point in one viewport at a specified distance and
angle from a base point in another viewport.

4 Make sure the viewport with the view that is to remain stationary is
current. Then specify a base point.

5 Select the viewport with the view you want to realign. Then specify an
alignment point in that view.

6 For angled alignments only, specify a distance and displacement angle
from the base point to the alignment point in the second viewport.
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Rotate Views in Layout Viewports

You can rotate an entire view within a layout viewport by changing the UCS
and using the PLAN command.

With the  command, you can rotate the XY plane at any angle around the
Z-axis. When you enter the PLAN command, the view rotates to match the
orientation of the XY plane.

original view rotated view

For a faster method, use the Align and then Rotate View options in the
command.

NOTE The  command rotates individual objects only and should not be used to
try to rotate a view.

To rotate a view by changing the UCS

1 Make sure you are on a layout tab.

2 Double-click within the viewport whose objects you want to rotate.

3 Make sure that the current UCS is parallel to the plane of rotation (the
UCS icon should look normal). If the UCS is not parallel to the plane of
rotation, click Tools menu ➤ New UCS ➤ View.

4 Click Tools menu ➤ New UCS ➤ Z. To rotate the view 90 degrees
clockwise, enter 90. To rotate the view 90 degrees counter-clockwise,
enter -90.

5 Click View menu ➤ 3D Views ➤ Plan View. Click Current UCS.

The entire view rotates within the viewport. You may need to respecify
the scale of the viewport.

UCS toolbar
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To rotate a view using MVSETUP

1 At the Command prompt, enter mvsetup.

2 Enter a (Align).

3 Enter r to rotate the view.

4 Select the viewport with the view you want to rotate.

5 Specify a base point for the rotation.

6 Specify the rotation angle.

The entire view rotates within the viewport.

Reuse Layouts and Layout Settings
When you create a layout, you can choose to apply the information from an
existing template.

A layout template is a layout imported from a DWG or DWT file. When you
create a layout, you can choose to apply the information from an existing
template. The program has sample layout templates to use when you design
a new layout environment. The paper space objects and page setup in the
existing template are used in the new layout. Thus, the layout objects,
including any viewport objects, are displayed in paper space. You can keep
any of the existing objects from the template you import, or you can delete
the objects. No model space objects are imported.

The layout templates are identified with a .dwt file extension. However, a
layout template or layout from any drawing or drawing template can be
imported into the current drawing.

Save a Layout Template

Any drawing can be saved as a drawing template (DWT file), including all of
the objects and layout settings. You can save a layout to a new DWT file by
choosing the Save As option of the LAYOUT command. The template file is
saved in the drawing template file folder as defined in the Options dialog box,
Support tab. The layout template has a .dwt or .dwg extension like a drawing
template or drawing file, but it contains little information not essential to the
layout.

When you create a new layout template, any named items, such as blocks,
layers, and dimension styles, that are used in the layout are saved with the
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template. These definition table items are imported as part of the layout
settings if you import this template into a new layout. It is recommended that
you use the Save As option of the LAYOUT command to create a new layout
template. When you use the Save As option, unused definition table items are
not saved with the file; they are not added to the new layout into which you
import the template.

If you insert a layout from a drawing or template that was not created using
the Save As option of the LAYOUT command, definition table items that are
used in the drawing but not in the layout are inserted with the layout. To
eliminate unnecessary definition table items, use the  command.

Insert a Layout Using DesignCenter

Using DesignCenter™ , you can drag a layout with its objects from any drawing
into the current drawing.

When you use DesignCenter to insert a layout into a drawing, a new layout
is created that includes all of the paper space objects, definition tables, and
block definitions from the source layout. You can delete unneeded paper space
objects. To eliminate any unnecessary definition table information from the
new layout, use the  command.

To create a layout using a layout template

1 Click Insert menu ➤ Layout ➤ Layout from Template.

2 In the Select Template From File dialog box, select a drawing template
file from the list.

3 Click Open.

4 In the Insert Layout(s) dialog box, select the layout template from the
list. Click OK.

A new layout is created using the layout template you selected. The new
layout is assigned the name Layout with the next number in the sequence
and with the name of the imported layout attached.

For example, if you insert a layout called ANSI D from a layout template
and you already have two layouts in your drawing called Layout1 and
Layout2, the new layout is called Layout3 - ANSI D.

Layouts toolbar

Right-click the layout tab. Click From Template.
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To save a layout template

1 At the Command prompt, enter layout.

2 At the prompt, enter sa to save the current layout as a template.

3 Enter the name of the layout you are saving.

4 In the Create Drawing File dialog box, enter a name for the drawing
template file you are saving.

5 In Files of Type, select Drawing Template File (*.dwt).

6 Click Save.

To insert a layout using DesignCenter

1 Click Tools menu ➤ DesignCenter.

2 In the tree view, find the drawing that contains the layout you want to
reuse.

3 Double-click the drawing name to expand the options beneath it.

4 Select the Layouts icon to display the individual layouts in the content
area.

5 Use one of the following methods to insert the layout into the current
drawing:

■ Drag the layout icon from the content area into the drawing.

■ Select a layout in the content area and right-click. Click Add Layout(s).

■ Double-click the layout in the content area.

Standard toolbar
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Work with Sheets in a
Sheet Set

 

With the Sheet Set Manager, you can organize drawing layouts

into named sheet sets. The sheets in a sheet set can be

transmitted, published, and archived as a unit.

Sheet sets facilitate the organization and management of

drawings in a project, and improve the communication in a

work group.
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Quick Start for Sheet Sets
A sheet set is an organized collection of sheets from several drawing files. A
sheet is a selected layout from a drawing file.

Sets of drawings are the primary deliverable for most design groups. Sets of
drawings communicate the overall design intent of a project and provide the
documentation and specifications for the project. However, managing sets of
drawings manually can be complicated and time consuming.

With the Sheet Set Manager, you can manage drawings as sheet sets. A sheet
set is an organized and named collection of sheets from several drawing files.
A sheet is a selected layout from a drawing file. You can import a layout from
any drawing into a sheet set as a numbered sheet.

You can manage, transmit, publish, and archive sheet sets as a unit.

Understand the Sheet Set Manager Interface
Using the controls in the Sheet Set Manager, you can create, organize, and
manage sheets in a sheet set.
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You can use the following tabs and controls in the Sheet Set Manager:

Sheet Set Control. Lists menu options to create a new sheet set, open an
existing sheet set, or switch between open sheet sets.

Sheet List Tab. Displays an organized list of all sheets in the sheet set. Each
sheet in a sheet set is a specified layout in a drawing file.

View List Tab. Displays an organized list of all sheet views in the sheet set.
Only sheet views created with AutoCAD 2005 and later are listed.

Resource Drawings Tab. Lists the paths and folder names for the drawings
to be used as resources for the sheet set.

■ Click a folder to list the drawing files that are located in that folder.

■ Click a drawing file to list the named model space views that are available
for placement in the current sheet.

■ Double-click a view to open the drawing containing the view.

■ Right-click or drag a view to place it in the current sheet.

Buttons. Provides convenient access for the most commonly used operations
for the currently selected tab.

Tree View. Displays the contents of a tab.
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Details or Preview. Displays either descriptive information or a thumbnail
preview of the currently selected item in the tree view.

Actions Used in the Tree View

You can use the following actions in the tree view:

■ Right-click to access shortcut menus of the operations that are relevant to
the currently selected item.

■ Double-click items to open them. This is a convenient method for opening
drawing files from the Sheet List tab or from the Resource Drawings tab.
You also double-click items in the tree view to expand or collapse them.

■ Click one or more items to select them for operations such as opening,
publishing, or transmitting.

■ Click a single item to display descriptive information or a thumbnail preview
of a selected sheet, view, or drawing file.

■ Drag items within the tree view to reorder them.

NOTE To use the Sheet Set Manager effectively, right-click items in the tree view
to access relevant shortcut menus. For access to shortcut menus in the drawing
area that are needed for sheet set operations, the Shortcut Menus in Drawing Area
must be checked in the Options dialog box, User Preferences tab.

Create and Manage a Sheet Set
There are several methods for setting up and organizing a sheet set. You can
also include relevant information with a sheet set and its components.

Create a Sheet Set

You create a sheet set with the Create a Sheet Set wizard. In the wizard, you
can either create a sheet set from scratch based on existing drawings or use
an example sheet set as a template.

Layouts from specified drawing files are imported into the sheet set. The
associations and information that define a sheet set are stored in a sheet set
data (DST) file.

When creating a new sheet set using the Create Sheet Set wizard, a new folder
is created as the default sheet set storage location. This new folder, named
AutoCAD Sheet Sets is located in the My Documents folder. The default
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location for the sheet set file can be changed, and it is recommended that the
DST file is stored with the project files.

NOTE The DST file should be stored in a network location that is accessible to all
sheet set users on the network and mapped using the same logical drive. It is
strongly recommended that you store the DST and the sheet drawings in the same
folder. If an entire sheet set needs to be moved, or a server or folder name changes,
the DST file will still be able to locate the sheets using relative path information.

Preparation Tasks

Before you begin creating a sheet set, you should complete the following tasks:

■ Consolidate drawing files. Move the drawing files to be used in the sheet
set into a small number of folders. This will simplify sheet set
administration.

■ Eliminate multiple layout tabs. Each drawing you plan to use in the
sheet set should have only one layout to be used as a sheet in the sheet set.
This is important for access to sheets by multiple users. Only one sheet in
each drawing can be open at a time.

■ Create a sheet creation template. Create or identify a drawing template
(DWT) file to be used by the sheet set for creating new sheets. This drawing
template file is called the sheet creation template. You specify this template
file in the Sheet Set Properties dialog box or the Subset Properties dialog
box.

■ Create a page setup overrides file. Create or identify a DWT file to store
page setups for plotting and publishing. This file, called the page setup
overrides file, can be used to apply a single page setup to all sheets in a sheet
set, overriding the individual page setups stored in each drawing.

NOTE Although it is possible to use several layouts from the same drawing file
as separate sheets in a sheet set, it is not recommended. This makes concurrent
access to each layout by multiple users impossible. This practice can also reduce
your management options and can complicate the organization of your sheet sets.

Create a Sheet Set from an Example Sheet Set

In the Create Sheet Set wizard, when you choose to create a sheet set from an
example, the example sheet set provides the organizational structure and
default settings for the new sheet set. You can also specify that folders are
created corresponding to the subset storage paths of the sheet set.

After you create an empty sheet set with this option, you can import layouts
or create sheets individually.
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Create a Sheet Set from Existing Drawing Files

In the Create Sheet Set wizard, when you choose to create a sheet set from
existing drawing files, you specify one or more folders that contain drawing
files. With this option, you can specify that the subset organization for the
sheet set duplicates the folder structure of the drawing files. The layouts from
these drawings can be imported into the sheet set automatically.

You can easily add more folders containing drawings by clicking the Browse
button for each additional folder.

Backup and Recover Sheet Set Data Files

The data stored in the sheet set data file represents a significant amount of
work, so you should take the same care to create backups of DST files as you
do for drawing files.

In the unlikely event of DST file corruption or a major user error, the previously
saved sheet set data file can be recovered. Every time the sheet set data file is
opened, the current sheet set data file is copied to a backup file (DS$). This
backup file has the same file name and is located in the same folder as the
current sheet set data file.

To recover the previous version of the sheet set data file, first make sure that
no one else on your network is working on the sheet set. Then, it is
recommended that you copy the existing DST file to another file name. Finally,
rename the backup file from the DS$ file extension to the DST file extension.

To open the Sheet Set Manager

■ Click Tools menu ➤ Sheet Set Manager.

Standard toolbar

To create a new sheet set

1 To create a new sheet set, do one of the following:

■ Click File menu ➤ New Sheet Set.

■ In the Sheet Set Manager, click the Sheet Set control. Click New Sheet
Set.

2 Follow the steps in the Create Sheet Set wizard.

Standard toolbar
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To open a sheet set

1 To open a sheet set, do one of the following:

■ Click File menu ➤ Open Sheet Set.

■ In the Sheet Set Manager, click the Sheet Set control. Click Open.

■ Double-click a sheet set data (DST) file.

2 In the Open Sheet Set dialog box, navigate to a folder that contains a
DST file. Click the DST file and then click open.

The Sheet Set Manager displays the sheet set data.

NOTE You can open several sheet sets and then use the Sheet Set control
to switch between them.

Standard toolbar

To close a sheet set

1 In the Sheet Set Manager, Sheet List tab, right-click the sheet set node
(at the top of the list). Click Close Sheet Set.

The sheet set is no longer displayed in the Sheet Set Manager.

NOTE Close a sheet set to reduce the number of sheet sets listed in the
Sheet Set control. However, if you close a sheet set while you still have sheets
in the sheet set open, you will not be able to update the Sheet List table and
certain fields.

Standard toolbar
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Organize a Sheet Set

You can organize a sheet set by creating a hierarchy of subsets and categories.
Sheets can be arranged into collections called subsets. Views can be arranged
into collections called categories.

With a large sheet set, you will find it essential to organize sheets and views
in the tree view. On the Sheets tab, sheets can be arranged into collections
called subsets. On the View List tab, views can be arranged into collections
called categories.

Use Sheet Subsets

Sheet subsets are often associated with a discipline such as architecture or
mechanical design. For example, in architecture, you might use a subset named
Structural; and in mechanical design, you might use a subset called Standard
Fasteners. In some cases, you might also find it useful to create subsets
associated with a review or completion status.

You can nest subsets into other subsets as needed. After you create or import
sheets or subsets, you can reorder them by dragging them in the tree view.

Use View Categories

View categories are often associated with a function. For example, in
architecture, you might use a view category called Elevations; and in
mechanical design, you might use a view category called Exploded.

You can display views either by category or by the sheet on which they are
located.
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You can nest categories into other categories as needed. To move a view to a
different category, drag them in the tree view or use the Set Category shortcut
menu option.

To reorder sheets in the sheet list

■ In the Sheet Set Manager, on the Sheet List tab, drag a sheet up or down
the list.

The sheet is relocated above or below its previous location on the sheet list.
The sheet may also be moved into or out of a sheet subset.

Standard toolbar

To create a new subset in the sheet list

1 In the Sheet Set Manager, Sheet List tab, right-click the sheet set node
(at the top of the list), or an existing subset. Click New Subset.

2 In the Subset Properties dialog box, under Subset Name, enter the name
of the new subset. Click OK.

You can drag the new subset anywhere on the sheet list, even under
other subsets.

NOTE If you want to create a subset under an existing subset, you can
right-click the existing subset. On the shortcut menu, click New Subset.

Standard toolbar
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To create a new view category in the view list

1 In the Sheet Set Manager, View List tab, click the View by Category
button.

2 Right-click the sheet set node (at the top of the list). Click New View
Category.

3 In the View Category dialog box, under Category Name, enter the name
of the new view category.

4 If a list of blocks is displayed, select the callout blocks to be used for the
views in this view category. You can add blocks to the list by clicking
the Add Blocks button.

Standard toolbar

To remove a subset from the sheet list

1 In the Sheet Set Manager, Sheet List tab, drag all sheets out of the subset
that you want to remove.

2 Right-click the subset that you want to remove. Click Remove Subset.

Standard toolbar

To remove a view category from the view list

1 In the Sheet Set Manager, View List tab, click the View by Category
button.

2 Drag all views out of the view category that you want to remove.

3 Right-click the view category that you want to remove. Click Remove
Category.

Standard toolbar

242 | Chapter 20   Work with Sheets in a Sheet Set



Create and Modify Sheets

There are several options in the Sheet Set Manager for creating sheets and
adding views, either through a shortcut menu or one of the tab buttons.

Following are descriptions of common sheet operations. You can access
commands by right-clicking an item in the tree view to display the relevant
shortcut menu.

■ Import layout as sheet. After you create a sheet set, you can import one
or more layouts from existing drawings. This is a fast method for creating
multiple sheets from layouts in several drawings.

■ Create a new sheet. As an alternative to importing existing layouts, you
can create a new sheet. When you place views in this sheet, the drawing
files associated with the views are attached as xrefs to the sheet drawing.

■ Modify a sheet. Double-click a sheet on the Sheet List tab to open a
drawing from the sheet set. Use SHIFT or CTRL to select multiple sheets.
To review a sheet, use the shortcut menu to open a drawing in read-only
mode.

NOTE Modifying a sheet should always be done using an open sheet set in the
Sheet Set Manager. This ensures that all data associated with the sheet are updated.

■ Remove a sheet from a sheet set. Removing a sheet from a sheet set
disassociates the sheet from the sheet set, but does not delete the drawing
file or the layout.

■ Reassociate a sheet. If you move a sheet to a different folder, you should
reassociate the sheet to the sheet set with the Sheet Properties dialog box
to correct the path. For any relocated sheet drawing, the paths for Expected
Layout and Found Layout are displayed in the Sheet Properties dialog box.
To reassociate the sheet, click the path in Expected Layout and then click
to navigate to the new location of the sheet.

NOTE You can quickly confirm whether a sheet is in the expected folder by looking
at Details at the bottom of the Sheet List tab. If the selected sheet is not in the
expected location, path information for both Expected Location and Found Location
is displayed in Details.

■ Add a view to a sheet. From the Resource Drawings tab, you can easily
add a view to a sheet by placing a named model space view or the entire
drawing onto the current sheet.
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NOTE After creating a named model space view, you must save the drawing to
add the view to the Resource Drawings tab. Click Refresh on the Resource Drawings
tab to update the Sheet Set Manager tree view.

■ Add label blocks to views. With the Sheet Set Manager, you can label
views and details automatically as you place them. Labels contain data
associated with the referenced view.

Scale: 1/8" = 1'-0"

MAIN FLOOR PLAN

■ Add callout blocks to views.  Callout blocks is the term for the symbols
that reference other sheets. Callout blocks have many industry-specific
names such as reference tags, detail keys, detail makers, building section
keys, and so on. Callout blocks contain data associated with the sheet and
view that are referenced.

NOTE When you place a callout block with fields or a view on a sheet, make
sure that the current layer is unlocked.

1

A3

■ Create a title sheet and table of contents. The first sheet in a sheet set
will usually be a title sheet that includes a description of the sheet set and
a table that lists all the sheets in the sheet set. You can create this table,
called a sheet list table, on an open sheet. The table automatically includes
all the sheets in the sheet set. You can create a sheet list table from the
sheet set level shortcut menu only when a sheet is open.

NOTE For access to shortcut menus in the drawing area that are needed for
sheet list table operations, the Shortcut Menus in Drawing Area must be checked
in the Options dialog box, User Preferences tab.

Create Callout Blocks and Label Blocks (Advanced)

If you create a block to be used as a callout block or label block in a sheet set,
you can use a placeholder field to display information such as view title or
sheet number. The callout or label block must be defined in a DWG or DWT
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file that is specified in the Sheet Set Properties dialog box. Later, you can insert
the callout or label block from a shortcut menu on the Views List tab in the
Sheet Set Manager.

For the field to display the correct information about a view or sheets on
which you later insert it, the field must be included within a block attribute,
not text, when you define the block. To create the block attribute definition,
insert a placeholder field as the value, select the Preset option, and specify a
tag.

NOTE If you create your own label blocks and callout blocks, set any attribute
definitions to Preset to avoid prompts when placing these blocks in a drawing.

For more information about fields, see “Insert Fields” on page 725.

Place a Sheet View (Advanced)

The Sheet Set Manager automates and enhances the process for adding views
to a sheet. A view on a sheet, called a sheet view, consists of several coincident
entities: an xref or geometry in model space, a layout viewport on a sheet,
and a named view in paper space.

■ The sheet view can display model space from a different drawing file. In
this case, that drawing is attached as an xref in your current drawing. The
layers of that drawing file are displayed only in the sheet view that you
create.

■ A layout viewport that displays the model space view is created on your
current sheet.

■ A named view that encompasses the area of the layout viewport is created
in paper space.

If you need to remove a sheet view from a sheet, you can delete the layout
viewport to remove the view. However, to remove all unused items, you need
to detach the xref and delete the named paper space view.

NOTE The easiest method for removing a sheet view immediately after placing
it is to use .

See also:

“Create Multiple-View Drawing Layouts (Paper Space)” on page 203

To import layouts from existing drawings as sheets

1 In the Sheet Set Manager, Sheet List tab, right-click the sheet set node,
a subset node, or a sheet node. Click Import Layout as Sheet.
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2 In the Import Layouts as Sheets dialog box, click Browse for Drawings
and navigate to the drawing that you want to use.

To select several drawings, use SHIFT or CTRL when you click on the
drawing files.

3 Click the check boxes of the layouts to be imported as sheets in the
current sheet set. Click Import Checked.

4 (Optional) On the Sheet List tab, right-click a newly imported sheet.
Click Rename & Renumber.

5 (Optional) In the Rename & Renumber Sheet dialog box, make any
changes to the sheet number and sheet title. Click OK.

NOTE Changes to the sheet number and sheet title have no effect on the
drawing file name unless a file rename option is checked.

Standard toolbar

To create a new sheet

1 In the Sheet Set Manager, Sheet List tab, right-click either the sheet set
node, a subset node, or a sheet node. Click New Sheet.

2 In the New Sheet dialog box, enter the sheet number and sheet title.
Click OK.

The new sheet is created from the drawing template file specified in
Sheet Set Properties for the default new sheet creation template.

NOTE You can change the default folder location for new sheets from the
Sheet Set Properties or the Subset Properties dialog box.

Standard toolbar

To open a drawing file within a sheet set

1 In the Sheet Set Manager, open a sheet set.

2 On the Sheet List tab, double-click a sheet. To select several drawings,
use SHIFT or CTRL when you click on the drawing files.
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The drawing file for the sheet is opened. Any changes made to the
drawing that are relevant to the sheet list are updated in the sheet set
data (DST) file.

Standard toolbar

To open a drawing file read-only within a sheet set

1 In the Sheet Set Manager, open a sheet set.

2 On the Sheet List tab, right-click a sheet. Click Open read-only.

Standard toolbar

To remove a sheet from a sheet set

1 In the Sheet Set Manager, open a sheet set.

2 On the Sheet List tab, right-click the sheet that you want to remove.
Click Remove Sheet

The specified sheet is removed from the sheet list. The sheet and the
drawing file are not deleted, however. The sheet can be added to a
different sheet set.

NOTE The DWG file associated with a sheet does not have to be accessible
for the sheet to be removed from the sheet set.

Standard toolbar

To reassociate a sheet in a sheet set

1 In the Sheet Set Manager, open a sheet set.

2 On the Sheet List tab, open the sheet that you want to reassociate.

3 In the Sheet Set Manager, right-click the sheet. Click Remove Sheet.

4 Save the drawing.
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5 In the Sheet Set Manager, right-click the Sheet Set. Click Import Layout
as Sheet.

6 In the Import Layout as Sheet dialog box, click Browse for Drawings.
Navigate to the drawing that you want to use.

7 Click the check box of the layout to be reassociated as a sheet in the
current sheet set. Click Import Checked.

Standard toolbar

To add a view to a sheet

1 In the Sheet Set Manager, open a sheet set.

2 On the Sheet List tab, do one of the following:

■ Double-click a sheet to open it.

■ Create a new sheet and open it.

3 On the Resource Drawings tab, click the plus sign (+) next to a folder to
list the drawings in the folder.

4 From the list of drawing files, do one of the following:

■ To add a model view to a sheet, click the plus sign (+) next to a
drawing file to list its named model space views. Right-click a model
space view.

■ To add an entire drawing as a view in a sheet, right-click a drawing
file.

5 Click Place on Sheet.

NOTE As an alternative to the previous two steps, you can drag a model
space view or a drawing from the Resources tab to a sheet.

6 Right-click on the sheet. Click the scale for the sheet view.

7 Specify the insertion point for the sheet view.

The specified view is added to the sheet. If a view label block is defined
in the sheet set properties, a view label that displays view-specific
information is automatically placed on the sheet.

Standard toolbar
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To add a block to be used for sheet view callouts

1 In the Sheet Set Manager, open a sheet set.

2 On the View List tab, right-click the sheet set node.

3 In the Sheet Set Properties dialog box, click Callout Blocks. Click the [...]
button.

4 In the List of Blocks dialog box, do one of the following:

■ Click a block from the list of blocks.

■ Click the Add button and specify a new block to be added to the list.

5 Click OK to close each dialog box.

Standard toolbar

To change the default block used for sheet view labels

1 In the Sheet Set Manager, open a sheet set.

2 On the View List tab, right-click the sheet set node.

3 In the Sheet Set Properties dialog box, click Label Block for Views. Click
the [...] button.

4 In the Select Block dialog box, specify a new block to be used as the
default view label block.

5 Click OK to close each dialog box.

Standard toolbar

To add a callout block to a sheet

1 In the Sheet Set Manager, open a sheet set.
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2 On the View List tab, right-click the view with which you want to
associate a callout. Click Place Callout Block.

3 Specify the insertion point of the callout block.

The callout block is placed on the sheet. The callout block automatically
displays view-specific information about the view with which it is
associated.

Standard toolbar

To create a sheet list table on a title sheet

1 In the Sheet Set Manager, open a sheet set.

2 On the Sheet List tab, double-click the sheet to be used as the title sheet.

3 Right-click the sheet set node. Click Insert Sheet List Table.

4 In the Sheet List Table dialog box, enter the title of the table. Make any
formatting changes needed.

5 Click OK.

6 Specify the insertion point of the table.

The sheet list table automatically generates a list of all the sheets in the
sheet set.

Standard toolbar

Include Information with Sheets and Sheet Sets

Sheet sets, subsets, and sheets include several types of information. This
information, called properties, includes titles, descriptions, file paths, and
custom properties that you define.

Different Properties for Different Levels (Owners)

Sheet sets, subsets, and sheets represent different levels of organization, and
each of these includes different types of properties. You specify the values for
these properties when you create the sheet set, subset, or sheet.
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In addition, you can define custom properties for a sheet and a sheet set. The
values for custom properties for sheets are typically specific to each sheet. For
example, a custom property for a sheet might include the name of the designer.
The values for custom properties for a sheet set are typically specific to a
project. For example, a custom property for a sheet set might include the
contract number.

You cannot create custom properties for subsets.

View and Edit Properties

You can view and edit properties from the Sheet List tab by right-clicking the
name of the sheet set, subset, or sheet. On the shortcut menu, click Properties.
The properties and values that are displayed in the Properties dialog box
depend on what you selected. You can edit the values of the properties by
clicking a value.

To edit the properties of a sheet set, subset, sheet, or view category

1 In the Sheet Set Manager, open a sheet set.

2 Do one of the following:

■ On the Sheet List tab, right-click the sheet set node, a subset, or a
sheet.

■ On the View List tab, right-click a view category.

3 Click Properties.

4 In the dialog box that is displayed, click any field and enter the changes.

5 Click OK.

Standard toolbar

To create a custom property for a sheet set

1 In the Sheet Set Manager, open a sheet set.

2 On the Sheet List tab, right-click the sheet set node. Click Properties.

3 In the Sheet Set Properties dialog box, click the Edit Custom Properties
button.
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4 In the Custom Properties dialog box, do one of the following:

■ Click Add to create a new custom property for the sheet set. Click the
name and the default value to enter the information for these fields.
To assign this property to the sheet set, make sure that Sheet Set is
selected under Owner.

■ Click the name and the default value to change the information for
these fields.

■ Click a custom property from the list. Click Delete to remove the
property.

5 Click OK to close each dialog box.

Standard toolbar

To create a custom property for a sheet

1 In the Sheet Set Manager, open a sheet set.

2 On the Sheet List tab, right-click the sheet set node.

3 In the Sheet Set Properties dialog box, click the Edit Custom Properties
button.

4 In the Custom Properties dialog box, do one of the following:

■ Click Add to create a new custom property for the sheet. Click the
name and the default value to enter the information for these fields.
To assign this property to the sheet, make sure that Sheet is selected
under Owner.

■ Click the name and the default value to change the information for
these fields. With this method, you can change the value for every
sheet in the sheet set.

■ Click a custom property from the list. Click Delete to remove the
property.

5 Click OK to close each dialog box.

Standard toolbar
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Publish, Transmit, and Archive Sheet Sets
After you have organized drawings into a sheet set, you can publish, transmit,
and archive the sheet set as a package.

■ Publish a sheet set. Use the Publish feature to create single and
multiple-sheet Design Web Format™ (DWF™ ) files from a sheet set or
portion of a sheet set. Alternatively, you can plot the sheet set. For more
information, see “Publish a Sheet Set” on page 934. For information about
DWF files, see “Plot DWF Files” on page 913.

■ Set options for properties to include in a published DWF file. You
can decide what types of information to reveal in your published DWF files.
The types of metadata that you can include are sheet and sheet set
properties, block properties and attributes, dynamic block properties and
attributes, and properties contained in custom objects. Metadata is only
included when you publish to DWF; it is not available when plotting to
DWF.

■ Transmit a sheet set. Package and send a sheet set or a portion of a sheet
set over the Internet. For more information, see “Package a Set of Files for
Internet Transmission”.

■ Archive a sheet set. Package a sheet set or portion of a sheet set for storage.
This is very similar to packaging a transmittal set, except that you specify
a folder for the archive and you do not transmit the package. For more
information, see the ARCHIVE command.

Use Page Setups

Page setups provide the settings that are used for publishing and plotting.
When you create a sheet set, you specify a drawing template (DWT) file that
contains one or more page setups for all new sheets. This DWT file is called
the sheet creation template.

Another DWT file, called the page setup overrides file, contains page setups that
can be specified to override the page setups in each sheet. You specify the
page setup overrides file in the Sheet Set Properties dialog box.

When you publish a sheet set, you can use the page setups defined in each
drawing file, you can use the page setup overrides for all drawing files, or you
can publish to a DWF file. For more information about page setups, see “Use
Named Page Setups with Sheet Sets” on page 867.
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Save a Selection of Sheets

You can select part of a sheet set for publishing and transmitting. On the Sheet
List tab, you can select individual sheets using standard Microsoft® Windows®
selection methods—press CTRL or SHIFT when you click items. You can specify
all the sheets in a sheet subset by clicking the subset node.

You will likely need to perform operations on the same group of sheets in a
sheet set repeatedly. To speed up selecting the sheets and to ensure that the
same sheets are selected each time, you can use the Sheet Set Manager to
reselect groups of sheets by name. These named groups of sheets are called
sheet selections. You can create and manage sheet selections by using the Sheet
Selections button at the top of the Sheet List tab.

To save a sheet selection

1 In the Sheet Set Manager, open a sheet set.

2 On the Sheet List tab, click the sheets and subsets to include in the sheet
selection.

You can use CTRL or SHIFT to specify several items from the list.

3 In the Sheet List Manager, near the upper-right corner, click the Sheet
Selections button. Click Create.

4 In the New Sheet Selection dialog box, enter the name of the sheet
selection. Click OK.

Sheet Set Manager window

To restore a sheet selection

1 In the Sheet Set Manager, open a sheet set.

2 On the Sheet List tab, near the upper-right corner, click the Sheet
Selections button. Select the name of the sheet selection that you want
to restore.

The sheet selection is activated and available for publishing and
transmitting operations.

Sheet Set Manager window
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To rename or delete a sheet selection

1 In the Sheet Set Manager, open a sheet set.

2 On the Sheet List tab, near the upper-right corner, click the Sheet
Selections button. Click Manage.

3 In the Sheet Selections dialog box, select the name of a sheet selection
and do one of the following:

■ Click Rename to rename the sheet selection. Enter the new name for
the sheet selection.

■ Click Delete to remove the sheet selection name from the list. Click
Yes to confirm that you want to remove this sheet selection name.

4 Click OK.

Sheet Set Manager window

To modify an existing sheet selection

NOTE You cannot modify a sheet selection directly. Instead, you activate a sheet
selection and modify it, delete the name of the sheet selection, and then create a
new sheet selection in its place.

1 In the Sheet Set Manager, open a sheet set.

2 On the Sheet List tab, near the upper-right corner, click the Sheet
Selections button. Select the name of the sheet selection to modify.

3 Use the CTRL key to add and remove items from the sheet selection.

4 On the Sheet List Manager, near the upper-right corner, click the Sheet
Selections button. Click Manage.

5 Click Delete to remove the sheet selection name from the list. Click Yes
to confirm that you want to remove this sheet selection name.

6 Click OK to close the Sheet Selections dialog box.

7 On the Sheet List Manager, near the upper-right corner, click the Sheet
Selections button. Click Create.

8 In the New Sheet Selection dialog box, enter the name of the sheet
selection. Click OK.
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Sheet Set Manager window

To include layer, block, sheet set and sheet information in a published DWF
file

1 In the Sheet Set Manager, Sheet List tab, select the sheet set to publish
in a DWF file.

2 Click the Publish button. Click Sheet Set Publish Options.

3 In the Sheet Set Publish Options dialog box, under DWF Data Options,
depending on what you want to include in the published DWF file, click
any of the following to change the option to “Include.”

■ Layer information

■ Sheet set information (attributes you can choose to include are
description and custom properties)

■ Sheet information (attributes you can choose to include are sheet title,
sheet number, description, sheet set, subset, and sheet custom
properties)

■ Block information

NOTE Some sheet properties are always published in the DWF file (no
matter what setting you make in the Sheet Set Publish Options dialog
box). These are: sheet name, sheet size, author, creator, creation time,
and modification time.

4 Click OK.

Sheet Set Manager window

To use a block template file to include block properties and attributes in a
published DWF file

1 In the Sheet Set Manager, Sheet List tab, select the sheet set to publish
in a DWF file.

2 Click the Publish button. Click Sheet Set Publish Options.
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3 In the Sheet Set Publish Options dialog box, under DWF Data Options,
Block Information, click to display the drop-down list, and select
“Include.”

4 Under DWF Data Options, Block Template File, select the block template
file you want to use or create a new one. Click OK.

The block template file defining the blocks and their properties and
attributes will be included in the published DWF file.

Sheet Set Manager window

Use Sheet Sets in a Team
You can use sheet sets in a team that can involve network access, Internet
collaboration, and email transmittal. The team can also include people who
use software that does not include Sheet Set Manager.

Work in a Team That Uses Sheet Set Manager

When you use sheet sets in a team, each member should have network access
to the sheet set data (DST) file and the drawing template (DWT) files associated
with the sheet set. Each team member can open the sheet set to load the sheet
set information from the DST file into the Sheet Set Manager.

Any changes that any team member makes opens the DST file briefly and
updates the information stored in that file. When the DST file is opened, a
lock icon is displayed next to the sheet set name in the top left corner of the
Sheet Set Manager. A green dot in the lock icon indicates that the Sheet Set
Manager session on your computer has temporarily locked the DST file; a red
dot indicates that the Sheet Set Manager session on a team member’s computer
has temporarily locked the DST file. Other members of the team can
automatically see changes to the sheet set in the Sheet Set Manager tree view.

If each member of the team has access to the sheet set DWT files, new drawing
files and their sheets are created using the same drawing template file; page
setups for these drawings are also standardized.

NOTE If two or more users access the same sheet files through different logical
drives on a network, each will in turn be prompted to resave the sheet set using
their own logical drive. To avoid unnecessary saving, users should map the same
logical drives, if possible.
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Status data for sheets in the current sheet set is also available to other team
members. This status data is displayed in the tree view and indicates one of
the following conditions:

■ The sheet is available for editing (a normal sheet icon is displayed).

■ The sheet is locked (a lock icon is displayed).

■ The sheet is missing or found in an unexpected folder location (a ? icon is
displayed).

The active sheets of other team members are automatically polled for status
changes; the tree view is updated in your session of the Sheet Set Manager.
The polling cycle skips the poll interval in your session when a command is
active. To force a sheet status update, click Refresh Sheet Status on the Sheet
List tab.

You can click any sheet to display more information in the Details area of the
Sheet Set Manager.

NOTE A false lock icon may be displayed if there is a network problem or if the
program terminates unexpectedly. If you suspect a problem, click the sheet to
display more information.

Work in a Team That Does Not Use Sheet Set Manager

With some limitations, you can use sheets sets in a team with members who
do not have network access, or do not have access to the Sheet Set Manager.
These team members may be using AutoCAD LT or an older version of
AutoCAD. In those circumstances, not all members of the team will have
access to the DST file. However, relevant information from the DST file is
stored (cached) in each drawing file, and sheet set information, such as custom
properties, is preserved when the drawing file is shared by other team members.

After a member of the team changes information in the DST file, the
information in several drawing files might be stale and need to be updated.
With the sheet set open, update a sheet by opening and saving the sheet. You
can update all sheets in a sheet set automatically with the Resave All Sheets
option in the sheet set shortcut menu. All drawing files in the sheet set will
be saved to the current DWG file format. Drawing files saved in formats earlier
than the current DWG file format are updated to the current format regardless
of the SAVEAS setting.

NOTE In a network environment, make sure that all drawing files used in the
current sheet set that are opened by other users are closed before performing the
Resave All Sheets operation.
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To resave all sheets in a sheet set

1 In the Sheet Set Manager, open a sheet set.

2 On the Sheet List tab, right-click the sheet set node. Click Resave All
Sheets.

All sheets in the sheet set are resaved. This updates the sheet set
information that is stored in each drawing file.

Standard toolbar
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Control the Properties of
Objects

 

You can organize objects in your drawing and control how

they are displayed and plotted by changing their properties,

which include layer, linetype, color, lineweight, and plot

style.

Layers are like transparent overlays on which you organize

and group different kinds of drawing information. The objects

you create have common properties including colors,

linetypes, and lineweights. An object can assume these

properties from the layer it is drawn on, or properties can be

specifically assigned to individual objects. Color helps you

distinguish similar elements in your drawings, while linetypes

help you differentiate easily between different drafting

elements, such as centerlines or hidden lines. Lineweights

represent the size or type of an object through width,

enhancing your drawing and increasing legibility. Organizing

layers and the objects on layers makes it easier to manage the

information in your drawings.

17
In this chapter

■ Overview of Object Properties

■ Display and Change the
Properties of Objects

■ Copy Properties Between
Objects

■ Work with Layers

■ Work with Colors

■ Work with Linetypes

■ Control Lineweights

■ Control the Display Properties
of Certain Objects



Overview of Object Properties
Every object you draw has properties. Some properties are general and apply
to most objects; for example, layer, color, linetype, and plot style. Other
properties are object-specific; for example, the properties of a circle include
radius and area, and the properties of a line include length and angle.

Most general properties can be assigned to an object by layer or can be assigned
to an object directly.

■ When a property is set to the value BYLAYER, the object is assigned the
same value as the layer on which it is drawn.

For example, if a line drawn on Layer0 is assigned the color BYLAYER, and
Layer0 is assigned the color Red, the line is red.

■ When a property is set to a specific value, that value overrides the value
set for the layer.

For example, if a line drawn on Layer0 is assigned the color Blue, and Layer0
is assigned the color Red, the line is blue.

See also:

Control the Color and Linetype Properties in Blocks

Display and Change the Properties of Objects
You can display and change the current properties for any object in your
drawing in the following ways:

■ Open the Properties palette and view and change the settings for all
properties of the object.

■ View and change the settings in the Layer control on the Layers toolbar
and the Color, Linetype, Lineweight, and Plot Style controls on the
Properties toolbar.

■ Use  to view information in the text window.

■ Use the  command to display a coordinate location.
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Use the Properties Palette

The Properties palette lists the current settings for properties of the selected
object or set of objects. You can modify any property that can be changed by
specifying a new value.

■ When more than one object is selected, the Properties palette displays only
those properties common to all objects in the selection set.

■ When no objects are selected, the Properties palette displays only the general
properties of the current layer, the name of the plot style table attached to
the layer, the view properties, and information about the UCS.

You can double-click most objects to open the Properties palette when the
command is on (the default). The exceptions are blocks and attributes, hatches,
gradient fills, text, multilines, and xrefs. If you double-click any of these
objects, an object-specific dialog box displays instead of the Properties palette.

You can double-click most objects to open the Properties palette when the
command is on (the default). The exceptions are blocks and attributes, hatches,
text, and xrefs. If you double-click any of these objects, and object-specific
dialog box displays instead of the Properties palette.

NOTE The  command must be on and the  system variable must be on (set to
1, the default) for double-clicking to work.

See also:

Control the Color and Linetype Properties in Blocks
Filter Selection Sets

To turn Auto-hide on or off for a tool palette

■ On the tool palette title bar, click the Auto-hide button.

If this option is selected, only the tool palette title bar is displayed when
the cursor moves outside the tool palette. If this option is clear, the full
tool palette is displayed when the cursor moves.

NOTE This procedure applies to the Tool Palette, DesignCenter, the Properties
palette, and several other palettes.

To remove the description pane at the bottom of the Properties palette

1 On the title bar, click the Properties button.

2 On the shortcut menu, click Description to clear the check mark.
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To display the properties of a single object

1 Select the object.

2 Right-click in the drawing. Click Properties.

The Properties palette displays the properties of the selected object.

Alternatively, you can double-click almost any object to display the
Properties palette.

Standard toolbar

To list database information for several objects

1 Click Tools menu ➤ Inquiry ➤ List.

2 Select one or more objects and press  ENTER.

The text window displays a report.

Inquiry toolbar

To display the coordinate values of a point

1 Click Tools menu ➤ Inquiry ➤ ID Point.

2 Specify the point whose coordinate values you want to identify.

The X, Y, and Z values are displayed on the command line.

Inquiry toolbar

To change properties of objects in the Properties palette

1 Select one or more objects.

2 Right-click in the drawing. Click Properties.
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3 In the Properties palette, use the scroll bar next to the title bar to scroll
through the list of properties. You can click the arrow at the right of
each category to expand or collapse the list.

4 Select the value you want to change; use one of the following methods
to change the value:

■ Enter a new value.

■ Click the down arrow at the right and select a value from the list.

■ Click the Pick Point button to use the pointing device to change a
coordinate value.

■ Click the QuickCalc calculator button to calculate a new value.

■ Click the left or right arrow to increase or decrease the value.

■ Click the [...] button and change the property value in a dialog box.

Changes are applied immediately.

5 To undo a change, right-click an empty area in the Properties palette.
Click Undo.

6 Press ESC to remove selection.

Standard toolbar

Copy Properties Between Objects
You can copy some or all properties of one object to other objects using Match
Properties.

The types of properties that can be copied include, but are not limited to,
color, layer, linetype, linetype scale, lineweight, plot style, and 3D thickness.

By default, all applicable properties are automatically copied from the first
object you selected to the other objects. If you don't want a specific property
or properties to be copied, use the Settings option to suppress the copying of
that property. You can choose the Settings option at any time during the
command.
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To copy properties from one object to other objects

1 Click Standard Toolbar ➤ Match Properties.

2 Select the object whose properties you want to copy.

3 If you want to control which properties are transferred, enter s (Settings).
In the Property Settings dialog box, clear the items that you do not want
copied (all are on by default). Click OK.

4 Select the objects to which to apply the selected properties and press
ENTER .

Standard toolbar

Work with Layers
Layers are like transparent overlays on which you organize and group different
kinds of drawing information.

Overview of Layers

Layers are used to group information in a drawing by function and to enforce
linetype, color, and other standards.

Layers are the equivalent of the overlays used in paper-based drafting. Layers
are the primary organizational tool used in drawing. You use layers to group
information by function and to enforce linetype, color, and other standards.
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By creating layers, you can associate similar types of objects by assigning them
to the same layer. For example, you can put construction lines, text,
dimensions, and title blocks on separate layers. You can then control

■ Whether objects on a layer are visible in any viewports

■ Whether and how objects are plotted

■ What color is assigned to all objects on a layer

■ What default linetype and lineweight are assigned to all objects on a layer

■ Whether objects on a layer can be modified

Every drawing includes a layer named 0. Layer 0 cannot be deleted or renamed.
It has two purposes:

■ Ensure that every drawing includes at least one layer

■ Provide a special layer that relates to controlling colors in blocks

NOTE It is recommended that you create several new layers with which to organize
your drawing rather than create your entire drawing on layer 0.

Use Layers to Manage Complexity

You can use layers to control the visibility of objects and to assign properties
to objects. Layers can be locked to prevent objects from being modified.

You can reduce the visual complexity of a drawing and improve display
performance by controlling which objects are displayed or plotted. For
example, you can use layers to control the properties and visibility of similar
objects, such as electrical parts or dimensions. Also, you can lock a layer to
prevent objects on that layer from being accidentally selected and modified.
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Control the Visibility of Objects on a Layer

You can make drawing layers invisible either by turning them off or by freezing
them. Turning off or freezing layers is useful if you need an unobstructed view
when working in detail on a particular layer or set of layers or if you don't
want to plot details such as reference lines. Whether you choose to freeze
layers or turn them off depends on how you work and on the size of your
drawing.

■ On/Off . Objects on turned-off layers are invisible, but they still hide
objects when you use HIDE. When you switch layers on and off, the drawing
is not regenerated.

■ Freeze/Thaw. Objects on frozen layers are invisible and do not hide other
objects. Thawing one or more layers causes the drawing to be regenerated.
Freezing and thawing layers takes more time than turning layers on and
off.

In a layout (paper space), you can make some layers visible only in certain
viewports.

Assign a Default Color and Linetype to a Layer

Each layer has associated properties such as color and linetype that are assumed
by all objects on that layer. For example, if the Color control on the Properties
toolbar is set to BYLAYER, the color of new objects is determined by the color
setting for the layer in the Layer Properties Manager.

If you set a specific color in the Color control, that color is used for all new
objects, overriding the default color for the current layer. The same is true for
the Linetype, Lineweight, and Plot Style controls on the Properties toolbar.

The BYBLOCK setting should be used only for creating blocks. See Control
the Color and Linetype Properties in Blocks.

Control Whether Objects on a Layer Can Be Modified

When a layer is locked, none of the objects on that layer can be modified until
you unlock the layer. Locking layers reduces the possibility of modifying
objects accidentally. You can still apply object snaps to objects on a locked
layer and perform other operations that do not modify those objects.

To make a selected layer the current layer

1 On the Layers toolbar, click the Layer control.

2 Click the layer name that you want to use.
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To make the layer of a selected object the current layer

1 On the Layers toolbar, click Make Object’s Layer Current.

2 Select an object.

The layer of the object you selected is now the current layer.

Layers toolbar

or

To turn a layer on and off

1 On the Layers toolbar, click the Layer control.

2 Click the light bulb for the layer name that you want to turn on or off.

If the light bulb is yellow, the layer is turned on.

To assign a color to a layer

1 Click Format menu ➤ Layer.

2 In the Layer Properties Manager, select a layer. Click the color icon.

3 In the Select Color dialog box, select a color.

4 Click Apply to save your changes, or click OK to save and close.

Layers toolbar

To change the properties of more than one layer

1 Click Format menu ➤ Layer.

2 In the Layer Properties Manager list view, use one of the following
methods to select the layers:

■ Hold down  CTRL  and select layer names.

■ Right-click. Click Show Filters in Layer List to display a check mark,
and then select a layer filter.

3 Click the icons for the properties you want to change.
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4 Click Apply to save your changes, or click OK to save and close.

Layers toolbar

To hide the tree view in the Layer Properties Manager

■ Right-click in the list view. Clear the Show Filter Tree option.

To hide a column in the Layer Properties Manager

■ Drag the right column separator to the left until the column is hidden.

To show the column, drag the column separator to the right.

Create and Name Layers

By grouping objects into layers, you can control their display and make changes
quickly and efficiently.

You can create and name a layer for each conceptual grouping (such as walls
or dimensions) and assign common properties to those layers. By grouping
objects into layers, you can control their display and make changes quickly
and efficiently.

The number of layers you can create in a drawing and the number of objects
you can create per layer are virtually unlimited. Layers are usually dedicated
to each conceptual grouping (such as walls or dimensions). Layers can have
alphanumeric names up to 255 characters long. In many cases, the layer names
you choose are dictated by corporate, industry, or client standards.

The Layer Properties Manager sorts layers alphabetically by name. If you're
organizing your own layer scheme, name layers carefully. By using common
prefixes to name layers with related drawing components, you can use
wild-card characters in layer name filters when you need to find those layers
quickly.

NOTE If you consistently use a specific layering scheme, you can set up a drawing
template with layers, linetypes, and colors already assigned. For more information
about creating templates, see “Use a Template File to Start a Drawing” on page
105.
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Copy Layers from Another Drawing

You can use DesignCenter™  to copy layers from any drawing to another by
dragging. For example, you might have a drawing that contains all the standard
layers needed for a project. You can create a new drawing and use DesignCenter
to drag the predefined layers to the new drawing, which saves you time and
ensures consistency between drawings.

You can also drag layers or copy layers by double-clicking or by clicking Insert
on the shortcut menu.

NOTE You need to resolve duplicate layer names before you drag layers from
DesignCenter.

Select a Layer to Draw On

As you draw, newly created objects are placed on the current layer. The current
layer may be the default layer (0) or a layer you create and name yourself. You
switch from one layer to another by making a different layer current; any
subsequent objects you create are associated with the new current layer and
use its color, linetype, and other properties. You cannot make a layer the
current layer if it is frozen or if it is an xref-dependent layer.

Remove Layers

You can remove unused layers from your drawing with  or by deleting the
layer from the Layer Properties Manager. You can delete only unreferenced
layers. Referenced layers include layers 0 and DEFPOINTS, layers containing
objects (including objects in block definitions), the current layer, and
xref-dependent layers.

WARNING Be careful about deleting layers if you are working on a drawing in a
shared project or one based on a set of layering standards.

To create a new layer

1 Click Format menu ➤ Layer.

2 In the Layer Properties Manager, click the New Layer button.

A layer name, such as LAYER1, is automatically added to the layer list.

3 Enter a new layer name by typing over the highlighted layer name.

A layer name can include up to 255 characters: letters, digits, and the
special characters dollar sign ($), hyphen (-), and underscore (_). Use a
reverse quote (`) before other special characters so that the characters
are not interpreted as wild-card characters. Layer names cannot include
blank spaces.

Work with Layers | 273



4 To change the properties, click icons.

When you click Color, Linetype, Lineweight, or Plot Style, a dialog box
is displayed.

5 (Optional) Click in the Description column and enter text.

6 Click Apply to save your changes, or click OK to save and close.

Layers toolbar

To remove an unused layer

1 On the Layers toolbar, click Layer.

2 In the Layer Properties Manager, select the layer. Click the Delete Layer
button.

Layers that have objects assigned to them cannot be removed until those
objects are reassigned to a different layer or are deleted. Layers 0 and
DEFPOINTS and the current layer cannot be removed.

3 Click Apply to save your changes, or click OK to save and close.

The selected layer is removed.

Layers toolbar

To purge all unused layers

1 Click File menu ➤ Drawing Utilities ➤ Purge.

The Purge dialog box displays a tree view of object types with items that
can be purged (removed from the drawing).

2 To purge unreferenced layers, use one of the following methods:

■ To purge all unreferenced layers, select Layers.

■ To purge specific layers, double-click Layers to expand the tree view.
Select the layers to be purged.

3 If the item you want to purge is not listed, select View Items You Cannot
Purge, select the layer, and read the explanation.
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4 You are prompted to confirm each item in the list. If you do not want
to confirm each purge, clear the Confirm Each Item to Be Purged option.

5 Click Purge.

6 To confirm the purging of each item, respond to the prompt by choosing
Yes or No, or Yes to All if more than one item is selected.

7 Click Close.

Change Layer Settings and Layer Properties

You can change the name of a layer and any of its properties, including color
and linetype, and you can reassign objects from one layer to another.

Because everything in your drawing is associated with a layer, it’s likely that
in the course of planning and creating a drawing, you’ll need to change what
you place on a layer or how you view the layers in combination. You can

■ Reassign objects from one layer to another.

■ Change the name of a layer.

■ Change the default color, linetype, or other properties of the layer.

Reassigning an object to a different layer is useful if you create an object on
the wrong layer or decide to change your layer organization. Unless the color,
linetype, or other properties of the object have been set explicitly, an object
that you reassign to a different layer will acquire the properties of that layer.

You can change layer properties in the Layer Properties Manager and in the
Layer control on the Layers toolbar. Click the icons to change settings. Layer
names and colors can be changed only in the Layer Properties Manager, not
the Layer control.

Undo Changes to Layer Settings

You can use Layer Previous to undo changes you make to layer settings. For
example, if you freeze several layers and change some of the geometry in a
drawing, and then want to thaw the frozen layers, you can do this with a
single command without affecting the geometry changes. In another example,
if you changed the color and linetype of several layers but later decide you
prefer the old properties, you can use Layer Previous to undo the changes and
restore the original layer settings.

When you use Layer Previous, it undoes the most recent change or set of
changes made using either the Layer control or the Layer Properties Manager.
Every change you make to layer settings is tracked and can be undone with
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Layer Previous. You can use  to suspend layer property tracking when you
don’t need it, such as when you run large scripts. There is a modest
performance gain in turning off Layer Previous tracking.

Layer Previous does not undo the following changes:

■ Renamed layers. If you rename a layer and change its properties, Layer
Previous restores the original properties but not the original layer name.

■ Deleted layers. If you delete or purge a layer, using Layer Previous does
not restore it.

■ Added layers. If you add a new layer to a drawing, using Layer Previous
does not remove it.

To change the layer of one or more objects

1 Select the objects whose layer you want to change.

2 On the Layers toolbar, click the Layer control.

3 Select the layer that you want to assign to the objects.

4 Press  ESC  to remove selection.

Layers toolbar

To change the default linetype assigned to a layer

1 Click Format menu ➤ Layer.

2 In the Layer Properties Manager, select the linetype for the layer you
want to change.

3 In the Select Linetype dialog box, if the linetype you need is not
displayed, click Load and use one of the following methods:

■ In the Load or Reload Linetypes dialog box, select one or more
linetypes to load. Click OK to return to the Select Linetype dialog box.

■ In the Load or Reload Linetypes dialog box, click File to open
additional linetype definition (LIN) files. Select one or more linetypes
to load. Click OK to return to the Select Linetype dialog box.

4 Select the linetype you want to us. Click OK to return to the Layer
Properties Manager.
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5 Click Apply to save your changes, or click OK to save and close.

Layers toolbar

To rename a layer

1 Click Format menu ➤ Layer.

2 In the Layer Properties Manager, select a layer. Click the name or press
F2 .

3 Enter a new name.

4 Click Apply to save your changes, or click OK to save and close.

Layers toolbar

To rename more than one layer

1 On the command line, enter rename.

2 In the Rename dialog box, in the Named Objects list, select Layers.

3 In Old Name, enter the old name, using wild-card characters; for example,
enter stairs$*.

4 In Rename To, enter the new name using wild-card characters; for
example, enter s_*.

Results for this example are as follows: the layers STAIR$LEVEL-1,
STAIR$LEVEL-2, STAIR$LEVEL-3 are renamed S_LEVEL-1, S_LEVEL-2,
S_LEVEL-3.

5 Click Rename To to apply changes and continue, or click OK.

To undo changes to layer settings

■ On the Layers toolbar, click Layer Previous.

The command line displays the message “Restored previous layer status.”
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NOTE LAYERP does not restore deleted or purged layers and does not remove a
layer that was added. If you rename a layer and change its properties, Layer
Previous restores the original properties but not the original layer name.

Layers toolbar

To set Layer Previous tracking on or off

1 At the Command prompt, enter layerpmode.

The current Layer Previous tracking status is displayed.

2 Enter on to turn on Layer Previous tracking of layer settings, or enter
off to turn off tracking.

Filter and Sort the List of Layers

You can control which layer names are listed in the Layer Properties Manager
and sort them by name or by property, such as color or visibility.

A layer filter limits the display of layer names in the Layer Properties Manager
and in the Layer control on the Layers toolbar. In a large drawing, you can
use layer filters to display only the layers you need to work with.

There are two kinds of layer filters:

■ Layer property filters: Includes layers that have names or other
properties in common. For example, you can define a filter that includes
all layers that are red and whose names include the letters mech.

■ Layer group filters: Includes the layers that are put into the filter when
you define it, regardless of their names or properties.

The tree view in the Layer Properties Manager displays default layer filters and
any named filters that you create and save in the current drawing. The icon
next to a layer filter indicates the type of filter. Three default filters are
displayed:

■ All. Displays all the layers in the current drawing.

■ All Used. Displays all the layers on which objects in the current drawing
are drawn.
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■ Xref. If xrefs are attached to the drawing, displays all the layers being
referenced from other drawings.

Once you have named and defined a layer filter, you can select it in the tree
view to display the layers in the list view. You can also apply the filter to the
the Layers toolbar, so that the Layer control displays only the layers in the
current filter.

When you select a filter in the tree view and right-click, options on the shortcut
menu can be used to delete, rename, or modify filters. For example, you can
convert a layer property filter to a layer group filter. You can also change a
property of all layers in a filter. The Isolate Group option turns off all layers
in the drawing that are not in the selected filter.

Define a Layer Property Filter

A layer property filter is defined in the Layer Filter Properties dialog box, where
you select any of the following properties you want to include in the filter
definition:

■ Layer names, colors, linetypes, lineweights, and plot styles

■ Whether layers are in use

■ Whether layers are turned on or off

■ Whether layers are frozen or thawed in the current viewport or all viewports

■ Whether layers are locked or unlocked

■ Whether layers are set to be plotted

You use wild-card characters to filter layers by name. For example, if you want
to display only layers that start with the letters mech, you can enter mech*.
See “Wild-Card Characters” for a complete list.

The layers in a layer property filter may change as the properties of the layers
change. For example, if you define a layer property filter named Site that
includes all layers with the letters site in the name and a CONTINUOUS
linetype, and then you change the linetype of some of those layers, the layers
with the new linetype are no longer part of the Site filter and are not displayed
when you apply that filter.

Layer property filters can be nested under other properties filters or under
group filters.
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Define a Layer Group Filter

A layer group filter includes only those layers that you explicitly assign to it.
If the properties of the layers assigned to the filter change, the layers are still
part of the filter. Layer group filters can be nested only under other layer group
filters.

Invert a Layer Filter

You can also invert a layer filter. For example, if all the site plan information
in a drawing is contained in multiple layers that include the word site as part
of the layer name, you can display all information except site plan information
by first creating a filter definition that filters layers by name (*site*) and then
using the Invert Filter option.

Sort Layers

Once you have created layers, you can sort them by name or other properties.
In the Layer Properties Manager, click the column heading to sort layers by
the property in that column. Layer names can be sorted in ascending or
descending alphabetical order.

Wild-Card Characters

You can use wild-card characters to sort layers by name.

DefinitionCharacter

Matches any numeric digit# (Pound)

Matches any alphabetic character@ (At)

Matches any nonalphanumeric character. (Period)

Matches any string and can be used anywhere in the search
string

* (Asterisk)

Matches any single character; for example, ?BC matches ABC,
3BC, and so on

? (Question mark)

Matches anything but the pattern; for example; ~*AB*matches
all strings that don't contain AB

~ (Tilde)

Matches any one of the characters enclosed; for example, [AB]C
matches AC and BC

[ ]

Matches any character not enclosed; for example, [~AB]C
matches XC but not AC

[~]

Specifies a range for a single character; for example, [A-G]C
matches AC, BC, and so on to GC, but not HC

[-]
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DefinitionCharacter

Reads the next character literally; for example, `~AB matches
~AB

` (Reverse quote)

NOTE If you want to use a wild-card character in the name of a named object,
precede the character with a reverse quote (`) so that it is not interpreted as a
wild-card character.

To quickly filter the display of layers by name

1 Click Format menu ➤ Layer.

2 In the Layer Properties Manager, click in Search for Layer below the tree
view.

3 (Optional) To limit your search, select a layer filter in the tree view.

4 Enter a string of characters, including wild-card characters.

The list view displays all layers whose names match the string. For
example, if you enter *mech*, all layers with the letters mech in their
names are displayed.

This quick filter is discarded when the Layer Properties Manager closes.

To filter the display of layers by layer property

1 Click Format menu ➤ Layer.

2 In the Layer Properties Manager, click the New Property Filter button.

3 In the Layer Filter Properties dialog box, enter a name for the filter.

4 Under Filter Definition, set the layer properties that you want to use to
define the filter.

■ To filter by name, use wild-card characters.

■ To filter by property, click in the column for the property you want.

Some properties display a dialog box when you click the [...] button.

■ To select more than one value for a property, right-click the row in
the filter definition. Click Duplicate Row. Select another value for that
property in the next row.

For example, the definition for a filter that displays only layers that
are on and are either yellow or red has two rows. The first row of the
filter definition has the On icon and red. The second row has the On
icon and yellow.
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5 Click Apply to save your changes, or click OK to save and close.

Layers toolbar

To filter the display of layer names by selecting layers

1 On the Layers toolbar, click Layer Properties Manager.

2 In the Layer Properties Manager, click the New Group Filter button.

A new layer group filter named GROUP FILTER1 is created in the tree
view.

3 Enter a name for the filter.

4 In the tree view, click All or one of the other nodes to display layers in
the list view.

5 In the list view, select the layers you want to add to the filter, and drag
them to the filter name in the tree view.

6 Click Apply to save your changes, or click OK to save and close.

Layers toolbar

To nest a layer filter under another layer filter

1 On the Layers toolbar, click Layer Properties Manager.

2 In the Layer Properties Manager tree view, select a layer filter.

■ A new layer property filter can be nested under a group filter or
another property filter.

■ A new layer group filter can be nested only under another group filter.

3 Right-click. Click New Properties Filter or New Group Filter.

4 Use one of the following methods:

■ For a new property filter, the Layer Properties Filter dialog box is
displayed. Under Filter Definition, set the layer properties that you
want to use to define the filter. Click OK.
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■ For a new group filter, a filter is added to the tree view. Rename it,
select the parent filter to display its layers in the list view, and drag
layers from the list view to the new layer group filter.

5 Click Apply to save your changes, or click OK to save and close.

Layers toolbar

To sort the layer list in the Layer Properties Manager

■ Click any column heading.

To reverse the sorting order, click a second time.

Layers toolbar

To remove a layer from a layer group filter

1 On the Layers toolbar, click Layer Properties Manager.

2 In the Layer Properties Manager tree view, select a group filter.

3 Select the layer you want to remove.

4 Right-click in the list view. Click Remove from Group Filter.

Layers toolbar

Save and Restore Layer Settings

You can save the current layer settings in a drawing as a named layer state
and restore them later. Saving layer settings is convenient if you need to return
to particular settings for all layers during different stages in completing a
drawing or for plotting.
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Save Layer Settings

Layer settings include layer states, such as on or locked, and layer properties,
such as color or linetype. In a named layer state, you can choose which layer
states and layer properties you want to restore later. For example, you can
choose to restore only the Frozen/Thawed setting of the layers in a drawing,
ignoring all other settings. When you restore that named layer state, all settings
remain as they are currently set except whether each layer is frozen or thawed.

Using the Layer States Manager, you can export named layer states to an LAS
file for use in other drawings. The layer states of external references cannot
be exported.

Restore Layer Settings

When you restore a named layer state, the layer settings (layer states and layer
properties) that were specified when the layer state was saved are restored by
default. Because all the layer settings are saved in the named layer state, you
can specify different settings at the time you restore. All layer settings that are
not selected to be restored remain unchanged.

In addition, the layer that was current when the named layer state was saved
is made current. If that layer no longer exists, the current layer does not
change.

In addition to restoring named layer states, you can import named layer states
that were previously exported to LAS files.

To save layer settings in a named layer state

1 Click Format menu ➤ Layer.

2 In the Layer Properties Manager, click the Layer States Manager button.

3 In the Layer States Manager, click New.

4 In the New Layer State to Save dialog box, enter a name for the new layer
state, or select a name from the list.

5 (Optional) Add a description.

6 Click OK.

7 In the Layer States Manager, select the layer settings to restore by default.

8 (Optional) Select the Turn Off New Layers Not Found in Layer State
option.

When this option is selected and you restore a named layer state, the
drawing looks the same way it did when the named layer state was saved.
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9 Click Close to exit the Layer States Manager. Click OK to exit the Layer
Properties Manager.

Layers toolbar

To export saved layer settings

1 Click Format menu ➤ Layer.

2 In the Layer Properties Manager, click the Layer States Manager button.

3 In the Layer States Manager, select a named layer state. Click Export.

4 In the Export Layer State dialog box, enter a file name. Specify a location
for the layer state (LAS) file.

The .las file name extension is added automatically.

5 Click Save to exit the dialog box.

6 Click Close to exit the Layer States Manager. Click OK to exit the Layer
Properties Manager.

Layers toolbar

To restore layer settings

1 Click Format menu ➤ Layer.

2 In the Layer Properties Manager, click the Layer States Manager button.

3 In the Layer States Manager, select a named layer state.

4 Select the settings to restore. Click Restore.

The Layer States Manager closes.

5 Click OK.

Layers toolbar
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To modify a named layer state

1 Click Format menu ➤ Layer.

2 In the Layer Properties Manager, click the Layer States Manager button.

3 In the Layer States Manager, select the named layer state that you want
to edit, rename, or delete.

4 Use one of the following methods:

■ To rename the named layer state, click the name and enter a new
name.

■ To edit the description, click the description and enter new text.

■ To delete the saved layer state, click Delete.

■ To change which layer settings to restore by default, select or clear
layer settings.

5 Click Close to exit the Layer States Manager. Click OK to exit the Layer
Properties Manager.

Layers toolbar

To import saved layer settings from another drawing

1 Click Format menu ➤ Layer.

2 In the Layer Properties Manager, click the Layer States Manager button.

3 In the Layer States Manager, click Import.

4 In the Import Layer State dialog box, select a file name with an .las file
name extension. Click Open.

5 Click Yes to restore the named layer state now. Click No to add it to the
Layer States Manager without restoring it.

If you restore the named layer state, the Layer States Manager closes.

6 Click Close to exit the Layer States Manager. Click OK to exit the Layer
Properties Manager.

Layers toolbar
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Work with Colors
Color helps to group objects visually. You can assign colors to object by layer
or individually.

Set the Current Color

You can use color to help you identify objects visually. You can assign the
color of an object either by layer or by specifying its color explicitly,
independent of layer.

You can assign the color of an object either by layer or by specifying its color
explicitly, independent of layer. Assigning colors by layer makes it easy to
identify each layer within your drawing. Assigning colors explicitly provides
additional distinctions between objects on the same layer. Color is also used
as a way to indicate lineweight for color-dependent plotting.

You can use a variety of color palettes when assigning color to objects,
including

■ AutoCAD Color Index (ACI)

■ True Color® , PANTONE®

■ RAL™ Classic and RAL Design color books

■ DIC®  Color Guide

■ Colors from imported color books.

ACI Colors

ACI colors are the standard colors used in AutoCAD. Each color is identified
by an ACI number, an integer from 1 through 255. Standard color names are
available only for colors 1 through 7. The colors are assigned as follows: 1 Red,
2 Yellow, 3 Green, 4 Cyan, 5 Blue, 6 Magenta, 7 White/Black.

True Colors

True colors use 24-bit color definitions to display over 16 million colors. When
specifying true colors, you can use either an RGB or HSL color model. With
the RGB color model, you can specify the red, green, and blue components
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of the color; with the HSL color model, you can specify the hue, saturation,
and luminance aspects of the color.

Color Books

This program includes several standard Pantone color books. You can also
import other color books such as the DIC color guide or RAL color sets.
Importing user-defined color books can further expand your available color
selections.

NOTE Pantone has provided new color definitions for Architectural & Interiors
Cotton and Architectural & Interiors Paper color books. If you used these color
books in releases prior to AutoCAD 2006, you may notice subtle changes in the
colors.

You install color books on your system by using the Files tab in the Options
dialog box. Once a color book is loaded, you can select colors from the color
book and apply them to objects in your drawings.

All objects are created using the current color, which is displayed in the Color
control on the Properties toolbar. You can also set the current color with the
Color control or the Select Color dialog box.

If the current color is set to BYLAYER, objects are created with the color
assigned to the current layer. If you do not want the current color to be the
color assigned to the current layer, you can specify a different color.

If the current color is set to BYBLOCK, objects are created using color 7 (white
or black) until the objects are grouped into a block. When the block is inserted
into the drawing, it acquires the current color setting.

To set an ACI color for all new objects

1 On the Properties toolbar, click the Color control.

2 Click a color to draw all new objects in that color, or click Select Color
to display the Select Color dialog box and do one of the following:

■ On the Index Color tab, click a color or enter the color name or
number in the Color box.

■ On the Index Color tab, click BYLAYER to draw new objects in the
color assigned to the current layer.

■ On the Index Color tab, click BYBLOCK to draw new objects in the
current color until they are grouped into a block. When the block is
inserted into the drawing, the objects in the block acquire the current
color setting.

288 | Chapter 22   Control the Properties of Objects



3 Click OK.

The Color control displays the current color.

To set a true color for all new objects

1 On the Properties toolbar, click the Color control.

2 Click Select Color to display the Select Color dialog box.

3 In the Select Color dialog box, True Color tab, do one of the following:

■ Select the HSL color model in the Color Model box. Specify a color
by entering a color value in the Color box or by specifying values in
the Hue, Saturation, and Luminance boxes.

■ Select the RGB color model in the Color Model box. Specify a color
by entering a color value in the Color box or by specifying values in
the Red, Green, and Blue boxes.

4 Click OK.

The Color control displays the current color.

To set a color from a color book for all new objects

1 On the Properties toolbar, click the Color control.

2 Click Select Color.

3 In the Select Color dialog box, Color Book tab, select a color book from
the Color Book box.

4 Select a color by clicking on a color chip. To browse through the color
book, use the up and down arrows on the color slider.

5 Click OK.

The Color control displays the current color.

Change the Color of an Object

You can change the color of an object by reassigning it to another layer, by
changing the color of the layer the object is on, or by specifying a color for
the object explicitly.
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You have three choices for changing the color of an object:

■ Reassign the object to another layer with a different color. If an object's
color is set to BYLAYER, and you reassign the object to a different layer, it
acquires its color from the new layer.

■ Change the color assigned to the layer that the object is on. If an object's
color is set to BYLAYER, it acquires the color of its layer. When you change
the color assigned to a layer, all objects on that layer assigned the BYLAYER
color are updated automatically.

■ Specify a color for an object to override the layer's color. You can specify
the color of each object explicitly. If you want to override the
layer-determined color of an object with a different one, change an existing
object's color from BYLAYER to a specific color, such as red, or a true color.

If you want to set a specific color for all subsequently created objects, change
the current color setting on the Properties toolbar from BYLAYER to a specific
color.

To change the layer of an object

1 Select the objects whose layer you want to change.

2 On the Layers toolbar, click the Layer control.

3 Select the layer that you want to assign to the objects.

Layers toolbar

To change the color assigned to a layer

1 On the Layers toolbar, click the Layer Properties Manager button.

2 In the Layer Properties Manager, click the color you want to change.

3 In the Select Color dialog box, do one of the following:

■ On the Index tab, click a color or enter the ACI color number (1-255)
or name in the Color box. Click OK.

■ On the True Color tab, select the HSL color model in the Color Model
option and specify a color by entering a color value in the Color box
or by specifying values in the Hue, Saturation, and Luminance boxes.
Click OK.
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■ On the Color Books tab, select a color book from the Color Book box,
select a color by navigating the color book (using the up and down
arrows) and clicking on a color chip. Click OK.

4 Click OK to close each dialog box.

Layers toolbar

To change the color of objects, overriding the layer's color

1 Select the objects whose color you want to change.

2 Right-click one of the objects. Click Properties.

3 In the Properties palette, select Color.

An arrow is displayed in the right column.

4 Click the arrow and select a color from the list or click Select Color to
display the Select Color dialog box. If you click Select Color, do one of
the following:

■ On the Index tab, click a color or enter the ACI color number (1-255)
or name in the Color box.

■ On the True Color tab, select the HSL color model in the Color Model
option and specify a color by entering a color value in the Color box
or by specifying values in the Hue, Saturation, and Luminance boxes.
Click OK.

■ On the True Color tab, select the RGB color model in the Color Model
box. Specify a color by entering a color value in the Color box or by
specifying values in the Red, Green, and Blue boxes.

■ On the Color Books tab, select a color book from the Color Book box,
select a color by navigating the color book (using the up and down
arrows) and clicking on a color chip. Click OK.

Use Color Books

When assigning colors to objects, you can choose colors from color books
that are loaded on your system. You can choose from a wide range of custom
colors when using color books. Color books include third-party or user-defined
files that contain named color swatches. These colors can be used to enhance
presentation drawings as well as to optimize the variety of color used in your
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drawings. You can apply color book colors to objects in your drawings by
using the Color Books tab in the Select Color dialog box.

Install Color Books

Color book files must contain an .acb file extension in order to be recognized
by this program. To access color book colors from the Select Color dialog box,
you must first copy your color book files to a specified color book location.
On the Files tab of the Options dialog box, you can define the path where
color book files are stored. Multiple locations can be defined for the color
book path. These locations are saved in your user profile.

After loading a color book on your system, to access the new colors, you need
to close the Select Color dialog box and then open it again. The new color
book is displayed in the Color Book drop-down list on the Color Books tab.
Once you have loaded a color book, you can apply any colors that are defined
in the book to objects in your drawing.

Browse Color Books

Color books are organized alphabetically into pages that you can browse
through. A page holds up to ten colors. If the color book you are browsing
through is not organized into pages, the colors are arranged into pages, with
each page containing up to seven colors.

To install a color book

1 Click Tools menu ➤ Options.

2 In the Options dialog box, Files tab, click Color Book Locations.

3 Click Add to add a color book location.

4 Enter the new location in the blank path box.

5 Click OK.

To search for color swatches within a color book

1 Click Format menu ➤ Color.

2 In the Color dialog box, Color Books tab, select a color book from the
Color Book drop-down list.

You must first select any color swatch in the color book in order to
activate the Color edit box.

3 Under Color, enter the number of the color swatch you would like to
locate and press TAB.
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The Color edit box and the New color chip display the requested color
or the color that is the closest match.

4 Click OK to apply the color.

To change the default location of color book files

1 Click Tools menu ➤ Options.

2 In the Options dialog box, Files tab, double-click Color Book Locations.

3 Select the following default color book location:

C:\Program Files\[current AutoCAD release number]\support\color

4 Click the location name to edit the path.

5 Enter the new location in the path box.

6 Click OK.

To define multiple folders for the color book path

1 Click Tools menu ➤ Options.

2 In the Options dialog box, Files tab, click Color Book Locations.

3 Click Add to add a color book location.

4 Enter the new location in the blank path box.

5 Click OK.

Work with Linetypes
You can use linetypes to distinguish objects from one another visually and
make your drawing easier to read.

Overview of Linetypes

A linetype is a repeating pattern of dashes, dots, and blank spaces displayed
in a line or a curve. You assign linetypes to objects either by layer or by
specifying the linetype explicitly, independent of layers.

In addition to choosing a linetype, you can set its scale to control the size of
the dashes and spaces, and you can create your own custom linetypes.

NOTE These linetypes should not be confused with the hardware linetypes
provided by some plotters. The two types of dashed lines produce similar results.
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Do not use both types at the same time, however, because the results can be
unpredictable.

See also:

“Custom Linetypes” in the Customization Guide

Load Linetypes

At the start of a project, you load the linetypes that are required for the project
so that they are available when you need them.

If you want to know what linetypes are already available, you can display a
list of linetypes that are loaded in the drawing or stored in an LIN (linetype
definition) file.

This program includes the linetype definition files acad.lin and acadiso.lin.
Which linetype file is appropriate depends on whether you use imperial or
metric measurements.

■ For imperial units, use the acad.lin file.

■ For metric measurements, use the acadiso.lin file.

Both linetype definition files contain several complex linetypes.

If you select a linetype whose name begins with ACAD_ISO, you can use the
ISO pen-width option when you plot.

You can remove unreferenced linetype information with  or by deleting the
linetype from the Linetype Manager. BYBLOCK, BYLAYER, and CONTINUOUS
linetypes cannot be removed.

To load a linetype

1 Click Format menu ➤ Linetype.

2 In the Linetype Manager, click Load.

3 In the Load or Reload Linetypes dialog box, select a linetype. Click OK.

If the linetype you need is not listed, click File. In the Select Linetype
File dialog box, select an LIN file whose linetypes you want to list and
click. The dialog box displays the linetype definitions stored in the
selected LIN file. Select a linetype. Click OK.

You can hold down  CTRL  to select several linetypes or  SHIFT  to select
a range of linetypes.

4 Click OK.
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To list the linetypes loaded in the current drawing

1 On the Properties toolbar, click the Linetype control.

All loaded linetypes are displayed in the list. If necessary, use the scroll
bar to see the whole list.

2 Click anywhere outside the box to close it.

To list the linetypes in a linetype definition file

1 Click Format menu ➤ Linetype.

2 In the Linetype Manager, click Load.

3 In the Load or Reload Linetypes dialog box, click File.

4 In the Select Linetype File dialog box, select an LIN (linetype definition)
file whose linetypes you want to lit. Click Open.

The dialog box displays the linetype definitions stored in the selected
LIN file.

5 In the Load or Reload Linetypes dialog box, click Cancel.

6 Click Cancel to close the Linetype Manager.

To unload an unused linetype

1 Click Format menu ➤ Linetype.

2 In the Linetype Manager, select a linetype. Click Delete.

The selected linetype is unloaded. Certain linetypes cannot be unloaded:
BYLAYER, BYBLOCK, CONTINUOUS, and any linetypes currently in use.

To purge an unused linetype

1 Click File menu ➤ Drawing Utilities ➤ Purge.

The Purge dialog box displays a tree view of object types with items that
can be purged.

2 To purge unreferenced linetypes, use one of the following methods:

■ To purge all unreferenced linetypes, select Linetypes.

■ To purge specific linetypes, double-click Linetypes to expand the tree
view. Then select the linetypes to be purged.

If the item you want to purge is not listed, select View Items You Cannot
Purge.
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3 You are prompted to confirm each item in the list. If you do not want
to confirm each purge, clear the Confirm Each Item to Be Purged option.

4 Click Purge.

To confirm the purging of each item, respond to the prompt by choosing
Yes or No, or Yes to All if more than one item is selected.

5 Click Close.

Set the Current Linetype

All objects are created using the current linetype, which is displayed in the
Linetype control on the Properties toolbar.

You can also set the current linetype with the Linetype control.

If the current linetype is set to BYLAYER, objects are created with the linetype
assigned to the current layer.

If the current linetype is set to BYBLOCK, objects are created using the
CONTINUOUS linetype until the objects are grouped into a block. When the
block is inserted into the drawing, those objects acquire the current linetype
setting.

If you do not want the current linetype to be the linetype assigned to the
current layer, you can specify a different linetype explicitly.

The program does not display the linetype of certain objects: text, points,
viewports, hatches, and blocks.

To set the linetype for all new objects

1 Click Format menu ➤ Linetype.

2 If you need to load additional linetypes, click Load, select one or more
linetype. Click OK.

You can hold down  CTRL  to select several linetypes or  SHIFT  to select
a range of linetypes.

3 In the Linetype Manager, do one of the following:

■ Select a linetype and select Current to draw all new objects with that
linetype.

■ Select BYLAYER to draw new objects in the linetype assigned to the
current layer.
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■ Select BYBLOCK to draw new objects in the current linetype until
they are grouped into a block. When the block is inserted into a
drawing, the objects in the block acquire the current linetype setting.

4 Click OK.

NOTE The Linetype control displays the current linetype. If the linetype you want
to use is already loaded, you can click the Linetype control and click the linetype
to make it current.

To change the linetype assigned to a layer

1 On the Layers toolbar, click the Layer Properties Manager button.

2 In the Layer Properties Manager, select the linetype name you want to
change.

3 In the Select Linetype dialog box, select the linetype you want. Click
OK.

4 Click OK again.

Layers toolbar

Change the Linetype of an Object

You can change the linetype of an object by reassigning it to another layer,
by changing the linetype of the layer the object is on, or by specifying a
linetype for the object explicitly.

You have three choices for changing the linetype of an object:

■ Reassign the object to another layer with a different linetype. If an object's
linetype is set to BYLAYER, and you reassign the object to a different layer,
it acquires its linetype from the new layer.

■ Change the linetype assigned to the layer that the object is on. If an object's
linetype is set to BYLAYER, it acquires the linetype of its layer. When you
change the linetype assigned to a layer, all objects on that layer assigned
the BYLAYER linetype are updated automatically.

■ Specify a linetype for an object to override the layer's linetype. You can
specify the linetype of each object explicitly. If you want to override the
layer-determined linetype of an object with a different one, change an
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existing object's linetype from BYLAYER to a specific linetype, such as
DASHED.

If you want to set a specific linetype for all subsequently created objects,
change the current linetype setting on the Properties toolbar from BYLAYER
to a specific linetype.

object selected result-continuous linetype
changed to center

To change the layer of an object

1 Select the objects whose layer you want to change.

2 On the Layers toolbar, click the Layer control.

3 Select the layer that you want to assign to the objects.

Layers toolbar

To change the default linetype assigned to a layer

1 On the Layers toolbar, click the Layer Properties Manager button.

2 In the Layer Properties Manager, select the linetype name you want to
change.

3 In the Select Linetype dialog box, select a linetype.

If the linetype you need is not listed, click Load. Select a linetype and
click OK, or click File to open additional linetype definition (LIN) files.

4 Click OK to exit each dialog box.

Layers toolbar
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To change the linetype of an object, overriding the layer's linetype

1 Select the objects whose linetype you want to change.

2 On the Properties toolbar, click the Linetype control.

3 Choose the linetype that you want to assign to the objects.

Control Linetype Scale

You can use the same linetype at different scales by changing the linetype
scale factor either globally or individually for each object.

By default, both global and individual linetype scales are set to 1.0. The smaller
the scale, the more repetitions of the pattern are generated per drawing unit.
For example, with a setting of 0.5, two repetitions of the pattern in the linetype
definition are displayed for each drawing unit. Short line segments that cannot
display one full linetype pattern are displayed as continuous. You can use a
smaller linetype scale for lines that are too short to display even one dash
sequence.

The Linetype Manager displays the Global Scale Factor and Current Object
Scale.

■ The Global Scale Factor value controls the  system variable, which changes
the linetype scale globally for both new and existing objects.

■ The Current Object Scale value controls the  system variable, which sets
the linetype scale for new objects.

The CELTSCALE value is multiplied by the LTSCALE value to get the displayed
linetype scale. You can easily change linetype scales in your drawing either
individually or globally.

In a layout, you can adjust the scaling of linetypes in different viewports with
.

To change the linetype scale of selected objects

1 Select the objects whose linetype scale you want to change.

2 Right-click one of the objects. Click Properties.

3 In the Properties palette, select Linetype Scale and enter the new value.

Standard toolbar
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To set the linetype scale for new objects

1 Click Format menu ➤ Linetype.

2 In the Linetype Manager, click Show Details to expand the dialog box.

3 Enter a new value for Current Object Scale.

4 Click OK.

To change linetype scale globally

1 Click Format menu ➤ Linetype.

2 In the Linetype Manager, click Show Details to expand the dialog box.

3 Enter a new value for Global Scale Factor.

4 Click OK.

Display Linetypes on Short Segments and Polylines

You can center the pattern of a linetype on each segment of a polyline, and
you can control how the linetype is displayed on short segments.

If a line is too short to hold even one dash sequence, the result is a continuous
line between the endpoints, as shown below.

You can accommodate short segments by using a smaller value for their
individual linetype scales. For more information, see “Control Linetype Scale”
on page 299.

For polylines, you can specify whether a linetype pattern is centered on each
segment or is continuous across vertices throughout the entire length of the
polyline. You do this by setting the  system variable.
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PLINEGEN = 0 PLINEGEN = 1

linetype centered on each 2D
polyline segment

linetype continuous throughout the
2D polyline

To set the linetype display for all new polylines

1 At the Command prompt, enter plinegen.

2 Enter 1 to make the linetype pattern continue throughout the entire
length of two-dimensional polylines, or enter 0 to center the linetype
pattern on each segment.

To change the linetype display of existing polylines

1 Double-click the polyline whose linetype display you want to change.

2 In the Properties palette, click Linetype Generation and select Enabled
or Disabled.

Standard toolbar

Control Lineweights
You can further differentiate objects in your drawing by controlling their
lineweights both in the drawing display and in plotting.

Overview of Lineweights

Using lineweights, you can create heavy and thin lines to show cuts in sections,
depth in elevations, dimension lines and tick marks, and differences in details.
For example, by assigning varying lineweights to different layers, you can
easily differentiate between new, existing, and demolition construction.
Lineweights are not displayed unless the Lwt button on the status bar is
selected.
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All objects except TrueType fonts, raster images, points, and solid fills (2D
solids) can display lineweight. In a plan view, wide polylines override any
width value applied by a lineweight. Wide polylines display lineweights only
when the polyline is being viewed in a view other than Plan. You can export
drawings to other applications or cut objects to the Clipboard and retain
lineweight information.

In model space, lineweights are displayed in pixels and do not change when
zoomed in or out. Thus, you should not use lineweights to represent the exact
width of an object in model space. For example, if you want to draw an object
with a real-world width of 0.5 inches, do not use a lineweight; instead, use a
polyline with a width of 0.5 inches to represent the object.

You can also plot objects in your drawing with custom lineweight values. Use
the Plot Style Table Editor to adjust the fixed lineweight values to plot at a
new value.

Lineweight Scale in Drawings

Objects with a lineweight are plotted with the exact width of the assigned
lineweight value. The standard settings for these values include BYLAYER,
BYBLOCK, and Default. They are displayed in either inches or millimeters,
with millimeters being the default. All layers are initially set to 0.25 mm,
controlled by the  system variable.

A lineweight value of 0.025 mm or less is displayed as one pixel in model
space and is plotted at the thinnest lineweight available on the specified
plotting device. Lineweight values that you enter on the command line are
rounded to the nearest predefined value.

You set the lineweight units and the default value in the Lineweight Settings
dialog box. You can access the Lineweight Settings dialog box by using the
command, by right-clicking the Lwt button on the status bar and choosing
Settings, or by choosing Lineweight Settings on the Display tab in the Options
dialog box.

See also:

“Draw Polylines” on page 391

To assign width to polylines

1 Click Draw menu ➤ Polyline.

2 Specify the start point for the first segment in the polyline.

3 Enter w (width).

4 Enter a value for the width at the start of the line segment.

5 Enter a value for the width at the end of the line segment.
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6 Specify the endpoint of the first segment of the polyline.

7 Enter w to specify different widths for the next segment, or press  ENTER
to end the command.

Draw toolbar

To assign a lineweight to a layer

1 Click the Format menu ➤ Layer.

2 In the Layer Properties Manager, select a layer. Click the lineweight
associated with that layer.

3 In the Lineweight dialog box, select a lineweight from the list.

4 Click OK to close each dialog box.

To set the display scale of lineweights on the Model tab

1 Click Format menu ➤ Lineweight.

2 In the Lineweight Settings dialog box, under Adjust Display Scale, move
the slider to change the scale.

3 Click OK.

,

Display Lineweights

Lineweights are displayed differently in model space than in a paper space
layout.

■ In model space, a 0-value lineweight is displayed as one pixel, and other
lineweights use a pixel width proportional to their real-unit value.

■ In a paper space layout, lineweights are displayed in the exact plotting
width.
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Display Lineweights in Model Space

In model space, weighted lines that are joined form a beveled joint with no
end caps. You can use plot styles to apply different joins and endcap styles to
objects with lineweights.

NOTE Different styles of endcaps and joins of objects with lineweight are displayed
only in a full plot preview.

Lineweight display in model space does not change with the zoom factor. For
example, a lineweight value that is represented by a width of four pixels is
always displayed using four pixels regardless of how far you zoom in. If you
want the lineweights on objects to appear thicker or thinner on the Model
tab, use  to set their display scale. Changing the display scale does not affect
the lineweight plotting value.

Regeneration time increases with lineweights that are represented by more
than one pixel. Turn off the display of lineweights to optimize performance
of the program. On the Model tab, you can turn the display of lineweights
on or off by clicking Lwt on the status bar.

Display Lineweights in Layouts

In layouts and plot preview, lineweights are displayed in real-world units, and
lineweight display changes with the zoom factor. You can control lineweight
plotting and scaling in your drawing in the Plot dialog box, Plot Settings tab.

In layouts, you can turn the display of lineweights on or off by clicking Lwt
on the status bar. This setting does not affect the plotting of lineweights.

To display lineweights

Use one of the following methods:

■ Toggle Lwt on the status bar.

■ Select or clear Display Lineweight in the Lineweight Settings dialog box.

■ Set the LWDISPLAY system variable to 0 or 1 to turn lineweight display off
or on.

Set the Current Lineweight

The current lineweight is the lineweight used for any objects you draw until
you make another lineweight current.
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All objects are created using the current lineweight, which is displayed in the
Lineweight control on the Properties toolbar. You can also set the current
lineweight with the Lineweight control.

If the current lineweight is set to BYLAYER, objects are created with the
lineweight assigned to the current layer.

If the current lineweight is set to BYBLOCK, objects are created using the
default lineweight setting until the objects are grouped into a block. When
the block is inserted into the drawing, it acquires the current lineweight setting.

If you do not want the current lineweight to be the lineweight assigned to
the current layer, you can specify a different lineweight explicitly.

Objects in drawings created in an earlier release of AutoCAD are assigned the
lineweight value of BYLAYER, and all layers are set to DEFAULT. Lineweight
assigned to objects is displayed as a solid fill drawn in the object's assigned
color.

To make a lineweight current for creating objects

1 Click Format menu ➤ Lineweight.

2 In the Lineweight Settings dialog box, select a lineweight.

3 Click OK.

NOTE To display the lineweight at its current setting, the Display Lineweight
option must be selected in the Display Lineweight dialog box.

,

Change the Lineweight of an Object

You can change the lineweight of an object by reassigning it to another layer,
by changing the lineweight of the layer the object is on, or by specifying a
lineweight for the object explicitly.

You have three choices for changing the lineweight of an object:

■ Reassign the object to another layer with a different lineweight. If an object's
lineweight is set to BYLAYER, and you reassign the object to a different
layer, it acquires its lineweight from the new layer.

■ Change the lineweight assigned to the layer that the object is on. If an
object's lineweight is set to BYLAYER, it acquires the lineweight of its layer.
When you change the lineweight assigned to a layer, all objects on that
layer assigned the BYLAYER lineweight are updated automatically.
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■ Specify a lineweight for an object to override the layer's lineweight. You
can specify the lineweight of each object explicitly. If you want to override
the layer-determined lineweight of an object with a different one, change
an existing object's lineweight from BYLAYER to a specific lineweight.

If you want to set a specific lineweight for all subsequently created objects,
change the current lineweight setting on the Properties toolbar from BYLAYER
to a specific lineweight.

To change the line width of a polyline, donut, rectangle, or polygon

1 Click Modify menu ➤ Object ➤ Polyline.

2 Select one or more polyline objects.

3 Enter w (Width) and enter a new width for all segments.

4 Press  ENTER  to end the command.

Modify II toolbar

Control the Display Properties of Certain
Objects

You can control how overlapping objects and certain other objects are
displayed and plotted.

Control the Display of Polylines, Hatches, Gradient
Fills, Lineweights, and Text

You can simplify the display of certain kinds of objects in order to speed
performance.

Display performance is improved when wide polylines and donuts, solid-filled
polygons (two-dimensional solids), hatches, gradient fills, and text are
displayed in simplified form. Simplified display also increases the speed of
creating test plots.
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Turn Off Solid Fill

When you turn off Fill mode, wide polylines, solid-filled polygons, gradient
fill, and hatches are displayed in outline form. Except for patterned hatches
and gradient fills, solid fill is automatically turned off for hidden view and
nonplan views in three dimensions.

Fill mode on Fill mode off

Use Quick Text

When you turn on Quick Text mode in drawings that contain a lot of text
using complex fonts, only a rectangular frame defining the text is displayed
or plotted.

Quick Text mode off Quick Text mode on

Turn Off Lineweights

Any lineweight width that is represented by more than one pixel may slow
down performance. If you want to improve display performance, turn
lineweights off. You can turn lineweights on and off by choosing the Lwt
button on the status bar or by using the Lineweight Settings dialog box.
Lineweights are always plotted at their real-world value whether their display
is turned on or off.

Update the Display

New objects automatically use the current settings for displays of solid fill and
text. Except for lineweights, to update the display of existing objects using
these settings, you must use .
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See also:

“Use Layers to Manage Complexity” on page 269
“Display Lineweights” on page 303
“Use TrueType Fonts” on page 735

To turn the display of solid fill on or off

1 Click Tools menu ➤ Options.

2 In the Options dialog box, Display tab, under Display Performance, select
Apply Solid Fill.

A check mark indicates that Fill mode is on.

3 Click OK.

4 To display your changes, click View menu ➤ Regen.

,

To turn the display of text on or off

1 Click Tools ➤ Options.

2 In the Options dialog box, Display tab, under Display Performance, select
Show Text Boundary Frame Only.

The check mark indicates that text is displayed as a rectangular frame.

3 Click OK.

4 To display your changes, click View menu ➤ Regen.

,

To turn lineweights on or off

1 Click Format menu ➤ Lineweight.

2 In the Lineweight Settings dialog box, select or clear Display Lineweight.

3 Click OK.

Control How Overlapping Objects Are Displayed

You can control which overlapping objects appear to be on top.

Generally, overlapping objects such as text, wide polylines, and solid-filled
polygons are displayed in the order they are created: newly created objects in
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front of existing objects. You can use  to change the draw order (which is the
display and plotting order) of any objects.  changes the draw order of all text
and dimensions in the drawing.

1
2

3
4

1
2

4
3

The rectangles are
displayed in the order
they were created

The third rectangle has
an assigned draw
order

NOTE Overlapping objects cannot be controlled between model space and paper
space. They can be controlled only within the same space.

To change the draw order of overlapping objects

1 On the Draw Order toolbar, click one of the draw order options.

2 Select the object(s) whose draw order you want to modify and press
ENTER.

3 Select the reference object(s) and press  ENTER. (This step is necessary
only for the Bring Above Objects and Send Under Objects options.)

Tools menu Draw Order

Select an object and right-click. Click Draw Order
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Use Precision Tools

 
You can use a variety of precision drawing tools to help you

produce accurate drawings quickly and without performing

tedious calculations.

18
In this chapter

■ Use Coordinates and
Coordinate Systems

■ Use Dynamic Input

■ Snap to Locations on Objects
(Object Snaps)

■ Restrict Cursor Movement

■ Combine or Offset Points and
Coordinates

■ Specify Distances

■ Extract Geometric Information
from Objects

■ Use a Calculator



Use Coordinates and Coordinate Systems
For precise coordinate input, you can use several coordinate system entry
methods. You can also use a movable coordinate system, the user coordinate
system, for convenient coordinate entry and to establish drawing planes.

Overview of Coordinate Entry

When a command prompts you for a point, you can use the pointing device
to specify a point, or you can enter a coordinate value on the command line.
When Dynamic Input is on, you can enter coordinate values in tooltips near
the cursor. You can enter two-dimensional coordinates as either Cartesian
(X,Y) or polar coordinates.

Cartesian and Polar Coordinates

A Cartesian coordinate system has three axes, X, Y, and Z. When you enter
coordinate values, you indicate a point's distance (in units) and its direction
(+ or -) along the X, Y, and Z axes relative to the coordinate system origin
(0,0,0).

In 2D, you specify points on the XY plane, also called the construction plane.
The construction plane is similar to a flat sheet of grid paper. The X value of
a Cartesian coordinate specifies horizontal distance, and the Y value specifies
vertical distance. The origin point (0,0) indicates where the two axes intersect.

Polar coordinates use a distance and an angle to locate a point. With both
Cartesian and polar coordinates, you can enter absolute coordinates based on
the origin (0,0), or relative coordinates based on the last point specified.

Another method of entering a relative coordinate is by moving the cursor to
specify a direction and then entering a distance directly. This method is called
direct distance entry.

You can enter coordinates in scientific, decimal, engineering, architectural,
or fractional notation. You can enter angles in grads, radians, surveyor's units,
or degrees, minutes, and seconds. The UNITS command controls unit format.

Display Coordinates on the Status Bar

The current cursor location is displayed as a coordinate value on the status
bar.
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There are three types of coordinate display: static, dynamic, and distance and
angle.

■ Static display. Updates only when you specify a point.

■ Dynamic display. Updates as you move the cursor.

■ Distance and angle display. Updates the relative distance (distance<angle)
as you move the cursor. This option is available only when you draw lines
or other objects that prompt for more than one point.

To display the coordinate values of a point

1 Click Tools menu ➤ Inquiry ➤ ID Point.

2 Select the location you want to identify.

The X,Y,Z coordinate values are displayed on the command line.

Inquiry toolbar

To visually locate a point

1 Click Tools menu ➤ Inquiry ➤ ID Point.

2 On the command line, enter the coordinate values of the point you want
to locate.

If the BLIPMODE system variable is on, a blip (a small cross) is displayed
at the point location.

Inquiry toolbar

To change the coordinate display on the status bar

Use one of the following methods:

■ Click the coordinate display at the Specify Next Point prompt.

■ Press F6 or CTRL+D.

■ Set the COORDS system variable to 0 for static display, 1 for dynamic
display, or 2 for distance and angle display.
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Enter 2D Coordinates

Absolute and relative 2D Cartesian and polar coordinates determine precise
locations of objects in a drawing.

Enter Cartesian Coordinates

You can use absolute or relative Cartesian (rectangular) coordinates to locate
points when creating objects.

To use Cartesian coordinates to specify a point, enter an X value and a Y value
separated by a comma (X,Y). The X value is the positive or negative distance,
in units, along the horizontal axis. The Y value is the positive or negative
distance, in units, along the vertical axis.

Absolute coordinates are based on the UCS origin (0,0), which is the
intersection of the X and Y axes. Use absolute coordinates when you know
the precise X and Y values of the point.

With Dynamic Input, you can specify absolute coordinates with the # prefix.
If you enter coordinates on the command line instead of in the tooltip, the
# prefix is not used. For example, entering #3,4 specifies a point 3 units along
the X axis and 4 units along the Y axis from the UCS origin. For more
information about Dynamic Input, see “Use Dynamic Input” on page 335.

The following example draws a line beginning at an X value of –2, a Y value
of 1, and an endpoint at 3,4. Enter the following in the tooltip:

Command: line
From point: #–2,1
To point: #3,4
The line is located as follows:

-X

Y

-Y

X
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Relative coordinates are based on the last point entered. Use relative
coordinates when you know the location of a point in relation to the previous
point.

To specify relative coordinates, precede the coordinate values with an @ sign.
For example, entering @3,4 specifies a point 3 units along the X axis and 4
units along the Y axis from the last point specified.

The following example draws the sides of a triangle. The first side is a line
starting at the absolute coordinates -2,1 and ending at a point 5 units in the
X direction and 0 units in the Y direction. The second side is a line starting
at the endpoint of the first line and ending at a point 0 units in the X direction
and 3 units in the Y direction. The final line segment uses relative coordinates
to return to the starting point.

Command: line
From point: #-2,1
To point: @5,0
To point: @0,3
To point: @-5,-3

Y

-Y

-X X

To enter absolute Cartesian coordinates (2D)

At a prompt for a point, enter coordinates in the tooltip using the following
format:

# x , y

If Dynamic Input is turned off, enter coordinates on the command line
using the following format:

x , y

To enter relative Cartesian coordinates (2D)

At a prompt for a point, enter coordinates using the following format:
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@ x , y

Enter Polar Coordinates

You can use absolute or relative polar coordinates (distance and angle) to
locate points when creating objects.

To use polar coordinates to specify a point, enter a distance and an angle
separated by an angle bracket (<).

By default, angles increase in the counterclockwise direction and decrease in
the clockwise direction. To specify a clockwise direction, enter a negative value
for the angle. For example, entering 1<315 locates the same point as entering
1<-45. You can change the angle conventions for the current drawing with .

Absolute polar coordinates are measured from the UCS origin (0,0), which is
the intersection of the X and Y axes. Use absolute polar coordinates when you
know the precise distance and angle coordinates of the point.

With Dynamic Input, you can specify absolute coordinates with the # prefix.
If you enter coordinates on the command line instead of in the tooltip, the
# prefix is not used. For example, entering #3<45 specifies a point 3 units
from the origin at an angle of 45 degrees from the X axis. For more information
about Dynamic Input, see “Use Dynamic Input” on page 335.

The following example shows two lines drawn with absolute polar coordinates
using the default angle direction setting. Enter the following in the tooltip:

Command: line
From point: #0,0
To point: #4<120
To point: #5<30
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Relative coordinates are based on the last point entered. Use relative
coordinates when you know the location of a point in relation to the previous
point.

To specify relative coordinates, precede the coordinate values with an @ sign.
For example, entering @1<45 specifies a point at a distance of 1 unit from
the last point specified at an angle of 45 degrees from the X axis.

The following example shows two lines drawn with relative polar coordinates.
In each illustration, the line begins at the location labeled as the previous
point.

Command: line
From point: @3<45
To point: @5<285

previous point

previous point

To enter absolute polar coordinates (2D)

■ At a prompt for a point, enter coordinates in the tooltip using the following
format:

# distance < angle

Use Coordinates and Coordinate Systems | 317



If Dynamic Input is turned off, enter coordinates on the command line
using the following format:

distance < angle

To enter relative polar coordinates (2D)

■ At a prompt for a point, enter coordinates using the following format:

@ distance < angle

Enter 3D Coordinates

Cartesian, cylindrical, or spherical coordinates locate points when you are
creating objects in 3D.

Enter 3D Cartesian Coordinates

3D Cartesian coordinates specify a precise location by using three coordinate
values: X, Y, and Z.

Entering 3D Cartesian coordinate values (X,Y,Z) is similar to entering 2D
coordinate values (X,Y). In addition to specifying X and Y values, you also
specify a Z value using the following format:

X,Y,Z

NOTE For the following examples, it is assumed that dynamic input is turned off
or that the coordinates are entered on the command line. With Dynamic Input,
you specify absolute coordinates with the # prefix.

In the illustration below, the coordinate values of 3,2,5 indicates a point 3
units along the positive X axis, 2 units along the positive Y axis, and 5 units
along the positive Z axis.
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WCS origin point

+Z

-Z

+Y

-Y

-X

+X

Use Default Z Values

When you enter coordinates in the format X,Y, the Z value is copied from the
last point you entered. As a result, you can enter one location in the X,Y,Z
format and then enter subsequent locations using the X,Y format with the Z
value remaining constant. For example, if you enter the following coordinates
for a line

From point: 0,0,5
To point: 3,4

both endpoints of the line will have a Z value of 5. When you begin or open
any drawing, the initial default value of Z is 0.

Use Absolute and Relative Coordinates

As with 2D coordinates, you can enter absolute coordinate values, which are
based on the origin, or you can enter relative coordinate values, which are
based on the last point entered. To enter relative coordinates, use the @ sign
as a prefix. For example, use @1,0,0 to enter a point one unit in the positive
X direction from the previous point. To enter absolute coordinates on the
command line, no prefix is necessary.

Digitize Coordinates

When you enter coordinates by digitizing, the UCS Z value for all coordinates
is 0. You can use  to set a default height above or below the Z = 0 plane for
digitizing without moving the UCS.
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To enter absolute coordinates (3D)

At a prompt for a point, enter coordinates in the tooltip using the following
format:

# x,y,z

If Dynamic Input is turned off, enter coordinates on the command line
using the following format:

x , y , z

To enter relative coordinates (3D)

At a prompt for a point, enter coordinates using the following format:

@x,y,z

Enter Cylindrical Coordinates

3D cylindrical coordinates describe a precise location by a distance from the
UCS origin in the XY plane, an angle from the X axis in the XY plane, and a
Z value.

Cylindrical coordinate entry is the 3D equivalent of 2D polar coordinate entry.
It specifies an additional coordinate on an axis that is perpendicular to the
XY plane. Cylindrical coordinates define points by a distance in the XY plane
from the UCS origin, an angle from the X axis in the XY plane, and a Z value.
You specify a point using the following syntax:

X <[ angle from X axis ], Z

NOTE For the following examples, it is assumed that dynamic input is turned off
or that the coordinates are entered on the command line. With Dynamic Input,
you specify absolute coordinates with the # prefix.

In the illustration below, 5<60,6 indicates a point 5 units from the origin of
the current UCS, 60 degrees from the X axis in the XY plane, and 6 units along
the Z axis. 8<30,1 indicates a point 8 units from the origin of the current UCS
in the XY plane, 30 degrees from the X axis in the XY plane, and 1 unit along
the Z axis.
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When you need to define a point based on a previous point, you can enter
relative cylindrical coordinate values with the @ sign. In the illustration below,
@4<45,5 indicates a point 4 units in the XY plane from the last point entered,
at an angle of 45 degrees from the positive X direction, and extending 5 units
in the Z direction.

last point
entered

To enter relative cylindrical coordinates

At a prompt for a point, enter the coordinate values using the following
format:

@ x < angle from the X axis , z
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For example, @4<60,2 represents a location that is 4 units along the X axis
from the last point measured at 60 degrees from the positive X axis and at 2
units in the positive Z direction.

Enter Spherical Coordinates

3D spherical coordinates specify a location by a distance from the origin of
the current UCS, an angle from the X axis in the XY plane, and an angle from
the XY plane.

Spherical coordinate entry in 3D is similar to polar coordinate entry in 2D.
You locate a point by specifying its distance from the origin of the current
UCS, its angle from the X axis (in the XY plane), and its angle from the XY
plane, each angle preceded by an open angle bracket (<) as in the following
format:

X <[ angle from X axis ]<[ angle from XY plane ]

NOTE For the following examples, it is assumed that dynamic input is turned off
or that the coordinates are entered on the command line. With Dynamic Input,
you specify absolute coordinates with the # prefix.

In the following illustration, 8<60<30 indicates a point 8 units from the origin
of the current UCS in the XY plane, 60 degrees from the X axis in the XY
plane, and 30 degrees up the Z axis from the XY plane. 5<45<15 indicates a
point 5 units from the origin, 45 degrees from the X axis in the XY plane, and
15 degrees up from the XY plane.

5<45<15

8<30<30

When you need to define a point based on a previous point, enter the relative
spherical coordinate values by preceding them with the @ sign.
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To enter relative spherical coordinates

■ At a prompt for a point, enter the coordinate values using the following
format:

@x<angle from the x axis<angle from the xy plane

For example, @4<60<30 represents a location that is 4 units from the last point
measured at 60 degrees from the positive X axis in the XY plane and at 30
degrees from the XY plane.

Control the User Coordinate System (UCS) in 2D

You can relocate and rotate the user coordinate system for convenient
coordinate entry, grid display, grid snap, and Ortho mode.

There are two coordinate systems: a fixed system called the world coordinate
system (WCS) and a movable system called the user coordinate system (UCS).
In the WCS, the X axis is horizontal, the Y axis is vertical, and the Z axis is
perpendicular to the XY plane. The origin is where the X and Y axes intersect
(0,0) in the lower-left corner of the drawing. You define a UCS in terms of the
WCS. Virtually all coordinate entry uses the current UCS.

Moving the UCS can make it easier to work on particular sections of your
drawing. Rotating the UCS helps you specify points in three-dimensional or
rotated views. Snap, Grid, and Ortho modes all rotate in line with the new
UCS.

You can relocate the user coordinate system using any of the following
methods:

■ Move the UCS by defining a new origin.

■ Align the UCS with an existing object or with the current viewing direction.

■ Rotate the current UCS around any of its axes.

■ Restore a saved UCS.

Once you have defined a UCS, you can name it and then restore it when you
need to use it again. If you no longer need a named UCS, you can delete it.
Also, you can restore the UCS to be coincident with the WCS.

To define a new UCS origin

1 Click Tools menu ➤ New UCS ➤ Origin.

2 Specify a point for the new origin.
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The 0,0,0 coordinate is redefined at the point you specify.

UCS toolbar

To restore the WCS

1 Click Tools menu ➤ Named UCS.

2 In the UCS dialog box, Named UCSs tab, select World.

3 Click Set Current.

4 Click OK.

UCS toolbar

To restore the previous UCS

1 Click Tools menu ➤ Named UCS.

2 In the UCS dialog box, Named UCSs tab, select Previous.

3 Click Set Current.

4 Click OK.

UCS toolbar

To save a UCS

1 Click Tools menu ➤ Named UCS.

The new UCS is displayed in the UCS list as UNNAMED.

2 In the UCS dialog box, Named UCSs tab, select UNNAMED and enter a
new name. (You can also select UNNAMED, and right-click. Click
Rename.)

3 Click OK.
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You can use up to 255 characters, including letters, digits, and the special
characters dollar sign ($), hyphen (-), and underscore(_). All UCS names
are converted to uppercase.

UCS toolbar

To restore a named UCS

1 Click Tools menu ➤ Named UCS.

2 In the UCS dialog box, Named UCSs tab, you can view the origin and
axis direction of a listed UCS. Select the UCS name. Click Details.

When you have finished viewing the list, click OK to return to the UCS
dialog box.

3 Select the coordinate system you want to restore. Click Set Current.

4 Click OK.

UCS toolbar

To rename a UCS

1 Click Tools menu ➤ Named UCS.

2 In the UCS dialog box, Named UCSs tab, select the coordinate system
you want to rename. (You can also select UNNAMED, and right-click.
Click Rename)

3 Enter a new name.

4 Click OK.

UCS toolbar

To delete a UCS

1 Click Tools menu ➤ Named UCS.

Use Coordinates and Coordinate Systems | 325



2 In the UCS dialog box, Named UCSs tab, select the UCS you want to
delete.

3 Press  DELETE .

You cannot delete the current UCS or a UCS with the default name
UNNAMED.

UCS toolbar

Specify Drawing Planes in 3D (UCS)

Control of the user coordinate system is essential for effective 3D modeling.

Use World and User Coordinate Systems in 3D

When you work in 3D, there is both a fixed coordinate system and a movable
one. The movable user coordinate system is useful for entering coordinates,
establishing drawing planes, and setting views.

There are two coordinate systems: a fixed system called the world coordinate
system (WCS) and a movable system called the user coordinate system (UCS).
The UCS is useful for entering coordinates, defining drawing planes, and
setting views. Changing the UCS does not change your viewpoint. It changes
only the orientation and tilt of the coordinate system.

If you are creating 3D objects, you can relocate the UCS to simplify your work.
For example, if you have created a 3D box, you can edit each of its six sides
easily by aligning the UCS with each side as you edit it.

You relocate a UCS by choosing the location of the origin point and the
orientation of the XY plane and the Z axis. You can locate and orient a UCS
anywhere in 3D space. Only one UCS is current at any given time, and all
coordinate input and display is relative to it. If multiple viewports are
displayed, they share the current UCS.

However, with the  system variable turned on, you can lock a UCS to a
viewport, automatically restoring the UCS each time that viewport is made
current.

When drawing in 3D, you specify X, Y, and Z coordinate values in either the
world coordinate system or the current user coordinate system. The illustration
below shows the X, Y, and Z axes of the WCS.
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+Z

-Z-Y

-X

+X

+Y

WCS origin point

The WCS and the UCS are often coincident — their axes and origin points
overlap exactly. No matter how you reorient the UCS, you can always make
it coincident with the WCS by using the World option of the UCS command.

Apply the Right-Hand Rule

Use the right-hand rule to determine the positive axis direction of the Z axis
when you know the direction of the X and Y axes in a 3D coordinate system.
Place the back of your right hand near the screen and point your thumb in
the direction of the positive X axis. Extend your index and middle fingers as
illustrated, pointing your index finger in the direction of the positive Y axis.
Your middle finger indicates the direction of the positive Z axis. By rotating
your hand, you see how the X, Y, and Z axes rotate as you change the UCS.

You can also use the right-hand rule for determining the positive direction of
rotation about an axis in 3D space. Point your right thumb in the positive
direction of the axis and curl your fingers. Your fingers indicate the positive
rotation direction about the axis.

Y

Z
X

To enter coordinates relative to the WCS

■ Precede coordinate values with an asterisk (*).
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Entering @*2,0,0 specifies a point two units in the X direction of the last point
entered relative to the WCS. Entering @2,0,0 specifies a point two units in
the X direction of the last point entered relative to the UCS.

In practice, most coordinates are entered relative to the UCS rather than the
WCS.

Control the User Coordinate System in 3D

Several methods are available for manipulating the user coordinate system in
3D. You can also save and restore user coordinate system orientations.

You define a user coordinate system (UCS) to change the location of the 0,0,0
origin point and the orientation of the XY plane and Z axis. You can locate
and orient a UCS anywhere in 3D space, and you can define, save, and recall
as many UCSs as you require. Coordinate input and display are relative to the
current UCS.

UCSs are especially useful in 3D. You may find it easier to align the coordinate
system with existing geometry than to figure out the exact placement of a 3D
point.

first UCS second UCS model with both UCSs

If multiple viewports are active, you can assign a different UCS to each
viewport. With the  system variable turned on, you can lock a UCS to a
viewport, automatically restoring the UCS each time that viewport is made
current. With UCSVP turned on, each UCS can have a different origin and
orientation for various construction requirements.

Define the UCS Location

You can define a UCS in the following ways:

■ Specify a new origin, new XY plane, or new Z axis.

■ Align the new UCS with an existing object.
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■ Align the new UCS with the current viewing direction.

■ Rotate the current UCS around any of its axes.

■ Apply a new Z-depth to an existing UCS.

■ Apply a UCS by selecting a face.

Use UCS Presets

If you do not want to define your own UCS, you can choose from several
preset coordinate systems. The images on the Orthographic UCSs tab of the
UCS dialog box show the available choices.

If you have already specified a UCS, you can control whether choosing a preset
option shifts the UCS relative to the current UCS orientation or relative to
the default world coordinate system (WCS). This option has no effect if you
restore the WCS, restore the previous UCS, or set the UCS to the current view.

Change the Default Elevation

The  command sets the default Z value for new objects above or below the
XY plane of the current UCS. This value is stored in the ELEVATION system
variable.

Generally, it is recommended that you leave the elevation set to zero and
control the XY plane of the current UCS with the  command.

When the UCSVP system variable is set to 1, that is, when different UCS
settings are saved in individual viewports, the default elevation for new objects
in each viewport is relative to the UCS in that viewport.

Change the UCS in Paper Space

You can define a new UCS in paper space just as you can in model space;
however, the UCSs in paper space are restricted to 2D manipulation. Although
you can enter 3D coordinates in paper space, you cannot use 3D viewing
commands such as , , and . The program keeps track of the last 10 coordinate
systems created in model space and the last 10 in paper space.

Save and Restore UCS Locations by Name

If you plan to work extensively in 3D, you can save named UCS locations,
each having a different origin and orientation, for various construction
requirements. You can relocate, save, and recall as many UCS orientations as
you require.
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To shift the XY plane

1 Click Tools menu ➤ New UCS ➤ 3 Point.

2 Specify an origin point for the new UCS (1).

For example, in a large drawing, you might specify an origin point near
the area in which you want to work.

3 Specify a point to indicate the horizontal orientation of the new UCS
(2). This point should be on the positive portion of the new X axis.

4 Specify a point to indicate the vertical orientation of the new UCS (3).
This point should be on the positive portion of the new Y axis.

The UCS, including grid, shifts to represent the X and Y axes you have
specified.

points specified new UCS

1

2

3

X

Y

UCS toolbar

To select a UCS preset

1 Click Tools menu ➤ Orthographic UCS ➤ Preset.

2 In the UCS dialog box, Orthographics UCSs tab, select a UCS orientation
from the list.

3 Click Set Current.

4 Click OK.

The UCS changes to the selected option.

UCS II toolbar
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To restore the location and orientation of the previous UCS

■ On the command line, enter ucs. Then enter p (Previous).

The previous UCS is restored.

UCS toolbar

Assign User Coordinate System Orientations to
Viewports

To facilitate editing objects in different views, you can define a different user
coordinate system orientation for each view.

Multiple viewports provide different views of your model. For example, you
might set up viewports that display top, front, right side, and isometric views.
To facilitate editing objects in different views, you can define a different UCS
for each view. Each time you make a viewport current, you can begin drawing
using the same UCS you used the last time that viewport was current.

The UCS in each viewport is controlled by the  system variable. When UCSVP
is set to 1 in a viewport, the UCS last used in that viewport is saved with the
viewport and is restored when the viewport is made current again. When
UCSVP is set to 0 in a viewport, its UCS is always the same as the UCS in the
current viewport.

For example, you might set up three viewports: a top view, front view, and
isometric view. If you set the UCSVP system variable to 0 in the isometric
viewport, you can use the Top UCS in both the top viewport and the isometric
viewport. When you make the top viewport current, the isometric viewport’s
UCS reflects the UCS top viewport. Likewise, making the front viewport current
switches the isometric viewport’s UCS to match that of the front viewport.

The example is illustrated in the following figures. The first figure shows the
isometric viewport reflecting the UCS of the upper-left, or top, viewport, which
is current.
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UCSVP = 0; UCS icon reflects
UCS of current viewport

top viewport is current

The second figure shows the change that occurs when the lower-left, or front,
viewport is made current. The UCS in the isometric viewport is updated to
reflect the UCS of the front viewport.

front viewport is current UCSVP = 0; UCS icon reflects
UCS of current viewport

In previous releases, the UCS was a global setting for all viewports in either
model or paper space. If you want to restore the behavior of previous releases,
you can set the value of the UCSVP system variable to 0 in all active viewports.

To apply the current UCS to other viewports

1 Make sure the UCS that you want to apply to another viewport is current.
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2 Click Tools menu ➤ New UCS ➤ Apply.

3 At the prompt, click in a viewport to apply the current UCS to that
viewport, or enter all to apply the current UCS setting to all active
viewports.

Control the Display of the User Coordinate System
Icon

To help visualize the current orientation of the user coordinate system, you
can display the user coordinate system icon. Several versions of this icon are
available, and you can change its size, location, and color.

To indicate the location and orientation of the UCS, the UCS icon is displayed
either at the UCS origin point or in the lower-left corner of the current
viewport.

You can choose one of three styles of icon to represent the UCS.

Use the  command to choose between displaying the 2D or the 3D UCS icon.
Use  to display the shaded UCS icon. To indicate the origin and orientation
of the UCS, you can display the UCS icon at the UCS origin point using the
UCSICON command.

If the icon is displayed at the origin of the current UCS, a cross (+) appears in
the icon. If the icon is displayed in the lower-left corner of the viewport, no
cross appears in the icon.

If you have multiple viewports, each viewport displays its own UCS icon.

The UCS icon is displayed in various ways to help you visualize the orientation
of the drawing plane. The following figure shows some of the possible icon
displays.
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2D UCS at WCS right side view
of 2D UCS

iso view of 2D
UCS

2D UCS viewed
from below

3D UCS at WCS right side view
of 3D UCS

3D UCS viewed
from below

iso view of 3D
UCS

You can use the UCSICON command to switch between the 2D UCS icon and
the 3D UCS icon. You can also use the command to change the size, color,
arrowhead type, and icon line width of the 3D UCS icon.

The UCS broken pencil icon replaces the 2D UCS icon when the viewing
direction is in a plane parallel to the UCS XY plane. The broken pencil icon
indicates that the edge of the XY plane is almost perpendicular to your viewing
direction. This icon warns you not to use your pointing device to specify
coordinates.

broken pencil
icon

When you use the pointing device to locate a point, it’s normally placed on
the XY plane. If the UCS is rotated so that the Z axis lies in a plane parallel to
the viewing plane—that is, if the XY plane is edge-on to the viewer—it may
be difficult to visualize where the point will be located. In this case, the point
will be located on a plane parallel to your viewing plane that also contains
the UCS origin point. For example, if the viewing direction is along the X axis,
coordinates specified with a pointing device will be located on the YZ plane,
which contains the UCS origin point.

Use the 3D UCS icon to help you visualize which plane these coordinates will
be projected on; the 3D UCS icon does not use a broken pencil icon.
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To turn the display of the UCS icon on and off

1 Click View menu ➤ Display ➤ UCS Icon ➤ Select On.

The check mark indicates whether the icon is on or off.

To display the UCS icon at the UCS origin

1 Select View menu ➤ Display ➤ UCS Icon ➤ Origin.

The UCS icon is displayed at the origin of the current coordinate system.
The check mark indicates whether the option is on or off.

To change the appearance of the UCS icon

1 Click View menu ➤ Display ➤ UCS Icon ➤ Properties.

2 In the UCS Icon dialog box, change the settings.

3 Click OK.

Use Dynamic Input
Dynamic Input provides a command interface near the cursor to help you
keep your focus in the drafting area.

When Dynamic Input is on, tooltips display information near the cursor that
is dynamically updated as the cursor moves. When a command is active, the
tooltips provide a place for user entry.

The actions required to complete a command or to use grips are similar to
those for the command line. The difference is that your attention can stay
near the cursor.

Dynamic Input is not designed to replace the command window. You can
hide the command window to add screen area for drawing, but you will need
to display it for some operations. Press F2 to hide and display command
prompts and error messages as needed. Alternatively, you can undock the
command window and use Auto-hide to roll open or roll up the window.

Turn Dynamic Input On and Off

Click Dyn on the status bar to turn Dynamic Input on and off. You can turn
it off temporarily by holding down the F12 key. Dynamic Input has three
components: pointer input, dimensional input, and dynamic prompts.
Right-click Dyn and click Settings to control what is displayed by each
component when Dynamic Input is on.
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NOTE Dynamic Input is not supported for perspective views.

Pointer Input

When pointer input is on and a command is active, the location of the
crosshairs is displayed as coordinates in a tooltip near the cursor. You can
enter coordinate values in the tooltip instead of on the command line.

The default for second and subsequent points is relative polar coordinates
(relative Cartesian for ). There is no need to type the at sign (@). If you want
to use absolute coordinates, use the pound sign (#) prefix. For example, to
move an object to the origin, for the second point prompt, enter #0,0.

Use the pointer input settings to change the default format for coordinates
and to control when pointer input tooltips are displayed.

Dimensional Input

When dimensional input is on, the tooltips display distance and angle values
when a command prompts for a second point. The values in the dimensional
tooltips change as you move the cursor. Press TAB to move to the value you
want to change. Dimensional input is available for , , , , and .

NOTE For dimensional input, after you type a value in an input field and press
TAB, the field then displays a lock icon, and the cursor is constrained by the value
that you entered.

When you use grips to edit an object, the dimensional input tooltips can
display the following information:

Original length

A length that updates as you move the grip
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The change in the length

Angle

The change in the angle as you move the grip

The radius of an arc

Use the dimensional input settings to display only the information you want
to see.

When you use grips to stretch objects or when you create new objects,
dimensional input displays only acute angles, that is, all angles are displayed
as 180 degrees or less. Thus, an angle of 270 degrees is displayed as 90 degrees
regardless of the  system variable setting (set in the Drawing Units dialog box).
Angles specified when creating new objects rely on the cursor location to
determine the positive angle direction.

Dynamic Prompts

When dynamic prompts are on, prompts are displayed in a tooltip near the
cursor. You can enter a response in the tooltip instead of on the command
line. Press the DOWN ARROW key to view and select options. Press the UP
ARROW key to display recent input.

NOTE To use  in a dynamic prompt tooltip, type a letter and then backspace to
delete it before you paste the entry. Otherwise, the entry is pasted into the drawing
as text.
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To enter coordinate values in dynamic input tooltips

1 On the status bar, verify that Dynamic Input (the Dyn button) is on.

2 Use one of the following methods to enter coordinate values or select
options:

■ To enter polar coordinates, enter the distance from the first point and
press TAB, and then enter an angle value and press ENTER.

■ To enter Cartesian coordinates, enter an X coordinate value and a
comma (,), and then enter a Y coordinate value and press ENTER.

■ If a down-arrow icon follows the prompt, press the DOWN ARROW
key until a dot is displayed next to the option. Press ENTER.

NOTE For dimensional input, after you type a value in an input field and press
TAB, the field then displays a lock icon, and the cursor is constrained by the value
that you entered.

To correct typing errors in dynamic input tooltips

■ When a dynamic input tooltip displays the red error outline, use the RIGHT
ARROW, LEFT ARROW, BACKSPACE, and DELETE keys to correct your
entry. After you make the correction, press TAB, comma (,), or a left angle
bracket (<) to remove the red outline and complete the coordinates.

■ Press the UP ARROW key to access recent coordinates, or right-click and
click Recent Input to access the coordinates from a shortcut menu.

■ If you type the @ or # or * prefixes in a pointer input tooltip and then want
to change it, you can just type the character you want. There is no need to
backspace.

To specify relative or absolute coordinates in pointer input tooltips

■ To enter absolute coordinates when relative coordinates are displayed in
the tooltip, enter # to temporarily override the  system variable.

■ To enter relative coordinates when absolute coordinates are displayed, enter
@ to temporarily override the  system variable.

■ To enter absolute world coordinate system (WCS) coordinates, enter *.

NOTE During pointer input, you can use the shortcut menu to access the # and
* prefixes.
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To choose options in dynamic prompt tooltips

1 Start a command.

Tooltips near the crosshairs display the coordinates of the cursor location
and a prompt.

2 If a prompt is displayed, press the DOWN ARROW key to display the
options.

3 Press DOWN ARROW or UP ARROW to place a dot next to the option
you want. Press ENTER.

Press ESC to undo the most recent action.

4 Specify points and enter options to complete the command.

To change the color, size, or transparency of tooltips

1 Right-click Dyn on the status bar. Click Settings.

2 In the Drafting Settings dialog box, Dynamic input tab, click Drafting
Tooltip Appearance.

3 In the Tooltip Appearance dialog box, under Color, click Model Color
or Layout Color to display the “Select Color Dialog Box”, where you can
specify a color for tooltips in the space you selected.

4 Under Size, move the slider to the right to make tooltips larger or to the
left to make them smaller. The default value, 0, is in the middle.

5 Under Transparency, move the slider. The lower the setting, the more
transparent the tooltip. A value of 100 sets the tooltip to opaque.

6 Under Apply To, choose an option:

■ Override OS Settings for All Drafting Tooltips. Applies the
settings to all tooltips, overriding the settings in the operating system.

■ Use Settings Only for Dynamic Input Tooltips. Applies the
settings only to the drafting tooltips used in Dynamic Input.

7 Click OK.

To turn on or turn off Dynamic Input

■ On the status bar, click Dyn, or press F12 .

To turn off Dynamic Input temporarily, hold down the F12 key while you
work.
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NOTE The F12 temporary override key does not turn on Dynamic Input.

To change pointer input settings

1 Right-click Dyn on the status bar. Click Settings.

2 In the Drafting Settings dialog box, Dynamic input tab, under Pointer
Input, click Settings.

3 In the Pointer Input Settings dialog box, select polar or Cartesian format
as the default.

4 Select relative or absolute coordinate format as the default.

5 Under Visibility, select one of the following options:

■ As Soon As I Type Coordinate Data. When pointer input is turned
on, displays tooltips only when you start to enter coordinate data.

■ When a Command Asks for a Point. When pointer input is
turned on, displays tooltips whenever a command prompts for a point.

■ Always—Even When Not in a Command. Always displays tooltips
when pointer input is turned o.

6 Click OK to close each dialog box.

DSETTINGS

To change dimensional input settings

1 Right-click Dyn on the status bar. Click Settings.

2 In the Drafting Settings dialog box, Dynamic input tab, under Dimension
Input, click Settings.

3 In the Dimension Input Settings dialog box, select Polar or Cartesian
format as the default.

4 Under Visibility, select one of the following options:

■ Show Only 1 Dimension Input Field at a Time. Displays only
the distance dimensional input tooltip when you are using grip editing
to stretch an object.

■ Show 2 Dimension Input Fields at a Time. Displays the distance
and angle dimensional input tooltips when you are using grip editing
to stretch an object.
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■ Show the Following Dimension Input Fields Simultaneously.
Displays the selected dimensional input tooltips when you are using
grip editing to stretch an object. Select one or more of the check boxes.

5 Click OK to close each dialog box.

DSETTINGS

To display prompts in tooltips

1 Right-click Dyn on the status bar. Click Settings.

2 In the Drafting Settings dialog box, Dynamic input tab, under Dynamic
Prompts, check Show Command Prompting and Command Input Near
the Crosshairs.

3 Click OK.

DSETTINGS

Snap to Locations on Objects (Object Snaps)
Instead of entering coordinates, you can specify points relative to existing
objects such as endpoints of lines or center points of circles.

Use Object Snaps

Use object snaps to specify precise locations on objects. For example, you can
use an object snap to draw a line to the center of a circle or to the midpoint
of a polyline segment.

You can specify an object snap whenever you are prompted for a point. By
default, a marker and a tooltip are displayed when you move the cursor over
an object snap location on an object. This feature, called AutoSnap™ , provides
a visual clue that indicates which object snaps are in effect.

For a list of object snaps, see .
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Specify an Object Snap

To specify an object snap at a prompt for a point, you can

■ Press SHIFT and right-click to display the Object Snap shortcut menu

■ Click an object snap button on the Object Snap toolbar

■ Enter the name of an object snap on the command line

When you specify an object snap at a prompt for a point, the object snap stays
in effect only for the next point that you specify.

NOTE Object snaps work only when you are prompted for a point. If you try to
use an object snap at the Command prompt, an error message is displayed.

Use Running Object Snaps

If you need to use one or more object snaps repeatedly, you can turn on running
object snaps. For example, you might set Center as a running object snap if
you need to connect the centers of a series of circles with a line.

You can specify one or more running object snaps on the Object Snaps tab in
the Drafting Settings dialog box, which is accessible from the Tools menu. If
several running object snaps are on, more than one object snap may be eligible
at a given location. Press TAB to cycle through the possibilities before you
specify the point.

Click the OSNAP button on the status bar or press F3 to turn running object
snaps on and off.

NOTE If you want object snaps to ignore hatch objects, set the OSNAPHATCH
system variable to 0.

Use Object Snaps in 3D

By default, the Z-value of an object snap location is determined by the object’s
location in space. However, if you work with object snaps on the plan view
of a building or the top view of a part, a constant Z-value is more useful.

If you turn on the  system variable, all object snaps are projected onto the XY
plane of the current UCS or, if  is set to a non-zero value, onto a plane parallel
to XY plane at the specified elevation.

NOTE When you draw or modify objects, make sure that you know whether
OSNAPZ is on or off. There is no visual reminder, and you can get unexpected
results.
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To snap to a geometric point on an object

1 At the prompt for a point, hold down SHIFT and right-click in the
drawing area. Select the object snap you want to use.

2 Move your cursor over the desired object snap location.

If AutoSnap is on, your cursor automatically locks onto the snap location
you selected, and a marker and tooltip indicate the object snap point.

3 Select an object.

The cursor snaps to the eligible location closest to your selection.

To set running object snaps

1 Click Tools menu ➤ Drafting Settings.

2 In the Drafting Settings dialog box, Object Snap tab, select the object
snaps you want to use.

3 Click OK.

Object Snap toolbar

Hold down SHIFT and right-click to display the object snap menu. Click Osnap
Settings.

To turn on and turn off running object snaps as you work

■ On the status bar, click Osnap, or press F3.

If running object snaps have been set, the settings are turned on or off.

To turn running object snaps on and off temporarily, hold down the F3 key
while you work.

To set object snaps to ignore hatch objects

1 At the Command prompt, enter osnaphatch.

2 Enter 0.
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Set Visual Aids for Object Snaps (AutoSnap)

Object snaps include a visual aid called AutoSnap™  to help you see and use
object snaps more efficiently. AutoSnap displays a marker and a tooltip when
you move your cursor over an object snap location.

AutoSnap Tools

AutoSnap consists of the following snap tools:

■ Marker. Displays the object snap location when the cursor moves over or
near an object. Marker shape is dependent on the snap it is marking.

■ Tooltip. Describes which part of the object you are snapping to in a small
flag at the cursor location.

■ Magnet. Attracts and locks the cursor onto the nearest detected snap
points. Provides a visual cue, similar to snapping to a grid.

■ Aperture box. Surrounds the crosshairs and defines an area within which
object snaps are evaluated. You can choose to display or not display the
aperture box, and you can change the aperture box size.

The AutoSnap markers, tooltips, and magnet are turned on by default. You
can change AutoSnap settings on the Drafting tab in the Options dialog box.

Use AutoSnap to Confirm or Change an Object Snap

If you have set more than one running object snap, you can press  TAB  to
cycle through all the object snap points available for a particular object.

To change the AutoSnap settings

1 Click Tools menu ➤ Options.

2 In the Options dialog box, Drafting tab, change settings as needed:

■ Marker. Turns the marker on or off.

■ Magnet. Turns the magnet on or off.

■ Display AutoSnap Tooltip. Turns tooltips on or off.

■ Display AutoSnap Aperture Box. Turns the target box on or off
when you specify an object snap. This setting does not affect object
snaps when you are not using AutoSnap.

■ AutoSnap Marker Color.  Changes the color of the marker.
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■ AutoSnap Marker Size. Adjusts the size of the marker.

3 Click OK.

Object Snap toolbar

Override Object Snaps

While you work, you can turn running object snaps on and off temporarily
by using an override key. Temporary override keys can also be used for other
drawing aids; for example, Ortho mode and Polar mode.

For example, if you have set running object snaps but you want to turn them
off for one point, you can hold down F3. When you release this override key,
running object snaps are restored.

There are also temporary override keys for individual object snaps. Override
keys are set up to be easy to find by touch without looking away from your
drawing.

The keys in the following illustration are the default keys, but you can change
key assignments and add your own as needed.

Hold down SHIFT and one of the temporary override keys in the illustration:

Turns off all snapping and tracking5Object snap override: Endpoint1

Object snap override: CenterEnforces object snap selection2

Object snap override: Midpoint7Toggles object snap tracking3

Toggles object snap mode (OSNAP)4
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Temporary override keys are also available for the other drawing aids that you
set in the “Drafting Settings Dialog Box”.

See also:

“Adjust Grid and Grid Snap”
“Use Orthogonal Locking (Ortho Mode)”
“Use Polar Tracking and PolarSnap”
“Use Dynamic Input”
Add Shortcut Keys and Temporary Override Keys in the Customization Guide

To temporarily override the running object snap settings

■ Hold down F3 while you work.

When you release the key, the current running object snap settings are
restored.
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Restrict Cursor Movement
Several tools are available that you can use to restrict or lock the movement
of your cursor.

Adjust Grid and Grid Snap

To enhance your drawing speed and efficiency, you can display and snap to
a rectangular pattern of grid points. You can also control its spacing, angle,
and alignment.

The grid is a rectangular pattern of dots that extends over the area you specify
as the grid limits. Using the grid is similar to placing a sheet of grid paper
under a drawing. The grid helps you align objects and visualize the distances
between them. The grid is not plotted. If you zoom in or out of your drawing,
you may need to adjust grid spacing to be more appropriate for the new
magnification.

Snap mode restricts the movement of the crosshairs to intervals that you
define. When Snap mode is on, the cursor seems to adhere, or "snap," to an
invisible rectangular grid. Snap is useful for specifying precise points with the
arrow keys or the pointing device.

Change Grid and Snap Spacing

As you work, you can turn Grid and Snap mode on and off, and you can
change the grid and snap spacing. You can turn Snap mode on and off
temporarily by using an override key.

Snap spacing does not have to match grid spacing. For example, you might
set a wide grid spacing to be used as a reference but maintain a closer snap
spacing for accuracy in specifying points.

Change the Snap Angle and Base Point

If you need to draw along a specific alignment or angle, you can change the
snap angle. This rotation realigns the crosshairs on the screen to match the
new angle. In the following example, the snap angle is adjusted to match the
angle of the anchor bracket.
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default snap angle - 0
degrees

rotated snap angle - 30
degrees

When you set the snap angle, the grid rotation also changes.

The snap base point is the offset from a specified X,Y value from which snap
points are measured. The default snap base point is 0,0, but it can be changed
to any X,Y coordinate value to adjust snap points.

For example, if X and Y spacing are set to 0.5, and X and Y base points are set
to 0,0, the snap points along the X and Y axes are 0, 0.50, 1.0, and so on.
Changing the X snap base point to 0.1 and the Y snap base point to 0.2 causes
the snap points along the X axis to shift to 0.1, 0.60, 1.1, and so on, and the
snap points along the Y axis to shift to 0.2, 0.7, 1.2, and so on. Shifting the
snap base point may be necessary to align a hatch pattern.

See also:

“Set Isometric Grid and Snap”
“Override Object Snaps”

To display a grid and set grid spacing

1 Click Tools menu ➤ Drafting Settings.

2 In the Drafting Settings dialog box, Snap & Grid tab, select Grid On to
display the grid.

3 Under Snap Type and Style, make sure Grid Snap and Rectangular Snap
are selected.

4 For grid X Spacing, enter the horizontal grid spacing in units.

5 To use the same value for vertical grid spacing, press ENTER. Otherwise,
enter a new value for grid Y Spacing.

6 Click OK.

Although the grid dots do not necessarily correspond to the current snap
interval, they do reflect the current snap angle and isometric snap and
grid settings.
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To turn on Snap mode and set snap spacing

1 Click Tools menu ➤ Drafting Settings.

2 In the Drafting Settings dialog box, Snap & Grid tab, select Snap On.

3 Under Snap Type and Style, make sure Grid Snap and Rectangular Snap
are selected.

4 In Snap Type & Style, select Grid Snap.

5 In the Grid X Spacing box, enter the horizontal snap spacing value in
units.

6 To specify the same vertical snap spacing, press ENTER. Otherwise, enter
a new distance in the Grid Y Spacing box.

7 Click OK.

To temporarily override Snap mode

■ Hold down F9 while you work.

When you release the key, Snap mode is restored.

To rotate the snap angle and change its base point

1 Click Tools menu ➤ Drafting Settings.

2 In the Drafting Settings dialog box, Snap & Grid tab, under Snap, enter
a rotation angle in the Angle box.

3 If you want to set the base point in order to align snap locations, enter
the X and Y coordinate values in the X Base and Y Base boxes.

4 Click OK.

Use Orthogonal Locking (Ortho Mode)

You can restrict cursor movement to horizontal and vertical for convenience
and precision when creating and modifying objects.

As you create or move objects, you can use Ortho mode to restrict the cursor
to the horizontal or vertical axis. As you move the cursor, the rubber-band
line follows the horizontal or vertical axis, whichever is nearest the cursor.
The orthogonal alignment depends on the current snap angle, UCS, or
isometric grid and snap setting.

Use Ortho mode to draw more quickly. For example, create a series of
perpendicular lines by turning on Ortho mode before you start.

Restrict Cursor Movement | 349



You can turn Ortho on and off at any time during drawing and editing. Ortho
is ignored when you enter coordinates on the command line, use perspective
views, or specify an object snap. To turn Ortho on or off temporarily, hold
down the temporary override key, SHIFT. While you use the temporary override
key, the direct distance entry method is not available.

For drawing or editing objects at angles that are not parallel to the horizontal
or vertical axis, see “Use Polar Tracking and PolarSnap” on page 350.

NOTE Ortho mode and polar tracking cannot be on at the same time. Turning
on Ortho turns off polar tracking.

See also:

“Override Object Snaps”

To turn on or turn off Ortho mode

■ On the status bar, click Ortho.

To turn Ortho on or off temporarily, hold down the SHIFT key while you
work. While you use the temporary override key, the direct distance entry
method is not available.

NOTE Turning on Ortho automatically turns off polar tracking.

Use Polar Tracking and PolarSnap

Polar tracking restricts cursor movement to specified angles. PolarSnap restricts
cursor movement to specified increments along a polar angle.

When you are creating or modifying objects, you can use polar tracking to
display temporary alignment paths defined by the polar angles you specify.
You can use PolarSnap™ to snap to specified distances along the alignment
path.

For example, in the following illustration you draw a two-unit line from point
1 to point 2, and then draw a two-unit line to point 3 at a 45-degree angle to
the line. If you turn on the 45-degree polar angle increment, an alignment
path and tooltip are displayed when your cursor crosses the 0 or 45-degree
angle. The alignment path and tooltip disappear when you move the cursor
away from the angle.
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1 2

3

1.5<45
polar:

tooltip display of
distance and angle

alignment path

As you move your cursor, alignment paths and tooltips are displayed when
you move the cursor near polar angles. The default angle measurement is 90
degrees. Use the alignment path and tooltip to draw your object. You can use
polar tracking with Intersection and Apparent Intersection object snaps to
find where a polar alignment path intersects another object.

NOTE Ortho mode and polar tracking cannot be on at the same time. Turning
on polar tracking turns off Ortho mode. Similarly, PolarSnap and grid snap cannot
be on at the same time. Turning on PolarSnap turns off grid snap.

Specify Polar Angles (Polar Tracking)

You can use polar tracking to track along polar angle increments of 90, 60,
45, 30, 22.5, 18, 15, 10, and 5 degrees, or you can specify other angles. The
following illustration shows the alignment paths displayed as you move your
cursor 90 degrees with the polar angle increment set to 30 degrees.

Y

X

Y

X

Y

X

1.5<60
polar:

polar:
1.5<90polar:

1.5<30

The orientation of 0 depends on the angle you set in the Drawing Units dialog
box (). The direction of snap (clockwise or counterclockwise) depends on the
units direction you specify when setting units of measurement.

You can turn polar tracking on and off temporarily by using an override key.
The direct distance entry method is not available while you are using the
temporary override key for polar tracking.
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Specify Polar Distances (PolarSnap)

PolarSnap restricts cursor movement to increments of a polar distance you
specify. For example, if you specify a length of 4 units, the cursor snaps from
the first point specified to lengths of 0, 4, 8, 12, 16, and so on. As you move
your cursor, a tooltip indicates the nearest PolarSnap increment. To restrict
point entry to polar distances, both polar tracking and Snap mode (set to
PolarSnap) must be on. You can turn off all snapping and tracking temporarily
by using an override key.

See also:

“Override Object Snaps”

To turn on and turn off polar tracking

■ Press F10, or click Polar on the status bar.

To turn polar tracking on or off temporarily, hold down the F10 key while
you work.

To set polar snap distance

1 Click Tools menu ➤ Drafting Settings.

2 In the Drafting Settings dialog box, Snap and Grid tab, select Snap On.

3 In Snap Type & Style, select PolarSnap.

4 Under Polar Spacing, enter the polar distance.

5 On the Polar Tracking tab, select Polar Tracking On.

6 Select the angle from the Increment Angle list.

You can specify your own angles by choosing Additional Angles and
then New.

7 Click OK.

To draw objects using polar tracking

1 Turn on polar tracking and start a drawing command, such as ARC,
CIRCLE, or LINE.

You can also use polar tracking with editing commands, such as COPY
and MOVE.

2 As you move your cursor to specify points, notice the dotted polar
tracking line that appears at the tracking angles you specified. Points
you specify while the line is displayed conform to the polar tracking
angle.
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To draw objects using polar distance

1 Turn on snap and polar tracking.

Make sure Polar Snap is selected in the Drafting Settings dialog box, Snap
& Grid tab.

2 Start a drawing command, such as LINE.

3 As you move your cursor, notice that the dotted polar tracking line
displays a tooltip that shows distance and angle.

4 Specify a point.

The length of the new line conforms to the polar distance.

To set polar tracking angles

1 Click Tools menu ➤ Drafting Settings.

2 In the Drafting Settings dialog box, Polar Tracking tab, select Polar
Tracking On.

3 In the Increment Angle list, select the polar tracking angle.

4 To set additional tracking angles, select Additional Angles. Click New.
Enter the angle value in the text box.

5 Under Polar Angle Measurement, specify whether polar tracking
increments are based on the UCS or relative to the last object you created.

6 Click OK.

Lock an Angle for One Point (Angle)

You can specify an angle override that locks the cursor for the next point
entered.

To specify an angle override, enter a left angle bracket (<) followed by an angle
whenever a command asks you to specify a point. The command prompt
sequence below shows a 30-degree override entered during a  command.

Command: line
Specify first point: Specify a start point for the line
Specify next point or [Undo]: < 30
Angle Override: 30
Specify next point or [Undo]:  Specify a point

The angle you specify will lock the cursor, overriding Grid Snap, Ortho mode,
and PolarSnap. Coordinate entry and object snaps have precedence over an
angle override.
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Combine or Offset Points and Coordinates
To specify a new point location, you can combine coordinate values from
several points or you can specify offsets from existing objects.

Combine Coordinate Values (Coordinate Filters)

You can use coordinate filters to extract one coordinate value at a time from
locations on existing objects.

Coordinate filters specify a new coordinate location by using the X value from
one location, the Y value of a second location, and, for 3D coordinates, the
Z value of a third location. When used with object snaps, coordinate filters
extract coordinate values from an existing object.

Coordinate filters are commonly used to locate the center of a rectangle and
to locate the projection of a 3D point on the XY plane of the UCS.

To specify a filter on the command line, enter a period and one or more of
the letters X, Y, and Z. The next entry is limited to a specific coordinate value.

Example: Use of Coordinate Filters in 2D

In the following illustration, the hole in the holding plate was centered in the
rectangle by extracting the X,Y coordinates from the midpoints of the plate’s
horizontal and vertical line segments.

midpoint x

midpoint y

result

Here is the command line sequence:

Command: circle
Specify center point for circle or [3P/2P/Ttr (tangent tangent radius)]: .x
of: mid
of: Select the horizontal line on the lower edge of the holding plate
of: (need YZ): mid
of: Select the vertical line on the left side of the holding plate
of: Diameter/<Radius> Specify the radius of the hole
Coordinate filters work only when the program prompts you for a point. If
you try to use a coordinate filter at the Command prompt, you see an error
message.
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Example: Use of Coordinate Filters in 3D

This example shows how to use coordinate filters to create a point object at
the center (centroid) of a 3D object. Hidden lines have been removed for
clarity. The X value of the new point is extracted from the first location
specified, the Y value from the second location, and the Z value from the
third. The three values are combined to form the coordinate values of the new
point.

Command: point
Point: .x
of mid
of select object (1)
(need YZ): .y
of mid
of select object (2)
(need Z): mid
of select object (3)

point
1

2

3

To use coordinate filters to specify a point in 2D

1 At the prompt for a point, enter a coordinate filter (.x or .y).

For example, enter .x to specify the X value first.

2 To extract the first coordinate value, specify a point.

For example, if you entered .x in step 1, the X value is extracted from
this point.

3 To extract the next coordinate value, specify a different point.

The new point location combines the coordinate values extracted from
the points you specified in steps 2 and 3.

NOTE Instead of specifying a point in steps 2 or 3, you can enter a numeric value.

To use coordinate filters to specify a point in 3D

1 At the prompt for a point, enter a coordinate filter (.x, .y, .z, .xy, .xz, or
.yz).
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For example, enter .x to specify the X value first.

2 To extract the specified coordinate value(s), specify a point.

For example, if you entered .x in step 1, the X value is extracted from
this point.

3 At the prompt for the remaining coordinates, do one of the following:

■ Extract the remaining coordinate values by specifying a point.

■ Enter another coordinate filter and return to step 2.

For example, if you entered .x in step 1, specify a second point to extract
the Y and Z coordinates simultaneously, or enter .y or .z to specify Y
and Z values separately.

The new point location combines the coordinate values extracted from
the points specified in steps 2 and 3.

NOTE Instead of specifying a point in steps 2 or 3, you can enter a numeric value.

Track to Points on Objects (Object Snap Tracking)

You can draw objects at specific angles or in specific relationship to other
objects along specified directions called alignment paths.

AutoTrack™  helps you draw objects at specific angles or in specific
relationships to other objects. When you turn on AutoTrack, temporary
alignment paths help you create objects at precise positions and angles.
AutoTrack includes two tracking options: polar tracking and object snap
tracking.

You can toggle AutoTrack on and off with the Polar and Otrack buttons on
the status bar. Use temporary override keys to turn object snap tracking on
and off or to turn off all snapping and tracking. See the keyboard illustration
in “Override Object Snaps” on page 345.

Object snap tracking works in conjunction with object snaps. You must set
an object snap before you can track from an object’s snap point.

Object Snap Tracking

Use object snap tracking to track along alignment paths that are based on
object snap points. Acquired points display a small plus sign (+), and you can
acquire up to seven tracking points at a time. After you acquire a point,
horizontal, vertical, or polar alignment paths relative to the point are displayed
as you move the cursor over their drawing paths. For example, you can select
a point along a path based on an object endpoint or midpoint or an
intersection between objects.
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In the following illustration, the Endpoint object snap is on. You start a line
by clicking its start point (1), move the cursor over another line’s endpoint
(2) to acquire it, and then move the cursor along the horizontal alignment
path to locate the endpoint you want for the line you are drawing (3).

start point acquired point endpoint

alignment path

1

2 3

Endpoint:
0.48<0

Change Object Snap Tracking Settings

By default, object snap tracking is set to orthogonal. Alignment paths are
displayed at 0, 90, 180, and 270 degrees from acquired object points. However,
you can use polar tracking angles instead.

For object snap tracking, object points are automatically acquired. However,
you can choose to acquire points only when you pressSHIFT.

Change Alignment Path Display

You can change how AutoTrack displays alignment paths, and you can change
how object points are acquired for object snap tracking. By default, alignment
paths stretch to the end of the drawing window. You can change their display
to abbreviated lengths, or no length.

Tips for Using Object Snap Tracking

As you use AutoTrack (polar tracking and object snap tracking), you will
discover techniques that make specific design tasks easier. Here are a few you
might try.

■ Use Perpendicular, End, and Mid object snaps with object snap tracking to
draw to points that are perpendicular to the end and midpoints of objects.

■ Use the Tangent and End object snaps with object snap tracking to draw
to points that are tangent to the endpoints of arcs.

■ Use object snap tracking with temporary tracking points. At a point prompt,
enter tt, then specify a temporary tracking point. A small + appears at the
point. As you move your cursor, AutoTrack alignment paths are displayed
relative to the temporary point. To remove the point, move the cursor back
over the +.
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■ After you acquire an object snap point, use direct distance to specify points
at precise distances along alignment paths from the acquired object snap
point. To specify a point prompt, select an object snap, move the cursor to
display an alignment path, then enter a distance at the Command prompt.

NOTE The direct distance entry method is not available while you are using
the temporary override key for object snap tracking.

■ Use the Automatic and SHIFT to Acquire options set on the Drafting tab
of the Options dialog box to manage point acquisition. Point acquisition
is set to Automatic by default. When working in close quarters, press SHIFT
to temporarily avoid acquiring a point.

To turn on and turn off object snap tracking

■ Press F11, or click Otrack on the status bar.

To change AutoTrack settings

1 Click Tools menu ➤ Options.

2 In the Options dialog box, Drafting tab, under AutoTrack Settings, select
or clear the following alignment path display options:

■ Display Polar Tracking Vector.  Controls alignment path display
for object snap tracking. When cleared, no polar tracking path is
displayed.

■ Display Full Screen Tracking Vector.  Controls alignment path
display for object snap tracking. When cleared, an alignment path is
displayed only from the object snap point to the cursor.

■ Display AutoTrack Tooltip.  Controls the display of AutoTrack
tooltips. Tooltips tell you the type of object snap (for object snap
tracking), alignment angle, and distance from the previous point.

3 Under Alignment Point Acquisition, select a method for acquiring object
points for object snap tracking:

■ Automatic.  Acquires object points automatically. If you select this
option, you can press SHIFT to not acquire an object point

■ Shift to Acquire. Acquires object points only when you press SHIFT
while the cursor is over an object snap point.
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Specify Distances
When specifying a point, you can enter distances, offsets, and measured
intervals.

Enter Direct Distances

You can specify a point by moving the cursor to indicate a direction and then
entering the distance.

To specify a line length quickly, without entering coordinate values, you can
specify a point by moving the cursor to indicate a direction and then entering
the distance from the first point.

You can use direct distance entry to specify points for all commands requiring
more than one point. When Ortho mode or polar tracking is on, this method
is an efficient way to draw lines of specified length and direction, and to move
or copy objects.

NOTE The direct distance entry method is not available while you are using the
temporary override keys for Ortho mode, object snap tracking, or polar tracking.

See also:

“Use Polar Tracking and PolarSnap” on page 350
“Lock an Angle for One Point (Angle)” on page 353

To draw a line using direct distance entry

1 Start the LINE command and specify the first point.

2 Move the pointing device until the rubber-band line extends at the same
angle as the line you want to draw.

3 Enter a distance on the command line.

The line is drawn at the length and angle you specified.

Offset from Temporary Reference Points

You can establish a temporary reference point as a base point for offsetting
subsequent points.

The From command modifier establishes a temporary reference point as a
base point for offsetting subsequent points. The From method does not
constrain the cursor to orthogonal movement. The From method usually is
used in combination with object snaps.
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To offset a point from a temporary reference point

1 At a prompt for a point, enter from.

2 If you want to offset from a location on an existing object, specify an
object snap method. Then select the object.

3 Enter a relative coordinate.

Press SHIFT and right-click to display the object snap menu.

Object Snap toolbar

Specify Intervals on Objects

You can mark off equal distances along objects.

Overview of Specifying Intervals on Objects

Provides a high-level overview of two options for marking off equal distances
along objects.

Sometimes you need to create points or insert symbols (blocks) at intervals
on an object.

You can

■ Specify the length of the segments ()

■ Specify the number of equal segments ()

You can measure or divide lines, arcs, splines, circles, ellipses, and polylines.
With both methods, you can identify the intervals by inserting either a point
or a block.

By specifying points, you can use the Node object snap to align other objects
at intervals on the measured or divided object. By specifying blocks, you can
create precise geometric constructions or insert custom markers. The blocks
can rotate at each insertion point.

You cannot insert a block unless it has already been defined within the
drawing. Variable attributes within the block are not included when you insert
the block references.
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The points or blocks you draw using MEASURE or DIVIDE are placed in a
selection set. Therefore, if you want to edit them immediately, you can use
the Previous option of .

See also:

“Create and Use Blocks (Symbols)” on page 451

Specify Measured Intervals on Objects

You can mark off equal lengths from one end of a selected object.

You can use  to mark an object at specified intervals. You can mark the intervals
with either points or blocks. The last segment of a measured object may be
shorter than the interval you specify.

The starting point for measurements or divisions varies with the object type.
For lines or open polylines, the starting point is the endpoint closest to the
selection point. For closed polylines, it is the polyline start point. For circles,
it is at the angle from the center point that is equivalent to the current snap
angle. For example, if the snap angle is 0, the circle starts at the three o'clock
position and continues counterclockwise.

If the point marker is displayed as a single dot (the default setting), you may
not be able to see the measured intervals. You can change the style of the
point markers using several methods. To change the point style in a dialog
box, you can use , or choose Point Style from the Format menu. The  system
variable also controls the appearance of point markers. For example, you can
change the value to make points appear as crosses.  controls the size of point
objects.

To insert points at measured intervals on an object

1 Click Draw menu ➤ Point ➤ Measure.

2 Select a line, arc, spline, circle, ellipse, or polyline.

3 Enter an interval length, or specify points to indicate a length.

Points are placed on the object at the specified intervals.

To insert blocks at measured intervals on an object

1 If necessary, create the block you want to insert.

2 Click Draw menu ➤ Point ➤ Measure.

3 Select a line, arc, spline, circle, ellipse, or polyline.

4 Enter b (Block).
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5 Enter the name of the block you want to insert.

6 Enter y to align the blocks with the measured object. Enter n to use a
rotation angle of 0 degrees.

7 Enter an interval length, or specify points to indicate a length.

Blocks are inserted on the object at the specified intervals.

,

Divide an Object into Equal Segments

You can divide a selected object into a specified number of equal lengths.

You can create points or insert blocks on an object at a specific number of
equal intervals. This operation does not actually break an object into individual
objects; it only identifies the location of the divisions so that you can use
them as geometric reference points.

object selected blocks indicating
five divisions

points indicating
divisions

object selected

The starting point for measurements or divisions varies with the object type.
For lines or open polylines, the starting point is the endpoint closest to the
selection point. For closed polylines, it is the polyline start point. For circles,
it is at the angle from the center point that is equivalent to the current snap
angle. For example, if the snap angle is 0, the circle starts at the three o'clock
position and continues counterclockwise.

If the point marker is displayed as a single dot (the default setting), you may
not be able to see the segments. You can change the style of the point markers
using several methods. To change the point style in a dialog box, you can use
, or choose Point Style from the Format menu. The  system variable also
controls the appearance of point markers. For example, you can change the
value to make points appear as crosses.  controls the size of point objects.

To insert points to mark equal segments

1 Click Draw menu ➤ Point ➤ Divide.

2 Select a line, circle, ellipse, polyline, arc, or spline.

3 Enter the number of segments you want.
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A point is placed between each segment.

To insert blocks to mark equal segments on an object

1 If necessary, create the block you want to insert.

2 Click Draw menu ➤ Point ➤ Divide.

3 Select a line, arc, circle, ellipse, polyline, or spline.

4 Enter b (Block).

5 Enter the name of the block you want to insert.

6 Enter y to align the blocks with the divided object. Enter n to use a
rotation angle of 0 degrees.

7 Enter the number of segments you want.

,

Extract Geometric Information from Objects
The inquiry and calculation commands can provide information about objects
in your drawing and do useful calculations.

Obtain Distances, Angles, and Point Locations

You can retrieve information about the relation between two specified points:
for example, the distance between them or their angle in the XY plane.

To determine the relation between two points, you can display the

■ Distance between them

■ Angle between the points in the XY plane

■ Angle of the points from the XY plane

■ Delta, or changed, X, Y, and Z distances between them
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angle in XY plane

angle from XY plane

delta X

delta Y

delta Z

The  command lists the X, Y, and Z coordinate values of a specified point.

See also:

“Overview of Coordinate Entry” on page 312

To calculate a distance and angle

1 Click Tools menu ➤ Inquiry ➤ Distance.

2 Specify the first and second points of the distance you want to calculate.

A brief report is displayed on the command line.

Inquiry toolbar

Obtain Area Information

You can obtain the area and perimeter defined by selected objects or a sequence
of points.

You can calculate and display the area and perimeter of a sequence of points
or of any of several types of objects. If you need to calculate the combined
area of more than one object, you can keep a running total as you add or
subtract one area at a time from the selection set. You cannot use window
selection or crossing selection to select objects.

Total area and perimeter are saved in the  and  system variables.
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Calculate a Defined Area

You can measure an arbitrary closed region defined by the points you specify.
The points must lie on a plane parallel to the XY plane of the current UCS.

1

23

4

56

7

points specified arbitrary closed region

Calculate the Area, Perimeter, or Circumference of an Object

You can calculate the enclosed area and perimeter or circumference of circles,
ellipses, polylines, polygons, regions, and AutoCAD 3D solids. The displayed
information differs according to the type of object you select:

■ Circles. Area and circumference are displayed.

■ Ellipses, closed polylines, polygons, planar closed spline curves,
and regions. Area and perimeter are displayed. For wide polylines, this
area is defined by the center of the width.

■ Open objects such as open spline curves and open polylines. Area
and length are displayed. The area is computed as though a straight line
connected the start point and endpoint.

■ AutoCAD 3D solids. Total 3D area for the object is displayed.
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Example: How Various Areas Are Calculated

closed polyline calculated area

calculated areawide polyline

calculated areaopen polyline

polyline
selected

polyline
selected

polyline
selected

Calculate Combined Areas

You can measure more than one area, either by specifying points or by selecting
objects. For example, you can measure the total area of selected rooms in a
floor plan.

Subtract Areas from Combined Areas

You can subtract one or more areas from a combined area that you have
already calculated. In the example, the area of the floor plan is first calculated,
and then a room is subtracted.
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Example: Subtraction of Areas from a Calculation

In the following example, the closed polyline represents a metal plate with
two large holes. You first calculate the area of the polyline and then subtract
each hole. Area and perimeter or circumference of each object are displayed,
with a running total after each step.

Here is the command line sequence:

Command: area
Specify first corner point or [Object/Add/Subtract]: a
Specify first corner point or [Object/Subtract]: o
(ADD mode) Select objects: Select the polyline (1)
Area = 0.34, Perimeter = 2.71
Total area = 0.34
(ADD mode) Select objects: Press  ENTER
Specify first corner point or [Object/Subtract]: s
Specify first corner point or [Object/Add]: o
(SUBTRACT mode) Select objects: Select the lower circle (2)
Area = 0.02, Circumference = 0.46
Total area = 0.32
(SUBTRACT mode) Select objects: Select the upper circle (3)
Area = 0.02, Circumference = 0.46
Total area = 0.30
(SUBTRACT mode) Select circle or polyline: Press  ENTER
Specify first corner point or [Object/Add]: Press  ENTER

1
2

3

total area

You can also use  to convert the plate and the holes to regions, subtract the
holes, and then use the Properties palette or the  command to find the area
of the plate.

See also:

“Create and Combine Areas (Regions)” on page 421
“Overview of Object Properties” on page 264

To calculate an area you define

1 Click Tools menu ➤ Inquiry ➤ Area.

2 Specify points in a sequence that defines the perimeter of the area to be
measured. Then press ENTER.
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The first and last points are connected to form a closed area and the area
and perimeter measurements are displayed using the settings specified
with UNITS.

Inquiry toolbar

To calculate the area of an object

1 Click Tools menu ➤ Inquiry ➤ Area.

2 On the command line, enter o (Object).

3 Select an object.

The area and perimeter of the selected object are displayed.

Inquiry toolbar

To add areas as you calculate

1 Click Tools menu ➤ Inquiry ➤ Area.

2 Enter a (Add).

3 Use one of the following methods:

■ Specify points to define the area you want to add and press ENTER.

■ Enter o (Object) and select the objects you want to add.

You see the measurements of each new area and a running total of
all areas.

4 Press ENTER twice to end the command.

Inquiry toolbar

To subtract areas from a calculation

1 While a combined area is displayed, enter s (Subtract).
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2 Use one of the following methods:

■ Specify points to define the area you want to subtract and press ENTER.

■ Enter o (Object) and select the objects you want to subtract.

The running total is updated as you define new areas.

3 Press ENTER to end the command.

Inquiry toolbar

Use a Calculator
You can access a calculator function as you work with the program. You can
use either the QuickCalc calculator interface or the command line calculator.

Use the QuickCalc Calculator

With the QuickCalc calculator, an interface that looks and functions like a
hand-held calculator, you can perform mathematical, scientific, and geometric
calculations, convert units of measurement, manipulate the properties of
objects, and evaluate expressions.

Overview of QuickCalc

The QuickCalc calculator includes basic features similar to most standard
mathematical calculators. In addition, QuickCalc has features specific to
AutoCAD such as geometric functions, a Units Conversion area, and a Variables
area.

Unlike most calculators, QuickCalc is an expression builder. For greater
flexibility, it does not immediately calculate an answer when you click a
function. Instead, you compose an expression that you can easily edit and,
when you are finished, you click the equal sign (=) or press ENTER. Later, you
can retrieve the expression from the History area, modify it, and recalculate
the results.

With QuickCalc, you can

■ Perform mathematical and trigonometric calculations

■ Access and review previously entered calculations for re-evaluation
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■ Use the calculator with the Properties palette to modify object properties

■ Convert units of measurement

■ Perform geometric calculations related to specific objects

■ Copy and paste values and expressions to and from the Properties palette
and the command line

■ Perform computations on mixed numbers (fractions), and feet and inches

■ Define, store, and use calculator variables

■ Use geometric functions from the CAL command
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Change QuickCalc Size and Appearance

Click the More/Less button on the calculator and only the Input box and
History area are displayed. You can use the expand/collapse arrows to open
and close areas. You can also control the size, location, and appearance of
QuickCalc. See “Set Interface Options” on page 80.

To clear the Input box

Do one of the following:

■ On the QuickCalc toolbar, click the Clear button.
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■ On the QuickCalc Number Pad, click the Clear button.

Any current value or expression in the Input box is cleared and the value
is reset to 0.

To use basic math functions in QuickCalc

1 On the Number Pad, click a number.

2 Click an operator (+, -, *, /) button. Then enter the next number, and so
on.

3 Click the equal (=) sign.

The result is displayed in the Input box. The expression and result are
also displayed in the History area.

To use scientific functions in QuickCalc

1 On the Number Pad, enter a value.

2 In the Scientific area, click a function.

3 On the Number Pad, click the equal (=) sign.

1 The result is displayed in the Input box.

To get the absolute value of a number using QuickCalc

1 With the current value displayed, in the Scientific area click the abs
button.

2 On the Number Pad, click the equal (=) sign.

1 The absolute value is displayed in the Input box.

To round a number to the nearest integer using QuickCalc

1 With the current value displayed, in the Scientific area click the rnd
button.

2 On the Number Pad, click the equal (=) sign.

1 The number, rounded to the nearest integer, is displayed in the Input
box.
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To display only the integer portion of a number with QuickCalc

1 With the current value displayed, in the Scientific area click the trunc
button.

2 On the Number Pad, click the equal (=) sign.

1 The integer portion of the number is displayed in the Input box without
the decimal portion.

To store a value in the QuickCalc memory

■ With the current value displayed, click MS.

■ The previous value is overwritten and the new value is stored in memory.

To add the current value to the value stored in the QuickCalc memory

■ With the current value displayed, click M+.

■ The sum of the new value and the value already in memory are displayed.

To restore the value stored north QuickCalc memory

■ With the current value displayed, click MR.

■ The displayed value or expression is appended and the value stored in
memory is displayed.

To clear the value stored in the QuickCalc memory

■ Click MC.

■ The value currently stored in memory is cleared.

Access QuickCalc and Understand Its Behavior

There are three ways to work with QuickCalc within the program:

■ Directly from the Tools menu, the Standard toolbar, a shortcut menu, or
the Command prompt

■ Transparently during a command from a shortcut menu or the command
line

■ Transparently from the Properties palette
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The method that you choose depends on how you are using QuickCalc.

Use QuickCalc Directly

When you work directly with QuickCalc, you can perform calculations and
unit conversions just as you would with a desktop calculator. You can use the
Windows clipboard (CTRL+C, CTRL+V) to transfer the results of your
calculations to other parts of the program or to external programs. Calculations
that you perform directly do not affect or change anything in your drawing.

You can access QuickCalc directly in the following ways:

■ On the Tools menu, click QuickCalc

■ On the Standard toolbar, click the QuickCalc button

■ In the drawing editor (with no command active), right-click, and then click
QuickCalc

■ On the command line, enter quickcalc or qc, and then press ENTER

Use QuickCalc Transparently from Within a Command

During a command, you can access QuickCalc transparently in the following
ways:

■ Right-click to display the shortcut menu. Click QuickCalc.

■ Enter ‘quickcalc or ‘qc on the command line.

Calculations that you transfer to the command affect the drawing. For example,
if you are drawing a line with the LINE command and you pass an expression
to the command line from the calculator, the next point of the line uses the
results, which might be a distance or coordinate value. In QuickCalc, you click
the Apply button to pass the value to the drawing based on that expression.

NOTE When using QuickCalc transparently to calculate a value for direct distance
entry, Apply transfers the value to the command line. To use the value, position
the crosshairs to determine the direction and then press ENTER.

Use QuickCalc Transparently from the Properties Palette

■ Click any box in the Properties palette that contains a numeric value. Then
click the QuickCalc button that appears in the box.

■ After calculating a value, transfer the result to the Properties palette by
clicking the Apply button.

374 | Chapter 23   Use Precision Tools



The object or drawing property is modified and the changes are displayed in
the drawing.

To use the QuickCalc calculator

Do one of the following:

■ On the command line, enter quickcalc or qc .

■ Right-click the drawing area to display a shortcut menu. Click QuickCalc.

■ On the Tools menu, click QuickCalc.

■ On the Standard toolbar, click QuickCalc.

To use the QuickCalc calculator within a command

Do one of the following:

■ On the command line, enter ‘quickcalc or ‘qc.

■ Right-click to display a shortcut menu. Click QuickCalc.

To use the QuickCalc calculator with the Properties palette

1 Open the Properties palette.

2 Click one or more objects.

3 Click a box with a numeric property.

4 Click the QuickCalc button in the box.

Enter, Evaluate, and Retrieve Expressions

Enter expressions in QuickCalc using standard mathematical rules of
precedence; review and retrieve computations from the History area; and
understand the rules for using imperial units: length, area, and volume.

QuickCalc evaluates expressions according to the following standard
mathematical rules of precedence:

■ Expressions in parentheses first, starting with the innermost set

■ Operators in standard order: exponents first, multiplication and division
second, and addition and subtraction last

■ Operators of equal precedence from left to right
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The Input box of the calculator is where you enter and retrieve expressions.
With QuickCalc, there are two ways you can enter data in the Input box. You
can either enter expressions using the QuickCalc Number Pad buttons, or you
can use the computer keyboard or numeric keypad. To use the computer
numeric keypad, you must have NUMLOCK on.

To evaluate an expression, click the equal (=) sign on the QuickCalc Number
Pad, or press ENTER on the computer keyboard.

Understand the Syntax of Expressions

The syntax for QuickCalc expressions and command line calculator expressions
is identical. For example, to perform an operation on the vector or coordinates
5,2,0, you enter [5,2,0] in the Input box.

You can use the GETVAR function to read the value of a system variable. The
syntax is

getvar(variable_name)

For more information see CAL.

Use the History Area

The History area keeps an ongoing record of calculations, similar to the paper
tape in a physical desk calculator. You can use the History area to review
previous operations and pass them back to the Input box for re-evaluation
with different parameters.

Rules for Displaying and Handling Units

QuickCalc adheres to the following rules:

■ Results of calculations are always expressed in decimal format unless a
distance is entered in feet and inches

■ Angular values entered in the Input box are assumed to be degrees regardless
of the settings in the Drawing Units dialog box. To specify radians, grads,
and degrees, append an r, g, or d after the angle value.

■ Results of angular calculations are always expressed in degrees with full
AutoCAD precision.

When the drawing units are set to architectural units, the calculator displays
the results of calculations of imperial units in the architectural format and
rounds to the display precision (LUPREC) specified in the drawing. The results
for all other calculations display in decimal format with full precision.
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You can separate feet, inches, and fractional inches with a dash, a space, or
nothing. You can use any of the following syntax cases to enter valid feet-inch
formatted values:

■ 5’ or 60”

■ 5’-9” or 5’ 9” or 5’9”

■ 5’-1/2” or 5’ 1/2” or 5’1/2”

■ 5’-9-1/2” or 5’ 9-1/2” or 5’9-1/2”

■ 5’-9 1/2” or 5’ 9 1/2” or 5’9 1/2”

To designate inches for linear calculations, entering double quotes (“) is
optional. For example, instead of entering 5’9-1/2”, you could enter 5’9-1/2.

WARNING With imperial units, QuickCalc interprets a minus or a dash (-) as a
unit separator rather than a subtraction operation. To specify subtraction, include
at least one space before or after the minus sign. For example, to subtract 9” from
5’, enter 5’ -9” rather than 5’-9”.

You can use QuickCalc to calculate square feet and cubic feet. To enter square
or cubic feet, you must enter units using these abbreviations:

■ sq. ft. or sq ft

■ cu. ft. or cu ft

To copy and paste a value from the QuickCalc Input box

■ Right-click the value in the Input box. Click Copy.

The current entry is copied to the clipboard.

■ Click in the new location and then right-click. Click Paste.

The value is copied to the new location.

To paste a value from the QuickCalc Input box to the command line

1 On the QuickCalc toolbar, click the Paste Value to Command Line
button.

The value in the Input box is pasted into the command line.
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To clear the History area

■ On the QuickCalc toolbar, click the Clear History button.

Right-click the History area. Click Clear History.

To reuse a stored value or expression in the QuickCalc History area

1 Click the C button to clear the Input box if needed.

2 In the History area, double-click a value or expression. The value or
expression is displayed in the Input box.

NOTE The cursor must be on the value or expression to select it.

To change the font color of values or expressions in the QuickCalc History
area

1 Right-click in the History area. Click either Value Font Color or
Expression Font Color.

2 In the Color dialog box, click a Basic Color or click Define Custom Colors.

With Define Custom Colors, you can select a custom color and add it
to Custom Colors.

3 Click OK.

2 The colors you selected for values and expressions in the History area
are displayed.

Right-click Expression Font Color or Value Font Color. Click Basic Color
or Define Custom Colors.

To copy and paste an expression from the QuickCalc History area

■ Right-click the expression in the History area. Click Copy.

The current entry is copied to the clipboard.

■ Right-click in the new location. Click Paste.

The expression is copied to the new location.

To append a value or expression from the QuickCalc History area to the Input
box

■ Double-click the value or expression in the History area.

The value or expression is appended to the Input box.
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NOTE The cursor must be on the value or expression to select it.

Right-click Append Value to Input Area or Append Expression to Input Area.

To modify a property in the Properties palette with QuickCalc

1 Select an object.

NOTE If QuickCalc is displayed on your desktop when you work with the
Properties palette, it is temporarily hidden while you use the modal calculator
from within the Properties palette.

2 In the Geometry section of the Properties palette, click on the value of
a property.

A small calculator icon is displayed to the right of the value.

NOTE Only properties that are displayed with a white background can be
changed.

3 Click the calculator icon.

QuickCalc opens and displays the current value of the object in the Input
box.

4 Perform a calculation on the displayed value and click the equal sign (=)
button.

The new value is displayed in the Input box.

5 Click Apply.

NOTE The Apply button is only available for editable number-based
properties.

The calculator closes and the new value is displayed in the Properties
palette. The object is modified in the drawing.

To obtain X, Y, Z coordinate values for a point using QuickCalc

NOTE The QuickCalc toolbar Get Coordinates button uses the cur function.

1 On the QuickCalc toolbar, click the Get Coordinates button.

QuickCalc temporarily closes and you are prompted to specify a point.

2 In the drawing, click a point.

QuickCalc opens and displays the coordinate values of the point in the
Input box.
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To measure the distance between two points using QuickCalc

NOTE The QuickCalc toolbar Distance Between Two Points button uses the
dist(p1,p2) function.

1 On the QuickCalc toolbar, click the Distance Between Two Points button.

QuickCalc temporarily closes and you are prompted to specify two points.

2 In the drawing, click the first point and then the second point.

QuickCalc opens and displays the value of the distance between the two
points in the Input box.

To get the angle of a line defined by two points using QuickCalc

NOTE The QuickCalc toolbar Angle of Line Defined by Two Points button uses
the ang(p1,p2) function.

1 On the QuickCalc toolbar, click the Angle of Line Defined by Two Points
button.

QuickCalc temporarily closes and you are prompted at the command
line to specify two points.

2 Enter the coordinate values for the first point and then the second point.

QuickCalc opens and appends the value of the angle between the two
points to the end of any value or expression already present in the Input
box.

To get the intersection of a line defined by four points using QuickCalc

NOTE The QuickCalc Intersection of Two Lines Defined by Four Points button
uses the ill(p1,p2,p3,p4) function.

1 On the QuickCalc toolbar, click the Intersection of Two Lines Defined
by Four Points button.

QuickCalc temporarily closes and you are prompted at the command
line to specify four points.

2 Enter the coordinate values for the first point of line one, then the second
point of line one. Next, enter the coordinate values for the first point of
line two, then the second point of line two.

QuickCalc opens and appends the value of the evaluated expression to
the end of any value or expression already present in the Input box.
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Convert Units of Measurement

In the Units Conversion area of QuickCalc, you can obtain equivalent values
for different units of measurement.

Unit conversions are available for length, area, volume, and angular values.
Based on which unit type you select, you can then select a list of units to
convert from and a list of units to convert to.

The Value to Convert box automatically displays the value from the Input
box. You can also enter a different value. The results of the units conversion
displays in the Converted Value box. You can paste this result to the Input
box by clicking the QuickCalc icon in the Converted Value box.

NOTE In the Value to Convert box, enter decimal values without units.

To convert units of measurement with QuickCalc

1 In the Units Conversion area, select a unit category on the Units Type
list.

2 In the Convert From list, select the type of unit you are converting from.

3 In the Convert To list, select the type of unit you are converting to.

4 In the Value to Convert box, enter the value you want to convert. Press
ENTER.

1 The converted value is displayed in the Converted Value box.

To copy a unit conversion result to the Input box of QuickCalc

1 On the Units Conversion title bar, click the Return Conversion Value to
Input Area button.

1 The converted value is displayed in the Input box.

To convert radians to degrees using QuickCalc

1 On the Number Pad, enter a value in radians.
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2 In the Scientific area, click the r2d button.

3 On the Number Pad, click the equal (=) sign.

The conversion is displayed in the Input box.

To convert degrees to radians using QuickCalc

1 On the Number Pad, enter a value in degrees.

2 In the Scientific area, click the d2r button.

3 On the Number Pad, click the equal (=) sign.

The conversion is displayed in the Input box.

Create and Use Calculator Variables

You can use the Variables area to define, store, and retrieve calculator variables.
Calculator variables can either be constants (coordinates/vectors, real numbers,
and integers) or functions. In the Variables area, you can

■ Click a calculator variable to display information such as value, type, and
description in the Details box at the bottom of the Variables area.

■ Double-click a calculator variable to load it into the QuickCalc Input box.

Additional operations are available on the shortcut menus in the Variables
area.
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Create New Calculator Variables

You can create new calculator variables using the shortcut menus in the
Variables area. When defining new calculator variables in the Variable
Definition dialog box, the following rules apply:

■ Constants. Any expression entered in the Value or Expression text entry
box is evaluated before the calculator variable is stored. Calculator variables
that are defined as constants are available “globally.” You can access and
use global constants in different drawings and sessions.

■ Functions. Any expression entered in the Value or Expression text entry
box is stored as text. Functions are evaluated when used in the QuickCalc
Input box.

Create Global Constants

You can use one of the following methods to create global constants:

■ Enter an expression in the Input box using the format $ variable_name =
value. For example, to define the golden ratio to 8 decimal places as a global
constant called Phi, enter $Phi=1.61803399 in the Input box.

■ Click the New Variable button in the Variables area title bar. In the Variables
Definition dialog box, click Constant and fill in the other boxes.

■ Right-click the Variables area. Click New Variable.

Access Global Constants

You can access global constants and pass them to the Input box of the
QuickCalc as follows:

■ Double-click a variable in the Variables area of QuickCalc.

■ Click a variable from the list of calculator variables, and click the Return
Variable to Input Area button.

■ Enter a dollar sign ($) followed by the variable name, and press ENTER.

To use a global constant in a text or numeric entry box in a window or dialog
box, use the syntax: =$ variable_name followed by pressing the END key. For
example, to use the previously mentioned global variable, Phi, enter =$Phi
and press the END key.

NOTE In QuickCalc, only constants can be directly referred to by their global
variable names in the text or numeric entry boxes in windows and dialog boxes.
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Use Shortcut Functions

Several sample calculator variables have been predefined and stored in the
Shortcut Functions category. These are geometric expressions that combine
functions with the Endpoint Snap mode. The following table describes the
predefined variables that are available in the Variables area of the calculator.

DescriptionShortcut ForVariable

Distance between two endpointsdist(end,end)dee

Intersection of two lines defined by four endpointsill(end,end,end)ille

Midpoint between two endpoints(end+end)/2mee

Unit vector in the XY plane and normal to two
endpoints

nor(end,end)nee

Radius of a selected circle, arc, or polyline arcradrad

Vector from two endpointsvee(end,end)vee

Unit vector from two endpointsvec1(end,end)vee1

You can easily modify these calculator variables or create your own. For more
information, see the  command.

Organize Variables into Categories

You can organize calculator variables in the Variables area under several
categories. This results in a one-level tree structure. The Shortcut Functions
category has already been created and contains several functions.

Use the shortcut menu in the Variables area to create, rename, or delete variable
categories.

To use a predefined variable in a QuickCalc expression

1 In the Variables area, click the variable you want to use.

2 On the QuickCalc Variables title bar, click the Return Variable to Input
Area button.

The variable is displayed in the Input box as part of your expression.

To create a new variable in QuickCalc

1 On the QuickCalc Variables title bar, click the New Variable button.

2 In the Variable Definition dialog box, under Variable Type, select
Constant or Function.

384 | Chapter 23   Use Precision Tools



3 In the Variable Definition dialog box, under Variable Properties Name,
enter a name for the variable. Variable names cannot contain spaces or
special characters.

NOTE When referencing this variable from the Input box, the variable name
must begin with the dollar sign ($) to differentiate it from local LISP variables.

4 Under Variable Properties Group With, click New.

5 In the Category Definition dialog box, under Category Properties Name,
enter a name for the new category.

6 Under Description, enter a description for the new category. Click OK.

7 In the Variable Definition dialog box, under Value or Expression, enter
a value or expression for the new variable.

8 Under Description, enter a description of the new variable. Click OK.

The new variable is now displayed in the Variables area.

To edit a variable in QuickCalc

1 In the Variables area, click the variable you want to edit.

2 On the QuickCalc Variables title bar, click the Edit Variable button.

3 In the Variable Definition dialog box, make the edits to the variable.
Click OK.

To delete a variable in QuickCalc

1 In the Variables area, click the variable you want to delete.

2 On the QuickCalc Variables title bar, click the Delete button.

To create a new global constant in the Input box of QuickCalc

1 In the Input box of QuickCalc, enter the following syntax: $
variable_name = value.

For example, you could center $Phi=1.618

NOTE Global variables are not case-sensitive.

QuickCalc adds the global constant to the list of variables in the Variables
area.
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To access a global constant from dialog box or window

■ In any text or numeric entry box, enter an expression using the syntax: =$
variable_name followed by pressing the END key.

Use the Command Line Calculator

By entering an expression in the command line calculator, you can quickly
solve a mathematical problem or locate points in your drawing.

The  command runs the 3D calculator utility to evaluate vector expressions
(combining points, vectors, and numbers) and real and integer expressions.
The calculator performs standard mathematical functions. It also contains a
set of specialized functions for calculations involving points, vectors, and
AutoCAD geometry. With the CAL command, you can

■ Calculate a vector from two points, the length of a vector, a normal vector
(perpendicular to the XY plane), or a point on a line

■ Calculate a distance, radius, or angle

■ Specify a point with the pointing device

■ Specify the last-specified point or intersection

■ Use object snaps as variables in an expression

■ Convert points between a UCS and the WCS

■ Filter the X, Y, and Z components of a vector

■ Rotate a point around an axis

Evaluating Expressions

CAL evaluates expressions according to standard mathematical rules of
precedence.

Mathematical operators in order of precedence

OperationOperator

Groups expressions( )

Indicates numeric exponent^

Multiplies and divides numbers*, /

Adds and subtracts numbers+, –
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Calculating Points

You can use CAL whenever you need to calculate a point or a number within
a command.

For example, you enter (mid+cen)/2 to specify a point halfway between the
midpoint of a line and the center of a circle.

The following example uses CAL as a construction tool. It locates a center
point for a new circle, and then calculates one fifth of the radius of an existing
circle.

1
2 and 3

center of circle

(mid+cen)/2

Here is the command line sequence:

Command: circle
Specify center point for circle or [3P/2P/Ttr (tan tan radius)]: 'cal
>> Expression: (mid+cen)/2
>> Select entity for MID snap: Select the notch line (1)
>> Select entity for CEN snap: Select the large circle (2)
Diameter/<Radius>: 'cal
>> Expression: 1/5*rad
>> Select circle, arc or polyline segment for RAD function: Select the large circle(3)

No procedures for this topic.
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Draw Geometric Objects

 
You can create a range of objects, from simple lines and circles

to spline curves, and ellipses. In general, you draw objects by

specifying points with the pointing device or by entering

coordinate values on the command line.

19
In this chapter

■ Draw Linear Objects

■ Draw Curved Objects

■ Draw Construction and
Reference Geometry

■ Create and Combine Areas
(Regions)

■ Create 3D Objects

■ Create Revision Clouds



Draw Linear Objects
A line, the most basic object, can be one segment or a series of connected
segments.

Draw Lines

In a simple line with connected segments, each segment is a separate line
object.

With , you can create a series of contiguous line segments.

Each single line segment can be edited separately from the other line segments
in a series. You can close a sequence of line segments so that the first and last
segments are joined.

You can assign properties to lines including color, linetype, and lineweight.
For more information about properties, see “Control the Properties of Objects”
on page 263.

You specify the locations that define the endpoints of each line with precision.
You can

■ Enter the coordinate values for an endpoint, using either absolute or relative
coordinates

■ Specify an object snap relative to an existing object. For example, you can
specify the center of a circle as one endpoint of the line

■ Turn grid snap on and snap to a location

There are other methods for creating precise lines. A highly efficient technique
is to offset a line from an existing line, and then trim or extend it to the desired
length.

Use polyline objects instead of line objects if you want the segments to be
connected as a single object.

See also:

“Use Coordinates and Coordinate Systems” on page 312
“Use Object Snaps” on page 341
“Adjust Grid and Grid Snap” on page 347
“Draw Polylines” on page 391
“Offset an Object” on page 610
“Break and Join Objects” on page 634
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To draw lines

1 Click Draw menu ➤ Line.

2 Specify the start point.

You can use the pointing device or enter coordinate values on the
command line.

3 Complete the first line segment by specifying the endpoint.

To undo the previous line segment during the LINE command, enter u
or click Undo on the toolbar.

4 Specify the endpoints of any additional line segments.

5 Press  ENTER  to end or c to close a series of line segments.

To start a new line at the endpoint of the last line drawn, start the LINE
command again and press  ENTER  at the Specify Start Point prompt.

Draw toolbar

Draw Polylines

A polyline is a connected sequence of line segments created as a single object.
You can create straight line segments, arc segments, or a combination of the
two.

pipe symbol differing widths an insulated wall

Multisegmented lines provide editing capabilities unavailable for single lines.
For example, you can adjust their width and curvature. After you've created
a polyline, you can edit it with  or use  to convert it to individual line and arc
segments. You can

■ Convert a spline-fit polyline into a true spline with

■ Use closed polylines to create a polygon
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■ Create a polyline from the boundaries of overlapping objects

Create Arc Polylines

When you draw arc segments in a polyline, the first point of the arc is the
endpoint of the previous segment. You can specify the angle, center point,
direction, or radius of the arc. You can also complete the arc by specifying a
second point and an endpoint.

Create Closed Polylines

You can draw a closed polyline to create a polygon. To close a polyline, specify
the starting point of the last side of the object, enter c (Close), and press
ENTER .

Create Wide Polylines

You can draw polylines of various widths by using the Width and Halfwidth
options. You can set the width of individual segments and make them taper
gradually from one width to another. These options become available after
you specify a starting point for the polyline.

varying width uniform width

The Width and Halfwidth options set the width of the next polyline segments
you draw. Zero (0) width produces a thin line. Widths greater than zero
produce wide lines, which are filled if Fill mode is on and outlined if Fill mode
is off. The Halfwidth option sets width by specifying the distance from the
center of the wide polyline to an outside edge.

Taper

When you use the Width option, you are prompted for both a starting and
an ending width. By entering different values, you can taper the polyline. The
starting and ending points of wide polyline segments are in the center of the
line. Intersections of adjacent wide segments are usually beveled. However,
nontangent arc segments, acute angles, or segments that use a dash-dot
linetype are not beveled.

Create Polylines from the Boundaries of Objects

You can create a polyline from the boundaries of overlapping objects that
form a closed area. A polyline created using the boundary method is a separate
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object, distinct from the objects used to create it. You can edit it using the
same methods used to edit other polylines.

To expedite the boundary selection process in large or complex drawings, you
can specify a group of boundary candidates, called a boundary set. You create
this set by selecting the objects you want to use define the boundary.

internal point
selected

boundary

See also:

“Draw Rectangles and Polygons” on page 395
“Modify Complex Objects” on page 645
“Break and Join Objects” on page 634
“Control Lineweights” on page 301

To draw a polyline with straight segments

1 Click Draw menu ➤ Polyline.

2 Specify the first point of the polyline.

3 Specify the endpoint of the first polyline segment.

4 Continue specifying segment endpoints as needed.

5 Press  ENTER  to end, or enter c to close the polyline.

To start a new polyline at the endpoint of the last polyline drawn, start
the PLINE command again and press  ENTER  at the Specify Start Point
prompt.

Draw toolbar

To draw a line and arc combination polyline

1 Click Draw menu ➤ Polyline.

2 Specify the start point of the polyline segment.
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3 Specify the endpoint of the polyline segment.

■ Switch to Arc mode by entering a (Arc) on the command line.

■ Return to Line mode by entering L (Line).

4 Specify additional polyline segments as needed.

5 Press  ENTER  to end, or enter c to close the polyline.

Draw toolbar

To create a wide polyline

1 Click Draw menu ➤ Polyline.

2 Specify the start point of the line segment.

3 Enter w (Width).

4 Enter the starting width of the line segment.

5 Specify the ending width of the line segment using one of the following
methods:

■ To create a line segment of equal width, press  ENTER .

■ To create a tapering line segment, enter a different width.

6 Specify the endpoint of the polyline segment.

7 Continue specifying segment endpoints as needed.

8 Press  ENTER  to end, or enter c to close the polyline.

Draw toolbar

To create a boundary polyline

1 Click Draw menu ➤ Boundary.

2 In the Boundary Creation dialog box, in the Object Type list, select
Polyline.
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3 Under Boundary Set, do one of the following:

■ To create a boundary set from all objects visible in the current
viewport, select Current Viewport. Avoid this option for large, complex
drawings.

■ To specify which objects to include in the boundary set, click New.
Select the objects that you want to use to create the boundary. Using
this option automatically selects the Existing Set option.

4 Click Pick Points.

5 Specify points within each area that you want to form a boundary
polyline.

This area must be totally enclosed; that is, there can be no gaps between
enclosing objects. You can select more than one area. Click Island
Detection if you want internal closed areas to be included in the
boundary set.

6 Press  ENTER  to create the boundary polyline and end the command.

The command creates a polyline in the shape of the boundary. Because
this polyline overlaps the objects used to create it, it may not be visible.
However, you can move, copy, or modify it just as you can any other
polyline.

Draw Rectangles and Polygons

You can create rectangles and regular polygons quickly. Creating polygons is
a simple way to draw equilateral triangles, squares, pentagons, hexagons, and
so on.

Two commands, RECTANG and POLYGON, provide an efficient method to
create rectangles and regular polygons such as equilateral triangles, squares,
pentagons, hexagons, and so on. If necessary, you can use  to convert the
resulting polyline object into lines.

Draw Rectangles

Use  to create closed polylines in a rectangular shape. You can specify the
length, width, area, and rotation parameters. You can also control the type
of corners on the rectangle—fillet, chamfer, or square.

Draw Regular Polygons

Use  to create closed polylines with between 3 and 1,024 equal-length sides.
The following illustrations show polygons created using three methods. In
each case, two points are specified.
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inscribed circumscribed edge

1

2

1

2

edge start point

edge endpoint

See also:

“Draw Polylines” on page 391

To draw a circumscribed polygon

1 Click Draw menu ➤ Polygon.

2 On the command line, enter the number of sides.

3 Specify the center of the polygon (1).

4 Enter c to specify a polygon circumscribed about a circle.

5 Enter the radius length (2).

2

1

Draw toolbar

To draw a polygon by specifying one edge

1 Click Draw menu ➤ Polygon.

2 On the command line, enter the number of sides.

3 Enter e (Edge).
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4 Specify the start point for one polygon segment.

5 Specify the endpoint of the polygon segment.

Draw toolbar

To draw an inscribed polygon

1 Click Draw menu ➤ Polygon.

2 On the command line, enter the number of sides.

3 Specify the center of the polygon.

4 Enter i to specify a polygon inscribed within a circle of specified points.

5 Enter the radius length.

Draw toolbar

To draw a rectangle

1 Click Draw menu ➤ Rectangle.

2 Specify the first corner of the rectangle.

3 Specify the other corner of the rectangle.

Draw toolbar

Draw Multiple-Line Objects

Multilines are composed of 1 to 16 parallel lines, called elements.

When you draw a multiline, you can use the STANDARD style, which has two
elements, or specify a style that you created previously. You can also change
the justification and scale of the multiline before you draw it.

Multiline justification determines which side of the cursor that the multiline
is drawn, or whether it is centered on the cursor.
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Multiline scale controls the overall width of the multiline using the current
units. Multiline scale does not affect linetype scale. If you change the multiline
scale, you might need to make equivalent changes to the linetype scale to
prevent dots or dashes from being disproportionately sized.

Create Multiline Styles

You can create named styles for multilines to control the number of elements
and the properties of each element. The properties of multilines include

■ The total number of elements and position of each element

■ The offset distance for each element from the middle of the multiline

■ The color and linetype of each element

■ The visibility of the lines, called joints, that appear at each vertex

■ The type of end caps that are used

■ The background fill color of the multiline

end caps

three elements

ten elements

five elements

You can add up to 16 elements to a multiline style. Elements with a positive
offset appear on one side of the middle of the multiline; elements with a
negative offset appear on the other side of the middle of the multiline.

See also:

“Modify Multilines” on page 653

To draw a multiline

1 Click Draw menu ➤ Multiline.

2 At the Command prompt, enter st to select a style.

3 To list available styles, enter the style name or enter ?.

4 To justify the multiline, enter j and select top, zero, or bottom
justification.
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5 To change the scale of the multiline, enter s and enter a new scale.

Now draw the multiline.

6 Specify the starting point.

7 Specify a second point.

8 Specify additional points, or press  ENTER . If you specify three or more
points, you can enter c to close the multiline.

To create a multiline style

1 Click Format menu ➤ Multiline Style.

2 In the Multiline Style dialog box, click New.

3 In the Create New Multiline Style dialog box, enter a name for the
multiline style and select a multiline style from which to start. Click
Continue.
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4 In the New Multiline Style dialog box, select the parameters for the
multiline style. You can also enter a description.

Descriptions are optional and can be up to 255 characters, including
spaces.

5 Click OK.

6 In the Multiline Style dialog box, click Save to save the multiline style
to a file (the default is acad.mln). You can save multiline styles to the
same file.

If you create more than one multiline style, save the current style before
creating a new one or you lose the changes to the first style.

Draw Freehand Sketches

Sketching is useful for creating irregular boundaries or for tracing with a
digitizer.

You can use the  command to draw freehand sketches. Sketching is useful for
creating irregular boundaries or for tracing with a digitizer.

400 | Chapter 24   Draw Geometric Objects



sketch lines

Create Sketches

To sketch, use the pointing device like a pen, clicking to put the “pen” down
on the screen to draw and clicking again to lift it up and stop drawing.
Freehand sketches comprise many line segments. Each line segment can be a
separate object or a polyline. You set the minimum length or increment of
the segments. Small line segments allow for greater accuracy, but they can
greatly increase the drawing file size. For this reason, use this tool sparingly.

Before sketching, check the system variable to make sure the current linetype
is BYLAYER. If you use a linetype with dots or dashes and set the sketch line
segment shorter than the spaces or dashes, you won’t see the spaces or dashes.

Erase Freehand Lines

You erase freehand lines by using the Erase option of the SKETCH command.
In Erase mode, wherever the cursor intersects the freehand line, everything
from the intersection to the end of the line is erased.

Once you record freehand lines, you can’t edit them or erase them with the
Erase option of SKETCH. Use the  command after you finish sketching.

Sketch in Tablet Mode

You use Tablet mode with a digitizer. Sketching in Tablet mode is useful for
such things as tracing map outlines from paper directly into a drawing. You
can’t turn off Tablet mode while sketching.

When Tablet mode is on, you can configure the program to map the paper
drawing’s coordinate system directly into the world coordinate system. Thus,
there is a direct correlation between the coordinates where screen crosshairs
appear, the coordinates on the tablet, and the coordinates in the original paper
drawing. After configuring the program to match the coordinates of the paper
drawing, you may find that the area shown on the screen is not the area you
need. To avoid this problem, use  to display the entire work area before you
start to sketch.
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With some digitizers you can’t select the menus while Tablet mode is on. See
your digitizer documentation for details.

Maintain Sketching Accuracy

To ensure accuracy on a slow computer, set the record increment value to a
negative value. SKETCH uses this value as if it was positive but tests every
point received from the pointer against twice the record increment. If the
point is more than two record increments away, your computer beeps as a
warning that you should slow down to avoid losing accuracy. For example,
if the record increment is –1, you should move the cursor in increments of
no more than 2. Using this method does not slow down the tracing speed.

To sketch and record freehand lines

1 At the Command prompt, enter sketch.

2 At the Record Increment prompt, enter the minimum line segment
length.

3 Click the start point to put the “pen” down.

When you move the pointing device, temporary freehand line segments
of the length you specified are drawn. SKETCH doesn’t accept coordinate
input. During the command, freehand lines are displayed in a different
color.

4 Click the endpoint to lift the “pen” up so that you can move the cursor
around the screen without drawing. Click a new start point to resume
drawing from the new cursor position.

5 Enter r at any time to record (save) the line you’re drawing in the
database and those already drawn.

If the pen is down, you can continue drawing after recording. If the pen
is up, click to resume drawing. The freehand line starts from wherever
the cursor is when you click.

6 Press  ENTER  to complete the sketch and record all unrecorded lines.

To erase freehand lines

1 While running the  command, with the pen up or down, enter e (Erase).

If the pen was down, it moves up.

2 Move the cursor to the end of the line you drew last and then move it
back as far along the line as you want to erase.

3 To end the erasure and return to the SKETCH Command prompt, enter
p. To undo the erasure, enter e.
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If you want to change the current viewport while sketching, make sure
the pen is up, all lines entered so far have been recorded, and Tablet
mode is off.

Draw Curved Objects
Curved objects are arcs, circles, polyline arcs, donuts, ellipses, and splines.

Draw Arcs

You can create arcs in several ways. With the exception of the first method,
arcs are drawn counterclockwise from the start point to the endpoint.

Draw Arcs by Specifying Three Points

You can draw an arc by specifying three points. In the following example, the
start point of the arc snaps to the endpoint of a line. The second point of the
arc snaps to the middle circle in the illustration.

1
2

3

endpoint of line

Draw Arcs by Specifying Start, Center, End

When you know the start point, center point, and endpoint, you can draw
an arc by specifying either the start point or the center point first. The center
point is the center of a circle that the arc is part of.

1

2

3

1

3

2

start(1), center(2),
end(3)

center(1), start(2),
end(3)
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Draw Arcs by Specifying Start, Center, Angle

When you have a start point and a center point you can snap to and you
know the included angle, use the Start, Center, Angle or the Center, Start,
Angle option.

included
angle

The included angle determines the endpoint of the arc. Use the Start, End,
Angle method when you know both endpoints but cannot snap to a center
point.

2
1

1

2

2

1

start, center, angle center, start, angle start, end, angle

Draw Arcs by Specifying Start, Center, Length

When you have a start point and a center point you can snap to; when you
know the chord length, use the Start, Center, Length or the Center, Start,
Length option.

1

2
2

1

chord length

chord length
start, center, length center, start, length

The length of the chord of the arc determines the included angle.
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Draw Arcs by Specifying Start, End, Direction/Radius

When you have a start point and an endpoint, use the Start, End, Direction
or the Start, End, Radius option.

The illustration on the left shows an arc drawn by specifying a start point,
endpoint, and radius. You can specify the radius by entering a length or by
moving the pointing device clockwise or counterclockwise and clicking to
specify a distance.

1

2

1
2

start, end, radius start, end, direction

radius

direction

The illustration on the right shows an arc drawn with the pointing device by
specifying a start point and an endpoint and a direction. Moving the cursor
up from the start point and endpoint draws the arc concave to the object, as
shown here. Moving the cursor down draws the arc convex to the object.

Draw Contiguous Arcs and Lines

Immediately after you complete an arc, you can start a line tangent to the arc
at an endpoint by starting the  command and pressing  ENTER  at the Specify
First Point prompt. You need to specify only the line length.

arc endpoint

resulting line

Conversely, after you complete a line, you can start an arc tangent to the line
at an endpoint by starting the  command and pressing  ENTER  at the Specify
Start Point prompt. You need to specify only the endpoint of the arc.

You can connect sequentially drawn arcs in the same way. To create connected
arcs using a menu, click Arc from the Draw menu, and then click Continue.
In both cases, the resulting object is tangent to the previous one. You can use
the shortcut menu to repeat the Continue option.
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See also:

“Draw Polylines” on page 391
“Break and Join Objects” on page 634

To draw an arc by specifying three points

1 Click Draw menu ➤ Arc ➤ 3 Points.

2 Specify the start point.

3 Specify a point on the arc.

4 Specify the endpoint.

Draw toolbar

To draw an arc using a start point, a center point, and an endpoint

1 Click Draw menu ➤ Arc ➤ Start, Center, End.

2 Specify a start point.

3 Specify the center point.

4 Specify the endpoint.

Draw toolbar

To continue an arc with a tangential line

1 Complete the arc.

2 Click Draw menu ➤ Line.

3 Press  ENTER  at the first prompt.

4 Enter the length of the line and press  ENTER .

Draw toolbar
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To continue an arc with a tangential arc

1 Complete the arc.

2 Click Draw menu ➤ Arc ➤ Continue.

3 Specify the second endpoint of the tangent arc.

Draw toolbar

Draw Circles

You can create circles in several ways. The default method is to specify the
center and the radius. Three other ways to draw a circle are shown in the
illustration.

1 2 1 2

3

center, radius two points
defining
diameter

three points
defining
circumference

tangent, tangent,
radius

tangent
objects

center

radius

radius

Draw a Circle Tangent to Other Objects

The tangent point is a point where an object touches another object without
intersecting it. To create a circle that is tangent to other objects, select the
objects and then specify the radius of the circle. In the illustrations below,
the bold circle is the one being drawn, and points 1 and 2 select the objects
to which it is tangent.
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1 2 1
2

1

2

radius of new
circle = 1

radius of new
circle = 2

radius of new
circle = 4

To create a circle tangent at three points, set running object snaps () to Tangent
and use the three-point method to create the circle.

See also:

“Use Object Snaps” on page 341
“Draw Isometric Circles”

To draw a circle by specifying a center point and radius or diameter

1 Click Draw menu ➤ Circle ➤ Center, Radius (or Center, Diameter).

2 Specify the center point.

3 Specify the radius or diameter.

Draw toolbar

To create a circle tangent to two objects

1 Click Draw menu ➤ Circle ➤ Tan, Tan, Radius.

The command starts Tangent object snap mode.

2 Select the first object to draw the circle tangent to.

3 Select the second object to draw the circle tangent to.

4 Specify the radius of the circle.

Draw toolbar
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Draw Polyline Arcs

A polyline is a connected sequence of line segments created as a single object.
You can create straight line segments, arc segments, or a combination of the
two.

pipe symbol differing widths an insulated wall

Multisegmented lines provide editing capabilities unavailable for single lines.
For example, you can adjust their width and curvature. After you've created
a polyline, you can edit it with  or use  to convert it to individual line and arc
segments. You can

■ Convert a spline-fit polyline into a true spline with

■ Use closed polylines to create a polygon

■ Create a polyline from the boundaries of overlapping objects

Create Arc Polylines

When you draw arc segments in a polyline, the first point of the arc is the
endpoint of the previous segment. You can specify the angle, center point,
direction, or radius of the arc. You can also complete the arc by specifying a
second point and an endpoint.

Create Closed Polylines

You can draw a closed polyline to create a polygon. To close a polyline, specify
the starting point of the last side of the object, enter c (Close), and press
ENTER .

Create Wide Polylines

You can draw polylines of various widths by using the Width and Halfwidth
options. You can set the width of individual segments and make them taper
gradually from one width to another. These options become available after
you specify a starting point for the polyline.
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varying width uniform width

The Width and Halfwidth options set the width of the next polyline segments
you draw. Zero (0) width produces a thin line. Widths greater than zero
produce wide lines, which are filled if Fill mode is on and outlined if Fill mode
is off. The Halfwidth option sets width by specifying the distance from the
center of the wide polyline to an outside edge.

Taper

When you use the Width option, you are prompted for both a starting and
an ending width. By entering different values, you can taper the polyline. The
starting and ending points of wide polyline segments are in the center of the
line. Intersections of adjacent wide segments are usually beveled. However,
nontangent arc segments, acute angles, or segments that use a dash-dot
linetype ar not beveled.

Create Polylines from the Boundaries of Objects

You can create a polyline from the boundaries of overlapping objects that
form a closed area. A polyline created using the boundary method is a separate
object, distinct from the objects used to create it. You can edit it using the
same methods used to edit other polylines.

To expedite the boundary selection process in large or complex drawings, you
can specify a group of boundary candidates, called a boundary set. You create
this set by selecting the objects you want to use to define the boundary.

internal point
selected

boundary

See also:

“Modify Splines” on page 650
“Modify or Join Polylines” on page 647
“Break and Join Objects” on page 634
“Control Lineweights” on page 301

410 | Chapter 24   Draw Geometric Objects



To draw a polyline with straight segments

1 Click Draw menu ➤ Polyline.

2 Specify the first point of the polyline.

3 Specify the endpoint of the first polyline segment.

4 Continue specifying segment endpoints as needed.

5 Press  ENTER  to end, or enter c to close the polyline.

To start a new polyline at the endpoint of the last polyline drawn, start
the PLINE command again and press  ENTER  at the Specify Start Point
prompt.

Draw toolbar

To draw a line and arc combination polyline

1 Click Draw menu ➤ Polyline.

2 Specify the start point of the polyline segment.

3 Specify the endpoint of the polyline segment.

■ Switch to Arc mode by entering a (Arc) on the command line.

■ Return to Line mode by entering L (Line).

4 Specify additional polyline segments as needed.

5 Press  ENTER  to end, or enter c to close the polyline.

Draw toolbar

To create a wide polyline

1 Click Draw menu ➤ Polyline.

2 Specify the start point of the line segment.

3 Enter w (Width).

4 Enter the starting width of the line segment.
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5 Specify the ending width of the line segment using one of the following
methods:

■ To create a line segment of equal width, press  ENTER .

■ To create a tapering line segment, enter a different width.

6 Specify the endpoint of the polyline segment.

7 Continue specifying segment endpoints as needed.

8 Press  ENTER  to end, or enter c to close the polyline.

Draw toolbar

To create a boundary polyline

1 Click Draw menu ➤ Boundary.

2 In the Boundary Creation dialog box, in the Object Type list, select
Polyline.

3 Under Boundary Set, do one of the following:

■ To create a boundary set from all objects visible in the current
viewport, select Current Viewport in the list. Avoid this option for
large, complex drawings.

■ To specify which objects to include in the boundary set, click New.
Select the objects that you want to use to create the boundary.
Choosing this option automatically selects the Existing Set option.

4 Click Pick Points.

5 Specify points within each area that you want to form a boundary
polyline.

This area must be totally enclosed; that is, there can be no gaps between
enclosing objects. You can select more than one area.

6 Press  ENTER  to create the boundary polyline and end the command.

The command creates a polyline in the shape of the boundary. Because
this polyline overlaps the objects used to create it, it may not be visible.
However, you can move, copy, or modify it just as you can any other
polyline.
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Draw Donuts

Donuts are filled rings or solid-filled circles that actually are closed polylines
with width.

To create a donut, you specify its inside and outside diameters and its center.
You can continue creating multiple copies with the same diameter by
specifying different center points. To create solid-filled circles, specify an inside
diameter of 0.

filled rings solid-filled circles

donut
donuts

To create a donut

1 Click Draw menu ➤ Donut.

2 Specify the inside diameter (1).

3 Specify the outside diameter (2).

4 Specify the center of the donut (3).

5 Specify the center point for another donut, or press  ENTER  to complete
the command.

2

1

3
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Draw Ellipses

The shape of an ellipse is determined by two axes that define its length and
width. The longer axis is called the major axis, and the shorter one is the
minor axis.

endpoints of first axis minor axis

midpoint of first
axis

distance

major axis

distance

The illustrations below show two different ellipses created by specifying axis
and distance. The third point specifies only a distance and does not necessarily
designate the axis endpoint.

1 2

3

1 2

3

first axis as major axis first axis as minor
axis

If you are drawing on isometric planes to simulate 3D, you can use ellipses to
represent isometric circles viewed from an oblique angle. First you need to
turn on Isometric Snap in the Drafting Settings dialog box.

See also:

“Draw Isometric Circles”
“Break and Join Objects” on page 634

To draw an isometric circle

1 Click Tools menu ➤ Drafting Settings.
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2 In the Drafting Settings dialog box, Snap and Grid tab, under Snap Type
and Style, click Isometric Snap. Click OK.

3 Click Draw menu ➤ Ellipse ➤ Axis, End.

4 Enter i (Isocircle).

5 Specify the center of the circle.

6 Specify the radius or diameter of the circle.

Draw toolbar

To draw a true ellipse using endpoints and distance

1 Click Draw menu ➤ Ellipse ➤ Axis, End.

2 Specify the first endpoint of the first axis (1).

3 Specify the second endpoint of the first axis (2).

4 Drag the pointing device away from the midpoint, and click to specify
a distance (3) for half the length of the second axis.

1

3

2

Draw toolbar

To draw an elliptical arc using start and end angles

1 Click Draw menu ➤ Ellipse ➤ Arc.

2 Specify endpoints for the first axis (1 and 2).

3 Specify a distance to define half the length of the second axis (3).
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4 Specify the start angle (4).

5 Specify the end angle (5).

The elliptical arc is drawn counterclockwise between the start point and
endpoint.

1

2

4

3

5

Draw toolbar

Draw Splines

A spline is a smooth curve that passes through or near a given set of points.
You can control how closely the curve fits the points.

The  command creates a particular type of spline known as a nonuniform
rational B-spline (NURBS) curve. A NURBS curve produces a smooth curve
between control points.

splines

You create splines by specifying points. You can close the spline so that the
start and endpoints are coincident and tangent.

Tolerance describes how closely the spline fits the set of fit points you specify.
The lower the tolerance, the more closely the spline fits the points. At zero
tolerance, the spline passes through the points. You can change the
spline-fitting tolerance while drawing the spline to see the effect.
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You can use two methods for creating splines:

■ Create spline curves with the Spline option of  to smooth existing polylines
created with . Such spline-fit polylines are created with uniform knot vectors
and are more likely to be included in drawings created with earlier versions
of the product.

■ Create splines, which are NURBS curves, with . Drawings containing splines
use less memory and disk space than those containing spline-fit polylines
of similar shape.

You can easily convert spline-fit polylines into true splines with SPLINE.

See also:

“Modify Splines” on page 650
“Break and Join Objects” on page 634

To convert a spline-fit polyline to a spline

1 Click Draw menu ➤ Spline.

2 Enter o (Object).

3 Select a spline-fit polyline and press  ENTER .

The selected object changes from a polyline to a spline.

To convert a spline by specifying points

1 Click Draw menu ➤ Spline.

2 Specify the start point for the spline (1).

3 Specify points (2 through 5) to create the spline, and press  ENTER .

4 Specify the start and end tangents (6, 7).

1

2

3

4

5

7

6

The spline below uses the same points but different start and end tangents.
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6 7

The spline below uses the same points but a higher tolerance and different
start and end tangents.

1

6

2

3

4

7

5

Draw toolbar

Draw Construction and Reference Geometry
Construction lines and reference points are temporary objects you create to
help you draw accurately.

Draw Reference Points

Point objects are useful as nodes or reference geometry for object snaps and
relative offsets.

You can set the style of the points and their size relative to the screen or in
absolute units. Changing the style of points

■ Makes them more visible and easier to differentiate from grid dots

■ Affects the display of all point objects in the drawing

■ Requires using  to make the change visible
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To set point style and size

1 Click Format menu ➤ Point Style.

2 In the Point Style dialog box, select a point style.

3 In the Point Size box, specify a size, either relative to the screen or in
absolute units.

4 Click OK.

To create a point object

1 Click Draw menu ➤ Point ➤ Single Point.

2 Specify the point location.

You can snap to a point using the Node object snap.

Draw toolbar

Draw Construction Lines (and Rays)

Lines that extend to infinity in one or both directions, known as rays and
construction lines, respectively, can be used as references for creating other
objects.

Lines that extend to infinity in one or both directions, known as rays and
construction lines, respectively, can be used as references for creating other
objects. For example, you can use construction lines to find the center of a
triangle, prepare multiple views of the same item, or create temporary
intersections to use for object snaps.

Infinite lines do not change the total area of the drawing. Therefore, their
infinite dimensions have no effect on zooming or viewpoints, and they are
ignored by commands that display the drawing extents. You can move, rotate,
and copy infinite lines just as you can move, rotate, and copy other objects.
You may want to create infinite lines on a construction line layer that can be
frozen or turned off before plotting.

Construction Lines

A construction line (xline) can be placed anywhere in three-dimensional space.
You can specify its orientation in several ways. The default method for creating
the line is the two-point method: you specify two points to define the
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orientation. The first point, the root, is the conceptual midpoint of the
construction line, that is, the point snapped to by the Midpoint object snap.

You can also create construction lines in several other ways.

■ Horizontal and Vertical. Create construction lines that pass through a
point you specify and are parallel to the X or Y axis of the current UCS.

■ Angle. Creates a construction line in one of two ways. Either you select a
reference line and then specify the angle of the construction line from that
line, or you create a construction line at a specific angle to the horizontal
axis by specifying an angle and then a point through which the construction
line should pass.

■ Bisector. Creates a construction line that bisects an angle you specify. You
specify the vertex and the lines that create the angle.

■ Offset. Creates a construction line parallel to a baseline you specify. You
specify the offset distance, select the baseline, and then indicate on which
side of the baseline to locate the construction line.

Rays

A ray is a line in three-dimensional space that starts at a point you specify and
extends to infinity. Unlike construction lines, which extend in two directions,
rays extend in only one direction. Using rays instead of construction lines can
help reduce visual clutter. Like construction lines, rays are ignored by
commands that display the drawing extents.

4

3

1 2

three rays

To create a construction line by specifying two points

1 Click Draw menu ➤ Construction Line.

2 Specify a point to define the root of the construction line.
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3 Specify a second point through which the construction line should pass.

4 Continue to specify construction lines as needed.

All subsequent xlines pass through the first point specified.

5 Press  ENTER  to end the command.

Draw toolbar

To create a ray

1 Click Draw menu ➤ Ray.

2 Specify a starting point for the ray.

3 Specify a point through which the ray should pass.

4 Continue to specify points to create additional rays as needed.

All subsequent rays pass through the first point specified.

5 Press  ENTER  to end the command.

Create and Combine Areas (Regions)
Regions are two-dimensional enclosed areas that have physical properties such
as centroids or centers of mass. You can combine existing regions into a single,
complex region to calculate area.

Regions are two-dimensional enclosed areas you create from objects that form
closed loops. Loops can be combinations of lines, polylines, circles, arcs,
ellipses, elliptical arcs, and splines. The objects that make up the loops must
either be closed or form closed areas by sharing endpoints with other objects.

Regions can be used for

■ Applying hatching and shading

■ Analyzing properties, such as area, using

■ Extracting design information, such as the centroid

Create and Combine Areas (Regions) | 421



shapes that can form regions

You can create regions out of multiple loops and out of open curves whose
endpoints are connected and form loops. You cannot form regions from open
objects that intersect to form a closed area: for example, intersecting arcs or
self-intersecting curves.

You can also create regions using .

You create composite regions by combining, subtracting, or finding the
intersection of regions. After forming these more complex regions, you can
apply hatching or analyze their area.

Objects combined using :

selected regions result

Objects combined using :

2

1

selected regions result - a composite
region

Objects combined using :
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selected intersecting regions result

To define regions

1 Click Draw menu ➤ Region.

2 Select objects to create the region.

These objects must each form an enclosed area, such as a circle or a
closed polyline.

3 Press  ENTER .

A message on the command line indicates how many loops were detected
and how many regions were created.

To define regions by using boundaries

1 Click Draw menu ➤ Boundary.

2 In the Boundary Creation dialog box, in the Object Type list, select
Region.

3 Click Pick Points.

4 Specify a point in your drawing inside each closed area that you want
to define as a region and press  ENTER .

This point is known as the internal point.

NOTE You can make a new boundary set to limit the objects used to
determine the boundary.

To combine regions by adding

1 Click Modify menu ➤ Solids Editing ➤ Union.

2 Select one region for the union.

3 Select another region.

You can select regions to unite in any order.
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4 Continue selecting regions or press  ENTER  to end the command.

The command converts the selected regions to a new combined region.

To combine regions by subtracting

1 Click Modify menu ➤ Solids Editing ➤ Subtract.

2 Select one or more regions from which to subtract and press  ENTER .

3 Select the region to subtract and press  ENTER .

The areas of the second regions you selected are subtracted from the
areas of the first regions.

To combine regions by finding intersections

1 Click Modify menu ➤ Solids Editing ➤ Intersect.

2 Select one region of the intersection.

3 Select another intersecting region.

You can select regions in any order to find their intersection.

4 Continue selecting regions or press  ENTER  to end the command.

The command converts the selected regions to a new region defined by
the intersection of the selected regions.

Create 3D Objects
3D objects can be represented by simulated surfaces (3D thickness), as a
wireframe model, as a surface model, or as a solid model.

Overview of 3D Objects

Although 3D models can be more difficult and time-consuming to create than
3D views of 2D objects, 3D modeling has several advantages. You can

■ View the model from any vantage point

■ Generate reliable standard and auxiliary 2D views automatically

■ Create 2D profiles ()

■ Remove hidden lines and do realistic shading

■ Check interference
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■ Export the model to create an animation

■ Perform engineering analysis

■ Extract manufacturing data

Three types of 3D modeling are supported: wireframe, surface, and solid. Each
type has its own creation and editing techniques.

3D wireframe mesh solid

A wireframe model is a skeletal description of a 3D object. There are no surfaces
in a wireframe model; it consists only of points, lines, and curves that describe
the edges of the object. You can create wireframe models by positioning 2D
(planar) objects anywhere in 3D space. Some 3D wireframe objects are also
provided, such as 3D polylines (that can only have a CONTINUOUS linetype)
and splines. Because each object that makes up a wireframe model must be
independently drawn and positioned, this type of modeling can be the most
time-consuming.

Surface modeling is more sophisticated than wireframe modeling in that it
defines not only the edges of a 3D object, but also its surfaces. The surface
modeler defines faceted surfaces using a polygonal mesh. Because the faces
of the mesh are planar, the mesh can only approximate curved surfaces. With
Autodesk Mechanical Desktop®, you can create true curved surfaces. To
differentiate these two types of surfaces, faceted surfaces are called meshes.

Solid modeling is the easiest type of 3D modeling to use. With the solid
modeler, you can make 3D objects by creating basic 3D shapes: boxes, cones,
cylinders, spheres, wedges, and tori (donuts). You can then combine these
shapes to create more complex solids by joining or subtracting them or finding
their intersecting (overlapping) volume. You can also create solids by sweeping
a 2D object along a path or revolving it about an axis. With Autodesk
Mechanical Desktop, you can also define solids parametrically and maintain
associativity between 3D models and the 2D views that you generate from
them.
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NOTE Because each modeling type uses a different method for constructing 3D
models and editing methods vary in their effect on the different model types, it
is recommended that you not mix modeling methods. Limited conversion between
model types is available from solids to surfaces and from surfaces to wireframes;
however, you cannot convert from wireframes to surfaces or from surfaces to
solids.

Add 3D Thickness to Objects

Thickness is a property of certain objects that gives them a 3D appearance.

Thickness is a property of certain objects that gives them a 3D appearance.

The 3D thickness of an object is the distance that object is extended, or
thickened, above or below its location in space. Positive thickness extrudes
upward in the positive Z direction; negative thickness extrudes downward
(negative Z). Zero (0) thickness means that there is no 3D thickening of the
object. The Z direction is determined by the orientation of the UCS at the
time the object was created. Objects with a non-zero thickness can be shaded
and can hide other objects behind them.

2D objects elevation changed thickness added

The thickness property changes the appearance of the following types of
objects:

■ 2D solids

■ Arcs

■ Circles

■ Lines

■ Polylines (including spline-fit polylines, rectangles, polygons, boundaries,
and donuts)

■ Text (only if created as a single-line text object using an SHX font)

■ Traces
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■ Points

Modifying the thickness property of other types of objects does not affect
their appearance.

You can set the default thickness property for new objects you create by setting
the  system variable. Change the thickness property of an existing object using
the Properties palette. The 3D thickening is applied uniformly on an object:
a single object cannot have different thicknesses for its various points.

You may need to change the 3D viewpoint to see the effect of thickness on
an object.

To set the 3D thickness of new objects

1 Click Format menu ➤ Thickness.

2 On the command line, enter the value for the thickness distance.

New objects are created with the specified 3D thickness.

To change the 3D thickness of existing objects

1 Select the objects whose 3D thickness you want to change.

2 Right-click one of the objects. Click Properties.

3 In the Properties palette, select Thickness and enter a new value.

The selected objects now display the specified 3D thickness.

Standard toolbar

Create Wireframe Models

A wireframe model is an edge or skeletal representation of a real-world 3D
object using lines and curves.

A wireframe model is an edge or skeletal representation of a real-world 3D
object using lines and curves. You can use a wireframe model to

■ View the model from any vantage point

■ Generate standard orthographic and auxiliary views automatically

■ Generate exploded and perspective views easily
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■ Analyze spatial relationships, including the shortest distance between
corners and edges, and checking for interferences

■ Reduce the number of prototypes required

Tips for Working with Wireframe Models

Creating 3D wireframe models can be more difficult and time-consuming
than creating their 2D views. Here are some tips that will help you work more
effectively:

■ Plan and organize your model so that you can turn off layers to reduce the
visual complexity of the model. Color can help you differentiate between
objects in various views.

■ Create construction geometry to define the basic envelope of the model.

■ Use multiple views, especially isometric views, to make visualizing the
model and selecting objects easier.

■ Become adept at manipulating the UCS in 3D. The XY plane of the current
UCS operates as a construction plane to orient planar objects such as circles
and arcs. The UCS also determines the plane of operation for trimming and
extending, offsetting, and rotating objects.

■ Use object snaps and grid snap carefully to ensure the precision of your
model.

■ Use coordinate filters to drop perpendiculars and easily locate points in 3D
based on the location of points on other objects.

Methods for Creating Wireframe Models

You can create wireframe models by positioning any 2D planar object anywhere
in 3D space, using the following methods:

■ Entering 3D coordinates. You enter coordinates that define the X, Y, and
Z location of the object.

■ Setting the default construction plane (the XY plane of the UCS) on which
you will draw the object.

■ Moving or copying the object to its proper 3D location after you create it.

Wireframe modeling is a skill that requires practice and experience. The best
approach to learning how to create wireframe models is to begin with simple
models before attempting models that are more complex.
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To drop a perpendicular line from a 3D point down to the XY plane

1 Click Draw menu ➤ Line.

2 Use an object snap to specify a point on an object that is not on the XY
plane of the UCS.

This defines the first point of the line.

3 Enter .xy and then enter @ at the Of prompt.

This operation extracts the X and Y coordinate values from the first
point.

4 Enter 0 to specify the Z value.

Using coordinate filters, the X and Y values extracted from the first point
are combined with a new Z value (0) to finish the definition of the second
point.

5 Press  ENTER  to end the command.

Create Surfaces

The surface modeler creates faceted surfaces using a polygonal mesh. Because
the faces of the mesh are planar, the mesh can only approximate curved
surfaces.

Use surface meshes if you need hiding, shading, and rendering capabilities
that wireframe models cannot provide but do not need the physical properties
that solid models provide (mass, volume, center of gravity, moments of inertia,
and so on). Meshes are useful if you want to create geometry with unusual
mesh patterns, such as a 3D topographical model of mountainous terrain.

Surface meshes are displayed as wireframe representations until you use , , or
. Use REGEN (after using HIDE) and SHADEMODE to restore the wireframe
display.

You can create several types of surfaces:

■ 3D face.  creates a planar surface with either three or four sides.

■ Ruled surface.  creates a polygon mesh representing the ruled surface between
two lines or curves.

■ Tabulated surface.  creates a polygon mesh representing a general tabulated
surface defined by the extrusion of a line or curve (called a path curve) in
a specified direction and distance (called a direction vector).

■ Revolved surface.  creates a polygon mesh approximating a surface of
revolution by rotating a path curve or profile (lines, circles, arcs, ellipses,
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elliptical arcs, polylines, or splines, closed polylines, polygons, closed splines,
or donuts) about a specified axis.

■ Edge-defined surface.  creates a polygon mesh approximating a Coons surface
patch mesh from four adjoining edges. A Coons surface patch mesh is a
bicubic surface interpolated between four adjoining edges (which can be
general space curves).

■ Predefined 3D surface.  creates three-dimensional polygon mesh objects in
common geometric shapes, including boxes, cones, spheres, tori, wedges,
and pyramids.

■ General surface meshes.  and PFACE create three-dimensional polygon mesh
objects in any shape.

Understand Mesh Construction

The mesh density controls the number of facets on a surface, and is defined
in terms of a matrix of M and N vertices, similar to a grid consisting of columns
and rows. M and N specify the column and row position, respectively, of any
given vertex.

A mesh can be open or closed. A mesh is open in a given direction if the start
and end edges of the mesh do not touch, as shown in the following
illustrations.

M open
N open N open

M closed

M closed
N closed

M open
N closed

There are several methods for creating meshes.
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Create a Ruled Surface Mesh

With , you can create a surface mesh between two lines or curves. You can
use two different objects to define the edges of the ruled surface: lines, points,
arcs, circles, ellipses, elliptical arcs, 2D polylines, 3D polylines, or splines. Pairs
of objects to be used as the “rails” of a ruled surface mesh must both be either
open or closed. You can pair a point object with either an open or a closed
object.

curves defined result

1

2

You can specify any two points on closed curves to complete RULESURF. For
open curves, construction of the ruled surface is based on the locations of the
specified points on the curves.

specified point on
corresponding sides

result

specified points on
opposite sides

result

Create a Tabulated Surface Mesh

With the  command, you can create a surface mesh representing a general
tabulated surface defined by a path curve and a direction vector. The path
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curve can be a line, arc, circle, ellipse, elliptical arc, 2D polyline, 3D polyline,
or spline. The direction vector can be a line or an open 2D or 3D polyline.
TABSURF creates the mesh as a series of parallel polygons running along a
specified path. You must have the original object and the direction vector
already drawn, as shown in the following illustrations.

object specified direction vector
specified

result

1

2

Create a Revolved Surface Mesh

Use the  command to create a revolved surface, also called a surface of
revolution, by rotating a profile of the object about an axis. REVSURF is useful
for surfaces with rotational symmetry.

profile specified axis of revolution
specified

result

1

2

The profile is called a path curve, which can be any combination of lines,
circles, arcs, ellipses, elliptical arcs, polylines, or splines, closed polylines,
polygons, closed splines, or donuts.

Create an Edge-Defined Surface Mesh

With the  command, you can create a Coons surface patch mesh, as shown in
the following illustration, from four objects called edges. Edges can be arcs,
lines, polylines, splines, and elliptical arcs, and they must form a closed loop
and share endpoints. A Coons patch is a bicubic surface (one curve in the M
direction and another in the N direction) interpolated between the four edges.
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four edges selected result

M N1

2
3

4

Create a Predefined 3D Surface Mesh

The 3D command creates the following 3D shapes: boxes, cones, dishes, domes,
meshes, pyramids, spheres, tori (donuts), and wedges.

To view the objects you are creating with the 3D command more clearly, set
a viewing direction with , , or .

In the following illustrations, the numbers indicate points you specify to create
the mesh.

1

2

3
4

1 1 1

2

3

M

N

radius

radius

radius apex

1

1

2

3

4

1

top radius

height

length width

1

height

1

base radius

height

length width
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Create a Rectangular Mesh

With the  command, you can create polygon meshes that are open in both
the M and N directions (similar to the X and Y axes of an XY plane). You can
close the meshes with . You can use 3DMESH to construct very irregular
surfaces. In most cases, you can use 3DMESH in conjunction with scripts or
AutoLISP routines when you know the mesh points.

In the following example of text on the command line, you enter the
coordinate values for each vertex to create the mesh in the illustration.

Example:

Command: 3dmesh
Mesh M size: 4
Mesh N size:  3
Vertex (0, 0): 10,1, 3
Vertex (0, 1):  10, 5, 5
Vertex (0, 2):  10,10, 3
Vertex (1, 0):  15,1, 0
Vertex (1, 1):  15, 5, 0
Vertex (1, 2):  15,10, 0
Vertex (2, 0): 20,1, 0
Vertex (2, 1): 20, 5, –1
Vertex (2, 2): 20,10 ,0
Vertex (3, 0): 25,1, 0
Vertex (3, 1):  25, 5, 0
Vertex (3, 2):  25,10, 0
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10,1,3

15,5,0

15,1,0

20,1,0

20,5,-1 25,1,0

10,5,5
10,10,3

20,10,0

25,10,0

25,5,0

15,10,0

M direction

N direction

Create a Polyface Mesh

The  command produces a polyface (polygon) mesh, with each face capable
of having numerous vertices. PFACE is typically used by applications rather
than by direct user input.

Creating a polyface mesh is similar to creating a rectangular mesh. To create
a polyface mesh, you specify coordinates for its vertices. You then define each
face by entering vertex numbers for all the vertices of that face. As you create
the polyface mesh, you can set specific edges to be invisible, assign them to
layers, or give them colors.

To make the edge invisible, enter the vertex number as a negative value. For
instance, to make the edge between vertices 5 and 7 invisible in the following
illustration, you enter the following:

Face 3, vertex 3: –7

In the illustration, face 1 is defined by vertices 1, 5, 6, and 2. Face 2 is defined
by vertices 1, 4, 3, and 2. Face 3 is defined by vertices 1, 4, 7, and 5, and face
4 is defined by vertices 3, 4, 7, and 8.

face 4

face 2

face 3

face 1

1

2

5
6 4

7

8

3
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You can control the display of invisible edges with the  system variable. If
SPLFRAME is set to a nonzero value, the invisible edges become visible and
can then be edited. If SPLFRAME is set to 0, the invisible edges remain invisible.

SPLFRAME = 1 SPLFRAME = 0

To create a rectangular mesh

1 Click Draw menu ➤ Surfaces ➤ 3D Mesh.

2 Specify the M size, using an integer from 2 through 256.

3 Specify the N size, using an integer from 2 through 256.

4 Specify the vertex points as prompted. Specifying the last vertex point
completes the mesh.

Mesh M size: 2
Mesh N size: 2 Mesh N size: 3

Mesh M size: 2 Mesh M size: 3
Mesh N size: 3

Surfaces toolbar

To create a ruled surface

1 Click Draw menu ➤ Surfaces ➤ Ruled Surface.

2 Select the first defining curve. Then select the second.

3 Erase the original curve if necessary.
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Surfaces toolbar

To create a tabulated surface mesh

1 Click Draw menu ➤ Surfaces ➤ Tabulated Surface.

2 Specify a path curve.

3 Specify a direction vector.

4 Erase the original objects if necessary.

Surfaces toolbar

To create a surface of revolution mesh

1 Click Draw menu ➤ Surfaces ➤ Revolved Surface.

2 Specify a path curve.

The path curve, which defines the N direction of the mesh, can be a line,
arc, circle, ellipse, elliptical arc, 2D polyline, 3D polyline, or spline. If
you select a circle, closed ellipse, or closed polyline, the mesh is closed
in the N direction.

3 Specify the axis of revolution.

The direction vector can be a line or an open 2D or 3D polyline. If you
choose a polyline, the vector sets the rotation axis from its first vertex
to its last vertex. Any intermediate vertices are ignored. The axis of
revolution determines the M direction of the mesh.

4 Specify the start angle. Then specify the included angle.

If you specify a nonzero start angle, the mesh is generated at a position
offset from the path curve by that angle. The included angle specifies
how far about the axis of revolution the surface should extend.

5 Erase the original objects if necessary.

Surfaces toolbar
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To create an edge-defined Coons surface patch mesh

1 Click Draw menu ➤ Surfaces ➤ Edge Surface.

2 Select the four edges in any order.

The first edge you select determines the mesh’s M direction.

Surfaces toolbar

Create 3D Solids

A solid object represents the entire volume of an object. Complex solid shapes
are easier to construct and edit than wireframes and meshes.

A solid object represents the entire volume of an object. Solids are the most
informationally complete and least ambiguous of the 3D modeling types.
Complex solid shapes are also easier to construct and edit than wireframes
and meshes.

You create solids from one of the basic solid shapes of box, cone, cylinder,
sphere, torus, and wedge or by extruding a 2D object along a path or revolving
a 2D object about an axis.

Once you have created a solid in this manner, you can create more complex
shapes by combining solids. You can join solids, subtract solids from each
other, or find the common volume (overlapping portion) of solids.

Solids can be further modified by filleting, chamfering, or changing the color
of their edges. Faces on solids are easily manipulated because they don’t require
you to draw any new geometry or perform Boolean operations on the solid.
This program also has commands for slicing a solid into two pieces or obtaining
the 2D cross section of a solid (see “Modify 3D Solids” on page 655).

Like meshes, solids are displayed as wireframes until you hide, shade, or render
them. Additionally, you can analyze solids for their mass properties (volume,
moments of inertia, center of gravity, and so on). You can export data about
a solid object to applications such as NC (numerical control) milling or FEM
(finite element method) analysis. By exploding a solid, you can break it down
to mesh and wireframe objects.

The  system variable controls the number of tessellation lines used to visualize
curved portions of the wireframe. The  system variable adjusts the smoothness
of shaded and hidden-line objects.
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Create a Solid Box

You can use  to create a solid box. The base of the box is always parallel to
the XY plane of the current UCS.

1 2

3

The  or  command creates a rectangle or closed polyline from which you can
create a box using . The  command creates a box shape defined by surfaces
only.

Create a Solid Cone

You can use  to create a solid cone defined by a circular or an elliptical base
tapering to a point perpendicular to its base. By default, the cone’s base lies
on the XY plane of the current UCS. The height, which can be positive or
negative, is parallel to the Z axis. The apex determines the height and
orientation of the cone.

2

1

3

To create a truncated cone or a cone that requires a specific angle to define
its sides, draw a 2D circle and then use EXTRUDE to taper the circle at an
angle along the Z axis. To complete the truncation, you can subtract a box
from the tip of the cone with the  command.  creates a circle from which you
can create a cone using EXTRUDE with its Taper option. The 3D command
creates a conical shape defined by surfaces only.

Create a Solid Cylinder

You can use  to create a solid cylinder with a circular or an elliptical base. The
base of the cylinder lies on the XY plane of the current UCS.

If you want to construct a cylinder with special detail, such as grooves along
its sides, create a 2D profile of its base with a closed PLINE and use EXTRUDE
to define its height along the Z axis. CIRCLE creates a circle from which you
can create a cylinder using EXTRUDE.
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1

2

3

1

2

To create a dome or dish, combine a sphere with a box and use SUBTRACT.
If you want to create a spherical object that has additional detail, create a 2D
profile and use  to define a rotation angle about the Z axis. The 3D command
creates a spherical shape defined by surfaces only.

Create a Solid Torus

You can use  to create a ring-shaped solid similar to the inner tube of a tire.
The torus is parallel to and bisected by the XY plane of the current UCS. A
torus is defined by two radius values, one for the tube and the other for the
distance from the center of the torus to the center of the tube.

To create a lemon-shaped solid, use a negative torus radius and a positive
number of greater magnitude for the tube radius. For example, if the torus
radius is –2.0, the tube radius must be greater than 2.0.

A torus may be self-intersecting. A self-intersecting torus has no center hole
because the radius of the tube is greater than the radius of the torus.

The 3D command creates a toroidal shape defined by surfaces only.

1

2

3
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Create a Solid Wedge

You can use  to create a solid wedge. The base of the wedge is parallel to the
XY plane of the current UCS with the sloped face opposite the first corner. Its
height, which can be positive or negative, is parallel to the Z axis.

1

3

2

The 3D command creates a wedge shape defined by surfaces only.

Create an Extruded Solid

With EXTRUDE, you can create solids by extruding selected objects. You can
extrude closed objects such as polylines, polygons, rectangles, circles, ellipses,
closed splines, donuts, and regions. You cannot extrude 3D objects, objects
contained within a block, polylines that have crossing or intersecting segments,
or polylines that are not closed. You can extrude an object along a path, or
you can specify a height value and a tapered angle.

Use EXTRUDE to create a solid from a common profile of an object, such as
a gear or sprocket. EXTRUDE is particularly useful for objects that contain
fillets, chamfers, and other details that might otherwise be difficult to
reproduce except in a profile. If you create a profile using lines or arcs, use the
Join option of  to convert them to a single polyline object or make them into
a region before you use EXTRUDE.

Tapering the extrusion is useful specifically for parts that need their sides
defined along an angle, such as a mold used to create metal products in a
foundry. Avoid using extremely large tapered angles. If the angle is too large,
the profile can taper to a point before it reaches the specified height.

original object

extruded object extruded and
tapered circle
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Create a Revolved Solid

With REVOLVE, you can create a solid by revolving a closed object about the
X or Y axis of the current UCS, using a specified angle. You can also revolve
the object about a line, polyline, or two specified points. Similar to EXTRUDE,
REVOLVE is useful for objects that contain fillets or other details that would
otherwise be difficult to reproduce in a common profile. If you create a profile
using lines or arcs that meet a polyline, use the PEDIT Join option to convert
them to a single polyline object before you use REVOLVE.

You can use REVOLVE on closed objects such as polylines, polygons, rectangles,
circles, ellipses, and regions. You cannot use REVOLVE on 3D objects, objects
contained within a block, polylines that have crossing or intersecting segments,
or polylines that are not closed.

1

2

1

2
1

2

original polyline revolved about X axis revolved about Y axis

resultaxis selectedobject to revolve
selected

Y axis X axis

Create a Composite Solid

You can combine, subtract, and find the intersection of existing solids to
create composite solids.

With , you can combine the total volume of two or more solids or two or
more regions into a composite object.
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1
2

objects to be combined result

With SUBTRACT, you can remove the common area of one set of solids from
another. For example, you can use SUBTRACT to add holes to a mechanical
part by subtracting cylinders from the object.

1

2

objects to subtract
from

objects to subtract
selected

result (lines hidden
for clarity)

With , you can create a composite solid from the common volume of two or
more overlapping solids. INTERSECT removes the nonoverlapping portions
and creates a composite solid from the common volume.

objects to intersect selected result

1

2

performs the same operation as INTERSECT, but INTERFERE keeps the original
two objects.

To create a solid box

1 Click Draw menu ➤ Solids ➤ Box.
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2 Specify the first corner of the base.

3 Specify the opposite corner of the base.

4 Specify the height.

To create a solid cone with a circular base

1 Click Draw menu ➤ Solids ➤ Cone.

2 Specify the base center point.

3 Specify the radius or diameter of the base.

4 Specify the height.

To create a solid cone with an elliptical base

1 Click Draw menu ➤ Solids ➤ Cone.

2 Enter e (Elliptical).

3 Specify an axis endpoint.

4 Specify a second axis endpoint.

5 Specify the length of the other axis.

6 Specify height, and then press  ENTER .

To create a solid cylinder with a circular base

1 Click Draw menu ➤ Solids ➤ Cylinder.

2 Specify the base center point.

3 Specify the radius or diameter of the base.
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4 Specify the height.

To create a solid sphere

1 Click Draw menu ➤ Solids ➤ Sphere.

2 Specify the center of the sphere.

3 Specify the radius or diameter of the sphere.

To create a solid torus

1 Click Draw menu ➤ Solids ➤ Torus.

2 Specify the center of the torus.

3 Specify the radius or diameter of the torus.

4 Specify the radius or diameter of the tube.

To create a solid wedge

1 Click Draw menu ➤ Solids ➤ Wedge.

2 Specify the first corner of the base.

3 Specify the opposite corner of the base.

4 Specify the height of the wedge.

To extrude an object along a path

1 Click Draw menu ➤ Solids ➤ Extrude.

2 Select the objects to extrude.
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3 Enter p (Path).

4 Select the object to use as the path.

After the extrusion, the original object may be deleted or retained,
depending on the setting of the  system variable.

1

2

To revolve an object about an axis

1 Click Draw menu ➤ Solids ➤ Revolve.

2 Select the objects to revolve.

3 Specify the start point and endpoint of the axis of revolution.

Specify the points so that the object is on one side of the axis points you
specify. The positive axis direction is from the start point to the endpoint.

4 Specify the angle of revolution.

To combine solids

1 Click Modify menu ➤ Solids Editing ➤ Union.

2 Select the objects to combine.

To subtract one set of solids from another

1 Click Modify menu ➤ Solids Editing ➤ Subtract.

2 Select the objects to subtract from.

3 Select the objects to subtract.
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To create a solid from the intersection of two or more other solids

1 Click Modify menu ➤ Solids Editing ➤ Intersect.

2 Select the objects to intersect.

Create Revision Clouds
Revision clouds are polylines that consist of sequential arcs. They are used to
call attention to parts of a drawing during the review stage.

If you review or redline drawings, you can increase your productivity by using
the Revision Cloud feature to highlight your markups.  creates a polyline of
sequential arcs to form a cloud-shaped object. You can select a style for a
revision cloud: Normal or Calligraphy. If you select Calligraphy, the revision
cloud looks as if it was drawn with a calligraphy pen.

You can create a revision cloud from scratch, or you can convert objects, such
as a circle, ellipse, polyline, or spline, to a revision cloud. When you convert
an object to a revision cloud, the original object is deleted if  is set to 1 (the
default).

You can set the minimum and maximum default values for the arc lengths
of a revision cloud. When you draw a revision cloud, you can vary the size of
the arcs by using pick points for the smaller arc segments. You can also edit
the individual arc lengths and chord lengths of a revision cloud by adjusting
the pick points.

REVCLOUD stores the last used arc length as a multiple of the  system variable
to provide consistency among drawings with different scale factors.

Make sure that you can see the entire area to be outlined with REVCLOUD
before you begin the command. REVCLOUD is not designed to support
transparent and real-time panning and zooming.
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To create a revision cloud from scratch

1 Click Draw menu ➤ Revision Cloud.

2 At the Command prompt, specify a new minimum and maximum arc
length or specify a revision cloud starting point.

The default minimum and maximum arc lengths are set to 0.5000 units.
The maximum arc length can be no more than three times the minimum
arc length.

3 Guide the crosshairs along the cloud path. You can click pick points
along the path if you want to vary the size of the arcs.

4 Press ENTER at any time to stop drawing the revision cloud.

To close the revision cloud, return to its starting point.

Draw toolbar

To create revision clouds with a calligraphy pen style

1 Click Draw menu ➤ Revision Cloud.

2 At the Command prompt, enter style.

3 At the Command prompt, enter calligraphy.

4 Press ENTER to save the calligraphy setting and to continue with the
command, or press ESC to end the command.

Draw toolbar

To convert an object to a revision cloud

1 Click Draw menu ➤ Revision Cloud.

2 At the Command prompt, specify a new minimum and maximum arc
length or press ENTER.

The default minimum and maximum arc lengths are set to 0.5000 units.
The maximum arc length can be no more than three times the minimum
arc length.
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3 Select the circle, ellipse, polyline, or spline that you want to convert to
a revision cloud.

To reverse the direction of the arcs, enter yes on the command line and
press ENTER.

4 Press ENTER to change the selected object to a revision cloud.

Draw toolbar

To change the default values for arc lengths in a revision cloud

1 Click Draw menu ➤ Revision Cloud.

2 At the Command prompt, specify a new minimum arc length and press
ENTER.

3 At the Command prompt, specify a new maximum arc length and press
ENTER.

The maximum arc length can be no more than three times the minimum
arc length.

4 Press ENTER to continue with the command or ESC to end the command.

Draw toolbar

To edit the individual lengths of arcs or chords in a revision cloud

1 In your drawing, select the revision cloud you want to edit.

2 Move the pick points along the path of the revision cloud to change the
arc lengths and chords.
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Create and Use Blocks
(Symbols)

 

A block is one or more objects combined to create a single

object. Blocks help you reuse objects in the same drawing or

in other drawings.

20
In this chapter

■ Overview of Blocks
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■ Add Dynamic Behavior to
Blocks

■ Control the Color and
Linetype Properties in Blocks

■ Nest Blocks

■ Insert Blocks

■ Work with Dynamic Blocks in
Drawings

■ Attach Data to Blocks (Block
Attributes)

■ Modify Blocks

■ Change the Color and
Linetype in a Block

■ Disassemble a Block Reference
(Explode)

■ Remove Block Definitions



Overview of Blocks
You can use several methods to create blocks:

■ Combine objects to create a block definition in your current drawing.

■ Use the Block Editor to add dynamic behavior to a block definition in your
current drawing.

■ Create a drawing file and later insert it as a block in other drawings.

■ Create a drawing file with several related block definitions to serve as a
block library.

A block can be composed of objects drawn on several layers with various
colors, linetypes, and lineweight properties. Although a block is always inserted
on the current layer, the block reference preserves information about the
original layer, color, and linetype properties of the objects that are contained
in the block. You can control whether objects in a block retain their original
properties or inherit their properties from the current layer, color, linetype,
or lineweight settings.

A block definition can also contain elements that add dynamic behavior to
the block. You add these elements to the block in the Block Editor. When you
add dynamic behavior to a block, you add flexibility and intelligence to the
geometry. When you insert a block reference with dynamic behavior in a
drawing, you can manipulate the geometry of the block reference through
custom grips or custom properties, depending on how the block was defined.

You can use  to remove unused block definitions from a drawing.

Create and Store Blocks

How Blocks Are Stored and Referenced

Every drawing file has an invisible data area called the block definition table.
The block definition table stores all block definitions, which consist of all
information associated with the block. It is these block definitions that are
referenced when you insert blocks in your drawing. The following illustrations
are conceptual representations of three drawing files. Each rectangle represents
a separate drawing file and is divided into two parts: the smaller part represents
the block definition table, and the larger part represents the objects in a
drawing.
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When you insert a block, you are inserting a block reference. The information
is not simply copied from the block definition to the drawing area. Instead,
a link is established between the block reference and the block definition.
Therefore, if the block definition is changed, all references are updated
automatically.

To reduce the size of a drawing, you can purge unused block definitions.

No procedures for this topic.

Create Blocks Within a Drawing

After you define a block in a drawing, you can insert a block reference in the
drawing as many times as necessary. Use this method to create blocks quickly.

Each block definition includes a block name, one or more objects, the
coordinate values of the base point to be used for inserting the block, and any
associated attribute data.

The base point is used as a reference for positioning the block when you insert
it. Suppose you specify that the base point is at the lower-left corner of an
object in the block. Later, when you insert the block, you are prompted for
an insertion point. The block base point is aligned at the insertion point you
specified.

The block definition in the illustration comprises a name, PLUG_VALVE, four
lines, and a base point at the intersection of the two diagonal lines. For an
explanation of the schematic representation shown, see “Overview of Blocks”
on page 452.
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The illustration shows a typical sequence for creating a block definition within
a drawing.
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You can also use the Block Editor to create blocks that are saved within a
drawing. For more information about using the Block Editor, see “Use the
Block Editor” on page 463.

To define a block for the current drawing

1 Create the objects you want to use in the block definition.

2 On the Draw menu, click Block ➤ Make.

3 In the Block Definition dialog box, enter a block name in the Name box.

4 Under Objects, select Convert to Block.

If you want the original objects used to create the block definition to
remain in your drawing, make sure the Delete option is not selected. If
this option is selected, the original objects are erased from the drawing.
If necessary, you can use OOPS to restore them.

5 Click Select Objects.
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6 Use your pointing device to select the objects to be included in the block
definition. Press  ENTER  to complete object selection.

7 In the Block Definition dialog box under Base Point, specify the block
insertion point using one of these methods:

■ Click Pick Point to specify a point using the pointing device.

■ Enter the X,Y,Z coordinate values of the point.

8 In the Description box, enter a description for the block definition. This
description is displayed in DesignCenter™ (ADCENTER).

9 Click OK.

The block is defined in the current drawing and can be inserted at any
time.

Draw toolbar

Create Block Libraries

A block library is a collection of block definitions stored in a single drawing
file. You can use block libraries supplied by Autodesk or other vendors or
create your own.

You can organize a set of related block definitions by creating the blocks in
the same drawing file. Drawing files used this way are called block, or symbol,
libraries. These block definitions can be inserted individually into any drawing
that you are working on. Block library drawings are not different from other
drawing files except in how they are used.

When you use  to define each block definition in the block library drawing,
you can include a short description of the block that can be viewed in
DesignCenter.

Optionally, you can also document each block definition by inserting it in
the drawing area of the library drawing. In addition to the block geometry,
you can include text that provides the block name, the date of creation, the
date of the last modification, and any special instructions or conventions.
This creates a visual index of the blocks in the block library drawing.
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Use DesignCenter to view and copy block definitions individually from block
library drawings (or from any existing drawing) to your current drawing.
DesignCenter does not overwrite an existing block definition in a drawing
with one that comes from another drawing.

To create a block library drawing

1 Begin a new drawing.

2 Define a block.

3 Repeat step 2 for as many related block definitions as you want to make.

4 Save the drawing using a name appropriate for a library drawing.

These blocks can be inserted into any drawing using DesignCenter
(ADCENTER).

Draw toolbar

Create Drawing Files for Use as Blocks

You can create drawing files for the purpose of inserting them into other
drawings as blocks. Individual drawing files are easy to create and manage as
the source of block definitions. Collections of symbols can be stored as
individual drawing files and grouped in folders.
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Create a New Drawing File

You have two methods for creating drawing files:

■ Create and save a complete drawing file using  or .

■ Create and save only selected objects from your current drawing to a new
drawing using  or .

With either method, you create an ordinary drawing file that can be inserted
as a block into any other drawing file. Using WBLOCK is recommended when
you need to create several versions of a symbol as separate drawing files, or
when you want to create a drawing file without leaving the current drawing.

Change the Base Point of Drawings to Be Used as Blocks

By default, the WCS (world coordinate system) origin (0,0,0) is used as the
base point for drawing files inserted as blocks. You can change the base point
by opening the original drawing and using  to specify a different base point
for insertion. The next time you insert the block, the new base point is used.

Update Changes in the Original Drawing

If you change the original drawing after inserting it, the changes have no
effect on the current drawing. If you expect the original drawing to change,
and you want the changes to be reflected in the current drawing, you may
want to attach it as an external reference instead of inserting it as a block. For
more information about external references, see “Reference Other Drawing
Files (Xrefs)” on page 963.

Use Paper Space Objects in Blocks

Objects in paper space are not included when you insert a drawing as a block.
To transfer paper space objects to another drawing, make the objects into a
block or save them in a separate drawing file, and then insert the block or
drawing file into the other drawing.
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To create a new drawing file from selected objects

1 Open an existing drawing or create a new drawing.

2 At the Command prompt, enter wblock.

3 In the Write Block dialog box, select Objects.

If you want the original objects used to create the new drawing to remain
in your drawing, make sure the Delete From Drawing option is not
selected. If this option is selected, the original objects are erased from
the drawing. If necessary, you can use OOPS to restore them.

4 Click Select Objects.

5 Use your pointing device to select the objects to be included in the new
drawing. Press  ENTER  to complete object selection.

6 In the Write Block dialog box under Base Point, specify the point to be
the origin point (0,0,0) for the new drawing using one of these methods:

■ Click Specify Point to specify a point using the pointing device.

■ Enter the X,Y,Z coordinate values of the point.

7 Under Destination, enter a file name and path for the new drawing, or
click the [...] button to display a standard file selection dialog box.

8 Click OK.

A new drawing is created with the selected objects.

To create a new drawing file from an existing block definition

1 On the Modify menu, click Object ➤ Block Description.

2 In the Block Definition dialog box, in the Name box, select the block to
modify.

3 In the Name box, enter a new name.

4 In the Description box, enter or modify the description for the new
drawing file.

5 Click OK.

Use Tool Palettes to Organize Blocks

You can use tool palettes to organize blocks that are stored in one drawing
file or separate drawing files.
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Once you’ve added a block tool to a tool palette, you can easily insert the
block reference in your drawing by dragging it from the tool palette to the
drawing or by clicking and placing it in the drawing. For information about
using tool palettes to organize and insert blocks, see “Tool Palettes” on page
22.

No procedures for this topic.

Add Dynamic Behavior to Blocks
When you add dynamic behavior to a block definition, you add flexibility
and intelligence to the block geometry. Instead of being a fixed part of a
drawing, a dynamic block reference can be changed or manipulated as you
work in a drawing.

Quick Start to Creating Dynamic Blocks

You add dynamic behavior to new or existing block definitions by adding
parameters and actions to the block in the Block Editor. In the following
example, a desk block is shown in the Block Editor. The block contains a linear
parameter, which displays similar to a dimension and is labeled “Distance,”
and a stretch action, which displays a lightning bolt and a “Stretch” label.

For a block to be dynamic, you must add at least one parameter. You then
add an action and associate the action with the parameter. The types of
parameters and actions you add to the block definition define how the block
reference will work in a drawing. To see demonstrations of how parameters
and actions are added to a block, see the New Features Workshop. Click Help
➤ New Features Workshop ➤ Produce ➤ Dynamic Blocks.

For more information in the Help system about creating dynamic blocks, see:

■ “Overview of Dynamic Blocks” on page 460

■ “Overview of Dynamic Block Elements” on page 474
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Overview of Dynamic Blocks

A dynamic block has flexibility and intelligence. A dynamic block reference
can easily be changed in a drawing while you work. You can manipulate the
geometry in a dynamic block reference through custom grips or custom
properties. This allows you to adjust the block in-place as necessary rather
than searching for another block to insert or redefining the existing one.

For example, if you insert a door block reference in a drawing, you might need
to change the size of the door while you’re editing the drawing. If the block
is dynamic and defined to have an adjustable size, you can change the size of
the door simply by dragging the custom grip or by specifying a different size
in the Properties palette. You might also need to change the open angle of
the door. The door block might also contain an alignment grip, which allows
you to align the door block reference easily to other geometry in the drawing.

You use the Block Editor to create dynamic blocks. The Block Editor is a special
authoring area where you add the elements that make a block dynamic. You
can create a block from scratch, or you can add dynamic behavior to an existing
block definition. You can also create geometry, just as you would in the
drawing area.
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You add parameters and actions to a block to make it dynamic. When you add
these elements to the block, you add flexibility and intelligence to the block
geometry.

■ Parameters define custom properties for the dynamic block by specifying
positions, distances, and angles for geometry in the block.

■ Actions define how the geometry of a dynamic block reference will move
or change when the block reference is manipulated in a drawing. When
you add actions to the block, you must associate them with parameters and
usually geometry.

When you add a parameter to a block definition, custom grips and properties
are automatically added to the block. You use these custom grips and properties
to manipulate the block reference in the drawing.

Process for Creating Dynamic Blocks

To create quality dynamic blocks, so you get the results you expect, it is
recommended that you follow the steps in the following process. This process
will help you author dynamic blocks effectively.

Step 1. Plan the contents of the dynamic block before you create it

Before you create a dynamic block, you should know what it will look like
and how it will be used in a drawing. Decide which objects within the block
will change or move when the dynamic block reference is manipulated.
Furthermore, decide how these objects will change. For example, you might
create a dynamic block that can be resized. In addition, when the block
reference is resized, additional geometry may be displayed. These factors
determine the types of parameters and actions you add to the block definition,
and how you make the parameters, actions, and geometry work together.

Step 2. Draw the geometry

You can draw the geometry for your dynamic block in the drawing area or
the Block Editor. You can also use existing geometry in a drawing or an existing
block definition.

NOTE If you will use visibility states to change how geometry is displayed in the
dynamic block references, you may not want to include all the geometry at this
point. For more information about working with visibility states, see “Create
Visibility States” on page 514.
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Step 3. Understand how the block elements will work together

Before you add parameters and actions to your block definition, understand
their dependencies on each other and on the geometry within the block. When
you add an action to the block definition, you will need to associate the action
with a parameter and a selection set of geometry. This creates a dependency.
When you add multiple parameters and actions to a dynamic block reference,
you will need to set up the correct dependencies in order for the block reference
to function properly in a drawing.

For example, you create a dynamic block that contains several objects. Some
of the objects have a stretch action associated with them. You also want all
the objects to rotate around the same base point. In this case, you should add
the rotate action after adding all the other parameters and actions. If the rotate
action isn’t associated with all of the other objects (geometry, parameters, and
actions) in the block definition, parts of the block reference may not rotate
or manipulating the block reference may cause unexpected results.

Step 4. Add parameters

Add the appropriate parameters to the dynamic block definition, following
the prompts on the command line. For more information about using
parameters, see “Use Parameters in Dynamic Blocks” on page 476.

NOTE You can use the Parameter Sets tab of the Block Authoring Palettes to add
a parameter and an associated action at the same time. For more information
about using parameter sets, see “Use Parameter Sets” on page 508.

Step 5. Add actions

Add the appropriate actions to the dynamic block definition. Follow the
prompts on the command line, making sure to associate the actions with the
correct parameters and geometry. For more information about using actions,
see “Overview of Using Actions in Dynamic Blocks” on page 488.

Step 6. Define how the dynamic block reference will be manipulated

You can specify how the dynamic block reference will be manipulated in the
drawing. You can manipulate a dynamic block reference through custom grips
and custom properties. When you create a dynamic block definition, you
define what grips are displayed and how they edit the dynamic block reference.
You also specify whether or not custom properties for the block will be shown
in the Properties palette and whether or not these properties can be changed
through the palette or through custom grips.
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Step 7. Save the block and then try it in a drawing

Save the dynamic block definition and exit the Block Editor. Insert the dynamic
block reference in a drawing and test the block’s functionality.

See also:

“Save a Block in the Block Editor” on page 541

No procedures for this topic.

Use the Block Editor

You use the Block Editor to add dynamic behavior to blocks. The Block Editor
provides all the tools you need to add intelligence and flexibility to your
blocks.

Overview of the Block Editor

The Block Editor is a special authoring area for creating block definitions and
adding dynamic behavior.

The Block Editor provides special Authoring palettes. These palettes provide
quick access to block authoring tools.

In addition to the Block Authoring palettes, the Block Editor provides a drawing
area in which you can draw and edit geometry as you would in the program’s
main drawing area. You can specify the background color for the Block Editor
drawing area.

NOTE You can use most commands in the Block Editor. When you enter a
command that is not allowed in the Block Editor, a message is displayed on the
command line.

You can use the Block Editor to edit or add dynamic behavior to block
definitions that exist in the current drawing. You can also use it to create new
block definitions.

In the Block Editor, a special toolbar is displayed above the drawing area. The
toolbar shows the name of the block definition currently being edited and
provides tools to do the following:

■ Save the block definition

■ Add a parameter

■ Add an action

■ Define attributes
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■ Close the Block Editor

■ Manage visibility states

You can select any parameter, grip, action, or geometric object in the Block
Editor to view its properties in the Properties palette. When you select an
object in the Block Editor, the coordinate values shown in the Properties
palette reflect the block definition space.

When you work in the Block Editor, the command line should be displayed.
The command line displays prompts for nearly all aspects of creating dynamic
blocks.

UCS in the Block Editor

A UCS icon is displayed in the drawing area of the Block Editor. The origin of
the UCS icon defines the base point for the block. You can change the base
point for the block by moving the geometry relative to the origin of the UCS
icon, or by adding a base point parameter.

The UCS command is disabled in the Block Editor. You can open an existing
3D block definition in the Block Editor and assign parameters to the block.
However, the parameters will ignore any Z coordinate values in the block
space. Consequently, the block reference cannot be edited along the Z axis.
Furthermore, while you can create a dynamic block that contains solid objects
and add actions to it, such as move, rotate, and scale, you can’t perform solid
editing features within a dynamic block reference (for example, stretch a solid,
move a hole within a solid, and so on).

See also:

“Define Block Attributes” on page 552

To open an existing block definition in the Block Editor

1 Click Tools menu ➤ Block Editor.

2 In the Edit Block Definition dialog box, do one of the following:

■ Select a block definition from the list.

■ Select <Current Drawing> if the drawing is the block definition you
want to open.

3 Click OK.

Standard toolbar
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Right-click a selected block. Click Block Editor.

To create a new block definition in the Block Editor

1 Click Tools menu ➤ Block Editor.

2 In the Edit Block Definition dialog box, enter a name for the new block
definition.

3 Click OK.

4 In the Block Editor, click Save Block Definition.

NOTE This saves the block definition even if you have not added any objects
in the Block Editor drawing area.

5 Click Close Block Editor.

Standard toolbar

To open a block on a tool palette in the Block Editor

1 If the Tool Palettes window is not already open, click Tools menu ➤ Tool
Palettes Window.

2 Right-click a block icon.

3 Click Block Editor.

NOTE A block on a tool palette may reside in another drawing. The drawing that
contains the block definition is opened in the Block Editor.

Standard toolbar

To open a block from the DesignCenter window in the Block Editor

1 If DesignCenter is not already open, click Tools menu ➤ DesignCenter.
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2 Right-click a block icon.

3 Click Block Editor.

Standard toolbar

To open a drawing file saved as a block (not dynamic) in the Block Editor

1 Open the drawing file that is saved as a block.

2 Click Tools menu ➤ Block Editor.

3 In the Edit Block Definition dialog box, select <Current Drawing>.

4 Click OK.

Standard toolbar

To open a drawing file saved as a dynamic block in the Block Editor

1 Open the drawing file that is saved as a block.

An alert is displayed that states that the drawing file contains authoring
elements.

2 In the alert dialog box, click Yes to open the drawing in the Block Editor.

Standard toolbar

To view properties of a block definition in the Block Editor

1 Click Tools menu ➤ Block Editor.

2 In the Edit Block Definition dialog box, do one of the following:

■ Select a block definition from the list.

■ Select <Current Drawing> if the drawing is the block definition you
want to open.

466 | Chapter 25   Create and Use Blocks (Symbols)



3 Click OK.

4 Make sure the Properties Palette window is displayed. If it’s not displayed,
click Tools menu ➤ Properties.

5 In the Properties Palette window, under Block, view the properties of
the block definition.

Standard toolbar

To view properties of objects in the Block Editor

1 In the Block Editor, select an object.

2 Make sure the Properties Palette window is displayed. If it’s not displayed,
click Tools menu ➤ Properties.

3 In the Properties Palette window, view the properties of the selected
object.

Standard toolbar

Right-click the selected object. Click Properties.

To close the Block Editor

■ In the Block Editor, click Close Block Editor.

Block Editor toolbar

To prevent access to the Block Editor

■ On the command line, enter blockedtlock.

■ Enter 1, and then press ENTER.
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Use Block Authoring Palettes

The Block Editor has three block authoring palettes: Parameters, Actions, and
Parameter Sets.

The Block Authoring Palettes window is displayed only in the Block Editor.
Use these palettes to add parameters and actions to your dynamic block
definition.

Create Custom Block Authoring Tools

You can create custom block authoring tools. In order to preserve the default
tools on the block authoring palettes, you should create a new palette for
custom block authoring tools. You can then copy a parameter set tool from
one of the existing palettes and paste the copy onto the new palette. In the
Tool Properties Dialog Box, you can then change the properties of the new
tool, including the following:

■ Tool description

■ Parameter type

■ Associated action(s)

■ Key point on the parameter to which the action is tied (if applicable)

■ Tool palette image

You cannot drag parameters and actions from the Block Editor onto any tool
palette.

See also:

“Use Parameters in Dynamic Blocks” on page 476
“Use Actions with Dynamic Blocks” on page 488
“Use Parameter Sets” on page 508
“Control Tool Properties” on page 31
“Organize Tool Palettes” on page 38

To show or hide the Block Authoring palettes in the Block Editor

■ In the Block Editor, on the Block Editor toolbar, click the Block Authoring
Palettes button.

Block Editor toolbar
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To make a copy of a parameter set

1 In the Block Editor, in the Block Authoring Palettes window, Parameters
Sets tab, right-click a parameter set. Click Copy.

2 Right-click anywhere on the palette to which you want to add the
parameter set (except on a parameter set). Click Paste.

To add an action to a parameter set

1 In the Block Editor, in the Block Authoring Palettes window, Parameters
Sets tab, right-click a parameter set. Click Properties.

2 In the Tool Properties dialog box, under Parameter, click Actions, and
then click the [...] button.

3 In the Add Actions dialog box, under Action Object to Add, select an
action from the list.

4 Click Add.

5 (Optional) Repeat steps 3 and 4 to add additional actions.

6 Click OK.

7 In the Tool Properties dialog box, click OK.

To delete an action from a parameter or parameter set

1 In the Block Editor, in the Block Authoring Palettes window, right-click
a parameter or parameter set. Click Properties.

2 In the Tool Properties dialog box, under Parameter, click Actions, and
then click the [...] button.

3 In the Add Actions dialog box, under Action Object List, select an action
from the list.

4 Click Delete.

5 (Optional) Repeat steps 3 and 4 to delete additional actions.

6 Click OK.

7 In the Tool Properties dialog box, click OK.
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How Objects Are Displayed in the Block Editor

Parameters, actions, and their relationships (dependencies) are displayed in
different ways in the Block Editor. You can specify settings for some of these
elements.

Parameters

In the Block Editor, most parameters look like dimensions. If you create a
value set (a range or list of values) for a parameter, tick marks are shown at
the locations of those values.

You can specify the following settings for parameters in the Block Editor:

■ Parameter color

■ Parameter text and arrow size

■ Parameter font

■ Grip color

■ Display of value set markers (tick marks) for parameters

When you use a visibility parameter in your dynamic block definition, you
can specify which geometric objects are invisible for a given visibility state.
You can specify whether or not geometry that is made invisible for visibility
states displays in the Block Editor. In the following example, a visibility state
is displayed in the Block Editor. The geometry that displays in a dimmed state
is invisible for that visibility state.

Actions

An action displays its name and icon (a lightning bolt) in the Block Editor.
You can specify the text size and color for actions in the Block Editor.

Grips

You can specify grip size and color for display in the Block Editor. This setting
does not affect the size and color of the grips in a block reference in a drawing.
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Dependencies

When you select a parameter, grip, or action in the Block Editor, its associated
objects, or dependencies, are highlighted. This is called dependency highlighting.
You can turn dependency highlighting on or off.

The following example shows how dependency highlighting creates a halo
effect for the associated parameter (labeled Distance) and action (labeled
Stretch) when you select the custom grip in the Block Editor.

The following table details what is dependency highlighted when you select
an element in the Block Editor.

Objects that are dependency highlightedSelected object in
the Block Editor

Associated grips and actionsParameter

Associated parameter and actionsGrip

Associated parameters, grips, and the selection set (geometry)Action

To specify the display color for parameters in the Block Editor

1 On the command line, enter bparametercolor.

2 Enter one of the following values:

■ BYLAYER

■ BYBLOCK

■ An integer from 1 to 255

■ A true color specified by three integers each ranging from 1 to 255 in
the following format: RGB:000,000,000.

3 Press ENTER.

To specify the text size for parameters and actions in the Block Editor

1 On the command line, enter bparametersize.

2 Enter an integer from 1 to 255 (pixels).
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3 Press ENTER.

To specify the font for parameters in the Block Editor

1 On the command line, enter bparameterfont.

2 Enter any TrueType or SHX font on your system.

3 Press ENTER.

To specify the text color for actions in the Block Editor

1 On the command line, enter bactioncolor.

2 Enter one of the following values:

■ BYLAYER

■ BYBLOCK

■ An integer from 1 to 255.

■ A true color specified by three integers each ranging from 1 to 255 in
the following format: RGB:000,000,000.

3 Press ENTER.

To specify the display size of grips in the Block Editor

1 On the command line, enter bgripobjsize.

2 Enter an integer from 1 to 255 (pixels).

3 Press ENTER.

To specify the display color of grips in the Block Editor

1 On the command line, enter bgripobjcolor.

2 Enter one of the following values:

■ BYLAYER

■ BYBLOCK

■ An integer from 1 to 255.

■ A true color specified by three integers each ranging from 1 to 255 in
the following format: RGB:000,000,000.
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3 Press ENTER.

To update the text and grip display size at their specified values in the Block
Editor

1 In the Block Editor, on the Block Editor toolbar, click Update Parameter
and Action Text Size.

NOTE When you zoom in and out in the Block Editor, text and grip size will change
relative to the zoom factor. However, you can update the Block Editor to display
the text and grip size at their specified values.

To specify whether or not objects that are invisible for a visibility state can
be seen in the Block Editor

1 On the command line, enter bvmode.

2 Enter one of the following values:

■ 0 Specifies that objects that are invisible are not visible in the Block
Editor.

■ 1 Specifies that objects that are invisible are dimmed in the Block
Editor.

3 Press ENTER.

Block Editor toolbar

To turn dependency highlighting on or off in the Block Editor

1 On the command line, enter bdependencyhighlight.

2 Enter one of the following values:

■ 0 Turns off dependency highlighting.

■ 1 Turns on dependency highlighting.

3 Press ENTER.

To control whether value set markers (tick marks) are displayed

1 On the command line, enter btmarkdisplay.
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2 Enter one of the following values:

■ 0 Specifies that value set markers are not displayed.

■ 1 Specifies that value set markers are displayed.

3 Press ENTER.

Add Dynamic Elements to Blocks

To make a block dynamic, you need to add specific elements to the block
definition.

Overview of Dynamic Block Elements

You add dynamic elements to a block definition in the Block Editor. In addition
to geometry, a dynamic block generally includes one or more parameters and
one or more actions.

■ Parameters. Define custom properties for the dynamic block by specifying
positions, distances, and angles for geometry in the block.

■ Actions. Define how the geometry of a dynamic block reference will move
or change when you manipulate the block reference in a drawing. When
you add actions to a dynamic block definition, you must associate the
actions with parameters. You also specify a selection set of geometry that
the action will affect.

NOTE Parameters and actions are displayed only in the Block Editor. When you
insert a dynamic block reference in a drawing, the parameters and actions
contained in the dynamic block definition are not displayed.

When you add a parameter to a dynamic block definition, grips are added to
key points of the parameter. Key points are the parts of a parameter that you
use to manipulate the block reference. For example, a linear parameter has
key points at its base point and end point. You can manipulate the parameter
distance from either key point.

The type of parameter that you add to a dynamic block determines the type
of grips that are added. Each type of parameter supports only certain types of
actions. The following table shows the relationship among parameters, grips,
and actions.
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Actions You Can
Associate with a
Parameter

Grip TypeParameter Type

Move, StretchStandardPoint

Move, Scale, Stretch, ArrayLinearLinear

Move, Scale, Stretch, Polar
Stretch, Array,

StandardPolar

Move, Scale, Stretch, ArrayStandardXY

RotateRotationRotation

FlipFlipFlip

None (The action is implied
and contained within the
parameter.)

AlignmentAlignment

None (The action is implied
and controlled by visibility
states.)

LookupVisibility

LookupLookupLookup

NoneStandardBase

To create a dynamic block

1 Click Tools menu ➤ Block Editor.

2 In the Edit Block Definition dialog box, do one of the following:

■ Select a block definition from the list.

■ Select <Current Drawing> if you want to save the drawing as a dynamic
block.

■ Under Block to Create or Edit, enter a name for a new block definition.
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3 Click OK.

4 In the Block Editor, add or edit geometry as necessary.

5 Do one of the following:

■ Add one or more parameter sets from the Parameter Sets tab of the
Block Authoring Palettes, following the prompts on the command
line. Double-click the yellow alert icon (or use the  command) and
follow the prompts on the command line to associate the action with
a selection set of geometry.

■ Add one or more parameters from the Parameters tab of the Block
Authoring Palettes, following the prompts on the command line. Add
one or more actions from the Actions tab, following the prompts on
the command line.

6 On the Block Editor toolbar, click Save Block Definition.

7 Click Close Block Editor.

Standard toolbar

Right-click a block. Click Block Editor.

Use Parameters in Dynamic Blocks

You add parameters to a dynamic block definition in the Block Editor. In the
Block Editor, parameters have an appearance similar to dimensions. Parameters
define custom properties for the block. Parameters also specify positions,
distances, and angles for geometry in the block reference. When you add a
parameter to a dynamic block definition, the parameter defines one or more
custom properties for the block.

For example, when you add a rotation parameter to a dynamic block definition,
the rotation parameter defines an Angle property for the block reference. So,
if you have a block of a chair in your drawing, and you want to be able to
rotate the block’s position as you edit, the parameter defines the axis whereby
the block can be rotated.

If you add a point parameter to a dynamic block definition, the point
parameter defines two custom properties for the block reference: Position X
and Position Y (relative to the base point of the block reference.)

A dynamic block definition must contain at least one parameter. When a
parameter is added to a dynamic block definition, grips associated with key
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points of the parameter are automatically added. You must then add an action
to the block definition and associate the action with a parameter.

In a drawing, you use a grip or custom property in the Properties palette to
manipulate the block reference. When you manipulate the block reference in
a drawing, by moving a grip or changing the value of a custom property in
the Properties palette, you change the value of the parameter that defines that
custom property in the block. When you change the value of the parameter,
it drives the action that is associated with that parameter, which changes the
geometry (or a property) of the dynamic block reference.

Parameters also define and constrain values that affect the dynamic block
reference’s behavior in a drawing. Some parameters can have a fixed set of
values, minimum and maximum values, or increment values. For example, a
linear parameter used in a window block may have the following fixed set of
values: 10, 20, 30, and 40. When the block reference is inserted in a drawing,
you can only change the window to one of these values. Adding a value set
to a parameter allows you to limit how the block reference is manipulated in
a drawing. For more information about parameter value sets, see “Specify
Value Sets for Dynamic Blocks” on page 532.

The point, linear, polar, XY, and rotation parameters have a property called
Chain Actions. For more information about allowing chained actions for a
parameter, see “Allow Chained Actions for Dynamic Blocks” on page 536.

You can also extract parameter values through the Attribute Extraction wizard
or through an attribute extraction template file.

The following table lists and describes the types of parameters you can add to
a dynamic block definition and the types of actions you can associate with
each parameter.

Supported
Actions

DescriptionParameter
Type

Move, StretchDefines an X and Y location in the drawing. In the Block
Editor, looks similar to an ordinate dimension.

Point

Move, Scale,
Stretch, Array

Shows the distance between two anchor points.
Constrains grip movement along a preset angle. In the
Block Editor, looks similar to an aligned dimension.

Linear

Move, Scale,
Stretch, Polar
Stretch, Array,

Shows the distance between two anchor points and
displays an angle value. You can use both grips and the
Properties palette to change both the distance value and

Polar

the angle. In the Block Editor, looks similar to an aligned
dimension

Move, Scale,
Stretch, Array

Shows the X and Y distances from the base point of the
parameter. In the Block Editor, displays as a pair of
dimensions (horizontal and vertical).

XY
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Supported
Actions

DescriptionParameter
Type

RotateDefines an angle. In the Block Editor, displays as a circle.Rotation

FlipFlips objects. In the Block Editor, displays as a reflection
line. Objects can be flipped about this reflection line.

Flip

Displays a value that shows if the block reference has been
flipped or not.

None (The
action is implied

Defines an X and Y location and an angle. An alignment
parameter always applies to the entire block and needs

Alignment

and containedno action associated with it. An alignment parameter
within
parameter.)

allows the block reference to automatically rotate around
a point to align with another object in the drawing. An
alignment parameter affects the rotation property of the
block reference. In the Block Editor, looks like an
alignment line.

None (The
action is implied

Controls the visibility of objects in the block. A visibility
parameter always applies to the entire block and needs

Visibility

and controlledno action associated with it. In a drawing, you click the
by visibility
states.)

grip to display a list of visibility states available for the
block reference. In the Block Editor, displays as text with
an associated grip.

LookupDefines a custom property that you can specify or set to
evaluate a value from a list or table you define. It can be

Lookup

associated with a single lookup grip. In the block
reference, you click the grip to display a list of available
values. In the Block Editor, displays as text with an
associated grip.

NoneDefines a base point for the dynamic block reference
relative to the geometry in the block. Cannot be

Base

associated with any actions, but can belong to an action’s
selection set. In the Block Editor, displays as a circle with
crosshairs.

See also:

“Specify Value Sets for Dynamic Blocks” on page 532
“Overview of Specifying Custom Properties for Dynamic Blocks” on page 529
“Extract Data from Block Attributes” on page 554
“Extract Block Attribute Data (Advanced)” on page 555

To add a point parameter to a dynamic block definition

1 In the Block Editor, in the Block Authoring Palettes window, Parameters
tab, click the Point Parameter tool.
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2 (Optional) Follow the prompts on the command line to specify the
following for the parameter:

■ Name

■ Label

■ Description

■ Chained Actions

■ Properties displayed for block reference

NOTE You can also specify and edit these properties in the Properties palette
at a later time, after you’ve added the parameter to the block definition.

3 Do one of the following to specify a location for the parameter:

■ Use the pointing device.

■ Enter the X and Y coordinate values, separated by a comma.

4 Do one of the following to specify a location for the parameter label:

■ Use the pointing device.

■ Enter the X and Y coordinate values, separated by a comma.

The yellow alert icon indicates that you should associate an action
with the parameter you just added.

5 To add an action now, double-click the alert icon. Follow the prompts
to associate an action with the parameter and a selection set of geometry.

6 On the Block Editor toolbar, click Save Block Definition.

7 If you are finished using the Block Editor, click Close Block Editor.

Block Editor toolbar

To add a linear parameter to a dynamic block definition

1 In the Block Editor, in the Block Authoring Palettes window, Parameters
tab, click the Linear Parameter tool.

2 (Optional) Follow the prompts on the command line to specify the
following for the parameter:

■ Name
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■ Label

■ Description

■ Value set

■ Chained Actions

■ Properties displayed for block reference

NOTE You can also specify and edit these properties in the Properties palette
at a later time, after you’ve added the parameter to the block definition.

3 Do one of the following to specify a base point for the parameter:

■ Use the pointing device.

■ Enter the X and Y coordinate values, separated by a comma.

4 Do one of the following to specify an endpoint for the parameter:

■ Use the pointing device.

■ Enter the X and Y coordinate values, separated by a comma.

5 Do one of the following to specify a location for the parameter label:

■ Use the pointing device.

■ Enter the X and Y coordinate values, separated by a comma.

The yellow alert icon indicates that you should associate an action
with the parameter you just added.

6 To add an action now, double-click the alert icon. Follow the prompts
to associate an action with the parameter and a selection set of geometry.

7 On the Block Editor toolbar, click Save Block Definition.

8 If you are finished using the Block Editor, click Close Block Editor.

Block Editor toolbar

To add a polar parameter to a dynamic block definition

1 In the Block Editor, in the Block Authoring Palettes window, Parameters
tab, click the Polar Parameter tool.
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2 (Optional) Follow the prompts on the command line to specify the
following for the parameter:

■ Name

■ Label

■ Description

■ Value set

■ Chained Actions

■ Properties displayed for block reference

NOTE You can also specify and edit these properties in the Properties palette
at a later time, after you’ve added the parameter to the block definition.

3 Do one of the following to specify a base point for the parameter:

■ Use the pointing device.

■ Enter the X and Y coordinate values, separated by a comma.

4 Do one of the following to specify an endpoint for the parameter:

■ Use the pointing device.

■ Enter the X and Y coordinate values, separated by a comma.

5 Do one of the following to specify a location for the parameter label:

■ Use the pointing device.

■ Enter the X and Y coordinate values, separated by a comma.

The yellow alert icon indicates that you should associate an action
with the parameter you just added.

6 To add an action now, double-click the alert icon. Follow the prompts
to associate an action with the parameter and a selection set of geometry.

7 On the Block Editor toolbar, click Save Block Definition.

8 If you are finished using the Block Editor, click Close Block Editor.

Block Editor toolbar
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To add an XY parameter to a dynamic block definition

1 In the Block Editor, in the Block Authoring Palettes window, Parameters
tab, click the XY Parameter tool.

2 (Optional) Follow the prompts on the command line to specify the
following for the parameter:

■ Name

■ Label

■ Description

■ Value set

■ Chained Actions

■ Properties displayed for block reference

NOTE You can also specify and edit these properties in the Properties palette
at a later time, after you’ve added the parameter to the block definition.

3 Do one of the following to specify a base point for the parameter:

■ Use the pointing device.

■ Enter the X and Y coordinate values, separated by a comma.

4 Do one of the following to specify an endpoint for the parameter:

■ Use the pointing device.

■ Enter the X and Y coordinate values, separated by a comma.

The yellow alert icon indicates that you should associate an action
with the parameter you just added.

5 To add an action now, double-click the alert icon. Follow the prompts
to associate an action with the parameter and a selection set of geometry.

6 On the Block Editor toolbar, click Save Block Definition.

7 If you are finished using the Block Editor, click Close Block Editor.

Block Editor toolbar
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To add a rotation parameter to a dynamic block definition

1 In the Block Editor, in the Block Authoring Palettes window, Parameters
tab, click the Rotation Parameter tool.

2 (Optional) Follow the prompts on the command line to specify the
following for the parameter:

■ Name

■ Label

■ Description

■ Value set

■ Chained Actions

■ Properties displayed for block reference

NOTE You can also specify and edit these properties in the Properties palette
at a later time, after you’ve added the parameter to the block definition.

3 Do one of the following to specify a base point for the parameter:

■ Use the pointing device.

■ Enter the X and Y coordinate values, separated by a comma.

4 Do one of the following to specify the radius for the parameter:

■ Use the pointing device.

■ Enter a value.

5 Specify a base angle for the parameter.

The angle shown in the Properties palette when you select the block
reference in a drawing is measured relative to the base angle specified
in the block definition.

6 Do one of the following to specify a default rotation angle for the
parameter:

■ Use the pointing device.

■ Enter an angle value.

7 Do one of the following to specify a location for the parameter label:

■ Use the pointing device.

■ Enter the X and Y coordinate values, separated by a comma.
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The yellow alert icon indicates that you should associate an action
with the parameter you just added.

8 To add an action now, double-click the alert icon. Follow the prompts
to associate an action with the parameter and a selection set of geometry.

9 On the Block Editor toolbar, click Save Block Definition.

10 If you are finished using the Block Editor, click Close Block Editor.

Block Editor toolbar

To add an alignment parameter to a dynamic block definition

1 In the Block Editor, in the Block Authoring Palettes window, Parameters
tab, click the Alignment Parameter tool.

2 Follow the prompts on the command line to specify the parameter name.

3 Do one of the following to specify the base point of the alignment
parameter:

■ Use the pointing device.

■ Enter the X and Y coordinate values, separated by a comma.

This base point is the default location for the alignment parameter grip.

4 (Optional) Enter type on the command line and follow the prompts to
specify whether the parameter type is perpendicular or tangent.

5 Do one of the following to specify the alignment direction:

■ Use the pointing device.

■ Enter the X and Y coordinate values, separated by a comma.

6 On the Block Editor toolbar, click Save Block Definition.

7 If you are finished using the Block Editor, click Close Block Editor.

Block Editor toolbar
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To add a flip parameter to a dynamic block definition

1 In the Block Editor, in the Block Authoring Palettes window, Parameters
tab, click the Flip Parameter tool.

2 (Optional) Follow the prompts on the command line to specify the
following for the parameter:

■ Name

■ Label

■ Description

■ Properties displayed for block reference

NOTE You can also specify and edit these properties in the Properties palette
at a later time, after you’ve added the parameter to the block definition.

3 Do one of the following to specify the first point of the reflection line
for the flip parameter:

■ Use the pointing device.

■ Enter the X and Y coordinate values, separated by a comma.

This first point of the reflection line is the default location for the flip
parameter grip.

4 Do one of the following to specify the second point of the reflection line
for the flip parameter:

■ Use the pointing device.

■ Enter the X and Y coordinate values, separated by a comma.

5 Do one of the following to specify a location for the parameter label:

■ Use the pointing device.

■ Enter the X and Y coordinate values, separated by a comma.

The yellow alert icon indicates that you should associate an action
with the parameter you just added.

6 To add an action now, double-click the alert icon. Follow the prompts
to associate an action with the parameter and a selection set of geometry.

7 On the Block Editor toolbar, click Save Block Definition.

8 If you are finished using the Block Editor, click Close Block Editor.

Block Editor toolbar
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To add a visibility parameter to a dynamic block definition

1 In the Block Editor, in the Block Authoring Palettes window, Parameters
tab, click the Visibility Parameter tool.

2 (Optional) Follow the prompts on the command line to specify the
following for the parameter:

■ Name

■ Label

■ Description

■ Properties displayed for block reference

NOTE You can also specify and edit these properties in the Properties palette
at a later time, after you’ve added the parameter to the block definition.

3 Do one of the following to specify a location for the parameter:

■ Use the pointing device.

■ Enter the X and Y coordinate values, separated by a comma.

This is the location for the visibility parameter grip in the block reference.

4 On the Block Editor toolbar, click Save Block Definition.

5 If you are finished using the Block Editor, click Close Block Editor.

Block Editor toolbar

To add a lookup parameter to a dynamic block definition

1 In the Block Editor, in the Block Authoring Palettes window, Parameters
tab, click the Lookup Parameter tool.

2 (Optional) Follow the prompts on the command line to specify the
following for the parameter:

■ Name

■ Label
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■ Description

■ Properties displayed for block reference

NOTE You can also specify and edit these properties in the Properties palette
at a later time, after you’ve added the parameter to the block definition.

3 Do one of the following to specify a location for the parameter:

■ Use the pointing device.

■ Enter the X and Y coordinate values, separated by a comma.

The yellow alert icon indicates that you should associate an action
with the parameter you just added.

4 To add an action now, double-click the alert icon. Follow the prompts
to associate a lookup action with the parameter. This will display the
Property Lookup Table dialog box, which you can complete now or later.

5 Click OK.

6 On the Block Editor toolbar, click Save Block Definition.

7 If you are finished using the Block Editor, click Close Block Editor.

Block Editor toolbar

To add a base point parameter to a dynamic block definition

1 In the Block Editor, in the Block Authoring Palettes window, Parameters
tab, click the Base Point Parameter tool.

2 Do one of the following to specify a location for the parameter:

■ Use the pointing device.

■ Enter the X and Y coordinate values, separated by a comma.

3 On the Block Editor toolbar, click Save Block Definition.

4 If you are finished using the Block Editor, click Close Block Editor.

Block Editor toolbar
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Use Actions with Dynamic Blocks

Actions define how the geometry of a dynamic block reference will move or
change when the custom properties of the block reference are manipulated
in a drawing.

Overview of Using Actions in Dynamic Blocks

Actions define how the geometry of a dynamic block reference will move or
change when the custom properties of a block reference are manipulated in
a drawing. A dynamic block usually contains at least one action.

In general, when you add an action to a dynamic block definition, you must
associate the action with a parameter, a key point on the parameter, and
geometry. A key point is the point on a parameter that drives its associated
action when edited. The geometry associated with an action is called the
selection set.

In the following example, the dynamic block definition contains geometry
that represents a desk, a linear parameter with one grip specified for its
endpoint, and a stretch action associated with the endpoint of the parameter
and the geometry for the right side of the desk. The endpoint of the parameter
is the key point. The geometry on the right side of the desk is the selection
set.

When you want to change the block reference in a drawing, you move the
grip, and the desk stretches.

The types of actions you can use in a dynamic block are

■ Move
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■ Scale

■ Stretch

■ Polar Stretch

■ Rotate

■ Flip

■ Array

■ Lookup

You can assign more than one action to the same parameter and geometry.
However, you should not assign two or more of the same type of actions to
the same key point on a parameter if both actions affect the same geometry.
This can result in unexpected behavior in the block reference.

Actions and Parameter Types

Each type of action can be associated with specific parameters. The following
table shows the parameters with which you can associate each type of action.

ParameterAction Type

Point, linear, polar, XYMove

Linear, polar, XYScale

Point, linear, polar, XYStretch

PolarPolar Stretch

RotationRotate

FlipFlip

Linear, polar, XYArray

LookupLookup

Use a Move Action in a Dynamic Block

The move action is similar to the  command. In a dynamic block reference, a
move action causes objects to move a specified distance and angle.

In a dynamic block definition, you can associate a move action with any of
the following parameters:

■ Point
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■ Linear

■ Polar

■ XY

After associating a move action with a parameter, you associate the action
with a selection set of geometry.

In a dynamic block reference, if you change the value of a parameter associated
with a move action through a grip or the Properties palette, it may affect the
key point on the parameter associated with the move action. If the key point
is affected, the geometry in the move action’s selection set will move.

For example, you have a dynamic block that represents a chair. The block
contains a point parameter and a move action associated with the point
parameter. The move action’s selection set contains all the geometry in the
block (the chair). When you use the grip associated with the point parameter
(or the Position X or Position Y properties in the Properties palette) to
manipulate the dynamic block reference, it changes the value of the point
parameter. This change in value causes the chair to move.

In the following example, when the chair block reference is moved by dragging
the point parameter grip, the new position of this grip is reported in the
Properties palette

Specify the Distance Type Property for a Move Action

When a move action is associated with an XY parameter, the move action has
an override property called Distance Type. This property specifies whether the
distance applied to the move is the parameter’s X value, Y value, or X and Y
coordinate value from the parameter’s base point.

For example, you specify X Distance as the Distance Type for a move action
in a dynamic block definition. That means that the block can only be moved
on the X axis. So if you try to move the block on the Y axis, it doesn’t move.
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See also:

“Use Distance Multiplier and Angle Offset Action Overrides” on page 507

To add a move action to a dynamic block definition

1 In the Block Editor, in the Block Authoring Palettes window, Actions
tab, click the Move Action tool.

2 In the Block Editor drawing area, select a parameter to associate with
the action. (You can associate the following parameter types with a move
action: point, linear, polar, and XY.)

3 Select the objects (the selection set) to associate with the action.

4 Press ENTER.

5 (Optional) Follow the prompts on the command line to specify a distance
multiplier and angle offset.

6 Do one of the following to specify the location of the action:

■ Use the pointing device.

■ Enter the X and Y coordinate values, separated by a comma.

NOTE The action location in the block definition has no effect on the
appearance or functionality of the block reference.

7 On the Block Editor toolbar, click Save Block Definition.

8 If you are finished using the Block Editor, click Close Block Editor.

Block Editor toolbar

To specify the Distance Type property for a move action associated with an
XY parameter

1 In the Block Editor, select a move action.

2 On the Properties palette, Overrides area, Distance Type, select an option
from the list.
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Use a Scale Action in a Dynamic Block

The scale action is similar to the  command. In a dynamic block reference, a
scale action causes the block’s selection set to scale when the associated
parameter is edited by moving grips or by using the Properties palette.

In a dynamic block definition, you associate a scale action with an entire
parameter, not a key point on the parameter. You can associate a scale action
with any of the following parameters:

■ Linear

■ Polar

■ XY

After associating a scale action with a parameter, you associate the action with
a selection set of geometry.

Specify the Type of Base Point for a Scale Action

The scale action has a property called Base Type. With this property, you specify
whether the base point for the scale factor is dependent or independent.

Specify the Scale Type Property for a Scale Action

When a scale action is associated with an XY parameter, the scale action has
an override property called Scale Type. This property specifies whether the
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scale factor applied is the parameter’s X distance, Y distance, or X and Y
coordinate value distance from the parameter’s base point.

For example, you specify X Distance as the Scale Type for a scale action in a
dynamic block definition. In a drawing, when you edit the block reference by
dragging a grip on the XY parameter only along the Y axis, the associated
geometry does not scale.

To add a scale action to a dynamic block definition

1 In the Block Editor, in the Block Authoring Palettes window, Actions
tab, click the Scale Action tool.

2 In the Block Editor drawing area, select a parameter to associate with
the action. (You can associate the following parameter types with a scale
action: linear, polar, and XY.)

3 Select the geometry (the selection set) to associate with the action.

4 Press ENTER.

5 (Optional) Follow the prompts on the command line to specify the type
of base point.

6 Do one of the following to specify the location of the action:

■ Use the pointing device.

■ Enter the X and Y coordinate values, separated by a comma.

NOTE The action location in the block definition has no effect on the
appearance or functionality of the block reference.

7 On the Block Editor toolbar, click Save Block Definition.

8 If you are finished using the Block Editor, click Close Block Editor.

Block Editor toolbar

To specify an independent base point for a scale action in a dynamic block
definition

1 In the Block Editor, select a scale action.

2 On the Properties palette, Overrides area, Base Type, select Independent
from the drop-down list.
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To specify the Scale Type property for a scale action associated with an XY
parameter

1 In the Block Editor, select a scale action associated with an XY parameter.

2 On the Properties palette, Overrides area, Scale Type, select an option
from the drop-down list.

Depending on the override you apply, the scale action for the block is
limited to the X axis, the Y axis, or both.

Use a Stretch Action in a Dynamic Block

In a dynamic block reference, a stretch action causes objects to move and
stretch a specified distance in a specified location.

In a dynamic block definition, you can associate a stretch action with any of
the following parameters:

■ Point

■ Linear

■ Polar

■ XY

After associating a stretch action with a parameter, you specify a stretch frame
for the stretch action. You then select the objects for the stretch action’s
selection set. The stretch frame determines how the objects within or crossed
by the frame are edited in the block reference. The behavior is similar to
specifying a crossing selection window with the  command.

■ Objects entirely within the frame are moved.

■ Objects that cross the frame are stretched.

■ Objects within or crossed by the frame, but not included in the selection
set, are not stretched or moved.

■ Objects outside the frame and included in the selection set are moved.

In the following example, the stretch frame is indicated by the dashed line,
and the selection set has a haloed effect. The top circle, while enclosed by the
stretch frame, is not included in the selection set, so the top circle won’t move.
The bottom circle is entirely enclosed in the stretch frame and included in
the selection set, so the bottom circle will move. The rectangle is crossed by
the stretch frame and included in the selection set, so the rectangle will stretch.
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In a dynamic block reference, if you change the value of a parameter associated
with a stretch action through a grip or the Properties palette, it may affect the
key point on the parameter associated with the stretch action. If the key point
is affected, the geometry in the stretch action’s selection set will move.

Specify the Distance Type Property for a Stretch Action

When a stretch action is associated with an XY parameter, the stretch action
has an override property called Distance Type. This property specifies whether
the distance applied to the move is the parameter’s X value, Y value, or X an
Y coordinate value from the parameter’s base point.

For example, you specify X Distance as the Distance Type for a stretch action
in a dynamic block definition. In a drawing, when you try to edit the block
reference by dragging the key point only along the Y axis, the associated
geometry does not move because you’ve added the Distance Type override
allowing only a move on the X axis.

See also:

“Use Distance Multiplier and Angle Offset Action Overrides” on page 507

To add a stretch action to a block definition

1 In the Block Editor, in the Block Authoring Palettes window, Actions
tab, click the Stretch Action tool.

2 In the Block Editor drawing area, select a parameter to associate with
the action. (You can associate the following parameter types with a move
action: point, linear, polar, and XY.)
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If you associated the stretch action with a point parameter, go to step
4.

3 Do one of the following to select a parameter point to associate with the
action:

■ Use the pointing device.

■ Follow the prompts on the command line.

4 Do one of the following to specify the first corner of the stretch frame:

■ Use the pointing device.

■ Enter the X and Y coordinate values, separated by a comma.

5 Do one of the following to specify the opposite corner of the stretch
frame:

■ Use the pointing device.

■ Enter the X and Y coordinate values, separated by a comma.

6 Select the objects for the selection set.

7 Press ENTER.

8 (Optional) Follow the prompts on the command line to specify a distance
multiplier and angle offset.

9 Do one of the following to specify the location of the action:

■ Use the pointing device.

■ Enter the X and Y coordinate values, separated by a comma.

NOTE The action location in the block definition has no effect on the
appearance or the functionality of the block reference.

10 On the Block Editor toolbar, click Save Block Definition.

11 If you are finished using the Block Editor, click Close Block Editor.

Block Editor toolbar
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To specify the Distance Type property for a stretch action associated with an
XY parameter

1 In the Block Editor, select a stretch action associated with an XY
parameter.

2 On the Properties palette, Overrides area, Distance Type, select an option
from the drop-down list.

Depending on the override you apply, the stretch action for the block is limited
to the X axis, the Y axis, or both.

Use a Polar Stretch Action in a Dynamic Block

In a block reference, a polar stretch action rotates, moves, and stretches objects
a specified angle and distance when the key point on the associated polar
parameter is changed through a grip or the Properties palette.

In a dynamic block definition, you can only associate a polar stretch action
with a polar parameter. The base point for the stretch part of the action is the
parameter point opposite the key point.

After associating a polar stretch action with a polar parameter, you specify a
stretch frame for the polar stretch action. You then select objects to stretch
and objects to rotate.

Objects entirely within the frame are moved.

Objects that cross the frame are stretched.

Objects in the action’s selection set specified to rotate only are not stretched.

Objects within the frame are moved linearly after they are rotated.

Objects crossed by the frame are stretched linearly after they are rotated.

Objects within or crossed by the frame, but not included in the selection
set, are not stretched or rotated.

■ Objects outside the frame and included in the selection set are moved.

In the following example, the stretch frame is indicated by the dashed line,
and the selection set has a haloed effect. The top circle, while enclosed by the
stretch frame, is not included in the selection set, so the top circle won’t move.
The bottom circle is entirely enclosed in the stretch frame and included in
the stretch selection set, so the bottom circle will move. The rectangle is crossed
by the stretch frame and included in the selection set, so the rectangle will
stretch. The square is entirely enclosed in the stretch frame and included in
the rotate selection set, but not the stretch selection set, so the square will
rotate only.
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In a dynamic block reference, if you change the value of a parameter associated
with a polar stretch action through a grip or the Properties palette, it may
affect the key point on the parameter associated with the polar stretch action.
If the key point is affected, the geometry in the polar stretch action’s selection
set will move or rotate depending on how the block was defined.

If you only want objects in the block reference to rotate, don’t include any
objects in the stretch frame.

See also:

“Use Distance Multiplier and Angle Offset Action Overrides” on page 507

To add a polar stretch action to a block definition

1 In the Block Editor, in the Block Authoring Palettes window, Actions
tab, click the Stretch Action tool.

2 In the Block Editor drawing area, select a polar parameter to associate
with the action. (You can associate only a polar parameter with a polar
stretch action.)

3 Do one of the following to select a parameter point to associate with the
action:

■ Use the pointing device.

■ Follow the prompts on the command line.
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4 Do one of the following to specify the first corner of the stretch frame:

■ Use the pointing device.

■ Enter the X and Y coordinate values, separated by a comma.

5 Do one of the following to specify the opposite corner of the stretch
frame:

■ Use the pointing device.

■ Enter the X and Y coordinate values, separated by a comma.

6 Select the objects to stretch or move.

7 Press ENTER.

8 Select the objects that you want to rotate.

(The objects you select in steps 6 and 8 make up the polar stretch action’s
selection set.)

9 Press ENTER.

10 (Optional) Follow the prompts on the command line to specify distance
and offset.

11 Do one of the following to specify the location of the action:

■ Use the pointing device.

■ Enter the X and Y coordinate values, separated by a comma.

NOTE The action location in the block definition has no effect on the
appearance or functionality of the block reference.

12 On the Block Editor toolbar, click Save Block Definition.

13 If you are finished using the Block Editor, click Close Block Editor.

Block Editor toolbar

Use a Rotate Action in a Dynamic Block

The rotate action is similar to the  command. In a dynamic block reference,
a rotate action causes its associated objects to rotate when the associated
parameter is edited through a grip or the Properties palette.
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In a dynamic block definition, you can associate a rotate action only with a
rotation parameter. The rotate action is associated with the entire parameter,
not a key point on the parameter.

After associating a rotate action with a rotation parameter, you associate the
action with a selection set of geometry.

Specify the Type of Base Point for a Rotate Action

The rotate action has a property called Base Type. With this property, you
specify whether the base point for the rotation is the base point of the
parameter or an independent base point that you specify in the block
definition.

By default, Base Type is set to Dependent. This means that the block rotates
around the associated rotation parameter’s base point. In the following
example, the chair block contains a rotation parameter and an associated
rotate action. The rotate action’s Base Type is Dependent. The base point of
the parameter is at the center of the chair. Thus, the chair rotates about the
center point.

When you set Base Type to Independent, you can specify a base point for the
rotate action other than the base point of the associated rotation parameter.
This independent base point is shown in the Block Editor as an X marker. The
location of the independent base point can be changed by dragging it or by
editing the Base X and Base Y values in the Overrides section of the Properties
palette.

In the following example, the chair block contains a rotation parameter and
an associated rotate action. The rotate action’s Base Type is Independent. The
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independent base point is located at the lower left corner of the chair. Thus,
the chair rotates about the lower left corner.

In the following example, each of the three rectangles in the dynamic block
reference rotates about an independent base point located at the lower left
corner of each rectangle. To achieve this, you assign one rotation parameter.
You then add three rotate actions. Each rotate action is associated with the
rotate parameter. Each rotate action is then associated with a different object
and assigned a different independent base point.

You could achieve the same result by using dependent base points, each with
a different base offset, for each rotation action. However, if you need to move
the rectangles independently from one another (for example, with a polar or
XY parameter and a move action) in the block reference, you should use
independent base points for the rotate actions, or the objects won’t rotate
correctly.

To add a rotate action to a block definition

1 In the Block Editor, in the Block Authoring Palettes window, Actions
tab, click the Rotate Action tool.

2 In the Block Editor drawing area, select a rotation parameter to associate
with the action. (You can associate only a rotation parameter with a
rotate action.)

3 Select the objects (the selection set) to associate with the action.
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4 Press ENTER.

5 (Optional) Follow the prompts on the command line to specify the type
of base point.

6 Do one of the following to specify the location of the action:

■ Use the pointing device.

■ Enter the X and Y coordinate values, separated by a comma.

NOTE The action location in the block definition has no effect on the
appearance or functionality of the block reference.

7 On the Block Editor toolbar, click Save Block Definition.

8 If you are finished using the Block Editor, click Close Block Editor.

Block Editor toolbar

Use a Flip Action in a Dynamic Block

With a flip action, you can flip a dynamic block reference about a specified
axis called a reflection line.

In a dynamic block reference, a flip action causes its associated selection set
to flip about an axis called a reflection line when the associated parameter is
edited through a grip or the Properties palette.

In a dynamic block definition, you can associate a flip action only with a flip
parameter. The flip action is associated with the entire parameter, not a key
point on the parameter. After associating a flip action with a flip parameter,
you associate the action with a selection set of geometry. Only the selected
objects will flip about the reflection line.
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For example, in the following illustration, the polyline between the two circles
is not included in the flip action’s selection set. When the block reference is
flipped, the polyline does not flip with the rest of the geometry.

To add a flip action to a block definition

1 In the Block Editor, in the Block Authoring Palettes window, Actions
tab, click the Flip Action tool.

2 In the Block Editor drawing area, select a parameter to associate with
the action. (You can associate only a flip parameter with a flip action.)

3 Select the objects (the selection set) to associate with the action.

4 Press ENTER.

5 Do one of the following to specify the location of the action:

■ Use the pointing device.

■ Enter the X and Y coordinate values, separated by a comma.

NOTE The action location in the block definition has no effect on the
appearance or functionality of the block reference.

6 On the Block Editor toolbar, click Save Block Definition.

7 If you are finished using the Block Editor, click Close Block Editor.

Block Editor toolbar

Use an Array Action in a Dynamic Block

In a dynamic block reference, an array action causes its associated objects to
copy and array in a rectangular pattern when the associated parameter is edited
through a grip or the Properties palette.
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In a dynamic block definition, you can associate an array action with any of
the following parameters:

■ Linear

■ Polar

■ XY

After associating an array action with a parameter, you associate the action
with a selection set of geometry.

Specify Rows and Columns for an Array Action

When you associate an array action with a linear or polar parameter, you
specify the column offset for the arrayed objects. The column offset determines
the distance between the arrayed objects. When you edit the parameter in the
block reference, the distance of the parameter (from base point to second
point) is divided by the column offset to determine the number of columns
(the number of objects).

For example, you might associate an array action with a linear parameter. You
specify that the array action has a column offset of 2. When you change the
linear parameter in the dynamic block reference to a distance of 10, the number
of columns for the block reference is 5.

If you associate an array action with an XY parameter, you can also specify
the row offset.

Including Parameters in an Array Action’s Selection Set

When you include a parameter in an array action’s selection set, it has no
effect on the behavior of the block reference. The parameter is not copied
with the other objects in the selection set. Additional grips are not displayed
in the block reference.

In the following example, a parking lot block can be arrayed to contain any
number of spaces. The vertical line can also be rotated. Notice that even after
the block has been arrayed, it still contains only one rotation grip.
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However, when you edit the grip for the parameter included in the array
action’s selection set, the parameter’s associated action is triggered for all
instances of the objects. The same behavior occurs when the parameter is not
included in the array action’s selection set.

Using Rotate and Array Actions in the Same Dynamic Block

A dynamic block can contain an array action and a rotate action that have
the same selection set. The order in which the block reference is arrayed and
rotated affects the display of the block.

When you rotate the block first and then array it, all instances of the arrayed
objects are individually rotated around their own base point.

When you array the block first and then rotate it, all instances of the arrayed
objects are rotated around a single base point.

To add an array action a block definition

1 In the Block Editor, in the Block Authoring Palettes window, Actions
tab, click the Array Action tool.

2 In the Block Editor drawing area, select a parameter to associate with
the action. (You can associate linear, polar, and XY parameters with an
array action.)

3 Select the objects (the selection set) to associate with the action.

4 Press ENTER.
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5 If you are associating the array action with an XY parameter, do one of
the following:

■ Enter the distance between rows.

■ Specify a unit cell by entering two values separated by a comma or
by picking two opposite points of a rectangle in the drawing area, and
then go to step 7.

6 Enter a value for the distance between columns.

7 If you are assigning the array action to an XY parameter, enter the
distance between rows.

8 Do one of the following to specify the location of the action:

■ Use the pointing device.

■ Enter the X and Y coordinate values, separated by a comma.

NOTE The action location in the block definition has no effect on the
appearance or functionality of the block reference.

9 On the Block Editor toolbar, click Save Block Definition.

10 If you are finished using the Block Editor, click Close Block Editor.

Block Editor toolbar

Use a Lookup Action in a Dynamic Block

When you add a lookup action to a dynamic block definition and associate
it with a lookup parameter, it creates a lookup table. You can use a lookup
table to assign custom properties and values to a dynamic block.

For information about adding lookup tables to dynamic blocks, see “Use
Lookup Tables to Assign Data to Dynamic Blocks” on page 521.

To add a lookup action to a dynamic block definition

1 In the Block Editor, in the Block Authoring Palettes window, Actions
tab, click the Lookup Action tool.

2 In the Block Editor drawing area, select one or more lookup parameters
to associate with the action. (You can associate only a lookup action
with lookup parameters.)
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3 Do one of the following to specify the location of the action:

■ Use the pointing device.

■ Enter the X and Y coordinate values, separated by a comma.

NOTE The action location in the block definition has no effect on the
appearance or functionality of the block reference.

4 In the Property Lookup Table dialog box, complete the table as necessary.

5 Click OK.

6 On the Block Editor toolbar, click Save Block Definition.

7 If you are finished using the Block Editor, click Close Block Editor.

Block Editor toolbar

Use Distance Multiplier and Angle Offset Action Overrides

Some actions have distance multiplier and angle offset override properties.
These properties allow you to specify a factor by which a parameter value is
increased or decreased when the parameter is edited in a dynamic block
reference.

Action overrides are properties of actions. However, they have no effect on
the block reference until the block reference is manipulated in a drawing.
There are two types of action overrides: distance multiplier and angle offset.

■ Distance multiplier. You use the distance multiplier property to change
a parameter value by a specified factor. For example, if you set the distance
multiplier property to 2 for a stretch action, the associated geometry in the
block reference would increase and double the distance of the grip
movement.

■ Angle offset. You use the angle offset property to increase or decrease the
angle of a changed parameter value by a specified amount. For example, if
you set the angle offset property of a move action to 90, the block reference
would move 90 degrees beyond the angle value of the grip movement.

You can specify these action override properties by following the prompts on
the command line when you add an action to a dynamic block definition.
You can also specify these properties in the Properties palette when you select
an action in the Block Editor.
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The following table shows the available override properties for each type of
action.

Available Override PropertiesAction Type

Distance Multiplier, Angle OffsetMove

NoneScale

Distance Multiplier, Angle OffsetStretch

Distance Multiplier, Angle OffsetPolar Stretch

NoneRotate

NoneFlip

NoneArray

NoneLookup

To specify a distance multiplier override for an action

1 In the Block Editor, select a move, stretch, polar stretch, or array action.

2 On the Properties palette, Overrides area, Distance Multiplier, enter a
value.

3 Press ENTER.

To specify an angle offset override for an action

1 In the Block Editor, select a move, stretch, or polar stretch action.

2 On the Properties palette, Overrides area, Angle Offset, enter a value.

3 Press ENTER.

Use Parameter Sets

Use the Parameter Sets tab on the Block Authoring palette to add commonly
paired parameters and actions to your dynamic block definition.

You add a parameter set to your block the same way you add a parameter. The
action included in the parameter set is automatically added to your block
definition and associated with the added parameter. You must then associate
a selection set (geometry) with each action.

When you first add a parameter set to your dynamic block definition, a yellow
alert icon is displayed next to each action. This indicates that you need to
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associate a selection set with each action. You can double click the yellow
alert icon (or use the  command) and follow the prompts on the command
line to associate the action with a selection set.

NOTE When you insert a lookup parameter set and double click the yellow alert
icon, the Property Lookup Table dialog box is displayed. Lookup actions are
associated with the data you add to this table, not a selection set.

The following table lists the parameter sets provided on the Parameter Sets
tab of the Block Authoring palette.

DescriptionParameter
Set

Adds a point parameter with one grip and an associated move action to the
dynamic block definition.

Point Move

Adds a linear parameter with one grip and an associated move action to
the dynamic block definition.

Linear Move

Adds a linear parameter with one grip and an associated stretch action to
the dynamic block definition.

Linear
Stretch

Adds a linear parameter with one grip and an associated array action to the
dynamic block definition.

Linear Array

Adds a linear parameter with two grips and a move action associated with
each grip to the dynamic block definition.

Linear Move
Pair

Adds a linear parameter with two grips and a stretch action associated with
each grip to the dynamic block definition.

Linear
Stretch Pair

Adds a polar parameter with one grip and an associated move action to the
dynamic block definition.

Polar Move

Adds a polar parameter with one grip and an associated stretch action to
the dynamic block definition.

Polar Stretch

Adds a polar parameter with one grip and an associated array action to the
dynamic block definition.

Polar Array

Adds a polar parameter with two grips and a move action associated with
each grip to the dynamic block definition.

Polar Move
Pair

Adds a polar parameter with two grips and a stretch action associated with
each grip to the dynamic block definition.

Polar Stretch
Pair

Adds an XY parameter with one grip and an associated move action to the
dynamic block definition.

XY Move

Adds an XY parameter with two grips and move action associated with each
grip to the dynamic block definition.

XY Move
Pair

Add Dynamic Behavior to Blocks | 509



DescriptionParameter
Set

Adds an XY parameter with four grips and a move action associated with
each grip to the dynamic block definition.

XY Move
Box Set

Adds an XY parameter with four grips and a stretch action associated with
each grip to the dynamic block definition.

XY Stretch
Box Set

Adds an XY parameter with four grips and an array action associated with
each grip to the dynamic block definition.

XY Array Box
Set

Adds a rotation parameter with one grip and an associated rotate action to
the dynamic block definition.

Rotation

Adds a flip parameter with one grip and an associated flip action to the
dynamic block definition.

Flip

Adds a visibility parameter with one grip. No action is required with a
visibility parameter.

Visibility

Adds a lookup parameter with one grip and a lookup action to the dynamic
block definition.

Lookup

See also:

“Use Block Authoring Palettes” on page 468

To add parameter set to a dynamic block definition

1 In the Block Editor, in the Block Authoring Palettes window, on the
Parameter Sets tab, click a parameter set.

2 Follow the prompts on the command line.

3 On the Block Editor toolbar, click Save Block Definition.

4 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

Specify Grips for Dynamic Blocks

When you add a parameter to a dynamic block definition, custom grips
associated with key points of the parameter are automatically added to the
block. In a drawing, you can use these custom grips to manipulate the geometry
of a dynamic block reference.

All parameters (except the alignment parameter, which always displays one
grip) have a property called Number of Grips. When you select a parameter in
the Block Editor, the Number of Grips property is displayed in the Properties
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palette. This property allows you to specify, from a preset list, the number of
grips you want to display for the parameter.

If you specify that a parameter has 0 grips, you can still edit the dynamic block
reference through the Properties palette (if the block is defined that way).

If a dynamic block definition contains visibility states or a lookup table, you
can define the block so that the only grip that is displayed is a lookup grip.
When you click this grip on the block reference, a drop-down list is displayed.
When you select an item from the list, the display of the block reference may
change.

Grips are automatically added at key points on the parameter. You can
reposition a grip anywhere in the block space relative to its associated key
point on the parameter. When you reposition a grip, it is still tied to the key
point with which it is associated. No matter where the grip is shown in the
block reference, it will still manipulate the key point with which it is associated.
If you move or change the key point of the parameter, the grip’s position
relative to the key point is maintained. Because you use grips to manipulate
dynamic block references in a drawing, you should make sure that each grip
is placed in a logical location. If a grip is not in a logical place, the behavior
may not be what is expected.

Both linear and polar parameters can display two, one, or no grips. When you
define a linear or polar parameter to display one grip, it is displayed at the
endpoint of the parameter. You should only assign actions to the endpoint
of either of these parameters if you plan to display only one grip. Otherwise,
you will not be able to manipulate the reference (trigger the actions) because
a grip won’t be displayed for the key point associated with the action.

If you reposition the grips for a dynamic block, you can use the  command
to reset the grips to their default locations.

The type of parameter you add to the dynamic block definition determines
the type of grips that are added to the block. These grips give visual clues as
to how the block reference can be manipulated in a drawing. The following
table details the types of grips used in dynamic blocks, what they look like,
and the parameters with which they are associated.
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Associated
Parameters

How the Grip Can Be
Manipulated in a Drawing

Grip
Type

Base, Point, Polar, and
XY

Within a plane in any directionStandard

LinearBack and forth in a defined direction or
along an axis

Linear

RotationAround an axisRotation

FlipClick to flip the dynamic block referenceFlip

AlignmentWithin a plane in any direction; when
moved over an object, triggers the block
reference to align with the object

Alignment

Visibility, LookupClick to display a list of itemsLookup

Specify Insertion Cycling for Grips in Dynamic Blocks

Grips in dynamic blocks have a property called Cycling. When this property
is set to Yes, the grip becomes an available insertion point for the dynamic
block reference. You can use the  command to turn on and off cycling for
grips in dynamic blocks as well as specify the cycling order for the grips. When
you insert the dynamic block reference in a drawing, you can use the CTRL
key to cycle through the available grips to select which grip will be the insertion
point for the block.

To specify the number of custom grips displayed for a parameter in a dynamic
block

1 In the Block Editor, select a parameter.

2 On the Properties palette, under Misc, click Number of Grips, and then
select the number of grips you want to display for the parameter.

3 On the Block Editor toolbar, click Save Block Definition.

4 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

In the Block Editor, select a parameter. Right-click in the drawing area. Click
Grip Display ➤ any value.
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To reposition a grip in a dynamic block definition

1 In the Block Editor, select a custom grip (not the standard grip associated
with the key point of the parameter).

2 Do one of the following to reposition the grip:

■ Drag the grip to another position in the block space.

■ On the Properties palette, under Geometry, enter values for the Base
X and Base Y properties. (These values are relative to the base point
of the parameter.)

3 On the Block Editor toolbar, click Save Block Definition.

4 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

To reset grips in a dynamic block definition to their default locations

1 In the Block Editor, enter bgripset on the command line.

2 Select the grip for which you want to reset the grip position(s).

3 On the command line, enter reposition, and then press ENTER.

4 On the Block Editor toolbar, click Save Block Definition.

5 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

In the Block Editor, select a parameter. Right-click in the drawing area. Click
Grip Display ➤ Reset Position.

To turn insertion cycling on or off for a custom grip in a dynamic block
reference

1 In the Block Editor, enter bcycleorder on the command line.

2 In the Insertion Cycling Order dialog box, select a grip from the list, and
click Cycling to turn cycling on or off for the grip. (A check mark in the
Cycling column indicates that cycling is turned on for the grip.)

3 Click OK.

4 On the Block Editor toolbar, click Save Block Definition.

5 (Optional) If you are finished using the Block Editor, click Close Block
Editor.
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In the Block Editor, select a dynamic grip. Right-click in the drawing area.
Click Insertion Cycling.

To modify the insertion cycling order for custom grips in a dynamic block
reference

1 In the Block Editor, enter bcycleorder on the command line.

2 In the Insertion Cycling Order dialog box, select a grip from the list, and
click Move Up or Move Down. (A check mark in the Cycling column
indicates that cycling is turned on for the grip.)

3 Repeat step 2 until you are finished modifying the grip cycling order.

4 Click OK.

5 On the Block Editor toolbar, click Save Block Definition.

6 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

Create Visibility States

You can use visibility states to make geometry visible or invisible in a dynamic
block. One block can have any number of visibility states.

Using visibility states is a powerful way to create a block that has many
different graphical representations. You can easily change a block reference
that has different visibility states without having to find a different one to
insert in your drawing.

For example, you have the following four different weld symbols.

Using visibility states, you can combine these weld symbols into a single
dynamic block. The following example shows the geometry for the four weld
symbols combined in one dynamic block definition in the Block Editor.
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After you combine the geometry in the Block Editor, you add a visibility
parameter. You add only one visibility parameter to a dynamic block definition.
You do not associate any actions with a visibility parameter.

You can then create and name a different visibility state for each weld symbol
(for example, WLD1, WLD2, WLD3, and WLD4). You can make particular
geometry visible or invisible for each state. In the following example, the
WLD1 visibility state is displayed in the Block Editor. The geometry that
displays in a dimmed state is invisible for the WLD1 visibility state.

The visibility parameter includes a lookup grip. This grip is always displayed
in a block reference that contains visibility states. When you click the grip in
the block reference, a drop-down list of all the visibility states in the block
reference is displayed. When you select one of the states from the list, the
geometry that is visible for that state is displayed in the drawing.
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The right-hand side of the Block Editor toolbar displays the name of the current
visibility state. All blocks have at least one visibility state. You cannot delete
the current state. This area of the tool bar also provides several tools for
working with visibility states.

When you work with visibility states, you may or may not want to see the
geometry that is invisible for a given state. You can use the Visibility Mode
button () to display or not display geometry (in a dimmed state) that is
invisible. When the BVMODE system variable is set to 1, geometry that is
invisible for a given state displays in a dimmed mode.

To enable visibility states (add a visibility parameter)

1 In the Block Editor, in the Block Authoring Palettes window, Parameters
tab, click the Visibility Parameter tool.

2 (Optional) Follow the prompts on the command line to specify the
following for the parameter:

■ Name

■ Label

■ Description

■ Properties displayed for the block reference

NOTE You can also specify and edit these properties in the Properties palette
at a later time, after you’ve added the parameter to the block definition.

3 Do one of the following to specify a location for the parameter:

■ Use the pointing device.

■ Enter the X and Y coordinate values, separated by a comma.

This is the default location for the visibility parameter grip.

4 On the Block Editor toolbar, click Save Block Definition.

5 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

Block Editor toolbar
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To create a new visibility state based on the current state

1 On the Block Editor toolbar, click Manage Visibility States.

2 In the Visibility States dialog box, click New.

3 In the New Visibility State dialog box, enter a name for the new visibility
state.

4 Click Leave Visibility of Existing Objects Unchanged in New State.

5 Click OK.

The visibility of existing objects is unchanged in the new state.

Block Editor toolbar

To create a new visibility state in which all objects are invisible

1 On the Block Editor toolbar, click Manage Visibility States.

2 In the Visibility States dialog box, click New.

3 In the New Visibility State dialog box, enter a name for the new visibility
state.

4 Click Hide All Existing Objects in New State.

5 Click OK.

Block Editor toolbar

To create a new visibility state in which all objects are visible

1 On the Block Editor toolbar, click Manage Visibility States.

2 In the Visibility States dialog box, click New.

3 In the New Visibility State dialog box, enter a name for the new visibility
state.

4 Click Show All Existing Objects in New State.

5 Click OK.
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Block Editor toolbar

To make a visibility state current

1 On the Block Editor toolbar, click the Visibility States control.

2 Select the visibility state that you want to set as the current state.

Block Editor toolbar

In the Visibility States dialog box, right-click a visibility state in the list. Click
Set Current.

To delete a visibility state

1 On the Block Editor toolbar, click Manage Visibility States.

2 In the Visibility States dialog box, select a visibility state in the list.

3 Click Delete.

4 Click OK.

Block Editor toolbar

In the Visibility States dialog box, right-click a visibility state in the list. Click
Delete State.

To rename a visibility state

1 In the Block Editor, click Manage Visibility States.

2 In the Visibility States dialog box, select a visibility state in the list.

3 Click Rename.

4 Enter a new name for the visibility state.

5 Click OK.

Block Editor toolbar
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Right-click a visibility state in the list. Click Rename State.

To make objects visible in the current visibility state

1 On the Block Editor toolbar, click Make Visible.

2 In the drawing area, select the objects to make visible in the current
visibility state.

3 Press ENTER.

4 On the command line, enter current.

5 Press ENTER.

Block Editor toolbar

In the Block Editor drawing area, select one or more objects. Right-click in the
drawing area. Click Object Visibility ➤ Show for Current State.

To make objects visible in all visibility states

1 In the Block Editor drawing area, select the objects that you want to
make visible in all visibility states.

2 Right-click in the drawing area.

3 Click Object Visibility ➤ Show for All States.

To make objects invisible in the current visibility state

1 On the Block Editor toolbar, click Make Invisible.

2 In the drawing area, select the objects that you want to make invisible
in the current visibility state.

3 Press ENTER.

4 On the command line, enter current.

5 Press ENTER.

Block Editor toolbar
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In the Block Editor drawing area, select one or more objects. Right-click in the
drawing area. Click Object Visibility ➤ Hide for Current State.

To make objects invisible in all visibility states

1 In the drawing area, select the objects that you want to make invisible
in all visibility states.

2 Right-click in the drawing area.

3 Click Object Visibility ➤ Hide for All States.

To display or not display invisible geometry for visibility states

1 On the Block Editor toolbar, click Visibility Mode.

Block Editor toolbar

To change the order of the visibility states list for a dynamic block reference

1 On the Block Editor toolbar, click Manage Visibility States.

2 In the Visibility States dialog box, select a visibility state in the list.

3 Click Move Up or Move Down to change the order.

4 Repeat steps 2 and 3 until the list of visibility states is in the correct
order.

5 Click OK.

Block Editor toolbar

To set the default visibility state for the dynamic block reference

1 In the Block Editor, click Manage Visibility States.

2 In the Visibility States dialog box, select a visibility state in the list.
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3 Click Move Up until the selected visibility state is at the top of the list.

4 Click OK.

Block Editor toolbar

Use Lookup Tables to Assign Data to Dynamic Blocks

You can use a lookup table to define properties for and assign property values
to a dynamic block.

Overview of Using Lookup Tables to Assign Data to Dynamic Blocks

You can use a lookup table to define properties for and assign property values
to a dynamic block. Using lookup tables is a powerful way to associate
parameter values for the dynamic block reference with other data that you
specify (for example, a model or part number). You can extract this data from
block references in a drawing just as you would extract block attribute data.

When completed, the lookup table assigns property values to the dynamic
block reference based on how it is manipulated in a drawing. Conversely, you
can change how the block reference is displayed in the drawing by changing
the value of a lookup property of the block reference through a lookup grip
or the Properties palette.

The following example shows a dynamic block reference for a lighting fixture.
For this block, the Custom area of the Properties palette displays a size property.
This property is defined in the lookup table for the block.

If you change the size of the lighting fixture in your drawing (using the custom
grips), the size property in the Properties palette changes accordingly.
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You can also use the lookup grip to change the display of the block reference.
When you select a size from the list that is displayed when you click the grip,
the block’s geometry changes and the new size is displayed in the Properties
palette under Custom.

Create a Lookup Table

After you’ve drawn the geometry and added the appropriate parameters and
actions required for the dynamic block’s functionality, you can add a lookup
table to the block definition.

A blank lookup table is created when you add a lookup parameter to a dynamic
block definition and then add a lookup action and associate it with the lookup
parameter. The lookup table is displayed in the lookup table dialog box.
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Add Properties and Values to a Lookup Table

The Property Lookup Table consists of input properties and lookup properties.
Each input property and lookup property is represented by a column in the
table.

■ Input properties. Parameters other than lookup parameters (for example,
a linear parameter labeled “Width”). You can create a column under Input
Properties for every parameter in the block definition except for lookup,
alignment, and base point parameters.

■ Lookup properties. Lookup parameters. You add one lookup parameter
to the dynamic block definition for every lookup property column you
want to add to the lookup table. The lookup parameter label is used as the
property name.

After you add the properties (columns) to the table, you add values to the cells
in each column. You click a cell and enter a value. Make sure to follow the
guidelines in “Specify Values for Lookup Tables” on page 528.

If you defined a value set for an input property (parameter) in the table, a
drop-down list of available values will display when you click a cell in that
column.

The following lookup table is used for the lighting fixture block shown
previously. The linear parameters that have been labeled “Height” and “Width”
have been added as input properties. “Size” has been added as a lookup
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property. The values under Height and Width are taken from the value sets
defined for each of those parameters. The values under Size are entered
manually.

When the parameter values in a dynamic block reference match a row of input
property values, the corresponding lookup property values in that table row
are assigned to the block reference. These lookup properties and values are
displayed in the Properties palette under Custom.

For example, when you edit the lighting fixture block reference to have a
height of 250 centimeters and a width of 500 centimeters, the Size property
in the Custom area of the Properties palette will display a value of 0.25 m x
0.50 m.

In the lookup table, at the bottom of the input properties is a row labeled
<Unmatched>. When the parameter values in a block reference do not match
a row of input property values defined in the block’s lookup table, the lookup
property value that corresponds to <Unmatched> is assigned to the block
reference. The default value is Custom, but you can specify another value by
changing it in the table.

Enable Reverse Lookup

You can also specify that a lookup property allows for reverse lookup. This
adds a lookup grip to the dynamic block reference. When you click this grip,
a drop-down list of the lookup values for that lookup property (column in the
table) is displayed. When you select a value from the list, the corresponding
input property values are assigned to the block reference. Depending on how
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the block was defined, this usually results in a change in the block reference’s
geometry.

To enable reverse lookup for a lookup property, each row in the lookup table
must be unique. After you add properties and values to the table, you can
check for errors and empty cells by clicking the audit button in the Property
Lookup Table dialog box. You can also use the shortcut menu options to insert,
delete, or reorder rows.

NOTE If you leave a cell empty in the lookup properties column and the cell has
an associated input property in the same row, the lookup property will not allow
for reverse lookup.

See also:

“Extract Data from Block Attributes” on page 554
“Extract Block Attribute Data (Advanced)” on page 555

To create a lookup table for a dynamic block

1 In the Block Editor, add one or more lookup parameters to a dynamic
block definition by following the steps in “To add a lookup parameter
to a dynamic block definition” on page 486.

2 In the Block Editor, add a lookup action to a dynamic block definition
by following the steps in “To add a lookup action to a dynamic block
definition” on page 506.

The Property Lookup Table dialog box is displayed.
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3 Use any of the following procedures to set up a lookup table for the
dynamic block:

■ “To add input properties to a lookup table” on page 526

■ “To add lookup properties to a lookup table” on page 526

■ “To enable reverse lookup” on page 527

4 On the Block Editor toolbar, click Save Block Definition.

5 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

Block Editor toolbar

To add input properties to a lookup table

1 In the Block Editor, double-click a lookup action in a dynamic block
definition.

2 In the Property Lookup Table dialog box, click Add Properties.

3 In the Add Parameter Properties dialog box, in the bottom-left corner of
the dialog box, click Add Input Properties.

4 In the Parameter Properties list, select the parameter properties you want
to add to the lookup table. Hold CTRL down to select more than one
property.

5 Click OK.

To add lookup properties to a lookup table

1 In the Block Editor, double-click a lookup action in a dynamic block
definition.

2 In the Property Lookup Table dialog box, click Add Properties.

3 In the Add Parameter Properties dialog box, in the bottom-left corner of
the dialog box, click Add Lookup Properties.

4 In the Parameter Properties list, select the lookup parameter properties
you want to add to the lookup table. Hold CTRL down to select more
than one property.

5 Click OK.
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To add values to a lookup table

1 In the Block Editor, double-click a lookup action in a dynamic block
definition.

2 In the Property Lookup Table dialog box, click an empty cell and do one
of the following:

■ Select a value from the drop-down list. (A drop-down list only displays
if a value set has been defined for the parameter.)

■ Enter a value.

3 Repeat Step 2 as required to complete the table.

4 Click OK.

To enable reverse lookup

1 In the Block Editor, double-click a lookup action in a dynamic block
definition.

2 In the Property Lookup Table dialog box, at the bottom of a Lookup
Property column, click Read Only, and then select Allow Reverse Lookup
from the list.

NOTE You can only select Allow Reverse Lookup if you have entered data
in the column.

3 Click OK.

To make the lookup property read-only

1 In the Block Editor, double-click a lookup action in a dynamic block
definition.

2 In the Property Lookup Table dialog box, at the bottom of a Lookup
Property column, click Allow Reverse Lookup, and then select Read Only
from the list.

3 Click OK.

To check for errors in a lookup table

1 In the Property Lookup Table dialog box, click Audit.
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To open an existing lookup table

1 In the Block Editor, double-click a lookup action.

Specify Values for Lookup Tables

The following rules apply when you specify values in lookup tables:

■ Use a comma as the delimiter between values.

■ You can specify any number of unique values separated by commas. For
example: 5,6,7 5.5,6.25

■ To specify a range, use brackets [ ] to specify that the range includes the
values separated by a comma, or use parentheses ( ) to specify that the range
does not include the values separated by a comma.

■ For a continuous range, use a pair of values separated by a comma, enclosed
in brackets or parentheses. For example: [3,10] specifies any value between
3 and 10, including 3 and 10 (3,10) specifies any value between 3 and 10,
not including 3 and 10.

■ For an open-ended range, use one value with a comma, enclosed in brackets
or parentheses. For example: [,5] specifies less than or equal to 5; (5,)
specifies greater than 5.

■ Use no more than 256 characters in a table cell.

■ You can use architectural and mechanical unit syntax (for example, 15’1/4”).

■ If you enter a value in an invalid format, the value will be reset to the last
value when you move to another cell in the table.

Lookup tables support the following:

■ All numeric parameter properties (for example, distance and angles for
point, linear, polar, XY, and rotation parameters)

■ Text string parameter properties (for example, flip and visibility parameter
values)

No procedures for this topic.

528 | Chapter 25   Create and Use Blocks (Symbols)



Specify Custom Properties for Dynamic Blocks

When you create a dynamic block, you can specify custom properties for the
block. You can also specify whether or not these properties appear in the
Properties palette when you select the block reference in a drawing.

Overview of Specifying Custom Properties for Dynamic Blocks

In the Block Editor, you can specify properties for a parameter in a dynamic
block definition. Some of these properties can be displayed as custom properties
for the dynamic block reference when it is in a drawing. These properties are
displayed under Custom in the Properties palette.

In the Block Editor, you can specify parameter labels. When you select the
dynamic block reference in a drawing, these properties are shown under
Custom in the Properties palette. It is good practice to specify unique parameter
labels within the block.

Depending on the parameters used in the dynamic block definition, other
parameter properties may be listed under Custom in the Properties palette
when you select the dynamic block reference in a drawing. For example, a
polar parameter has an angle property that displays in the Properties palette.
Depending on how the dynamic block is defined, these properties might
display values such as size, angle, and position for a selected block reference.

You can specify whether or not these custom properties are displayed for the
block reference when it is selected in a drawing. These properties can also be
extracted using the Attribute Extraction wizard.

You can also use the Properties palette to specify the geometric properties
(such as color, linetype, and lineweight) of a parameter. These properties are
listed in the Properties Palette under Geometry when you select a parameter
in the Block Editor.

Other parameter properties, such as Value Set properties and Chain Actions,
define how the block reference will function in a drawing.

In the Block Editor, you can also specify if the block can be exploded and if
the block can be non-uniformly scaled.

See also:

“Specify Value Sets for Dynamic Blocks” on page 532
“Allow Chained Actions for Dynamic Blocks” on page 536
“Specify Grips for Dynamic Blocks” on page 510
“Extract Data from Block Attributes” on page 554
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To specify a parameter label

1 In the Block Editor, click Tools menu ➤ Properties to display the
Properties palette.

2 In the Block Editor, select a parameter.

3 In the Properties palette, under Property Labels, click <parameter name>
label.

4 Enter a label for the parameter.

5 On the Block Editor toolbar, click Save Block Definition.

6 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

Standard toolbar

Right-click the selected object. Click Rename Label. Enter a new name for the
parameter, and press ENTER.

To specify the display of custom properties in a dynamic block reference

1 In the Block Editor, click Tools menu ➤ Properties to display the
Properties palette.

2 In the Block Editor, select a parameter.

3 In the Properties palette, under Misc, click Show Properties.

4 On the drop-down list, do one of the following:

■ Select Yes to display custom properties for the block reference.

■ Select No to specify that the custom properties will not display for a
block reference.

5 On the Block Editor toolbar, click Save Block Definition.

6 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

Standard toolbar
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To specify exploding dynamic block reference

1 Use one of the following procedures to open a block definition in the
Block Editor:

■ “To open an existing block definition in the Block Editor” on page
464

■ “To open a block from the DesignCenter window in the Block Editor”
on page 465

2 In the Block Editor, make sure nothing is selected.

3 In the Properties palette, under Block, click Allow Exploding.

4 On the drop-down list, select Yes or No.

5 On the Block Editor toolbar, click Save Block Definition.

6 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

Standard toolbar

BEDIT

To prevent non-uniform scaling in dynamic block reference

1 Use one of the following procedures to open a block definition in the
Block Editor:

■ “To open an existing block definition in the Block Editor” on page
464

■ “To open a block from the DesignCenter window in the Block Editor”
on page 465

2 In the Block Editor, make sure nothing is selected.

3 In the Properties palette, under Block, click Scale Uniformly.

4 On the drop-down list, select Yes.

5 On the Block Editor toolbar, click Save Block Definition.

6 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

Standard toolbar

Add Dynamic Behavior to Blocks | 531



BEDIT

Specify Value Sets for Dynamic Blocks

You can specify a defined value set for linear, polar, XY, and rotation
parameters.

A value set is a range or list of values specified for a parameter. These values
can be displayed for the block reference as a drop-down list next to the
parameter label under Custom in the Properties palette. When you define a
value set for a parameter, the parameter is limited to these values when the
block reference is manipulated in a drawing. For example, if you define a linear
parameter in a block that represents a window to have a value set of 20, 40,
and 60, the window can only be stretched to 20, 40, or 60 units.

When you create a value list for a parameter, the value of the parameter as it
exists in the definition is automatically added to the value set. This is the
default value for the block reference when you insert it in a drawing.

In a block reference, if you change the parameter’s value to a value other than
one in the list, the parameter will adjust to the closest valid value. For example,
you define a linear parameter to have a value set of 2, 4, and 6. When you try
to change the value of that parameter in a block reference to 10, the resulting
parameter value is 6 because it is the closest valid value.

When you specify a value set for a parameter in a dynamic block, tick marks
are displayed when you grip-edit the block reference in a drawing. The tick
marks indicate the locations for the parameter’s valid values.

NOTE If you redefine the values in a value set after you’ve added the parameter
properties to a lookup table, make sure to update the lookup table to match the
new values in the value set.
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To specify a value set for a linear or polar parameter

1 In the Block Editor, click Tools menu ➤ Properties to display the
Properties palette.

2 In the Block Editor, select a linear or polar parameter.

3 In the Properties palette, under Value Set, click Dist Type.

4 On the drop-down list, select List.

5 In the Properties palette, under Value Set, click Dist Value List.

6 Click the [...] button.

7 In the Add Distance Value dialog box, under Distances to Add, enter one
value or two or more values separated by commas.

8 Click Add.

9 Click OK.

10 On the Block Editor toolbar, click Save Block Definition.

11 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

Standard toolbar

To specify a value set for an XY parameter

1 In the Block Editor, click Tools menu ➤ Properties to display the
Properties palette.

2 In the Block Editor, select an XY parameter.

3 In the Properties palette, under Value Set, click Hor Type or Ver Type.

4 On the drop-down list, select List.

5 In the Properties palette, under Value Set, click Hor Value List or Ver
Value List.

6 Click the [...] button.

7 In the Add Distance Value dialog box, under Distances to Add, enter one
value or two or more values separated by commas.

8 Click Add.

9 Click OK.

Add Dynamic Behavior to Blocks | 533



10 On the Block Editor toolbar, click Save Block Definition.

11 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

Standard toolbar

To specify a value set for a rotation parameter

1 In the Block Editor, click Tools menu ➤ Properties to display the
Properties palette.

2 In the Block Editor, select a rotation parameter.

3 In the Properties palette, under Value Set, click Ang Type.

4 On the drop-down list, select List.

5 In the Properties palette, under Value Set, click Ang Value List.

6 Click the [...] button.

7 In the Add Angle Value dialog box, under Angle to Add, enter one value
or two or more values separated by commas.

8 Click Add.

9 Click OK.

10 On the Block Editor toolbar, click Save Block Definition.

11 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

Standard toolbar

To delete values from a parameter’s value set

1 In the Block Editor, click Tools menu ➤ Properties to display the
Properties palette.

2 In the Block Editor, select a linear, polar, XY, or rotation parameter.

3 In the Properties palette, under Value Set, click one of the following:

■ Dist Value List
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■ Ang Value List

■ Hor Value List

■ Ver Value List

4 Click the [...] button.

5 In the Add Distance Value or Add Angle Value dialog box, select a value
from the list to delete.

6 Click Delete.

7 Click OK.

8 On the Block Editor toolbar, click Save Block Definition.

9 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

Standard toolbar

To specify an incremental value set for a linear, polar, XY, or rotation
parameter

1 In the Block Editor, click Tools menu ➤ Properties to display the
Properties palette.

2 In the Block Editor, select a linear, polar, XY, or rotation parameter.

3 In the Properties palette, under Value Set, click Dist Type, Ang Type, Hor
Type, or Ver Type.

4 On the drop-down list, select Increment.

5 In the Properties palette, under Value Set, click Dist Increment, Ang
Increment, Hor Increment, or Ver Increment, and then enter an
incremental value for the parameter.

6 Click Dist Minimum, Ang Minimum, Hor Minimum, or Ver Minimum,
and then enter a minimum value for the parameter.

7 Click Dist Maximum, Ang Maximum, Hor Maximum, or Ver Maximum,
and then enter a maximum value for the parameter.

8 On the Block Editor toolbar, click Save Block Definition.

9 (Optional) If you are finished using the Block Editor, click Close Block
Editor.
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Standard toolbar

To specify minimum and maximum values for a linear, polar, XY, or rotation
parameter

1 In the Block Editor, click Tools menu ➤ Properties to display the
Properties palette.

2 In the Block Editor, select a linear, polar, XY, or rotation parameter.

3 In the Properties palette, under Value Set, click Dist Minimum, Ang
Minimum, Hor Minimum, or Ver Minimum, and then enter a minimum
value for the parameter.

4 Click Dist Maximum, Ang Maximum, Hor Maximum, or Ver Maximum,
and then enter a maximum value for the parameter.

5 On the Block Editor toolbar, click Save Block Definition.

6 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

Standard toolbar

Allow Chained Actions for Dynamic Blocks

Point, linear, polar, XY, and rotation parameters have a property called Chain
Actions. This property affects the parameter behavior if the parameter is part
of an action’s selection set.

For example, you might include a point parameter in the selection set of a
stretch action that is associated with a linear parameter. When the linear
parameter is edited in a block reference, its associated stretch action triggers
a change in its selection set. Because the point parameter is included in the
selection set, the point parameter is edited by the change in the linear
parameter.

The following example shows a block definition in the Block Editor. The point
parameter (labeled Position) is included in the stretch action’s selection set.
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If the Chain Actions property for the point parameter is set to Yes, a change
in the linear parameter will trigger the move action associated with the point
parameter, just as if you edited the point parameter in the block reference
through a grip or custom property.

If the Chain Actions property is set to No, the point parameter’s associated
move action is not triggered by the changes to the linear parameter. Thus, the
circle doesn’t move.
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To specify the Chain Actions property for a point, linear, polar, XY, or rotation
parameter

1 In the Block Editor, click Tools menu ➤ Properties to display the
Properties palette.

2 In the Block Editor, select a point, linear, polar, XY, or rotation parameter.

3 In the Properties palette, under Misc, click Chain Actions.

4 On the drop-down list, select Yes or No.

5 On the Block Editor toolbar, click Save Block Definition.

6 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

Standard toolbar

Modify Dynamic Block Definitions

After you’ve defined a dynamic block, you can modify it in the Block Editor.
You can delete, add, and modify the following elements in the Block Editor:

■ Parameters (see “Use Parameters in Dynamic Blocks” on page 476)

■ Actions (see “Use Parameters in Dynamic Blocks” on page 476 “Use Actions
with Dynamic Blocks” on page 488)

■ Geometry

■ Visibility states (see “Create Visibility States” on page 514)

■ Lookup tables (see “Use Lookup Tables to Assign Data to Dynamic Blocks”
on page 521)

■ Grips (see “Specify Grips for Dynamic Blocks” on page 510)

■ Properties (see “Overview of Specifying Custom Properties for Dynamic
Blocks” on page 529)

You can also use the  command to change an action’s selection set. If you
delete a parameter associated with an action and need to reassign that action
to another parameter, use the  command.

After you modify a dynamic block definition in the Block Editor, you must
save your changes (see “Save a Block in the Block Editor” on page 541).
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WARNING If you redefine a dynamic block in AutoCAD 2005 or earlier, the block
will lose its dynamic behavior.

To open an existing dynamic block definition in the Block Editor

1 Open the drawing file that contains the dynamic block definition, or
open the drawing file that has been saved as a block.

2 Follow the steps in “To open an existing block definition in the Block
Editor” on page 464.

Standard toolbar

Right-click a selected block. Click Block Editor.

To delete an element from a dynamic block definition

1 In the Block Editor, select the element you want to delete from the
dynamic block definition.

2 Press the DELETE key.

To modify an action’s selection set in a dynamic block definition

1 In the Block Editor, select an action.

2 On the command line, enter bactionset, and then press ENTER.

3 Follow the prompts on the command line.

4 On the Block Editor toolbar, click Save Block Definition.

5 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

To redefine a stretch or polar stretch action’s stretch frame set in a dynamic
block definition

1 In the Block Editor, double-click a stretch or polar stretch action.

2 Follow the prompts on the command line to define a new stretch frame
and add objects to or remove objects from the action’s selection set.

3 On the Block Editor toolbar, click Save Block Definition.
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4 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

Correct Errors in Dynamic Block Definitions

A yellow alert icon is displayed in the Block Editor if a dynamic block definition
contains errors or is incomplete. You need to correct the errors (or complete
the block) so the block reference will function properly in a drawing.

The yellow alert icon indicates that the block definition is not defined correctly
or is incomplete. For example, a parameter that is not associated with an
action will display an alert icon. An action that is not associated with a
parameter or a selection set, will also display an alert icon.

You can correct these errors by double-clicking the yellow alert icon and
following the prompts on the command line.

After you create a dynamic block definition in the Block Editor, you should
save it and then test the functionality of the block reference in a drawing. If
the block reference isn’t functioning the way you intended, open the definition
in the Block Editor and double-check the types of parameters and actions you
used as well as their dependencies and properties.

To correct an error indicated by a yellow alert icon in a dynamic block
definition

1 In the Block Editor, double-click a yellow alert icon.

2 Follow the prompts on the command line to correct the errors in the
dynamic block definition.

3 On the Block Editor toolbar, click Save Block Definition.

4 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

To view dependencies within a dynamic block definition

1 In the Block Editor, select a parameter or an action.

If you selected a parameter, its associated action is highlighted.

If you selected an action, its associated parameter and selection set of
geometry is highlighted.

2 When you’re finished viewing the dependencies, press ESC.

3 (Optional) If you are finished using the Block Editor, click Close Block
Editor.
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Save a Block in the Block Editor

When you are finished adding elements to your dynamic block definition in
the Block Editor, save the block definition.

In the Block Editor, you can save your block definition by clicking the Save
Block Definition button on the Block Editor toolbar, or by entering bsave on
the command line. You should then save your drawing to make sure that the
block definition is saved in the drawing.

When you save a block definition in the Block Editor, the current values of
the geometry and parameters in the block are set as the default values for the
block reference. When you create a dynamic block that uses visibility states,
the default visibility state for the block reference is the visibility state at the
top of the list in the Manage Visibility States dialog box.

Once you’ve saved the block definition, you can close the Block Editor and
try your block in a drawing.

NOTE If you click File ➤ Save while you are in the Block Editor, you will save the
drawing but not the block definition. You must specifically save the block definition
while you are in the Block Editor.

To save a block definition in the Block Editor

1 On the Block Editor toolbar, click Save Block Definition.

2 Click File ➤ Save to save the block definition in the drawing.

3 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

Standard toolbar

To save a copy of the current block definition in the Block Editor under a new
name

1 On the Block Editor toolbar, click Save Block Definition As.

2 In the Save Block As dialog box, enter a name for the new block
definition.

3 Click OK.

4 Click File ➤ Save to save the block definition in the drawing.
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5 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

Standard toolbar

Control the Color and Linetype Properties in
Blocks

The objects in an inserted block can retain their original properties, can inherit
properties from the layer on which they are inserted, or can inherit the
properties set as current in the drawing.

Generally when you insert a block, the color, linetype, and lineweight of
objects in the block retain their original settings regardless of the current
settings in the drawing. However, you can create blocks with objects that
inherit the current color, linetype, and lineweight settings. These objects have
floating properties.

You have three choices for how the color, linetype, and lineweight properties
of objects are treated when a block reference is inserted.

■ Objects in the block do not inherit color, linetype, and lineweight properties
from the current settings. The properties of objects in the block do not
change regardless of the current settings.

For this choice, it is recommended that you set the color, linetype, and
lineweight properties individually for each object in the block definition:
do not use BYBLOCK or BYLAYER color, linetype, and lineweight settings
when creating these objects.

■ Objects in the block inherit color, linetype, and lineweight properties from
the color, linetype, and lineweight assigned to the current layer only.

For this choice, before you create objects to be included in the block
definition, set the current layer to 0, and set the current color, linetype,
and lineweight to BYLAYER.

■ Objects inherit color, linetype, and lineweight properties from the current
color, linetype, and lineweight that you have set explicitly, that is, that
you have set to override the color, linetype, or lineweight assigned to the
current layer. If you have not explicitly set them, then these properties are
inherited from the color, linetype, and lineweight assigned to the current
layer.
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For this choice, before you create objects to be included in the block
definition, set the current color or linetype to BYBLOCK.

Create objects with
these properties

Create objects on these
layers

If you want objects in a
block to

Any but BYBLOCK or
BYLAYER

Any but 0 (zero)Retain original properties

BYLAYER0 (zero)Inherit properties from the
current layer

BYBLOCKAnyInherit individual properties
first, then layer properties

Floating properties also apply to nested blocks when the nested block references
and the objects they contain use the settings required for floating properties.

To set the color for all new objects

1 On the Properties toolbar, click the Color control.

2 Either click a color to draw all new objects in that color, or click Select
Color to display the Select Color dialog box and do one of the following:

■ On the Index tab, click a color or enter the ACI color number (1-255)
or name in the Color box, and then click OK.

■ On the True Color tab, select the HSL color model in the Color Model
option and specify a color by entering a color value in the Color box
or by specifying values in the Hue, Saturation, and Luminance boxes,
and then click OK.

■ On the Color Books tab, select a color book from the Color Book box,
select a color by navigating the color book (using the up and down
arrows) and clicking on a color chip, and then click OK.

■ Click BYLAYER to draw new objects in the color assigned to the current
layer.

■ Click BYBLOCK to draw new objects in the current color until they
are grouped into a block. When the block is inserted into the drawing,
the objects in the block acquire the current color setting.

3 Click OK.

The Color control displays the current color.
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To set the linetype for all new objects

1 On the Format menu, click Linetype.

2 If you need to load additional linetypes, click Load, select one or more
linetypes, and click OK.

You can hold down  CTRL  to select several linetypes or  SHIFT  to select
a range of linetypes.

3 In the Linetype Manager, do one of the following:

■ Select a linetype and select Current to draw all new objects with that
linetype.

■ Select BYLAYER to draw new objects in the linetype assigned to the
current layer.

■ Select BYBLOCK to draw new objects in the current linetype until
they are grouped into a block. When the block is inserted in a drawing,
the objects in the block acquire the current linetype setting.

4 Click OK.

The Linetype control displays the current linetype. If the linetype you
want to use is already loaded, you can click the Linetype control and
click the linetype to make it current.

Nest Blocks
Block references that contain other blocks are known as nested blocks. Using
blocks within blocks can simplify the organization of a complex block
definition.

With nested blocks, you can build a single block out of several components.
For example, you can insert as a block a drawing of a mechanical assembly
that contains a housing, a bracket, and fasteners in which each fastener is a
block composed of a bolt, washer, and nut. The only restriction on nested
blocks is that you cannot insert blocks that reference themselves.
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assembly block blocks that are components of the assembly
block

blocks that are components of the fastener
block

fastener block

Procedures to come.

Insert Blocks
When you insert a block, you create a block reference and specify its location,
scale, and rotation.

When you insert a block, you create a block reference. You determine its
location, scale factor, and rotation angle. You can specify the scale of a block
reference using different X, Y, and Z values. Inserting a block creates an object
called a block reference because it references a block definition stored in your
current drawing. An orange lightning bolt icon displayed in the bottom-right
corner of the block preview indicates that the block is dynamic.

default values rotation angle
= 45

X scale = .5
Y scale = 1

X scale = 1
Y scale = .5

If you insert a block that uses different drawing units than the units specified
for the drawing, the block is automatically scaled by a factor equivalent to
the ratio between the two units.
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Insert a Drawing File as a Block

When you insert an entire drawing file into another drawing, the drawing
information is copied into the block table of the current drawing as a block
definition. Subsequent insertions reference the block definition with different
position, scale, and rotation settings, as shown in the following illustration.

fastener block instances of fastener

Xrefs contained in a drawing you insert may not be displayed properly unless
the xref was previously inserted or attached to the destination drawing.

Insert Blocks from Block Libraries

You can insert one or more block definitions from an existing drawing file
into your current drawing file. Choose this method when retrieving blocks
from block library drawings. A block library drawing contains block definitions
of symbols with similar functions. These block definitions are stored together
in a single drawing file for easy accessibility and management.

block definition inserted from block
library drawing

Insert Blocks at Intervals

You can insert blocks at intervals along a selected geometric object.

■ Use  to insert a block at measured intervals.
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■ Use  to insert a block at proportional (evenly spaced) intervals.

Insert Blocks with DesignCenter

Use DesignCenter to insert blocks from the current drawing or from another
drawing. Drag and drop the block names for quick placement. Double-click
the block names to specify the precise location, rotation, and scale of the
blocks.

You cannot add blocks to a drawing while another command is active, and
you can only insert or attach one block at a time.

See also:

“Create Drawing Files for Use as Blocks” on page 456
“Overview of Blocks” on page 452
“Create Block Libraries” on page 455
“Work with Dynamic Blocks in Drawings” on page 548
“Add Content with DesignCenter” on page 67
“Create and Use Tools from Objects and Images” on page 22

To insert a block defined in the current drawing

1 On the Insert menu, click Block.

2 In the Insert dialog box, in the Name box, select a name from a list of
block definitions.

3 If you want to use the pointing device to specify the insertion point,
scale, and rotation, select Specify On-Screen. Otherwise, enter values in
the Insertion Point, Scale, and Rotation boxes.

4 If you want the objects in the block to be inserted as individual objects
instead of as a single block, select Explode.

5 Click OK.

Insert toolbar

To insert a drawing file as a block by dragging

1 From Windows Explorer or any folder, drag the drawing file icon into
the drawing area.

When you release the button, you are prompted for an insertion point.

2 Specify the insertion point and scale and rotation values.
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To insert a block using DesignCenter

1 On the Tools menu, click DesignCenter.

The DesignCenter window is displayed.

2 Do one of the following to list the content you want to insert:

■ On the DesignCenter toolbar, click Tree View Toggle. Click the folder
that contains the drawing you want to insert.

■ Click the icon of a drawing file displayed in the tree view.

3 Do one of the following to insert the content:

■ Drag the drawing file or block into your current drawing. Use this
option when you want to insert blocks quickly and move or rotate
the blocks to their precise locations later.

■ Double-click the drawing file or block that you want to insert into
your current drawing. Use this option when you want to specify the
exact placement, rotation, and scale of the block as you insert it. Use
this option also when you want to update a block reference in your
drawing from the original source drawing file.

Standard toolbar

Work with Dynamic Blocks in Drawings
A dynamic block has flexibility and intelligence. A dynamic block reference
can easily be changed in a drawing while you work. You can manipulate the
geometry through custom grips or custom properties. This allows you to adjust
the block reference in-place as necessary rather than searching for another
block to insert or redefining the existing one.

For example, if you insert a door block reference in a drawing, you might need
to change the size of the door while you’re editing the drawing. If the block
is dynamic and defined to have an adjustable size, you can change the size of
the door simply by dragging the custom grip or by specifying a different size
in Properties palette. You might also need to change the open angle of the
door. The door block might also contain an alignment grip, which allows you
to align the door block reference easily to other geometry in the drawing.
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A dynamic block can have custom grips and custom properties. Depending
on how the block was defined, you may be able to manipulate the block
through these custom grips and custom properties. By default, custom grips
for a dynamic block are a different color than standard grips. You can change
the display color for custom grips with the  system variable. The following
table shows the different types of custom grips that can be included in a
dynamic block.

How the Grip Can Be Manipulated in a DrawingGrip Type

Within a plane in any directionStandard

Back and forth in a defined direction or along an axisLinear

Around an axisRotation

Clicked to flip the dynamic block referenceFlip

Within a plane in any direction; when moved over an
object, triggers the block reference to align with the object

Alignment
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How the Grip Can Be Manipulated in a DrawingGrip Type

Clicked to display a list of itemsLookup

After you’ve manipulated a dynamic block in a drawing, you can reset it.
When you reset a block reference, the block changes back to the default
specified in the block definition. If you non-uniformly scale or explode a
dynamic block reference, it loses its dynamic properties. You can reset the
block to its default values, which will make it dynamic again.

Some dynamic blocks are defined so that geometry within the block can only
be edited to certain sizes specified in the block definition. When you use a
grip to edit the block reference, tick marks are displayed at the locations of
valid values for the block reference. If you change a block property value to
a value other than one specified in the definition, the parameter will adjust
to the closest valid value. For example, a block is defined to have a length of
2, 4, and 6. When you try to change that distance value to 10, the resulting
value is 6 because it is the closest valid value.

To manipulate a dynamic block using custom grips

1 In a drawing, select a dynamic block reference.

2 Use the grips to stretch or change the block.

To manipulate a dynamic block using custom properties

1 In a drawing, select a dynamic block reference.

2 In the Properties palette, under Custom, change the required values.

To reset block references in a drawing

1 In a drawing, select a dynamic block reference.

2 Right-click in the drawing area. Click Reset Block.

NOTE To reset more than one block reference at a time, use the  command.

To change the display color for custom grips

1 On the command line, enter gripdyncolor.

2 Enter an integer from 1 to 255 (ACI color).

3 Press ENTER.
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Attach Data to Blocks (Block Attributes)
You can attach information to blocks and later extract the information to
create a bill of materials or other report.

Overview of Block Attributes

An attribute is a label or tag that attaches data to a block. Examples of data
that might be contained in an attribute are part numbers, prices, comments,
and owners' names. The tag is equivalent to a column name in a database
table. The following illustration shows tags for type, manufacturer, model,
and cost.

CHAIR
CHAIR2000
310C-9000
76.00

CH-0014-633-02
CHAIR2000
CHAIR

129.99COST

TYPE
MANUFACTURER
MODEL

Attribute information extracted from a drawing can be used in a spreadsheet
or database to produce a parts list or a bill of materials. You can associate more
than one attribute with a block, provided that each attribute has a different
tag.

Whenever you insert a block that has a variable attribute, you are prompted
to enter data to be stored with the block. Blocks may also use constant
attributes, attributes whose values do not change. Constant attributes do not
prompt you for a value when you insert the block.

Attributes also can be "invisible." An invisible attribute is not displayed or
plotted; however, the attribute information is stored in the drawing file and
can be written to an extraction file for use in a database program.

See also:

“Modify Block Attributes”
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Define Block Attributes

To create an attribute, you first create an attribute definition, which describes
the characteristics of the attribute. The characteristics include the tag (which
is a name that identifies the attribute), the prompt displayed when you insert
the block, value information, text formatting, location, and any optional
modes (Invisible, Constant, Verify, and Preset).

After creating the attribute definition, you select it as one of the objects when
you define the block. Then, whenever you insert the block, you are prompted
with the text you specified for the attribute. For each new block insertion,
you can specify a different value for the attribute.

To use several attributes together, define them and then include them in the
same block. For example, you can define attributes tagged "Type,"
"Manufacturer," “Model,” and "Cost," and then include them in a block called
CHAIR.

TYPE
MANUFACTURER
MODEL
COST

If you plan to extract the attribute information for use in a parts list, you may
want to keep a list of the attribute tags you have created. You will need this
tag information later when you create the attribute template file.

Correct Mistakes in Block Attribute Definitions

If you make a mistake, you can use the Properties palette or  to edit an attribute
definition before it is associated with a block. You can change the tag, prompt,
and default value.

Attach Attributes to Blocks

You can attach attributes to a block when you define or redefine that block.
When you are prompted to select the objects to include in the block definition,
include in the selection set any attributes you want to attach to the block.

To attach several attributes to the same block, first define the attributes and
then include them in the block definition. The order in which you select the
attributes determines the order in which you are prompted for attribute
information when you insert the block.
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Usually, the order of the attribute prompts is the same as the order in which
you selected the attributes when you created the block. However, if you used
crossing or window selection to select the attributes, the order of the prompts
is the reverse of the order in which you created attributes. You can use the
Block Attribute Manager to change the order in which you are prompted for
attribute information when you insert the block reference.

When you’re working in the Block Editor, you can also use the Attribute Order
dialog box to change the order in which you are prompted for attribute
information when you insert the block reference. You can only do this when
you have a block definition open in the Block Editor.

Use Attributes Without Attaching Them to Blocks

Stand-alone attributes can also be created. Once attributes have been defined,
and the drawing is saved, this drawing file can be inserted into another
drawing. When the drawing is inserted, you are prompted for the attribute
values.

To create an attribute definition

1 On the Draw menu, click Block ➤ Define Attributes.

2 In the Attribute Definition dialog box, set the attribute modes and enter
tag information, location, and text options.

3 Click OK.

After creating the attribute definition, you can select it as an object while
creating a block definition. If the attribute definition is incorporated
into a block, whenever you insert the block, you are prompted with the
text string you specified for the attribute. Each subsequent instance of
the block can have a different value specified for the attribute.

To edit an attribute definition before it is associated with a block

1 On the Modify menu, click Object ➤ Text.

2 Select the attribute to edit.

3 In the Edit Attribute Definition dialog box, specify the attribute tag,
prompt, and default value. Then click OK.

To change the order of attribute definitions

1 In the Block Editor, select a block attribute.

2 Right-click in the Block Editor drawing area.
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3 Click Attribute Order.

4 In the Attribute Order dialog box, select an attribute definition.

5 Click Move Up or Move Down to change the order of the attribute
definitions.

6 Repeat steps 2 and 3 until the attribute definition list is in the desired
order.

7 Click OK.

➤

Extract Data from Block Attributes

If you have attached attributes to blocks, you can then query one or more
drawings for this block attribute information and save it to a table or to an
external file.

Extracting attribute information is an easy way to produce a schedule or bill
of materials directly from your drawing data. For example, a facilities drawing
might contain blocks representing office equipment. If each block has attributes
identifying the model and manufacturer of the equipment, you can generate
a report that estimates the cost of the equipment.

The Attribute Extraction wizard guides you through selecting drawings, block
instances, and attributes. The wizard can also create a file with a .blk file
extension that contains all the settings for later reuse.

Output to a Table

If you extract attribute data to a table, the table is inserted in the current
drawing and current space (model space or paper space) and on the current
layer.

When you update the table, the attribute information is extracted again and
the data rows in the table are replaced. If you have included a title row, one
or more header rows, or a summary row in the table, they are not replaced
during update. You can insert mathematical expressions in the cells of the
summary row that do calculations using values in the table cells.

NOTE For access to shortcut menus in the drawing area that are needed for editing
and updating tables, the Shortcut Menus in Drawing Area must be checked in the
Options dialog box, User Preferences tab.
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Output to a File

If you save the data to an external file, the comma-separated (CSV),
tab-separated (TXT), Microsoft Excel (XLS), and Microsoft Access (MDB) file
formats are available.

When the characters period (.), comma (,), or pound sign (#) are written to
an Excel or Access file, they are replaced with their Unicode representation.

To extract block attributes to a table or a file

■ Click Tools menu ➤ Attribute Extraction.

The Attribute Extraction Wizard is displayed. The wizard provides
step-by-step instructions for extracting information from block attributes
in the current drawing or other drawings. The information is used to create
a table in the current drawing or is saved to an external file.

The “Attribute Extraction Wizard” topic describes the options in the wizard.

Modify II toolbar

To update an attribute extraction table

■ When the “Attribute Extraction Table Needs Updating” notification is
displayed in the status tray, click Refresh Table Data.

To turn off update notification for attribute extraction tables

1 To turn off notification for all notification-enabled tables in the drawing,
right-click the notification icon in the status tray. Clear the Enable
Notifications for Out-of-Synch Table Data option.

2 To turn off notification for a selected table, right-click. Click the Suppress
Notifications for This Table option.

The notification option is on by default on the Table Style page when you use
the Attribute Extraction wizard.

Extract Block Attribute Data (Advanced)

You can extract attribute information from a drawing and create a separate
text file for use with database software. This feature is useful for creating parts
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lists with information already entered in the drawing database. Extracting
attribute information does not affect the drawing.

To create a parts list

■ Create and edit an attribute definition

■ Enter values for the attributes as you insert the blocks

■ Create a template file and then extract attribute information to a text file

To extract attribute information, you first create an attribute template file
using any text processor, then generate the attribute extraction file using
AutoCAD, and, finally, open the attribute extraction file in a database
application. If you plan to extract the attribute information to a DXF (drawing
interchange format) file, it is not necessary to first create an attribute template
file.

NOTE Make sure that the attribute extraction file does not have the same name
as the attribute template file.

Create an Attribute Extraction Template File

Before you extract attribute information, you must create an ASCII template
file to define the structure of the file that will contain the extracted attribute
information. The template file contains information about the tag name, data
type, field length, and number of decimal places associated with the
information you want to extract.

Each field in the template file extracts information from the block references
in the drawing. Each line in the template file specifies one field to be written
to the attribute extraction file, including the name of the field, its character
width, and its numerical precision. Each record in the attribute extraction file
includes all the specified fields in the order given by the template file.

The following template file includes the 15 possible fields. N means numeric,
C means character, www means a 3 digit number for the total width of the
field, and ddd means a 3 digit number representing how many numeric decimal
places are to be displayed to the right of the decimal point.

BL:NAME Cwww000 (Block name)
BL:LEVEL Nwww000 (Block nesting level)
BL:X Nwwwddd (X coordinate of block insertion point)
BL:Y Nwwwddd (Y coordinate of block insertion point)
BL:Z Nwwwddd (Z coordinate of block insertion point)
BL:NUMBER Nwww000 (Block counter; the same for MINSERT)
BL:HANDLE Cwww000 (Block handle; the same for MINSERT)
BL:LAYER Cwww000 (Block insertion layer name)
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BL:ORIENT Nwwwddd (Block rotation angle)
BL:XSCALE Nwwwddd (X scale factor)
BL:YSCALE Nwwwddd (Y scale factor)
BL:ZSCALE Nwwwddd (Z scale factor)
BL:XEXTRUDE Nwwwddd (X component of block extrusion direction)
BL:YEXTRUDE Nwwwddd (Y component of block extrusion direction)
BL:ZEXTRUDE Nwwwddd (Z component of block extrusion direction)
numeric Nwwwddd (Numeric attribute tag)
character Cwww000 (Character attribute tag)
The template file can include any or all of the BL:xxxxxxx field names listed,
but must include at least one attribute tag field. The attribute tag fields
determine which attributes, hence which blocks, are included in the attribute
extraction file. If a block contains some, but not all, of the specified attributes,
the values for the absent ones are filled with blanks or zeros, depending on
whether the field is a character field or a numeric field.

Comments should not be included in an attribute template file.

The illustration and table show an example of the type of information you're
likely to extract, including block name, manufacturer, model number, and
cost.

TYPE
MANUFACTURER
MODEL
COST

Decimal placesMaximum field
length

(C)haracter or
(N)umeric data

Field

000040CBlock name

000006CManufacturer

000015CModel

002006NCost

You can create any number of template files, depending on how you'll use
the data. Each line of a template file specifies one field to be written in the
attribute extraction file.
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Follow these additional guidelines:

■ Be sure to place a space between the attribute tag and the character or
numeric data. Use  SPACEBAR , not  TAB , to enter the space.

■ Press  ENTER  at the end of each line, including the last line.

■ Each attribute extraction template file must include at least one attribute
tag field, but the same field can appear only once in the file.

The following is a sample template file.

BL:NAME C008000 (Block name, 8 characters)

BL:X N007001 (X coordinate, format nnnnnn.d)

BL:Y N007001  (Y coordinate, format nnnnnn.d)

SUPPLIER C016000 (Manufacturer's name, 16 characters)

MODEL C009000 (Model number, 9 characters)

PRICE N009002 (Unit price, format nnnnnnnn.dd)

NOTE The format code for a numeric field includes the decimal point in the total
field width. For example, the minimum field width to accommodate the number
249.95 would be 6 and would be represented as N006002. Character fields do
not use the last three digits of the format code.

Create an Attribute Extraction File

After creating a template file, you can extract the attribute information using
one of the following formats:

■ Comma-delimited format (CDF)

■ Space-delimited format (SDF)

■ Drawing interchange format (DXF)

The CDF format produces a file containing one record for each block reference
in a drawing. A comma separates the fields of each record, and single quotation
marks enclose the character fields. Some database applications can read this
format directly.

The SDF format also produces a file containing one record for each block
reference in a drawing. The fields of each record have a fixed width and employ
neither field separators nor character-string delimiters. The dBASE III Copy .
. . SDF operation also produces SDI-format files. The Append From... SDF
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operation can read a file in dBASE IV format, which user programs written in
FORTRAN can easily process.

DXF produces a subset of the drawing interchange format containing only
block reference, attribute, and end-of-sequence objects. This option requires
no attribute extraction template. The file extension .dxx distinguishes an
extraction file in DXF format from normal DXF files.

Use the Attribute Extraction File

The attribute extraction file lists values and other information for the attribute
tags you specified in the template file.

If you specified a CDF format using the sample template, the output might
appear as follows:

'DESK', 120.0, 49.5, 'ACME INDUST.', '51-793W', 379.95
'CHAIR', 122.0, 47.0, 'ACME INDUST.', '34-902A', 199.95
'DESK', -77.2, 40.0, 'TOP DRAWER INC.', 'X-52-44',249.95
By default, character fields are enclosed with single quotes (apostrophes). The
default field delimeter is a comma. The following two template records can
be used to override these defaults:

C:QUOTE c (Character string delimeter)
C:DELIM c (Field delimeter)
The first nonblank character following the C:QUOTE or C:DELIM field name
becomes the respective delimiter character. For example, if you want to enclose
character strings with double quotes, include the following line in your
attribute extraction template file:

C:QUOTE “
The quote delimiter must not be set to a character that can appear in a
character field. Similarly, the field delimiter must not be set to a character
that can appear in a numeric field.

If you specified an SDF format using the sample template, the file might be
similar to the following example.

(PRICE)(MODEL)(SUPPLIER)(Y)(X)(NAME)

379.9551-793WACME INDUST.49.5120.0DESK

199.9534-902AACME INDUST.47.0122.0CHAIR

249.95X-52-44TOP DRAWER
INC.

40.0-77.2DESK

The order of the fields corresponds to the order of the fields in the template
files. You can use these files in other applications, such as spreadsheets, and
you can sort and manipulate the data as needed. For example, you can open

Attach Data to Blocks (Block Attributes) | 559



an attribute extraction file in Microsoft Excel in which you can specify a
separate column for each field. See the documentation for your spreadsheet
program for information about how to use data from other applications. If
you open the file in Notepad or another Windows text processor, you can
paste the information back into the drawing as text.

Nested Blocks

The line BL:LEVEL in a template file reports the nesting level of a block
reference. A block that is inserted in a drawing has a nesting level of 1. A block
reference that is part of (nested within) another block has a nesting level of
2, and so on.

For a nested block reference, the X,Y, Z coordinate values, scale factors,
extrusion direction, and rotation angle reflect the actual location, size,
orientation, and rotation of the nested block in the world coordinate system.

In some complex cases, nested block references cannot be correctly represented
with only two scale factors and a rotation angle, for example, if a nested block
reference is rotated in 3D. When this happens, the scale factors and rotation
angle in the extracted file record are set to zero.

Error Handling

If a field is not wide enough for the data that is to be placed in it, the data is
truncated and the following message is displayed:

** Field overflow in record <record number>

This could happen, for example, if you have a BL:NAME field with a width of
8 characters and a block in your drawing has a name 10 characters long.

To create an attribute extraction template file

1 Start Notepad.

You can use any text editor or word processor that can save a text file
in ASCII format.

2 Enter template information in Notepad. See “Extract Block Attribute
Data (Advanced)” on page 555 for format information.

3 Save the file with a .txt file extension.

To extract data about a specific tag, insert the tag name in place of the
"numeric" or "character" fields.

WARNING Do not use tab characters when constructing the template file with
a word processor. If you use tab character alignment, the attribute information
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file is not created. To align the columns, insert ordinary spaces by pressing
SPACEBAR . The use of tab characters may cause inconsistent alignment.

To extract attribute information

1 At the Command prompt, enter attext.

2 In the Attribute Extraction dialog box, specify the appropriate file format:
CDF, SDF, or DXF.

3 Specify the objects to extract attributes from by choosing Select Objects.

You can select a single block or multiple blocks in the drawing.

4 Specify the attribute template file to use by entering the file name or by
choosing Template File and browsing.

5 Specify the output attribute information file by entering the file name
or by choosing Output File and browsing.

6 Click OK.

Modify Blocks
You can modify a block definition or a block reference already inserted in the
drawing.

Modify a Block Definition

You can redefine block definitions in your current drawing. Redefining a block
definition affects both previous and future insertions of the block in the current
drawing and any associated attributes.

There are two methods for redefining a block definition:

■ Modify the block definition in the current drawing.

■ Modify the block definition in the source drawing and reinsert it into the
current drawing.

The method you choose depends on whether you want to make changes in
the current drawing only or in a source drawing also.

Modify a Block Definition in the Current Drawing

To modify a block definition, follow the procedure to create a new block
definition, but enter the name of the existing block definition. This replaces
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the existing block definition, and all the references to that block in the drawing
are immediately updated to reflect the new definition.

To save time, you can insert and explode an instance of the original block
and then use the resulting objects in creating the new block definition.

Update a Block Definition That Originated from a Drawing File

Block definitions created in your current drawing by inserting a drawing file
are not updated automatically when the original drawing is modified. You
can use  to update a block definition from the drawing file.

Update a Block Definition That Originated from a Library Drawing (Advanced)

DesignCenter™ does not overwrite an existing block definition in a drawing
with one that comes from another drawing. To update a block definition that
came from a library drawing, use  to create a separate drawing file from the
library drawing block. Then, use INSERT to overwrite the block definition in
the drawing that uses the block.

NOTE Block descriptions are stripped off when using INSERT. Use the Clipboard
to copy and paste a block description displayed in the Block Definition dialog box
from one block definition to another.

Modify the Description of a Block

To modify the DesignCenter description of a block definition, use . You can
also add descriptions to any number of existing blocks in the Block Definition
dialog box.

Redefine Block Attributes

You can attach attributes to a block when you define or redefine that block.
When you are prompted to select the objects to include in the block definition,
include the desired attributes in the selection set. Redefining the attributes in
the block definition has the following effects on block references that were
previously inserted:

■ Constant attributes, which have a fixed value, are lost and replaced by any
new constant attributes.

■ Variable attributes remain unchanged, even if the new block definition has
no attributes.

■ New attributes do not appear in the existing block references.

See also:

“Attach Data to Blocks (Block Attributes)” on page 551
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“Modify Dynamic Block Definitions” on page 538

To update a block definition that originated from a drawing file

1 On the Tools menu, click DesignCenter.

2 In the tree view, click the folder that contains the drawing file from
which the block originated.

3 In the content area (on the right side), right-click the drawing file.

4 On the shortcut menu, click Insert as Block.

5 In the Insert dialog box, click OK.

6 In the alert box, click Yes to overwrite the existing block definition.

7 Press ESC to exit the command.

To modify a block description

1 On the Modify menu, click Object ➤ Block Description.

2 In the Block Definition dialog box, in the Name list, select the block for
which you want to modify the block description.

3 In the Description box, enter or modify the description of the block.

4 Click OK.

5 A message box displays the warning "Block name is already defined. Do
you want to re-define it?" Click Yes to redefine the block.

Modify Block Attributes

You can modify attributes in block definitions with the Block Attribute
Manager. For example, you can modify the following:

■ Properties that define how values are assigned to an attribute and whether
or not the assigned value is visible in the drawing area

■ Properties that define how attribute text is displayed in the drawing

■ Properties that define the layer that the attribute is on and the attribute
line’s color, weight, and type

By default, attribute changes you make are applied to all existing block
references in the current drawing.
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Changing the attribute properties of existing block references does not affect
the values assigned to those blocks. For example, in a block containing an
attribute whose tag is Cost and value is 19.99, the 19.99 value is unaffected
if you change the tag from Cost to Unit Cost.

Updating attributes with duplicate tag names can lead to unpredictable results.
Use the Block Attribute Manager to find duplicate tags and change tag names.

If constant attributes or nested attributed blocks are affected by your changes,
use  to update the display of those blocks in the drawing area.

Change the Prompt Order for Attribute Values

When you define a block, the order in which you select the attributes
determines the order in which you are prompted for attribute information
when you insert the block. You can use the Block Attribute Manager to change
the order of prompts that request attribute values.

Remove Block Attributes

You can remove attributes from block definitions and from all existing block
references in the current drawing. Attributes removed from existing block
references do not disappear in the drawing area until you regenerate the
drawing using REGEN.

You cannot remove all attributes from a block; at least one attribute must
remain. If you need to remove all attributes, redefine the block.

Update Block References

You can update attributes in all block references in the current drawing with
changes you made to the block definition. For example, you may have used
the Block Attribute Manager to modify attribute properties in several block
definitions in your drawing but elected not to automatically update existing
block references when you made the changes. Now that you are satisfied with
the attribute changes you made, you can apply those changes to all blocks in
the current drawing.

You can also use  to update attribute properties in block references to match
their block definition.

Updating attribute properties in block references does not affect any values
that have been assigned to those attributes.

Edit Attributes in a Block Reference

You can modify attribute properties and values in a block reference using the
Enhanced Attribute Editor. For example, you can change options that
determine how attribute text appears in the block, and you can modify
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properties that set the layer, linetype, color, lineweight, or plot style of the
attribute.

See also:

“Define Block Attributes” on page 552
“Modify a Block Definition” on page 561

To edit attributes assigned to a block definition

1 On the Modify menu, click Object ➤ Attribute ➤ Block Attribute
Manager.

2 In the Block Attribute Manager, select a block from the Block list, or click
Select Block and select a block in the drawing area.

3 In the list of attributes, double-click the attribute you want to edit, or
select the attribute and click Edit.

4 In the Edit Attribute dialog box, make the attribute changes you want,
and then click OK.

Modify II toolbar

To specify whether changes are applied to existing block references

1 On the Modify menu, click Object ➤ Attribute ➤ Block Attribute
Manager.

2 In the Block Attribute Manager, click Settings.

3 In the Settings dialog box, do one of the following:

■ To apply changes to existing block references, select the Apply Changes
to Existing References option.

■ To apply changes only to new block insertions, clear the Apply
Changes to Existing References option.

4 Click OK.

Modify II toolbar
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To highlight duplicate attribute tags in a block

1 On the Modify menu, click Object ➤ Attribute ➤ Block Attribute
Manager.

2 In the Block Attribute Manager, click Settings.

3 In the Settings dialog box, select Emphasize Duplicate Tags.

4 Click OK.

Modify II toolbar

To change the prompt order for attribute values

1 On the Modify menu, click Object ➤ Attribute ➤ Block Attribute
Manager.

2 In the Block Attribute Manager, select a block from the Block list, or click
Select Block and select a block in the drawing area.

For the selected block, attributes are listed in their prompt order.

3 To move an attribute up in the prompt order, select the attribute, and
then click Move Up; to move an attribute down in the prompt order,
select the attribute, and then click Move Down.

NOTE The Move Up and Move Down buttons are unavailable for attributes
with constant values (Mode=C).

Modify II toolbar

To remove an attribute from a block definition and all block references

1 On the Modify menu, click Object ➤ Attribute ➤ Block Attribute
Manager.

2 In the Block Attribute Manager, select a block from the Block list, or click
Select Block and select a block in the drawing area.

3 (Optional) If you do not want attributes removed from existing instances
of the block, click Settings, and, in the Settings dialog box, clear Apply
Changes to Existing References.
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4 In the Block Attribute Manager, select an attribute from the attribute
list, and then click Remove.

Attributes removed from existing block instances do not disappear until
you regenerate the drawing using REGEN.

Modify II toolbar

To update existing block references with attributes you have modified

1 On the Modify menu, click Object ➤ Attribute ➤ Block Attribute
Manager.

2 In the Block Attribute Manager, select a block from the Block list, or click
Select Block and select a block in the drawing area.

3 Click Sync to update attributes you have changed in all block references
for the selected block.

Modify II toolbar

To update the attributes in block references for a selected block definition

1 On the Modify II toolbar, click Synchronize Attributes.

2 At the prompt, do one of the following:

■ Enter name, and then enter the name of the block whose block
references you want to update.

■ Enter ? to view a list of blocks, and then enter name, followed by the
name of the block.

■ Press  ENTER , and then use your pointing device to select a block in
the drawing area.

If you specify a block that does not exist, or if the block exists but does
not contain attributes, an error message is displayed.

Modify II toolbar
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Alternate

1 On the Modify menu, click Object ➤ Attribute ➤ Single.

2 In the drawing area, select the block you want to edit.

3 In the Enhanced Attribute Editor, select the attribute you want to edit.
You can change the attribute value or choose another tab and edit other
attribute properties.

4 Make the attribute changes you want, and then do one of the following:

■ Click Apply to save your changes. The Enhanced Attribute Editor
remains open.

If you click Cancel later to exit the Enhanced Attribute Editor, attribute
changes you made prior to choosing Apply are not reversed.

■ Click OK to save your changes and close the Enhanced Attribute
Editor.

■ Click Select Block to edit the attributes of a different block. If you
made changes to the current block, but have not saved them, you are
prompted to do so before selecting a new block.

Modify II toolbar

Change the Color and Linetype in a Block
Blocks containing objects with floating properties inherit their color and
linetype from the layer on which they are inserted. Depending on how the
objects in the block were created, blocks can also inherit floating color and
linetype properties from the current explicit color and linetype that you set
to override the layer settings.

If a block was not created using objects with floating color and linetype
properties, the only way to change these properties is to redefine the block.

See also:

“Control the Color and Linetype Properties in Blocks” on page 542

To change the layer of an object

1 Select the objects whose layer you want to change.

2 On the Layers toolbar, click the Layer control.
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3 Select the layer that you want to assign to the objects.

To change the color assigned to a layer

1 On the Layers toolbar, click the Layer Properties Manager button.

2 In the Layer Properties Manager, click the color you want to change.

3 In the Select Color dialog box, use one of the following methods:

■ On the Index tab, click a color and then click OK.

■ On the Index tab, enter the ACI color number (1-255) or name in the
Color box, and then click OK.

■ On the True Color tab, select the HSL color model in the Color Model
option and specify a color by entering a color value in the Color box
or by specifying values in the Hue, Saturation, and Luminance boxes,
and then click OK.

■ On the Color Books tab, select a color book from the Color Book box,
select a color by navigating the color book (using the up and down
arrows) and clicking on a color chip, and then click OK.

4 Click OK.

Layers toolbar

To change the color of an object, overriding the layer's color

1 On the Standard toolbar, click Properties.

2 Select the objects whose color you want to change.

3 In the Properties palette, select Color.

An arrow is displayed in the right column.

4 Click the arrow and select a color from the list.

Standard toolbar
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To change the linetype assigned to a layer

1 On the Layers toolbar, click the Layer Properties Manager button.

2 In the Layer Properties Manager, click Load and click one or more
linetypes to load, and then click OK.

You can hold down  CTRL  to select several linetypes or  SHIFT  to select
a range of linetypes.

3 Select a layer from the list and then click Details to expand the dialog
box.

4 Select a linetype from the Linetype list.

5 Click OK to close the dialog box.

You can click Layer on the Format menu to open the Layer Properties
Manager.

Layers toolbar

To change the linetype of an object, overriding the layer's linetype

1 Select the objects whose linetype you want to change.

2 On the Properties toolbar, click the Linetype control.

3 Click the linetype that you want to assign to the objects.

To modify an existing block definition

1 Select the block to modify.

2 Right-click the block and click Properties on the shortcut menu.

3 In the Properties palette, select and modify X and Y position, scale,
rotation values, or other properties.

Disassemble a Block Reference (Explode)
If you need to modify one or more objects within a block separately, you can
disassemble, or explode, the block reference into its component objects. After
making the changes, you can

■ Create a new block definition
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■ Redefine the existing block definition

■ Leave the component objects uncombined for other uses

You can automatically explode block references as you insert them by selecting
the Explode option in the Insert dialog box.

To explode a block reference

1 On the Modify menu, click Explode.

2 Select the block to explode and press  ENTER.

The block reference is disassembled into its component objects; however,
the block definition still exists in the drawing for insertion later.

Modify toolbar

Remove Block Definitions
To reduce the size of a drawing, you can remove unused block definitions.
You can remove a block reference from your drawing by erasing it; however,
the block definition remains in the drawing's block definition table. To remove
unused block definitions and decrease the drawing size, use  at any time in
your drawing session.

All references to a block must be erased before you can purge the block
definition.

See also:

“Overview of Blocks” on page 452

To remove a block definition

1 On the File menu, click Drawing Utilities ➤ Purge.

The Purge dialog box displays a tree view of named objects that can be
purged.

2 To purge blocks, use one of the following methods:

■ To purge all unreferenced blocks, select Blocks. To include nested
blocks, select Purge Nested Items.
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■ To purge specific blocks, double-click Blocks to expand the Block tree
view. Select the blocks to be purged.

If the item you want to purge is not listed, select View Items You Cannot
Purge.

3 You are prompted to confirm each item in the list. If you do not want
to confirm each purge, clear the Confirm Each Item to Be Purged option.

4 Click Purge.

To confirm the purging of each item, respond to the prompt by choosing
Yes or No, or Yes to All if more than one item is selected.

5 Select more items to purge, or click Close.
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Change Existing Objects

 
You can select objects, view and edit object properties, and

perform general and object-specific editing operations.

21
In this chapter

■ Select Objects

■ Correct Mistakes

■ Erase Objects

■ Use Windows Cut, Copy, and
Paste

■ Modify Objects

■ Modify Complex Objects

■ Modify 3D Solids



Select Objects
You have a wide range of options when you need to select objects for editing
operations.

Select Objects Individually

At the Select Objects prompt, you can select one or more objects individually.

Use the Pickbox Cursor

When the square pickbox cursor is in position to select an object, the object
is highlighted. Click to select the object.

You can control the size of the pickbox in the Options dialog box, Selection
tab.

Select Objects Close Together

It is difficult to select objects that are close together or lie directly on top of
one another. The example shows two lines and a circle that lie within the
pickbox.

first selected object second selected object third selected object

Hold down CTRL and click to cycle through these objects, one after the other,
until the one you want is highlighted. Press ESC to turn off cycling. (Selection
previewing is not available when you press CTRL.)

Remove Selection from Objects

Remove objects from the current selection set by holding down SHIFT and
selecting them again.

To select a single object

1 At the Select Objects prompt of any command, move the rectangular
pickbox cursor so that the object that you want to select is highlighted.
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2 Click the object.

The object you selected is highlighted.

3 Press ENTER to end object selection.

NOTE If the PICKFIRST system variable is set to 1 (noun-verb selection),
you can select objects before entering a command.

To change the size of the pickbox cursor

1 Click Tools menu ➤ Options.

2 On the Selection tab, under Pickbox Size, move the pickbox size slider
until the pickbox is the size you want to use.

3 Click OK.

To cycle through objects for selection

1 At the Select Objects prompt, hold down CTRL. Click as near as possible
to the object you want.

Selection previewing is not available when you press CTRL.

2 Keep clicking until the object you want is highlighted.

3 Press ENTER to select the object.

To remove selection from objects

■ Hold down SHIFT. Click the objects that you want removed from the
selection set.

Select Multiple Objects

At the Select Objects prompt, you can select many objects at the same time.

Specify a Rectangular Selection Area

Specify opposite corners to define a rectangular area. The background inside
the area changes color and becomes transparent. The direction that you drag
your cursor from the first point to the opposite corner determines which
objects are selected.

■ Window selection. Drag your cursor from left to right to select only
objects that are entirely enclosed by the rectangular area.
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■ Crossing selection. Drag your cursor from right to left to select objects
that the rectangular window encloses or crosses.

objects selected using window selection box

objects selected using crossing selection box

1

2

1

2

With a window selection, usually the entire object must be contained in the
rectangular selection area. However, if an object with a noncontinuous (dashed)
linetype is only partially visible in the viewport and all the visible vectors of
the linetype can be enclosed within the selection window, the entire object
is selected.

Specify an Irregularly Shaped Selection Area

Specify points to define an irregularly shaped area. Use window polygon
selection to select objects entirely enclosed by the selection area. Use crossing
polygon selection to select objects enclosed or crossed by the selection area.
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window polygon result

Specify a Selection Fence

In a complex drawing, use a selection fence. A selection fence looks like a
polyline and selects only the objects it passes through. The circuit board
illustration shows a fence selecting several components.

fence selection selected objects highlighted

Use Other Selection Options

You can see all selection options by entering ? at the Select Objects prompt.
For a description of each of the selection options, see .

Remove Selection from Multiple Objects

You can enter r (Remove) at the Select Objects prompt and use any selection
option to remove objects from the selection set. If you are using the Remove
option and want to return to adding objects to the selection set, enter a (Add).

You can also remove objects from the current selection set by holding down
SHIFT and selecting them again, or by holding down SHIFT and then clicking
and dragging window or crossing selections. You can add and remove objects
repeatedly from the selection set.

To see a list of options at the Select Objects prompt

■ Enter ? at the Select Objects prompt.
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To select objects within an irregularly shaped area

1 At the Select Objects prompt, enter wp (Window Polygon).

2 Specify points that define an area entirely enclosing the objects you want
to select.

3 Press ENTER to close the polygon selection area and complete the
selection.

To select objects crossing an irregularly shaped area

1 At the Select Objects prompt, enter cp (Crossing Polygon).

2 Specify points that define an area that encloses or crosses the objects
you want to select.

3 Press ENTER to close the polygon selection area and complete the
selection.

To select objects with a fence

1 At the Select Objects prompt, enter f (Fence).

2 Specify points to create a fence that passes through the objects you want
to select.

3 Press ENTER to complete the selection.

To remove several objects from the selection set

1 After selecting objects, at the Select Objects prompt, enter r (Remove).

2 Enter any selection option such as cp (Crossing Polygon) or f (Fence),
and select the objects to be removed from the selection set.

To return to adding objects to the selection set, enter a (Add).

Prevent Objects from Being Selected

You can prevent objects on specified layers from being selected and modified
by locking those layers.

Typically, you lock layers to prevent accidental editing of particular objects.
Other operations are still possible when a layer is locked. For example, you
can make a locked layer current, and you can add objects to it. You can also
use inquiry commands (such as ), use object snaps to specify points on objects
on locked layers, and change the draw order of objects on locked layers.

578 | Chapter 26   Change Existing Objects



To lock or unlock a layer

1 On the Layers toolbar, click the Layer Properties Manager button.

2 In the Layer Properties Manager, click the padlock for the layers that
you want to lock.

3 Click OK.

If the padlock is closed, the layer is locked and objects on that layer
cannot be selected.

Layers toolbar

Filter Selection Sets

You can use object properties or object types to include objects in a selection
set, or to exclude them.

Using either Quick Select () from the Properties palette or the Object Selection
Filters dialog box (), you can filter selection sets by property (such as color)
and by object type. For example, you can select all of the red circles in a
drawing without selecting any other object, or you can select all objects except
the red circles.

With Quick Select, you can quickly define a selection set based on filtering
criteria that you specify, and if an Autodesk or a third-party application was
used to add a feature classification to an object, you can select objects by
classification property. With object selection filters, you can name and save
filters for future use.

With either Quick Select or object selection filters, if you want to filter your
selection set based on color, linetype, or lineweight, first consider whether
these properties are set to BYLAYER for any objects in your drawing. For
example, an object may appear red because its color is set to BYLAYER and
the layer color is red.

See also:

“Customize Object Selection” on page 582
“Work with Layers” on page 268
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To create a selection set using Quick Select

In the following example, you use Quick Select to select the red objects in a
drawing.

1 Click Tools menu ➤ Quick Select.

2 In the Quick Select dialog box, under Apply To, select Entire Drawing.

3 Under Object Type, select Multiple.

4 Under Properties, select Color.

5 Under Operator, select Equals.

6 Under Value, select Red.

7 Under How to Apply, select Include in New Selection Set.

8 Click OK.

All red objects in the drawing are selected and the Quick Select dialog
box closes. Objects that are set to BYLAYER and are red because the layer
color is red are not included in the selection set.

NOTE If an application such as Autodesk Map was used to add a feature
classification to an object, and the associated classification (XML) file is present,
you can select objects by classification property. Specifically, you can select a
classification in the Object Type box and a property in the Properties box.

To exclude objects from the selection set

You can exclude objects from the current selection set by using the Exclude
from New Selection Set option. In the following example, you exclude all
circles with a radius greater than 1 from a set of objects already selected.

1 With several objects selected, click Tools menu ➤ Quick Select.

2 In the Quick Select dialog box, under Apply To, select Current Selection.

3 Under Object Type, select Circle.

4 Under Properties, select Radius.

5 Under Operator, select Greater Than.

6 Under Value, enter 1.

7 Under How to Apply, select Exclude from New Selection Set.

8 Click OK.
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All circles with a radius greater than 1 are removed from the selection
set.

To append objects to the selection set

You can use Quick Select to append objects to a current selection set. In the
following example, you keep the current selection set and append all objects
in the drawing that contain hyperlinks whose names begin with bld1_.

1 Click Tools menu ➤ Quick Select.

2 In the Quick Select dialog box, select Append to Current Selection Set.

3 In the Object Type box, select Multiple.

4 Under Properties, select Hyperlink.

5 Under Operator, select Wildcard Match.

6 Under Value, enter bld1_*.

7 Under How to Apply, select Include in New Selection Set.

8 Click OK.

To name and save a filtered list

1 At the Command prompt, enter filter.

2 In the Object Selection Filters dialog box, under Select Filter, select a
filter such as Line.

3 Click Add to List.

4 Under Save As, enter a filter name such as Linefilter.

5 Click Save As.

6 Click Apply.

The filter is applied so you can select, in this case, only lines in the
drawing. If you select objects with a selection, the filter is applied to all
objects in the selection area.

To use a named filter

1 At the Select Object prompt, enter 'filter. (The apostrophe makes it a
transparent command.)

2 In the Object Selection Filters dialog box, under Select Filter, select the
filter you want to use. Click Apply.
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3 Use a crossing window to specify objects for selection.

Only the objects selected by the crossing window that match the filter
criteria are selected.

Customize Object Selection

You can control several aspects of selecting objects, such as whether you enter
a command first or select objects first, the size of the pickbox cursor, and how
selected objects are displayed.

For commands that use the Select Objects prompt, you can

■ Enter a command first, and then select objects

■ Select the objects first, and then enter a command

You can also choose

■ Whether objects to be selected are previewed during selection

■ Whether selected objects are highlighted

■ How you define selection areas and how you create selection sets

Select the Command First

When you use an editing command, a Select Objects prompt is displayed and
the crosshairs is replaced with a pickbox. You can respond to the Select Objects
prompt in various ways:

■ Select objects one at a time.

■ Click an empty area. Drag the cursor to define a rectangular selection area.

■ Enter a selection option. Enter ? to display all selection options.

■ Combine selection methods. For example, to select most of the objects in
the drawing area, select all objects and then remove the objects that you
do not want selected.

■ Enter 'filter to use a named selection filter. The apostrophe runs the
command transparently.
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Select Objects First

You can use one of two methods to select objects before starting a command:

■ Use the  command, and enter ? to display all selection options. All objects
selected are put into the Previous selection set. To use the Previous selection
set, enter p at the Select Objects prompt of any subsequent command.

■ When noun/verb selection is turned on, select objects at the Command
prompt before entering a command such as , , or . With this method, you
can only select objects by clicking them individually or by using automatic
selection.

■ Enter qselect to filter the selection. Then enter p at the Select Objects
prompt of any subsequent command.

Highlight Objects to Be Selected

Objects are highlighted when the pickbox cursor rolls over them, providing
a preview of which object will be selected when you click.

When you specify an area to select multiple objects, the background of the
area becomes transparent.

These selection previewing effects are turned on by default. You can turn them
off or change the appearance of selection previewing (Options dialog box,
Selection tab). When the  system variable is set to 0, selection previewing of
objects is not available.

Control the Appearance of Selected Objects

By default, selected objects are displayed with dashed lines. You can increase
program speed by setting the  system variable to 0. Turning off selection
highlighting does not affect grips on selected objects.
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Set Up Default Selection Methods

Options on the Selection tab of the Options dialog box control default selection
methods:

■ Use selection previewing and selection area effects to preview selection.

■ Select objects before entering a command (noun-verb selection) or after
entering a command. ()

■ Press  SHIFT  to append objects to the selection set. ()

■ Click and drag to create a selection window. Otherwise you must click twice
to define the corners of a selection window. ()

■ Start Window or Crossing selection automatically when you click an empty
space. Otherwise, you must enter c or w to specify window crossing
selection. ()

■ Change the size of the pickbox. ()

■ Select all objects in a group when you select one object in that group.

■ Include the boundary in the selection set when you select a hatch.

To change the size of the pickbox cursor

1 Click Tools menu ➤ Options ➤ Selection tab.

2 Under Pickbox Size, move the slider until the pickbox is the size you
want to use.

3 Click OK.

To change object selection settings

1 Click Tools menu ➤ Options.

2 In the Options dialog box, Selection tab, make changes to the Selection
Preview and Selection Modes areas and the pickbox size.

3 Click OK.

To turn on or turn off selection previewing

1 Click Tools menu ➤ Options.
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2 In the Options dialog box, Selection tab, select or clear options as follows:

■ Select the When a Command Is Active option to display the check
mark.

■ Select the When No Command Is Active option to display the check
mark.

■ Select both options to turn on selection preview whenever it is
available.

■ Clear both options to turn off selection preview entirely.

To change the appearance of selection previewing

1 Click Tools menu ➤ Options.

2 In the Options dialog box, Selection tab, click Visual Effect Settings.

3 In the Visual Effect Settings dialog box, select one of the following
options:

■ Dash. Displays dashed lines.

■ Thicken. Displays thickened lines.

■ Both. Displays dashed and thickened lines.

4 Click OK to exit each dialog box.

To exclude objects from selection previewing

1 Click Tools menu ➤ Options.

2 In the Options dialog box, Selection tab, click Visual Effect Settings.

3 In the Visual Effect Settings dialog box, click Advanced Options.

4 In the Advanced Preview Options dialog box, select any of the following
options to exclude objects from selection previewing:

■ Exclude Objects on Locked Layers.

■ Xrefs.

■ Tables.

■ Groups.

■ Multiline Text.

■ Hatches.
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5 Click OK to exit each dialog box.

To change the appearance of the selection area

1 Click Tools menu ➤ Options.

2 In the Options dialog box, Selection tab, click Visual Effect Settings.

3 In the Visual Effect Settings dialog box, change any of the following
settings:

■ Indicate Selection Area. Select to display effects for selection areas.

■ Window Selection Color. Select a color, or click Select Color to
display the “Select Color Dialog Box”. ( system variable)

■ Crossing Selection Color. Select a color, or click Select Color to
display the Select Color Dialog Box. ( system variable)

■ Selection Area Opacity. Use the slider to set transparency for
selection areas. The lower the setting, the more transparent the area.
A value of 100 makes the area opaque. ( system variable)

4 Click OK to exit each dialog box.

Group Objects

A group is a saved set of objects that you can select and edit together or
separately as needed. Groups provide an easy way to combine drawing elements
that you need to manipulate as a unit.

See also:

“Create and Use Blocks (Symbols)” on page 451

Overview of Groups

A group is a saved set of objects that you can select and edit together or
separately as needed. Groups provide an easy way to combine drawing elements
that you need to manipulate as a unit.You can create them quickly and with
a default name, or you can use the Group Manager to assign a name from the
start.

You can change the components of groups as you work by adding or removing
objects.

In some ways, groups resemble blocks, which provide another method of
combining objects into a named set. For example, the groups you create are
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saved from session to session. However, you can edit individual objects in
groups more easily than you can edit them in blocks, which must be exploded
first. Unlike blocks, groups cannot be shared with other drawings.

NOTE The buttons in the Group Manager become available depending on what
you have selected. For example, the Ungroup button is available only when one
or more group names are selected in the Group Manager.

To close the Group Manager, undock it and click the Close button at the
upper-right corner.

Create Groups

In addition to choosing the objects that will become the members of a group,
you can give the group a name and description.

When you create a group, you can give the group a name and description. If
you copy a group, the copy is given the default name Ax and is considered
unnamed. Unnamed groups are not listed in the Object Grouping dialog box
unless you select Include Unnamed.

If you choose a member of a group that can be selected for inclusion in a new
group, all members of the former group are included in the new group.

■ Unnamed groups. Create an unnamed group by selecting the objects
you want to group and then choosing Group from the Tool menu or
choosing Group on the Group toolbar. A default name such as *A1 or *A2
is assigned. You can use the Group Manager later to assign a name and
description or change the components in this unnamed group.

■ Named groups. Create a named group in the Group Manager. Select the
objects you want to group and then select Create Groups. With this method,
you can assign the group a name and description as you create it.

The objects in your drawing can be members of more than one group, and
groups themselves can be nested in other groups. You can ungroup a nested
group to restore the original group configuration.

Named groups are not maintained when you use a drawing as an external
reference or insert it as a block. However, you can bind and then explode the
external reference or explode the block to make the group available as an
unnamed group.

NOTE Avoid creating large groups containing hundreds or thousands of objects.
A large group significantly degrades the performance of this program.
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To create a group

1 At the Command prompt, enter group.

2 In the Object Grouping dialog box, under Group Identification, enter a
group name and a description.

3 In the Create Group area, click New.

The dialog box closes temporarily.

4 Select objects and press  ENTER .

5 Click OK.

Select Objects in Groups

There are several methods for choosing a group, including selecting the group
by name or selecting one of the members of the group.

You can select groups by name at the Select Objects prompt. If the  system
variable is set to 1 or 3 and you select any member of a selectable group, all
group members that meet the selection criteria are selected. You can also
toggle group selection on and off by pressing  CTRL + H or  SHIFT +  CTRL
+  A .

All members of selectable groups are also selected when you use object selection
cycling (for example, if you want to select an object that lies directly behind
another object). Selecting an object that is a member of more than one
selectable group selects all the members of all the groups that contain that
object. To select groups for editing with grips, use the pointing device to select
the group at the Command prompt.

To toggle group selection

■ At any time, toggle group selection on and off by pressing either  CTRL +
H or  SHIFT +  CTRL +  A .

Edit Groups

You can add or remove group members and rename groups. You can also
perform editing operations, such as copy, mirror, and array, on groups.

Erasing a group member deletes that object from the group definition. When
a group member is included in a deleted block, the object is deleted from the
drawing and also from the group. If deleting an object or removing it from a
group leaves the group empty, the group remains defined. You can remove
the group definition by exploding the group. Exploding a group deletes it
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from a drawing; however, objects that were part of the group remain in the
drawing.

You can alter the group’s member order (the order in which the objects were
selected), its description, and whether it can be selected. You can reorder group
members in two ways: either change the numerical position of individual
members or ranges of group members, or reverse the order of all members.
The first object in each group is number 0, not number 1.

You can use the Group Manager to add or remove group members. Erasing
an object that is a member of a group deletes that object from the group
definition. You can also use the Group Manager to revise a group's name or
description.

Exploding an object within a group does not automatically add the resulting
components to the group.

You can delete a group description by using the Ungroup options on the menu
or toolbar in the Group Manager.

NOTE Exploding an object in a group removes the exploded components from
the group definition. See “Disassociate Compound Objects (Explode)” on page
646.

To delete a named group

1 At the Command prompt, enter group.

2 In the Object Grouping dialog box, select the group name from the list
of groups.

3 Under Change Group, select Explode.

4 Click OK.

The group is deleted.

To reorder group members

1 At the Command prompt, enter group.

2 In the Object Grouping dialog box, under Change Group, click Re-Order.

3 In the Order Group dialog box, under Group Name, select the group to
reorder.

4 To view the current order of this group, click Highlight.

5 In the Object Grouping dialog box, click Next or Previous to view the
objects. Click OK when you have finished viewing the order of the
objects.
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6 In the Order Group dialog box, under Remove From Position, enter an
object number.

7 Under Enter New Position Number for the Object, enter a new position.

8 Under Number of Objects, enter the object number or range of numbers
to reorder. Click Re-Order.

9 Click OK to close each dialog box.

Correct Mistakes
You can backtrack your recent actions using one of several methods.

Undo a Single Action

The simplest method of backtracking is to use Undo on the Standard toolbar
or the  command to undo a single action. Many commands include their own
U (undo) option so that you can correct mistakes without leaving the
command. When you are creating lines and polylines, for example, enter u
to undo the last segment.

NOTE By default, the system variable is set to combine consecutive pan and zoom
commands into a single operation when you undo or redo.

Undo Several Actions at Once

Use the Mark option of  to mark an action as you work. You can then use the
Back option of UNDO to undo all actions that occurred after the marked
action. Use the Begin and End options of UNDO to undo actions you've defined
as a group.

You can also undo several actions at once with the Undo list on the Standard
toolbar.

Reverse the Effect of Undo

You can reverse the effect of a single U or UNDO command by using
immediately after using U or UNDO.

You can also redo several actions at once with the Redo list on the Standard
toolbar.

Erase Objects

You can erase any object that you draw. If you accidentally erase the wrong
object, you can use the UNDO command or the OOPS command to restore
it.
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For more information, see “Erase Objects” on page 592.

Cancel a Command

You can cancel a command without completing it by pressing ESC. To change
the cancel key assignment, clear the Windows Standard Accelerator Keys
option in the Options dialog box, User Preferences tab.

To undo the most recent action

■ Click Edit menu ➤ Undo.

Standard toolbar

To undo a specific number of actions

1 On the Standard toolbar, click the Undo list arrow.

A list of actions that you can undo, starting with the most recent action,
is displayed.

2 Drag to select the actions to undo.

3 Click to undo the selected actions.

Standard toolbar

To redo an action

■ Click Edit menu ➤ Redo.

Only the action immediately preceding an UNDO command can be reversed
with REDO. You cannot use REDO to repeat another command.

Standard toolbar

To redo a specific number of actions

1 On the Standard toolbar, click the Redo list arrow.
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A list of undo actions that you can redo, starting with the most recent
action, is displayed.

2 Drag to select the actions to redo.

3 Click to redo the selected actions.

Standard toolbar

Erase Objects
You can erase objects from your drawing using several methods.

■ Erase them with .

■ Select them and then cut them to the Clipboard with CTRL+X.

■ Select them and press DELETE.

You can restore accidentally erased objects using . The  command restores all
objects deleted by the most recent use of ERASE, , or .

Clean Up the Display

You can remove the plus-shaped markers called blips and stray pixels that
may be left over from some editing operations from the display area.

■ To remove blips, use .

■ To remove stray pixels, use .

Remove Unused Definitions and Styles

You can remove unused named objects, including block definitions, dimension
styles, layers, linetypes, and text styles with .

See also:

“Correct Mistakes” on page 590

To erase an object

1 Click Modify menu ➤ Erase.
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2 At the Select Objects prompt, use a selection method to select the objects
to be erased or enter an option:

■ Enter L (Last) to erase the last object drawn.

■ Enter p (Previous) to erase the last selection set.

■ Enter all to erase all objects from the drawing.

■ Enter ? to see a list of all selection methods.

3 Press ENTER to end the command.

Modify toolbar

To restore the last erased object

■ At the Command prompt, enter oops.

The last objects that were removed by ERASE, BLOCK, or WBLOCK are restored.

To cut objects to the Clipboard

1 Select the objects you want to cut.

2 Click Edit menu ➤ Cut. You can also press CTRL+X.

The objects are available to be pasted into other Windows applications.

To remove plus-shaped marker blips

■ Click View menu ➤ Redraw.

To purge an unused linetype

1 Click File menu ➤ Drawing Utilities ➤ Purge.

The Purge dialog box displays a tree view of object types with items that
can be purged.

2 To purge unreferenced linetypes, use one of the following methods:

■ To purge all unreferenced linetypes, select Linetypes.

■ To purge specific linetypes, double-click Linetypes to expand the tree
view. Then select the linetypes to be purged.
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If the item you want to purge is not listed, select View Items You Cannot
Purge.

3 You are prompted to confirm each item in the list. If you do not want
to confirm each purge, clear the Confirm Each Item to Be Purged option.

4 Click Purge.

To confirm the purging of each item, respond to the prompt by choosing
Yes or No, or Yes to All if more than one item is selected.

5 Click Close.

Use Windows Cut, Copy, and Paste
When you want to use objects from a drawing file in another application, you
can cut or copy these objects to the Clipboard and then paste them from the
Clipboard into the other application.

Cut Objects

Cutting deletes selected objects from the drawing and stores them on the
Clipboard. The objects are now available to be pasted into other Microsoft®

Windows®  documents.

Copy Objects

You can use the Clipboard to copy part or all of a drawing into a document
created by another application. The objects are copied in vector format, which
retains the high resolution in other applications. These objects are stored in
WMF (Windows metafile) format in the Clipboard. The information stored
in the Clipboard can then be embedded in the other document. Updating the
original drawing does not update the copy embedded in the other application.

Paste Objects

Applications use different internal formats to store Clipboard information.
When you copy objects to the Clipboard, information is stored in all available
formats. When you paste the Clipboard contents into a drawing, the format
that retains the most information is used. However, you can override this
setting and convert pasted information to AutoCAD format.

Because it is the easiest format to edit, the AutoCAD format is the preferred
format for copying objects to and from AutoCAD. It retains all relevant object
information, including block references and 3D aspects.

The Windows metafile (picture) format contains screen vector information,
and files can be scaled and printed without losing resolution. Use this format
to paste objects into Windows applications that support WMF files. Metafiles
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pasted into AutoCAD are of higher resolution than bitmapped images (BMP
files) but are not as easily manipulated as AutoCAD objects. Bitmapped images
are raster images consisting of a pattern of pixels and are commonly used by
paint applications.

The color of the object doesn't change when copied to the Clipboard. For
example, white objects pasted onto a white background won't be visible. Use
the  and  system variables to control whether the background or foreground
is transparent for metafile objects pasted into other applications.

You can insert a linked or embedded object from the Clipboard into a drawing
with . If you convert pasted information to AutoCAD format, the object is
inserted as a block reference. To edit the pasted information, explode the block
reference into its component objects. When you convert a Windows metafile
stored on the Clipboard to AutoCAD format, you may lose some scaling
precision. To retain proper scaling, save objects in the original drawing as a
block (), and then insert them into AutoCAD using .

To cut objects to the Clipboard

1 Select the objects you want to cut.

2 Click Edit menu ➤ Cut. You can also press  CTRL +  X .

The objects are available to be pasted into other Windows applications.

To copy objects to the Clipboard

1 Select the objects you want to copy.

2 Click Edit menu ➤ Copy. You can also press  CTRL +  C .

To paste objects from the Clipboard

■ Click Edit menu ➤ Paste. You can also press  CTRL +  V .

The objects currently on the Clipboard are pasted into the drawing.

To convert pasted information to drawing file format

1 Click Edit menu ➤ Paste Special.

2 In the Paste Special dialog box, select Paste.

3 From the list of formats, select Picture.

4 Click OK.
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Modify Objects
You can easily modify the size, shape, and location of objects.

See also:

“Work with Custom and Proxy Objects”

Choose a Method to Modify Objects

You can easily modify the size, shape, and location of objects. You can

■ Enter a command first, and then select the objects to modify.

■ Select the objects first, and then enter a command to modify them.

■ Double-click an object to display the Properties palette or, in some cases,
a dialog box that is specific to that type of object.

■ Select and right-click an object to display a shortcut menu with relevant
options.

See also:

“Select Objects” on page 574
“Display and Change the Properties of Objects” on page 264
“Work with Custom and Proxy Objects”

Move or Rotate Objects

You can move objects to a different location, or change the orientation of
objects by rotating them by an angle or to other objects.

Move Objects

You can move objects at a specified distance and direction from the originals.

Use coordinates, grid snap, object snaps, and other tools to move objects with
precision.

Specify Distance with Two Points

Move an object using the distance and direction specified by a base point
followed by a second point. In this example, you move the block representing
a window. After clicking Move on the Edit menu, select the object to be moved
(1). Specify the base point for the move (2) followed by a second point (3).
The object is moved the distance and direction of point 2 to point 3.
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Specify Distance with Relative Coordinates

You can move an object using a relative distance by entering coordinate values
for the first point and pressing ENTER for the second point. The coordinate
values are used as a relative displacement rather than the location of a base
point.

NOTE Do not include an @ sign as you normally would for relative coordinates,
because relative coordinates are expected.

To copy objects a specified distance, you can also use direct distance entry
with Ortho mode and polar tracking. For more information, see “Enter Direct
Distances” on page 359

Use a Stretch-Move

You can also use  to move objects if all their endpoints lie entirely within the
selection window. Turn on Ortho mode or polar tracking to move the objects
at a specific angle.

A practical example is moving a door in a wall. The door in the illustration is
entirely within a crossing selection, while the wall lines are only partly within
the crossing selection area.

2

1

3

4

objects selected with
crossing selection

objects dragged with
Ortho mode on

result

The result is that only the endpoints that lie within the crossing selection
move.
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Use Alternate Methods

You can use grips to move and copy objects quickly. See “Use Grips to Edit
Objects” on page 636. You can also select objects and drag them to a new
location; press CTRL to make a copy. Using this method, you can drag objects
between open drawings and other applications. See “Embed OLE Objects in
Drawings” on page 1003.

To move an object using two points

1 Click Modify menu ➤ Move.

2 Select the objects to move.

3 Specify a base point for the move.

4 Specify a second point.

The objects you selected are moved to a new location determined by the
distance and direction between the first and second points.

Modify toolbar

To move an object using a displacement

1 Click Modify menu ➤ Move.

2 Select the object to move.

3 Enter the displacement in the form of a Cartesian, polar, cylindrical, or
spherical coordinate value. Do not include the @ sign, because a relative
coordinate is assumed.

4 At the prompt for the second point, press ENTER.

The coordinate values are used as a relative displacement rather than
the location of a base point. The selected objects are moved to a new
location determined by the relative coordinate values you enter.

Modify toolbar

To move by stretching

1 Click Modify menu ➤ Stretch.
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2 Select the object by using crossing selection.

The crossing selection must include at least one vertex or endpoint.
Specify crossing selection by clicking, moving your pointing device from
right to left, and clicking again.

3 Do one of the following:

■ Specify the base point for the move, and then specify a second point.

■ Enter the displacement in the form of a Cartesian, polar, cylindrical,
or spherical coordinate value. Do not include the @ sign, because a
relative coordinate is assumed. At the prompt for the second point of
displacement, press ENTER.

Any objects with at least one vertex or endpoint included within the
crossing selection are stretched. Any objects that are completely within
the crossing selection are moved without being stretched.

Modify toolbar

Rotate Objects

You can rotate objects in your drawing around a specified base point.

To determine the angle of rotation, you can enter an angle value, drag using
the cursor, or specify a reference angle to align to an absolute angle.

Rotate an Object by a Specified Angle

Enter a rotation angle value from 0 to 360 degrees. You can also enter values
in radians, grads, or surveyor bearings. Entering a positive angle value rotates
the objects counterclockwise or clockwise, depending on the Direction Control
setting in the Drawing Units dialog box.

Rotate an Object by Dragging

Drag the object around the base point and specify a second point. Use Ortho
mode, polar tracking, or object snaps for greater precision.

For example, you can rotate the plan view of a house by selecting the objects
(1), specifying a base point (2), and specifying an angle of rotation by dragging
to another point (3).
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Rotate an Object to an Absolute Angle

With the Reference option, you can rotate an object to align it to an absolute
angle.

For example, to rotate the part in the illustration so the diagonal edge rotates
to 90 degrees, you select the objects to be rotated (1, 2), specify the base point
(3), and enter the Reference option. For the reference angle, specify the two
endpoints of the diagonal line (4, 5). For the new angle, enter 90.

2
base point (3) ,
reference points (4, 5)

objects selected
(1, 2)

1

5

4

3

result
90

Rotate an Object in 3D

To rotate 3D objects, you can use either ROTATE or ROTATE3D.

■ With ROTATE, you can rotate objects around a specified base point. The
axis of rotation passes through the base point and is parallel to the Z-axis
of the current UCS.

■ With ROTATE3D, you can specify the axis of rotation using either two
points; an object; the X, Y, or Z axis; or the Z direction of the current view.
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See also:

“Rotate Views in Layout Viewports” on page 228

To rotate an object

1 Click Modify menu ➤ Rotate.

2 Select the object to rotate.

3 Specify the base point for the rotation.

4 Do one of the following:

■ Enter the angle of rotation.

■ Drag the object around its base point and specify a point location to
which you want to rotate the object.

■ Enter c to create a copy of the selected objects.

■ Enter r to rotate the selected objects from a specified reference angle
to an absolute angle.

Modify toolbar

To rotate an object to an absolute angle

1 Click Modify menu ➤ Rotate.

2 Select the objects to rotate.

3 Specify the base point for the rotation.

4 Enter r (Reference).

5 Enter a reference angle value or specify two point locations.

This determines an imaginary line that will be rotated to a new angle.

6 Enter the new angle, or specify a point.

The value that you enter for the new angle is an absolute angle, not a
relative value. Alternatively, if you specify a point, the reference angle
will be rotated to that point.

Modify toolbar
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To rotate a 3D object around an axis

1 Click Modify menu ➤ 3D Operation ➤ Rotate 3D.

2 Select the object to rotate (1).

3 Specify the start point and endpoint of the axis about which the objects
are to be rotated (2 and 3).

The positive axis direction is from the start point to the end point, and
the rotation follows the right-hand rule (see “Use World and User
Coordinate Systems in 3D” on page 326).

4 Specify the angle of rotation.

1

2

3

object to rotate
selected

axis of rotation
specified

result

Align Objects

You can move, rotate, or tilt an object so that it aligns with another object.

In the following example, align the pieces of piping using a window selection
box to select the object to be aligned. Use the Endpoint object snap to align
the pieces precisely.
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To align two objects

1 Click Modify menu ➤ 3D Operation ➤ Align.

2 Select the objects you want to align.

3 Specify the first source point and then the first destination point.

If you press  ENTER  now, the objects are moved from the source point
to the destination point.

4 Specify the second source point, and then the second destination point.

5 Specify the third source point, or press  ENTER  to continue.

6 Specify whether you want to scale objects to the alignment points.

The objects are aligned (moved and rotated into position), and then
scaled. The first destination point is the base point of the scale, the
distance between the first and second source points is the reference
length, and the distance between the first and second destination points
is the new reference length.

Copy, Offset, or Mirror Objects

You can create duplicates of objects in your drawing that are either identical
or similar to selected objects.

Copy Objects

You can create duplicates of objects at a specified distance and direction from
the originals.
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Use coordinates, grid snap, object snaps, and other tools to copy objects with
precision.

Specify Distance with Two Points

Copy an object using the distance and direction specified by a base point
followed by a second point. In this example, you copy the block representing
an electronic component. After clicking Copy on the Edit menu, select the
original object to be copied. Specify the base point for the move (1) followed
by a second point (2). The object is copied the distance and direction of point
1 to point 2.

1

2

result

copy of object

object selected

original object

Specify Distance with Relative Coordinates

Copy an object using a relative distance by entering coordinate values for the
first point and pressing ENTER for the second point. The coordinate values
are used as a relative displacement rather than the location of a base point.

NOTE Do not include an @ sign as you normally would for relative coordinates,
because relative coordinates are expected.

To copy objects a specified distance, you can also use direct distance entry
with Ortho mode and polar tracking. For more information, see “Enter Direct
Distances” on page 359.

Create Multiple Copies

The  command repeats for convenience. To exit the command, press ENTER.
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Use Alternate Methods

You can use grips to move and copy objects quickly. See “Use Grips to Edit
Objects” on page 636. You can also select objects and drag them to a new
location; press CTRL to make a copy. Using this method, you can drag objects
between open drawings and other applications. See “Embed OLE Objects in
Drawings” on page 1003.

To copy an object using two points

1 Click Modify menu ➤ Copy.

2 Select the objects to copy.

3 Specify the base point.

4 Specify the second point. Press ENTER.

Modify toolbar

Create an Array of Objects

You can create copies of objects in a rectangular or polar (circular) pattern
called an array.

For rectangular arrays, you control the number of rows and columns and the
distance between each. For polar arrays, you control the number of copies of
the object and whether the copies are rotated. To create many regularly spaced
objects, arraying is faster than copying.

Modify Objects | 605



1

object selected distance between columns
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rows

Create Rectangular Arrays

A rectangular array is built along a baseline defined by the current snap rotation
angle. This angle is zero by default, so the rows and columns of a rectangular
array are orthogonal with respect to the X and Y axes. The default angle 0
direction setting can be changed in .

object selected

angle of
rotation

Create Polar Arrays

When you create a polar array, the array is drawn counterclockwise or
clockwise, depending on whether you enter a positive or a negative value for
the angle to fill.

1

2

The radius of the array is determined by the distance from the specified center
point to a reference or base point on the last selected object. You can use the
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default reference point (usually an arbitrary point that coincides with a snap
point), or you can specify a new base point to be used as the reference point.

Array in 3D

With , you can create a rectangular array or a polar array of objects in 3D. In
addition to specifying the number of columns (X direction) and rows (Y
direction), you also specify the number of levels (Z direction).

Limit the Size of Arrays

If you specify a very large number of rows and columns for an array, it may
take a long time to create the copies. By default, the number of array elements
that can be generated by one command is limited to 100,000. This limit is
controlled by the MaxArray setting in the registry.

You can change the limit by setting the MaxArray system registry variable
using (setenv “MaxArray” “n”) where n is a number between 100 and
10000000 (ten million).

NOTE When changing the value of MaxArray, you must enter MaxArray with the
capitalization shown.

To create a rectangular array

1 Click Modify menu ➤ Array.

2 In the Array dialog box, select Rectangular Array.

3 Click Select Objects.

The Array dialog box closes. You are prompted for object selection.

4 Select the objects to be arrayed and press ENTER.

5 In the Rows and Columns boxes, enter the number of rows and columns
in the array.

6 Specify the horizontal and vertical spacing (offsets) between objects by
using one of the following methods:

■ In the Row Offset and Column Offset boxes, enter the distance
between rows and between columns. Adding a plus sign (+) or a minus
sign (-) determines direction.

■ Click the Pick Both Offsets button to use the pointing device to specify
the diagonal corners of a cell in the array. The cell determines the
vertical and horizontal spacing of the rows and columns.

■ Click the Pick Row Offset or Pick Column Offset button to use the
pointing device to specify the horizontal and vertical spacing.
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The example box displays the result.

7 To change the rotation angle of the array, enter the new angle next to
Angle of Array.

8 The default angle 0 direction setting can also be changed in UNITS.

9 Click OK to create the array.

Modify toolbar

To create a polar array

1 Click Modify menu ➤ Array.

2 In the Array dialog box, select Polar Array.

3 Next to Center Point, do one of the following:

■ Enter an X value and a Y value for the center point of the polar array.

■ Click the Pick Center Point button. The Array dialog box closes and
you are prompted for object selection. Use the pointing device to
specify the center point of the polar array.

4 Click Select Objects.

The Array dialog box closes and you are prompted for object selection.

5 Select the objects to be arrayed.

6 In the Method box, select one of the following methods:

■ Total Number of Items & Angle to Fill

■ Total Number of Items & Angle Between Items

■ Angle to Fill & Angle Between Items

7 Enter the number of items (including the original object), if available.

8 Use one of the following methods:

■ Enter the angle to fill and angle between items, if available. Angle to
Fill specifies the distance to fill around the circumference of the array.
Angle Between Items specifies the distance between each item.

■ Click the Pick Angle to Fill button and the Pick Angle Between Items
button. Use the pointing device to specify the angle to fill and the
angle between items.
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The example box displays the result.

9 You can set any of the following options:

■ To rotate the objects as they are arrayed, select Rotate Items As Copied.
The example area displays the result.

■ To specify the X,Y base point, select More, clear the Set to Object's
Default option and enter values in the X and Y boxes, or click the
Pick Base Point button and use the pointing device to specify the
point.

10 Click OK to create the array.

Modify toolbar

To create a 3D rectangular array of objects

1 Click Modify menu ➤ 3D Operation ➤ 3D Array.

2 Select the object to array (1).

3 Specify Rectangular.

4 Enter the number of rows.

5 Enter the number of columns.

6 Enter the number of levels.

7 Specify the distance between rows.

8 Specify the distance between columns.

9 Specify the distance between levels.
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object to array selected result

1

To create a 3D polar array of objects

1 Click Modify menu ➤ 3D Operation ➤ 3D Array.

2 Select the object to array (1).

3 Specify Polar.

4 Enter the number of items to array.

5 Specify the angle that the arrayed objects are to fill.

6 Press  ENTER  to rotate the objects as they are arrayed, or enter n to retain
their orientation.

7 Specify the start point and endpoint of the axis about which the objects
are to be rotated (2 and 3).

1

2

3

Offset an Object

creates a new object whose shape parallels the shape of a selected object.
Offsetting a circle or an arc creates a larger or smaller circle or arc, depending
on which side you specify for the offset.
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polyline polyline with
offset

A highly effective drawing technique is to offset objects and then trim or
extend their ends.

offset trim and extend the
offset lines

result

You can offset

■ Lines

■ Arcs

■ Circles

■ Ellipses and elliptical arcs (resulting in an oval-shaped spline)

■ 2D polylines

■ Construction lines (xlines) and rays

■ Splines

Special Cases for Offset Polylines and Splines

2D polylines and splines are trimmed automatically when the offset distance
is larger than can otherwise be accommodated.
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offset automatic trim

Closed 2D polylines that are offset to create larger polylines result in potential
gaps between segments. The  system variable controls how these potential
gaps are closed.

OFFSETGAPTYPE=0 OFFSETGAPTYPE=1 OFFSETGAPTYPE=2

chamfer distancefillet radius

To offset an object by specifying a distance

1 Click Modify menu ➤ Offset.

2 Specify the offset distance.

You can enter a value or use the pointing device.

3 Select the object to offset.

4 Specify a point on the side where you want to place the new objects.

5 Select another object to offset, or press ENTER to end the command.

Modify toolbar

To offset an object through a point

1 Click Modify menu ➤ Offset.

2 Enter t (Through).

3 Select the object to offset.

4 Specify the through point.
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5 Select another object to offset, or press ENTER to end the command.

Modify toolbar

Mirror Objects

You can flip objects about a specified axis to create a symmetrical mirror image.

Mirroring is useful for creating symmetrical objects because you can quickly
draw half the object and then mirror it instead of drawing the entire object.

You flip objects about an axis called a mirror line to create a mirror image. To
specify this temporary mirror line, you enter two points. You can choose
whether to erase or retain the original objects.

1

2 3

4

object selected
with window

mirror line defined
with two points

result with original
object retained

mirror line

When you mirror text, attributes, and attribute definitions, they are reversed
or turned upside down in the mirror image. If you want to prevent this, set
the  system variable to 0 (off). Text then has the same alignment and
justification as before the mirroring.

before MIRROR after MIRROR
(MIRRTEXT = 1)

after MIRROR
(MIRRTEXT = 0)

MIRRTEXT affects text that is created with the , , or  commands; attribute
definitions; and variable attributes. Text and constant attributes within an
inserted block are mirrored as a consequence of mirroring the entire block.
These objects are reversed regardless of the MIRRTEXT setting.
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Mirror in 3D

With , you can mirror objects across a specified mirroring plane. The mirroring
plane can be one of the following:

■ The plane of a planar object

■ A plane parallel to the XY, YZ, or XZ plane of the current UCS that passes
through a specified point

■ A plane defined by three specified points (2, 3, and 4)

1

3

2

4

object to mirror defining a mirror plane result

To mirror objects

1 Click Modify menu ➤ Mirror.

2 Select the objects to mirror.

3 Specify the first point of the mirror line.

4 Specify the second point.

5 Press ENTER to retain the original objects, or enter y to erase them.

Modify toolbar

To mirror objects in 3D

1 Click Modify menu ➤ 3D Operation ➤ Mirror 3D.

2 Select the object to mirror.

3 Specify three points to define a mirroring plane.

4 Press  ENTER  to retain the original objects, or enter y to delete them.
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Change the Size and Shape of Objects

There are several methods for adjusting the lengths of existing objects relative
to other objects, both symmetrically and asymmetrically.

Trim or Extend Objects

You can shorten or lengthen objects to meet the edges of other objects.

This means you can first create an object such as a line and then later adjust
it to fit exactly between other objects.

Objects you select as cutting edges or boundary edges are not required to
intersect the object being trimmed. You can trim or extend an object to a
projected edge or to an extrapolated intersection; that is, where the objects
would intersect if they were extended.

If you do not specify a boundary and press ENTER at the Select Objects prompt,
all displayed objects become potential boundaries.

NOTE To select cutting edges or boundary edges that include blocks, you can
use only the single selection, Crossing, Fence, and Select All options.

Trim Objects

You can trim objects so that they end precisely at boundary edges defined by
other objects.

For example, you can clean up the intersection of two walls smoothly by
trimming.

1

2

3

cutting edges selected
with a crossing selection

object to trim selected result

An object can be one of the cutting edges and one of the objects being
trimmed. For example, in the illustrated light fixture, the circle is a cutting
edge for the construction lines and is also being trimmed.
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cutting edges
selected

objects to trim
selected

result

When you trim several objects, the different selection methods can help you
choose the current cutting edges and objects to trim. In the following example,
the cutting edges are selected using crossing selection.

2

1

edges selected with
crossing selection

objects to trim selected result

The following example uses the fence selection method to select a series of
objects for trimming.

cutting edge selected objects to trim selected
with fence selection

result

You can trim objects to their nearest intersection with other objects. Instead
of selecting cutting edges, you press ENTER. Then, when you select the objects
to trim, the nearest displayed objects act as cutting edges. In this example,
the walls are trimmed so that they intersect smoothly.
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cutting edges selected
with crossing selection

objects to trim selected result

You can extend objects without leaving the  command. Hold down SHIFT
and select the objects to be extended.

Extend Objects

Extending operates the same way as trimming. You can extend objects so they
end precisely at boundary edges defined by other objects. In this example,
you extend the lines precisely to a circle, which is the boundary edge.

boundary selected objects to extend
selected

result

You can trim objects without leaving the EXTEND command. Hold down
SHIFT and select the objects to be trimmed.

Trim and Extend Wide Polylines

2D wide polylines trim and extend at their centerlines. The ends of wide
polylines are always square. Trimming a wide polyline at an angle causes
portions of the end to extend beyond the cutting edge

If you trim or extend a tapered 2D polyline segment, the width of the extended
end is corrected to continue the original taper to the new endpoint. If this
correction gives the segment a negative ending width, the ending width is
forced to 0.

Modify Objects | 617



selected boundary polylines to extend result

Trim and Extend Spline-Fit Polylines

Trimming a spline-fit polyline removes the curve-fit information and changes
the spline-fit segments into ordinary polyline segments.

Extending a spline-fit polyline adds a new vertex to the control frame for the
polyline.

Trim or Extend in 3D

You can trim or extend an object to any other object in 3D space, regardless
of whether the objects are on the same plane or parallel to the cutting or
boundary edges. In the TRIM and EXTEND commands, use the Project and
Edge options to select one of three projections for trimming or extending:

■ The XY plane of the current UCS

■ The plane of the current view

■ True 3D, which is not a projection

See also:

“Break and Join Objects” on page 634

To extend an object

1 Click Modify menu ➤ Extend.

2 Select the objects to serve as boundary edges.

To select all displayed objects as potential boundary edges, press ENTER
without selecting any objects.

3 Select the objects to extend.

Modify toolbar

618 | Chapter 26   Change Existing Objects



To trim an object

1 Click Modify menu ➤ Trim.

2 Select the objects to serve as cutting edges.

To select all displayed objects as potential cutting edges, press ENTER
without selecting any objects.

3 Select the objects to trim.

Modify toolbar

To extend objects in 3D wireframe models

1 Click Modify menu➤ Extend.

2 Select the boundary edge for extending (1).

3 Enter e (Edge).

4 Enter e (Extend).

5 Enter p (Project).

6 Enter u (UCS).

7 Select the object to extend (2).

1

2
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To trim in 3D using the current view plane

1 Click Modify menu ➤ Trim.

2 Select the cutting edge for trimming (1).

3 Enter p (Project).

4 Enter v (View).

5 Select the object to trim (2).

1

2

To trim objects in 3D wireframe models

1 Click Modify menu ➤ Trim.

2 Select the cutting edges to use for trimming (1 and 2).

3 Enter p (Project).

4 Enter n (None).

5 Select the object to trim (3 and 4).

1

2

3

4
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Resize or Reshape Objects

You can resize objects to make them longer or shorter in only one direction
or to make them proportionally larger or smaller.

You can also stretch certain objects by moving an endpoint, vertex, or control
point.

Lengthen Objects

With , you can change the included angle of arcs and the length of the
following objects:

■ Lines

■ Arcs

■ Open polylines

■ Elliptical arcs

■ Open splines.

The results are similar to extending and trimming. You can

■ Drag an object endpoint dynamically

■ Specify a new length or angle as a percentage of the total length or angle

■ Specify an incremental length or angle measured from an endpoint

■ Specify the object's total absolute length or included angle

Stretch Objects

With STRETCH, you relocate the endpoints of objects that lie across or within
a crossing selection window:

■ Objects that are partially enclosed by a crossing window are stretched.

■ Objects that are completely enclosed within the crossing window, or that
are selected individually, are moved rather than stretched.

To stretch an object, you specify a base point and then a point of displacement.

Modify Objects | 621



objects selected with
a crossing selection

points specified for stretch result

1

2

3

4

To stretch with precision, use object snaps, grid snaps, and relative coordinate
entry.

Scale Objects Using a Scale Factor

With , you can make an object uniformly larger or smaller. To scale an object,
you specify a base point and a scale factor. Alternatively, you can specify a
length to be used as a scale factor based on the current drawing units.

A scale factor greater than 1 enlarges the object. A scale factor between 0 and
1 shrinks the object.

Scaling changes the size of all dimensions of the selected object. A scale factor
greater than 1 enlarges the object. A scale factor less than 1 shrinks the object.

object selected object scaled by factor
of 0.5

result

1
2

Scale Objects Using a Reference Distance

You can also scale by reference. Scaling by reference uses an existing distance
as a basis for the new size. To scale by reference, specify the current distance
and then the new desired size. For example, if one side of an object is 4.8 units
long and you want to expand it to 7.5 units, use 4.8 as the reference length.

You can use the Reference option to scale an entire drawing. For example, use
this option when the original drawing units need to be changed. Select all
objects in the drawing. Then use Reference to select two points and specify
the intended distance. All the objects in the drawing are scaled accordingly.

See also:

“Break and Join Objects” on page 634
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To stretch an object

1 Click Modify menu ➤ Stretch.

2 Select the object using a crossing window selection.

The crossing window must include at least one vertex or endpoint.

3 Do one of the following:

■ Enter the displacement in the form of a relative Cartesian, polar,
cylindrical, or spherical coordinate. Do not include the @ sign, because
a relative coordinate is assumed. Press ENTER at the prompt for the
second point of displacement.

■ Specify the base point for the stretch, and then specify a second point,
to determine the distance and direction.

Any objects with at least one vertex or endpoint included within the
crossing window are stretched. Any objects that are completely within
the crossing window, or selected individually, are moved without
stretching.

Modify toolbar

To scale an object by a scale factor

1 Click Modify menu ➤ Scale.

2 Select the object to scale.

3 Specify the base point.

4 Enter the scale factor or drag and click to specify a new scale.

Modify toolbar

To scale an object by reference

1 Click Modify menu ➤ Scale.

2 Select the object to scale.

3 Select the base point.
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4 Enter r (Reference).

5 Select the first and second reference points, or enter a value for the
reference length.

Modify toolbar

To change the length of an object by dragging

1 Click Modify menu ➤ Lengthen.

2 Enter dy (Dynamic Dragging mode).

3 Select the object you want to lengthen.

4 Drag the endpoint closest to the point of selection, and specify a new
endpoint.

The selected object is lengthened or shortened without changing its
location or orientation.

Fillet, Chamfer, Break, or Join Objects

You can change objects to meet in rounded or flattened corners. You can also
create or close gaps in objects.

Create Fillets

A fillet connects two objects with an arc that is tangent to the objects and has
a specified radius.

first selected object second selected
object

result

An inside corner is called a fillet and an outside corner is called a round; you
can create both using the  command.
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You can fillet

■ Arcs

■ Circles

■ Ellipses and elliptical arcs

■ Lines

■ Polylines

■ Rays

■ Splines

■ Xlines

■ 3D solids

FILLET can be used to round all corners on a polyline using a single command.

NOTE Filleting a hatch boundary that was defined from line segments removes
hatch associativity. If the hatch boundary was defined from a polyline, associativity
is maintained.

If both objects being filleted are on the same layer, the fillet arc is created on
that layer. Otherwise, the fillet arc is created on the current layer. The layer
affects object properties including color and linetype.

Use the Multiple option to fillet more than one set of objects without leaving
the command.

Set the Fillet Radius

The fillet radius is the radius of the arc that connects filleted objects. Changing
the fillet radius affects subsequent fillets. If you set the fillet radius to 0, filleted
objects are trimmed or extended until they intersect, but no arc is created.

two lines before
fillet

two lines filleted
with radius

two lines filleted
with zero radius

You can hold down SHIFT while selecting the objects to override the current
fillet radius with a value of 0.
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Trim and Extend Filleted Objects

You can use the Trim option to specify whether the selected objects are
trimmed or extended to the endpoints of the resulting arc or left unchanged.

two lines filleted with
Trim option set

two lines filleted with
No Trim option set

Control the Location of the Fillet

Depending on the locations you specify, more than one possible fillet can
exist between the selected objects. Compare the selection locations and
resulting fillets in the illustrations.

fillet location points
selected

result

resultfillet location points
selected

Fillet Line and Polyline Combinations

To fillet lines with polylines, each line or its extension must intersect one of
the polyline line segments. If the Trim option is on, the filleted objects and
the fillet arc join to form a single new polyline.
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polyline selected line selected result

Fillet an Entire Polyline

You can fillet an entire polyline or remove fillets from an entire polyline.

If you set a nonzero fillet radius, FILLET inserts fillet arcs at the vertex of each
polyline segment that is long enough to accommodate the fillet radius.

polyline selected for
filleting

result

polyline line segments
long enough to fillet

polyline line segments
too short to fillet

If two polyline line segments converge as they approach an arc segment that
separates them, FILLET removes the arc segment and replaces it with a fillet
arc.

polyline selected for
filleting

result - fillet arc
replaces arc segment

polyline arc
segment

polyline line
segment

fillet arc

If you set the fillet radius to 0, no fillet arcs are inserted. If two polyline line
segments are separated by one arc segment, FILLET removes that arc and
extends the lines until they intersect.

Fillet Parallel Lines

You can fillet parallel lines, xlines, and rays. The current fillet radius
temporarily adjusts to create an arc that is tangent to both objects and located
in the plane common to both objects.
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The first selected object must be a line or a ray, but the second object can be
a line, an xline, or a ray. The fillet arc connects as shown in the illustration.

first parallel line
selected

second parallel line
selected

result

Fillet Objects with Non-Zero Thickness in 3D

You can fillet coplanar objects with extrusion directions not parallel to the Z
axis of the current UCS. FILLET determines the extrusion direction for the
fillet arc in 3D space closest to the direction of the Z axis of the current UCS.

To set the fillet radius

1 Click Modify menu ➤ Fillet.

2 Enter r (Radius).

3 Enter the fillet radius

4 Select the objects to fillet.

Modify toolbar

To fillet two line segments

1 Click Modify menu ➤ Fillet.

2 Select the first line.

3 Select the second line.

Modify toolbar

To fillet without trimming

1 Click Modify menu ➤ Fillet.
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2 If necessary, enter t (Trim). Enter n (No Trim).

3 Select the objects to fillet.

Modify toolbar

To fillet an entire polyline

1 Click Modify menu ➤ Fillet.

2 Enter p (Polyline).

3 Select the polyline.

Modify toolbar

To fillet multiple sets of objects

1 Click Modify menu ➤ Fillet.

2 Enter m (Multiple).

The main prompt is displayed.

3 Select the first line, or enter an option and complete the prompts for
that option. Select the first line.

4 Select the second line.

The main prompt is displayed again.

5 Select the first line for the next fillet, or press  ENTER  or  ESC  to end
the command.

Modify toolbar

Create Chamfers

A chamfer connects two objects with an angled line. It is usually used to
represent a beveled edge on a corner.

Modify Objects | 629



first selected line second selected line result

You can chamfer

■ Lines

■ Polylines

■ Rays

■ Xlines

■ 3D solids

CHAMFER can be used to bevel all corners of a polyline using a single
command.

NOTE Chamfering a hatch boundary that was defined from line segments removes
hatch associativity. If the hatch boundary was defined from a polyline, associativity
is maintained.

If both objects being chamfered are on the same layer, the chamfer line is
created on that layer. Otherwise, the chamfer line is created on the current
layer. The layer affects object properties including color and linetype.

Use the Multiple option to chamfer more than one set of objects without
leaving the command.

Chamfer by Specifying Distances

The chamfer distance is the amount each object is trimmed or extended to
meet the chamfer line or to intersect the other. If both chamfer distances are
0, chamfering trims or extends the two objects until they intersect but does
not create a chamfer line. You can hold down SHIFT while selecting the objects
to override the current chamfer distances with a value of 0.

original objects chamfer distance zero chamfer distance
nonzero
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In the following example, you set the chamfer distance to 0.5 for the first line
and 0.25 for the second line. After you specify the chamfer distance, you select
the two lines as shown.

first line selected second line selected result

first distance

second
distance

Trim and Extend Chamfered Objects

By default, objects are trimmed when chamfered, but you can use the Trim
option to specify that they remain untrimmed.

Chamfer by Specify Length and Angle

You can chamfer two objects by specifying where on the first selected object
the chamfer line starts, and then the angle the chamfer line forms with this
object.

In this example, you chamfer two lines so that the chamfer line starts 1.5
units from the intersection along the first line and forms an angle of 30 degrees
with this line.

first line selected second line selected result

angle with first
line

distance along
first line

Chamfer Polylines and Polyline Segments

If the two objects you select for chamfering are segments of a polyline, they
must be adjacent or separated by no more than one arc segment. If they are
separated by an arc segment, as shown in the illustration, chamfering deletes
the arc and replaces it with a chamfer line.
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first polyline segment
selected

second polyline
segment selected

result-chamfer line
replaces polyline arc

polyline arc segment

Chamfer an Entire Polyline

When you chamfer an entire polyline, each intersection is chamfered. For
best results, keep the first and second chamfer distances equal.

In this example, the chamfer distances are set to equal values.

polyline selected when
chamfer distances equal

result

When you chamfer an entire polyline, only the segments that are long enough
to accommodate the chamfer distance are chamfered. The polyline in the
following illustration has some segments too short to be chamfered.

polyline selected result

chamfered segments

segments too short to
chamfer

To set chamfer distances

1 Click Modify menu ➤ Chamfer.

2 Enter d (Distances).

3 Enter the first chamfer distance.

4 Enter the second chamfer distance.
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5 Select the lines for chamfering.

Modify toolbar

To chamfer two nonparallel line segments

1 Click Modify menu ➤ Chamfer.

2 Select the first line.

3 Select the second line.

Modify toolbar

To chamfer by specifying chamfer length and angle

1 Click Modify menu ➤ Chamfer.

2 Enter a (Angle).

3 Enter the distance from the corner to be chamfered along the first line.

4 Enter the chamfer angle.

5 Select the first line. Then select the second line.

Modify toolbar

To chamfer without trimming

1 Click Modify menu ➤ Chamfer.

2 Enter t (Trim Control).

3 Enter n (No Trim).

4 Select the objects to chamfer.

Modify toolbar
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To chamfer an entire polyline

1 Click Modify menu ➤ Chamfer.

2 Enter p (Polyline).

3 Select the polyline.

The polyline is chamfered using the current chamfer method and the
default distances.

Modify toolbar

To chamfer multiple sets of objects

1 Click Modify menu ➤ Chamfer.

2 Enter m (Multiple).

The main prompt is displayed.

3 Select the first line, or enter an option and complete the prompts for
that option and then select the first line.

4 Select the second line.

The main prompt is displayed again.

5 Select the first line for the next chamfer, or press  ENTER  or  ESC  to
end the command.

Modify toolbar

Break and Join Objects

You can break an object into two objects with or without a gap between them.
You can also join objects to make a single object.
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Break Objects

Use  to create a gap in an object, resulting in two objects with a gap between
them. BREAK is often used to create space for block or text.

1 2
first break point second break point result

To break an object without creating a gap, specify both break points at the
same location. The fastest way to do this is to enter @0,0 at the prompt for
the second point.

You can create breaks in most geometric objects except

■ Blocks

■ Dimensions

■ Mlines

■ Regions

Join Objects

Use  to combine similar objects into a single object. You can also create
complete circles and ellipses from arcs and elliptical arcs. You can join

■ Arcs

■ Elliptical arcs

■ Lines

■ Polylines

■ Splines

The object to which you want to join similar objects is called a source object.
Objects to be joined must be located in the same plane. Additional restrictions
for each type of objects are described in the  command.

NOTE When joining two or more arcs (or elliptical arcs), the arcs are joined
counterclockwise beginning from the source object.
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See also:

“Modify or Join Polylines” on page 647
“Modify Complex Objects” on page 645

To break an object

1 Click Modify menu ➤ Break.

2 Select the object to break.

By default, the point at which you select the object is the first break
point. To select a different pair of break points, enter f (First) and specify
the first break point.

3 Specify the second break point.

To break an object without creating a gap, enter @0,0 to specify the
previous point.

Modify toolbar

To join objects

1 Click Modify menu ➤ Join.

2 Select the source object to which you want to join objects.

3 Select one or more objects to join to the source object.

Valid objects include arcs, elliptical arcs, lines, polylines, and splines.
Additional restrictions for each type of objects are described in the
command.

Modify toolbar

Use Grips to Edit Objects

Grips are small squares that are displayed at strategic points on objects that
you have selected with a pointing device. You can drag these grips to edit
objects directly and quickly.
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Use Grip Modes

You can drag grips to perform any stretch, move, rotate, scale, or mirror
operations. You choose the editing operation to be performed by specifying
a grip mode.

Grips are small, solid-filled squares that are displayed at strategic points on
objects that you have selected with a pointing device. You can drag these grips
to stretch, move, rotate, scale, or mirror objects quickly.

When grips are on, you select the objects you want before entering a command,
and then you manipulate the objects with the pointing device.

circle line polyline

textblockspline

To use grips, select a grip to act as the base point for the action. Then select
one of the grip modes. You can cycle through these modes by pressing ENTER
or SPACEBAR. You can also use shortcut keys or right-click to see all of the
modes and options.

You can use multiple grips as the base grips to keep the shape of the object
intact between the selected grips. Hold down SHIFT as you select the grips.

For quadrant grips on circles and ellipses, distance is measured from the center
point, not the selected grip. For example, in Stretch mode, you can select a
quadrant grip to stretch a circle and then specify a distance on the command
line for the new radius. The distance is measured from the center of the circle,
not the selected quadrant. If you select the center point to stretch the circle,
the circle moves.

Modify Objects | 637



When a 2D object lies on a plane other than the current UCS, the object is
stretched on the plane on which it was created, not on the plane of the current
UCS.

You can limit the display of grips on selected objects. The GRIPOBJLIMIT
system variable suppresses the display of grips when the initial selection set
includes more than the specified number of objects. If you add objects to the
current selection set, the limit does not apply. For example, if GRIPOBJLIMIT
is set to 20, you can select 15 objects and then add 25 objects to the selection,
and all objects display grips.

Stretch with Grips

You can stretch an object by moving selected grips to new locations. Grips
on text, block references, midpoints of lines, centers of circles, and point
objects move the object rather than stretching it. This is an excellent method
for moving block references and adjusting dimensions.

Move with Grips

You can move objects by the grip selected. Selected objects are highlighted
and are moved the direction and distance of the next point location you
specify.

Rotate with Grips

You can rotate selected objects around a base point by dragging and specifying
a point location. Alternatively, you can enter an angle value. This is an
excellent method for rotating block references.

Scale with Grips

You can scale selected objects relative to a base point. Increase the size of an
object by dragging outward from the base grip and specifying a point location,
or decrease the size by dragging inward. Alternatively, you can enter a value
for relative scaling.

Mirror with Grips

You can mirror selected objects across a temporary mirror line. Turning Ortho
on helps you specify a vertical or horizontal mirror line.

See also:

“Use Dynamic Input” on page 335
“Work with Dynamic Blocks in Drawings” on page 548
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To turn on grips

1 On the Tools menu, click Options.

2 In the Options dialog box, Selection tab, select Enable Grips.

3 Click OK.

To set the color of the unselected grip beneath the cursor

1 Click Tools menu ➤ Options.

2 In the Options dialog box, Selection tab, click the arrow under Hover
Grip Color.

3 Select a color, or click Select Color to display the Select Color dialog box.

To limit the number of objects in the initial selection set that display grips

1 Click Tools menu ➤ Options.

2 In the Options dialog box, Selection tab, enter a number in the Object
Selection Limit for Display of Grips box. The maximum is 32,767.

If you add objects to the current selection set, the limit does not apply.

To display grip tips for custom objects that support grip tips

1 Click Tools menu ➤ Options.

2 In the Options dialog box, Selection tab, select Enable Grip Tips.

To cancel grip selection

■ Press ESC.

To stretch an object using grips

1 Select the object to stretch.

2 Select a base grip on the object.

The selected grip is highlighted, and Stretch, the default grip mode, is
active.

3 Move the pointing device and click.

The selected object is stretched as the grip moves.
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To stretch using more than one grip

1 Select several objects to stretch.

2 Hold down SHIFT and click several grips so that they are highlighted.

3 Release SHIFT and select a grip as the base grip by clicking the grip.

The default grip mode, Stretch, is active.

4 Move the pointing device and click.

The selected grips act in unison and the selected objects are stretched.

To move objects using grips

1 Select the objects to move.

2 Select a base grip on an object by clicking the grip.

The selected grip is highlighted, and Stretch, the default grip mode, is
active.

3 Cycle through the grip modes by pressing ENTER until the grip mode
Move appears.

Alternatively, you can right-click to display a shortcut menu of modes
and options.

4 Move the pointing device and click.

The selected objects are moved along with the grip.

To rotate objects using grips

1 Select the objects to rotate.

2 Select a base grip on an object by clicking the grip.

The selected grip is highlighted, and Stretch, the default grip mode, is
active.

3 Cycle through the grip modes by pressing ENTER until the grip mode
Rotate appears.

Alternatively, you can right-click to display shortcut menu modes and
options.

4 Move the pointing device and click.

The selected objects are rotated around the base grip.

To scale objects using grips

1 Select the objects to scale.
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2 Select a base grip on an object by clicking the grip.

The selected grip is highlighted, and Stretch, the default grip mode, is
active.

3 Cycle through the grip modes by pressing ENTER until the grip mode
Scale appears.

Alternatively, you can right-click to display shortcut menu modes and
options.

4 Move the pointing device and click.

To mirror objects using grips

1 Select the objects to mirror.

2 Select a base grip on an object by clicking the grip.

The selected grip is highlighted, and the default grip mode, Stretch, is
active.

3 Cycle through the grip modes by pressing ENTER until the grip mode
Mirror appears.

Alternatively, you can right-click to display shortcut menu modes and
options.

4 Click to specify the second point of the mirror line.

Turning on Ortho mode is often useful when mirroring objects.

Make Multiple Copies with Grips

You can create multiple copies of objects as you modify them with any of the
grip modes.

For example, by using the Copy option, you can rotate the selected objects,
leaving copies at each location you specify with the pointing device.

You can also make multiple copies by holding down CTRL as you select the
first point. For example, with the Stretch grip mode, you can stretch an object,
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such as a line, and then copy it to any point in the drawing area. Multiple
copies continue being made until you turn off grips.

Define an Offset Snap or a Rotation Snap

You can place multiple copies at regularly spaced intervals with an offset snap.
The offset snap is defined by the distance between an object and the next
copy. In the lighting layout below, the first copy of the light fixture symbol
is placed at an offset of two units. All subsequent copies are then placed two
units apart.

base grip selected copy offset defined result

1

2

3

4

If you hold down  CTRL  while you select multiple copy points with the
pointing device, the graphics cursor snaps to an offset point based on the last
two points you selected. In the illustration below, the midpoint of line 1 is at
coordinate 8,5. Based on that midpoint, line 2 was copied using the CTRL key
and Stretch grip mode; its midpoint is at 9,5. The third line snaps to an offset
based on the coordinate values 10,5.

midpoint of line 3 at
10,5

midpoint of line 2 at
9,5

midpoint of line 1 at
8,5

Similarly, you can place multiple copies at angular intervals around a base
grip with a rotation snap. The rotation snap is defined as the angle between
an object and the next copy when you are using Rotate grip mode. Hold down
CTRL  to use the rotation snap.
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block selected for
multiple copy with grips

block copied and
rotated

result - four blocks
copied and rotated

1

To create copies in any grip mode

1 Select the objects to copy.

2 Select a base grip on an object by clicking the grip.

The selected grip is highlighted, and the default grip mode, Stretch, is
active.

3 Cycle through the grip modes by pressing ENTER until the grip mode
you want appears.

Alternatively, you can right-click to display shortcut menu modes and
options.

4 Enter c (Copy).

Copies continue being made until you turn off grips.

5 Enter or specify the additional input required for the current grip mode.

6 Turn off grips by pressing ENTER, SPACEBAR, or ESC.

To create an offset snap for multiple copies using grips

1 Select the objects to copy.

2 Select a base grip on an object by clicking the grip.

The selected grip is highlighted, and the default grip mode, Stretch, is
active.

3 Cycle through the grip modes by pressing ENTER until the grip mode
Move appears.

Alternatively, you can right-click to display shortcut menu modes and
options.
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4 Enter c (Copy).

5 Move the cursor and click.

The offset snap is the distance between the grip you selected and the
location you specified for the copy.

6 Hold down CTRL and place additional copies by specifying additional
locations.

These copies are created at the same offset snap distance as the last copy.

7 Turn off grips by pressing ENTER, SPACEBAR, or ESC.

To create a rotation snap for multiple rotated copies using grips

1 Select the objects to rotate.

2 Select a base grip on an object by clicking the grip.

The selected grip is highlighted, and the default grip mode, Stretch, is
active.

3 Cycle through the grip modes by pressing ENTER until the grip mode
Rotate appears.

Alternatively, you can right-click to display shortcut menu modes and
options.

4 Enter c (Copy).

5 Move the pointing device and click.

The rotation snap is the angle between the grip you selected and the
location you specified for the copy.

6 Hold down CTRL and place additional copies by specifying additional
locations.

These copies are created at the same rotation snap angle as the first copy.

7 Turn off grips by pressing ENTER, SPACEBAR, or ESC.

To mirror objects and retain the originals using grips

1 Select the objects to mirror.

2 Select a base grip on an object by clicking the grip.

The selected grip is highlighted, and the default grip mode, Stretch, is
active.

3 Cycle through the grip modes by pressing ENTER until the grip mode
Mirror appears.
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Alternatively, you can right-click to display shortcut menu modes and
options.

4 Hold down CTRL (or enter c for Copy) to retain the original image, and
specify the second point of the mirror line.

Turning on Ortho mode is often useful when mirroring objects.

5 Turn off grips by pressing ENTER, SPACEBAR, or ESC.

Control Grips in Blocks

You can specify whether a block displays a single grip or multiple grips.

You can specify whether a selected block reference displays a single grip at its
insertion point or displays multiple grips associated with the objects grouped
within the block.

grips within blocks
turned off

grips within blocks
turned on

insertion point

See also:

“Specify Grips for Dynamic Blocks” on page 510

To turn grips within blocks on or off

1 Click Tools menu ➤ Options.

2 In the Options dialog box, Selection tab, select or clear Enable Grips
Within Blocks.

3 Click OK.

Modify Complex Objects
Additional editing operations are available for complex objects, such as blocks,
dimensions, hatches, and polylines.
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See also:

“Modify 3D Solids” on page 655
“Modify Blocks” on page 561
“Modify Hatches and Solid-Filled Areas” on page 693
“Change Text” on page 742
“Modify Existing Dimensions” on page 824
“Update Fields” on page 730
“Create and Modify Tables” on page 758
“Modify Raster Images and Image Boundaries”

Disassociate Compound Objects (Explode)

You can explode a compound object, such as a polyline, dimension, hatch,
or block reference, to convert it into individual elements. For example,
exploding a polyline breaks it down to simple lines and arcs. Exploding a
block reference or an associative dimension replaces it with copies of the
objects that compose the block or dimension.

Explode Dimensions and Hatches

When you explode a dimension or a hatch, all associativity is lost and the
dimension or hatch object is replaced by individual objects such as lines, text,
points, and 2D solids.

Explode Polylines

When you explode a polyline, any associated width information is discarded.
The resulting lines and arcs follow the polyline's centerline. If you explode a
block that contains a polyline, you need to explode the polyline separately.
If you explode a donut, its width becomes 0.

Explode Block References

If you explode a block with attributes, the attribute values are lost, leaving
only the attribute definitions. The colors and linetypes of objects in exploded
block references can change.

Explode External References

An external reference (xref) is a drawing file linked (or attached) to another
drawing. You cannot explode xrefs and their dependent blocks.

To explode an object

1 Click Modify menu ➤ Explode.

2 Select the objects to be exploded.

646 | Chapter 26   Change Existing Objects



For most objects, exploding has no visible effect.

Modify toolbar

Modify or Join Polylines

Additional editing operations are available for changing the shape of polyline
objects. You can also join separate polylines.

You can edit polylines by closing and opening them and by moving, adding,
or deleting individual vertices. You can straighten the polyline between any
two vertices and toggle the linetype so that a dash appears before and after
each vertex. You can set a uniform width for the entire polyline or control
the width of each segment. You can also create a linear approximation of a
spline from a polyline.

Joined Polyline Segments

You can join a line, an arc, or another polyline to an open polyline if their
ends connect or are close to each other. If the ends are not coincident but are
within a distance that you can set, called the fuzz distance, the ends are joined
by either trimming them, extending them, or connecting them with a new
segment.

Properties of Modified Polylines

If the properties of several objects being joined into a polyline differ, the
resulting polyline inherits the properties of the first object that you selected.
If two lines meet a polyline in a Y shape, one of the lines is selected and joined
to the polyline. Joining also causes an implicit decurve, with the program
discarding the spline information of the original polyline and any polylines
being joined to it. Once the joining is completed, you can fit a new spline to
the resulting polyline.

Additional Editing Options for Polylines

In addition to the general editing operations available for most objects, there
are additional options available for editing and joining polylines with .

■ Close. Creates the closing segment of the polyline, connecting the last
segment with the first. The polyline is considered open unless you close it
using the Close option.
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■ Join. Adds lines, arcs, or polylines to the end of an open polyline and
removes the curve fitting from a curve-fit polyline. For an object to join
the polyline, their endpoints must touch.

■ Width. Specifies a new uniform width for the entire polyline. Use the
Width option of the Edit Vertex option to change the starting and ending
widths of segments.

polyline selected segments with different
start and end widths

■ Edit Vertex. Marks the first vertex of the polyline by drawing an X on
the screen. If you have specified a tangent direction for this vertex, an arrow
is also drawn in that direction.

■ Fit. Creates a smooth curve consisting of arcs joining each pair of vertices.
The curve passes through all vertices of the polyline and uses any tangent
direction you specify.

■ Spline. Uses the vertices of the selected polyline as the control points, or
frame, of a spline-fit polyline. The curve passes through the first and last
control points unless the original polyline was closed.

polyline splined polyline

■ Decurve. Removes extra vertices inserted by an arc-fit or spline-fit polyline
and straightens all segments of the polyline.

■ Ltype Gen. Generates the linetype in a continuous pattern through the
vertices of the polyline. When this option is turned off, the linetype is
generated starting and ending with a dash at each vertex.

See also:

“Trim or Extend Objects” on page 615
“Break and Join Objects” on page 634
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To modify a polyline

1 Click Modify menu ➤ Object ➤ Polyline.

2 Select the polyline to modify.

If the selected object is a line or an arc, the following prompt is displayed:

Object selected is not a polyline.

Do you want it to turn into one? <Y>: Enter y  or n , or press  ENTER

If you enter y, the object is converted into a single-segment 2D polyline
that you can edit. You can use this operation to join lines and arcs into
a polyline. When the  system variable is set to 1, this prompt is
suppressed, and the selected object is automatically converted to a
polyline.

3 Edit the polyline by entering one or more of the following options:

■ Enter c (Close) to create a closed polyline.

■ Enter j (Join) to join contiguous lines, arcs, or polylines.

■ Enter w (Width) to specify a new uniform width for the entire
polyline.

■ Enter e (Edit Vertex) to edit a vertex.

■ Enter f (Fit) to create a series of arcs joining each pair of vertices.

■ Enter s (Spline) to create an approximation of a spline.

■ Enter d (Decurve) to remove extra vertices inserted by a fit or spline
curve and to straighten all segments of the polyline.

■ Enter L (Ltype Gen) to generate the linetype in a continuous pattern
through the vertices of the polyline.

■ Enter u (Undo) to reverse actions back to the start of PEDIT.

4 Enter x (Exit) to end the command.

Modify II toolbar

To taper the width of individual polyline segments

1 Click Modify menu ➤ Object ➤ Polyline.

2 Select the polyline to edit.

Modify Complex Objects | 649



3 Enter e (Edit Vertex).

The first vertex is marked with an X. Move to the appropriate vertex
with Next or Previous.

4 Enter w (Width).

5 Enter new starting and ending widths, and press ENTER to move to the
next vertex. Repeat steps 4 and 5 for each segment.

6 Enter u (Undo) to reverse actions back to the start of PEDIT.

7 Enter x (Exit) to end editing vertexes.

8 Enter x (Exit) again to end the command.

Modify II toolbar

Modify Splines

Additional editing options are available for changing the shape of spline
objects.

In addition to the general editing operations available for most objects, there
are additional options available for editing splines with .

■ Fit Data. Edits the fit point data that defines the spline, including changing
the tolerance.

■ Close. Changes an open spline into a continuous, closed loop.

■ Move Vertex. Moves a fit point to a new location.

■ Refine. Modifies a spline definition by adding and weighting control
points and elevating the order of the spline.

■ Reverse. Changes the direction of the spline.

You also can change the tolerance of the spline. Tolerance refers to how closely
the spline fits the set of fit points you specify. The lower the tolerance, the
more closely the spline fits the points.

Edit Splines with Grips

When you select a spline, grips are displayed on its fit points (the  system
variable must be set to 1). You can use grips to modify the shape and location
of the spline.
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After certain operations, fit points are discarded and grips are displayed on
control points instead. These operations include trimming the spline, moving
the control points, and purging the fit data. If the spline's control frame is
turned on (the  system variable is set to 1), grips are displayed on both the
spline's control points and its fit points, when available.

spline with fit tolerance = 0 spline with fit tolerance = .5

control points

control points

fit points fit points

You can delete fit points of a spline, add fit points for greater accuracy, or
move fit points to alter the shape of a spline. You can open or close a spline
and edit the spline start and end tangents. Spline direction is reversible. You
can change the tolerance of the spline also. Tolerance refers to how closely the
spline fits the set of fit points you specify. The lower the tolerance, the more
closely the spline fits the points.

Refine the Shape of a Spline

You can refine a spline by increasing the number of control points in one
portion of the spline or by changing the weight of specific control points.
Increasing the weight of a control point pulls the spline more towards that
point. You can also refine a spline by changing its order. A spline’s order is
the degree of the spline polynomial + 1. A cubic spline, for example, has order
4. The higher a spline’s order, the more control points it has.

Consider the following example. You have created a spline to represent a
geographic contour. Grips are turned on, and you need to move the fourth
fit point to increase accuracy. When you select the spline, grips appear at the
control points. If you created the spline by fitting it through a set of points,
and you haven’t purged this information using the Purge option of the
SPLINEDIT command, and you select the Fit Data option, grips appear at the
fit points on the selected spline instead of at the control points.
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fourth fit point
selected

fit point moved result

See also:

“Break and Join Objects” on page 634

To edit a spline

1 Click Modify menu ➤ Object ➤ Spline.

2 Select the spline to modify.

3 Edit the spline by entering one or more of the following options:

■ Enter f (Fit) to edit the fit data that defines the spline.

■ Enter c (Close) to change an open spline into a continuous, closed
loop.

■ Enter m (Move Vertex) to move a fit point to a new location.

■ Enter r (Refine) to modify a spline definition by adding and weighting
control points and elevating the order of the spline.

■ Enter e (Reverse) to reverse the direction of the spline.

■ Enter u (Undo) to cancel the last editing action.

4 Enter x (Exit) to end the command.
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Modify II toolbar

Modify Multilines

Multiline objects are composed of 1 to 16 parallel lines, called elements. To
modify multilines or their elements, you can use common editing commands,
a multiline editing command, and multiline styles.

Special multiline editing features are available with the command including
the following:

■ Add or delete a vertex

■ Control the visibility of corner joints

■ Control the style of intersection with other multilines

■ Open or close gaps in a multiline object

Add and Delete Multiline Vertices

You can add or delete any vertex in a multiline.

vertex in multiline to
delete

multiline with vertex
deleted

Edit Multiline Intersections

If you have two multilines in a drawing, you can control the way they intersect.
Multilines can intersect in a cross or a T shape, and the crosses or T shapes
can be closed, open, or merged.

closed cross open T merged cross

Modify Complex Objects | 653



Edit Multiline Styles

You can use  to edit multiline styles to change the properties of multiline
elements or the end caps and background fill of subsequently created
multilines.

Multiline styles control the number of line elements in a multiline and the
color, linetype, lineweight, and offset of each element. You can also modify
the display of joints, end caps, and background fill.

Multiline styles have the following limitations:

■ You cannot edit the element and multiline properties of the STANDARD
multiline style or any multiline style already used in the drawing.

■ To edit an existing multiline style, you must do so before you draw any
multilines in that style.

NOTE If you use  to create a multiline style without saving it, and then select
another style or create a new style, the first MLSTYLE properties are lost. To
maintain the properties, save each multiline style to an MLN file before creating
a new one.

Use Common Editing Commands on Multilines

You can use most of the common editing commands on multilines except

■ BREAK

■ CHAMFER

■ FILLET

■ LENGTHEN

■ OFFSET

To perform these operations, first use  to replace the multiline object with
separate line objects.

NOTE If you trim or extend a multiline object, only the first boundary object
encountered determines the shape of the end of the multiline. A multiline cannot
have a complex boundary at its endpoint.

See also:

“Draw Multiple-Line Objects” on page 397
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To delete a vertex from a multiline

1 Click Modify menu ➤ Object ➤ Multiline.

2 In the Multiline Edit Tools dialog box, select Delete Vertex.

3 In the drawing, specify the vertex to delete. Press  ENTER.

To create a closed cross intersection

1 Click Modify menu ➤ Object ➤ Multiline.

2 In the Multiline Edit Tools dialog box, select Closed Cross.

3 Select the multiline for the foreground.

4 Select the multiline for the background.

The intersection is modified. You can continue selecting intersecting
multilines to modify, or press  ENTER  to end the command. Press  ENTER
again to redisplay the Multiline Edit Tools dialog box.

To edit a multiline style

1 Click Format menu ➤ Multiline Style.

2 In the Multiline Styles dialog box, select the style name from the list.
Click Modify.

3 Click Element Properties.

4 In the Modify Multiline Styles dialog box, change the settings as needed.

5 Click OK.

6 In the Multiline Styles dialog box, click Save to save the changes to the
style in the MLN file.

7 Click OK.

Modify 3D Solids
After creating a 3D solid model, you can use the ShapeManager modeler to
change the form and appearance of the model.

Overview of Modifying 3D Solids

After creating a solid model, you can change its appearance by filleting,
chamfering, sectioning, slicing, and separating.
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You can also edit faces and edges on your solid model. You can easily remove
blends created by  or . You can change the color or copy a face or edge of a
solid as a body, region, line, arc, circle, ellipse, or spline object. Imprinting
geometry on existing solids creates new faces or merges redundant faces.
Offsetting changes the faces relative to the original faces on the solid model,
for example, making the diameter of a hole larger or smaller. Separating
disjointed composite solids creates 3D solid objects. Shelling creates thin walls
with a specified thickness.

Fillet and Chamfer 3D Solids

You can add rounds and fillets to selected edges of 3D solids.

With , you can add rounds and fillets to selected 3D solids. The default method
is specifying the fillet radius and then selecting the edges to fillet. Other
methods specify individual measurements for each filleted edge and fillet a
tangential series of edges.

Similarly, with , you can bevel the edges along adjoining faces of selected 3D
solids.

To fillet a solid object

1 Click Modify menu ➤ Fillet.

2 Select the edge of the solid to fillet (1).

3 Specify the fillet radius.

4 Select additional edges or press  ENTER  to fillet.

1

edge to fillet selected result
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To chamfer a solid object

1 Click Modify menu ➤ Chamfer.

2 Select the edge of the base surface to chamfer (1).

One of two surfaces adjacent to the selected edge is highlighted.

3 To select a different surface, enter n (Next), or press  ENTER  to use the
current surface.

4 Specify the base surface distance.

The base surface distance is measured from the selected edge to a point
on the base surface. The other surface distance is measured from the
selected edge to a point on the adjacent surface.

5 Specify the adjacent surface distance.

Loop selects all edges around the base surface and Select Edge selects
individual edges.

6 Specify the edges to chamfer (2).

base surface selected edge to chamfer
selected

result

1
2

Section and Slice 3D Solids

You can create a cross section through a 3D solid. The result can be a
two-dimensional object representing the shape of the section, or it can be a
3D solid chopped in half.

With , you can create a cross section through a solid as a region or an
anonymous block. The default method is specifying three points to define the
plane. Other methods define the cross-sectional plane by another object, the
current view, the Z axis, or the XY, YZ, or ZX plane. The cross-sectional plane
is placed on the current layer.
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With , you can create a new solid by cutting the existing solid and removing
a specified side. You can retain one or both halves of the sliced solids. The
sliced solids retain the layer and color properties of the original solids. The
default method of slicing a solid is to specify three points that define the
cutting plane and then select which side to retain. You can also define the
cutting plane by using another object, the current view, the Z axis, or the XY,
YZ, or ZX plane.

To create a cross section of a solid

1 Click draw menu ➤ Solids ➤ Section.

2 Select the objects to cross-section.

3 Specify three points to define the cross-sectional plane.

The first point defines the origin (0,0,0) of the cutting plane. The second
point defines the X axis, and the third point defines the Y axis.

cross section isolated
and hatched for clarity

cross-sectional cutting
plane defined

object selected and
three points specified

2

3

1

NOTE If you are applying hatching to the cross-sectional cutting plane, you must
align the UCS with the cross-sectional cutting plane first.

To slice a solid

1 Click Draw menu ➤ Solids ➤ Slice.

2 Select the objects to slice.
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3 Specify three points to define the cutting plane.

The first point defines the origin (0,0,0) of the cutting plane. The second
point defines the positive X axis, and the third point defines the positive
Y axis.

4 Specify which side to retain, or enter b to retain both sides.

2

1

3

three points specified to
define the cutting plane

one half of object
retained

both halves retained

Modify Faces of 3D Solids

You can edit a 3D solid object by performing operations on selected faces of
the object.

Overview of Modifying Faces on 3D Solids

You can edit your solid object by extruding, moving, rotating, offsetting,
tapering, deleting, or copying it, or by changing the color of the faces.

You can select individual faces on a 3D solid object or use one of the following
selection methods:

■ Boundary set

■ Crossing polygon

■ Crossing window

■ Fence

Boundary sets are sets of faces defined by a closed boundary, which consists of
lines, circles, arcs, elliptical arcs, and spline curves. When defining a boundary
set on a solid object, you first select an internal point on the solid, highlighting
the face. If you select the same point on the face again, the adjoining face is
highlighted.
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You can also select individual faces or edges with your pointing device or use
a crossing window, an irregular shaped polygon, or a fence that selects faces
or edges that it passes through.

Extrude Faces on 3D Solids

You can extrude planar faces of a 3D solid along a path, or you can specify a
height value and a tapered angle.

You can extrude planar faces along a path, or you can specify a height value
and a tapered angle. Each face has a positive side, which is the side in the
direction of the face’s normal (the current face you’re working on). Entering
a positive value extrudes the face in its positive direction (usually outward);
a negative value extrudes in the negative direction (usually inward).

Tapering the selected face with a positive angle tapers the face inward, and a
negative angle tapers the face outward. The default angle, 0, extrudes the face
perpendicular to its plane. If you specify a large taper angle or a long extrusion
height, you can cause the face to taper to a point before it reaches the extrusion
height; the extrusion is rejected. Face extrusion along a path is based on a
path curve (lines, circles, arcs, ellipses, elliptical arcs, polylines, or splines).

You can also extrude the face of a solid object along the path of a specified
line or curve. All profiles of the selected face extrude along the chosen path
to create the extrusion. You can select lines, circles, arcs, ellipses, elliptical
arcs, polylines, or splines as paths. The path should not lie on the same plane
as the selected face or have areas of high curvature.

To extrude a face on a solid object

1 Click Modify menu ➤ Solids Editing ➤ Extrude Faces.

2 Select the face to extrude (1).

3 Select additional faces or press  ENTER  to extrude.

4 Specify the height of extrusion.

5 Specify a taper angle.

6 Press  ENTER  to complete the command.
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face extrudedface selected

1

To extrude a face along a path on a solid object

1 Click Modify menu ➤ Solids Editing ➤ Extrude Faces.

2 Select the face to extrude (1).

3 Select additional faces or press  ENTER  to extrude.

4 Enter p (Path).

5 Select the object to use as the path (2).

6 Press  ENTER  to complete the command.

face selected path selected face extruded

1

2

Move Faces on 3D Solids

You can edit a 3D solid object by moving selected faces of the object.

The selected faces are moved without their orientation changing. You can
easily move holes from one location to another location in a 3D solid. You
can use Snap mode, coordinates, and object snaps to move the selected faces
with precision.

Modify 3D Solids | 661



To move a face on a solid object

1 Click Modify menu ➤ Solids Editing ➤ Move Faces.

2 Select the face to move (1).

3 Select additional faces or press  ENTER  to move the face.

4 Specify the base point for the move (2).

5 Specify the second point of displacement (3).

6 Press  ENTER  to complete the command.

face selected base point and second
point selected

face moved

1
3

2

Rotate Faces on 3D Solids

You can rotate selected faces or a collection of features on a 3D solid object.

You rotate selected faces or a collection of features on a solid, such as holes,
by choosing a base point and a relative or absolute rotation angle. All 3D faces
rotate about a specified axis. The current UCS and the  system variable setting
determine the direction of the rotation. You can specify the axis of rotation
using two points; an object; the X, Y, or Z axis; or the Z direction with respect
to the line of sight in the current view.

To rotate a face on a solid object

1 Click Modify menu ➤ Solids Editing ➤ Rotate Faces.

2 Select the face to rotate (1).

3 Select additional faces or press  ENTER  to rotate.

4 Enter z for the axis point.

You can also specify the X or Y axis, two points (defines the axis of
rotation), or axis by object (aligns the axis of revolution with an existing
object) to define the axis point. The positive axis direction is from the
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start point to the endpoint, and the rotation follows the right-hand rule,
unless it is reversed by the setting of the ANGDIR system variable.

5 Specify the angle of rotation.

6 Press  ENTER  to complete the command.

face selected rotation point selected face rotated about Z axis
35 deg

1

2

Offset Faces on 3D Solids

On a 3D solid, you can uniformly offset faces by a specified distance.

On a 3D solid, you can uniformly offset faces by a specified distance. New
faces are created by offsetting existing ones inside or outside at a specified
distance from their original positions (offsetting works in the direction of the
face’s normal or the positive side of the surface or face). For example, you can
offset larger or smaller holes on a solid object. Specifying a positive value
increases the size or volume of the solid; a negative value decreases the size
or volume of the solid. You can also use a through point to specify the offset
distance.

To offset a face on a solid object

1 Click Modify menu ➤ Solids Editing ➤ Offset Faces.

2 Select the face to offset (1).

3 Select additional faces or press  ENTER  to offset.

4 Specify the offset distance.

5 Press  ENTER  to complete the command.
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face selected face offset = 1 face offset = -1

1

NOTE Holes inside a solid object offset smaller as the volume of the solid gets
larger.

Taper Faces on 3D Solids

You can taper faces with a draft angle along a vector direction. Tapering the
selected face with a positive angle tapers the face inward, and a negative angle
tapers the face outward. Avoid using extremely large tapered angles. If the
angle is too large, the profile can taper to a point before it reaches the specified
height, and the tapering is rejected.

To taper a face on a solid object

1 Click Modify menu ➤ Solids Editing ➤ Taper Faces.

2 Select the face to taper (1).

3 Select additional faces or press  ENTER  to taper.

4 Specify the base point for the taper (2).

5 Specify the second point along an axis (3).

6 Specify the angle of the taper.

7 Press  ENTER  to complete the command.

face selected base point and second
point selected

face tapered 10 deg

1

2

3
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Delete Faces on 3D Solids

You can remove faces and fillets from a 3D solid object. For example, you can
use  to remove drilled holes or fillets from your 3D solid object.

To delete a face on a solid object

1 Click Modify menu ➤ Solids Editing ➤ Delete Faces.

2 Select the face to delete (1).

3 Select additional faces or press  ENTER  to delete.

4 Press  ENTER  to complete the command.

face selected face deleted

1

Copy Faces on 3D Solids

You can copy faces on a 3D solid object. Selected faces are copied as regions
or bodies. If you specify two points, the first point is used as a base point and
a single copy is placed relative to the base point. If you specify a single point,
and then press  ENTER, the original selection point is used as a base point and
the next point as a point of displacement.

To copy a face on a solid object

1 Click Modify menu ➤ Solids Editing ➤ Copy Faces.

2 Select the face to copy (1).

3 Select additional faces or press  ENTER  to copy.

4 Specify the base point for the copy (2).

5 Specify the second point of displacement (3).

6 Press  ENTER  to complete the command.
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face selected base point and second
point selected

face copied

1

3

2

NOTE Use EXTRUDE to extrude a copied face.

Color Faces on 3D Solids

You can change the color of a selected face on a 3D solid object.

You can select a color from the seven standard colors or select a color from
the Select Color dialog box. When specifying a color, you can enter the name
of the color or an AutoCAD Color Index (ACI) number, an integer from 1
through 255. Setting a color on a face overrides the color setting for the layer
on which the solid object resides. For information about assigning colors, see
“Work with Colors” on page 287.

To change the color of a face on a solid object

1 Click Modify menu ➤ Solids Editing ➤ Color Faces.

2 Select the face whose color you want to change.

3 Select additional faces or press  ENTER.

4 In the Select Color dialog box, select a color. Click OK.

5 Press  ENTER  to complete the command.

Modify Edges of 3D Solids

You can change the color of edges or copy individual edges on a 3D solid
object. Colors are selected from the Select Color dialog box. All 3D solid edges
are copied as lines, arcs, circles, ellipses, or spline objects.
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Color Edges

You can assign colors to individual edges on your 3D solid object. You can
select a color from the seven standard colors or select a color from the Select
Color dialog box. When specifying a color, you can enter the name of the
color or an ACI number, an integer from 1 through 255. Setting a color on an
edge overrides the color setting for the layer on which the solid object resides.
For information about assigning colors, see “Work with Colors” on page 287.

Copy Edges

You can copy individual edges on a 3D solid object. All edges are copied as
lines, arcs, circles, ellipses, or splines. If you specify two points, the first point
is used as a base point and a single copy is placed relative to the base point.
If you specify a single point, and then press  ENTER, the original selection
point is used as a base point and the next point is used as a point of
displacement.

To change the color of an edge on a solid object

1 Click Modify menu ➤ Solids Editing ➤ Color Edges.

2 Select the edge of a face to color.

3 Select additional edges or press  ENTER.

4 In the Select Color dialog box, select a color. Click OK.

5 Press  ENTER  to complete the command.

To copy an edge on a solid object

1 Click Modify menu ➤ Solids Editing ➤ Copy Edges.

2 Select the edge of the face to copy (1).

3 Select additional edges or press  ENTER.

4 Specify the base point for the move (2).

5 Specify the second point of displacement (3).

6 Press  ENTER  to complete the command.
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edge selected base point and second
point selected

edge copied

1

3

2

Imprint 3D Solids

You can create new faces on 3D solids by imprinting arcs, circles, lines, 2D
and 3D polylines, ellipses, splines, regions, bodies, and 3D solids. For example,
if a circle intersects with a 3D solid, you can imprint the intersecting curves
on the solid. You can delete or retain the original imprinted objects to be used
for further editing. The imprinted object must intersect a face or faces on the
selected solid in order for the imprinting to be successful.

To imprint a 3D solid object

1 Click Modify menu ➤ Solids Editing ➤ Imprint.

2 Select the 3D solid object (1).

3 Select the object that you want to imprint (2).

4 Press  ENTER  to retain the original objects, or enter y to delete them.

5 Select additional objects to imprint or press  ENTER.

6 Press  ENTER  to complete the command.

solid selected object selected object imprinted on
solid

1

2

668 | Chapter 26   Change Existing Objects



Separate 3D Solids

You can separate (take apart) composite solids. The composite 3D solid object
cannot share a common area or volume. After separation of the 3D solid, the
individual solids retain the layers and colors of the original. All nested 3D
solid objects are separated into their simplest form.

To separate a 3D solid composite into individual solids

1 Click Modify menu ➤ Solids Editing ➤ Separate.

2 Select the 3D solid object.

3 Press  ENTER  to complete the command.

Shell 3D Solids

You can create a shell (a hollow, thin wall with a specified thickness) from
your 3D solid object. New faces are created by offsetting existing ones inside
or outside their original positions. Continuously tangent faces are treated as
single faces when offsetting.

To create a 3D solid shell

1 Click Modify menu ➤ Solids Editing ➤ Shell.

2 Select the 3D solid object.

3 Select a face to be excluded from shelling (1).

4 Select additional faces to be excluded or press  ENTER.

5 Specify the shell offset valve.

A positive offset value creates a shell in the positive face direction; a
negative value creates a shell in the negative face direction.

6 Press  ENTER  to complete the command.
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face selected shell offset=0.5 shell offset=-0.5

1

Clean and Check 3D Solids

You can remove edges or vertices if they share the same surface or vertex
definition on either side of the edge or vertex. The body, faces, or edges on
the solid object are checked, and adjacent faces that share the same surface
are merged. All redundant edges, imprinted as well as unused, on your 3D
solid object are deleted.

You can check to see if your solid object is a valid 3D solid object. With a valid
3D solid, you can modify the object without incurring failure error messages.
If the 3D solid is not valid, you cannot edit the object.

To clean up a 3D solid object

1 Click Modify menu ➤ Solids Editing ➤ Clean.

2 Select the 3D solid object (1).

3 Press  ENTER  to complete the command.

solid selected solid cleaned

1

To validate a 3D solid object

1 Click Modify menu ➤ Solids Editing ➤ Check.
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2 Select the 3D solid object.

3 Press  ENTER  to complete the command.

A message states that the solid is a valid ShapeManager solid.

Modify 3D Solids | 671



672



Part 6
Hatches, Notes, Tables, and
Dimensions

Chapter 21 Hatches, Fills, and Wipeouts

Chapter 22 Notes and Labels

Chapter 23 Tables

Chapter 24 Dimensions and Tolerances

673



674



Hatches, Fills, and
Wipeouts

 

22
In this chapter

■ Overview of Hatch Patterns
and Fills

■ Define Hatch Boundaries

■ Choose Hatch Patterns and
Solid Fills

■ Modify Hatches and Solid-Filled
Areas

■ Create a Blank Area to Cover
Objects



Overview of Hatch Patterns and Fills
Define the Boundaries of a Hatch

You can choose from several methods to specify the boundaries of a hatch.

■ Specify a point in an area that is enclosed by objects.

■ Select objects that enclose an area.

■ Drag a hatch pattern into an enclosed area from a tool palette or
DesignCenter.

When you hatch a drawing, whole or partial objects that are not part of the
object boundary are ignored.

If a hatch line encounters an object such as text, an attribute, or a solid-fill
object, and if the object is selected as part of the boundary set, HATCH hatches
around the object.

Autodesk Autodesk

text object not part
of the boundary set

text object included
in the boundary set

NOTE If you want to hatch an area whose boundary is not quite closed, you can
set the  system variable to bridge gaps and treat the boundary as closed. HPGAPTOL
applies only to gaps between lines and arcs that, if extended, would meet.

To reduce file size, a hatched area is defined in the drawing database as a single
graphical object.

Add Hatch Patterns and Solid Fills

You can use several methods to add hatch patterns to your drawing.

■ The  command provides the most options.

■ You can drag hatches from a tool palette. Use tool palettes when you need
additional speed and convenience.

With the Tool Palettes window open, you can right-click a pattern tool to
access the Tool Properties dialog box from the shortcut menu. This dialog
box contains several hatch pattern options that are also available through

676 | Chapter 28   Hatches, Fills, and Wipeouts



HATCH. For example, you can specify the scale and spacing for the hatch
pattern.

■ You can also use DesignCenter.

Control the Hatch Origin

By default, hatch patterns always “line up” with each other. However,
sometimes you might need to move the starting point, called the origin point,
of the hatch. For example, if you create a brick pattern, you might want to
start with a complete brick in the lower-left corner of the hatched area. In
that case, use the Hatch Origin options in the Hatch and Gradient dialog box.

default hatch origin new hatch origin

The location and behavior of a hatch pattern depends on the , , and  system
variables, and the location and orientation of the user coordinate system.

Choose a Hatch Pattern

The program supplies a solid fill and more than 50 industry-standard hatch
patterns that you can use to differentiate the components of objects or
represent object materials. The program also comes with 14 hatch patterns
that conform to the ISO (International Standards Organization) standards.
When you select an ISO pattern, you can specify a pen width, which
determines the lineweight in the pattern.

On the Hatch tab of the Hatch and Gradient dialog box, the Type and Pattern
area displays the names of all the hatch patterns defined in the acad.pat text
file. You can add new hatch patterns to the dialog box by adding their
definitions to the acad.pat file.

Create Associative Hatches

An associative hatch is updated when you change the boundary. Hatched areas
created with HATCH are associative by default. This setting is stored in the
system variable . Hatches created by dragging hatch patterns from tool palettes
or DesignCenter™ use the setting in HPASSOC. You can remove hatch
associativity at any time or use  to create a nonassociative hatch. When the
HPGAPTOL system variable is set to 0 (the default), associativity is
automatically removed if editing creates an open boundary.

You can use HATCH to create nonassociative hatches, which are independent
of their boundaries.
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hatched object result of editing
boundary with
nonassociative hatch

result of editing
boundary with
associative hatch

Assign a Draw Order to a Hatch

You can assign a draw order to a hatch so that it is drawn either behind or in
front of the hatch boundary, or behind or in front of all other objects.

When you create a hatch, by default the hatch is drawn behind the hatch
boundary. This makes it easier to view and select the hatch boundary. You
can change the draw order of the hatch so that the hatch is drawn in front of
the hatch boundary instead, or either behind or in front of all other objects.
This setting is stored in the system variable. Hatches created by dragging hatch
patterns from tool palettes or DesignCenter use the draw order setting in
HPDRAWORDER.

Limit Hatch Pattern Density

If you create a very dense hatch, the program may reject the hatch and display
a message indicating that the hatch scale is too small or its dash length too
short. You can change the maximum number of hatch lines by setting the
MaxHatch system registry variable at the Command prompt by entering
(setenv “MaxHatch” “n”) where n is a number between 100 and 10000000
(ten million). The default value for MaxHatch is 10000.

NOTE When changing the value of MaxHatch, you must enter MaxHatch with
the capitalization as shown.

Edit Hatch Boundaries

Because there are so many combinations of objects that can be hatched, editing
hatched geometry can produce unexpected results. If you create a hatch that
you don't want, you can undo it, trim the hatch, or delete the hatch and
rehatch the area.

678 | Chapter 28   Hatches, Fills, and Wipeouts



Create Custom Hatch Patterns

You can also define your own hatch pattern using the current linetype with
the User Defined Pattern option of the Hatch and Gradient dialog box, or you
can create more complex hatch patterns.

See also:

“Modify Hatches and Solid-Filled Areas” on page 693
“Overview of Hatch Pattern Definitions” in the Customization Guide

To drag hatch patterns into your drawing

1 Click Tools menu ➤ DesignCenter.

NOTE This procedure describes how to use DesignCenter to drag hatch
patterns into your drawing. You can also drag hatch patterns from a tool
palette.

2 On the Folders tab, click the Search button.

3 In the Search dialog box, make the following entries:

■ In Look For, select Hatch Pattern Files.

■ In the In box, select the drive where the program is installed.

■ Select the Search Subfolders option.

■ On the Hatch Pattern Files tab, in Search for the Name, enter *
(asterisk).

4 Click Search Now.

The default hatch pattern file is acad.pat or acadiso.pat. The search results
may display the same file in different locations.

NOTE For convenient access, you can add the PAT file to Favorites by
selecting the file and clicking the Favorites button. A shortcut to the PAT file
is displayed in the Favorites folder on the Folders tab in DesignCenter.

5 In the search results, double-click the file to load the hatch patterns into
the content area of DesignCenter.

6 (Optional) Right-click a pattern to display a shortcut menu with the
following options:

■ HATCH. Opens the Hatch and Gradient dialog box.

■ Copy. Stores the hatch pattern to the Clipboard.
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■ Create Tool Palette. Creates a new tool palette with the selected
pattern displayed.

7 From the content area, drag a hatch pattern onto a closed object in your
drawing or onto a tool palette.

NOTE If the hatch pattern scale is too large or small, an error message is
displayed. You can adjust the scale for any hatch pattern by double-clicking
it to display the Hatch and Gradient dialog box.

Standard toolbar

To hatch areas

1 Click Draw menu ➤ Hatch.

2 In the Hatch and Gradient dialog box, click Add: Pick points.

3 In your drawing, specify a point inside each area that you want hatched,
and then press  ENTER .

This point is known as the internal point.

4 In the Hatch and Gradient dialog box, Hatch tab, in the swatch box,
verify that the sample pattern is the pattern you want to use. To change
patterns, select another pattern from the Pattern list.

To see how the hatch pattern will look, click the [...] button next to
Pattern. Click OK when you finish previewing.

5 In the Hatch and Gradient dialog box, make adjustments, if necessary.

You can specify new hatch boundaries by clicking Add Boundaries or
Remove Boundaries.

6 Under Draw Order, click one of the options.

You can change the draw order of the hatch so that the hatch is drawn
either behind or in front of the hatch boundary, or behind or in front
of all other objects.

7 Click OK.

Draw toolbar
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To hatch selected objects

1 Click Draw menu ➤ Hatch.

2 In the Hatch and Gradient dialog box, click Add: Select objects.

3 Specify the object or objects you want to hatch.

The objects need not form a closed boundary. You can also specify any
islands that should remain unhatched. Also, you can set the HPGAPTOL
system variable to treat a set of objects that almost enclose an area as a
closed hatch boundary.

4 Under Draw Order, click one of the options.

You can change the draw order of the hatch so that the hatch is drawn
either behind or in front of the hatch boundary, or behind or in front
of all other objects.

5 Click OK.

Draw toolbar

Define Hatch Boundaries
You create a hatch by selecting an object to hatch or fill, or by defining a
boundary and then specifying an internal point.

Overview of Hatch Boundaries

You can hatch an enclosed area or hatch within a specified boundary using
. By default, HATCH creates associative hatches that are updated when the
boundary is changed.

You create a hatch by selecting an object to hatch or by defining a boundary
and then specifying an internal point. A hatch boundary can be any
combination of objects, such as lines, arcs, circles, and polylines, that forms
an enclosed area.

Enclosed areas within the hatch area are referred to as islands. You can hatch
them or leave them unhatched depending on the Islands setting in the Hatch
and Gradient dialog box.

If you are hatching a small area in a complex drawing, you can use boundary
sets to speed the process.
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Objects can be hatched only if they are in a plane parallel to the XY plane of
the current UCS.

NOTE If you want to hatch an area that is not completely enclosed, you can set
a gap tolerance ( system variable). Any gaps equal to or smaller than the value
you specify in the gap tolerance are ignored, and the boundary is treated as closed.

Control the Hatching in Islands

You can determine how islands, enclosed areas within the hatch boundary,
are hatched using the three hatching styles: Normal, Outer, and Ignore. You
can preview these hatching styles in the More Options area of the Hatch and
Gradient dialog box.

Normal hatching style (the default) hatches inward from the outer boundary.
If the hatching process encounters an internal boundary, hatching is turned
off until another boundary is encountered.

If you hatch using the Normal hatching style, islands remain unhatched and
islands within islands are hatched, as shown below.

internal point selected boundaries detected result

internal point

Outer hatching style hatches inward from the outer boundary and stops at
the next boundary.

Ignore hatching style hatches the entire enclosed area, ignoring internal
boundaries.
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Normal Outer Ignore

You can also remove any islands from the hatch area.

boundaries detected islands to remove
(soild boundaries)

result

internal point

See also:

“Modify Hatches and Solid-Filled Areas” on page 693

To remove islands from the hatch area

1 Click Draw menu ➤ Hatch.

2 In the Hatch and Gradient dialog box, after adding one or more
boundaries, click Remove Boundaries.

3 Select the boundaries that you want to remove and press ENTER.

4 In the Hatch and Gradient dialog box, click OK to apply the hatch.

Draw toolbar
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Define Hatch Boundaries in Large Drawings

You can save time hatching a small area in a complex drawing by defining a
set of objects in the drawing to be used in determining the hatch boundary.

By default, HATCH defines the boundary by analyzing all closed objects in
the drawing. Analysis of all objects fully or partially visible on the screen as
boundaries can be time consuming in a complex drawing. To hatch a small
area of a complex drawing, you can define a set of objects in the drawing
called a boundary set. HATCH does not analyze objects that are not included
in the boundary set.

For clarity, first zoom into the area you want to hatch.

area for
hatching

The View Selections option in the Hatch and Gradient dialog box, highlights
the objects in the drawing that define the boundary.

To define a boundary set in a complex drawing

1 Click Draw menu ➤ Hatch.

2 In the Hatch and Gradient dialog box, More Options, under Boundary
Set, click New.

3 At the Select Objects prompt, specify opposite corner points for the
boundary set and press  ENTER .

If you use crossing selection by specifying points from right to left, you
select all objects enclosed or crossed.
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4 In the Hatch and Gradient dialog box, click Add Boundary. If necessary,
enter k to specify the Pick Internal Point option.

5 Specify the internal point.

6 Click OK to apply the hatch.

21

new boundary set internal point result

Draw toolbar

Create Unbounded Hatches

There are several methods you can use to create a hatch that does not display
a hatch boundary.

■ You can create a hatch with , and then erase some or all of the boundary
objects.

■ You can create a hatch with , making sure that the boundary objects are
on a different layer than the hatch. Then turn off or freeze the layer of the
boundary objects. This is the only method that maintains hatch
associativity.

■ You can trim an existing hatch with objects created as trim boundaries.
After trimming the hatch, erase the objects.

■ You can define a hatch boundary with the Draw option of  on the command
line by specifying boundary points.

For example, you might want to show that a large area of a drawing is filled
with a pattern by filling only a small section of that area, as shown in the
following illustration.
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points specified to define hatch
boundary

result

You can choose whether to retain the polyline boundary after the hatch is
created; here, the polyline boundary is not retained.

To define a boundary by specifying points

1 At the Command prompt, enter -hatch.

2 Enter the desired pattern. For example, enter earth to select the EARTH
pattern.

3 Specify the scale and angle for the pattern.

4 Enter w to specify the Draw option.

5 Specify points to define the boundary. Enter c to close the polyline
boundary, and then press  ENTER.

6 Enter n to discard the polyline boundary once the hatch area has been
defined, or enter y to create a polyline.

Choose Hatch Patterns and Solid Fills
You can use a predefined hatch pattern or solid fill, or you can create your
own hatch patterns.

Create Solid-Filled Areas

Solid-filled areas can be created using

■ Hatches with a solid hatch pattern ()

■ 2D solids ()

■ Wide polylines or donuts (, )
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solid filled areas

See also:

“Overview of Hatch Patterns and Fills” on page 676
“Modify Hatches and Solid-Filled Areas” on page 693
“Draw Polylines” on page 391
“Draw Donuts” on page 413

To create a hatch with a solid pattern

1 Click Draw menu ➤ Hatch.

2 In the Hatch and Gradient dialog box, click Add: Pick points.

3 Specify a point in your drawing inside each area that you want hatched.

This point is known as the internal point.

4 Press  ENTER .

5 In the Hatch and Gradient dialog box, Hatch tab, under Type, click
Predefined.

6 Click the [...] button next to Pattern.

7 In the Hatch Pattern Palette dialog box, Other Predefined tab, select
Solid. Click OK.

8 To see how the hatch pattern will look, click Preview.

9 When you finish previewing the hatch pattern, right-click or press
ENTER  to apply the hatch, or press any other button or key to return
to the Hatch and Gradient dialog box.

10 In the Hatch and Gradient dialog box, make adjustments, if necessary.
(You can specify new hatch boundaries by clicking Add Boundaries or
Remove Boundaries.)

11 Click OK.

Draw toolbar
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To create a 2D solid object

1 At the Command prompt, enter solid.

2 Specify the first point.

3 Specify the second point, moving left to right.

4 Continue to specify points. Press  ENTER  when the object is complete.

When you create a quadrilateral solid-filled area, the sequence of the
third and fourth points determines its shape. Compare the following
illustrations:

1 2

3 4 4 3

21

Notice that to create the quadrilateral area, both the top and bottom
edges are specified from left to right. If you specify the first point on the
right and the second point on the left, then the third and fourth points
should also be in a right-to-left direction. As you continue to specify
pairs of points, be sure to continue this zigzag sequence to ensure the
results you expect.

To create a wide polyline

1 Click Draw menu ➤ Polyline.

2 Specify the start point of the line segment.

3 Enter w (Width).

4 Enter the starting width of the line segment.

5 Specify the ending width of the line segment using one of the following
methods:

■ To create a line segment of equal width, press  ENTER .

■ To create a tapering line segment, enter a different width.
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6 Specify the endpoint of the polyline segment.

7 Continue specifying segment endpoints as needed.

8 Press  ENTER  to end, or enter c to close the polyline.

Draw toolbar

To create a donut

1 Click Draw menu ➤ Donut.

2 Specify the inside diameter (1).

3 Specify the outside diameter (2).

4 Specify the center of the donut (3).

5 Specify the center point for another donut, or press  ENTER  to complete
the command.

2

1

3

Create Gradient-Filled Areas

A gradient fill is a solid hatch fill that gives the blended-color effect of a surface
with light on it. You can use gradient fills to suggest a solid form in
two-dimensional drawings.

The color in a gradient fill makes a smooth transition from light to dark, or
from dark to light, and back. You select a predefined pattern (for example,
linear, spherical, or radial sweep) and specify an angle for the pattern. In a
two-color gradient fill, the transition is both from light to dark and from the
first color to the second.

Gradient fills are applied to objects in the same way solid fills are and can be
associated with their boundaries or not. An associated fill is automatically
updated when the boundary changes.
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You cannot use plot styles to control the plotted color of gradient fills.

Double-click a gradient fill to modify it.

To create a one-color gradient fill

1 Click Draw menu ➤ Hatch.

2 In the Hatch and Gradient dialog box, click Add: Pick points or Add:
Select objects.

3 Specify an internal point or select an object, and then press  ENTER .

4 In the Hatch and Gradient dialog box, Gradient tab, select One Color.

5 If you want to change the color, click the [...] button next to the color.

6 In the Select Color dialog box, use the Shade/Tint slider to adjust the
color.

■ Move the slider toward Tint to create a color transition that moves
toward white.

■ Move the slider toward Shade to create a transition that moves toward
black.

7 Click a pattern, and set the following options:

■ Select Center to create a symmetrical fill, or clear Center to move the
“highlight” up and to the left.

■ Specify an angle for the “highlighted” area.

8 To see how the gradient fill will look, click Preview. Press  ENTER  or
right-click to return to the dialog box and make adjustments.

9 When you are satisfied, in the Hatch and Gradient dialog box, click OK
to create the gradient fill.

Draw toolbar

To create a two-color gradient fill

1 Click Draw menu ➤ Hatch.

2 In the Hatch and Gradient dialog box, click Add: Pick points or Add:
Select objects.
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3 Specify an internal point or select an object, and then press  ENTER .

4 In the Hatch and Gradient dialog box, Gradient tab, select Two Color.

The second color is the color of the highlighted area in the gradient fill.

5 If you want to change either color, click the [...] button next to the color
to open the Select Color dialog box.

6 Click a pattern, and set the following options:

■ Select Center to create a symmetrical fill, or clear Center to move the
“highlight” up and to the left.

■ Specify an angle for the “highlighted” area.

7 To see how the gradient fill will look, click Preview. Press  ENTER  or
right-click to return to the dialog box and make adjustments.

8 When you are satisfied, in the Hatch and Gradient dialog box, click OK
to create the gradient fill.

Draw toolbar

To modify a gradient fill

■ Double-click a gradient fill to modify it.

Use Predefined Hatch Patterns

The program supplies a solid fill and more than 50 industry-standard hatch
patterns, which can represent materials such as earth, brick, or clay.

Fourteen hatch patterns conform to International Standards Organization
(ISO) standards. When you select an ISO pattern, you can specify a pen width,
which determines the lineweight in the pattern.

In addition to using the patterns supplied with the program, you can use
patterns from an external pattern library. These patterns are listed by name
and are displayed in the Hatch Pattern Palette dialog box.

To use a predefined hatch pattern

1 Click Draw Menu ➤ Hatch
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2 In the Hatch and Gradient dialog box, click Add: Pick points or Add:
Select objects.

3 Specify an internal point or select an object.

4 In the Hatch and Gradient dialog box, Hatch tab, select Predefined in
the Type box.

5 From the Pattern box, select a pattern.

6 Click OK.

Draw toolbar

Create User-Defined Hatch Patterns

In addition to using predefined hatch patterns, you can define a simple hatch
pattern based on the current linetype. You define the pattern by changing
the angle and spacing of the hatch lines.

To create a user-defined hatch pattern

1 Specify the linetype for the user-defined hatch pattern by making that
linetype current.

2 Click Draw Menu ➤ Hatch.

3 In the Hatch and Gradient dialog box, click Add: Pick points or Add:
Select objects.

4 Specify an internal point or select an object.

5 In the Hatch and Gradient dialog box, Hatch tab, select User-Defined in
the Type box.

6 Specify the angle and spacing of the hatch pattern.

7 To use intersecting lines in the pattern, select Double.

8 Click OK.

Draw toolbar
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Modify Hatches and Solid-Filled Areas
You can modify both the pattern fill and the boundaries of hatches. You can
also modify solid-filled areas, but the method you use depends on whether
the solid-filled area is a solid-filled hatch, a 2D solid, or a wide polyline or
donut. You can also modify the draw order of your hatch.

Control Hatch Pattern Density

Hatching can produce a very large number of line and point objects. Although
stored as hatch objects, these line and point objects do use disk space and take
time to generate. If you use a relatively small scale factor when hatching an
area, the hatch could require millions of line and point objects, thus taking
a very long time to complete and possibly exhausting the available resources.
You can avoid this problem by imposing a limit on the number of objects
created by a single  command. If the approximate number of objects needed
for a particular hatch (considering the boundary extents, pattern, and scale)
exceeds the limit, HATCH displays a message indicating that the hatch scale
is too small or that its dash length is too short, and the hatch request is
rejected. If this occurs, carefully examine your hatch settings. The scale factor
may be unreasonable and may need to be adjusted.

The hatch object limit is set by the MaxHatch environment setting, which is
stored in the system registry. Its default value is 10000. You can change this
limit by setting the MaxHatch system registry variable using (setenv
”MaxHatch” “n”) where n is a number between 100 and 10000000 (ten
million).

Change the Hatch Properties of an Existing Hatch

You can modify hatch-specific properties, such as pattern, scale, and angle,
of an existing hatch. You can use the following:

■ Hatch Edit dialog box (recommended)

■ Properties palette

You can also copy properties from one hatch to another. With the Inherit
Properties button in the Hatch Edit dialog box, you can copy all hatch-specific
properties, including the hatch origin, from one hatch to another. Use the
Match Properties dialog box to copy general properties and hatch-specific
properties (with the exception of the hatch origin), from one hatch to another.

You can use  to disassemble a hatch into its component objects.
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Modify a Hatch Boundary

Hatch boundaries can be copied, moved, stretched, trimmed, and so on. You
can also use grips to stretch, move, rotate, scale, and mirror hatch boundaries
and their associated hatches just as you do other objects. If the editing you
do maintains a closed boundary, an associative hatch is updated automatically.
If the editing produces an open boundary, the hatch loses any associativity
with the boundary and remains unchanged. Associativity may also be lost
during editing of a hatch boundary if the hatch pattern file is not available
at the time of editing.

NOTE If you trim a hatch area to create a hole within it, the hole is not the same
as a hatch island and the hatch loses associativity. To create an island instead,
delete the existing hatch and create a new hatch with the new boundary. Also, if
you trim a hatch and the hatch pattern (PAT) file is no longer available, the hatch
will disappear.

Hatch associativity depends on whether you choose Associative in the Hatch
and Gradient (HATCH) and Hatch Edit () dialog boxes. Nonassociative hatches
are not updated when their original boundary is changed.

You can remove hatch associativity at any time, but once it is removed for an
existing hatch, it cannot be reestablished. The hatch must be re-created to
restore associativity or a new hatch boundary must be created and associated
with the hatch.

To create a boundary around a nonassociative or unbounded hatch, in the
Hatch and Gradient dialog box, use the Recreate Boundary option. With this
option you can also specify that the new boundary is associated with the
hatch.

Modify Solid-Filled Areas

Solid-filled areas can be represented by

■ Hatches (with a solid hatch pattern)

■ 2D solids

■ Gradient fills

■ Wide polylines or donuts

You modify each of these solid-filled objects just as you would any other
hatch, 2D solid, wide polyline, or donut. In addition to , you can use
HATCHEDIT for solid-filled hatches and gradient fills, grip editing for 2D
solids, and  for wide polylines and donuts.
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Modify the Draw Order of a Hatch

When you edit a hatch, you can change its draw order, so that it is displayed
behind the hatch boundary, in front of the hatch boundary, behind all other
objects, or in front of all other objects.

To change the angle of a hatch

1 Select the hatch pattern.

2 Right-click the hatch. Click Properties.

3 In the Properties palette, enter the new value for Angle.

Standard toolbar

To set the limit of objects in a hatch pattern

■ At the Command prompt, enter (setenv “MaxHatch” “n”)

where n is a number between 100 and 10000000 (ten million). The higher the
value, the more dense the hatch pattern.

NOTE MaxHatch is case-sensitive.

To modify a gradient fill

1 Double-click the gradient fill you want to modify.

2 In the Hatch Edit dialog box, Gradient tab, make any changes.

3 To see how the gradient fill will look, click Preview. Press  ENTER  or
right-click to return to the dialog box and make adjustments.

4 When you are satisfied, in the Hatch and Gradient dialog box, click OK
to create the gradient fill.

Create a Blank Area to Cover Objects
A wipeout object is a polygonal area that masks underlying objects with the
current background color. This area is bounded by the wipeout frame, which
you can turn on for editing and turn off for plotting.
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You can create a wipeout object by specifying a polygonal area with a series
of points, or you can convert a closed polyline into a wipeout object.

Requirements and Limitations

If a polyline is used to create a wipeout object, the polyline must be closed,
contain line segments only, and have zero width.

You can create wipeout objects on a layout in paper space to mask objects in
model space; however, on the Plot Settings tab of the Plot dialog box, the Plot
Paper Space Last option must be cleared before you plot to ensure that the
wipeout object is plotted correctly.

Because a wipeout object is similar to a raster image, it has the same
requirements for plotting: you need a raster-capable plotter with either an
ADI 4.3 raster-capable driver or the system printer driver.

To cover existing objects with a blank area

1 Click Draw menu ➤ Wipeout.

2 Specify points in a sequence that defines the perimeter of the area to be
masked.

3 Press ENTER to end.

To turn all wipeout frames on or off

1 Click Draw menu ➤ Wipeout.

2 On the command line, enter f (Frames).

3 Enter on or off and press  ENTER .
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Notes and Labels

 
You can create and modify several types of text, including

text with leaders. You can control most text style settings by

defining text styles.

23
In this chapter

■ Overview of Notes and Labels

■ Create Text

■ Use Fields in Text

■ Work with Text Styles

■ Change Text

■ Check Spelling

■ Use an Alternate Text Editor



Overview of Notes and Labels
You can create text in various ways. For short, simple entries, use single-line
text. For longer entries with internal formatting, use multiline text (also called
mtext). You can also create multiline text with leaders.

Although all entered text uses the current text style, which establishes the
default font and format settings, you can use several methods to customize
the text appearance. There are several tools that can change text scale and
justification, find and replace text, and check for spelling errors.

Text that is included in a dimension or tolerance is created using the
dimensioning commands.

Create Text
You can create text using several methods, depending on your needs.

See also:

“Use Fields in Text” on page 725

Overview of Creating Text and Leaders

The text you add to your drawings conveys a variety of information. It may
be a complex specification, title block information, a label, or even part of
the drawing.

Single-Line Text

For short entries that do not require multiple fonts or lines, create single-line
text. Single-line text is most convenient for labels.

Multiline Text

For long, complex entries, create multiline, or paragraph text. Multiline text
consists of any number of text lines or paragraphs that fit within a width you
specify; it can extend vertically to an indefinite length.

Regardless of the number of lines, each set of paragraphs created in a single
editing session forms a single object, which you can move, rotate, erase, copy,
mirror, or scale.

There are more editing options for multiline text than there are for single-line
text. For example, you can apply underlining, fonts, color, and text height
changes to individual characters, words, or phrases within a paragraph.
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Leader Objects

A leader object is a line or a spline with an arrowhead at one end and a
multiline text object at the other. The leader object is associated with the
multiline text object, so when the text object is moved, rotated, or scaled, the
leader object is updated accordingly. Similarly, when associative dimensioning
is turned on, and object snaps are used to locate the leader arrowhead, a leader
object is also associated with any objects to which the arrowhead is attached.

You can copy text used elsewhere in a drawing and append a leader to it.

NOTE The leader object should not be confused with the leader line that is
automatically generated as part of a dimension line.

Create Single-Line Text

Use single-line text () to create one or more lines of text, ending each line
when you press ENTER. Each text line is an independent object that you can
relocate, reformat, or otherwise modify.

When you create single-line text, you assign a text style and set alignment.
The text style sets the default characteristics of the text object. The alignment
determines what part of the text character aligns with the insertion point. Use
the TEXT command to enter the text in-place, or enter -text on the command
line to enter the text on the command line.

You can insert a field in single-line text. A field is text that is set up to display
data that might change. When the field is updated, the latest value of the field
is displayed.

The text styles used for single-line text are the same as those used for multiline
text. When you create text, you assign an existing style by entering its name
at the Style prompt. If you need to apply formatting to individual words and
characters, use multiline text instead of single-line text.

You can also compress single-line text to fit between points that you specify.
This option stretches or squeezes the text to fill the designated space.

Align Single-Line Text

As you create text, you can align it. That is, you can justify it with one of the
alignment options shown in the following illustrations. Left alignment is the
default. To left-align text, do not enter an option at the Justify prompt.
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TR (top right)

MR (middle right)

BR (bottom right)

TL (top left)

ML (middle left)

BL (bottom left)

TC (top center)

MC (middle center)

BC (bottom center)

right-justified text

left-justified text

center-justified text

middle-justified text
fit-justified
text

See also:

“Use Fields in Text” on page 725

To create single-line text

1 Click Draw menu ➤ Text ➤ Single Line Text.
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2 Specify the insertion point for the first character. If you press ENTER,
the program locates the new text immediately below the last text object
you created, if any.

3 Specify the height of the text. This prompt is displayed only if text height
is set to 0 in the current text style.

A rubber-band line is attached from the text insertion point to the cursor.
Click to set the height of the text to the length of the rubber-band line.

4 Specify a text rotation angle.

You can enter an angle value or use your pointing device.

5 Enter the text. At the end of each line, press ENTER. Enter more text as
needed.

If you specify another point during this command, the cursor moves to
that point, and you can continue typing. Every time you press ENTER
or specify a point, a new text object is created.

6 Press ENTER on a blank line to end the command.

To specify a text style when you create single-line text

1 Click Draw menu ➤ Text ➤ Single Line Text.

2 Enter s (Style).

3 At the Style Name prompt, enter an existing text style name.

If you first want to see a list of text styles, enter ? and press ENTER twice.

4 Continue creating text.

To align single-line text as you create it

1 Click Draw menu ➤ Text ➤ Single Line Text.

2 Enter j (Justify).

3 Enter an alignment option. For example, enter br to align text at its
bottom-right corner.

4 Continue creating text.

Create Multiline Text

A multiline text (mtext) object includes one or more paragraphs of text that
can be manipulated as a single object.
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Overview of Multiline Text

You can create one or more paragraphs of multiline text (mtext) in the In-Place
Text Editor (or an alternative text editor) or use prompts on the command
line. You can also insert text from a file saved in ASCII or RTF format.

Before entering or importing text, you specify opposite corners of a text
bounding box that defines the width of the paragraphs in the multiline text
object. The length of the multiline text object depends on the amount of text,
not the length of the bounding box. You can use grips to move or rotate a
multiline text object.

The In-Place Text Editor displays the bounding box with a ruler at the top
and the Text Formatting toolbar. The editor is transparent so that, as you
create text, you can see whether the text overlaps other objects. To turn off
transparency while you work, check Opaque Background on the Options
menu. You can also make the background of the finished multiline text object
opaque and set its color.

You can set tabs and indent text to control the appearance of paragraphs in
the multiline text object.

You can also insert fields in multiline text. A field is text that is set up to
display data that might change. When the field is updated, the latest value of
the field is displayed.

Text Style

Most characteristics of the text are controlled by the text style, which sets the
default font and other options, such as line spacing, justification, and color.
You can use the current text style or select a new one. The STANDARD text
style is the default.

Within the multiline text object, you can override the current text style by
applying formatting such as underlining, boldface, and different fonts to
individual characters. You can also create stacked text, such as fractions or
geometric tolerances and insert special characters, including Unicode
characters, for TrueType fonts.

NOTE Not all SHX and TrueType text fonts support Unicode characters.

Text Properties

In the Properties palette, you can view and change the object properties of a
multiline text object, including properties that apply specifically to text:

■ Justification determines where text is inserted with respect to the bounding
box and sets the direction of text flow as text is entered.
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■ Line space options control the amount of space between lines of text.

■ Width defines the width of the bounding box and therefore controls where
the text wraps to a new line.

■ Background inserts an opaque background so that objects under the text
are masked.

To create multiline text

1 Click Draw menu ➤ Text ➤ Multiline Text.

2 Specify opposite corners of a bounding box to define the width of the
multiline text object.

The In-Place Text Editor is displayed.

3 To indent the first line of each paragraph, drag the first-line indent slider
on the ruler. To indent the other lines of each paragraph, drag the
paragraph slider.

4 To set tabs, click the ruler where you want a tab stop.

5 If you want to use a text style other than the default, click the arrow
next to the Text Style control on the toolbar and then select a style.

6 Enter text.

7 To override the current text style, select text as follows:

■ To select one or more letters, click and drag the pointing device over
the characters.

■ To select a word, double-click the word.

■ To select a paragraph, triple-click the paragraph.

8 On the toolbar, make format changes as follows:

■ To change the font of the selected text, select a font from the list.

■ To change the height of the selected text, enter a new value in the
Height box.

■ To format text in a TrueType font with boldface or italics, or to create
underlined or overlined text for any font, click the corresponding
button on the toolbar. SHX fonts do not support boldface or italics.

■ To apply color to selected text, choose a color from the Color list.
Click Other to display the Select Color dialog box.

Create Text | 703



9 To save your changes and exit the editor, use one of the following
methods:

■ Click OK on the toolbar.

■ Click in the drawing outside the editor.

■ Press  CTRL +  ENTER .

Draw toolbar

To insert symbols or special characters in multiline text

1 Double-click a multiline text object to open the In-Place Text Editor.

2 On the expanded toolbar, click Symbol.

3 Click one of the options on the menu, or click Other to display the
Character Map dialog box.

To access the Character Map dialog box, you must have charmap.exe
installed. See Microsoft®  Windows® Help for information about adding
programs to your system.

4 In the Character Map dialog box, select a font.

5 Select a character, and use one of the following methods:

■ To insert a single character, drag the selected character into the editor.

■ To insert multiple characters, click Select to add each character to the
Characters to Copy box. When you have all the characters you want,
click Copy. Right-click in the editor. Click Paste.

6 To save your changes and exit the editor, use one of the following
methods:

■ Click OK on the toolbar.

■ Click in the drawing outside the editor.

■ Press  CTRL +  ENTER .

Draw toolbar
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To add an opaque background or fill to a multiline text object

1 Double-click a multiline text object to open the In-Place Text Editor.

2 In the editor, right-click. Click Background Mask.

3 In the Background Mask dialog box, select Use Background Mask.

4 Enter a value for Border Offset Factor.

The value is based on the text height. A factor of 1.0 exactly fits the
multiline text object. A factor of 1.5 (the default) extends the background
by 0.5 times the text height.

5 Under Fill Color, do one of the following:

■ Select the Use Drawing Background Color option.

■ Select a color for the background, or click Select Color to open the
“Select Color Dialog Box”.

6 Click OK to return to the editor.

7 To save your changes and exit the editor, use one of the following
methods:

■ Click OK on the toolbar.

■ Click in the drawing outside the editor.

■ Press  CTRL +  ENTER .

The opaque background is applied when you exit the editor.

Draw toolbar

Justify Multiline Text

Justification controls both text alignment and text flow relative to the text
insertion point. Text is left-justified and right-justified with respect to the
boundary rectangle that defines the text width. Text flows from the insertion
point, which can be at the middle, the top, or the bottom of the resulting text
object.

There are nine justification settings for multiline text.

If a single word is longer than the width of the paragraph, the word will extend
beyond the paragraph boundary.
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top left:
left-justified,
spills down

top center:
center-justified,
spills down

top right:
right-justified, spills
down

middle left:
left-justified,
spills up and
down

bottom center:
center-justified,
spills up

bottom right:
right-justified,
spills up

middle center:
center-justified,
spills up and down

middle right:
right-justified, spills
up and down

bottom left:
left-justified,
spills up

To justify multiline text

1 Click Tools menu ➤ Properties.

2 Select the multiline text object.

3 On the Properties palette, select one of the Justification options.

4 Click outside the Properties palette.

Format Characters Within Multiline Text

As you create multiline text, you can override the text style and apply different
formatting to individual words and characters. The format changes affect only
the text you select; the current text style is not changed.
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You can specify a different font and text height and apply boldface, italics,
underlining, overlining, and color. You can also set an obliquing angle, change
the space between characters, and make characters wider or narrower. The
Remove Formatting option on the menu of options resets the character
attributes of selected text to the current text style and also resets the text color
to the color of the mtext object.

The text height setting specifies the height of capitalized text. For more
information about how height is calculated, see .

See also:

“Use an Alternate Text Editor” on page 751

To format characters in multiline text

1 Double-click a multiline text object to open the In-Place Text Editor.

2 Select the text you want to format:

■ To select one or more letters, click and drag the pointing device over
the characters.

■ To select a word, double-click the word.

■ To select a paragraph, triple-click the paragraph.

3 On the toolbar, make format changes as follows:

■ To change the font of the selected text, select a font from the list.

■ To change the height of the selected text, enter a new value in the
Height box.

■ To format text in a TrueType font with boldface or italics, or to create
underlined or overlined text for any font, click the corresponding
button on the toolbar. SHX fonts do not support boldface or italics.

■ To apply color to selected text, select a color from the Color list. Click
Other to display the “Select Color Dialog Box”.

■ To set an obliquing angle for the text, enter a value between -85 and
85. A positive value slants text to the right. A negative value slants
text to the left.

■ To change letter spacing in the selected text, enter a new value.

■ To change the width of characters in the selected text, enter a new
value.
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4 To save your changes and exit the editor, use one of the following
methods:

■ Click OK on the toolbar.

■ Click in the drawing outside the editor.

■ Press  CTRL +  ENTER .

Draw toolbar

Create Lists in Multiline Text

Lines of multiline text can be formatted as a list. When you add or delete an
item, or move an item up or down a level, the list numbering automatically
adjusts. You can also remove and reapply list formatting.

By default, list formatting is applied to all text that looks like a list. Text that
meets the following criteria is considered to be a list. The line begins with (1)
one or more letters or numbers or a symbol, followed by (2) punctuation after
a letter or number, (3) a space created by pressing TAB, and (4) some text
before the line is ended by ENTER or SHIFT+ENTER.

NOTE If you do not want list formatting applied to all text that fits the criteria,
clear the Allow Bullets and Lists option. (Right-click in the In-Place Text Editor,
click Bullets and Lists, and clear Allow Bullets and Lists.) When Allow Bullets and
Lists is not checked, you cannot create formatted lists in the multiline text object,
and existing lists are converted to plain text. The plain text lists retain their bullets,
numbers, or letters, but if you add or delete list items, the numbering does not
adjust automatically.

List formatting is only available when the Allow Bullets and Lists option is
checked (the default). To create a list, use one of the following methods:

■ Apply list formatting to new or selected text.

■ Use Auto-list (on by default) and type the elements of a list.

■ With Auto-list off, type the elements of a list and close and reopen the
editor to convert the text to a list.
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Apply List Formatting

When you apply list formatting, you can specify bullets, uppercase or lowercase
letters, or numbers. Default settings are used for the type of list you choose.
Letters or numbers are followed by a period. Nested lists use a double bullet,
letter, or number. Items are indented based on the tab stops on the ruler in
the In-Place Text Editor.

Use Auto-list to Type a List

When Auto-list is on, you can create a list as you type. You can use letters,
numbers, or symbols. For example, you can type 421., press TAB, and enter
some text. When you press ENTER, the next line starts with 422, a period,
and a TAB space.

The following characters can be used as punctuation after the number or letter
when you type a list but cannot be used as bullets:

DescriptionCharacter

Period.

Colon:

Close parenthesis)

Close angle bracket>

Close square bracket]

Close curly bracket}

Paste a List from Another Document

If you copy a nested bulleted list (a list within a list) from Microsoft® Word
and paste the list into multiline text, the bullets that are displayed as empty
circles cannot be formatted like other bullets in multiline text. This is because
Word uses the letter o instead of a bullet for nested bulleted lists. You can
remove formatting from the nested list and reapply to change the bullets to
double bullets.

To format multiline text as a list

1 Click Draw menu ➤ Text ➤ Multiline Text.

2 Specify opposite corners of a bounding box to define the width of the
multiline text object.

3 To expand the Text Formatting toolbar, click Options button ➤ Show
Options.
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4 If you are converting multiline text to a list, select the paragraphs.

NOTE List formatting is only available when the Allow Bullets and Lists option
is checked (the default).

5 On the expanded toolbar, click Numbering, Bullets, or Uppercase Letters.

■ Numbering. Uses numbers with periods for the items in a list.

■ Bullets. Uses a bullet or other character for the items in a list.

■ Uppercase Letters. Uses uppercase letters with periods for the items
in a list. If the list has more items than the alphabet has letters, the
sequence continues by using double letters. To use lowercase letters,
right-click in the editor. Click Bullets and Lists ➤ Lettered ➤
Lowercase.

6 If you are creating new list items, enter the text.

7 To end the list, press ENTER to move to a new line. Click the button that
you clicked to start the list.

8 To save your changes and exit the editor, use one of the following
methods:

■ Click OK on the toolbar.

■ Click in the drawing outside the editor.

■ Press  CTRL +  ENTER .

Draw toolbar

To remove list formatting from multiline text

1 Double-click a multiline text object to open the In-Place Text Editor.

2 Select the list items.

3 To expand the Text Formatting toolbar, click Options button ➤ Show
Options.

4 On the expanded toolbar, click the active list button to make it inactive:
Numbering, Bullets, or Uppercase Letters.

NOTE If the list uses lowercase letters, click Uppercase Letters to convert
the list to uppercase. Then click Uppercase Letters to make it inactive.
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5 To save your changes and exit the editor, use one of the following
methods:

■ Click OK on the toolbar.

■ Click in the drawing outside the editor.

■ Press  CTRL +  ENTER .

Draw toolbar

To create a lettered or numbered list in multiline text as you type

1 Click Draw menu ➤ Text ➤ Multiline Text.

2 Specify opposite corners of a bounding box to define the width of the
multiline text object.

3 To expand the Text Formatting toolbar, click Options button ➤ Show
Options.

4 Click Bullets and Lists. Verify that Allow Auto-list and Allow Bullets and
Lists are checked.

5 Enter a letter or a number and a period (or other punctuation).

The following characters can be used as punctuation after letters and
numbers: period (.), colon (:), close parenthesis ()), close angle bracket
(>), close square bracket (]), and close curly bracket (}).

6 Press TAB .

7 Enter the text of the list item. Press ENTER to move to the next item, or
press SHIFT+ENTER to add a plain paragraph before the next item.

The item is automatically lettered or numbered in sequence.

8 Press ENTER twice to end the list.

9 To save your changes and exit the editor, use one of the following
methods:

■ Click OK on the toolbar.

■ Click in the drawing outside the editor.

■ Press  CTRL +  ENTER .

Draw toolbar
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To create a bulleted list in multiline text as you type

1 Click Draw menu ➤ Text ➤ Multiline Text.

2 Specify opposite corners of a bounding box to define the width of the
multiline text object.

3 To expand the Text Formatting toolbar, click Options button ➤ Show
Options.

4 Click Bullets and Lists. Verify that Allow Auto-list and Allow Bullets and
Lists are checked.

5 Start a line of text by entering \U+2022 (the Unicode string for a bullet)
or by selecting a bullet character or another symbol.

The following characters cannot be used as bullets: period (.), colon (:),
close parenthesis ()), close angle bracket (>), close square bracket (]), and
close curly bracket (}).

6 Press TAB .

7 Enter the text of the list item. Press ENTER to move to the next item, or
press SHIFT+ENTER to add a plain paragraph before the next item.

The bullet character is automatically added to the next item.

8 Press ENTER twice to end the list.

9 To save your changes and exit the editor, use one of the following
methods:

■ Click OK on the toolbar.

■ Click in the drawing outside the editor.

■ Press  CTRL +  ENTER .

Draw toolbar

To move a list item in multiline text down a level

1 Double-click a multiline text object to open the In-Place Text Editor.

2 Place the cursor at the beginning of a list item and press TAB .
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The item moves down one level and begins a nested list.

3 Press ENTER to start the next item at the same level, or press SHIFT +
TAB to move the item up a level.

4 To save your changes and exit the editor, use one of the following
methods:

■ Click OK on the toolbar.

■ Click in the drawing outside the editor.

■ Press  CTRL +  ENTER .

Draw toolbar

To separate an existing list

1 Double-click a multiline text object to open the In-Place Text Editor.

2 Select a sequence of list items or place the cursor at the beginning of the
item where you want to start the new list.

3 Right-click in the editor. Click Bullets and Lists ➤ Restart.

The selected items are renumbered as a separate sequence. If you select
items in the middle of a list, unselected items below the selected items
also become part of the new list.

4 To continue the original list below the new list, select the first item below
the new list.

5 Right-click in the editor. Click Bullets and Lists ➤ Continue.

The selected item and the items following it are renumbered to continue
the previous list.

6 To save your changes and exit the editor, use one of the following
methods:

■ Click OK on the toolbar.

■ Click in the drawing outside the editor.

■ Press  CTRL +  ENTER .

Draw toolbar
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To convert the lists in a multiline text object to plain text

1 Double-click a multiline text object to open the In-Place Text Editor.

2 Right-click in the editor. Click Bullets and Lists. Remove the check mark
next to Allow Bullets and Lists.

The plain text lists retain their bullets, numbers, or letters. If you add an
item to the list, the number or letter sequence does not change.

Indent Multiline Text and Use Tabs

You can control how paragraphs are indented in a multiline text (mtext)
object. The ruler in the In-Place Text Editor shows the settings for the current
paragraph.

Tabs and indents that you set before you start to enter text apply to the whole
multiline text object. To apply different tabs and indents to individual
paragraphs, click in a single paragraph or select multiple paragraphs and then
change the settings.

Sliders on the ruler show indentation relative to the left side of the bounding
box. The top slider indents the first line of the paragraph, and the bottom
slider indents the other lines of the paragraph.

The long tick marks on the ruler show the default tab stops. If you click the
ruler to set your own tabs, the ruler displays a small, L-shaped marker at each
custom tab stop. You can delete a custom tab stop by dragging the marker off
the ruler.
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To create paragraphs with hanging indentation

1 Double-click a multiline text object to open the In-Place Text Editor.

2 Select the paragraphs you want to indent.

3 On the ruler, slide the top indent marker to where you want the first
line of the paragraphs to start.

NOTE The ruler displays the tabs and indents that are set for the selected
paragraphs or, if no text is selected, the paragraph where the cursor is
located. The default tab stops are the long tick marks on the ruler. To set a
custom tab stop, click the ruler where you want the tab stop.

4 Slide the bottom indent marker to where you want the other lines of
the paragraphs to start.

This step indents turnover lines in paragraphs that are more than one
line long.

5 To change the indentation, select the paragraphs you want to change,
click the ruler to set new tab stops, if needed, and move the indent
markers.

6 To save your changes and exit the editor, use one of the following
methods:

■ Click OK on the toolbar.

■ Click in the drawing outside the editor.

■ Press  CTRL +  ENTER .

Draw toolbar

Specify the Line Spacing Within Multiline Text

Line spacing for multiline text is the distance between the baseline (bottom)
of one line of text and the baseline of the next line of text. The line space
factor applies to the entire multiline text object, not to selected lines.

You can set the spacing increment to a multiple of single line spacing, or as
an absolute distance. Single spacing is 1.66 times the height of the text
characters.

The default line space style, At Least, automatically increases line spacing to
accommodate characters that are too large to fit the line spacing you set for
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the multiline text object. Use the other line space style, Exactly, to line up
text in tables.

To ensure that line spacing is identical in multiple multiline text objects, use
Exactly and set the Line Space Factor to the same value in each multiline text
object.

NOTE Using Exactly can cause text in lines located above or below lines with large
font characters to overlap the larger characters.

To change the line spacing of multiline text

1 Click Tools menu ➤ Properties.

The Properties palette is displayed.

2 Select the multiline text object you want to edit.

3 In the Properties palette, for Line Space Style, select one of the following:

■ At Least. Adjusts lines of text automatically based on the height of
the largest character in the line. More space is added between lines
of text with taller characters. This is the default setting.

■ Exactly. Forces the line spacing to be the same size for all lines of
text regardless of format differences such as font or text height.

4 Change the line spacing by entering a new value for either of the
following options. The two line spacing options provide different ways
to set the same thing:

■ Line Space Factor. Sets the line spacing to a multiple of single-line
spacing. Single spacing is 1.66 times the height of the text characters.

■ Line Space Distance. Sets the line spacing to an absolute value
measured in drawing units. Valid values must be between 0.0833 and
1.3333.

NOTE After you exit the Properties palette, the value of the other line spacing
option is updated to correspond with the line spacing value that you entered.

Standard toolbar
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Create Stacked Characters Within Multiline Text

Characters representing a fractional measurement or tolerance can be formatted
to conform to several standards.

Stacked text is text or fractions that indicate tolerances or measurements. You
use special characters to indicate where selected text should be stacked.

■ Slash (/) stacks text vertically, separated by a horizontal line.

■ Pound sign (#) stacks text diagonally, separated by a diagonal line.

■ Carat (^) creates a tolerance stack, which is not separated by a line.

plain text tolerance stack

diagonal fraction vertical fraction

.054-.057DIA-2 HOLES DIA-2 HOLES

Ø GALV. STL. POSTSGALV. STL. POSTS

You can set the program to automatically stack numeric characters entered
before and after the slash, pound sign, or carat. For example, if you enter 1#3
followed by a nonnumeric character or space, the AutoStack Properties dialog
box is displayed. You can change the settings to indicate your formatting
preferences.
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AutoStack stacks only numeric characters immediately before and after the
slash, pound sign, and carat. To stack nonnumeric characters or text that
includes spaces, select the text and click the Stack button on the Text
Formatting toolbar.

See also:

“Use an Alternate Text Editor” on page 751

To create stacked text

1 Click Draw menu ➤ Text ➤ Multiline Text.

2 Specify opposite corners of a bounding box to define the width of the
multiline text object.

3 In the In-Place Text Editor, set text style and other multiline text
properties as needed.

4 Enter the text you want to stack separated by one of the following
characters:

■ Slash (/) stacks text vertically, separated by a horizontal line.

■ Pound sign (#) stacks text diagonally, separated by a diagonal line.

■ Carat (^) creates a tolerance stack, which is not separated by a line.

If you enter numbers separated by stack characters and then enter a
nonnumeric character or press SPACEBAR, the AutoStack Properties
dialog box is displayed.

5 In the AutoStack Properties dialog box, you can choose to automatically
stack numbers (not nonnumeric text) and to remove leading blanks. You
can also specify whether the slash character creates a diagonal fraction
or creates a vertical fraction. If you do not want to use AutoStack, click
Cancel to exit the dialog box.

6 Select the text that you want to stack, and click the Stack button on the
toolbar.

7 To save your changes and exit the editor, use one of the following
methods:

■ Click OK on the toolbar.

■ Click in the drawing outside the editor.

■ Press  CTRL +  ENTER .

Draw toolbar
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To change stack properties

1 Double-click the multiline text object you want to edit.

2 In the In-Place Text Editor, select the stacked text.

3 Right-click in the editor. Click Properties.

4 In the Stack Properties dialog box, change settings as needed.

5 To set properties for automatic stacking, click Autostack.

6 To save your changes and exit the editor, use one of the following
methods:

■ Click OK on the toolbar.

■ Click in the drawing outside the editor.

■ Press  CTRL +  ENTER .

Draw toolbar

To unstack text

1 Double-click the multiline text object you want to edit.

2 In the In-Place Text Editor, select the stacked text.

3 Click Stack on the Text Formatting toolbar.

4 To save your changes and exit the editor, use one of the following
methods:

■ Click OK on the toolbar.

■ Click in the drawing outside the editor.

■ Press  CTRL +  ENTER .

Draw toolbar
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Create Text with Leaders

You can create text that includes one or more leader lines.

Overview of Text with Leaders

A leader object is a line or a spline with an arrowhead at one end and a
multiline text object at the other. In some cases, a short horizontal line, called
a hook line, dogleg, or landing, connects text and feature control frames to
the leader line.

The leader line is associated with the multiline text object, so when the text
object is relocated, the leader line stretches accordingly.

When associative dimensioning is turned on and object snaps are used to
locate the leader arrowhead, the leader is associated with the object to which
the arrowhead is attached. If the object is relocated, the arrowhead is relocated,
and the leader line stretches accordingly.

You can copy text used elsewhere in a drawing and append a leader to it.

See also:

“Change Text with a Leader” on page 747

Create a Leader Line

A leader object typically consists of an arrowhead, a leader line or curve, and
a multiline text object.

You can create a leader line from any point or feature in a drawing and control
its appearance as you draw. Leaders can be straight line segments or smooth
spline curves. Leader color is controlled by the current dimension line color.
Leader scale is controlled by the overall dimension scale set in the current
dimension style. The type and size of arrowhead, if one is present, are
controlled by the first arrowhead defined in the current dimension style.

LEADER creates complex leader lines that can be made up of more than two
line segments.  and  create simple automatic leader lines with two line segments
for circles and arcs.
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Associate Leaders with Objects

When associative dimensioning is turned on (), the leader arrowhead can be
associated with a location on an object using an object snap. If the object is
relocated, the arrowhead remains attached to the object and the leader line
stretches, but the multiline text remains in place.

To create a leader with straight lines

1 Click Dimension menu ➤ Leader.

2 Press ENTER to display the Leader Settings dialog box and make the
following selections:

■ On the Leader Line & Arrow tab, select Straight. Under Number of
Points, select No Limit.

■ On the Annotation tab, select MText.

■ Click OK.

3 Specify the First leader point and Next points of the leader line.

4 Press ENTER to finish selecting leader points.

5 Specify the text width.

6 Enter the line of text. Press ENTER to enter new lines of text as needed.

7 Press ENTER twice to end the command.

After the QLEADER command is completed, the text annotation becomes
a multiline text object.

Dimension toolbar
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To create a two-segment spline leader with text

1 Click Dimension menu ➤ Leader.

2 Press ENTER to display the Leader Settings dialog box, and make the
following selections:

■ On the Annotation tab, select MText.

■ On the Leader Line & Arrow tab, select Spline. Under Number of
Points, in the Maximum box, enter 3. Clear the No Limit option if
necessary.

3 Click OK.

4 Specify the first, second, and third (optional) leader line points.

5 Specify the width of the text column.

6 Enter the first line of text. To add additional lines, press ENTER once.

7 Press ENTER twice to end the command.

FLOWLINE

Dimension toolbar

To create multiple leaders from the same annotation

1 Select the leader and then the leader arrowhead grip.

2 At the Command prompt, enter c to select the Copy option.

3 Specify the endpoints for the multiple leaders, and then press ENTER.

4 To move the end of the new leader to the hook line (dogleg or landing),
clear any grips by pressing ESC, select the new leader line, select the
leader line grip, and move the grip to the hook line.

Dimension toolbar
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Add Text to a Leader

There are two ways to create leader text. You can enter text on the command
line, or you can create paragraphs of text using the In-Place Text Editor. If you
create multiline text, you can apply formatting to individual words or letters.
You can also append copies of existing annotation to a leader.

Text is placed automatically at the endpoint of the leader, at the specified
offset. You specify this offset in the Modify Dimension Style Manager, Text
tab, under Text Placement. Feature control frames also are placed automatically
at the endpoint of the leader. Blocks are inserted at the location, scale, and
rotation you specify.

Use the Vertical settings in the Modify Dimension Style Manager, Text tab,
under Text Placement to align the annotation vertically with the leader. In
the following illustration, the vertical justification option used is Above.

6 x 12 KEYWAY

To create a box around the text, set the  system variable to a negative value.
The offset between the box and the text is the absolute value of DIMGAP.

To create a leader using the In-Place Text Editor

1 Click Dimension menu ➤ Leader.

2 Specify the First leader point and Next points of the leader.

3 Press ENTER to end the leader.

4 Specify the text width.

5 At the Enter First Line of Annotation prompt, press ENTER.

6 In the In-Place Text Editor, enter and format the text.

7 To save your changes and exit the editor, use one of the following
methods:

■ Click OK on the toolbar.

■ Click in the drawing outside the editor.
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■ Press  CTRL +  ENTER .

The text is appended to the leader endpoint at the offset distance
specified in the Dimension Style Manager (DIMSTYLE).

Dimension toolbar

Import Text from External Files

You can insert TXT or RTF text files created in word processors into your
drawing by either importing the text or dragging a file icon from Windows
Explorer.

Importing TXT or RTF files from other sources gives you the most flexibility.
For example, you can create a text file of standard notes that you include in
drawings. The imported text becomes a multiline text object, which you can
edit and reformat. Text imported from a TXT file inherits the current text
style. Text imported from an RTF file inherits the current text style name, but
retains its original fonts and format. Imported text files are limited to 32 KB
and must have a file extension of .txt or .rtf.

If you drag a text file into a drawing, text width is determined by line breaks
and carriage returns in the original document. When you drag an RTF file into
a drawing, the text is inserted as an OLE object.

If you use the Clipboard to paste text from another application, the text
becomes an OLE object. If you use the Clipboard to paste text from another
file, the text is inserted as a block reference, and it retains its original text
style.

See also:

“Import OLE Objects” on page 1000

To import text files

1 Click Draw menu ➤ Text ➤ Multiline Text.

2 Specify opposite corners of a bounding box to define the width of the
multiline text object.

3 Right-click in the editor. Click Import Text.

The size limit for an imported file is 32 KB.

4 In the Select File dialog box, double-click the file you want to import,
or select the file. Click Open.
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The text is inserted at the cursor location.

5 Change the text as needed.

6 To save your changes and exit the editor, use one of the following
methods:

■ Click OK on the toolbar.

■ Click in the drawing outside the editor.

■ Press  CTRL +  ENTER .

Draw toolbar

To insert a text file using the drag-and-drop method

1 Open Windows Explorer, but make sure it does not fill the screen.

2 Display the folder that contains the TXT or RTF file you want.

3 Drag the TXT or RTF file icon onto the drawing. TXT files are inserted
as multiline text objects using the current text style. RTF files are inserted
as OLE objects.

Use Fields in Text
A field is updatable text that is set up to display data that may change during
the life cycle of the drawing. When the field is updated, the latest value of the
field is displayed.

Insert Fields

A field is text that contains instructions to display data that you expect to
change during the life cycle of the drawing.

When a field is updated, the latest data is displayed. For example, the value
of the FileName field is the name of the file. If the file name changes, the new
file name is displayed when the field is updated.

Fields can be inserted in any kind of text (except tolerances), including text
in table cells, attributes, and attribute definitions. When any text command
is active, Insert Field is available on the shortcut menu.
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Some sheet set fields can be inserted as placeholders. For example, you can
insert SheetNumberAndTitle as a placeholder. Later, when the layout is added
to a sheet set, the placeholder field displays the correct sheet number and
title.

Block placeholder fields can be used in block attribute definitions while you’re
working in the Block Editor.

A field for which no value is available displays hyphens (----). For example,
the Author field, which is set in the Drawing Properties dialog box, may be
blank. An invalid field displays pound signs (####). For example, the
CurrentSheetName field, which is valid only in paper space, displays pound
signs if it is placed in model space.

Change the Appearance of a Field

The field text uses the same text style as the text object in which it is inserted.
By default, fields are displayed with a light gray background that is not plotted
( system variable).

Formatting options in the Field dialog box control the appearance of the text
that is displayed. The options that are available depend on the type of field.
For example, the format for date fields includes options for displaying the day
of the week and the time, and the format for named object fields includes
capitalization options.

Edit a Field

Because a field is part of a text object, it cannot be selected directly. The text
object must be selected and an editing command must be active. When a field
is selected, Edit Field is available on the shortcut menu, or you can double-click
the field to display the Field dialog box. Any changes are applied to all text
in the field.

If you no longer want to update a field, you can preserve the value that is
currently displayed by converting the field to text.

The field expression, consisting of escape characters and a field code, is shown
in the Field dialog box but cannot be edited.

To insert a field in text

1 Double-click the text to display the appropriate text editing dialog box.

2 Place the cursor where you want the field text to appear and right-click.
Click Insert Field.

For keyboard access, press  CTRL +  F .

3 In the Field dialog box, in Field Category, select All or select a category.

726 | Chapter 29   Notes and Labels



The fields in the selected category are displayed in the Field Names list.

4 In the Field Names list, select a field.

The current value of most fields is displayed in a shaded text box to the
right of Field Category. The current value of a date field is displayed in
the Examples list.

5 Select a format and any other options.

For example, when the NamedObject field is selected, you select a type
(for example, layer or textstyle) and a name (for example, 0 for layer or
STANDARD for textstyle).

Field Expression displays the expression that underlies the field. The
field expression cannot be edited, but you can learn how fields are
constructed by viewing this area.

6 Click OK to insert the field.

The field displays its current value in the text when the Field dialog box
closes.

To insert a field in a table

1 Double-click inside a cell in a table to select it for editing.

2 Place the cursor where you want the field text to appear and right-click.
Click Insert Field.

3 In the Field dialog box, select All or select a category.

4 In the Field Names list, select a field.

The current value of the field is displayed in a shaded text box to the
right of Field Category.

5 Select a format and any other option.

6 Click OK to insert the field.

The field displays its current value when you move to the next cell.

To use a field to display a property of an object

1 Double-click a text object to display the appropriate text editing dialog
box.

2 Place the cursor where you want the field text to appear and right-click.
Click Insert Field.

3 In the Field dialog box, in Field Category, select All.

4 In the Field Names list, select Object.
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5 In Object Type, click the Select Object button, and select an object in
the drawing.

6 In the Field dialog box, in Property, select the property whose value you
want to display in the text.

For example, the field could display the radius of a selected circle.

7 Select a format for the text.

8 Click OK.

The current value for the object’s property is displayed in the text.

To insert a sheet set placeholder field

1 On the Draw menu, click Block ➤ Define Attributes.

2 In the Attribute Definition dialog box, under Mode, click Preset. Specify
any text options.

3 Under Attribute, in the Tag box, enter a name for the field.

4 To the right of the Value box, click the Insert Field button.

5 In the Field dialog box, under Field Category, select SheetSet.

6 In the Field Names list, select SheetSetPlaceholder.

7 In Placeholder Type, select the type of field that you want.

Temporary Value previews the placeholder field.

8 In Format, select a capitalization style for the placeholder field.

When the field is updated, the same style is used for the value of the
field.

9 (Optional) Click Associate Hyperlink if you want the field to serve as a
hyperlink to a location.

NOTE Associate Hyperlink is not available for the ViewportScale field.

10 Click OK to exit the Field dialog box.

The placeholder field displays its name when the Field dialog box closes:
for example, SheetNumber. Later, when the block is inserted from the
Views List tab shortcut menu in the Sheet Set Manager, the field displays
a value based on the sheet it is dragged to: for example, its sheet number.

11 Click Ok in the Attribute Definition dialog box. Specify the location for
the field text to appear near the geometry that you have created to use
with the Sheet Set Manager as a callout block or a label block.
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12 Create a block that includes the newly created attribute object along
with the geometry for the block.

To format a field value

1 Double-click a text object to display the appropriate text editing dialog
box.

2 Double-click the field you want to format.

The Field dialog box is displayed. If formatting is available for the field,
the Field Format button is displayed.

3 Click Field Format.

In the Field Format dialog box, the current value of the field is displayed.
When you select an option, the result is displayed in Preview.

4 Enter a conversion factor to apply to the current value.

For example, to convert inches to millimeters, enter 0.03937.

5 Enter any text that you want to precede or follow the field value.

For example, enter mm for millimeters.

6 Select a decimal separator. Select None or Comma to group thousands.

7 Select an option for suppressing zeros:

■ Leading: Suppresses leading zeros in all decimal field values. For
example, 0.5000 becomes .5000.

■ Trailing: Suppresses trailing zeros in all decimal field values. For
example, 12.5000 becomes 12.5, and 30.0000 becomes 30.

■ 0 Feet: Suppresses the feet portion of a feet-and-inches field value
when the distance is less than one foot. For example, 0'-6 1/2" becomes
6 1/2".

■ 0 Inches: Suppresses the inches portion of a feet-and-inches field value
when the distance is an integral number of feet. For example, 1'-0"
becomes 1'.

8 Click OK.

In the Field dialog box, the field value is displayed in Preview with the
formatting you specified.

9 Click OK.
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Update Fields

You can also set fields to be updated automatically when the drawing is
opened, saved, plotted, regenerated, or sent via .

Settings on the User Preferences Tab (Options Dialog Box) control whether
fields are updated automatically or on demand ( system variable). The Date
field cannot be updated automatically regardless of the setting of FIELDEVAL.

NOTE When the  system variable is set to 2, fields cannot be updated until you
use  or .

Contextual Fields in Blocks and Xrefs

Some fields are contextual; that is, their value is different depending on which
space or layout they reside in. For example, because each layout can have a
different page setup attached, the value displayed by the PlotOrientation field
can be different in different layouts in the same drawing.

List of contextual fields

CurrentSheetTitleCurrentSheetCustom

DeviceNameCurrentSheetDescription

PaperSizeCurrentSheetNumber

PlotDateCurrentSheetNumberAndTitle

PlotOrientationCurrentSheetSet

PlotScaleCurrentSheetSetCustom

PageSetupNameCurrentSheetSetDescription

PlotStyleTableCurrentSheetSubSet

For compatibility with previous versions, contextual fields in blocks and xrefs
are not updated when you insert them in a drawing; instead, the field displays
the last cached value. Therefore, if you want to use a contextual field within
a block, for example, a title block, you must insert the field as an attribute.
For example, a title block can use the CurrentSheetNumber field as an attribute.
When you insert the title block, the field displays the sheet number of the
sheet on which the title block is inserted.

Most fields are not contextual and are updated in blocks and xrefs. Fields in
xrefs are updated based on the host file, not the source xref. These fields do
not have to be placed in attributes. For example, a field that displays the sheet
number of a particular sheet in a sheet set and that updates if that sheet
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number changes, is a property of the sheet set. When you create the field, you
select the SheetSet field name, select the sheet set and the sheet that you want
in the tree view, and then select the property SheetNumber for the field value
to be displayed. This field displays the sheet number of that sheet, even if you
put the field in a block and insert it in another drawing. If the sheet is removed
from the sheet set, it no longer has a sheet number, and the field becomes
invalid and displays pound signs.

Some sheet set fields can be inserted as placeholders. For example, when you
create your own callout blocks and label blocks, you can insert the
SheetNumber field as a placeholder. Later, when the block is inserted from
the Views List tab shortcut menu in the Sheet Set Manager, the field displays
the sheet number of the drawing.

Compatibility with AutoCAD LT and with Previous Releases of AutoCAD

When a drawing with fields is opened in AutoCAD 2004 or earlier, the fields
are not updated; they display the value last displayed in the drawing before
it was opened. If no changes are made to a field, it is updated normally when
it is reopened in a release that supports fields.

Fields are not available in AutoCAD LT. When a drawing with fields is opened
in AutoCAD LT, the fields are evaluated based on the setting of the FIELDEVAL
system variable in the drawing, but the FIELDEVAL system variable is not
accessible.

See also:

“Work with AutoCAD Drawings in AutoCAD LT”

To update a field manually

1 Double-click text.

2 Select the field to update and right-click. Click Update Field.

To update multiple fields manually

1 On the command line, enter updatefield.

2 At the Select Objects prompt, select the objects that contain the fields
you want to update and press  ENTER .

All of the fields in the selected objects are updated.

To update fields automatically

1 On the command line, enter fieldeval.
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2 Enter a bitcode that is the sum of any of the following values:

■ 0: Not updated

■ 1: Updated on open

■ 2: Updated on save

■ 4: Updated on plot

■ 8: Updated on use of ETRANSMIT

■ 16: Updated on regeneration

For example, to update fields only when the file is opened, saved, or
plotted, enter 7.

Use Hyperlinks in Fields

The hyperlink works the same way as a hyperlink attached to an object. When
the cursor pauses over the text, a hyperlink cursor is displayed, along with a
tooltip that describes the hyperlink. Hold down the  CTRL  key and click to
follow the link.

NOTE The Hyperlink field uses an absolute path to a file; the  command can create
a hyperlink with a relative path.

The fields that point to sheet and view titles and numbers can be assigned a
hyperlink when they are created. When these items are changed or moved in
the Sheet Set Manager, the hyperlinks associated with them still jump to the
correct location.

Hyperlinks in fields are converted from links to DWG files into links to DWF
files when published to a multi-sheet DWF file format.

To add a hyperlink field to text

1 Click Draw menu ➤ Text ➤ Multiline Text.

2 Place the cursor where you want the hyperlink text to appear.

3 Right-click in the editor. Click Insert Field.

4 In the Field dialog box, in Field Category, select Linked.

5 In Field Names, select Hyperlink, and click Hyperlink.
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6 In the Insert Hyperlink dialog box, use one of the following methods to
specify a location:

■ Under Type the File or Web Page Name, enter the path and name of
the file that you want to associate with the hyperlink.

■ Under Browse For, click File, Web Page, or Target. Navigate to the
location to which you want to link. Click Open or OK.

7 (Optional) In Text to Display, select the default text that is displayed,
and enter the link text that you want to appear in the mtext object.

8 Click OK to close each dialog box.

9 To save your changes and exit the editor, use one of the following
methods:

■ Click OK on the toolbar.

■ Click in the drawing outside the editor.

■ Press  CTRL +  ENTER .

The hyperlink is displayed in the mtext object with the link text that
you entered. Use  CTRL + click to jump to the hyperlinked location.

Draw toolbar

Work with Text Styles
When you enter text into your drawing, the current text style determines the
text font, size, angle, orientation, and other text characteristics.

Overview of Text Styles

All text in a drawing has a text style associated with it. When you enter text,
the program uses the current text style, which sets the font, size, obliquing
angle, orientation, and other text characteristics. If you want to create text
using a different text style, you can make another text style current. The table
shows the settings for the STANDARD text style.

The settings for the current text style are displayed at the prompts on the
command line. You can use or modify the current text style or create and load
a new text style. Once you've created a text style, you can modify its
characteristics, change its name, or delete it when you no longer need it.
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Create and Modify Text Styles

Except for the default STANDARD text style, you must create any text style
that you want to use.

Text style names can be up to 255 characters long. They can contain letters,
numbers, and the special characters dollar sign ($), underscore (_), and hyphen
(-). If you don't enter a text style name, the text styles are automatically named
Stylen, where n is a number that starts at 1.

You can modify an existing text style in the Text Style dialog box by changing
the settings. You can also update existing text of that text style to reflect the
changes.

Certain style settings affect multiline and single-line text objects differently.
For example, changing the Upside Down and Backwards options has no effect
on multiline text objects. Changing Width Factor and Obliquing has no effect
on single-line text.

If you rename an existing text style, any text using the old name assumes the
new text style name.

You can remove unreferenced text styles from your drawing with  or by
deleting the text styles from the Text Styles dialog box. The STANDARD text
style cannot be removed.

Change Text Style

When you change the text style of a multiline text object, the updated settings
are applied to the entire object, and some formatting of individual characters
might not be retained. The following table describes the effects of text style
change on character formatting.

Retained?Formatting

NoBold

YesColor

NoFont

NoHeight

NoItalic

YesStacking

YesUnderlining
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To set the current text style

■ On the Styles toolbar, in the Text Style control, click the arrow and select
a text style from the list.

Assign Text Fonts

You can assign a text font as part of the text style definition. Several factors
depend on the type of text you are working with.

Overview of Assigning Text Fonts

Fonts define the shapes of the text characters that make up each character set.
You can use TrueType fonts in addition to compiled SHX fonts.

A single font can be used by more than one text style. If your company has a
standard font, you can modify other text style settings to create a set of text
styles that use this standard font in different ways. The following illustration
shows the same font used by different text styles that use different obliquing
settings to define the slant of the text.

FRAME
BAR

INSIDE

You can assign a font to a text style by selecting a font file from the list in the
Text Style dialog box.

Use TrueType Fonts

Several factors affect the display of TrueType fonts in a drawing.

TrueType fonts always appear filled in your drawing; however, when you plot,
the  system variable controls whether the fonts are filled. By default TEXTFILL
is set to 1 to plot the filled-in fonts.

The In-Place Text Editor can display only fonts that are recognized by Microsoft
Windows. Because SHX fonts are not recognized by Windows, a TrueType
equivalent is supplied in the In-Place Text Editor when you select an SHX or
any other non-TrueType font for editing.
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See also:

“Set Text Height” on page 740

To assign a TrueType font to a text style

1 Click Format menu ➤ Text Style.

2 In the Text Style dialog box under Style Name, click New.

3 In the New Text Style dialog box, enter a style name for the new text
style. Click OK.

4 Under Font Name, select a TrueType font from the list. TrueType fonts
display a TrueType icon in front of their names.

5 To see the effects on different characters, enter a text string in the sample
text box that is located to the left of the Preview button. Click Preview.

6 To update text of the current style in the drawing, click Apply.

7 Click Close.

Styles toolbar

Use Unicode and Big Fonts

Several factors affect your choosing, entering, and displaying Unicode and
big fonts in a drawing.

The program supports the Unicode character-encoding standard. A Unicode
font can contain 65,535 characters, with shapes for many languages. Unicode
fonts contain many more characters than are defined in your system; therefore,
to use a character not directly available from the keyboard, you can enter the
escape sequence \U+nnnn, where nnnn represents the Unicode hexadecimal
value for the character. All SHX shape fonts are now Unicode fonts.

The text files for some alphabets, such as Kanji, contain thousands of
non-ASCII characters. To accommodate such text, the program supports a
special type of shape definition known as a Big Font file. You can set a style
to use both regular and Big Font files.

When you specify fonts using STYLE Command Line, the assumption is that
the first name is the normal font and the second (separated by a comma) is
the Big Font. If you enter only one name, it's assumed that it is the normal
font and any associated Big Font is removed. By using leading or trailing
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commas when specifying the font file names, you can change one font without
affecting the other, as shown in the following table.

Specifying fonts and Big Fonts on the command line

To specify this ...Enter this ...

Both normal fonts and Big Fonts[font name],[big font name]

Only a normal font (Big Font unchanged)[font name],

Only a Big Font (normal font unchanged),[big font name]

Only a normal font (Big Font, if any, removed)[font name]

No changeENTER  (null response)

NOTE  Long file names that contain commas as font file names are not accepted.
The comma is interpreted as a separator for an SHX font–Big Font pair.

See also:

“Substitute Fonts” on page 738

To assign an Asian-language font to a text style

1 Click Format menu ➤ Text Style.

2 In the Text Style dialog box, under Style Name, click New.

3 In the New Text Style dialog box, enter a style name for the new text
style. Click OK.

4 Under Font Name, select the name of a an SHX font file, and then select
Use Big Font to select an Asian-language big font.

When you select Use Big Font, the Font Style box changes to a Big Font
Name box. Only SHX fonts are available for selection, and only Big Font
names are shown in the Big Font box.

5 To see the effects on different characters, enter a text string in the sample
text box that is located to the left of the Preview button. Click Preview.

6 To update text of the current style in the drawing, click Apply.

7 Click Close.

Styles toolbar

Work with Text Styles | 737



Substitute Fonts

The program accommodates a font that is not currently on your system by
substituting another font.

Specify an Alternate Font

If your drawing specifies a font that is not currently on your system, the font
designated as your alternate font is automatically substituted. By default, the
simplex.shx file is used. If you want to specify a different font, enter the
alternate font file name by changing the  system variable. If you use a text
style that uses a Big Font, you can map it to another font using the FONTALT
system variable. This system variable uses a default font file pair of txt.shx,
bigfont.shx. For more information, see “Use Unicode and Big Fonts” on page
736.

In previous releases, you could display PostScript® fonts in the drawing.
Because later releases cannot display PostScript fonts, Autodesk has supplied
TrueType font equivalents. These PostScript fonts are mapped to the equivalent
TrueType fonts in a font mapping file that comes with the program.

Display Proxy Fonts

For third-party or custom SHX fonts that have no TrueType equivalent, one
of several different TrueType fonts called proxy fonts is substituted. In the
In-Place Text Editor, proxy fonts look different from the fonts they represent
to indicate that the proxy fonts are substitutions for the fonts used in the
drawing.

Custom SHX fonts do not appear in the Font list on the Text Formatting
toolbar. If you want to format characters by assigning one of these fonts, first
create a text style that uses the font and then apply that text style to the
characters.

Use Font Mapping Files

Sometimes you might want to ensure that your drawing uses only certain
fonts, or perhaps you might want to convert the fonts you used to other fonts.
You can use any text editor to create font mapping tables for both of these
purposes.

You can use these font mapping files to enforce corporate font standards, or
to facilitate off-line printing. For example, if you share drawings with
consultants, you may want to use a font mapping table to specify what font
is substituted when a text object created with another font is encountered.
Similarly, you can edit the drawing using quicker-drawing SHX fonts and then
switch to more complex fonts for the final plot by setting up a font mapping
file that converts each SHX font to an equivalent.
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The font mapping file is a plain ASCII text (FMP) file containing one font
mapping per line. Each line contains the name of a font file (with no directory
name or path) followed by a semicolon (;) and the name of the substitute font
file. The substitute file name includes a file extension such as .ttf.

For example, you could use the following entry in a font map table to specify
that the times.ttf TrueType font file be substituted for the romanc.shx font file:

romanc.shx;times.ttf

The program comes with a default font mapping file. You can edit this file
using any ASCII text editor. You can also specify a different font mapping file
in the Options dialog box by using the  system variable. The following table
shows the font substitution rules used if a font file cannot be located when a
drawing is opened.

Font substitution

Fourth
mapping order

Third mapping
order

Second mapping
order

First mapping
order

File
extension

Windows substitutes a
similar font

Use font defined in
text style

Use font mapping
table

.ttf

Prompt for new
font

Use FONTALTUse font defined in
text style

Use font mapping
table

.shx

Prompt for new fontUse FONTALTUse font mapping
table

.pfb

To specify a font mapping file

1 Click Tools menu ➤ Options.

2 On the Files tab, in the list, double-click Text Editor, Dictionary, and
Font File Names.

3 Double-click Font Mapping File.

The acad.fmp file is specified by default.

4 To change the font mapping file, double-click the arrow line to open
the Select a File dialog box. Select a file and click Open. Click OK.

5 At the Command prompt, enter regen to convert existing text using
the new font mappings.

To specify a default alternate font

1 At the Command prompt, enter fontalt.
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2 Enter the name of the font file you want to use as the alternative.

Set Text Height

Text height determines the size in drawing units of the letters in the font you
are using. Except in TrueType fonts, the value usually represents the size of
the uppercase letters.

If you specify a fixed height as part of a text style, the Height prompt is
bypassed when you create single-line text. When the height is set to 0 in the
text style, you are prompted for the height each time you create single-line
text. Set the value to 0 if you want to specify the height as you create text.

TrueType Fonts

For TrueType fonts, the value specified for text height represents the height
of a capital letter plus an ascent area reserved for accent marks and other marks
used in non-English languages. The relative portion of text height that is
assigned to capital letters and ascent characters is determined by the font
designer at the time the font is designed; consequently, it varies from font to
font.

In addition to the height of a capital letter and the ascent area that make up
the text height specified by the user, TrueType fonts have a descent area for
portions of characters that extend below the text insertion line, for example,
y, j, p, g, and q.

When you apply a text height override to all text in the editor, the entire
multiline text object is scaled, including its width.

To set text height in a text style

1 Click Format menu ➤ Text Style.

2 In the Text Style dialog box, select a style from the Style Name list.

3 Under Font, enter the text height (in drawing units) in the Height box.

4 To update existing text that uses this text style, click Apply.

5 Click Close.

Styles toolbar
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Set Text Obliquing Angle

The obliquing angle determines the forward or backward slant of the text.
The angle represents the offset from 90 degrees.

0 deg rotation
0 deg obliquing

30 deg obliquing
30 deg rotation

-30 deg rotation
-30 deg obliquing

-30 deg obliquing
30 deg rotation

Entering a value between -85 and 85 makes the text oblique. A positive
obliquing angle slants text to the right. A negative obliquing angle slants text
to the left.

To set the obliquing angle in a text style

1 Click Format menu ➤ Text Style.

2 In the Text Style dialog box, select a text style from the Style Name list.

3 Under Effects, enter an angle between -85 and 85 in the Oblique Angle
box.

A positive value slants text to the right. A negative value slants text to
the left.

4 To update existing text that uses this text style, click Apply.

5 Click Close.

Styles toolbar
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Set Horizontal or Vertical Text Orientation

Lines of text are oriented to be vertical or horizontal. Text can have a vertical
orientation only if the associated font supports dual orientation. You can
create more than one line of vertical text. Each successive text line is drawn
to the right of the preceding line. The normal rotation angle for vertical text
is 270 degrees.

vertical text

NOTE Vertical orientation is not supported for TrueType fonts and symbols.

To set vertical orientation in a text style

1 Click Format menu ➤ Text Style.

2 In the Text Style dialog box, select a text style from the Style Name list.

3 Under Effects, select Vertical.

4 To update existing text that uses this text style, click Apply.

5 Click Close.

Styles toolbar

Change Text
You can change text content, formatting, and properties such as scale and
justification.
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Overview of Changing Text

Text, whether created with , , , or , can be modified like any other object. You
can move, rotate, erase, and copy it. You can change text properties in the
Properties palette.

You can also edit the contents of existing text and create a mirror image of
it. The  system variable controls whether text is also reversed when you mirror
objects in your drawing. The procedures for modifying text vary slightly,
depending on how the text was created.

Change Single-Line Text

You can change single-line text with  and . Use DDEDIT when you need to
change only the content of the text, not the formatting or properties of the
text object. Use PROPERTIES when you want to change content, text style,
location, orientation, size, justification, and other properties.

Text objects also have grips for moving, scaling, and rotating. A text object
has grips at the lower-left corner of the baseline and at the alignment point.

grips for
middle-justified line
text

grips for right-justified
line text

alignment point

alignment point

The effect of a command depends on which grip you choose.

To edit single-line text

1 Click Modify menu ➤ Object ➤ Text ➤ Edit.

2 Select a single-line text object.

3 In the in-place editor, enter the new text.

4 Press ENTER .
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5 Select another text object to edit, or press  ENTER  to end the command.

To modify properties of single-line text objects

1 Select a single-line text object.

2 Right-click the selected object. Click Properties.

3 In the Properties palette, enter any new text, and then change formatting
and other properties as needed.

Standard toolbar

Change Multiline Text

You can change the location and content of multiline text objects with the
Properties palette, the In-Place Text Editor, and grips. You can easily find and
replace text with the FIND command.

After you create multiline text, you can use the Properties palette to change

■ Text style assignment

■ Justification

■ Width

■ Rotation

■ Line spacing

In addition, you can use the In-Place Text Editor to modify individual
formatting, such as boldface and underlining, and to change the width of the
multiline text object.

Change Text Location

You can use grips to move multiline text or to resize the line width. A multiline
text object has grips at the four corners of the text boundary and, in some
cases, at the justification point.

If you use the Properties palette to move multiline text, you can edit content
and change properties at the same time.
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Commands such as  or  create multiline text automatically without requiring
that a bounding box be specified; these objects have only a single grip at the
justification point.

Find and Replace Text

To search for and replace text, use . Replacement is based on text content
only; character formatting and text properties are not changed.

With FIND, you can use wild-card characters in your search.

DefinitionCharacter

Matches any numeric digit# (Pound)

Matches any alphabetic character@ (At)

Matches any nonalphanumeric character. (Period)

Matches any string and can be used anywhere in the search
string

* (Asterisk)

Matches any single character; for example, ?BC matches ABC,
3BC, and so on

? (Question mark)

Matches anything but the pattern; for example; ~*AB*matches
all strings that don't contain AB

~ (Tilde)

Matches any one of the characters enclosed; for example, [AB]C
matches AC and BC

[ ]

Matches any character not enclosed; for example, [~AB]C
matches XC but not AC

[~]

Specifies a range for a single character; for example, [A-G]C
matches AC, BC, and so on to GC, but not HC

[-]

Reads the next character literally; for example, `~AB matches
~AB

` (Reverse quote)

To search for drawing files that contain a specific word or phrase, use the
Search tool in Microsoft® Windows® . You can use the Search tool to find all
textual data except text in tables and fields, and Xrefs within drawing files.

See also:

“Work with Text Styles” on page 733
“Control the Display of Polylines, Hatches, Gradient Fills, Lineweights, and Text”
on page 306
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To change multiline text

1 Select a multiline text object.

2 Right-click the selected object. Click Properties.

3 In the Properties palette, enter any new text and change formatting and
other settings as needed.

Standard toolbar

To find specified text in a drawing

1 Click Edit menu ➤ Find.

2 In Find Text String, enter the text you want to find.

3 In Search In, select Entire Drawing or click the Select Objects button to
select one or more text objects.

4 Click Options to specify the types of text to include in the search,
whether to find whole words only, and whether to match the case of
the specified text.

5 Click Find.

The Context area displays the found text with its surrounding context.

6 To zoom to the found text in the drawing, click Zoom To.

7 Click Close.

To replace text

1 Click Edit menu ➤ Find.

2 In Find Text String, enter the text you want to find.

3 In Search In, select Entire Drawing or click the Select Objects button to
select one or more text objects.

4 Click Options to specify the types of text to include in the search,
whether to find whole words only, and whether to match the case of
the specified text.

5 In Replace With, enter the text with which you want to replace the found
text.

6 Click Find.
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The Context area displays the found text with its surrounding context.

7 Use one of the following methods:

■ To replace only the found instance of the text string, click Replace.

■ To replace all instances of the text in Find Text String, click Replace
All.

The replacement is confirmed in the status area at the bottom of the
dialog box.

8 Click Close.

To change the width of a multiline text object

1 Double-click the multiline text object.

2 In the In-Place Text Editor, use one of the following methods:

■ Move the cursor over the right end of the ruler until the cursor changes
to a double arrow. As you drag to the right to stretch the ruler, a tooltip
displays the width. Release to set a new width.

■ Right-click the bottom of the ruler. Click Set Mtext Width. In the
dialog box, enter the width in drawing units.

3 To save your changes and exit the editor, use one of the following
methods:

■ Click OK on the toolbar.

■ Click in the drawing outside the editor.

■ Press  CTRL +  ENTER .

Change Text with a Leader

You can change both the text component and the leader geometry component
of leader objects.

To resize a leader, stretch or scale it. Stretching modifies the offset between
the leader endpoint and its annotation. Scaling updates the scale of the selected
object only. For example, if you scale the leader, the annotation stays in the
same position relative to the leader endpoint but is not scaled itself. Leaders
can function as edges for trimming and extending, but they cannot be trimmed
or extended.

Change Text | 747



To edit leader text

1 Double-click the text you want to edit.

The In-Place Text Editor is displayed for both single-line text and
multiline text. The Text Formatting toolbar is not available for single-line
text.

2 Edit the text.

You can also select the text and right-click. Click Properties. Edit the text
in the Properties palette.

Any modification to the annotation that changes the annotation position
or its attachment point affects the leader's endpoint position. Rotating
the annotation causes the leader hook line (if any) to rotate.

Change Text Scale and Justification

You can change the scale of one or more text objects, attributes, and attribute
definitions, or their insertion points, simultaneously without changing the
location of the objects.

Change the Scale of Multiple Text Objects

A drawing may contain hundreds of text objects that need to be scaled, and
it would be tedious to scale them individually. Use  to change the scale of one
or more text objects such as text, multiline text, and attributes. You can specify
a relative scale factor or an absolute text height, or you can scale selected text
to match the height of existing text. Each text object is scaled using the same
scale factor, and it maintains its current location.

Convert Text Height Between Model Space and Paper Space

The  command converts distances between model space units and paper space
units. By using SPACETRANS transparently, you can provide commands with
distance entries relative to another space. For example, you may want to create
a text object in model space that matches the height of other text in a layout.
From model space, you could enter

Command: text
Specify start point of text or [Justify/Style]: 1,3
Specify height <0.375>: 'spacetrans
>>Specify paper space distance <1.000>: 3/8
Resuming TEXT command
Specify height <0.375>: 1.173

When the command is complete, a text object is created in model space with
a height of 1.173, which appears as 3/8 when viewed from a layout.
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For more information about entering commands transparently, see “Enter
Commands on the Command Line” on page 52.

Change the Justification of Text Objects Without Changing Their Location

Use  to redefine the insertion point of text without moving the text. For
example, a table or schedule may contain text that is located correctly but
each text object in the table should be right-justified instead of left-justified
for future entries or modifications.

Check Spelling
You can check the spelling of all text in your drawing, including

■ Single-line text

■ Multiline text

■ Text within attribute values

■ Text within block references and their associated block definitions

■ Text within nested blocks

Spelling is checked only in objects in the current selection set. If you enter
the All option when selecting objects, spelling is checked in all objects in
model space and in all layouts. Spelling is not checked in block definitions of
unselected block references or in text within dimensions.

Switch Dictionaries

The program contains several main dictionaries, which are available in different
languages. The main dictionaries use a standard word list that you can
customize.

During a spelling check, the words in the drawing are matched to the words
in the current main dictionary. Any words you add are stored in the custom
dictionary that is current at the time of the spelling check. For example, you
can add proper names so they are no longer identified as misspelled words.

To check spelling in another language, you can change to a different main
dictionary. You can also create any number of custom dictionaries and switch
to them as needed.

You can change dictionaries in a dialog box or by specifying the dictionary
name in the  or  system variable. For a list of the dictionary file names, see
DCTMAIN.
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Create and Edit Custom Dictionaries

A custom dictionary is a list of spelling exceptions that you have identified.
The files that contain them can be identified by the .cus file extension. You
can use any ASCII text editor to add and delete words or to combine
dictionaries. If a word is preceded by a tilde (~), the word is always flagged as
incorrect.

You can also create and edit dictionaries from inside the program.

To check spelling

1 Click Tools menu ➤ Spelling.

2 Select the text objects you want to check, or enter all to select all text
objects.

3 If no mispelled words are found , a message is displayed. If a misspelling
is found , the Check Spelling dialog box identifies the misspelled word.

4 Do one of the following:

■ To correct a word, select an alternate word from the Suggestions list
or type a word in the Suggestions box. Click Change or Change All.

■ To leave a word unchanged, click Ignore or Ignore All.

■ To leave a word unchanged and add it to the custom dictionary, click
Add. (This option is not available unless a custom dictionary is
specified.)

5 Repeat step 4 for each misspelled word. Click OK or Cancel to exit.

To switch dictionaries while checking spelling

1 Click Tools menu ➤ Spelling.

2 Select the text that you want to check and press  ENTER .

3 In the Check Spelling dialog box, click Change Dictionaries.

4 Do one of the following:

■ To change the main dictionary, select a dictionary from the Main
Dictionary list.

■ To change the custom dictionary, select or enter a name under Custom
Dictionary.

■ To select from a list of dictionaries, click Browse.

5 Click Apply and Close.
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To create or edit custom dictionaries during a spelling check

1 Click Tools menu ➤ Spelling.

2 Select the text that you want to check and press  ENTER .

3 In the Check Spelling dialog box, click Change Dictionaries.

4 In the Change Dictionaries dialog box, under Custom Dictionary, specify
the dictionary you want to edit using one of these methods:

■ To specify a dictionary, enter its name, using the .cus file extension.

■ To select from a list of folders, click Browse.

■ To create a new custom dictionary, enter a new name. Use the .cus
file extension.

5 To add a word, enter it under Custom Dictionary Words. Click Add.

6 To remove a word, select it from the list. Click Delete.

7 Click OK.

Use an Alternate Text Editor
The default text editor is the In-Place Text Editor, but you can elect to use any
alternate editor that saves files in ASCII format.

Overview of Using an Alternate Text Editor

The default text editor is the In-Place Text Editor, but you can elect to use an
alternate editor by specifying the editor with the  system variable. You can
use any text editor, such as Microsoft Notepad, that saves files in ASCII format.

If you use an alternate text editor for multiline text, you specify the properties
of the multiline text object on the command line first. Then the text editor
opens for entering text. When you close the text editor, the text is inserted
within the width limit you specified.

If you use an alternate editor, you must enter special codes to apply formatting.

To edit text using an alternate text editor, use the same format codes. To avoid
losing format information when you make changes to the text, use the same
text editor you used to create the text.

Use an Alternate Text Editor | 751



Format Multiline Text in an Alternate Text Editor

If you use an alternate text editor, you apply formatting by entering format
codes. You can underline text, add a line over text, and create stacked text.
You can also change color, font, and text height. You can change the spaces
between text characters or increase the width of the characters themselves.
To apply formatting, use the format codes shown in the following table.

Format codes for paragraphs

To produce this …Enter this …PurposeFormat code

Autodesk AutoCAD

Autodesk \OAutoCAD\oTurns overline on
and off

\0...\o

Autodesk AutoCAD

Autodesk \LAutoCAD\lTurns underline on
and off

\L...\l

Autodesk
AutoCAD LT

Autodesk AutoCAD\~LTInserts a nonbreaking
space

\~

Autodesk \\AutoCADInserts a backslash\\

Autodesk \{AutoCAD\}Inserts an opening and
closing brace

\{...\}

Autodesk \C2;AutoCADChanges to the
specified color

\Cvalue;

Autodesk \Ftimes; AutoCADChanges to the
specified font file

\File name;

Autodesk \H2;AutoCADChanges to the text
height specified in
drawing units

\Hvalue;

Autodesk

AutoCAD

Autodesk \H3x;AutoCADChanges the text height
to a multiple of the
current text height

\Hvaluex;
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Format codes for paragraphs

To produce this …Enter this …PurposeFormat code

1.000\S+0.010^-0.000;Stacks the subsequent text
at the /, #, or ^ symbol

\S...^...;

\T2;AutodeskAdjusts the space between
characters, from .75 to 4
times

\Tvalue;

\Q20;AutodeskChanges obliquing angle\Qangle;

\W2;AutodeskChanges width factor to
produce wide text

\Wvalue;

\A1;1\S1/2Sets the alignment value;
valid values: 0, 1, 2
(bottom, center, top)

\A

Autodesk
AutoCAD

Autodesk\PAutoCADEnds paragraph\P

Braces can be nested up to eight levels deep.

You can also use control codes to add special characters, such as tolerance or
dimensioning symbols. See .

Example: Formatting Text in an Alternate Text Editor

This example describes how the text in the following illustration was created.

Use an Alternate Text Editor | 753



Big text
over text/ under text

Baseline: 1
1
2

Center: 1 12

Topline: 1 1
2

Tolerances: 1.000
+0.010
-0.000

Architectural: 9-11/16"

Each line below was entered in an alternate text editor:

{{\H1.5x; Big text} \A2; over text\A1;/\A0; under text}\P

{\A0;Baseline: 1 \S1/2;}\P

{\A1;Center: 1 \S1/2;}\P

{\A2;Topline: 1 \S1/2;}\P

{Tolerances: \A1;1.000\H.75x;\S+0.010^-0.000;}\P

{Architectural: 9-{\H.666x;\A2;11\A1;/\A0;16}\A2;"}\P

To specify an alternate text editor

1 At the Command prompt, enter mtexted.

2 At the prompt do one of the following:

■ Enter the path and name of the executable file for the ASCII text editor
that you want to use to create or edit multiline text.

■ Enter internal to restore the text editor.

To create multiline text in an alternate text editor

1 To specify a text editor, at the Command prompt, enter mtexted. Then
enter the path of the editor you want to use.
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2 Click Draw menu ➤ Text ➤ Multiline Text.

3 Specify the first corner of the multiline text boundary rectangle.

4 Specify the opposite corner of the multiline text boundary rectangle.

5 In the text editor, enter the text. Enter \P to end a paragraph and start
a new paragraph on the next line. (Be sure to capitalize the P.)

6 When your text entry is complete, save the changes and exit the text
editor.

Draw toolbar
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Tables

 
A table is a rectangular array of cells that contain annotation,

primarily text but also blocks. Tables appear in many different

forms on many of the sheets that make up drawing sets. In

the AEC industry, tables are often referred to as “schedules”

and contain information about the materials needed for the

construction of the building being designed. In the

manufacturing industry, they are often referred to as “BOM”

(bills of materials).

The table object creates a table of any size that can be used

for any purpose, including as a list or index to a set of drawing

sheets to be published.

24
In this chapter

■ Create and Modify Tables

■ Work with Table Styles

■ Add Text and Blocks to Tables

■ Use Formulas in Table Cells



Create and Modify Tables
A table is an object that contains data in rows and columns. When you create
a table object, you first create an empty table, and then you add content to
the cells in the table.

After the table has been created, you can click any gridline on the table to
select it and then modify it by using the Properties palette or grips.

changes table
width

changes table
height and width

widens or
narrows a column

moves the
table

changes table
height

When you change the height or width of the table, the rows or columns
change proportionally. When you change the width of a column, the table
widens or narrows to accommodate the change. To maintain the table width,
press  CTRL  while you use a column grip.

Modify a Table Cell

You can click inside a cell to select it. Grips are displayed in the middle of the
cell borders. Click inside another cell to move selection to that cell. Drag the
grips on a cell to make the cell and its column or row larger or smaller.

To select more than one cell, click and drag over several cells. You can also
hold down  SHIFT  and click inside another cell to select those two cells and
all the cells between them.

With a cell selected, right-click and use the options on the shortcut menu to
insert or delete columns and rows, combine adjacent cells, or make other
changes. When cells are selected, you can use  CTRL +  Y  to repeat the last
action, including changes made in the Property palette.

Add a Table to a Tool Palette

When you add a table to a tool palette, the table properties (for example, table
style and number of rows and columns) and the cell property overrides (for
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example, alignment and border lineweight) are stored in the tool definition.
The text or block content and character formatting is ignored.

See also:

“Add Text and Blocks to Tables” on page 765

To create a table

1 Click Draw menu ➤ Table.

2 In the Insert Table dialog box, select a table style from the list, or click
the [...] button to create a new table style.

3 Select an insertion method:

■ Specify an insertion point for the table.

■ Specify a window for the table to fit.

4 Set the number of columns and the column width.

If you used the window insertion method, you can select the number
of columns or the column width, but not both.

5 Set the number of rows and the row height.

If you used the window insertion method, the number of rows is
determined by the size of the window you specified and the row height.

6 Click OK.

To use grips to modify a table

1 Click a gridline to select the table.

2 Use one of the following grips:

■ Upper-left grip. Moves the table.

■ Upper-right grip. Changes the width of the table and all columns
proportionally.

■ Lower-left grip. Changes the height of the table and all rows
proportionally.

■ Lower-right grip. Changes both the height and the width of the
table and changes the columns and rows proportionally.

■ Column grip (at the top of the column head row). Changes the
width of the column to the left of the grip and widens or narrows the
table to accommodate the change.
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■ CTRL +  a column grip. Widens or narrows adjacent columns
without changing the width of the table.

The minimum column width is the width of a single character. The
minimum row height for an empty table is the height of a line of text
plus the cell margins.

3 Press  ESC  to remove selection.

To use grips to modify cells in a table

1 Select one or more cells in a table that you want to change using one of
the following methods:

■ Click inside a cell.

■ Hold down  SHIFT  and click inside another cell to select those two
cells and all the cells between them.

■ Click inside the selected cell, drag to the cells you want to select, and
release.

2 To change the row height of the selected cell, drag the top or bottom
grip.

If more than one cell is selected, the row height changes equally for each
row.

3 To change the column width of the selected cell, drag the left or right
grip.

If more than one cell is selected, the column width changes equally for
each column.

4 To merge selected cells, right-click. Click Merge Cells.

If cells in more than one row or column are selected, you can merge by
row or by column.

5 Press  ESC  to remove selection.

To use the Properties palette to modify a table

1 Click a gridline to select the table.

2 Click Tools menu ➤ Properties.

3 In the Properties palette, click the value you want to change and enter
or select a new value.

The property is changed in the selected table.
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4 Move the cursor outside the Properties palette, and press  ESC  to remove
selection.

To change column width or row height in a table

1 Click inside a table cell in the column or row you want to change.

Hold down SHIFT and click inside another cell to select those two cells
and all the cells between them.

2 Click Tools menu ➤ Properties.

3 In the Properties palette, under Cell, click the cell width or the cell height
value and enter a new value.

4 Press  ESC  to remove selection.

To add columns or rows to a table

1 Click inside a table cell where you want to add a column or a row.

You can select more than one cell to add more than one column or row.

2 Right-click and use one of the following options:

■ Insert Column ➤ Right. Inserts a column to the right of the selected
cell.

■ Insert Column ➤ Left. Inserts a column to the left of the selected
cell.

■ Insert Row ➤ Above. Inserts a row above the selected cell.

■ Insert Row ➤ Below. Inserts a row below the selected cell.

3 Press  ESC  to remove selection.

To merge cells in a table

1 Select the cells in a table that you want to merge using one of the
following methods:

■ Select a cell, and hold down  SHIFT  and click inside another cell to
select those two cells and all the cells between them.

■ Click inside a selected cell, drag to the cells you want to select, and
release.

The resulting merged cell must be rectangular.
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2 Right-click. Click Merge Cells. If you want to create more than one
merged cell, use one of the following options:

■ By Row: Merges the cells horizontally by removing the vertical
gridlines and leaving the horizontal gridlines intact.

■ By Column: Merges the cells vertically by removing the horizontal
gridlines and leaving the vertical gridlines intact.

3 Start typing to enter text in the new merged cell, or press  ESC  to remove
selection.

To delete columns or rows in a table

1 Click inside a table cell in the column or row that you want to delete.

Hold down SHIFT and click inside another cell to select those two cells
and all the cells between them.

2 Right-click and use one of the following options:

■ Delete Columns. Deletes the columns you specified.

■ Delete Rows. Deletes the rows you specified.

3 Press  ESC  to remove selection.

To export a table

1 At the Command prompt, enter tableexport.

2 Select the table that you want to export.

A standard file selection dialog box is displayed.

3 Enter a file name and select a location for the file.

Table data is exported in the comma-separated (CSV) file format. All
table and text formatting is lost.

With a table selected, right-click. Click Export.

Work with Table Styles
The appearance of the table is controlled by its table style. You can use the
default table style, STANDARD, or create your own table styles.

The table style can specify formatting for rows. In the STANDARD table style,
for example, the first row is a title row that consists of a row of merged cells
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with text that is centered. The second row is for column heads, and all the
other rows are data rows.

The table style can specify different justification and appearance for the text
and gridlines in each type of row. For example, a table style can specify larger
text for the title row or center alignment for the column heads row and left
alignment for the data rows.

The table can read from top to bottom or from the bottom up. The number
of columns and rows is almost unlimited.

The border properties in a table style control the display of the gridlines that
divide the table into cells. The borders of the title row, the column heads row,
and the data rows can have different lineweight and color and can be displayed
or not displayed. The preview image in the Table Style dialog box updates as
you select border options.

The appearance of text in the cells of the table is controlled by the text style
that is specified in the current table style. You can use any text style in the
drawing or create a new one. You can also use DesignCenter to copy table
styles from other drawings.

See also:

“Work with Text Styles” on page 733

To define or modify a table style

1 Click Format menu ➤ Table Style.

2 In the Table Style dialog box, click New.

3 In the Create New Table Style dialog box, enter a name for the new table
style, select a table style in Start With to provide default settings for the
new table style, and click Continue.

4 In the New Table Style dialog box, set the following options for the whole
table:

■ Table Direction. Select Down or Up. Up creates a table that reads
from the bottom up; the title row and the column heads are at the
bottom of the table.

■ Cell Margins. Enter a value for the vertical and horizontal spacing
between the border of the cell and the cell content. The default setting
is one-third of the text height in the data rows, and the maximum is
the text height in the data rows.

5 To set the appearance of the data cells, the column head cells, or the
title cell, click the appropriate tab.
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6 If you want to include a title row or a header row, on the Title tab or the
Column Heads tab (as appropriate), select or clear the following options:

■ Include Title Row. When this option is selected, the first row in
the table is all one cell that has the appearance that you set on the
Title tab.

■ Include Header Row. When this option is selected, the first row
in each column is a column heads row that has the appearance that
you set on the Column Heads tab.

When both options are selected, the first row of the table is a title row,
and the second row is a column heads row.

7 On any of the tabs, use the following cell properties options to control
the appearance of the cell contents:

■ Text Style. Select a text style, or click the [...] button to open the
Text Style dialog box and create a new text style.

■ Text Height. Enter a height for the text. This option is available
only when the selected text style has a text height of 0. (The default
text style, STANDARD, has a 0 text height.) If the selected text style
specifies a fixed text height, this option is unavailable.

■ Text Color. Select a color, or click Select Color to display the “Select
Color Dialog Box”Select Color dialog box.

■ Fill Color. Select None or a background color, or click Select Color
to display the “Select Color Dialog Box”Select Color dialog box.

■ Alignment. Specify an alignment for cell contents. Center refers to
horizontal alignment; Middle refers to vertical alignment.

8 Use the following border properties options to control the appearance
of the gridlines:

■ Border display buttons. Click a button to apply lineweight and
color properties to all borders of the cell, the outside border, the inside
borders (not available on the Title tab), no borders, or the bottom
border. The preview in the dialog box updates to show the effect.

■ Grid Lineweight. Enter the lineweight to be used for borders that
are displayed. If you use a heavy lineweight, you may have to change
the cell margins so that the text can be seen.

■ Grid Color. Select a color to be used for borders that are displayed,
or click Select Color to display the “Select Color Dialog Box”Select
Color dialog box.
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9 Click another tab to continue defining the table style, or click OK to exit
the dialog box.

To apply a new table style to a table

1 Click a gridline to select the table.

2 Click Tools menu ➤ Properties.

3 In the Properties palette, under Table, click the Table Style value and
select a table style.

The new table style is applied to the table.

NOTE If the previous table style had a title row and the new one does not,
the title text is placed in the first cell of the table, and the other cells in the
first row are left blank.

4 Press ESC twice to remove selection.

To change the table style that is applied to new tables

1 Click Format menu ➤ Table Style.

2 In the Table Style dialog box, select a table style. Click Set Current.

3 Click Close.

The current table style is applied to new tables that you create.

Add Text and Blocks to Tables
The data in a table cell can be text or a block.

When the table is created, the first cell is highlighted, the Text Formatting
toolbar is displayed, and you can begin entering text. The row height of the
cell increases to accommodate the number of lines of text. To move to the
next cell, press  TAB , or use the arrow keys to move left, right, up, and down.

When you insert a block into a table cell, either the block can be automatically
fit to the size of the cell, or the cell can adjust to accommodate the size of the
block.

Inside the cell, the arrow keys move the cursor. Use the toolbar and the
shortcut menu to format text, import text, or make other changes to the text
in the cell.
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See also:

“Use Fields in Text” on page 725
“Create Multiline Text” on page 701

To enter text in a table

1 Click inside a table cell, and start to enter text.

The Text Formatting toolbar is displayed.

2 Use the arrow keys to move the cursor in text inside a cell.

3 To create a line break within a cell, press ALT +  ENTER  .

4 To override the text style specified in the table style, click the arrow next
to the Text Style control on the toolbar and select a new text style.

The text style you select is applied to the text in the cell and any new
text that you enter in the cell.

5 To override the formatting in the current text style, first select text as
follows:

■ To select one or more characters, click and drag the pointing device
over the characters.

■ To select a word, double-click the word.

■ To select all the text in the cell, triple-click in the cell. (You can also
right-click. Click Select All.)

6 On the toolbar, make format changes as follows:

■ To change the font of the selected text, select a font from the list.

■ To change the height of the selected text, enter a new value in the
Height box.

■ To format text in a TrueType font with boldface or italics, or to create
underlined text for any font, click the corresponding button on the
toolbar. SHX fonts do not support boldface or italics.

■ To apply color to selected text, choose a color from the Color list.
Click Other to display the “Select Color Dialog Box”Select Color dialog
box.

7 Use the keyboard to move from cell to cell:

■ Press  TAB  to move to the next cell. In the last cell of the table, press
TAB  to add a new row.

■ Press  SHIFT +  TAB  to move to the previous cell.
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■ When the cursor is at the beginning or end of text in a cell, use the
arrow keys to move the cursor to adjacent cells. You can also use
CTRL + an arrow key.

■ When text is highlighted in a cell, press an arrow key to remove
selection and move the cursor to the beginning or end of the text in
the cell.

■ Press  ENTER  to move down one cell.

8 To save your changes and exit, click OK on the toolbar or press  CTRL +
ENTER  .

To change the properties of cells in a table

1 Click inside the table cell you want to change.

Hold down SHIFT and click inside another cell to select those two cells
and all the cells between them.

2 Use one of the following methods:

■ To change one or more properties, in the Properties palette, click the
value you want to change and enter or select a new value.

■ To restore the default properties, on the shortcut menu, click Remove
Property Overrides.

To copy the properties of a cell to other cells

1 Click inside the table cell whose properties you want to copy.

2 (Optional) To view the current properties of the selected table cell, press
CTRL +  1  to open the Properties palette.

All the properties of the cell are copied except the cell type: text or block.

3 Right-click. Click Match Cell.

The cursor changes to a paintbrush.

4 To copy the properties to another table cell in the drawing, click inside
the cell.

5 Right-click or press  ESC  to stop copying properties.

To change the lineweight or color of the borders of table cells

1 Click inside the table cell you want to change.
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Hold down SHIFT and click inside another cell to select those two cells
and all the cells between them.

2 Right-click. Click Cell Borders.

3 In the Cell Border Properties dialog box, select a lineweight and a color.

Use BYBLOCK to set the border properties to match the settings in the
table style that has been applied to the table.

4 Click one of the border type buttons to specify which borders of the cell
to modify, or select a border in the preview image.

5 Click OK.

6 Move the cursor outside the Properties palette, and press  ESC  to remove
selection, or select another cell.

To edit text in a table cell

1 Double-click inside the cell whose text you want to edit, or select the
cell and click Edit Cell on the shortcut menu.

2 Use the Text Formatting toolbar or the shortcut menu to make changes.

3 To save the changes and exit, click OK on the toolbar, press  CTRL +
ENTER , or click outside the cell.

4 To remove selection from the table, press  ESC .

To insert a block in a table cell

1 Click inside the table cell to select it and right-click. Click Insert Block.

2 In the Insert dialog box, select a block from the list of blocks in the
drawing, or click Browse to find a block in another drawing.

3 Specify the following properties for the block:

■ Cell Alignment. Specifies alignment for the block in the table cell.
The block is middle-, top-, or bottom-aligned with respect to the top
and bottom borders of the cell. The block is center-, left-, or
right-aligned with respect to the left and right borders of the cell.

■ Scale. Specifies the scale for the block reference. Enter a value or select
AutoFit to scale the block to fit in the selected cell.

■ Rotation Angle. Specifies a rotation angle for the block.

4 Click OK.

If the block has attributes attached, the Edit Attributes dialog box is
displayed.
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To insert a field in a table cell

1 Double-click inside the table cell.

2 Right-click. Click Insert Field, or press  CTRL +  F .

3 In the Field dialog box, select a category in the Field Category list to
display the field names in that category.

4 Select a field.

5 Select the format or other options available for that field.

6 Click OK.

Use Formulas in Table Cells
Table cells can contain formulas that do calculations using the values in other
table cells. With a table cell selected, you can insert formulas from the shortcut
menu. You can also open the In-Place Text Editor and enter a formula in a
table cell manually.

Insert a Formula

In formulas, cells are referred to by their column letter and row number. For
example, the cell at top left in the table is A1. Merged cells use the number
of what would be the top-left cell. A range of cells is defined by the first and
last cells, with a colon between them. For example, the range A5:C10 includes
cells in rows 5 through 10 in columns A, B, and C.

A formula must start with an equal sign (=). The formulas for sum, average,
and count ignore empty cells and cells that do not resolve to a numeric value.
Other formulas display an error (#) if any cell in the arithmetic expression is
empty or contains nonnumeric data.

Use the Cell option on the shortcut menu to select a cell in another table in
the same drawing. When you have selected the cell, the In-Place Text Editor
opens so you can enter the rest of the formula.

Copy a Formula

When you copy a formula to another cell in the table, the range changes to
reflect the new location. For example, if the formula in A10 sums A1 through
A9, when you copy it to B10, the range of cells changes so that it sums B1
through B9.

If you don’t want a cell address to change when you copy and paste the
formula, add a dollar sign ($) to the column or row part of the address. For
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example, if you enter $A10, the column stays the same and the row changes.
If you enter $A$10, both column and row stay the same.

Customize Display of Column Letters and Row Numbers

By default, the In-Place Text Editor displays column letters and row numbers
when a table cell is selected for editing. Use the  system variable to turn this
display on and off. To set a new background color, select a table, right-click,
and click Table Indicator Color on the shortcut menu. The text color, size,
and style and the line color are controlled by the settings for column heads
in the current table style.

See also:

“Use Fields in Text” on page 725

To sum the values in a range of table cells

1 Select the table cell where you want to place the formula by clicking
inside it.

2 Right-click. Click Insert Formula ➤ Sum.

The following prompt is displayed:

Select first corner of table range:

3 Click inside the first cell in the range.

The following prompt is displayed:

Select second corner of table range:

4 Click inside the last cell in the range.

The In-Place Text Editor opens and displays the formula in the cell.

5 Edit the formula, if necessary.

6 To save your changes and exit the editor, use one of the following
methods:

■ Click OK on the toolbar.

■ Click in the drawing outside the editor.

■ Press  CTRL +  ENTER .

The cell displays the sum of the values in the range of cells. Empty cells
and cells that do not resolve to a numeric value are ignored.

770 | Chapter 30   Tables



To average the values in a range of table cells

1 Select the table cell where you want to place the formula by clicking
inside it.

2 Right-click. Click Insert Formula ➤ Average.

The following prompt is displayed:

Select first corner of table range:

3 Click inside the first cell in the range.

The following prompt is displayed:

Select second corner of table range:

4 Click inside the last cell in the range.

The In-Place Text Editor opens and displays the formula in the cell.

5 Edit the formula, if necessary.

6 To save your changes and exit the editor, use one of the following
methods:

■ Click OK on the toolbar.

■ Click in the drawing outside the editor.

■ Press  CTRL +  ENTER .

The cell displays the average of the values in the range of cells. Empty
cells and cells that do not resolve to a numeric value are ignored.

To count the cells in a table column or a table row

1 Select the table cell where you want to place the formula by clicking
inside it.

2 Right-click. Click Insert Formula ➤ Count.

The following prompt is displayed:

Select first corner of table range:

3 Click inside the first cell in the range.

The following prompt is displayed:

Select second corner of table range:

4 Click inside the last cell in the range.

The In-Place Text Editor opens and displays the formula in the cell.

5 Edit the formula, if necessary.
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6 To save your changes and exit the editor, use one of the following
methods:

■ Click OK on the toolbar.

■ Click in the drawing outside the editor.

■ Press  CTRL +  ENTER .

The cell displays the total number of cells in the range.

To use a cell from a different table in a formula

1 Select the table cell where you want to place the formula by clicking
inside it.

2 Right-click. Click Insert Formula ➤ Cell.

The following prompt is displayed:

Select table cell:

3 Click inside the cell in the other table.

The In-Place Text Editor opens and displays the cell address.

4 Enter the rest of the formula.

5 To save your changes and exit the editor, use one of the following
methods:

■ Click OK on the toolbar.

■ Click in the drawing outside the editor.

■ Press  CTRL +  ENTER .

The cell displays the result of the calculation.

To manually enter a formula in a table cell

1 Double-click inside a table cell.

The In-place Text Editor opens.

2 Enter a formula (a function or an arithmetic expression), as in the
following examples:

■ =sum(a1:a25,b1). Sums the values in the first 25 rows of column A
and the first row in column B.

■ =average(a100:d100). Calculates the average of the values in the
first 4 columns in row 100.
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■ =count(a1:m500). Displays the total number of cells in column A
through column M in rows 1 through 100.

■ =(a6+d6)/e1. Adds the values in A6 and D6 and divides the total by
the value in E1.

Use a colon to define a range of cells and a comma for individual cells.
A formula must start with an equal sign (=) and can contain any of
the following signs: plus (+), minus (-), times (*), divided by (/),
exponent (^), and parentheses ().

3 To save your changes and exit the editor, use one of the following
methods:

■ Click OK on the toolbar.

■ Click in the drawing outside the editor.

■ Press  CTRL +  ENTER .

The cell displays the result of the calculation.

To turn off the display of column letters and row numbers for tables

1 On the command line, enter tableindicator.

2 At the Enter New Value prompt, enter 0.

When  is set to 1, the In-Place Text Editor displays column letters and row
numbers when a table cell is selected.

To change the background color of column letters and row numbers for tables

1 Click a grid line to select a table.

2 Right-click. Click Table Color Indicator.

3 In the Select Color dialog box, select a color.

4 Click OK.

The text color, size, and style and the line color are controlled by the
settings for column heads in the current table style.

To insert a Formula field in a table cell

1 Double-click inside a table cell.

2 In the In-Place Text Editor, right-click. Click Insert Field.

3 In the Field dialog box, Field Category list, select Objects.
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4 In Field Names, select Formula.

5 To enter a formula, use any of the following methods one or more times:

■ Click Average, Sum, or Count. The Field dialog box closes temporarily.
To specify a range, click inside the first and the last cell. The result is
appended to the formula.

■ Click Cell. The Field dialog box closes temporarily. Select a cell in a
table in the drawing. The cell address is appended to the formula.

6 (Optional) Select a format and a decimal separator.

7 Click OK.

8 To save your changes and exit the editor, use one of the following
methods:

■ Click OK on the toolbar.

■ Click in the drawing outside the editor.

■ Press  CTRL +  ENTER .

The cell displays the result of the calculation.
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Understand Basic Concepts of Dimensioning
You can create several types of dimensions, and you can control their
appearance by setting up dimension styles or by editing individual dimensions.

Overview of Dimensioning

Dimensioning is the process of adding measurement annotation to a drawing.

You can create dimensions for a variety of object types in many orientations.
The basic types of dimensioning are

■ Linear

■ Radial (radius and diameter)

■ Angular

■ Ordinate

■ Arc Length

Linear dimensions can be horizontal, vertical, aligned, rotated, baseline, or
continued (chained). Some examples are shown in the illustration.

R2
0

baseline

continued

diameter

vertical
linear

aligned

horizontal linearangular

radius

NOTE To simplify drawing organization and dimension scaling, it is recommended
that you create dimensions on layouts rather than in model space.
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To create a dimension

1 Create a layer designated for dimensions and make it the current layer.

2 Near the bottom-left corner of the application window, click a layout
tab.

3 Click the Dimension menu and select a dimension command.

4 Follow the command prompts.

Parts of a Dimension

Here is a list of the parts of a dimension along with their descriptions.

Dimensions have several distinct elements: dimension text, dimension lines,
arrowheads, and extension lines.

60.00

REBAR
30cm O.C

dimension text

arrowhead

extension line

dimension line

leader

Dimension text is a text string that usually indicates the measurement value.
The text can also include prefixes, suffixes, and tolerances.

A dimension line indicates the direction and extent of a dimension. For angular
dimensions, the dimension line is an arc.

Arrowheads, also called symbols of termination, are displayed at each end of
the dimension line. You can specify different sizes and shapes for arrowheads
or tick marks.

Extension lines, also called projection lines or witness lines, extend from the
feature to the dimension line.

A center mark is a small cross that marks the center of a circle or arc.

Centerlines are broken lines that mark the center of a circle or arc.
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centerlines

center mark

Associative Dimensions

Dimensions can be associative, nonassociative, or exploded. Associative
dimensions adjust to changes in the geometric objects that they measure.

Dimension associativity defines the relationship between geometric objects
and the dimensions that give their distance and angles. There are three types
of associativity between geometric objects and dimensions.

■ Associative dimensions . Automatically adjust their locations,
orientations, and measurement values when the geometric objects associated
with them are modified. Dimensions in a layout may be associated to objects
in model space. The  system variable is set to 2.

■ Nonassociative dimensions . Selected and modified with the geometry
they measure. Nonassociative dimensions do not change when the
geometric objects they measure are modified. The dimension variable
DIMASSOC is set to 1.

■ Exploded dimensions . Contain a collection of separate objects rather
than a single dimension object. The DIMASSOC system variable is set to 0.

You can determine whether a dimension is associative or nonassociative by
selecting the dimension and doing one of the following:

■ Use the Properties palette to display the properties of the dimension.

■ Use the  command to display the properties of the dimension.

You can also use the Quick Select dialog box to filter the selection of associative
or nonassociative dimensions. A dimension is considered associative even if
only one end of the dimension is associated with a geometric object. The
command displays the associative and nonassociative elements of a dimension.
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Special Situations and Limitations

You may need to use  to update associative dimensions after panning or
zooming with a wheel mouse, after opening a drawing that was modified with
an earlier release, or after opening a drawing with external references that
have been modified.

Although associative dimensions support most object types that you would
expect to dimension, they do not support the following:

■ Hatches

■ Multiline objects

■ 2D solids

■ Objects with nonzero thickness

When selecting objects to dimension, make sure that the objects that you
select don’t include a directly overlapping object that does not support
associative dimensioning such as a 2D solid.

Associativity is not maintained between a dimension and a block reference if
the block is redefined.

Associativity is not maintained between a dimension and a 3D solid if the
shape of the 3D solid is modified.

Dimensions created with  are not associative but may be associated individually
with DIMREASSOCIATE.

NOTE In releases prior to AutoCAD 2002, the definitions of associative and
nonassociative dimensions were different and were controlled by the DIMASO
system variable. The behavior of dimensions is now controlled by the DIMASSOC
system variable.

For information about working with associative dimensions in combination
with previous releases, see “Save Drawings to Previous Drawing File Formats”.

See also:

“Change Dimension Associativity” on page 833

To change the dimension associativity default

1 Click Tools menu ➤ Options.

2 In the Options dialog box, User Preferences tab, under Associative
Dimensioning, select or clear Make New Dimensions Associative.
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3 Do either or both of the following:

■ Click Apply to record the current Options settings in the system
registry.

■ Click OK to record the current Options settings in the system registry
and close the Options dialog box.

All subsequently created dimensions in the drawing use the new setting. Unlike
most other option settings, dimension associativity is saved in the drawing
file rather than in the system registry.

Use Dimension Styles
You can control the appearance of dimensions by changing settings. For
convenience and to help maintain dimensioning standards, you can store
these settings in dimension styles.

Overview of Dimension Styles

A dimension style is a named collection of dimension settings that controls
the appearance of dimensions, such as arrowhead style, text location, and
lateral tolerances. You create dimension styles to specify the format of
dimensions quickly, and to ensure that dimensions conform to industry or
project standards.

■ When you create a dimension, it uses the settings of the current dimension
style

■ If you change a setting in a dimension style, all dimensions in a drawing
that use the style update automatically

■ You can create dimension substyles that, for specified types of dimensions,
deviate from the current dimension style

■ If necessary, you can override a dimension style temporarily

To set the current dimension style

■ On the Styles toolbar, in the Dimension Styles control, click the arrow and
select a dimension style from the list.
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Compare Dimension Styles and Variables

You can view all the settings in a dimension style. Dimension styles used in
externally referenced drawings are differentiated from those defined in your
current drawing.

You can list the dimension styles in the current drawing. You can also list all
dimensioning system variables and their current status or only the variables
affected by a dimension style.

When you list the current status of all dimensioning system variables, any
running overrides that apply to the current dimension style are listed. You
can also list the differences between a named dimension style and the current
dimension style.

Use Externally Referenced Dimension Styles

The program displays externally referenced dimension style names using the
same syntax as for other externally dependent named objects. When you view
externally referenced dimension styles using the Dimension Style Manager,
the name of the xref displays in the Styles list as Xref:drawing name with each
xref style appearing below the drawing name. For example, if the drawing file
baseplat.dwg has a dimension style called FRACTIONAL-1, and you attach
baseplat.dwg as an xref to a new drawing, then the xref dimension style is
displayed in the Styles list of the Dimension Style Manager as Xref:baseplat.dwg,
and FRACTIONAL-1 appears under the drawing name.

Externally referenced dimension styles can be examined, but they cannot be
modified or made current. You can use an externally referenced dimension
style as a template for creating a new dimension style in your current drawing.

To list all dimension settings for the current dimension style

1 Click Dimension menu ➤ Style.

2 In the Dimension Style Manager, select the style from the Styles list.

3 Click Compare.

The dimensioning system variables, their current settings, and a brief
description are listed. Overrides are included.

Dimension or Styles toolbar
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To list settings for an existing dimension style

1 Click Dimension menu ➤ Style.

2 In the Dimension Style Manager, enter a dimension style name, or select
a dimension whose dimension style you want to examine.

3 Click Compare.

Affected variables, their settings, and a brief description of each are listed.
Overrides are not included.

Dimension or Styles toolbar

To list dimension styles in the current drawing

1 Click Dimension menu ➤ Style.

2 In the Dimension Style Manager, under List, select All Styles or Style in
Use.

Dimension or Styles toolbar

To compare dimension styles

1 Click Dimension menu ➤ Style.

2 In the Dimension Style Manager, select the style to compare from the
Styles list.

3 Click Compare.

The dimension style is compared to the current dimension style.

Dimension or Styles toolbar
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Control Dimension Geometry

You can control the appearance of dimension lines, extension lines,
arrowheads, and center marks.

Control Dimension Lines

You can control dimension line properties including color, lineweight, and
spacing.

You can control several aspects of a dimension line. You can

■ Specify color and lineweight for visual effect and plotting

■ Suppress the dimension line or, if the dimension line is broken by text,
one or both halves

first dimension line
suppressed

second dimension
line suppressed

■ Control the spacing between successive dimension lines in baseline
dimensions

angular baseline dimensioning linear baseline dimensioning

dimension spacing

■ Control the distance by which the dimension line extends beyond the
extension lines for architectural tick (oblique stroke) arrowheads
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dimension line
extension past
extension line

To modify the display of dimension lines

1 Click Dimension menu ➤ Style.

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Lines tab, change the settings
under Dimension Lines as needed.

4 Click OK.

5 Click Close to exit the Dimension Style Manager.

Dimension or Styles toolbar

Control Extension Lines

You can control extension line properties including color, lineweight,
overshoot, and offset length.

You can control several aspects of the extension lines. You can

■ Specify color and lineweight for visual effect and plotting

■ Suppress one or both extension lines if they are unnecessary, or if there is
not enough space

first dimension line
suppressed

second dimension
line suppressed

■ Specify how far beyond the dimension line that the extension line extends
(overshoot)
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dimension line
extension past
extension line

■ Control the extension origin offset, the distance between the extension
line origin, and the start of the extension line

offset

■ Specify a fixed length for extension lines, as measured from the dimension
line toward the extension line origin

extension

■ Specify a noncontinuous linetype, typically used for centerlines

center mark centerlines

■ Modify the angle of the extension lines of a selected dimension to make
them oblique
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dimensions set to oblique

Fixed-Length Extension Lines

With the Dimension Style Manager, on the Lines tab, you can specify a
dimension style that sets the total length of extension lines starting from the
dimension line toward the dimension origin point.

16 17 16 22 13

fixed-length extension lines

The extension-line offset distance from the origin will never be less than the
value specified by the  system variable.

See also:

“Create Dimensions with Oblique Extension Lines” on page 814

To modify the display of extension lines

1 Click Dimension menu ➤ Style.

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.
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3 In the Modify Dimension Style dialog box, Lines tab, under Extension
Lines, change the settings as needed.

4 Click OK.

5 Click Close to exit the Dimension Style Manager.

Dimension or Styles toolbar

Control Dimension Arrowheads

You can control the arrowhead symbols in dimensions and leaders including
their type, size, and visibility.

You can choose from many standard types of arrowheads, or you can create
your own arrowheads. Additionally, you can

■ Suppress the display of arrowheads, or use one arrowhead only

■ Apply a different type of arrowhead to each end of a dimension line

■ Control the size of arrowheads

■ Flip the direction of an arrowhead using the dimension shortcut menu

NOTE Flipped arrowheads maintain their appearance in versions later than
AutoCAD 2002. However, if you edit a drawing with flipped arrowheads in a
release earlier than AutoCAD 2006, the arrowhead directions will revert to their
original orientations.

See also:

“Customize Arrowheads” on page 788

To choose an arrowhead

1 Click Dimension menu ➤ Style.

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Symbols and Arrows tab,
under Arrowheads, select the arrowhead type for the first end of the
dimension line.

The second arrowhead is automatically set to the same type.
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4 To set the second end of the dimension line to a different arrowhead
type, select an arrowhead type from the Second list.

5 In the Size box, enter a size for the arrowhead.

6 Click OK.

7 Click Close to exit the Dimension Style Manager.

Dimension or Styles toolbar

To flip the direction of an arrowhead

1 At the Command prompt, select a single dimension object near the
arrowhead that you want to flip.

2 Right-click. Click Flip Arrow.

Customize Arrowheads

You can create your own custom arrowheads.

Arrowheads are stored as block definitions. To use your own arrowhead,
provide the name of an existing block definition. For information about
creating blocks, see “Create Blocks Within a Drawing” on page 453.

Arrowhead sizing relies on the overall dimension scale factor. When you create
a dimension, the block is inserted where the arrowheads would normally go.
The object's X and Y scale factors are set to arrowhead size x overall scale. The
dimension line is trimmed by text gap x overall scale units at each end. To trim
the dimension line, the rightmost block is inserted with a zero rotation angle
for horizontal dimensioning. The leftmost block is rotated 180 degrees about
its insertion point.

If you use paper-space scaling, the scale factor is computed before applying it
to the arrowhead size value.

To use your own arrowhead symbol

1 Click Dimension menu ➤ Style.

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Dimension Style Manager, Symbols and Arrows tab, under
Arrowheads, select User Arrow from the First arrowhead list.
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4 In the Select Custom Arrow Block dialog box, enter the name of your
block. Click OK.

5 To choose a different custom arrowhead for the second arrowhead, repeat
steps 3 and 4, choosing User Arrow from the Second arrowhead list
(optional).

6 Click OK.

7 Click Close to exit the Dinemsion Style Manager.

Dimension or Styles toolbar

Control Dimension Text

You can control the placement of dimension text, arrowheads, and leader
lines relative to the dimension and extension lines.

Fit Dimension Text Within Extension Lines

Dimension text and arrowheads usually appear between the extension lines
when there is enough space. You can specify how these elements are placed
when space is limited.

Many factors, such as the size of extension line spacing and arrowhead size,
influence how dimension text and arrowheads fit within the extension lines.
In general, the best fit, given the available space, is applied. If possible, both
text and arrowheads are accommodated between the extension lines, no matter
what fit option you choose.

When creating new dimensions, you can choose to place text by entering a
coordinate or using the pointing device; this is known as user-defined text
placement. Alternatively, the program can compute the text position for you.
The options for automatic fitting of text and arrowheads are listed in the
Dimension Style Manager, Fit tab. For example, you can specify that text and
arrowheads be kept together. In this case, if there is not room for both between
the extension lines, they are both placed outside. You can specify that if there
is room for only text or arrowheads, then either text only or arrowheads only
are placed between the extension lines.

The following illustrations show how the program applies a "best fit" for
arrowheads and text.
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text and
arrowheads
inside

arrowheads
inside, text
outside

text inside,
arrowheads
outside

text and
arrowheads
outside

If there is no room for text between the extension lines, you can have a leader
line created automatically. This is useful in cases where text outside the
extension lines would interfere with other geometry, for example, in continued
dimensions. Whether text is drawn to the right or the left of the leader is
controlled by the horizontal justification setting on the Text tab of the
Modify/New Dimension Style dialog box. Also, you can fit text and arrowheads
by changing their size.

Even if the arrowheads are outside the extension lines, you can have a line
drawn between the extension lines. This is called forcing an internal line and
is illustrated as follows.

forced internal line

Fit Diameter Dimension Text

You can draw several different diameter dimensions depending on text
placement, horizontal settings on the Text tab, and whether you select the
Always Draw Dim Line Between Ext Lines options on the Fit tab.
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default horizontal
placement-text outside
circle, center mark, no
forced interior line

user-defined horizontal
placement-dimension line
and arrows, no center
mark, forced interior line

Text and Arrows inside
with Inside Horizontal
option selected

To place text within extension lines

1 Click Dimension menu ➤ Style.

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Fit tab, under Fit Options,
select an option.

4 Click OK.

5 Click Close to exit the Dimension Style Manager.

If there is enough room, text is fit between extension lines.

Dimension or Styles toolbar

To force an internal line and choose a fit option

1 Click Dimension menu ➤ Style.

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Fit tab, Under Fine Tuning,
select Always Draw Dim Line Between Ext Lines.

4 Under Fit Options, select an option.

5 Click OK.
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6 Click Close to exit the Dimension Style Manager.

Dimension or Styles toolbar

Control the Location of Dimension Text

You can locate dimension text manually and specify its alignment and
orientation.

The program comes with several justification settings that facilitate compliance
with international standards, or you can choose your own location for the
text.

text centered above
the dimension line

text centered
horizontally and
vertically

text left-justified
above the dimension
line

Many of the settings are interdependent. Example images in the Dimension
Style Manager are updated dynamically to illustrate how text appears as you
change the settings.

Align Dimension Text

Whether text is inside or outside the extension lines, you can choose whether
it is aligned with the dimension line or remains horizontal. The following
examples show two combinations of these options.
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text inside extension lines
oriented horizontally

text outside extension lines
aligned with dimension line

The default alignment is horizontal dimension text, even for vertical
dimensions.

Position Dimension Text Horizontally

The position of the text along the dimension line in relation to the extension
lines is referred to as text placement. To place text yourself when you create
a dimension, use the Place Text Manually When Dimensioning option on the
Fit tab of the Modify/New Dimension Style dialog box. Use the text placement
options to automatically place text at the center of the dimension line, at
either extension line, or over either extension line.

horizontal justification over
extension line one, vertical
justification of text, Centered over
extension line

horizontal justification over
extension line one, vertical
justification of text, Above
extension line

First and second extension lines are defined by the order in which you specified
the extension line origins when you created the dimension. For angular
dimensions, the second extension line is counterclockwise from the first. In
the following illustrations, 1 is the first extension line origin and 2 the second.
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text horizontal and
centered along
dimension line

text horizontal at first
extension line

text horizontal at
second extension line

1
2

1
2

1

2

If you place text manually, you can place the dimension text anywhere along
the dimension line, inside or outside the extension lines, as you create the
dimension. This option provides flexibility and is especially useful when space
is limited. However, the Horizontal alignment options provide better accuracy
and consistency between dimensions.

Position Dimension Text Vertically

The position of the text relative to the dimension line is referred to as vertical
text placement. Text can be placed above or below or centered within the
dimension line. In the ANSI standards, centered text usually splits the
dimension line. In the ISO standards, it is usually above or outside the
dimension line. For example, ISO standards permit angular dimension text
to appear in any of the ways shown.

ANSI standard text
centered within the
dimension line

ISO standard text
above the dimension
line

text aligned with and
centered within the
dimension line
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Other settings, such as Text Alignment, affect the vertical alignment of text.
For example, if Horizontal Alignment is selected, text inside the extension
lines and centered within the dimension line is horizontal, as shown in the
leftmost illustration above. The text is horizontal even if the dimension line
is not itself horizontal.

To align text with the dimension line

1 Click Dimension menu ➤ Style.

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Text tab, under Text
Alignment, select Aligned with Dimension Line.

4 Click OK.

5 Click Close to exit the Dimension Style Manager.

Dimension or Styles toolbar

To place text at the second extension line

1 Click Dimension menu ➤ Style.

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Text tab, under Text
Placement, select Over Ext Line 2 from the Horizontal list box.

The example area reflects your selection.

4 Click OK.

5 Click Close to exit the Dimension Style Manager.

Dimension or Styles toolbar

To place dimension text manually

1 Click Dimension menu ➤ Style.
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2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Fit tab, under Fine Tuning,
select Place Text Manually When Dimensioning.

4 Click OK.

5 Click Close to exit the Dimension Style Manager.

As you create dimensions, you can move the text along the dimension
line. Use the pointing device or enter coordinates to specify the
dimension line and text locations.

Dimension or Styles toolbar

To place text above the dimension line

1 Click Dimension menu ➤ Style.

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Text tab, under Text
Placement, select Above from the Vertical list box.

The example area reflects your selection.

4 Click OK.

5 Click Close to exit the Dimension Style Manager.

Dimension or Styles toolbar

Control the Appearance of Dimension Text

You can include prefixes, suffixes, and user-supplied text in dimensions. You
can also control the text style and formatting used in dimension text.

The program supports a mixture of user-supplied text, prefixes and suffixes
supplied by the dimension style, and generated measurements. For example,
you could add a diameter symbol as a prefix to a measurement or add the
abbreviation for a unit, such as mm, as a suffix. Text in this context refers to
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all dimension text, prefixes and suffixes, primary and alternate units, and
lateral tolerances. Geometric tolerances are controlled independently.

Dimension text is treated as a single string of text, which you create and format
using your text editor.

Control the Text Style in Dimensions

The appearance of dimension text is governed by the text style selected in the
Dimension Style Manager, Text tab. You can choose a text style while creating
a dimension style and specify a text color and a height independent of the
current text style's height setting. You can also specify the gap between base
dimension text and the box that surrounds it.

The text styles used for dimensions are the same text styles used by all text
created in your drawing.

For more information, see “Work with Text Styles” on page 733.

Supply User Text to Dimensions

In addition to the prefixes and suffixes specified for primary and alternate
units, you can supply your own text as you create a dimension. Because the
prefix, suffix, and user-supplied text form a single text string, you can represent
tolerance stacks and apply changes to font, text size, and other characteristics
using the text editor.

To add user text above and below the dimension line, use the separator symbol
\X. Text that precedes this symbol is aligned with and above the dimension
line. Text that follows the \X symbol is aligned with and below the dimension
line. The space between the dimension line and the text is determined by the
value you enter under Gap in the Annotation dialog box.

Example: User Text in Dimensions

In this example, the primary dimension measurement is 5.08, and the alternate
dimension measurement is 2.00. The primary units have the suffix H7/h6,
and the alternate units have the suffix inches.

At the text prompt, while creating the dimension, you enter the following
format string:

<> H7/h6\XSee Note 26\P[ ]

The angle brackets represent the primary units, and the square brackets
represent the alternate units. The \X separates text above the dimension line
from text below the dimension line. The \P is a paragraph break.

The resulting text appears as follows:
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5.08 H7/h6
See Note 26
[2.00 inches]

To control the text style in dimensions

1 Click Dimension menu ➤ Dimension Style.

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Text tab, under Text
Appearance, select a text style.

4 If the current text style does not have a fixed height, enter the height
of dimension text in the Text Height box.

5 Under Tolerances, enter a height for tolerance values in the Scaling for
Height box.

6 In the Offset from Dim Line box, enter a value for the gap around base
dimension text.

7 Select a color from the Text Color box.

8 Click OK

9 Click Close to exit the Dimension Style Manager.

Dimension or Styles toolbar

Control Dimension Values

The numeric values displayed in dimensions can appear in several formats.
You can also control how numeric distances are represented.

Control the Display of Dimension Units

The numeric values of dimensions can be displayed as a single measurement
or in two measurement systems. In either case, you can control details of how
the numeric values are presented.
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The settings for primary units control the display of the dimension values,
including the unit format, the numeric precision, and the decimal separator
style. For example, you can enter the diameter symbol as a prefix, as shown
in the illustration. Any prefix you specify replaces the prefixes normally used
for diameter and radius dimensions (Diameter (unicode 2205 and R,
respectively).

diameter symbol

These settings are available on the Primary Units tab of the Dimension Style
Manager.

Control the Display of Alternate Units

You can create dimensions in two systems of measurement simultaneously.
A common use of this feature is to add feet and inches dimensions to drawings
created using metric units. The alternate units appear in square brackets ([ ])
in the dimension text. Alternate units cannot be applied to angular dimensions.

If alternate-units dimensioning is on when you edit a linear dimension, the
measurement is multiplied by an alternate scale value that you specify. This
value represents the number of alternate units per current unit of measurement.
The default value for imperial units is 25.4, which is the number of millimeters
per inch. The default value for metric units is 0.0394, which is the number of
inches per millimeter. The number of decimal places is specified by the
precision value for alternate units.

For example, for imperial units, if the alternate scale setting is the default
value, 25.4, and the alternate precision is 0.00, the dimension might look like
the following figure.
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To add and format primary units

1 Click Dimension menu ➤ Style.

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Primary Units tab, under
Linear or Angular Dimensions, select a unit format and precision value
for the primary units.

4 Under Linear Dimensions, enter any prefix and suffix for the displayed
dimension.

5 Click OK.

6 Click Close to exit the Dimension Style Manager.

Dimension or Styles toolbar

To add and format alternate units

1 Click Dimension menu ➤ Style.

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Alternate Units tab, select
Display Alternate Units.

4 Under Alternate Units

■ Select a unit format from the list.

■ Select a precision value for the alternate units.
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■ Enter any prefix and suffix for the displayed dimension, including a
space character if you want a gap between the dimension and the
prefix or suffix.

5 Click OK.

6 Click Close to exit the Dimension Style Manager.

Dimension or Styles toolbar

Round Off Dimension Values

You can round off the numeric values in dimensions and lateral tolerances.

You can round off all dimension values except those for angular dimensions.
For example, if you specify a round-off value of 0.25, all distances are rounded
to the nearest 0.25 unit. The number of digits displayed after the decimal
point depends on the precision set for primary and alternate units and lateral
tolerance values.

round-off value set to
default (0)

round-off value set to
default .25

round-off value set to
default 1

To round off dimension values

1 Click Dimension menu ➤ Style.

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In Modify Dimension Style dialog box, Primary Units tab, under Linear
Dimensions, enter the round-off value.

4 Click OK.
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5 Click Close to exit the Dimension Style Manager.

Dimension or Styles toolbar

Suppress Zeros in Dimensions

You can suppress leading and trailing zeros in the numeric portion of
dimension text.

If you suppress leading zeros in decimal dimensions, 0.500 becomes .500. If
you suppress trailing zeros, 0.500 becomes 0.5. You can suppress both leading
and trailing zeros so that 0.5000 becomes .5 and 0.0000 becomes 0.

The table shows the effect of selecting each option and provides examples of
the architectural units style. If feet are included with a fractional inch, the
number of inches is indicated as zero, no matter which option you select.
Thus, the dimension 4'-3/4" becomes 4'-0 3/4".

Zero suppression for feet and inches

ExamplesEffectOption

1'-0 3/4"1'-0"0'-6"0'-0 1/2"Includes zero feetNo options
selected and zero inches

1'-0 3/4"1'0'-6"0'-0 1/2"Suppresses zero inches
(includes zero feet)

0 Inches
selected

1'-0 3/4"1'-0"6"1/2"Suppresses zero feet
(includes zero inches)

0 Feet
selected

1'-0 3/4"1'6"1/2"Suppresses zero feet0 Feet and 0
Inches selected and zero inches

To suppress zeros in dimension values

1 Click Dimension menu ➤ Style.

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Primary Units tab or Alternate
Units tab, under Zero Suppression, select from the following:

■ Leading. Suppresses leading zeros in decimal values.

■ Trailing. Suppresses trailing zeros in decimal values.
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■ 0 Feet. Suppresses display of 0 feet in feet and inches values.

■ 0 Inches. Suppresses display of 0 inches in feet and inches values.

4 Click OK.

5 Click Close to exit the Dimension Style Manager.

Dimension or Styles toolbar

Display Lateral Tolerances

Lateral tolerances are values indicating the amount a measured distance can
vary. You can control whether lateral tolerances are displayed and you can
choose from several styles of lateral tolerances.

A lateral tolerance specifies the amount by which a dimension can vary. By
specifying tolerances in manufacturing, you can control the degree of accuracy
needed for a feature. A feature is some aspect of a part, such as a point, line,
axis, or surface.

You can apply tolerances directly to a dimension by appending the tolerances
to the dimension text. These dimension tolerances indicate the largest and
smallest permissible size of the dimension. You can also apply geometric
tolerances, which indicate deviations of form, profile, orientation, location,
and runout.

Lateral tolerances can be specified from theoretically exact measurements.
These are called basic dimensions and have a box drawn around them.

If the dimension value can vary in both directions, the plus and minus values
you supply are appended to the dimension value as deviation tolerances. If
the deviation tolerance values are equal, they are displayed with a ± sign and
they are known as symmetrical. Otherwise, the plus value goes above the
minus value.
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deviation tolerance symmetrical deviation
tolerance

If the tolerances are applied as limits, the program uses the plus and minus
values you supply to calculate a maximum and minimum value. These values
replace the dimension value. If you specify limits, the upper limit goes above
the lower.

0.
56

0.
49

0.
98

0.
91

Format Lateral Tolerances

You can control the vertical placement of tolerance values relative to the main
dimension text. Tolerances can align with the top, middle, or bottom of the
dimension text.
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top middle bottom

You can also control zero suppression as you can with the primary and
alternate units. Suppressing zeros in lateral tolerances has the same effect as
suppressing them in the primary and alternate units. If you suppress leading
zeros, 0.5 becomes .5, and if you suppress trailing zeros, 0.5000 becomes 0.5.

See also:

“Add Geometric Tolerances” on page 835

To specify methods for lateral tolerances

1 Click Format menu ➤ Dimension Style.

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Tolerances tab, under
Tolerance Format, select a method from the Method list, and then do
one of the following:

■ If you select Limits, enter upper and lower tolerance deviation in the
Upper Value and Lower Value boxes.

■ If you select Symmetrical tolerances, Lower Value is not available,
because you need only one tolerance value.

■ If you select Basic, enter a value in Offset from Dim Line (on the Text
tab) to represent the gap between the text and its enclosing box.

4 Click OK.

5 Click Close to exit the Dimension Style Manager.

Dimension or Styles toolbar
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To align and suppress zeros in tolerance values

1 Click Dimension menu ➤ Style.

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Tolerances tab, under
Tolerance Format, select the alignment from the Vertical Position list.

4 To suppress zeros in primary or alternate units, under Zero Suppression,
select Leading to suppress leading zeros. Select Trailing to suppress trailing
zeros.

5 Click OK.

6 Click Close to exit the Dimension Style Manager.

Dimension or Styles toolbar

Set the Scale for Dimensions
You can specify the size of dimensions in your drawing. How you set dimension
size depends on the method you use to lay out and plot drawings.

Dimension scale affects the size of the dimension geometry relative to the
objects in the drawing. Dimension scale affects sizes, such as text height and
arrowhead size, and offsets, such as the extension line origin offset. You should
set these sizes and offsets to values that represent their actual plotted size.
Dimension scale does not apply the overall scale factor to tolerances or
measured lengths, coordinates, or angles.

Setting dimension scale depends on how you lay out your drawing. There are
three methods used to create dimensions in a drawing layout:

■ Dimension in model space for plotting in model space. This is the
traditional method used with single-view drawings. To create dimensions
that are scaled correctly for plotting, set the  system variable to the inverse
of the intended plot scale. For example, if the plot scale is 1/4, set  to 4.
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■ Dimension in model space for plotting in paper space. This was
the preferred method for complex, multiple-view drawings prior to AutoCAD
2002. Use this method when the dimensions in a drawing need to be
referenced by other drawings (xrefs) or when creating isometric dimensions
in 3D isometric views. To prevent the dimensions in one layout viewport
from being displayed in other layout viewports, create a dimensioning layer
for each layout viewport that is frozen in all other layout viewports. To
create dimensions that are scaled automatically for display in a paper space
layout, set the DIMSCALE system variable to 0.

■ Dimension in layouts. This is the simplest dimensioning method.
Dimensions are created in paper space by selecting model space objects or
by specifying object snap locations on model space objects. By default,
associativity between paper space dimensions and model space objects is
maintained. No additional scaling is required for dimensions created in a
paper space layout:  and DIMSCALE do not need to be changed from their
default value of 1.0000.

NOTE When you dimension model space objects in paper space using associative
dimensions, dimension values for the display scale of each viewport are
automatically adjusted. This adjustment is combined with the current setting for
DIMLFAC and is reported by the LIST command as a dimension style override. For
nonassociative dimensions, you must set DIMLFAC  manually.

See also:

“Draw, Scale, and Annotate in Model Space” on page 198
“Scale Views in Layout Viewports” on page 216

To set the overall dimension scale

1 Click Dimension menu ➤ Style.

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In Modify Dimension Style dialog box, Fit tab, under Scale for Dimension
Features, enter a value for the overall scale.

4 Click OK.

5 Click Close to exit the Dimension Style Manager.

Dimension or Styles toolbar
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To set the dimension scale for model space dimensions in layouts

1 Click Dimension menu ➤ Style.

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In Modify Dimension Style dialog box, Fit tab, under Scale for Dimension
Features, select Scale Dimension to Layout (Paperspace).

4 Click OK.

5 Click Close to exit the Dimension Style Manager.

Dimension or Styles toolbar

To set dimension scale for creating dimensions in a layout

1 Click a layout tab to switch to paper space.

2 To create dimensions in paper space with the correct model space
dimension values, use object snap modes to snap to points in model
space from paper space or select the objects directly.

The DIMLFAC system variable can be changed if you need to convert
the linear dimension values between the imperial and metric
measurement systems.

Create Dimensions
You can create all of the standard types of dimensions.

Create Linear Dimensions

You can create linear dimensions with horizontal, vertical, and aligned
dimension lines. These linear dimensions can also be stacked, or they can be
created end to end.

Overview of Creating Linear Dimensions

Linear dimensions can be horizontal, vertical, or aligned. With aligned
dimensions, the dimension line is parallel to the line (imaginary or real)
between the extension line origins. Baseline (or parallel) and continued (or
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chain) dimensions are series of consecutive dimensions that are based on a
linear dimension.

In all four illustrations, the extension line origins are designated explicitly at
1 and 2, respectively. The dimension line location is specified at 3.

1
3

2

1

2 3

1
3

2

1
3

2

horizontal vertical

rotated 315 degreesaligned

As you create linear dimensions, you can modify the content of the text, the
angle of the text, or the angle of the dimension line.

Create Horizontal and Vertical Dimensions

You can create dimensions using only the horizontal or vertical components
of the locations or objects that you specify.

The program automatically applies a horizontal or vertical dimension according
to the extension line origins that you specify or the location where you select
an object; however, you can override this as you create the dimension by
specifying that a dimension be horizontal or vertical. For example, in the
following illustration, a horizontal dimension is drawn by default unless you
specify a vertical one.
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40

horizontal dimension created
by default

vertical dimension specified

To create a horizontal or vertical dimension

1 Click Dimension menu ➤ Linear.

2 Press ENTER to select the object to dimension, or specify the first and
second extension line origins.

3 Before specifying the dimension line location, you can override the
dimension direction and edit the text, the text angle, or the dimension
line angle:

■ To rotate the extension lines, enter r (Rotated). Then enter the
dimension line angle.

■ To edit the text, enter m (multiline text). In the In-place Text Editor,
revise the text. Click OK.

■ Editing within or overwriting the brackets (<>) changes or removes
the dimension value calculated by the program. Adding text before
or after the brackets appends text before or after the dimension value.

■ To rotate the text, enter a (Angle). Then enter the text angle.

4 Specify the dimension line location.

Dimension toolbar

Create Aligned Dimensions

You can create dimensions that are parallel to the locations or objects that
you specify.
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In aligned dimensions, the dimension line is parallel to the extension line
origins. The illustration shows two examples of aligned dimensioning. The
object is selected (1), and the location of the aligned dimension is specified
(2). The extension lines are drawn automatically.

2

1

1
2

To create an aligned dimension

1 Click Dimension menu ➤ Aligned.

2 Press ENTER to select the object to dimension, or specify the first and
second extension line origins.

3 Before specifying the dimension line location, you can edit the text or
change the text angle. Editing within or overwriting the brackets (<>)
changes or removes the dimension value calculated by the program.
Adding text before or after the brackets appends text before or after the
dimension value.

■ To edit the text using multiline text, enter m (multiline text). In the
In-place Text Editor, revise the text. Click OK.

■ To edit the text using single-line text, enter t (Text). Revise the text
on the command line and press  ENTER  .

■ To rotate the text, enter a (Angle). Then enter the text angle.

4 Specify the dimension line location.

Dimension toolbar
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Create Baseline and Continued Dimensions

Baseline dimensions are multiple dimensions measured from the same baseline.
Continued dimensions are multiple dimensions placed end to end. You must
create a linear, aligned, or angular dimension before you create baseline or
continued dimensions. You create baseline dimensions incrementally from
the most recently created dimension in the current session.

.457 .488 .554

Both baseline and continued dimensions are measured from the previous
extension line unless you specify another point as the point of origin.

To create a baseline linear dimension

1 Click Dimension menu ➤ Baseline.

By default, the origin of the last linear dimension created is used as the
first extension line for the new baseline dimension. You are prompted
for the second dimension line.

2 Use an object snap to select the second extension line origin, or press
ENTER to select any dimension as the base dimension.

The program automatically places the second dimension line at the
distance specified by the Baseline Spacing option in the Dimension Style
Manager, Lines tab.

3 Use an object snap to specify the next extension line origin.

4 Continue to select extension line origins as required.

5 Press ENTER twice to end the command.

Dimension toolbar
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To create a continued linear dimension

1 Click Dimension menu ➤ Continue.

The program uses the origin of the second extension line of the existing
dimension as the first extension line origin.

2 Use object snaps to specify additional extension line origins.

3 Press ENTER twice to end the command.

Dimension toolbar

Create Rotated Dimensions

In rotated dimensions, the dimension line is placed at an angle to the extension
line origins. The illustration shows an example of a rotated dimension. In the
example, the angle specified for dimension rotation is equal to the angle of
the slot.

To create a rotated dimension

1 Click Dimension menu ➤ Linear.

2 Press ENTER to select the object to dimension or specify the first and
second extension line origins.
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3 To rotate the dimension line, enter r (Rotated). Then enter the dimension
line angle.

4 Specify the dimension line location.

Dimension toolbar

Create Dimensions with Oblique Extension Lines

You can create dimensions with extension lines that are not perpendicular to
their dimension lines.

Extension lines are created perpendicular to the dimension line. However, if
the extension lines conflict with other objects in a drawing, you can change
their angle after the dimension has been drawn.

New dimensions are not affected when you make an existing dimension
oblique.

dimensions set to oblique

To make extension lines oblique

1 Click Dimension menu ➤ Oblique.

2 Select the dimension.
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3 Enter a value for the angle of obliqueness, or specify two points.

Dimension toolbar

Create Radial Dimensions

Radial dimensions measure the radii and diameters of arcs and circles with
optional centerlines or a center mark.

There are two types of radial dimensions:

■ measures the radius of an arc or circle, and displays the dimension text
with the letter R in front of it.

■ measures the diameter of an arc or circle, and displays the dimension text
with the diameter symbol in front of it.

For horizontal dimension text, if the angle of the radial dimension line is
greater than 15 degrees from horizontal, a hook line, also called a dogleg or
landing, one arrowhead long, is created next to the dimension text.

Control Centerlines and Center Marks

Depending on your dimension style settings, center marks and lines generate
automatically for diameter and radius dimensions. They are created only if
the dimension line is placed outside the circle or arc. You can create centerlines
and center marks directly with the command.
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centerlines

centerline
size

You can control the size and visibility of centerlines and center marks on the
Modify Dimension Style dialog box, Symbols and Arrows tab, under Center
Marks. You can also access this setting with the  system variable.

The size of the centerline is the length of the centerline segment that extends
outside the circle or arc. It is also the size of the gap between the center mark
and the start of the centerline.

The size of the center mark is the distance from the center of the circle or arc
to the end of the center mark.

Create Jogged Radius Dimensions

With , you can create jogged radius dimensions, also called “foreshortened
radius dimensions,” when the center of an arc or circle is located off the layout
and cannot be displayed in its true location. The origin point of the dimension
can be specified at a more convenient location called the center location override.

R
30
0

You can control the default angle of the jog in the Modify Dimension Style
dialog box, Symbols and Arrows tab, under Radius Dimension Jog.
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45°

extension line

dimension line

jog angle

Once a jogged radius dimension is created, you can modify the jog and the
center location override by

■ Using grips to move the features

■ Changing the locations of the features with the Properties palette

■ Using STRETCH

NOTE Jogged radius dimensions can be viewed but not edited in versions previous
to AutoCAD 2006. Also, if you make dramatic changes to the associated geometry,
you may get unpredictable results for the jogged radius dimension.

See also:

“Fit Dimension Text Within Extension Lines” on page 789

To create a diameter dimension

1 Click Dimension menu ➤ Diameter.

2 Select the arc or circle to dimension.

3 Enter options as needed:

■ To edit the dimension text content, enter t (Text) or m (multiline
text). Editing within or overwriting the brackets (<>) changes or
removes the dimension value. Adding text before or after the brackets
appends text before or after the dimension value.

■ To change the dimension text angle, enter a (Angle).

4 Specify the leader line location.
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Dimension toolbar

To create a radius dimension

1 Click Dimension menu ➤ Radius.

2 Select an arc, circle, or polyline arc segment.

3 Enter options as needed:

■ To edit the dimension text content, enter t (Text) or m (multiline
text). Editing within or overwriting the brackets (<>) changes or
removes the dimension value. Adding text before or after the brackets
appends text before or after the dimension value.

■ To edit the dimension text angle, enter a (Angle).

4 Specify the leader line location.

Dimension toolbar

To create a jogged radius dimension

1 Click Dimension menu ➤ Jogged.

2 Select an arc, circle, or polyline arc segment.

3 Specify a point for the dimension origin (the center location override).

4 Specify a point for the dimension line angle and the dimension text
location.

5 Specify another point for the location of the dimension jog.

Dimension toolbar

To create centerlines automatically with radial dimensions

1 Click Dimension menu ➤ Style.
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2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Lines tab, under Center Marks,
select Line in the Type box. The example area reflects your selection.

4 In the Size box, enter the centerline size.

Dimension or Styles toolbar

To create centerlines or center marks on an arc or circle

1 Click Dimension menu ➤ Style.

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Lines tab, under Center Marks,
select Line in the Type box. The example area reflects your selection.

4 In the Size box, enter the centerline size.

5 Click Dimension menu ➤ Center Mark.

6 Select an arc or a circle.

Dimension toolbar

Create Angular Dimensions

Angular dimensions measure the angle between two lines or three points. To
measure the angle between two radii of a circle, you select the circle and specify
the angle endpoints. With other objects, you select the objects and then specify
the dimension location. You can also dimension an angle by specifying the
angle vertex and endpoints. As you create the dimension, you can modify the
text content and alignment before specifying the dimension line location.

NOTE You can create baseline and continued angular dimensions relative to
existing angular dimensions. Baseline and continued angular dimensions are limited
to 180 degrees or less. To obtain baseline and continued angular dimensions larger
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than 180 degrees, use grip editing to stretch the location of the extension line of
an existing baseline or continued dimension.

Dimension Lines

If you use two straight, nonparallel lines to specify an angle, the dimension
line arc spans the angle between the two lines. If the dimension line arc does
not meet one or both of the lines being dimensioned, The program draws one
or two extension lines to intersect the dimension line arc. The arc is always
less than 180 degrees.

Dimension Circles and Arcs

If you use an arc or a circle or three points to specify an angle, the program
draws the dimension line arc between the extension lines. The extension lines
are drawn from the angle endpoints to the intersection of the dimension line
arc.

circle lines lines specify vertex

The location that you specify for the dimension line arc determines the
quadrant of the dimensioned angle.

To create an angular dimension

1 Click Dimension menu ➤ Angular.

2 Use one of the following methods:

■ To dimension a circle, select the circle at the first endpoint of the
angle and then specify the second endpoint of the angle.

■ To dimension any other object, select the first line, and then select
the second line.
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3 Enter options as needed:

■ To edit the dimension text content, enter t (Text) or m (multiline
text). Editing within or overwriting the brackets (<>) changes or
removes the calculated dimension value. Adding text before or after
the brackets appends text before or after the dimension value.

■ To edit the dimension text angle, enter a (Angle).

4 Specify the dimension line arc location.

Dimension toolbar

Create Ordinate Dimensions

Ordinate dimensions measure the perpendicular distance from an origin point
called the datum to a dimensioned feature, such as a hole in a part. These
dimensions prevent escalating errors by maintaining accurate offsets of the
features from the datum.

ordinate dimensions

Ordinate dimensions consist of an X or Y value with a leader line. X-datum
ordinate dimensions measure the distance of a feature from the datum along
the X axis. Y-datum ordinate dimensions measure the distance along the Y
axis. If you specify a point, the program automatically determines whether it
is an X- or Y-datum ordinate dimension. This is called an automatic ordinate
dimension. If the distance is greater for the Y value, the dimension measures
the X value. Otherwise, it measures the Y value.
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Y ordinate

X ordinate

The program uses the absolute coordinate value of the current UCS to
determine the ordinate values. Before creating ordinate dimensions, you
typically reset the UCS origin to coincide with the datum.

UCS origin

The dimension text is aligned with the ordinate leader line, regardless of the
text orientation defined by the current dimension style. You can accept the
default text or supply your own.

To create ordinate dimensions

1 Click Dimension menu ➤ Ordinate.

2 If straight ordinate leaders are required, turn Ortho mode on.

3 At the Select Feature Location prompt, specify a point location.

4 Enter x (X Datum) or y (Y Datum).

You can skip this step by making sure that the ordinate leader endpoint
is close to vertical for an X datum or close to horizontal for a Y datum.

5 Specify the ordinate leader endpoint.

Dimension toolbar
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Create Arc Length Dimensions

Arc length dimensions measure the distance along an arc or polyline arc
segment.

Typical uses of arc length dimensions include measuring the travel distance
around a cam or indicating the length of a cable. To differentiate them from
linear or angular dimensions, arc length dimensions display an arc symbol
by default.

1.60

The arc symbol, also called a hat or cap, is displayed either above the dimension
text or preceding the dimension text. You can specify the placement style
using the Dimension Style Manager. The placement style can be changed on
the Symbols and Arrows tab of either the New Dimension Style dialog box or
the Modify Dimension Style dialog box.

The extension lines of an arc length dimension can be orthogonal or radial.

0.90

88°

0.97

94°

NOTE Orthogonal extension lines are displayed only when the included angle of
the arc is less than 90 degrees.

To create an arc length dimension

1 Click Dimension menu ➤ Arc Length.

2 Select an arc or polyline arc segment.

3 Specify the dimension line location.

Create Dimensions | 823



Dimension toolbar

Modify Existing Dimensions
You can modify all components of the existing dimension objects in a drawing
either individually or by using dimension styles.

Apply a New Dimension Style to Existing
Dimensions

You can modify existing dimensions by applying a different dimension style.
If you make changes to a dimension style, you can choose whether to update
the dimensions associated with that dimension style.

When you create a dimension, the current dimension style is associated with
that dimension. The dimension retains this dimension style unless you apply
a new dimension style to it or set up dimension style overrides.

You can modify existing dimensions by applying a different dimension style.
If you make changes to a dimension style, you can choose whether to update
the dimensions associated with that dimension style.

You can restore an existing dimension style or apply the current dimension
style, including any dimension style overrides, to selected dimensions.

To apply the current dimension style to existing dimensions

1 Click Dimension menu ➤ Update.

2 Select the dimensions to update to the current dimension style.

3 Press ENTER.

Dimension toolbar

To restore a dimension style

1 Click Dimension menu ➤ Style.
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2 In the Dimension Style Manager, select the dimension style to restore.
Click Set Current.

3 Click Close.

Dimension toolbar

Alternate

■ On the Styles toolbar, click the arrow in the Dimension Styles control and
select a dimension style.

Override a Dimension Style

With dimension style overrides, you can temporarily change a dimensioning
system variable without changing the current dimension style.

A dimension style override is a change made to specific settings in the current
dimension style. It is equivalent to changing a dimensioning system variable
without changing the current dimension style.

You can define dimension style overrides for individual dimensions, or for
the current dimension style.

■ For individual dimensions, you may want to create overrides to suppress a
dimension’s extension lines or modify text and arrowhead placement so
that they do not overlap drawing geometry without creating a different
dimension style.

■ You can also set up overrides to the current dimension style. All dimensions
you create in the style include the overrides until you delete the overrides,
save the overrides to a new style, or set another style current. For example,
if you choose Override in the Dimension Style Manager, and change the
color of extension lines on the Lines tab, the current dimension style
remains unchanged. However, the new value for color is stored in the
system variable. The next dimension you create will have extension lines
in the new color. You can save the dimension style overrides as a new
dimension style.

Some dimension characteristics are common to a drawing or to a style of
dimensioning and are therefore suited to be permanent dimension style
settings. Others generally apply on an individual basis and can be applied
more effectively as overrides. For example, a drawing usually uses a single type
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of arrowhead, so it makes sense to define the arrowhead type as part of the
dimension style. Suppression of extension lines, however, usually applies in
individual cases only and is more suited to a dimension style override.

There are several ways to set up dimension style overrides. You can change
options in the dialog boxes or change system variable settings on the command
line. You reverse the override by returning the changed settings to their original
values. The overrides apply to the dimension you are creating and all
subsequent dimensions created with that dimension style until you reverse
the override or make another dimension style current.

Example: Change a Dimension Style Override on the Command Line

You can override the current dimension style while creating a dimension by
entering the name of any dimensioning system variable at any prompt. In
this example, the dimension line color is changed. The change affects
subsequent dimensions you create until you reverse the override or make
another dimension style current.

Command: dimlinear
Specify first extension line origin or <select object>: dimclrd
Enter new value for dimension variable <byblock>: 5
Specify first extension line origin <select object>: Specify the first extension line
origin, or select an object to dimension

To set up dimension style overrides

1 Click Dimension menu ➤ Style.

2 In the Dimension Style Manager, under Styles, select the dimension style
for which you want to create an override. Click Override.

3 In the Override Current Style dialog box, make changes to the dimension
style by clicking the appropriate tab.

4 Click OK to return to the Dimension Style Manager.

The dimension style overrides are listed below the style they modify in
the dimension style name list.

5 Click Close.

Dimension or Styles toolbar
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To apply dimension style overrides

1 Click Dimension menu ➤ Style.

2 In the Dimension Style Manager, click Override.

3 In the Override Current Style dialog box, enter the style overrides. Click
OK.

The program displays <style overrides> below the dimension style name
in the Dimension Style Manager dialog box. After you create dimension
style overrides, you can continue to modify dimension styles, compare
them with other dimension styles, or delete or rename the overrides.

Dimension or Styles toolbar

Modify Dimension Text

Once you've created a dimension, you can rotate the existing text or replace
it with new text. You can move the text to a new location or back to its home
position, which is the position defined by the current dimension style. In the
following illustration, the home position is above and centered on the
dimension line.

dimension text rotated dimension text moved
back to home position

When you rotate or replace dimension text, you specify the change first, for
example, rotating the text to be at an angle. When you move dimension text,
you select a single dimension to move.
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You can move dimension text to the left, right, or center along the dimension
line or to any position inside or outside the extension lines. A quick and simple
way to do this is by using grips. If you move text up or down, the current
vertical alignment of the text relative to the dimension line is not changed,
so the dimension and extension lines are modified accordingly. The following
illustration shows the result of moving text down and to the right. The text
remains centered vertically in relation to the dimension line.

18.9318.93

text centered vertically on
the dimension line

result of moving text to the right
and outside the extension lines

See also:

“Control Dimension Text” on page 789

To rotate dimension text

1 Click Dimension menu ➤ Align Text ➤ Angle.

2 Select the dimension to edit.

3 Enter the new angle for the text.

Dimension toolbar

To return dimension text to its home position

1 Click Dimension menu ➤ Align Text ➤ Home.

2 Select the dimension text you want to return to its home position.

Dimension toolbar
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To replace existing dimension text with new text

1 Click Modify menu ➤ Object ➤ Text ➤ Edit.

2 Select the dimension text you want to edit.

3 In the In-Place Text Editor, enter the new dimension text. Click OK.

Text toolbar

To move text to the left side of the dimension line

1 Click Dimension menu ➤ Align Text ➤ Left.

2 Select the dimension.

The dimension text is left-justified along the dimension line inside the
extension lines. You can choose the Center or Right options to move
the text to the center or right of the dimension line.

Dimension toolbar

To set dimension line spacing for baseline and continued dimensions

1 Click Dimension menu ➤ Style.

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Lines tab, under Dimension
Lines, enter in the Baseline Spacing box the offset distance between
dimension lines for baseline and continued dimensions.

4 Click OK.

5 Click Close to exit the Dimension Style Manager.

Dimension or Styles toolbar
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To change the extension origin offset

1 Click Dimension menu ➤ Style.

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Lines tab, under Extension
Lines, enter the new value for Offset from Origin.

4 Click OK.

5 Click Close to exit the Dimension Style Manager.

Dimension or Styles toolbar

Modify Dimension Geometry

Grip editing is the quickest and easiest way to modify the location of
dimension elements. How you edit dimensions depends whether the dimension
is associative.

You can modify dimensions with the editing commands and with grip editing.
Grip editing is the quickest and easiest way to modify dimensions. How you
edit dimensions depends on whether the dimension is associative.

Modify Associative Dimensions

Associative dimensions retain their associativity to dimensioned objects
through many editing commands if both the dimension and the associated
geometry are selected and operated on with a single command. For example,
if a dimension and its associated geometry are moved, copied, or arrayed in
the same command, each dimension retains associativity with its respective
geometry.

In some circumstances, dimensions are automatically disassociated, including

■ If the associated geometric object is erased

■ If the associated geometric object undergoes a Boolean operation such as
UNION or SUBTRACT
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■ If grip editing is used to stretch a dimension parallel to its dimension line

■ If the association to a geometric object is specified using the Apparent
Intersection object snap, and the geometric object is moved so that the
apparent intersection no longer exists

In other circumstances, a dimension may become partially associated. For
example, if a linear dimension is associated with the endpoints of two
geometric objects and one of the objects is erased, the remaining association
is preserved. The disassociated end of the linear dimension may then be
associated with another geometric object using DIMREASSOCIATE.

NOTE The command line displays a warning message if a dimension is
disassociated.

Modify Nonassociative Dimensions

For nonassociative dimensions, when you edit dimensioned objects, you must
include the relevant dimension definition points in the selection set, or the
dimension is not updated. Definition points determine the dimension location.
For example, to stretch a dimension, you must include the appropriate
definition points in the selection set. You can easily include them by turning
on grips and selecting the object so that the grips are highlighted.

The definition points for each type of dimension are indicated in the following
illustrations. The middle point of the dimension text is a definition point for
all dimension types.

Modify Existing Dimensions | 831



Linear: extension line origins and
intersection of first extension line and
dimension line

Diameter: selection point and
opposite point

Radius: selection
point and center

ordinate: feature
location and
leader endpoint

Three-Point Angular: angle vertex,
extension line origins, and
dimension line arc

Two-Point Angular: extension line
origins, and dimension line arc

If no angle vertex is shown, definition points are placed at the ends of the
lines that form the angle. In the two-line angular example, a definition point
is placed at the center point of the dimensioned arc.

NOTE Definition points are drawn on a special layer named DEFPOINTS, which
is not plotted.

Modify Exploded Dimensions

You can edit exploded dimensions as you would any other objects because
an exploded dimension is a collection of separate objects: lines, 2D solids, and
text. Occasionally you may need to explode a dimension to make changes
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such as creating a break in a dimension line or extension line. Once a
dimension is exploded, you cannot reassociate the dimension into a dimension
object.

See also:

“Control Dimension Geometry” on page 783

Change Dimension Associativity

You may need to change the associativity of dimensions in several
circumstances including adding associativity to dimensions created in previous
releases.

You may need to change the associativity of dimensions in several
circumstances such as the following:

■ Redefine the associativity of dimensions in drawings that have been edited
significantly.

■ Add associativity to dimensions that have been partially disassociated.

■ Add associativity to dimensions in legacy drawings.

■ Remove associativity from dimensions in drawings that will be used by
people working in releases prior to AutoCAD 2002, but who do not want
any proxy objects in the drawings.

Reassociate Dimensions to Different Objects

With DIMREASSOCIATE, you can select one or more dimensions and step
through the extension-line origin points of each dimension. For each
extension-line origin point, you can specify a new association point on a
geometric object. Association points determine the attachment of extension
lines to locations on geometric objects.

NOTE When you create or modify associative dimensions, it is important to locate
their association points carefully so that if you make a future design change, the
geometric objects that you change will also change the dimensions associated
with them.

When you use the DIMREASSOCIATE command, a marker is displayed that
indicates whether each successive extension line origin point of the dimension
is associative or nonassociative. A square with an X in it means that the point
is associated with a location on an object, while an X without the square
means that the point is not associated with an object. Use an object snap to
specify the new association for the extension-line origin point or press  ENTER
to skip to the next extension-line origin point.
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NOTE The marker disappears if you pan or zoom with a wheel mouse.

Change Nonassociative Dimensions to Associative

You can change all the nonassociative dimensions in a drawing to associative.
Use  to select all nonassociative dimensions, and then use DIMREASSOCIATE
to step through the dimensions, associating each one with locations on
geometric objects.

Change Associative Dimensions to Nonassociative

You can change all associative dimensions in a drawing to nonassociative
dimensions. Use QSELECT to select all associative dimensions, and then use
DIMDISASSOCIATE to convert them into nonassociative dimensions.

See also:

“Associative Dimensions” on page 778
“Save Drawings to Previous Drawing File Formats”

To associate or reassociate a dimension

1 Click Dimension menu ➤ Reassociate Dimensions.

2 Select one or more dimensions to associate or reassociate.

3 Do one of the following:

■ Specify the new location of the extension-line origin point.

■ Enter s and select a geometric object to associate with the dimension.

■ Press  ENTER  to skip to the next extension-line origin point.

■ Press  ESC  to end the command but keep any associations you made
up to that point.

4 Repeat the previous step as needed.

To disassociate a dimension

1 On the command line, enter .

2 Select one or more dimensions to disassociate and press  ENTER  when
you finish.
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Add Geometric Tolerances
You can add geometric tolerances that show acceptable deviations of form,
profile, orientation, location, and runout of a feature.

Overview of Geometric Tolerances

Geometric tolerances show acceptable deviations of form, profile, orientation,
location, and runout of a feature. You add geometric tolerances in feature
control frames. These frames contain all the tolerance information for a single
dimension. Geometric tolerances can be created with or without leader lines,
depending on whether you create them with  or .

A feature control frame consists of two or more components. The first feature
control frame contains a symbol that represents the geometric characteristic
to which a tolerance is being applied, for example, location, profile, form,
orientation, or runout. Form tolerances control straightness, flatness, circularity
and cylindricity; profiles control line and surface. In the illustration, the
characteristic is position.

primary, secondary,
and tertiary datum
reference letters

material conditions of
datums

material conditions of tolerance

tolerance value

optional diameter symbol

geometric characteristic
symbol-in this case, position

You can use most editing commands to change feature control frames, and
you can snap to them using the object snap modes. You can also edit them
with grips.
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NOTE Unlike dimensions and leaders, geometric tolerances cannot be associated
with geometric objects.

To create geometric tolerances

1 Click Dimension menu ➤ Tolerance.

2 In the Geometric Tolerance dialog box, click the first square under Sym
and select a symbol to insert.

3 Under Tolerance 1, click the first black box to insert a diameter symbol.

4 In the Text box, enter the first tolerance value.

5 To add a material condition (optional), click the second black box and
click a symbol in the Material Conditions dialog box to insert it.

6 In the Geometric Tolerance dialog box, add a second tolerance value
(optional) in the same way as the first tolerance value.

7 Under Datum 1, Datum 2, Datum 3, enter the datum reference letter.

8 Click the black box to insert a material condition symbol for each datum
reference.

9 In the Height box, enter a height.

10 Click the Projected Tolerance Zone box to insert the symbol.

11 In the Datum Identifier box, add a datum value.

12 Click OK.

13 In the drawing, specify a location for the feature control frame.

Dimension toolbar

To create a geometric tolerance with a leader

1 On the command line, enter leader.

2 Specify the start point of the leader.

3 Specify the second point of the leader.

4 Press ENTER twice to display the Annotation options.

5 Enter t (Tolerance), and create a feature control frame.

The feature control frame is attached to the endpoint of the leader.
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Material Conditions

Material conditions apply to features that can vary in size.

The second compartment contains the tolerance value. Depending on the
control type, the tolerance value is preceded by a diameter symbol and followed
by a material condition symbol.

Material conditions apply to features that can vary in size:

■ At maximum material condition (symbol M, also known as MMC), a feature
contains the maximum amount of material stated in the limits.

■ At MMC, a hole has minimum diameter, whereas a shaft has maximum
diameter.

■ At least material condition (symbol L, also known as LMC), a feature contains
the minimum amount of material stated in the limits.

■ At LMC, a hole has maximum diameter, whereas a shaft has minimum
diameter.

■ Regardless of feature size (symbol S, also known as RFS) means a feature can
be any size within the stated limits.

Datum Reference Frames

The tolerance values in the feature control frame are followed by up to three
optional datum reference letters and their modifying symbols. A datum is a
theoretically exact point, axis, or plane from which you make measurements
and verify dimensions. Usually, two or three mutually perpendicular planes
perform this task best. These are jointly called the datum reference frame.

The following illustration shows a datum reference frame verifying the
dimensions of the part.
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tertiary datum
plane

primary datum plane

secondary datum
plane

Projected Tolerance Zones

Projected tolerances are specified in addition to positional tolerances to make
the tolerance more specific. For example, projected tolerances control the
perpendicularity tolerance zone of an embedded part.

The symbol for projected tolerance (

) is preceded by a height value, which specifies the minimum projected
tolerance zone. The projected tolerance zone height and symbol appear in a
frame below the feature control frame, as shown in the following illustration.

Composite Tolerances

A composite tolerance specifies two tolerances for the same geometric
characteristic of a feature or for features that have different datum
requirements. One tolerance relates to a pattern of features and the other
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tolerance to each feature within the pattern. The individual feature tolerance
is more restrictive than the pattern tolerance.

In the following illustration, the point where datums A and B intersect is called
the datum axis, the point from which the position of the pattern is calculated.

datum B

datum A

A composite tolerance could specify both the diameter of the pattern of holes
and the diameter of each individual hole, as in the following illustration.

0.375

When you add composite tolerances to a drawing, you specify the first line
of a feature control frame and then choose the same geometric characteristic
symbol for the second line of the feature control frame. The geometric symbol
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compartment is extended over both lines. You can then create a second line
of tolerance symbols.
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Prepare Drawings for
Plotting and Publishing

 

You prepare your drawing for plotting or publishing by

specifying page setup settings. These settings are stored in the

drawing file with the layout. Once a layout is established, you

can modify the settings of its page setup or apply a different

page setup.

26
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■ Quick Start to Preparing
Drawings for Plotting and
Publishing

■ Specify Page Setup Settings

■ Use the Layout Wizard to
Specify Layout Settings

■ Import PCP or PC2 Settings
into a Layout

■ Create and Use Named Page
Setups

■ Use Named Page Setups with
Sheet Sets



Quick Start to Preparing Drawings for Plotting
and Publishing

Preparing a drawing for plotting or publishing requires specifying many settings
and options that define the output of your drawing. These settings can be
saved as a named page setup.

You can apply a named page setup to multiple layouts using the Page Setup
Manager. You can also import a named page setup from another drawing and
apply it to layouts in the current drawing.

If you want to specify the same output options for several layouts or sheets,
use named page setups.

Specify Page Setup Settings
Page setups are associated with layouts and stored in the drawing file. The
settings specified in a page setup determine the appearance and format of
your final output.

Overview of Page Setup Settings

A page setup is a collection of plot device and other settings that affect the
appearance and format of your final output. These settings can be modified
and applied to other layouts.

After you complete a drawing on the Model tab, you can begin creating a
layout to plot by clicking a layout tab. When you click a layout tab for the
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first time, a single viewport is displayed on the page. A dashed line indicates
the printable area of the paper for the currently configured paper size and
plotter.

Once you have your layout set up, you specify the settings for the layout’s
page setup, which includes the plot device settings and other settings that
affect the appearance and format of the output. The settings you specify in
the page setup are stored in the drawing file with the layout. You can modify
the settings of a page setup at any time.

By default, every initialized layout has a page setup associated with it. A layout
is initialized if its paper size is defined in the page setup to any size other than
0 x 0. You can apply a named page setup saved with one layout to another
layout. This creates a new page setup with the same settings as the first one.

If you want the Page Setup Manager to be displayed each time you begin a
new drawing layout, select the Show Page Setup Manager for New Layouts
option on the Display tab in the Options dialog box. If you don't want a
viewport to be automatically created for each new layout, clear the Create
Viewport in New Layouts option on the Display tab in the Options dialog
box.

To modify the settings of a layout’s page setup

1 Click the layout tab for which you want to modify the page setup settings.

2 Click File menu ➤ Page Setup Manager.

3 In the Page Setup Manager, Page Setups area, select the page setup that
you want to modify.
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4 Click Modify.

5 In the Page Setup dialog box, modify the required settings. Click OK.

6 In the Page Setup Manager, click Close.

Layouts toolbar

Right-click a layout tab. Click Page Setup Manager.

To apply a layout’s named page setup to another layout

1 Click the layout tab to which you want to apply another layout’s page
setup settings.

2 Click File menu ➤ Page Setup Manager.

3 In the Page Setup Manager, Page Setups area, select a named page setup
that you want to apply to the layout selected in the drawing area.

4 Click Set Current.

5 Click Close.

Layouts toolbar

Right-click a layout tab. Click Page Setup Manager.

Select a Printer or Plotter for a Layout

When you create a layout, you must select a printing or plotting device in the
Page Setup dialog box in order for the layout to be printed or plotted. Once
you’ve selected a device, you can view details about the name and location
of the device, and you can change the device’s configuration.

The printer or plotter you select in the Page Setup dialog box determines the
printable area of the layout. This printable area is indicated by the dashed line
in the layout. If you change the paper size or the printing or plotting device,
it may change the printable area of your drawing page.

See also:

“Select a Printer or Plotter” on page 875
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“Control PC3 File Device and Document Settings” in the Driver and Peripheral
Guide

To select a printer or plotter for a layout

1 Click the layout tab for which you want to specify a printer or plotter.

2 Click File menu ➤ Page Setup Manager.

3 In the Page Setup Manager, Page Setups area, select the page setup that
you want to modify.

4 Click Modify.

5 In the Page Setup dialog box, under Printer/Plotter, select a printer or
plotter from the list. Click OK.

6 In the Page Setup Manager, click Close.

Layouts toolbar

Right-click a layout tab and select Page Setup Manager.

To change the configuration of a printer or plotter specified in a page setup

1 Click the layout tab for which you want to specify a printer or plotter.

2 Click File menu ➤ Page Setup Manager.

3 In the Page Setup Manager, Page Setups area, select the page setup that
you want to modify.

4 Click Modify.

5 In the Page Setup dialog box, under Printer/Plotter, click Properties.

6 In the Plotter Configuration Editor, change the required settings. Click
OK.

7 In the Page Setup dialog box, click OK.

8 In the Page Setup Manager, click Close.

Layouts toolbar

Right-click a layout tab. Click Page Setup Manager.
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Select a Paper Size for a Layout

You can select a paper size from a standard list. The paper sizes available in
the list are determined by the plot device that is currently selected for the
layout. If your plotter is configured for raster output, you must specify the
output size in pixels. You can add custom paper sizes, which are stored in the
plotter configuration (PC3) file, using the Plotter Configuration Editor.

If you are using a system printer, the paper size is determined by the document
defaults that are set in the Windows Control Panel. The default paper size is
displayed in the Page Setup dialog box when you create a new layout for that
configured device. If you change the paper size in the Page Setup dialog box,
the new paper size is saved with the layout and overrides the size saved in the
plotter configuration (PC3) file.

See also:

“Control PC3 File Device and Document Settings” in the Driver and Peripheral
Guide

To set the paper size for a layout

1 Click the layout tab for which you want to set the paper size.

2 Click File menu ➤ Page Setup Manager.

3 In the Page Setup Manager, Page Setups area, select the page setup that
you want to modify.

4 Click Modify.

5 In the Page Setup dialog box, under Paper Size, select a paper size from
the list. Click OK.

6 In the Page Setup Manager, click Close.

Layouts toolbar

Right-click a layout tab. Click Page Setup Manager.

To start the Plotter Configuration Editor

1 Click File menu ➤ Plotter Manager.

2 In the Plotter Manager, double-click the plotter configuration (PC3) file
you want to edit.
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The Plotter Configuration Editor is displayed.

To add a custom paper size from scratch

1 Click File menu ➤ Plotter Manager.

2 In the Plotter Manager, double-click the plotter configuration (PC3) file
you want to edit.

3 In the Plotter Configuration Editor, Device and Document Settings tab,
double-click User-Defined Paper Sizes & Calibration to display the
calibration and paper size options.

4 Select Custom Paper Sizes.

5 Under Custom Paper Sizes, click Add.

6 In the Custom Paper Size wizard, Begin page, select Start from Scratch.
Click Next.

7 On the Media Bounds page, in the Units list, select either Inches or
Millimeters for paper size.

When a nondimensional raster image, such as BMP or TIFF, is plotted,
the size of the plot is specified in pixels, not inches or millimeters.

8 In the Width and Length lists, specify the paper width and length. Click
Next.

NOTE Each plotter has a maximum printable area determined by where it
grips the paper and how far the pen shuttle reaches. If you are creating a
paper size that is larger than the paper sizes offered in the Custom Paper
Size wizard, verify that the plotter is capable of plotting the new dimensions.

9 On the Printable Area page, use Top, Bottom, Left, and Right to specify
the printable area. Click Next.

10 On the Paper Size Name page, enter a name for the paper size. Click
Next.

11 On the File Name page, enter a name for the PMP file.

12 On the Finish page, specify whether the paper source is Sheet-Fed or
Roll-Fed.

13 Click Print Test Page to verify the custom size.

A cross is printed that defines the paper size and a rectangle that defines
the printable area. If all four sides of the rectangle are not printed,
increase the printable area.

14 Click Finish to exit the Custom Paper Size wizard.
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To add a new custom paper size starting from an existing paper size

1 Click File menu ➤ Plotter Manager.

2 In the Plotter Manager, double-click the plotter configuration (PC3) file
you want to edit.

3 In the Plotter Configuration Editor, Device and Document Settings tab,
double-click User-Defined Paper Sizes & Calibration to display the
calibration and paper size settings.

4 Select Custom Paper Sizes.

5 Under Custom Paper Sizes, click Add.

6 In the Custom Paper Size wizard, Begin page, select Use Existing.

7 In the list of existing standard paper sizes, select a paper size on which
to base the custom paper size you are creating.

8 Follow the instructions in “To add a custom paper size from scratch ”
on page 849 to continue through the Custom Paper Size wizard.

The new paper size is a user-defined size, not a standard size.

9 Click Finish to exit the Custom Paper Size wizard.

To edit a custom paper size

1 Click File menu ➤ Plotter Manager.

2 In the Plotter Manager, double-click the plotter configuration (PC3) file
you want to edit.

3 In the Plotter Configuration Editor, Device and Document Settings tab,
double-click User-Defined Paper Sizes & Calibration to display the
calibration and paper size settings.

4 Select Custom Paper Sizes.

5 Under Custom Paper Sizes, select a paper size from the list. Click Edit.

6 In the Custom Paper Size wizard, make changes to the paper size,
printable area, custom paper size name, and source.

7 Click Finish to exit the Custom Paper Size wizard.

To delete a custom paper size

1 Click File menu ➤ Plotter Manager.
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2 In the Plotter Manager, double-click the plotter configuration (PC3) file
you want to edit.

3 In the Plotter Configuration Editor, Device and Document Settings tab,
double-click User-Defined Paper Sizes & Calibration to display the
calibration and paper size settings.

4 Click Custom Paper Sizes.

5 Under Custom Paper Sizes, select a paper size from the list.

6 Click Delete.

To modify a standard paper size

1 Click File menu ➤ Plotter Manager.

2 In the Plotter Manager, double-click the Plotter Configuration (PC3) file
you want to edit.

3 In the Plotter Configuration Editor, Device and Document Settings tab,
double-click User-Defined Paper Sizes & Calibration to display the
calibration and paper size settings.

4 Select Modify Standard Paper Sizes.

5 Under Modify Standard Paper Sizes, select the paper size you want to
adjust. Click Modify.

6 In the Custom Paper Size wizard, adjust the printable area as necessary.
Click Finish to exit the Custom Paper Size wizard.

Set the Plot Area of a Layout

When you prepare to plot from the Model tab or a layout tab, you can specify
the plot area to determine what will be included in the plot. When you create
a new layout, the default Plot Area option is Layout. Layout plots all objects
within the printable area of the specified paper size.

The Display Plot Area option plots all the objects displayed in the drawing.
The Extents Plot Area option plots all the visible objects in the drawing. The
View Plot Area option plots a saved view. You can use the Window Plot Area
option to define an area to be plotted.

See also:

“Specify the Area to Plot” on page 876
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To set the plot area and adjust the display

1 Click the layout tab for which you want to set the plot area and adjust
the display.

2 Click File menu ➤ Page Setup Manager.

3 In the Page Setup Manager, Page Setups area, select the page setup that
you want to modify.

4 Click Modify.

5 In the Page Setup dialog box, under Plot Area, select one of the following
options:

■ Layout. Prints all objects within the printable area of the paper. This
option is only available from a layout tab.

■ Limits. Prints or plots the current grid limits. This option is only
available from the Model tab.

■ Extents. Plots all objects in the drawing.

■ Display. Plots all objects displayed in the drawing area.

■ View. Prints or plots a saved view. Select a named view from the list
provided.

■ Window. Plots objects in the area you define. Select the Window
option, and then respond to the prompts to define the area. Click the
Window button to edit the defined area.

6 Click OK.

7 In the Page Setup Manager, click Close.

Layouts toolbar

Right-click a layout tab. Click Page Setup Manager.

Adjust the Plot Offset of a Layout

The printable area of a drawing sheet is defined by the selected output device
and is represented by the dashed line in a layout. When you change the output
device, the printable area may change.

The plot offset specifies an offset of the plot area relative to the lower-left
corner (the origin) of the printable area or the edge of the paper, depending
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on the Specify Plot Offset Relative To option specified in the Options dialog
box, Plot and Publish tab. The Plot Offset area of the Plot dialog box displays
the specified plot offset option in parentheses.

You can offset the geometry on the paper by entering a positive or negative
value in the X and Y Offset boxes. However, this may result in the plot area
being clipped.

If you choose to plot an area other than the entire layout, you can also center
the plot on the sheet of paper.

plot with origin 0,0

plot with origin -1.0,-0.5

lower-left corner of paper

home position

To adjust the plot offset of a layout

1 Click the layout tab for which you want to adjust the plot offset.

2 Click File menu ➤ Page Setup Manager.

3 In the Page Setup Manager, Page Setups area, select the page setup that
you want to modify.

4 Click Modify.

5 In the Page Setup dialog box, under Plot Offset, enter a value in units
for X or Y or both. Click OK.

6 In the Page Setup Manager, click Close.

Layouts toolbar

Right-click a layout tab. Click Page Setup Manager.
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Set the Plot Scale for a Layout

When you plot a drawing layout, you can either specify a precise scale for the
layout or fit the image to the paper.

Normally, you plot a layout at a 1:1 scale. To specify a different scale for the
layout, set the plot scale for the layout in the Page Setup or the Plot dialog
box. In those dialog boxes, you can select a scale from a list or enter a scale.

NOTE You can modify the list of scales with .

When you are reviewing an early draft view, a precise scale is not always
important. You can use the Fit to Paper setting to plot the layout at the largest
possible size that fits the paper.

See also:

“Scale Views in Layout Viewports” on page 216
“Draw, Scale, and Annotate in Model Space” on page 198

To set the plot scale in a layout

1 Click the layout tab for which you want to set the plot scale.

2 Click File menu ➤ Page Setup Manager.

3 In the Page Setup Manager, Page Setups area, select the page setup that
you want to modify.

4 Click Modify.

5 In the Page Setup dialog box, under Plot Scale, select a scale from the
Scale list.

The default scale when plotting a layout is 1:1. To set a custom plot scale,
enter values in the Inches or Millimeters box and the Units box. The
type of unit is determined by the paper size, but you can change it in
the list box.

6 Click OK.

7 In the Page Setup Manager, click Close.

Layouts toolbar

Right-click a layout tab and choose Page Setup.
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To set the Fit to Paper option when plotting

1 Click the layout tab for which you want to set the plot scale to Fit to
Paper.

2 Click File menu ➤ Page Setup Manager.

3 In the Page Setup Manager, Page Setups area, select the page setup that
you want to modify.

4 Click Modify.

5 In the Page Setup dialog box, Under Plot Scale, select Fit to Paper.

NOTE If the Plot Area is set to Layout, you cannot select the Fit to Paper
option.

6 Click OK.

7 In the Page Setup Manager, click Close.

Layouts toolbar

Right-click a layout tab. Click Page Setup Manager

Set the Lineweight Scale for a Layout

You can scale lineweights proportionately in a layout with the plot scale.

Typically, lineweights specify the line width of plotted objects and are plotted
with the line width size regardless of the plot scale. Most often, you use the
default plot scale of 1:1 when plotting a layout. However, if you want to plot
an E-size layout that is scaled to fit on an A-size sheet of paper, for example,
you can specify lineweights to be scaled in proportion to the new plot scale.

See also:

“Control Lineweights” on page 301

To scale lineweights in a layout

1 Click the layout tab for which you want to scale lineweights.

2 Click File menu ➤ Page Setup Manager.

3 In the Page Setup Manager, Page Setups area, select the page setup that
you want to modify.
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4 Click Modify.

5 In the Page Setup dialog box, under Plot Scale, select Scale Lineweights.

The lineweights in the current layout are scaled in proportion to the
designated plot scale. When you are working in the Model tab, this
option is not available.

6 Click OK.

7 In the Page Setup Manager, click Close.

Layouts toolbar

Right-click a layout tab. Click Page Setup Manager

Select a Plot Style Table for a Layout

A plot style table is a collection of plot styles assigned to a layout or the Model
tab. A plot style is an object property, similar to linetype and color. A plot
style can be assigned to an object or assigned to a layer. A plot style controls
an object's plotted properties.

You can also create a new plot style table to save in the page setup for the
layout or edit an existing plot style table.

If you select the Display Plot Styles option under Plot Style Table (Pen
Assignments), the properties of the plot styles assigned to objects are displayed
in the selected layout.

See also:

“Control How Objects Are Plotted” on page 881

To select a plot style table for a layout

1 Click the layout tab for which you want to select a plot style table.

2 Click File menu ➤ Page Setup Manager.

3 In the Page Setup Manager, Page Setups area, select the page setup that
you want to modify.

4 Click Modify.

5 In the Page Setup dialog box, Under Plot Style Table, select a Plot Style
Table from the list.
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6 Click OK.

7 In the Page Setup Manager, click Close.

Layouts toolbar

Right-click a layout tab. Click Page Setup Manager

To create a new plot style table for a layout

1 Click the layout tab for which you want to create a new plot style table.

2 Click File menu ➤ Page Setup Manager.

3 In the Page Setup Manager, Page Setups area, select the page setup that
you want to modify.

4 Click Modify.

5 In the Page Setup dialog box, Under Plot Style Table, select New from
the list.

6 Follow the instructions in the wizard that is shown (the Add
Color-Dependent Plot Style Table wizard or the Add Named Plot Style
Table wizard).

7 In the Page Setup dialog box, click OK.

8 In the Page Setup Manager, click Close.

Layouts toolbar

Right-click a layout tab. Click Page Setup Manager

To edit a plot style table for a layout

1 Click the layout tab for which you want to edit a plot style table.

2 Click File menu ➤ Page Setup Manager.

3 In the Page Setup Manager, Page Setups area, select the page setup that
you want to modify.

4 Click Modify.
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5 In the Page Setup dialog box, under Plot Style Table, select the plot style
table you want to edit from the list.

6 Click the Edit button.

7 In the Plot Style Table Editor, make the required changes. Click Save &
Close.

8 In the Page Setup dialog box, click OK.

9 In the Page Setup Manager, click Close.

Layouts toolbar

Right-click a layout tab. Click Page Setup Manager

To display plot styles in a layout

1 Click the layout tab for which you want to display plot styles.

2 Click File menu ➤ Page Setup Manager.

3 In the Page Setup Manager, Page Setups area, select the page setup that
you want to modify.

4 Click Modify.

5 In the Page Setup dialog box, under Plot Style Table, select the Display
Plot Styles option.

6 Click OK.

7 In the Page Setup Manager, click Close.

Layouts toolbar

Right-click a layout tab. Click Page Setup Manager

Set Shaded Viewport and Plot Options for a Layout

Shaded viewport and plot options affect how objects are plotted. The options
for shaded viewport plotting give you a large degree of flexibility in conveying
your three-dimensional designs to others. You can convey your design intent
by choosing how viewports are plotted and by specifying resolution levels.
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Shaded Viewport Plotting Options

With shaded plotting options, you can choose whether to plot a set of shaded
objects using the As Displayed, Wireframe, Hidden, or Rendered option.

Shaded viewport plotting options apply to all objects in viewports and model
space. If you use the Shaded or Rendered options plot style tables included in
the page setup do not affect plots. If you use the Render option,
two-dimensional wireframe objects, such as lines, arcs, and text, are not plotted.

NOTE Shaded viewport plotting requires a raster-capable device. Most modern
plotters and printers are raster-capable devices.

Plot Options

The following options that can be specified for layouts affect how objects are
plotted.

■ Plot Object Lineweights. Specifies that lineweights assigned to objects
and layers are plotted.

■ Plot with Plot Styles. Specifies that the drawing is plotted using plot
styles. Selecting this option automatically plots lineweights. If you do not
select this option, objects are plotted with their assigned properties and
not with the plot style overrides.

■ Plot Paper Space Last. Specifies that objects in model space are plotted
before those in paper space.

■ Hide Paperspace Objects. Specifies whether the Hide operation applies
to objects in the paper space viewport. This option is available only from
a layout tab. The effect of this setting is reflected in the plot preview, but
not in the layout.

See also:

“Set Shaded Viewport Options” on page 883
“Set Options for Plotted Objects” on page 886

To set shaded viewport options for a layout

1 Click the layout tab for which you want to set shaded viewport options.

2 Click File menu ➤ Page Setup Manager.

3 In the Page Setup Manager, Page Setups area, select the page setup that
you want to modify.

4 Click Modify.
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5 In the Page Setup dialog box, under Shaded Viewport Options, select the
required settings.

6 Click OK.

7 In the Page Setup Manager, click Close.

Layouts toolbar

Right-click a layout tab and click Page Setup Manager

To set plot options for a layout

1 Click the layout tab for which you want to set plot options.

2 Click File menu ➤ Page Setup Manager.

3 In the Page Setup Manager, Page Setups area, select the page setup that
you want to modify.

4 Click Modify.

5 In the Page Setup dialog box, under Plot Options, select the required
settings.

6 Click OK.

7 In the Page Setup Manager, click Close.

Layouts toolbar

Right-click a layout tab. Click Page Setup Manager

Determine the Drawing Orientation of a Layout

You can specify the orientation of the drawing on the paper using the
Landscape and Portrait settings. Landscape orients the drawing on the paper
so that the long edge of the paper is horizontal, and Portrait orients the paper
so that the short edge is horizontal. Changing the orientation creates the effect
of rotating the paper underneath the drawing.

In either landscape or portrait orientation, you can select Plot Upside-Down
to control whether the top or bottom of the drawing is plotted first.
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Although you can specify the drawing orientation in both the Page Setup
dialog box and the Plot dialog box, the Page Setup settings are always saved
and reflected in the layout. In the Plot dialog box, you can override the page
setup settings for a single plot; however, the settings you apply are not saved
in the layout. To save the settings you apply using the Plot dialog box, click
the Apply to Layout button in the Plot dialog box.

If you change the drawing orientation, the layout origin remains in the
lower-left corner of the rotated page.

To set the orientation of the plotted drawing

1 Click the layout tab for which you want to set the drawing orientation.

2 Click File menu ➤ Page Setup Manager.

3 In the Page Setup Manager, Page Setups area, select the page setup that
you want to modify.

4 Click Modify.

5 In the Page Setup dialog box, under Drawing Orientation, do one of the
following:

■ If your drawing is horizontal, select Landscape.

■ If your drawing is vertical, select Portrait.

■ To rotate 180 degrees, select either Portrait or Landscape, and then
select Plot Upside-Down.

6 Click OK.

7 In the Page Setup Manager, click Close.

Layouts toolbar

Right-click a layout tab. Click Page Setup Manager
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Use the Layout Wizard to Specify Layout
Settings

You can create a new layout using the Create Layout wizard. The wizard
prompts you for information about the layout settings, including

■ A name for the new layout

■ The printer associated with the layout

■ A paper size to use for the layout

■ The orientation of the drawing on the paper

■ A title block

■ Viewport setup information

■ A location for the viewport configuration in the layout

You can edit the information entered in the wizard later by selecting the
layout, clicking Page Setup Manager on the File menu, and clicking Modify
in the Page Setup Manager.

To create a layout using the wizard

1 Click Insert menu ➤ Layout ➤ Layout Wizard.

2 On each page of the Create Layout wizard, select the appropriate settings
for the new layout.

When finished, the new layout will be the current layout tab.

Import PCP or PC2 Settings into a Layout
If you work with drawings created in AutoCAD Release 14 or earlier, you can
choose to import layout and plot settings contained in a PCP or PC2 file and
apply them to the current layout. Settings that are saved in a PCP or PC2 file
include

■ Plot Area

■ Rotation

■ Paper Size

■ Plot Scale
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■ Plot Origin

■ Plot Offset

In addition, a PC2 file contains any resolution information that has been
modified by a plotter calibration. Pen assignment information can also be
imported and saved in a plot style table using the Add Plot Style Table wizard.

To import plotting device and pen settings information, you can use the
Import PCP or PC2 Plot Settings wizard to choose a PCP or PC2 file whose
settings you want to import. You can also choose to modify any of the
imported settings using the Page Setup dialog box.

To import PCP or PC2 settings into the current layout

1 At the Command prompt, enter pcinwizard.

2 In the Import PCP or PC2 Plot Settings wizard, select the PCP or PC2 file
whose settings you want to import into the current layout.

Create and Use Named Page Setups
You can save plot device and other page setup settings as named page setups
that can be modified and imported into other drawings.

You can create named page setups and apply them to other layouts in your
drawing. Named page setups are saved in the drawing file and can be imported
into other drawing files and applied to other layouts. You can also modify the
settings of named page setups. If you modify a named page setup, you can
choose whether the modifications apply to the current layout or to all the
layouts in the current drawing that use the named page setup.

If you want to plot the same layout more than one way, or if you want to
specify the same output options for several layouts, use named page setups.

You can apply different named page setups to the same layout to achieve
specific results when plotting. For example, you might create the named page
setups in the following table to control scaling and paper size.

DescriptionPage setup name

Plot at scale 1:1, E-size sheetNoScaling

Plot at scale 1:2, C-size sheetScale 1 to 2

Plot to the draft-quality plotterDraft

Plot to the high-quality plotterFinal
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DescriptionPage setup name

Fit to Paper, A-size sheetFit-to-Paper

Once you specify a named page setup for a layout, whenever you plot or
publish the layout, it is plotted or published with the settings specified in the
named page setup set for the layout.

To create a new named page setup

1 Click File menu ➤ Page Setup Manager.

2 In the Page Setup Manager, Page Setups area, click New.

3 In the New Page Setup dialog box, enter a name for the new page setup.

4 Under Start With, select a page setup in the list. The settings specified
in the selected page setup will be displayed in the Page Setup dialog box
after you click OK.

5 Click OK.

6 In the Page Setup dialog box, change any required settings. Click OK.

The new page setup is displayed in the Page Setups list in the Page Setup
Manager.

7 To apply the new page setup to the current layout, in the Page Setup
Manager, click Set Current.

8 In the Page Setup Manager, click Close.

Layouts toolbar

Right-click a layout tab. Click Page Setup Manager

To apply a named a page setup to a layout

1 Click the layout tab for which you want to apply a named page setup.

2 Click File menu ➤ Page Setup Manager.

3 In the Page Setup Manager, under Page Setups, select a named page setup
from the list.

NOTE A page setup that is not named is shown in the Page Setup Manager
with an asterisk on either side of its layout name. An unnamed page setup
does not have the same functionality as a named page setup. For example,
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if you set an unnamed page setup as the current page setup for another
layout, the values are applied to the layout. If you make changes to the
original unnamed page setup, those changes do not carry over to the layout
to which the unnamed page setup was applied.

4 Click Set Current.

5 Click Close.

Layouts toolbar

Right-click a layout tab. Click Page Setup Manager

To modify a named a page setup

1 Click File menu ➤ Page Setup Manager.

2 In the Page Setup Manager, under Page Setups, select a named page setup
from the list.

NOTE A page setup that is not named is shown in the Page Setup Manager
with an asterisk on either side of its layout name. An unnamed page setup
does not have the same functionality as a named page setup. For example,
if you set an unnamed page setup as the current page setup for another
layout, the values are applied to the layout. If you make changes to the
original unnamed page setup, those changes do not carry over to the layout
to which the unnamed page setup was applied.

3 Click Modify.

4 In the Page Setup dialog box, make the required changes. Click OK.

5 In the Page Setup Manager, click Close.

Layouts toolbar

Right-click a layout tab. Click Page Setup Manager

To import named page setups from another drawing

1 Click File menu ➤ Page Setup Manager.

Create and Use Named Page Setups | 865



2 In the Page Setup Manager, click Import.

3 In the Select Page Setup From File dialog box, select a drawing file from
which you want to import one or more named page setups. Click Import.

4 In the Import Page Setups dialog box, select one or more page setups to
import. Click OK.

If a page setup with the same name already exists in the drawing, you
can redefine the settings of the existing one with the settings of the
imported page setup, or you can cancel the operation.

The imported page setups are displayed in the Page Setup Manager in
the list of page setups.

NOTE You can import both model space and layout page setups at the same
time. However, an imported model space page setup is shown in the Page
Setup Manager only if the model tab was current when you opened the
Page Setup Manager. Similarly, an imported layout page setup is shown in
the Page Setup Manager only if a layout tab was current when you opened
the Page Setup Manager.

5 In the Page Setup Manager, click Close.

Layouts toolbar

Right-click a layout tab. Click Page Setup Manager

To delete a named page setup

1 Click File menu ➤ Page Setup Manager.

2 In the Page Setup Manager, under Page Setups, right-click the named
page setup you want to delete. Click Delete.

NOTE A page setup that is not named is shown in the Page Setup Manager
with an asterisk on either side of its layout name. An unnamed page setup
does not have the same functionality as a named page setup. For example,
if you set an unnamed page setup as the current page setup for another
layout, the values are applied to the layout. If you make changes to the
original unnamed page setup, those changes do not carry over to the layout
to which the unnamed page setup was applied.

3 Click Close.
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Layouts toolbar

Right-click a layout tab and click Page Setup Manager

To rename a page setup

1 Click File menu ➤ Page Setup Manager.

2 In the Page Setup Manager, under Page Setups, right-click the named
page setup you want to rename. Click Rename.

NOTE A page setup that is not named is shown in the Page Setup Manager
with an asterisk on either side of its layout name. An unnamed page setup
does not have the same functionality as a named page setup. For example,
if you set an unnamed page setup as the current page setup for another
layout, the values are applied to the layout. If you make changes to the
original unnamed page setup, those changes do not carry over to the layout
to which the unnamed page setup was applied.

3 Enter a new name for the page setup.

4 Click Close.

Layouts toolbar

Right-click a layout tab. Click Page Setup Manager

Use Named Page Setups with Sheet Sets
You can use named page setups to specify the same output options for all the
sheets in a sheet set.

You can create a sheet from scratch using the Sheet Set Manager, and then
apply a named page setup to the layout.

You can also apply named page setups that are stored in the sheet set’s page
setup overrides DWT file to a single sheet or to an entire sheet set for a
one-time publish operation.

See also:

“Create and Use Named Page Setups” on page 863
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To apply a named page setup to a sheet created from scratch

1 Click File menu ➤ Open Sheet Set.

2 In the Open Sheet Set dialog box, select a sheet set. Click Open.

3 In the Sheet Set Manager, right click in the Sheets area. Click New Sheet.

4 In the New Sheet dialog box, enter a number and sheet title. Click OK.

5 In the Sheet Set Manager, under Sheets, double-click the new sheet.

6 Click File menu ➤ Page Setup Manager.

7 In the Page Setup Manager, under Page Setups, select a named page setup.
Click Set Current.

Named page setups are not enclosed in asterisks.

8 Click Close.

Standard toolbar

To apply a named page setup as an override when publishing sheets

1 Click File menu ➤ Open Sheet Set.

2 In the Open Sheet Set dialog box, select a sheet set. Click Open.

3 In the Sheet Set Manager, in the Sheets area, select a sheet set, a subset,
or a sheet to publish.

4 At the top of the Sheet Set Manager, click the Publish button.

5 On the shortcut menu, place your cursor over Publish Using Page Setup
Override.

6 On the submenu, click the named page setup you want to use.

Standard toolbar
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Plot Drawings

 
Once you have completed a drawing, you can use a number

of methods to output the drawing. You can plot the drawing

on paper or create a file for use with another application. In

either case, you select the plot settings.

27
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Quick Start to Plotting
To print a single layout or part of a drawing, use the Plot dialog box.

Use a named page setup or change the settings in the Plot dialog box to define
the output of your drawing.

To output more than one drawing, use the Publish dialog box.

See also:

“Quick Start to Publishing” on page 920

Overview of Plotting
Understanding terms and concepts that relate to plotting makes your first
plotting experience in the program easier.

Plotter Manager

The Plotter Manager is a window that lists plotter configuration (PC3) files
for every nonsystem printer that you install. Plotter configuration files can
also be created for Windows®  system printers if you want to use default
properties different from those used by Windows. Plotter configuration settings
specify port information, raster and vector graphics quality, paper sizes, and
custom properties that depend on the plotter type.

The Plotter Manager contains the Add-a-Plotter wizard, which is the primary
tool for creating plotter configurations. The Add-a-Plotter wizard prompts you
for information about the plotter you want to set up.

Layouts

A layout represents a plotted page. You can create as many layouts as you
need. Each layout is saved on its own layout tab and can be associated with
a different page setup.

Elements that appear only on a plotted page, such as title blocks and notes,
are drawn in paper space in a layout. The objects in the drawing are created
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in model space on the Model tab. To view these objects in the layout, you
create layout viewports.

Page Setups

When you create a layout, you specify a plotter and settings such as page size
and plot orientation. These settings are saved in a page setup. You can control
these settings for layouts and for the Model tab using the Page Setup Manager.
You can name and save page setups for use with other layouts.

If you don’t specify all the settings in the Page Setup dialog box when you
create a layout, you can set up the page just before you plot. Or you can
override a page setup at plot time. You can use the new page setup temporarily
for the current plot, or you can save the new page setup.

Plot Styles

A plot style controls how an object or layer is plotted by determining plotted
properties such as lineweight, color, and fill style. Plot style tables collect
groups of plot styles. The Plot Style Manager is a window that shows all the
plot style tables available.

There are two plot style types: color-dependent and named. A drawing can
use only one type of plot style table. You can convert a plot style table from
one type to the other. You can also change the type of plot style table a
drawing uses once it has been set.

For color-dependent plot style tables, an object’s color determines how it is
plotted. These plot style table files have .ctb extensions. You cannot assign
color-dependent plot styles directly to objects. Instead, to control how an
object is plotted, you change its color. For example, all objects assigned the
color red in a drawing are plotted the same way.

Named plot style tables use plot styles that are assigned directly to objects and
layers. These plot style table files have .stb  extensions. Using them enables
each object in a drawing to be plotted differently, independent of its color.

Plot Stamps

A plot stamp is a line of text that is added to your plot. You can specify where
this text is located on the plot in the Plot Stamp dialog box. Turn this option
on to add specified plot stamp information—including drawing name, layout
name, date and time, and so on—to a drawing that is plotted to any device.
You can choose to record the plot stamp information to a log file instead of
plotting it, or in addition to plotting it.

NOTE A drawing file or drawing template file that was created with an educational
version will always be plotted with the following plot stamp: PRODUCED BY AN
AUTODESK EDUCATIONAL PRODUCT. Blocks and xrefs created with an educational
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version and used in a commercial version will also result in the educational plot
stamp being plotted.

See also:

“Create Multiple-View Drawing Layouts (Paper Space)” on page 203
“To view the custom properties Help” in the Driver and Peripheral Guide

To plot a drawing

1 Click File menu ➤ Plot.

2 In the Plot dialog box, under Printer/Plotter, select a plotter from the
Name list.

3 Under Paper Size, select a paper size from the Paper Size box.

4 (Optional) Under Number of Copies, enter the number of copies to plot.

5 Under Plot Area, specify the portion of your drawing to plot.

6 Under Plot Scale, select a scale from the Scale box.

7 For more options, click the More Options button.
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8 (Optional) Under Plot Style Table (Pen Assignments), select a plot style
table from the Name box.

9 (Optional) Under Shaded Viewport Options and Plot Options, select any
appropriate settings.

NOTE Plot stamping happens at plot time and is not saved with the drawing.

10 Under Drawing Orientation, select an orientation.

11 Click OK.

Standard toolbar

Right-click the Model tab or a layout tab and click Plot.

To plot on the command line instead of in a dialog box, use -PLOT.

To turn background plotting on or off

1 Click Tools menu ➤ Options.

2 In the Options dialog box, Plot and Publish tab, under Background
Processing Options, select or clear the Enable Background Plot When
Plotting option.

3 Click OK.

NOTE When you plot in the background, you can return immediately to
your drawing. While a plot job is being processed in the background, you
can check the status of your job by placing your cursor over the plotter icon
in the status tray. You can also view details about all completed jobs from
the current program session.

To check the status of a plot job currently processing in the background

■ In the status tray, place your mouse over the plotter icon. The tooltip
displays the status of the plot job.

Status tray
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To cancel part or all of a plot job that is processing in the background

1 In the status tray, right-click the plotter icon. Click Cancel Sheet
<sheetname> or Cancel Entire Job.

Status tray

To view details about jobs you have plotted

1 Do one of the following:

■ Click File menu ➤ View Plot and Publish Details.

■ In the status tray, click the plotter icon.

2 In the Plot and Publish Details dialog box, view details about plotted
jobs.

In the status tray, right-click the plotter icon. Click View Plot and Publish
Details.

Use a Page Setup to Specify Plot Settings
You can use a page setup to specify the settings for your plot job. When you
select a page setup in the Plot dialog box, the settings from the page setup are
added to the Plot dialog box. You can choose to plot with those settings, or
change any of the settings individually and then plot.

Any settings you specify in the Plot dialog box can be saved as a new named
page setup by clicking the Add button in the Page Setup area.

Any settings specified in the Plot dialog box, whether you’ve applied a page
setup from the Page Setup list, or changed the settings individually, can be
saved to the layout for use the next time you plot.

To plot a drawing using the settings specified in a page setup

1 Click File menu ➤ Plot.

2 In the Plot dialog box, under Page Setups, select a page setup from the
list.

3 (Optional) Change any of the individual settings in the Plot dialog box.

4 To save these settings to the layout, click Apply to Layout.

874 | Chapter 34   Plot Drawings



5 Click Plot.

Standard toolbar

To save plot settings as a new named page setup

1 Click File menu ➤ Plot.

2 In the Plot dialog box, change the required settings.

3 Under Page Setups, click Add.

4 In the Add Page Setup dialog box, enter a name for the new named page
setup. Click OK.

Standard toolbar

To save plot settings to the layout

1 With a layout tab selected, click File menu ➤ Plot.

2 In the Plot dialog box, under Page Setups, select a page setup or specify
settings individually.

3 Click Apply to Layout.

Standard toolbar

Select a Printer or Plotter
After selecting a printing or plotting device, you also can easily plot a drawing
using the default settings in the Plot dialog box.

To select a printer or plotter

1 Click File menu ➤ Plot.
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2 In the Plot dialog box, under Printer/Plotter, select a plotter from the
Name list.

If you have already selected a paper size and it is not supported by the
plotter you have chosen, you are warned that a paper size supported by
the plotter will be used. Click OK if the warning is displayed.

3 Once you have selected a plotter, you can continue to select a paper size,
or if the paper size is correct, click OK to plot the drawing.

Standard toolbar

Specify the Area to Plot
When plotting a drawing, you must specify the area of the drawing to plot.
The Plot dialog box provides the following options under Plot Area.

■ Layout or Limits. When plotting a layout, plots everything within the
printable area of the specified paper size, with the origin calculated from
0,0 in the layout. When plotting the Model tab, plots the entire drawing
area defined by the grid limits. If the current viewport does not display a
plan view, this option has the same effect as the Extents option.

■ Extents. Plots the portion of the current space of the drawing that contains
objects. All geometry in the current space is plotted. The drawing might be
regenerated to recalculate the extents before plotting.

■ Display. Plots the view in the current viewport in the Model tab or the
current paper space view in a layout tab.

■ View. Plots a view saved previously with the  command. You can select a
named view from the list provided. If there are no saved views in the
drawing, this option is unavailable.

■ Window. Plots any portion of the drawing you specify. Click the Window
button to use a pointing device to specify opposite corners of the area to
be plotted, or enter coordinate values.

To set the drawing area as you plot

1 Click File menu ➤ Plot.

2 In the Plot dialog box, under Plot Area, specify the portion of your
drawing that you want to plot.
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3 Change other settings as needed. Click OK to plot the drawing.

Standard toolbar

Set Paper Size
In the Plot dialog box, select the paper size that you want to use.

If you plot from a layout, you may have already specified a paper size in the
Page Setup dialog box. However, if you plot from the Model tab, you need to
specify a paper size when you plot. In the Plot dialog box, select the paper
size that you want to use. The list of paper sizes depends on the printer or
plotter that you have selected in either the Plot or Page Setup dialog box. The
list of available plotters includes all those that are currently configured for use
with Windows and those for which you have installed nonsystem drivers.

You can also set the default page size used to create new layouts for most
plotters by editing the PC3 file associated with that plotter. For Windows
system printers, you can use this technique to specify different default page
sizes for Windows and for this program.

NOTE If the PAPERUPDATE system variable is set to 0, you are prompted if the
layout’s existing paper size is not supported by the plotter you have selected. If
the PAPERUPDATE system variable is set to 1, the paper size is automatically
updated to reflect the default paper size of the selected plotter.

Use a Custom Paper Size

If you need to specify a paper size that is not listed in either the Plot dialog
box or the Page Setup dialog box, you can add a custom paper size for a
nonsystem plotter using the Plotter Configuration Editor. Typically, you
cannot add a custom paper size to Windows system printers because the
allowable page sizes and printable areas are determined by the manufacturer.
However, you can modify the printable area for paper sizes associated with a
Windows system printer.

To select a paper size for the current plot

1 Click File menu ➤ Plot.

2 In the Plot dialog box, under Printer/Plotter, select a plotter in the Name
box.
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3 Under Paper Size, select a paper size from the list.

The paper sizes that are listed depend on the plotter you selected.

Standard toolbar

To set the default paper size for a layout

1 Click File menu ➤ Page Setup Manager.

2 In Page Setup Manager, Page Setups area, the layout for which you want
to set the paper size should be selected. If not, select the layout. Click
Modify.

3 In the Page Setup dialog box, under Paper Size, select a paper size from
the list. Click OK.

The paper sizes that are listed depend on the plotter specified in the page
setup.

4 In Page Setup Manager, click Close.

The layout reflects the changes.

Layouts toolbar

To set the default paper size for a plotter

1 Click File menu ➤ Plot.

2 In the Plot dialog box, under Printer/Plotter, select a plotter from the
Name list.

3 Click Properties.

The Plotter Configuration Editor is displayed.

4 To specify a default paper size, use one of the following methods:

■ For a nonsystem plotter, under Media, select Source and Size.

■ For a system printer, in the tree view, select Custom Properties. Then
under Access Custom Dialog, select Custom Properties.

5 Select the appropriate paper size.

878 | Chapter 34   Plot Drawings



6 Click OK to close each dialog box.

NOTE The available paper sizes depend on the printer or plotter. Some
plotter manufacturers may control paper size differently in the Plotter
Configuration Editor.

Layouts toolbar

To create or edit a custom paper size for a nonsystem printer

1 Click File menu ➤ Plotter Manager.

2 In the Plotter Manager, double-click the PC3 file whose configuration
you want to change.

3 In the Plotter Configuration Editor, Device and Document Settings tab,
under the User Defined Paper Sizes & Calibration, select Custom Paper
Sizes.

4 Set a new paper size using one of the following methods:

■ To add a custom paper size, click Add and follow the steps in the
Custom Paper Size wizard. You specify the size of the paper, the
printable area, and a name for the new paper size.

■ To edit an existing paper size, under Custom Paper Sizes, select the
paper size and click Edit. The Custom Paper Size wizard opens. Change
any of the paper size settings.

5 Click OK.

The new or edited paper size is available in both the Plot and Page Setup
dialog boxes when that PC3 file is selected.

NOTE Creating a custom paper size for a nonsystem driver attaches a plot
model parameter (PMP) file to the plotter configuration (PC3) file. The PMP
file contains custom plotter calibration and custom paper size information.
By default, PMP files are stored in the Drv folder.

Position the Drawing on the Paper
There are several ways to position a drawing on the paper. You can specify
the printable area, set the position of the plot, and set the drawing orientation.
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Specify the Printable Area

The printable area is displayed by a dashed border in a layout. The plotter and
paper size you select determine the printable area.

WARNING If you set your plotter to use paper-saving features such as plotting
inked area or nesting, your plotter will probably not use the printable area and
plot offset specifications.

If your plotter reports an incorrect printable area for your paper size, you can
adjust the printable area in the Modify Standard Paper Sizes area under the
Modify Standard Paper Sizes (Printable Area) option on the Device and
Document Settings tab in the Plotter Configuration Editor.

NOTE The Modify Standard Paper Sizes option is not a margins feature. Specify
where your drawing is plotted on the page in the Plot Offset area in the Plot dialog
box.

Set the Position of the Plot

The printable area of a drawing sheet is defined by the selected output device
and is represented by the dashed line in a layout. When you change to another
output device, the printable area may change.

The settings in the Plot Offset area of the Plot dialog box specify an offset of
the plot area relative to the lower-left corner (the origin) of the printable area
or the edge of the paper, depending on the setting made in the Specify Plot
Offset Relative To option (Options dialog box, Plot and Publish tab). The Plot
Offset area of the Plot dialog box displays the specified plot offset option in
parentheses.

You can offset the drawing on the paper by entering positive or negative values
in the X and Y offset boxes. However, this may result in the plot area being
clipped. If the Plot Area is not set to Layout (Extents, Display, View, or
Window), you can also select the Center the Plot option.

Set Drawing Orientation

The drawing orientation determines whether the position of the plotted
drawing is landscape (the longer edge of the drawing is horizontal) or portrait
(the longer edge of the drawing is vertical). This is based on the size of paper
selected. You can also choose to plot upside down.
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Control How Objects Are Plotted
You can control how objects are plotted by setting the plot scale, by using
plot styles and plot style tables, and by setting an object’s layer properties.

Set Plot Scale

When you specify a scale to output your drawing, you can choose from a list
of real-world scales, enter your own scale, or select Fit to Paper to scale the
drawing to fit onto the selected paper size.

Usually, you draw objects at their actual size. That is, you decide how to
interpret the size of a unit (an inch, a millimeter, a meter) and draw on a 1:1
scale. For example, if your unit of measurement is millimeters, then every unit
in your drawing represents a millimeter. When you plot the drawing, you
either specify a precise scale or fit the image to the paper.

Most final drawings are plotted at a precise scale. The method used to set the
plot scale depends on whether you plot the Model tab or a layout:

■ On the Model tab, you can establish the scale in the Plot dialog box. This
scale represents a ratio of plotted units to the world-size units you used to
draw the model.

■ In a layout, you work with two scales. The first affects the overall layout of
the drawing, which usually is scaled 1:1, based on the paper size. The second
is the scale of the model itself, which is displayed in layout viewports. The
scale in each of these viewports represents a ratio of the paper size to the
size of the model in the viewport.

NOTE You can modify the list of scales that are displayed in all view and plot scale
lists with .

Set a Specific Scale

When you plot, the paper size you select determines the unit type, inches or
millimeters. For example, if the paper size is in mm, entering 1 under mm
and 10 under Units produces a plotted drawing in which each plotted
millimeter represents 10 actual millimeters.

The illustrations show a light bulb plotted at three different scales.
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plotted at 1=1 plotted at .5=1 plotted at 1.5=1

Scale the Drawing to Fit the Page

When you review drafts, a precise scale is not always important. You can use
the Fit to Paper option to plot the view at the largest possible size that fits the
paper. The height or width of the drawing is fit to the corresponding height
or width of the paper.

When you plot a perspective view from model space, the view is scaled to fit
the paper even when you enter a scale.

When you select the Fit to Paper option, the text boxes change to reflect the
ratio of plotted units to drawing units. This scale is updated whenever you
change the paper size, plotter, plot origin, orientation, or size of the plotted
area in the Plot dialog box.

NOTE This option is not available when the Plot Area is set to Layout.

To plot using a real-world scale

1 Click File menu ➤ Plot.

2 In the Plot dialog box, under Plot Scale, select a scale from the Scale box.

3 Click OK to plot the drawing.

Standard toolbar

To plot using a custom scale

1 Click File menu ➤ Plot.
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2 In the Plot dialog box, under Plot Scale, enter a custom scale. The scale
requires two values, the number of plotted units (inches or mm) per the
number of drawing units. The type of unit is determined by the paper
size, but you can change it in the list box.

If you enter a custom scale, Custom is automatically selected in the Scale
box, even if the scale you enter is the same as a standard scale in the list.
A custom scale is the ratio between the plotted units and drawing units.
For example, 1:12 and 2:24 are plotted at the same scale.

3 Click OK to plot the drawing.

Standard toolbar

To scale a drawing to fit the page

1 Click File menu ➤ Plot.

2 In the Plot dialog box, under Plot Scale, select the Fit to Paper option.

The resulting scale is automatically calculated. The ratio of plotted units
to drawing units in the custom scale boxes is displayed.

3 Click OK to plot the drawing.

NOTE This option is not available when the Plot Area is set to Layout.

Standard toolbar

Set Shaded Viewport Options

You can choose among several options for plotting shaded and rendered
viewports. You can plot a viewport as it is displayed, in wireframe, with hidden
lines removed, or as rendered.

You can specify how each viewport should be plotted, and save the plot settings
with a drawing. You also can choose from a wide variety of resolutions, up to
the resolution of your plotter, and save the resolution settings with a drawing.
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Overview of Shaded Viewport Plotting

The options for shaded viewport plotting give you a large degree of flexibility
in conveying your three-dimensional designs to others. You can convey your
design intent by choosing how viewports are plotted and by specifying
resolution levels.

With shaded plotting options, you can choose whether to plot a set of shaded
objects using the As Displayed, Wireframe, Hidden, or Rendered option. Shaded
and rendered viewports are plot-previewed, plotted, plotted to file, and
published with full shading and rendering.

You can use realistic plots in your presentations by plotting viewports as they
are displayed on the screen or otherwise.

Shaded viewport plotting options apply to all objects in viewports and model
space. If you use the Shaded or Rendered options plot style tables included in
the page setup do not affect plots. If you use the Render option,
two-dimensional wireframe objects, such as lines, arcs, and text, are not plotted.

NOTE Shaded viewport plotting requires a raster-capable device. Most modern
plotters and printers are raster-capable devices.

Specify Shaded Plotting Settings

If you are plotting a drawing that contains 3D solids that are shaded, you can
control how the drawing is plotted.

Specifically, you can choose from the following options:

■ As Displayed. Plots the design as it is displayed; all the shading is
preserved.

■ Wireframe. Displays lines and curves to represent object boundaries.

■ Hidden. Suppresses the plotting of objects that are located behind other
objects.

■ Rendered. Renders objects before they are plotted, based on Render options
you set before you plot.

You can select an option for your drawing either from model space or from a
layout. From model space, the options are available in the Properties palette
and the Plot dialog box. From a layout, after you select a viewport, the options
are available from the shortcut menu and from the Properties palette.

Either way, you can save your settings with the drawing.
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NOTE If you select the Rendered option, specify Render settings before plotting.
If the Rendered option is used for a highly complex set of objects, the hardcopy
output might contain only the viewport border.

To modify the shade plot setting of a viewport

1 Make sure you are on a layout tab.

2 Double-click the border of the viewport you want to modify.

3 In the Properties palette, under Misc., select Shade Plot, and then select
an option for plotting.

Select the viewport and right-click in the drawing area. Click a setting from
the Shade Plot options.

To modify the shade plot setting in model space

1 Make sure you are on the Model tab and no objects are selected.

2 Click File menu ➤ Plot.

3 In the Plot dialog box, under Shaded Viewport Options, Shade Plot
drop-down list, select an option.

Specify a Resolution Level for Shaded Plotting

You can set the resolution of shaded plots for either greater speed or higher
fidelity.

After you select an appropriate plotter, you can specify the level of quality for
plotted output. The quality level determines the dpi. The dpi that corresponds
to a quality level is based on the plotter you select.

The maximum dpi available is also based on the plotter you select. You can
specify a custom quality level and directly change the dpi to a setting between
100 and the maximum dpi of the plotter.

The higher the fidelity, the more computer memory is used, so the longer it
takes to plot. High fidelity is not necessary for all plots, and a setting between
300 and 600 dpi is generally sufficient for most plots.

To specify a resolution level for shaded plotting

1 Click File menu ➤ Plot.

2 In the Plot dialog box, under Shaded Viewport Options, Quality
drop-down list, select an option.
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If you want to enter a custom dpi, select Custom and specify a dpi in
the DPI box.

3 Click OK.

Set Options for Plotted Objects

In the Plot and the Page Setup dialog boxes, you can choose from options that
affect how objects are plotted.

■ Shaded Viewport Plotting. Specifies shaded plotting options: As
Displayed, Wireframe, or Hidden. The effect of this setting is reflected in
the plot preview, but not in the layout.

■ Plot Object Lineweights. Specifies that lineweights assigned to objects
and layers are plotted.

■ Plot with Plot Styles. Specifies that the drawing is plotted using plot
styles. Selecting this option automatically plots lineweights. If you do not
select this option, objects are plotted with their assigned properties and
not with the plot style overrides.

■ Plot Paper Space Last. Specifies that objects in model space are plotted
before those in paper space.

■ Hide Paperspace Objects. Specifies whether the Hide operation applies
to objects in the paper space viewport. This option is available only from
a layout tab. The effect of this setting is reflected in the plot preview, but
not in the layout.

■ Plot Stamp On. Turns on plot stamping and places a plot stamp on a
specified corner of each drawing and/or logs it to a file. Plot stamp settings
are specified in the Plot Stamp dialog box, where you can specify the
information you want applied to the plot stamp, such as drawing name,
date and time, plot scale, and so on. To open the Plot Stamp dialog box,
select Plot Stamp On in the Plot dialog box, and then click the Plot Stamp
Settings button.

■ Save Changes to Layout. Saves changes you make in the Plot dialog box
to the layout if you click OK.

To set shaded plotting options from the Model tab

1 Click File menu ➤ Plot.

2 In the Plot dialog box, Shaded Viewport Options area, Shade Plot
drop-down list, select an option.
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Standard toolbar

To set shaded plotting options from a layout tab

1 Select a layout viewport.

2 Double-click the viewport border to display the Properties palette.

3 On the Properties palette, click Shade Plot.

4 In the Shade Plot drop-down list, select an option.

Standard toolbar

Select the viewport, right-click in the drawing area, and then click Shade Plot.

To remove hidden lines when plotting from the Model tab

1 Click File menu ➤ Plot.

2 In the Plot dialog box, under Shaded Viewport Options area, Shade Plot
drop-down list, select Hidden.

3 Click OK to plot the drawing.

Hidden lines not removed Hidden lines removed

Standard toolbar
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To remove hidden lines when plotting from a layout tab

1 Select a layout viewport.

2 Double-click the viewport border to display the Properties palette.

3 On the Properties palette, click Shade Plot.

4 In the Shade Plot drop-down list, select Hidden.

5 Click OK to plot the drawing.

Hidden lines not removed Hidden lines removed

Standard toolbar

Select the viewport and right-click in the drawing area. Click Shade Plot.

To plot lineweights

1 Click File menu ➤ Plot.

2 In the Plot dialog box, under Plot Options, select Plot Object Lineweights.

You can change this option only if the Plot with Plot Styles option is
cleared.

3 Click OK to plot the drawing.

Standard toolbar
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To turn off plot styles

1 Click File menu ➤ Plot.

2 In the Plot dialog box, under Plot Options, clear the Plot with Plot Styles
option.

3 Click OK to plot the drawing.

Standard toolbar

To change the order in which objects are plotted

1 Click File menu ➤ Plot.

2 In the Plot dialog box, under Plot Options, select Plot Paperspace Last.
Clear the Plot Paperspace Last option to plot paper space first.

3 Click OK to plot the drawing.

Standard toolbar

To hide paper space objects when plotting from a layout tab

1 Click File menu ➤ Plot.

2 In the Plot dialog box, under Plot Options, select Hide Paperspace Objects.

3 Click OK to plot the drawing.

Standard toolbar
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Use Plot Styles to Control Plotted Objects

You can control many aspects of how an object is plotted by using plot styles.

Overview of Plot Styles

A plot style is an object property, similar to linetype and color. A plot style
can be assigned to an object or assigned to a layer. A plot style controls an
object’s plotted properties, including

■ Color

■ Dither

■ Grayscale

■ Pen number

■ Virtual pen

■ Screening

■ Linetype

■ Lineweight

■ Line end style

■ Line join style

■ Fill style

Using plot styles gives you great flexibility because you can set them to override
other object properties or turn off the override as needed.

Groups of plot styles are saved in either of two types of plot style tables:
color-dependent (CTB) or named (STB). Color-dependent plot style tables set
style based on the color of the object. Named plot styles can be assigned to
an object independent of color.

Choose a Type of Plot Style Table

A plot style table is a collection of plot styles assigned to a layout or the Model
tab. There are two types of plot style tables: color-dependent plot style tables
and named plot style tables.

Color-dependent plot style tables (CTB) use an object’s color to determine
characteristics such as lineweight. Every red object in a drawing is plotted the
same way. While you can edit plot styles in a color-dependent plot style table,
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you cannot add or delete plot styles. There are 256 plot styles in a
color-dependent plot style table, one for each color.

Named plot style tables (STB) contain user-defined plot styles. When you use a
named plot style table, objects that have the same color may be plotted
differently, based on the plot style assigned to the object. A named plot style
table can contain as many or as few plot styles as required. Named plot styles
can be assigned to objects or layers, just like any other property.

To set a plot style table type for new drawings

1 Click Tools menu ➤ Options.

2 In the Options dialog box, Plot and Publish tab, click the Plot Style Table
Settings button.

3 In the Plot Style Table Settings dialog box, select Use Color-dependent
Plot Styles or Use Named Plot Styles.

4 (Optional) In the Default Style Table box, select a default plot style table.

5 (Optional) If Use Named Plot Styles is selected, select plot styles to assign
to Layer 0 and to new objects.

6 Click OK.

NOTE Setting plot style table types for new drawings does not affect existing
drawings.

Switch the Type of Plot Style Table

You can change which type of plot style table, color-dependent or named, is
used in a drawing.

You can use  to change which type of plot style table, color-dependent or
named, is used in a drawing.

When you convert a drawing from using color-dependent plot style tables to
using named plot style tables, any color-dependent plot style tables attached
to layouts in the drawing are removed, and named plot styles are attached in
their place. If you want to use the styles defined in the color-dependent plot
style tables after you convert to using named plot styles tables, you should
first convert any color-dependent plot style tables to named plot style tables.

When you convert a drawing from using named plot style tables to using
color-dependent plot style tables, the plot style names assigned to the objects
in the drawing are lost.
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In addition to changing which type of plot style table a drawing uses, you can
use  to convert color-dependent plot style tables to named plot style tables.
You cannot, however, convert a named plot style table to a color-dependent
plot style table.

To convert a drawing to use named plot styles

1 At the Command prompt, enter convertpstyles.

2 Click OK when the alert box appears.

3 In the Select File dialog box, select a named plot style table to use for
the Model tab and any layouts that use plot style tables of the same
name.

4 Click Open.

A message is displayed to confirm that the drawing was converted.

NOTE If the Display Plot Styles option was already selected in the dialog
box, you must enter regen on the command line to display the plot style
settings.

To convert a drawing to use color-dependent plot styles

1 At the Command prompt, enter convertpstyles.

2 Click OK.

A message is displayed to confirm that the drawing was converted.

To convert a color-dependent plot style table into a named plot style table

1 At the Command prompt, enter convertctb.

2 In the Select File dialog box, select the name of the plot style table to
convert, and then click Open. By default, plot style tables are saved in
the Plot Styles folder.

3 Enter the new plot style table name. Click Save.

4 Click OK when the alert box appears.

NOTE Be sure to use the Plot Style Table Editor to change the names of the plot
styles in their new plot style table to be more meaningful before using the plot
style table with any drawings.
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Assign Plot Style Tables to Layouts

By assigning different plot style tables to each layout in your drawing, you
can control how objects in the layout are plotted. The plot style table affects
both model space and paper space objects. To plot the drawing without
applying plot style properties, select None from the list of plot style tables.

If you use named plot style tables, each object in the drawing either is assigned
a plot style directly or inherits a plot style from its layer.

To display the effects of a plot style table in a layout, select Display Plot Styles
under Plot Style Table in the Page Setup dialog box.

NOTE If you insert an xref into your current drawing, all defined plot style tables
are also inserted. You can modify the appearance of your objects by editing the
attached plot style tables with the Plot Style Table Editor.

To assign a plot style table to a layout

1 Click the Model tab or the layout tab to which you want to assign the
plot style table.

2 Click File menu ➤ Page Setup.

3 In Page Setup Manager, click Modify.

4 Under Plot Style Table (Pen Assignments), select a plot style table from
the list.

5 In the Question dialog box, click Yes or No to indicate whether the
selection should be applied to the current tab only or to all layouts.

This option is available only for the Model tab.

6 To preview the effects of the plot style table in the layout, select Display
Plot Styles.

This option is available only for layouts.

7 Click OK.

8 In Page Setup Manager, click Close.

NOTE If the Display Plot Styles option was already selected in the dialog box, you
must enter regen on the command line to display the plot style settings.

Layouts toolbar
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To preview the effects of a plot style table in a layout

1 Click the layout tab in which you want to preview the effects of the plot
style table.

2 Click File menu ➤ Page Setup.

3 In Page Setup Manager, click Modify.

4 In the Page Setup dialog box, under Plot Style Table (Pen Assignments),
select the Display Plot Styles option.

5 Click OK.

6 In Page Setup Manager, click Close.

The effects of the plot style table are previewed in the layout.

Layouts toolbar

Manage Plot Style Tables

You can use the Plot Style Manager to add, delete, rename, copy, and edit plot
style tables.

Color-dependent (CTB) and named (STB) plot style tables are stored in the
Plot Styles folder by default. This folder is also known as the Plot Style Manager.

You can use the Plot Style Manager to add, delete, rename, copy, and edit plot
style tables. The Plot Style Manager lists all of the available plot style tables.

To create a plot style table

1 Click Tools menu ➤ Wizards ➤ Add Plot Style Table.

2 Read the first page. Click Next.

3 On the Begin page, you can choose to use an configuration file (CFG)
or plotter configuration file (PCP or PC2) to import pen settings, base
the new plot style table on an existing plot style table, or start from
scratch. If you use an existing plot style table, the new plot style table
uses the same type of table as the original. Click Next.

4 On the Pick Plot Style Table page, select Color-Dependent Plot Style
Table or Named Plot Style Table.

5 If you are importing pen settings from a PCP, PC2, or CFG file, or if you
are basing the new plot style table on an existing plot style table, specify
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the file on the Browse File Name page. If you use a CFG file, you may
need to select which plotter’s configuration to import. Click Next.

6 On the File Name page, enter a name for the new plot style table. Click
Next.

7 On the Finish page, you can edit the new plot style table by choosing
Plot Style Table Editor. You can assign the new plot style table so that it
can be used in all drawings.

8 Click Finish.

The new plot style table is available in both the Plot and the Page Setup
dialog boxes for all drawings using color-dependent plot style tables.

To rename a plot style table

1 Click File menu ➤ Plot Style Manager.

2 Right-click the plot style whose name you want to change. Click Rename.

3 Enter the new file name. Be sure to add the same file extension (.ctb or
.stb). When finished, press  ENTER .

The renamed plot style table is available in the Plot and Page Setup dialog
boxes for all drawings using that type of plot style table.

To change a plot style table description

1 Click File menu ➤ Plot Style Manager.

2 Double-click the plot style table file whose description you want to
change.

3 In the Plot Style Table Editor, General tab, enter the new description for
the plot style table.

4 Click Save & Close.

To edit plot styles in a plot style table

1 Click File Menu ➤ Plot Style Manager.

2 Double-click the plot style table you want to change.

3 In the Plot Style Table Editor, Form View tab, under Plot Styles, select a
plot style and edit the settings.

4 Click Save & Close.
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Use Color-Dependent Plot Style Tables

When a drawing uses color-dependent plot style tables, you cannot assign a
plot style to individual objects or layers. Instead, to assign plot style properties
to an object, you change the color of the object or layer.

You can assign color-dependent plot style tables to layouts. You can use several
predefined color-dependent plot style tables, edit existing plot style tables, or
create your own.

Color-dependent plot style tables are stored in the Plot Styles folder and have
a .ctb extension.

Use Predefined Color-Dependent Plot Style Tables

Several color-dependent plot style tables are installed in the Plot Styles folder,
also known as the Plot Style Manager.

DescriptionTable

Default plot style tableacad.ctb

Sets first 9 colors to use first 9 fill patterns, all others to use
object’s fill

fillPatterns.ctb

Converts all colors to grayscale when plottedgrayscale.ctb

Plots all colors as blackmonochrome.ctb

Applies no plot style tableNone

Uses 100% ink for all colorsscreening 100%.ctb

Uses 75% ink for all colorsscreening 75%.ctb

Uses 50% ink for all colorsscreening 50%.ctb

Uses 25% ink for all colorsscreening 25%.ctb

NOTE You can assign a color-dependent plot style table to a layout only if the
drawing has been set to use color-dependent plot style tables.

See also:

“Assign Plot Style Tables to Layouts” on page 893

Use Named Plot Style Tables

You can only create, delete, and apply plot styles in a named plot style table.
You can define as many or as few plot styles as you need in a drawing.
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Use Named Plot Styles

Named plot styles are assigned to objects and layers in the same way that
linetype and color are assigned to objects.

An object whose plot style is set to BYLAYER inherits the plot style assigned
to its layer.

Use the Properties palette to change an object’s plot style and the Layer
Properties Manager to change the plot style for a layer.

Because different plot style tables can be assigned to each layout and a named
plot style table can contain any number of plot styles, an object or layer may
have a plot style assigned to it that is not in every plot style table. In this case,
the plot style as missing in the Select Plot Style dialog box; the object’s default
plotting properties are used. For example, named plot style table Style1 contains
plot styles A and B. Named plot style table Style2 contains plot styles B and
C. In a layout that uses Style1, any objects that use plot style C are listed as
having a missing plot style. Objects that are assigned plot style C in this layout
are plotted using their default settings.

To change an object’s plot style

You can change an object’s plot style only if the drawing uses named plot
style tables. If the drawing uses color-dependent plot style tables, change the
object’s color to alter its plotted appearance.

1 Select one or more objects whose plot style you want to change.

2 Right-click in the drawing area. Click Properties.

3 In the Properties palette, select a plot style from the list of available plot
styles. Click the column next to Plot Style.

The plot styles listed are those already in use by objects and in the plot
style table attached to the current layout.

4 To select a plot style from a different plot style table, select Other. In the
Select Plot Style dialog box, you can attach a different plot style table to
the current layout and select a plot style from that plot style table.

5 To edit the current plot style table, click Editor.

6 Click OK when finished.

Any changes made in the Properties palette are immediate. If you change
the plot style table attached to the current layout, both model space and
paper space objects are affected.

Standard toolbar
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To change a layer’s plot style

1 Click Format menu ➤ Layer.

2 In the Layer Properties Manager, select the layer whose plot style you
want to change.

3 Click the current plot style in the Plot Style column. Select the plot style
you want to use.

4 To select a plot style from a different plot style table, select an active
plot style table from the Active Plot Style Tables list.

The list of plot styles changes to those in the selected plot style table.

5 To edit the selected plot style table, click Editor. Change settings as
necessary and click Save & Close.

6 Click OK.

You can change a layer’s plot style only if the drawing uses named plot
style tables. If the drawing uses color-dependent plot style tables, change
the layer’s color to alter the plotted appearance of objects on the layer.

NOTE An object's plot style property can be set to BYLAYER to inherit the
plot style of its layer.

Layers toolbar

To set the current plot style

1 Click Format menu ➤ Plotstyle.

2 In the Current Plot Style dialog box, select a plot style from the list.

The plot styles displayed are those available in the current plot style
table.

3 To select a plot style from a different plot style table, under Active Plot
Style Table, select a plot style table.

The list of plot styles changes to those in the selected plot style table.

4 To edit the selected plot style table, click Editor. Change settings as
necessary. Click Save & Close.
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5 Click OK.

The plot style that you made current is used for any new objects created
in the drawing.

You can change the current plot style only if the drawing uses named
plot style tables. If the drawing uses color-dependent plot style tables,
change the color to alter the plotted appearance of objects and layers.

NOTE The current plot style property can be set to BYLAYER to inherit the
plot style of the current layer.

Manage Named Plot Styles

You can add, delete, rename, and copy plot styles in a named plot style table
using the Plot Style Table Editor.

The Plot Style Table Editor is also used to change plot style settings for both
named and color-dependent plot style tables.

NOTE You cannot delete or edit the NORMAL plot style. Also, you cannot add,
delete, copy, or rename plot styles in a named plot style table if a color mapping
table has been attached to the plot style table. A color mapping table associates
every plot style with an ACI color.

See also:

“Change Plot Style Settings” on page 902

To create a named plot style

1 Click File menu ➤ Plot Style Manager.

2 Double-click the STB file to which you want to add a plot style.

3 (Optional) If you want to position the plot style in the list, on the Form
View tab, select the plot style that should precede the new plot style.

4 On the Form View or Table View tab, click Add Style.

5 In the Add Plot Style dialog box, enter the name of the plot style.

6 Click Save & Close.

To copy a named plot style

1 Click File menu ➤ Plot Style Manager.

2 Double-click the STB file you want to edit.
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3 In the Plot Style Table Editor, Form View tab, right-click the plot style
that you want to copy. Click Copy.

4 Right-click a plot style. Click Paste. If you want to position the new plot
style in the list, right-click the plot style that should precede the new
plot style.

5 In the Add Plot Style dialog box, enter the name of the plot style.

6 Click Save & Close.

To change a plot style’s description

1 Click File menu ➤ Plot Style Manager.

2 Double-click the plot style table that contains the plot style whose
description you want to change.

3 In the Plot Style Table Editor, Form View tab, select the plot style whose
description you want to change.

4 Under Description, change the plot style’s description.

You can select additional plot styles and modify their descriptions or
settings.

5 Click Save & Close.

To rename a named plot style

1 Click File menu ➤ Plot Style Manager.

2 Double-click the STB file that contains the plot style you want to rename.

3 In the Plot Style Table Editor, Form View tab, right-click the plot style
whose name you want to change. Click Rename.

4 Enter the new name for the plot style.

5 Click Save & Close.

To delete a named plot style

1 Click File menu ➤ Plot Style Manager.

2 Double-click the STB file you want to edit.

3 In the Plot Style Table Editor, Form View tab, select the plot style that
you want to delete from the list of plot styles.

4 Click Delete Style.
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5 Click Save & Close.

Use Predefined Named Plot Style Tables

One additional named plot style table is installed for you to use beyond the
default plot style table. All named plot style tables have an .stb extension.

■ acad.stb: Default plot style table

■ Monochrome.stb: All colors plot as black

■ None: No plot style table applied

NOTE Named plot style tables are available only if the drawing has been set to
use named plot style tables.

See also:

“Assign Plot Style Tables to Layouts” on page 893

Delete Color Mapping Tables

If you delete the mapping table, the plot style table becomes an ordinary plot
style table and is no longer useful for applying plot styles to old drawings.

Named plot style tables that you create using CFG, PCP, or PC2 files have
color mapping tables that are created from your previous pen mappings.
Color-dependent plot style tables also have color mapping tables. Color
mapping tables are used to map plot styles to colors and thus to objects of
each color when opening pre- AutoCAD 2000 drawings. This enables you to
simulate the way drawings were plotted in previous versions.

While the color mapping table exists, you cannot add, delete, or rename plot
styles in that plot style table.

If you delete the mapping table, the plot style table becomes an ordinary plot
style table and is no longer useful for applying plot styles to old drawings. It
continues to be useful for new drawings.

WARNING If you delete a color mapping table, plot styles cannot automatically
be assigned to objects when older drawings are opened for the first time.

To delete a color mapping table

1 Click File menu ➤ Plot Style Manager.

2 Double-click the plot style table that you want to modify.
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3 In the Plot Style Table Editor, General tab, click Delete AutoCAD Release
14 Color Mapping Table.

4 Read the warning. Click Yes to delete the color mapping table, or click
No to keep it.

5 Click Save & Close.

Change Plot Style Settings

You can modify plot styles using the Plot Style Table Editor. Changes you
make to a plot style affect the objects to which that plot style is assigned.

Overview of Plot Style Settings

You can open the Plot Style Table Editor by double-clicking a CTB or STB file
in the Plotter Manager. The Plot Style Table Editor displays the plot styles
contained in the specified plot style table.

The General tab lists general information about the table. The Table View and
Form View tabs provide two ways to modify plot style settings. In general, the
Table View tab is convenient if you have a small number of plot styles. If you
have a large number of plot styles, the Form View tab might be more
convenient.

In a named plot style table, the NORMAL plot style represents an object’s
default properties (no plot style applied). You cannot modify or delete the
NORMAL style.

To edit plot style settings

1 Click File menu ➤ Plot Style Manager.

2 Double-click the plot style table you want to modify.

3 In the Plot Style Table Editor, Form View tab, under Plot Styles, select
the plot style you want to modify.

4 Under Properties, click the arrow next to the property you want to
change. Select an option from the list.

5 Edit other properties or plot styles as needed.

6 Click Save & Close.
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Set Color, Screening, Grayscale, and Dither in Plot Style
Tables

You can use a plot style to assign color, screening, grayscale, and dither
properties.

Assign Plot Style Colors

The default setting for plot style color is Use Object Color. With this setting,
the object retains its layer or individually set color. If you assign a plot style
color, the color overrides the object’s color at plot time. You can specify one
of 255 ACI colors, a true color, or a color book color. The plotter must be
configured for True Color if you want to plot True Color plot styles.

The default setting for plot style color is Use Object Color. With this setting,
the object retains its layer or individually set color. If you assign a plot style
color, the color overrides the object’s color at plot time. You can specify one
of 255 ACI colors.

NOTE If you use a plot style table saved in AutoCAD 2000 or later, the True
Color values change to the nearest match in the current version’s palette.

Use Screening

You can select a color intensity setting that determines the amount of ink
placed on the paper while plotting. The valid range is 0 through 100. Selecting
0 reduces the color to white. Selecting 100 displays the color at its full intensity.
Screening is effective only if your plotter is configured to plot colors or
grayscale. Also, dithering must be enabled.

Use Dithering

A plotter uses dithering to approximate colors with dot patterns, giving the
impression of plotting with more colors than the ink colors available in the
plotter. If the plotter does not support dithering, the dithering setting is
ignored.

The most common reason for turning off dithering is to avoid false line typing
from dithering of thin vectors and to make dim colors more visible. When
you turn off dithering, colors are mapped to the nearest color, which limits
the range of colors used for plotting. Dithering is available whether you use
the object’s color or assign a plot style color.

NOTE Dithering disables merge control.
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Convert to Grayscale

When you select Convert to Grayscale, the object’s colors are converted to
grayscale if the plotter supports grayscale. Light colors, such as yellow, are
plotted with light gray values. Dark colors are plotted with dark gray values.
If you clear Convert to Grayscale, the RGB values are used for the object’s
colors. Conversion to grayscale is available whether you use the object’s color
or assign a plot style color.

To assign a plot style color

1 Click File menu ➤ Plot Style Manager.

2 Right-click a CTB or STB file. Click Open.

3 In the Plot Style Table Editor, Table View tab, click the Color field for
the plot style you want to change.

4 On the Color drop-down list, click the color you want to use or click
Select Color to display the Select Color dialog box and do one of the
following:

■ On the Index tab, click a color or enter the ACI color number (1-255)
or name in the Color box. Click OK.

■ On the True Color tab, in the Color Model box, specify a color, (Enter
a color value in the Color box or specify values in the Hue, Saturation,
and Luminance boxes.) Click OK.

■ On the Color Books tab, in the Color Book box, select a color (use the
up and down arrow and click on a color chip.) Click OK.

To use screening

1 Click File menu ➤ Plot Style Manager.

2 Double-click the plot style table that you want to modify.

3 In the Plot Style Table Editor, Form View tab, select the plot style you
want to change.

4 In the Screening box, enter an intensity value between 1 and 100.

5 When finished, click Save & Close.

You can edit properties for multiple plot styles while in the Plot Style
Table Editor.

NOTE A common practice when using screening is to set the plotted color
to black for each style so that the screening will be a percentage of black.
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To enable or disable dithering

1 Click File menu ➤ Plot Style Manager.

2 Double-click the plot style table that you want to modify.

3 In the Plot Style Table Editor, Form View tab, select the plot style you
want to change and select Dither.

4 Select On or Off.

5 When finished, click Save & Close.

You can edit properties for multiple plot styles while in the Plot Style
Table Editor.

To enable or disable conversion to grayscale

1 Click File menu ➤ Plot Style Manager.

2 Double-click the plot style table that you want to modify.

3 In the Plot Style Table Editor, Form View tab, select the plot style you
want to change and select Grayscale.

4 Select On or Off.

5 When finished, click Save & Close.

You can edit properties for multiple plot styles while in the Plot Style
Table Editor.

Assign Pen Numbers and Virtual Pens in Plot Style Tables

The pen assignments used by the plotter differ depending on whether you
use a pen plotter or another kind of printer, such as a laser printer.

Assign Pens to Plot Styles

The Use Assigned Pen Number setting in the Plot Style Table Editor specifies
which physical pen to use for each plot style. The physical pens in the plotter
are described in the plotter’s configuration (PC3) file. If you use a pen plotter,
you must provide information about the color, speed, and width of each pen
in the Physical Pen Configuration section of the Plotter Configuration Editor.

For example, when you specify pen information in the Plotter Configuration
Editor, you might specify that pen #1 is black and 0.010 inches and pen #2 is
red and 0.020 inches. In the Plot Style Table Editor you can assign pen #1 to
the plot style called WATER PIPES and pen #2 to the plot style called SEWER
PIPES.
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You can assign a pen to a plot style by selecting from a range of 32 pen
numbers in the Use Assigned Pen Number field. The default value is 1. If plot
style color is set to Use Object Color, or if you are editing a plot style in a
color-dependent plot style table, you cannot change the assigned pen number.

If you specify 0, the field is updated to read Automatic. The information you
provided under Physical Pen Characteristics in the Plotter Configuration Editor
is used to select the pen closest in color to the color of the object you are
plotting.

Assign Pen Settings to Plotters Without Pens

Many plotters that do not use pens can simulate the performance of a pen
plotter by using virtual pens. For many devices, you can control the virtual
pens in the device with software or, by configuring them from the plotter’s
control panel, with hardware.

If you allow software to control the pens, the Plot Style Table values for the
Lineweight, Linetype, Screening, Line End Style, Line Join Style, and Fill Style
settings are effective and override the settings on the plotter’s control panel.

If you turn off software control of the pen attributes (typically done on the
plotter), then the software can select virtual pens but can’t control lineweight,
linetype, end style, join style, fill style, or color. In the program, you select
hardware (virtual pen) control over software (normal) control by selecting
255 Virtual Pens in the Color Depth area of the Vector Graphics option on
the Device and Document Settings tab in the Plotter Configuration Editor.
Selecting any other color depth specifies software control.

In the Plot Style Table Editor under Virtual Pen #, you can specify a virtual
pen number between 1 and 255. Enter 0 or Automatic to specify that the
virtual pen assignment should be made from the ACI.

When you create a plot style table, it is important to remember that it can be
used with many different plotters and that the plotter and mode determine
what parts of the plot style table are enabled.

■ When using a pen plotter with user assigned pens, the virtual pen number
and any color assignments are ignored.

■ When using a pen plotter with automatically assigned pens, pens are
selected based on entity color and entity lineweight. Virtual pen numbers
are ignored.

■ When using a raster plotter in raster mode, the physical pen number and
the virtual pen number are ignored.

■ When using a raster plotter in virtual pen mode, everything except the
virtual pen number is ignored.
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NOTE If you use another application to process your plot files after creating them,
and you modify the pen attributes, plotting without using virtual pens results in
pen numbers in the plot file having no simple relationship to object colors in the
program. This makes it difficult to apply additional pen attributes.

To specify a virtual pen number

1 Click File menu ➤ Plot Style Manager.

2 Double-click the plot style table that you want to modify.

3 In the Plot Style Table Editor, Form View tab, select the plot style you
want to change and click Virtual Pen.

4 Under Virtual Pen #, enter a number between 1 and 255 or enter 0 or
Automatic to have the program assign the ACI color of the object you
are plotting to the virtual pen.

5 When finished, click Save & Close.

You can edit properties for multiple plot styles while in the Plot Style
Table Editor.

Control Plotted Lineweight and Linetype

Both lineweight and linetype can be set as an object property or controlled
when plotted by using a plot style. Lineweight or linetype settings in the plot
style override the object’s lineweight or linetype at plot time.

Assign and Display Lineweights

When you select the Lineweight field in the Plot Style Table Editor, a sample
of the lineweight as well as its numeric value are displayed. The default setting
for plot style lineweight is Use Object Lineweight. You can modify an existing
lineweight if the one you need is not available.

To view plot style lineweights in a layout, select Display Plot Styles under Plot
Style Table in the Page Setup dialog box.

Assign Linetypes

When you select the Linetype field in the Plot Style Table Editor, a list with
a sample and a description of each linetype are displayed. The default setting
for plot style linetype is Use Object Linetype.

Whether you choose to assign a linetype as a property of the object or as a
plot style, you can set the Adaptive Adjustment option. This option adjusts
the scale of the linetype to complete the linetype pattern. If you don’t select
Adaptive Adjustment, the line might end in the middle of a pattern. Turn off
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Adaptive Adjustment if linetype scale is important. Turn on Adaptive
Adjustment if complete linetype patterns are more important than correct
linetype scaling.

You can apply a global scale factor to non-ISO linetypes and fill patterns in
plot styles.

See also:

“Work with Linetypes” on page 293
“Control Lineweights” on page 301

To set the plotted lineweight

1 Click File menu ➤ Plot Style Manager.

2 Double-click the plot style table that you want to modify.

3 In the Plot Style Table Editor, Form View tab, select the plot style you
want to change.

4 Click the Lineweight arrow and select a lineweight from the list. To
specify that the object’s lineweight should be used select Use Object
Lineweight.

5 Click Save & Close.

You can edit properties for multiple plot styles while in the Plot Style
Table Editor.

To set the plotted linetype

1 Click File menu ➤ Plot Style Manager.

2 Double-click the plot style table that you want to modify.

3 In the Plot Style Table Editor, Form View tab, select the plot style you
want to change.

4 Click the Linetype arrow and select a linetype from the list. To specify
that the object’s linetype should be used, select Use Object Linetype.

5 To adjust the linetype scale to show the complete pattern, on the Form
View tab, select On in the Adaptive box.

6 Click Save & Close.

You can edit properties for multiple plot styles while in the Plot Style
Table Editor.
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To apply scaling to non-ISO linetypes and fill patterns

1 Click File menu ➤ Plot Style Manager.

2 Double-click the plot style table that you want to modify.

3 In the Plot Style Table Editor, General tab, select Apply Global Scale
Factor to Non-ISO Linetypes.

This option scales linetypes and fill patterns according to a value that
you specify.

4 In the Scale Factor box, enter a scale factor to apply.

5 Click Save & Close.

Assign Plotted Line End and Join Styles

You can set the line end and join styles for objects that have lineweight
assigned, either as an object property or as a plot style override.

Assign Line End Style

The program includes the following line end style options:

■ Butt

■ Square

■ Round

■ Diamond

The default setting for Line End Style is Use Object End Style, which is rounded.
Assign a line end style in a plot style to override the object’s default line end
style at plot time.

NOTE SHX text plots best with the Round End and Round Join styles.

Assign Line Join Style

The program includes the following line join style options:

■ Miter

■ Bevel

■ Round

■ Diamond
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The default setting for Line Join Style is Use Object Join Style, which is
rounded. Assign a line join style in a plot style to override the object’s default
line join style at plot time.

To assign a line end or line join style

1 Click File menu ➤ Plot Style Manager.

2 Right-click a CTB or STB file. Click Open.

3 In the Plot Style Table Editor, Table View tab, click the Line End Style
or Line Join Style field for the plot style you want to change.

4 Select an option from the drop-down list.

Assign Plotted Fill Styles

The program includes the following fill style options when plotting wide
polylines, donuts, objects hatched with a solid fill, and solids:

■ Solid

■ Checkerboard

■ Crosshatch

■ Diamonds

■ Horizontal Bars

■ Slant Left

■ Slant Right

■ Square

■ Dots

■ Vertical Bar

The default setting for Fill Style is Use Object Fill Style. Assign a fill style in a
plot style to override the object’s fill style at plot time.

You can apply a global scale factor to non-ISO linetypes and fill patterns in
plot styles.

See also:

“Choose Hatch Patterns and Solid Fills” on page 686
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To assign a fill style

1 Click File menu ➤ Plot Style Manager.

2 Right-click a CTB or STB file. Click Open.

3 In the Plot Style Table Editor, Table View tab, click the Fill Style field for
the plot style you want to change.

4 Select a fill style from the drop-down list.

Preview a Plot
It is good practice to generate a preview of the plotted drawing before sending
the drawing to the printer or plotter. Generating a preview saves time and
material.

You can preview the drawing from the Plot dialog box. The preview shows
exactly how the drawing will look when plotted, including lineweights, fill
patterns, and other plot style options.

When you preview your drawing, the active toolbars and tool palettes are
hidden and a temporary Preview toolbar is displayed that provides buttons
to plot, pan, and zoom the drawing.
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In the Plot and Page Setup dialog boxes, a thumbnail preview is also displayed,
which shows the printable area and the position of the drawing on the page.

To preview a plot

1 Click File menu ➤ Plot.

2 In the Plot dialog box, click Preview.

A preview window opens, and the cursor changes to the real-time zoom
cursor.

3 Right-click to display a shortcut menu with the following options: Plot,
Pan, Zoom, Zoom Window, or Zoom Original (to zoom to the original
preview magnification).

4 Press  ESC  to exit the preview and return to the Plot dialog box.

5 If necessary, make additional adjustments to the plot settings and preview
the plotted drawing again.

6 Once the settings are correct, click OK to plot the drawing.

Standard toolbar
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Plot Files to Other Formats
You can export or plot your drawings in a number of formats, including DWF,
DXF, and Windows metafile (WMF). You can also output your drawings in
image formats using specially designed plotter drivers.

In each case, a nonsystem plotter driver is configured to output file
information. You can control the custom properties of each nonsystem driver
in the Plotter Configuration Editor. Specific help for each driver is also available
by choosing Help while in the custom Properties dialog box for the individual
driver (accessed through the Plotter Configuration Editor).

See also:

“Publish Drawings” on page 919

Plot DWF Files

You can use the program to create Design Web Format (DWF) files. A DWF
file is a 2D vector file that you can use to publish your drawing on the World
Wide Web or an intranet network. Each DWF file can contain one or more
drawing sheets.

DWF files can be opened, viewed, and plotted by anyone using Autodesk®

DWF™ Composer or Autodesk®  DWF™ Viewer. With Autodesk DWF Composer
or Autodesk DWF Viewer, you can also view DWF files in Microsoft® Internet
Explorer 5.01 or later. DWF files support real-time panning and zooming as
well as control over the display of layers and named views.

See also:

“Publish Drawings” on page 919

To plot a DWF file

1 Click File menu ➤ Plot.

2 In the Plot dialog box, under Printer/Plotter, in the Name box, select the
DWF6 ePlot.pc3 configuration from the Name list.

3 Select plot settings for the DWF file as needed.

4 Click OK
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5 In the Browse for Plot File dialog box, select a location and enter a file
name for the DWF file.

6 Click Save.

Standard toolbar

Plot to DXB File Formats

DXB (drawing interchange binary) file formats are supported using the DXB
nonsystem file driver. This is commonly used to “flatten” 3D drawings to 2D.

The output is compatible with the DXBIN command and with the ADI DXB
driver delivered with earlier releases. The DXB driver shares these limitations
of the ADI driver:

■ The driver produces 16-bit integer DXB files containing only vectors.

■ DXB output is monochrome; all vectors are color 7.

■ Raster images and embedded OLE objects are not supported.

■ The driver ignores object and plot style lineweights.

See also:

“Configure for File Output” in the Driver and Peripheral Guide

To create a DXB file

1 Make sure you have configured a plotter driver for DXB file output. (See
Configure for File Output in the Driver and Peripheral Guide.)

2 Click File menu ➤ Plot.

3 In the Plot dialog box, under Printer/Plotter, in the Name box, select a
DXB format configuration from the list.

4 Select plot settings for the DXB file as needed.

5 Click OK.

6 In the Browse for Plot File dialog box, select a location and enter a file
name for the DXB file.

7 Click Save.
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Standard toolbar

Plot to Raster File Formats

The nonsystem raster driver supports several raster file formats, including
Windows BMP, CALS, TIFF, PNG, TGA, PCX, and JPEG. The raster driver is
most commonly used to plot to files for desktop publishing.

All but one of the formats supported by this driver produce “dimensionless”
raster files that have size in pixels but do not have size in inches or millimeters.
The Dimensional CALS format is for plotters that can accept CALS files. If
your plotter accepts CALS files, you must specify a real paper size and
resolution. Specify the resolution in dots per inch in the Vector Graphics pane
of the Plotter Configuration Editor.

By default, the raster driver plots only to files. However, you can select Show
All Ports on the Ports page of the Add-a-Plotter wizard or the Ports tab in the
Plotter Configuration Editor; all of the ports on your computer are then
available for configuration. When configured for plotting to a port, this driver
plots to a file and then copies that file to the specified port. To plot successfully,
make sure that the device connected to the configured port can accept and
process the file. For more information, refer to the documentation provided
by the device manufacturer.

The type, size, and color depth of the raster file determine the final file size.
Raster files can grow very large. Use only the pixel dimensions and color depth
that you need.

You can configure the background color for raster plots in the custom
Properties dialog box in the Plotter Configuration Editor. If you change the
background color, any objects plotted in that color are invisible.

See also:

“Configure for File Output” in the Driver and Peripheral Guide

To create a raster file

1 Make sure you have configured a plotter driver for raster file output. (See
“Configure for File Output” in the Driver and Peripheral Guide.)

2 Click File menu ➤ Plot.

3 In the Plot dialog box, under Printer/Plotter, in the Name box, select a
raster format configuration from the list.
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4 Select plot settings for the raster file as needed.

5 Click OK.

6 In the Browse for Plot File dialog box, select a location and enter a file
name for the raster file.

7 Click Save.

Standard toolbar

Plot Adobe PostScript Files

Using the Adobe PostScript driver, you can use DWGs with an array of page
layout programs and archive tools such as the Adobe Acrobat Portable
Document Format (PDF).

You can use the nonsystem PostScript driver to plot drawings to PostScript
printers and PostScript files. Use the PS file format for printers and the EPS
file format for files. If you plot to a hardware port, PS output is automatic. If
you plot to a file and plan to copy the file to a printer, configure for PS output.

Use the custom Properties dialog box in the Plotter Configuration Editor to
customize the output. To display this dialog box, on the Device and Document
Settings tab, in the tree view, select Custom Properties. Then under Access
Custom Dialog, click the Custom Properties button.

The PostScript driver supports three types of PostScript.

Level 1: Use for most plotters.

Level 1.5: Use for plotters that support color images.

Level 2: If your plotter supports Level 2 PostScript, use to produce smaller files
that print more rapidly.

The Tokenize PostScript Code and Compression options in the PostScript
Custom Properties dialog box reduce output file size and improve printing
speed on devices that support these options. If you have problems printing,
try clearing all the options. If you successfully print with no optimizations,
you can try turning the options on one at a time to determine the options
your printer supports.

Some desktop publishing applications only support Level 1 PostScript. If you
have problems using your EPS files, try a lower PostScript level and turn off
the optimizations just described.
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Including a preview thumbnail in your EPS file makes the file substantially
larger but allows quick preview by many applications. The WMF preview is
for Windows; the EPSF preview is for Macintosh and other platforms.

NOTE Including both preview images can triple your file size.

See also:

“PostScript Files”
“Configure for File Output” in the Driver and Peripheral Guide

To plot a PostScript file

1 Make sure you have configured a plotter driver for PostScript file output.
(See “Configure for File Output” in the Driver and Peripheral Guide.)

2 Click File menu ➤ Plot.

3 In the Plot dialog box, under Printer/Plotter, in the Name box, select a
PostScript format configuration.

4 Select plot settings for the PostScript file as needed.

5 Click OK.

6 In the Browse for Plot File dialog box, select a location and enter a file
name for the PostScript file.

7 Click Save.

Standard toolbar

Create Plot Files

You can use any plotter configuration to create plot files that can be used with
spooling software or given to service bureaus for output.

For example, HP-GL and HP-GL/2 formats are used as an intermediate format
for illustration and manufacturing applications, for archive purposes, and for
use with a wide range of output devices.

The HP-GL nonsystem driver supports HP-GL (Hewlett-Packard Graphics
Language), a widely used pen plotter language that has vector-only capabilities.
Raster objects are not supported by the HP-GL device driver.

The nonsystem HP-GL/2 driver supports a variety of HP-GL/2 pen plotters
and ink-jet plotters. It is a generic HP-GL/2 driver that is not optimized for
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any particular manufacturer’s devices. For example, it does not send PJL
commands to devices, as a true Hewlett-Packard driver would. The HP-GL/2
driver supports obsolete pen plotters and newer devices made by manufacturers
other than Hewlett-Packard.

See also:

“Set Device-Specific Configurations” in the Driver and Peripheral Guide

To create a plot file

1 Click File menu ➤ Plot.

2 In the Plot dialog box, under Printer/Plotter, in the Name box, select a
plotter configuration.

3 If the Plot to File option is available and is not selected, select it.

4 Select plot settings for the plot file as needed.

5 Click OK.

6 In the Browse for Plot File dialog box, select a location and enter a file
name for the plot file.

7 Click Save.

Standard toolbar

918 | Chapter 34   Plot Drawings



Publish Drawings

 
Publishing provides a streamlined alternative to plotting

multiple drawings. You can easily publish an entire sheet set

from the Sheet Set Manager as a set of paper drawings or as

a single, electronic, multisheet Design Web Format (DWF)

file.

Publishing an electronic drawing set as a DWF file saves time

and increases productivity by providing accurate, compressed

representations of drawings in a file that’s easy to distribute

and view. DWF files can be viewed or plotted by anyone using

a free, downloaded DWF file viewer, Autodesk
®

 DWF™

Viewer.
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Quick Start to Publishing
Sets of drawings are the primary deliverable for most design groups. Creating
a drawing set to distribute for review can be complicated and time consuming.

Using the Publish dialog box, you can easily assemble a collection of drawings
and, with one click, create a paper drawing set or an electronic drawing set.

Electronic drawing sets are saved as Design Web Format™ (DWF™ ) files. You
can view or plot DWF files using a free DWF file viewer, Autodesk® DWF™
Viewer.

To output a single drawing, use the Plot dialog box.

See also:

“Quick Start to Plotting” on page 870

No procedures for this topic.

Overview of Publishing
Publishing provides an easy way to create a paper drawing set or an electronic
drawing set. An electronic drawing set is the digital equivalent of a set of
plotted drawings. You create an electronic drawing set by publishing drawings
to a Design Web Format™ (DWF™ ) file.

You can publish an entire sheet set from the Sheet Set Manager. With one
click, you can create an electronic drawing set by publishing the sheet set to
a single, multisheet DWF file.

You can create a paper drawing set by publishing the sheet set to the plotter
named in each sheet’s page setup.
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Using the Publish dialog box, you can assemble a collection of drawings to
publish and save the list as a Drawing Set Descriptions (DSD) file. You can
customize this collection of drawings for a specific user, and you can add and
remove sheets as a project evolves. Once you’ve created a list of drawing sheets
in the Publish dialog box, you can publish the drawings to any of the
following:

■ The plotter named in each sheet’s page setup (including drawings that you
want to plot to file)

■ A single, multisheet DWF file

■ Multiple single-sheet DWF files

Using 3D DWF Publishing, you can create and publish DWF files of your
three-dimensional models. As a technology preview in AutoCAD® 2006, the
3DDWFPUBLISH command is, by default, installed in all network installations,
and an optional feature in stand-alone installations.

Publishing an electronic drawing set as a DWF file saves time and increases
productivity by providing accurate, compressed representations of drawings
in a file that’s easy to distribute and view. This also maintains the integrity
of your original drawings.

Publishing generates DWF6 files, which are created in a vector-based format
(except for inserted raster image content), ensuring that precision is
maintained. You can view or plot DWF files using a free DWF file viewer,
Autodesk® DWF™ Viewer. DWF files can be distributed using email, FTP sites,
project websites, or CDs.

You can specify which block-related properties and attributes you want to
make available to others who are using the Autodesk DWF Viewer to view or
print your published DWF files. For example, you can publish a DWF file for
a plumbing contractor that contains block attribute information about the
plumbing fixtures specified in your drawing data. And, from the same set of
sheets, you can include only the block attribute data about light fixtures for
an electrical contractor.

By default, jobs that are published are processed in the background, so that
you can return immediately to your drawing. Only one job that you have
published can be processed in the background at a time. While a job is being
processed in the background, you can check its status by placing the cursor
over the plotter icon on the right side of the status bar. You can also view
details about all completed jobs that you have plotted or published from the
current session.

See also:

“Publish, Transmit, and Archive Sheet Sets” on page 253
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“Specify Page Setup Settings” on page 844
“3D DWF Publishing” on page 948

To check the status of a published job that is being processed in the
background

■ Place the cursor over the plotter icon in the status tray. A tooltip displays
the status of the job.

Status tray

To cancel part or all of a published job that is processing in the background

1 Right-click the plotter icon in the status tray. Click Cancel Sheet
<sheetname> or Cancel Entire Job.

Status tray

To view details about jobs you have published

1 Do one of the following:

■ Click File menu ➤ View Plot and Publish Details.

■ In the status tray, left-click the plotter icon.

2 In the Plot and Publish Details dialog box, view details about published
jobs.

In the status tray, right-click the plotter icon. Click View Plot and Publish
Details.

To turn background publishing on or off

1 Click Tools menu ➤ Options.

2 In the Options dialog box, Plot and Publish tab, under Background
Processing Options, select or clear the Enable Background Plot When
Publishing option.

3 Click OK.
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Create and Modify a Drawing Set for
Publishing

You can assemble a collection of drawing sheets to publish to a plotter, plot
files, or a DWF™  file. You can customize your drawing set for a specific user,
and you can add, remove, reorder, copy, and rename sheets in a drawing set
as a project evolves.

You can publish the drawing set directly to paper or to a single DWF file or
multiple DWF files that can be distributed using email, FTP sites, project
websites, or CD. You can save a description of a drawing set that’s been
assembled to publish in a Drawing Set Descriptions (DSD) file.

To create a drawing set for publishing

1 With a drawing open, click File menu ➤ Publish.

The Publish dialog box is displayed. If the Include Layouts When Adding
Sheets option is selected, either in the shortcut menu or in the Publish
dialog box, all the layouts in the current drawing are listed in the
sheetlist.

2 In the Publish dialog box, you can modify the list of sheets by doing
any of the following as needed:

■ Add sheets. To add sheets from other drawings, click the Add Sheets
button (or drag drawings from the desktop). In the Select Drawings
dialog box, select drawings. Click Select to add them to the list of
sheets in the Publish dialog box. All of the layouts in a drawing become
individual sheets in the list of drawing sheets. You must remove those
sheets that you don’t want to become a part of the drawing set. A
layout must be initialized (its paper size must be defined in the page
setup to any size other than 0 x 0) before it can be published.

NOTE To include all layouts when you add sheets to a drawing set, make
sure the Include Layouts When Adding Sheets option is selected on the
shortcut menu or in the Publish dialog box.

■ Include model layouts. If you include an uninitialized (the paper
size is not defined in the page setup or is set to 0 x 0) model layout,
it will be marked as Uninitialized in the Status column on the sheet
list. It can be plotted if you select an override page setup for it in the
Publish dialog box from the page setup drop-down list under Page
Setups in the sheet list.
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NOTE To include the model when you add sheets to a drawing set, make
sure the Include Model When Adding Sheets option is selected either on the
shortcut menu or in the Publish dialog box.

■ Remove sheets. To remove sheets from the list, select one or more
sheets in the list. Click the Remove Sheets button. To remove all
sheets, right-click. Click Remove All.

■ Reorder sheets. To reorder the sheets up or down one position in
the list, select a sheet. Click either the Move Sheet Up or Move Sheet
Down button. Sheets in the drawing set are viewed or plotted in the
order shown in the list.

■ Rename sheets. To rename a sheet, select it in the list and right-click.
Click Rename Sheet. Enter the new sheet name.

■ Change page setups. To change the page setup for a layout, select
the sheet, and in the Page Setup list select a named page setup from
the list; or select one or more sheets and right-click. Click Change
Page Setup. In the Page Setup list, select a page setup, or select Import
to import page setups from another drawing or template. In the Import
Page Setups dialog box, select a drawing with one or more page setups.
Click Import. In the Page Setup list, select a named page setup.

NOTE It is important that you change the page setup for each layout
depending on your desired output. Only model space page setups can be
applied to model space sheets, and only paper space page setups can be
applied to paper space sheets.

■ Copy sheets. To copy one or more drawing sheets, select the sheets
in the list and right-click. Click Copy Selected Sheets. The copied
drawing sheets are added and highlighted at the end of the sheet list.
When a sheet is copied, its name is created by the addition of -Copy(n)
at the end of the original sheet name. For example, if you create one
copy of a sheet called Plumbing, the copied sheet is called
Plumbing-Copy(1). Each time you copy the same sheet, the n is
incremented by 1. By creating copies of a sheet, you can have different
page setups and other settings for the same sheet.

3 When your list of drawing sheets is assembled and configured the way
you want for your drawing set, click the Save List button.

4 In the Save List As dialog box, in the File Name box, enter a name for
the list. Click Save.

The drawing set list is saved as a DSD (Drawing Set Descriptions) file.
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Standard toolbar

To add sheets from a drawing to a drawing set for publishing

1 Click File menu ➤ Publish.

2 In the Publish dialog box, click the Add Sheets button.

3 In the Select Drawings dialog box, select drawings. Click Select to add
them to the list of sheets in the Publish dialog box.

NOTE You can also drag drawings from the desktop into the Publish dialog
box to add sheets to the list.

All of the layouts in a drawing become individual sheets in the list of
drawing sheets.

You must remove the drawing sheets that you don’t want to become a
part of the drawing set. Layouts must be initialized before they can be
published. (A layout is initialized if its paper size is defined in the page
setup to any size other than 0 x 0.)

Standard toolbar

To add sheets from a DSD file to a drawing set for publishing

1 Click File menu ➤ Publish.

2 In the Publish dialog box, click the Load Sheet List button.

3 In the Load List of Sheets dialog box, select a DSD file. Click Load.

4 In the Replace or Append dialog box, click Replace to replace the current
sheets with the sheets in the DSD file, or click Append to add the sheets
in the DSD file to the list of sheets in the Publish dialog box.

Standard toolbar
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To remove a sheet from a drawing set for publishing

1 Click File menu ➤ Publish.

2 In the Publish dialog box, make sure the sheets that you want to remove
are listed.

3 Under Sheets, select one or more sheets to remove. Click the Remove
Sheets button.

Standard toolbar

To remove all sheets from a drawing set for publishing

1 Click File menu ➤ Publish.

2 In the Publish dialog box, make sure the sheets that you want to remove
are listed.

3 In the Sheet List area, right-click. Click Remove All.

NOTE Removing all sheets cannot be undone.

Standard toolbar

To reorder sheets in a drawing set for publishing

1 Click File menu ➤ Publish.

2 In the Publish dialog box, make sure the sheets that you want to reorder
are listed.

3 Select a sheet. Click either the Move Sheet Up or Move Sheet Down
button.

NOTE Sheets in the drawing set are viewed or plotted in the order shown
in the Publish dialog box.

Standard toolbar
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To copy sheets in a drawing set for publishing

1 Click File menu ➤ Publish.

2 In the Publish dialog box, make sure the sheets that you want to copy
are listed.

3 Select one or more sheets in the Sheets list and right-click. Click Copy
Selected Sheets.

The copied drawing sheets are added and highlighted at the end of the
sheet list. When a sheet is copied, its name is created by the addition of
-copy(n) at the end of the original sheet name. For example, if you create
one copy of a sheet called Plumbing, the copied sheet is called
Plumbing-Copy(1). Each time you copy the same sheet, the n is
incremented by 1. By creating copies of a sheet, you can have different
page setups and other settings for the same sheet.

Standard toolbar

To rename sheets in a drawing set for publishing

1 Click File menu ➤ Publish.

2 In the Publish dialog box, make sure the sheets that you want to rename
are listed.

3 Select a sheet in the Sheet list, and then do one of the following:

■ Right-click. Click Rename Sheet.

■ Press F2.

4 Enter the new sheet name.

Standard toolbar
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To change the page setup of one sheet in a drawing set for publishing

1 Click File menu ➤ Publish.

2 In the Publish dialog box, make sure the sheet for which you want to
change the page setup is listed.

3 Select a sheet in the Sheet list.

4 Under Page Setup, select a page setup to apply to the drawing sheet.

Standard toolbar

To change the page setup of one or more sheets in a drawing set for
publishing

1 Click File menu ➤ Publish.

2 In the Publish dialog box, make sure the sheets for which you want to
change the page setups are listed.

3 Select one or more sheets in the list and right-click. Click Change Page
Setup.

4 In the Page Setup list, select a page setup to apply to the drawing sheets.

NOTE It is important that you change the page setup for each layout
depending on your desired output. Only model space page setups can be
applied to model space sheets, and only paper space page setups can be
applied to paper space sheets.

Standard toolbar

To import a page setup from another drawing to apply to a drawing sheet
for publishing

1 Click File menu ➤ Publish.

2 In the Publish dialog box, make sure the sheet for which you want to
change the page setup is listed.

3 Select a sheet in the Sheet list.
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4 Under Page Setup, select Import from the list.

5 In the Import Page Setups dialog box, select the drawing whose page
setups you want to import. Click Import.

Standard toolbar

To publish multiple layouts in a drawing

1 In the drawing area, click a layout tab that you want to publish.

2 Press and hold the CTRL key, and then click the other layout tabs that
you want to publish.

3 Right-click one of the selected layout tabs. Click Publish Selected Layouts.

4 In the Publish dialog box, change any settings for the selected layouts.

5 Click Publish.

Create a Paper or Plot File Drawing Set
You can publish a drawing set to a plotter or plot file.

You can assemble drawing sheets into a customized drawing set and publish
the sheets to the plotter named in the page setup specified for each sheet. If
the plot device named in the page setup is a paper plotter, then your output
will be a paper drawing set.

If the plotter is configured to plot to a file, the sheets are saved to files in the
plot file location specified in the Publish Options dialog box. Each drawing
sheet’s plot file is saved with the same name as the sheet, with the appropriate
file extension for the file (for example, .plt, .jpg, or .bmp). The default location
can be changed in the Options dialog box, Plot and Publish tab, under Plot
to File.

See also:

“Set Publish Options” on page 940

To create and publish a paper or plot file drawing set

1 With a drawing open, click File menu ➤ Publish.

Create a Paper or Plot File Drawing Set | 929



2 In the Publish dialog box, the drawing layouts are shown in the Sheets
List. To create the drawing set, modify the list of drawing sheets by doing
any of the following as needed:

■ Add sheets. To add sheets from other drawings, click the Add Sheets
button (or drag drawings from the desktop). In the Select Drawings
dialog box, select drawings. Click Select to add them to the list of
sheets in the Publish dialog box. All of the layouts in a drawing become
individual sheets in the list of drawing sheets. You must remove those
that you don’t want to become a part of the drawing set. A layout
must be initialized (its paper size must be defined in the page setup
to any size other than 0 x 0) before it can be published.

NOTE To include all layouts when you add sheets to a drawing set, make
sure the Include Layouts When Adding Sheets option is selected on the
shortcut menu or in the Publish dialog box.

■ Include model layouts. If an uninitialized (the paper size is not
defined in the page setup or is set to 0 x 0) model layout is included,
it will be marked as Uninitialized in the Status column on the sheet
list. It can be plotted if a page setup override is applied.

NOTE To include the Model when you add sheets to a drawing set, make
sure the Include Model When Adding Sheets option on the shortcut menu
is selected.

■ Remove sheets. To remove sheets from the list, select one or more
sheets in the list. Click the Remove Sheets button. To remove all
sheets, right-click. Click Remove All.

■ Reorder sheets. To reorder the sheets up or down one position in
the list, select a sheet. Click either the Move Sheet Up or Move Sheet
Down button. Sheets in the drawing set are viewed or plotted in the
order shown in the list.

■ Rename sheets. To rename a sheet, select it in the list and right-click,
Click Rename Sheet. Enter the new sheet name.

■ Change page setups. To change the page setup for a layout, select
the sheet. In the Page Setup list, select a named page setup from the
list, or select one or more sheets in the list and right-click. Click
Change Page Setup. In the Page Setup list, select a page setup or select
Import to import page setups from another drawing or template. In
the Import Page Setups dialog box, select a drawing with one or more
page setups. Click Import. In the Page Setup list, select a named page
setup.
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NOTE It is important that you change the page setup for each layout
depending on your desired output. Only model space page setups can be
applied to model space sheets, and only paper space page setups can be
applied to paper space sheets.

■ Copy sheets. To copy one or more drawing sheets, select the sheets
in the list and right-click. Click Copy Selected Sheets. The copied
drawing sheets are added and highlighted at the end of the sheet list.
When a sheet is copied, its name is created by the addition of -Copy(n)
at the end of the original sheet name. For example, if you create one
copy of a sheet called Plumbing, the copied sheet is called
Plumbing-Copy(1). Each time you copy the same sheet, the n is
incremented by 1. By creating copies of a sheet, you can have different
page setups and other settings for the same sheet.

3 When your list of drawing sheets is assembled and configured the way
you want for your paper or plot file drawing set, click the Save Sheet List
button.

4 In the Save List As dialog box, in the File Name box, enter a name for
the drawing set list. Click Save.

The drawing set list is saved as a DSD (Drawing Set Descriptions) file.

5 In the Publish dialog box, under Publish To, select Plotter Named in
Page Setup.

6 Click Publish to start the process.

If you have background publishing enabled, the animated plotter icon
on the right side of the status bar indicates that the publish job is in
progress: paper drawings are being plotted or plot files are being created.

7 To view information about the processed publish job, right-click the
plotter icon on the right side of the status bar. Click View Plot and
Publish Details.

Standard toolbar

Publish an Electronic Drawing Set
You can publish an electronic drawing set in the Design Web Format.

You can assemble drawing sheets into a customized electronic drawing set.
An electronic drawing set is the digital equivalent of a set of plotted drawings.
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An electronic drawing set is saved as a single, multisheet DWF file and can be
shared with customers, suppliers, or people within your own company who
may need the drawings for examination or for their records.

You can also send the published electronic drawing set as an email attachment,
share it using a project collaboration site such as Autodesk® Buzzsaw®, or post
it to a website. Using Autodesk DWF Viewer, you can view or plot only the
layouts you need.

You can also publish the drawing set as individual, single-sheet DWF files for
each sheet.

When you publish to a DWF file, you use the DWF6 ePlot.pc3 plotter
configuration file. You can use the default DWF6 ePlot.pc3 plotter driver as
installed, or you can modify configuration settings such as color depth, display
resolution, file compression, font handling, and other options. Once you
modify the DWF6 ePlot.pc3 file, all future plotting and publishing of DWF
files will be affected.

WARNING Before you make changes to the original DWF6 ePlot.pc3 file, make
sure you have backed up a copy in case you want to return to the default settings.

See also:

“Set Publish Options” on page 940

To create an electronic drawing set

1 With a drawing open, click File menu ➤ Publish.

The Publish dialog box is displayed. If the Include Layouts When Adding
Sheets option is selected either in the shortcut menu or in the Publish
dialog box, all the layouts in the current drawing are listed in the sheet
list.

2 In the Publish dialog box, you can modify the list of sheets by doing
any of the following as needed:

■ Add sheets. To add sheets from other drawings, click the Add Sheets
button (or drag drawings from the desktop). In the Select Drawings
dialog box, select drawings. Click Select to add them to the list of
sheets in the Publish dialog box. All of the layouts in a drawing become
individual sheets in the list of drawing sheets. You must remove those
sheets that you don’t want to become a part of the drawing set. A
layout must be initialized (its paper size must be defined in the page
setup to any size other than 0 x 0) before it can be published.

932 | Chapter 35   Publish Drawings



NOTE To include all layouts when you add sheets to a drawing set, make
sure the Include Layouts When Adding Sheets option is selected on the
shortcut menu or in the Publish dialog box.

■ Include model layouts. If you include an uninitialized (the paper
size is not defined in the page setup or is set to 0 x 0) model layout,
it will be marked as Uninitialized in the Status column on the sheet
list. It can be plotted if you select an override page setup for it in the
Publish dialog box from the page setup drop-down list under Page
Setups in the sheet list.

NOTE To include the model when you add sheets to a drawing set, make
sure the Include Model When Adding Sheets option is selected either on the
shortcut menu or in the Publish dialog box.

■ Remove sheets. To remove sheets from the list, select one or more
sheets, and then click the Remove Sheets button. To remove all sheets,
right-click. Click Remove All.

■ Reorder sheets. To reorder the sheets up or down one position in
the list, select a sheet. Click either the Move Sheet Up or Move Sheet
Down button. Sheets in the drawing set are viewed or plotted in the
order shown in the list.

■ Rename sheets. To rename a sheet, select it in the list and right-click.
Click Rename Sheet. Enter the new sheet name.

■ Change page setups. To change the page setup for a layout, select
the sheet, and in the Page Setup list select a named page setup from
the list; or select one or more sheets and right-click. Click Change
Page Setup. In the Page Setup list, select a page setup, or select Import
to import page setups from another drawing or template. In the Import
Page Setups dialog box, select a drawing with one or more page setups.
Click Import. In the Page Setup list, select a named page setup.

NOTE It is important that you change the page setup for each layout
depending on your desired output. Only model space page setups can be
applied to model space sheets, and only paper space page setups can be
applied to paper space sheets.

■ Copy sheets. To copy one or more drawing sheets, select the sheets
in the list and right-click. Click Copy Selected Sheets. The copied
drawing sheets are added and highlighted at the end of the sheet list.
When a sheet is copied, its name is created by the addition of -Copy(n)
at the end of the original sheet name. For example, if you create one
copy of a sheet called Plumbing, the copied sheet is called
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Plumbing-Copy(1). Each time you copy the same sheet, the n is
incremented by 1. By creating copies of a sheet, you can have different
page setups and other settings for the same sheet.

3 When your list of drawing sheets is assembled and configured the way
you want for your drawing set, click the Save List button.

4 In the Save List As dialog box, in the File Name box, enter a name for
the list. Click Save.

The drawing set list is saved as a DSD (Drawing Set Descriptions) file.

5 In the Publish dialog box, under Publish To, select DWF File.

6 In the Select DWF File dialog box, enter a file name. Click Select to
provide the name and destination for the DWF file.

NOTE You can also enter a URL so that the DWF file is uploaded to an FTP
or HTTP site.

7 Click Publish to start the electronic drawing set creation.

If you have background publishing enabled, the animated plotter icon
on the right side of the status bar indicates that the publish job is in
progress.

8 To view information about the processed publish job, right-click the
plotter icon on the right side of the status bar. Click View Plot and
Publish Details.

The information in the Plot and Publish Details dialog box is also saved
to the plot and Publish log file.

9 If you have background publishing enabled you can view the published
DWF file. Right-click the plotter icon on the right side of the status. Click
View DWF File.

Standard toolbar

Publish a Sheet Set
From the Sheet Set Manager, you can easily publish an entire sheet set, a subset
of a sheet set, or a single sheet. If you want to publish a sheet set that you’ve
set up in the Sheet Set Manager, it’s much quicker to publish the sheet set
directly from the Sheet Set Manager, rather than starting from the Publish
dialog box.

934 | Chapter 35   Publish Drawings



When you publish from the Sheet Set Manager, you can publish an electronic
sheet set by publishing to a DWF file, or you can publish a paper set by
publishing to the plotter named in the page setup that is associated with each
drawing sheet. You can also publish your sheets using a page setup that is
saved in the page setup overrides DWT file associated with the sheet set. This
page setup overrides the current page setup settings for the individual publish
job.

When you open the Publish dialog box from the Sheet Set Manager, the Publish
dialog box automatically lists the sheets you selected in the sheet set. You can
then modify the sheet set for publishing.

See also:

“Use Named Page Setups with Sheet Sets” on page 867
“Work with Sheets in a Sheet Set” on page 233
“Set Publish Options” on page 940

To publish a sheet set to a DWF file

1 In the Sheet Set Manager, under Sheets, select the Sheet Set node or
name.

2 In the upper-right corner of the Sheet Set Manager, click the Publish to
DWF button.

NOTE If you have background publishing enabled, the animated plotter
icon on the right side of the status bar indicates that the publish job is in
progress. Right-click this icon for options to view the DWF file or to view
information about the publish job.

Standard toolbar

Right-click a sheet set node or name. Click Publish ➤ Publish to DWF.

To publish a subset of a sheet set or an individual sheet to a DWF file

1 In the Sheet Set Manager, under Sheets, select the node or name of a
subset or an individual sheet.

2 In the upper-right corner of the Sheet Set Manager, click the Publish to
DWF button.
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NOTE If you have background publishing enabled, the animated plotter
icon on the right side of the status bar indicates that the publish job is in
progress. Right-click this icon for options to view the DWF file or to view
information about the publish job.

Standard toolbar

Right-click the node or name of a subset or an individual sheet. Click Publish
➤ Publish to DWF.

To publish sheets in a sheet set to the plotter named in the sheet’s page setup

1 In the Sheet Set Manager, under Sheets, select the node or name of a
sheet set, a subset, or an individual sheet.

2 In the upper-right corner of the Sheet Set Manager, click the Publish
button. Click Publish to Plotter.

NOTE If you have background publishing enabled, the animated plotter
icon on the right side of the status bar indicates that the publish job is in
progress. Right-click this icon for options to view the DWF file or to view
information about the publish job.

Standard toolbar

Right-click the node or name of a sheet set, subset, or an individual sheet.
Click Publish ➤ Publish to Plotter.

To publish sheets in a sheet set using a page setup from the page setup
overrides file

1 In the Sheet Set Manager, under Sheets, select the node or name of a
sheet set, subset, or an individual sheet.

936 | Chapter 35   Publish Drawings



2 In the upper-right corner of the Sheet Set Manager, click the Publish
button. Click Publish Using Page Setup Override ➤ <filename.dwt>. (All
the named page setups that are saved in the page setup override DWT
file are listed.)

The settings in the selected page setup override file take precedence over
(override) the page setup settings currently set for the selected sheets.
The page setup override settings apply only for this individual publish
job.

NOTE If you have background publishing enabled, the animated plotter
icon on the right side of the status bar indicates that the publish job is in
progress. Right-click this icon for options to view the DWF file or to view
information about the publish job.

Standard toolbar

Right-click the node or name of a sheet set, subset, or an individual sheet.
Click Publish ➤ Publish Using Page Setup Override ➤ <filename.dwt>.

To include a plot stamp on published sheets from a sheet set

■ In the upper-right corner of the Sheet Set Manager, click the Publish button.
Click Include Plot Stamp.

A plot stamp will be included on all published sheets.

NOTE To change the plot stamp settings, click the Publish button. Click Plot
Stamp Settings.

Standard toolbar

Right-click the node or name of a sheet set, subset, or an individual sheet.
Click Publish ➤ Include Plot Stamp.
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To set options for publishing sheet sets

1 In the upper-right corner of the Sheet Set Manager, click the Publish
button. Click Sheet Set Publish Options.

2 In the Sheet Set Publish Options dialog box, modify the settings as
required.

3 Click OK.

Standard toolbar

Right-click the node or name of a sheet set, subset, or an individual sheet.
Click Publish ➤ Sheet Set Publish Options.

To open the Publish dialog box from the Sheet Set Manager and modify the
sheet set for publishing

1 In the Sheet Set Manager, under Sheets, select the node or name of a
sheet set, subset, or an individual sheet.

2 In the upper-right corner of the Sheet Set Manager, click the Publish
button. Click Publish Dialog Box.

The Publish dialog box is displayed and lists the sheets you selected in
the Sheet Set Manager.

3 In the Publish dialog box, modify the sheet list and settings as required.

4 Click Publish to publish the modified sheet set.

NOTE If you have background publishing enabled, the animated plotter
icon on the right side of the status bar indicates that the publish job is in
progress. Right-click this icon for options to view the DWF file or to view
information about the publish job.

Standard toolbar
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Right-click the node or name of a sheet set, subset, or an individual sheet.
Click Publish ➤ Publish Dialog Box.

Republish a Drawing Set
After drawings have been updated, you may want to republish a drawing set
for viewing or plotting. You can easily republish a sheet set (DST file) or a
collection of drawing sheets that you've saved a description of as a DSD
(Drawing Set Descriptions) file. You can also load and republish BP3 (Batch
Plot) files.

To republish a drawing set

1 Click File menu ➤ Publish.

If you have a drawing open, all the layouts in your drawing are shown
in the sheet list in the Publish dialog box. Right-click in the sheet list.
Click Remove All to delete the layouts from the list of drawing sheets.

2 In the Publish dialog box, click the Load Sheet List button.

3 In the Load List of Sheets dialog box, select the location of the DSD file
or the BP3 file. Click Load.

The drawing sheets in the saved drawing set are displayed in the sheet
list in the Publish dialog box.

4 In the Publish dialog box, do one of the following:

■ If you want to publish the drawing set to a DWF file, under Publish
To, select DWF file.

■ If you want to publish the drawing set to a plotter or printer, under
Publish To, select Plotter Named in Page Setup.

5 Click Publish.

If you have background publishing enabled, the animated plotter icon
on the right side of the status bar indicates that the publish job is in
progress.

6 If you have background publishing enabled, you can view information
about the processed publish job. Right-click the plotter icon on the right
side of the status bar. Click View Plot and Publish Details. The
information in the Plot and Publish Details dialog box is also saved to
the plot and publish log file.

Standard toolbar

Republish a Drawing Set | 939



View a Published Electronic Drawing Set
A published electronic drawing set can be viewed and plotted with Autodesk™
DWF™ Viewer.

A published drawing set is the digital equivalent of paper plots created from
your original drawings. The drawing set, which is saved as a Design Web
Format™ (DWF™ ) file, can be viewed or plotted by anyone using Autodesk
DWF Viewer. With Autodesk DWF Viewer, you can open, view, and print all
DWF file formats and other raster format images. You can pan, zoom, and
view individual drawing sheets and viewports. You can also view layer
information, sheet and sheet set properties, block information and attributes,
and custom properties, if they are included in the DWF file. As you move your
cursor across DWF geometry in the viewer, objects with associated data are
displayed with a red highlighting effect.

Recipients of drawing sets in DWF format don't have to own or know the
program. From anywhere in the world, they can view and print high-quality
layouts using Autodesk DWF Viewer.

Autodesk DWF Viewer runs as a stand-alone application or embedded in any
application that supports ActiveX controls, such as Microsoft® Internet
Explorer.

For more information about using Autodesk DWF Viewer, see Help in Autodesk
DWF Viewer.

To view the most recently published DWF file in Autodesk DWF Viewer

■ In the program, right-click the plotter icon on the right side of the status
bar. Click View DWF file.

NOTE This option is available only if you have background publishing enabled.

Set Publish Options
You can set options for publishing, such as output file location, DWF type,
multisheet DWF name options, DWF security (password protection), and
whether or not to include layer information. You can also decide what types
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of information to reveal in your published DWF files. You can include the
following types of metadata:

■ Sheet set properties (must publish using the Sheet Set Manager)

■ Sheet properties (must publish using the Sheet Set Manager)

■ Block standard properties and block custom properties and attributes

■ Properties contained in custom objects

You use a block template (BLK) file to determine which blocks and properties
to include in your published DWF file. You use the Block Template dialog box
to create or modify the settings of a block template (BLK) file. You can also
use BLK files created with the Attribute Extraction wizard.

When you change settings in the Publish Options dialog box, you can save
the settings to the Drawing Set Descriptions (DSD) file to reuse the next time
you publish drawings. You can also save them to just the DSD file.

To change the default output location for published DWF and plot files

1 Click File menu ➤ Publish.

2 In the Publish dialog box, under Publish To, click either Plotter Named
in Page Setup or DWF File, and then click Publish Options.

3 In the Publish Options dialog box, under Default Output Location (DWF
and Plot-to-File), do one of the following:

■ Click Location and make a selection from the drop-down list.

■ Click the [...] button, and in the Select a Folder for Generated Files
dialog box, select a folder. Click Select.

4 In the Publish Options dialog box, click OK.

Standard toolbar

To specify the DWF file output type to single-sheet DWF files or a single
multi-sheet DWF file

1 Click File menu ➤ Publish

2 In the Publish dialog box, under Publish To, select the DWF File, and
then click Publish Options.

Set Publish Options | 941



3 In the Publish Options dialog box, under General DWF Options, DWF
Type, make a selection from the drop-down list as follows:

■ Single-sheet DWF. Specifies that an individual single-sheet DWF
file is created for each sheet.

■ Multi-sheet DWF. Specifies that one multi-sheet DWF file is created.

4 Click OK.

5 In the Publish dialog box, either continue with publishing tasks or close
the dialog box.

Standard toolbar

To specify a name for multi-sheet DWF files

1 Click File menu ➤ Publish

2 In the Publish dialog box, under Publish To, click DWF File, and then
click Publish Options.

3 In the Publish Options dialog box, under General DWF Options, DWF
Type, select Multi-sheet DWF from the drop-down list.

4 In the Publish Options dialog box, under Multi-sheet DWF Options,
DWF Naming, select Specify Name from the drop-down list.

5 Click OK.

6 In the Publish dialog box, either continue with publishing tasks or close
the dialog box.

Standard toolbar

To specify to be prompted for a name for a multi-sheet DWF file

1 Click File menu ➤ Publish

2 In the Publish dialog box, under Publish To, click DWF File, and then
click Publish Options.

3 In the Publish Options dialog box, under General DWF Options, DWF
Type, select Multi-sheet DWF from the drop-down list.
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4 In the Publish Options dialog box, under Multi-sheet DWF Options,
select Prompt for Name to be prompted for a file name every time you
publish a DWF file.

5 Click OK.

6 In the Publish dialog box, either continue with publishing tasks or close
the dialog box.

Standard toolbar

To specify that DWF files are published with password security

1 Click File menu ➤ Publish.

2 In the Publish dialog box, under Publish To, click DWF File, and then
click Publish Options.

3 In the Publish Options dialog box, under General DWF Options, Password
Protection, select one of the following from the drop-down list:

■ Select Specify Password, and under Password, enter a password to use
for the DWF file.

■ Select Prompt for Password. You will be prompted for a password or
phrase to open the published DWF file.

DWF passwords are case-sensitive. The password or phrase can consist
of letters, numbers, punctuation marks, or non-ASCII characters.

WARNING If you lose or forget the password, it cannot be recovered. Keep
a list of passwords and their corresponding DWF file names in a safe place.

4 Click OK.

5 In the Publish dialog box, either continue with publishing tasks or close
the dialog box.

Standard toolbar

To include layer information in a published DWF file

1 Click File menu ➤ Publish.
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2 In the Publish dialog box, under Publish To, click DWF File, and then
click Publish Options.

3 In the Publish Options dialog box, under DWF Data Options, Layer
Information, click to display the drop-down list, and select Include.

NOTE By default, Layer Information is set to Don’t Include, to reduce
publishing time. If you change the setting to include layer information, you
can turn individual layers on and off when you view or print the DWF file.

4 Click OK.

5 In the Publish dialog box, either continue with publishing tasks or close
the dialog box.

Standard toolbar

To include block information in a published DWF file

1 Click File menu ➤ Publish.

2 In the Publish dialog box, under Publish To, click DWF File, and then
click Publish Options.

3 In the Publish Options dialog box, under DWF Data Options, Block
Information, click to display the drop-down list, and select Include.

NOTE By default, Block Information is set to Don’t Include. If you change
the setting to include block information, you can use the viewer to view or
print block property and attribute information in the DWF file.

4 Click OK.

5 In the Publish dialog box, either continue with publishing tasks or close
the dialog box.

Standard toolbar
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To include block template information in a published DWF file

NOTE You can use block template (BLK) files created with the Publish Options
dialog box or BLK files created using the Attribute Extraction wizard.

1 Click File menu ➤ Publish.

2 In the Publish dialog box, under Publish To, click DWF File. Click Publish
Options.

3 In the Publish Options dialog box, under DWF Data Options, Block
Information, click to display the drop-down list. Select Include.

4 In the Publish Options dialog box, under DWF Data Options, Block
Template File, click to display the drop-down list. Select the block
template (BLK) file that contains the properties and attribute definitions
you want to make available in your published DWF file. Click OK.

NOTE The list also contains the Create and Edit options. Create opens the
Publish Block Template dialog box where you can create a new block
template file. Edit opens the Edit Publish Template dialog box where you
can select an existing block template file to modify.

5 Click OK.

6 In the Publish dialog box, either continue with publishing tasks or close
the dialog box.

Standard toolbar

To create a block template (BLK) file

1 Click File menu ➤ Publish.

2 In the Publish dialog box, under Publish To, click DWF File, and then
click Publish Options.

3 In the Publish Options dialog box, under DWF Data Options, Block
Information, click to display the drop-down list, and select Include.

4 Under DWF Data Options, Block Template File, click to display the
drop-down list, and select Create.

The Publish Block Template dialog box opens with the Block Source
Drawing area displaying the current drawing.
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NOTE The working set of drawings for this list is completely independent
of the drawings to include in the Publish operation.

5 Do one of the following:

■ If this drawing contains the block properties you want to include in
the published DWF file, click Scan for Blocks.

The program scans the DWG file for all unique block definitions and
their associated properties and attributes.

■ If this drawing does not contain the block properties you want to
include in the published DWF file, click Add.

The Select Drawings dialog box is displayed. Select drawings to add
to the block source drawings list. You can also add and remove
drawings that contain target blocks whose properties you want to
include in the published DWF file. Click Scan for Blocks.

The DWG file is scanned for all unique block definitions and their
associated properties and attributes.

NOTE By default, block settings for nested blocks and blocks in xrefs are
included. If you don’t want to include these block settings, click Options
in the Publish Block Template dialog box and clear the related options.

6 In the Publish Block Template dialog box, under Block Data to Publish,
Unique Blocks From Source Drawings, Check Blocks to Publish, select
the block names you want to include in the published DWF files. You
can right-click to select or clear all boxes.

7 Under Block Data to Publish, Properties of Selected Blocks, Check
Properties to Publish, select the properties you would like to include in
your published DWF files. You can right-click to select or clear all boxes.

The list displays the union of the properties of all selected blocks.

NOTE If you select a block on the block list and clear the check marks of all
its properties, only the name of the block is published to the resultant DWF
file; no property information is included.

8 Click Save to name and save the block template file. Click OK.

The new block template file is now available under DWF Data Options
in the Publish Block Template dialog box.

9 In the Publish dialog box, either continue with publishing tasks or close
the dialog box.

Standard toolbar
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To edit a block template (BLK) file

1 Click File menu ➤ Publish.

2 In the Publish dialog box, under Publish To, click DWF File, and then
click Publish Options.

3 In the Publish Options dialog box, under DWF Data Options, Block
Information, click to display the drop-down list, and select Include.

4 Under DWF Data Options, Block Template File, click to display the
drop-down list, and select Edit.

5 In the Select Block Template dialog box, click the Block Template (BLK)
file you want to edit, and then click Select.

NOTE The working set of drawings for this list is completely independent
of the drawings to include in the Publish operation.

6 In the Publish Block Template dialog box, click Scan for Blocks.

The program scans the DWG files for all unique block definitions and
their associated properties and attributes.

NOTE By default, block settings for nested blocks and blocks in xrefs are
included. If you don’t want to include these block settings, click Options in
the Publish Block Template dialog box and clear the related options.

7 Under Block Data to Publish, Unique Blocks From Source Drawings,
Check Blocks to Publish, select or clear the block names you want to
include in the published DWF files.

8 Under Block Data to Publish, Properties of Selected Blocks, Check
Properties to Publish, select or clear the properties you want to include
in your published DWF files.

This list displays the union of the properties of all selected blocks.

NOTE If you select a block from the block list and clear the check marks of
all its properties, only the name of the block is published to the resultant
DWF file; no property information is included.

9 Click Save. Click OK.

The modified block template file is now available under DWF Data
Options in the Publish Block Template dialog box.
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10 In the Publish dialog box, either continue with publishing tasks or close
the dialog box.

Standard toolbar

3D DWF Publishing
Using 3D DWF Publishing, you can create and publish Design Web Format™

(DWF™ ) files of your three-dimensional models. As a technology preview in
AutoCAD® 2006, the 3DDWFPUBLISH command is a default feature in all
network installations and an optional feature in stand-alone installations.

With 3D DWF Publishing, you can generate DWF files of your
three-dimensional models with nearly the same visual fidelity as your original
DWG files. 3D DWF Publishing creates a single-sheet DWF file which contains
just model space objects. Access to the 3D DWF Publishing feature is limited
to command line interaction. As a technology preview, there are some known
limitations. Please refer to the Readme file.

Recipients of 3D DWF files can view and print them using Autodesk® DWF™
Viewer. For more information about using Autodesk DWF Viewer, see the
Autodesk DWF Viewer Help system.

Increase the Smoothness of 3D DWF Models

The smoothness of 3D DWF models can be increased by changing the value
of the FACETRES system variable. For 3DDWFPUBLISH, two special settings
of FACETRES, 9 and 10, increase smoothing. These values multiply the effect
of FACETRES.

NOTE Higher values of FACETRES may increase 3D DWF file sizes.

To publish a 3D DWF file

NOTE The 3DDWFPUBLISH command is available only if you have installed the
3D DWF Publishing feature.

1 On the command line, enter 3ddwfpublish .

2 In the 3D DWF Publish dialog box, under DWF File Name, change the
name and location of the DWF file to be saved, or use the [...] button to
navigate to a new location for the 3D DWF file.
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3 Under Objects to Publish, click one of the following:

■ All Model Space Objects. All model space objects are published to
the 3D DWF file.

■ Selected Model Space Objects. You are prompted to create a
selection set of model space objects which are published to the 3D
DWF file.

4 If your drawing contains xrefs, the Group By Xref Hierarchy option is
selected by default. Clear the check box if you do not want to display
the objects grouped by xref hierarchy in the published DWF file.

5 Under Group Individual Objects By, select one of the following options
to group individual objects in the DWF file for viewing. Click OK.

■ Layer. Groups individual objects by layer.

■ Object Type. Groups individual objects by object type (for example,
by block).

6 (Optional) Click Yes to open the Autodesk DWF Viewer and view the
published 3D DWF file.

To install the 3D DWF Publishing feature

■ In Windows Control Panel, double-click Add or Remove Programs.

■ In the Add or Remove Programs dialog box, select AutoCAD 2006. Click
Change.

■ In the AutoCAD 2006 Setup dialog box, click Add or Remove Features. Click
Next.

■ On the Please Select Which Features You Would Like to Install page, click
the red X next to 3D DWF Publish. Select Entire Feature Will Be Installed
on Local Hard Drive.

■ On the Install Optional Tools page, the Install 3D DWF Publish option is
selected. Click Next.

■ On the Start Installation page, click Next to start the installation.

■ On the AutoCAD 2006 Has Been Successfully Installed page, click Finish.
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To view and print a published 3D DWF file

■ If you want to view a 3D DWF file, do one of the following:

■ Immediately after the 3D DWF file has been published, click Yes to the
question "Would you like to view it now?" The Autodesk DWF Viewer
opens the 3D DWF file.

■ In Windows Explorer, double-click the 3D DWF file to open the Autodesk
DWF Viewer and view the file.

■ Open the Autodesk DWF Viewer. Click File menu ➤  Open. Select the
3D DWF file you want to view.

■ If you want to print a 3D DWF file, in Autodesk DWF Viewer, click File
menu ➤ Print. For more information, see the Autodesk DWF Viewer Help
system.

Configure a DWF6 Driver (Advanced)
You are not likely to change the settings in the DWF6 ePlot Properties dialog
box often. However, when you need to make some subtle changes to your
DWF6 ePlot configuration, you can do so through the DWF6 ePlot Properties
dialog box. You can specify settings for color depth, display resolution, file
compression, handling of fonts, pen settings, and other options. When you
create DWF6 files, you use a plotter configuration file that uses a DWF6 driver
model. You must use the DWF6 ePlot.pc3 file to plot DWF6 files.

Overview of Creating or Modifying a DWF6
Configuration File

Publish uses only the DWF6 ePlot.pc3 plotter configuration file. You can use
the default DWF6 ePlot.pc3 plotter configuration file as installed, or you can
make changes to it using the Properties button in the Plot dialog box. This
invokes the pc3 editor, which allows you to make changes directly to the
DWF6 ePlot.pc3 file. Although you can save DWF6 ePlot.pc3 files under other
names for use with the Plot command, no other name will work with the
Publish command. Any changes you make to the DWF6 ePlot.pc3 file are used
whenever you plot or publish DWF6 files until you change the settings of
your DWF6 ePlot.pc3 file again.

NOTE If you are going to make changes to the DWF6 ePlot.pc3 file, make a backup
copy of the file first in case you want to use the default settings later. If necessary,
the default DWF6 ePlot.pc3 file can be re-created with the Add-A-Plotter wizard.
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These settings may change file size and plot quality, depending on the content
of the source drawing for the Design Web Format™ (DWF™ ) file. You can
specify the following settings when you edit the DWF6 ePlot.pc3 configuration
file:

■ Color depth

■ Display resolution

■ Compression options

■ Inclusion and handling of fonts

■ Background color

■ Virtual pen settings and patterns

■ Inclusion of layer information

■ Inclusion of a paper boundary

■ Inclusion of a saved preview

NOTE DWF files intended for plotting should be configured with a white
background color. If the background color is set to black, color 7 objects will be
plotted as white. For all other background colors, color 7 objects will be plotted
as black.

To create a plotter configuration file for DWF file output

1 Click File menu ➤ Plotter Manager.

2 Double-click the Add-A-Plotter wizard.

3 On the Add Plotter-Introduction page, click Next.

4 On the Add Plotter-Begin page, select My Computer. Click Next.

5 On the Plotter Model page, under Manufacturers, select Autodesk ePlot
(DWF). Under Models, select the DWF6 ePlot file that you want to create.
Click Next.

6 (Optional) If you want to import a pre-existing plotter configuration,
on the Import PCP or PC2 page, click Import File. Select a PCP or PC2
file to import. Click Import.

7 Click Next.

8 On the Ports page, select Plot to File. Click Next.
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9 On the Plotter Name page, enter a name for the plotter configuration
file. Click Next.

10 On the Finish page, click Finish.

A new plotter configuration file (PC3) is created.

To specify or modify settings for plotted DWF files

1 Click File menu ➤ Plot.

2 In the Plot dialog box, under Printer/Plotter, in the Name list, select a
DWF plotting device. Click Properties.

3 In the Plotter Configuration Editor, Device and Document Settings tab,
select Custom Properties in the tree window.

4 Click Custom Properties.

5 In the DWF6 ePlot Properties dialog box, select the options you want.
Click OK.

6 In the Plotter Configuration Editor, click OK.

7 In the Changes to a Printer Configuration dialog box, do one of the
following. Then click OK.

■ Select Apply Changes for the Current Plot Only to specify a one-time
override of the configuration settings that isn’t saved to the ePlot
configuration file.

■ Select Save Changes to the Following File to save the configuration
changes to the DWF configuration file.

8 In the Browse for Plot File dialog box, in the Save In location list, select
a plotting location for the DWF file, and click Save. Click OK.

Standard toolbar

To set color depth for plotted DWF files

1 Click File menu ➤ Plot.

2 In the Printer/Plotter area, in the Name list, select a DWF plotting device.
Click Properties.

3 In the Plotter Configuration Editor, Device and Document Settings tab,
expand the Graphics node in the tree window.
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4 Click Vector Graphics.

5 In the Color Depth area, select a color depth. Click OK.

6 In the Changes to a Printer Configuration dialog box, do one of the
following. Then click OK.

■ Select Apply Changes for the Current Plot Only to specify a one-time
override of the configuration settings that isn’t saved to the DWF
configuration file.

■ Select Save Changes to the Following File to save the configuration
changes to the DWF configuration file.

7 In the Browse for Plot File dialog box, in the Save In location list, select
a plotting location for the DWF file, and click Save. Click OK.

Standard toolbar

Set the DWF File Resolution

You can specify the pixel resolution for vector and raster graphics of the DWF6
files that you create. The higher the resolution, the greater the precision but
the larger the file size.

WARNING Raster and gradient resolution settings can never exceed the vector
setting.

The following list shows the default values for vector and raster resolutions:

■ Vector resolution: 1200 dpi

■ Custom vector resolution: 40000 dpi

■ Gradient resolution: 200 dpi

■ Custom gradient resolution: 200 dpi

■ Color and grayscale resolution: 200 dpi

■ Custom color and grayscale resolution: 200 dpi

■ Black and white resolution: 400 dpi

■ Custom black and white resolution: 400 dpi
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When you create DWF files intended for plotting, select a resolution to match
the output of your plotter or printer. High resolutions (over 2400 dpi) are for
viewing. For example, when you create DWF files of drawings that contain a
lot of detail, such as a topographical map of a large region, use a higher
resolution setting for greater detail in the DWF file. Use extreme resolutions
(over 40,000 dpi) only when necessary; they may produce very large files. As
you increase the resolution setting, raster image quality increases, the speed
of printing decreases, and memory requirements increase.

As an example of the difference between DWF resolution settings, consider a
map of the world that you want to output as a DWF file for viewing. With a
medium resolution setting, you might be able to zoom to a level of detail
approximately the size of the state of California on the world map. With a
high resolution setting, you might be able to zoom to a level of detail the size
of a city. With an extreme resolution setting, you might be able to zoom to a
level of detail the size of a building.

To specify the DWF file resolution

1 Click File menu ➤ Plot.

2 In the Printer/Plotter area, in the Name list, select a DWF plotting device.
Click Properties.

3 In the Plotter Configuration Editor, Device and Document Settings tab,
select Custom Properties from the tree window.

4 In the Access Custom Dialog area, click Custom Properties.

NOTE You can enter any whole number between 150 and 100,000,000 for
color and grayscale resolution settings as long as the number does not exceed
the current vector resolution setting.

5 In the DWF6 ePlot Properties dialog box, in the Vector and Gradient
Resolution (Dots Per Inch) area, select Vector and Gradient Resolution
settings from the list, or select Custom and enter custom settings. Click
OK.

6 In the DWF6 ePlot Properties dialog box, in the Raster Image Resolution
(Dots Per Inch) area, select Color and Grayscale Resolution settings or
Black and White Resolution settings from the list, or enter Custom
settings. Click OK.

7 In the Plotter Configuration Editor, click OK.
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8 In the Changes to a Printer Configuration dialog box, do one of the
following. Then click OK.

■ Select Apply Changes for the Current Plot Only to specify a one-time
override of the configuration settings that isn’t saved to the DWF
configuration file.

■ Select Save Changes to the Following File to save the configuration
changes to the DWF configuration file.

9 In the Browse for Plot File dialog box, in the Save In location list, select
a plotting location for the DWF file, and click Save. Click OK.

Standard toolbar

Set the DWF File Compression

By default, the DWF6 files that you create are in a compressed binary format.
The compression does not result in any loss of data; this is the recommended
output for most DWF files. You can also create zipped ASCII encoded 2D
stream (plain text) files. You specify these settings when you create or edit a
DWF configuration file.

To specify the DWF file compression

1 Click File menu ➤ Plot.

2 In the Printer/Plotter area, in the Name list, select a DWF plotting device.
Click Properties.

3 In the Plotter Configuration Editor, Device and Document Settings tab,
select Custom Properties from the tree window.

4 In the Access Custom Dialog area, click Custom Properties.

5 In the DWF6 ePlot Properties dialog box, in the Additional Output
Settings and in the DWF Format area, specify a file compression option.
Click OK.

6 In the Plotter Configuration Editor, click OK.
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7 In the Changes to a Printer Configuration dialog box, do one of the
following. Then click OK.

■ Select Apply Changes for the Current Plot Only to specify a one-time
override of the configuration settings that isn’t saved to the DWF6
configuration file.

■ Select Save Changes to the Following File to save the configuration
changes to the DWF configuration file.

8 In the Browse for Plot File dialog box, in the Save In location list, select
a plotting location for the DWF file, and click Save. Click OK.

Standard toolbar

Set Font Handling for the DWF File

When you create DWF files, you can specify how fonts are handled and
included in the DWF6 file. By default, font handling is set to Capture Some
in the DWF6 ePlot Properties dialog box; you can specify which fonts are
eligible for capture in your DWF file. This is the recommended option.

NOTE DWF file size can be affected by the font-handling settings as well as by
the amount of text and the number and type of fonts used in the DWF file. If the
size of your DWF file seems too large, try changing the font-handling settings.

To specify font handling for the DWF file

1 Click File menu ➤ Plot.

2 In the Printer/Plotter area, in the Name list, select a DWF plotting device.
Click Properties.

3 In the Plotter Configuration Editor, Device and Document Settings tab,
select Custom Properties from the tree window.

4 In the Access Custom Dialog area, click Custom Properties.

5 In the DWF6 ePlot Properties dialog box, in the Font Handling area,
select a font capture option. Click OK.

6 In the Plotter Configuration Editor, click OK.
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7 In the Changes to a Printer Configuration dialog box, do one of the
following. Then click OK.

■ Select Apply Changes for the Current Plot Only to specify a one-time
override of the configuration settings that isn’t saved to the DWF6
configuration file.

■ Select Save Changes to the Following File to save the configuration
changes to the DWF configuration file.

8 In the Browse for Plot File dialog box, in the Save In location list, select
a plotting location for the DWF file, and click Save. Click OK.

Standard toolbar

To edit the list of fonts eligible for capture in the DWF file

1 Click File menu ➤ Plot.

2 In the Printer/Plotter area, in the Name list, select a DWF plotting device.
Click Properties.

3 In the Plotter Configuration Editor, Device and Document Settings tab,
select Custom Properties from the tree window.

4 In the Access Custom Dialog area, click Custom Properties.

5 In the DWF6 ePlot Properties dialog box, in the Font Handling area,
select Capture Some.

6 Select Edit Font List.

NOTE Capturing fonts in the DWF file causes the file size to increase. To
minimize file size, the TrueType fonts that are common to all Microsoft®
Windows® platforms are by default not selected in the list. Even though
these fonts have no check marks beside them, they are shown in the DWF6
file if you are using a Windows operating system. You should select all other
TrueType fonts that you have installed to ensure that they are captured for
embedding in the DWF6 file. Only the fonts that are needed are embedded
in the file.

7 In the Available TrueType Fonts dialog box, select the fonts that you
want to be eligible for capture in the DWF file. Click OK.

8 In the DWF6 ePlot Properties dialog box, click OK.
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9 In the Plotter Configuration Editor dialog box, click OK.

10 In the Browse for Plot File dialog box, in the Save In location list, select
a plotting location for the DWF file, and click Save. Click OK.

Standard toolbar

Edit Pen Patterns for the DWF File

In the Edit Pen Set dialog box, you can specify pen pattern, width, shape,
effect, and other settings such as scaling and global pen widths. The changes
you make in the Edit Pen Set dialog box are saved in the plotter configuration
file.

NOTE To edit pen patterns when using DWF6 ePlot, you must select 255 Virtual
Pens as your color depth.

To edit the Edit Pen Set dialog box for the DWF file

1 Click File menu ➤ Plot.

2 In the Printer/Plotter area, in the Name list, select a DWF plotting device.
Click Properties.

3 In the Plotter Configuration Editor, Device and Document Settings tab,
expand the Graphics node in the tree window. Select Vector Graphics.
In the Color Depth Area, select 255 Virtual Pens as your color depth,
and then select Custom Properties from the tree window.

4 In the Access Custom Dialog area, click Custom Properties.

5 In the DWF6 ePlot Properties dialog box, click Edit Patterns.

6 In the Edit Pen Set dialog box, right-click a field.

7 Select from the menu of common settings, or click Properties to display
the Pen Properties dialog box where you can modify the attributes for
each individual pen set.

8 In the Pen Properties dialog box, click OK.

9 In the Edit Pen dialog box, click OK.

10 In the DWF6 ePlot Properties dialog box, click OK.

11 In the Plotter Configuration Editor dialog box, click OK.
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12 In the Changes to a Printer Configuration File dialog box, click one of
the following:

■ Apply Changes for the Current Plot Only.

■ Save Changes to the Following File. (Enter the file name.)

13 In the Browse for Plot File dialog box, in the Save In location list, select
a plotting location for the DWF file, and click Save. Click OK.

Standard toolbar

Configure a DWF6 Driver (Advanced) | 959



960



Part 8
Share Data Between Drawings and
Applications

Chapter 29 Reference Other Drawing Files (Xrefs)

Chapter 30 Link and Embed Data (OLE)

961



962



Reference Other
Drawing Files (Xrefs)

 

You can attach an entire drawing to the current drawing as

an external reference (xref). With xrefs, changes in the

referenced drawing are reflected in the current drawing.

Attached xrefs are linked to, but not actually inserted in,

another drawing. Therefore, with xrefs you can build drawings

without significantly increasing the drawing file size.

29
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■ Detach External References

■ Edit External References and
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■ Resolve External Reference
Errors

■ Increase Performance with
Large Xrefs



Overview of External References
By using xrefs, you can

■ Coordinate your work with the work of others by referencing other drawings
in your drawing to keep up with the changes being made by other users.
You can also assemble a master drawing from component drawings that
may undergo changes as a project develops.

■ Ensure that the most recent version of the referenced drawing is displayed.
When you open your drawing, each xref is automatically reloaded, so it
reflects the latest state of the referenced drawing file.

■ Keep the names of layers, dimensioning styles, text styles, and other named
elements in your drawing separate from those in referenced drawings.

■ Merge (bind) attached xrefs permanently with your drawing when the
project is complete and ready to be archived.

NOTE Like a block reference, an xref appears in the current drawing as a single
object. However, you cannot explode an xref without binding it first.

See also:

“DesignCenter” on page 61

Attach, Update, and Bind External References
You can perform several operations on referenced drawing files including
attaching, updating, and detaching them.

Attach External References

When you attach a drawing as an xref, you link that referenced drawing to
the current drawing; any changes to the referenced drawing are displayed in
the current drawing when it is opened.

The program treats an xref as a type of block definition with some important
differences. When you insert a drawing as a block reference, it is stored in the
drawing and is not updated if the original drawing changes. When you attach
a drawing as an xref, you link that referenced drawing to the current drawing;
any changes to the referenced drawing are displayed in the current drawing
when it is opened.
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A drawing can be attached as an xref to multiple drawings at the same time.
Conversely, multiple drawings can be attached as external references to a
single drawing.

The saved path used to locate the xref can be an absolute (fully specified) path,
a relative (partially specified) path, or no path.

If an xref contains any variable block attributes, The program ignores them.

NOTE Xrefs must be model space objects. They can be attached at any scale,
location, and rotation.

Notification of Attached Xrefs

An xref icon is displayed in the lower-right corner of the application window
(the status bar tray) when xrefs are attached to the drawing.

When one or more xrefs are not found or if any of the xrefs need reloading,
an exclamation point is added to the Xref icon. If you click the Xref icon, the
Xref Manager is displayed.

Tools for Attaching Xrefs

To attach an xref, use  to display the Xref Manager or use .

You can also use DesignCenter™ to attach xrefs to a drawing. Use DesignCenter
for simple attachments, previewing external references and their descriptions,
and quick placement by dragging.

You can attach an xref by dragging it from DesignCenter or by clicking Attach
as Xref on the shortcut menu.

Visibility, Color, and Linetype

You can control the visibility, color, linetype, and other properties of an xref's
layers and make these changes temporary or permanent. If the  system variable
is set to 0, these changes apply only to the current drawing session. They are
discarded when you end the drawing session, or when you reload or detach
the xref.
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Xref Clipping Boundaries

Drawings can include xrefs that are clipped. If you want to see the clipping
boundary, you can turn on the  system variable.

Attachments from Educational Products

If you open, insert, or attach an xref from an Autodesk Educational Product,
the drawings you plot contain the following banner: “PRODUCED BY AN
AUTODESK EDUCATIONAL PRODUCT.”

See also:

“DesignCenter” on page 61
“Nest and Overlay External References” on page 967
“Clip External References and Blocks” on page 970
“Set Paths to Externally Referenced Drawings” on page 983

To attach an xref

1 Click Insert menu ➤ External Reference.

2 In the Select Reference File dialog box, select the file you want to attach.
Click Open.

3 In the External Reference dialog box, under Reference Type, select
Attachment.

4 Specify the insertion point, scale, and rotation angle. Click Specify
On-Screen to use the pointing device.

Attachment includes all nested xrefs.

5 Click OK.

Reference toolbar

To attach or overlay an xref using DesignCenter

1 Click Tools menu ➤ DesignCenter.

2 In the content area or in the Search dialog box, locate the xref you want
to attach or overlay.

3 Right-click. Drag the xref into the open drawing.

4 Release the right-pointing device button. Click Attach as Xref.
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5 In the External Reference dialog box, under Reference Type, select
Attachment or Overlay.

6 Enter values for Insertion Point, Scale, and Rotation, or select Specify
On-Screen to use the pointing device.

7 Click OK.

You can also attach an xref by dragging or by clicking Attach as Xref on
the shortcut menu.

8 Click OK.

Standard toolbar

Nest and Overlay External References

Xrefs can be nested within other xrefs: that is, you can attach an xref that
contains another xref. You can attach as many copies of an xref as you want,
and each copy can have a different position, scale, and rotation.

In the following illustration, master.dwg references a.dwg and b.dwg. Drawing
a.dwg references c.dwg. In master.dwg, c.dwg is a nested xref.

master.dwg a.dwg c.dwg

b.dwg

You can also overlay an xref on your drawing. Unlike an attached xref, an
overlaid xref is not included when the drawing is itself attached or overlaid as
an xref to another drawing. Overlaid xrefs are designed for data sharing in a
network environment. By overlaying an xref, you can see how your drawing
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relates to the drawings of other groups without changing your drawing by
attaching an xref.

In the following illustration, several people are working on drawings referenced
by master.dwg. The person working on a.dwg needs to see the work being
completed by the person working on b.dwg, but does not want to xref b.dwg
because it would then appear twice in master.dwg. Instead, the person overlays
b.dwg, which is not included when a.dwg is referenced by master.dwg.

overlay

master.dwg a.dwg

b.dwg

c.dwg

b.dwg

Relative Saved Paths and Nested Xrefs

The saved path for an xref can be an absolute (fully specified) path, a relative
(partially specified) path, or no path. For a nested xref, a relative path always
references the location of its immediate host and not necessarily the currently
open drawing.

To overlay an xref

1 Click Insert menu ➤ External Reference.

2 In the Select Reference File dialog box, select the file you want to overlay.
Click Open.

3 In the External Reference dialog box, under Reference Type, select
Overlay.

Using the Overlay option excludes any nested xrefs.

4 Specify insertion point, scale, and rotation angle, or click Specify
On-Screen to use the pointing device.

5 Click OK.

968 | Chapter 37   Reference Other Drawing Files (Xrefs)



Reference toolbar

Update Attached External References

When you open a drawing, all xrefs update automatically. Use the  Reload
option to update xrefs whenever you want to ensure that the most current
versions are displayed in your drawing.

xref attached edited xref file xref updated

Whenever you modify and save an externally referenced drawing in a network
environment, other people can access your changes immediately by reloading
the xrefs in their open drawings.

Notification of Changed Xrefs

When you attach xrefs to a drawing, the program periodically checks whether
the referenced files have changed since the last time the xrefs were loaded or
reloaded. The  system variable controls xref notification.

By default, if a referenced file has changed, a balloon message is displayed
near the Xref icon in the lower-right corner of the application window (the
status bar tray). Click the link in the balloon to reload all changed xrefs.
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If you close the balloon message without reloading, an exclamation point is
added to the Xref icon. If you click the Xref icon, the Xref Manager is displayed.

By default, the program checks for changed xrefs every five minutes. You can
change the number of minutes between checks by setting the XNOTIFYTIME
system registry variable using (setenv "XNOTIFYTIME" " n ") where n is a
number of minutes between 1 and 10080 (seven days).

NOTE When changing the value of XNOTIFYTIME, you must enter XNOTIFYTIME
with the capitalization shown.

Update Xrefs with Demand Loading Turned On

If demand loading is turned on when you load or reload an xref

■ With the  system variable set to 1, the referenced drawing is kept open and
locked. No one else can modify the referenced drawing.

■ With XLOADCTL set to 2, a temporary copy of the most recently saved
version of the referenced file is opened and locked. Others can open and
modify the referenced drawing.

For information about demand loading, see “Increase Performance with Large
Xrefs” on page 992.

To update an attached xref

1 Click Insert menu ➤ Xref Manager.

2 In the Xref Manager, select the reference name that you want to reload.

3 Select Reload. Click OK.

NOTE If the drawing you selected has been changed since you opened your
drawing, the xref is reloaded.

Reference toolbar

Clip External References and Blocks

After attaching a drawing as an xref or inserting a block, you can define a
clipping boundary by using . A clipping boundary can define a portion of a
block or xref while suppressing the display of geometry outside of the
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boundary. Clipping applies to an individual instance of an xref, not to the
xref definition itself. The portion of the xref or block within the clipped
boundary remains visible, and the remainder of the xref or block becomes
invisible. The referenced geometry is not altered; only the display of the xref
is edited.

You can use XCLIP to create a new clipping boundary, delete an existing
boundary, or generate a polyline object coincident with the vertices of the
clipping boundary. Xref clipping can be turned on or off. When a clipping
boundary is turned off, the boundary is not displayed and the entire xref is
visible, provided that the geometry is on a layer that is on and thawed. When
a clipping boundary is turned off, it still exists and can be turned on. However,
deleting a clipping boundary is permanent.

After an xref or block has been clipped, it can be edited, moved, or copied just
like an unclipped xref or block. The boundary moves with the reference. If an
xref contains nested clipped xrefs, they appear clipped in the drawing. If the
parent xref is clipped, the nested xrefs are also clipped.

If you want to see the clipping boundary, you can turn on the  system variable.
XCLIPFRAME determines whether the clipping boundary frame is displayed.
When the clipping frame is on (set to 1), it can be selected as part of the object
and plotted.

Clipping Boundary Options

An xref clipping boundary can be specified as a rectangular window or a
polygonal boundary. You can also select a polyline to define the clipping
boundary. The boundary can be specified anywhere in 3D space, but it is
always applied planar to the current UCS. If a polyline is selected, the clipping
boundary is applied in the plane of that polyline.

Rectangular Window Clipping Boundary

When you specify a rectangular clipping boundary, you are prompted for the
corners of the window. The window is drawn parallel to the current UCS, and
the clipping boundary is applied normal to the plane it lies on.

Polygonal Clipping Boundary

When you specify a polygonal clipping boundary, you are prompted to enter
points to define the boundary. As you specify the clipping points, the last
segment of the polygon is sketched so that the boundary is closed at all times.
When you apply polygonal clipping to images in externally referenced
drawings, the clipping boundary is applied to the rectangular extents of the
polygonal boundary, rather than to the polygon itself.
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Polyline Clipping Boundary

When you specify a polyline clipping boundary, you are prompted to select
a 2D polyline object. The clipping boundary is created coincident with the
polyline. Valid boundaries are 2D polylines with straight or spline-curved
segments. Polylines with arc segments, or fit-curved polylines, can be used as
the definition of the clip boundary, but the clip boundary will be created as
a straight segment representation of that polyline. If the polyline has arcs, the
clip boundary is created as if it had been decurved prior to being used as a clip
boundary. An open polyline is treated as if it were closed.

Clip Depth

The front and back clipping planes for xrefs can be set. The xref must contain
a clipping boundary before you can specify a clip depth. The clip depth is always
calculated normal to the clipping boundary. When defining clip depth, you
are prompted to specify a front and back point or distance relative to the
clipped plane. Regardless of the current UCS, the clip depth is applied parallel
to the clipping boundary.

existing drawings another similar drawing is
referenced

resulting clipped xrefxref is clipped to show only the
conference table

To clip a reference

1 On the Command line, enter xclip.
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2 Select a reference.

3 At the prompt, select New Boundary by pressing  ENTER .

4 Select a rectangular or polygonal clipping boundary. Specify the corners
or vertices of the boundary.

The image is clipped based on the area that you specified and hides the
portion of the xref outside the clipping boundary.

Resolve Name Conflicts in External References

When you attach an xref, the names of its blocks, dimensioning styles, layers,
linetypes, and text styles are differentiated from those in the current drawing.

A typical xref definition includes objects, such as lines or arcs. It also includes
xref-dependent definitions of blocks, dimension styles, layers, linetypes, and
text styles. When you attach an xref, the program differentiates the names of
these xref-dependent named objects from those in the current drawing by
preceding their names with the name of the externally referenced drawing
and a vertical bar character ( | ). For example, in the Layer Properties Manager,
the xref-dependent named object that is a layer named STEEL in an externally
referenced drawing called stair.dwg is listed as STAIR|STEEL.

When you attach an xref, the definitions of its dependent named objects are
not added to your drawing permanently. Instead, these definitions are loaded
from the referenced drawing file each time you reload it.

Bind Xref-Dependent Definitions

An xref-dependent named object's definition can change if the referenced
drawing file is modified. For example, a layer name from a referenced drawing
can change if the referenced drawing is modified. The layer name can even
disappear if it is purged from the referenced drawing. This is why the program
does not allow you to use an xref-dependent layer or other named object
directly. For example, you cannot insert an xref-dependent block or make an
xref-dependent layer the current layer and begin creating new objects on it.

To avoid the restrictions on xref-dependent named objects, you can bind them
to your current drawing. Binding makes the xref-dependent named objects
that you select become a permanent part of your current drawing.

When xref-dependent named objects are merged into a drawing through
binding, you can use them the same way you use the drawing’s own named
objects. After you bind an xref-dependent named object, the vertical bar
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character ( | ) is remved from the name and replaces it with two dollar signs
($$) separated by a number (usually zero): for example, the referenced layer,
STAIR|STEEL, becomes STAIR$0$STEEL. You can then use the RENAME
command to change STAIR$0$STEEL to STEEL.

If you specify a layer whose associated linetype is not CONTINUOUS, the
referenced linetype is also bound. If you apply XBIND to a block, all named
objects that are referenced by the objects in the block are also bound. If the
block contains a reference to an xref, that xref is bound and all of its dependent
definitions.

To bind xref-dependent named objects to the current drawing

1 Click Modify menu ➤ Object ➤ External Reference ➤ Bind.

2 In the Xbind dialog box, click the plus (+) sign next to an external
reference.

The five types of named object definitions (Block, Dimstyle, Layer,
Linetype, and Textstyle) are listed.

3 Click the plus (+) sign of one of the definition types.

The names of the definition table entries are listed.

4 Select a named object definition. Click Add.

The named object definition is listed under Definitions to Bind.

5 If necessary, repeat steps 3 and 4.

6 Click OK.

To change the names of layers, dimension styles, and other named objects

1 Click Format menu ➤ Rename.

2 In the Rename dialog box, select the named object type and then the
item you want to rename.

3 Enter the new name in the Rename To box below the old name.

4 Click Rename To. Click OK.

Archive Drawings That Contain External References
(Bind)

When you archive final drawings that contain xrefs, you have two choices:

■ Store the xref drawings along with the final drawing
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■ Bind the xref drawings to the final drawing

Storing an xref drawing along with the final drawing requires that the drawings
always remain together. Any change to the referenced drawing will continue
to be reflected in the final drawing.

To prevent unintentional updating of archived drawings by later changes to
referenced drawings, bind the xrefs to the final drawing.

Binding an xref to a drawing makes the xref a permanent part of the drawing
and no longer an externally referenced file. You can bind the entire database
of the xref drawing, including all its xref-dependent named objects (blocks,
dimension styles, layers, linetypes, and text styles), by using the  Bind option.
For more information, see “Resolve Name Conflicts in External References”
on page 973.

Binding xrefs to a drawing is also an easy way to send a drawing to reviewers.
Rather than sending a master drawing plus each of the drawings it references,
you can use the Bind option to merge the xrefs into the master drawing.

NOTE You cannot bind xrefs that contain proxy objects. For more information,
see “Work with Custom and Proxy Objects”.

To bind an xref to the current drawing

1 Click Insert menu ➤ Xref Manager.

2 In the Xref Manager, select an external reference. Click Bind.

3 In the Bind Xrefs dialog box, select one of the following options:

■ Bind converts the objects in the xref into a block reference. Named
object definitions are added to the current drawing with a prefix of
blockname$n$.

■ Insert also converts the objects in the xref into a block reference.
Named object definitions are merged into the current drawing without
adding prefixes.

4 Click OK to close each dialog box.

Reference toolbar

Attach, Update, and Bind External References | 975



Detach External References
To completely remove xrefs from your drawing, you need to detach them.
Erasing xrefs does not remove, for example, layer definitions associated with
those xrefs. Using the Detach option removes the xrefs and all associated
information.

To detach an xref

1 Click Insert menu ➤ Xref Manager.

2 In the Xref Manager, select an external reference. Select Detach.

3 Click OK.

Reference toolbar

Edit External References and Blocks in Place
There are two methods for editing xrefs: you can open the referenced drawing,
or you can edit the xref in place from within the current drawing. You can
edit a block definition directly from any selected block reference.

Edit an Xref in a Separate Window

The simplest and most direct method for editing xrefs is to open the referenced
drawing file in a separate window. This method gives you access to all objects
in the referenced drawing.

Instead of browsing for the xref using the Select File dialog box, you can select
the xref and open the referenced drawing. To use this method to edit xrefs,
use the Xref Manager dialog box or the  command.

To edit an xref in a separate window

1 On the command line, enter xopen.

2 Select an object in an external reference.

3 In the new window, edit the referenced drawing file, save it, and then
close window.
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Edit Xrefs and Blocks Within Context

By editing a reference in place, you can modify the reference within the visual
context of your current drawing.

Edit Selected Objects in Xrefs and Blocks

You can modify external references and redefine block definitions from within
the current drawing by using in-place reference editing. Both blocks and xrefs
are considered references.

By editing the reference in place, you can modify the reference within the
visual context of your current drawing.

Often, a drawing contains one or more xrefs as well as multiple block
references. When working with block references, you can select a block, modify
it, and update the block definition. You cannot edit a block reference that is
inserted using .

When working with xrefs, you can select the reference you want to work with,
modify its objects, and save back the changes to the reference drawing. You
can make minor changes without having to go back and forth between
drawings.

NOTE If you plan to make major changes to a reference, open the reference
drawing and edit directly within the file. Using in-place reference editing to make
major changes can increase the size of your current drawing file significantly during
the in-place reference editing session.

Understand the Working Set

Only the objects that are a part of the selected reference are available for
selection in the drawing area. The objects you select from the selected reference
are extracted and made available for modification in the current drawing. The
set of extracted objects, or the working set, can be modified and then saved
back to update the xref or block definition. Objects that make up the working
set are visually distinct from other objects in the drawing. All objects in the
current drawing, except objects in the working set, are faded.

Control the Fading of Objects

The  system variable controls how objects are displayed while a reference is
edited in place. The set of objects extracted from the reference are displayed
normally. All other objects in the drawing, including objects in the current
drawing and in any references not belonging to the working set, are faded.

Edit External References and Blocks in Place | 977



The value indicates the intensity of display for objects not in the working set.
The larger the value is for XFADECTL, the more the objects are faded.

other objects in
drawing

reference objects in drawing
selected for editing

NOTE Objects outside the working set are not faded during in-place reference
editing unless  is set to a value of 2D wireframe.

Use the Refedit Toolbar

The Refedit toolbar is displayed and activated after you select which nested
objects to edit. Using the buttons on the Refedit toolbar, you can add objects
to or remove objects from the working set, and you can discard or save back
changes to the reference. Unless it is docked, the Refedit toolbar is
automatically dismissed after you save back or discard changes made to the
working set.

To edit an xref or block reference in place

1 Click Tools menu ➤ Xref and Block In-Place Editing ➤ Edit Reference
In-Place.

2 From within the current drawing, select the reference that you would
like to edit.

If the object you select in the reference belongs to any nested references,
all the references available for selection are displayed in the Reference
Edit dialog box.

3 In the Reference Edit dialog box, select the specific reference that you
want to edit.
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The reference file is locked to prevent multiple users from opening the
file at once. You cannot edit a reference in place if the drawing file is
being used by another user.

4 Click OK.

5 Select the objects you would like to edit in the reference and press ENTER.

The objects that you select become the working set. By default, all other
objects are locked and faded.

6 Edit the objects in the working set. Click Save Back Changes to Reference.

The objects in the working set are saved to the reference and the xref or
the block is updated.

Use the Working Set to Edit Xrefs and Blocks

To edit an external reference from within the current drawing, you use the
working set to identify objects that belong to the external reference or block
definition rather than the current drawing.

While editing a reference in place, you can add or remove objects from the
working set. If you create a new object while editing a reference in place, it is
almost always added to the working set automatically. Objects that are not
added to the working set are displayed as faded in the drawing.

If a new object is created because of changes made to objects outside the
working set, the new object is not added to the working set. For example, your
drawing contains two lines that are not a part of the working set. If you edit
the lines by using , a new arc is created between the two lines. The arc is not
added to the working set.

When a reference object is part of the working set, you can select the object
for editing even if it is drawn on a locked layer in the reference file. You can
unlock the object’s layer and make changes to the object. Changes made to
the object can be saved, but the layer state remains the same in the reference
file, whether it is locked or unlocked.

An object that is removed from the working set is added to the host drawing
and removed from the reference when changes are saved back. An object that
is added to the working set is removed from the host drawing and is added
to the reference when changes are saved back. If you create or delete objects,
they are automatically added to or removed from the working set. For example,
if you use  while editing a reference in place, the erased objects are removed
from the working set. You can tell whether an object is in the working set or
not by the way it is displayed; a faded object is not in the working set.

The Refedit toolbar is displayed when a reference is being edited in place. The
name of the selected reference is displayed in the toolbar. The editing buttons
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on the toolbar (Add Objects to the Working Set, Remove Objects from the
Working Set, Discard Changes to Reference, and Save Back Changes to
Reference) are active only during in-place reference editing. The Edit Block or
Xref button is active whenever the toolbar is initiated and a reference editing
session is not already in progress within the current drawing. The Refedit
toolbar is dismissed automatically after changes made to the reference are
saved back or discarded.

To add objects to the working set

1 Click Tools menu ➤ Xref and Block In-Place Editing ➤ Add to Working
Set, or at the Command prompt, enter refset.

2 If you entered refset at the Command prompt, click the Add Objects
to the Working Set button on the Refedit toolbar.

3 Select the objects you want to add. You can also set  to 1 and create a
selection set before using the Add option.

REFSET can be used only with objects in the space (paper space or model
space) in which REFEDIT is initiated.

To remove objects from the working set

1 Click Tools menu ➤ Xref and Block In-Place Editing ➤ Remove from
Working Set, or at the Command prompt, enter refset.

2 If you entered refset at the Command prompt, click the Remove Objects
from the Working Set button on the Refedit toolbar.

3 Select the objects you want to remove. You can also set  to 1 and create
a selection set before using the Remove option.
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REFSET can be used only with objects in the space (paper space or model
space) in which REFEDIT is initiated.

Save Back Edited Xrefs and Blocks

While editing a block reference in place, you either can save back or discard
changes made to the reference. If you save back changes to a reference, the
drawing is regenerated.

When the changes are saved back, the block definition is redefined and all
instances of the block are regenerated to reflect the changes. If you choose to
discard the changes, the working set is deleted and the block reference returns
to its original state.

Similarly, while editing an xref in place, you can save back or discard changes.
Objects in the working set that inherit properties not originally defined in the
xref retain those new properties. For example, an xref contains layers A, B,
and C, and the drawing that references it contains layer D. If new objects are
drawn on layer D during in-place reference editing and changes are saved back
to the reference, layer D is copied to the xref drawing.

If you remove objects from the working set and save changes, the objects are
removed from the reference and added to the current drawing. Any changes
you make to objects in the current drawing (not in the xref or block) are not
discarded. If you delete any object that is not in the working set, the object
is not restored even if you choose to discard changes. You can return the
drawing to its original state by using . If you make unwanted changes to an
xref and use  to save back the changes, you must use UNDO to undo any
changes made during the reference editing session. After you have undone
any unwanted changes, use REFCLOSE to save changes to restore the xref file
to its original state.

WARNING While editing a reference in place, if you delete an object that is not
in the working set, the object is not restored if you discard changes at the closing
of the reference editing session.

Objects in the current drawing that inherit properties defined by the xref
retain those new properties. Properties taken from the xref drawing are bound
to the current drawing. The xref layer named SITE, for example, appears in
the current drawing as $#$SITE when assigned to an object not in the working
set. If  is set to 0, a prefix of $#$ is added to the reference name in the current
drawing. If BINDTYPE is set to 1, reference names remain unchanged in the
current drawing, similar to names of inserted objects.

NOTE When you edit and save an xref in place, the original drawing preview is
no longer available unless you open and save the referenced drawing.
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To save back changes from edited xrefs and blocks

■ Click Tools menu ➤ Xref and Block In-Place Editing ➤ Save Reference Edits
or click the Save Back Changes to Reference button on the Refedit toolbar.

Refedit toolbar

With no objects selected during in-place reference editing, right-click in the
drawing area. Click Close Refedit Session.

To discard all changes from edited xrefs and blocks

■ On the Refedit toolbar, click the Discard Changes to Reference button.

Refedit toolbar

Edit Xrefs and Blocks with Nesting, OLE, or Attributes

There are limitations with editing external references and blocks from your
current drawing if they contain nested objects.

If the reference you select for editing has attached xrefs or block definitions,
the reference and its nested references are displayed and available for selection
in the Reference Edit dialog box. Nested references are displayed only if the
object chosen for selection is part of a nested reference. Only one reference
at a time can be selected for editing. If you are editing a reference that contains
OLE objects, the OLE objects are displayed but cannot be selected for editing.
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If a block reference with attributes is selected for editing, you can choose to
display the attribute definitions in the reference and make them available for
editing. The attributes are made invisible and the attribute definitions are
available for editing along with the selected reference geometry. When changes
are saved back to the block reference, the attributes of the original reference
remain unchanged. The new or altered attribute definitions only affect
subsequent insertions of the block; the attributes in existing block instances
are not affected.

Set Paths to Externally Referenced Drawings
You can view and edit the file name and path that the program uses when
loading an xref. Use this option if the xref drawing file has been moved to a
different folder or renamed since it was first attached.

You can choose from three types of folder path information to save with an
attached external reference: an absolute path, a relative path, and no path.

Specify an Absolute Path

An absolute path is a fully specified hierarchy of folders that locates the
external reference. An absolute path includes the local hard drive letter or the
network server drive letter. This is the most specific but least flexible option.

Specify a Relative Path

Relative paths are partially specified folder paths that assume the current drive
letter or the folder of the host drawing. This is the most flexible option, and
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enables you to move a set of drawings from your current drive to a different
drive that uses the same folder structure.

If the drawing file that is being referenced is located on a different local hard
drive or on a network server, the relative path option is not available.

The conventions for specifying a relative folder path are as follows:

\

Look in the root folder of the host drawing’s drive

path

From the folder of the host drawing, follow the specified path

\path

From the root folder, follow the specified path

.\path

From the folder of the host drawing, follow the specified path

..\path

From the folder of the host drawing, move up one folder level and follow
the specified path

..\..\path

From the folder of the host drawing, move up two folder levels and follow
the specified path

NOTE If a drawing that contains xrefs is moved or saved to a different path, to a
different local hard drive, or to a different network server, you must edit any relative
paths to accommodate the host drawing’s new location or you must relocate the
referenced files.

Specify No Path

When no path information is saved with the attached external reference, the
following search is initiated in the order shown:

■ Current folder of the host drawing

■ Project search paths defined on the Files tab in the Options dialog box and
in the  system variable

■ Support search paths defined on the Files tab in the Options dialog box
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■ Start In folder specified in the Microsoft®  Windows®  application shortcut

Specifying the No Path option is useful when moving a set of drawings to a
different folder hierarchy or to an unknown folder hierarchy.

Know When an External Reference Has Been Relocated

If the drawing you are working on contains an xref that has been moved to
a different folder, a message is displayed at the site of the xref when you load
the drawing. The message indicates that the xref cannot be loaded using the
old path. When you specify the new path, the xref is reloaded into your
drawing.

Use Project Names to Define External Reference Paths

Project names make it easier for you to manage xrefs when drawings are
exchanged between customers or if you have different drive mappings to the
same location on a server. The project name points to a section in the registry
that can contain one or more search paths for each project name defined.

If the program cannot find an xref at the location specified by the search path,
the prefix (if any) is stripped from the path. If the drawing has a
PROJECTNAME value set and a corresponding entry exists in the registry, the
program searches for the file along the project search paths. If the xref still is
not located, the program search path is searched again.

You can add, remove, or modify the project names that exist in the registry.
The folder search paths beneath the project name can also be added, removed,
or modified.

The search paths beneath the project name can be added, removed, or modified
in the same manner as the project name. The order in which the folders are
searched can also be modified. Projects and their search paths can only be
edited through the Files tab in the Options dialog box. You cannot edit project
names on the command line.

Once you have established a project name and the search paths you want
associated with that project name, you can make that project name the
currently active project. The program searches the paths associated with that
currently active project for xrefs that were not found in the full search path,
the current drawing folder, or the program support paths.

To change an xref path

1 Click Insert menu ➤ Xref Manager.

2 In the Xref Manager, select a reference name.
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3 Under Xref Found At, do one of the following:

■ Edit the xref path directly.

■ Click Browse. Select the xref in its new path.

4 Click OK.

The program reloads the xref and then regenerates the drawing with the
xref in place.

Reference toolbar

To display the currently defined project names

1 Click Tools menu ➤ Options.

2 In the Options dialog box, Files tab, double-click Project Files Search
Path.

3 Click each project name folder to display the search paths associated
with it.

4 Click OK (or Apply).

To add a project name

1 Click Tools menu ➤ Options.

2 In the Options dialog box, Files tab, double-click Project Files Search
Path. Click Add.

A folder named projectx (where x indicates the next available number)
is created and indented beneath the project folder.

3 Either enter a new name, or press ENTER to accept projectx.

The project name must be 31 characters or fewer, and it cannot contain
leading spaces or terminating spaces.

4 Click OK (or Apply).

To remove a project name

1 Click Tools menu ➤ Options.

2 In the Options dialog box, Files tab, double-click Project Files Search
Path.
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3 Select a project name. Click Remove.

4 Click OK (or Apply).

To modify a project name

1 Click Tools menu ➤ Options.

2 In the Options dialog box, Files tab, select a project name. Enter a new
name.

3 Click OK (or Apply).

You can also modify a project name by selecting the name in the project
folder and pressing F2.

To add a search path

1 Click Tools menu ➤ Options.

2 In the Options dialog box, Files tab, select a project name. Click Add.

3 Add a new search path beneath the project name by entering a new path,
or click Browse and select a new path.

4 Click OK (or Apply).

The new path is indented and placed beneath the project name.

To delete a search path

1 Click Tools menu ➤ Options.

2 In the Options dialog box, Files tab, select a project name. Click Remove.

3 Click OK.

To change a search path

1 Click Tools menu ➤ Options.

2 In the Options dialog box, Files tab, select a project name. Click Browse.

3 In the Browse for Folder dialog box, select a new path.

4 Click OK to close each dialog box.

You can also change a search path by selecting the project path and
pressing F2.
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To make a project current

1 Click Tools menu ➤ Options.

2 In the Options dialog box, Files tab, double-click Project Files Search
Path.

3 Select a Project name. Click Set Current.

4 Click OK (or Apply).

You can also set a project current by entering projectname on the
command line and then entering the name of the project.

To clear the current project

1 Click Tools menu ➤ Options.

2 In the Options dialog box, Files tab, click Project Files Search Path.

3 Click Clear Current.

This clears the setting for the current drawing.

4 Click OK (or Apply).

You can also clear the current project at the Command prompt by
entering projectname and then entering a period (.).

Resolve External Reference Errors
If an external reference cannot be loaded when you open a drawing, an error
message is displayed.

Resolve Missing External Reference Files

If an external reference cannot be located when you open a drawing, an error
message is displayed. There are several options available to you if this occurs.

The program stores the path of the drawing that is used to create the external
reference. Each time you load or plot the drawing or use the xref Reload option
in the Xref Manager to update the external reference, the program checks this
path to determine the name and location of the referenced drawing file. If
the name or location of the drawing file has changed, the program cannot
reload the external reference.

If the program cannot load an external reference when it is loading your
drawing, it displays an error message. In this example, the program can't find
the xref HOUSE:
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"\acad\dwg\house.dwg": Can't open file

** Error resolving Xref HOUSE.

For each insertion of the external reference, the program displays text (at the
location, scale, and rotation angle of the original reference) that contains the
path of the missing xref. You can use the  Path option to update or correct
the path.

One way to avoid these errors is to be sure that when you give other people
files that have xrefs attached, you also give them all the referenced files.

Change Nested Xref Paths

When the drawing is reopened and the nested xref is loaded, the program
attempts to find the xref in the original xref path first. If the xref is not found,
the following search is initiated in the order shown:

■ Current folder of the host drawing

■ Project search paths defined on the Files tab in the Options dialog box and
in the  system variable

■ Support search paths defined on the Files tab in the Options dialog box

■ Start In folder specified in the Microsoft®  Windows®  application shortcut

This ensures that revisions made to the xref are reflected in the current drawing
and also makes it possible for the xref to be found if its path has changed.

For example, suppose that the xref tree of the current drawing A is A>B>C,
and the owner of drawing B changes the path of xref C to point to C1.dwg.
When drawing A is reopened, it reflects the path change in drawing B and
displays C1.dwg. However, if C1.dwg is not found, the program looks for xref
C at the last location it was saved in drawing A.

See also:

“Update Attached External References” on page 969

To change an xref path

1 Click Insert menu ➤ Xref Manager.

2 In the Xref Manager dialog box, select an external reference.

3 Under Xref Found At, do one of the following:

■ Edit the xref path directly.

■ Click Browse. Select the xref in its new path.
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4 Click OK.

The program reloads the xref and then regenerates the drawing with the
xref in place.

Reference toolbar

Resolve External References That Are Circular

A reference file that contains a sequence of nested references that refers back
to itself is considered a circular reference. For example, if drawing A attaches
drawing B, which attaches drawing C, which attaches drawing A, the reference
sequence A>B>C>A is a circular reference.

If the program detects a circular reference while attaching an xref, a warning
is displayed asking you if you want to continue. If you respond with yes, the
program reads in the xref and any nested xrefs to the point where it detects
the circularity. If you respond with no, the process is halted and the xref is
not attached.

If the program encounters a circular reference while loading a drawing, it
displays an error message and breaks the circular reference for the current
session. For example, if you have the circular reference A>B>C>A, and you
open a.dwg, the program detects and breaks the circularity between c.dwg and
a.dwg. The following error message is displayed:

Breaking circular reference from C to current drawing.

Track External Reference Operations (Log File)

The program can maintain a log of its actions while attaching, detaching, and
reloading xrefs and while loading a drawing containing xrefs. This log is
maintained only if the  system variable is set to 1. The default setting is 0.

The log file is an ordinary ASCII text file with the same name as the current
drawing and the file extension .xlg. If you load a drawing with the file name
sample.dwg, for example, the program searches for a log file named sample.xlg
in the current folder. If the file does not exist, a new file is created with that
name.

Once a log file has been created for a drawing, the program continues to
append information to it. the program writes a title block to the log file each
time the file is opened. If the log file becomes too large, you can delete it.
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Example: A Sample Title Block from an Xref Log File

This title block contains the name of the current drawing, the date and time,
and the operation being performed.

=============================
Drawing: detail
Date/Time: 09/28/99 10:45:20
Operation: Attach Xref
=============================
During a detaching or reloading operation, the program prints the nesting
level of all affected xrefs immediately following the title block. To see a
reference tree for a set of xrefs in your current drawing, use Detach or Reload
and check the resulting entries in the log file.

Example: A Sample Log File Entry Showing Nested Xrefs

In the following example, the xref ENTRY_DR contains two nested xrefs:
HARDWARE and PANELS. The xrefs HARDWARE and PANELS also each contain
two xrefs.

==============================
Drawing: detail
Date/Time: 10/05/99 15:47:39
Operation: Reload Xref
=============================
Reference tree for ENTRY_DR:
ENTRY_DR Xref
–HARDWARE Xref
––LOCKSET Xref
––HINGES Xref
–PANELS Xref
––UPPER Xref
––LOWER Xref
The program writes an entry in the log file for each xref-dependent named
object temporarily added to the current drawing and for any errors that occur.
Most error messages are written both to the screen and to the log file.

Example: A Sample Log File That Shows the Results of Attaching an Xref

The following example shows a partial listing of the log file entries generated
when the external reference STAIR is attached to the working drawing test.dwg.
The log file lists the definition (symbol) table affected and the name of the
definition added, along with a status message.

==============================
Drawing: test
Date/Time: 12/18/99 14:06:34
Operation: Attach Xref
=============================
Attach Xref STAIR: \ACAD\DWGS\STAIR.dwg
Searching in ACAD search path
Update block symbol table:
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Appending symbol: STAIR|BOLT
Appending symbol: STAIR|BOLT-HALF
...
block update complete.
Update Ltype symbol table:
Appending symbol: STAIR|DASHED
Appending symbol: STAIR|CENTER
Appending symbol: STAIR|PHANTOM
Ltype update complete.
Update Layer symbol table:
Appending symbol: STAIR|STEEL-HIDDEN
Appending symbol: STAIR|OAK
...
Layer update complete.
STAIR loaded.

To use the xref log file

1 At the Command prompt, enter xrefctl.

2 Enter 1 to turn logging on or 0 to turn logging off.

3 Press  ENTER .

Logging is off by default.

Increase Performance with Large Xrefs
There are several features that can improve performance with large external
references.

Overview of Demand Loading

Provides a high-level description of using demand loading to improve
performance when working with large external references.

The program uses demand loading and saving drawings with indexes to increase
performance with large external references that have been clipped using the
program or that have many objects on frozen layers. With demand loading,
the program loads into memory only the data from the reference drawing
that is necessary to regenerate the current drawing. In other words, referenced
material is read in “on demand.” Demand loading works in conjunction with
the , , and  system variables.

Unload Xrefs

When an xref is unloaded from the current drawing, the drawing opens much
faster and uses less memory. The xref definition is unloaded from the drawing
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file, but the pointer to the reference drawing remains. The xref is not displayed,
and nongraphical object information does not appear in the drawing. However,
you can restore all the information by reloading the xref. If  (demand loading)
is set to 1, unloading the drawing unlocks the original file.

You should unload a reference file if it is not needed in the current drawing
session but may be used later for plotting. You can maintain a working list of
unloaded xrefs in the drawing file that you can load as needed.

To unload an xref

1 Click Insert menu ➤ Xref Manager.

2 In the Xref Manager, select an xref. Click Unload.

3 Click OK.

Reference toolbar

Work with Demand Loading

With demand loading, only the data from the referenced drawing that is
necessary to regenerate the current drawing is loaded into memory.

To realize the maximum benefits of demand loading, you need to save the
referenced drawings with layer and spatial indexes. The performance benefits
of demand loading are most noticeable when you do one of the following:

■ Clip the xref with the program to display a small fraction of it, and a spatial
index is saved in the externally referenced drawing.

■ Freeze several layers of the xref, and the externally referenced drawing is
saved with a layer index.

If demand loading is turned on, and you have clipped xrefs that were saved
with spatial indexes, objects in the external reference database that are
contained within the clip volume comprise the majority of the objects read
into the drawing. If the clip volume is modified, more objects are loaded as
required from the reference drawing. Similarly, if you have xrefs with many
layers frozen that were saved with layer indexes, only the objects on those
thawed layers are read into the current drawing. If those xref-dependent layers
are thawed, the program reads in that geometry from the reference drawing
as required.
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When demand loading is turned on, the program places a lock on all reference
drawings so that it can read in any geometry it needs to on demand. Other
users can open those reference drawings, but they cannot save changes to
them. If you want other users to be able to modify an xref that is being demand
loaded into another drawing, use demand loading with the Copy option.

If you turn on demand loading with the Enable with Copy option, the program
makes a temporary copy of the externally referenced file and demand loads
the temporary file. You can then demand load the xref while allowing the
original reference drawing to be available for modification. When you turn
off demand loading, the program reads in the entire reference drawing
regardless of layer visibility or clip instances.

Layer and spatial indexes were added in AutoCAD Release 14 and AutoCAD
LT 97. If you externally reference a drawing saved in a release previous to this,
you do not see the same performance benefit as drawings saved with the
indexes. For maximum performance, use demand loading with referenced
drawings saved with layer and spatial indexes turned on in AutoCAD Release
14, AutoCAD LT 97, or more recent versions.

To turn on demand loading

1 Click Tools menu ➤ Options.

2 In the Options dialog box, Open and Save tab, under External References,
select Disabled, Enabled, or Enabled with Copy.

3 Click OK.

Work with Layer and Spatial Indexes

To receive the maximum benefit of demand loading, it is recommended that
you save any drawings that are used as xrefs with layer and spatial indexes.

A layer index is a list showing which objects are on which layers. This list is
used when the program is referencing the drawing in conjunction with demand
loading to determine which objects need to be read in and displayed. Objects
on frozen layers in an external reference are not read in if the external reference
has a layer index and is being demand loaded.

The spatial index organizes objects based on their location in 3D space. This
organization is used to efficiently determine which objects need to be read in
when the drawing is being demand loaded and clipped as an external reference.
If demand loading is turned on, and the drawing is attached as an xref and
clipped, the program uses the spatial index in the externally referenced drawing
to determine which objects lie within the clip boundary. The program then
reads only those objects into the current session.
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Spatial and layer indexes are best used in drawings that will be used as xrefs
in other drawings where demand loading is enabled. Drawings that are not
going to be used as xrefs will not benefit from layer and spatial indexing or
demand loading.

To save a drawing with layer and spatial indexes

1 Click File menu ➤ Save As.

2 In the Save Drawing As dialog box, click Tools menu ➤ Options.

3 In the Saveas Options dialog box, under Index Type, select Layer, Spatial,
or Layer & Spatial. Click OK.

NOTE If you are saving a partially open drawing that does not already contain
layer and spatial indexes, this option is disabled.

4 Click Save.

Set Paths for Temporary Xref File Copies

When you turn on demand loading with copy, the  system variable can be
used to indicate the path where copies of externally referenced files are to be
placed. The path you specify remains in effect for all drawing sessions until
you indicate a different path. If no value for XLOADPATH is specified, the
temporary file copies are placed in the standard folder for temporary files.

If you find that referencing drawings over a network is slow, it is recommended
that you set XLOADPATH to reference a local folder, and set  to 2 so that the
externally referenced files are demand loaded from your local machine.
Conversely, to minimize the number of temporary files created by multiple
users referencing the same drawing, those users can set XLOADPATH to point
to a common folder. In this manner, multiple sessions of the program can
share the same temporary copies of reference drawings.
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You can set XLOADPATH in the Options dialog box and indicate the path
where copies of externally referenced files are to be placed.

To set the file path for xref copies

1 Click Tools menu ➤ Options.

2 In the Options dialog box, Files tab, select the Temporary External
Reference File Location folder.

The expanded tree view displays the path where copies of xref files are
placed. If no path is specified, the temporary copies are placed in the
location specified by Temporary Drawing File Location.

3 Edit the path by selecting it and entering a new path.

4 Click OK (or Apply) to set the path.
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Link and Embed Data
(OLE)

 

Object linking and embedding (OLE) is a Windows feature

that combines data from different applications into one

document. For example, you can create an Adobe PageMaker

layout that contains an AutoCAD drawing, or you can create

an AutoCAD drawing that contains all or part of a Microsoft

Excel spreadsheet.

30
In this chapter

■ Overview of Object Linking
and Embedding

■ Import OLE Objects

■ Export OLE Objects from
Drawings

■ Edit OLE Objects in Drawings



Overview of Object Linking and Embedding
Object linking and embedding is a way to use information from one application
in another application. To use OLE, you need both source and destination
applications that support OLE.

Both linking and embedding insert information from one document into
another document. Also, both linked and embedded OLE objects can be edited
from within the destination application. However, linking and embedding
store information differently.

The relationship between embedding and linking is similar to that between
inserting a block and creating an external reference.

Embed Objects

An embedded OLE object is a copy of information from another document.
When you embed objects, there is no link to the source document and any
changes made to the source document are not reflected in destination
documents. Embed objects if you want to be able to use the application that
created them for editing, but you do not want the OLE object to be updated
when you edit information in the source document.

source document compound document
unmodified

source document
modified

compound
document

Link Objects

A linked object is a reference to information in another document. Link objects
when you want to use the same information in more than one document.
Then, if you change the original information, you need to update only the
links in order to update the document containing the OLE objects. You can
also set links to be updated automatically.
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When you link a drawing, you need to maintain access to the source
application and the linked document. If you rename or move either of them,
you may need to reestablish the link.

source
document

compound
document

source document
modified

compound document
modified

Control the Plot Quality of OLE Objects

OLE objects are treated as raster objects when a raster plotter is used. Because
large, high-resolution, color-rich rasters can be expensive to plot, you can set
the  system variable to control how each OLE object is plotted. The default
setting, Automatically Select, assigns a plot-quality level based on the type of
object. The higher the plot-quality setting, the more time and memory are
used to plot.

You can also adjust OLE plot quality in the Plotter Configuration Editor. The
Graphics option displays a Raster Graphics dialog box with a slider that controls
OLE plot quality.

NOTE Nested OLE objects may cause problems. For example, an Excel
spreadsheet embedded in a Word document may fail to plot. Also, an OLE object
that is not in the current view plane is not plotted, but the frame is plotted based
on the setting of the  system variable.

See also:

“Use Windows Cut, Copy, and Paste” on page 594

To set the plot quality for OLE objects

1 Click Tools menu ➤ Options.
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2 In the Options dialog box, Plot and Publish tab, in the OLE Plot Quality
list, select one of the following settings:

■ Monochrome. For example, spreadsheets

■ Low Graphics. For example, color text and pie charts

■ High Graphics. For example, photographs

■ Automatically Select. Plot-quality setting assigned based on the
type of file

3 Click Apply to continue setting options, or click OK to close the dialog
box.

Import OLE Objects
You can import information into a drawing from other applications that
support OLE.

Overview of Importing OLE Objects into Drawings

Use one of the following methods to insert information from another
application as an OLE object:

■ Copy or cut information from an existing file and paste it into the drawing.

■ Import an existing file created in another application.

■ Open another application from within the drawing and create the
information that you want to use.

When you insert the information, you specify an insertion point.

By default the OLE object is displayed with a frame that is not plotted. OLE
objects are opaque and are plotted as opaque; they hide objects in back of
them. OLE objects support draw order. You control the display of OLE objects
in two ways:

■ Set the  system variable to display or suppress the display of all OLE objects
in paper space, model space, or both.

■ Turn off or freeze a layer to suppress the display of OLE objects on that
layer.

When OLE objects with text are printed, the text size approximates the text
size in the source application.
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NOTE OLE objects in drawings are not displayed or plotted in external references
or block references.

Link OLE Objects in Drawings

You can link information from a document created by another application
to a drawing. For example, you might want to insert a schedule that will be
automatically updated. You can also install multimedia icons that are activated
when double-clicked.

Update Links

Links can be set to be updated either automatically or manually when
information in the linked document changes. By default, links are updated
automatically. Use  to specify automatic or manual updating.

Reconnect Links

Because a link references the location of the linked document, you need to
reconnect the link if the document changes location or is renamed.

Break Links

Breaking a link does not remove the inserted information from the drawing.
Instead, it removes the connection to the linked document. You can break a
link when you no longer need to update the information.

To link objects in a drawing

1 Start the source application and open a document.

2 Select the information you want to link and copy it to the Clipboard.

3 Open the drawing.

4 Click Edit menu ➤ Paste Special.

5 In the Paste Special dialog box, click Paste Link.

Paste Link pastes the contents of the Clipboard into the current drawing
and creates a link to the file in the source application. If you click Paste,
the Clipboard contents are embedded instead of linked.

6 In the As box, select the data format you want to use.

7 Click OK.
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To link an entire file as an OLE object in a drawing

1 Open the drawing.

2 Click Insert menu ➤ OLE Object.

3 In the Insert Object dialog box, select Create from File.

4 Select Link. Click Browse.

5 In the Browse dialog box, select the file you want to link. Click Open.

6 In the Insert Object dialog box, click OK.

The entire file is linked to the drawing.

To update links manually

1 Click Edit Menu ➤ OLE Links.

2 In the Links dialog box, select the links you want to update.

3 Click Update Now.

4 Click Close.

NOTE If you want to select the links from the drawing area rather than from a list
in the Links dialog box, select the OLE objects before step 1.

To reconnect a link to an OLE object

1 In the drawing, select the OLE object whose link you want to change.

2 Click Edit menu ➤ OLE Links.

3 In the Links dialog box, click Change Source.

4 In the Change Source dialog box, search for the source file.

5 Select the source file. Click Open.

6 Click OK.

To break a link to an OLE object

1 Select the linked object whose link you want to break.

2 On the Edit menu, click OLE Links.

3 In the OLE Links dialog box, click Break Link.

4 Click Yes.
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5 Click Close.

Embed OLE Objects in Drawings

When you embed information from another document in a drawing, the
information is not updated when it changes in the source document.

You can embed an object in a drawing by copying the object to the Clipboard
and then pasting it into the drawing file. For example, you can embed a
company logo created with another application into a drawing.

Drag Objects into a Drawing

You can drag selected data and graphics into a drawing from another
application window. Both applications must be running and visible on your
screen. The other application must support ActiveX to drag information
between applications. Objects dragged into a drawing are embedded, not
linked.

Dragging data is the same as cutting and pasting. The information is removed
from one document and pasted into the other document. Holding down CTRL
while dragging is the same as copying and pasting in that it creates a copy of
the information, leaving the original document intact.

To embed an OLE object in a drawing

1 Open the document in the source application.

2 Copy the information you want to embed to the Clipboard.

3 Open the drawing.

4 Click Edit menu ➤ Paste.

5 Click OK.

To create an object in another application and embed it in a drawing

1 Open the drawing.

2 Click Insert menu ➤ OLE Object.

3 In the Insert Object dialog box, under Object Type, select Create New.

4 Under Object Type, select an application. Click OK.

The source application opens.

5 Using the server application, create the information you want to insert.
Save the document.
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6 On the source application's File menu, click Exit and Return.

7 Close the source application.

The OLE object is embedded in the drawing.

To specify a new height or width for an OLE object

1 Right-click an OLE object. Click Properties.

2 In the Properties palette, enter new values for Width or Height, or enter
a percentage for Scale Width or Scale Height.

NOTE When Lock Aspect is set to Yes, if you change either height or width,
the other automatically changes to maintain the current ratio between the
two. For example, if you change height to 50 percent, width automatically
changes to 50 percent. Set Lock Aspect to No if you want to change only
height or only width.

3 Click OK to apply changes.

To scale text in an OLE object according to its font

1 Select an OLE object.

2 Right-click. Click Text Size.

3 In the OLE Text Size dialog box, select a font.

The OLE Text Font list contains all of the fonts that appear in the selected
OLE object.

4 Select a point size.

The OLE Point Size list contains all of the sizes for the selected font.

5 In Text Height, enter a value in drawing units.

This value is the height for text in the selected font and point size. For
example, if you select Arial and 10 points, and then enter .5 in Text
Height, all text in the selected OLE object that is currently 10-point Arial
changes to 0.5 drawing units in height. All other text in the object
changes size in relation to the selected font. The size of the OLE object
adjusts to accommodate the new text sizes.

Export OLE Objects from Drawings
You can link or embed a view of a drawing in another application that supports
OLE.

1004 | Chapter 38   Link and Embed Data (OLE)



Link Views to Other Documents

A drawing can be a source document linked to one or more documents in
other applications. The  command copies the view in the current viewport to
the Clipboard. You can then paste the view into the destination document.

If you paste an unnamed view into a document, it is assigned a view name
such as OLE1. If you then exit the drawing, you are prompted to save your
changes to the newly named view. To establish the link and to save the view
name, OLE1, you must save the drawing.

Embed Drawing Objects in Other Documents

You can select objects and embed them in documents created by other
applications. Embedding places a copy of the selected objects in the destination
document. If you use AutoCAD to edit the OLE object from within the
destination document, the object is not updated in the original drawing.

To embed objects in another document

1 Click Edit menu ➤ Copy.

2 In the drawing area, select the objects that you want to embed and then
press  ENTER  .

The selected objects are copied to the Clipboard.

3 Start the destination application, and open a new or existing document.

4 Paste the Clipboard contents into the document, following the
destination application's instructions for embedding the Clipboard
contents.

To link a view to another document

1 Save the drawing that you want to link, so that it has a drawing name.

2 If multiple viewports are displayed, select a viewport.

3 Click Edit menu ➤ Copy Link.

The view is copied to the Clipboard.

4 Open a new or existing document in the destination application.

5 Paste the Clipboard contents into the document, following that
application's procedures for inserting linked data.

The inserted OLE object is displayed in the document and can be edited
from AutoCAD through the destination application.
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Edit OLE Objects in Drawings
You can edit a linked or embedded OLE object in a drawing by double-clicking
the object to open the source application.

You can use any selection method to select OLE objects and then use most
editing commands, the Properties palette, or grips to make changes. When
you use grips to change the size of an OLE object, the shape of the object does
not change if the aspect ratio is locked in the Properties palette. The following
editing commands are not available for OLE objects: , , , and .

When an OLE object is rotated or is not in Plan view, the content of the OLE
object is temporarily hidden and only the frame is displayed.

In the Properties palette, the general properties listed for an OLE object apply
to the frame.

Because grips are displayed on the frame, grip editing is not available if the
frame is not displayed. To display the frame, change the setting of the  system
variable.

Edit Information in OLE Objects

You can edit the information in linked or embedded OLE objects by
double-clicking the object to open the source application.

Edit OLE Objects When AutoCAD Is the Source Application

The document that contains a linked drawing stores the drawing's file location.
You can edit a linked drawing either from the destination application or in
the source program. The program must be loaded or accessible on the system
along with the document you are editing.

An AutoCAD drawing that is embedded in a document can be edited only
from within the destination application. Double-click the OLE object to start
the program. Editing the original drawing in the program has no effect on
documents in which that drawing is embedded.

See also:

“Copy Objects” on page 603

To edit a linked drawing from within the destination application

1 Open the document that contains the linked drawing (for example, a
Microsoft Word file).

2 Double-click the linked drawing.

The drawing opens.

1006 | Chapter 38   Link and Embed Data (OLE)



3 Modify the drawing as necessary.

4 Click File menu ➤ Save to save the changes to the drawing.

5 Click File menu ➤ Exit to return to the destination application.

The drawing is changed in all documents that have links to it.

How the link is updated depends on the destination application. Some
applications support automatic updating of links; others require manual
updating of links.

To edit a linked drawing in the source application

1 Start the program and open the linked drawing.

2 Modify the drawing and view as necessary.

3 Click File menu ➤ Save to save the changes to the drawing.

4 Update the link in the destination document if necessary.

The drawing is changed in all documents that have links to it.

How the link is updated depends on the destination application. Some
applications support automatic updating of links; others require manual
updating of links.

To edit embedded AutoCAD objects

1 Open the document that contains the embedded AutoCAD objects (for
example, a Microsoft Word file).

2 Double-click the embedded objects to start the program and display the
objects.

3 Modify the objects as necessary.

4 Click File menu ➤ Update to save changes to the embedded objects.

5 Click File menu ➤ Exit to return to the destination application.

To restore an OLE object to its original size and shape

1 Select the OLE object.

2 Right-click. Click OLE ➤ Reset.

The Reset option is also available in the Text Size dialog box.
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To control the display of OLE objects

1 At the Command prompt, enter olehide.

2 Enter one of the following values:

■ 0 Displays OLE objects in both paper space and model space.

■ 1 Displays OLE objects in paper space only.

■ 2 Displays OLE objects in model space only.

■ 3 Does not display OLE objects.

To turn the display of the frames of OLE objects on or off

1 At the Command prompt, enter oleframe.

2 Enter one of the following values:

■ 0 Frame is not displayed and not plotted.

■ 1 Frame is displayed and is plotted.

■ 2 Frame is displayed but is not plotted.

The frame must be displayed in order for grips to be visible.
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Glossary

 



Commands associated with definitions are shown in parentheses at the end
of the definition.

X,Y,Z point filters

See coordinate filters.

absolute coordinates

Coordinate values measured from a coordinate system’s origin point. See
also origin, relative coordinates, user coordinate system (UCS), world
coordinates, and world coordinate system (WCS).

acquired point

In the tracking or object snap tracking methods of locating a point, an
intermediate location used as a reference.

acquisition marker

During tracking or object snap tracking, the temporary plus sign displayed
at the location of an acquired point.

action

Defines how the geometry of a dynamic block reference will move or change
when the custom properties of a block reference are manipulated in a
drawing. A dynamic block definition usually contains at least one action
that is associated with a parameter. (BACTION)

activate

Part of the Autodesk software registration process. It allows you to run a
product in compliance with the product’s end-user license agreement.

adaptive sampling

A method to accelerate the anti-aliasing process within the bounds of the
sample matrix size. See also anti-aliasing.

affine calibration

A tablet calibration method that provides an arbitrary linear transformation
in two-dimensional space. Affine calibration requires three calibration points
to allow a tablet transformation that combines translation, independent X
and Y scaling, rotation, and some skewing. Use affine calibration if a drawing
has been stretched differently in the horizontal or vertical direction.
(TABLET)
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alias

A shortcut for a command. For example, CP is an alias for COPY, and Z is
an alias for ZOOM. You define aliases in the acad.pgpaclt.pgp file.

aliasing

The effect of discrete picture elements, or pixels, aligned as a straight or
curved edge on a fixed grid appearing to be jagged or stepped. See also
anti-aliasing.

aligned dimension

A dimension that measures the distance between two points at any angle.
The dimension line is parallel to the line connecting the dimension’s
definition points. (DIMALIGNED)

ambient color

A color produced only by ambient light.

ambient light

Light that illuminates all surfaces of a model with equal intensity. Ambient
light has no single source or direction and does not diminish in intensity
over distance.

angular dimension

A dimension that measures angles or arc segments and consists of text,
extension lines, and leaders. (DIMANGULAR)

angular unit

The unit of measurement for an angle. Angular units can be measured in
decimal degrees, degrees/minutes/seconds, grads, and radians.

annotations

Text, dimensions, tolerances, symbols, or notes.

anonymous block

An unnamed block created by a number of features, including associative
and nonassociative dimensions.

ANSI

For American National Standards Institute. Coordinator of voluntary standards
development for both private and public sectors in the United States.
Standards pertain to programming languages, Electronic Data Interchange
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(EDI), telecommunications, and the physical properties of diskettes,
cartridges, and magnetic tapes.

anti-aliasing

A method that reduces aliasing by shading the pixels adjacent to the main
pixels that define a line or boundary. See also “aliasing” on page 1015.

approximation points

Point locations that a B-spline must pass near, within a fit tolerance. See
also fit points and interpolation points.

array

1. Multiple copies of selected objects in a rectangular or polar (radial) pattern.
(ARRAY) 2. A collection of data items, each identified by a subscript or key,
arranged so a computer can examine the collection and retrieve data with
the key.

arrowhead

A terminator, such as an arrowhead, slash, or dot, at the end of a dimension
line showing where a dimension begins and ends.

sample
arrowheads

ASCII

For American Standard Code for Information Interchange. A common numeric
code used in computer data communications. The code assigns meaning
to 128 numbers, using seven bits per character with the eighth bit used for
parity checking. Nonstandard versions of ASCII assign meaning to 255
numbers.

aspect ratio

Ratio of display width to height.
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associative dimension

A dimension that automatically adapts as the associated geometry is
modified. Controlled by the DIMASSOC system variable. See also
nonassociative dimension and “exploded dimension ” on page 1026.

associative hatch

Hatching that conforms to its bounding objects such that modifying the
bounding objects automatically adjusts the hatch. (BHATCH)

attenuation

The diminishing of light intensity over distance.

attribute definition

An object that is included in a block definition to store alphanumeric data.
Attribute values can be predefined or specified when the block is inserted.
Attribute data can be extracted from a drawing and inserted into external
files. (ATTDEF)

attribute extraction file

An ASCII text file to which extracted attribute data is written. The contents
and format are determined by the attribute extraction template file. See also
attribute extraction template file.

attribute extraction template file

An ASCII text file that determines which attributes are extracted and how
they are formatted when written to an attribute extraction file. See also
“attribute extraction file” on page 1017.

attribute prompt

The text string displayed when you insert a block with an attribute whose
value is undefined. See also attribute definition, attribute tag, and attribute
value.

attribute tag

A text string associated with an attribute that identifies a particular attribute
during extraction from the drawing database. See also attribute definition,
attribute prompt , and attribute value.

attribute value

The alphanumeric information associated with an attribute tag. See also
attribute definition, attribute prompt, and attribute tag.
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AutoCAD library search path

The order in which looks for a support file: current directory, drawing
directory, directory specified in the support path, and directory containing
the executable file, acad.exe.

AutoCAD window

The drawing area, its surrounding menus, and the command line.

axis tripod

Icon with X, Y, and Z coordinates that is used to visualize the viewpoint
(view direction) of a drawing without displaying the drawing. (VPOINT)

B-spline curve

A blended piecewise polynomial curve passing near a given set of control
points. See also Bezier curve. (SPLINE)

back face

The opposite side of a front face. Back faces are not visible in a rendered
image. See also front faces.

base point

1. In the context of editing grips, the grip that changes to a solid color when
selected to specify the focus of the subsequent editing operation. 2. A point
for relative distance and angle when copying, moving, and rotating objects.
3. The insertion base point of the current drawing. (BASE) 4. The insertion
base point for a block definition. (BLOCK)

baseline

An imaginary line on which text characters appear to rest. Individual
characters can have descenders that drop below the baseline. See also baseline
dimension.

baseline dimension

Multiple dimensions measured from the same baseline. Also called parallel
dimensions. See also baseline.

Bezier curve

A polynomial curve defined by a set of control points, representing an
equation of an order one less than the number of points being considered.
A Bezier curve is a special case of a B-spline curve. See also B-spline curve.
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bitmap

The digital representation of an image having bits referenced to pixels. In
color graphics, a different value represents each red, green, and blue
component of a pixel.

blips

Temporary screen markers displayed in the drawing area when you specify
a point or select objects. (BLIPMODE)

block

A generic term for one or more objects that are combined to create a single
object. Commonly used for either block definition or block reference. See
also block definition and block reference. (BLOCK)

block authoring palettes

Tool palettes used in the Block Editor to add actions and parameters to
dynamic block definitions.

block authoring tools

Actions, parameters, and parameter sets on the tabs of the Block Authoring
Palettes window. Used in the Block Editor to create dynamic blocks.

block definition

The name, base point, and set of objects that are combined and stored in
the symbol table of a drawing. See also block and block reference.

block definition table

The nongraphical data area of a drawing file that stores block definitions.
See also named object.

block instance

See block reference.

block reference

A compound object that is inserted in a drawing and displays the data stored
in a block definition. Also called instance. See also block and block definition.
(INSERT)

bump map

A map in which brightness values are translated into apparent changes in
the height of the surface of an object.
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button menu

The menu for a pointing device with multiple buttons. Each button on the
pointing device (except the pick button) can be defined in the customization
file (acad.cui).

BYBLOCK

A special object property used to specify that the object inherits the color
or linetype of any block containing it. See also BYLAYER.

BYLAYER

A special object property used to specify that the object inherits the color
or linetype associated with its layer. See also BYBLOCK.

callout block

A block used as symbol to reference another sheet. Callout blocks have
many industry-specific terms, such as reference tags, detail keys, detail
markers, and so on. See also label block.

category

See view category.

Chain Actions

In a dynamic block definition, a property of point, linear, polar, XY, and
rotation parameters. When set to Yes, a change in an action that contains
the parameter in the action’s selection set triggers any actions associated
with that parameter, just as if you had edited the parameter in the block
reference through a grip or custom property.

circular external reference

An externally referenced drawing (xref) that references itself directly or
indirectly. The xref that creates the circular condition is ignored.

clipping planes

The boundaries that define or clip the field of view. (DVIEW)

CMYK

For cyan, magenta, yellow, and key color. A system of defining colors by
specifying the percentages of cyan, magenta, yellow, and the key color,
which is typically black.
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color map

A table defining the intensity of red, green, and blue (RGB) for each
displayed color.

command line

A text area reserved for keyboard input, prompts, and messages.

construction plane

A plane on which planar geometry is constructed. The XY plane of the
current UCS represents the construction plane. See also elevation and user
coordinate system (UCS).

continued dimension

A type of linear dimension that uses the second extension line origin of a
selected dimension as its first extension line origin, breaking one long
dimension into shorter segments that add up to the total measurement.
Also called chain dimension. (DIMCONTINUE)

control frame

A series of point locations used as a mechanism to control the shape of a
B-spline. These points are connected by a series of line segments for visual
clarity and to distinguish the control frame from fit points. The SPLFRAME
system variable must be turned on to display control frames.

control point

See control frame.

Coons patch

In 3D surface meshes, the bicubic surface (one curved in the M direction
and another in the N direction) interpolated between four edges.

coordinate filters

Functions that extract individual X, Y, and Z coordinate values from different
points to create a new, composite point. Also called X,Y,Z point filters.

crosshairs

A type of cursor consisting of two lines that intersect.

crosshairs
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crossing selection

A rectangular area drawn to select objects fully or partly within its borders.

CTB file

SA color-dependent plot style table.

cursor

See pointer and crosshairs.

cursor menu

See shortcut menu.

custom grips

In a dynamic block reference, used to manipulate the geometry and custom
properties.

custom object

A type of object that is created by an ObjectARX application and that
typically has more specialized capabilities than standard objects. Custom
objects include parametric solids (Autodesk Mechanical Desktop),
intelligently interactive door symbols (Autodesk Architectural Desktop),
polygon objects (Autodesk Map), and associative dimension objects
(AutoCAD and AutoCAD LT). See also proxy object and object enabler.

customization (CUI) file

An XML-based file that stores customization data. You modify a
customization file through the Customize User Interface dialog box. CUI
files replace MNU, MNS, and MNC files that were used to define menus in
releases prior to AutoCAD 2006.

default

A predefined value for a program input or parameter. Default values and
options for commands are denoted by angle brackets (<>).

default drawing

See initial environment.

definition points

Points for creating a dimension. The program refers to the points to modify
the appearance and value of a nonassociative dimension when the
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dimensioned object is modified. Also called defpoints and stored on the
special layer DEFPOINTS.

definition table

The nongraphical data area of a drawing file that stores block definitions.

dependency highlighting

In a dynamic block definition, how associated objects are displayed when
you select a parameter, grip, or action.

dependent named objects (in xrefs)

Named objects brought into a drawing by an external reference. See also
named object  and symbol table.

dependent symbols

See dependent named objects (in xrefs).

DIESEL

For Direct Interpretively Evaluated String Expression Language. A macro language
for altering the status line with the MODEMACRO system variable and for
customizing menu items.

diffuse color

An object’s predominant color.

dimension line arc

An arc (usually with arrows at each end) spanning the angle formed by the
extension lines of an angle being measured. The dimension text near this
arc sometimes divides it into two arcs. See also angular dimension.

dimension style

A named group of dimension settings that determines the appearance of
the dimension and simplifies the setting of dimension system variables.
(DIMSTYLE)

dimension text

The measurement value of dimensioned objects.

dimension variables

A set of numeric values, text strings, and settings that control dimensioning
features. (DIMSTYLE)
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direct distance entry

A method to specify a second point by first moving the cursor to indicate
direction and then entering a distance.

dithering

Combining color dots to give the impression of displaying more colors than
are actually available.

dockable window

A user interface element that can be either docked or floating in the drawing
area. Dockable windows include the command window, tool palettes,
Properties Palette, and so on.

drawing area

drawing area

The area in which your drawings are displayed and modified. The size of
the drawing area varies, depending on the size of the AutoCAD window
and on how many toolbars and other elements are displayed. See also
AutoCAD window.

drawing extents

The smallest rectangle that contains all objects in a drawing, positioned on
the screen to display the largest possible view of all objects. (ZOOM)

drawing extents

drawing limits

See grid limits.

drawing set

A collection of drawings assembled using the Publish dialog box.
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drawing template

A drawing file with preestablished settings for new drawings such as acad.dwt,
aclt.dwt and acadiso.dwt, acltiso.dwt; however, any drawing can be used as
a template. See also initial environment.

DSD

For drawing set descriptions. A file format for saving a description of a drawing
set that has been assembled using the Publish dialog box.

DST

For sheet set data. The XML file format used to store the associations and
information that define a sheet set.

DWF

For Design Web Format. A highly compressed file format that is created from
a DWG file. DWF files are easy to publish and view on the Web. See also
DWG and DXF.

DWG

Standard file format for saving vector graphics. See also DWF and DXF.

DXF

For drawing interchange format. An ASCII or binary file format of a drawing
file for exporting drawings to other applications or for importing drawings
from other applications. See also DWF and DWG.

edge

The boundary of a face.

electronic drawing set

The digital equivalent of a set of plotted drawings. You create an electronic
drawing set by publishing drawings to a DWF file.

elevation

The default Z value above or below the XY plane of the current user
coordinate system, which is used for entering coordinates and digitizing
locations. (ELEV)
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elevation

Y

X

embed

To use object linking and embedding (OLE) information from a source
document in a destination document. An embedded object is a copy of the
information from a source document that is placed in the destination
document and has no link to the source document. See also link.

enterprise customization file

A CUI file that is typically controlled by a CAD manager. It is often accessed
by many users and is stored in a shared network location. The file is
read-only to users to prevent the data in the file from being changed. A
CAD manager creates an enterprise CUI file by modifying a main CUI file
and then saving the file to the support location defined in the Options
dialog box, Files tab.

environment variable

A setting stored in the operating system that controls the operation of a
program.

explode

To disassemble a complex object, such as a block, dimension, solid, or
polyline, into simpler objects. In the case of a block, the block definition
is unchanged. The block reference is replaced by the components of the
block. See also block, block definition, and block reference. (EXPLODE)

exploded dimension

Independent objects that have the appearance of a dimension but are not
associated with the dimensioned object or each other. Controlled by the
DIMASSOC system variable. See also associative dimension, nonassociative
dimension, and explode. (EXPLODE)

extents

See drawing extents.
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external reference (xref)

A drawing file referenced by another drawing. (XREF)

extrusion

A 3D solid created by sweeping an object that encloses an area along a linear
path.

face

A triangular or quadrilateral portion of a surface object.

feature control frame

The tolerance that applies to specific features or patterns of features. Feature
control frames always contain at least a geometric characteristic symbol to
indicate the type of control and a tolerance value to indicate the amount
of acceptable variation.

fence

A multisegmented line specified to select objects it passes through.

field

A specialized text object set up to display data that may change during the
life cycle of the drawing. When the field is updated, the latest value of the
field is displayed. (FIELD)

fill

A solid color covering an area bounded by lines or curves. (FILL)

filters

See coordinate filters.

fit points

Locations that a B-spline must pass through exactly or within a fit tolerance.
See also interpolation points and approximation points.

fit tolerance

The setting for the maximum distance that a B-spline can pass for each of
the fit points that define it.

floating viewports

See layout viewports.
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font

A character set, comprising letters, numbers, punctuation marks, and
symbols of a distinctive proportion and design.

freeze

A setting that suppresses the display of objects on selected layers. Objects
on frozen layers are not displayed, regenerated, or plotted. Freezing layers
shortens regenerating time. See also thaw. (LAYER)

front faces

Faces with their normals pointed outward.

geometry

All graphical objects such as lines, circles, arcs, polylines, and dimensions.
Nongraphical objects, such as linetypes, lineweights, text styles, and layers
are not considered geometry. See also named object.

graphics area

See drawing area.

graphics screen

See drawing area

graphics window

See AutoCAD window and drawing area.

grid

An area covered with regularly spaced dots to aid drawing. The spacing
between grid dots is adjustable. Grid dots are not plotted. See also grid limits.
(GRID)

grid limits

The user-defined rectangular boundary of the drawing area covered by dots
when the grid is turned on. Also called drawing limits. (LIMITS)
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grid limits

grip modes

The editing capabilities activated when grips are displayed on an object:
stretching, moving, rotating, scaling, and mirroring.

grips

Small squares that appear on objects you select. After selecting the grip, you
edit the object by dragging it with the pointing device instead of entering
commands.

handle

A unique alphanumeric tag for an object in the program’s database.

HDI

For Heidi Device Interface. An interface for developing device drivers that are
required for peripherals to work with the program and other Autodesk
products.

HLS

For hue, lightness, and saturation. A system of defining color by specifying
the amount of hue, lightness, and saturation.

home page

The main navigating screen for a Web site.

i-drop

A method by which a drawing file can be dragged from a Web page and
inserted into another drawing.

IGES

For Initial Graphics Exchange Specification. An ANSI-standard format for digital
representation and exchange of information between CAD/CAM systems.
See also ANSI.

 | 1029



initial environment

The variables and settings for new drawings as defined by the default
drawing template, such as acad.dwg, aclt.dwg or acadiso.dwg, acltiso.dwg. See
also template drawing.

input property

In a dynamic block definition, a parameter property other than that of a
lookup, alignment, or base point parameter that you can add as a column
to a lookup table. When the parameter values in a dynamic block reference
match a row of input property values, the corresponding lookup property
values in that table row are assigned to the block reference.
(BLOOKUPTABLE)

interface element

A user interface object that can be customized, such as a toolbar, pull-down
menu, shortcut key, dockable window, and so on.

interpolation points

Defining points that a B-spline passes through. See also approximation
points and fit points.

island

An enclosed area within another enclosed area. Islands may be detected as
part of the process of creating hatches, polylines, and regions. (BHATCH,
BOUNDARY)

ISO

For International Standards Organization. The organization that sets
international standards in all fields except electrical and electronics.
Headquarters are in Geneva, Switzerland.

isometric snap style

A drafting option that aligns the cursor with two of three isometric axes
and displays grid points, making isometric drawings easier to create.

key point

In a dynamic block definition, the point on a parameter that drives its
associated action when edited in the block reference.
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label block

A block used to label views and details. Labels contain data, such as a title,
view number, and scale, that is associated with the referenced view. See also
callout block.

layer

A logical grouping of data that are like transparent acetate overlays on a
drawing. You can view layers individually or in combination. (LAYER)

layer index

A list showing the objects on each layer. A layer index is used to locate what
portion of the drawing is read when you partially open a drawing. Saving
a layer index with a drawing also enhances performance when you work
with external references. The INDEXCTL system variable controls whether
layer and spatial indexes are saved with a drawing.

layer translation mappings

Assignments of a set of layers to another set of layers that defines standards.
These standards include layer names and layer properties. Also called layer
mappings.

layout

The tabbed environment in which you create and design paper space layout
viewports to be plotted. Multiple layouts can be created for each drawing.

layout viewports

Objects that are created in paper space that display views. See also paper
space. (VPORTS)

limits

See drawing limits.

line font

See linetype.

linetype

How a line or type of curve is displayed. For example, a continuous line has
a different linetype than a dashed line. Also called line font. (LINETYPE)
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lineweight

A width value that can be assigned to all graphical objects except TrueType®

fonts and raster images.

link

To use object linking and embedding (OLE) to reference data in another
file. When data is linked, any changes to it in the source document are
automatically updated in any destination document. See also embed.

lookup property

In a dynamic block definition, a lookup parameter that you add to a lookup
table. The lookup parameter label is used as the property name. When the
parameter values in a dynamic block reference match a row of input property
values, the corresponding lookup property values in that table row are
assigned to the block reference. (BLOOKUPTABLE)

lookup table

Defines properties for and assigns property values to a dynamic block.
Assigns property values to the dynamic block reference based on how the
block is manipulated in a drawing. (BLOOKUPTABLE)

main customization file

A writable CUI file that defines most of the user interface elements (including
the standard menus, toolbars, keyboard accelerators, and so on). The acad.cui
file (the default main CUI file) is automatically loaded when you start
AutoCAD.

markup

A single comment or a redline geometry correction inserted into a DWF file
using Autodesk DWF Composer.

markup set

A group of markups contained within a single DWF file.

mirror

To create a new version of an existing object by reflecting it symmetrically
with respect to a prescribed line or plane. (MIRROR)

mode

A software setting or operating state.
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model

A two- or three-dimensional representation of an object.

model space

One of the two primary spaces in which objects reside. Typically, a geometric
model is placed in a three-dimensional coordinate space called model space.
A final layout of specific views and annotations of this model is placed in
paper space. See also paper space. (MSPACE)

model viewports

A type of display that splits the drawing area into one or more adjacent
rectangular viewing areas. See also layout viewports, TILEMODE, and
viewport. (VPORTS)

multi-sheet DWF

A DWF file that contains multiple sheets.

named object

Describes the various types of nongraphical information, such as styles and
definitions, stored with a drawing. Named objects include linetypes, layers,
dimension styles, text styles, block definitions, layouts, views, and viewport
configurations. Named objects are stored in definition (symbol) tables.

named objects, dependent

See dependent named objects (in xrefs).

named view

A view saved for restoration later. (VIEW)

node

An object snap specification to locate points, dimension definition points,
and dimension text origins.

nonassociative dimension

A dimension that does not automatically change as the associated geometry
is modified. Controlled by the DIMASSOC system variable. See also
associative dimension and exploded dimension.

normal

A vector that is perpendicular to a face.
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noun-verb selection

Selecting an object first and then performing an operation on it rather than
entering a command first and then selecting the object.

NURBS

For nonuniform rational B-spline curve. A B-spline curve or surface defined by
a series of weighted control points and one or more knot vectors. See also
B-spline curve.

object

One or more graphical elements, such as text, dimensions, lines, circles, or
polylines, treated as a single element for creation, manipulation, and
modification. Formerly called entity.

object enabler

A tool that provides specific viewing and standard editing access to a custom
object when the ObjectARX application that created the custom object is
not present. See also custom object and proxy object.

Object Snap mode

Methods for selecting commonly needed points on an object while you
create or edit a drawing. See also running object snap and object snap
override.

object snap override

Turning off or changing a running Object Snap mode for input of a single
point. See also Object Snap mode and running object snap.

ObjectARX (AutoCAD Runtime Extension)

A compiled-language programming environment for developing AutoCAD
applications.

OLE

For object linking and embedding. An information-sharing method in which
data from a source document can be linked to or embedded in a destination
document. Selecting the data in the destination document opens the source
application so that the data can be edited. See also embed and link.

opacity map

Projection of opaque and transparent areas onto objects, creating the effect
of a solid surface with holes or gaps.
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origin

The point where coordinate axes intersect. For example, the origin of a
Cartesian coordinate system is where the X, Y, and Z axes meet at 0,0,0.

Ortho mode

A setting that limits pointing device input to horizontal or vertical (relative
to the current snap angle and the user coordinate system). See also snap
angle and user coordinate system (UCS).

orthogonal

Having perpendicular slopes or tangents at the point of intersection.

page setup

A collection of plot device and other settings that affect the appearance and
format of the final output. These settings can be modified and applied to
other layouts.

pan

To shift the view of a drawing without changing magnification. See also
zoom. (PAN)

paper space

One of two primary spaces in which objects reside. Paper space is used for
creating a finished layout for printing or plotting, as opposed to doing
drafting or design work. You design your paper space viewports using a
layout tab. Model space is used for creating the drawing. You design your
model using the Model tab. See also model space and viewpoint. (PSPACE)

parameter

In a dynamic block definition, defines custom properties for the dynamic
block by specifying positions, distances, and angles for geometry in the
block.

parameter set

A tool on the Parameter Sets tab of the Block Authoring Palettes window
that adds one or more parameters and one or more associated actions to
the dynamic block definition.

partial customization file

Any CUI file that is not defined as the main CUI file. You can load and
unload partial CUI files as you need them during a drawing session.
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PC2 file

Complete plotter configuration file. PC2 files contain all plot settings and
device-specific settings that were saved in previous versions. See also PCP
file and PC3 file.

PC3 file

Partial plotter configuration file. PC3 files contain plot settings information
such as the device driver and model, the output port to which the device
is connected, and various device-specific settings, but do not include any
custom plotter calibration or custom paper size information. See also PMP
file, STB file, and CTB file.

PCP file

Partial plotter configuration file. PCP files contain basic plot specifications
and pen parameters that were saved in previous versions. Plot settings that
are stored in a PCP file include pen assignments, plotting units, paper size,
plot rotation, plot origin, scale factor, and pen optimization level. See also
PC2 file and PC3 file.

personalization

Customizes the executable file acad.exeaclt.exe during installation, by
entering the user name, company, and other information.

perspective view

Objects in 3D seen by an observer positioned at the viewpoint looking at
the view center. Objects appear smaller when the distance from the observer
(at the view point) to the view center increases. Although a perspective view
appears realistic, it does not preserve the shapes of objects. Parallel lines
seemingly converge in the view, so measurements cannot be made to scale
from perspective views. The program has perspective view settings for
VPORTS table entries as well as viewport objects. When you are looking at
a viewport with a perspective view, the UCS icon has a different appearance.

photorealistic rendering

Rendering that resembles a photograph.

pick button

The button on a pointing device that is used to select objects or specify
points on the screen. For example, on a two-button mouse, it is the left
button.
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plan view

A view orientation from a point on the positive Z axis toward the origin
(0,0,0). (PLAN)

plan view

planar projection

Mapping of objects or images onto a plane.

pline

See polyline.

plot style

An object property that specifies a set of overrides for color, dithering, gray
scale, pen assignments, screening, linetype, lineweight, endstyles, joinstyles,
and fill styles. Plot styles are applied at plot time.

plot style table

A set of plot styles. Plot styles are defined in plot style tables and apply to
objects only when the plot style table is attached to a layout or viewport.

PMP file

Plot Model Parameter. File containing custom plotter calibration and custom
paper size information associated with plotter configuration file.

point

1. A location in three-dimensional space specified by X, Y, and Z coordinate
values. 2. An object consisting of a single coordinate location. (POINT)

point filters

See coordinate filters.
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pointer

A cursor on a video display screen that can be moved around to place textual
or graphical information. See also crosshairs.

polar array

Objects copied around a specified center point a specified number of times.
(ARRAY)

Polar Snap

A precision drawing tool used to snap to incremental distances along the
polar tracking alignment path. See also polar tracking.

polar tracking

A precision drawing tool that displays temporary alignment paths defined
by user-specified polar angles. See also Polar Snap.

polygon window selection

A multisided area specified to select objects in groups. See also crossing
selection and window selection.

polyline

An object composed of one or more connected line segments or circular
arcs treated as a single object. Also called pline. (PLINE, PEDIT)

procedural materials

Materials that generate a 3D pattern in two or more colors, and apply it to
an object. These include marble, granite, and wood. Also called template
materials.

prompt

A message on the command line that asks for information or requests action
such as specifying a point.

proxy object

A substitute for a custom object when the ObjectARX application that
created the custom object is not available. See also custom object and object
enabler.

PWT

A template file format used to publish drawings to the Web.
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redraw

To quickly refresh or clean up blip marks in the current viewport without
updating the drawing’s database. See also regenerate. (REDRAW)

reference

A definition, known as an external reference or block reference, that is used
and stored in the drawing. See also block (BLOCK) and external reference
(xref). (XREF)

reflection color

The color of a highlight on shiny material. Also called specular color.

reflection line

In a dynamic block reference, the axis about which a flip action's selection
set flips when the associated parameter is edited through a grip or the
Properties palette.

reflection mapping

Creates the effect of a scene reflected on the surface of a shiny object.

regenerate

To update a drawing’s screen display by recomputing the screen coordinates
from the database. See also redraw. (REGEN)

relative coordinates

Coordinates specified in relation to previous coordinates.

resource drawing

A drawing that is used as a data resource for the sheet set. You can place a
saved model space view from a resource drawing onto a sheet.

return button

The button on a pointing device used to accept an entry. For example, on
a two-button mouse, it is the right button.

reverse lookup

Adds a lookup grip to a dynamic block reference. When you click this grip,
a drop-down list of the lookup values for that lookup property (column in
the lookup table) is displayed. When you select a value from the list, the
corresponding input property values are assigned to the block reference.
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Depending on how the block was defined, this usually results in a change
in the block reference's geometry. (BLOOKUPTABLE)

RGB

For red, green, and blue. A system of defining colors by specifying percentages
of red, green, and blue.

rubber-band line

A line that stretches dynamically on the screen with the movement of the
cursor. One endpoint of the line is attached to a point in your drawing, and
the other is attached to the moving cursor.

running object snap

Setting an Object Snap mode so it continues for subsequent selections. See
also Object Snap mode and object snap override. (OSNAP)

save back

To update the objects in the original reference (external or block reference)
with changes made to objects in a working set during in-place reference
editing.

script file

A set of commands executed sequentially with a single SCRIPT command.
Script files are created outside the program using a text editor, saved in text
format, and stored in an external file with the file extension .scr.

selection set

One or more selected objects that a command can act upon at the same
time.

In a dynamic block definition, the geometry associated with an action.

ShapeManager

The technology used to produce 3D solids.

sheet

A layout selected from a drawing file and assigned to a sheet set. See also
sheet set.

sheet list table

A table listing all sheets in a sheet set. A sheet list table can be generated
automatically with the Sheet Set Manager.
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sheet selection

A named selection of sheets in a sheet set that can be conveniently recalled
for archiving, transmitting, and publishing operations.

sheet set

An organized and named collection of sheets from several drawing files. See
also sheet. (SHEETSET)

shortcut keys

Keys and key combinations that start commands; for example,  CTRL +  S
saves a file. The function keys (F1, F2, and so on) are also shortcut keys.
Also known as accelerator keys.

shortcut menu

The menu displayed at your cursor location when you right-click your
pointing device. The shortcut menu and the options it provides depend on
the pointer location and other conditions, such as whether an object is
selected or a command is in progress.

slide file

A file that contains a raster image or snapshot of the objects displayed in
the drawing area. Slide files have the file extension .sld. (MSLIDE, VSLIDE)

slide library

A collection of slide files organized for convenient retrieval and display.
Slide library names have the extension .slb and are created with the
slidelib.exe utility.

smooth shading

Smoothing of the edges between polygon faces.

snap angle

The angle that the snap grid is rotated.

snap grid

The invisible grid that locks the pointer into alignment with the grid points
according to the spacing set by Snap. Snap grid does not necessarily
correspond to the visible grid, which is controlled separately by GRID.
(SNAP)
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Snap mode

A mode for locking a pointing device into alignment with an invisible
rectangular grid. When Snap mode is on, the screen crosshairs and all input
coordinates are snapped to the nearest point on the grid. The snap resolution
defines the spacing of this grid. See also Object Snap mode. (SNAP)

snap resolution

The spacing between points of the snap grid.

spatial index

A list that organizes objects based on their location in space. A spatial index
is used to locate what portion of the drawing is read when you partially
open a drawing. Saving a spatial index with a drawing also enhances
performance when working with external references. The  system variable
controls whether layer and spatial indexes are saved with a drawing.

specular reflection

The light in a narrow cone where the angle of the incoming beam equals
the angle of the reflected beam.

STB file

For plot style table file. Contains plot styles and their characteristics.

stretch frame

In a dynamic block definition that contains a stretch action or a polar stretch
action, determines how the objects within or crossed by the frame are edited
in the block reference.

Subscription Center

A resource available from the Help menu for subscription members to access
the latest releases of Autodesk software, incremental product enhancements,
personalized web support, and self-paced e-Learning.

subset

A named collection of sheets in a sheet set that is often organized by
discipline or workflow stage. See also view category.

symbol

A representation of an item commonly used in drawings. Symbols are
inserted in drawings as blocks.
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symbol library

A collection of block definitions stored in a single drawing file.

symbol table

See definition table and block definition table.

system variable

A name that is recognized as a mode, size, or limit. Read-only system
variables, such as DWGNAME, cannot be modified directly by the user.

table

A rectangular array of cells that contain annotation, primarily text but also
blocks. In the AEC industry, tables are often referred to as “schedules” and
contain information about the materials needed for the construction of the
building being designed. In the manufacturing industry, they are often
referred to as “BOM” (bills of materials). (TABLE)

temporary files

Data files created during an program session. The files are deleted by the
time you end the session. If the session ends abnormally, such as during a
power outage, temporary files might be left on the disk.

tessellation lines

Lines that help you visualize a curved surface.

tessellation
lines

text style

A named, saved collection of settings that determines the appearance of
text characters—for example, stretched, compressed, oblique, mirrored, or
set in a vertical column.

texture map

The projection of an image (such as a tile pattern) onto an object (such as
a chair).

 | 1043



thaw

A setting that displays previously frozen layers. See also freeze. (LAYER)

thickness

The distance certain objects are extruded to give them a 3D appearance.
(PROPERTIES, CHPROP, ELEV, THICKNESS)

tiled viewports

See model viewports.

TILEMODE

A system variable that controls whether viewports can be created as movable,
resizable objects (layout viewports), or as nonoverlapping display elements
that appear side-by-side (model viewports). See also viewport.

toolbar

Part of the interface containing icons that represent commands.

tracking

A way to locate a point relative to other points on the drawing.

transparent command

A command started while another is in progress. Precede transparent
commands with an apostrophe.

UCS

See user coordinate system (UCS).

UCS icon

An icon that indicates the orientation of the UCS axes. (UCSICON)

UCS icon

user coordinate system (UCS)

A user-defined coordinate system that defines the orientation of the X, Y,
and Z axes in 3D space. The UCS determines the default placement of
geometry in a drawing. See also world coordinate system (WCS).

1044 | Glossary



value set

In a dynamic block definition, a range or list of values specified for a linear,
polar, XY, or rotation parameter.

vector

A mathematical object with precise direction and length but without specific
location.

vertex

A location where edges or polyline segments meet.

view

A graphical representation of a model from a specific location (viewpoint)
in space. See also viewpoint and viewport. (VPOINT, DVIEW, VIEW)

view category

A named collection of views in a sheet set that is often organized by
function. See also subset.

viewpoint

The location in 3D model space from which you are viewing a model. See
also view and viewport. (DVIEW, VPOINT)

viewport

A bounded area that displays some portion of the model space of a drawing.
The TILEMODE system variable determines the type of viewport created.
1. When TILEMODE is off (0), viewports are objects that can be moved and
resized on a layout. (MVIEW) 2. When TILEMODE is on (1), the entire
drawing area is divided into nonoverlapping model viewports. See also
TILEMODE, view, and viewpoint. (VPORTS)

viewport configuration

A named collection of model viewports that can be saved and restored.
(VPORTS)

virtual screen display

The area in which the program can pan and zoom without regenerating
the drawing.
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visibility mode

Displays or does not display geometry (in a dimmed state) that is invisible
for a visibility state. (BVMODE)

visibility state

In a dynamic block, a custom property that allows only specified geometry
to display in the block reference. (BVSTATE)

volumetric shadows

A photorealistically rendered volume of space cast by the shadow of an
object.

WCS

See world coordinate system (WCS).

window selection

A rectangular area specified in the drawing area to select multiple objects
at the same time. See also crossing selection, polygon window selection.

wipeout object

A polygonal area that masks underlying objects with the current background
color. This area is bounded by the wipeout frame, which you can turn on
for editing and turn off for plotting.

wireframe model

The representation of an object using lines and curves to represent its
boundaries.

working drawing

A drawing for manufacturing or building purposes.

working set

A group of objects selected for in-place reference editing.

workspace

A set of menus, toolbars and dockable windows (such as the Properties
palette, DesignCenter, and the Tool palettes window) that are grouped and
organized so that you can work in a custom, task-oriented drawing
environment.
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world coordinate system (WCS)

A coordinate system used as the basis for defining all objects and other
coordinate systems. See also user coordinate system (UCS).

world coordinates

Coordinates expressed in relation to the world coordinate system (WCS).

WCS icon

xref

See external reference (xref).

zoom

To reduce or increase the apparent magnification of the drawing area.
(ZOOM)
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# (pound sign).....280, 336, 338, 717, 745
absolute coordinates entry in pointer

input.....336
prefix in pointer input, accessing.....

338
stacked text indicator.....717
wild-card character.....280, 745

#### (pound signs).....725, 769
formula error display.....769
invalid field display.....725

$ (dollar sign).....769, 973
bound named object name dividers...

973
formula cell address fix value prefix...

769
$#$, bound xref name prefix.....981
(L) least material condition symbol.....837
* (asterisk).....338, 745

prefix in pointer input, accessing.....
338

wild-card character.....745
* (asterisk), wild-card character.....280
+ (plus sign).....65, 356–357

DesignCenter tree view level display
button.....65

tracking points marker.....356–357
, (comma).....772

formula argument delimiter.....772
- (hyphen), dialog box suppression

character.....56
- (minus sign), DesignCenter tree view

level display button.....65
---- (hyphens).....725

no value in field display.....725
-PLOT command.....873
. (period).....745

wild-card character.....745
. (period), wild-card character.....280
.dws extension for standards files.....138
.dxx file name extension.....559
/ (forward slash), stacked text indicator....

717

/b command line switch.....84
/c command line switch.....85
/ld command line switch.....85
/nologo command line switch.....85
/nossm command line switch.....86
/p command line switch.....85
/r command line switch.....85
/s command line switch.....85
/set command line switch.....86
/t command line switch.....85
/v command line switch.....85
= (equal sign).....769, 772

formula start character.....769, 772
>custom grips

in dynamic blocks. See grips (for
parameters) (custom grips)

? (question mark).....280, 745
wild-card character.....280, 745

@ (at sign)...280, 315–316, 319, 321–322, 
635, 745

break point without a gap symbol.....
635

relative coordinate specifier.....315–
316, 319, 321–322

wild-card character.....280, 745
^ (caret).....717

stacked text indicator.....717
{ } (braces, open and close).....752

format codes for.....752
| (vertical bar).....973

dependent named object name
divider.....973

~ (tilde).....280, 745, 750
incorrect word flag.....750
wild-card character.....280, 745

2D Cartesian coordinates (X, Y
coordinates).....266, 312–315, 
354–355

absolute values.....312, 314–315
coordinate values.....266

1049 | Index



entering.....314–315
with coordinate filters....354–355

point locations, displaying.....313
point values, displaying.....313
relative values.....312, 315
X, Y values.....314

2D coordinates.....312, 316
polar coordinates.....312, 316

2D solids.....306–307, 688, 694, 779
and associative dimensioning.....779
creating.....688
modifying.....694
simplified display.....306–307

2D UCS icon.....333
3D arrays.....607, 609–610

creating.....607, 609–610
3D blocks.....463

Block Editor and.....463
3D Cartesian coordinates (X, Y, Z

coordinates).....167, 266, 313, 
318–320, 354–355

absolute values.....319–320
defining 3D views with.....167
displaying coordinate values.....266
entering.....318–320

by digitizing.....319
with coordinate filters....354–355

point locations, displaying.....313
point values, displaying.....313
relative values.....319–320
Z value defaults.....319

3D command.....429, 433
3D coordinates.....320–323

cylindrical coordinates.....320–321
spherical coordinates.....322–323

3D DWF files.....948, 950
publishing.....948
viewing and printing published

files.....948, 950
3D DWF Publishing.....948

installing.....948
3D DWF publishing.....921
3D edges. See edges (of 3D solids)
3D faces.....429
3D graphics, display options.....174
3D isometric views.....166

3D modeling.....424–426
methods.....425

mixing.....426
uses.....424

3D models (images).....424, 426
types.....424

converting between.....426
3D objects

arraying.....607, 609
clipping.....170

in 3D Orbit view.....185
creating.....424
curved, smoothness.....438
graphics display options.....174
hidden lines. See hidden lines (in 3D

objects)
See also 3D solids
See also surface meshes
See also wireframes
slices, creating.....185
viewing.....170, 173, 920, 922, 940, 

948, 950
dynamically.....170

wireframes.....1046
3D Orbit commands.....177, 179

accessing from the command line.....
179

3D Orbit view.....173–174, 176–182, 184–
187

arcball.....173, 179
camera distance.....176
clipping planes....170–171, 185–187, 

1020
adjusting.....185–186
turning on/off.....185, 187

continuous orbit.....178
editing views while active.....178
starting.....178

cursor icons.....179
displaying lights, materials, textures,

and transparency in.....174
graphics display options.....174
panning in.....180
parallel projections.....182
perspective views.....182
preset views.....179, 185
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resetting.....179, 185
shading modes.....182
shading objects.....177
visual aids.....177

displaying.....184
zooming in.....181

to the drawing extents.....181
using zoom windows.....181

3D solids.....185, 429, 438–447, 463, 655–
658, 668–670

adding.....442, 446
analyzing.....438
boxes.....439, 443
chamfering.....657
checking.....670
cleaning up.....670
combining.....442, 446–447
composite solids.....442, 446–447

separating.....669
cones.....439, 444
creating.....438
curved, smoothness.....438
cylinders.....439, 444
dishes.....440
domes.....440
exploding.....438
exporting.....42, 87, 147, 285, 438, 

762, 1004
data about.....438

filleting.....656
imprinting objects on.....668
in dynamic blocks.....463
intersections.....443, 447
lemon-shaped solids.....440
modifying.....438, 655
properties.....429, 438
revolved solids.....442, 446
sectioning.....657–658
shelling.....656, 669
slicing.....185

in 3D Orbit view.....185
spheres.....445
subtracting.....443, 446
torus/tori.....440, 445
validating.....670
wedges.....441, 445

3D solids, calculating total area.....365
3D space.....166, 170, 326, 328–329, 342, 

600, 614, 618–620, 628, 656
defining UCSs in.....328
drawing planes in.....326

specifying.....326
dynamic viewing.....170
entering coordinates in.....326
extending objects in.....618–619
filleting objects in.....628, 656
mirroring objects in.....614
relocating UCSs in.....326
rotating objects in.....600
trimming objects in.....618, 620
using object snaps in.....342
viewpoints in.....166

3D surface meshes, predefined....429, 433
creating.....433

3D UCS icon.....178, 333–334
changing the appearance of.....334

3D views.....166–171, 173, 175–176, 307, 
326, 328, 331

architectural vs. mechanical design
conventions.....167

changing to plan views.....169
defining.....167
dynamic viewing.....170
Fill mode option.....307
isometric views.....166
multiple viewports in....326, 328, 331
positioning the camera.....175–176
preset views.....166–167
restoring the default view.....169, 171
rotating.....167
setting.....138, 168, 185–186, 753, 

807–808, 848, 854–855, 877–
878, 881–883, 938

with angles of rotation.....168
with viewpoint coordinate....168

specifying.....166
interactively.....173

3DARRAY command.....607
3DDWFPUBLISH command.....921, 948

in network and stand-alone
installations.....921

3DFACE command.....429, 435
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3DMESH command.....429, 434
3DORBIT command...173–175, 178, 180, 

182
CAMERA command and.....175
displaying lights, materials, textures,

and transparency.....174
exiting.....180, 182
graphics display options.....174
GRID command and.....178

A

absolute coordinates...312, 314–317, 319–
320, 336, 338, 1014

entering.....312
Cartesian.....314–315, 319–320
polar.....316–317

entering, in pointer input tooltips.....
338

specifying in pointer input.....336
absolute paths.....983

for xrefs.....983
absolute value function (in QuickCalc).....

372
absolute world coordinate system (WCS)

coordinates.....338
entering, in pointer input tooltips.....

338
acad.err file.....128
acad.exe.....86

command line switches.....86
accuracy. See precision
ACI colors (numbers).....287–288

setting (for new objects).....288
acquired points.....1014
acquisition marker.....1014
action.....1014
action override properties.....507–508

specifying.....507–508
action selection sets.....488, 504, 508, 539

assigning actions to.....508
for array actions.....504

including parameters in.....504
modifying.....539

actions

for dynamic blocks. See actions (for
dynamic blocks)

redoing.....590–591
undoing. See undoing actions

actions (for dynamic blocks)
adding to dynamic block

definitions.....460, 462, 474, 
488

array actions.....503, 505
flip actions.....502–503
lookup actions.....506, 521
move actions.....489, 491
polar stretch actions.....497–498
rotate actions.....499, 501
scale actions.....492–493
stretch actions.....494–495
specifying text color.....472
specifying text size.....471
updating text size.....473

assigning to parameters.....488, 510
array actions.....503, 505
flip actions.....502–503
lookup actions.....506, 521
move actions.....489, 491
polar stretch actions.....497–498
rotate actions.....499, 501
scale actions.....492–493
stretch actions.....494–495

assigning to selection sets.....508
deleting from parameters/parameter

sets.....469
dependencies (dynamic block element

relationships).....462, 474
dependency highlighting.....471

turning on/off.....473
as displayed in the Block Editor....470
override properties.....507

specifying.....507–508
parameters supported by.....489
selection sets. See action selection sets
types....426, 474, 476, 489, 510, 549, 

891
by parameter type.....474, 476
parameter types supported by.....

489
actions, click actions in tree views.....236
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activate.....1014
Adaptive Adjustment option (Plot Style

Table Editor).....907
adaptive sampling.....1014
Add-a-Plotter wizard.....870
adding...25, 366, 368, 422–423, 442, 446, 

574
3D solids.....442, 446
areas.....366, 368
regions.....422–423
tool flyouts.....25

Adjust Clipping Planes window.....185
Adobe PostScript driver.....916
Advanced Setup wizard.....104

starting drawings.....104
Aerial View window.....158–160

displaying the entire drawing in.....
160

panning with.....158–160
resizing the image in.....159–160
updating the image in.....159–160
updating viewports in.....160
view box.....158
zooming with.....158–160

affine calibration.....1014
alias.....1015
aliases.....52

entering commands with.....52
aliasing.....1015
aligned dimensions

creating.....811
extension line origins.....809
See also dimensions

aligning.....225–226, 347, 360–363, 602–
603, 699, 701, 705, 723, 753, 
764, 792, 795, 804, 806, 829

dimension text....698, 777, 789–798, 
827–829, 1023

with dimension lines.....792, 795
hatch patterns.....347
lateral tolerances.....804, 806
leader text.....723
objects.....22–23, 35, 121, 123, 185, 

211, 218, 222, 226, 264, 266–
267, 270–271, 275–276, 281, 
287–288, 290, 297–298, 305, 

308–309, 343, 352–353, 360–
363, 365, 389, 439–442, 445–
447, 457, 461, 470, 546, 568, 
574–575, 577–578, 581, 589, 
592–605, 610–615, 617–624, 
628–633, 635–644, 646, 656, 
668, 681, 696, 734, 870, 974, 
979–980, 998, 1001, 1003, 
1005, 1022, 1034, 1038

in different layout viewports.....
226

marking equal segments on other
objects.....360, 362–363

marking measured intervals on
other objects.....360–361

text.....55, 199–200, 308, 613, 698–
699, 701, 703, 705, 707, 724, 
732, 741–743, 745–746, 748, 
753, 765–766, 827, 829

multiline text.....705, 753
single-line text.....699, 701

text, in tables.....764
views, in layout viewports.....225

aligning, text, multiline text.....706
alignment grips.....510, 549
alignment parameters.....474, 476, 484

actions supported by.....474, 476
adding to dynamic block

definitions.....484
grip type.....474

alignment paths.....350
displaying.....350

alignment paths (AutoTrack).....356–357
in object snap tracking.....356–357

alternate units (for dimensions).....797, 
799–800

adding and formatting.....800
conversion values.....799
symbol for.....797, 799

alternative font.....738–739, 752
specifying.....738–739

format code.....752
ambient color (of materials).....1015
ambient light.....1015
American Standard Code for Information

Interchange (ASCII).....1016
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analyzing 3D solids.....438
AND operator, in Help topic searches.....5
ANGDIR system variable.....336

and dimensional input.....336
angle brackets.....53, 316, 797

double close, transparent command
prompt indicator.....53

open and close.....797
primary units symbol.....797

open, polar coordinate delimiter.....
316

primary units symbol.....797
angle direction.....111, 201, 316

setting.....111
specifying.....201

for polar coordinates.....316
angle offset action override property.....

507–508
specifying.....507–508

angle overrides.....353
operations with precedence over.....

353
specifying points.....353

angles
bisecting, with construction lines.....

420
calculating.....363–364
defining 3D views with.....167–168
dimensioning. See angular dimensions
direction. See angle direction
displaying the angle of a line.....380
hatch angle.....695
locking, specifying points by.....353
polar angles.....351, 353
for polar coordinates.....316
polar. See polar angles
snap angle.....347, 349, 1041
surveyor angles.....111
text obliquing angle.....741

format code (multiline text).....
753

units. See angular units
angular dimensions

creating.....819–820
definition points.....831
See also dimensions

angular unit conventions.....111
setting.....111

angular units.....111, 201, 312, 1015
setting.....111, 201
types.....312

animation.....84
for panning and zooming.....84
for running scripts.....84

annotations.....199, 1015
scaling.....199

anonymous blocks.....1015
ANSI (American National Standards

Institute).....1015
ANSI code pages supported by Windows..

794
anti-aliasing.....1016
aperture box (AutoSnap).....344
apostrophe.....53

transparent command character....53
appending objects to selection sets.....581
application window.....80, 82

coloring elements in.....80, 82
font selection.....80

applications
destination. See container applications

(destination applications)
dragging objects from other

applications.....1003
embedding objects in other

application documents.....
1005

linking views to other application
documents.....1005

opening attribute extraction files in
other applications.....559

source. See server applications
approximation points.....1016
ARC command.....336

dimensional input.....336
arc length dimensions.....823

creating.....823
uses.....823

arc polylines, drawing.....392–393, 409, 
411

arc symbol.....823
display options.....823
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arcball (3D Orbit view).....173, 179
architectural blocks, accessing collections

of.....75–76
architectural units.....110, 802

specifying.....110
suppressing zero feet/inch values.....

802
archiving.....253

sheet sets.....253
archiving drawings.....974

with xrefs.....974
arcs

connecting.....405
creating centerlines/center marks

on.....815, 819
creating object profiles from.....441
dimension line arcs.....820, 1023
dimensioning. See radial dimensions
drawing.....403

by specifying three points....403, 
406

tangent to arcs.....407
tangent to lines/arcs.....405
using start point, center point,

and angle.....404
using start point, center point,

and endpoint.....403, 
406

using start point, center point,
and length.....404

using start point, endpoint, and
direction/radius.....405

elliptical arcs.....415
joining to polylines.....647–648
See also objects

arcs (in revision clouds).....447, 449
editing lengths.....449
setting default values for lengths.....

449
setting lengths.....447

AREA system variable.....364
areas

adding.....366, 368
calculating.....364–365, 367–368
enclosed. See regions
plot area. See plot area

subtracting.....366, 368
ARG (profile text) files.....87
array actions.....503–505

adding to dynamic block
definitions.....503, 505

parameters supported by.....503
rows and columns.....504

specifying.....504
selection sets.....504, 508, 574–575, 

577–581, 638–639, 1040
including parameters in.....504

arrays (multiple copies)....605–610, 1016, 
1038

3D.....607, 609–610
creating.....605
limiting in size.....607
polar.....606, 608, 610, 1038
rectangular.....607

arrowheads.....777, 787–788, 1016
choosing.....787
control options.....787
customizing.....788
flipped arrowhead appearance in

earlier versions.....787
flipping.....788
scale factors.....788

arrows. See arrowheads
ARX applications.....85

loading with /ld command line
switch.....85

ASCII (American Standard Code for
Information Interchange)....1016

Asian-language fonts. See Big Fonts
Ask Me tab (Help window)

See also natural language queries (in
Help)

aspect ratio.....1016
Associated Standards File(s) icon.....143
associating.....138–139, 833–834

dimensions.....833–834
standards files with drawings.....138–

139
association points (of dimensions).....833
associative dimensions

associativity. See associativity (of
dimensions)
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converting into nonassociative
dimensions.....834

converting nonassociative dimensions
into.....834

as disassociated automatically.....830
filtering selections.....778
modifying.....830
object types supported/not

supported.....779
updating.....779

associative hatches.....646, 677, 694, 1017
exploding.....646

associativity (of dimensions).....778–779, 
831, 833–834

changing.....275–276, 290–291, 297–
300, 305–306, 334–335, 569–
570, 779

the default.....779
determining.....778
partial.....831
system variable controlling.....779
types.....778

asterisk (*).....745
wild-card character.....745

asterisk (*), wild-card character.....280
asterisk(*).....338

prefix in pointer input, accessing.....
338

at sign (@)...315–316, 319, 321–322, 635, 
745

break point without a gap symbol.....
635

relative coordinate specifier.....315–
316, 319, 321–322

wild-card character.....745
at sign (@), wild-card character.....280
attached labels

See also labels
attached xrefs.....965, 969–970, 985

notification of.....965
relocated xrefs.....985

updating.....969–970
with demand loading turned

on.....970
attaching

attributes to blocks.....552

attributes, to blocks.....551–552
xrefs.....965–967, 971, 976–978, 982, 

989
with DesignCenter.....965–966
overlaying xrefs vs......967
tools for.....965

See also linking
attaching attributes to blocks.....553

order of attribute prompts.....553
changing.....553

attenuation of light
See also falloff angle (of spotlights)

attribute definitions...552–553, 983, 1017
changing the order of.....553
creating.....552–553
editing.....552–553
in-place reference editing and.....983

attribute extraction files
creating.....558
error handling in.....560
formats.....558
nested blocks in.....560
opening in other applications.....559
See also attribute extraction template

files
attribute extraction table.....555

updating.....555
turning off notification for....555

attribute extraction template files.....556–
558, 560, 1017

aligning columns.....560
attribute tag fields in.....557
creating.....556, 560
elements in.....556
numeric field format codes.....558
sample file.....558

Attribute Extraction wizard.....554
attribute information.....552, 555, 561

extracting.....552, 555, 561
attribute prompts.....553, 1017

order of, when attaching attributes to
blocks.....553

changing.....553
attribute tags.....552, 557, 564, 566, 1017

duplicate tags.....564, 566
highlighting .....564, 566
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fields in attribute extraction template
files.....557

attribute values
changing the prompt order.....564, 

566
See also attribute information

attributes (of blocks)
attaching to blocks.....551–552
characteristics.....552
defining.....552–553
displayable. See labels
exporting. See attributes (of blocks),

extracting information from
extracting information from.....552, 

561
for use in database.....555

in-place reference editing and.....983
invisible.....551
modifying.....36, 211, 213, 216, 243, 

255, 438, 538–539, 561–565, 
568, 570, 596, 647, 649, 653, 
655–656, 659, 666, 691, 693–
695, 702, 734, 743–744, 746, 
759, 784, 786, 816, 824, 827, 
830–832, 845, 851, 865, 880, 
924, 928, 930, 933, 976–977, 
987

applying changes to block
references.....565

in block definitions.....563, 565
in block references.....564, 568

overview.....551
querying.....554

output to file.....555
redefining.....562
removing.....564, 566
selecting.....552
specifying for publishing in DWF

files.....920
stand-alone.....553
stand-alone attributes.....553
updating.....564
uses.....551
variable. See variable attributes
visibility.....551

ATTSYNC command.....564

AUDIT command.....128
auditing.....128

drawing files.....128
auditing drawings.....136, 140–141, 143, 

146
multiple drawings.....141, 146

for standards violations.....136, 140, 
143

authenticity of drawing files.....116
checking.....116

Auto-hide option.....81
Auto-hide setting, Tool Palettes window...

29–30
Auto-hide, for palettes, turning on/off.....

265
Auto-list.....709
AutoCAD.....1018

library search paths.....1018
window.....1018

Autodesk Authorized Training Centers.....
12

Autodesk DWF Composer.....913
Autodesk DWF Viewer.....913
Autodesk DWF viewer.....920, 940

viewing DWF files in.....940
Autodesk e-learning lessons.....12
Autodesk Educational Products.....966
Autodesk Express Viewer. See Autodesk

DWF Viewer
Autodesk Official Training Courseware.....

12
Autodesk product information

resources.....11
Autodesk products

late-breaking information about.....
10, 18

support. See product support
Autodesk Subscription.....13
Autodesk website.....10
AutoLISP Compatibility Analyzer

(Migration Tool).....2
Autolist. See Auto-list
automatic saves.....80, 123, 130

specifying.....80, 123, 130
AutoSnap.....341, 344
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running object snap display
options.....344

settings.....344
tools.....344

AutoStack.....718
AutoStack Properties dialog box.....718
AutoTrack.....356, 358

settings.....358
averaging the values in table cell ranges...

770
axes.....323, 327, 442, 446, 502, 602

positive direction of.....327
rotation about.....327

reflection lines.....502
revolving objects about.....442, 446
rotating objects around.....602
in the WCS.....323

axis tripod (in 3D model space).....1018

B

B-spline curves.....1018
Bezier curves.....1018

back faces (of 3D objects).....1018
back, moving objects to.....308
background color.....696

masking objects with.....696
background colors.....80, 702, 764, 773, 

950
for drawings.....80
for DWF plot files.....950
multiline text object fills.....702
for the table cell and row indicator

display.....773
tables.....764

background lines. See hidden lines (in 3D
objects)

background plotting.....873–874
canceling.....874
turning on/off.....873

background publishing.....874, 920, 922
canceling.....874
canceling published jobs in process...

922
checking published-job-in-process

status.....922

turning on/off.....922
backgrounds.....702

multiline text object options.....702
backup files.....123, 130–131, 238

file name extension.....130
restoring drawings from.....130–131
saving.....37, 42, 80, 87–88, 91, 121–

124, 130, 138, 161–162, 193–
194, 229, 231, 254, 259, 284, 
324, 329, 402, 541, 581, 766, 
772, 940, 993–995

when saving drawings...123, 130
for sheet set data (DST) files.....238

BAK file name extension.....130
balloon messages, in Communication

Center.....17
balloon notification, in Communication

Center.....17–18
turning off.....18

base grips.....637
base parameters.....474, 476, 487

actions supported by.....474, 476
adding to dynamic block

definitions.....487
grip type.....474

base point.....1018
base points....347, 349, 463, 492–493, 500

dynamic block base point.....463
independent base points.....492–493, 

500
snap base point.....347, 349

base points (for insertion point).....453, 
457

for inserting blocks.....453, 457
Base Type property.....492, 500

for rotate actions.....500
for scale actions.....492

baseline.....1018
baseline dimensions

creating.....812
dimension line spacing.....829
See also dimensions

basic dimensions.....803, 805
basic math functions (in QuickCalc)...372

using.....372
batch audit reports.....141, 146–147
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adding notes to.....146
exporting.....147
filtering data.....147
generating.....146
viewing.....146
See also Batch Standards Checker

batch audits
running.....141, 146
See also batch audit reports

Batch Drawing Converter (Migration
Tool).....2

batch plot. See BP3 files
Batch Standards Checker

starting.....145
See also batch audits

beveling objects. See chamfering
Bezier curves.....1018
Big Fonts.....736–737

assigning to text styles.....737
font file.....736
specifying.....736

binding.....973–975
dependent named objects to

drawings.....973–974
xrefs to drawings.....974–975

BINDTYPE system variable.....981
bisecting.....420

angles, with construction lines.....420
bitmaps (BMP images)

mapping onto 3D object surfaces. See
image mapping

See also BMP (bitmap) files
blips.....592–593, 1019

removing.....592–593
BLK files. See block template (BLK) files
block attribute information.....554–555

extracting.....554–555
output to file.....555
updating in table.....555

turning off notification for....555
block attributes. See attributes (of blocks)
Block Authoring palettes.....463, 468

showing/hiding in the Block Editor...
468

block authoring palettes.....1019
block authoring tools.....468, 1019

customizing.....468
BLOCK command.....121, 123

saving block definitions.....121, 123
saving selected objects.....121, 123

block definition tables.....452, 1019
block definitions....68, 71, 121, 123, 452–

456, 458, 464–465, 539, 541, 561–
563, 565, 570–571, 976–977, 1019

copying.....456
creating.....453–454

in the Block Editor.....465
creating drawing files from.....458
dynamic. See dynamic block

definitions
libraries of.....455–456
modifying.....561, 570, 976–977
modifying attributes in.....563, 565
modifying in current drawing.....561
opening.....464
removing.....571
saving.....541
saving as drawing files.....121, 123
tables.....452
updating.....68, 71, 562–563

block descriptions.....562–563
modifying.....562–563

Block Editor
and 3D blocks.....463
actions as displayed in.....470

specifying text color.....472
specifying text size.....471
updating text size.....473

Block Authoring palettes in.....468
closing.....467
commands-not-allowed-in message...

463
creating block definitions.....465
dependency highlighting.....471

turning on/off.....473
dimensions in. See parameters (for

dynamic blocks)
displaying object properties.....467
drawing area.....463
grips as displayed in.....470

specifying color.....472
specifying size.....472
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invisible objects as displayed in....473
modifying dynamic block

definitions.....538
opening block definitions.....464, 539
opening blocks.....465–466
opening drawing files as blocks....466
opening dynamic blocks.....466
parameters as displayed in.....470

specifying color.....471
specifying font.....472
specifying text and arrow size.....

471
updating text size.....473

preventing access to.....467
saving block definitions.....541
toolbar.....463
UCS command in.....463

Block Editor drawing area.....463
block instances.....1019
block instances. See blocks
block instances. See blocks (block

references)
block libraries (symbol libraries).....455–

456
creating.....455–456

block library drawings (symbol library
drawings).....546, 562

inserting block definitions from...546
updating block definitions from...562

block placeholder fields, in block attribute
definitions.....726

block references
blocks as. See also blocks

block references (instances).....1019
block references. See blocks (block

references)
block template (BLK) files....940, 945, 947

creating.....945
editing.....947
including information in published

DWF files.....945
block tools.....22, 34

prompt for rotation angle.....22
refreshing image on tool palette.....34

block-related metadata options for
published DWF files.....940

block-related properties and attributes.....
920

specifying for publishing in DWF
files.....920

blocks
attaching attributes to.....551–552
attributes. See attributes (of blocks)
base point.....453, 457
binding referenced objects.....974
clipped.....971
clipping.....972
colors....263–264, 270–271, 275, 287–

288, 290, 542–543, 550, 568–
569, 579, 595, 639, 764, 903–
905, 1015, 1023

insert settings.....542
colors in.....568
copying.....41, 53, 55, 120, 209, 267–

268, 273, 456–457, 469, 594–
595, 604–605, 641–643, 665, 
667, 767, 769, 899, 924, 927, 
931, 933, 994–995, 1003

block definitions.....456
paper space objects between

drawings.....457
creating.....453–454

in block libraries.....455–456
drawing files as.....456, 458

defining.....453–454, 552
descriptions. See block descriptions
drawing files as....116, 456, 458, 466, 

546–547, 562–563
creating.....456, 458
inserting.....116, 546–547
updating block definitions

from.....562–563
editing. See also in-place reference

editing
exploding.....570–571, 646, 1026
grips in.....645
vs. groups.....586
inserting drawing files as....116, 546–

547
inserting. See also inserting blocks
linetypes in.....568
linetypes, insert settings.....542
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lineweights, insert settings.....542
modifying

block attributes in.....564, 568
See also in-place reference editing

nested. See also nested blocks
object properties.....263–268, 270–

271, 287–288, 290, 296–297, 
299, 301–303, 305–306, 438, 
467, 542–544, 569–570, 579, 
647, 727, 920

insert settings.....542
OLE objects in.....982
pasted text as.....724
as references in drawings.....545
selection sets of objects within. See

working sets
updating.....564, 567
vs. xrefs.....457

blocks (block references)....22–23, 27, 64, 
68, 71–72, 76, 199, 201, 458, 465–
466, 552, 730, 765, 768, 779, 
944, 977–978, 981–982, 1015

accessing.....64
online.....71

adding to tool palettes.....68
anonymous.....1015
attaching attributes to.....552
contextual fields in.....730
creating tools for.....22
discarding changes to.....982
downloading.....72, 76
drawing files as....116, 456, 458, 466, 

546–547, 562–563
opening.....466

dynamic. See dynamic blocks
editing in place.....977–978
including block information in

published DWF files.....944
inserting.....116, 230–231, 360–363, 

458, 546–547, 704–705, 724–
728, 752, 759, 761, 765, 768–
771, 773

in table cells.....765, 768
with tool palettes.....458

opening.....465–466
organizing.....458

placing.....23
placing from tool palette.....27

prompt for rotation angle.....27
redefined.....779
saving back changes to.....981–982
scaling.....199, 201
scaling automatically.....23
using a tool created from.....27

BMP (bitmap) files
See also bitmaps (BMP images)

boldfacing multiline text.....707
Boolean operators.....5

Help topic searches.....5
borders (of table cells).....763–764
boundaries.....214, 216, 422–423

creating.....37, 41, 68, 89, 170, 207–
208, 229–230, 237–238, 253, 
422–423, 439, 441, 448, 455–
456, 458, 460, 465, 517, 610, 
744, 751, 753, 818, 862

regions out of.....422–423
of layout viewports.....214, 216

clipping.....214, 216
suppressing display in

nonrectangular
viewports.....214

boundary edges.....615
boundary points.....685–686

defining hatch boundaries with.....
685–686

boundary polylines, creating.....392, 394, 
410, 412

boundary sets.....393, 395, 410, 412, 659
for boundary polylines.....393, 395, 

410, 412
for faces of 3D solids.....659

boundary sets (for hatch areas)....681, 684
defining.....684

bounding boxes (for multiline text)..702–
703

drawing.....702–703
BOX command.....439
boxes

creating.....433
solid boxes.....439, 443
text boxes for leader text.....723
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view box (Aerial View window)....158
See also pickbox cursor

BP3 files.....939
BP3 files. See batch plot lists
braces ({ }).....752

format codes for.....752
BREAK command.....635
breaking.....1001–1002

links.....1001–1002
breaking objects.....635–636
bringing objects to front.....308

draw order of objects.....308
broken pencil icon.....334
browsing.....74

for online content.....74
bulleted lists.....708–710, 712–713

bullets for.....708
creating as you type.....708, 712
formatting multiline text as.....709
moving items down a level.....712
removing list formatting from.....710
separating items from.....713

bullets.....708
for bulleted lists.....708

bump maps.....1019
button menus.....1020
BYBLOCK property.....1020
BYBLOCK setting.....270, 288, 296, 305, 

543
color value.....288
linetype value.....296
lineweight value.....305

BYLAYER property.....1020
BYLAYER setting.....264, 270, 288, 290, 

296–297, 305, 542
color value.....288, 290
linetype value.....296–297
lineweight value.....305

C

CAD Manager Control utility.....73
accessing.....73
installing.....73
used to turn DC Online tab on/off.....

73

CAD Standards Settings dialog box...138, 
142

CAD standards. See standards (for named
objects)

CALCINPUT system variable.....80
calculating.....80, 83, 200, 363–365, 367–

368
angles.....363–364
areas.....364–365, 367–368
circumferences.....365
distances.....363–364
grid limits.....200
mathematical expressions in dialog

boxes.....80, 83
perimeters.....365
point coordinate values.....364

calculator variables (in QuickCalc)....382–
385

creating.....383–384
deleting.....385
displaying information on.....382
editing.....385
loading into the Input box.....382
organizing.....384
predefined variables.....384
types.....383

calculators. See QuickCalc calculator...369
calligraphy pen style, revision clouds.....

447
calligraphy pen-style revision clouds

(markups).....448
callout blocks.....1020
callout blocks (for sheet views).....244–

245, 249
adding.....249
avoiding prompts when placing...245
changing.....249

camera (in 3D views).....175–176
adjusting distance.....176
positioning.....175–176
positioning the target.....175–176

CAMERA command.....175
and the 3DORBIT command.....175

canceling.....53, 591, 922
commands.....53, 591
published jobs in process.....922
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caret (^), stacked text indicator.....717
Cartesian coordinates.....312, 338

entering in dynamic input tooltips....
338

catalogs (of parts) (online).....71, 74
accessing.....71, 74

CDF (comma-delimited format) files...559
cell address format.....769

formula cell address fix value prefix...
769

cell and row indicator display (in tables)..
773

background color control.....773
turning off/on.....773

cell properties.....767
changing/restoring defaults.....767
copying to other cells.....767

cell ranges.....769–772
averaging the values in.....770
counting the cells in.....771
format.....769, 772
summing the values in.....770

cells (in tables)
address format.....769
border properties.....767
copying formulas to other cells....769
copying properties to other cells.....

767
counting the cells in ranges.....771
editing text.....765, 768
entering formulas.....769, 772
entering text.....765–766
formatting text.....765–766
formulas in.....769–773

copying to other cells.....769
entering.....769, 772
inserting.....769–771
inserting fields.....773

inserting blocks.....765, 768
inserting fields in formulas.....773
inserting fields in text.....727, 769
inserting formulas.....769–771
line breaks in.....766
moving the cursor within/between

cells.....766

properties.....31–33, 112, 216, 250–
251, 379, 398, 767

border properties.....767
changing/restoring defaults...767
copying to other cells.....767

ranges. See cell ranges
selecting text.....766
text in.....727, 765–766, 768–769

editing.....765, 768
entering.....765–766
formatting.....765–766
inserting fields.....727, 769
line breaks.....766
selecting.....766

cells (tables).....758, 760–761, 763–764
gridlines.....764
margins.....763
merging.....760–761
modifying.....758, 760

CELTSCALE system variable.....299, 401
center marks.....777, 815, 819

control options.....815
creating.....815, 819

centerlines.....777, 815, 818–819
control options.....815
creating.....815, 819

automatically with radial
dimensions.....818

centimeters.....108, 110–111
converting inches to.....108, 110
converting to inches.....108, 111

Chain Actions.....1020
Chain Actions property.....476, 529, 536, 

538
specifying.....538

chain dimensions. See continued
dimensions

CHAMFER command.....629
chamfer distances.....630, 632

overriding.....630
setting.....630, 632

chamfered objects.....631
trimming and extending.....631

chamfering.....629–634, 657
3D solids.....657
hatch boundaries.....629
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line segments.....633
multiple sets of objects.....629, 634
objects.....629

by setting the distances.....630, 
632

by specifying length and angle....
631, 633

without trimming.....633
polyline segments.....631
polylines.....632, 634

chamfers
creating.....629
creating. See chamfering
setting the distances.....630, 632

channels, in Communication Center....17
character formatting, in multiline text.....

707
character spacing (multiline text), format

code.....753
characters.....718

stacking.....718
Check Standards dialog box.....141
checking

3D solids.....670
drawing files.....116

for authenticity.....116
drawings....37, 64, 68, 70, 77, 80, 85, 

101–107, 116–118, 120–124, 
129–131, 136, 138–140, 143, 
146, 160, 173, 198–199, 204, 
243, 246–247, 273, 304, 453, 
457, 594–595, 676, 854–855, 
860–861, 880–883, 891–892, 
911–912, 964–967, 973–976, 
993–995, 998, 1001–1003, 
1030, 1039, 1046

for standards violations.....136, 
140, 143, 146

published-job-in-process status....922
spelling

in another language.....749
text not checked.....749
See also dictionaries

Checking Complete alert summary
(standards checking).....141

CHECKSTANDARDS command.....141

chords (in revision clouds).....449
editing lengths.....449

CIRCLE command.....336, 439
dimensional input.....336

circled sphere icons in 3D Orbit view.....
179

circles
calculating areas/circumferences.....

365
creating centerlines/center marks

on.....815, 819
creating cones from.....439, 444
creating cylinders from.....439, 444
dimensioning. See radial dimensions
drawing.....407–408

tangent to objects.....407–408
extruding.....439, 441, 445
revolving.....442
See also objects

circular external reference.....1020
circular references (between xrefs)....990, 

1020
resolving.....990

circumferences, calculating.....365
circumscribed polygons.....395–396

drawing.....395–396
classification property, selecting objects

by.....579–580
Clean Screen (View menu).....80
cleaning up the screen (display).....592
cleanup (of 3D solids).....670
clearing the screen.....80
click actions in tree views.....236
Clipboard.....593

cutting objects to.....593
Clipboard (Windows).....594–595

copying objects to.....594–595
cutting objects to.....594–595
pasting objects from.....594–595

clipdepth (of clipping boundaries).....972
clipped.....971

references.....971
clipping.....170, 185, 972, 993

3D objects.....170
in 3D Orbit view.....185

references.....972
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xrefs.....993
clipping boundaries (for blocks and

xrefs).....965, 971–972
clipdepth.....972
displaying.....965
turning off.....971
types.....971

clipping planes...170–171, 185–187, 1020
creating slices with.....185
rotating objects through.....185
setting.....138, 168, 185–186, 753, 

807–808, 848, 854–855, 877–
878, 881–883, 938

in 3D Orbit view.....185–186
setting (adjusting).....170–171
turning on/off.....185

in 3D Orbit view.....187
closed polylines.....392, 409

drawing.....392, 409
closing.....44, 56, 239

sheet sets.....239
Text window.....56
toolbars.....44

clouds. See revision clouds (markups)
CMYK color system.....1020
codes. See control codes
collaborative environments, maintaining

standards in.....136, 140, 142
collections (of content), specifying.....72, 

75–76
colon.....769, 772

cell range character.....769, 772
color attribute of materials. See diffuse

color (of materials)
color book colors.....292

searching for swatches in color
books.....292

color books.....288–289, 291–293
browsing.....292
changing colors.....291

layer colors.....291
object colors.....291

file path.....293
changing.....293
defining multiple folders for.....

293

installing.....288, 292
searching for color swatches in....292
setting colors (for new objects)...289, 

291
Color control (Properties toolbar).....264, 

270
color depth.....952

for DWF plot files.....952
setting.....952

color mapping tables.....901
deleting.....901

color maps.....1021
color names.....287
color numbers. See ACI numbers
color palettes.....287
color swatches.....292

searching for, in color books.....292
color-dependent plot style tables.....871, 

890–892, 896, 901
and color mapping tables.....901
converting...107–108, 110–111, 148, 

381–382, 395, 417, 595, 738, 
799–800, 834, 891–892, 904–
905

to named plot style tables.....892
converting drawings from named

tables to.....891–892
converting drawings to named tables

from.....891–892
file name extension.....871
plot styles in.....890
predefined tables.....896

color-dependent plot styles.....871, 890–
892

converting drawings from named
styles to.....891–892

converting drawings to named styles
from.....891–892

coloring..80, 82, 339, 666–667, 703, 707, 
752, 767

application window elements.....80, 
82

edges of 3D solids.....667
faces of 3D solids.....666
multiline text.....703, 707

format code.....752
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objects. See object colors
table cell borders.....767
tooltips.....339
See also colors

colors
ambient color.....1015
assigning.....264, 270–271, 275, 287–

288, 296–297, 301–303, 305, 
544

to layers.....270–271
to objects.....264, 287–288

background. See background color
in blocks.....568
changing.....275–276, 290–291, 297–

300, 305–306, 334–335, 569–
570, 779

layer colors.....275, 290
object colors.....290, 569

changing for layers.....569
converting to grayscale.....904–905
copying.....595
current color.....288
custom grips, changing.....550
diffuse color (of materials).....1023
dithering.....903, 905
filtering selection sets based on....579
for grips.....639
for objects. See object colors
setting (for new objects).....264, 287–

288
setting (making current).....543
table background.....764
table borders or gridlines.....764
table text.....764
uses.....287
See also coloring
See also layer colors

columns (in tables).....770–771
averaging values in.....770
counting cells in.....771
summing the values in.....770

columns (tables).....759–762, 764
adding.....761
deleting.....762
header rows.....764
modifying.....759–761

setting number of.....759
columns. See database table columns
combining.....422–424, 442, 446–447

3D solids.....442, 446–447
regions.....422–424

comma (,).....772
formula argument delimiter.....772

comma-delimited format (CDF) files...559
comma-separated format (CSV) files...762
command aliases.....52

entering commands with.....52
command history.....55

displaying all.....55
command line....52, 54, 56–58, 179, 1021

accessing 3D Orbit commands
from.....179

copying text from the text window
to.....56

displaying.....3–4, 11, 45, 47, 56–57, 
149, 160, 264–266, 300–304, 
308, 467

prompts when entering
commands.....56

displaying when hidden.....57–58
entering commands on.....52
entering system variables on.....54
hiding.....57–58
prompts on, displaying when entering

commands.....56
switching between dialog boxes

and.....56
command line calculator.....386

overview.....386
command line prompts.....80

coloring.....80
command line switches.....84, 86

precedence of environment
settings.....86

starting the program by using.....84, 
86

syntax.....86
command line window. See command

window
command options, specifying.....52
command prompts. See command line

prompts

Index | 1066



command prompts. See command line,
prompts on

command prompts. See dynamic prompts
Command Reference, accessing.....10
Command shortcut menu.....46, 55

displaying.....46
command strings, creating command tools

for executing.....28
command tools.....28–29

AutoLISP routines, VBA
macros/applications,
executing.....28

creating.....28
creating/using.....28
executing command strings,

customized commands, or
scripts.....28

using.....29
command window.....54–55, 57–58, 83, 

335
displaying when hidden.....57–58
docking.....57–58
and Dynamic Input.....335
editing in.....54
floating (undocking).....57–58
font selection.....83
hiding.....57–58
navigating in.....54
repeating commands in.....55
resizing.....55, 57–58
switching to the text window from....

55
transparency setting.....58

commands.....10, 28, 46, 52–53, 55–56, 
217, 335, 374–375, 463, 591, 
1044

accessing QuickCalc from within.....
374–375

accessing recently used commands....
55

canceling.....53, 591
commands-not-allowed-in-Block-Editor

message.....463
completing with Dynamic Input.....

335
copying command already used.....53

creating tools for executing.....28
customized.....28

creating command tools for
executing.....28

cycling through commands on
command line.....52

editing commands. See editing
commands

entering.....52, 54, 56, 312, 314–323, 
326–327, 334, 338, 354–355, 
582–583, 765–766, 769, 772

on the command line.....52
displaying prompts on the

command line.....56
suppressing dialog boxes.....56

executing.....52
by right-clicking.....52

for viewing.....217
scale locking and.....217

Help on.....10
interrupting with other

commands/system
variables.....53

prompts. See command line prompts
prompts. See dynamic prompts
repeating.....46, 55

in the command window.....55
by right-clicking.....46

restarting recently used command.....
52–53

right-clicking in the drawing area
while in/not in progress....46

specifying command options.....52
transparent commands.....53, 1044

Commands tab (Help window).....8
information depth.....8

comments
on drawings. See markups

Communication Center.....15, 17–18
balloon notification.....17
channels.....17
customizing.....17
frequency of updates.....17
information displayed in.....17
opening.....15, 18
privacy and.....15
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turning off balloon notification.....18
comparing dimension styles.....781–782
compass, in 3D Orbit view.....177
complete plotter configuration files. See

PCP (legacy plotter configuration)
files

composite 3D solids.....442, 446–447, 669
creating.....442, 446–447
separating.....669

composite regions, creating.....422–424
composite tolerances.....838
compressing text.....699
Concepts tab (Help window).....8

information types.....8
cones.....433, 439, 444

creating.....433
solid, creating.....439, 444

connectivity feature. See database
connectivity feature

constants.....369
calculator variables. See global

constants.....369
construction lines (xlines)...226, 418–420

aligning objects in different layout
viewports with.....226

bisecting angles with.....420
drawing.....419–420
offsetting.....420

construction plane. See XY construction
plane

construction planes.....1021
content (for drawings) (DesignCenter)

accessing.....64
online.....71, 74

adding.....67
bookmarking.....65
changing the source displayed.....66
collections of, specifying.....72, 75–76
creating tool palettes with.....68
online content.....71–72, 74–76

accessing.....71, 74
browsing.....74
downloading.....72, 76
previewing.....72, 76
searching for.....72, 75–76
types.....74

shortcut folder. See Favorites folder
content area (DesignCenter Online)...72, 

75
controlling the number of

categories/items displayed
in.....75

content area (DesignCenter).....62, 67, 69
displaying detail in.....67
loading.....69

Contents tab (Help window).....3–4
displaying (viewing) topics.....4
expanding/contracting the list.....4

context-sensitive Help
F1 key.....10
See also Quick Help (Info palette)

contextual fields (in text).....730
listing of.....730

continued dimensions
creating.....812–813
dimension line spacing.....829
See also dimensions

CONTINUOUS linetype.....269
continuous orbit (in 3D Orbit view).....

178, 184
editing views while active.....178
starting.....178, 184

control frame.....1021
control grips (in blocks).....645
control points.....651, 1021
conversions (of units).....381

copying to the QuickCalc Input
box.....381

converting
associative/nonassociative

dimensions.....834
colors....263–264, 270–271, 275, 287–

288, 290, 542–543, 550, 568–
569, 579, 595, 639, 764, 903–
905, 1015, 1023

to grayscale.....904–905
degrees to radians.....382
dimension units (primary to

alternate).....799–800
drawing units.....107–108, 110–111
drawings to a different plot style

type.....891–892
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fonts.....738
layers to drawing standards.....148
pasted information to drawing file

format.....595
polylines into lines.....395
radians to degrees.....381
spline-fit polylines into splines....417
units of measurement.....381
See also migrating

Coons surface patch meshes.....429, 432, 
438, 1021

creating.....432, 438
coordinate display (cursor location)....48, 

312–313, 336
changing.....313
in tooltips.....336
types.....312

coordinate filters.....354–355, 1021
specifying points with.....354–355

coordinate systems.....312, 323, 401
Cartesian.....312
mapping, on paper to the WCS....401
origin.....312, 323

coordinate systems, in model space
viewports.....191

coordinate values.....313, 336, 338, 364
entering.....52, 54, 56, 312, 314–323, 

326–327, 334, 338, 354–355, 
582–583, 765–766, 769, 772

in dynamic input tooltips.....338
entering in tooltips.....336

coordinates...48, 266, 312–316, 320–323, 
326–327, 334, 336, 364, 379

absolute values.....312, 314, 316
Cartesian.....312
cursor coordinate display.....48

in tooltips.....336
cursor location display.....312
cylindrical.....320–321
displaying coordinate values.....266, 

379
entering

broken pencil icon warning.....
334

in 3D space.....326
relative to the WCS.....327

relative values.....312, 315–316
See also under \

filters. See coordinate filters
point locations, displaying.....313
point values.....313, 364

calculating.....364
displaying.....313

polar coordinates.....312, 316
relative values.....312, 315–316
spherical coordinates.....322–323
unit types.....312

COPYHIST command.....55
copying.....41, 53, 55, 120, 209, 267–268, 

273, 456–457, 469, 594–595, 604–
605, 641–643, 665, 667, 767, 
769, 899, 924, 927, 931, 933, 
994–995, 1003

block definitions.....456
cell properties to other table cells.....

767
colors.....595
command already used.....53
drawing sheets (in drawing sets).....

924, 927, 931, 933
between drawings.....120
edges of 3D solids.....667
faces of 3D solids.....665
formulas to other table cells.....769
layers, between drawings.....273
layouts.....209
named plot styles.....899
object properties.....267–268

suppressing specific properties....
267

objects.....22–23, 35, 121, 123, 185, 
211, 218, 222, 226, 264, 266–
267, 270–271, 275–276, 281, 
287–288, 290, 297–298, 305, 
308–309, 343, 352–353, 360–
363, 365, 389, 439–442, 445–
447, 457, 461, 470, 546, 568, 
574–575, 577–578, 581, 589, 
592–605, 610–615, 617–624, 
628–633, 635–644, 646, 656, 
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668, 681, 696, 734, 870, 974, 
979–980, 998, 1001, 1003, 
1005, 1022, 1034, 1038

in arrays.....605
to the Clipboard.....594–595
with grips.....641, 643
multiple copies.....604, 641, 643
with offset snaps.....642–643
point method.....604–605
by relative displacement.....604
with rotation snaps.....642–643

OLE objects.....1003
paper space objects, between

drawings.....457
parameter sets.....469
text, all of, in the text window.....55
tool palettes between tool palette

groups.....41
xrefs, for demand loading.....994–995

COPYLINK command.....1005
correcting drawings. See markups
correcting dynamic block definitions.....

540
correcting mistakes. See undoing actions
correcting spelling. See checking spelling
counting the cells in table cell ranges.....

771
covering objects (with blank areas).....696
CPolygons (crossing polygon selections)..

576, 578
Create Layout wizard.....207–208, 862
Create New Drawing dialog box.....102–

103
displaying.....102
starting drawings in.....102–103

Create New Table Style dialog box.....763
Create Sheet Set wizard.....236
Create Support Request option,

Subscription Center.....13
creating.....37, 41, 68, 89, 170, 207–208, 

229–230, 237–238, 253, 422–423, 
439, 441, 448, 455–456, 458, 
460, 465, 517, 610, 744, 751, 
753, 818, 862

workspaces.....89
cross (+), UCS icon symbol.....333

cross sections (of 3D solids), creating.....
658

crosshairs.....80, 336, 1021
coloring.....80
coordinate display.....336

in tooltips.....336
crosshatching. See hatching
crossing polygon selections.....576, 578
crossing selections.....576, 1022
crossing windows. See crossing selections
CSV (comma-separated format) files...762
CTB (plot style table) files.....1022
CTB file name extension.....871
CTRL+A keys, toggling group selection.....

588
CTRL+click, cycling through objects.....

574–575
CTRL+drag, copying and pasting.....1003
CTRL+ENTER keys.....766

saving table changes.....766
CTRL+R keys.....192–193

cycling through viewports....192–193
cubic feet units (in QuickCalc).....376
Current Object Scale value (linetype

scale).....299
cursor.....48, 179, 312, 336, 349, 766, 

1022, 1040
3D Orbit view icons.....179
coordinate display.....48, 312

in tooltips.....336
crosshairs. See crosshairs
moving from table cell to table cell....

766
pickbox. See pickbox cursor
rubber-band line.....349, 1040

cursor menus
See also shortcut menus

curve-fit polylines, creating.....648
custom dictionaries (spelling checker).....

749–751
creating.....751
editing.....749–751

custom grips.....1022
custom grips (dynamic blocks)....549–550

changing color.....549
changing display color.....550
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manipulating dynamic blocks with....
550

types....426, 474, 476, 489, 510, 549, 
891

alignment.....549
flip.....549
linear.....549
lookup.....549
rotation.....549
standard.....549
table of.....549

custom hatch patterns.....679
defining.....679

custom menus.....125
specifying.....125

custom objects.....1022
custom paper sizes.....849–850, 877, 879

adding.....849–850, 877, 879
deleting.....850
editing.....850, 879

custom properties.....251–252, 460, 462, 
529–530

in dynamic blocks.....460, 462, 529
creating.....251–252
displaying/not displaying.....530
extracting.....529

for sheets/sheet sets.....251
custom properties (dynamic blocks).....

549–550
manipulating dynamic blocks with....

550
custom scales.....882

plotting using.....882
Custom tab (Drawing Properties dialog

box).....113
customization (CUI) file.....1022
customization (CUI) files.....44

specifying.....44
customized commands.....28

creating command tools for
executing.....28

customizing.....26, 45–47, 49, 79, 87, 96, 
468, 582, 788

arrowheads.....788
object selection.....582
object snap menu.....49

parameter sets.....468
program environment.....79

with profiles.....87
right-clicking.....45, 47, 96
shortcut menus.....45–46
tool flyouts.....26
workspaces.....49

cutaway views (of 3D objects), creating....
170

cutting.....593–595, 1003
objects to the Clipboard.....593–595
OLE objects.....1003

cutting edges.....615
cycling.....192–193, 344, 574–575, 588

through objects.....574–575
in groups.....588

through running object snaps.....344
through viewports.....192–193

CYLINDER command.....439
cylinders (solid).....439, 444

creating.....439, 444
cylindrical coordinates, specifying a point

with.....320–321

D

damaged drawing files.....128–129
repairing.....128–129

data.....438
3D solids, exporting.....438

data labels. See labels
data sources

See also external databases
database information (for objects),

listing.....266
database records

editing
See also database table data

fields, data labels. See labels (data
labels)

viewing
in filtered subsets. See queries

database table data
See also database records

database tables
columns. See database table columns
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rows. See database records
See also database table data

databases
external. See external databases

datum (for geometric tolerances).....835, 
837

reference frames.....837
reference letters.....835, 837

datum (for ordinate dimensions)
See also ordinate dimensions

DBLCLKEDIT command.....265
DBX applications.....85

loading with /ld command line
switch.....85

DC Online tab.....73
turning on/off using CAD Manager

Control utility.....73
DC Online tab (DesignCenter).....65
DCTCUST system variable.....749
DCTMAIN system variable.....749
DDEDIT command.....743
decurving polylines.....648
default drawing.....1022
default drawing folder.....116–117

changing.....116–117
default drawing template file.....103, 105, 

107
restoring.....105, 107
starting drawings with.....103

Default shortcut menu.....46
displaying.....46

defaults.....1022
definition points (of dimensions).....831, 

1022
definition table.....1023
definition table items

eliminating unnecessary items.....230
See also named objects

defpoints. See definition points (of
dimensions)

degrees.....381–382
converting radians to.....381
converting to radians.....382

deleting.....37, 39–40, 163, 194, 209, 255–
256, 273–274, 286, 294, 325, 
385, 469, 518, 534, 539, 589, 

665, 734, 762, 850, 866, 900–
901, 987

actions from parameters/parameter
sets.....469

calculator variables.....385
color mapping tables.....901
columns/rows in tables.....762
custom paper sizes.....850
dynamic block definition elements....

539
faces of 3D solids.....665
layer settings.....286
layers.....273–274
layouts.....209
linetypes.....294
named groups.....589
named page setups.....866
named plot styles.....900–901
named views.....163
search paths.....987
sheet selections.....255–256
text styles.....734
tool palette groups.....39–40
tool palettes.....37
UCSs.....325
value set values.....534
viewport arrangements.....194
visibility states.....518

delimiter characters, in multiline text
lists.....709

DELOBJ system variable.....447
demand loading (of xrefs)....970, 993–995

copying xrefs for.....994–995
saving xrefs with indexes.....993–994
turning on/off.....994
updating xrefs when turned on....970

DEMANDLOAD system variable.....730
dependencies (dynamic block element

relationships).....462, 540
viewing.....540

dependency highlighting.....473, 1023
dependency highlighting (in the Block

Editor).....471, 473
turning on/off.....473

dependent named objects (in xrefs)
binding to drawings.....973–974
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listing.....991
name conflicts.....973
referencing, as impossible.....973
See also named objects

dependent symbols
See also dependent named objects (in

xrefs)
design environment. See model space
design standards. See standards, for named

objects
Design Web Format files. See DWF (Design

Web Format) files
DesignCenter.....62–64, 66–71, 112, 456, 

547–548, 562, 679
accessing content.....64
adding content.....67
adding items to tool palettes.....68
content area.....67

displaying detail in.....67
content specification tabs.....64
copying block definitions.....456

overwrite limitation.....562
dragging hatch patterns into

drawings.....679
Home button folder, changing.....66
home folder.....70

setting to a folder with symbol
library drawings.....70

inserting blocks.....547–548
loading content area with hatch

patterns.....70
loading content area with symbol

libraries.....69
opening drawings from.....70
toolbar.....63
updating block definitions.....68, 71
uses.....62, 112

DesignCenter Online.....71–74
content area.....72
content specification views.....72
content types.....74
privacy.....73
retrieving content on the Web.....74
turning on/off using CAD Manager

Control utility.....73
DesignCenter window

attaching xrefs.....965–966
content area.....62
creating tool palettes.....37
docking.....63

preventing.....64
inserting layouts.....230–231
opening blocks in the Block Editor

from.....465
overlaying xrefs.....966
resizing.....63
roll-over behavior.....63
shortcut menu.....63
tree view. See tree view (DesignCenter)
undocking.....63
See also DesignCenter

destination application.....1006
editing linked objects (drawings) in...

1006
destination application, in OLE object

editing.....1006
destination applications. See container

applications
detaching.....976

xrefs.....976
Developer Help.....4

starting.....4
deviation tolerances.....803
dialog boxes.....10, 53, 56

Help on.....10
suppressing when entering

commands.....56
switching between the command line

and.....56
system variables affecting.....56
transparently opened, change

delays.....53
diameter dimensions.....776, 790, 815, 

817, 831
creating.....815, 817
definition points.....831
placing dimension text for.....790

dictionaries for spelling checker.....749–
751

custom.....749–751
creating.....751
editing.....749–751
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switching.....749–750
DIESEL (Direct Interpretively Evaluated

String Expression Language).....
1023

diffuse color (of materials)
See also diffuse reflection

diffuse reflection
See also diffuse color (of materials)

digital signatures
See also signed files

digitizing.....319
entering 3D Cartesian coordinates

by.....319
digitizing tablets.....96

calibrating.....96
configuring.....96

DIMASO system variable.....779
DIMASSOC system variable.....778–779
DIMCEN system variable.....815
DIMCENTER command.....815
DIMDIAMETER command.....815
dimension geometry.....777, 783

controlling.....783
dimension line arcs (for angular

dimensions).....820, 1023
dimension lines.....777, 783–784, 788–

792, 795–796, 820, 829
aligning dimension text with.....792, 

795
arcs.....820
control options.....783
forcing an internal line.....790–791
modifying.....784
placing dimension text.....789, 791, 

796
above.....796
within/outside of.....789, 791

properties.....783
spacing for baseline/continued

dimensions.....829
trimming of.....788

dimension scale.....806–808
setting.....807

for dimensioning in layouts.....
808

the overall dimension scale...807

for scaling model space
dimensions to layouts....
808

values affected/not affected by.....806
dimension style.....1023
dimension style overrides....781, 825–827

applying.....827
creating.....825–826
listing.....781

dimension styles
applying.....824
comparing.....781–782
creating.....781
listing.....781–782
listing settings for.....781–782
overrides. See dimension style

overrides
restoring.....824
standards. See standards (for named

objects)
See also named objects

dimension system variables.....1023
dimension text

aligning.....225–226, 347, 360–363, 
602–603, 699, 701, 705, 723, 
753, 764, 792, 795, 804, 806, 
829

with dimension lines.....792, 795
controlling.....789
home position.....827

returning text to.....828
modifying.....827
moving.....827
placing.....789–791, 793–796

above dimension lines.....796
for diameter dimensions.....790
horizontally.....793, 795
manually.....793–795
at the second extension line.....

795
vertically.....794, 796
within/outside of dimension

lines.....789, 791
prefixes and suffixes.....797
replacing.....827, 829
rotating.....827–828
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text styles.....797–798
user text.....797
values. See dimension values
See also leader text

dimension text paragraph break symbol...
797

dimension text separator symbol.....797
dimension values.....798–802

rounding off.....801
units.....799

adding and formatting.....800
zero suppression.....802

dimension variables.....1023
dimension variables. See dimensioning

system variables
dimensional input.....336, 340

changing settings.....340
lock icon.....336
tooltips, specifying points in.....336

dimensioning
basic concepts.....776
methods.....806
types.....776
See also dimensions

dimensioning system variables, listing.....
781

dimensions
angular. See angular dimensions
associating/reassociating.....833–834
association points.....833
associative

See also associative dimensions
associativity.....831

partial.....831
associativity. See associativity (of

dimensions)
basic dimensions.....803, 805
in the Block Editor. See parameters (in

dynamic blocks)
creating

See also dimensioning
creating tools for.....22
definition points.....831
draw order...308–309, 678, 695, 1000

changing.....308
elements.....777

exploded dimensions. See exploded
dimensions

exploding.....646
filtering associative/nonassociative

selections.....778
linear. See linear dimensions
modifying (editing).....824
nonassociative. See nonassociative

dimensions
radial. See radial dimensions
restyling.....824
scaling

See also dimension scale
styles. See dimension styles
text. See dimension text
types.....776
using a tool created from.....24
values. See dimension values
See also dimensioning

DIMGAP system variable.....723
DIMLINEAR command.....744
DIMRADIUS command.....815
DIMREASSOCIATE command....778–779, 

833
DIMREGEN command.....779
DIMSCALE system variable.....807
direct distance entry.....312, 359, 1024

drawing lines.....359
specifying points.....359

Direct Interpretively Evaluated String
Expression Language (DIESEL)....
1023

direction.....327
of axes, positive, determining.....327

direction vectors.....429
direction, of table text.....763
disassociating

compound objects. See exploding
compound objects

dimensions.....834
discarding.....982

changes for in-place reference
editing.....982

dishes.....433, 440
creating.....433
solid, creating.....440
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display (screen). See screen display
Display Alert upon Standards Violation

option (CAD Standards
Settings/Check Standards dialog
boxes).....142–143

Display Lineweight dialog box.....305
display performance.....306
Display Plot Area option (Page Setup dialog

box).....851–852, 876
Display Standards Status Bar Icon option

(CAD Standards Settings/Check
Standards dialog boxes).....142–
143

display. See screen
displayable attributes. See labels
displaying.....3–4, 11, 45, 47, 56–57, 149, 

160, 264–266, 300–304, 308, 467
command line when hidden.....57
draw order and object display.....308
Quick Help (Info palette).....11
selected layers.....149

distance and angle coordinate display.....
313

distance multiplier action override
property.....507–508

specifying.....507–508
Distance Type property.....490–491, 495, 

497
for move actions.....490–491
for stretch actions.....495, 497

distances
calculating.....363–364
converting between model space and

paper space.....748
entering directly. See direct distance

entry
fuzz distance.....647
measuring the distance between two

points.....380
polar distances.....352–353
specifying.....359

dithering.....903, 905, 1024
turning off.....903, 905

dividing.....360, 362–363

objects.....22–23, 35, 121, 123, 185, 
211, 218, 222, 226, 264, 266–
267, 270–271, 275–276, 281, 
287–288, 290, 297–298, 305, 
308–309, 343, 352–353, 360–
363, 365, 389, 439–442, 445–
447, 457, 461, 470, 546, 568, 
574–575, 577–578, 581, 589, 
592–605, 610–615, 617–624, 
628–633, 635–644, 646, 656, 
668, 681, 696, 734, 870, 974, 
979–980, 998, 1001, 1003, 
1005, 1022, 1034, 1038

into equal segments.....360, 362–
363

dockable window.....1024
dockable windows, in workspaces.....88
docking.....43, 57–58, 63–64

command window.....57–58
DesignCenter.....63
preventing.....64
toolbars.....43

docking windows.....81
doglegs (for dimension text).....815
doglegs (hook lines).....720
dollar sign ($).....769

formula cell address fix value prefix...
769

dollar signs ($).....973
bound named object name dividers...

973
domes.....433, 440

creating.....433
solid, creating.....440

donuts.....306–307, 413, 433, 441, 445, 
646, 689, 694

creating.....433, 689
drawing.....413
exploding.....646
extruding.....441, 445
line widths, changing.....306
modifying.....694
simplified display.....306–307

double-byte characters.....122
renaming drawings named with...122

double-click editing.....265
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DOWN ARROW key, viewing/selecting
options in dynamic prompts.....
337

down-arrow icon.....338
in dynamic input tooltips.....338

downloading online content.....72, 76
dragging.....154, 156, 599, 624, 676, 679, 

1003
as copying and pasting.....1003
as cutting and pasting.....1003
hatch patterns into drawings.....676, 

679
lengthening objects by.....624
objects.....22–23, 35, 121, 123, 185, 

211, 218, 222, 226, 264, 266–
267, 270–271, 275–276, 281, 
287–288, 290, 297–298, 305, 
308–309, 343, 352–353, 360–
363, 365, 389, 439–442, 445–
447, 457, 461, 470, 546, 568, 
574–575, 577–578, 581, 589, 
592–605, 610–615, 617–624, 
628–633, 635–644, 646, 656, 
668, 681, 696, 734, 870, 974, 
979–980, 998, 1001, 1003, 
1005, 1022, 1034, 1038

into drawings.....1003
panning by.....154
rotating objects by.....599
zooming by.....156

dragline. See rubber-band line
draw order.....308–309, 678, 695, 1000

of hatches.....678
of dimensions.....308

changing.....308
modifying.....695

of objects.....218, 270, 308–309
changing.....308–309

of text.....308
changing.....308

OLE objects and.....1000
drawing

arcs.....403
specifying three points.....406
tangent to arcs.....407
tangent to lines/arcs.....405

using start point, center point,
and endpoint.....406

circles.....407–408
tangent to objects.....407–408

construction lines.....419–420
donuts.....413
ellipses.....414–415
elliptical arcs.....415
equilateral triangles.....395–397
geometry.....119, 461, 514, 519–520, 

777, 1028
for dynamic blocks.....461

isometric circles.....414
lines.....192, 302, 349, 359, 380, 390–

391, 395, 405–406, 438, 441, 
626, 647–648, 764, 1018, 
1040, 1043

in viewports.....192
in model space.....302
tangent to arcs.....405–406
using direct distance entry.....359
using orthogonal locking.....349

in model space.....198
multilines.....398
objects.....22–23, 35, 121, 123, 185, 

211, 218, 222, 226, 264, 266–
267, 270–271, 275–276, 281, 
287–288, 290, 297–298, 305, 
308–309, 343, 352–353, 360–
363, 365, 389, 439–442, 445–
447, 457, 461, 470, 546, 568, 
574–575, 577–578, 581, 589, 
592–605, 610–615, 617–624, 
628–633, 635–644, 646, 656, 
668, 681, 696, 734, 870, 974, 
979–980, 998, 1001, 1003, 
1005, 1022, 1034, 1038

for dynamic blocks.....461
in layout viewports.....211
using polar distances.....353
using polar tracking.....352

polygons.....392, 395–397, 409
polylines.....300–302, 306, 365, 391–

395, 401, 409–412, 441–442, 
445, 611, 626–627, 629, 632, 
634, 646–649, 972, 1038
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freehand.....401
in model space.....302

rays.....420–421
rectangles.....395, 397
reference points.....419
splines.....417
squares.....395, 397
wide polylines.....392, 394, 409, 411
See also drawings

drawing (DWG) files..112, 116, 121, 123–
124, 128–129, 237, 243, 456, 
458, 466, 546–547, 562–563, 745

as blocks.....116, 456, 458, 466, 546–
547, 562–563

creating.....456, 458
inserting.....116, 546–547
opening.....466
updating block definitions

from.....562–563
auditing.....128
checking.....116, 136, 140, 143, 146, 

670, 749–750, 922
for authenticity.....116

file name extension.....121
finding.....112, 124, 745
for sheet sets/views.....237

consolidating.....237
inserting as blocks.....116
repairing damaged files.....128–129
saving block definitions as.....123
saving selected objects into.....121, 

123
transmitting on the Internet. See

transmittal sets
See also drawings

drawing area.....46, 80, 82
clearing the screen.....80
coloring elements in.....80, 82
font selection (for windows).....80
right-clicking in.....46
turning off shortcut menus in.....46

drawing area (in application window).....
96, 1024

turning off shortcut menus in.....96
drawing boundary. See drawing limits

drawing content. See content
(DesignCenter)

drawing display.....89
changes stored in profile/saved to

workspace.....89
drawing extents....94, 156–157, 181, 1024

zooming to.....94, 156–157
in 3D Orbit view.....181

drawing interchange binary files. See DXB
(drawing interchange binary) files

drawing interchange files. See DXF
(drawing interchange format) files

drawing limits.....1024
drawing limits. See grid limits
drawing orientation.....860–861, 880

setting.....861
drawing planes (in 3D space).....326, 329

specifying.....326
drawing projects. See projects
drawing properties.....112–113, 124

changing.....112
creating additional.....112
defining.....113
displaying.....113
in fields (in text).....113
finding drawing files with certain

properties.....112, 124
Drawing Properties dialog box.....113

defining drawing properties.....113
Drawing Recovery Manager.....131–133

expanding/collapsing nodes in....133
opening.....131–132
removing drawings from.....133

drawing sets.....234, 923, 929–934, 939, 
1024

creating.....923
including model layouts in.....923, 

930, 933
publishing.....923
republishing.....939

drawing sheets (in drawing sets).....923–
928, 930–933

adding.....923, 925, 930, 932
copying.....924, 927, 931, 933
page setups for....237, 253, 924, 928, 

930, 933
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changing.....924, 928, 930, 933
importing.....928

removing.....924, 926, 930, 933
renaming.....924, 927, 930, 933
reordering in the sheet list.....924, 

926, 930, 933
drawing standards. See standards (for

named objects)
drawing template.....1025
drawing templates/template files

contents common to.....105
creating.....105–106
for creating sheets.....237
default file. See default drawing

template file
default location.....105
for extracting attribute information.

See attribute extraction
template files

file name extension.....105
importing layouts from.....208
starting drawings with.....85, 102–

103, 105–106
See also templates (template files)

drawing tools (precision tools).....312
drawing units.....107–111, 199–200, 312

angular unit conventions.....111
converting.....107–108, 110–111
coordinate unit types.....312
determining.....107, 199
linear unit conventions.....109
precision.....109
rounding off of.....109
setting.....108, 110, 199–200
See also architectural units
See also imperial units
See also metric units

DRAWINGRECOVERY command.....131
drawings

accessing.....64
adding from/to tool palettes.....68
adding hatch patterns to.....676
associating standards files with...138–

139

attaching digital signatures to. See
files, attaching digital
signatures to

attaching xrefs to.....964, 966–967
with DesignCenter.....965–966
overlaying xrefs on vs......967

background colors.....80
binding.....973–975

dependent named objects to.....
973–974

xrefs to.....974–975
checking.....116, 136, 140, 143, 146, 

670, 749–750, 922
for standards violations.....136, 

140, 143, 146
comments on. See markups
content for. See content (for drawings)

(DesignCenter)
content. See content (for drawings)

(DesignCenter)
converting to a different plot style

type.....891–892
copying.....41, 53, 55, 120, 209, 267–

268, 273, 456–457, 469, 594–
595, 604–605, 641–643, 665, 
667, 767, 769, 899, 924, 927, 
931, 933, 994–995, 1003

layers between.....273
paper space objects between.....

457
copying between.....120
correcting. See markups
creating.....37, 41, 68, 89, 170, 207–

208, 229–230, 237–238, 253, 
422–423, 439, 441, 448, 455–
456, 458, 460, 465, 517, 610, 
744, 751, 753, 818, 862

tool palettes from.....37
creating drawing template files

from.....105–106
default folder.....116

changing.....116–117
design environment. See model space
detaching xrefs from.....976
dimensioning. See dimensioning
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displaying.....3–4, 11, 45, 47, 56–57, 
149, 160, 264–266, 300–304, 
308, 467

in the Aerial View window....160
displaying on the Windows taskbar...

120
downloading content to.....77
dragging objects into.....1003
embedding objects in.....998, 1003
exporting

See also plotting to files
files. See drawing (DWG) files
identifying information in. See

drawing properties
initial environment.....1030
layout environment. See paper space
linking.....998, 1001–1002, 1005

files in.....1002
objects in.....998, 1001

marking up. See markups
multiple open drawings.....120
multiple. See multiple drawings
naming.....122, 162, 194, 272, 281, 

734
for international work.....122

offsetting (on paper).....880
opening.....15, 68, 70, 116–118, 145, 

238–239, 243, 246–247, 464–
466, 528, 539

authenticity check.....116
with DesignCenter.....68, 70
in Windows Explorer.....116
partially.....117–118
within sheet sets.....243, 246–247

orientation.....860–861, 880
panning. See panning
partially open. See partially open

drawings
pasting objects into.....594–595
plotting. See also plotting
preparing for plotting (process

steps).....204
previewing.....124

for plotting.....911–912
printing. See printing
properties. See drawing properties

reducing.....269, 453
file size.....453

regenerating.....1039
removing standards files from.....139
renaming drawings named with

double-byte/special
characters.....122

repairing open drawings.....129
restoring from backup files...130–131
saving.....37, 42, 80, 87–88, 91, 121–

124, 130, 138, 161–162, 193–
194, 229, 231, 254, 259, 284, 
324, 329, 402, 541, 581, 766, 
772, 940, 993–995

automatic saves.....80, 123, 130
incremental saves.....121
with layer indexes.....993–995
partial saves.....121, 123
with preview images.....124
reducing the time required for....

121
saving backup files when.....123, 

130
with spatial indexes.....993–995
to different formats.....121

scaling.....107, 198–199
to fit the paper.....854–855, 882–

883
for plotting.....199, 854, 881

signing. See digital signatures
standards for. See standards (for

named objects)
starting.....101–102

with the default drawing template
file.....103

with drawing templates/template
files....102–103, 105–106

with wizards.....104
starting, with templates.....85
switching between.....120
templates. See templates (template

files)
titles. See title blocks
working drawings.....1046
with xrefs, archiving.....974
zooming. See zooming
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DRAWORDER command.....308
DS\$ (sheet set data backup) files.....238
DSD (Drawing Set Descriptions) files.....

920, 925, 940, 1025
adding drawing sheets to drawing sets

from.....925
saving publish options to.....940

DST (sheet set data) files....236, 257, 1025
team member access to.....257
update of data from team member

changes.....257
DWF (Design Web Format) files.....253, 

256, 913, 920, 932, 934–935, 940–
941, 943, 953–958, 1025, 1033

compression.....955
specifying.....955

distribution options.....920
font-handling.....956

editing the fonts eligible for
capture list.....957

specifying.....956
format.....913
layers displayed in.....913
minimizing file size.....956–957
multi-sheet.....1033
named views displayed in.....913
opening/viewing/plotting.....913
output directory.....941

changing the default.....941
output type.....941

setting.....941
panning/zooming in.....913
password security.....943

specifying.....943
pen settings...863, 894, 901, 906, 958

editing.....958
plot files. See DWF plot files (plotted

DWF files)
plotting.....913, 920
published.....256

sheet properties in.....256
published files. See published DWF

files
publishing....253, 868, 873–874, 920–

921, 923, 929–932, 934–939, 
948

property options for.....253
publishing electronic drawing sets

as.....920
publishing electronic drawing sets

to.....932, 934
publishing sheet sets to.....935
publishing sheet subsets to.....935
resolution.....953

specifying.....953–954
viewers.....913
viewing.....920

in Autodesk DWF viewer.....940
DWF plot files (plotted DWF files)....941, 

950, 952
background color.....950
output directory.....941

changing the default.....941
settings.....950

color depth.....952
specifying.....952

DWF6 ePlot.pc3 plotter configuration
files.....932

creating.....950–951
recreating the default file.....950
settings.....950

color depth.....952
file compression.....955
font handling.....956–957
resolution.....953–954
specifying.....952

DWF6 files
plotting.....950
See also DWF (Design Web Format)

files
DWF6 plotter drivers

configuring.....950
See also DWF6 ePlot.pc3 plotter

configuration files
DWG (drawing) files.....1025
DWG file name extension.....121, 229
DWG files. See DWG (drawing) files
DWGCHECK system variable.....116
DWS (standards) files

See also standards files
DWT (template) files
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See also drawing templates/template
files

team member access to.....257
DWT file name extension.....105, 229
DXB (drawing interchange binary) files....

914
creating (plotting).....914
format.....914

DXB driver.....914
DXF (drawing interchange format) files....

559, 1025
format.....559

Dyn button (status bar).....335
dynamic block definitions.....460, 462, 

474, 476, 478–480, 482–489, 491–
495, 497–499, 501–503, 505–506, 
508, 510, 514, 521, 538–540

adding actions to.....460, 462, 474, 
488

array actions.....503, 505
flip actions.....502–503
lookup actions.....506, 521
move actions.....489, 491
polar stretch actions.....497–498
rotate actions.....499, 501
scale actions.....492–493
stretch actions.....494–495

adding parameter sets to.....508
adding parameters to.....460, 462, 

476, 508, 510
alignment parameters.....484
base parameters.....487
flip parameters.....485
linear parameters.....479
lookup parameters.....486
point parameters.....478
polar parameters.....480
rotation parameters.....483
visibility parameters.....486, 514
XY parameters.....482

correcting.....540
deleting elements from.....539
modifying.....538
opening.....539

dynamic block references.....548, 550
resetting.....550

dynamic blocks..452, 459–463, 466, 471, 
473–475, 521, 527, 531, 540, 
548, 550

_aaz3D solids in.....463
actions. See actions (for dynamic

blocks)
adding elements to. See dynamic block

definitions
assigning data to.....521
base point.....463
behavior.....452
changing data associated with.....521
creating.....459–460, 474–475

process steps.....460
dependencies (element relationships)

in.....462
viewing.....540

dependency highlighting (in the Block
Editor).....471

turning on/off.....473
designing.....461
drawing geometry for.....461
editing by changing lookup

properties.....527
allowing/disallowing.....527

exploding....438, 531, 570–571, 589, 
646, 1026

allowing/disallowing.....531
grips. See grips (for parameters)

(custom grips)
manipulating, with custom grips.....

550
manipulating, with custom

properties.....550
opening.....466
overview.....460
parameters. See parameters (for

dynamic blocks)
properties. See action override

properties
properties. See parameter properties
resetting after manipulation.....550
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scaling....23, 107, 198–201, 216–217, 
224–225, 299, 531, 622–623, 
638, 640, 743, 747–748, 758, 
761, 854–855, 881–883, 907, 
909

preventing non-uniform
scaling.....531

testing.....463, 540
dynamic coordinate display.....313
Dynamic Input.....335, 339

turning on/off.....335, 339
using.....335

dynamic input tooltips.....338
correcting typing errors.....338
entering coordinate values in.....338

dynamic panning (Realtime option)...154
dynamic prompts (tooltips).....337, 339, 

341
choosing options.....339
displaying.....341

dynamic updating of the Aerial View
window.....159–160

turning on/off.....160
dynamic viewing (of 3D objects).....170
dynamic zooming (Realtime option).....

155

E

e-Learning Catalog option, Subscription
Center.....13

e-learning lessons (Autodesk).....12
edge-defined surface meshes.....429, 432, 

438
creating.....432, 438

edges.....435, 615
boundary edges.....615
cutting edges.....615
invisible edges of polyface meshes.....

435
edges (of 3D solids)....656, 666–667, 1025

coloring.....667
copying.....667
modifying.....656, 666

EDGESURF command.....429, 432
Edit shortcut menu.....46

displaying.....46
editing

attribute definitions.....552–553
block references, in place.....977–978
block template (BLK) files.....947
calculator variables.....385
in the command window.....54
custom paper sizes.....850, 879
dictionaries (custom).....749–751
embedded objects.....1007
fields (in text).....726
the fonts eligible for capture list...957
groups.....588
hatch boundaries.....678
layer.....286

settings.....286
layers, controlling.....270
in layout viewports.....212
linked objects (drawings).....1007

when AutoCAD is the destination
application.....1007

when AutoCAD is the source
application.....1007

multiline.....653, 698
styles.....653
text.....698

multiline styles.....654–655
multiline text.....744, 746
objects.....596

with grips.....637
methods.....596

OLE objects in drawings.....1006
plot style tables.....857, 895
plot styles.....895, 902
sheet/sheet set properties.....251
splines.....650, 652

with grips.....650
tables.....759
text. See editing text
xrefs.....976

in place.....977–978
in a separate window.....976

See also modifying
editing commands.....582–583, 654

commands not for multilines.....654
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entering before selecting objects.....
582

selecting objects before entering.....
583

editing text.....719, 743, 748, 765, 768
leader text.....748
single-line text.....743
stacked text.....719
in table cells.....765, 768

educational products.....966
electronic drawing sets.....920, 931–932, 

934, 940, 1025
creating.....932
plotting published sets.....940
publishing....253, 868, 873–874, 920–

921, 923, 929–932, 934–939, 
948

as DWF files.....920
to DWF files.....932, 934

viewing published sets.....940
electronic markup feature

See  markups (markup objects)
electronic sheet sets.....935

publishing.....935
elevation.....1025
elevation (default Z value).....329

in UCSs.....329
ELLIPSE command.....336

dimensional input.....336
ellipses

calculating areas/perimeters.....365
creating.....37, 41, 68, 89, 170, 207–

208, 229–230, 237–238, 253, 
422–423, 439, 441, 448, 455–
456, 458, 460, 465, 517, 610, 
744, 751, 753, 818, 862

cones from.....439
cylinders from.....439

drawing.....414–415
extruding.....441, 445
revolving.....442
See also objects

elliptical arcs.....415
drawing.....415

embed.....1026
embedded objects.....998, 1006–1007

editing.....1006–1007
embedding.....998, 1003, 1005

objects.....22–23, 35, 121, 123, 185, 
211, 218, 222, 226, 264, 266–
267, 270–271, 275–276, 281, 
287–288, 290, 297–298, 305, 
308–309, 343, 352–353, 360–
363, 365, 389, 439–442, 445–
447, 457, 461, 470, 546, 568, 
574–575, 577–578, 581, 589, 
592–605, 610–615, 617–624, 
628–633, 635–644, 646, 656, 
668, 681, 696, 734, 870, 974, 
979–980, 998, 1001, 1003, 
1005, 1022, 1034, 1038

in drawings.....998, 1003
in other application

documents.....1005
encircled sphere icons (in 3D Orbit

view).....179
ENTER key.....52, 766

executing commands.....52
moving down one cell.....766
repeating commands.....52

entering....52, 54, 56, 312, 314–323, 326–
327, 334, 338, 354–355, 582–583, 
765–766, 769, 772

commands.....10, 28, 46, 52–53, 55–
56, 217, 335, 374–375, 463, 
591, 1044

displaying prompts on the
command line.....56

on the command line.....52
suppressing dialog boxes.....56

coordinate values.....313, 336, 338, 
364

in dynamic input tooltips.....338
coordinates

broken pencil icon warning.....
334

in 3D space.....326
relative to the WCS.....327
relative values.....312, 315–316
See also under \

editing commands.....582–583, 654
after selecting objects.....583
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before selecting objects.....582
formulas.....769–773

in table cells.....769, 772
system variables, on the command

line.....54
text.....55, 199–200, 308, 613, 698–

699, 701, 703, 705, 707, 724, 
732, 741–743, 745–746, 748, 
753, 765–766, 827, 829

in table cells.....765–766
enterprise customization files.....1026
environment.....87

customizing, with profiles.....87
environment maps. See reflection maps
environment profiles. See profiles (of

environment settings)
environment settings.....86

precedence.....86
environment variables.....86, 1026

precedence of settings.....86
EPS (Encapsulated PostScript) files.....916–

917
format.....916
plotting.....916–917

equal sign (=).....769, 772
formula start character.....769, 772

equilateral triangles.....395–397
drawing.....395–397

erased objects.....592–593
restoring.....592–593

erasing.....401–402, 590
freehand lines.....401–402
undoing.....590

erasing objects.....592
error.....988

messages, from xrefs.....988
error reporting (to Autodesk).....13, 132–

133
Resolved Error Reports.....13
turning on/off.....133

errors
correcting mistakes. See undoing

actions
in dynamic input tooltips,

correcting.....338
ESC key.....53, 591

canceling commands.....53, 591
evaluating mathematical expressions.....

80, 83
in dialog boxes.....80, 83

executing.....52
commands.....52

exernal references (xrefs).....27
placing from tool palette.....27

prompt for rotation angle.....27
exiting.....180, 182

3DORBIT command.....180, 182
expanding text.....699
EXPLODE command.....395
exploded dimensions.....778, 832, 1026

modifying.....832
exploding...438, 531, 570–571, 589, 646, 

1026
blocks.....1026
compound objects.....438, 570–571, 

589, 646
3D solids.....438
associative hatches.....646
blocks.....570–571, 646
donuts.....646
groups.....589
polylines.....646
xrefs.....646

dynamic blocks...452, 459–463, 466, 
471, 473–475, 521, 527, 531, 
540, 548, 550

allowing/disallowing.....531
objects.....646, 1026

export file formats
CDF files.....558
DXF files.....559
SDF files.....558
WMF format.....594
See also plot file formats

exporting.....42, 87, 147, 285, 438, 762, 
1004

batch audit reports.....147
block attributes. See extracting

attribute information
environment profiles.....87
layer settings.....285
OLE objects.....1004
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tables.....762
tool palettes.....42
See also export file formats

expressions (in QuickCalc).....372, 375–
376, 378

calculating (evaluating).....375
changing the font color in the History

area.....378
copying from the History area.....378
entering and retrieving.....372
precedence rules.....375
syntax.....376

EXTEND command.....617–618
extending.....615, 617–619, 626, 631

chamfered objects.....631
filleted objects.....626
objects.....615, 617–618

in 3D.....618–619
while trimming.....615

spline-fit polylines.....618
wide polylines.....617

extending objects
See also stretching

extension line origins.....809, 833
as association points.....833

extension lines...777, 784, 786, 795, 809, 
814, 823, 833

for arc length dimensions.....823
control options.....784
fixed-length lines.....786
modifying.....786
oblique.....814
origins of.....809, 833
placing dimension text at the

second.....795
properties.....784

extension origin offset.....830
changing.....830

extents.....1026
Extents Plot Area option (Page Setup dialog

box).....851–852, 876
extents. See drawing extents
external databases

See also database objects
external references (xrefs)

attaching.....551–552, 965–967

with DesignCenter.....965–966
overlaying vs......967
tools for.....965

binding.....973–975
to drawings.....974–975

vs. blocks.....457
bound xref name prefix.....981
changed xrefs.....969

accessing.....969
notification of.....969

circular references.....990
clipped.....971
clipping.....972, 993
contextual fields in.....730
copying, for demand loading.....994–

995
creating tools for.....22
detaching.....976
discarding changes to.....982
drawing files for sheet views as.....243
in drawing files inserted as blocks.....

546
drawings with, archiving.....974
editing.....976

in place.....977–978
in a separate window.....976

error messages.....988
exploding.....646
freezing layers of.....993
from Autodesk Educational Product...

966
layer properties.....965
listing.....991
log files, turning on/off.....992
nested. See also nested xrefs
notification of attached xrefs.....965

relocated xrefs.....985
notification of changed xrefs.....969
OLE objects in.....982
overlaying.....966–967

vs. attaching.....967
with DesignCenter.....966

reloading.....969
saving back changes to.....981–982
saving with indexes.....993–995
unloading.....992–993
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updating.....964, 969–970
with demand loading turned

on.....970
uses.....964
using a tool created from.....27

extracting.....476, 529, 552, 554–555, 561
attribute information....552, 555, 561
block attribute data.....554
block attribute information.....555
custom properties (in dynamic

blocks).....529
parameter values.....476

EXTRUDE command.....441
extruded.....439, 441

solids.....439, 441
boxes.....439
cones.....439
creating.....441
cylinders.....439
tapering.....439, 441

extruding.....439, 441, 445, 660–661
faces of 3D solids.....660–661
objects.....22–23, 35, 121, 123, 185, 

211, 218, 222, 226, 264, 266–
267, 270–271, 275–276, 281, 
287–288, 290, 297–298, 305, 
308–309, 343, 352–353, 360–
363, 365, 389, 439–442, 445–
447, 457, 461, 470, 546, 568, 
574–575, 577–578, 581, 589, 
592–605, 610–615, 617–624, 
628–633, 635–644, 646, 656, 
668, 681, 696, 734, 870, 974, 
979–980, 998, 1001, 1003, 
1005, 1022, 1034, 1038

circles.....439
extrusion.....1027

F

F1 key, Help resource.....10
F12 key, for Dynamic Input.....335
F2 key, switching from the command

window to the text window....55
F3 key.....342

turning running object snaps
on/off.....342

face.....1027
faces

3D faces. See faces (of 3D solids)
surface mesh faces.....429

faces (of 3D objects).....1027
faces (of 3D solids)

back faces. See back faces
boundary sets.....659
coloring.....666
copying.....665
deleting.....665
edges. See edges (of 3D solids)
extruding.....660–661
modifying.....656, 659
moving.....661–662
offsetting.....663
rotating.....662
selecting.....659
tapering.....660, 664

faceted surfaces. See meshes
faceted surfaces. See surface meshes
FACETRES system variable.....438
fade (fading).....977

of objects not in working sets.....977
falloff of light. See attenuation of light
Favorites folder (DesignCenter).....65–67

adding items to.....65–66
displaying the contents.....67

feature control frames.....835, 837, 1027
compartments.....835, 837

features (of objects), material condition
symbol.....837

features (of objects), material condition
symbols.....835

feet.....110, 376, 802
QuickCalc formats.....376
specifying.....110
suppressing zero values.....802

fences.....1027
fields (in formulas).....773

inserting.....116, 230–231, 360–363, 
458, 546–547, 704–705, 724–
728, 752, 759, 761, 765, 768–
771, 773
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in table cells.....773
fields (in text).....113, 699, 702, 725–728, 

730–732, 769, 1027
adding hyperlink fields.....732
background.....726
compatibility with AutoCAD LT and

previous releases of
AutoCAD.....731

contextual fields.....730
displaying object properties in.....727
drawing properties in.....113
editing.....726
formatting options.....726
inserting.....725–726

as placeholders.....725, 728
in table cells.....727, 769

invalid field display.....725
no value in field display.....725
preserving values in.....726
selecting.....726
text style.....726
updating automatically.....731
updating manually.....731
updating multiple fields.....731

fields. See database record fields
file compression.....955

of DWF files.....955
specifying.....955

file formats.....558–559, 594, 913–914, 
916–917

attribute extraction files.....558
CDF files.....558
DWF files.....913
DXB files.....914
DXF files.....559
HP-GL format.....917
HP-GL/2 format.....917
PostScript files.....916
SDF files.....558
WMF files.....594

FILEDIA system variable.....57
files

linking in drawings.....1002
plotting to.....913–918

DWF files.....913
DXB files.....914

plot files.....918
PostScript files.....916–917
raster files.....915

script files.....1040
signing. See digital signatures
slide files.....1041
support. See support files
temporary files.....1043
temporary. See temporary files

Files tab (Options dialog box).....125
Fill mode, turning on or off.....307
fill patterns, scaling.....909
fill styles.....910–911

assigning.....910–911
FILLET command.....624, 656
fillet radius.....625, 628

overriding.....628
setting.....625, 628

filleted objects.....626
trimming and extending.....626

filleting (rounding).....624, 626–629
hatch boundaries.....624
line segments.....628
lines with polylines.....626
multiple sets of objects.....624, 629
objects.....624

in 3D.....628
without trimming.....628

parallel lines.....627
polylines.....627, 629

filleting objects.....656
3D solids.....656

fillets (rounds)
creating.....624
creating. See filleting objects
setting the radius.....625, 628
specifying locations for.....626

fills.....702, 764, 909–911, 1027
assigning styles.....910–911
multiline text object fills.....702
scaling patterns.....909
table colors.....764

filtered lists, saving.....581
filtering.....147, 272, 281–282, 579, 583

batch audit report data.....147
layer names.....272
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layer names by selecting layers.....282
layers, by layer property.....281
layers, by name.....281
nested layer filters.....282
object selection.....583
selection sets.....579

filters
layer filters.....278
named object selection filters.....579, 

581
See also coordinate filters

FIND command.....745
Find tool.....112

finding drawing files.....112
finding.....75–76, 112, 124, 745–746

drawing files.....112, 124, 745
online content.....75–76
text.....55, 199–200, 308, 613, 698–

699, 701, 703, 705, 707, 724, 
732, 741–743, 745–746, 748, 
753, 765–766, 827, 829

multiline text.....745–746
fit points (for spline curves).....651, 1027, 

1030
interpolation points.....1030

fit tolerance.....1027
fixed-length extension lines.....786
flat shading.....183
flip actions.....502–503

adding to dynamic block
definitions.....502–503

parameter supported by.....502
flip grips.....510, 549
flip parameters.....474, 476, 485, 508

actions supported by.....474, 476
adding to dynamic block

definitions.....485
grip type.....474
sets.....508

Flip Set parameter set.....508
flipped arrowheads.....787

appearance in earlier versions.....787
flipping

arrowheads.....788
See also mirroring

flipping. See mirroring

floating properties, block insert settings...
542

floating viewports.....1027
floating. See undocking
FMP (font mapping) files.....739
folders.....37, 66, 116–117, 125–126

creating tool palettes from.....37
default drawing folder.....116

changing.....116–117
DesignCenter Home button folder,

changing.....66
My Documents folder.....116

specifying the search path...125–
126

See also Favorites folder
Folders tab (DesignCenter).....64
font mapping files.....738–739

default table.....739
for PostScript fonts.....738
specifying.....739

FONTALT system variable.....738
fonts....707, 735–739, 752, 956–957, 1028

alternative font.....738–739
format code.....752

assigning to text styles.....736–737
Big Fonts.....736
changing multiline text fonts.....707
converting.....738
DWF file font-handling.....956

editing the fonts eligible for
capture list.....957

specifying.....956
modifying, with text styles.....735
proxy fonts.....735, 738
specifying.....736
styling.....735
substitute fonts.....738

foreshortened radius dimensions. See
jogged radius dimensions

format codes, for multiline text.....753
formatting text

character formatting.....734
in fields.....726
multiline text.....702–703, 706–707

in alternate text editors.....752
as lists.....709
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stacked text.....717
in table cells.....765–766
See also text styles

formulas.....769–773
cell address fix value prefix.....769
copying to other table cells.....769
entering in table cells.....769, 772
fields in.....773

inserting in table cells.....773
inserting in table cells.....769–771
start character.....769, 772

fractions.....717–719
stacking.....717–718
unstacking.....719

freehand lines (sketching).....401–402
accuracy on slow computers.....402
erasing.....401–402
linetypes.....401
saving.....402
in Tablet mode.....401

freeze.....1028
freezing.....190, 218–221, 270, 993, 1028

layers....118, 148–150, 190, 211, 218–
221, 263–264, 268–277, 279–
283, 290, 297–298, 301, 303, 
305, 568–569, 578–579, 944, 
965, 993, 1000, 1031

in layout viewports.....190, 218–
221

in paper space.....221
of xrefs.....993

From option (object snaps).....359
front faces.....1028
front, moving objects to.....308

draw order of objects.....308
frozen layers.....218–219, 221, 270

creating.....219, 221
functions.....383

calculator variables.....383
fuzz distance.....647

G

gap tolerance in hatch boundaries....676, 
681

general surface meshes.....429, 434–435

creating.....434–435
geometric

characteristics.....835
points. See points (geometric)
tolerances.....803, 835

composite tolerances.....838
creating.....835–836
creating with leaders.....836
projected tolerances.....838

geometric characteristic symbols.....835
geometric objects.....22, 24

drawing, creating tools for.....22
using a tool created from.....24

geometry....119, 461, 514, 519–520, 777, 
1028

dimension geometry.....777
for dynamic blocks

drawing.....461
making objects invisible in

visibility states.....519–
520

making objects visible in visibility
states.....519

See also action selection sets
showing/hiding.....514, 520

loading into partially open
drawings.....119

getvar AutoLISP function.....376
GIS blocks, accessing collections of.....75–

76
global constants.....383, 385–386

accessing.....383
accessing from dialog box or

window.....386
creating.....383
specifying from the QuickCalc Input

box.....385
Global Scale Factor value (linetype

scale).....299
Gouraud shading.....183–184
gradient fills....22, 306–307, 689–691, 695

creating.....690
creating tools for.....22
modifying.....691, 695
simplified display.....306–307

graphical objects. See objects
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graphics area.....1028
graphics area. See drawing area
graphics cursor. See crosshairs
graphics screen.....1028
graphics system (3D), default.....174
graphics window.....1028
graphics window. See application window
grayscale.....904–905

converting colors to.....904–905
grid.....347–348

displaying.....348
spacing.....347

setting.....348
vs. snap grid spacing.....347

grid (drawing area)
in 3D Orbit view.....178
See also snap (snap grid)

GRID command.....178
and 3DORBIT command.....178

grid limits.....156–157, 1028
zooming to.....156–157

grid limits, calculating.....200
grid snap. See snap
gridlines (tables).....764
grip modes.....637–638, 1029

cycling through.....637
grip tips, displaying.....639
GRIPDYNCOLOR system variable.....549

changing color of custom grips....549
GRIPOBJLIMIT system variable.....638
grips....336, 636–641, 643–645, 650, 743–

744, 758–760, 828, 1006, 1022, 
1029

base grips.....637
in blocks.....645
canceling grip selection.....639
copying objects.....641, 643
custom.....1022
editing...54, 212, 251, 270, 286, 385, 

552–553, 588, 596, 637, 650, 
652–655, 678, 698, 726, 744, 
746, 749–751, 759, 850, 857, 
879, 895, 902, 947, 957, 976–
978, 1006–1007

objects.....637
splines.....650

editing OLE objects with.....1006
hover color.....639
limiting the display of.....638–639
mirroring objects.....638, 641

retaining the originals.....644
moving.....37, 323, 596–598, 638, 

640, 661–662, 744, 746, 759, 
827–828

dimension text.....828
objects.....638, 640

moving multiline text.....744
for parameters. See grips (for

parameters) (custom grips)
quadrant grips.....637
rotating objects.....638, 640
scaling objects.....638, 640
selecting.....637
stretching objects.....638–639
table cells.....758–760
for text objects.....743
turning on/off.....639
using with dimensional input.....336

grips (for parameters) (custom grips).....
470–474, 476, 510, 512–514
specifying color.....472
specifying size.....472

dependency highlighting.....471
turning on/off.....473

as displayed in the Block Editor.....
470, 474

insertion cycling.....512
modifying the grips order.....514
turning on/off.....512–513

repositioning.....510, 513
resetting.....510, 513
specifying.....510, 512
types....426, 474, 476, 489, 510, 549, 

891
by parameter type.....474

grooves in cylinders, creating.....439
Group Manager.....587

button availability.....587
closing.....587

group selection, toggling.....588
groups (of objects).....586–589

adding objects to.....589

1091 | Index



vs. blocks.....586
creating.....587–588
cycling through objects in.....588
editing.....588
exploding objects in.....589
removing (ungrouping).....589
removing objects from.....589
reordering objects in.....589
selecting.....588
toggling group selection.....588
unnamed groups.....587

H

handles.....1029
hanging indents, creating.....715
hardware.....293

linetype use.....293
hatch angle.....695

changing.....695
hatch areas.....680–681, 683, 687, 694

hatching.....680–681
with a solid pattern.....687

holes within.....694
islands within.....681

creating.....694
removing.....683

planar requirement.....681
hatch associativity.....677, 694

loss of.....677, 694
removing.....677, 694
restoring.....694

hatch boundaries
bridging gaps in.....676, 681
chamfering.....629
in complex drawings. See boundary

sets
defining.....676, 681

with boundary points....685–686
as boundary sets.....684
with internal points.....680
redefining.....694

editing.....678
enclosed areas within. See islands (in

hatch areas)
filleting.....624

gap tolerance.....676, 681
hiding.....685
modifying.....694
recreating.....694
See also boundary sets

HATCH command.....676–677, 681, 684
hatch objects.....343

setting object snaps to ignore.....343
hatch patterns

adding to drawings.....676
adding to the program supply.....677
aligning.....347
angle.....695

changing.....695
behavior.....677
choosing.....677, 691
default file.....679
defining custom patterns.....679
density limit.....678, 693

setting.....678, 693, 695
dragging into drawings.....676, 679
enclosed areas within. See islands (in

hatch areas)
ISO patterns.....677, 691
loading the DesignCenter content area

with.....70
location.....677
modifying.....693
predefined patterns.....677, 691

using.....691
scaling.....199
solid fills.....687
solid, See also gradient fills
user-defined patterns.....692

hatches
adding to tool palettes.....68
associative hatches.....677, 694
associative. See associative hatches
associativity.....677, 694
boundaries. See hatch boundaries
creating, creating tools for.....22
creating. See hatching
draw order.....678

modifying.....695
islands in. See islands
modifying.....693
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nonassociative hatches.....677, 694
origin point.....677
patterns. See hatch patterns
simplified display.....306–307
solid-filled hatches.....687, 694
trimming.....685, 694
unbounded hatches.....685
using a tool created from.....26
See also hatch areas
See also hatching

hatching.....676, 679–681, 687
areas.....680–681

with a solid pattern.....687
dragging hatch patterns into

drawings.....676, 679
objects.....681

HDI (Heidi Device Interface).....1029
header rows in tables.....764
height.....707, 740, 752, 759, 761, 764

of rows in tables.....759, 761
of text in tables.....764

Help
Autodesk website.....10
on commands.....10
for developers, starting.....4
on dialog boxes.....10
F1 key.....10
late-breaking product information.....

10, 18
queries (natural language queries).....

7
Quick Help.....10
Readme topic.....10, 18
starting.....4
on system variables.....10
topics. See Help topics
windows. See Help window

Help Contents. See Contents tab (Help
window)

Help toolbar, buttons.....9
Help topics.....3–7

displaying.....3–4, 11, 45, 47, 56–57, 
149, 160, 264–266, 300–304, 
308, 467

contents list.....3–4
index.....3

natural language queries vs. topic
searches.....7

searching for words/phrases.....3, 5
advanced search rules.....5
basic search rules.....5
in the current topic.....3

Help window.....3–5, 7, 9–10
Ask Me tab.....4, 7
components.....3
Contents tab.....3–4
expanding (restoring).....10
Index tab.....3
left pane.....3

hiding/redisplaying.....9
Search tab.....3, 5
shrinking.....9

hidden lines.....884, 887–888
removing.....884

plotting from layout tabs.....888
plotting from the Model tab.....

887
hidden-line images

creating.....182
smoothness.....438
See also hidden lines (in 3D objects)

Hide button (Help toolbar).....9
hiding

columns, in the Layer Properties
Manager.....272

command window.....57–58
hatch boundaries.....685
lines. See hidden lines, removing
lines. See removing hidden lines in 3D

objects
objects.....270
paper space objects, plotting from a

layout tab.....886
tree view, in Layer Properties

Manager.....272
hiding, lines. See removing, hidden lines
HIGHLIGHT system variable.....583
highlighting

duplicate attribute tags.....564, 566
objects.....583
See also dependency highlighting (in

the Block Editor)
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See also selecting
highlights. See specular reflection
History area (QuickCalc).....376, 378

changing value or expression font
colors in.....378

clearing.....378
copying values or expressions from...

378
History tab (DesignCenter).....65
HLS color system.....1029
Home button (DesignCenter), changing

the folder.....66
home folder, in DesignCenter.....70

setting to a folder with symbol library
drawings.....70

home page.....1029
hook lines.....720
hook lines (for dimension text).....815
horizontal

dimensions
creating.....810
extension line origins.....809
See also dimensions

text orientation, setting.....742
horizontal dimensions.....776
HP-GL (language).....917
HP-GL driver.....917
HP-GL format.....917
HP-GL/2 driver.....917
HP-GL/2 format.....917
HPDRAWORDER system variable.....678
HPGAPTOL system variable.....676–677
HPORIGIN system variable.....677
HPORIGINMODE system variable.....677
HPSCALE system variable.....199
hyperlink fields.....732

adding to text.....732
hyphen (-).....56

dialog box suppression character.....
56

hyphens (----).....725
no value in field display.....725

I

i-drop.....1029

icons.....30–32, 37, 143, 965
Associated Standards File(s) icon.....

143
Missing Standards File(s) icon.....143
tool palette lock icon.....37
tool palette tool icon display style.....

30–31
tool palette tool icon updates.....32
Xref icon.....965

exclamation point.....965
ID command.....264, 364
identifying information in drawings. See

drawing properties
IGES (Initial Graphics Exchange

Specification).....1029
image mapping (in rendering)

See also material maps
image paths. See raster image paths
imperial units.....102, 108, 110–111, 294, 

799
converting metric dimension units

to/from.....799
alternate units conversion

values.....799
converting metric units to....108, 111
converting to metric units....108, 110
linetype definition file for.....294
specifying feet and inches.....110
specifying, in metric drawings.....799
starting drawings based on.....102

import file formats.....594
WMF format.....594

importing.....42, 87, 208, 245, 286, 724, 
863, 865, 928

environment profiles.....87
layer settings.....286
layouts.....207–211, 214–215, 221, 

229–231, 237, 245, 270, 303–
304, 807, 844–848, 851–854, 
856–863, 870, 875–878, 880–
881, 883, 886, 893–894, 896, 
930, 933, 1031

as sheets.....245
from templates.....208

page setups.....865

Index | 1094



for drawing sheets (in drawing
sets).....928

PCP/PC2 plotter configuration
settings.....863

into layouts.....863
RTF files.....724
text files.....724
tool palettes.....42
See also import file formats

imprinting objects on 3D solids.....668
improving performance. See performance

improvement
in-place reference editing...977–978, 981–

983
and attributes (of blocks).....983
discarding changes.....982
inheritance of properties during...981
and nested references.....982
and OLE objects in references.....982
saving back changes.....981–982
undoing changes.....981

In-Place Text Editor....702, 704–705, 770, 
773

displaying column letters/row
numbers for table cell
editing.....770, 773

opening.....704–705
transparency.....30–31, 58, 81, 174, 

339, 702
turning off.....702

inches.....108, 110–111, 376, 802
converting centimeters to.....108, 111
converting to centimeters.....108, 110
QuickCalc formats.....376
specifying.....110
suppressing zero values.....802

incremental parameter values.....535
specifying.....535

incremental saves.....121
indenting.....714–715

paragraphs.....714
hanging indents.....715

independent base points.....492–493, 500
specifying.....492–493, 500

Index tab (Help window).....3
infinite lines.....419

inheritance.....542, 647
layer properties, during block

insertion.....542
object properties.....263–268, 270–

271, 287–288, 290, 296–297, 
299, 301–303, 305–306, 438, 
467, 542–544, 569–570, 579, 
647, 727, 920

between joined polylines.....647
during block insertion.....542

inheritance, object properties, during
in-place reference editing.....981

initial environment.....1030
Input box (QuickCalc).....371, 375, 377–

378, 381–382, 385
appending values or expressions from

the History area to.....378
clearing.....371
copying unit conversions to.....381
copying values from.....377
loading calculator variables into.....

382
pasting values to the command

line.....377
specifying global constants from.....

385
input history display.....48
input properties (Property Lookup

Table).....521, 526
adding to lookup tables.....526

input property.....1030
inscribed polygons.....395, 397

drawing.....395, 397
insert properties, of tool palette tools.....

32
Insert Table dialog box.....759
inserting

blocks...116, 451, 453–458, 542, 545–
547, 551–552, 561–564, 567–
568, 570–571, 586, 645–646, 
724, 765, 768, 971–972, 974, 
982, 1019, 1026

in table cells.....765, 768
with tool palettes.....458

blocks. See inserting blocks
columns/rows in tables.....761
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drawing files as blocks...116, 546–547
fields (in formulas).....773

in table cells.....773
fields (in text).....725–726

as placeholders.....725, 728
in table cells.....727, 769

formulas.....769–773
in table cells.....769–771

layouts.....207–211, 214–215, 221, 
229–231, 237, 245, 270, 303–
304, 807, 844–848, 851–854, 
856–863, 870, 875–878, 880–
881, 883, 886, 893–894, 896, 
930, 933, 1031

using DesignCenter.....230–231
nonbreaking spaces, format code.....

752
points...154, 266, 313, 334, 353–357, 

359–364, 453, 651, 831, 833, 
1016, 1021, 1027, 1030, 1037

marking equal segments on
objects.....360, 362–363

marking measured intervals on
objects.....360–361

RTF files.....724–725
special characters in multiline text.....

704–705
tables.....759
text files.....724

inserting blocks.....360–363, 453, 457, 
542, 545–548, 551

at intervals on objects.....360–363
marking equal segments.....360, 

362–363
marking measured intervals.....

360–361
base points.....453, 457
from block library drawings.....546
with DesignCenter.....547–548
drawing files as.....546–547
object property settings.....542
with variable attributes.....551

inserting blocks, system variables used
for.....199

insertion point.....453
for blocks.....453

specifying.....453
insertion point, for tables.....759
installing.....14, 73, 288, 292, 948

3D DWF Publishing.....948
CAD Manager Control utility.....73
color books.....288, 292
Subscription Center.....14

Intellimouse. See wheel mouse
interface element.....1030
interface options.....80, 82

setting.....80, 82
International Standards Organization

(ISO).....1030
Internet (Web).....74

retrieving content on.....74
interpolation points.....1030
INTERSECT command.....422, 443
intersecting

lines. See intersections (of lines)
objects.....22–23, 35, 121, 123, 185, 

211, 218, 222, 226, 264, 266–
267, 270–271, 275–276, 281, 
287–288, 290, 297–298, 305, 
308–309, 343, 352–353, 360–
363, 365, 389, 439–442, 445–
447, 457, 461, 470, 546, 568, 
574–575, 577–578, 581, 589, 
592–605, 610–615, 617–624, 
628–633, 635–644, 646, 656, 
668, 681, 696, 734, 870, 974, 
979–980, 998, 1001, 1003, 
1005, 1022, 1034, 1038

self-intersecting torus/tori.....440
intersections (of 3D solids).....443, 447
intersections (of lines).....380, 653

displaying the intersection of two
lines.....380

multilines.....653
intersections (of regions).....422, 424
intervals on objects, specifying.....360
inverting layer filters.....280
invisible edges (of polyface meshes)....435

creating.....435
displaying.....435

invisible objects (in dynamic blocks).....
473, 519–520
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as displayed in the Block Editor....473
making objects invisible in visibility

states.....519–520
irregular

selection areas, selecting objects in....
576, 578

viewports. See nonrectangular
viewports

irregular polygons. See closed polylines
ISAVEPERCENT system variable.....121
islands.....1030
islands (in hatch areas).....681, 683, 694

creating.....694
removing.....683

ISO (International Standards
Organization).....294, 794, 1030

dimension text placement.....794
pen widths.....294

ISO hatch patterns.....677, 691
ISOLINES system variable.....438
isometric.....166, 414, 1030

circles...365, 407–408, 414, 439, 441–
442, 444–445, 815, 819

drawing.....414
snap style.....1030
views.....82, 84–85, 117, 153–154, 

160–162, 166, 168–169, 211, 
216–217, 225, 228, 1005, 
1045

3D views.....166
italic typeface

See also text obliquing angle
italicizing text, multiline text.....707

J

jogged radius dimensions.....816, 818
creating.....816, 818
modifying.....816

joining.....647–648
polylines to lines, arcs, or polylines...

647–648
joining model space viewports.....192
joystick panning.....95
justification.....397

of multilines.....397

justification, multiline text.....705–706, 
749

JUSTIFYTEXT command.....749

K

Kanji. See Big Fonts
key

columns. See key values
key point.....1030
key points (on parameters).....474, 488, 

510

L

label blocks (for sheet views).....244–245, 
249, 1031

avoiding prompts when placing...245
changing.....249

landings (for dimension text).....815
landscape orientation.....860–861, 880

setting.....861
languages.....749

checking spelling in another
language.....749

lateral tolerances.....803–806
aligning vertically.....804, 806
specifying.....803, 805
suppressing zeros.....805–806

lateral tolerances, stacked text in.....717
layer 0.....269
layer colors...270–271, 275, 290–291, 569

assigning.....270–271
changing.....275, 290
changing color assigned to layer.....

569
overriding.....290–291, 569

layer colors, in xrefs.....965
Layer control (Layers toolbar).....264
layer filters.....278–282

defining.....279–282
inverting.....280
nesting.....282

layer group filters.....278, 280, 282–283
defining.....280, 282
removing layers from.....283
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layer index.....1031
layer indexes (of xrefs).....993–995

saving drawings with.....993–995
layer linetypes....270, 275–276, 297–299, 

570
assigning.....270
changing.....275, 297–298, 570
changing the default.....276
overriding.....297, 299, 570

layer linetypes, binding referenced
linetypes.....974

layer linetypes, in xrefs.....965
layer lineweights.....270, 275, 301, 303, 

305–306
assigning.....270, 301, 303
changing.....275, 305
overriding.....306

layer names.....272, 275
changing.....275
choosing.....272
filtering.....272

layer plot styles.....270, 275, 897–898
assigning.....270
changing.....275, 898
setting.....898

layer plug-in, properties checked by....137
Layer Previous, to undo layer changes.....

275–276
changes that cannot be undone...276

layer properties.....33, 137, 264, 270–271, 
275, 290–291, 297–299, 301, 303, 
305–306, 542, 569–570, 965

assigning.....264, 270
colors.....270–271
linetypes.....270
lineweights.....270, 301, 303
plot styles.....270

changing.....275
colors.....275
linetypes.....275, 297–298
lineweights.....275, 305
plot styles.....275

changing, colors.....290
changing, for multiple layers.....271
colors. See layer colors

inheritance, during block insertion....
542

linetypes. See layer linetypes
lineweights. See layer lineweights
overriding....237, 253, 297, 299, 306, 

345–347, 349, 569–570, 628, 
630

colors.....569
linetypes.....297, 299, 570
lineweights.....306

overriding, colors.....290–291
plot styles. See layer plot styles
properties checked by layer plug-in....

137
tool palette tool overrides.....33
in xrefs.....965

Layer Properties Manager...271–272, 280, 
283

assigning properties.....271
hiding a column.....272
hiding tree view.....272
selecting layers.....271
sorting layers.....280, 283

layer property filters.....278–279, 281
defining.....279, 281

layer settings.....275, 284–286
changing.....275
editing/renaming/deleting.....286
exporting.....285
importing.....286
restoring.....284–285
saving.....284
undoing changes to.....275

Layer State Converter (Migration Tool).....
2

layer states.....283
layer translation mapping.....1031
Layer Translator.....147–148
layers

assigning.....264, 270–271, 275, 287–
288, 296–297, 301–303, 305, 
544

colors to.....270–271
linetypes to.....270
lineweights to.....270, 301, 303
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objects to other layers.....275, 
297, 305

plot styles to.....270
assigning objects to other layers...290
assigning properties to.....264, 270

colors.....270–271
linetypes.....270
lineweights.....270, 301, 303
plot styles.....270

changing.....275–276, 290–291, 297–
300, 305–306, 334–335, 569–
570, 779

for selected objects.....276, 298
changing for objects.....568
changing, for selected objects.....290
colors....263–264, 270–271, 275, 287–

288, 290, 542–543, 550, 568–
569, 579, 595, 639, 764, 903–
905, 1015, 1023

changing.....569
colors. See layer colors
converting to drawing standards.....

148
copying.....41, 53, 55, 120, 209, 267–

268, 273, 456–457, 469, 594–
595, 604–605, 641–643, 665, 
667, 767, 769, 899, 924, 927, 
931, 933, 994–995, 1003

between drawings.....273
creating.....272–273
deleting.....273–274
display of OLE objects.....1000
displaying selected layers.....149
filtering.....147, 272, 281–282, 579, 

583
names.....272

filtering by layer property.....281
filtering by name.....281
filtering by selecting layers.....282
freezing.....190, 218–221, 270, 993, 

1028
in layout viewports.....190, 218–

221
in paper space.....221
xref layers.....993

frozen layers.....218, 270

creating.....219, 221
in layout viewports.....220

viewing list.....220
including layer information in

published DWF files.....944
indexes. See layer indexes
layer 0.....269
in layer property filters.....279
linetypes. See layer linetypes
lineweights. See layer lineweights
locked layer operations.....578
locking.....269–270, 578
making current.....270–271, 273
mapping to standard layers.....148
naming.....272
nesting layer filters.....282
of objects (selected).....271, 276, 298

changing.....276, 298
making current.....271

organizing objects on.....268, 275
plot styles. See layer plot styles
properties. See layer properties
purging.....150, 274

unreferenced layers.....274
removing from layer group filter.....

283
renaming.....275, 277
renaming, multiple layers.....277
selecting.....270–271, 273
settings. See layer settings
sorting.....280, 283

using wild-card characters.....280
standards. See standards (for named

objects)
standards. See standards, for named

objects
thawing.....218–221

in layout viewports.....218–221
in paper space.....221

turned off layers.....270
turning off.....270
turning on/off.....271
undoing changes to settings.....275
unlocking.....579
visibility.....211, 218, 270

in layouts.....211, 270
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visibility, in xrefs.....965
xref-dependent layers.....118
See also named objects

Layers toolbar.....264, 271, 273–274, 276–
277

changing default linetype of a layer...
276

changing the layer of an object....276
creating a new layer.....273
and the Layer control.....264
and Layer Previous.....277
removing an unused layer.....274
renaming a layer.....277
turning layers on/off.....271
undoing changes to layer settings.....

277
layout environment. See paper space
Layout Plot Area option (Page Setup dialog

box).....851–852, 876
layout tabs.....192, 204, 206–207, 209, 

211, 237, 885–889
creating new.....207
eliminating multiple tabs for sheet

sets.....237
plotting from.....885–889

hiding paper space objects.....
886, 889

removing hidden lines.....888
shaded viewport plotting

options.....885, 887
rearranging.....209
as restored from maximized

viewports.....211
switching to the Model tab from.....

192
working on.....204, 206

layout templates.....229–231
creating.....229
creating layouts with.....229–230
file name extensions.....229
saving.....229, 231

layout viewports
accessing model space from.....211
aligning objects in different

viewports.....226
aligning views in.....225

clipping boundaries.....214, 216
creating.....213–214, 845
creating viewport configurations in

layouts.....214
drawing and modifying objects in.....

211
editing in.....212
freezing layers in.....190, 218–221

creating frozen layers.....219, 221
freezing/thawing layers

automatically.....219
locking the scale.....211
maximizing.....211
minimizing.....211
modifying views in.....211, 216
nonrectangular. See nonrectangular

viewports
placing named viewport

configurations into
layouts.....215

properties, modifying.....216
resizing.....214
rotating views in.....228
scale locking.....217–218
scaling linetypes in.....224–225
scaling views in.....216–217
screening (color intensity) of objects

in.....222
thawing layers in.....218–221
turning on/off.....223–224
view scale factor.....216
viewing list of fozen layers.....220
visibility of objects in.....218

layouts.....207–211, 214–215, 221, 229–
231, 237, 245, 270, 303–304, 
807, 844–848, 851–854, 856–863, 
870, 875–878, 880–881, 883, 886, 
893–894, 896, 930, 933, 1031

activating (making current).....210
activating prevous (making the

previous layout current).....
210

applying named page setups to.....
845–846

assigning plot style tables to.....893, 
896
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copying.....209
creating.....37, 41, 68, 89, 170, 207–

208, 229–230, 237–238, 253, 
422–423, 439, 441, 448, 455–
456, 458, 460, 465, 517, 610, 
744, 751, 753, 818, 862

with the Layout wizard.....207–
208, 862

with templates.....229–230
creating viewport configurations in...

214
deleting.....209
dimensioning in.....807
drawing orientation.....860–861, 880
duplicating.....209
freezing layers in paper space.....221
importing.....42, 87, 208, 245, 286, 

724, 863, 865, 928
as sheets.....245
from templates.....208

importing PCP/PC2 settings into.....
863

initial display.....844
initialized layouts.....845
inserting.....116, 230–231, 360–363, 

458, 546–547, 704–705, 724–
728, 752, 759, 761, 765, 768–
771, 773

using DesignCenter.....230–231
lineweight.....303–304

display in.....303–304
model layouts.....923, 930, 933

including in drawing sets....930, 
933

multiple.....159, 237, 326, 328, 331, 
575, 641, 643

as sheets from single drawing
files.....237

paper size.....848, 877–878
placing viewport configurations

into.....215
plot area.....851–852, 876
plot offset.....853
plot options.....858–860
plot scales.....854, 881
plot style tables.....856

creating.....857
editing.....857
previewing the effects of.....894
selecting.....856

plot styles, displaying.....858
plotting.....210
renaming.....209
reusing.....229
saving page setup plot settings to.....

875
selecting all.....210
selecting printers/plotters for.....846–

847
settings.....207
shaded viewport plotting options.....

859, 883, 886
thawing layers in paper space.....221
viewing objects in.....870
visibility of layers in.....211, 270

LEADER command.....744
leader lines

See also leaders (leader lines)
leader objects. See leaders (leader lines)
leader text.....699, 720, 723

aligning.....723
associativity with leaders.....699, 720
creating.....723
offsetting.....723
text boxes for.....723

leader text, editing.....748
leaders (leader lines)

annotations. See leader text
associativity with leader text (mtext

objects).....699, 720
associativity with objects arrowheads

are attached to.....699
automatic.....699, 790
creating.....720–722
creating geometric tolerances with.....

836
dimension line\=associated.....699, 

720
vs. leader lines (automatic).....699
multiple leaders.....722
resizing.....747
scaling.....747
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spline leaders.....722
stretching.....747

least material condition value (L/LMC)....
837

left mouse button. See pick button (mouse)
lemon-shaped solids, creating.....440
LENGTHEN command.....621
lengthening objects.....621, 624
lettered lists.....708–713

creating as you type.....708, 711
formatting multiline text as.....709
moving items down a level.....712
removing list formatting from.....710
separating items from.....713

letters.....703
selecting.....703

letters, selecting.....707
libraries.....1018, 1041

search paths.....1018
slide libraries.....1041

light
attenuation.....1017
See also attenuation of light
See also reflection (of light)
See also lights (for rendering)

lightness
See also brightness

lights (for rendering)
ambient. See also ambient light
display limitations.....175
displaying.....174
distant. See also distant lights
point. See also point lights
spotlights. See also spotlights

limits
tolerances.....804–805
See also drawing limits

LIN (linetype library) files.....294
line breaks.....766

in table cells.....766
LINE command.....336, 390

dimensional input.....336
line end styles.....909–910

assigning.....909–910
line join styles.....909–910

assigning.....909–910

line segments
chamfering.....633
filleting.....628
linetypes on short segments.....300
See also lines

line spacing, multiline text.....715–716
line text. See single-line text
line widths. See lineweights
line-hiding. See removing hidden lines in

3D objects
Linear Array parameter set.....508
linear dimensions

creating.....809
definition points.....831
rotated. See rotated dimensions
types.....776
See also aligned dimensions
See also baseline dimensions
See also continued dimensions
See also dimensions
See also horizontal dimensions
See also ordinate dimensions
See also vertical dimensions

linear grips.....510, 549
Linear Move Pair parameter set.....508
Linear Move parameter set.....508
linear objects. See lines
linear parameters.....474, 476, 479, 508, 

510, 529, 533, 535–536, 538
actions supported by.....474, 476
adding to dynamic block

definitions.....479
Chain Actions property.....476, 529, 

536
specifying.....538

grip numbers.....510
grip type.....474
incremental values.....535

specifying.....535
minimum and maximum values.....

536
specifying.....536

sets.....508
value sets.....473, 533–535, 1045

specifying.....533, 535
Linear Stretch Pair parameter set.....508
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Linear Stretch parameter set.....508
linear unit conventions.....109

setting.....109
lines

baselines.....1018
centerlines. See centerlines
construction. See construction lines
converting polylines into.....395
creating object profiles from.....441
dimension. See dimension lines
dimensioning. See linear dimensions
displaying the angle of a line.....380
displaying the intersection of two

lines.....380
drawing.....22, 192, 198, 211, 302, 

349, 352–353, 359, 389–398, 
401, 403–409, 411, 413–415, 
417, 419–421, 461

in model space.....302
tangent to arcs.....405–406
using direct distance entry.....359
using orthogonal locking.....349

extension. See extension lines
filleting lines with polylines.....626
freehand. See freehand lines
hidden. See hidden lines (in 3D

objects)
hidden. See hidden lines in 3D objects
hiding. See removing, hidden lines
intersecting. See intersections (of lines)
joining to polylines.....647–648
multilines. See multilines
of text. See also single-line text
perpendicular lines.....349
polylines. See polylines
rubber-band line.....1040
segments. See line segments
styles. See linetypes
table gridlines.....764
tessellation lines.....438, 1043
weights. See lineweights

lines, drawing, in viewports.....192
Linetype Control (Properties toolbar).....

297
Linetype control (Properties toolbar).....

264

linetype definition files.....295
listing linetypes in.....295

linetype scale.....299–300, 397
changing.....275–276, 290–291, 297–

300, 305–306, 334–335, 569–
570, 779

globally.....300
for selected objects.....299

Current Object Scale.....299
Global Scale Factor.....299
multiline scale and.....397
setting (making current).....300

linetypes
assigning.....264, 270–271, 275, 287–

288, 296–297, 301–303, 305, 
544

to layers.....270
to objects.....296, 544

assigning, to objects.....264
binding referenced linetypes.....974
in blocks.....568
changing.....275–276, 290–291, 297–

300, 305–306, 334–335, 569–
570, 779

layer linetypes.....275, 297–298, 
570

object linetypes.....297, 299, 570
CONTINUOUS linetype.....269
current linetype.....296
definition files.....295

listing linetypes in.....295
deleting.....294
displaying.....3–4, 11, 45, 47, 56–57, 

149, 160, 264–266, 300–304, 
308, 467

on polylines.....300–301
on short segments.....300

filtering selection sets based on....579
for freehand lines.....401
hardware linetype use.....293
for layers. See layer linetypes
listing.....54, 295, 781, 991

definition file linetypes.....295
loaded linetypes.....295

loading.....276, 294
for objects. See object linetypes
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plot style linetypes.....907–908
purging.....295, 593
scale. See linetype scale
scaling.....199, 299, 907

in layout viewports (paper
space).....224–225

non-ISO linetypes.....909
setting (for new objects).....264
setting (making current).....296, 544
standards. See standards (for named

objects)
standards. See standards, for named

objects
unloading.....295
See also named objects

Lineweight control (Properties toolbar)....
264

lineweight scale.....303, 855
displaying.....303
setting.....138, 168, 185–186, 753, 

807–808, 848, 854–855, 877–
878, 881–883, 938

for layouts.....855
Lineweight Settings dialog box.....302

accessing.....302
lineweights

assigning.....264, 270–271, 275, 287–
288, 296–297, 301–303, 305, 
544

to layers.....270, 301, 303
to objects.....302, 305
to polylines.....302

assigning, to objects.....264
changing.....275–276, 290–291, 297–

300, 305–306, 334–335, 569–
570, 779

layer lineweights.....275, 305
object lineweights.....305–306

current lineweight.....305
default value.....302
displaying.....3–4, 11, 45, 47, 56–57, 

149, 160, 264–266, 300–304, 
308, 467

in model space.....302–303
in paper space layouts....303–304
scale.....303

turning off.....304
displaying at current setting.....305
filtering selection sets based on....579
for layers. See layer lineweights
for objects. See object lineweights
objects not displaying.....302
plot style lineweights.....907–908
plotting.....199, 204, 210, 302, 306–

308, 696, 854, 870, 872–874, 
877, 881–882, 886, 888–889, 
911–918, 920, 940, 950, 999

with custom values.....302
in previous release drawing objects....

305
and regenerating drawings.....304
scaling.....855
setting (for new objects).....264
setting (making current).....302, 305
for table cell borders.....767
table gridlines.....764
turning on/off.....307–308
values.....302
See also named objects

link path names. See link templates
linked objects (OLE links).....998

updating.....998
linked objects (OLE objects).....1006

editing.....1006
linking

files, in drawings.....1002
objects.....22–23, 35, 121, 123, 185, 

211, 218, 222, 226, 264, 266–
267, 270–271, 275–276, 281, 
287–288, 290, 297–298, 305, 
308–309, 343, 352–353, 360–
363, 365, 389, 439–442, 445–
447, 457, 461, 470, 546, 568, 
574–575, 577–578, 581, 589, 
592–605, 610–615, 617–624, 
628–633, 635–644, 646, 656, 
668, 681, 696, 734, 870, 974, 
979–980, 998, 1001, 1003, 
1005, 1022, 1034, 1038

in drawings.....998, 1001
to other application

documents.....1005
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views, to other application
documents.....1005

See also attaching
links (in databases)

See also database links
links (related to OLE).....1001–1002, 1032

breaking.....1001–1002
reconnecting.....1001
switching (changing).....1002
updating.....1001

LIST command.....264
listing.....54, 295, 781, 991

dependent named objects (in xrefs)...
991

dimension style overrides.....781
dimensioning system variables.....781
linetypes.....199, 224–225, 263–264, 

269–270, 275–276, 293–301, 
401, 544, 568, 570, 579, 593, 
648, 907–909, 974, 1031

in definition files.....295
loaded linetypes.....295

system variables.....54
xrefs.....991

listing, database information.....266
lists in multiline text.....708–713

creating as you type.....708, 711–712
formatting multiline text as.....709
moving items down a level.....712
removing list formatting from.....710
separating items from.....713

LMC least material condition symbol.....
837

loading.....69, 119, 276, 294
DesignCenter content area.....69
geometry into partially open

drawings.....119
linetypes.....276, 294
xrefs

on demand. See demand loading
locating.....334

points.....334
lock icon.....336

in dimensional input.....336
lock icon, in tool palettes.....37
lock icons.....257–258

false.....258
for sheet sets in Sheet Set Manager.....

257
locked layers.....270
locked layers, operations possible on.....

578
locking.....11, 81, 83, 211, 269–270, 353

angles, specifying points by.....353
layers.....269–270
the layout viewport scale.....211
Quick Help (Info palette).....11
toolbars.....81, 83
windows.....81, 83
See also orthogonal locking
See also scale locking

locking, layers.....578
log files.....992

for xrefs.....992
turning on/off.....992

logo screen, not displaying on startup.....
85

lookup actions.....506, 508, 521
adding to dynamic block

definitions.....506, 521
parameter supported by.....506

lookup grips.....510, 514, 521, 549
lookup parameters.....474, 476, 486, 508

actions supported by.....474, 476
adding to dynamic block

definitions.....486
grip type.....474
sets.....508

lookup properties.....524
allowing for reverse lookup.....524

lookup properties (Property Lookup
Table).....521, 526–527

adding to lookup tables.....526
making read only.....527

lookup property.....1032
Lookup Set parameter set.....508
lookup table.....1032
lookup tables (for dynamic blocks)....521–

523, 525–528
adding input properties and lookup

properties.....523
adding input properties to.....526
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adding lookup properties to.....526
adding lookup values to.....527
assigning data to dynamic blocks.....

521
checking for errors in.....521, 527
creating.....522, 525
opening.....528
value specification rules.....528

lookup values (Property Lookup Table).....
527

adding to lookup tables.....527
LTSCALE system variable.....299
LWDEFAULT system variable.....302

M

M maximum material condition
symbol.....837

magnet (AutoSnap lock).....344
magnifying views. See zooming
main customization file.....1032
main window. See application window
manufacturers' content.....71–72, 74, 76

accessing.....71
downloading.....72, 76

mapping
2D images onto 3D object surfaces.

See image mapping
coordinate systems on paper to the

WCS.....401
See also color mapping
See also font mapping

mapping, layers to standard layers.....148
maps

color maps.....1021
See also material maps

margins in table cells.....763
markers

for object snaps.....344
for point objects.....361–362
for tracking points.....356–357
See also blips
See also center marks

marking.....360–363
equal segments on objects.....360, 

362–363

measured intervals on objects.....360–
361

markup sets.....1032
markups.....1032
markups (markup objects).....447

highlighting with revision clouds.....
447

masking objects.....696
master drawings, creating.....964
material condition symbol.....835, 837
material conditions (of features).....837
materials (for rendering)

display limitations.....175
displaying.....174
maps. See material maps
texture. See texture (of materials)
transparency.....174

displaying.....174
math expressions (in QuickCalc). See

expressions (in QuickCalc)....369
math functions (in QuickCalc).....372

using.....372
mathematical expressions.....80, 83

evaluating in dialog boxes.....80, 83
MaxArray system registry variable,

setting.....607
MaxHatch system registry variable....678, 

693, 695
setting.....678, 693, 695

maximum material condition value
(M/MMC).....837

measurement units. See units of
measurement

measuring intervals on objects....360–361
mechanical blocks, accessing collections

of.....75–76
Mechanical Desktop.....425

3D modeling capabilities.....425
memory functions (in QuickCalc). See

QuickCalc memory.....369
menu bar.....44
menus.....44, 49, 88, 125

choosing options.....44
custom menus.....125
in workspaces.....88
for workspaces.....49
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See also menu files
See also shortcut menus

merging.....760–761
cells in tables.....760–761

meshes (faceted surfaces)
polyface (polygon). See polyface

meshes
metadata options for published DWF

files.....940
metafiles. See WMF files
metric units.....102, 108, 110–111, 294, 

799
converting imperial units to.....108, 

110
converting imperial units to/from.....

799
alternate units conversion

values.....799
converting to imperial units.....108, 

111
linetype definition file for.....294
specifying, in English unit

drawings.....799
starting drawings based on.....102

Migration Tools.....2
minus sign (-), tree view level display

button.....65
mirror.....1032
mirroring

objects.....613–614, 1032
in 3D.....614

text.....613, 743
See also flipping

mirroring, objects, with grips....638, 641, 
644

MIRRTEXT system variable.....613, 743
Missing Standards File(s) icon.....143
mistakes, correcting. See undoing actions
MMC maximum material condition

symbol.....837
model layouts.....923, 930, 933

including with drawing sheets...923, 
930, 933

model space
accessing from layout viewports...211
dimensioning in.....806–807

for plotting in.....806
for plotting in paper space.....807

lineweight display in.....302–303
switching between paper space and...

212
uses.....205
working in (on the Model tab)...198, 

204–205, 211
See also Model tab

model space viewports.....190–193
coordinate systems in.....191
cycling through.....192–193
drawing lines in.....192
joining.....192
making current.....192–193
restoring.....192
subdividing.....191
uses.....191

model space, converting text height
between paper space and.....748

Model tab...192, 199, 204–206, 211, 877, 
881, 885–887

activating.....206
layer visibility settings.....211
plot scale.....881
plotting from.....199, 877

removing hidden lines.....887
shaded viewport plotting

options.....885–886
switching from a layout tab to.....192
working on.....204–205, 211

model viewports
arrangements. See viewport

arrangements
(configurations)

multiple.....159, 237, 326, 328, 331, 
575, 641, 643

in 3D views.....326, 328, 331
UCSs in.....326, 328
using the Aerial View window

with.....159
models

See also 3D models
modes.....1032
modifying.....36, 211, 213, 216, 243, 255, 

438, 538–539, 561–565, 568, 570, 
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596, 647, 649, 653, 655–656, 
659, 666, 691, 693–695, 702, 
734, 743–744, 746, 759, 784, 
786, 816, 824, 827, 830–832, 
845, 851, 865, 880, 924, 928, 
930, 933, 976–977, 987

3D solids.....438, 655
_aaz2D solids.....694
action selection sets.....539
associative dimensions.....830
block attributes.....563–565, 568

applying changes to block
references.....565

in block definitions.....563, 565
in block references.....564, 568

block definitions...561, 570, 976–977
block descriptions.....562–563
blocks

See also in-place reference editing
dimension.....827

text.....827
dimension lines.....784
dimensions.....824
donuts.....694
dynamic block definitions.....538
edges of 3D solids.....656, 666
exploded dimensions.....832
extension lines.....786
faces of 3D solids.....656, 659
gradient fills.....691, 695
hatch boundaries.....694
hatch patterns.....693
hatches.....693
jogged radius dimensions.....816
layout viewports.....213
multiline text.....702, 744, 746
multilines.....653
named page setups.....865
nonassociative dimensions.....831
objects.....596

methods.....596
page setups.....845

for drawing sheets in drawing
sets....924, 928, 930, 933

paper size.....851, 880
polylines.....647, 649

printable area of a drawing.....880
project names.....987
search paths.....987
sheet selections.....255
sheets.....243
solid-filled areas.....694
tables.....759
text objects.....743

single-line text objects...743–744
text styles.....734

and multiline text character
formatting.....734

tool palette tools.....36
views.....82, 84–85, 117, 153–154, 

160–162, 166, 168–169, 211, 
216–217, 225, 228, 1005, 
1045

in layout viewports.....211, 216
wide polylines.....694
See also editing

mouse.....94–95
practicing with.....95
wheel mouse.....94

mouse buttons
right button.....94
See also pick button (mouse)

move actions.....489–491
adding to dynamic block

definitions.....489, 491
Distance Type property.....490–491
parameters supported by.....489

moving.....37, 323, 596–598, 638, 640, 
661–662, 744, 746, 759, 827–828

dimension text.....827
faces of 3D solids.....661–662
multiline text.....744, 746
objects.....596

point method.....596, 598
by relative displacement.....597–

598
by stretching.....597–598

tables.....759
tool palette tabs.....37
UCSs.....323
See also converting

moving, objects, with grips.....638, 640
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mtext. See multiline text
MTEXTED system variable.....751
multi-sheet DWF files.....941–942, 1033

default names.....942
specifying.....942

name prompt.....942
specifying.....942

specifying.....941
multiline.....653, 698

intersections.....653
styles....334, 653, 701, 706, 734, 1030

editing.....653
multiline intersections.....653, 655

modifying.....653, 655
multiline objects. See multilines
multiline scale.....397

and linetype scale.....397
multiline styles.....398–399, 654–655

creating.....399
editing.....654–655

multiline text
aligning.....705–706

vertical alignment format
codes.....753

boldfacing.....707
character formatting.....734

as affected by modifying text
styles.....734

character spacing, format code.....753
coloring.....703, 707

format code.....752
creating.....702–703

in alternate text editors.....751
without a bounding box.....744

editing.....698, 744, 746
in alternate text editors.....751

finding.....745–746
fonts, changing.....707
format codes.....753
formatting

in alternate text editors.....752
as lists.....709
See also text styles

height.....707
changing.....707
format codes.....752

setting.....740
indenting.....714

hanging indents.....715
inserting special characters in.....704–

705
italicizing.....707
justification.....705–706, 749
line spacing.....715–716
line width.....702–703

defining.....702–703
lists.....709

delimiter characters.....709
prohibited characters for

bullets.....709
lists. See lists in multiline text
modifying (changing)...702, 744, 746
moving.....744, 746
as objects. See multiline text objects
obliquing angle.....741

format code.....753
orientation.....742
overlining, format codes.....752
paragraph end format code.....753
properties.....702
replacing.....745–746
selecting.....703, 707
stacked.....717

format codes.....753
styles

not affecting.....734
overriding.....706
See also text styles

tabs, setting.....714
underlining.....707

format codes.....752
wide text, format code.....753
See also multiline text objects
See also text
See also text styles

Multiline Text Editor....714–715, 735, 751
fonts displayed.....735
ruler.....714–715

multiline text objects
background options.....702
defining.....702–703
leader associativity with.....699, 720
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See also multiline text
multilines

adding vertices.....653
deleting vertices.....653
double lines. See double lines
drawing.....398
editing commands not for.....654
end points.....654
intersections.....653, 655
justification of.....397
modifying.....653
properties.....398
scale.....397
vertices.....653, 655
See also multiline styles

multilines, and associative
dimensioning.....779

multiple.....159, 237, 326, 328, 331, 575, 
641, 643

copies (of objects).....641, 643
making, with grips.....641, 643

objects.....22–23, 35, 121, 123, 185, 
211, 218, 222, 226, 264, 266–
267, 270–271, 275–276, 281, 
287–288, 290, 297–298, 305, 
308–309, 343, 352–353, 360–
363, 365, 389, 439–442, 445–
447, 457, 461, 470, 546, 568, 
574–575, 577–578, 581, 589, 
592–605, 610–615, 617–624, 
628–633, 635–644, 646, 656, 
668, 681, 696, 734, 870, 974, 
979–980, 998, 1001, 1003, 
1005, 1022, 1034, 1038

selecting.....575
UCSs.....326, 328
viewports (model viewports).....159, 

326, 328, 331
in 3D views.....326, 328, 331
UCSs in.....326, 328
using the Aerial View window

with.....159
multiple drawings.....120

copying between.....120
displaying.....120
switching between.....120

multiple drawings, checking for standards
violations.....141, 146

multiple layers.....271
changing properties.....271
selecting.....271

multiple layout viewports, creating.....213
multiple layouts.....237

as sheets from single drawing files.....
237

multiple object snaps. See running object
snaps

multiple sets of objects.....624, 629, 634
chamfering.....629, 634
filleting.....624, 629

multiple text objects, scaling.....748
multiple-line objects. See multilines
MVIEW command, creating

nonrectangular layout
viewports.....213

MVSETUP command.....227, 229
aligning objects in different layout

viewports.....227
rotating views.....229

My Documents folder.....116, 125–126
specifying the search path....125–126

MYDOCUMENTSPREFIX system
variable.....125

N

name conflicts in xrefs.....973
named

groups.....587
deleting.....589

objects
dependent. See dependent named

objects (in xrefs)
names, special characters for.....

734
renaming.....974
standards. See standards, for

named objects
page setups

See also page setups
queries. See stored queries
UCSs, restoring.....325, 329
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viewport arrangements. See viewport
arrangements

views
See also views

named groups.....587
named layer states.....283–284

restoring.....284
saving.....284

named object selection filters.....579, 581
named objects....117, 136–138, 141–143, 

592–593
availability in partially open

drawings.....117
defining properties for.....138
fixing objects with standards

violations.....137, 141–143
nonstandard.....136, 142

fixing.....137
purging.....592

linetypes.....593
types for which standards can be

created.....136
named objects, dependent.....1033
named page setups.....844–846, 863–868, 

875
applying.....845–846

to other layouts.....845–846
applying as override when publishing

sheets.....868
applying to multiple layouts.....844
applying to sheet created from

scratch.....868
creating.....845, 864, 875
deleting.....866
importing.....865
importing from a drawing.....844
modifying.....865
renaming.....867
using with sheet sets.....867

named plot style tables.....871, 891–892, 
897, 899, 901

and color mapping tables.....901
converting color-dependent plot style

tables to.....892

converting drawings from
color-dependent tables to.....
891–892

converting drawings to
color-dependent tables
from.....891–892

file name extension.....871
managing plot styles in.....899
plot styles in.....897

named plot styles.....871, 891–892, 899–
901

converting drawings from
color-dependent styles to.....
891–892

converting drawings to
color-dependent styles
from.....891–892

copying.....899
creating (adding).....899, 901
deleting.....900–901
description, changing.....900
managing.....899
predefined styles.....901
renaming.....900–901

named views.....161–163, 1033
deleting.....163
restoring.....161–162
saving.....37, 42, 80, 87–88, 91, 121–

124, 130, 138, 161–162, 193–
194, 229, 231, 254, 259, 284, 
324, 329, 402, 541, 581, 766, 
772, 940, 993–995

settings saved.....161
naming

drawings....37, 64, 68, 70, 77, 80, 85, 
101–107, 116–118, 120–124, 
129–131, 136, 138–140, 143, 
146, 160, 173, 198–199, 204, 
243, 246–247, 273, 304, 453, 
457, 594–595, 676, 854–855, 
860–861, 880–883, 891–892, 
911–912, 964–967, 973–976, 
993–995, 998, 1001–1003, 
1030, 1039, 1046

for international work.....122
layers.....272
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objects, using wild-card characters.....
281

text styles.....734
viewport arrangements.....194
views.....162
See also renaming

natural language queries (in Help).....7
tips for good results.....7
Web searches.....7

navigating.....11, 54
in the command window.....54
Quick Help (Info palette).....11

NEAR operator, Help topic searches.....5
nested.....544, 971, 982, 989, 999

blocks.....544
clipped.....971
in-place reference editing and.....

982
xref paths, changing.....989
xrefs.....965–967, 971, 976–978, 982, 

989
clipped.....971
in-place reference editing and.....

982
paths, changing.....989

nested blocks, in attribute extraction
files.....560

nested xref paths.....968
nested xrefs.....967–968

paths.....968
nesting.....282

layer filters.....282
Network Administrators Guide, accessing.....

2
New Table Style dialog box.....763
no path option, for xrefs.....985
nodes.....1033
nonassociative.....831, 834, 1033

dimensions.....22, 24, 199, 308, 646, 
776–778, 803, 805, 808–810, 
824, 831, 833–834

converting associative dimensions
into.....834

converting into associative
dimensions.....834

modifying.....831

nonassociative dimensions.....778
filtering selections.....778

nonassociative hatches.....677, 694
nonbreaking spaces, inserting, format

code.....752
nonnumeric characters, stacking.....718
nonrectangular layout viewports.....213–

214
creating.....213
suppressing boundary display.....214

nonstandard named objects.....136–137, 
142

fixing.....137
nonsystem plotter/printer drivers.....879, 

913–917
custom paper sizes.....879
DXB driver.....914
HP-GL driver.....917
HP-GL/2 driver.....917
PostScript driver.....916
raster driver.....915

NORMAL plot style.....899, 902
normals (of surfaces).....1033
NOT operator, Help topic searches.....5
notification...47, 141–142, 144, 965, 969, 

985
of attached xrefs.....965
of changed xrefs.....969

relocated xrefs.....985
turning on and off.....142, 144

from services.....47
of standards violations.....141–142

noun/verb selection.....575, 583–584
noun/verb selection of objects.....1034
Number of Grips property.....510
numbered lists.....708–713

creating as you type.....708, 711
formatting multiline text as.....709
moving items down a level.....712
removing list formatting from.....710
separating items from.....713

Numbering.....708
and creating formatted lists.....708

numeric characters, stacking.....718
NURBS.....1034
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object classifications.....579–580
object colors

assigning to layers.....270–271
block insert settings.....542
changing.....290

overriding layer colors.....290–
291, 569

converting to grayscale.....904–905
setting (for new objects).....264, 287–

288
setting (making current).....543
See also colors

object linetypes..270, 293, 296–297, 299, 
542, 544, 570

assigning to layers.....270
block insert settings.....542
changing.....297

overriding layer linetypes....297, 
299, 570

setting (making current).....296, 544
object linetypes, setting (for new

objects).....264
object lineweights.....270, 301–303, 305–

306, 542, 886, 888
assigning to layers.....270, 301, 303
block insert settings.....542
changing.....305–306

overriding layer lineweights.....
306

plotting.....886, 888
setting (making current).....302, 305

object lineweights, setting (for new
objects).....264

object linking and embedding. See OLE
object plot styles

assigning to layers.....270
changing.....897
setting.....898
See also plot styles

object profiles, creating.....441
object properties

of 3D solids.....438
assigning to layers.....264, 270

colors.....270–271

linetypes.....270
lineweights.....270, 301, 303
plot styles.....270

assigning to objects.....264
colors.....287–288

changing.....264, 266
colors.....290, 569
linetypes.....297, 299, 570
lineweights.....305–306

colors. See object colors
copying.....267–268

suppressing specific properties....
267

display properties.....306
displaying.....3–4, 11, 45, 47, 56–57, 

149, 160, 264–266, 300–304, 
308, 467

in the Block Editor.....467
methods.....264
with the Properties palette...265–

266
displaying in fields.....727
editing

See also object properties,
changing

filtering selection sets based on....579
floating properties.....542
in blocks.....542

insert settings.....542
inheritance.....542, 647

during block insertion.....542
linetypes. See object linetypes
lineweights. See object lineweights
listing database information.....266
plot styles. See object plot styles
setting (for new objects).....264

colors.....287–288
setting (making current).....296, 302, 

305, 543–544
colors.....543
linetypes.....296, 544
lineweights.....302, 305

specifying block-related properties for
publishing in DWF files.....
920

See also BYBLOCK setting
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See also thickness
object properties, inheritance, during

in-place reference editing.....981
object selection

area transparency.....583
customizing.....582
cycling.....574–575

in groups.....588
filtering.....583
filters.....579, 581
group selection, toggling.....588
highlighting

previewing effects. See selection
previewing

turning off.....583
methods (default options).....584

changing.....584
preventing.....578
previewing effects.....583

turning on/off.....584
Object Selection Filters dialog box.....579
object snap.....48–49, 95, 1034

menu.....48–49, 95
customizing.....49
displaying.....48–49, 95

override.....1034
Object Snap mode.....1034
Object Snap shortcut menu.....342

displaying.....342
object snap tracking.....356–358

changing AutoTrack settings.....358
settings.....357
tips.....357
tracking points.....356–357
turning on/off.....358

object snaps
aperture box.....344
magnet.....344
marker.....344
overriding.....345
running object snaps.....1040
running. See running object snaps
setting to ignore hatch objects.....343
specifying.....342
tooltips.....344
using in 3D.....342

visual aids. See AutoSnap
See also running object snaps

ObjectARX (AutoCAD Runtime
Extension).....1034

objects
3D objects. See 3D objects
adding to groups.....589
adding, to selection sets.....581
aligning.....225–226, 347, 360–363, 

602–603, 699, 701, 705, 723, 
753, 764, 792, 795, 804, 806, 
829

in different layout viewports.....
226

assigning properties to.....264
colors.....287–288

assigning to other layers.....275, 290, 
297, 305

breaking.....635–636
calculating.....80, 83, 200, 363–365, 

367–368
area/perimeter/circumference.....

365
chamfering.....629

by setting the distances.....630, 
632

by specifying length and angle....
631, 633

without trimming.....633
changing layers of.....568
colors. See object colors
converting to revision clouds.....447
copying.....41, 53, 55, 120, 209, 267–

268, 273, 456–457, 469, 594–
595, 604–605, 641–643, 665, 
667, 767, 769, 899, 924, 927, 
931, 933, 994–995, 1003

in arrays.....605
to the Clipboard.....594–595
with grips.....641, 643
multiple copies.....604, 641, 643
with offset snaps.....642–643
point method.....604–605
properties between.....267
properties between, suppressing

specific properties....267
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by relative displacement.....604
with rotation snaps.....642–643

creating tools from.....22–23, 35
creating with tool palette tools.....22
custom.....1022
cutting to the Clipboard.....593–595
cycling through.....574–575
database information, listing.....266
definition.....1034
as displayed in the Block Editor....470
dragging, into drawings.....1003
draw order...308–309, 678, 695, 1000

changing.....308–309
drawing.....22, 192, 198, 211, 302, 

349, 352–353, 359, 389–398, 
401, 403–409, 411, 413–415, 
417, 419–421, 461

creating tools for.....22
for dynamic blocks.....461
in layout viewports.....211
using polar distances.....353
using polar tracking.....352

editing.....596
methods.....596

editing, with grips.....637
embedding.....998, 1003, 1005

in drawings.....998, 1003
in other application

documents.....1005
erasing.....592
exploding.....646
exploding. See exploding compound

objects
extending.....615, 617–618

in 3D.....618–619
while trimming.....615

extruding.....441, 445
filleting.....624

3D solids.....656
in 3D.....628
without trimming.....628

hatching.....681
hiding.....270
imprinting on 3D solids.....668
inserting blocks at intervals on...360–

363

marking equal segments.....360, 
362–363

marking measured intervals.....
360–361

intersecting. See intersecting objects
invisible. See invisible objects (in

dynamic blocks)
layers of selected objects.....271, 276, 

298
changing.....276, 298
making current.....271

layers of selected objects, changing....
290

lengthening.....621, 624
linetypes. See object linetypes
lineweights. See object lineweights
linking.....998, 1001–1002, 1005

in drawings.....998, 1001
to other application

documents.....1005
markups. See markups (markup

objects)
masking (covering).....696
measuring intervals on.....360–361
mirroring.....613–614

in 3D.....614
mirroring, with grips.....638, 641, 644
in model space. See model space

objects
modifying.....596

methods.....596
moving.....596

point method.....596, 598
by relative displacement.....597–

598
by stretching.....597–598

moving, with grips.....638, 640
named. See named objects
naming, using wild-card characters....

281
noun-verb selection.....575
offsetting.....610

in copying with grips.....642–643
distance method.....612
point method.....612
polylines or splines.....611
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OLE. See OLE objects
in paper space. See paper space objects
pasting.....594–595, 724

into drawings.....594–595
points. See point objects (points)
properties. See object properties
proxy.....1038
reassigning to different layers.....275
removing.....25, 139, 242–243, 247, 

564, 566, 571, 574–575, 577–
578, 589, 592–593, 677, 683, 
694, 887–888, 924, 926, 930, 
933, 979–980, 986

from groups.....589
from selection sets.....574–575, 

577–578
removing, from working sets.....979–

980
reordering in groups.....589
reshaping.....621
resizing.....621
revolving.....442, 446
rotating.....599, 601

in 3D.....600
to an absolute angle.....600–601
around an axis.....602
by dragging.....599
by a specified angle.....599

rotating, with grips.....638, 640
saving selected objects.....121, 123
scaling....23, 107, 198–201, 216–217, 

224–225, 299, 531, 622–623, 
638, 640, 743, 747–748, 758, 
761, 854–855, 881–883, 907, 
909

by reference.....622–623
by scale factor.....622–623

scaling, with grips.....638, 640
screening (color intensity).....222, 

903–904
in layout viewports.....222

selecting. See selecting objects
snapping to points on.....343
stretching.....621, 623
stretching, with grips.....638–639
text. See text objects

trimming.....615, 619
in 3D.....618, 620
chamfering without.....633
while extending.....617
filleting without.....628

viewing in layouts.....870
visibility.....211, 218, 270

layer control.....270
in layout viewports.....218

See also geometry
oblique.....814

extension lines.....814
obliquing angle (text).....741, 753

setting.....741
format code (multiline text).....

753
offset snaps, copying objects with.....642–

643
offsetting.....359–360, 420, 610–612, 642–

643, 663, 723, 880
construction lines.....420
drawings (on paper).....880
faces of 3D solids.....663
leader text.....723
objects.....610

in copying with grips.....642–643
distance method.....612
point method.....612

points, from temporary reference
points.....359–360

polylines.....611
splines.....611

OLE (object linking and embedding).....
997, 1034

OLE objects.....179, 724, 982, 998–1001, 
1003–1008

3D Orbit view and.....179
in block references and xrefs.....1001
in blocks.....982
changing size with grips.....1006
copying.....1003
cutting.....1003
display of.....1000
displaying.....1008
displaying frame for editing.....1006, 

1008
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editing...54, 212, 251, 270, 286, 385, 
552–553, 588, 596, 637, 650, 
652–655, 678, 698, 726, 744, 
746, 749–751, 759, 850, 857, 
879, 895, 902, 947, 957, 976–
978, 1006–1007

in drawings.....1006
when AutoCAD is source

application.....1006
editing commands that are

unavailable.....1006
embedding.....998, 1003, 1005

in drawings.....998, 1003
in other application

documents.....1005
exporting.....1004
height.....1004
importing.....1000
linking.....998, 1001–1002, 1005

in drawings.....998, 1001
to other application

documents.....1005
nested.....544, 971, 982, 989, 999

and plotting.....999
opening source application by

double-clicking object.....
1006

pasted text as.....724
plot quality of.....999
plotted as opaque.....1000
restoring to original size/shape...1007
setting plot quality of.....999
text size in print.....1000
width.....1004
in xrefs.....982

OLEFRAME system variable.....999, 1006
OLEHIDE system variable.....1000
OLEQUALITY system variable.....999
one-color gradient fills.....690

creating.....690
online content (for drawings)

(DesignCenter Online).....71–72, 
74–76

accessing.....71, 74
browsing.....74
downloading.....72, 76

previewing.....72, 76
searching for.....72, 75–76
types.....74

OOPS command.....590
opacity maps.....1034
OPEN command.....117

Partial Open option.....117
Open Drawings tab (DesignCenter).....65
opening.....15, 68, 70, 116–118, 145, 238–

239, 243, 246–247, 464–466, 528, 
539

block definitions.....464, 539
blocks.....465–466
Communication Center.....15
drawing files as blocks.....466
drawings

authenticity check.....116
with DesignCenter.....68, 70
partially.....117–118
See also starting drawings
within sheet sets.....243, 246–247
in Windows Explorer.....116

dynamic block definitions.....539
dynamic blocks.....466
lookup tables (for dynamic blocks)....

528
Sheet Set Manager.....238
sheet sets.....239
standards check files.....145

opening, Properties palette.....265
operators. See query operators
optimizing program performance. See

performance improvement
Options dialog box.....80, 82, 125

Files tab.....125
setting interface options.....80, 82

Options dialog box, environment settings,
precedence.....86

OR operator, Help topic searches.....5
ordinate dimensions

automatic.....821
creating.....822
definition points.....831
See also dimensions

organizing.....38, 112, 240, 458
blocks.....458
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sheet sets.....112, 240
tool palettes.....38

organizing objects on layers.....268, 275
orientation.....742, 860–861, 880

of drawings.....860–861, 880
text.....742

origin.....1035
origin (coordinate systems)

See also UCS origin
Ortho mode.....350, 1035

and polar tracking.....350
orthogonal.....349–350, 1035

locking (Ortho mode).....349–350
drawing lines.....349
overrides.....350
and polar tracking.....350
turning on/off.....350

orthogonal extension lines.....823
orthographic projections. See parallel

projections (of 3D views)
OSNAP button (status bar).....342

turning running object snaps
on/off.....342

OSNAPZ system variable.....342
outlines. See lists in multiline text
output directory for published DWF

files.....941
changing the default.....941

overall dimension scale, setting.....807
overlapping objects.....308–309

draw order...308–309, 678, 695, 1000
changing.....308–309

overlapping, objects, draw order.....308
overlaying xrefs.....966–968

vs. attaching xrefs.....967
with DesignCenter.....966

overlays. See layers
overlining multiline text, format codes....

752
override keys.....345, 351–352

for running object snaps.....345
overrides. See dimension style overrides
overriding...237, 253, 297, 299, 306, 345–

347, 349, 569–570, 628, 630
chamfer distances.....630
the fillet radius.....628

object snaps.....345
running object snaps.....345–346

the snap (grid snap).....347, 349
overriding page setups.....237, 253, 861, 

871
for sheet sets.....237, 253

P

page settings. See page setups
Page Setup dialog box.....851–852

plot area options.....851–852
Page Setup Manager.....845

displaying with new layouts.....845
page setup override templates.....253
page setup overrides file.....237, 935–936
page setups.....208, 237, 253, 845–846, 

861, 865, 868, 871, 874–875, 
924, 928, 930, 933, 936, 1035

for the current layout.....208
for sheet sets.....237, 253

overriding.....237, 253
importing.....865

for drawing sheets (in drawing
sets).....928

modifying.....845
for drawing sheets in drawing

sets....924, 928, 930, 933
named.....325, 329, 587, 589, 734, 

845–846, 865, 868, 875, 974, 
1033

applying as override when
publishing sheets.....868

applying to other layouts.....845–
846

applying to sheet created from
scratch.....868

creating.....845, 875
importing.....865

overriding....237, 253, 297, 299, 306, 
345–347, 349, 569–570, 628, 
630

for sheet sets.....237, 253
plot settings.....861

plotting with.....874
saving.....875
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specifying.....874
publishing sheets (in sheet sets) using

page setup overrides.....936
page setups overrides.....936

publishing sheets (in sheet sets)
using.....936

page size. See paper size
palettes

Auto-hide, turning on/off.....265
See also color palettes
See also Properties palette

palettes. See color palettes
palettes. See tool palettes
pan box. See view box (Aerial View

window)
PAN command.....154
panning.....84, 154, 158–160, 180, 1035

in 3D Orbit view.....180
with the Aerial View window.....158–

160
by dragging.....154
dynamic (Realtime option).....154
by specifying points.....154
turning on animation for.....84

PANTONE color books. See color books
paper.....854–855, 880, 882–883

offsetting drawings on.....880
scaling drawings to fit.....854–855, 

882–883
paper drawing sets.....929–930

creating and publishing.....929–930
paper image

See also printable area
paper sheet sets.....935

publishing.....935
paper size.....848–851, 877–881

custom sizes.....849–850, 877, 879
adding.....849–850, 877, 879
deleting.....850
editing.....850, 879

modifying.....851, 880
and plot scale.....881
setting.....138, 168, 185–186, 753, 

807–808, 848, 854–855, 877–
878, 881–883, 938

for layouts.....848, 877–878

for plotters.....877–878
paper space

dimensioning in model space for
plotting in.....807

freezing layers in.....221
lineweight display in.....303–304
objects.....22–23, 35, 121, 123, 185, 

211, 218, 222, 226, 264, 266–
267, 270–271, 275–276, 281, 
287–288, 290, 297–298, 305, 
308–309, 343, 352–353, 360–
363, 365, 389, 439–442, 445–
447, 457, 461, 470, 546, 568, 
574–575, 577–578, 581, 589, 
592–605, 610–615, 617–624, 
628–633, 635–644, 646, 656, 
668, 681, 696, 734, 870, 974, 
979–980, 998, 1001, 1003, 
1005, 1022, 1034, 1038

copying between drawings....457
objects in. See paper space objects
scaling linetypes in.....225
switching between model space

and.....212
thawing layers in.....221
UCS limitations.....329
uses.....205
viewing commands not available in...

166, 329
views.....166
working in (on a layout tab).....204, 

206
paper space objects.....886, 889

hiding, plotting from a layout tab.....
886

plotting last/first.....886, 889
paper space, converting text height

between model space and.....748
PAPERUPDATE system variable.....877
paragraphs.....703, 715

selecting.....703
paragraphs (multiline text).....707, 714–

715, 753
format codes.....753
indenting.....714

hanging intents.....715
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selecting.....707
parallel dimensions. See baseline

dimensions
parallel lines.....627

filleting.....627
parallel projections (of 3D views).....166, 

170, 182
creating.....166

dynamically.....170
in 3D Orbit view.....182

parameter.....1035
parameter labels.....529–530

specifying.....529–530
parameter properties.....460, 462, 476, 

490–492, 494–495, 497, 500, 510, 
529–530, 536, 538

Base Type property.....492, 500
Chain Actions property.....476, 529, 

536
specifying.....538

custom properties.....460, 462, 529
displaying/not displaying.....530

Distance Type property.....490–491, 
495, 497

Number of Grips property.....510
Scale Type property.....492, 494
Value Set properties.....529

parameter set.....1035
parameter sets.....468–469, 508

adding actions to.....469
adding to dynamic block

definitions.....508
copying.....469
customizing.....468

properties.....468
deleting actions from.....469
types.....508

parameter values.....476, 521, 534–536
associating with other data.....521
deleting from value sets.....534
extracting.....476
incremental values.....535

specifying.....535
input properties.....521
minimum and maximum values.....

536

specifying.....536
parameters (for dynamic blocks)

actions supported by.....474, 476
adding to dynamic block

definitions.....460, 462, 476, 
508, 510

alignment parameters.....484
base parameters.....487
flip parameters.....485
linear parameters.....479
lookup parameters.....486
point parameters.....478
polar parameters.....480
rotation parameters.....483
visibility parameters.....486, 514
XY parameters.....482
specifying color.....471
specifying font.....472
specifying text and arrow size.....

471
updating text size.....473

assigning actions to.....488, 510
array actions.....503, 505
flip actions.....502–503
lookup actions.....506, 521
move actions.....489, 491
polar stretch actions.....497–498
rotate actions.....499, 501
scale actions.....492–493
stretch actions.....494–495

deleting actions from.....469
dependencies (dynamic block element

relationships).....462, 474
dependency highlighting.....471

turning on/off.....473
as displayed in the Block Editor....470
grips. See grips (for parameters)
key points.....474, 488, 510
labeling.....529–530
properties. See parameter properties
settings.....470
types.....474, 476

by action type.....489
by grip type.....510

value sets.....470, 476
tick mark display in.....473
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values. See parameter values
partial customization file.....1035
Partial Open option (OPEN command).....

117
partial plot configuration files. See PCP

files
partial saves.....121, 123
partially open drawings.....117–119

loading geometry into.....119
named objects available in.....117
xref-dependent layers as displayed

in.....118
partially opening drawings.....117–118
Partner Products and Services

(Autodesk).....12
parts (discipline-specific).....72, 74, 76

accessing.....72, 74
downloading.....72, 76

parts lists, creating.....555
password security.....943

for DWF files.....943, 958
specifying.....943

PASTECLIP command.....337
using in dynamic prompt tooltip.....

337
pasted information.....595

converting to drawing file format.....
595

PASTESPEC command.....595
pasting.....594–595, 724

objects, into drawings.....594–595
text, from other application.....724

PAT file.....679
path curves.....429
pattern properties, of tool palette tools.....

32
PC2 (legacy plotter configuration) files.....

862–863, 894, 1036
importing settings from.....863, 894

into layouts.....863
into plot style tables.....894

PC3 (plotter configuration) files.....870, 
879, 1036

and PMP files.....879
tool for creating.....870

pc3 editor.....950

PCP (legacy plotter configuration) files.....
862–863, 894, 1036

importing settings from.....863, 894
into layouts.....863
into plot style tables.....894

PEDIT command.....647
command options.....647

pen plotters.....905–906
pen assignments.....905–906

pen settings.....863, 894, 901, 906, 958
color mapping tables for previous

release settings.....901
for DWF files.....943, 958

editing.....958
importing PCP/PC2 settings.....863, 

894
into layouts.....863
into plot style tables.....894

for raster (penless) plotters.....906
pens

assigning to plot styles.....905–906
settings. See pen settings
virtual pens.....906–907

performance improvement.....159, 304, 
306–308, 453, 993–994

Aerial View window dynamic
updating.....159

drawing size, reducing.....453
fills display.....306–307
lineweight display.....307–308
lineweights and.....304
object display properties.....306
text display.....306–307
xrefs with indexes.....993–994

PERIMETER system variable.....364
perimeters, calculating.....365
period (.).....745

wild-card character.....745
period (.), wild-card character.....280
perpendicular lines, drawing.....349
personalization.....1036
perspective view.....1036
perspective views (of 3D views).....166, 

172–173, 182, 335
defining.....172
and Dynamic Input.....335
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in 3D Orbit view.....182
operations not available in.....172
turning off.....173

PFACE command.....429, 435
Photo Raytrace (renderer)

See also photorealistic renderers
Photo Real (renderer)

See also photorealistic renderers
photorealistic rendering.....1036
pick button (mouse).....94, 1036

uses.....94
pickbox cursor.....574–575, 583–584

resizing.....574–575, 584
selecting objects with.....574, 583

PICKFIRST system variable.....265
PICKSTYLE system variable.....588
pipe character (|).....973

dependent named object name
divider.....973

pixels.....592
removing strays.....592

placeholders.....725, 728
inserting fields as.....725, 728

plan views.....167, 169, 302, 342, 1037
changing 3D views to.....169
using object snaps in.....342
wide polyline lineweight display in...

302
planar closed spline curves.....365

calculating areas/perimeters.....365
planar projection (in image mapping).....

1037
planes

clipping.....1020
clipping. See also clipping planes
construction.....1021

pline.....1037
PLINE command.....336

dimensional input.....336
plines. See polylines
plot area

setting.....851–852, 876
See also printable area

plot configurations. See plotter
configurations

plot devices. See plotters

Plot dialog box, plot area options.....876
plot file drawing sets.....929–930

creating and publishing.....929–930
plot file formats.....913–914, 916

DWF format.....913
DXB format.....914
PostScript formats.....916

plot files
creating.....918
DWF files. See DWF plot files

plot offset (of layouts).....853, 880
adjusting.....853
paper-saving feature conflicts.....880

plot orientation.....860–861, 880
plot scale.....854–855, 881–883

paper size and.....881
setting.....138, 168, 185–186, 753, 

807–808, 848, 854–855, 877–
878, 881–883, 938

to fit the paper.....854–855, 882–
883

for layouts.....854, 881
on the Model tab.....881
using a custom scale.....882
using a real-world scale.....882

plot scale lists.....854, 881
modifying.....854, 881

plot settings.....874–875, 886
Plot Stamp dialog box.....886

displaying.....886
plot stamps.....871, 886, 937

publishing sheets (in sheet sets)
with.....937

turning on.....886
plot style colors.....903–904

assigning.....903–904
Plot Style control (Properties toolbar).....

264
plot style linetypes.....907–908

assigning.....907–908
plot style lineweights.....907–908

assigning.....907–908
Plot Style Manager.....871, 894
Plot Style Table Editor.....899
plot style tables

assigning to layouts.....893, 896
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color-dependent. See color-dependent
plot style tables

converting color-dependent tables
into named tables.....892

converting drawings to a different
table type.....891–892

creating.....894
descriptions, changing.....895
editing for layouts.....857
editing plot styles in.....895
folder for.....894

creating.....857
editing.....857
selecting.....856

importing PCP/PC2/CGF file pen
settings into.....894

for layouts.....856
managing.....894
named. See named plot style tables
previewing the effects of in layouts....

894
renaming.....895
rendered viewport plotting options

and.....859, 884
shaded viewport plotting options

and.....859, 884
types.....871

setting.....891
switching.....891

plot styles
assigning to layers.....270
assigning, to objects.....264
in color-dependent plot style tables...

890
color-dependent. See color-dependent

plot styles
converting drawings to a different

style type.....891–892
converting from color-dependent

styles to named styles....891–
892

converting from named styles to
color-dependent styles.....
891–892

dithering.....903, 905
editing.....895, 902

fill styles.....910–911
grayscale conversion.....904–905
for layers. See layer plot styles
in layouts, displaying.....858
line end styles.....909–910
line join styles.....909
linetypes.....907–908
lineweights.....907–908
in named plot style tables.....897
named. See named plot styles
NORMAL style.....899, 902
for objects. See object plot styles
pen assignments.....905–906
plotting with/without.....886, 889
screening (color intensity)....903–904
True Color values.....903
types.....871, 890
See also plot style tables

plots
area. See plot area
batch. See batch plots
orientation.....860–861, 880
previewing.....911–912
scaling. See plot scale
styles. See plot styles

Plotter Configuration Editor.....999
Plotter Configuration Editor, starting.....

848
plotter configuration files

for DWF files. See DWF plotter
configuration files

specifying the path.....85
plotter configuration settings.....870
plotter drivers

See also nonsystem plotter/printer
drivers

plotter icon (status bar).....931, 934
Plotter Manager.....870
plotters.....846–847, 875, 877–878, 905–

906, 936
paper size.....877–878
pen plotters.....905–906

pen assignments.....905–906
publishing sheets (in sheet sets) to.....

936
raster plotters.....906
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pen settings.....906
reconfiguring.....847
selecting.....846–847, 875

plotting
background plotting.....873–874

canceling.....874
turning on/off.....873

batch plotting
See also batch plots

checking job status.....873
drawings.....872
DWF files.....913, 920
DWF6 files.....950
DXB files.....914
file formats. See plot file formats
layouts.....210
lineweights.....263–264, 270, 275, 

301–308, 579, 764, 767, 855, 
886, 888, 907–908, 1032

with custom values.....302
from the Model tab.....199, 877
OLE objects.....999
order of objects in plotting.....308
overview.....870
with page setup plot settings.....874
paper space objects last/first.....886, 

889
plot files.....918
PostScript files.....916–917
preparing drawings for.....204

process steps.....204
previewing drawings for.....911–912
published electronic drawing sets.....

940
raster files.....915
scaling drawings for.....199, 854, 881
setting plot quality for OLE objects....

999
styles. See plot styles
test plot performance.....306
text frames.....307
to files.....913–918

DWF files.....913
DXB files.....914
plot files.....918
PostScript files.....916–917

raster files.....915
using a custom scale.....882
using a real-world scale.....882
viewing job details.....874
wipeout objects.....696
with/without plot styles.....886, 889

plug-ins. See standards plug-ins
plus sign (+).....65, 356–357

tracking points marker.....356–357
tree view level display button.....65

plus-or-minus sign (tolerance symbol}.....
803

plus-or-minus tolerances. See lateral
tolerances

plus-shaped marker blips.....592–593
removing.....592–593

PMP (plot model parameter) files.....879, 
1037

point filters.....1037
point filters. See coordinate filters
point markers (for point objects)

restyling.....361–362
See also markers

Point Move parameter set.....508
point objects (points)

as reference points. See reference
points

See also points (geometric)
point parameters.....474, 476, 478, 508, 

529, 536, 538
actions supported by.....474, 476
adding to dynamic block

definitions.....478
Chain Actions property.....476, 529, 

536
specifying.....538

grip type.....474
sets.....508

pointer.....1038
pointer input.....336, 340

absolute coordinates, specifying with
# sign.....336

changing settings.....340
relative polar coordinates as default

for subsequent points.....336
pointer input tooltips.....338
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entering different types of
coordinates.....338

pointing device buttons
See also pick button (mouse)

pointing devices
buttons.....94

operational definitions.....94
right mouse button.....94

buttons. See also pointing device
buttons

buttons. See pointing device buttons
click and drag actions in tree views....

236
digitizing tablets.....96
mouse.....94–95

practicing with.....95
restoring the default on startup.....85
sketching freehand with.....401
wheel mouse.....94

points.....154, 266, 313, 334, 353–357, 
359–364, 453, 651, 831, 833, 
1016, 1021, 1027, 1030, 1037

approximation points.....1016
association points (of dimensions).....

833
control points.....651, 1021
coordinate locations, displaying...313
coordinate values.....313, 336, 338, 

364
calculating.....364
displaying.....313

definition points (of dimensions).....
831

displaying coordinate values.....266
fit points.....651, 1027
insertion base point.....453
interpolation.....1030
locating.....334
for offset objects.....359–360
specifying....125–126, 154, 173, 316, 

336, 353–355, 359–360, 533–
535, 752

with angle overrides.....353
with coordinate filters....354–355
with direct distance entry.....359
by locking angles.....353

panning by.....154
from temporary reference point

offsets.....359–360
tracking.....356–357, 1044

points.....356–357
points (geometric)

base points. See base points
copying objects using two points.....

604–605
defining hatch boundaries with

multiple points.....686
key points (on parameters).....474, 

488, 510
measuring the distance between two

points.....380
moving objects using two points.....

596, 598
snapping to points on objects.....343
specifying....125–126, 154, 173, 316, 

336, 353–355, 359–360, 533–
535, 752

in dimensional input tooltips.....
336

tracking to points on objects. See
object snap tracking

points (point objects)...360–363, 418–419
creating.....419
inserting.....116, 230–231, 360–363, 

458, 546–547, 704–705, 724–
728, 752, 759, 761, 765, 768–
771, 773

marking equal segments on
objects.....360, 362–363

marking measured intervals on
objects.....360–361

markers.....361–362
sizing.....419
styling.....418–419

polar angles
specifying.....351, 353
tracking along. See polar tracking

polar array.....1038
Polar Array parameter set.....508
polar arrays.....606, 608, 610

creating.....606, 608
in 3D.....610
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polar coordinates.....312, 316–318, 320–
323, 338

entering.....312, 316
absolute.....317
cylindrical.....320–321
relative.....318
spherical.....322–323

entering in dynamic input tooltips....
338

polar distances.....352–353
drawing objects using.....353
specifying.....352

Polar Move Pair parameter set.....508
Polar Move parameter set.....508
polar parameters.....474, 476, 480, 508, 

510, 529, 533, 535–536, 538
actions supported by.....474, 476
adding to dynamic block

definitions.....480
Chain Actions property.....476, 529, 

536
specifying.....538

grip numbers.....510
grip type.....474
incremental values.....535

specifying.....535
minimum and maximum values.....

536
specifying.....536

sets.....508
value sets.....473, 533–535, 1045

specifying.....533, 535
polar stretch actions.....497–498

adding to dynamic block
definitions.....497–498

parameter supported by.....497
Polar Stretch Pair parameter set.....508
Polar Stretch parameter set.....508
polar tracking.....350–353, 356, 1038

drawing objects using.....352
and Ortho mode.....350
specifying angles.....351, 353
turning on/off.....352

PolarSnap.....350, 1038
and grid snap.....350
See also polar distances

polling cycle.....258
teamwork on sheet sets.....258

polyface meshes.....435
creating.....435

POLYGON command.....395
polygon selection windows.....576, 578, 

1038
crossing polygon selections.....576, 

578
window polygon selections.....576, 

578
polygon window selection.....1038
polygon windows. See polygon selection

windows
polygonal clipping boundaries.....971
polygonal meshes. See surface meshes
polygons.....306, 365, 392, 395–397, 409, 

441–442, 445, 576, 578, 971
calculating areas/perimeters.....365
circumscribed polygons.....395–396
as clipping boundaries.....971
CPolygons (crossing polygon

selections).....576, 578
drawing.....392, 395–397, 409
extruding.....441, 445
inscribed polygons.....395, 397
irregular. See closed polylines
line widths, changing.....306
revolving.....442
WPolygons (window polygon

selections).....576, 578
polyline clipping boundaries.....972
polyline segments.....631, 647–649

chamfering.....631
joining.....647–648
tapering.....649

polylines
arc polylines.....392–393, 409, 411
boundary polylines.....392, 394, 410, 

412
calculating areas/perimeters.....365
chamfering.....632, 634
as clipping boundaries.....972
closed.....392, 409
converting into lines.....395
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creating.....37, 41, 68, 89, 170, 207–
208, 229–230, 237–238, 253, 
422–423, 439, 441, 448, 455–
456, 458, 460, 465, 517, 610, 
744, 751, 753, 818, 862

object profiles from.....441
decurving.....648
drawing.....22, 192, 198, 211, 302, 

349, 352–353, 359, 389–398, 
401, 403–409, 411, 413–415, 
417, 419–421, 461

freehand.....401
in model space.....302

exploding.....646
extruding.....441, 445
filleting.....627, 629
filleting lines with.....626
fitting.....648

curves to.....648
splines to.....648

joining.....647–648
to lines, arcs, or polylines....647–

648
line widths.....302, 306, 648

changing.....306, 648
setting.....302

linetypes.....199, 224–225, 263–264, 
269–270, 275–276, 293–301, 
401, 544, 568, 570, 579, 593, 
648, 907–909, 974, 1031

changing.....301
generating.....648
setting.....300–301

modifying.....647, 649
offsetting.....611
revolving.....442
segments. See polyline segments
wide. See wide polylines
See also objects

polylines, for wipeout objects.....696
polylines, overlapping, draw order.....308
Portable Network Graphics files. See PNG

(Portable Network Graphics) files
portrait orientation.....860–861, 880

setting.....861
positive direction.....327

of axes, determining.....327
of rotation about axes, determining...

327
PostScript driver.....916
PostScript files.....916–917

formats.....916
levels.....916
plotting.....916–917

PostScript fonts, TrueType equivalents.....
738

PostScript formats.....916
pound sign (#).....336, 338, 745

absolute coordinates entry in pointer
input.....336

prefix in pointer input, accessing.....
338

wild-card character.....745
pound sign (#), stacked text indicator.....

717
pound sign (#), wild-card character.....280
pound signs (####).....725, 769

formula error display.....769
invalid field display.....725

precedence of operators and expressions..
375

QuickCalc rules.....375
precedence of standards files.....138–139

reordering.....139
precision.....312

drawing tools.....312
precision of drawing units.....108–110

setting.....108, 110
prefixes (for dimension text).....797
preset views.....166, 179, 185

3D Orbit view.....179, 185
3D views.....166

preview images.....124
saving drawings with.....124

previewing.....124, 894, 911–912
drawings.....124

for plotting.....911–912
plot style table effects in layouts.....

894
plots.....911–912

previewing,.....72
online content.....72
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previewing, online content.....76
previous release formats.....731

compatibility of fields with.....731
previous views.....155, 157, 161

restoring.....161
zooming to.....155, 157

primary units (for dimensions).....797, 
799–800

adding and formatting.....800
symbol for.....797

prime symbol (').....110
feet specifier.....110

Print button (Help toolbar).....9
printable area.....844, 846, 849, 880

modifying.....880
paper-saving feature conflicts.....880
plotter maximums.....849

printers
reconfiguring.....847
selecting.....846–847, 875
See also plotters

printing
3D DWF files.....948, 950
See also plotting

privacy.....73
and DesignCenter Online.....73

privacy, and Communication Center....15
procedural materials (for rendering).....

1038
Procedures tab (Help window).....8

information depth.....8
procedures, Help topic searches for.....6
product support, Migration Tools.....3
productivity. See performance

improvement
profiles.....89

workspaces and.....89
profiles (of environment settings).....87–

88
creating (saving).....87–88
exporting/importing.....87
making current.....87

before starting the program.....88
profiles (of environment settings),

specifying on startup.....85
profiles (of objects), creating.....441

project names.....985–987
adding/removing.....986
defining xref paths with.....985
displaying.....986
modifying.....987

projected tolerance.....838
zones.....838

projected tolerance symbol.....838
projected tolerances.....838
projecting 2D images onto 3D object

surfaces. See image mapping
projection lines. See extension lines
projects

clearing the current project.....988
making current.....985, 988
See also project names

prompts
See also command line prompts

prompts (in commands). See command
line prompts

prompts (in commands). See dynamic
prompts

properties.....31–33, 112, 216, 250–251, 
379, 398, 767

of drawings. See drawing properties
of layout viewports, modifying....216
modifying with QuickCalc.....379
multiline properties.....398
of dynamic block elements. See action

override properties
of dynamic block elements. See

parameter properties
editing.....251

of tool palette tools.....31–33
changing.....31, 33
displaying.....33
overrides.....32

of sheet sets.....112
of sheets/sheet sets.....250
See also layer properties
See also object properties

PROPERTIES command.....743
Properties palette.....217, 264–267, 374–

375, 379, 702, 744, 746, 760
accessing QuickCalc from.....374–375
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changing multiline text.....702, 744, 
746

changing object properties...265–266
displaying object properties.....265–

266
expanding/collapsing the properties

list.....267
modifying a layout viewport scale.....

217
modifying properties with

QuickCalc.....379
moving multiline text.....744, 746
opening.....265
removing the description pane....265
table properties.....760

Properties toolbar.....264, 270
property controls.....270

property controls (Properties toolbar).....
270

Property Lookup Table dialog box.....508, 
521

displaying.....508, 521
property types.....521
Unmatched row.....521

proxy fonts.....735, 738
proxy objects.....1038
PS (PostScript) files.....916–917

format.....916
plotting.....916–917

PSLTSCALE system variable.....224
Publish dialog box.....923, 930, 932, 938

modifying sheet sets for publishing...
938

modifying the sheet list.....923, 930, 
932

opening from the Sheet Set
Manager.....938

publish options.....920, 938, 940
saving.....940
setting.....138, 168, 185–186, 753, 

807–808, 848, 854–855, 877–
878, 881–883, 938

from Sheet Set Manager.....938
Publish Options dialog box.....940

saving the settings.....940
published 3D DWF files.....948, 950

viewing and printing.....948, 950
published DWF files...922, 940–941, 944–

945
canceling jobs in process.....922
checking jobs in process status.....922
including block information in....944
including block template information

in.....945
including layer information in.....944
metadata options.....940
output directory for.....941

changing the default.....941
plotting.....940
viewing.....940
viewing job details.....922

published electronic drawing sets.....940
plotting.....940
viewing.....940

publishing...253, 868, 873–874, 920–921, 
923, 929–932, 934–939, 948

3D DWF Publishing and.....921
3D DWF files.....948
in the background. See background

publishing
background publishing.....874, 920, 

922
canceling.....874

checking job status.....873
drawing sets.....923

electronic sets.....931–932, 934
paper sets.....929–930
plot file sets.....929–930
republishing.....939

electronic drawing sets.....920, 931–
932, 934, 940, 1025

as DWF files.....920
sheet sets.....253, 935

to DWF files.....935
including plot stamps.....937
option settings.....938
to plotters.....936
using page setup overrides.....936

sheets (in sheet sets)....234, 237, 241, 
243–247, 250–252, 256–259, 
867–868, 1040
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and applying named page setup
as override.....868

viewing job details.....874
purging.....274, 295, 593

layers.....274
unreferenced layers.....274

linetypes.....295
purging named objects.....592–593

linetypes.....593
purging, layers.....150
PWT (Publish to Web template) files.....

1038
pyramids.....433

creating.....433

Q

QDIM command.....779
QSELECT command.....579
quadrant grips.....637
queries (in databases)

stored. See stored queries
queries (in Help). See natural language

queries (in Help)
question mark (?).....745

wild-card character.....745
question mark (?), wild-card character.....

280
Question Mark button (in dialog boxes)...

10
Quick Help (Info palette).....10–11

displaying.....11
locking.....11
navigating.....11
printing information.....11

Quick Select dialog box, filtering
dimensions.....778

Quick Select, filtering selection sets....579
Quick Setup wizard.....104

starting drawings.....104
Quick Text mode, turning on/off.....307
QuickCalc calculator.....369

memory functions. See QuickCalc
memory.....369

variables. See calculator variables.....
369

See also History area.....369
See also Input box.....369
absolute value function.....372
accessing.....373

from within a command.....374–
375

directly.....374–375
from the Properties Palette.....

374–375
basic math functions.....372
changing size and appearance.....371
clearing the History area.....378
clearing the Input box.....371
displaying coordinate values.....379
displaying the angle of a line.....380
displaying the intersection of two

lines.....380
as an expression builder.....369
functions.....369
layout.....369
measuring the distance between two

points.....380
modifying properties in the Properties

palette.....379
rounding numbers.....372
scientific functions.....372
truncating numbers.....373
units display and handling rules.....

376
QuickCalc memory.....373

adding the current value to the stored
value.....373

clearing the stored value.....373
restoring the stored value.....373
storing a value in.....373

quotation marks.....5
Help topic search-text delimiters.....5

R

radial dimensions.....776, 815, 818
creating.....815, 818
creating centerlines automatically

with.....818
types.....776, 815

radians.....381–382

Index | 1130



converting degrees to.....382
converting to degrees.....381

radius dimensions
creating.....815, 818
definition points.....831
foreshortened. See jogged radius

dimensions
See also dimensions

raster driver.....915
raster files.....915

creating (plotting).....915
size.....915

Raster Graphics dialog box.....999
raster images.....22, 27, 124, 179, 953

3D Orbit view and.....179
boundaries. See raster image

boundaries
creating tools for .....22
paths. See raster image paths
preview images.....124
resolution.....885, 953–954, 1042

in DWF6 files.....953
using a tool created from.....27

raster plotters.....906
pen settings.....906

RASTERPREVIEW system variable.....124
rays.....419–421

drawing.....421
raytraced renderer. See Photo Raytrace

(renderer)
Readme topic (in Help).....10, 18
real-time panning. See dynamic panning
real-time zooming. See dynamic zooming
real-world scales.....882

plotting using.....882
rearranging.....37, 40–41, 209

layout tabs.....209
tool palette groups.....40
tool palette tools.....37
tool palettes.....22–23, 28, 35, 37–39, 

41–42, 68, 458, 465, 676
in tool palette groups.....41

reassociating.....243, 247
moved sheets to sheet sets....243, 247

reassociating dimensions.....833–834
recent input history display.....48

reconnecting links.....1001
records. See database records
RECOVER command.....128
recovering.....131, 238

sheet set data (DST) files, previous
versions of.....238

from system failures.....131
See also restoring

recovery audits.....128
recovery files.....131

name format.....131
RECTANG command.....336, 395

relative Cartesian coordinates for
subsequent points in pointer
input.....336

rectangles.....306, 395, 397, 441–442, 445
drawing.....395, 397
extruding.....441, 445
line widths, changing.....306
revolving.....442

rectangular areas. See rectangular windows
rectangular arrays.....607

creating.....607
rectangular meshes.....434, 436

creating.....434, 436
rectangular selection areas, selecting

objects in.....575
rectangular window clipping

boundaries.....971
rectangular windows....155, 157, 575, 971

as clipping boundaries.....971
as selection areas.....575
zooming to.....155, 157

red error outline, in dynamic input
tooltips.....338

REDO command.....590
redoing actions.....590–591
redrawing the screen.....1039
reducing.....269, 453

visual complexity.....269
REFCLOSE command.....981
Refedit toolbar.....978–979
reference.....622–623, 1039

scaling objects by.....622–623
reference points

drawing.....419
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offsetting points from.....359–360
See also point objects

references.....977, 993
reflection (of light)

diffuse. See diffuse reflection
specular. See specular reflection

(highlights)
reflection color (of materials)

See also specular color
reflection line.....1039
reflection lines.....502
reflection maps.....1039
refreshing the image of a block tool on a

tool palette.....34
regardless of feature size value (S/RFS).....

837
REGEN command.....429
regenerating.....304, 1039

drawings....37, 64, 68, 70, 77, 80, 85, 
101–107, 116–118, 120–124, 
129–131, 136, 138–140, 143, 
146, 160, 173, 198–199, 204, 
243, 246–247, 273, 304, 453, 
457, 594–595, 676, 854–855, 
860–861, 880–883, 891–892, 
911–912, 964–967, 973–976, 
993–995, 998, 1001–1003, 
1030, 1039, 1046

lineweight display and.....304
regions.....365, 421–424, 441–442, 445

adding.....422–423
calculating areas/perimeters.....365
combining.....422–424
composite regions.....422–424
creating.....422–423

out of boundaries.....422–423
extruding.....441, 445
intersections.....422, 424
revolving.....442
subtracting.....422, 424
uses.....421

regular polygons.....395–397
drawing.....395–397

regular polygons. See polygons
relative coordinates....312, 315–316, 318–

322, 338, 597–598, 604, 1039

copying objects using.....604
entering.....312

Cartesian.....315, 319–320
polar.....316, 318, 321–322

entering, in pointer input tooltips.....
338

moving objects using.....597–598
relative paths, for xrefs.....983
relative polar coordinates.....336

as default for subsequent points in
pointer input.....336

Reload option (XREF command).....969
reloading.....969

xrefs.....969
relocated xrefs, notification of.....985
relocating UCSs.....323, 326

in 3D space.....326
REMEMBERFOLDERS system variable.....

116
removing.....25, 139, 242–243, 247, 564, 

566, 571, 574–575, 577–578, 589, 
592–593, 677, 683, 694, 887–888, 
924, 926, 930, 933, 979–980, 986

blips.....592–593
block attributes.....564, 566
block definitions.....571
drawing sheets (from drawing sets)....

924, 926, 930, 933
hatch associativity.....677, 694
hidden lines.....884, 887–888

plotting from layout tabs.....888
plotting from the Model tab.....

887
hidden lines. See removing hidden

lines in 3D objects
islands (from hatch areas).....683
objects.....22–23, 35, 121, 123, 185, 

211, 218, 222, 226, 264, 266–
267, 270–271, 275–276, 281, 
287–288, 290, 297–298, 305, 
308–309, 343, 352–353, 360–
363, 365, 389, 439–442, 445–
447, 457, 461, 470, 546, 568, 
574–575, 577–578, 581, 589, 
592–605, 610–615, 617–624, 
628–633, 635–644, 646, 656, 
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668, 681, 696, 734, 870, 974, 
979–980, 998, 1001, 1003, 
1005, 1022, 1034, 1038

from groups.....589
from selection sets.....574–575, 

577–578
objects, from working sets....979–980
project names.....986
sheet subsets.....242
sheet view categories.....242
sheets (from sheet sets).....243, 247
standards files from drawings.....139
stray pixels.....592
tool flyouts.....25
unused named objects.....592

linetypes.....593
See also deleting

removing hidden lines in 3D objects.....
182

renaming.....40, 122, 209, 255–256, 275, 
277, 286, 325, 518, 867, 895, 
900–901, 924, 927, 930, 933, 974

drawing sheets (in drawing sets).....
924, 927, 930, 933

drawings named with
double-byte/special
characters.....122

layer settings.....286
layers.....275
layers, multiple layers.....277
layouts.....209
named objects.....974
named page setups.....867
named plot styles.....900–901
plot style tables.....895
sheet selections.....255–256
tool palette groups.....40
UCSs.....325
visibility states.....518

rendered images
viewport plotting options.....883–885
aliasing in. See anti-aliasing

rendering
See also Render (renderer)

renderings. See rendered images
reordering objects in groups.....589

repairing.....128–129
damaged drawing files.....128–129
open drawings.....129

repeating commands.....46, 52, 55
in the command window.....55
by right-clicking.....46

replacing.....745–746, 827, 829
text.....55, 199–200, 308, 613, 698–

699, 701, 703, 705, 707, 724, 
732, 741–743, 745–746, 748, 
753, 765–766, 827, 829

dimension text.....827, 829
multiline text.....745–746

REPORTERROR system variable.....132
republishing.....939

drawing sets.....939
resaving all sheets in sheet sets.....259
RESETBLOCK command.....550

resetting more than one block
reference at a time.....550

resetting.....53–54, 179, 185
3D Orbit view.....179, 185
system variables...10, 53–54, 56, 1043

transparently.....53–54
resetting block references.....550
reshaping objects.....621
resizing....44, 55, 57–58, 63, 81, 159–160, 

339, 574–575, 584, 621, 747
Aerial View window image...159–160
the command window.....55, 57–58
command window.....57–58
DesignCenter.....63
leaders.....747
objects.....621
pickbox cursor.....574–575, 584
toolbars.....44, 81
tooltips.....339
windows.....81

resizing tables.....759
resizing, layout viewports.....214
resolution

of DWF files.....953
setting.....885
specifying.....953–954

for plotting shaded images.....885
snap resolution.....1042
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See also precision
resource drawings.....1039
Resource Drawings tab (Sheet Set

Manager).....235
restarting recently used command.....53
restoring

the default drawing template file.....
105, 107

dimension styles.....824
drawings....37, 64, 68, 70, 77, 80, 85, 

101–107, 116–118, 120–124, 
129–131, 136, 138–140, 143, 
146, 160, 173, 198–199, 204, 
243, 246–247, 273, 304, 453, 
457, 594–595, 676, 854–855, 
860–861, 880–883, 891–892, 
911–912, 964–967, 973–976, 
993–995, 998, 1001–1003, 
1030, 1039, 1046

from backup files.....130–131
erased objects.....592–593
hatch associativity.....694
layer settings.....284–285
model space viewports.....192
named views.....161–162
previous views.....161
sheet selections.....254
UCSs.....323–325, 329, 331

named UCSs.....325, 329
previous UCSs.....323–324, 331
to the WCS.....324

viewport arrangements.....194
See also recovering
See also repairing

return button (mouse)
See also right mouse button

REVCLOUD command.....447
reverse lookup.....524, 527, 1039

enabling/disabling.....527
reverse quote.....745

wild-card character.....745
reverse quote (’).....745

wild-card character.....745
reverse quote, wild-card character.....281
revision clouds (markups).....447–449

calligraphy style.....447

converting closed objects to.....448
converting objects to.....447
creating.....447

from scratch.....448
creating with calligraphy pen style....

448
editing lengths of arcs or chords.....

449
normal style.....447
setting default values for arc

lengths.....447, 449
styles.....447

REVOLVE command.....442
revolved solids, creating.....442, 446
revolved surface meshes.....429, 432, 437

creating.....432, 437
revolving objects.....442, 446
REVSURF command.....429, 432
RGB color system.....1040
right mouse button

uses.....94
See also right-clicking

right-clicking.....45–47, 52, 96
customizing.....45, 47, 96
displaying shortcut menus.....46
in the drawing area.....46
executing commands.....52
repeating commands.....52
repeating commands by.....46
time-sensitive behavior.....45

turning on.....47
right-hand rule.....327
roll-over behavior.....63

DesignCenter.....63
rolling windows up or down.....81
rollover behavior.....29–30

Tool Palettes window.....29–30
rotate actions.....499–501

adding to dynamic block
definitions.....499, 501

Base Type property.....500
parameter supported by.....499

rotated dimensions
extension line origins.....809
See also dimensions

rotating
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3D views.....167
dimension text.....827–828
faces of 3D solids.....662
objects

in 3D.....600
to an absolute angle.....600–601
around an axis.....602
by dragging.....599
with grips.....638, 640
by a specified angle.....599
through clipping planes.....185
See also mirroring

the snap angle.....347, 349
UCSs.....323
views.....82, 84–85, 117, 153–154, 

160–162, 166, 168–169, 211, 
216–217, 225, 228, 1005, 
1045

in layout viewports.....228
rotation angle, prompting for, when

placing block or xref from tool
palette.....27

rotation direction about axes, positive,
determining.....327

rotation grips.....510, 549
rotation parameters...474, 476, 483, 508, 

529, 534–536, 538
actions supported by.....474, 476
adding to dynamic block

definitions.....483
Chain Actions property.....476, 529, 

536
specifying.....538

grip type.....474
incremental values.....535

specifying.....535
minimum and maximum values.....

536
specifying.....536

sets.....508
value sets.....473, 533–535, 1045

specifying.....534–535
Rotation Set parameter set.....508
rotation snaps, copying objects with.....

642–643
rounding numbers (in QuickCalc).....372

rounding off.....109
of drawing units.....109

rounding off dimension values.....801
rounding. See filleting
rounds. See fillets
rows (in database tables). See database

records
rows (in tables).....759–762, 764, 770–771

adding.....761
averaging values in.....770
counting cells in.....771
deleting.....762
header rows.....764
modifying.....759–761
setting number of.....759
summing the values in.....770
title rows.....764

RTF files.....724–725
importing.....724
inserting.....724–725

rubber-band line.....349, 1040
in orthogonal locking.....349

ruled surface meshes.....429, 431, 436
creating.....431, 436

ruler (Multiline Text Editor).....714–715
RULESURF command.....429, 431
running object snaps.....342–346, 1040

cycling through.....344
overriding.....345–346
setting.....343
turning on/off.....342–343

S

S (regardless of feature size symbol)....837
save back.....1040
saving.....37, 42, 80, 87–88, 91, 121–124, 

130, 138, 161–162, 193–194, 229, 
231, 254, 259, 284, 324, 329, 
402, 541, 581, 766, 772, 940, 
993–995

backup files.....123, 130–131, 238
when saving drawings...123, 130

block definitions.....541
block definitions as drawing files.....

123
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drawings
automatic saves.....80, 123, 130
to different formats.....121
incremental saves.....121
with layer indexes.....993–995
partial saves.....121, 123
with preview images.....124
reducing the time required for....

121
saving backup files when.....123, 

130
See also exporting drawings
with spatial indexes.....993–995

environment variables. See profiles (of
environment settings)

filtered lists.....581
freehand lines.....402
layer settings.....284
layout templates.....229, 231
named views.....161–163, 1033

settings saved.....161
profiles.....87–88
publish options.....940
selected objects.....121, 123
sheet selections.....254
sheets in sheet sets, resaving all....259
standards files.....138
table changes.....766, 772
tool palette groups.....42
tool palettes.....37, 42
UCSs.....324, 329
viewport arrangements.....194
views.....82, 84–85, 117, 153–154, 

160–162, 166, 168–169, 211, 
216–217, 225, 228, 1005, 
1045

settings saved.....161
workspaces.....91

saving back.....981–982, 1040
in-place reference editing changes.....

981–982
scale actions.....492–494

adding to dynamic block
definitions.....492–493

base point type.....492, 494
parameters supported by.....492

Scale Type property.....492, 494
SCALE command.....107–108

converting drawing units.....107–108
scale factors

arrowheads.....788
dimensions. See dimension scale
for layout viewport views.....216
for plotting.....199
scaling objects by.....622–623

scale locking.....211, 217–218
in layout viewports.....211, 217–218

Scale Type property.....492, 494
for scale actions.....492, 494

SCALELISTEDIT command.....216, 854, 
881

SCALETEXT command.....748
scaling...23, 107, 198–201, 216–217, 224–

225, 299, 531, 622–623, 638, 
640, 743, 747–748, 758, 761, 854–
855, 881–883, 907, 909

annotations.....199
blocks.....23, 199, 201
dimensions

See also dimension scale
drawings.....107, 198–199

to fit the paper.....854–855, 882–
883

for plotting.....199, 854, 881
dynamic blocks...452, 459–463, 466, 

471, 473–475, 521, 527, 531, 
540, 548, 550

preventing non-uniform
scaling.....531

fill patterns.....909
hatch patterns.....199
inserted content.....201
leaders.....747
linetypes.....199, 299, 907

in layout viewports (paper
space).....224–225

non-ISO linetypes.....909
lineweights.....855
multiple text objects.....748
objects.....22–23, 35, 121, 123, 185, 

211, 218, 222, 226, 264, 266–
267, 270–271, 275–276, 281, 
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287–288, 290, 297–298, 305, 
308–309, 343, 352–353, 360–
363, 365, 389, 439–442, 445–
447, 457, 461, 470, 546, 568, 
574–575, 577–578, 581, 589, 
592–605, 610–615, 617–624, 
628–633, 635–644, 646, 656, 
668, 681, 696, 734, 870, 974, 
979–980, 998, 1001, 1003, 
1005, 1022, 1034, 1038

by reference.....622–623
by scale factor.....622–623
with grips.....638, 640

plots. See plot scale
table columns/rows.....761
tables.....758
text.....199–200, 743, 748
views.....82, 84–85, 117, 153–154, 

160–162, 166, 168–169, 211, 
216–217, 225, 228, 1005, 
1045

in layout viewports.....216–217
scientific functions (in QuickCalc).....372

using.....372
screen (display).....80, 592

cleaning up.....592
clearing.....80

screen display
resolution. See resolution
updating.....307

screen redrawing.....1039
screening (color intensity)...222, 903–904

of objects in layout viewports.....222
ScriptPro (Migration Tool).....2
scripts.....28, 84, 1040

creating command tools for
executing.....28

running, on startup.....84
turning on animation while script

runs.....84
SDF (space-delimited format) files.....558–

559
format.....558

Search dialog box (DesignCenter).....69
loading the content area from.....69

search paths.....42, 80, 85, 116–117, 125–
126, 983, 985, 987

adding/deleting.....987
specifying....125–126, 154, 173, 316, 

336, 353–355, 359–360, 533–
535, 752

for support files.....125–126
specifying (changing).....42, 80, 85, 

116–117, 983, 985
for the default drawing folder.....

116–117
defining with project names.....

985
for plotter configuration files.....

85
for support files.....80, 85
for tool palette files.....42
type options.....983

for support files.....80, 125–126
search paths (for support files).....1018

AutoCAD library search paths....1018
Search tab (Help window).....3, 5–6

advanced search rules.....5
basic search rules.....5
check boxes.....6

Search tool (Windows).....124, 745
finding drawing files.....124, 745

Search-the-Web link (natural language
queries).....7

searching.....3, 5–6
Help topics (for words/phrases).....3, 

5
advanced search rules.....5
basic search rules.....5
in the current topic.....3

See also finding
SECTION command.....657
section views (of 3D objects), creating.....

170
sectioning.....657–658

3D solids.....657–658
sectored views.....117
security.....943

password security for DWF files....943
SELECT command.....583
Select Template dialog box.....102
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displaying.....102
starting drawings in.....102

selected objects.....121, 123
saving.....121, 123

selecting.....55, 270–271, 273, 552, 588, 
637, 659, 703, 707, 726, 758, 
760, 765–766

attributes.....552
faces of 3D solids.....659
fields (in text).....726
grips.....637
groups.....588
layers.....270–271, 273
multiple layers.....271
objects. See selecting objects
paragraphs.....707
table cells/columns.....758, 760
tables.....765
text.....55, 703, 707

in tables.....766
words.....707

selecting objects...574–580, 582–584, 637
by classification property.....579–580
close together.....574
customizing selection.....582
cycling through objects.....574–575
after entering an editing command....

582
before entering an editing

command.....583
with grips on.....637
individually.....574
in irregular areas.....576, 578
methods.....577
methods (default options).....584

changing.....584
multiple objects.....575
noun/verb selection.....575, 583–584
with the pickbox cursor.....574, 583
preventing selection.....578
in rectangular areas.....575
with selection fences.....577–578
with selection windows.....575

selection areas.....575–576
irregular.....576
rectangular.....575

selection fences.....575, 577–578
selecting objects with.....577–578

selection highlighting
previewing effects. See selection

previewing
turning off.....583

selection methods.....577
listing options.....577

selection previewing.....583–584
turning on/off.....584

selection sets
for actions. See action selection sets
adding....25, 366, 368, 422–423, 442, 

446, 574
objects to.....574

adding objects to.....581
assigning actions to.....508
creating, with Quick Select...579–580
excluding objects from.....580
filtering.....579
limiting grip display in.....638–639
named. See groups
removing.....25, 139, 242–243, 247, 

564, 566, 571, 574–575, 577–
578, 589, 592–593, 677, 683, 
694, 887–888, 924, 926, 930, 
933, 979–980, 986

objects from....574–575, 577–578
selection windows

creating.....575
crossing selections.....576, 1022
window selections.....575
See also polygon selection windows

selections.....575–576, 578, 1022
crossing.....576, 1022

polygon selections.....576, 578
window polygon selections.....576, 

578
window selections.....575

self-intersecting torus/tori.....440
sending objects to back.....308

draw order of objects.....308
separating composite 3D solids.....669
servers

See also directory servers
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setenv AutoLISP function, using to set the
MaxHatch system registry
variable.....678, 693, 695

settings. See system variables
setup wizards.....104

starting drawings with.....104
shaded images

display limitations.....175
smoothness.....438
See also shading

shaded UCS icon.....333
shaded viewports.....859, 883, 885–886

plotting options.....859, 883, 886
Rendered option.....885
resolution.....885
setting.....885

SHADEMODE command.....175, 429, 978
display limitations.....175

shading
flat shading.....183
Gouraud shading.....183–184
in 3D Orbit view.....182
See also shaded images

ShapeManager.....1040
sheet creation templates.....237, 253

creating sheet sets from.....253
specifying.....237

sheet list (Publish dialog box)....923, 930, 
932

modifying.....923, 930, 932
sheet list (Sheet Set Manager).....241–242

creating subsets in.....241
removing subsets from.....242
reordering sheets in.....241

Sheet List tab (Sheet Set Manager).....235
sheet list tables.....1040
sheet list tables (on title sheets)...244, 250

creating.....250
sheet properties, published in DWF files...

256
sheet selections (named sheet sets).....86, 

254–256, 1041
deleting.....255–256
loading on startup.....86
modifying.....255
renaming.....255–256

restoring.....254
saving.....254

Sheet Set control (Sheet Set Manager).....
235

sheet set data (DST) files.....236, 238
backing up/recovering.....238

sheet set data backup (DS\$) files.....238
Sheet Set Manager.....112, 234, 238, 241, 

257, 934, 938
interface controls.....234
lock icons for sheet sets.....257
opening.....238
opening the Publish dialog box

from.....938
organizing sheet sets.....112
reordering sheets in.....241
setting publish options from.....938

Sheet Set Manager window, not displaying
on startup.....86

sheet sets.....112, 234, 236–240, 243, 246–
247, 250–251, 253, 257–259, 867, 
935–938, 1041

archiving.....253
closing.....239
creating.....236, 238

from drawing files.....238
from example sets.....237
preparation steps.....237
from sheet creation templates.....

253
creating new sheets.....243, 246
custom properties.....251

creating.....251
eliminating multiple layout tabs

for.....237
lock icons in Sheet Set Manager...257

false.....258
modifying for publishing.....938
opening.....239
opening drawings within....243, 246–

247
organizing.....112, 240
page setups for....237, 253, 924, 928, 

930, 933
overriding.....237, 253

properties.....112, 250
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editing.....251
publishing.....253, 935

to DWF files.....935
including plot stamps.....937
option settings.....938
to plotters.....936
using page setup overrides.....936

reassociating sheets that were moved
to another folder.....243, 247

removing sheets from.....243, 247
resaving all sheets in.....259
status data for team members using

sheets.....258
team use of.....257
transmitting over the Internet.....253
updating sheets for team members not

using Sheet Set Manager.....
258

using named page setups.....867
sheet subsets (in the sheet list)..240–242, 

251, 935
creating.....241
properties.....31–33, 112, 216, 250–

251, 379, 398, 767
editing.....251

publishing, to DWF files.....935
removing.....242

sheet view categories.....240, 242, 251
creating.....242
properties.....31–33, 112, 216, 250–

251, 379, 398, 767
editing.....251

removing.....242
sheet views.....243–245, 248–249

adding.....243, 245, 248
callout blocks for.....244, 249
components (entities).....245
drawing files for.....243
label blocks for.....244, 249
removing.....245

sheets (in sheet sets)...234, 237, 241, 243–
247, 250–252, 256–259, 867–868, 
1040

accessed by multiple users through
different logical drives....257

applying named page setups as
override when publishing
sheets.....868

common operations on.....243
creating.....243, 246
custom properties.....251

creating.....252
importing layouts as.....245
modifying.....243
multiple layouts from single drawing

files as.....237
properties.....250

editing.....251
properties in published DWF files.....

256
removing from sheet sets.....243, 247
reordering in the sheet list.....241
resaving all sheets in sheet sets.....259
specifying same output options in

named page setups.....867
status data for team members.....258
title sheets.....244

creating sheet list tables on...250
updating for team members not using

Sheet Set Manager.....258
shelling.....656, 669

3D solids.....656, 669
SHIFT+click.....574–575

adding objects to selection sets....574
removing objects from selection

sets.....574–575
SHIFT+right click.....342

displaying the Object Snap shortcut
menu.....342

SHIFT+right-click, displaying the object
snap menu.....48

SHIFT+TAB keys.....766
moving to the previous cell.....766

SHIFT-A.....345
overriding running object snaps.....

345
shifting the XY plane.....330
shortcut functions.....384

predefined calculator variables.....384
shortcut keys.....1041
shortcut menus.....45–47, 96, 236, 1041
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customizing.....45–46
displaying.....3–4, 11, 45, 47, 56–57, 

149, 160, 264–266, 300–304, 
308, 467

customizing right-click
behavior.....45, 47

options typical of.....45
turning off.....46, 96

in the drawing area.....46, 96
individually.....96

Show button (Help toolbar).....10
shrinking views. See zooming
SHX (font) files.....738
SHX fonts.....702, 708, 735, 738

bullet character.....708
custom fonts.....738
proxy fonts for.....735, 738
Unicode character support.....702

single-line text
aligning.....699, 701
compressing.....699
creating.....699–700
editing.....743
fields in.....699
objects, modifying.....743–744
obliquing angle.....741
orientation.....742
styles.....699

not affecting.....734
specifying.....701

See also text
single-sheet DWF files.....941

specifying.....941
sizing.....419

point objects.....419
SKETCH command.....400, 402
sketching. See freehand lines
SLA files. See Stereolithograph files
slash (/), stacked text indicator.....717
slash. See forward slash (/)
SLICE command.....658
slicing 3D solids.....185, 658

in 3D Orbit view.....185
slide files.....1041
slide libraries.....1041
smooth shading.....1041

smoothness (of curved objects).....438
3D objects.....438

snap (grid snap).....347, 349–350
overriding.....347, 349
and PolarSnap.....350
snap grid spacing.....347

vs. grid spacing.....347
setting.....349

turning on.....349
See also PolarSnap

snap (snap grid).....1041
snap angle.....347, 349, 1041

rotating.....347, 349
snap base point.....347, 349

changing.....347, 349
snap grid

See also snap (snap grid)
Snap mode.....1042
Snap mode. See snap
snap resolution.....1042
snapping to points on objects

See also snap (snap grid)
snaps

isometric snap style.....1030
See also object snaps

solid boxes, creating.....439, 443
solid cones, creating.....439, 444
solid cylinders, creating.....439, 444
solid dishes, creating.....440
solid domes, creating.....440
solid fill. See Fill mode
solid fills.....308

overlapping objects, draw order...308
solid fills (solid-filled areas).....307–308

turning off.....307–308
solid hatch patterns

See also gradient fills
solid modeling

See also 3D solids
solid spheres, creating.....445
solid torus/tori, creating.....440, 445
solid wedges, creating.....441, 445
solid-filled areas

creating.....686
modifying.....694
See also 2D solids
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See also donuts
See also solid-filled hatches
See also wide polylines

solid-filled areas. See solid fills (solid-filled
areas)

solid-filled hatches.....687, 694
creating.....687
modifying.....694

sorting layers.....280, 283
using wild-card characters.....280

source application, in OLE object
editing.....1006

source applications.....1007
editing linked objects within.....1007

source applications. See server applications
space-delimited format (SDF) files.....558–

559
format.....558

SPACEBAR key.....52
executing commands.....52
repeating commands.....52

SPACETRANS command.....748
spatial indexes.....993–995, 1042

saving drawings with.....993–995
special characters

inserting in multiline text.....704–705
for naming objects.....734
renaming drawings named with...122
See also \

specular color (of materials)
See also specular reflection (highlights)

specular reflection (highlights)
See also specular color

spelling. See checking spelling
sphere icons (in 3D Orbit view).....179
spheres.....433, 445

creating.....433
solid, creating.....445

spherical coordinates, entering....322–323
SPLFRAME system variable.....435
spline curves

B-spline curves.....1018
Bezier curves.....1018
fit points.....1027
See also spline-fit polylines

spline leaders, creating.....722

spline-fit polylines.....417, 618, 648
converting into splines.....417
creating.....417, 648
trimming and extending.....618

splined polylines. See spline-fit polylines
SPLINEDIT command.....650

command options.....650
splines.....611, 650

offsetting.....611
splines (NURBS curves).....365, 416–417, 

441, 445, 650–652
calculating areas/lengths.....365
control points.....651
converting...107–108, 110–111, 148, 

381–382, 395, 417, 595, 738, 
799–800, 834, 891–892, 904–
905

spline-fit polylines into.....417
drawing.....417
editing.....650, 652

with grips.....650
extruding.....441, 445
fit points.....651
order of.....651
refining the shape.....651
tolerance.....416, 650–651

square brackets.....280, 745, 797, 799
alternate units symbol.....797, 799
wild-card character.....280
wild-card characters.....745

square brackets with hyphen.....745
wild-card characters.....745

square brackets with tilde.....745
wild-card characters.....745

square feet units (in QuickCalc).....376
square-bracketed hyphen, wild-card

character.....280
square-bracketed tilde, wild-card

character.....280
squares.....395, 397

drawing.....395, 397
squeezing text.....699
stacked text (multiline text).....717–719, 

753
creating.....717–718

format codes.....753

Index | 1142



editing.....719
unstacking.....719

Stand-Alone Installation Guide, accessing....
2

standard grips.....510, 549
STANDARD style.....397

multilines.....397
standards (for named objects)

converting layers to.....148
maintaining in collaborative

environments.....136, 140, 
142

named object types for which
standards can be created.....
136

setting.....138, 168, 185–186, 753, 
807–808, 848, 854–855, 877–
878, 881–883, 938

standard options.....138
violations. See standards violations
See also standards files

standards audits...136, 140–141, 143, 146
batch audits.....141, 146

standards check files
creating.....145
opening.....145
overrides for, specifying.....146
See also standards files

standards files
associating with drawings.....138–139
conflicts between.....138
creating.....138
file name extension.....138
precedence.....138

reordering.....139
removing from drawings.....139
sample file.....136
saving.....138
uses for.....136
See also standards (for named objects)
See also standards check files

standards plug-ins.....137–138, 140
specifying.....137–138, 140

standards violations...136–137, 140–144, 
146

checking drawings for.....136, 140, 
143, 146

fixing.....137, 141–143
ignored problems display.....141

turning on/off.....144
notification alerts.....141–142

turning on/off.....142, 144
types.....136

starting.....4, 84–86, 88, 101–106, 145
Batch Standards Checker.....145
Developer Help.....4
drawings....37, 64, 68, 70, 77, 80, 85, 

101–107, 116–118, 120–124, 
129–131, 136, 138–140, 143, 
146, 160, 173, 198–199, 204, 
243, 246–247, 273, 304, 453, 
457, 594–595, 676, 854–855, 
860–861, 880–883, 891–892, 
911–912, 964–967, 973–976, 
993–995, 998, 1001–1003, 
1030, 1039, 1046

with the default drawing template
file.....103

with drawing templates/template
files....102–103, 105–106

with templates.....85
with wizards.....104

Help.....4
program.....84, 86, 88

making environment profiles
current before.....88

making profiles current before....
88

using command line switches.....
84, 86

the program.....84
using command line switches.....

84
static coordinate display.....313
status bar.....47–48, 312, 931, 934

button display.....47
cursor coordinate display.....48
cursor location coordinate display.....

312
icon and notifications display.....47
plotter icon.....931, 934
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STB (plot style table) files.....1042
STB file name extension.....871
stray pixels.....592

removing.....592
stretch actions.....494–495, 497

adding to dynamic block
definitions.....494–495

Distance Type property.....495, 497
parameters supported by.....494

STRETCH command.....621
stretch frames.....494, 497, 539, 1042

redefining.....539
stretching

leaders.....747
moving objects by.....597–598
objects.....621, 623
objects, with grips.....638–639
text.....699
See also extending

styles.....334, 653, 701, 706, 734, 1030
isometric snap style .....1030

subdividing model space viewports.....191
Subscription Center.....13–14, 1042

accessing.....14
installing.....14
services available.....13

subsets of sheet sets.....1042
substitute fonts.....740
SUBTRACT command.....422, 443
subtracting...366, 368, 422, 424, 443, 446

3D solids.....443, 446
areas.....366, 368
regions.....422, 424

suffixes.....797
Summary tab (Drawing Properties dialog

box).....113
summing the values in table cell ranges...

770
support files

search path.....85
search paths. See search paths
specifying (changing) search paths

for.....80
specifying search paths for....125–126

support folders, specifying on startup.....
85

surface meshes (faceted surfaces).....429–
438

closed.....430
density.....430
edge-defined (Coons surface patch)

meshes.....429, 432, 438
faces.....429
general meshes.....429, 434–435
open.....430

closing.....434
predefined meshes.....429, 433
revolved meshes.....429, 432, 437
ruled meshes.....429, 431, 436
tabulated meshes.....429, 431, 437
types.....429
uses.....429
wireframe display.....429

surface modeler, AutoCAD.....429
surface modeling

See also surfaces
surfaces

creating.....425
curved, smoothness.....438
faceted. See meshes
faceted. See surface meshes
irregular surfaces.....434
mapping 2D images onto. See image

mapping
types.....429
See also faces

surveyor angles.....111
specifying.....111

switching.....90
workspaces.....90

symbol libraries
accessing.....71
loading the DesignCenter content area

with.....69
See also block libraries

symbol library drawings. See block library
drawings

symbols.....1042
symmetrical tolerances.....803, 805
syntax of expressions.....376

evaluated in QuickCalc.....376
system failures.....129, 131
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recovering from.....131
repairing damaged drawing files due

to.....129
system printers, paper size.....848
system variables.....10, 53–54, 56, 1043

affecting dialog boxes.....56
entering on the command line.....54
help on.....10
listing.....54
resetting.....53–54, 179, 185

transparently.....53–54

T

tab characters, in attribute extraction
template files.....560

TAB key.....766
moving to the next cell.....766

TAB key, cycling through running object
snaps.....344

table data. See database table data
table of contents. See sheet list tables (on

title sheets)
Table Style dialog box.....763
table styles.....762–763, 765

applying.....765
defined.....762
defining new styles.....763
reapplying.....765

TABLEEXPORT command.....762
TABLEINDICATOR system variable.....773
tables

adding/deleting columns or rows.....
761–762

averaging the values in cell ranges.....
770

background color.....764
cell and row indicator display.....773

background color control.....773
turning off/on.....773

cell margins.....763
cells. See cells (in tables)
columns. See columns (in tables)
counting the cells in cell ranges...771
creating.....759
defined.....758

direction of.....763
editing cells.....758
editing text in.....765, 768
entering formulas in.....769, 772
entering text in.....765–766
exporting.....762
formatting text in.....765–766
gridlines.....764
header rows.....764
height/width, changing.....758
inserting blocks in.....765, 768
inserting fields in.....727, 769
merging cells.....760–761
number of columns/rows in.....759
Properties palette and.....760
resizing with grips.....759
rows. See rows (in tables)
saving changes.....766, 772
selecting text in.....766
summing the values in cell ranges.....

770
table styles.....762–763, 765
text color.....764
title rows.....764
See also database tables

tablet
See also digitizing tablet

Tablet mode.....401
sketching in.....401

tabs (multiline text), setting.....714
TABSURF command.....429, 431
tabulated surface meshes.....429, 431, 437

creating.....431, 437
tapering.....392, 410, 439, 441, 649, 660, 

664, 688
extruded solids.....439, 441
faces of 3D solids.....660, 664
wide polyline segments.....392, 410, 

649
wide polylines.....688

target, camera, positioning.....175–176
taskbar (Windows).....120

displaying drawings on.....120
TASKBAR command.....120
teams.....257–258
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limited member access to DST files
when not using Sheet Set
Manager.....258

logical drives for sheet set work....257
member access to DST and DWT

files.....257
sheet set use.....257
status data for sheets in current sheet

set.....258
work sessions polled for status

changes.....258
work with sheet sets with Sheet Set

Manager.....257
work with sheet sets without Sheet Set

Manager.....258
template (DWT) files

creating.....272
for extracting attribute information.

See attribute extraction
template files

label. See label templates
layout. See layout templates
link. See link templates

template drawing files. See template (DWT)
files

template drawings. See drawing
templates/template files

template materials. See solid materials
templates.....237, 253

sheet creation templates.....237, 253
templates (prototype drawings).....1025
temporary files.....125, 130, 1043

name format.....130
specifying location.....125

temporary reference points. See reference
points

termination symbols. See arrowheads
tessellation lines.....438, 1043

illustrated.....1043
in wireframes.....438

test plots, performance.....306
testing.....463, 540

dynamic blocks.....463, 540
text.....55, 199–200, 308, 613, 698–699, 

701, 703, 705, 707, 724, 732, 

741–743, 745–746, 748, 753, 765–
766, 827, 829

adding hyperlink fields to.....732
aligning. See aligning text
block-associated. See attributes (of

blocks)
compressing.....699
for dimensions. See dimension text
draw order...308–309, 678, 695, 1000

changing.....308
editing. See editing text
entering.....52, 54, 56, 312, 314–323, 

326–327, 334, 338, 354–355, 
582–583, 765–766, 769, 772

in table cells.....765–766
expanding (stretching).....699
finding.....75–76, 112, 124, 745–746

multiline text.....745–746
formatting.....709, 752, 765–766

in table cells.....765–766
formatting. See formatting text
height. See text height
importing.....724
mirroring.....613, 743
multiline. See multiline text
obliquing angle.....741

format code (multiline text).....
753

orientation.....742
overlapping, draw order.....308
pasting, from other

application/AutoCAD files....
724

pasting, from other
application/AutoCAD LT
files.....724

replacing.....745–746, 827, 829
multiline text.....745–746

scaling.....199–200, 748
selecting.....55, 703

in tables.....766
selecting, multiline text.....707
single-line. See single-line text
stacked. See stacked text
styles. See text styles
thickened. See thickened text
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types.....698
wide (multiline text), format code.....

753
width. See text width

text alignment
vertical alignment format

codes.....753
in multiline text.....705–706
See also text justification

text alignment, in single-line text.....699
text boxes, for leader text.....723
text control codes. See control codes (text)
text editors (multiline text)

alternate.....751–752
creating text.....751
editing text.....751
formatting text.....752
specifying.....751

default.....751
See also Multiline Text Editor

text fields. See fields (in text)
text files.....724–725

importing.....724
inserting.....724–725

text fonts. See fonts
text frames, displaying/plotting.....307
text height.....707, 740, 748, 752

converting between model space and
paper space.....748

multiline text.....707
changing.....707
format codes.....752

setting.....740
text justification, multiline text.....705–

706, 749
text justification. See text alignment
text objects

changing justification without
changing location.....749

grips.....743
modifying.....743

single-line text objects...743–744
moving.....743
scaling.....743, 748
See also attributes (of blocks)

text obliquing angle.....753

setting.....138, 168, 185–186, 753, 
807–808, 848, 854–855, 877–
878, 881–883, 938

format code (multiline text).....
753

text obliquing angle, setting.....741
text orientation, setting.....742
text styles

assigning fonts to.....736
creating.....734
deleting.....734
for dimension text.....797–798
in fields.....726
font styling.....735

overriding.....706
specifying.....701

height in.....740
modifying.....734
for multiline text.....702
naming.....734
obliquing angle in.....741
orientation in.....742
for single-line text.....699
standards. See standards (for named

objects)
standards. See standards, for named

objects
styles not affecting

single-line/multiline text.....
734

in tables.....764
text width.....699, 753

compressing/expanding.....699
wide text (multiline text), format

code.....753
text window.....55–56, 80

closing.....56
copying all text in.....55
copying text to the command line.....

56
displaying.....55
font selection.....80
selecting (highlighting) text in.....55
switching from the command window

to.....55
text, simplified display.....306–307
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TEXTFILL system variable.....735
TEXTTOFRONT command.....308
texture (of materials).....174

displaying.....174
texture maps.....1043
thaw.....1044
thawing layers.....218–221, 1044

in layout viewports.....218–221
in paper space.....221

thickened objects. See extruded objects
thickness.....426–427, 1044

changing.....427
setting.....427

THICKNESS system variable.....427
tick marks.....473, 532

displaying in value sets.....473, 532
tick marks, displayed at location of valid

values for block reference.....550
tilde (~).....745

wild-card character.....745
tilde (~), incorrect word flag.....750
tilde (~), wild-card character.....280
tiled viewports

See also model viewports
tiled viewports. See model viewports
TILEMODE system variable.....1044
time-sensitive right-clicking behavior.....

45, 47
turning on.....47

title rows in tables.....764
title sheets.....244, 250

creating sheet list tables on.....250
tolerance.....416, 650–651

of splines.....416, 650–651
tolerance symbol (±).....803

entering.....803
tool flyouts.....22, 25–26, 35

adding/removing.....25
customizing.....26
restoring default settings.....35
using tools on.....25

tool palette files.....42
default path.....42
file name extension.....42
lock icon.....42

tool palette groups.....38–42

adding tool palettes to.....39
copying tool palettes between.....41
creating.....38

within other groups.....41
deleting.....39–40
displaying.....39
rearranging.....40
rearranging tool palettes in.....41
removing tool palettes from.....39
renaming.....40
saving.....42

tool palette tabs, moving.....37
tool palette tools.....22–24, 26–37

command tools.....28
creating command tools.....28
creating from objects.....22–23, 35
icon display style.....30–31
icon updates.....32
images, changing.....34
modifying.....36
properties.....31–33, 112, 216, 250–

251, 379, 398, 767
changing.....31, 33
displaying.....33
overrides.....32

rearranging.....37
refreshing the image of block tools....

34
using command tools.....29
using tools created from

blocks/xrefs/raster images.....
27

using tools created from
dimensions.....24

using tools created from gradient
fills.....26

using tools created from hatches....26
using tools created from objects.....24

tool palettes.....22–23, 28, 35, 37–39, 41–
42, 68, 458, 465, 676

adding drawings from.....68
adding items to.....68
adding to tool palette groups.....39
adding tools to.....22–23, 35
command tools.....28
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copying between tool palette
groups.....41

creating.....35, 37
with DesignCenter content.....68

deleting.....37
displaying all.....41
dragging hatch patterns from.....676
exporting.....42
importing.....42
inserting blocks with.....458
lock icon.....37
opening blocks from.....465
organizing.....38
organizing blocks with.....458
rearranging.....37, 40–41, 209

in tool palette groups.....41
removing from tool palette groups.....

39
saving.....37, 42
tabs, moving.....37
tools. See tool palette tools
use in product versions other than the

one created in.....42
See also Tool Palettes window

Tool Palettes window.....22–23, 29–31
displaying.....23
settings.....29

icon display style.....30–31
rollover behavior.....29–30
transparency.....30–31

Tool Properties dialog box.....676
hatch pattern options.....676

toolbars.....43–44, 49, 63, 81, 83, 88, 463, 
978–979, 1044

Block Editor toolbar.....463
closing.....44
DesignCenter toolbar.....63
displaying.....43, 81
docking.....43
in workspaces.....88
locking/unlocking.....81, 83
Refedit toolbar.....978–979
resizing.....44, 81
undocking.....44, 81
for workspaces.....49
See also Layers toolbar

See also Properties toolbar
tools, on tool palettes. See tool palette tools
tools, precision drawing tools.....312
TOOLTIPMERGE system variable.....82
tooltips....82, 335–336, 338–339, 341, 344

appearance.....82
AutoSnap.....344
coloring.....339
coordinate display in.....336
dimensional input.....336
displaying prompts in.....341
in Dynamic Input.....335
dynamic prompts, choosing options

for.....339
entering coordinate values in.....338
resizing.....339
specifying points in.....336
transparency control.....339
turning on/off.....82
See also dimension input tooltips
See also dynamic prompts (tooltips)
See also pointer input tooltips

TOOLTIPS system variable.....82
tori.....433

creating.....433
torus/tori (solid).....440, 445

creating.....440, 445
tracking

points on objects. See object snap
tracking

polar. See polar tracking
tracking points on objects.....356–357
transmitting sheet sets (over the

Internet).....253
transparency.....30–31, 58, 81, 174, 339, 

702
command window.....58
In-Place Text Editor.....702
of materials.....174
multiline text objects.....702
Tool Palettes window.....30–31
tooltips.....339
windows.....81

transparent command character
(apostrophe).....53
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transparent command prompt indicator..
53

transparent commands.....53, 1044
commands that can be used as.....53

tree view (DesignCenter).....62, 64–65
displaying.....64
level display buttons.....65

tree view (Layer Properties Manager).....
272, 278

hiding.....272
tree view (Sheet Set Manager), click and

drag actions.....236
TRIM command.....615, 618
trimming

chamfered objects.....631
filleted objects.....626
hatches.....685, 694
objects

in 3D.....618, 620
chamfering without.....633
while extending.....617
filleting without.....628
See also chamfering

spline-fit polylines.....618
wide polylines.....617

True Color colors.....287, 289–291
changing.....275–276, 290–291, 297–

300, 305–306, 334–335, 569–
570, 779

layer colors.....290
object colors.....291

setting (for new objects).....289
True Color values, for plot styles.....903
TrueType fonts...702, 708, 735–736, 738, 

740
appearance.....735
assigning to text styles.....736
bullet character.....708
PostScript font equivalents.....738
as SHX proxy fonts.....735
SHX proxy fonts.....738
text height values.....740
Unicode character support.....702

truncating numbers (in QuickCalc).....373
turned off layers.....270
two-color gradient fills.....690

creating.....690
typefaces. See fonts

U

U command.....590
UCS.....1044
UCS command.....463

in the Block Editor.....463
UCS icon.....178, 333–335, 1044

2D UCS icon.....333
3D UCS icon.....178, 333–334
broken pencil icon.....334
changing.....275–276, 290–291, 297–

300, 305–306, 334–335, 569–
570, 779

appearance of.....334–335
cross in.....333
displaying, at the origin.....333, 335
shaded UCS icon.....333
styles.....333

switching between.....334
turning on/off.....335

UCS icons.....463
Block Editor drawing area icon.....463

UCS origin.....323, 333, 335
defining.....323
displaying the UCS icon at...333, 335

UCSICON command.....333–334
UCSs (user coordinate systems)

2D operations.....323
3D operations.....326
aligning with the WCS.....327
assigning to viewports.....331–332
defining.....323, 329

in 3D space.....328
deleting.....325
drawing planes for.....326

specifying.....326
elevation in.....329
moving.....323
in multiple viewports.....326, 328
origin. See UCS origin
paper space limitations on.....329
preset systems.....329

selecting.....330
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relocating.....323
in 3D space.....326

renaming.....325
restoring.....105, 107, 130–131, 161–

162, 192, 194, 254, 284–285, 
323–325, 329, 331, 592–593, 
694, 824

named UCSs.....325, 329
previous UCSs.....323–324, 331
to the WCS.....324

rotating.....167, 185, 228, 323, 347, 
349, 599–602, 638, 640, 662, 
827–828

views with.....228
saving.....324, 329
uses.....328

UCSVP system variable.....326, 328, 331–
332

unbounded hatches.....685
creating.....685

underlining multiline text.....707, 752
format codes.....752

UNDO command.....590
command line options.....590

undocking.....44, 57–58, 63
the command window.....57–58
command window.....57–58
DesignCenter.....63
toolbars.....44

undocking toolbars.....81
undoing.....275, 590–591

canceling commands.....591
changes to layer settings.....275
erasings.....590
redoing undoings.....590–591

undoing actions.....53, 591
canceling commands.....53
redoing undoings.....591

undoing, in-place reference editing
changes.....981

UNION command.....422, 442
units of measurement.....312, 376, 381

converting.....381
coordinate unit types.....312
QuickCalc display and handling

rules.....376

unloading.....295, 992–993
linetypes.....295
xrefs.....992–993

unlocking layers.....579
Unmatched row (Property Lookup Table

dialog box).....521
unnamed groups.....587
unreferenced layers.....274

purging.....274
unreferenced layers, purging.....150
unstacking text.....719
UP ARROW key, displaying recent input

in dynamic prompts.....337
updating.....68, 71, 159–160, 555, 562–

564, 567, 731, 779, 964, 969–
970, 998, 1001

of the Aerial View window image.....
159–160

associative dimensions.....779
attribute extraction table.....555

turn off notification for.....555
block attributes.....564
block definitions.....68, 71, 562–563
block references.....564, 567
fields.....731
linked objects (drawings).....998
links (OLE).....1001
multiple fields.....731
of viewports, in the Aerial View

window.....160
xrefs.....964, 969–970

updating, the display.....307
upgrading the program.....2
user coordinate systems (UCSs)

See also UCSs (user coordinate
systems)

V

validating 3D solids.....670
Value Set properties.....529
value sets.....473, 533–535, 1045
value sets (for parameters).....470, 473, 

476, 532–535
specifying.....532

deleting values from.....534
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for linear parameters.....533, 535
for polar parameters.....533, 535
for rotation parameters.....534–

535
for XY parameters.....533, 535

tick mark display.....473, 532
values (in QuickCalc).....369

memory functions. See QuickCalc
memory.....369

changing the font color in the History
area.....378

copying from the History area.....378
copying from the Input box.....377
displaying absolute values.....372
displaying coordinate values.....379
pasting to the command line.....377
rounding numbers.....372
truncating numbers.....373

values of parameters. See parameter values
variable attributes.....551

inserting blocks with.....551
vector graphics.....953

resolution.....885, 953–954, 1042
in DWF6 files.....953

vectors.....1045
vertex.....1045
vertical bar (|) (pipe character).....973

dependent named object name
divider.....973

vertical dimensions
creating.....810
extension line origins.....809
See also dimensions

vertical text.....742
setting.....742

vertices.....648, 653, 655, 1045
of multilines.....653, 655
of polylines.....648

view box (Aerial View window).....158
view categories.....1045
view list (Sheet Set Manager).....242

creating categories in.....242
removing categories from.....242

View List tab (Sheet Set Manager).....235
View Plot Area option (Page Setup dialog

box).....851–852, 876

view scale (in layout viewports).....216
changing.....216

view scale lists.....216
modifying.....216

View Support Requests option,
Subscription Center.....13

view transitions.....82, 84
appearance.....82

changing.....84
view windows.....155, 157

zooming to.....155, 157
viewing.....170, 173, 920, 922, 940, 948, 

950
3D DWF files.....948, 950
drawings....37, 64, 68, 70, 77, 80, 85, 

101–107, 116–118, 120–124, 
129–131, 136, 138–140, 143, 
146, 160, 173, 198–199, 204, 
243, 246–247, 273, 304, 453, 
457, 594–595, 676, 854–855, 
860–861, 880–883, 891–892, 
911–912, 964–967, 973–976, 
993–995, 998, 1001–1003, 
1030, 1039, 1046

in 3D.....173
DWF files.....920

in Autodesk DWF viewer.....940
published electronic drawing sets.....

940
published job details.....922

viewing commands.....217
scale locking and.....217

viewpoint coordinate.....168
defining 3D views with.....168

viewpoints (in 3D space)....166–167, 1045
defining 3D views from.....167

viewport arrangements (configurations)...
163, 191, 193–194, 215

default options.....191
deleting.....194
listing.....163, 194
naming.....194
placing into layouts.....215
restoring.....194
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saving.....37, 42, 80, 87–88, 91, 121–
124, 130, 138, 161–162, 193–
194, 229, 231, 254, 259, 284, 
324, 329, 402, 541, 581, 766, 
772, 940, 993–995

settings saved.....193
viewport configurations.....1045
viewports

arrangements. See viewport
configurations

assigning UCSs to.....331–332
irregular. See nonrectangular

viewports
layout. See layout viewports
Model tab. See model viewports
multiple. See multiple viewports
updating of, in the Aerial View

window.....160
views.....82, 84–85, 117, 153–154, 160–

162, 166, 168–169, 211, 216–217, 
225, 228, 1005, 1045

Aerial View. See Aerial View window
aligning, in layout viewports.....225
changing.....153, 160
defining with VPOINT.....168–169

AEC convention.....168
mechanical design convention....

169
displaying a view on startup.....85
in 3D. See 3D views
linking, to other application

documents.....1005
magnifying. See zooming
modifying.....36, 211, 213, 216, 243, 

255, 438, 538–539, 561–565, 
568, 570, 596, 647, 649, 653, 
655–656, 659, 666, 691, 693–
695, 702, 734, 743–744, 746, 
759, 784, 786, 816, 824, 827, 
830–832, 845, 851, 865, 880, 
924, 928, 930, 933, 976–977, 
987

in layout viewports.....211, 216
multiple. See multiple viewports
named. See named views
naming.....162

panning.....154
panning. See panning
in paper space.....166
plan views. See plan views
restoring.....105, 107, 130–131, 161–

162, 192, 194, 254, 284–285, 
323–325, 329, 331, 592–593, 
694, 824

named views.....161–162
previous.....161
previous views.....161

rotating.....167, 185, 228, 323, 347, 
349, 599–602, 638, 640, 662, 
827–828

in layout viewports.....228
saving.....37, 42, 80, 87–88, 91, 121–

124, 130, 138, 161–162, 193–
194, 229, 231, 254, 259, 284, 
324, 329, 402, 541, 581, 766, 
772, 940, 993–995

settings saved.....161
scaling....23, 107, 198–201, 216–217, 

224–225, 299, 531, 622–623, 
638, 640, 743, 747–748, 758, 
761, 854–855, 881–883, 907, 
909

in layout viewports.....216–217
sectored views.....117
transitions settings.....82

changing.....84
zooming. See zooming

virtual pens.....906–907
specifying pen numbers.....907

virtual screen display.....1045
visibility.....211, 218, 270

of dynamic block geometry. See
invisible objects (in dynamic
blocks)

of dynamic block geometry. See
visibility parameters

of dynamic block geometry. See
visibility states (for dynamic
block geometry)

of layers.....211, 270
in layouts.....211, 270

of objects.....218, 270, 308–309
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in layout viewports.....218
layer control.....270

visibility mode.....1046
visibility parameters...470, 474, 476, 486, 

508, 514
actions supported by.....474, 476
adding to dynamic block

definitions.....486, 514
grip type.....474
sets.....508
specifying.....470

Visibility Set parameter set.....508
visibility state.....1046
visibility states (for dynamic block

geometry)
changing the list order.....520
creating.....514

with all objects hidden.....517
with all objects showing.....517
current state based.....517

default state.....520
setting.....520

deleting.....518
and drawing geometry.....461
enabling.....516
making current.....518
making objects invisible in...519–520
making objects visible in.....519
renaming.....518
showing/hiding geometry for.....514, 

520
See also visibility parameters

visibility, of layers, in xrefs.....965
VISRETAIN system variable.....965
visual aids (in 3D Orbit view).....177, 184

displaying.....184
visual complexity, reducing.....269
volumetric shadows.....1046
VPOINT command.....168–169

defining views with.....169
mechanical design convention....

169
defining views with (AEC

convention).....168
VPORTS command.....193
VTOPTIONS command.....82, 84

controlling appearance of transitions
between views.....84

and transitions between views.....82

W

WBLOCK command....121, 123, 457, 562
saving block definitions.....121, 123
saving selected objects.....121, 123

WCS.....1046
WCS (world coordinate system).....323–

324, 327, 401
aligning the UCS with.....327
axes.....323
entering coordinates relative to....327
mapping coordinate systems on paper

to.....401
restoring the UCS to.....324

Web.....7
natural language queries.....7
See also Internet

Web. See Internet
websites, Autodesk website.....10
WEDGE command.....441
wedges.....433

creating.....433
wedges (solid).....441, 445

creating.....441, 445
wheel mouse.....94–95

panning with.....95
joystick panning.....95

zoom factor.....94
zooming with.....94

wide polylines....302, 306–307, 392, 394, 
409–411, 617, 649, 688, 694

creating.....688
drawing.....392, 394, 409, 411
lineweight display.....302
modifying.....694
simplified display.....306–307
tapering.....688
tapering segments.....392, 410, 649
trimming and extending.....617

wide text (multiline text), format code.....
753

width.....759, 761
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of columns in tables.....759, 761
wild-card characters.....279–281, 745

filtering layers by name using.....279
finding text using.....745
naming objects using.....281
sorting layers by name using.....280

Window Plot Area option (Page Setup
dialog box).....851–852, 876

window polygon selections.....576, 578
window selection.....1046
window selections.....575
windows.....80–83, 575, 759

application window.....80, 82
docking.....81
font selection.....80, 83
inserting tables in.....759
locking.....81, 83
resizing.....81
rolling up/down.....81
selection windows.....575
transparency control.....81
See alsoapplication window

Windows Clipboard. See Clipboard
(Windows)

Windows Explorer.....112, 116, 724–725
and drawing properties.....112
inserting text/RTF files from.....724–

725
opening drawings in.....116

Windows metafiles. See WMF files
Windows taskbar.....120

displaying drawings on.....120
wipeout objects.....696, 1046

creating.....696
frames, turning on/off.....696
plotting.....696

wireframe.....425, 428
modeling.....425, 428

Wireframe mode (3D Orbit view).....182
wireframe model.....1046
wireframes..182, 425, 427–429, 438, 619–

620
creating.....425, 428–429
displaying 3D objects as.....182
extending objects in.....619
surface meshes as.....429

tessellation lines in.....438
trimming objects in.....620
uses.....427

wireframes, creating.....884
witness lines. See extension lines
wizards.....104

setup wizards.....104
starting drawings with.....104

WMF files.....594–595
converting to drawing file format.....

595
format.....594

WMFBKGND system variable.....595
WMFFOREGND system variable.....595
words

adding/deleting to/from
dictionaries.....749–751

formatting. See character formatting
selecting.....703

words, selecting.....707
working set.....1046
working sets (of reference objects)....977, 

979–980
adding objects to.....979–980
fading of objects not in.....977
removing objects from.....979–980

workspaces.....49, 88–91, 1046
changing settings.....90
creating.....89
customizing.....49
profiles and.....89
saving.....91
selecting a sample.....90
switching.....90

world coordinate system (WCS)
See also WCS (world coordinate

system)
world coordinates.....1047
World Wide Web. See Internet
WPolygons (window polygon

selections).....576, 578
wireframe modeling. See wireframes

X

X axis.....323
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WCS.....323
X,Y,Z point filters.....1014
XATTACH command.....965
XCLIPFRAME system variable.....966, 971
XFADECTL system variable.....977
xlines. See construction lines
XLOADCTL system variable.....992, 995
XLOADPATH system variable.....995
XML reports

See also batch audit reports
xref.....1047
XREF command.....965, 969

command line options.....969
xref copies (for demand loading).....994–

996
creating.....994–995
setting paths for.....995–996

Xref icon.....965
exclamation point.....965

xref log files.....992
turning on/off.....992

Xref Manager, displaying.....965
xref paths....968, 983–985, 987, 989, 995–

996
absolute paths.....983
changing.....989
no path option.....985
no path search order.....984
relative paths.....983
specifying (changing)...983, 985, 987

defining with project names.....
985

type options.....983
for temporary xref copies.....995–996

xref tools.....22
prompt for rotation angle.....22

xref-dependent layers.....118
as displayed in partially open

drawings.....118
xrefs (external references).....963
xrefs. See external references (xrefs)
XTP file name extension.....42
XY Array Box Set parameter set.....508
XY Move Box Set parameter set.....508
XY Move parameter set.....508

XY parameters....474, 476, 482, 508, 529, 
533, 535–536, 538

actions supported by.....474, 476
adding to dynamic block

definitions.....482
Chain Actions property.....476, 529, 

536
specifying.....538

grip type.....474
incremental values.....535

specifying.....535
minimum and maximum values.....

536
specifying.....536

sets.....508
value sets.....473, 533–535, 1045

specifying.....533, 535
XY plane (construction plane)

shifting.....330
views of. See plan views

XY Stretch Box Set parameter set.....508

Y

Y axis.....323
WCS.....323

yellow alert icons.....540
correcting errors indicated by.....540

Z

Z axis.....323
in the WCS.....323

Z values (3D coordinates), default
values.....319

zero suppression.....802, 805–806
in dimension values for lateral

tolerances.....802, 805–806
zoom.....1047
ZOOM command.....154–155

command line options.....155
zoom factor.....94, 304

and lineweight display.....304
wheel mouse.....94

Zoom Original command.....162
Zoom Previous command.....161
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zoom windows, using in 3D Orbit view....
181

ZOOMFACTOR system variable.....94
zooming.....84, 94, 154–160, 181, 1047

in 3D Orbit view.....181
with Aerial View.....158–160
by dragging.....156
to the drawing extents....94, 156–157
to the drawing limits.....156–157

dynamic (Realtime option).....155
to the drawing extents.....181
using zoom windows.....181

to previous views.....155, 157
to rectangular areas (view

windows).....155, 157
in 3D Orbit view.....181

turning on animation for.....84
with a wheel mouse.....94
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