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CHAPTER 2
BASIC FEATURE CREATION AND MODEL

MANIPULATION

Chapter Objective:

• To teach students basic feature creation techniques.

• To teach students the importance of model
structure.

• To teach students to manipulate and save model
views. 
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Figure 3 Main Window

Figure 4 Header bar 

Figure 5 Menu Bar

The Pro/E Interface

The Main Window

Pro/E uses a graphical user interface that combines menus, toolbars, and windows to provide an
efficient working environment.  The active model appears in the graphics area of the main
window (Fig 1).
  

The header bar at the top of this window displays the model type and name, and indicates that
the model is active.  (Active models display ***** before and after the model name.)

The figure shows the header bar for a Pro/E part model named bracket2.  The stars indicate that
this window is active.

The menu bar, containing non-model specific menus, lies just below the header bar. 
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Figure 6 Toolbar

Following is a brief description of the menu bar options.  Most of these menus are treated
extensively in later chapters.

File File commands, such as set working directory, save, open, create new
object, erase from RAM, delete either old versions or all versions of a file. 

Note 1:  When Pro/E saves a file, it does not overwrite the previously
saved version, but creates a new file with an incremented version number,
such as frame.prt.4 .  Old versions of model files must be deleted, or
purged, periodically to prevent excessive numbers of files on disk.

Note 2: When a window is closed (see window menu), the model remains
in memory.  To remove it from memory, use the erase command (be sure
to save the file first!)

Info Access model information commands, such as bills of material, model or
feature information, parent-child relations, etc.

View Access image viewing commands such as repaint screen, shade image,
model orientation, model colors and lights.

Utilities Set environmental variables, modify configuration options, set system
colors, etc.

Applications Select other applications, such a Pro/MECHANICA, Pro/SHEETMETAL,
or Pro/NCPOST.

Analysis Analyze the model and obtain measurements such as distance between
entities, lengths and areas; curvature, etc. 

Window Activate, close or select a window.  (Note that Pro/E can have multiple
windows open at any time, but only one will be active.  In order to work on
a model, its window must be activated from this menu.)

Help Activate on-line help, either general or context-sensitive.

A toolbar, with icons for frequently-used commands, follows the menu bar.  It contains icons of
frequently used commands, such as create new object, save model, open model, repaint screen,
orient model, and blank datums, axes, points or coordinate systems.  The toolbar is easily
customized to contain icons for most Pro/E commands.
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Figure 7 Model Tree

Figure 8 Application Manager

The main graphics area contains the Pro/E model, and is where most of the modeling work
occurs. A message area is located just above the graphics area.  Important information and
prompts are provided in this area.       

� Important:  Always check the message area to avoid missing important information.

A one-line help area appears on the bottom line of the window.  When the cursor is placed over
a menu item or icon, a succinct description of the command is provided here.

When a model is opened or created, additional menus appear that are specific to the type of
model.  These menus will be discussed in the exercises.  Most menus have multiple levels, which
usually remain open as you move down the menu tree.

Model Tree

An additional window, called the Model Tree (Fig 2),  also opens when a
model is activated or created.   The model tree displays the hierarchy of
the model.  For part models, features are listed in order, along with an
icon indicating the feature class (solid feature, datum feature, or surface.) 
(By default, only components are shown for assembly models, although
assembly and part features can be easily shown on the tree.)  Additional
columns can be added for more information.  For example, it is often
useful to see feature IDs.  The model tree is a "roadmap" for your model. 
Good designers quickly learn to use the model tree frequently and
effectively.  

Usually, model features can be selected from either the model tree or the model itself.  Also, if
the highlight option is activated (it is by default), the model feature is highlighted when the
cursor is placed over a feature on the model tree.  This is very useful for identification of features
in complex models.

When Pro/E is started, an additional window may appear at the top of the screen.  This window is
called the application manager, and is used to navigate between various applications and
windows.   It contains a button for each open window.  To pop a window to the foreground,
simply click on its button.  When ending your work session, first exit Pro/E, then exit the
application manager. 
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Mouse View Control

Zoom Press Ctrl  and the left mouse key while dragging right or left.  

For a window zoom, press Ctrl  and left click  the mouse on opposite
corners of the zoom box.

Spin Press Ctrl  and center mouse key while dragging.

Pan Press Ctrl  and right mouse key while dragging

Pro/E model views can be manipulated with the mouse easier than from the view menu. Mouse
view control -- zoom, spin, and pan -- is accomplished by pressing the control key while
simultaneously pressing one of the mouse keys and dragging.  
   

Good Design Practice

Design Intent

To effectively use Pro/E as a design tool, designers must not only know and understand the
software functionality, they must also know how to build models that behave as desired during
modifications or downstream applications.  This is known as capturing design intent, and is
extremely important for reducing design cycle time.  Unlike many CAD programs, Pro/E requires
the designer to think beyond basic geometry.  Most parts designed in Pro/E will be modified,
sometimes drastically.  Most will also be used with other applications, such as
Pro/MECHANICA, NC machining, mold design, injection molding simulation,
stereolithography, etc.  If the part model is poorly constructed, modifications will be difficult,
perhaps requiring that the part be completely remodeled.  Also, much time may be required to
repair or remodel the part prior to using any of the downstream applications.  Some of the prime
benefits of the Pro/E package can be nullified by poor modeling.  

Throughout this book, emphasis is placed on capturing design intent.   Examples and tutorials
show good modeling practice and illustrate how the design intent is realized.  Emphasis is placed
on understanding the model and what it will be used for prior to modeling.  The importance of
model structure, especially parent-child relationships, is treated extensively.  The Pro/E student
should strive not just to understand how to obtain desired geometry, but how to obtain the
desired geometry with a robust model.  

Good practice starts at the feature creation level, where parameters and parent-child relationships
are defined.  The structure of the model -- as reflected in the model tree -- is the second tier in
developing good models.  Building robust assemblies is the third tier.  Attention, planning, and
foresight will ensure that good design practice is obtained at all three levels.
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Figure 9 Default Datum
Planes

Model Structure

Understanding how to structure a model is the first step to good design practice.  Pro/E models
are hierarchical.  Each feature (except the base feature) references earlier features in the model. 
When the model is changed in any way, features regenerate in sequence.  If the model has
changed in such a way as to delete the references for a feature, the regeneration process will fail
when it gets to that feature.  (What to do then is covered in Chapter 6.)  Thus it is very important
to understand the relationships between model features.  These are known as parent-child
relationships.  

Pro/E models are also parametric. Model geometry is defined by a set of parameters.  The two
most common ways to define parameters are dimensions and alignments.  When a dimension is
defined, it becomes a parameter of the model.  It is important to consider this when creating
geometry, as the model parameters define how the model will behave when modified. 
Alignments indicate that new geometry should be aligned with existing features (essentially a
dimension that always has a value of zero.) 

Every Pro/E model should start with default datum planes. 
These are three orthogonal datum planes that provide references,
either directly or indirectly, for all subsequent features in the
model.  Recall that datum planes are infinite planes and have both
a red and a yellow side.  Datum planes provide excellent
references for other features, and frequently models will contain
many of them.  However, the default datum planes are special, in
that they provide a three-dimensional anchor for the entire model.  

The first feature in any model should be default datum planes.

Thought should be given to the order of subsequent features. 
Sometimes the order is obvious:  to model a cylindrical shaft with
a keyway, create a cylindrical protrusion followed by a cut.  Other times careful thought is
required to ensure a robust model results.  In addition, there are usually many different ways to
obtain a particular geometry.  Learn as many of these methods as possible, then select the ones
that will best capture the design intent.  

As features are added, parent-child relationships are created.  For example, when a hole is placed
in a flat plate, three references are required:  the surface on which the hole is placed and two
edges or surfaces used to define the location of the hole on the placement surface.  All three
references could be to a single feature -- the flat plate, or they could be to different features, say
the flat plate, a datum plane and the surface of a cut in the plate.  In the former case, the hole
would have only one parent.  In the latter case, the hole would have three parents.  It is usually
good to minimize the number of parent-child relationships in the model.  Thus the first method is
usually, but not always, the best.  It is always important to know what you are using for
references during feature creation.  
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In short, a Pro/E model is comprised of an ordered set of features held together in a web of
dimensions, alignments, and references.  The web defines the parent-child relationships between
features.  

Data Base Management

Although model structure is the most important aspect of good design practice, data base
management is also important.  The File menu contains most of the commands needed.  Selected
commands are discussed here, along with some tips for good file management.

New Creates a new model.  A dialog box opens with the type of model (part is the
default) and the name of the new model (Fig 3).  Select the model type by
clicking on the appropriate button, and enter the new name.  Note that only the
base name should be provided -- Pro/E will append the correct extension based
on the type of file (For example, if the model is a part and bracket is entered,
the actual file name is bracket.prt.1.)   There is also a button called copy from. 
This loads an existing model into the new model (without affecting the old
model.)  It is very useful if the new part is similar to an existing part.  The
tutorials show how this feature is used to expedite model creation for all
models.

Open Opens an existing model.  A dialog box appears showing file names of objects
in the current working directory.  Click on the desired file and click the open
button.  Note that the Type box permits files to be filtered by type, such as
part, assembly, manufacturing, etc.  Icons provide shortcuts to navigate
through directories.  

Working
Directory

Sets the working directory.  The working directory is the directory that Pro/E
uses to look for files or to write new files (unless otherwise specified.)   At the
start of each work session, set the working directory to ensure the files are read
and written correctly.

Erase Erases models from memory.  When a window is closed, the model remains in
memory, or In Session.  To clear memory, use the erase function.  Two
options are available: Current  or Not Displayed.   Current will erase the
model in the active window from memory.  Not Displayed brings up a dialog
box of all items in memory that are not displayed on the screen -- select all or
some for erasure.  Note that files are NOT saved prior to erasing from
memory.

Delete Deletes files from the hard drive.  The two options are to delete All Versions
or delete Old Versions.  The latter purges all versions of the file except the
most recent.  
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Save Save the current model to the hard drive.  Note that you are prompted for the
object to save, which must exist in session (in memory.)  The current model is
the default.  

Other options include Save As (save model as a different object), Backup (save to a different
directory), and Rename (change the name of the model.)  

Pro/E Customization

There are many ways in which Pro/E can be customized.  While some of these methods should
only be attempted by advanced users, many others are both important enough and simple enough
for the novice Pro/E user to use.  The most important is the configuration file, typically called
config.pro.  This file should reside in the same directory from which Pro/E is started (the home
directory.)  It is an ASCII text file that contains configuration commands.  When Pro/E is started,
it looks for this file, and automatically executes all the commands.  This configures Pro/E for an
individual designer.  The config.pro file can be modified during a session, but must be loaded

Tips for good data management...

1. Create a new directory for each new project, with subdirectories as needed. 
Pro/E can generate a large number of files and good project organization is
imperative.

2. Create subdirectories for each Mechanica analysis and each manufacturing
model.   

3. Purge old versions frequently to prevent using excessive disk space.  One
approach is to always purge prior to saving -- then you will always have
just one backup version.  (Clearly, do not delete old versions if they are
needed for archives.) 

4. Typing "purge" from a system window will delete old versions of all files
in the directory.  

5. Remember that closing a window removes the model from the screen, but
does not erase it from memory or save it.  To clear memory, use the Erase
command.  

6. Always start Pro/E from the home directory, then use the working directory
command to change to the desired directory.  
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before changes take effect.  The Edit Config and Load Config commands accomplish this (they
are found under Preferences on the Utilities menu.) 

It is also quite simple to customize the toolbar.   While the default toolbar is usually fine for
beginners, experienced Pro/E users may find that some additional commands are used very often. 
It is convenient to place these commands as icons on the toolbar.  In fact, several different
toolbars can be created, each with its own set of commands.  To modify the toolbar, position the
cursor on the toolbar and press the right mouse button.  

Pro/Help

This manual provides an introduction to Pro/E and is designed to get the student productive as
rapidly as possible.  However, no tutorial or lab manual can include all the details of the many
Pro/E commands.  Students should form the habit of using the on-line help to obtain more
information.  On-line help, available through a web browser,  is accessed in several ways.  To
obtain access to all on-line manuals, use the Pro/HELP  command on the Help menu.  This
method permits browsing through any help manual desired.  To obtain context-sensitive  help on
a particular topic,  use the What's This command on the Help menu.  The cursor becomes a
question mark.  Select a command from any menu, and the help screen for that topic appears. 
Alternately, position the cursor over any command and press the right mouse button to bring up
context-sensitive help.  

Develop the habit of using on-line help on a regular basis.  This helps beginners master Pro/E
much more quickly.  

Basic Feature Creation

A sound understanding of feature creation is crucial for effective modeling in Pro/E.  Frequently
several feature types can be used to create the desired geometry.  The designer must choose the
types that best capture his or her design intent.  Then he or she must know the steps required to
create each feature.  

This section presents an overview of four of the most fundamental solid features -- protrusions,
cuts, slots, and holes.  (Solid features either add or remove solid "chunks" of material to the
model.)  The intent is to familiarize the student with the nature of each type of feature so that
appropriate choices can be made regarding which to use for a particular task.  The lab exercises
demonstrate implementation steps for each feature.  Subsequent sections address additional
feature types, and are accompanied by appropriate lab exercises.  A separate section describes
sketcher. 

� Hint: Use context-sensitive online help to learn more details about each of the
following features.
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Protrusions

A protrusion  adds solid material to the model.  Most protrusions are sketched features, meaning
that 2D geometry is first created using sketcher, and then swept through space in such a way as to
create a solid. There are several types of protrusions, depending on how the sketch is moved to
form the solid.  A brief description of the protrusion menu picks:

Extrude The 2D sketch is moved in a straight line perpendicular to the sketch
plane.  The resulting solid is prismatic. 

 Revolve The 2D sketch is rotated about an axis, through any desired angle.  If the
angle is 360�, the resulting solid is axisymmetric

Sweep The 2D sketch is moved along a 3D path called a trajectory.  The resulting
solid may be complex, but will always have a constant cross-section.

Blend
Several 2D sketches are used, located on parallel planes separated by
distances prescribed by the user.  The resulting solid changes cross-
sectional shape as it goes from one sketch to the next.  The cross sections
may have any shape, but must be comprised of the same number of
segments.  The resulting geometry is often complex.

From Quilt The solid is generated from a surface quilt (several connected surfaces.) 
This type of protrusion is not sketched, and will be discussed in Chapter
12.

Advanced Several advanced methods of creating protrusions are also available, such
as the Variable Section Sweep and the Swept Blend.  These features are
quite powerful, but somewhat more complex than the basic protrusions. 
Some of these will be treated in later chapters. 

 

Cuts

A cut removes solid material from the model.  This menu option is only available if the model
contains solid geometry.  Cuts are created exactly like protrusions, except that where the
protrusion adds material, the cut removes material.  The menu options are identical to those for
protrusions -- Extrude, Revolve, Sweep, Blend, From Quilt , and Advanced.  Like protrusions,
most cuts are sketched features.  Once the section has been sketched, Pro/E prompts the user for
the which side of the section (sketch) should be removed.  
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Holes

Holes are pick-and-place features, meaning that they are not sketched.  A hole always removes
material from the model, and always has a circular cross section.  To create a hole, Pro/E only
needs to know on what surface the hole is to be placed, the location of the center of the hole on
the surface, the hole diameter, and the depth of the hole.  Prompts are provided for all these
items. 

There are two types of holes: Straight and Sketched.   A straight hole is always cylindrical in
shape.  A sketched hole is similar to a 360� revolved cut in that the axial cross section can be
sketched.  Counterbores, countersinks, tapered holes, etc. can be created more easily with the
sketched hole feature than with a revolved cut.  

Sketcher and Intent Manager

Sketcher, along with an enhancement called Intent Manager, is used for creating most Pro/E
features.  It is a powerful tool for generating 2D sections, which  are subsequently used to
generate 3D geometry.  Sections are the resulting 2D entities which are produced by sketcher. 
Typically, sketcher is invoked within a feature creation sequence, such as a protrusion, cut, or
slot.  (It can also be used independently to create and save sections for later use, but that
functionality is not discussed here.)  Mastery of sketcher is essential for efficient and effective
use of Pro/E.  Fortunately, it is easy and intuitive – and smart.  This section provides a brief
overview of sketcher.  Chapter 5 describes sketcher assumptions and use in much greater detail.

Sections are created by sketching a rough approximation of the desired geometry.  Dimensions,
alignments, and sketcher assumptions refine the sketch.  The values of each dimension can then
be modified to obtain the exact desired geometry.  

Sketcher automatically makes assumptions as the sketch is created.  The Intent Manager
automatically places “weak” dimensions and alignments.  If a user understands how sketcher and
intent manager work, he or she can usually ensure that most of the automatic dimensions,
alignments, and assumptions are correct.  (Those that are not correct can easily be changed,
however.)  This is the key to using sketcher effectively.

In order to create solid geometry, a section must be located with respect to the part.   This is done
by first defining a sketching plane, then by aligning or dimensioning the section to the part.  The
sketch plane is defined prior to entering sketcher mode.  It can be either a datum plane or a flat
surface.  The section is sketched on this plane.  A point or an edge of a sketch can be forced to
always lie directly on an existing part entity, such as a datum plane, edge, side, or curve.  This is
called alignment, and is one way to locate the section to the part within the sketch plane. 
Alternatively, dimensions can be placed between the sketch an part entities.  In either case,
sufficient alignments and dimensions must be provided to locate the section in both the vertical
and horizontal directions.
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Intent manager automatically creates alignments and dimensions.  However, the user must tell
intent manager what references should be used to do this.  A sketch can not be started until
sufficient references are selected.  Choosing references is important!  Choosing correct references
will ensure that desired alignments and most dimensions are obtained automatically.  This affects
not only the current section, but also parent/child relationships within the model.  Some
guidelines for choosing references:

� Any and all part entities to be aligned to the sketch must be selected.

� Part entities to be used for dimensioning should be selected.

� Choose references to obtain desired parent/child relationships.  For example, choose
references that all belong to one feature to minimize the number of parents.

Sketching can begin once references are defined.  Sketches consist of lines, arcs, circles, points,
and several advanced entities such as splines.  Geometry types are selected either from the
GEOMETRY  menu or from a pop-up menu activated by the right mouse button.  Note that
entities snap to the references.  Also, lines that are nearly vertical or horizontal snap to vertical or
horizontal respectively, and symbols V or H appear.  These are two of the assumptions that
sketcher makes.  (If you want a line at a very small angle from the horizontal, sketch it at a large
angle, and modify the angle value later.)  Other assumptions are described below.  As each
segment of the sketch is completed, dimensions appear in white. 
 

� Note: Do not confuse a dimension (a parameter in the Pro/E model) with its value.  It
is very important to create the correct dimension scheme, but values can be
changed very easily – within sketcher or later, in part mode.   

These are “weak” dimensions, because they were created by the Intent Manager.  Frequently
some of these need to be replaced with more desirable dimensions.  Desirable dimensions can be
strengthened – that is, the user tells Pro/E that these dimensions should not be deleted.  “Strong”
dimensions are shown in yellow.  New dimensions can then be created.  As they are created,
weak dimensions are removed.  User-created dimensions are always “strong.”  If a new
dimension conflicts with an existing strong dimension, Pro/E asks which dimension should be
deleted.

Understanding assumptions is important for effective sketcher use.  Typically, assumptions are
obvious during a sketch because the pointer snap to the appropriate entity and a symbol for the
assumption appears.  Sketcher assumptions are summarized below:
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Assumption Description Sym.

Equal radius Circles or arcs sketched with approximately equal
radii are assumed to have exactly the same radii. 
The radius snaps to the assumed value.

R
(index)

Symmetry Entities approximately symmetric about a sketched
centerline are assumed to be symmetric.  Vertices
snap to symmetric positions.

� 

Horizontal &
vertical lines

Nearly horizontal or vertical lines are assumed to
be so.  Lines snap to horizontal or vertical.

H or V
(index)

Parallel or
Perpendicular
lines

Lines nearly parallel or perpendicular to existing
lines are assumed parallel or perpendicular.  Lines
snap to parallel or perpendicular.

� or �
(index)

Tangency Entities sketched approximately tangent to each
other are assumed tangent.  Entities snap to
tangency.

T
(index)

Equal segment
length

Lines of approximately the same length are
assumed to have the same length.  Line snaps to
length.

L
(index)

Point entities
lying on other
entities

Point entities that lie near other entities (lines, arcs,
circles) are assumed to lie on them.  Point snaps to
entity.  (Note: point entities include end points of
lines and arcs and center points of arcs and circles.)

� 

Equal
coordinates

Center points of arcs and circles with nearly the
same X and Y coordinates are assumed to have the
same coordinates.  Centers snap to X or Y
coordinate.

� or �
(pairs)

Sketcher assumptions can be used very effectively during sketching to quickly obtain the desired
section.  If an assumption needs to be avoided, exaggerate the sketch. For example, place two
circles that should lie near, but not on, the same horizontal line well away from each other.  This
forces sketcher to place a dimension rather than make an assumption.  The value of the
dimension can be modified later to any desired value (even zero, but that is poor practice!)
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After the sketch is complete, the values of the dimensions must be modified, and the sketch
regenerated.  Additions, deletions, and further modification may then take place. 

Some rules of thumb for sketcher:

� Choose references carefully in order to achieve desired alignments, dimensions, and
parent/child relationships.

� Exaggerate the sketch – avoid very small entities and undesirable assumptions.  Use
Modify  to achieve the desired geometry.
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Exercise 2.1 Base

Objective: To introduce students to fundamental feature creation techniques, including extruded
protrusions, slots, and holes.

This exercise involves modeling the base part shown below. The best way to learn Pro/E
software is to dive right in and create a part model.  That is exactly what this exercise involves. 

� Note 1: Prior to starting this lesson, create a new directory called tutorial. (Do this in
a system window.)

� Note 2: Strive to complete the exercise as presented, however, explore the menus and
toolbar to become familiar with their functionality.
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Create
New

1. Change the working directory to the tutorial directory.   Select  File>Working Directory .

Select the tutorial directory to highlight it and select okay.

2. Create a new part named base.  Select the create new object  icon  (blank paper). 
(Or use File>New.)   

Note that the radio button for part is selected by default.  Enter the name base
and  select  OK . 

3. Create default datums.  From the Part menu,  Select
Feature>create>datum>plane>default.  The datums appear.  

4. Create the base feature.  Select  Feature>Create>Protrusion.  

Accept the defaults of Extrude and Solid.  Select Done.  

Accept the default of One Side.  Select Done.  

At the prompt to create a sketching plane pick on DTM3.  (Note: To select a datum plane
pick either on the name tag or the border of the datum plane.)  Accept the default direction by
selecting Okay.  

For the second reference select Top and then pick on DTM2.  

The model now reorients and Pro/E enters sketcher mode.  The first task is to specify
references for the sketch.  DTM2 and DTM3 will be used for references.

Verify that Specify Refs is highlighted and pick DTM1 and DTM2 . 

To create the section geometry, select Sketch (Note: the middle mouse key also selects
Sketch.) 

For this example, it is important to have the plate symmetric about DTM2 and DTM3.  To
ensure this symmetry, create two centerlines,  aligned to  DTM2 and DTM3.  

From the LINE TYPE  menu, select Centerline, accepting the default of 2 Points.  Pick once
on DTM2 to begin the centerline.  Note that this becomes a pivot point for the line.  Drag the
line so that it aligns with DTM2 (a pair of small solid rectangles appear when aligned.) Pick a
second time on DTM2.  The first centerline is created.  Repeat for the second centerline,
using DTM3 as the alignment reference.  
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Figure 12 Sketch of rectangular base feature.

Sketch a rectangle symmetric about the two centerlines.  From the GEOMETRY  menu, select
Rectangle.  Use the grid and pick two diagonal corners of a rectangle symmetric about the two
centerlines.  Note that the rectangle snaps to symmetry.  Also, small arrows at the vertices
indicate the symmetry constraints.  (Do not sketch a square!) 

Dimensions for the width and height of the rectangle appear in white.  These are called weak
dimensions (system-supplied dimensions.)  The values for these dimensions may be quite
large at this point.  We will now modify those dimensions.  

From the SKETCHER  menu, select Modify .   Pick the horizontal dimension and enter a
value of 6.0.  Pick the vertical dimension and enter a value of 4.0.   To update the model to
conform to these new dimensions, it must be regenerated.  

From the SKETCHER  menu, select Regenerate.  The sketch is now complete.  

From the SKETCHER  menu, select Done.  

The depth of the solid rectangle must now be defined.  From the SPEC TO menu, select
Blind>Done.  Enter a value of .25.  

To preview the base select Preview from the extrude dialog box.  Press the control key while
dragging the mouse with the middle mouse key depressed to spin the model  and view it from
different angles.  Select OK from the PROTRUSION:Extrude dialog box.  The protrusion is
now complete.

5. Create a cut in the protrusion.   Select Feature>Create>Cut.  Accept the defaults of
Extrude and Solid. Select Done.  
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Figure 13 Orientation references for sketching the slot feature.

Datum
Planes 

Figure 15 Sketcher references and the first line  

Accept the default of One Side. Select Done.  

At the prompt to create a sketching plane pick on the front side of the base. Ensure that the
arrow points into the base. If so, select Okay.  If not, select Flip  and check that the arrow
flips direction into the base, then select Okay. (The slot feature will begin on the sketching
plane and extend into the direction shown by the arrow.  Clearly, in this case we want the slot
to extent into the part, rather than out into empty space.)

For the second reference select Top and then pick the top side of the part.
 

Turn off datum plane display for clarity. Select the Datum Planes on/off icon
from the toolbar to toggle the display.

Verify that Specify Refs is highlighted and pick the bottom edge of the part and
the right edge of the part.

Select Sketch.  Accept the defaults for Line and Geometry.  To sketch a single line as shown
(do not worry about dimensions yet) use a left pick to start and end the line, and middle pick
to terminate drawing lines.  Note the H symbol, denoting a horizontal line.
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Figure 17 Completed sketch, prior to dimensioning.

Figure 16 Line and arc showing constraint symbols
(Horizontal, Tangent, and 180� arc.)

Select Arc|Tangent End and create the 180� arc by a left pick on the end of the line
followed by a left pick when the sketch indicates 180�.  The arc will snap to 180�.  Note the
T indicating a tangency constraint and the two small solid rectangles representing the 180�

constraint. 

Select Line to sketch a second straight line.  Make sure the second line snaps to the same
length as the first line -- look for the L1 symbol indicating the equal length constraint.  Finish
with a  second tangent arc.  It should complete the loop.
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Figure 18 Completed sketch of cut after modifying
dimensions and regenerating.

Shortcuts �  In sketcher, the middle mouse key toggles between the Line and Arc  menus.

� The right mouse key initiates a pop-up menu with common sketcher
commands.

The default dimension scheme is not what is desired, so create new dimensions to replace the
undesired ones.  Select Dimension|Normal.  Pick the two center marks (center of the arcs),
place the pointer below the part and click the middle mouse key to place the dimension. 
Select Horizontal  and the dimension appears.  

Now select the center mark of the left arc and select the bottom edge of the part (or the
dashed brown line representing the reference.)  Middle mouse pick to the left of the slot to
place the dimension.  The remaining default dimensions are acceptable.  

To move any dimension, select Move and drag to the new position.

Add axis points at the centers of the arcs.  Sketched axis points will become datum axes
when the slot feature is complete.  Select Sketch>Adv Geometry>Axis Point.

Pick the center mark for each slot.  A small x indicated the axis point is placed.
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Figure 19 Correct arrow direction for cut feature.

Modify the dimensions.  Select Modify .  

Pick the dimension from the right edge to the center and enter 1.75.  
Pick the center-to-center dimension enter 2.5.  
Pick the dimension from the bottom edge to the center mark  and enter .75.  
Pick the radius and enter .375.  

Select Regenerate.  The section is now complete.  Select Done.

For the direction, the arrow should point toward the inside of the cut.  If it is correct, select
Okay, otherwise select Flip>Okay .

The SPEC TO menu defines the depth of the slot.  Select Through All  and Done.

Select Preview to review the slot, then select Okay to accept it.  Shading the part by
selecting the Shaded View icon may be helpful.

Note the model tree and how the features appear in the model tree.  

6. Create four holes for mounting feet to the base.  Select Feature>Create>Solid>Hole.  Select
Straight and Done.  

Accept the default Linear  and select Done.  

The placement plane is the surface where the hole starts.  Spin the model and select the top
surface of the part approximately 3/4" from the corner. 
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Figure 20 References for hole placement.

Figure 21 The completed hole feature

Two references must be selected to provide dimensions to locate the hole on the placement
surface.  The two side surfaces forming the corner of the plate should be chosen.  Spin the
model and use Query Select to pick the first of these surfaces.  Accept it when the entire
surface highlights, not just a single edge. 

� Recall: right mouse key initiates Query Select; left mouse key picks, right mouse key
goes to next entity, middle mouse key accepts)

Enter .75 for the distance.  Query select the second side and enter .75.  

Accept the default of One Side and select Done.  From the Spec To  menu select Through
All  and Done.  Enter the diameter .25.

Preview the hole and select OK  from the dialog box to complete the hole feature.  
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Figure 22 Holes after using Copy>Mirror twice.

Save icon

7. Turn on datum plane display by selecting the Datum Planes on/off icon.

Mirror the hole to create dependent copies.  Select
Feature>Copy>Mirror|Select|Dependent and Done.

Select the hole (Query Select may be helpful.)  Select Done Select and then Done.

The command line prompts for a plane or datum to mirror about.  Query select DTM2.  The
second hole now appears.  

Mirror both holes about DTM1. Select Feature>Copy>Mirror|Select|Dependent and Done. 
Select both holes.  Select Done Select and then Done.

The command line prompts for a plane or datum to mirror about.  Select DTM1.  The second
set hole now appears.

Selecting the Dependent option, all three of the copied holes have the same parameters as the
initial hole.  Thus, if the hole is modified, say to change the diameter, all four holes change
together.  Subsequent lessons will address Independent copies.  

8. Save the part.  From the toolbar, select the Save icon.  Press Enter to accept the
default part name.  

9. Review the model tree.  From the PTC Application Manager window, select
Model Tree.  The model tree window appears.  Note the features on the tree:
the three default datums, the base protrusion, the slot, the hole and the two
mirror features (listed as Group COPIED_GROUP.)  Picking the + sign by either copy
feature explodes the feature to show the individual elements copied.  Additional model tree
functionality is discussed in later lessons.



2-24

Figure 24 The completed part.

10. Modify the hole diameters.  From the PART menu (select Done to return to this menu)
select Modify .

Pick any one of the four holes.  The two linear placement dimensions and the diameter
dimension appear.  Pick the .25 diameter dimension and enter .1875.  Select Regenerate. 

All four holes change to the new diameter.  Any model parameter can be easily changed in
this way.  Note that our design intent – ensuring that the four holes remain the same
diameter and the same distances from their respective corners – is captured in this model.  

11. Experiment with the icons on the toolbar.  Try shaded image, hidden line, and no hidden
views.  Blank the datum planes and axes.  The Saved View icon includes only one view, the
default view.  The next lesson will include saving additional views.

� End Exercise 2.1


