
Pro/E Tutorial 2001  1 

Pro/ENGINEER Tutorials 
Zuomin Dong, Professor 

Department of Mechanical Engineering 
University of Victoria 

 
Last Update: January 2, 2002 for Pro/ENGINEER 2001 

 
 

Contents 
 
1 About this Tutorials .............................................................................................................................................. 2 

1.1 Pro/ENGINEER .......................................................................................................................................... 2 

1.2 Symbols Used in this Tutorial....................................................................................................................... 2 

1.3 A Tutorial of Pro/ENGINEER (2001)........................................................................................................... 2 

1.4 Objectives of the Tutorial.............................................................................................................................. 3 

1.5 Evolution of The Tutorial.............................................................................................................................. 4 

1.6 Acknowledgements ....................................................................................................................................... 4 

2 Pro/E Basics .......................................................................................................................................................... 5 
3 Generation of A Feature-based, Parametric Solid Model for Mechanical Part ..................................................... 8 

3.1 The Selection of Modeled Parts .................................................................................................................... 8 

3.2 Generation of A Feature-based and Parametric Solid Model - Modeling the Component, BASE................ 8 

3.2.1 Forming the Model................................................................................................................................ 8 
3.2.2 View the created model....................................................................................................................... 12 
3.2.3 Plotting the created solid ..................................................................................................................... 12 
3.2.4 Saving the created part ........................................................................................................................ 12 

3.3 Modeling the Second Component, CAP ..................................................................................................... 13 

4 Generation of 2D Engineering Drawings............................................................................................................ 16 
5 Forming A Mechanical Assembly Using Part Models........................................................................................ 21 

5.1 Forming the BASE-CAP Assembly Model................................................................................................. 21 

5.2 Creating the Drawing of the Assembly ....................................................................................................... 23 

6 Structure Analysis and Optimization Using Pro/MECHANICA Structure......................................................... 25 
7 Motion Analysis Using Pro/MECHANICA Motion ........................................................................................... 25 
8 An Introduction to Pro/MANUFACTURING .................................................................................................... 25 
 

 



Pro/E Tutorial 2001  2 

1 About this Tutorials 

1.1 Pro/ENGINEER 
Pro/ENGINEER is a feature-based, parametric solid modelling system with many extended 
design and manufacturing applications.  As a comprehensive CAD/CAE/CAM system, covering 
many aspects of mechanical design, analysis and manufacturing, Pro/ENGINEER represents the 
leading CAD/CAE/CAM technology.   
 
1.2 Symbols Used in this Tutorial 
To shorten the document, as in most Pro/E tutorials, user’s instructions are provided in the 
following form: 

 
"Choose SETUP SK PLN -> Setup New, SETUP PLANE -> Plane,...” 

Here: 

◊ UPPERCASE – Title of the Pro/E Menu, i.e. SETUP. 
◊ Title Case – An item of selection under the selected Pro/E Menu, i.e. Plane. 
◊ Italic – The action to be taken by the user, i.e. Chose SETUP SK PLN. 
◊ ->  – Going down the selected menu to pick up a menu item. 

 
1.3 A Tutorial of Pro/ENGINEER (2001) 
This tutorial covers the basic design and modeling functions of Pro/ENGINEER. The methods 
for modeling mechanical components and their assembly are demonstrated through a number of 
examples.  In the lecture notes, the features and functions of Pro/ENGINEER have been 
discussed in details. The objective of this tutorial is to provide a short, yet a well-covered, tour of 
the basic Pro/E functions through the creation of the part and assembly models as shown in 
Figure 1. 

 

Figure 1 A Model with Two Components and Their Assembly 

Pro/ENGINEER 2001 has been installed in all Windows 2000 workstations in our computer lab.  
The system can be started by clicking and selecting the Windows menu items: Start, Programs, 
and Pro ENGINEER → Proe2001 
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1.4 Objectives of the Tutorial 
The tutorial consists of two simple mechanical parts and an assembly formed using these two 
parts.  The tutorial was designed to cover all basic Pro/E operations that are needed to form the 
solid model of a part and an assembly as well as to produce engineering drawings.  The 
objectives of these tutorials include 
• Modeling the Component, BASE 

◊ Pro/ENGINEER user interface, windows, menus, mouse buttons 
◊ Three basic types of features: 

1) datum feature 
2) sweeping by extrusion  
3) sweeping by revolving 

◊ Specification of feature relations - alignment of feature planes and datum planes          
(The aligned planes have to be physically close to each other.) 

◊ Dimensioning (to parametrically specify part geometry) 
1) linear dimensions specifying the geometry of a 2D section. 
2) default "dimensions" specifying the location of the section "alignment to datum" 
3) modification of dimension values and parametric modeling 
4) over/under dimensioning 

◊ Protrusion and Cut 
◊ Save and print the part model 
◊ Other Practice 

1) Exploring various pull down menus and Pro/E Menus 
2) Displaying the model using various modes (wireframe, hidden lines, solid, …) 
3) Rotating the model 
4) Testing the reference features: rounds, shell, etc. 

 

• 2D Drawing Generation for the Component, BASE 
◊ Pro/E orthographic projections  
◊ Projection views: Front, Bottom, Right and General (isometric)  

Under DRAWING, View 
◊ Modification of lines, texts and other entities. 
◊ Adding dimensions (for documentation) 
◊ Other Matters for Engineering Documentation 

 

• Modeling the Second Component, CAP 
◊ Preparing Another Part for Assembly Modeling 

 

• Forming the BASE-CAP Assembly Model 
◊ Entering Assembly Mode 
◊ Handling of Components 
◊ Specifying Assembly Relations 
◊ Documentation  

1. Labeling all components 
2. List all components in assembly table 
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1.5 Evolution of The Tutorial 
The first version of this Pro/ENGINEER Tutorial was introduced in 1996.  Many minor and 
major revisions have been made since then to follow the constant updates of Pro/E new releases, 
about twice a year.  At present, the following versions of Pro/E tutorials are available on-line or 
in printed form: 
 

Pro/E 
Release Pro/ENGINEER Pro/MECHANICA 

Structure 
Pro/MECHANICA 

Motion Pro/Manufacturing 

20 � �  � 

2001i � � � � 

2000 i2 � �  � 

2001 � � (�) (�) 
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2 Pro/E Basics  

This "pre-tutorial" is intended to briefly explain the Pro/E User Interface.  The steps needed to 
start Pro/E and to generate a part model is discussed in the following tutorials. 
 

Starting Pro/E 

        

Figure 1a 

The top half of the main window is the 
message window, which shows text 
responses to many of the input commands. 
This window is also where text is typed at 
command prompts that ask for information 
such as dimensions and part names.  

Below it is the model window, is for 
viewing and manipulating your models. You 
can resize any window to suit individual 
preferences.  

At the very top of the main window are the 
pull-down menus and icons. The pull-down 
menus perform much as they do on other 
Windows-based programs. The icons 
provide frequently used file, view control, 
and display control commands. In some 
cases they duplicate commands that exist in 
other menus.  
 

   

 
Figure 1b 

  
Cascading menus appear to the right of the main menu once a file is opened. The menus 
displayed will be based to the command chosen. Sub-menus appear (most of the time) below 
the menu holding the command that called it.  If there is not enough room on the screen, scroll 
bars will appear on the menu.  
 

Move the overlapped menus apart.  A hidden menu could create frustration. 
 
The command window will give you a brief description of menu item you have your mouse 
over in yellow. 
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Beginning to work in Pro/E 
Go to the File menu at the top of the main window and choose New... 
You will see a dialogue box of the types of Pro/E files you can create (see Figure 2). You will 
be creating the default file type, Part. 
 

        
Figure 2a     Figure 2b 

 
The part name block was typed as the part name at the bottom of the dialogue box here. 
At this time, Part: BLOCK should appear in the title block of the main window and the part 
menu should appear on the right.  
 
In addition, a new window, the model tree window, will appear over the upper left corner of 
the model window.  The Cascading menus and model tree window of a simple mechanical 
assembly is shown in Figure 3.  
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Figure 3 
 

 
The left side of the main window is the model tree of the part of assembly.  Feature/part 
relations can be better interpreted and modified using this information and in this window.  
The information window of the system provides feedback to the user on the inquired 
information. 
 

Save your model frequently to avoid major loss of work. 
 
Pro/E on-line help can be accessed by going to the Help item of the pull down menus, then 
Content and Index.  In the web-based on line help, hit the Content icon to get a complete list 
of the items of the On-line Help. 
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3 Generation of A Feature-based, Parametric Solid 
Model for Mechanical Part 

 

A Tutorial of Pro/ENGINEER (2001) 
(Last update: January 2, 2001) 

3.1 The Selection of Modeled Parts 

This tutorial covers the very basic design and modeling functions of Pro/ENGINEER. The 
methods for modeling mechanical components and their assembly are demonstrated through a 
number of examples.   
In the lecture notes, the features and functions of Pro/ENGINEER have been discussed in 
details. The objective of this tutorial is to provide a short, yet a well-covered, tour of the basic 
Pro/E functions through the creation of the part and assembly models as shown in Figure 1. 
 

 

Figure 1 A Model with Two Components and Their Assembly 
 
Start the Pro/ENGINEER Program 
 

• On Windows Workstations 
Pro/ENGINEER 2001 has been installed in all Windows workstations in CAD lab. The 
system can be started by clicking and selecting the Windows menu items: Start, Programs, 
and Pro ENGINEER → proe2001. 

 
 
3.2 Generation of A Feature-based and Parametric Solid Model - Modeling 

the Component, BASE 
3.2.1 Forming the Model 
The solid model of the component part BASE can be created through the following steps: 
 
1. Creating the part BASE and a coordinate system and its three datum planes.  Datum  
    planes are reference planes in constructing and dimensioning solid models. 
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In the main menu, Choose File → New, select Part in the New window, enter part name 
BASE. Two windows will pop up, Model Tree window and Menu Manager window, and 
close the Model Tree window for larger working space. One should be able to see three 
datum planes in yellow shown on the screen.  Otherwise, check the main menu Utilities → 
Environment, choose the datum plane in Environment. 

 
2. Inputting the working directory 

In the main menu, Choose File → Working Directory…, in the Select Working Directory 
window, enter your own directory in the name window.  

  
3. Creating the major feature (extrusion) 
 

(1) Selecting feature creation method 
Choose PART → Feature, FEAT → Create, FEAT CLASS → Solid, SOLID → 
Protrusion, SOLID OPTS → Extrude, Solid, Done, PRPTRUSION : Extrude window 
appears at the top-right corner in the screen. In Menu Manager window, choose 
ATTRIBUTES → One Side, Done. 
 

(2) Selecting reference planes for sketching and orientation. The first plane is the 2-D sketch 
plane for you to work on; the second is the reference plane to set the orientation of the 
sketch plane. 

 Choose SETUP SK PLN → Setup New, SETUP PLANE → Plane, GET SELECT → 
Pick, left click the plane name tag FRONT in working window, A red arrow will point 
outside the screen, choose DIRECTION → Okay, SKET VIEW → Right, SETUP 
PLANE → Plane, GET SELECT → Pick, left click RIGHT in working window, the 
sketch plane is parallel with the screen.  

 
(3) Sketching the 2D section of the part for extrusion in plane FRONT 

In Sketcher Menus (shortcut buttons) that have appeared at the right of the screen, 
choose Create lines and left click it, draw the 2-D section of the part as shown in Figure 
2 (a). The profile of the section is drawn by moving the cursor to the desired screen 
location and clicking left button of the mouse. The line is ended by clicking middle 
mouse button (or shift + middle mouse button). Profile of the section is enough at this 
stage and the dimensions do not need to be accurate.  
  

(4) Dimensioning the generated 2-D section 
 

In Sketcher Menus, choose Create defining dimension and left click it, specify 
dimensions of sd0 to sd7, as illustrated in Figure 2(a). Redundant dimension definition 
that will be highlighted may happen and if that, delete the unexpected dimensions. A 
dimension is defined by selecting the two points (or two lines) at the geometric entities 
to be dimensioned using the left mouse button, and clicking the location of the dimension 
value using the middle mouse button. 
 

(5) Modifying the dimensions to the desired values 
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Select dimensions of sd0 to sd7 by clicking shift + left mouse button, and then click 
Modify the values of dimensions, window Modify Dimensions will pop up, uncheck 
Regenerate, enter new values in the window. The dimension values of this part model 
should be: sd0 = 1, sd1 = 1, sd2 = 6, sd3 = 2, sd4 = 1, sd5 = 2.5, sd6 = 5, and sd7 = 5.  
 

  
 
 
 
 
 
 
 

Figure 2 Creation of the Main Shape (or Major Feature) 
 
(6) Extruding the 2D section to form the solid 

Choose and left click shortcut button Continue with the Current Section, 
SPEC TO → Blind, Done, enter depth value as 5 in command window, click OK button 
in PROTRUSION: Extrude window, FEAT→Done. 

 
 (7) Viewing the created 3D solid model 

One can view the geometry in three ways. The first is to use the main menu Utilities → 
Environment, ENVIRONMENT → Display Style.  The second is to use the desktop 
icons to toggle different view options.  The last approach, which is used the most, is by 
press the Ctrl button on the keyboard, and meanwhile press the left mouse button to 
zoom in/out, the middle button to rotate, and the right button to move.  The created the 
solid model is shown in Figure 2 (b).  

 
4. Creating the vertical stepped hole feature (revolving and cut) 

(1) Selecting feature creation method 
Choose PART→Feature, FEAT→Create, FEAT CLASS→Solid, SOLID→Cut,  
SOLID OPTS→Revolve, Solid, Done, ATTRIBUTES→One Side, Done. 

 
 (2) Creating a sketch plane and set the second reference plane 

Choose SETUP PLANE → Make Datum, DATUM PLANE → Offset, Plane, Coord 
Sys, GET SELECT → Pick, click FRONT, OFFSET → Enter Value. A green arrow is 
indicating the offset direction in the working window, enter 2.5 in the command window, 
DATUM PLANE → Done. A new datum plane, DTM1, and a red direction arrow are 
created. SETUP SK PLN → Setup New, DIRECTION → Okay, SKET VIEW → Top, 
SETUP PLANE → Plane, GET SELECT → Pick, click TOP.  

 
 (3) Defining the 2-D section and revolving 

 

 
sd7



Pro/E Tutorial 2001  11 

            In Sketcher Menus (shortcut buttons) that have appeared at the right of the 
          screen, choose Create lines and left click it, draw the centerline by locating the 
          starting and ending points, and then draw a 2D polygon as shown in Figure 3 (b)  
          using left mouse button and middle mouse button. 

 
Figure 3 Creation of the Vertical Stepped Hole 

            In Sketcher Menus, choose Create defining dimension and left click it, specify  
          dimensions of sd0 to sd4, as illustrated in Figure 3 (b), modify the values of these  

 dimensions as sd0 = 1.5, sd1 = 0.8, sd2 = 3, sd3 = 0.8, sd4 = 2.5.  Choose and left   
 click shortcut button Continue with the Current Section, DIRECTION → Okay, 

          REV TO → 360, Done, click OK button in CUT: Revolve window, FEAT → Done 
 

(4) Viewing the created 3D solid 
Choose the main menu View → Default. (See Figure 4) 

 

Figure 4 The three-dimensional solid model of the part 
 
 
5. Creating the straight hole (Hole) 

(1) Selecting feature creation method 
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Choose PART → Feature, FEAT → Create, FEAT CLASS → Solid, SOLID → Hole, A 
HOLE window appears in the top-right corner of the screen, check Straight hole in the 
Hole Type field, enter the diameter value 1.4 and select    Thru Next for Depth One in 
the Hole Dimension field. 

 
(2) Selecting two reference edges to locate the hole 
 

GET SELECT → Pick, click the right side surface as Primary Reference.  Click the top 
edge of the same surface, enter the value 1.5 in command window, then click the left 
edge of the same surface, enter value 2.5, click Ok in the HOLE window.  

3.2.2 View the created model 

The created Pro/E model of the part, BASE, is shown in Figure 5. 

Figure 5 A three-dimensional view of the completed part, BASE 

3.2.3 Plotting the created solid 
Pro/E 2000i2 can print the shaded model directly by Window NT Printer Manager, from 
the main menu choose File → Print, In Print Menu, choose MS Printer Manager and OK. 

 

3.2.4 Saving the created part 
Choose File → Save, or press the desktop saving icon, accept the part name BASE.PRT by 
return in command window. 
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3.3 Modeling the Second Component, CAP 

 
Figure 6 Model the Part CAP 

 
1. Creating the part CAP and a coordinate system and its three datum planes.   

In the main menu, Choose File → New, select Part in the New window, enter part name 
CAP. Two windows will pop up, Model Tree window and Menu Manager window, and 
close the Model Tree window for larger working space. One should be able to see three 
datum planes in yellow shown on the screen.  Otherwise, check the main menu Utilities → 
Environment, choose the datum plane in Environment. 

 
2. Inputting the working directory 

In the main menu, Choose File → Working Directory…, in the Select working Directory 
window, enter your own working directory in the Name window.  

 
3. Creating the major feature (extrusion) 

(1) Selecting feature creation method 
Choose PART → Feature, FEAT → Create, FEAT CLASS → Solid, SOLID → 
Protrusion, SOLID OPTS → Extrude, Solid, Done, PRPTRUSION: Extrude window 
appears in the upper right corner. In Menu Manager window, choose ATTRIBUTES → 
One Side, Done. 
 

(2) Selecting reference planes for sketching and orientation. The first plane is the 2-D sketch 
plane for you to work on; the second is the reference plane to set the orientation of the 
sketch plane. 

 Choose SETUP SK PLN → Setup New, SETUP PLANE → Plane, GET SELECT → 
Pick, left click the plane name tag FRONT in working window, A red arrow will point 
outside the screen, choose DIRECTION → Okay, SKET VIEW → Right, SETUP 
PLANE → Plane, GET SELECT → Pick, left click RIGHT in working window, the 
sketch plane is parallel with the screen. 

 
(3) Sketching the 2D section of the part for extrusion in plane FRONT 
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In Sketcher Menus (shortcut buttons) that have appeared at the right of the screen, 
choose Create rectangle, draw the rectangle as shown in Figure 6(a), as you drag the 
cursor from the origin to another corner, a rectangle is formed and the dimensions are 
labeled as well. Click the middle button. 

 
(4) Modifying the dimensions the sketched 2D section 
 

Pick up a dimension by double clicking on it, and enter a new value. The dimension 
values of this part model should be: sd0 = 4, sd1 = 5. 

 
(5) Extruding the 2D section to form the solid 

Choose and left click shortcut button Continue with the Current Section, 
SPEC TO → Blind, Done, enter depth value as 2 in command window, click OK button 
in PROTRUSION: Extrude window, FEAT→Done. 

 
4. Creating the attached cylinder feature 

(1) Selecting feature creation method 
Choose PART → Feature, FEAT → Create, FEAT CLASS → Solid, SOLID → 
Protrusion, SOLID OPTS → Extrude, Solid, Done, PRPTRUSION: Extrude window 
appears in the upper right corner. In Menu Manager window, choose ATTRIBUTES → 
One Side, Done. 
 

(2) Selecting sketching plane 
 

Choose SETUP SK PLN → Setup New, SETUP PLANE → Plane, GET SELECT → 
Pick, left click the top plane of the block in working window. A red arrow will point 
upwards showing the direction of feature generation, choose DIRECTION → Okay, 
SKET VIEW → Top, SETUP PLANE → Plane, GET SELECT → Pick, left click TOP 
in working window. The sketch plane is parallel with the screen. 

 
(3) Defining the 2D circular section and extruding it into a solid 

 In Sketcher Menus (shortcut buttons) that have appeared at the right of the 
 screen, choose Create circle and left click it, draw the 2-D section of the part as   
 shown in Figure 6(c). Pick the center and stop at a adjacent point to generate a  
 circle. Then click the middle button. 
 
Pick up a dimension by double clicking on it, and enter a new value. The dimension 
values of this part model should be: sd0=1.5, sd1=2.5, sd2=2. 
 

Extruding the 2-D section to form the solid. Choose and left click shortcut button 
Continue with the Current Section, SPEC TO → Blind, Done, enter depth value as 
0.8 in command window, click OK button in PROTRUSION: Extrude window, 
FEAT→Done. 
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Figure 7  A Three Dimensional Graph of the Cap Component 

 
(4) Viewing the created 3D solid model 

Choose main menu View → Default. (See Figure 7) 
 
5. Plotting the created solid 

Pro/E 2000i can print the shaded model directly by Window NT Printer Manager. From 
the main menu choose File → Print, In Print Menu, choose MS Printer Manager and OK. 

 
6. Saving the created part 

Choose File → Save, or press the desktop saving icon, accept the part name CAP.PRT by 
return in command window. 
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4 Generation of 2D Engineering Drawings 

Creating a 2D Drawing for the Component BASE 

Figure 8 2-D Drawing of the Component BASE 

A 2-D drawing of the component BASE is shown in Figure 8. This drawing can be produced 
using Pro/ENGINEER 2001 through the following steps: 
1. Naming the drawing and choosing drawing size/orientation 

In the main menu, choose File → New, select Drawing in the radio button in New window, 
enter a drawing name BASE, uncheck Use default template and click Ok to create a 
drawing called BASE.DRW. In the pop-up New Drawing window, input the optional 
default model that is base.prt in the Name window, select Empty for Specify template, 
Landscape for Orientation, Standard Size A for Size, and click OK.  

 
2. Framing the drawing automatically or manually 

Choose DRAWING → Sheets, SHEETS → Format, DRAW FORMAT → Add/Replace, 
Unblank, Open window will show the already-made frame, select a.frm and click Open. 
The frame will frame the drawing screen. 
 

If one draws the boarder lines and the tittle box of the draft, choose SKETCH → LINE. 
 
3 Multiple view creation and layout 

(1) Creating top view 
In Manu Manager window, Choose DRAWING → Views, VIEWS → Add View, 
VIEW TYPE → General, Full View, No Xsec, Scale, Done. Select the center point of 
the top view in the working window, enter 0.4 in the command window as the scale for 
the view, then Orientation window appears. 
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In this window, choose Type → Orient By Reference, Reference 1 → Front, GET 
SELECT → Pick, pick up the top surface of the component. Choose Reference 2 → 
Bottom, pick up the front surface of the component, and click Ok. 
 

(2) Creating front and right views 
In Menu Manager window, choose DRAWING → Views, VIEWS → Add View, 
VIEW TYPE → Projection, Full View, No Xsec, No Scale, Done. Select the center 
point of the front view. Repeatedly, choose VIEWS → Add View, VIEW TYPE → 
Projection, Full View, No Xsec, No Scale, Done, select the center point of the right 
view. 

 
(3) Creating an isometric view 

Choose VIEWS → Add View, VIEW TYPE → General, Full View, No Xsec, Scale, 
Done, select the center point of the isometric view, enter 0.3 in the command window as 
the scale for the view. In the pop-up Orientation window, choose Ok. The three views 
and an isometric view are in the drawing frame. VIEWS → Move View, pick up one 
view to an appropriate place. Select the two scale labels and drag them to appropriate 
locations using drag handles. The drawing is shown in Figure 9. 

Figure 9  A drawing of the Component Base in the Drawing Process 

4. Changing the drawing configuration  
In Menu Manager window, choose DRAWING → Advanced, ADV DWG OPTS → Draw 
Setup. Notepad text editor with the drawing configuration file is popped up and change the 
following parameters: 

Table 1 The Modified Drawing Configuration Parameters 

Parameters Values 
drawing_text_height 0.1 

draw_arrow_style FILLED 
text_orientation PARALLEL 

draw_arrow_width 0.04 
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draw_arrow_length 0.12 
tol_display YES 

 
Choose FORMAT → Decimal Places, enter number of decimal places for value as 1. 
  

5. Showing the dimension, center lines and tolerance (drawing modification) 

Choose VIEW from the Pro/E pull-down (model window) menu, → Show/Erase, 
Show/Erase window comes up, click Show, in Type zone, choose the dimension button, 
tolerance button, and Axis button. In Show By zone, choose Feature radio button, and 
accept all default options in the window, click Show All. Confirm window pops up, Yes to 
the question. Those items appear in the drawing. Then Accept All and close in Show/Erase 
window. The dimensions, centerlines and tolerances are all there. 

6. Cleaning the dimensions 
Choose DRAWING → Tools → Clean Dims, and Clean Dimensions window is shown, 
GET SELECT → Pick Many, PICK MANY → Pick Box, Inside Box. Drag the cursor 
from one corner to the other diagonal corner of the rectangle draft area and form a 
rectangle in which the dimensions will be relocated to clear visibility. 
Erase some unimportant dimensions, choose VIEW→ Show/Erase, Show/Erase window 
comes up, click Erase, in Type zone, choose the dimension button, in Erase by zone, choose 
Selected Items.  Pick those dimensions to be deleted, GET SELECT → Done Sel. 
 

Add the user defined dimensions, choose INSERT→ Dimension → New References, use 
the left mouse button to select two points or two lines, and middle mouse button to specify 
the location of the dimension value, then select the dimension orientation.  To dimension 
the locations of the holes, one can select the circle and the edge, Pro/E 2000i2 will 
automatically dimension the edge to the center of the circle.  Pick up dimensions and move 
them to appropriate locations using drag handles. Up to now, the draft is shown in Figure 
10. 
 

7. Switch the dimensions between the views 
 

To evenly distribute the dimensions,  pick the clouded dimensions one at a time, EDIT → 
Switch to View, and pick one point in the other view, then the dimension switches to there. 
Pick the dimension to an appropriate place or the dimension text around using drag 
handles.  
 

8. Flip Arrows 
 

When the space is tight for the dimension arrow, flip the arrow by pick the dimension 
arrow, click EDIT → Properties → Flip Arrows and the arrow will change its directions 
for better looking. 
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Figure 10  A Draft of the Base Part 
 
9. Editing the dimension value and its tolerance 

To change the dimension value and/or its tolerance, pick the dimension, choose EDIT→ 
Properties. In the Dimension Properties window, four different Tolerance Modes can be 
selected, and Upper Tolerance and Lower Tolerance can be fed in new numbers, or even 
one can change the Dim Format and Number of Digits. Click Ok. New dimension will 
appear. 

 
10. Documenting the draft 

To make the notes of title and date, choose INSERT→ Note → Make Note, click the 
desired location of the note on the screen, type in TITLE, and hit return key twice. 
Following the same procedure, enter the note DATE.  

 
To change the height of the texts and move them to the ideal locations, pick note TITLE, 
EDIT → Properties. In the Text Style dialog box, click the Use Default check box regarding 
Height parameter, and enter the value as 0.15, click Apply button and Close button of the 
dialog box. Pick up the note TITLE: and move it to appropriate location using drag 
handles.  Following the same procedure, modify the height of note DATE: and move it to 
the appropriate location. Choose DETAIL → Done/Return. (See Figure 11) 
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Figure 11  A Standard Drawing of the Base Component 

11. Saving the drawing to a file 
Choose File → Save, or press the desktop saving icon, accept the drawing name 
BASE.DRW. 
 

12. Plotting the created drawing 
Choose the main menu File → Print → MS Printer Manager → OK.  One can also export 
the drawing to other types of CAD model or to an image by choosing File → Save a copy. 

13. Exit the window 
Choose File → Exit.  
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5 Forming A Mechanical Assembly Using Part 
Models  

 
5.1 Forming the BASE-CAP Assembly Model 
 

Figure 12 Drawing of the BASE-CAP Assembly Model 
 
1. Creating the assembly model BASE-CAP 

From main menu, choose File → New, select Assembly in the New window, enter name 
BASECAP, uncheck Use default template and then click Ok. New File Options window 
pops up, click Empty, then OK, Two new windows, Model Tree and ASSEMBLY, are 
shown. Model Tree window can be toggled off for beginner. 

 
2. Loading the component BASE as the assembly starting part, and CAP part 

In Menu Manager window, choose ASSEMBLY → Component, COMPONENT → 
Assemble, enter name BASE.PRT, This part comes out on the screen. To assembly the cap, 
choose COMPONENT → Assemble, enter name CAP.PRT. With the cap component, 
Component Placement window also appears on the right side of the screen. In Component 
Placement window, select Separate Window, Assembly. A window of COMPONENT 
WINDOW Part: CAP pops up. Holding on Ctrl button, press the middle mouse button to 
relocate the base graph on the working window in order to see the two components in 
different window at the same time. 
 

3. Defining constraints for assembly  

In Component Placement window, choose Constraint Type → Insert, for Component 
Reference, GET SELECT → Pick, click the cylindrical surface in the window of 
COMPONENT WINDOW Part: CAP. GET SELECT → Done Sel. For Assembly 
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Reference, click the stepped hole of the base in the main working window. “Partially 
Constrained” are shown in Placement Status zone in Component Placement window. And 
Insert is in Constraints Table in the window. To fully constrain the assembly, choose mate 
from Constraint Type. This time for Component Reference, GET SELECT → Pick, click 
the top surface of the cap. GET SELECT → Done Sel. For the assembly Reference, 
SELECT → Pick, pick the step surface of the stepped hole in base. The cap is assembled 
into the base component as shown in Figure 13. In Component Placement window, Mate is 
added in Constraints Table, Placement Status denotes Fully Constrained. Click Ok to end 
the assembly. 
 

 

Figure 13  A Three Dimensional Graph of the BASECAP Assembly 

 
4. Viewing and coloring components 

In the main menu, choose View → Model Setup → Color Appearances.  In the 
Appearances window, choose Add, Appearance Editor window appears, one can move two 
bars in Color zone to adjust the contrast of the picture, and by pressing the white icon on 
the right hand side of the Appearance Editor window. In the next Color Wheel window, one 
can choose the color for the assembly whatever color he or she likes. Or by adjusting the 
RGB (Red-Green-Blue) numbers, one can define various colors and add the colors to the 
Color Palette. Click Ok to return. Then choose one color, select Components from Set 
Object Appearance zone in Appearance window, GET SELECT → Pick, click a part, for 
example, the base, press GET SELECT → Done Sel, click Set in Appearance window, then 
the color of the base will change to the color selected.  Following the same procedure, one 
can set another color to the cap. 

 
4. Saving the created assembly 

From the main menu, choose File → Save, or press the desktop saving icon, accept the 
drawing name BASECAP.ASM. 
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5.2 Creating the Drawing of the Assembly  
The drawing of assembly BASE-CAP is illustrated in Figure 12. It can be created following 
the instructions below. 
 

1. Naming the drawing and choosing drawing size/orientation 
In the main menu, choose File → New, select Drawing in the radio button in New window, 
enter a drawing name BASE-CAP, uncheck Use default template and click Ok to create a 
drawing called BASE-CAP.DRW. In the pop-up New Drawing window, input the optional 
default model that is BASECAP.asm in the Name window, select Empty for Specify 
template, Landscape for Orientation, Standard Size A for Size, and click OK.  

 
2. Framing the drawing automatically or manually 

Choose DRAWING → Sheets, SHEETS → Format, DRAW DORMAT → Add/Replace, 
Unblank, Open window will show the already-made frame, select a.frm and click Open. 
The frame will frame the drawing screen. 
 

 
3 Loading the assembly model into the draft 

In Manu Manager window, Choose DRAWING → Views, VIEWS → Add View, VIEW 
TYPE → General, Full View, No Xsec, Unexploded, Scale, Done. Select the center point 
of the top view in the working window, enter 0.4 in the command window as the scale for 
the view, then Orientation window appears. In this window, choose Type → Angles, one 
can choose Normal, Vertical, Horizontal, Edge/Axis, input the proper angle to orient the 
assembly in the drawing. Click Ok. 

 
 

4. Labeling the components 
Move the scale description to an appropriate location using drag handles. INSERT → 
Balloon, NOTE TYPES → Leader, Enter, Horizontal, Standard, Default, Make Note, 
ATTACH TYPE → Free Point, Arrow Head, GET SELECT → Pick, select one point of 
the base component with left button, then select note location with middle button. Enter the 
label text 1 in command windows. Return twice to end the input. A balloon with label in it 
is shown in the drawing. Repeat the procedure to make another balloon label 2. 

 

5. Generating the component table and drawing title box 
To fill the component table and the title box, choose INSERT → Note, NOTE TYPES → 
Make Note, click the desired location of the note on the screen, type in the text and hit 
return key twice. (See Figure 14) 
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Figure 14 A 2-D Drawing of the Assembly of Base and Cap 

 

6. Saving the drawing to a file 
Choose File → Save, or press the desktop saving icon, accept the drawing name 
BASE_CAP.DRW. 
 

7. Plotting the created drawing 
Choose the main menu File → Print → MS Printer Manager → OK.  One can also export 
the drawing to other types of CAD model or to an image by choosing File → Save a Copy. 

 
8. Exit the window 

Choose File → Exit.  
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6 Structure Analysis and Optimization Using 
Pro/MECHANICA Structure  
… 

 

7 Motion Analysis Using Pro/MECHANICA Motion 
… 
 

8 An Introduction to Pro/MANUFACTURING 
… 
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